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Introduction
Release information
Along with this User's Guide, see the following documentation for additional information that will help you
install and use version 16.1:
n

The Installation Checklist contains a brief description of the steps involved in upgrading your software.

n

The Important document contains critical topics.

n

The Release Notes provide details about new features, database changes, resolved issues, and known
issues.

You can access a complete library of supported product documents.

About this guide
This User's Guide is designed to help you learn about installing the software. It also contains information
about systems, security, ODBC, and Crystal reports.

Conventions used in this document
This document uses the following conventions:
l

l

l

l

The names of windows, fields, and other features displayed by the software are bold.
Text that you type into the windows is green, as in the following example:
Type Miscellaneous.
Names of keys are shown in capitals; for example, ENTER, TAB. A plus sign (+) between two key
names indicates that you should press both keys at the same time; for example, SHIFT + TAB.
The names of buttons that you can click with your mouse are bold and enclosed in brackets; for
example, [OK] and [ Post].

Tip: Helpful information to make your experience better.
Note: Additional information of interest, such as information not included in steps.
Caution! Information that can help you avoid a costly or time-consuming error.
Important! Information that is of critical importance.
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Menu paths
In this document, menu paths show you the steps required to start a task, such as:
PR: Tools > Download Taxes
To follow this path, open the Payroll module. From the Tools menu, select Download Taxes.

Support and assistance
Online help
Each Sage 300 Construction and Real Estate application includes online help, which provides answers to
your questions about procedures as well as items in the windows.
To access the online help in Sage 300 Construction and Real Estate:
l

l

In a window, click the [Help] button, click
topic for that window.

(the help icon button), or press F1 to display the help

In an application or Desktop, select Help > Help Topics.

Tip: From Desktop, you can access the online help for an application by clicking Applications,
clicking the name of the application, and then clicking Help > Help Topics in the list of menu items for
that application.
To aid you in finding the information you need, the online help includes the following tabs:
l

Contents tab with an outline of the help with links to the help topics.

l

Index tab with keywords that link to help topics related to that keyword.

l

Search tab or Search text box, where you can type text and click [Search] to locate that text in the
help topics.

Technical assistance
When you need assistance, refer to the How do I get technical support for Sage 300 Construction and Real
Estate? article to determine which service works best for you.

Training
Sage University offers live and recorded online training sessions to help you get the most out of your software.
To access Sage University, either:
l

From an application, select Help > Web Resources > Sage University.

l

From Desktop, select Help > Sage University.

l

From your browser, visit http://www.sageu.com/.

Contact your business partner for local training.
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For assistance in selecting the right business-class computers for your Sage 300 Construction and Real
Estate software, contact your authorized business partner. For information about system environments, see
“Chapter 5: System Guidance,” on page 32.
To install and use Sage 300 Construction and Real Estate version 16.1, your server and workstations must
have Internet access due to Pervasive licensing requirements.
Refer to the System Requirements article in the Sage Knowledgebase for information about:
l

Hardware requirements

l

Supported operating systems

l

Software requirements

This chapter includes the following sections:
l

Privilege settings required for installation and use (the next section)

l

“Compatible versions” on page 6

l

“Supported upgrade paths” on page 6

l

“Required data file upgrades” on page 6

l

“Required custom report upgrades” on page 7

Privilege settings required for installation and use
The following sections describe the access rights you need to successfully install and use Sage 300
Construction and Real Estate.

Elevate permissions
You must elevate your permissions before upgrading Sage 300 Construction and Real Estate.
You can usually start a program with elevated privileges by right-clicking the application and selecting Run as
Administrator. In Sage 300 Construction and Real Estate, the application is usually installed in the following
path: /Program Files/Sage Timberline Office/Accounting.
During certain installation tasks, you will receive another prompt to elevate your privileges. If you do not
acknowledge each prompt within two minutes, the installation process will quit the task. If this occurs, you
will receive a separate prompt asking you to retry the task. Click [Retry] and then elevate your privileges at
the prompt.
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Sage 300 Construction and Real Estate program files and data files
You must have full control access rights to all folders or shares that contain Sage 300 Construction and Real
Estate program files and data files.
Windows 7 and Windows Server 2008 have stricter default access rights settings than earlier Microsoft
operating systems.
When you create a share for a folder, users get read access instead of full control access. For example, when
you create a shared folder to which you will install Sage 300 Construction and Real Estate, you must
manually grant full control access to users who will access this folder.

Full control of specific files and folders required
To use Sage 300 Construction and Real Estate, you must have full control of the following files and folders on
your file server, terminal server, and workstations that have Sage 300 Construction and Real Estate installed.
Make sure that your system administrator also gives you full control of all the subfolders and files.

Product
Sage 300
Construction
and Real
Estate

Operating
systems

Required folders
and files

All

32-bit:
[Drive]:
\Program Files
\Timberline Office

64-bit:
Program Files
(86)\Timberline
Office
Sage 300
Construction
and Real
Estate

Windows 7

Sage 300
Construction
and Real
Estate

All

Windows Server
2008

Location and specifications
This folder is located on the server, terminal
server, and workstations where you installed
Sage 300 Construction and Real Estate. It is
the default installation location for Sage 300
Construction and Real Estate. However,
depending on your system configuration, your
company may have renamed this folder or
installed it to a different location.

[Drive]:
\Users
\[username]

This folder is located on the workstation or
terminal server where you use Sage 300
Construction and Real Estate. Sage 300
Construction and Real Estate installs
necessary files to this folder and requires that
the user has full control of it. Typically, the
user has full control of this folder by default.

Company data
folder

Typically, the data folder is located on the
server where you installed Accounting and
Management Products.
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Operating
systems

Required folders
and files

Sage 300
Construction
and Real
Estate

Windows 7

[Drive]:
\ProgramData
\Sage
\Timberline Office

This folder is located on the server or host
machine where you use Accounting and
Management Products. This folder must be
shared. Sage 300 Construction and Real
Estate installs necessary files to this folder
and requires that all users have full control
permissions to this folder and all of its
subfolders.

Sage
Estimating

All

Database and
estimates

Typically, these files are located on the
server and the workstation where you
installed Estimating Products.

Sage
Estimating

Windows 7

[Drive]:
\Users
\Public
\Estimating

This folder is located wherever you use
Estimating Products. Sage 300 Construction
and Real Estate installs necessary files to
this folder and requires that all users have
read/write permissions to this folder and all of
its subfolders.

Product

Windows Server
2008

Windows Server
2008

Location and specifications

Note:
Some of these folders may be hidden. To view them on:
l

l

Windows 7 or Windows Server 2008: Open Windows Explorer, select Organize > Folder and
Search Options, click the View tab, and then select Show hidden files and folders.
Windows 8, Windows 8.1, Windows 10, Windows Server 2012, or Windows Server 2012 R2:
Open Windows Explorer, click the View tab, and then select the Hidden items check box.

Full control of and read access to specific registry keys required
To use Sage 300 Construction and Real Estate, you must have full control of the following Windows registry
key on your file server, terminal server, and workstations that have Sage 300 Construction and Real Estate
installed. Make sure that your system administrator also gives you full control of all subkeys.
l

HKEY_CURRENT_USER

l

HKEY_Local_Machine\Software\ODBC

l

HKEY_Local_Machine\Software\Pervasive Software

l

HKEY_Local_Machine\Software\Timberline

Caution! Incorrectly editing the Microsoft Windows registry may severely damage your system. Sage is
not responsible for damage to your system caused by editing the registry. Before making changes to the
registry, contact your system administrator for assistance and make a backup copy of all valued data.
System administrators should see Microsoft Registry Editor Help topics for detailed instructions.
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Compatible versions
Caution! Residential Management - There is no 16.1 version of Residential Management.
DO NOT install the 16.1 version of Accounting if you use Residential Management.
The following versions of Sage 300 Construction and Real Estate are compatible with each of the others:
n

Sage 300 Construction and Real Estate (formerly Sage Timberline Office)16.1

n

Sage Document Management 16.1

n

Sage Estimating 16.1 (Pervasive)

n

Sage Estimating (SQL)

Supported upgrade paths
This section covers the upgrade paths for Accounting and Estimating.

Accounting upgrade paths (without Document Management)
If you are on Sage 300 Construction and Real Estate (Accounting) version 14.1 or 15.1, you can upgrade
directly to version 16.1. If you are on version 13.1 or earlier, upgrade to 14.1 or 15.1 and upgrade your data
before upgrading to version 16.1.

Accounting upgrade paths (with Document Management)
If your Accounting and Document Management products are on version 14.1 or 15.1, you can upgrade directly
to version 16.1. If your products are on version 13.1 or earlier, upgrade both products to 14.1 or 15.1 and
upgrade your data before upgrading both products to version 16.1.

Estimating upgrade path
You can upgrade any Windows-based version of Estimating products (beginning with 1.0) to Estimating 16.1.

Required data file upgrades
You must upgrade all Accounting and Management application data files after you install version 16.1.
You can upgrade the data files for Accounting applications (except for Service Management, Purchasing, and
Inventory) from Sage Desktop. In the Applications pane, select Common Tasks > Tools > Upgrade files.
Caution! Service Management, Purchasing, and Inventory data files upgrade the first time you open
those applications. You must open the application and perform the upgrade at the server. Upgrading this
data on a workstation will incorrectly set DSNs and cause data access errors after the upgrade is
performed.
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Required custom report upgrades
If you have custom Crystal Reports report designs that were created for use with version 13.1 or earlier, they
must be upgraded to be used with version 16.1 and 16.1.
To use the upgrade tool:
1 Click [Start], select All Programs > Sage > Sage 300 Construction and Real Estate > Reporting and
Other Tools, right-click Upgrade Crystal Reports, and then select Run as administrator.
2 In the Upgrade Crystal Reports - Select Option window, select Specific report or folder, and then
click [Continue].
3 In the upper part of the Upgrade Crystal Reports window, specify the report file or folder containing the
reports that you want to upgrade. You can click the browse icon or folder icon to search for the report files
and folders.
4 Select the Also upgrade reports in subfolders check box if you want the upgrade tool to upgrade all of
the reports found in subfolders as well.
5 Near the bottom of the Upgrade Crystal Reports window, click [Upgrade Reports] to start the upgrade.
6 Review the messages in the window.
7 When you are finished, click [Close].
If you want to see details about the upgrade, view the CrystalReportsUpgradeLog.txt log file, which is
located in the C:\ProgramData\Sage\Timberline Office\9.5\ folder.
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A. Before you install
l

Read the Release Notes for more details about this release of Sage 300 Construction and Real Estate.

l

Refer to the System Requirements article in the Sage Knowledgebase for information.

l

Review the Installation Checklist.

Important! If you use third-party products that integrate with Sage 300 Construction and Real Estate,
check with your software vendor prior to upgrading to ensure their product is fully compatible with this
release. We do not support rolling Sage 300 Construction and Real Estate back to a previous version and
do not recommend it.

Special installation considerations
p

p

Estimating: If you use Sage Estimating, install Sage 300 Construction and Real Estate version 16.1
before installing Sage Estimating version 16.1.
Document Management: The 15.1 release of Document Management includes changes to DocuVault
indexes, which may take a long time to complete. If you are upgrading from a version prior to 15.1, we
recommend that you plan the timing of your upgrades so they will complete during non-work hours.

1 If you are upgrading, create a complete backup of all Sage 300 Construction and Real Estate data and
program files.
2 Install the appropriate operating system service pack, make sure sufficient hard disk space is available,
and verify that your server and workstations meet all other hardware and software requirements.
If you are upgrading from 9.7 or earlier, the upgrade to 9.8 may cause file sizes to increase up to 200% of
the current size of your data. Be sure to allow for increased disk space requirements when you upgrade.
Do not install Sage 300 Construction and Real Estate products unless you have sufficient hard disk space
available.
3 Make sure that you have full control of the required folders, files, and registry keys on your file server,
terminal server, and workstations that will have Accounting and Management Products installed. For a list
of the required folders, files, and registry keys for your operating system, see “Privilege settings required for
installation and use” on page 3.
4 Quit all programs and services for the duration of the installation. This includes programs that may be
running in the background, such as anti-virus, email, and backup programs.
5 For Windows 7 and Windows Server 2008, you must elevate your permissions before installing version
16.1. During certain installation tasks, you will receive a prompt to elevate your privileges. If you do not
acknowledge each prompt within two minutes, the installation process will quit the task. If this occurs, you
will receive a separate prompt asking you to retry the task. To retry the task, click [Retry] and then elevate
your privileges at the prompt.
6 Verify the upgrade path (see page 6). If you are upgrading from an older version, you may need to install
several versions to become current.
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7 Determine which installation instructions to read in this document. Most users should start with “B. Install
to a server or stand-alone computer” on page 9. If you have a terminal server or peer network, start with “D.
Other installation scenarios” on page 12. If you are installing Sage Estimating only, see “Chapter 3: Install
Sage Estimating” on page 17.

B. Install to a server or stand-alone computer
Important! Do not install Sage 300 Construction and Real Estate unless you have sufficient hard disk
space available. Refer to the System Requirements article in the Sage Knowledgebase for information.
Note: The installation process may restart your server or stand-alone computer several times.
1 At the server or stand-alone computer, log on with full administrative rights. Full administrative rights are
defined as write access to the Windows registry and all folders on the computer (including rights to the root
of all hard drives). If you are unsure whether you have full administrative rights, ask your network
administrator for assistance. Alternately, you can ask your network administrator to log on with the network
administrator ID before you start the installation.
2 Follow the instructions you received in the 16.1 download notice.
3 Open the 161_Rev7_Accounting folder and double-click Install.exe to begin the installation process.
4 In the Welcome window, click Install Software, then follow the on-screen instructions to accept the
License Agreement, enter your company's Registration name and Client number, and begin installing
prerequisites.

ABOUT INSTALLING PREREQUISITES:
p

p

p

If you receive a firewall warning message during the installation of the Pervasive database engine, work
with your network administrator to allow the Pervasive database engine to communicate through your
firewall software. For example, if a Microsoft Windows Firewall Security Alert window lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].
You may receive a similar message during the installation of Sage Service Host. Follow the same steps
to proceed.
If you are required to restart your computer, remember to stop antivirus, backup, and other services that
may have automatically started again after you restart your computer.
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5 After the prerequisites are successfully installed, click [Continue] to begin the main installation. If this is a
new installation or a migration, follow the on-screen prompts to enter your activation codes, and select
appropriate industry reports and data sets. Click [Install] to begin installing Sage 300 Construction and
Real Estate.
6 At the conclusion of the installation, you will be prompted to restart your computer. After you restart and log
on with the same user name that you used when you installed (user name must have full administrative
rights), wait until the message All configuration tasks for Sage 300 Construction and Real Estate
completed successfully. Do not attempt to start any Sage 300 Construction and Real Estate applications
until after you have received this message. It may take a few minutes before you see the message.
7 Some of the data and report folders and files will be hidden by default. At the end of the installation, you can
view these hidden files and folders. To view them on:
l

l

Windows 7 or Windows Server 2008: Open Windows Explorer, select Organize > Folder and
Search Options, click the View tab, and then select Show hidden files and folders.
Windows 8, Windows 8.1, Windows 10, Windows Server 2012, or Windows Server 2012 R2: Open
Windows Explorer, click the View tab, and then select the Hidden items check box.

Automatic creation of Timberline Office Share
The installation automatically creates a shared Timberline Office folder at the following locations on the server
if one does not already exist.
Windows 7 or Windows Server 2008:
[Drive]:\ProgramData\Sage\Timberline Office
Read and write permissions are automatically granted to Everyone for this folder. If the Timberline Office
folder is already present and shared, the installation will skip this step. The system will not change any
permissions you have already set up.
You will connect your workstations to the shared Timberline Office folder in the next section.

C. Install to a workstation connected to a network
After you install to a server (“B. Install to a server or stand-alone computer” on page 9), you can install to your
workstations or to a computer that functions as a terminal server.
Important! Do not install Sage 300 Construction and Real Estate unless you have sufficient hard disk
space available. Refer to the System Requirements article in the Sage Knowledgebase for information.
Note: The installation process may restart your workstations several times.
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Installing to a terminal server
If you are installing to a computer that will be used as a terminal server, follow the preceding installation steps
A, B, and C.
If your terminal server does not host Sage 300 Construction and Real Estate programs and data files, after
installing, verify that the Pervasive.SQL database service on the terminal server uses an account with access
to all Sage 300 Construction and Real Estate program and data files on the server.
To verify your account and access rights, select Start > Programs > Administrative Tools > Services on
the terminal server. In the Services window, right-click the Pervasive.SQL service and select Properties.
Then, on the Log On tab, select [Use this account].
Work with your network administrator to enter an account that has the access rights of the Local System
account and access to all Sage 300 Construction and Real Estate program and data files on the file server; for
example, a domain administrator account.
Note: If you use an account with insufficient access rights, you may receive a Pervasive status code 94
or 3119 error.

Installing to a workstation
1 At the workstation, log on with full administrative rights. Full administrative rights are defined as write
access to the Windows registry and all folders on the computer (including rights to the root of all hard
drives). If you are unsure whether you have full administrative rights, ask your network administrator for
assistance. Alternately, you can ask your network administrator to log on with the network administrator ID
before you start the installation.
2 Click [Start] > Run, click [Browse], navigate to the \\[Server name]\Timberline
Office\9.5\Accounting\WinInst\Install.exe folder on the server, and then double-click Install.exe.
3 In the Installation window, click Install Software to install components necessary to run Sage 300
Construction and Real Estate applications.
Note: If you receive a firewall warning message during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if a Windows Firewall Security Alert window lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].
You may also receive this message during the installation of Sage Service Host. Follow the same
steps to proceed.
4 Repeat steps 1–3 for each workstation.
5 At the conclusion of the installation, you will be prompted to restart your workstation.
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6 Some of the data and report folders and files will be hidden by default. At the end of the installation, you can
view these hidden files and folders. To view them on:
l

l

Windows 7 or Windows Server 2008: Open Windows Explorer, select Organize > Folder and
Search Options, click the View tab, and then select Show hidden files and folders.
Windows 8, Windows 8.1, Windows 10, Windows Server 2012, or Windows Server 2012 R2: Open
Windows Explorer, click the View tab, and then select the Hidden items check box.

D. Other installation scenarios
Peer server networks with Estimating products
Follow installation steps A, B, and C, but perform this step after the installation:
At the peer server, browse to the same shared folder that the workstations use. Use this path to access
Address Book data.

E. Upgrade data files
If you upgraded to a new version of Sage 300 Construction and Real Estate, read and follow the information in
this section. If this is a first-time installation, skip to “G. Install Crystal Reports Designer (optional)” on
page 14.
Caution! Service Management, Purchasing, and Inventory have specific upgrade requirements. First,
log onto the file server as an administrator. Then open and upgrade Service Management, Purchasing,
and Inventory data files at the server the first time you open these applications. Upgrading this data on a
workstation will incorrectly set DSNs and cause data access errors after the upgrade is completed.

Prepare to upgrade files
For optimal performance, we recommend that you upgrade your data from the server. If you prefer to upgrade
your data from a workstation instead, you must ensure that the same version and update are installed on both
the server and the workstation before starting the Upgrade Files process.
1 Back up your data files.
2 Make sure all users have closed Sage 300 Construction and Real Estate applications.
3 Log in to Sage 300 Construction and Real Estate as the application administrator.
4 Open Sage Desktop, select your company, and click [OK]. If you do not see your company:
a Click [Specify Folders].
b In the Specify Data Folders Path window, click [Browse], select the UNC path to the folder that
contains your Sage 300 Construction and Real Estate data, and click [OK].
c Select your data folder from the Specified Folders area and click [OK].
d Select your company from the list of companies in the Select Company window and click [OK].
5 If you use File Locations and the path is not accessible from the server (for example, you use mapped
drives instead of specific paths), modify the locations to point to files on the local hard drive of your server.
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Tip: We recommend that you convert your mapped drives to the equivalent UNC paths using the
following instructions. If you convert now, you will not have to perform this step during future upgrades,
and you can skip to “Restore file locations” on page 14.
a From Sage Desktop in the Applications pane, select Common Tasks > File > Company Settings >
File Locations.
b In the File Locations window, look for network paths in the Data Folder column.
c If you have network paths, write them down (you need this information when you restore the file locations
later) and then modify each network path to point to the appropriate file on the local hard drive of your
server.
d Click [OK] to close the File Locations window.
6 Repeat steps 4 and 5 for each data folder you will upgrade.

Upgrade files
Files cannot be in use while they are being upgraded.
1 From Sage Desktop in the Applications pane, select Common Tasks > Tools > Upgrade files.
2 In the Upgrade Files - Print Selection window, select the data folders to upgrade:
p
p

Current data folder: Upgrades only the files in the data folder in which you currently work.
All data folders: Upgrades files in all data folders that appear in the Open Company window. This may
include data folders on other drives. The upgrade process can take a long time if you have many data
folders.
Note: We recommend that you upgrade all data folders after you install version 16.1.

3 Click [Start].
4 In the Print File Selection window for File name, type a name for the upgrade report file, and then click
[Save].
The upgrade process begins in the background.
5 When the process is complete, review the report.
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Restore file locations
If you use UNC paths, you can skip this step now and in future upgrades.
If you use mapped drives instead of UNC paths and the modified file locations and path are not accessible
from the server, restore the previous file location entries.
1 From Sage Desktop in the Applications pane, select Common Tasks > File > Company Settings >
File Locations.
2 In the File Locations window, find the file locations you changed previously and change them back to the
original network path.
3 Click [OK] to close the File Locations window.

F. Upgrade custom Crystal Reports designs
If you upgraded from version 13.1 or earlier and have custom Crystal Reports designs, you must upgrade
them before they can be used in Sage 300 Construction and Real Estate. You can use the new Upgrade
Crystal Reports Tool, which is on the programs menu; click [Start], select All Programs > Sage > Sage 300
Construction and Real Estate > Reporting and Other Tools, right-click Upgrade Crystal Reports, and
then select Run as administrator. For more information, click

(the help button) in the tool's window.

G. Install Crystal Reports Designer (optional)
If you own Crystal Reports Designer, you must install Crystal Reports For Sage 2013 SP2, which is
compatible with Sage 300 Construction and Real Estate versions 14.1 through 16.1. If you have already
installed it, you can skip this step. For more information about setting up Crystal Reports with Sage 300
Construction and Real Estate, see “Chapter 8: Crystal Reports,” on page 78.
Caution! Crystal Reports For Sage 2013 SP2 software only runs on Windows 7 SP1, Windows
Server 2008, or higher operating systems (not Windows Vista).
To install Crystal Reports For Sage 2013 SP2:
1 Ensure all Windows programs are closed.
2 On the server or workstation where your report designs are kept, open the email with the download
information, click the download link, run the download, and select the folder for the download files.
3 Click [Yes] to run the setup wizard.
4 In the Crystal Reports For Sage 2013 SP2 setup window, click [Next] and follow the on-screen
instructions to run the installation.
5 When you see the message that Crystal Reports For Sage 2013 SP2 has been successfully installed, click
[Finish].
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H. After you install
Some of the data and report folders and files will be hidden by default. At the end of the installation, you can
view these hidden files and folders. To view them on:
l

l

Windows 7 or Windows Server 2008: Open Windows Explorer, select Organize > Folder and
Search Options, click the View tab, and then select Show hidden files and folders.
Windows 8, Windows 8.1, Windows 10, Windows Server 2012, or Windows Server 2012 R2: Open
Windows Explorer, click the View tab, and then select the Hidden items check box.

Elevated permission levels after installing
If you install Service Management (SM), Purchasing (PO), and Inventory (IV) on Windows 7 or Windows
Server 2008, you should elevate your permission level. Crystal Reports may not run correctly in these
applications if the permission level is set too low. If you encounter an error message when starting SM, PO, or
IV for the first time after installation, close the application, elevate your permission level, and start the
application again. To do this:
1 Close the Pervasive Workgroup engine (Right-click the Pervasive Database icon in the systems tray and
select Stop Engines and Exit.)
2 Navigate to SM.exe, PO.exe, or IV.exe. The default location for these files is C:\Program Files
(x86)\Timberline Office\Shared.
3 Select Run as Administrator.
4 Open each company data set at the server.
5 Repeat these steps for each company data folder.

If you have Purchasing, Inventory, or Service Management data in
Program Files
If, before upgrading, your company data folder was inside the Program Files folder in Purchasing (PO),
Inventory (IV), or Service Management (SM), follow these steps at the server to move your data to a shared
location and make the data available to your users.
1 Move the data files to a shared location. The default shared location is:
\\[Server name]\Timberline Office\Data
2 At the server, remove all Pervasive System DSNs and User DSNs for each Sage 300 Construction and
Real Estate installation:
a Click Start > All Programs > ODBC > 32bit ODBC Administrator.
b In the ODBC Data Source Administrator window on the System DSN tab, select the first Name
associated with a Pervasive ODBC Engine Interface Driver, and then click [Remove].
c Repeat this process to remove each Name associated with a Pervasive ODBC Engine Interface
Driver.
d On the User DSN tab, select the first Name associated with a Pervasive ODBC Client Interface
Driver, and then click [Remove].
e Repeat this process to remove each Name associated with a Pervasive ODBC Client Interface
Driver.
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f Click [OK].
3 At the server, delete the DBNAMES.CFG file:
a From \\[Server name]\WINDOWS, right-click DBNAMES.CFG, and select Delete.
b In the Confirm File Delete window, click [Yes].
4 Add each company to the company list:
a In TS-Main, select File > Open Company.
b Click [Specify Folders].
c Click [Browse] and browse to the shared location from step 1.
d Select a folder and click [OK].
e At the server, open the SM, PO, or IV applications for each Sage 300 Construction and Real Estate
company.
f Repeat these steps for each company folder that you want to add.
5 If you use security, give the appropriate users rights to the companies; in Sage Desktop, select Options >
Security Administration, click User Setup, and then click Companies.

If you have Estimating-only workstations
To access Address Book, Job Cost, and tax data on a server, see Additional Steps for Network
Installations in “D. Other installation scenarios,” on page 12. Workstations that have both Estimating and
Sage 300 Construction and Real Estate have already been configured as part of the Sage 300 Construction
and Real Estate installation and do not require these steps. The steps apply to both upgrades and first-time
installations.

I. Final steps
1 Restart all programs and services that you shut down for the installation.
2 Review the following guidelines for custom reports or custom third-party applications.
a If you have custom reports that use the Crystal Reports format, be sure to open these reports in Crystal
Reports Professional, select Database > Verify Database, and then save the report.
b If you use Inventory, Purchasing, or Service Management custom Crystal reports, see page 106 or
page 110 in Chapter 9 for special information and detailed instructions about upgrading these reports.
c As with any release, database changes in Sage 300 Construction and Real Estate applications may
affect your custom report designs or custom third-party applications. Contact your authorized business
partner to discuss any issues relating to custom reports or third-party applications.
3 If you set up a shortcut to Desktop, you must re-create it after installing version 16.1 by selecting the
Desktop.exe in C:\ProgramFiles\Timberline Office\Shared. All other application shortcuts will continue
to work after installing version 16.1.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 16

Chapter 3: Install Sage Estimating
A. Before you install or upgrade
1 Review the Estimating Release Notes for information regarding this release of Sage Estimating.
2 If you are upgrading, create a complete backup of all Sage 300 Construction and Real Estate data and
program files.
3 If you are upgrading from 9.8, ensure that you are running Estimating 9.8 Rev 3 before upgrading to version
16.1. Verify your software version in Help > About.
Modifying or uninstalling the original 9.8.0 Rev. 2 may result in a loss of data. 9.8.0 Rev 3 corrects the issue
and overwrites Rev 2. Download Estimating 9.8 Rev 3 and install it over Rev 2.
4 Install the appropriate operating system service pack level, make sure that there is sufficient hard disk
space available, and make sure that your server and workstations meet all other hardware and software
requirements. Refer to the System Requirements article in the Sage Knowledgebase for information.
5 Make sure that you have full control of the necessary folders, files, and registry keys on your file server,
terminal server, and workstations that will have Sage 300 Construction and Real Estate installed. For a list
of the required folders, files, and registry keys for your operating system, see “Privilege settings required for
installation and use” on page 3.
6 Windows 7 and Windows Server 2008: You must elevate your permissions before installing Sage 300
Construction and Real Estate. During certain installation tasks, you will receive another prompt to elevate
your privileges. If you do not acknowledge each prompt within two minutes, the installation process will quit
the task. If this occurs, you will receive a separate prompt asking you to retry the task. To retry the task,
click [Retry] and then elevate your privileges at the prompt.
7 Quit all programs and services for the duration of the installation. This includes programs that may be
running in the background, such as antivirus, email, and backup programs.
8 If Sentinel protection devices are not already attached to your computer, delay attaching these devices until
after you install Estimating. If you already have Sentinel protection devices attached, you can leave these
devices in place during the Estimating installation.
Decide which installation instructions to read in this document. Most readers should start with “B. Install to a
workstation” on page 18. If you have Sage 300 Construction and Real Estate, a terminal server, or a peer
network, start with “D. Other installation scenarios” on page 20.
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B. Install to a workstation
Important! Do not install Estimating until you have sufficient hard disk space available. Refer to the
System Requirements article in the Sage Knowledgebase for information.
Note: The installation process may restart your workstations several times.
1 At the workstation, log on with full administrative rights. Full administrative rights are defined as write
access to the Windows registry and all folders on the computer (including rights to the root of all hard
drives). If you are unsure whether you have full administrative rights, ask your network administrator for
assistance. Alternately, you can ask your network administrator to log on with the network administrator ID
before you start the installation.
2 Follow the instructions you received in the 16.1 download notice.
3 Open the 161_Rev7_Estimating folder and double-click Install.exe to begin the installation process.
4 Click Install Software, then follow the on-screen instructions to accept the License Agreement and begin
installing the prerequisites.
5 After the prerequisites are installed, click [Continue] to start the main installation. Follow the on-screen
prompts to install Estimating 16.1 and enter which location, features, activation codes, and whether you
want to install databases. You can install databases to your workstations, or you can install databases to a
server. Install databases at your server if you want to share databases across your network.
Note: If you receive a firewall warning message during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if a Windows Firewall Security Alert window lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].
6 If you are upgrading from Estimating 9.5 or later, you can skip to step 8. After restarting, Estimating will
automatically bring up the Estimating User Account Control and Configuration Setup window. This
process sets up all default User Account Control (UAC) compliant folders, transfers all Windows registry
settings, scans and copies any data found in Program Files, and copies relevant application data to a UACcompliant location.
n

If this is the first time Estimating is being installed on your computer, this process ensures that your
data will be stored in a UAC-compliant location and your computer is configured properly.

n

If you are upgrading from a previous version of Estimating, this process ensures any data stored in a
non-UAC compliant location is copied to a UAC-compliant location.

Click [Click to Begin] to start the upgrade process.
7 Windows 7 and Windows Server 2008: You must elevate your permissions before installing Sage 300
Construction and Real Estate. During certain installation tasks, you will receive another prompt to elevate
your privileges. If you do not acknowledge each prompt within two minutes, the installation process will quit
the task. If this occurs, you will receive a separate prompt asking you to retry the task. To retry the task,
click [Retry] and then elevate your privileges at the prompt.
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Note: For more information on User Account Control, see the User Account Control topics in
Estimating Help.
8 Repeat steps 1–7 for each workstation to which you want to install Estimating.
9 At the conclusion of the installation, you will be prompted to restart your computer. After you restart your
computer and log on with full administrative rights, wait until you see the All configuration tasks
completed successfully message. Do not attempt to start Estimating until you see this message.
Note: It may take some time before you see the All configuration tasks completed successfully
message.
If you plan to install Estimating to a server or if you plan to share estimates and databases from a server,
continue with “C. Install to a server,” on page 19. Otherwise, skip to “E. Set up Stand-Alone Security Devices”
on page 22.

C. Install to a server
Important! Do not install Estimating unless you have sufficient hard disk space available. Refer to the
System Requirements article in the Sage Knowledgebase for information.
Note: The installation process may restart your server several times.
Many users choose to share databases and estimates across their network. They also install Estimating to
their server so they can more efficiently perform file maintenance on their data. Follow these steps if you want
to install Estimating or share databases or estimates from your server.
Even if you do not install Estimating on your server, you still need to follow these steps to install required
components that enable you to access data.
1 At the server or stand-alone computer, log on with full administrative rights. Full administrative rights are
defined as write access to the Windows registry and all folders on the computer (including rights to the root
of all hard drives). If you are unsure whether you have full administrative rights, ask your network
administrator for assistance. Alternately, you can ask your network administrator to log on with the network
administrator ID before you start the installation.
2 Follow the instructions you received in the 16.1 download notice.
3 Open the 161_Rev7_Estimating folder and double-click Install.exe to begin the installation process.
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4 If you want to install Estimating on the server, skip to step 5. If you want to access databases and
estimates from the server, but you do not want to install Estimating, cancel the installation when the
License Agreement window appears. Pervasive SQL Database Engine and SQL Server Express are
automatically installed with the prerequisites.
n

After you canceled the installation, run the Sage System Verifier (SSV). This sets the Pervasive
settings to the recommended minimums. If Sage 300 Construction and Real Estate is installed, you
can run the Sage System Verifier (SSV) from Sage Desktop. In the Applications pane, select
Common Tasks > Tools > System Verification.

n

Run SSV by browsing to and double-clicking
\...\Estimating\AdditionalInstalls\SSV\SageSystemVerifierSA.exe.

5 In the Installation window, click Install Software. In the resulting installation, choose to install databases,
Estimating products, or both.
You can install Estimating to a server in order to perform file maintenance, but you should not perform other
Estimating tasks at the server. These tasks should be performed at workstations.
Note: If you receive a firewall warning message during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if a Windows Firewall Security Alert window lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].

D. Other installation scenarios
Additional steps for network installations that have Sage 300
Construction and Real Estate
To access Accounting data on a server, follow these steps on each Estimating-only workstation.
(Workstations that have both Estimating and Sage 300 Construction and Real Estate have already been
configured as part of the Sage 300 Construction and Real Estate installation and do not require these steps.)
The following steps apply to both upgrades and first-time installations.
1 Note the shared Timberline Office folder on the server or peer server where the Sage 300 Construction
and Real Estate data folder is installed. This shared folder should be the parent to the folder where the
application data is installed.
Windows 7 and Windows Server 2008:
[Drive]:\ProgramData\Sage\Timberline Office.
2 Click [Start] > Run.
3 In the Run window, click [Browse]. Browse to \\[Server name]\Timberline
Office\9.5\Accounting\WinInst\Install.exe. Click [Open]. Then, click [OK].
4 In the Installation window, click Install Sage Estimating and follow the instructions as they appear in the
windows.
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Note: If you receive a firewall warning message during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if a Windows Firewall Security Alert window lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].
You may also receive this message during the installation of Sage Service Host. Follow the same steps to
proceed.
5 Repeat steps 1–4 for each Estimating-only workstation. When finished, follow the steps in “B. Install to a
workstation” on page 18.
6 At the conclusion of the installation, you will be prompted to restart your computer. After you restart your
computer and log on with full administrative rights, wait until the "All configuration tasks completed
successfully" message. Do not attempt to start any Sage 300 Construction and Real Estate applications
until after you have received this message. It may take several minutes before you see the message All
configuration tasks completed successfully.
7 Some of the data and report folders and files will be hidden by default. At the end of the installation, show
hidden files and folders:
l

l

Windows 7 or Windows Server 2008: Open Windows Explorer, select Organize > Folder and
Search Options, click the View tab, and then select Show hidden files and folders.
Windows 8, Windows 8.1, Windows 10, Windows Server 2012, or Windows Server 2012 R2: Open
Windows Explorer, click the View tab, and then select the Hidden items check box.

8 If you set up a shortcut to other applications, you must re-create them after installing 16.1. Locate the
application.exe file in C:\ProgramFiles\Timberline Office\Shared. Right-click and select Create
shortcut.

Terminal server
Follow the installation steps for a Windows server, with these exceptions:
n

If you install on a Windows Server 2008 terminal server, begin the installation by selecting Control
Panel > Install Application on Terminal Server. Follow the prompts and browse to the install.exe
file.

n

In Windows Server 2008 R2, "terminal services" is called "Remote Desktop ".
Open Start > Control Panel > Install Application on Remote Desktop
or Start > Control Panel > Programs > Install Application on Remote Desktop. Follow the
prompts and browse to the install.exe file.

n

If you use another server to host Estimating databases, you can install only Estimating applications to
the terminal server.

Note: If you install Estimating Products on a terminal server that uses Windows Server 2003, you
must log on to the terminal server with full administrative rights when you use Estimating Products.
This ensures that Estimating Products have proper access to the Windows registry.
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Pervasive manual installation
The Pervasive database engines are installed automatically with other prerequisite software when you install
Sage 300 Construction and Real Estate.
To manually install this program, download the software and install the prerequisites. Then, cancel the
installation at the License Agreement window. Pervasive SQL Database Engine is automatically installed
with the prerequisites.
After you have canceled the installation, you should run the Sage System Verifier (SSV), which will set
Pervasive settings to the Sage 300 Construction and Real Estate recommended minimums.
If Sage 300 Construction and Real Estate is installed, you can run the Sage System Verifier (SSV) from Sage
Desktop. In the Applications pane, select Common Tasks > Tools > System Verification.
If Sage 300 Construction and Real Estate is not installed, run SSV by browsing to and double-clicking
...\Estimating\AdditionalInstalls\SSV\SageSystemVerifierSA.exe.
Note: Some Sage System Verifier checks may not pass if Sage 300 Construction and Real Estate is not
installed. This is acceptable if you ensure the Sage Timberline Office—Pervasive PSQL License and
Sage Timberline Office—Pervasive PSQL Settings checks are completed successfully when you run
the Sage System Verifier.

E. Set up Stand-Alone Security Devices
If you use License Manager to provide license security, skip to “F. Set up License Manager” on page 22.
If you already use stand-alone security devices, skip to “G. Upgrade estimates and databases” on page 25.

Install the Sentinel driver
The Estimating installation program automatically installed a Sentinel driver if you did not have one. For
instructions to install the Sentinel driver manually, access the Sage Knowledgebase at
https://support.na.sage.com, log on, and search for Article ID 22112.

Attach protection devices to workstations
1 If you have a parallel port protection device, disconnect any hardware or peripheral devices attached to the
parallel port of a workstation.
2 Plug a protection device into the parallel port or USB port of the workstation.
3 If you disconnected devices in step 1, reconnect these devices.
4 Repeat steps 1–3 for each workstation. Then, skip to “G. Upgrade estimates and databases” on page 25.

F. Set up License Manager
If you use stand-alone security devices to provide license security, see “E. Set up Stand-Alone Security
Devices” on page 22.
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Guidelines
Please note the following:
n

You must install License Manager to a Windows server or workstation.

n

All license-managed servers and workstations must use the same network protocol (TCP/IP).

n

n

n

You cannot install License Manager to a terminal server. If you have a terminal server, install to a
workstation.
If you use firewall software on your license server, you may not be able to use the WlmAdmin or
WCommute applications to view or check out licenses. To resolve this issue, discuss the server’s firewall
security with your network administrator. If you are willing to adjust your firewall security settings on the
license manager server, consider granting access to the lservnt.exe file.
Check in any licenses before upgrading.

For more information:
n

n

Getting Started With License Management
Sentinel License Manager System Administrator Online Help (index.html). This file is in
...\Estimating\AdditionalInstalls\LicenseManager\SysAdminHelp.

Install the Sentinel driver
The Estimating installation program automatically installed a Sentinel driver if you did not have one. For
instructions to install the Sentinel driver manually, access the Sage Knowledgebase at
https://support.na.sage.com, log on, and search for Article ID 22112.

Attach a protection device to the computer that will have License Manager
1 If you have a parallel port protection device, disconnect any hardware or peripheral devices attached to the
parallel port.
2 Plug the protection device into the parallel port or USB port.
3 If you disconnected devices in step 1, reconnect these devices.

Install License Manager
If you already have License Manager installed, skip to “Upgrade License Manager,” on page 24.
1 Log on with full administrative rights. Full administrative rights are defined as write access to the Windows
registry and all folders on the computer (including rights to the root of all hard drives). If you are unsure
whether you have full administrative rights, ask you network administrator for assistance. Alternately, you
can ask your network administrator to log on with the network administrator ID before you start the
installation.
2 Open and double-click ...\Estimating\AdditionalInstalls\LicenseManager\Server\Setup\Setup.exe.
3 Follow the on-screen prompts. The installation automatically installs the appropriate software for the
operating system.
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Note: Be sure to accept the default installation path when you install License Manager. If you need to
change the default installation path, change it to a local drive. You cannot install License Manager to a
network drive.

Install license codes
The number of network licenses purchased for an application indicates the total number of concurrent network
uses allowed for that application. To install license codes, follow these steps:
1 Verify that the Sentinel License Manager service is running. Click [Start]. Then select Settings > Control
Panel > Administrative Tools > Services. Look for Sentinel RMS License Manager in the list of
services.
2 Download the software.
Note: Consider copying the entire License Tools folder to your local hard drive. This makes License
Tools more accessible for future maintenance.
3 Expand "Subnet Servers".
4 Install license codes using one of the following methods.
n

To enter license codes from a file: In the WlmAdmin window, right-click your server and select
Add Feature > From a File > To Server and Its File. In the Open window, select your license file
and click [Open]. This installs all license codes in the file.

n

To type license codes: In the WlmAdmin window, right-click your server and select Add Feature >
From a String > To a Server and its File. In the Add feature to server window, type your license
code exactly as it appears in the license file or on the packing slip. (The code is not case-sensitive.) Be
sure to select the Add feature to server’s file check box.

When you enter a license code, the software adds this code to a file named Lservrc (which has no file
extension) in the License manager installation path.
5 If you receive a message that a license is invalid or already exists, review the information in Getting Started
With License Management .
6 Enter license codes.

Upgrade License Manager
To upgrade License Manager, you must use the following steps to remove the previous version of License
Manager and then install the new version. Perform these steps at the computer where License Manager is
installed.
1 Check in any licenses before upgrading.
2 Run LoadLS.exe, located in the folder where you installed the previous version of License Manager
(typically, C:\Program Files\Rainbow Technologies\SentinelLM7x.x.xServer\English). Click
[Remove], and then click [OK] to remove the Sentinel LM license manager.
3 Remove the previous License Manager version. Remove Sentinel LM x.x.x.x. Server.
4 Install the new version of License Manager. "Install License Manager" on the previous page.
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5 Copy the Lservrc file from the directory you identified in step 2 to the directory of License Manager, which
is typically C:\Program Files\Common Files\SafeNetSentinel\Sentinel RMS License
Manager\WinNT.
6 Click [Start] and then select Settings > Control Panel > Administrative Tools > Services. Find
Sentinel RMS License Manager in the list of services, right-click the service, and then select [Restart].

G. Upgrade estimates and databases
If you upgraded to a new version of Estimating Products, read the information in this section. If this is a firsttime installation of Estimating Products, skip to “H. After you install” on page 25.
Note: If you manually create a backup, clear the check box to auto-create a backup.
1 If you access data on another computer, map a drive to the network shared folder in which you have data.
Use the same drive letter for all workstations. To avoid network disruptions and to maximize performance,
upgrade files at the computer that hosts your data.
2 Back up your data files.
3 In Estimating Tools, select Upgrade Files.
4 In the Upgrade Files window, select the Upgrade - For current users of Estimating for Windows
option.
5 Select the folder containing the estimates or databases that you want to upgrade. Click [Browse] to browse
for a folder.
6 Complete the remaining fields in the window.
7 Click [Finish] to upgrade the selected files. During the upgrade, a progress bar in the lower right corner of
the Estimating Tools window shows the name and path of each file as well as the name of each record
type. Afterwards, you can print (File > Print Audit) or save (File > Save Audit) the information shown in
the window.
8 If you are prompted to upgrade Address Book data, follow the steps in “E. Upgrade data files” on page 12.
Tip:
Keep the following in mind if you are upgrading from an earlier version:
l

l

If you are upgrading from a version earlier than 6.0, you must upgrade databases before you
upgrade estimates. The update occurs automatically if the database and the estimates are in the
same folder. If Estimating Tools cannot upgrade an estimate because it cannot find the
associated database, use File > File Tools to move the estimate and database to the same
folder; then, upgrade the single estimate. Click [Yes] when asked if you want to use the database
that is in the same folder as the estimate.
When you move a database to a different location, the estimates that were created must be reassociated with the database’s new location.

H. After you install
1 Restart all programs and services that you shut down for the installation.
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2 If necessary, configure Estimating to access the Sage 300 Construction and Real Estate data folder. For
instructions, see “Selecting a company data folder for Address Book and Job Cost information” in
Estimating Help or “Select a company data folder for Address Book and accounting information” in Buyout
Help.
3 If you upgraded and your Estimating data resided in the Program Files folder, your Estimating data was
copied to a shared location. Verify proper operation of your files after upgrading, and then delete the original
data in the Program Files folder. Update any workstation maps to point to the new shared location.
4 Click [Help] in any window for detailed procedural information. Select Help > Product Documents for
release notes and technical information about your system.

I. Upgrade your Estimating Explorer data
If upgrading from 9.4.x, perform a back-up and restore operation to upgrade your existing Estimating Explorer
data from MSDE to SQL Server Express.

Backup Estimating Explorer
1 Have all users close Estimating.
2 Log on to the computer where you store your Estimating data.
3 Start Explorer on the computer where the data source resides.
4 Close any open data sources by selecting Close Data Source from the Estimating Explorer File menu.
5 From the File menu, select Data Source Tools. Click [Next] in the Data Source Tools window.
6 Select the name or address of the SQL Server where the data source you want to back up resides. If you do
not see the server in the list, click [Refresh] to update the list of available servers or type the server’s
computer name; for example, [Server name] or [Server name]\instance.
7 Click [Next].
8 Select Back up the Explorer data source and click [Next].
9 Browse to the location of the folder where you want to create the backup. You must select a folder located
on the computer that hosts the data source.
10 Click [Start]. If a backup copy already exists in the folder, Estimating Explorer warns you that the backup
copy will be overwritten. If you get this warning, click [OK] to continue. Otherwise, click [Cancel].
11 When you finish working with the data source tools, click [Finish].

Restore Estimating Explorer data
1 Close any open data sources by selecting Close Data Source from the File menu.
2 From the File menu, select Data Source Tools.
3 In the Run As window, select the user account to use with Data Source Tools. Note that the user account
you select must be an administrator account on the local computer.
4 If you select Current user, clear the Protect my computer and data from unauthorized program
activity check box.
5 Click [OK], and then click [Next] in the Data Source Tools window.
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6 Select the name or address of the SQL server on the destination computer.
If you do not see the server in the list, click [Refresh] to update the list of available servers or type the
server’s computer name. For example, type [Server name]\SQLEXPRESS for the default instance of SQL
Server Express or [Server name]\instance for a named instance of SQL Server Express.
7 Click [Next]. Select Restore an Explorer data source from a previous backup and click [Next] again.
8 Click [...] to browse to the folder that contains the data source backup. Then, click [Start].
If an Explorer data source already exists on the server, Explorer warns you that the existing data source will
be overwritten.
9 To overwrite the existing data source, click [OK]. Otherwise, click [Cancel].
10 Click [Finish] to close Data Source Tools.
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The server and data migration tool enables you to easily copy and transfer your Sage 300 Construction and
Real Estate Accounting data and customizations to a new server. Items transferred include:
l
l
l
l
l
l
l
l

Company data
Security settings
Custom fields
User formulas
Reports and reports menu
Inquiries
Macros
Attachments

You can select which companies you want to copy, giving you the flexibility to include all companies or only
selected companies.
Tip: Click [Help] in any of the server migration windows for more information.

Things to know before you begin
n

You must first install Sage 300 Construction and Real Estate Accounting version 16.1 on your new
server to access the server migration tool.

n

The server migration process copies data from the old server to the new server. Data is not removed
from the old server.

n

You can migrate data from Sage 300 Construction and Real Estate version 9.6 or later.

n

You must have administrative rights to the new server and a minimum of read permission to the old
server.

n

Your new server must have enough disk space to hold the information from the old server.

n

If you added reports to the Report menus on your old server using mapped drives, create identical
drive mapping for reports on your new server before performing the migration.

n

Macros that you want to migrate must be in the Company folder on the old server prior to migration.
You can copy the macros to the Company folder, if necessary. If the macros are not in the Company
folder, you will need to recreate them on the new server after the migration.

n

If you are using File Locations (File>Company Settings>File Locations) and the path to the file
points to the old server location, you should update this path prior to upgrading your data. During a data
upgrade, the program follows the path selected in File Locations to upgrade the data file. If that path is
the old location, data files in the old location/server are upgraded instead of data in the new
location/server.

n

We recommend that you perform a test migration, then validate that all of your data, reports, macros
and settings work properly on the new server. You can then stop work on the old server and perform the
migration again with the latest files.

n

The migration will overwrite companies and security on the new server. You should perform the
migration before setting up companies and security (for example, before setting up a new job).
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n

Most of the migration tasks are performed in a few minutes. However, moving attachments can take
more time. If you have many attachments, consider transferring them during non-business hours.

n

Estimating and Document Management items are not included in the migration. For additional
information, access the Knowledgebase at https://support.na.sage.com, log on, and search for the
following articles:
n

Document Management—Article ID: 22160

n

Estimating —Article ID: 23263

n

Migration—Article ID: 22043

After you migrate your server, you must uninstall and then reinstall Sage 300 Construction and Real Estate on
all workstations so they interact with the data on the new server instead of the old.

Recommended procedure
Preparing your new server
If you have not already installed and run Sage 300 Construction and Real Estate, do so now.
1. Install Sage 300 Construction and Real Estate Accounting version 16.1 on your new server.
2. Click Start > All Programs > Sage > Sage System Verifier.
3. In the Sage System Verifier window, click [Scan System].
4. When the system verification has completed, click [Close].
5. Set up administrative rights on the new server.
6. Set up existing or new printers on your new server. The TS PDF printer cannot be the only printer on
your system and cannot be selected as the default.

Migrating your server
1. On the new server, open your program files folder and \Timberline Office\Shared, and then doubleclick Sage.STO.ServerMigrator.exe.
2. In the Server Migration Tool window for Old server location, type the path or browse to the location
where Sage 300 Construction and Real Estate installed on your old server.
For example: \\oldservername\Timberline Office\9.5
3. Verify or change the server migration log path (on the new server) for Log file path. For example:
\\newservername\Timberline Office\9.5\Accounting\Migration\ServerMigrationLog 1.pdf
4. Click [Validate] to perform a test of the files to be transferred.
5. When you see the Validation complete message and the validation is successful, click [Migrate].
6. When you see the Migration complete message, view the server migration log (that you set up in
Step 3) to ensure that all files were transferred correctly.
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Migrating your data folders
1. On the new server, open your program files folder and \Timberline Office\Shared, and then doubleclick Sage.STO.ServerDataMigrator.exe.
2. In the Server Data Location window, verify or change the data folder migration log name and path (on
the new server) for Log file path. For example:\\newservername\Timberline
Office\9.5\Accounting\Migration\ServerDataMigrationLog 1.pdf
3. Select the companies whose data you want to copy.
4. Click [Validate] to perform a test of the files to be copied.
5. When you see the Validation complete message and the validation is successful, click [Migrate
data folders].
6. When you see the Migration complete message, view the server data migration log (that you set up in
Step 2) to ensure that all files were copied correctly.

Migrating your macros
Any macros that you have must be in the Company folder on the old server prior to migration. You can copy
the macros to the Company folder, if necessary. If the macros are not in the Company folder, you will need to
recreate them on the new server after the migration.
1. If the Server Data Location window is not already open on the new server, open your program files
folder and \Timberline Office\Shared, and then double-click Sage.STO.ServerDataMigrator.exe.
2. In the Server Data Location window, verify or change the macro migration log name and path (on the
new server) for Log file path. For example: \\newservername\Timberline
Office\9.5\Accounting\Migration\MacroMigration.pdf
3. Select the companies whose macros you want to copy.
4. Click [Migrate Macros].
5. In the Macro Printer List window, verify the printers that you want to use are listed. Click [Change] if
you want to select different printers.
6. Click [Migrate Macros].
7. When you see the Macro migration complete message, view the macro migration log (that you set
up in Step 2) to ensure that all macros were transferred correctly.
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Migrating your attachments
Note: Migrating attachments can take some time. If you have many attachments, you may want to
consider migrating them during non-business hours.
1. If the Server Data Location window is not already open on the new server, open your program files
folder and \Timberline Office\Shared, and then double-click Sage.STO.ServerDataMigrator.exe.
2. In the Server Data Location window, verify or change the attachment migration log name and path (on
the new server) for Log file path. For example: \\newservername\Timberline
Office\9.5\Accounting\Migration\AttachmentMigration.pdf
3. Select the companies whose attachments you want to copy.
4. Click [Migrate attachments].
5. In the Attachment Paths window, review the table showing the old and new locations for each set of
attachments. You can change the new location.
a. If you want to change the new attachment path for all rows to the default location on the new
server, click [Use default location].
b. If you want to replace portions of the new paths in specific rows, select the check box in front of
the rows that you want to change, click [Replace selected], type the old text (for Find), type
the new text (for Replace), and then click [OK].
c. If you want to change the new path for one row, either:
l

Click in the New attachment path column and type the new path.

l

Click [Change], specify the new path, and then click [OK].

6. When the rows display the desired new attachment paths, click [Migrate attachments].
7. When you see the Attachment migration complete message, view the attachment migration log
(that you set up in Step 2) to ensure that all attachments were transferred correctly.

Updating your workstations
After you migrate your server, you must uninstall and then reinstall Sage 300 Construction and Real Estate on
all workstations so they interact with the data on the new server instead of the old.
1. On the workstation, uninstall the program by opening the Control Panel, selecting Uninstall a
program, right-clicking Sage 300 Construction and Real Estate and selecting Uninstall.
2. Follow the instructions on page 11 for installing Sage 300 Construction and Real Estate on a
workstation.
3. Repeat these steps for every workstation running Sage 300 Construction and Real Estate.
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General information
Review the hardware and software requirements. For details about installing, see “Chapter 2: Install Sage 300
Construction and Real Estate” on page 8.
We strongly recommend that you use third-party software to back up all Sage 300 Construction and Real
Estate data files to external media daily.
Note: For information about backing up Document Management, see the Document Management User's
Guide.
Consider the following as you develop your backup plan:
n

n

n

n

n

Use third-party backup software for all backups.
Verify that when a folder is included in a backup, the backup software also includes the subfolders. The
backup software should support recursive backups.
Schedule the backup during off-peak hours, since all users must close Sage 300 Construction and Real
Estate before you back up files.
Always back up your entire Sage 300 Construction and Real Estate dataset. Do not perform incremental
backups.
Review the backup to be sure all data has been included. Back up all data and files, even if they are outside
the default folders. For most Accounting and Management products, you can see a list of folders that are
outside the current data folder.
From Sage Desktop in the Applications pane, select Common Tasks > File > Company Settings >
File Locations.

n

Back up all data and application files within the Sage folder:
On Windows 2008 and Windows 7–[Drive:]\Program Data\Sage

n

n

Store backup media in a secure location outside your building.
Test backups by restoring them to test folders. These tests are important because backup media may have
a limited life, backup devices may malfunction, and you may have incorrect software settings in your
backup software.
Caution! When you test a backup, keep the restored data separate from your production data.
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Using File Tools for Inventory, Purchasing, and Service Management
To use File Tools with Inventory or Purchasing, start Sage Desktop or another application (not Inventory or
Purchasing) and include the POIV Data folder in the File Tools operation.
To use File Tools with Service Management, start Sage Desktop or another application (not Service
Management) and include the SMDataData folder in the File Tools operation.
Note: To use Sage 300 Construction and Real Estate, users must have full control of the Pervasive
installation folder and subfolders. For information on using Pervasive, see “Pervasive Database Engines”
on page 35.

Do not actively scan Pervasive program files, Sage 300 Construction and Real Estate
program files, or Sage 300 Construction and Real Estate data files for viruses
Important! Scan these files at a time when they are not in use. For example, schedule a daily scan
overnight.
If you actively scan Pervasive program files, Sage 300 Construction and Real Estate program files, or Sage
300 Construction and Real Estate data files for viruses, this may cause Sage 300 Construction and Real
Estate to run slowly or to close unexpectedly. Typical folders that contain files that you should not scan
include:
n

Sage 300 Construction and Real Estate program files: (for example, [Drive]:\Program Files\Timberline
Office)

n

Sage 300 Construction and Real Estate data files: (for example, [Drive]:\TSData)

n

Pervasive program files:
Windows Server 2008 and Windows 7: C:\Program Data\Pervasive Software

Windows User Account Control (UAC)
Sage 300 Construction and Real Estate is designed to work with the Windows User Account Control (UAC)
security scheme. With Windows 7 and Windows Server 2008 and later, you cannot save a file to a folder to
which you do not have read/write permissions assigned. If such an attempt is made, Windows security
diverts your data to a copy of the data file or report and associates the copy with your user profile, thereby
possibly compromising the integrity of your application. To prevent this, Sage 300 Construction and Real
Estate applications present you with an error message if you try to save a file to such a location. See page 38
for more information about moving your data folders for compliance with UAC.
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Accounting and Management products
n

n

New installations of Sage 300 Construction and Real Estate on Windows 7 or Windows Server 2008
operating systems will place data files in the Drive]:\ProgramData\Timberline Office folder.
Upgrades to existing installations on Windows 7 or Windows Server 2008 require you to share the data
folders and assign read/write permissions or move the folders to a shared location and assign read/write
permission to the shared location.
Note: You can share the data files before installing the upgrade. You can move data folders after
completing the upgrade installation. If you move your data files and you use File Locations (File >
Company Settings > File Locations) to allow other data folders to access the folder's data files, be sure
you update the locations using File Locations for each affected data folder.

If you install in a client/server environment, note that the WinInst folder and corresponding Install.exe file was
moved in 9.5. The path to the WinInst folder is:
Windows 7 and Windows 2008: [Drive]:\Program Data\\Sage\Timberline
Office\9.5\Accounting\WinInst\Install.exe

Estimating products
If you are upgrading Sage Estimating, all of the Sage Estimating data files and reports previously residing in
the Program Files folder will be copied automatically to a shared location.
n

In Windows 7 and Windows Server 2008, these files will be copied to the
[Drive]:\Users\Public\Estimating folder.

After installation, verify your application operates correctly and you have access to your data then remove the
original data files from the Program Files folder.

View hidden folders
Some folders may be hidden. To view them on:
l

l

Windows 7 or Windows Server 2008: Open Windows Explorer, select Organize > Folder and
Search Options, click the View tab, and then select Show hidden files and folders.
Windows 8, Windows 8.1, Windows 10, Windows Server 2012, or Windows Server 2012 R2: Open
Windows Explorer, click the View tab, and then select the Hidden items check box.

Do not use NTFS file compression on data or program files for Sage 300 Construction
and Real Estate
Using Microsoft Windows NTFS file system to compress files causes Sage 300 Construction and Real
Estate to run very slowly.

Terminal services
Configure terminal services to maintain an operator’s session during connection breaks
Configuring terminal services to maintain an operator’s session during connection breaks prevents a program
from closing unexpectedly and helps preserve data integrity. To set up this aspect of Windows Terminal
Services, use the Terminal Services Configuration program.
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For more information about using terminal services, see “Terminal services” on page 39

Do not use fast user switching
Sage 300 Construction and Real Estate does not support fast user switching on Windows 7.

Pervasive Database Engines
The Pervasive database engines provide access to Sage 300 Construction and Real Estate data files. To use
Sage 300 Construction and Real Estate, users must have full control of the Pervasive installation folder and
subfolders.

Do not use the Subst or Netdrv commands in windows
The Subst and Netdrv commands may cause Pervasive status code 11 or 116 errors.

Do not exclusively use the NetBEUI network protocol
We do not support the NetBEUI network protocol. If NetBEUI is your only network protocol, you must install
TCP/IP before you install Sage 300 Construction and Real Estate. If no applications require the NetBEUI
protocol, consult with a network technician about removing it.

Firewalls and Sage Service Host
Beginning with Sage 300 Construction and Real Estate version 9.5, the Sage Service Host uses TCP instead
of named pipes for inter-machine communication. Sage Service Host is a Windows service that runs on Sage
300 Construction and Real Estate servers and workstations. This service facilitates communication between
Sage 300 Construction and Real Estate applications.
If you use Windows Firewall, you do not need to take any action, as Windows Firewall is configured during
installation to work correctly with Sage 300 Construction and Real Estate. However, if you use a nonWindows firewall, you may need to manually adjust some settings to ensure proper performance.

Setting up Sage Service Host on firewalls other than Windows Firewall
If you use a firewall other than Windows Firewall, you may be prompted during installation that the Sage
Service Host is attempting to access the internet or is attempting to act as a server. The Sage Service Host
must be given permission to perform these types of activities.
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If you need to manually set up this exception, make the following changes on every machine where Sage 300
Construction and Real Estate is installed:
n

n

Set up your firewall to allow an exception for the Sage Service Host. Refer to the Windows Firewall
instructions below and your firewall documentation for specific instructions.
If you have other software that uses TCP ports 8101 and 8102, you may need to manually configure either
the other software or the Sage Service Host to use different port numbers.
The Sage Service Host port numbers can be configured in the Sage.STO.9.5.xml file. This file is located in
Documents and Settings\All Users\Application Data\Sage\LS1\ServiceHost\1.0\Configuration. If
you need to change the default port numbers for Sage Service Host, this file should be changed on every
machine on the network where Sage 300 Construction and Real Estate is being installed, including the
accounting server.

Setting up Sage Service Host on a Windows Firewall
Windows Firewall is automatically configured during installation to work correctly with Sage Service Host.
However, if you need to manually set up Sage Service Host to communicate on a Windows Firewall, do the
following:
n

n

n

Open Windows Firewall and select the Exceptions tab. If Sage Service Host is not on the list, you can add
it by selecting [Add Program], and then browsing to the following path: [Drive]: \Program
Files\Common Files\Sage\LS1\ServiceHost\1.0\ Sage.LS1.ServiceHost.exe.
By default, the exception is set for any computer on the network. You can adjust this setting by selecting
[Change Scope].
If you have other software that uses TCP ports 8101 and 8102, you may need to manually configure either
the other software or the Sage Service Host to use different port numbers.
The Sage Service Host port numbers can be configured in the Sage.STO.9.5.xml file. This file is located in
Documents and Settings\All Users\Application Data\Sage\LS1\ServiceHost\1.0\Configuration. If
you need to change the default port numbers for Sage Service Host, this file should be changed on every
computer on the network where Sage 300 Construction and Real Estate is being installed, including the
accounting server.
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Troubleshooting
This section contains answers to the following questions:
l

l

l

l

l

l

“If Sage 300 Construction and Real Estate stops responding during the workstation installation, how
can I resolve this?”
“When I start Estimating or Buyout on my workstation, a message that begins with “Unable to connect
to the Address Book database” appears. How do I connect to the Address Book database?”
“How do I move Accounting and Management products from one server to another?” on page 38
“I upgraded from Sage 300 Construction and Real Estate 9.4. Do I need to move my data folders or
reports to comply with User Account Control (UAC) requirements?” on page 38
“Which Accounting and Management files were moved for Sage 300 Construction and Real Estate?”
on page 38
“Why am I getting an error message when I try to save data or reports?” on page 39

Depending on your service plan, you may be able to take advantage of the technical support offered by Sage
300 Construction and Real Estate.

If Sage 300 Construction and Real Estate stops responding during the workstation
installation, how can I resolve this?
Try the following:
n

n

Turn off antivirus software and unnecessary programs before you install.
Verify that you have full user rights to the parent folder of the application data folders containing files needed
so that Sage 300 Construction and Real Estate can run correctly.
For Accounting and Management applications, the default location is:
p

Windows 7 and Windows Server 2008: [Drive]:\Program Data\Sage.

For Estimating applications, the default location is:
p

Windows 7 and Windows Server 2008: [Drive]:\Users\Public\Estimating.

When I start Estimating or Buyout on my workstation, a message that begins with
“Unable to connect to the Address Book database” appears. How do I connect to the
Address Book database?
You must perform an additional installation and then configure Estimating and Buyout to access shared
Address Book, Job Cost, and tax data.
For instructions about the additional installation, see the ““D. Other installation scenarios” on page 20”.
For instructions about configuring Estimating and Buyout to access shared Address Book, Job Cost, and tax
data, see “Selecting a company data folder for Address Book and Job Cost information” in Estimating Help or
“Select a company data folder for Address Book and accounting information” in Buyout Help.
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How do I move Accounting and Management products from one server to another?
Use the server migration tool found in Sage 300 Construction and Real Estate. For detailed instructions, see
“Chapter 4: Server Migration” on page 28. You can also access the Knowledgebase at
https://support.na.sage.com, log on, and search for Article ID 22043.
Caution! Incorrectly moving Sage 300 Construction and Real Estate data folders may severely damage
your system. Sage Software is not responsible for damage to your data caused by incorrectly moving your
Sage 300 Construction and Real Estate data folders. Before making changes to your Sage 300
Construction and Real Estate data, contact your system administrator for assistance and make a backup
copy of all valued data.
Note: Versions of Sage 300 Construction and Real Estate prior to 9.5 will not install correctly on a
Windows 2007 or Microsoft Server 2008 operating system.

I upgraded from Sage 300 Construction and Real Estate 9.4. Do I need to move my data
folders or reports to comply with User Account Control (UAC) requirements?
For Accounting & Management applications, you do not need to move folders to comply with UAC
requirements unless you also install the Windows Server 2008 operating system.
If you install on Windows Server 2008 or Windows 7, you do not need to move folders if they are already
shared. If your data and report folders are not already shared, you will need to share the location or move them
to a shared location and then update their location at File > Open Company > [Specify Folders]. Refer to
“Which Accounting and Management files were moved for Sage 300 Construction and Real Estate?” (the next
question) for information on folder locations.
The Sage 300 Construction and Real Estate folder continues to exist under Program Files but contains only
the essential binary files required for the applications to operate.
For Estimating applications, your folders will be copied automatically to a shared location during upgrade.
In Purchasing (PO) and Inventory (IV), if you originally set up your company (data) folder inside the Program
Files folder, your data will not be accessible after you upgrade.
To prevent this issue, you should move your data from the Program Files folder to a different location prior to
upgrading, as described in “Windows User Account Control (UAC) ” on page 33.
Opening Purchasing or Inventory from a workstation before opening on a server will cause the DSN to be set
incorrectly. After Purchasing or Inventory has been opened at the server, the applications can be opened at
any workstation.
This issue is not specific to UAC but the solution to resolve it is the same.
After installation, verify your application operates correctly and you have access to your data, then remove the
original data files from the Program Files folder.

Which Accounting and Management files were moved for Sage 300 Construction and
Real Estate?
Many Sage 300 Construction and Real Estate folders were moved from the Program Files folder to a shared
location beginning with the 9.5 release. A list of the affected Accounting & Management application folders is
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provided in the following table.
Note:
Some folders may be hidden. To view them in:
l

l

Windows 7 or Windows Server 2008: Open Windows Explorer, select Organize > Folder and
Search Options, click the View tab, and then select Show hidden files and folders.
Windows 8, Windows 8.1, Windows 10, Windows Server 2012, or Windows Server 2012 R2:
Open Windows Explorer, click the View tab, and then select the Hidden items check box.

File/Original Location

New Location (Windows Server 2008)

[Program Files]\Timberline
Office\Accounting\Formula

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Formula

[Program Files]\Timberline
Office\Accounting\Inquiry

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Inquiry

[Program Files]\Timberline
Office\Accounting\Report

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Report

[Program Files]\Timberline
Office\Accounting\Template

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Template

[Program Files]\Timberline
Office\Accounting\
[Sample Data Folders]

ProgramData\Sage\TimberlineOffice\Data\[Sample Data Folders]

[Program Files]\Timberline
Office\Accounting\Wininst

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Wininst

[Program Files]\Timberline
Office\Documents

ProgramData\Sage\TimberlineOffice\9.5\Documents

Why am I getting an error message when I try to save data or reports?
You cannot save data or report files to a location for which you do not have read/write permissions. This is to
comply with Windows security requirements. To save the file, you must first have read/write permissions
assigned or else save the file to another location to which you already have these permissions.

Terminal services
Windows Terminal Services is a component of Microsoft Windows Server. Terminal Services consists of a
terminal server and one or more remote workstations. It enables users to access programs or data stored on a
remote computer by a phone, network, Internet connection, or other communication methods.
Remote network connections do not provide adequate bandwidth to run Sage 300 Construction and Real
Estate products without the use of Terminal Services. Terminal Services provides remote users with a stable
and well-performing experience.
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Note: You must use License Manager in order to use Estimating with Terminal Services.
Important! If you use Citrix MetaFrame, you must install it before you install Sage 300 Construction and
Real Estate.
You can install Sage 300 Construction and Real Estate applications on your terminal server (as described in
Chapter 2), or you can use Terminal Services in conjunction with a server for Sage 300 Construction and Real
Estate.
Note: Sage does not support the administrative configuration of Terminal Services with Sage 300
Construction and Real Estate products because it is a partially configured version of Terminal Services.

Printers
General guidelines
Sage 300 Construction and Real Estate supports the use of business-class laser printers.
We no longer support the use of dot matrix printers for printing 1099 and W-2 forms.
Instead, use a laser printer or dot matrix printer. Some reports that use the Crystal Reports® format require a
laser printer. For example, you must use a laser printer to generate cost and contract invoices (AIA
documents) in Billing, Service Management, Purchasing, and Inventory.
You should use inkjet or bubble jet printers only as backup printers; we do not test inkjet or bubble jet printers.

Printer driver
We strongly recommend that you use a PCL 5e printer driver.
Most new printers also support a PCL 6 printer driver. A PCL 6 driver supports higher resolutions than a PCL
5e driver (1200 dots per inch versus 600 dots per inch). However, because of its higher resolution (and, thus,
greater memory needs), PCL-6-based printing uses more toner, is slower, and is sometimes unstable.
Many printers come with both PCL 5e drivers and PCL 6 drivers. If your printer does not come with a PCL 5e
driver, your printer manufacturer probably offers one for free online.
Try using the PCL 5e driver first. Switch to a PCL 6 driver only if your printer does not function properly with a
PCL 5e driver.

Margins
The following margins work with most laser printers.
Products

Top margin

Bottom margin

Left margin

Right margin

Accounting and Management
products

0.25 inches

0.5 inches

0.25 inches

0.5 inches
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Products

Top margin

Bottom margin

Left margin

Right margin

Estimating products with portrait
printouts

0.2 inches

0.2 inches

0.3 inches

0.3 inches

Estimating products with
landscape printouts

0.3 inches

0.3 inches

0.2 inches

0.2 inches

Install, move, or remove Sage 300 Construction and Real
Estate products
Sage 300 Construction and Real Estate uses Microsoft Installer (MSI) for the installation, repair, modification,
and removal of Accounting and Management Products.

Installation
The MSI installation occurs automatically when you install Accounting and Management Products. Use the
Microsoft® Event Viewer to review the final status of the installation. You can find the Event Viewer in the
Control Panel > Administrative Tools folder. For information about installing, see:
l

“Chapter 2: Install Sage 300 Construction and Real Estate” on page 8 (Accounting and Management)

l

“Chapter 3: Install Sage Estimating” on page 17

Auto-repair feature
This feature occurs automatically when you start an application and does not require any action or response.
MSI tracks important groupings of files that are necessary for an application to run. If an important component
is missing, MSI restores these files from the original installation source.
If MSI detects missing components, you may notice a brief delay of approximately two minutes while MSI
validates them. In a Sage 300 Construction and Real Estate server configuration, you will be prompted for the
installation DVD unless the installation source was copied and installed from the hard drive. On a workstation
running Sage 300 Construction and Real Estate, the utility retrieves the missing files from the shared Sage
300 Construction and Real Estate server if a valid network connection exists.
Use the Microsoft Event Viewer to review the changes made to the installation. You can find the Event
Viewer in the Control Panel > Administrative Tools folder.

Modify option
Use to add new programs or change program uses. This option is available when you reinstall a currently
installed version of Accounting and Management Products on the server.
This utility proceeds through the traditional installation routine with the exception that you cannot change your
registration name or client number.
To start the utility, begin the installation process by double-clicking Install.exe. In the Accounting Server InstallShield Wizard window, select Modify.
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Remove utility
Use the Remove utility to permanently remove Sage 300 Construction and Real Estate products from a
server or workstation. For additional information, see “Removing Accounting and Management products
entirely” (the next section)
This utility removes application files and application registry folders which are created during the application
installation process. It does not necessarily return the server or workstation to its original state. Files and
registry values modified or created during the use of Accounting and Management products will still exist (for
example, \HKEY_CURRENT_USER\Software\Timberline).
To start the utility, open the Windows Add or Remove Programs option, select Timberline Accounting
Server or Timberline Accounting Client, and then click [Remove].

Removing Accounting and Management products entirely
A complete removal of the Accounting and Management Products includes running the uninstall program first,
then manually deleting the Program folder for Sage 300 Construction and Real Estate, manually deleting the
application data folder for Sage 300 Construction and Real Estate, manually deleting the Current User registry
keys for Sage 300 Construction and Real Estate, and uninstalling any third-party prerequisite products. If you
decide to reinstall after doing a complete removal of Accounting and Management Products, you must restore
all Accounting and Management Products folders and files from a backup and then reinstall the Accounting
and Management Products.

Summary of removal steps
1 Back up the Sage 300 Construction and Real Estate program folder and all company data. Confirm that the
backup was successful before continuing.
2 Remove Sage 300 Construction and Real Estate as described above.
3 Use Windows Explorer to delete the Sage 300 Construction and Real Estate folder (typically installed at
X:\Program Files\Timberline Office).
4 Use Windows Explorer to delete the Sage application data folder. This is typically installed at
[Drive]:\Program Data\Sage for Windows Server 2008.
5 (Optional) Use the Microsoft Registry Editor to delete the registry key \HKEY_CURRENT_
USER\Software\Timberline.
6 Use Windows Add or Remove Programs to remove Pervasive.SQL Server from the Sage 300
Construction and Real Estate Server. Use Windows Add or Remove Programs to remove
Pervasive.SQL Workgroup from Sage 300 Construction and Real Estate workstations.
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Security overview
If you have many people working in your office, you may not want each one to have access to all the features
of the software. For instance, you may not want all staff members to be able to print checks or to print reports
that include sensitive data.
You can use the security function in Sage 300 Construction and Real Estate to restrict access to various
areas of the software.
Sage 300 Construction and Real Estate security is set up through the Security Administration tool in Sage
Desktop (by selecting Options > Security Administration).

User types
The Security Administration tool for Sage 300 Construction and Real Estate includes three types of users:
security administrators, application administrators, and Sage 300 Construction and Real Estate users.
n

n

n

n

Security administrators set up and maintain accounts for users. For a complete list of tasks that a
security administrator can perform, see “Setting up security ” on page 52
Application administrators can restrict access to software features and data that each user has
permission to access. They define roles and assign users to the roles. For a complete list of tasks that an
application administrator can perform, see “Setting up security ” on page 52
Users have task permissions defined by the application administrator. These permissions can range from
none to almost as extensive as an application administrator. Users can have the same level of file and
record access as an application administrator. Users can have access to one or more companies.
A role represents a group of users who have the same security requirements. A role has its own user name
and its own task, record, file, and company permissions.
The use of roles often saves setup time, because the application administrator can assign permissions to
new users simply by assigning them to an existing role. The use of roles can also clarify your company's
security plan because the application administrator can create roles that correspond to the company's
organizational structure. For example, the application administrator can create roles for Accounts Payable
clerks, Payroll clerks, property managers, and project managers.

Types of security
n

Task security restricts access to menu items and certain tasks. For example, you can control who can set
up vendors in Accounts Payable.
With task security, an application administrator can restrict access to menu items and certain tasks found
within windows. For example, task security can control access to the Setup > Vendors menu item in
Accounts Payable (AP.) Also, task security can control whether you can approve a change order in the
Item Status field of the Enter Change Order Items - Scope of Change window in Job Cost.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 43

Chapter 6: Security

In the following example of task security, an application administrator assigns task permissions based on
the tasks that the employees need to perform.

Role

Permission to
AP Settings?

Permission to
Post Invoices?

Permission to
AP Reports?

CONTROL (controller)

Yes

Yes

Yes

Yes

Yes

APCLERK (AP clerk)
PROJMGR (project manager)
n

Yes

File security blocks all access to a file and restricts ODBC access. For example, you can restrict access
to sensitive payroll files.
File security allows application administrators to block all access to a file. This includes access through
open database connectivity and through all related tasks, reports, and inquiries. This differs from task
security, which allows application administrators to block tasks selectively and does not allow them to
control ODBC access.
In the following example of file security, a company has two Payroll (PR) master files. One is for the
executive staff and the other is for the field staff. In order to keep the executive payroll information private,
the company creates a separate role for users that handle the executive PR master file.

Role

Users

Access to Exec
PR Master File?

EXECPR
(executive payroll)

Controller and a
senior payroll clerk

Yes, for all users
assigned to this role

FIELDPR
(field payroll)

Controller and all
payroll clerks

Access to Field
PR Master File?

Yes, for all users
assigned to this role

In this example, the senior payroll clerk is a member of both the EXECPR and FIELDPR roles. A user can
belong to more than one role.
n

n

n

Record security controls access to certain records so that reports and inquiries display only the records to
which the user has security access. For example, you can restrict reporting and inquiries on jobs or bank
accounts.
Company security restricts access to which companies a user can see. Application administrators can
grant a user access to specific companies. Security administrators and application administrators have
access to all companies.
Application security prevents unauthorized users from accessing Sage 300 Construction and Real
Estate. When application administrators turn on application security, all users must enter a user name and
password to access the software. They can restrict access to software features and data that each user
has permission to access. Security Administration offers four types of application security: task, file,
record, and company.
Application security also lets application administrators hide applications from users and roles. When an
application administrator uses the Security Administration tool to deny a user or role access to all tasks in
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an application and sets secured menu items to not display, users cannot see the application in Sage
Desktop.

Log settings
By default, logging is turned on. Security administrators can turn off Application, Security, or Setup logging.
The Audit Setup, Field Report, and System logs are required. You cannot turn them off.
The Posting Recap and Task Summary logs are for future use. No logs are created at this time.
Required Log

Log Type

Description

No

Application

Logs the start and end of Accounting applications and tasks.

Yes

Audit Setup

Logs changes when the audit setup activity is selected in an
Accounting application.

Yes

Field Report

Logs changes to finalized field reports in Project Management.

Yes

Posting Recap

Logs recaps created while posting entries in Accounting. (For
future use.)

No

Security

Logs events in the Security Administration tool.

No

Setup

Logs changes to setup information in Accounting.

Yes

System

Logs Accounting system events.

Yes

Task Summary

Logs summaries created during an Accounting task. (For future
use.)

Applications with Security Administration
The following applications feature Security Administration:
n

Accounts Payable

n

Equipment Cost

n

Payroll

n

Accounts Receivable

n

Financial Statements

n

Project Management

n

Address Book

n

General Ledger

n

Property Management

n

Billing

n

Information Assistant

n

Remote Time

n

Cash Management

n

Inquiry Designer

n

Report Designer

n

Contacts

n

Job Cost
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The following applications have limited Security Administration:
n

n

Document Management security features are managed in two areas: Security Administration and
Document Management settings. Security administrators manage Document Management users and roles
in Security Administration. Application administrators manage Document Management task security
(inbox, scan queue, and query) in Security Administration. Privileged operators manage document security
and document type security in Document Management settings. For more information, see Document
Management Help.
Estimating is affected by file security and task security. Application administrators cannot set up Security
Administration for Estimating but, if Security Administration has been set up in one of the applications listed
previously, you must type a user name and password before you use Estimating.
Estimating offers its own form of file security on estimate and database files. Although similar to Security
Administration, it is different because it is not set up from the Security Administration tool and it requires a
password but not a user name.

n

n

Purchasing and Inventory are affected by task security. Like Estimating, application administrators
cannot set up Security Administration for these applications but you must type your user name and
password if Security Administration is on. Purchasing and Inventory also offer their own form of task
security. For more information, see Help in these applications.
Service Management uses task security. Application administrators can create users and roles and set up
task security for Service Management just as you would in the bulleted list of applications above.

Record security
With record security, you can control access to four records:
n

Cash Management bank account

n

General Ledger prefix

n

Job Cost and Project Management job

n

Property Management property

In addition, you can select or clear the Give all users access to records with blank security IDs check
box. Select the box if you want records with blank security IDs to be accessible to all users. Clear the box if
you want only application administrators to access these records. For more information, see “Set up record
security” on page 56.
When record security is active, reports and inquiries display only the records to which the user has access.
For more information, see “Effect of record security on reports” on page 47 and see “Effect of record security
on inquiries” on page 49.
Record security also affects Job Cost, Contracts, and Project Management tasks. In these applications, you
can type or select only jobs to which you have access. For more information, see “Effect of record security on
tasks” on page 51.
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Example—using record security
In the following example, a property manager, Accounts Payable (AP) clerk, and Property Management (PM)
clerk work as a team on certain properties. Another project manager, AP clerk, and PM clerk work as a team
on different properties.
With the following record security setup, these employees have access to only their team's properties.
Access to TEAM1
Properties?

Role

Users

TEAM1

Proj Mgr 1

Access to TEAM2
Properties?

Yes, for all TEAM1 users
assigned to this role

AP Clerk 1
JC Clerk 1
TEAM2

Proj Mgr 2

Yes, for all TEAM2 users
assigned to this role

AP Clerk 2
JC Clerk 2

Effect of record security on reports
When record security is active on a report, the report displays only the records that are accessible to the
current user. Moreover, totals on the report adjust to reflect only the accessible records.
For example, in Job Cost, a Cost Entries by Job report (simplified for this example) would look like the
following to an application administrator:
Job

Cost Code

Category

Amount

01-002

3-110

L (labor)

100.00

01-003

2-520

M (material)

350.00

Report Total

450.00

To a user with permissions to only job 01-002, the same report would look like the following:
Job

Cost Code

Category

Amount

01-002

3-110

L (labor)

100.00

Report Total

100.00
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Note: Some reports list information from several different records on the same line. If you lack access
rights to the report’s driving record (the primary record upon which the report is based), the report skips the
entire line. If you lack access rights to one of the non-driving records, the report skips only the information
from that record.

Report record security settings
Each report has security settings that control whether record security can affect the report. If you own Report
Designer, you can modify these settings (Report Designer >Design Security). If you do not own Report
Designer, an application administrator can control record security on reports only by turning on or turning off
record security. (For more information, see “Turn off record security,” on page 61.)
Sage 300 Construction and Real Estate defines the security settings on stock reports based on whether (a)
the report contains sensitive information or (b) the report's content should be tailored to the user. For example,
Sage 300 Construction and Real Estate allows the bank record on the Cash Management Check Register
report to be secured so that, if record security is on, you can generate reports that list only the entries for the
banks to which the current user has access.
In some cases, for practical reasons, Sage 300 Construction and Real Estate does not allow record security
to affect a report. For example, in Cash Management, you can type any bank in data entry tasks (bank
account record security currently only affects reports and inquiries). Therefore, Sage 300 Construction and
Real Estate does not secure the bank account record on the Cash Management Journal report.

Indicators that record security affects a report
Record security always affects a Crystal report, which has a “(CR)” in its name, unless the report uses a
special formula to disable record security. To check for this formula, you must open the report in Crystal
Decisions Crystal Reports. (You cannot use a Sage 300 Construction and Real Estate application to check
for this formula.) Add to Crystal section or link to/from
Note: If you create reports in Report Designer, then you can secure those reports with Security
Administration. You must be an application administrator and own Report Designer to modify security
settings on new report designs.
If you do not own Report Designer: the report's cover page indicates whether record security is on. You
have the following options regarding cover pages:
n

n

If you want to print a cover page every time you print any report, select Tools > Options. On the Reports
tab, select Attach to report.
If you want to print a cover page only some of the time, you must choose to print a cover page at the time of
printing. From an applications Tools menu, select the report and from the Print Selection window, click
[Page Setup]. Then select Attach to report.

If you own Report Designer: in addition to the report cover page (see above), record security information
can appear in three additional areas.
n

n

A report's design information (Tools > Design Info) lists the report's record security settings.
A report's page heading (defined in File > Page Setup > Page Headings) indicates whether record
security is on.
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n

If you open a report created in Report Designer 7.x or earlier and the report contains secured records, you
will receive an on-screen message that lists the secure records on that report. Once you save the report,
you will no longer receive this message.

Effect of an upgrade on reports
When you upgrade from Sage 300 Construction and Real Estate Accounting products 7.x or earlier to Sage
300 Construction and Real Estate 8.0 or later, the following changes take place with reports.

Stock reports
New stock reports replace your existing stock reports. The new reports have settings that control whether
record security can affect the reports. However, these settings take effect only if you activate record security.

Custom reports
If you open a custom report created in Report Designer 7.x or earlier, the software displays a message that
lists the secure records on that report. Once you save the report, you no longer receive this message.
The software also modifies the report's security settings. It changes these settings to allow record security, if
active, to affect all securable records on the report.
You must use Report Designer to change a report's settings. If you do not own Report Designer, the only way
to control record security on a report is for an application administrator to turn on or turn off record security.

Effect of record security on inquiries
When record security for an inquiry is on, the inquiry displays only records that are accessible to the current
user.
For example, in Cash Management, a Bank List inquiry would look like the following to an application
administrator:
Bank Account

Description

Account Number

Register Balance

First

First Bank

042134526

56,650.97

Liberty

Liberty S&L

874613754

91,450.44

To a user with permissions to only First Bank, the same inquiry would look like the following:
Bank Account

Description

Account Number

Register Balance

First

First Bank

042134526

56,650.97

Note: Some inquiries list information from several different records on the same line. If you lack access
rights to the inquiry's driving record (the primary record upon which the inquiry is based), the inquiry skips
the entire line. If you lack access rights to one of the non-driving records, the inquiry skips only the
information from that record.
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Inquiry record security settings
Each inquiry has record security settings that control whether record security can affect the inquiry. These
settings take effect in the following scenarios:
n

New installations of Sage 300 Construction and Real Estate 8.0 or later.

n

Subsequent upgrades of a new 8.0 or later installation.

If you upgrade from Sage 300 Construction and Real Estate Accounting and Management products 7.x or
earlier to Sage 300 Construction and Real Estate 8.0 or later, these settings do not take effect. Instead, record
security automatically affects your inquiries if it is on. For more information, see “Effect of an upgrade on
inquiries” (the next section).
Sage 300 Construction and Real Estate selects inquiry record security settings based on whether the inquiry
contains sensitive information or whether its information should be tailored to the user. For example, Sage 300
Construction and Real Estate allows the bank record on the Cash Management Bank Register inquiry to be
secured so that, if record security is on, your inquiry displays entries for only the banks to which you have
access.
If you own Inquiry Designer, you can modify inquiry security settings. For more information, see “Change
design security on an inquiry” on page 65.
If you do not own Inquiry Designer, application administrators can control record security on inquiries
only by turning on or turning off record security. For more information, see “Turn off record security,” on page
61.

Indicators that record security affects an inquiry
A button with a lock on it appears in the upper right corner of the inquiry. If you click this button, a Record
Security window appears that lists which records are secured on the inquiry.
Note: In this window, an application administrator can select or clear records to secure. However, the
selections affect only the current user's session. Therefore, selections are inconsequential because an
application administrator already has permission to view all records.

Effect of an upgrade on inquiries
If your Sage 300 Construction and Real Estate Accounting products installation started with 7.x or earlier,
record security affects your stock and custom inquiries to the extent that it is on. (Installations that started
with 8.0 or later are different; see next section). For example, if record security is on for the Cash Management
bank account record and the Job Cost and Project Management job records, these records are automatically
secured on the inquiry. If record security is on for only the Cash Management bank account record, only this
record is secured on the inquiry.
If you own Inquiry Designer, you can specify settings on each inquiry that control whether record security
affects the inquiry.

Difference between upgrades and new installations
New installations of Sage 300 Construction and Real Estate (and subsequent upgrades) use Sage 300
Construction and Real Estate’s predefined inquiry record security settings. These settings control whether
record security can affect an inquiry. For example, if an inquiry’s settings do not allow Cash Management
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bank account record security, this record is not secured on the inquiry (even if record security is on). For an
upgrade, record security automatically affects the bank account record because the inquiry does not use the
predefined record security settings.

Effect of record security on tasks
Record security can restrict access to the job record in certain Job Cost (JC), Contracts (CN), and Project
Management (PJ) tasks. When record security is turned on for jobs, you cannot view a job in a list or type a
job unless you have security access for that job. For example, in the PJ Job Setup window (PJ > Setup >
Jobs), when you click [Find] to list jobs that have been previously set up, you see only jobs to which you
have access.
In addition, you can select or clear the Give all users access to records with blank security IDs check
box. Select the box if you want records with blank security IDs to be accessible to all users. Clear the box if
you want only application administrators to access these records. For more information, see “Set up record
security” on page 56.
Job record security affects the following tasks:

Contracts
p

Edit > Link

p

Edit > Add/Edit JC CO link

p

Edit > JC CO Item Link Details

Job Cost
p

Setup > Jobs

p

Tasks > Enter Estimates

p

Tasks > Change Orders

p

Tasks > Commitments

p

Tasks > Commitment Change Orders

p

Tasks > Enter Misc Worksheets

Project Management
All tasks that involve the job record (for example, job setup and document creation).
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Setting up security
This section contains the tasks that security administrators and application administrators need to perform to
set up security. Some tasks can be performed by either administrator role. Other tasks must be performed by
a specific administrator role. The best practice is for the security administrator to perform steps 1 through 8
and for the application administrator to perform steps 9 through 13. Steps 6, 12, and 13 are optional.
Whether you can perform this tack
if you have this role:

Security
Administrator

Application
Administrator

1 “Turn on security”

Yes

No

2 “Add a security administrator”

Yes

No

3 “Add an application administrator”

Yes

No

4 “Log on”

Yes

No

5 “Restart Sage 300 Construction and Real Estate”

Yes

No

6 “Turn off logging” (optional)

Yes

No

7 “Add roles”

Yes

No

8 “Add users”

Yes

No

9 “Add users to roles”

Yes

Yes

10 “Add tasks to roles”

Limited

Yes

11 “Grant users access to companies”

No

Yes

12 “Restrict access to files” (optional)

No

Yes

13 “Set up record security” (optional)

No

Yes

Turn on security
To prevent unauthorized users from accessing your software, we recommend that you turn on application
security. When you turn on application security, all users must enter a user name and password to access the
software. Application administrators can restrict access to software features and data that each user has
permission to access.
Note: You must be a security administrator to turn on security.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Security Settings.
3 Select the Turn on application security check box.
4 Click [OK].
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Add a security administrator
When you turn on security, you must add a security administrator. Security administrators set up and maintain
accounts for users. For back-up purposes, we recommend adding at least two security administrators.
To add or change a security administrator later, go to Security Administration > User Setup. You must be a
security administrator to add another security administrator.

Add an application administrator
When you turn on security, you must add an application administrator. Application administrators define roles
and assign users to the roles. For back-up purposes, we recommend adding at least two application
administrators.
To add or change an application administrator later, go to Security Administration > User Setup.

Log on
1 From the Log On window, type your User name.
2 Type your Password.
3 Click [Log On].

Restart Sage 300 Construction and Real Estate
For the security settings to take effect, all users must restart Sage 300 Construction and Real Estate.
1 When the Restart message appears, click [OK].
2 Close Sage 300 Construction and Real Estate (File > Exit), and then reopen it.
3 Request all users to restart Sage 300 Construction and Real Estate.

Turn off logging
This task is optional.
Security administrators can only turn off Application, Security, or Setup logging.
The Audit Setup, Field Report, and System logs are required. You cannot turn them off.
The Posting Recap and Task Summary logs are for future use. No logs are created at this time.
Note: You must be a security administrator to turn on logging.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Log Settings.
3 In the On column, clear the types of logs that you want to turn off.
4 Click [OK].
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Add roles
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Role Setup.
3 On the Roles pane, click [Add].
4 On the Role Details pane, type the Name of the role (for example, AP Clerk.)
5 (Optional) Type the Description for this role.
6 (Optional) Select the tasks for this role. For more information, see “Add tasks to roles,” on page 55.
7 (Optional) Select the users for this role. For more information, see “Add users to roles” on page 54.
8 Click [Save Changes].

Add users
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click User Setup.
3 On the Users pane, click [Add].
4 On the User Details pane, type the User name.
5 (Optional) Type the Full name and Windows user associated with the user name.
6 (Optional) On the Settings tab, select the User Account Settings and Password Settings.
7 Click the Roles tab, and then select or add roles for the user.
8 (Optional) Click the Companies tab, and then select the companies for the user. For more information, see
“Grant users access to companies” on page 55.
Note: You must be an application administrator to grant a user access to companies. If you cannot
perform this step, the application administrator must do it before the user can log on to Sage 300
Construction and Real Estate.
9 Click [Save Changes].

Add users to roles
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click User Setup.
3 On the Users pane, select the User Name.
4 Click the Roles tab, and then select roles for the user.
5 Click [Save Changes].
6 For the change to take effect, the users associated with this role must restart Sage 300 Construction and
Real Estate.
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Add tasks to roles
Application administrators can add all tasks to roles.
Security administrators can only add the following tasks to a role:
p

Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

p

Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup Activity)

p

View System Activity (Tasks > Common Tasks > Security > View System Activity)

p

Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit Setup Fields)

You cannot change the tasks for the application administrator and security administrator roles.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Role Setup.
3 On the Roles pane, select the role that you want to edit.
4 On the Roles Details pane, click the Tasks tab.
5 In the tasks tree, navigate to the tasks or sub-tasks that you want to add and select the tasks.
6 Click [Save Changes].
7 For the change to take effect, the users associated with this role must restart Sage 300 Construction and
Real Estate.

Grant users access to companies
You must be an application administrator to grant a user access to companies.
Security administrators and application administrators have access to all companies.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Company.
3 On the Companies pane, select the Company Name to which you want to add users.
4 On the Company Security Details pane, click [Add].
5 In the Company Setup - Add Users window, select the users.
6 Click [OK].
7 Click [Save Changes].
8 For the change to take effect, the user associated with this company must restart Sage 300 Construction
and Real Estate.
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Restrict access to files
This step is optional.
Note: You must be an application administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Files.
3 Select the Company for which you want to restrict access to files.
4 Select the Role that will have access to the corresponding File Name.
5 Click [OK].
6 After securing a file, make sure that users can still perform their required tasks.
7 For the file restriction to take effect, all users not assigned to the role must restart Sage 300 Construction
and Real Estate.

Set up record security
This step is optional.
Note: You must be an application administrator to perform these tasks.

A. Setting up record security
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, select Records. The Record Security window opens.
3 On the Activation tab, select Activate record security.
4 Select or clear the Give all users access to records with blank security IDs check box. Select the box
if you want records with blank security IDs to be accessible to all users. Clear the box if you want only
application administrators to access these records.
5 In the Securable record types box, select the records that you want to secure.

B. Assigning security IDs to records
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, select Records. The Record Security window opens.
3 Select the tab for the record to which you want to assign security IDs.
4 In the Security ID column, type the ID of a role. You can type only a single ID.
5 Click [OK].
Note: Record tabs in the Record Security window are accessible only if you have turned on record
security for that record on the Activation tab.
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Modifying security
This section contains the following topics:
n

“Change password settings” (the next section)

n

“Delete a user” on page 59

n

“Delete a role” on page 59

n

“Copy a user” on page 60

n

“Copy a role” on page 60

n

“Turn off security” on page 60

n

“Remove file restrictions” on page 61

n

“Turn off record security” on page 61

n

“Turn on tasks” on page 61

n

“Turn off tasks” on page 62

n

“Add a role to a task” on page 62

n

“Remove a role from a task” on page 62

n

“Restrict access to files” on page 63

n

“Restrict access to additional files” on page 63

n

“Modify record security permissions” on page 64

n

“Change design security on reports” on page 64

n

“Change design security on an inquiry” on page 65

n

“Review record security settings” on page 65

Change password settings
Note: You must be a security administrator to change the password settings.
When you turn on security, you must set up password strengths and requirements for all users. To change
these settings later, go to Security Administration > Security Settings.
To change the password settings for a user name, go to Security Administration > User Setup > Settings.
For the password settings to take effect, all users must restart Sage 300 Construction and Real Estate.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 57

Chapter 6: Security

Set strong passwords
To prevent unauthorized users from accessing your software, we recommend that you require strong
passwords. Strong passwords must meet the following conditions for complexity:
n

Passwords must be at least eight characters long.

n

Passwords must contain at least three of the following four character groups:

English uppercase characters (A through Z)
English lowercase characters (a through z)
Numbers (0 through 9)
Special characters (~ ! @ # $ % ^ & * ( ) - + = { } [ ] | \ : ; < , > . ? /)
n

Passwords expire every 90 days.

n

You are warned 10 days before your password expires.

n

You cannot reuse your three previous passwords.

n

You must wait 10 days before changing your password.

When you turn on security, the password settings default to these strong password conditions.

Change password strengths and requirements for all users
Note: You must be a security administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Security Settings.
3 If security is turned off, select the Turn on application security check box.
4 In the Password Settings area, move the slider to select the password strength.
5 If you choose Custom (top setting on the slider), set the requirements:
a Click [Custom Password Settings].
b In the Password Settings window, clear the check boxes that you do not want or change the
requirements for the settings.
c Click [OK] to save the custom password settings.
6 Click [OK] to save the security setting changes.
7 If you are strengthening the password requirements, the following message appears, “Existing passwords
may not meet the new requirements. Do you want users to create new passwords the next time they log
on?” Click [Yes].
8 For the password settings to take effect, all users must restart Sage 300 Construction and Real Estate.
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Change password settings for a user name
Note: You must be a security administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click User Setup.
3 On the Users pane, select the User Name for which you want to change the password settings.
4 On the User Details pane, click the Settings tab.
5 Select or clear the Password Settings options.
6 If you want to add or change the password for the user:
a Click [Set Password].
b From the Set Password window, type the same password in the Password and Confirm password
fields.
c Click [OK].
Note: When you add or change the password, the User must change password at next log on
option is automatically selected.
7 Click [Save Changes].
8 For the password settings to take effect, the user must restart Sage 300 Construction and Real Estate.

Delete a user
Note: You must be a security administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click User Setup.
3 On the Users pane, select the User Name that you want to delete.
4 Click [Delete].
5 When you receive a confirmation message, click [Yes].

Delete a role
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Role Setup.
3 On the Roles pane, select the role that you want to delete.
4 Click [Delete].
5 When you receive the confirmation message, click [Yes].
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Copy a user
Use the copy feature when you want a new user to have the same permissions as an existing user.
Note: You must be a security administrator and an application administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click User Setup.
3 On the Users pane, select the User Name that you want to copy.
4 Click [Copy].
5 On the User Details pane, type the User name.
6 (Optional) Type the Full name and Windows user associated with the user name.
7 Click [Save Changes].

Copy a role
Use the copy feature when you want a new role to have the same tasks and users as an existing role.
Note: You must be an application administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Role Setup.
3 On the Roles pane, select the role that you want to copy.
4 Click [Copy].
5 On the Role Details pane, type the Name of the role (for example, AP Clerk.)
6 (Optional) Type the Description for this role.
7 Click [Save Changes].

Turn off security
Notes:
l

l

You must be a security administrator to turn off application security.
To prevent unauthorized users from accessing your software, we recommend that you leave
application security turned on.

1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Security Settings.
3 Clear the Turn on application security check box.
4 Click [OK].
5 For the security settings to take effect, all users must restart Sage 300 Construction and Real Estate.
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Remove file restrictions
Note: You must be an application administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Files.
3 Select the Company for which you want to remove a file restriction.
4 In the Role column for the corresponding File Name, select (None.)
5 Click [OK].
6 For the file setting to take effect, all users must restart Sage 300 Construction and Real Estate.

Turn off record security
Note: You must be an application administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, select Records. The Record Security window opens.
3 Select the Activation tab.
4 If you want to turn off all record security, clear the Activate record security check box.
5 If you want to turn off record security for a particular record, clear the check box for that record.
6 Click [OK].
Notes:
l

l

When you turn off record security, the Security ID field disappears from related record setup
windows. However, Sage 300 Construction and Real Estate security saves your security ID
assignments. If you reactivate record security, these settings take effect again.
In addition to record security settings in Security Administration, each Sage 300 Construction and
Real Estate report and inquiry has record security settings.

Turn on tasks
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Tasks.
3 On the Tasks pane, navigate to the tasks or sub-tasks that you want to turn on.
4 On the Task Security Details pane, clear Turn off task.
5 Click [Save Changes].
6 For the task settings to take effect, all users must restart Sage 300 Construction and Real Estate.
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Turn off tasks
Note: You cannot turn off tasks for the security administrator and application administrator roles.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Tasks.
3 On the Tasks pane, navigate to the tasks or sub-tasks that you want to turn off.
4 On the Task Security Details pane, select Turn off task.
5 If the Restart Sage 300 Construction and Real Estate message displays, click [OK].
6 Click [Save Changes].

Add a role to a task
Application administrators can add roles to all tasks.
Security administrators can only add roles to the following tasks:
p

Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

p

Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup Activity)

p

View System Activity (Tasks > Common Tasks > Security > View System Activity)

p

Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit Setup Fields)

To add a role to a task:
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Tasks.
3 On the Tasks pane, navigate to the task or sub-task to which you want to add a role.
4 On the Task Security Details pane, select the roles that you want to add.
5 Click [Save Changes].

Remove a role from a task
Application administrators can remove roles from all tasks.
Security administrators can only remove roles from the following tasks:
p

Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

p

Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup Activity)

p

View System Activity (Tasks > Common Tasks > Security > View System Activity)

p

Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit Setup Fields)

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 62

Chapter 6: Security

To remove a role from a task:
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Tasks.
3 On the Tasks pane, navigate to the task or sub-task that you want to remove from a role.
4 On the Task Security Details pane, clear the roles.
5 Click [Save Changes].

Restrict access to files
Note: You must be an application administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Files.
3 Select the Company for which you want to restrict access to files.
4 Select the Role that will have access to the corresponding FileName.
5 Click [OK].
6 After securing a file, make sure that users can still perform their required tasks.
7 For the file restriction to take effect, all users not assigned to the role must restart Sage 300 Construction
and Real Estate.

Restrict access to additional files
Application administrators will only see additional files if named files are selected for a securable file type
(Sage 300 Construction and Real Estate > Common Tasks > File > Company Settings > File
Locations > Ask Name.)
Note: You must be an application administrator to perform this task.
To restrict a file that is not in the File Security Setup grid:
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, click Files.
3 Select the Company for which you want to restrict access to files.
4 Click [Find Files].
5 From the File Security Setup - Find File window, select the File Type.
6 Click [OK].
7 Browse to the file location and select the File name that you want to restrict.
8 Click [Open]. The file is added to the grid.
9 Select the Role that will have access to the corresponding File Name.
10 Click [OK].
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11 After securing a file, make sure that users can still perform their required tasks.
12 For the file restriction to take effect, all users not assigned to the role must restart Sage 300 Construction
and Real Estate.

Modify record security permissions
Change the security ID in a Record Security window
Note: You must be an application administrator to perform this task.
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, select Records. The Record Security window opens.
3 Select the tab for the record you want to change.
4 In the Security ID column, change the security ID.
5 Click [OK].
Note: Record tabs in the Record Security window are available only if you have turned on record
security for that record.

Change the security ID in a Record Setup window
Note: You must be an application administrator or have security access to the Change Security ID
task.
1 Open the record setup window of a securable record (Cash Management bank account, General Ledger
prefix, Job Cost and Project Management job, and Property Management property.)
2 Click the Security ID field and change the ID.

Change design security on reports
Note: You must be an application administrator to modify report design security.
1 Start Report Designer.
2 Open the report design (File > Open Design.)
3 From the Tools menu, select Security > Design.
4 In the Design Record Security box, select or clear the check boxes.
5 Click [OK].
Note: The Design Record Security box lists all available records regardless of whether the report uses
all the records. If record security is off, the check box for that record will be unavailable.
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Change design security on an inquiry
Note: You must be an application administrator to modify the inquiry design security.
1 Start Inquiry Designer.
2 From the Inquiry menu, select Inquiry Manager.
3 In the Applications window, select an application and click [OK].
4 In the Inquiry Manager window, select the inquiry; then click [Change].
5 In the Change Inquiry window, click [Record Security].
6 In the Record Security window, select or clear the check boxes.
7 Click [OK] in successive windows; then click [Close].
Note: The Record Security window lists all available securable records regardless of whether the
inquiry uses all the records. If record security is not selected, the check box for that record will be
unavailable.

Review record security settings
Note: You must be an application administrator to perform this task
1 From the Sage Desktop, select Options > Security Administration.
2 On the Security Administration tab, select Records. The Record Security window opens.
3 Review the selections on the Activation tab. They control whether record security is on and how the
software interprets blank security IDs.
4 Select one of the record tabs.
5 Review the users and roles in the Security ID column.
6 Repeat steps 4 and 5 for each record.
Note: Every report and inquiry has settings that control whether record security can affect the report or
inquiry.
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Troubleshooting security
This section contains information about the following issues:
l

“I cannot see a security ID in a Record Setup window”

l

“I cannot change a security ID in a Record Setup window”

l

“I know a job was set up, but I cannot see it in the software”

l

“I forgot my password” on page 67

l

“My report or inquiry is missing information” on page 67

l

“Menu items and fields are unavailable” on page 67

l

“I cannot delete a user name” on page 67

l

“I cannot make an account unavailable” on page 68

l

“I cannot end account availability” on page 68

l

“I cannot remove a user name” on page 68

l

“I cannot turn on security” on page 68

l

“I cannot save changes” on page 69

I cannot see a security ID in a Record Setup window
The Security ID field appears in a record setup window only if record security is on for that record. For more
information, see “Set up record security” on page 56.

I cannot change a security ID in a Record Setup window
During the setup of a new record, anyone can type a security ID. Once the record has been saved, only
application administrators or users with permission to access the Change Security ID task can change the
security ID.

I know a job was set up, but I cannot see it in the software
In most Sage 300 Construction and Real Estate applications, record security affects only reports and
inquiries. In certain Contracts, Job Cost, and Project Management tasks, however, record security also
affects whether you can type jobs or select jobs from lists. For more information, see “Effect of record security
on tasks” on page 51.
Jobs may not appear for several reasons:
n

The job may have a status of closed; some lists do not display closed jobs.

n

The job may have been moved to a different file, such as a history file.

n

Record security may be active on the job and you do not have permission to access that job.
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I forgot my password
If you are an application administrator or user, request a new password from one of your company's security
administrators.
If you are the only security administrator and you forgot your password, you must call Customer Support to
restore access to your software. See “Technical assistance” on page 2.
Note: For back-up purposes, we recommend having at least two security administrators.

My report or inquiry is missing information
A report or inquiry can be missing information for several reasons. One explanation could be that you lack
record security permissions. To investigate this possibility, see the following topics.
Reports
p

“Effect of an upgrade on reports” on page 49

p

“Indicators that record security affects a report” on page 48

p

“Report record security settings” on page 48

p

“Review record security settings” on page 65

Inquiries
p

“Effect of record security on inquiries” on page 49

p

“Indicators that record security affects an inquiry” on page 50

p

“Inquiry record security settings” on page 50

Menu items and fields are unavailable
Menu items and fields can be unavailable for two reasons.
First, the task associated with the menu item or field requires a previous task that has not been performed. For
example, the Edit > Paste menu is unavailable if you have not previously cut or copied anything.
Second, you lack task security permissions (for example, access to PM > Setup > Properties.)

I cannot delete a user name
Note: You must be a security administrator to delete a security administrator.
If security is on and only one user name is assigned to the Security Administrator role, you cannot delete the
user name assigned to that role.
To delete the user name, you must assign another user name to the Security Administrator role. For more
information, see “Add a security administrator” on page 53.
For back-up purposes, we recommend adding at least two security administrators.
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I cannot make an account unavailable
If security is on and only one available user name is assigned to the security administrator or application
administrator role, you cannot make the account unavailable.
To make the account unavailable, you must assign another available user to that administrator role.
Note: You must be a security administrator to assign a user to an administrator role.
For back-up purposes, we recommend adding at least two security administrators and two application
administrators. If necessary, you can assign two user accounts to both roles.

I cannot end account availability
If security is on and only one user name is assigned to the security administrator or application administrator
role as of this date, you cannot end account availability.
To end account availability, you must assign another available user name to that administrator role.
Note: You must be a security administrator to assign a user to an administrator role.
For back-up purposes, we recommend adding at least two security administrators and two application
administrators. If necessary, you can assign two user accounts to both roles.

I cannot remove a user name
Note: You must be a security administrator to delete a security administrator.
If security is on and only one user name is assigned to the Security Administrator role, you cannot remove the
user name assigned to that role.
To remove the user name, you must assign another user name to the Security Administrator role. For more
information, see “Add a security administrator” on page 53.
For back-up purposes, we recommend adding at least two security administrators.

I cannot turn on security
Note: You must be a security administrator to turn on application security.
If a user name is not assigned to the Security Administrator role, you cannot turn on application security.
To turn on security, you must assign a user name to the Security Administrator role. For more information, see
“Add a security administrator” on page 53.
For back-up purposes, we recommend adding at least two security administrators.
For the security settings to take effect, all users must restart Sage 300 Construction and Real Estate.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 68

Chapter 6: Security

I cannot save changes
Note: You must be a security administrator to remove users from the Security Administrator role.
If security is on, you cannot remove all users from the Security Administrator role.
To remove all the existing users from the Security Administrator role, first you must assign another user name
to that role. For more information, see “Add a security administrator” on page 53.
For back-up purposes, we recommend having at least two security administrators.

Security tips
This section contains the following tips:
n

“Be careful with print files”

n

“Create separate roles for task and record security” on page 69

n

“Consider limiting access to Crystal Decisions Crystal Reports” on page 70

n

“Specify how secured tasks appear” on page 70

Be careful with print files
If you print to a folder that is not secure, others may have access to your reports.
By default, Sage 300 Construction and Real Estate prints files to your data folder. If you run the software over
a network, all users print to this location. Although you can change the default file location in File > Data
Folder Settings > File Locations > Printouts, all network users will still print to whatever location you
designate.
To print to a different folder, you must redirect the print job at the time of printing. From a Print Selection
window, click [Printer Setup]. Then, click [Select File] and browse to the desired location.

Create separate roles for task and record security
Administrators may need to create certain roles for task security and other roles for record security. For
example, a company has the following users:
p

Project Manager 1

p

Project Manager 2

p

Accounts Payable (AP) Clerk 1

p

AP Clerk 2

Project Manager 1 and AP Clerk 1 always work together on jobs. Project Manager 2 and AP Clerk 2 always
work together on a different set of jobs. In terms of record security, these two teams of users should be
members of different roles because they need access to different jobs.
Project Managers 1 and 2 perform tasks such as approving change orders (COs.) AP Clerks 1 and 2 perform
tasks such as entering invoices. In terms of task security, the project managers should be in one role and the
AP clerks should be in a different role.
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The overall security assignment for these users should look like the following:
Role

Users

Task Permissions

Record Permissions

PROJMGR

Proj managers

Approve COs

APCLERK

AP clerks

Enter invoices

TEAM1

Proj Mgr 1 and AP Clerk 1

Team 1 jobs

TEAM2

Proj Mgr 2 and AP Clerk 2

Team 2 jobs

Consider limiting access to Crystal Decisions Crystal Reports
A user can use Crystal Decisions Crystal Reports to disable record security settings on Crystal reports. If you
own Crystal Decisions Crystal Reports, guard against unwanted modification of reports by limiting who can
use this software. You may want to allow only administrators of Sage 300 Construction and Real Estate
security to use Crystal Decisions Crystal Reports.

Specify how secured tasks appear
Most securable tasks have an associated menu item or field. Application administrators can specify how
these menu items and fields appear to a user who does not have access to them. You can specify whether the
menu items and fields are hidden or whether they appear gray (which indicates that they are unavailable.)
1 Select Tools > Options.
2 In the Options window, look in the Secured Menu Items box. Select Don't display or Display as
disabled.
3 Click [OK].
Notes:
l

l

l

You must be an application administrator to perform this task.
The menu is subject to task security. You may not be able to see this menu item if the application
administrator has selected Don't display in the Secured Menu Items box.
Application administrators need to specify this setting in only one application for the effect to be
seen in all applications.
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Glossary of security terms
Application Administrator
An application administrator has unrestricted access to all features in Sage 300 Construction and Real
Estate. They can set up task security and set up most aspects of record security in the Security
Administration tool. For a complete list of tasks that an application administrator can perform, see “Setting up
security ” on page 52.
Like other users, an application administrator has a user name and password. If security is on, application
administrators must type this user name and password after they start an application.
Only security administrators can create users.

Application Log
Logs the start and end of Accounting applications and tasks.

Application Security
Application administrators can prevent unauthorized users from accessing Sage 300 Construction and Real
Estate by turning on application security. When application administrators turn on application security, all
users must enter a user name and password to access the software. They can restrict access to software
features and data that each user has permission to access. Security Administration offers four types of
application security: task, file, record, and company.
Application security also lets application administrators hide applications from users and roles. When an
application administrator uses the Security Administration tool to deny a user or role access to all tasks in an
application and sets secured menu items to not display, users cannot see the application in the Sage
Desktop.

Audit Setup Log
Logs changes when the audit setup activity is selected in an Accounting application.

Company Security
Company security allows an application administrator to grant a user access to specific companies.
Security administrators and application administrators have access to all companies.

Estimating Security
Estimating products allow you to secure certain files. This file security is similar to Security Administration file
security but is different in that it uses only a password and not a combination of user name and password.
You can assign a full access password to all securable Estimating files. This password allows you to both
read a file and write to a file.
With Estimating databases, you can also assign a read-only password. This password allows you to take off
items from a database but not modify a database.

Field Report Log
Logs changes to finalized field reports in Project Management.
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File Security
File security allows application administrators to block all access to a file. This includes access through open
database connectivity and through all related tasks, reports, and inquiries. This differs from task security,
which allows application administrators to block tasks selectively and does not allow them to control ODBC
access.

Open Database Connectivity (ODBC)
Open Database Connectivity (ODBC) allows a Sage 300 Construction and Real Estate database and a thirdparty program such as Microsoft Access to communicate. Once you set up an ODBC connection (which
requires a special ODBC driver), you can send data between the two programs.

Posting Recap Log
Logs recaps created while posting entries in Accounting. (For future use. No logs are created at this time.)

Record Security
With record security, you can control access to the Cash Management bank account, General Ledger prefix,
Job Cost and Project Management job, and Property Management property records.
When record security is active, reports and inquiries display only the records to which the user has access.
Record security also affects Job Cost, Contracts, and Project Management tasks. In these applications, you
can type or select only jobs to which you have access.

Roles
A role represents a group of users who have the same security requirements. A role has its own user account
and its own task, record, file, and company permissions.

Security Administration
With Security Administration, application administrators can restrict access to tasks, files, records, and
companies. For example, they can use task security to restrict who can set up vendors in Accounts Payable.
With file security, they can restrict access to sensitive payroll files. With record security, they can produce
reports that display only the jobs to which the user has security access. Finally, with company security, they
can restrict access to which company information a user sees.

Security Administrator
Security administrators set up and maintain accounts for users. For a complete list of tasks that a security
administrator can perform, see “Setting up security ,” on page 52.

Security Log
Logs events in the Security Administration tool.

Setup Log
Logs changes to setup information in Accounting.
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Strong Passwords
Strong passwords must meet the following conditions for complexity:
n

Passwords must be at least eight characters long.

n

Passwords must contain at least three of the following four character groups:

English uppercase characters (A through Z)
English lowercase characters (a through z)
Numbers (0 through 9)
Special characters (~ ! @ # $ % ^ & * ( ) - + = { } [ ] | \ : ; < , > . ? /)
n

Passwords expire every 90 days.

n

You are warned 10 days before your password expires.

n

You cannot reuse your three previous passwords.

n

You must wait 10 days before changing your password.

System Log
Logs Accounting system events.

Task Security
With task security, an application administrator can restrict access to menu items and certain tasks found
within windows.

Task Summary Log
Logs summaries created during an Accounting task. (For future use. No logs are created at this time.)

User
A user has restricted access to the Sage 300 Construction and Real Estate. A user can have security
permissions that range from very restrictive to almost as complete as an application administrator.
All users have a user name and password. If Security Administration is on, you must type a user name and
password immediately after you start an application.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 73

Chapter 7: Sage 300 Construction and
Real Estate ODBC
This chapter presents an overview of Sage 300 Construction and Real Estate open database connectivity
(ODBC). After you install ODBC, you should refer to the ODBC Help for detailed information about how to use
the driver to access databases.

ODBC overview
ODBC is a standard interface that serves as a translator between different database file structures and
different software. The ODBC driver lets applications collect data from databases in other applications.
Applications that are can access data via ODBC are commonly referred to as front-end applications and can
include databases (for example, Microsoft® Access), word processors (for example, Microsoft Word), and
spreadsheets (for example, Microsoft Excel). Applications such as Sage 300 Construction and Real Estate
that make their data available through ODBC are referred to as back-end applications. Both the front-end and
back-end applications must support the ODBC protocol for them to communicate with one another.
The Sage 300 Construction and Real Estate ODBC driver lets you read most Accounting and Management
Products and Estimating Products records as well as create and delete some selected records. You cannot
delete individual fields, but you can replace many fields with new data. See the "About record topics" topic in
ODBC Help for a list of records and fields that you can edit. To access the Help file, click Start > All
Programs > Sage > Sage 300 Construction and Real Estate > Accounting > ODBC Help.
Note: You cannot use the Sage 300 Construction and Real Estate ODBC driver to access Purchasing,
Inventory, or Service Management data. To access Purchasing, Inventory, or Service Management data
through ODBC, use the Pervasive ODBC Engine Interface and Pervasive ODBC Client Interface drivers.
For more information, see the Pervasive Help at Start > All Programs > Pervasive.PSQL 10 > Control
Center and Documentation. Under Documentation Library, click User’s Guide > Using Pervasive
PSQL > Setting Up ODBC Database Access.

Important issues for ODBC users
This section contains important information. You should read it before you use the Sage 300 Construction and
Real Estate ODBC driver.

ODBC Support Policy
Sage 300 Construction and Real Estate ODBC interfaces with a variety of third-party products. Because
other products are involved, Sage cannot guarantee that our Customer Support can resolve all ODBC-related
problems. Any multiple-vendor software arrangement requires a significant level of technical expertise.
Technical conflicts between databases from different vendors may require you to seek assistance from a
vendor other than Sage.
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Important! Currently, we test only Microsoft Office (Access, Word, and Excel) for compatibility with the
Sage 300 Construction and Real Estate ODBC driver. We do not test for compatibility with any other
products or programming languages, including Microsoft Visual Basic for Applications, which can be run
from a macro within Microsoft Office. Although you may find success using another product, Customer
Support can address only issues and problems that relate to the use of Microsoft Office (Access, Word,
and Excel) to access data via the ODBC driver.

Data loss
ODBC processing leaves no audit trail of changes made, and its misuse can create untraceable data
discrepancies. If Customer Support is unable to reproduce a data-dependent problem using Sage 300
Construction and Real Estate software and data, it is assumed that the problem is specific to a data
discrepancy introduced with ODBC.

Points to consider before you use ODBC
For fields like notes and memos, Sage 300 Construction and Real Estate software simply stores the values.
Some fields have a data dependency (the value in one field can affect the value of another field). In other
fields, the software requires the value to have a certain format or be within a specified range. When you make
changes through a Sage 300 Construction and Real Estate application, the software handles dependencies
automatically. ODBC does not handle dependencies. It is up to you to be aware of these issues and make any
necessary edits. To be safe, you should always back up any database before you modify it through ODBC.
Consider the issues that follow before you write changes to a data file through ODBC:
n

Data Dependencies: the values in some fields change based on the value contained in another field.
An example of data dependency in Estimating is the item record’s labor and equipment price fields. These
two price fields require the item to have an empty crew field. When you enter a labor or equipment crew into
the item’s crew field, Estimating removes the corresponding cost category’s price, because the price is
now derived from the labor/equipment rate table for that crew. ODBC will allow you to write a crew to the
item record without removing the cost category’s price. This results in an invalid record.

n

Referential Integrity: some records which reside in one data file relate to records in another file.
An example of referential integrity in Estimating is the item record. The item record (pei) references its
phase record, which is stored in the standards file (pes.dat). This same item may be part of an assembly,
which exists in the assembly file (pwa.dat). With ODBC, you can write a change to the phase of a given
item record. This change would not automatically carry through to the assembly file. The assembly would
then reference a phase or item that no longer existed. It would even be possible to assign a phase to the
item for which there was no corresponding phase record in the standards file.
An example of referential integrity in Accounting is the relationship between a job record and one of its
subsidiary category records. Amounts that you enter through a miscellaneous worksheet into a category’s
miscellaneous category amount field directly affect the total miscellaneous category amount field in the job
record. If you modify one of those fields through ODBC and do not modify the other, the Job Cost Master
file becomes out of balance.

n

Formatting: Sage 300 Construction and Real Estate applications expect the value stored in some fields to
be formatted in a certain way.
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An example of expected formatting in Estimating Products is the phase record. The General Information
screen in your database displays the value entered in the Estimating phase suffix field. Phases you enter
through Estimating will automatically conform to this setting. Through ODBC, you can to enter a phase
which does not match the formatting specified in your General Information.
Proper use of ODBC requires a thorough understanding of these dependencies to make sure referential
integrity is preserved.

Special considerations for Sage Estimating users
The following is a brief sample of fields and record types with which Estimating users should be thoroughly
familiar before they use ODBC. This list is not complete and is no substitute for an in-depth understanding of
the application’s records and fields. Estimating software is continually enhanced to keep up with customer
requests and industry trends. As a result of these enhancements, fields and their attributes change. Refer to
ODBC Help for lists of Estimating records and fields.
n

n

n

n

n

n

n

If you create or add to an existing price link, you must also make applicable changes to the item prices.
Each record has one or more key fields, and some records have alternate keys. These fields distinguish
one record from another and must be unique. For instance, on the subcontractor record, the key field is the
sub number. While two or more subcontractors may have the same address or sub type, each must
possess a unique sub number and spreadsheet name (alternate key). You should be familiar with the key
fields for any records you intend to modify through ODBC. In ODBC Help, key fields are marked with (k).
Avoid changing hierarchical flags on existing records. For example, the Group phase field on the phase
record and the Group workpackage field on the workpackage record.
Do not change values that result from a calculation. For instance, do not change the estimate total amount
or sequence numbers in an estimate.
Delphi users should be aware that the Delphi Database Engine supports the read capabilities of Sage 300
Construction and Real Estate ODBC, but does not fully support the write capabilities.
Refer to the "About the possible characters in Estimating database records" topic in ODBC Help for
detailed information on allowable entries to specific fields.
ODBC provides the ability to use non-Estimating tools for data manipulation and reporting. When you use
ODBC to write to Estimating files, you become responsible for many tasks which Estimating handles
automatically.

ODBC adds power and flexibility, but demands care and knowledge. If you elect to write to your Estimating
files, use caution and a realistic assessment of your own knowledge of the Estimating system as a guide.
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Set up a data source
Before you can use the ODBC driver, you must first set up a link to a Sage 300 Construction and Real Estate
data source. The data source contains the data a user wants to access and its associated Database
Management System. The data is pulled from a back-end application, for example, General Ledger. The data
is then sent to a front-end application, such as Microsoft Excel. Each data source you set up has a data
source name (DSN), which you provide.
When you set up a data source, you specify a particular ODBC driver to be attached to the data source. These
drivers are programs that access the information in the database and translate it into a format that the frontend application (Microsoft Excel, for example) can read.
You must set up a DSN for each Sage 300 Construction and Real Estate database. For example, your
company might maintain one database for its construction business and another for its remodeling business.
Because these databases are stored in separate folders, you must set up a DSN for each database folder.
For detailed instructions on how to set up a DSN, see “DSN setup options in ODBC,” on page 78 .

Use the ODBC driver
After you install ODBC and set up a data source, you can use the driver to access Sage 300 Construction and
Real Estate information from the database. Procedures to collect this data depend on the front-end application
being used. ODBC Help provides detailed instructions for accessing and inserting Sage 300 Construction and
Real Estate data into Microsoft Query, Excel, Access, and Word. Refer to the How To section on the Help
Contents tab for links to the applicable topics.
Other software manufacturers’ ODBC-compliant products can access data through the Sage 300
Construction and Real Estate ODBC driver. Refer to those manufacturers’ ODBC documentation for
instructions on using ODBC.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 77

Chapter 8: Crystal Reports
Introduction
If you already have technical experience using Crystal Reports®, this chapter will help you customize reports
and invoices that you use in Sage 300 Construction and Real Estate applications. Please review the entire
chapter before making changes to your reports.
If you do not have experience using Crystal Reports, contact your Sage certified consultant for help with
creating custom reports that fit your business needs. You can also attend training sessions in Crystal
Reports; visit http://www.sagesoftwareuniversity.com/ for more information.

Updated Crystal Reports runtime components
Sage 300 Construction and Real Estate version 16.1 updated the ODBC interface used by Crystal Reports for
data access. On average, most reports now run faster; some reports run significantly faster.

Crystal Reports Designer
If you use the Crystal Reports Designer, you will need to verify that you have installed Crystal Reports For
Sage 2013 SP2. This software only runs on Windows 7 SP1, Windows Server 2008, or higher operating
systems (not Windows Vista). If you create new custom CR designs, use the Upgrade Crystal Reports Tool
before using the designs in Sage 300 Construction and Real Estate.

DSN setup options in ODBC
The Timberline Data Source is automatically created the first time you open Sage 300 Construction and Real
Estate. However, you must configure the Timberline Data Source before you customize reports and invoices.
Note: Beginning with Sage 300 Construction and Real Estate version 16.1, you must have a properly
configured DSN to run "Custom Description" reports—even though these reports may have run without a
properly configured DSN in 15.1 and earlier versions of Sage 300 Construction and Real Estate.
To set up portability options for a report in the ODBC Setup window:
1 From the Start menu, select All Programs > ODBC > 32bit ODBC Administrator to open the Data
Source Administrator window.
2 From the User DSN, System DSN, or File DSN tab, select Timberline Data Source and click
[Configure].
3 In the Timberline Data ODBC Setup window, click [Options] to open the Data Source Options.
Note: Crystal report designs in Sage 300 Construction and Real Estate that use the Timberline Data
Source use the following options: Standard descriptions for Table and Field Naming, Use maximum
table segment size selected, and Shorten field and table names cleared.
The Table and Field Naming selection determines how table and field names appear when you access data
using this data source name (DSN). Three options are available:
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Naming
Option

Description

Standard
descriptions

(Recommended) Use this mode when you design a report for use in multiple databases.
The default descriptions appear on the report design in Crystal Reports Designer.
However, the operators’ custom descriptions appear when the report is generated in
Sage 300 Construction and Real Estate. If you select this option, you can use this report
with all databases.

Custom
descriptions

Use this mode when you design reports for a specific database. The custom
descriptions for that database appear on the report design in Crystal Reports Designer.
The custom descriptions also appear when the report is generated in Sage 300
Construction and Real Estate. If you select this option, you can only use it with
databases that have the same custom descriptions as the database used when creating
the report. If the custom descriptions in that database change, the report may break.

Dictionary
names

Use this mode only when modifying Billing invoice reports and reports that were
designed in Crystal Reports with dictionary names for Sage 300 Construction and Real
Estate earlier than version 8.0.0. Dictionary names are internal table and field names
that are less descriptive than the standard descriptions but provide the same
functionality. If you select this option, you can use this report with all databases.

The following table uses the Accounts Receivable customer field as an example to show how different Field
Naming options affect how the field appears.
Naming Option

Display Table and Field Name

Comments

Standard
descriptions

ARM_MASTER_CUSTOMER.Customer

No change regardless of custom
descriptions for AR Customer. Standard
descriptions are always the default
descriptions.

Custom
descriptions

MASTER_ARM_CUSTOMER.Customer

If the custom description for AR
Customer is “client,” the field appears as
MASTER_ARM_CLIENT.client

Dictionary
names

MASTER_ARM_RECORD_1.CUST

No change regardless of custom
descriptions. Internal names always
appear in dictionary names.
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To use reports in Sage 300 Construction and Real Estate that were designed using the Timberline Data
Source, you must select the Use maximum table segments size check box when you design the reports. If
you clear the Use maximum table segment size check box and you access a table with more than 255
columns, the table is split into two tables. If you select this option, tables remain intact regardless of size.
For example, the Job Cost JC job record contains more than 255 columns. If you clear the Use maximum
table segment size check box, the table splits into two tables (JCM_Master_Job_1 and JCM_Master_Job_
2). If you select the Use maximum table segment size check box, the table does not split (JCM_
Master_Job).
Important! Some programs, including Microsoft® Access, do not support the use of maximum table
segment size. Clear the check box when you use DSNs associated with those programs. You should set
up a separate DSN for these programs.
Before ODBC 8.00.3 (you can find the version number on the Drivers tab of the ODBC Data Source
Administrator), the Timberline ODBC driver shortened table names longer than 36 characters and shortened
field names longer than 25 characters. With the Accounting and Management Products 8.0.0 and Estimating
Products 6.5.0 release, the ODBC driver stopped shortening table and field names. This change could cause
previously designed reports and queries created with ODBC to stop working. A new option has been added to
the ODBC driver setup to let you select the appropriate mode for the data source.
Select the Shorten field and table names check box to create a DSN compatible with reports that were
designed with versions of the software earlier than Accounting and Management Products 8.0.0 and
Estimating Products 6.5.0. Clear the check box to create a DSN compatible with reports that were designed
later (when the table and field names were not shortened).

Crystal Reports integration
Requirements
You should use Crystal Reports For Sage 2013 SP2 (version 13) to modify or create report designs for
Accounting and Management Products. For instructions on upgrading custom reports created with version 9
or later, see “Chapter 8: Crystal Reports,” on page 78. For instructions on upgrading custom reports that were
created using a version prior to 9, see “Upgrade custom reports created with a version prior to 9” on page 116.
Note:
For the data source name (DSN):
l

l

Use Timberline Data Source for all Crystal reports that you will use with Accounting and
Management report menus.
Use TS Billing Field Names for Crystal reports that you will use for Billing invoice designs; see
“Billing considerations” on page 105 for more information .

Setting up printers
By default, the “No Printer” option (Crystal Reports: File > Page Setup) is selected for all Crystal report
designs that ship with Sage 300 Construction and Real Estate. We recommend selecting this option for all
Crystal reports you use to avoid potential printer error messages when using Sage 300 Construction and Real
Estate applications with the Windows 7 operating system.
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When printing a report in Crystal Reports, the data may print as cryptic symbols even though the report
displays correctly in preview mode. This is because Crystal Reports requires Unicode functions to print. If
your printer driver does not support Unicode, you must update your printer driver. To determine whether your
printer driver supports Unicode, see the printer driver manufacturer's support web site.
Note: In Crystal Reports, you must select Crystal Syntax as the Default Formula Language
(File>Options>Formula Editor tab > Default Formula Language).

Integration formulas
This section provides a list of acceptable formulas to use for generating reports.
Designs created in Crystal Reports use formulas to convey required report information to Sage 300
Construction and Real Estate. These formulas query the Sage 300 Construction and Real Estate application
for, or provide it with, required information that is not already in a database table field. For example, you may
need to set the margins of the report when it prints. You use a formula to provide the margin information to the
application.
Caution! Name the formulas exactly as they are named in this document. Formulas may be case
sensitive and may not work unless the formula name matches the corresponding formula written in Sage
300 Construction and Real Estate code.
Important! Do not type @ in front of formula fields. In Crystal Reports, “@” automatically appears in
front of formula fields; for example, when you create a formula and type tsDesignMode, the formula
appears as @tsDesignMode.
Note: Integration formulas need only to be included in the report design to function. You do not need to
include these formulas on the report itself.

Formula: tsAlternateSMFolder
Description

This formula allows you to select whether you want a Service Management report to
include current or historical information.

Syntax

None. Leave the formula value blank.

Example

@tsAlternateSMFolder=
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Formula: tsApp
Description

Use this formula to specify the application abbreviation for the report. This formula is
required on all Service Management primary reports and subreports. The formula is
not required on any report that uses the ODBC driver to access Sage 300
Construction and Real Estate data.

Syntax

“<Two-letter application abbreviation>”

Example

@tsApp = “SM”

Formula: tsAskFile
Description

Use the tsAskFile formula to limit the file types the operator can choose when the
report runs. This formula applies to the main report. It also applies to all subreports
unless you use the tsSubAskFile formula on the subreports. This formula does not
have file merging capabilities. If you use the following formula example on a report
design, the report will prompt the operator to choose between the New.glt file and the
Current.glt file when the report runs. Without the formula on the report, the operator
could choose whatever file codes are available.
For more information click “Formula: tsSubAskFile”

Syntax

“[<file type>(<file code name>[,<file code name>]*)]”
<file type> = the abbreviation of the data file type; for example: BLI, GLT, APT, etc.
<file code name> = the file code name of the data file; for example: new, current,
history, active, standard, etc.

Example

@tsAskFile = “GLT(new,current)” or “GLT(new, current)JCT(current)”

Note: You can also use one file code name in the tsAskFile function to force the report to use a specific
file; for example, use @tsAskFile = “JCT(new)”.

Formula: tsDataFolder
Description

Use this formula to specify the data folder to use for previewing the report in Crystal
Reports Designer.
This formula is ignored when the report is generated in Sage 300 Construction and
Real Estate; the report uses the current data folder path instead.

Example

@tsDataFolder = “C:\Timberline Office\YourCompanyDataFolder”
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Caution! If you place this formula on a primary report and you want to use it on a subreport, you must
pass the formula to the subreport as a shared variable. Subreports do not automatically read the formula
from the primary report.
You can use the tsDataFolder formula with any of the following functions:
tsarContractCustomerDetail

tsarContractOnlyDetail

tsarCustomerDetailWithRetainage

tsarJobCustomerDetail

tsarJobOnlyDetail

tsControlData

tsCustomDescription

tsFieldSection

tsFieldSectionDesc

tsglFiscalEntityInfo

tsHeaderData

tsItemDesc

tsLetterheadStyle
For more information on these functions, see “User-defined functions” on page 85.
Set the tsDataFolder formula to the same data path appearing in the Database box of the ODBC Setup
window for the DSN if the report uses any of these user-defined functions:
n

tsControlData

n

tsHeaderData

n

tsCustomDescription

Formula: tsDesignMode
Description

This formula specifies the DSN mode used to create the report design. The DSN
mode of the report design must match the mode selected for the Table and Field
Naming option when you access or process the report.
Do not use this formula on report designs that use custom descriptions as the naming
option. When you run the report from Sage 300 Construction and Real Estate, the
tsCrystal interface looks to the report design for the tsDesignMode formula. If the
formula exists on the design, the system takes the value of the formula and sets the
Table and Field Naming option to match it. If the formula is not on the report, the Table
and Field Naming option automatically sets to custom descriptions.

Syntax

“<mode>”; mode can be “Dictionary” (dictionary names) or “SDesc” (standard
description)

Example

@tsDesignMode = “SDesc”
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Note: Custom Billing invoice formats and subreports must include the tsDesignMode formula with a
value of “Dictionary”. See “Customizing Crystal Reports” on page 103 for more information.

Formula: tsDesktopId
Description

If you use security and you link a Desktop home page to an estimate, Sage 300
Construction and Real Estate will ask for your user name and password when you
open the estimate. Use the tsDesktopId formula together with the TSEstimatingDKM
function to suppress the request for user name and password when you open an
estimate from a home page. "Function: tsEstimatingDKM" on page 93 for more
information on applying this function.
Add the tsDesktopId function to the main report. Add the TSEstimatingDKM function
to hyperlinks that link to estimates.

Example

@tsDesktopId = “”

Formula: tsLetterhead
Description

Use this formula in conjunction with the tsLetterheadStyle function.
This formula dynamically places the letterhead image when the report runs. This
formula is not required. This formula dynamically places the letterhead image only
when the formula is set to “Y” and you have selected the Use this letterhead image
below for my forms option in the Options window (Tools > Options > Letterhead tab >
Use the letterhead image below for my forms). Sage 300 Construction and Real
Estate will not dynamically place the letterhead image if any of the following
conditions are true:
You set the formula to “N.”
You select one of the other letterhead options in the Options window
You do not include the formula on the report.
For more information on the tsLetterheadStyle function, see “Function:
tsLetterheadStyle” on page 98.

Formula: tsMargins
Description

Use the tsMargins formula to display the [Page Setup] button on the Print Selection
window when you run the report from the Report menu in Sage 300 Construction and
Real Estate. The tsMargins formula allows you to the set margins for the report.

Example

@tsMargins =
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Formula: tsReportType
Description

Use this formula to identify the report type with the SQL Server database.

Syntax

SQL

Example

@tsReportType = “SQL”

Formula: tsSubAskFile
Description

Use the tsSubAskFile formula on subreports only. Use this formula to limit the file
types the operator can choose for the subreport when it runs.
To limit the file types the operator can choose for the main report, use the tsAskFile
formula. See “Formula: tsAskFile” on page 82 for more information.
The tsSubAskFile formula applies to only the subreport on which you use it, not to
other subreports. This formula does not have file merging capabilities. If you use the
following formula example on a report design, the report will prompt the operator to
choose between the New.jct file and the Current.jct file when the report runs. Without
the formula on the report, the operator could choose from the new, current, or history
file.

Syntax

“[<file type>(<file code name>[,<file code name>]*)];Prompt Text”
<file type> = the abbreviation of the data file type; for example: BLI, GLT, APT, etc.
<file code name> = the file code name of the data file; for example: new, current,
history, active, standard, etc.
Prompt Text = Text to inform the person that runs the report. You can use the prompt
text to indicate which subreport requires this selection.

Example

@tsSubAskFile = “JCT(new,current);Select a file for the Job Cost Transaction
subreport”

Note: You can also use one file code name in the tsSubAskFile function to force the report to use a
specific file: for example, use @tsSubAskFile = “JCT(new)”.

User-defined functions
You can use the Sage 300 Construction and Real Estate user-defined functions in conjunction with Crystal
Reports formulas on all reports. These user-defined functions instruct the application how to transform the
data retrieved by a formula. To select a user-defined function, in the Formula Editor, click Functions >
Additional Functions.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 85

Chapter 8: Crystal Reports

Function: pjLastJobUsed
Description

If you use this function on a field in the report design and if you selected the Use last
job option in PJ Settings (Project Management: File > Company/Data Folder Settings
> PJ Settings), the field retrieves the job number from of the last job used.

Syntax

pjLastJobUsed

Example

pjLastJobUsed()

Function: rmCurrentPropertyID
Description

Use to retrieve the current Residential Management (RM) property. The current
property is the property currently open or the last property opened in the RM
application.

Example

rmCurrentPropertyID()

Function: rmSetupInfo
Description

Use to retrieve setting information based on the Residential Management property
you specify. The design retrieves the setting for the property if it is specific to the
property; otherwise, it retrieves the system setting.

Syntax

rmSetupInfo(property, setting)
Property: The Property ID
Setting: The system setting you want to retrieve

Example

rmSetupInfo(rmCurrentPropertyID()”DefaultDepositCode”)

Function: tsarContractCustomerDetail
Description

Use this function to determine whether Accounts Receivable (AR) details should print
for the specified contract and customer.
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Function: tsarContractCustomerDetail
Syntax

tsarContractCustomerDetail(Data Folder, AR Activity File, AR Transaction File,
Contract, Customer, Aging As Of Date, Aging Basis, Include Retainage, Unpaid
Only, Age Finance Charge)
Data Folder: The report design must use the tsDataFolder formula, which stores the
folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art) file.
Contract: The Contract ID.
Customer: The Customer ID.
Aging as of Date: The cutoff date based on the Aging Basis date.
Include Retainage: True or False value. A True value takes retainage transactions
into account. A False value bypasses retainage transactions.
Unpaid Only: True or False: A True value considers transactions at the invoice
(status) level. A False value considers transactions at the activity level.
Age Finance Charge: True or False value. A True value includes finance charges. A
False value bypasses finance charges.

Example

(From report AR Statement of Account(CR).rpt)
tsarContractCustomerDetail({tsDataFolder},{@tsFileName(ARA)},{@tsFileName
(ART)},{ART_CURRENT_TRANSACTION.Contract},{ART_CURRENT_
TRANSACTION.Customer},{?Aging Date},{?Aging Basis},{?Include Retainage?},
{?Unpaid only?},{?Include Finance Charges?})
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Function: tsarContractOnlyDetail
Description

Use this function to determine whether Accounts Receivable (AR) details should print
for the specified contract.

Syntax

tsarContractOnlyDetail(Data Folder, AR Activity File, AR Transaction File, Contract,
Aging As Of Date, Aging Basis, Include Retainage, Unpaid Only, Age Finance
Charge)
Data Folder: The report design must use the tsDataFolder formula, which stores the
folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art) file.
Contract: The Contract ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis date.
Aging Basis: The date that the Aging as of Date uses to determine the cutoff date.
Include Retainage: True or False value. A True value takes retainage transactions
into account. A False value bypasses retainage transactions.
Unpaid Only: True or False. A True value considers transactions at the invoice
(status) level. A False value considers transactions at the Activity level.
Age Finance Charge: True or False value. A True value includes finance charges. A
False value bypasses finance charges.

Example

(From report AR Statement of Account (CR).rpt)
tsarContractOnlyDetail({@tsDataFolder},{@tsFileName(ARA)},{@tsFileName
(ART)},{ART_CURRENT_TRANSACTION.Contract},{?Aging Date},{?Aging Basis},
{?Include Retainage?},{?Unpaid only?},{?Include Finance Charges?})
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Function: tsarCustomerDetailWithRetainage
Description

Use this function to determine whether Accounts Receivable details should print
for the specified customer.

Syntax

tsarCustomerDetailWithRetainage(Data Folder, AR Activity File, AR Transaction
File, Customer, Aging As Of Date, Aging Basis, Include Retainage, Unpaid Only,
Age Finance Charge)
Data Folder: The report design must use the tsDataFolder formula, which stores
the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art)
file.
Customer: The Customer ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis date.
Aging Basis: The date that the Aging as of Date uses to determine the cutoff
date.
Include Retainage: True or False value. A True value takes retainage
transactions into account. A False value bypasses retainage transactions.
Unpaid Only: True or False. A True value considers transactions at the invoice
(status) level. A False value considers transactions at the Activity level.
Age Finance Charge: True or False value. A True value includes finance charges.
A False value bypasses finance charges.

Example

(From report AR Statement of Account (CR).rpt)
tsarCustomerDetailWithRetainage({@tsDataFolder},{@tsFileName(ARA)},
{@tsFileName(ART)},{ART_CURRENT_TRANSACTION.Customer},{?Aging
Date},{?Aging Basis},{?Include Retainage?},{?Unpaid only?},{?Include Finance
Charges?})
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Function: tsarJobCustomerDetail
Description

Use this function to determine whether Accounts Receivable details should print for
the specified job and customer.

Syntax

tsarJobCustomerDetail(Data Folder, AR Activity File, AR Transaction File, Job,
Customer, Aging As Of Date, Aging Basis, Include Retainage, Unpaid Only, Age
Finance Charge)
Data Folder: The report design must use the tsDataFolder formula, which stores the
folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art) file.
Job: The Job ID.
Customer: The Customer ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis date.
Aging Basis: The date that the Aging as of Date uses to determine the cutoff date.
Include Retainage: True or False value. A True value takes retainage transactions
into account. A False value bypasses retainage transactions.
Unpaid Only: True or False. A True value considers transactions at the invoice
(status) level. A False value considers transactions at the Activity level.
Age Finance Charge: True or False value. A True value includes finance charges. A
False value bypasses finance charges.

Example

(From report AR Statement of Account (CR).rpt)
tsarJobCustomerDetail({@tsDataFolder},{@tsFileName(ARA)},{@tsFileName
(ART)},{ART_CURRENT_TRANSACTION.Job},{ART_CURRENT_
TRANSACTION.Customer},{?Aging Date},{?Aging Basis},{?Include Retainage?},
{?Unpaid only?},{?Include Finance Charges?})
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Function: tsarJobOnlyDetail
Description

Use this function to determine whether Accounts Receivable details should print for
the specified job.

Syntax

tsarJobOnlyDetail(Data Folder, AR Activity File, AR Transaction File, Job, Aging As
Of Date, Aging Basis, Include Retainage, Unpaid Only, Age Finance Charge)
Data Folder: The report design must use the tsDataFolder formula, which stores the
folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art) file.
Job: The Job ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis date.
Aging Basis: The date that the Aging as of Date uses to determine the cutoff date.
Include Retainage: True or False value. A True value takes retainage transactions
into account. A False value bypasses retainage transactions.
Unpaid Only: True or False. A True value considers transactions at the invoice
(status) level. A False value considers transactions at the Activity level.
Age Finance Charge: True or False value. A True value includes finance charges. A
False value bypasses finance charges.

Example

(From report AR Statement of Account (CR).rpt)
tsarJobOnlyDetail({@tsDataFolder},{@tsFileName(ARA)},{@tsFileName(ART)},
{ART_CURRENT_TRANSACTION.Job},{?Aging Date},{?Aging Basis},{?Include
Retainage?},{?Unpaid only?},{?Include Finance Charges?})
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Function: tsControlData
Description

Use this function to retrieve information such as company name, address, and phone
number from the Ts.ctl file.

Syntax

tsControlData(Data Folder Name, Field Name, Flags)
Data Folder Name: The report design must use the tsDataFolder formula, which
stores the folder path information.
Field Name: You can type (case sensitive):
l “Name”
l “Address” or “Address 1” and “Address 2”
l “City”
l “State”
l “Zip”
l “Phone”
l “Fax”
l “Email”
l “Web Address”
l “Accounting Method”
l “Assign Batch Name”
Flags: You can type
l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize the first letter only.
l “L” for all lowercase.
l “” to print as it is in the database.

Example

tsControlData(@tsDataFolder, “Name”, “A”) prints the company name in all capital
letters.
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Function: tsCustomDescription
Description

This function retrieves custom descriptions from the ts.fld file.

Syntax

tsCustomDescription(Data Folder Name, Code, Flags)
Data Folder Name: The report design must use the tsDataFolder formula, which
stores the folder path information.
Code: The custom description field code.
Flags: You can type:
l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize the first letter only.
l “L” for all lowercase.
l “” to print as it is in the database.

Example

tsCustomDescription(@tsDataFolder, 13, “A”) prints the JC Change Order
custom description in all capital letters.

Note: All custom description codes are stored in the Ts.fld file. Custom descriptions are listed when you
print an available fields report (TR:Tools > Available Fields) and you select the Include information
for ODBC reporting? check box in the PrintAvailable Fields – Print Selection window.
The tsCustomDescription function was new on Accounting and Management Products 8.0.0 and is used on
new Crystal Reports designs. Earlier versions stored a function with a slightly different syntax called
tsCustomDesc. The Billing invoice reports still use the older function. Both functions are stored in the u2lts.dll
file on Accounting and Management Products 8.0.0 and later.

Function: tsEstimatingDKM
Description

If you use security and you link a report design used as a Sage 300 Construction and
Real Estate Desktop home page to an estimate, Sage 300 Construction and Real
Estate will ask for your user name and password when you open the estimate. Use
the tsEstimatingDKM function to suppress the request for user name and password
when you open an estimate from a home page in Desktop.

Syntax

tsEstimatingDKM({@tsDesktopID}, {Detail.PATH} & “\” & {Detail.FILENAME});
Detail.PATH and Detail.FILENAME are fields that store the estimate’s path and file
name in the Estimating Explorer database.

Note: You must add the tsDesktopId formula to the main report when you use the tsEstimatingDKM
function in a hyperlink to an estimate.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 93

Chapter 8: Crystal Reports

Function: tsFieldSection
Description

Use this function to determine the value in a customer-specified field section. A field
section is any portion of the GL Account, JC Job, or AR Customer that you define.
For example, you can define up to 3 prefixes, the base, and the suffix of a GL
Account. Therefore, these are field sections. Using the tsFieldSection function, you
can retrieve the prefix, base, or suffix field information from the GL Account.

Syntax

tsFieldSection(Data Folder Name, File Type, Field Name, Section, Value)
Data Folder Name: Type a path to the data folder or use the tsDataFolder formula,
which stores the folder path information.
File Type: The type of file. For example, type “GLM” for the General Ledger account
file or “JCM” for the Job Cost master file.
Field Name: The name of the field. For example, type “AACCT” for the General
Ledger account field.
Section: Section 1, Section 2, or Section 3; Base; Suffix
Value: The ODBC field name on which to act.
For example, GLT_CURRENT_TRANSACTION.Account for the Account number
from the GLT current transaction file, GLM_MASTER_ACCOUNT.Account for the
Account number from the GLM Master account record, or JCM_MASTER_JOB.Job
for the job number from the JCM Job record.

Example

tsFieldSection(@tsDataFolder, “GLM”, “AACCT”, “Section 1”, GLM_
MASTER_ACCOUNT.Account) prints the information in section 1 of the GL Master
Account field.
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Function: tsFieldSectionDesc
Description

Use this function to determine the description in a customer-specified field section. A
field section is any portion of the GL Account, JC Job, or AR Customer that you
define. For example, you can define up to 3 prefixes, the base, and the suffix of a GL
Account. Therefore, these are field sections. Using the tsFieldSection function, you
can retrieve the prefix, base, or suffix field description information from the GL
Account.

Syntax

tsFieldSectionDec(Data Folder Name, File Type, Field Name, Section, Flags)
Data Folder Name: Type a path to the data folder or use the tsDataFolder formula,
which stores the folder path information.
File Type: The type of file. For example, type “GLM” for the General Ledger account
file or “JCM” for the Job Cost master file.
Field Name: The name of the field. For example, type “AACCT” for the General
Ledger account field.
Section: Section 1, Section 2, or Section 3; Base; Suffix
Flags: You can type:
l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize the first letter only.
l “L” for all lowercase.
l “” to print as it is in the database.

Example

tsFieldSectionDesc(@tsDataFolder, “GLM”, “AACCT”, “Section 1”, “A”) prints
the section 1 description of the GL Master Account field in all caps.
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Function: tsglFiscalEntityInfo
Description

Use this function to report on the Australian Business Number (ABN) for General
Ledger or Accounts Payable accounts. For General Ledger accounts, you can report
on the ABN for a General Ledger prefix or the entire account number.

Syntax

tsglFiscalEntityInfo(Data Folder Name, Field Name, Prefix or Account, Account
Section)
Data Folder Name: Type the path to the data folder or use the tsDataFolder formula,
which stores folder path information.
Field Name: You must use “abn” as the field name.
Prefix or Account: Type a valid prefix number or account number from the general
ledger chart of accounts or type a valid accounts payable account number.
Account Section: Type the section of the account to use. You can type:
l “account”
l “prefix a”
l “prefix b”
l “prefix c”
l “full prefix”

Example

tsglFiscalEntityInfo(@tsDataFolder,”abn”,”10-1201”,”account”)

Function: tsHeaderData
Description

Use to determine the header information, such as header records in the BLM file.

Syntax

tsHeaderData(Data Folder Name, File Name, Header Number, Field Name, Flags)
Data Folder Name: The report design must use the tsDataFolder formula, which
stores the folder path information.
Name: Use the actual file name; for example, Master.apm or Master.blm.
Header Number: Identifies the header record from which the field is retrieved.
Field Name: Use the internal field name; for example, SATXT or PABN.
Flags: You can type:
l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize only the first letter.
l “L” for all lowercase.
l “” to print as it is in the database.

Example

tsHeaderData(@tsDataFolder, “Master.blm”, 2,”SATXT”, “PA”) retrieves the Auto
Text field from the BL Settings Header, adds an “s” to the end, and prints in all
capital letters.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 96

Chapter 8: Crystal Reports

Notes: Internal field names are listed when you print an available fields report (TR: Tools > Available
Fields) and you select the Include information for ODBC reporting? check box in the Print Available
Fields – Print Selection window.
To retrieve a date field, you must use the Crystal Reports ToDate function to convert the string value to a
date. To retrieve a number, you must use the Crystal Reports ToNumber function to convert the string
value to a number.

Function: tsItemDesc
Description

This function returns the description of a list field. Use this function to perform string
comparisons on list fields that contain custom descriptions.

Syntax

tsItemDesc(Data Folder Name, File Type, Field Name, Item Name, Format)
Data Folder Name: Type a path to the data folder or use the tsDataFolder formula,
which stores the folder path information.
File Type: The type of file. For example, type “ART” for the accounts receivable
transaction file.
Field Name: The name of the custom list field. For example, type “TATYPE” for the
accounts receivable Amount Type custom list.
Item Name: The short description of the custom list item. For example, type “PMT”
for the cash receipt accounts receivable amount type.
Format:
l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize the first letter only.
l “L” for all lowercase.
l “” to print as it is in the database.

Example

tsItemDesc(@tsDataFolder, “ART”, “TATYPE”,”Lab”,”A”) returns LAB

Note: When you use tsItemDesc for literal string comparisons, set the Format parameter to nothing (““) to
return the description unchanged.
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Function: tsLetterheadStyle
Description

This function retrieves your Sage 300 Construction and Real Estate letterhead
settings (Tools > Options > Letterhead tab) and returns one of the following values:
“NONE”—No logo prints. The company name and address print in the header section.
“PREPRINTED”—No logo prints. Header is blank to accommodate letterhead
stationery.
“CUSTOM”—Logo prints on the left. Company address prints on the right.
To accommodate the use of different database-specific Sage 300 Construction and
Real Estate letterhead settings, all report designs created in Crystal Reports and
included in the software have separate header sections for all three letterhead options.
The tsLetterheadStyle function is used as a suppress condition on a header section.
The function determines which letterhead to use and suppresses the unused
letterheads when the report prints.

Example

(Page Header—Suppress Condition)
Custom: tsLetterheadStyle({@tsDataFolder}) <> “CUSTOM”
Preprinted: tsLetterheadStyle({@tsDataFolder}) <> “PREPRINTED”
None: tsLetterheadStyle({@tsDataFolder}) <> “NONE”
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Function: tsOperator
Description

Use to determine the identity or the description of the operator printing the report

Syntax

tsOperator(“Id”) or tsOperator(“Desc”)
Id: The identifier for the operator.
Desc: The description for the operator. For example, the name of the operator.

Example

tsOperator(“Id”) prints the Sage 300 Construction and Real Estate Security Id and
tsOperator(“Desc”) prints the Sage 300 Construction and Real Estate Security
operator description.

Function: tsRange
Description

Use this function to add range values to custom Crystal Report designs that you use
in Sage 300 Construction and Real Estate applications. You can select the range
values from a database list.
To view the database list, do the following:
Select Report Designer: Tools > Available Fields.
Select the record that you want to use, and then click [OK]. For example, AP Vendor.
On the Print Available Fields window, select Include information for ODBC
reporting?, and then click [Start].
Note: Use the report created in step 3 above to determine the values to use in the
formulas listed below.
Important: The tsRange parameter must be the last parameter on the report design.
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Function: tsRange
Syntax

Formula 1: "File Abbreviation, Record Number, Internal Name, Standard Order
Number, Internal Name 2"
Parameter: tsRange(Formula 1 Name)
Formula 2: ((UBound({?tsRange(Formula 1 Name)}) = 1) and ({?tsRange(Formula 1
Name)}[1] = "")) or Database Field = {?tsRange(Formula 1 Name)}
Database Field: {Table.Field}
Expert: Formula 2 Name is True.
Formula Name: The name of the formula can be whatever you choose.
File Abbreviation: The three-letter abbreviation for the data file type.
Record Number: The number of the record in the file.
Internal Name: This is the key field. For example, VENDOR or JOB.
Standard Order Number: Optional. This is the alternative key. Use it for sorting the
records.
Internal Name 2: Optional. This is the description field. For example, VNAME.
Database Field: The field in the database to which the parameter is attached.
Value options for the parameter should be set as follows:
Allow custom values: True
Allow multiple values: True
Allow discrete values: True
Allow range values: False (This is because you are using a Sage 300 Construction
and Real Estate range rather than a Crystal range.)
Steps to create function:
1 Name the formula and select the fields for the formula (Formula Workshop >
Formula Editor).
2 Edit the value options for the parameter (Edit Parameter).
3 Attach the parameter to the database field (Select Expert).

Example

Formula 1 Name: VendorRangeSelection
Formula 1: “APM,9,VENDOR,1,VNAME”
Parameter: tsRange(VendorRangeSelection)
Formula 2 Name: SELECT - Vendor Range or NULL
Formula 2: ((UBound({?tsRange(VendorRangeSelection)}) = 1) and ({?tsRange
(VendorRangeSelection)}[1] = "")) or APM_MASTER__VENDOR. Vendor =
{?tsRange(VendorRangeSelection)}
Expert:@SELECT - Vendor Range or NULL is True.
Provides a range in vendor number order with a description of vendor name.
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Special parameters in process reports
Process reports are reports that print forms and are printed directly from application tasks. This section
describes the procedure for defining the process reports to print using Crystal Reports. Although most
applications print process reports, only the Job Cost (JC) and Project Management (PJ) applications use
Crystal Reports currently to print process reports.
Project Management uses the process reports that follow:
l

Change order forms

l

Change request forms

l

Commitment change order forms

l

Drawing logs

l

Meeting minutes

l

RFI forms

l

Submittal forms

l

Transmittal forms

Job Cost uses the process reports that follow:
l

Change order forms

l

Purchase order change order forms

l

Purchase order forms

l

Subcontract change order forms

l

Subcontract forms

Note: Do not type “?” in front of parameter fields. In Crystal Reports, “?” automatically appears in front of
parameter fields; for example, when you create a parameter and type tsDocIndex, the parameter appears
as ?tsDocIndex.

Parameter: tsContactIndex
Description

Only transmittal forms require this additional parameter to retrieve the contact ID
created by the process for the report.
In Crystal Reports, create the tsContactIndex string parameter.
Link the ?tsContactIndex parameter on the main report to the Contact ID on the
subreport to print the To contact information.
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Parameter: tsDocIndex
Description

Process reports require this parameter to retrieve the document ID created by the
process for the report.
Use a tsDocIndex parameter when you want a document to print for only a specific
document ID.
This parameter is stored in the u2lxx.dll files. These files are installed in different
locations depending on the version of Crystal Reports that you use. If you use
Timberline Registry Editor (TSRegEdit) to switch between different versions of Sage
300 Construction and Real Estate applications, always use the latest version of the
Registry Editor to ensure that u2lxx.dll files are in the proper location.
Create a parameter named tsDocIndex. Use Select Expert (Report > Select
Expert) to set the document index field equal to ?tsDocIndex. For each report type,
use the settings that follow:
RFIs:{PJD_DOCUMENT_RFI.RFI_INDEX} = {?tsDocIndex}
Submittals: {PJD_DOCUMENT_SUBMITTAL.SUBMITTAL_INDEX} =
{?tsDocIndex}
Transmittals: {PJD_DOCUMENT_TRANSMITTAL.TRANSMITTAL_INDEX} =
{?tsDocIndex}
Purchase orders and subcontracts: {JCM_MASTER_COMMITMENT.doc_ID} =
{?tsDocIndex}
Change orders: {JCM_MASTER_CHANGE_ORDER.doc_ID} = {?tsDocIndex}
Purchase order COs and subcontract COs:{JCM_MASTER_COMMITMENT_
CO.doc_ID} = {?tsDocIndex}

Could not open data folder error
If you set the location on all tables and try to preview the report in Crystal, you still may receive an error
message stating: Could not open data folder. Data folder does not exist, it is not a Timberline data
folder, or the current operator does not have access.
This message refers to the path in the report’s tsDataFolder formula. The tsDataFolder formula must have a
valid path to be previewed from Crystal.
To correct this error, follow these steps:
1 Click [OK] to this message.
2 Close the Formula Workshop window.
3 Under Field Explorer, double-click Formula Fields and select tsDataFolder.
4 Right-click and select Edit.
5 Change the path to match your accounting data folder path.

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 102

Chapter 8: Crystal Reports

Customizing Crystal Reports
Add, modify, and create custom report designs
Use Report Manager to add Crystal Reports designs to your Reports menu.
All Crystal report designs available on the Reports menu in Sage 300 Construction and Real Estate use the
following options with the Timberline Data Source: Standard descriptions for Table and Field Naming,
Use maximum table segment size selected, Shorten field and table names cleared.
Note: Crystal Reports integration features are compatible only with Crystal Report designs created with
a DSN named “Timberline Data Source.” Currently, the only exception is for Billing invoices, which use a
DSN named TS Billing Field Names. For more information on the TS Billing Field Names DSN, see
“Billing considerations” on page 105.

Note:
For the data source name (DSN):
l

l

Use Timberline Data Source for all Crystal reports that you will use with Accounting and
Management report menus.
Use TS Billing Field Names for Crystal reports that you will use for Billing invoice designs; see
“Billing considerations” on page 105 for more information .

If you do not use the Timberline Data Source, then you must do the following:
n

On the computer from which you process the report:
l

l

n

You must create a data source name (DSN) with the same name DSN name used with the original
report.
The DSN must use the same table and field naming option as the DSN you used to create the original
design.

If the original report design used the custom description naming option, your custom descriptions must
match the custom descriptions used to create the report design.

If you use the Timberline Data Source, follow these steps to add, modify, and create custom report designs.
1 From the Start menu, select Control Panel > Administrative Tools > Data Sources (ODBC)) to open
the ODBC Data Source Administrator window.
2 From the User DSN tab, select Timberline Data Source.
3 Click [Configure].
4 Click [Select Folder] and select your Sage 300 Construction and Real Estate data folder. Click [OK].
5 Click [Options].
a In the Table and Field Naming list, select Standard descriptions.
b Select the Use maximum table segment size check box.
c Clear the Shorten field and table names check box.
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d Click [OK] twice.
6 Open Crystal Reports.
7 Log on to a Timberline data source.
a If you do not have the report open, from the File menu, select Log On or Off Server. If you have the
report open, from the Database menu, select Log On or Off Server.
b In the Data Explorer window, double-click Create New Connection.
c Double-click ODBC (RDO).
d Select Timberline Data Source and click [Next].
e If necessary, type your User ID and Password for Sage 300 Construction and Real Estate.
f Click [Finish].
g Click [Close].
8 Open the report design you want to modify and proceed to step 9 If you want to create a new report design,
select File > New. Select the tables and fields that you want to use on the report; then design the report.
9 Set the location of the database.
a From the Database menu, select Set Datasource Location.
b Under Current Data Source, select the first data source.
c Under Replace with, select Timberline Data Source.
d Click [Update].
e Verify that all table locations in the Set Datasource Location window use the same data folder path.
You know that all table locations point to the same path if only one group of tables appears under Current
Data Source.
f Click [Close].
10 Repeat step 9 for each table in the report.
11 From the Database menu, select Verify Database. Click [OK] when the message appears that states,
“The database is up to date.” Repeat step 9 if the database is not up to date.
12 Review the list of formulas, functions, and parameters from section 3. "Crystal Reports integration" on
page 80 to determine which to add or modify.
13 When you finish, save the report.
14 Use Reports Manager to add new reports to your Sage 300 Construction and Real Estate Reports menu.
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Billing considerations
When upgrading, changing, or creating Billing invoice designs, you must first set the location and verify the
database against a DSN called TS Billing Field Names.

Creating the TS Billing field names DSN
1 From the Start menu, select All Programs > ODBC > 32bit ODBC Administrator.
2 Click the User DSN tab.
3 Click [Add].
4 Select Timberline Data as the new data source.
5 Click [Finish].
6 In the Data Source Name box, type TS Billing Field Names.
7 Click [Select Folder].
8 Select the folder where the Sage 300 Construction and Real Estate data is located and click [OK].
9 Click [Options].
10 In the Table and Field Naming list, select Dictionary names.
11 Select the Use maximum table segment size check box.
Note: If the report was created in a version before Accounting and Management Products 8.0.0, you
may need to clear the Use maximum table segment size check box.
12 Clear the Shorten field and table names check box.
13 Click [OK] to accept the new DSN.
14 Click [OK] to close the ODBC Administrator.

tsDesignMode formula
The Billing invoice format invoice design and all subreports must contain the tsDesignMode formula. The
value in this formula must be “Dictionary”.
If you use a custom Crystal design for your Billing invoice task and it does not contain the tsDesignMode
formula, you will receive the following error messages: “Print Engine error 7: unable to connect to
database” and “File report design is not a valid invoice design.”
Note: The invoice format designs provided with your Sage 300 Construction and Real Estate software
already include these changes.
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Purchasing and Inventory considerations
Database record changes
You may need to modify Purchasing and Inventory custom reports to reflect Sage 300 Construction and Real
Estate database changes. Refer to the Accounting and Management Release Notes to review database
changes by application.
Notes:
l

l

When you open Purchasing, Sage 300 Construction and Real Estate creates the “Timberline
Office Data PO” and “Timberline PO Data” data sources. When you open Inventory, Sage 300
Construction and Real Estate creates the” Timberline Office Data IV” and “Timberline IV Data”
data sources. These data sources are not available until you open Purchasing or Inventory.
Purchasing and Inventory reports have a .crs extension. When you open one of these reports in
Crystal Reports, make sure to select All files for Files of type. This ensures that files with the
.crs extensions appear in the Open window.

Modify custom reports
To modify custom Purchasing and Inventory reports that were created in a previous version of Crystal
Reports.
1 Open the report in the current version of Crystal Reports.
2 For Purchasing or Inventory tables:
a From the Database menu, select Set Datasource Location.
b Under Replace with, double-click the Create New Connection folder.
c Double-click the ODBC (RDO) folder.
d In the ODBC (RDO) window, select Select Data Source.
e In the Data Source Name list, select Timberline PO Data or Timberline IV Data. (Select Timberline PO
Data if you are using a PO report; select Timberline IV Data if you are using an IV report).
f Click [Finish].
g For each table listed under Current Data Source, select the table, select the corresponding table in the
Replace with area, and click [Update]. (If all the data sources are the same, you can do this at the data
source level instead.)
h Click [Close].
Note: You may have to manually map changed fields.
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3 For Sage 300 Construction and Real Estate tables:
a From the Database menu, select Set Datasource Location.
b Under Replace with, double-click the Create New Connection folder.
c Double-click the ODBC (RDO) folder.
d Click Make New Connection if the Connection Information window does not appear.
e In the ODBC (RDO) window, select Select Data Source.
f In the Data Source Name list, select Timberline Office Data PO or Timberline Office Data IV.
(Select Timberline Office Data PO if you are using a PO report; select Timberline Office Data IV if you
are using an IV report). Click [Finish].
g For each table listed under Current Data Source, select the table, select the corresponding table in the
Replace with area, and click [Update]. (If all the data sources are the same, you can do this at the data
source level instead.)
h Click [Close].
Note: You may need to rename the report with a .crs extension after you save the report.

Formatted field formulas
Formatted fields are fields that you can format with sections separated by characters. You can create
formulas that will print the following as formatted fields on reports:
n

Job

n

Job cost code

n

Equipment

n

Equipment cost code

n

GL account

Formula content for formatted fields contains only the field name.
Formula Contents and Field Name

Formula Name

Job

FMTJOB + at least one character

Job Cost Code

FMTJCC + at least one character

Equipment

FMTEQU + at least one character

Equipment Cost Code

FMTECC + at least one character

GL Account

FMTGLA + at least one character

If you create a report that has several occurrences of the same fields from different records, you can create
multiple formulas with different names; for example, if you create a report that uses the job and job cost code
fields from both the PODetail and POHeader records, you could create the following formulas:
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Field

Record

Formula Name

Job

PODetail

FMTJOB1

Job

POHeader

FMTJOB2

Job Cost Code

PODetail

FMTJCC1

Job Cost Code

POHeader

FMTJCC2

Note: Formatting does not print from within Crystal Reports. Formatting does print when you print the
report from the Reports menu in Purchasing or Inventory.

Ts.ctl formulas
You can create formulas to include the general company information stored in the control (Ts.ctl) file. Follow
these steps.
Caution! If your existing reports contain Purchasing or Inventory control file fields (for example.,
Companyname, Address1, Address2, etc.), you must replace them with the formulas listed in the
following table.
1 Name the new formula according to the following table.
Ts.ctl Field Name

Ts.ctl Formula Name

Company

TSCOMPANY

Address

TSADDRESS

Address 2

TSADDRESS2

City

TSCITY

State

TSSTATE

Zip

TSZIP

Phone

TSPHONE

Folder

TSFOLDER

2 In the Formula Editor window, leave the contents of the formula blank.
3 Save the formula.
Note: Return values for these formulas do not print from within Crystal. They do print when you print the
report from the Reports menu in Purchasing or Inventory.
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Parameter fields
When you print a report with parameter fields, the parameters determine which prompts appear in the print
window. For example, if the parameter is a date field, the prompt uses the calendar control; if the parameter is
a logic (true or false) field, the prompt uses a check box. For Purchasing and Inventory, name your parameters
something specific if the design lets you see a list of available data for the parameter.

Preset parameter sets
All of the following parameter names allow use of drop-down selection lists to print.
Parameter
STARTDATE

ENDDATE

FIRSTITEM

LASTITEM

FIRSTLOC

LASTLOC

FIRSTCLASS

LASTCLASS

FIRSTJOB

LASTJOB

FIRSTVENDOR

LASTVENDOR

FIRSTPO

LASTPO

FIRSTRECEIPT

LASTRECEIPT

Purchase order form and purchase order change order form parameters
Parameter

Purpose

PONUMBER

You want the report (for example, a purchase order form) to print for a single purchase
order. Use also with the CONUMBER parameter as described below.

CONUMBER

You want the report (e.g., a purchase order change order form) to print for a single
purchase order change order.

Note: Lists for these parameters do not appear from within Crystal. They work, but you must type a
value, not select a value from a list. They do print when you print the report from the Reports menu in
Purchasing or Inventory.
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Add custom reports to the Purchasing or Inventory Reports menu
Use the steps that follow to add custom report designs to the Purchasing or Inventory Reports menu:
1 From the Reports menu in Purchasing or Inventory, select Report Manager.
2 To add a new report, click [New]. To change a report, click [Change].
3 Type the Report Name (the name that will appear on the report menu).
4 Select a Menu Group from the list, or type the name for a new menu group.
5 Click [List] to browse for the report. These must be Crystal Reports designs with a .crs extension.
6 Select the report, and then click [Open].
7 Click [OK] to close the Add New Report window.
8 Click [Close] to close the Reports Manager window.

DSN error
If you install or upgrade Purchasing or Inventory on a computer that has the Windows 7 operating system, you
may need to elevate your permissions level before starting the program or Purchasing/Inventory may not be
able to create the DSNs necessary to use Crystal Reports. If you encounter an error message when starting
Purchasing or Inventory for the first time after installation, close the program, elevate your permissions level,
and start Purchasing/Inventory again.

Service Management considerations
Database record changes
You may need to modify Service Management custom reports to reflect Sage 300 Construction and Real
Estate database changes. Refer to the Accounting and Management Release Notes to review database
changes by application.

Modify custom reports
There are two options for setting up Crystal Reports in Service Management. If the report is designed to
switch between the current and history files, see “Option A” (the next section). If the report is not designed to
switch between current and history files, see “Option B ,” on page 112.
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Option A
1 Verify the Timberline Data Source is set up correctly. Subreports that pull information from the accounting
database use the ODBC Timberline Data Source DSN.
a From the Start menu, select Control Panel > Administrative Tools > Data Sources (ODBC) to
open the ODBC Data Source Administrator window.
b From the User DSN tab, select Timberline Data Source.
c Click [Configure].
d Click [Select Folder] and select your Sage 300 Construction and Real Estate data folder. Click [OK].
e Click [Options].
f Under Data Source Options, select Standard descriptions from the Table and Field Naming list.
g Select the Use maximum table segment size check box.
h Clear the Shorten field and table names check box.
i Click [OK] twice.
Note: If you will print this custom report from within Crystal Reports, this DSN must use a valid Sage
300 Construction and Real Estate accounting data set.
2 Set the location to a valid data set.
a From Crystal Reports, open the custom report you are upgrading.
b From the Database menu, select Set Datasource Location.
c Under Current Data Source, select the first data source.
d Under Replace with, double-click Create New Connection.
e Double-click Btrieve.
f In the Open window, browse to the folder containing your Service Management data.
g Select FILE.DDF and click [Open].
h Select the data source that should replace the original.
i Click [Update].
j Repeat steps b through i for all data sources listed under Current Data Source.
k Verify all table locations in the Set Datasource Location window point to the same data folder path. All
table locations point to the same path if only one group of tables appears under Current Data Source.
You must also set the location on all subreports. If a subreport retrieves Service Management data, follow
the procedure in step 2. If a subreport retrieves data from the Timberline Data Source, follow the procedure
in step 3 below. The Current Data Source window lists subreport data sources in a separate group.

3 Select the data source for the subreport.
a From the Database menu, select Set Datasource Location.
b Under Current Data Source, double-click Subreports and select the first data source.
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c Under Replace with, double-click Create New Connection.
d Double-click ODBC (RDO).
e Select Timberline Data Source.
f Click [Finish].
g If you have security enabled, type your Operator ID and Password.
h Click [Close].
4 After you use Set Datasource Location, verify the path on each table of the report is correct.
5 From the Database menu, select Verify Database.
6 From the File menu, select Save.

Option B
1 Verify the Timberline Data Source is set up correctly. Subreports that pull information from the accounting
database use the Timberline Data Source.
a From the Start menu, select Control Panel > Administrative Tools > Data Sources (ODBC) to
open the ODBC Data Source Administrator window.
b From the User DSN tab, select Timberline Data Source.
c Click [Configure].
d Click [Select Folder] and select your Sage 300 Construction and Real Estate data folder. Click [OK].
e Click [Options].
f Under Data Source Options, select Standard descriptions from the Table and Field Naming list.
g Select the Use maximum table segment size check box.
h Clear the Shorten field and table names check box.
i Click [OK] twice.
2 Verify the Timberline SM Data DSN is set up correctly
a From the Start menu, select Control Panel > Administrative Tools > Data Sources (ODBC) to open
the ODBC Data Source Administrator window.
b If you are operating in a server/workstation environment, select the System DSN tab and verify there is
a Timberline SM Data DSN.
Note: If Timberline SM Data does not appear in the list of data sources, create it automatically by
the following steps: 1) Open Service Management at the server and preview any standard report. 2)
Open Service Management at each workstation and preview any standard report.
c If you are operating on a standalone system, perform steps d-h to set up the Timberline SM Data DSN
manually; otherwise, continue with step 3.
d If you are on a standalone system, create the Timberline SM Data DSN manually by selecting Start >
Control Panel > Administrative Tools > Data Sources (ODBC) to open the ODBC Data Source
Administrator window.
e From the System DSN tab, click [Add].
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f Select the Pervasive ODBC Engine Interface driver.
g Enter the following information in the Pervasive ODBC Engine DSN Setup window:
l

l

Data Source Name: Timberline SM Data
Database Name: From the list, select the entry starting with the letters SM in its label (for example,
“SM1FE43AFDF79D459F”).

Service Management creates two DSN GUIDs for each dataset. You may select any Service
Management DSN GUID when creating the Timberline SM Data DSN manually. During run time,
Service Management automatically points to the correct Service Management database.
h Click [OK].
Note: If you will print this custom report from within Crystal Reports, this DSN must use a valid Sage
300 Construction and Real Estate accounting data set.
3 Set the location to a valid data set.
a From Crystal Reports, open the custom report you are upgrading.
b From the Database menu, select Set Datasource Location.
c Under Current Data Source, make note of any paths where *.ddf files exist (for example,
C:\Development\Testdata\Field.ddf).
d Click [Close] to close the Set Datasource Location window without changing any locations.
e Based on the information you determined in step c, use Windows Explorer to browse to the location
referenced by the custom report. Confirm that these files exist:
l

Field.ddf

l

File.ddf

l

Index.ddf

f If the files do exist there, copy the .ddf files from your Servmngt folder to the location you determined in
step c. Typically, your Servmngt folder is located at X:\Program Files\Timberline
Office\Accounting\Servmngt (where X represents the drive where your Sage 300 Construction and Real
Estate programs are installed).
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4 Verify the database.
a Open the report design in the current version of Crystal Reports and select Database > Verify
Database.
b You may receive several prompts at this point. Respond to these messages as instructed until the Map
Fields window appears:
l

l

l

“The Database file ‘[file name]’ has changed. Proceeding to fix up the report!” Click [OK] at
this message.
“The database is now up to date.” Click [OK] at this message.
If you receive message other than these (for example, “Remove table” messages), do not proceed.
Close the design without saving your changes and then confirm that step 2 was done correctly before
proceeding.

5 Open the custom report design in the current version of Crystal Reports and update the data source as
follows:
a From the Database menu, select Set Datasource Location.
b Under Replace with, double-click the Create New Connection folder.
c Double-click the ODBC (RDO) folder.
d In the ODBC (RDO) window, select Select Data Source.
e In the Data Source Name list, select Timberline SM Data and then click [Finish].
f For each item listed under Current Data Source, select the corresponding table in the Replace with
area and click [Update].
g Click [Close].
6 Verify the database.
a Select Database > Verify Database.
b Respond to the prompts as appropriate.
7 Save the custom report design.
You must also set the location on all subreports. If a subreport retrieves Service Management data, follow
the procedure in steps 3-7. If a subreport retrieves data from Timberline Data Source, use the steps that
follow. The Current Data Source window lists subreport data sources in a separate group.
8 Select the data source for the subreport.
a From the Database menu, select Set Datasource Location.
b Under Current Data Source, double-click Subreports and select the first data source. Many of the
subreports retrieve information from the Timberline Data Source.
c Under Replace with, double-click Create New Connection.
d Double-click ODBC (RDO).
e Select Timberline Data Source.
f Click [Finish].
g If you have security enabled, type your Operator ID and Password.
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h Click [Close].
i After you use Set Datasource Location, verify that the path on each table of the report is correct.
j From the Database menu, select Verify Database.
k From the File menu, select Save.

DSN error
If you install or upgrade Service Management on a computer that has the Windows 7 operating system, you
may need to elevate your permissions level before starting the program or Service Management may not be
able to create the DSNs necessary to use Crystal Reports. If you encounter an error message when starting
Service Management for the first time after installation, close Service Management, elevate your permissions
level, and start Service Management again.

Add custom reports to the Service Management Reports menu
Use the steps that follow to add custom report designs to the Service Management Reports menu:
1 Open Service Management.
2 From the Reports menu, select Custom Reports Manager.
3 Click [New].
4 Type a Name for the new report.
5 Click the Path button and select the path to the report.
6 Type a Submenu name for the report.
7 To print the report automatically to a file, select the Print to file check box and type a File name.
8 Click [Finish].
9 Click [Done].
Notes:
If you want custom invoice formats in Service Management 8.3.0 and later to be retrieved, add them to the
appropriate location. These custom formats include Call Type, Service Location, AR Customer, and
Service Management Settings.
You can store custom reports in a subdirectory for reports called Custom (file path X:\Program
Data\Sage\Timberline Office\9.5\Accounting\Report\Service Management\Custom in Windows
2008, or X:\Documents and Settings\All Users\Application Data\Sage\Timberline
Office\9.5\Accounting\Report\Service Management\Custom in all other supported operating
systems). You must manually create this folder, but any reports you store there will be retrieved by
Service Management before it retrieves the reports stored in the Service Management folder. This
prevents custom reports from being overwritten during the upgrade process. This is most common for
process-oriented reports like work orders and agreements. You must use the same name as the original
report.

tsAlternateSMFolder
You can select whether you want a Service Management report to include current or historical information by
adding the tsAlternateSMFolder function to the report. You do not need to add a value to the formula. For
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more information on the tsAlternateSMFolder function, see “Formula: tsAlternateSMFolder,” on page 81

tsApp
All Service Management reports designs and all subreports must contain the tsApp formula. The value in this
formula must be “SM.” However, this formula is not required on any report that uses the ODBC driver to
access Sage 300 Construction and Real Estate data. For more information on the tsApp formula, see
“Formula: tsApp,” on page 82

Desktop considerations
You can display Crystal Reports in Sage Desktop. You will want to keep some concepts in mind when you
create Crystal Reports designs for use as home pages.
To maximize the performance of Crystal Reports displayed in Sage Desktop:
n

If you use subreports, use on-demand subreports.

n

Do not use named files.

n

If a report takes a long time to process, you may not want to display it in Sage Desktop.

The following formulas do not function on Crystal Reports displayed in Sage Desktop:
n

tsAskFile

n

tsSubAskFile

n

tsLetterhead

Upgrade custom reports created with a version prior to 9
Follow the steps in this section to upgrade custom reports that were created in a version prior to version 9. For
custom reports created in version 9 or later, use the Upgrade Crystal Reports Tool; see the “Chapter 8:
Crystal Reports” on page 78 for more information.
Important! Upgrading reports requires knowledge of Crystal Reports software. If you do not have
experience using Crystal Reports, contact your Sage 300 Construction and Real Estate certified
consultant for help with upgrading custom reports and creating custom reports that fit your business
needs.

A. Verify that the Timberline Data Source is set up correctly
1 From the Start menu, select All Programs > ODBC > 32bit ODBC Administrator.
2 Click the User DSN tab and select Timberline Data Source.
3 Click [Configure] and then [Select Folder].
4 Select your data folder and click [OK].
5 Click [Options].
6 In the Table and Field Naming list, select Standard descriptions.
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Note: If the report was not created using standard descriptions, select the same table and field naming
type used to create the original report.
7 Select the Use maximum table segment size check box.
8 Clear the Shorten field and table names check box.
9 Click [OK] twice.

B. Connect to the Timberline Data Source
1 If the report that you want to modify is not open, select File > Log On or Off Server. If you already have
the report open, from the Database menu, select Log On or Off Server.
2 In the Data Explorer window, double-click Create New Connection.
3 Double-click ODBC (RDO).
4 Select Timberline Data Source and click [Next].
5 If necessary, type your User ID and Password for Sage 300 Construction and Real Estate.
6 Click [Finish].
7 Click [Close].

C. Set the data source location
You may need to modify your custom reports to reflect Sage 300 Construction and Real Estate database
changes. Refer to the Accounting and Management Release Notes to review database changes by
application.
If there are no database changes listed in the Release Notes that affect your custom reports, skip to D. Verify
the database (the next section).
If the database changes in the Release Notes includes changes to fields on your custom report:
1 In the Set Datasource Location window (Database > Set Datasource Location), under Replace with,
select Timberline Data Source.
2 Click [Update].
3 Repeat these steps for each subreport.

D. Verify the database
If you are upgrading custom reports that were created for a previous version of Sage 300 Construction and
Real Estate, follow these steps for each report design and each subreport design:
1 From the Database menu, select Verify Database.
2 Whenever a “The database file has changed” message appears, click [OK].
3 Whenever a “The database is now up to date” message appears, click [OK].
4 Answer the remainder of the messages as they appear.
5 From the Database menu, select Verify Database again.
6 When the “The database is up to date” message appears, click [OK].

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 117

Chapter 8: Crystal Reports

7 Save the report design.

E. Add new tables to custom reports
If the database changes includes new tables that you want to use for a custom report:
1 Select Database > Database Expert.
2 From the Available Data Sources list, select the new table that you need to add to the report, click [>] to
add the table to the Selected Tables list, and then click [OK].
3 On the Links tab, verify that the new table is linked correctly to the existing data tables, and then click
[OK].
4 As necessary, replace or add fields to the report and report formulas, and revise the Select Criteria.
5 Save the report design.
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Integration
Introduction
This section introduces you to the steps to transfer:
n

Estimate information from Estimating to Job Cost.

n

Estimate information to Project Management.

n

Commitment information from Buyout to Job Cost or Purchasing.

n

Commitment information from Purchasing to Job Cost.
Note: Before you begin, be sure Estimating, Job Cost, Buyout, and, if needed, Purchasing and Project
Management are set up and configured properly for your company. Contact your business partner or
consultant if you have questions.

Sage 300 Construction and Real Estate terminology
Terminology varies between the estimating and accounting disciplines, so the Estimating, Job Cost, Buyout,
and Purchasing applications use different terms to describe certain items. Please familiarize yourself with the
terms contained in the table below before you proceed.
Job Cost

Estimating

Buyout

Purchasing

Cost Code
(custom description*)

Job Cost Phase

Cost code

Reads data from Job Cost

Commitment ID

N/A

Purchase Order #

Purchase Order

*In Job Cost, you can define the description used for cost codes (File > Company Settings > Custom
Descriptions). `
If your company uses different terms, you should substitute your company’s terms for the ones used above.
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Estimate processing
Introduction
If you transfer estimate information directly into your job costing application, you can efficiently access budget
and transaction data without rekeying the information. This section covers the interface between Estimating
and Job Cost, which enables this information transfer.
If you use Project Management, you can easily update your change requests by importing information from
Estimating.

The Estimating to Job Cost interface
When Estimating sends estimate information to Job Cost, the software creates a file with the extension .jce.
When Job Cost accesses the data contained in that file, it transfers the information into the New.jct file.
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Preparing Job Cost to receive estimates
Note: For detailed information about Job Cost concepts, see the online Help in Job Cost.
To successfully transfer estimate information from Estimating to Job Cost, in Job Cost you must verify three
things:
1 All needed standard cost codes are set up.
Note: When you import estimates into Job Cost, you can select the Allow creation of Cost Codes
not on standard Cost Code list check box (found in the Import Estimates – Print Selection
window) to have the software create cost codes not on the standard cost code list. When you set up a
cost code during the import, only the cost code itself is defined. To define additional attributes, such as
the cost code description and the cost and production unit descriptions, set up the standard cost codes
ahead of time using JC: Setup > Standard Cost Codes.
2 All needed standard categories are set up, if your company uses categories.
3 Import settings are configured appropriately for your company.

Verifying standard cost codes
To see a list of standard cost codes that are already set up in Job Cost, in Job Cost, select Reports > Lists >
Standard Cost Codes.
If you do not see a cost code that you know exists in the estimate to be imported, you can set up the standard
cost code using Setup > Standard Cost Codes.
To set up standard cost codes or group cost codes, in Job Cost, select Setup > Standard Cost Codes. For
information about setting up standard cost codes, in the Job Cost Help index type Standard Cost Codes.
Select the topic titled “setting up”.

Verifying standard categories
Note: Using categories is optional. If you do not use categories, proceed to the next section.
To see a list of standard categories that are already set up, in Job Cost, select Reports > Lists > Standard
Categories.
If you do not see a standard category listed that you know exists in the estimate to be imported, you must set
up that standard category.
To set up a standard category, in Job Cost, select Setup > Standard Categories.
For information about how to set up standard categories, in the Job Cost help index, type Standard
Categories, and then select the topic titled “setting up”.
Note: In Job Cost, if you try to import a record that contains a category that does not exist on the
standard category list, the import is rejected.
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Verifying import settings
To verify Job Cost’s import settings:
1 In Job Cost, select File > Company Settings > JC Settings and click [Import].
2 The Allow override of default options check box affects imported commitments, not imported
estimates, so you do not need to set this option to import estimates.
3 Select the Warning Response option appropriate for your company. The Warning response options let
you affect how the software responds if the contents of the import file generate a warning during the import.
Situations that would produce a warning during import include:
p

p

The imported commitment contains a category that has already been marked as Bought Out in Job
Cost.
The amount on the imported commitment causes the total amount committed to exceed the estimate.

The Warning Response setting has no effect when a record generates an error. A record that generates an
error rejects during the import process.
4 The Commit method affects only imported commitments, not imported estimates, so you do not need to
set this option to import estimates.
5 When you import estimate information, the software looks at the Estimating description for cost units and
compares it to the Job Cost description for cost units. If the two descriptions do not match, the Override
CUD: Reject if different Cost Unit Description check box controls how the software responds.
Verify that this check box is selected or cleared, as appropriate for your needs.

To read more information about this setting:
1 Select Help > Help Topics > Search.
Note: If necessary, complete the Setup Wizard using Maximize search capabilities.
2 On the Search tab, for step 1, type import cost unit.
3 For step 3, select the box for “About importing the cost unit description.”
4 Click [Display].
You may also want to read the help about the Reject if different Cost Unit Description check box.
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Preparing Estimating to send estimates
For detailed information about Estimating concepts, see Help in Estimating.
To successfully send estimate information from Estimating to Job Cost, in Estimating you must verify that
four settings are set appropriately for your company:
n

Database settings

n

Database phase settings

n

Database item settings

n

Database addon settings
Note: Any changes you make to these settings do not affect phases, items, or addons for estimates that
already exist. You must change phases, items, and addons individually for each estimate that already
exists if you want those estimates to reflect the new settings.

Verify database settings
To verify the database settings:
1 In Estimating, select Database > Database Settings > Company.
2 In the Company Folder area, verify that the listed path goes to your Sage 300 Construction and Real
Estate accounting data folder.
3 Click the Job Cost tab.
To interface with Job Cost:
1 For Job cost interface type, verify that Sage Timberline Office is selected.
Note: To change the interface type from a previously selected option to Sage Timberline Office, you
must use Estimating Tools to make the change.
2 Select the Use Sage Timberline Office Job Cost data check box. Once selected, the information
displayed on the Job Cost tab updates to reflect the job and cost code formats for the Company Folder
listed on the Company tab.
3 Type the path for the estimating transaction file, the .jce file that Estimating creates, in the Specify the
default folder for storing transaction files field.
4 Select the Transfer crew units as man hours check box if you want to convert the crew units to hours for
tracking labor and equipment in the estimate. If you want to keep the crew units the same between
Estimating and Job Cost, clear this check box. For more information about this check box’s function, use
What’s This? Help.
5 Click [OK] when you are finished.
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Verify database phase settings
Both Estimating and Job Cost use the concept of phases. In Job Cost, phases are often called cost codes. It
is possible that the phase structure used in Estimating is not the same as the cost code structure used in Job
Cost. Using the Database Phase window, you tell the software how you want the two structures to align. In
essence, you create a map for the software to use when you transfer data from a phase in Estimating to a cost
code in Job Cost.
To verify database phase settings:
1 In Estimating, select Database > Phases. The Database Phase window opens.
2 Click
(the list button located to the right of Job cost phase) to select the Estimating phase to be
mapped to a cost code in Job Cost. The Database Phase List window opens. If you don’t see the correct
phases, click [Refresh].
3 Double-click on the desired phase. You are returned to the Database Phase window. The selected Phase,
its Description, Unit description, and any previously selected Job cost phase prefill in the Database
Phase window. You can use the same Job Cost phase number for many different estimating phases.
4 Click [Close] when you are finished.

Verify database item settings
The Database Item window is where you define the Job Cost phase and Job Cost Category to use with the
item, and specify which quantity to send to Job Cost.
To verify database item settings
1 In Estimating, select Database > Items and then click the Job Cost tab.
The information you enter here creates a map for the software to use when you transfer information from
Estimating to Job Cost. For each item in the database, you can select a Job Cost Phase (remember, in the
Job Cost application, phases are often referred to as cost codes) and a Job Cost Category. When
Estimating sends this estimating item to Job Cost, the item and its associated information appears under
the cost code and category you select in this window.
Note: As with phases, you can use the same Job Cost Phase and Job Cost Category for any
number of estimating items.

2 Click in the Job Cost Phase field, and then click
(the list button). The Database Job Cost Phase
List window opens. If you don’t see the correct phases, click [Refresh].
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3 Locate and double-click the Job Cost phase you want to receive the item information when Estimating
interfaces with Job Cost. When you double-click on an item, the Database Job Cost Phase List window
closes and you are returned to the Database Item window. The Job Cost phase you selected appears in
the Job Cost Phase field.
You can also manually enter a phase. Be sure to follow the format set up in Job Cost, punctuation included.
If the phase does not exist in Job Cost, you can create it during the import if you select the Allow creation
of Cost Codes not on standard Cost Code list check box on the Import Estimates - Print Selection
window in Job Cost (Tools > Import > Estimates).
4 For Job Cost Category, select the category to receive the Estimating item information.
You can also manually enter a category. The category must already exist in Job Cost.
Be sure to select Job Cost Category, not the database item Category (which is used for pricing and
does not have any impact on the Job Cost interface).
5 For Qty to Job Cost, select the item quantity to send to the selected Job Cost category. Your cost
accounting needs should dictate which of the following options to choose:
p

Takeoff qty – sends to Job Cost the takeoff item quantity for the category.

p

Order qty – sends to Job Cost the order item quantity for the category.

p

None – sends to Job Cost the total dollar amount for the job cost phase and job cost category. It does
not send quantities, so the unit price field in Job Cost will be blank.

6 When you are done, click [OK] and [Close].
Note: You can also make changes to the Job Cost phase and category from the estimating spreadsheet
itself.

Verify database addon settings
To view the database addon settings:
1 In Estimating, select Database > Addons, and then click [Job Cost].
2 Select the Allocatable check box to make an addon cost eligible* for allocation when the transaction file is
sent to Job Cost.
* To actually allocate the addon, in Step 2 of the Job Cost Transfer Wizard, select Yes for the Allocate
addons? option.
To send the addon costs to a specific Job Cost cost code and category, click [Job Cost] and select the
Job cost phase and Category to receive the addon information.
Tip:
To get additional information about this setting, see the online help:
1 In Estimating, select Help > Help Topics, and click the Index pane.
2 Type addons.
3 Select the “Allocating” topic.
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Creating an estimating transaction file
Note: See the online help for each item in the wizard.

A. Create the transaction file in Estimating:
1 In Estimating, select Interface > Job Cost. The Job Cost Transfer Wizard opens. The wizard creates a
.jce file with a transaction for:
p
p

p

Each phase for which you have entered a phase quantity in the spreadsheet.
Each item category with an amount. The item setup determines whether the transaction includes the
takeoff quantity or order quantity.
Each addon that is not allocated. The cost of allocated addons is found in the items used to calculate
those addons.

To progress through each step of the wizard, click the tab at the top of the Job Cost Transfer Wizard
window.
2 Click the Step 1 tab.

B. On the Step 1 tab:
1 Enter a transaction file name and the date to appear on the transactions contained within the transaction
file.
2 The Sage Timberline Office JC job number prefills based on the information entered for Job Cost job
number in Takeoff > Estimate Information > WBE & Misc. In needed, you can enter a job number
(using the correct punctuation) for a job that already exists in Job Cost—or click
select a job.

(the list button) and

Note: If you selected Use Sage Timberline Office Job Cost data (Database > Database Settings
> Job Cost) and in Step 1 you enter a job number that does not exist in Job Cost, when you click the
Step 2 tab, you receive the Save Changes? message. Click [Yes] to advance to the Step 2 tab or
[No] to stay on the Step 1 tab and enter a different job number.
3 Enter the path to the folder that you want to receive the .jce file this wizard creates. If you do not enter a
path for the transaction file folder, the file is created in the Export folder specified in Database > Database
Settings > Job Cost.
4 Click the Step 2 tab.

C: On the Step 2 tab:
1 Select how you want item quantities to be rounded and how to allocate addons.
2 Click the Step 3 tab.
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D. On the Step 3 tab:
Note: If you do not use extras in Job Cost, you do not need to do anything on this tab.
Select whether you want to map estimate information to Job Cost extras and, if so, select which information
do you want to use.
In Job Cost, extras are sub-jobs of the main job. Extras allow you to track cost, revenue, and commitments
separately from the main job, while still being able to accumulate to the main job.
Some reasons you might need to use extras in Job Cost are:
n

The owner or architect requested additional work after the original contract was signed.

n

You must track income from certain cost codes separately from the main job.

n

Certain costs are billed and tracked separately from the main job.
Tip:
In Job Cost, you can change the term used for “extra” by changing custom descriptions. For information,
see the Job Cost online help:
1 In Job Cost, select Help > Help Topics, and click the Index pane.
2 Type custom descriptions, specifying.
3 Click [Display].

To attach information from a work breakdown structure or location to an item as an extra:
1 Select the Map estimate information to extras in Job Cost check box. The selected work breakdown
structure or location information you will select in step 3 then goes to Job Cost as an extra.
Each item is mapped to a specific cost code and category in Job Cost using Database > Items. The
mapping you enter on the Step 3 tab sends a location or work breakdown structure (WBS) code to Job Cost
as an extra.
In Estimating, WBS codes enable you to attach additional information to each item. Each WBS code has
values underneath it. For example, if you had a WBS code of CSI Phase, the values underneath that WBS
code might be field supervision, project administration, safety coordination, etc.
In Job Cost, the Extra ID field is limited to 10 characters. If your Estimating WBS codes contain more than
10 characters, they are truncated to 10 characters when you import them into Job Cost.
Additionally, you can use a location to relate an item to a specific job area. For example, if you build an
office, you might want to assign one item to the first floor and another item to the second floor.
2 For Sort Level, select the WBS code or location to send to Job Cost as an extra.
3 When you the If you choose a sort level, non-allocatable add-ons will not be exported. Choose
cancel to export all. warning, you can click [Cancel] if you want all addons included in the export.
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4 If you select a WBS code for the Sort Level, the WBS Value Selection area becomes available.
Note: If you selected Location as the Sort Level, the name of this area is Location Selection. Its
function is the same no matter which Sort Level you select.
5 Under WBS Value Selection, choose whether to send all WBS values to Job Cost or only selected WBS
Values.
6 Click the Step 4 tab.

On the Step 4 tab:
1 Select a report destination if you want the wizard to produce a report that lists job cost phases, units, and
amounts included in the transaction file.
2 Select the Automatically launch Job Cost check box if you would like to have the wizard automatically
open the Job Cost Import Estimates window after you start to generate transactions.
3 Click [Generate Transactions] to create the transaction file.
If you did not select the Automatically launch Job Cost check box, when the Generate Transactions
process completes the transfer wizard closes.
If you selected the Automatically launch Job Cost check box, the Select Company window opens.
4 Choose which data folder is to receive the transaction file and click [OK]. The Import Estimates – Print
Selection window opens.
Proceed to the next section for information about how to bring the exported estimate file in to Job Cost.

Receiving estimate transactions into Job Cost
To bring the .jce file from Estimating into Job Cost:
1 In Job Cost, select Tools > Import > Estimates. The Import Estimates – Print Selection window
opens.
Note: If you selected the Automatically launch Job Cost check box when you were in the interface
wizard, this window opens automatically after you click [Generate Transactions] and select a data
folder.
2 Verify that Import file contains the path to the file you want to import. If you selected Estimating’s
Automatically launch Job Cost check box, the Import file field prefills with the name of the exported
file.
However, if you did not select Estimating’s Automatically launch Job Cost check box, the Import file
field prefills with the name of the last imported file.
You can also type the path to the file you want to import, or click

(the browse button) to locate the file.

3 For Rejected records file, enter a path and file name to hold any records that are rejected during the import
process. Examples of things that cause record rejections are when you:
p

Do not have security permissions to access the job contained in the import file.

p

Try to import a category that is not on the standard category list.
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4 Select the Allow creation of Cost Codes not on standard Cost Code list check box if you want the
software to automatically create cost codes contained in the import file but not currently found in Job Cost’s
standard cost code list.
The job ID and description appear in the Estimate will be applied to: Job fields. If the job does not exist in
Job Cost, it can be created if the operator has security permission to set up jobs in Job Cost.
p

p
p

p

If the import file contains data for a single job and a single extra, the extra ID and description appear in
the Estimate will be applied to: Extra fields. If the extra does not exist in Job Cost, it can be created if
the operator has security permission to set up extras in Job Cost.
If you do not use extras in Job Cost, the Extra fields do not appear in the window.
If the import file contains data for multiple extras, the Estimate will be applied to Extra fields are
unavailable and their corresponding descriptions display Extra specified in import file.
Additionally, if you want to map the information in the import file to a specific extra, you can type that
extra in the Estimate will be applied to: Extra field. If the extra does not exist in Job Cost, it can be
created if the operator has security permission to set up extras in Job Cost.

5 Click [Add Job] to add to or change job information contained in the import file. Information entered in the
Add Job window overwrites the corresponding information in the import file.
6 Click [Printer Setup]. The Printer Setup – Import Estimates window appears.
7 Select Print to file.
8 Click [OK]. The Import Estimates – Print Selection window appears.
9 Verify the information in the window is correct.
10 Click [Start]. The Print File Selection – Import Estimates window opens.
11 Type a file name in the File name field.
Note: If you are using security, you may want to send this file to a folder that requires security in order
to access it.
12 Click [Save].
13 Once the import process is underway, click the Background Tasks icon on the menu bar to see whether
the import finishes normally. Even if the import finishes normally, that does not guarantee there were no
errors.
14 Examine the journal generated by Import Estimates.

To locate the Import Estimates journal:
1 From the Job Cost File menu, select Printouts.
2 Navigate to the file you created in the previous procedure.
3 Double-click on the file name to open the file.
The journal shows records that were added or created, transactions that were created, any records that
rejected during import, and the reason for the rejection. If the journal shows rejected records, correct the
errors, then import the reject file.
Tip:
To get additional help for how to correct errors that occur during the import:
1 In Job Cost, select Help > Help Topics.
2 On the Index tab, type correcting errors, import estimates.
Sage 300
Construction
and Real Estate Version 16.1 User's Guide
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To view the new transactions:
1 In Job Cost, select Inquiry > Entries > Cost/Estimate Entries.
2 Select New.
3 Click [OK].
4 Click [Go to].
5 Enter the job number.
6 Click [Transactions].
Note: Imported estimate transactions always go into the New.jct file, regardless of whether Job Cost is
set up to post automatically. To move the transactions to the Current.jct and Master.jcm, post the
transactions using Tasks > Post Entries in Job Cost.

Recommendations for a trouble-free interface
To help ensure a smooth data transfer between Estimating and Job Cost, follow these guidelines:

Job Cost
Before you create the transaction file in Estimating, ensure that in Job Cost:
n

n

n

n

Standard cost codes exist for each cost code contained in the import file sent from Estimating.
If you use categories, standard categories exist for each category contained in the import file sent from
Estimating.
The import settings in JC Settings (File > Company Settings > JC Settings > [Import]) are set
correctly for your company.
The operator doing the import has security permission in Job Cost to set up jobs and extras, if you track
extras.
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Estimating
Before you create an estimate to send to Job Cost, make sure the database settings for phases, items, and
addons are set up correctly for your needs. Any changes made to these settings after an estimate is created
do not affect existing phases, items, or addons. Existing phases, items, and addons must be changed
individually if you want the new settings to be reflected in the transaction file.
Before you create the transaction file to send to Job Cost, ensure that:
n

Database Settings are set to Job cost interface type: Sage Timberline Office and the Use Sage
Timberline Office Job Cost data check box is selected.

n

Database Phase settings are mapped to the desired Job cost phase.

n

Database Item settings are mapped to the desired Job Cost Phase and Job Cost Category.

n

Database Addon settings are mapped to the correct Job Cost Phase and Category.

n

Each step of the Job Cost Transfer Wizard is configured the way you need it.

n

The BOM description for the items are 30 characters or less. Job Cost can only accept up to 30
characters for the bill of materials description. To change the description, open Buyout, select the item in
the Items window, and then click

(the Display Item Detail button).

Troubleshooting
Several common error messages are listed below, along with the resolutions to correct the error’s cause.

This job exists only in Project Management (not in Job Cost).
The Project Management application can create jobs that the Job Cost application cannot access.
To correct the situation, in Project Management, select the Create JC Job check box on the job (in PJ: Setup
> Jobs) and reimport the estimate.

Cannot add cost code. Standard cost code not found.
To correct the situation, in Job Cost add the cost code to the standard cost code list using JC: Setup >
Standard Cost Codes or in the Import Estimates – Print Selection window select the Allow creation of
Cost Codes not on the standard Cost Code list check box.

Different cost unit description on Cost Code.
This situation can occur when the file being imported into Job Cost contains a different cost unit description
from what Job Cost uses and the check box for Override CUD: Reject if different Cost Unit Description
(JC: File > Company Settings > JC Settings > [Import]) is selected.
One way to correct the situation is clear the check box for Override CUD: Reject if different Cost Unit
Description (JC: File > Company Settings > JC Settings > [Import]) and import the reject file. To learn
about what will happen as a result of this approach, read the Help topic titled “About importing the cost unit
description.”
Another way to correct the situation is to determine which cost unit description you want to use, the one in
Estimating or the one in Job Cost, and change cost unit description in the other application.
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Importing estimates into Project Management
Project Management change requests are used to capture details about changes in scope, price, and cost.
Often, estimates are created to budget for these changes. You can easily import an Estimating estimate into a
Project Management change request, saving time and reducing errors.
You can select an existing estimate to import, open and edit an existing estimate before import, or create a
new estimate to import.
During the import, the extra, cost code, category, and unit description will be validated. You will be given the
opportunity to make corrections during the import for the extra, cost code, or category. These changes are
automatically written back to the estimate. Unit description errors require additional review. See “Import
validation” on page 133 for more information.
You can import an estimate into a change request multiple times, but only changes and new items are added.
All item information on the change request is removed and replaced with the information from the imported
estimate.
Note: Always open the estimate from the change request to make changes, or make your changes to the
estimate in Estimating and then open the estimate from the change request. If you make changes on the
change request but not the estimate, these will not be reflected in the estimate and will be lost if you later
import the estimate back into the change request.

Import an estimate into a change request
1 In Project Management, create the change request to which the estimate will be imported (Contract
Control > Change Request).
2 Select the Price/Cost Estimate tab.
3 Click [Estimate Change Request] and select the appropriate option:
p
p

p

Create New Estimate: Create a new estimate which can then be imported into a change request.
Open Existing Estimate: View and edit an existing estimate in Estimating prior to importing it into the
change request. Or, if you have already imported the estimate into the change request, you can open the
imported estimate to view or make changes. The import removes and replaces existing item information
on the change request.
Select Existing Estimate: Import a selected estimate into the change request.

4 If you create a new estimate or open an existing estimate, you must select Interface > Send to Change
Request in Estimating to start the import process. This option is only available on the Estimating menu if
you have accessed the estimate through the change request.
5 If any issues are found during the import, you can select [Yes] to fix the issues or [No] to cancel the import
and view a list of issues. For more information, see “Import validation” on page 133.
Note: Changes you make to the estimate in Estimating after importing are not automatically reflected on
the change request. To update the estimate information on the change request, you must first open the
change request in Project Management and then click [Estimate Change Request] on the Price/Cost
Estimate tab. This opens the estimate and refreshes the change request with any changes that were
made outside of Project Management.
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Import validation
Import issues
When you import an estimate into a change request, if any of the following issues exist in the estimate, you
will be prompted to correct them:
n

Extra length is too long (it must be 10 characters or less)

n

Cost code format is incorrect

n

Cost code does not exist

n

Category does not exist

If you choose to make corrections, these changes are written back to the estimate. For example, if you
change the length of the extra, this will change the location or WBS values on the estimate.
If you do not choose to fix the import issues, the import stops and issues that were not fixed are displayed.

Unit description
In addition to the issues listed above, the cost unit description on the category in Job Cost must match the
item unit description on the estimate if the estimate is set up to send quantities to Job Cost. If these do not
match, the import will stop. To correct this issue, either:
n

n

Change the unit description on the estimate to match the cost unit description on the category in Job Cost,
or
Change the cost unit description on the category in Job Cost to match the estimate

After you correct the unit description, you can perform the import again.
Note: Ensure that the correct quantity type is being sent to Job Cost. In the Category Detail window of
the estimate, you have the option of sending either the takeoff quantity or the order quantity to Job Cost.
The option you select determines which quantities and unit descriptions are imported. To view the
Category Detail window, on the estimate, right-click and select Detail Window, then on the Extensions
tab, right-click and select Category Detail.

Commitment processing
You can transfer commitment information from Buyout to Purchasing or from Buyout to Job Cost. If you send
the commitment information from Buyout to Purchasing, Purchasing can send that commitment information
on to Job Cost.
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The Buyout to Purchasing or Job Cost interface
Estimating information is sent from Estimating to Buyout. In Buyout, once you have selected vendors and
subcontractors for commitments, you can send the commitment information to Purchasing or to Job Cost.
If you send commitments to Purchasing, Buyout creates a text file (.txt) for Purchasing to import. If desired,
you can then have Purchasing send the commitments on to Job Cost.
If you send commitments directly to Job Cost, Buyout creates a Job Cost commitment file (.jcc).

Sage 300 Construction and Real Estate Version 16.1 User's Guide

Page 134

Chapter 9: Estimating to Accounting Integration

Preparing Purchasing to receive commitments
To prepare Purchasing to receive commitments, verify that the File Locations setting for Location of Export
file is appropriate for your company.
To verify Purchasing’s File Locations setting:
1 In Purchasing, select File > Data Folder Settings > File Locations.
2 Verify that the path for Location of Export file is correct for your company. The field prefills with the
location of your Sage 300 Construction and Real Estate data.

Preparing Job Cost to receive commitments
For detailed information about Job Cost concepts, see Job Cost Help.
To prepare Job Cost to receive commitments, whether from Buyout or from Purchasing, verify that Job Cost’s
import settings are set appropriately for your company.

Verify import settings
To verify Job Cost’s import settings:
1 In Job Cost, select File > Data Folder Settings > JC Settings > [Import].
2 Select the Allow override of default options check box if you want the person who imports the
commitments to have the ability to cancel the settings marked in this window for Warning response and
Commit method.
3 Select the Warning response appropriate for your company. The Warning response options let you
affect how the software responds if the contents of the import file generate a warning during the import.
Situations that would produce a warning during import include:
p

p

The imported commitment contains a category that has already been marked as Bought Out in Job
Cost.
The amount on the imported commitment causes the total amount committed to exceed the estimate.

The Warning Response setting has no effect when a record generates an error. A record that generates an
error rejects during the import process.
4 Select the Commit method appropriate for your company. The Commit method options let you determine
how the software responds to the status on the commitment record. All commitment records in the import
file have a status of either Yes (they are committed in Job Cost), or No (they are not committed in Job
Cost). After you import the commitments, you can change their status.
In the Commit method area, you can select to:
p
p

p

Never commit the commitment in Job Cost, regardless of its status in the import file.
Allow the software to commit or not commit the commitment in Job Cost, based on the commitment’s
status in the import file.
Automatically commit valid commitments in Job Cost as they are imported.

Note: If Sage 300 Construction and Real Estate security is active, imported commitments are
automatically released to accounting.
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Preparing Buyout to send commitments
For detailed information about Buyout concepts, see the online help in Buyout.
In Buyout, once you select a vendor for a quote sheet or issue a purchase order for a quote sheet, you can
send commitment information to Purchasing or Job Cost.
Before you send commitment information to either Purchasing or Job Cost, you need to verify that:
n

n

Buyout’s database settings for company setup, Job Cost setup, and tax setup are appropriate for your
company.
Buyout’s option for how purchase order numbers increment is set appropriately for your company.

Verify the company setup
The company folder assigned on this tab determines where Buyout gets its Address Book, Job Cost, and
other information.
To verify the company setup:
1 In Buyout, select Database > Database Settings > Company Setup.
2 In the Company Folder area, verify that the displayed path reflects the company folder you want to use
with Buyout or click [Select] to locate the correct company folder.

Verify the Job Cost setup
The Job Cost Setup window allows you to set up the interface between Buyout and Job Cost.
To verify the Job Cost setup:
1 In Buyout, select Database > Database Settings > Company Setup > [Job Cost Setup].
2 Verify that the Job cost interface type is set to Timberline.
3 Verify that Setup Options is set to Use Timberline Job Cost data. When you select this option, Buyout
brings in from the Job Cost application the format for the job number and cost code. To see the format, click
[View Sections].
4 Verify that the Select the application that commitments will be exported to field reflects the
application you plan to export to, either Job Cost or PO/IV. The export process creates a slightly different
file based on what you select here. For more information on file layouts, see Appendix B.
Tip: Job Cost can import both .jcc and .txt files. If you are going to send purchase orders to both
applications, select PO/IV in the Select the application that commitments will be exported to field.
Then you can bring the exported commitment file in to either Job Cost or Purchasing.
5 Type the path to the folder you want to hold exported commitment files in the Specify the default location
for storing new commitment files field. You can click [Browse] to locate the desired folder.
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Verify the tax setup
If you have tax groups set up in your Accounts Payable application, those tax groups can be used on
purchase orders in Buyout, included in the commitment information, and sent to Purchasing or Job Cost.
Verify your tax setup in the Tax Setup window.
To verify the tax setup:
1 In Buyout, select Database > Database Settings > Company Setup and then click [Tax Setup].
2 The Tax Setup area contains two options. You can select to:
p

Use Timberline tax groups, in which case tax groups from the Accounts Payable application are used
in Buyout. Tax groups assigned to items in Buyout go to Purchasing or Job Cost when you export
commitments.
Note: Only the tax group is included in the export file, not the tax rate or calculated tax amount. Job
Cost and Purchasing calculate the tax amount based on the tax group specified on the item.

p

Use User-defined tax groups, in which case the tax groups are created and used only in Buyout. Userdefined tax groups are not included in the export file.

3 The Default tax group for new work files lets you define the tax group used for work files created after
you accept this setting.
For more information about tax groups, from the Help menu, select Help Topics > Index and type tax
groups.
Once you set up the Job Cost and tax settings, Buyout is ready to send commitment information to
Purchasing or Job Cost.
Note: If you are using the Inventory application and want to take advantage of inventory codes that come
into Buyout from Estimating, you must set up the Price Code in Estimating to contain the appropriate
inventory code in the Price Code field.

Verify Buyout’s options
To verify Buyout’s options:
1 In Buyout, select Edit > Options.
2 Click the Miscellaneous tab.
3 In the PO Numbers area, select or clear the Auto-increment purchase orders when issuing check box,
as appropriate for your company.
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Creating a commitment transaction file in Buyout
Using the Export Commitments command in Buyout, you can create commitments from quote sheets that
have a selected vendor or that have been issued as purchase orders.
To create the commitment file in Buyout:
1 Select the quote sheet for which you want to export commitments.
2 From the worksheet view, select Interface > Export Commitments.
Under Quotes to Commit, you will see a list of quote sheets with the status of Selected or Issued. You
can click [List Quotes] to see a complete list of quote sheets with the status Selected or Issued.
Note: Once the commitment is exported, the quote sheet’s status in Buyout changes to Issued.
3 Enter a purchase order number in the PO Number field, if necessary. The PO Number field prefills in one
of three ways:
Quote Sheet Status

Auto-increment check box*

PO Number

Selected

Selected

Prefills, can be changed.

Selected

Cleared

Empty. Must enter PO number manually.

Issued

(irrelevant)

Prefills, cannot be changed.

* The Auto-increment purchase orders when issuing check box is found at BO: Edit > Options >
Miscellaneous.
4 Click the Options tab. Here you can change the export file name and select default settings.
5 The Job Cost commitment file name field prefills with the Buyout work file name, but you can change it.
You may want to manually change the file name if you send out in succession the commitments for a single
job. For example, once the concrete work is bought out for a job, you could create a commitment file named
Lakewood Commons Concrete. When the electrical work is bought out for that same job, you could create
a commitment file named Lakewood Commons Electrical.
Note: If the Select the application that commitments will be exported to field (Database
Settings > Company Setup > [Job Cost Setup]) is set to PO/IV, the name of the Job Cost
commitment file name field is changed to PO/IV commitment file name.
6 The Commitment export folder field prefills with the information provided in the Job Cost Setup window
(Database > Database Settings > Company Setup > [Job Cost Setup] > Specify the default location
for storing new commitment files). You can change the prefilled information.
7 Select the Include piece count check box if you want the piece count to appear on purchase orders.
The piece count is the item quantity expressed in the units by which the vendor sells the item. For example,
lumber is often priced by thousand board feet (mbf) but it is typically sold by piece. If you select the Include
Piece Count check box, when you print the purchase order it includes an extra line for the order’s piece
count.
Buyout calculates the piece count based on the takeoff-to-order unit conversion factor set in Estimating.
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If you include piece counts on the purchase order, Buyout rounds the piece count up to the nearest whole
number and recalculates the order quantity for the purchase order item.
Note: Buyout exports the order quantity shown on the purchase order.
8 Select the Auto-launch Job Cost import after creating the commitment file check box on the Export
Commitments Options tab if you would like the export commitment process to automatically start the
Import Commitments task in Job Cost.
Note: If you set the Select the application that commitments will be exported to field (Database >
Database Settings > Company Setup > [Job Cost Setup]) to PO/IV, the name of the Auto-launch
Job Cost import after creating the commitment file field is changed to Auto-launch Purchasing
import after creating the commitment file.
9 Select the Map workfile information to extras in Job Cost check box in the Job Cost Extra Setup area
if you track extras in Job Cost and want to create an association between Buyout items and Job Cost
extras. If you do not use extras in Job Cost, do not select this check box.
Note: In Job Cost, the Extra ID field is limited to 10 characters. Any sort you select here that has more
than 10 characters is truncated to 10 characters when you import in Job Cost.
In Buyout, you use sort sequences to organize items into different groupings for ease of viewing. The sort
you select here maps items in Buyout to extras in Job Cost.
To learn more about sort sequence set up, from the Buyout Help menu, select Help Topics. Click the
Search tab. Type sort sequence. Select the topic titled “Learn about sort sequences” and click [Display].
Click [Export]. When the export file has been created, the Export Complete message appears.
10 Click [OK].
If Buyout is configured to send commitments to PO/IV (Database > Database Settings > Company
Setup > [Job Cost Setup]) and you selected the Auto-launch Purchasing import after creating the
commitment file check box in the Export Commitments window, the Purchasing Import CSV Orders
window opens.
If Buyout is configured to send commitments to Job Cost (Database > Database Settings > Company
Setup > [Job Cost Setup]) and you selected the Auto-launch Job Cost import after creating the
commitment file check box in the Export Commitments window, the Job Cost Import Commitments
– Print Selection window opens.
Proceed to the next section for information on how to bring the exported commitment file in to Purchasing.
If you do not use the Purchasing application, turn to “Receiving the Buyout or Purchasing commitment
transaction file Into Job Cost,” on page 142 for information on how to bring the exported commitment file into
Job Cost.

Receiving a commitment transaction file Into Purchasing
Note: If you do not interface with the Purchasing application, proceed to “Receiving the Buyout or
Purchasing commitment transaction file Into Job Cost,” on page 142.
For detailed information about Purchasing concepts, see the online help in Purchasing.
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To import the Buyout commitment .txt file into Purchasing:
1 In Purchasing, select Tools > Import Orders. The Import CSV Orders window opens.
Alternately, if you selected the Auto-launch Purchasing import after creating the commitment file
check box when you were in the Buyout Export Commitments window, the Import CSV Orders window
opens automatically after you click [Export] and click [OK] to the Export Complete message.
2 In the Import File field, type the path to the file you want to import, or click
locate the file.

(the browse button) to

3 In the PO Number Assignment area, select whether to have the Purchasing application assign new
purchase order numbers to incoming POs or use the purchase order numbers from the import file.
Note: Purchasing does not allow duplicate purchase order numbers. If you select the Assign new
purchase order numbers option, imported Buyout commitments are renumbered in Purchasing. This
prevents import rejections caused by duplicate purchase order numbers.
4 Purchase orders are imported into Purchasing with a Pending status unless you select the Automatically
Commit check box in the Import CSV Orders window. If you do not select this check box, imported
commitments must be committed before you send them to Job Cost.
5 Click [Import]. A message tells you how many valid and rejected purchase orders are in the selected
export file and asks you to confirm the export’s completion.
6 Click [Yes], if you choose to continue.
7 When you see the Finished importing records message, click [OK].
8 Click [Print] to print the import journal.
If any records reject, you can edit the file.

To edit the rejected records file:
1 From the Import CSV Orders window, click [Rejects]. This opens the rejects.txt file where you can edit
the invalid records.
2 Make any necessary changes.
3 After you complete your changes to the rejects.txt file, click [Save] and then [Close].
4 Run the import process again and select the rejects.txt file as the file to import.

To change the commitment’s status
1 In Purchasing, select Tasks > Process Pending Orders. The Document Selection window appears.
2 For User ID, select the desired User ID if you are using the Extended Approval system—or leave the User
ID blank.
If you are not using the Extended Approval system, leave the User ID blank.
3 Select All Uncommitted Orders.
4 Click [OK]. The Process Pending Orders window appears.
5 Select the Commit? check box next to the commitments you want to commit.
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Note: You can also use PO: Tasks > Enter Orders to commit commitments one at a time.
6 Click [Process Selected] when all of the commitments to commit are selected.
7 Click [Finish].

Preparing Purchasing to send commitments
To successfully transfer commitment information from Purchasing to Job Cost, in Purchasing you must verify
that two things in File Locations are set appropriately for your company:
n

The Auto Import after Sending setting.

n

The location entered in the Export file setting.

To access Purchasing’s File Locations window:
1 In Purchasing, select File > Data Folder Settings > File Locations.
2 Select the Auto Import after Sending check box to have Purchasing automatically open the Job Cost
Import Commitments – Print Selection window after you start the Send Orders to Job Cost process.
If you clear this check box, the first time you send commitments the Auto Import window will ask you if
you would like to enable the auto import function. Select [Enable] or [Cancel] as appropriate for your
company.
3 The Location of Export file field prefills from the information you entered in PO: File > Data Folder
Settings > File Locations. You may also type the path to the folder you want to hold exported
commitment files.
4 Click [OK] to close the Data Folder Settings window.

Creating a commitment transaction file in Purchasing
To post committed purchase orders from Purchasing to Job Cost:
1 In Purchasing, select Tasks > Post Orders to Job Cost. The Send Purchase Orders to Job Cost
window opens.
2 Select or clear the Send Orders as Committed check box as appropriate for your company.
3 The Destination prefills from the information you entered in PO: File > Data Folder Settings > File
Locations. You may also type a different path or click
the exported file.

(the browse button) to locate the folder to hold

4 Click [Post].
5 Click [Yes] in the Confirm window.
If you selected Auto Import after Sending in File > Data Folder Settings > File Locations, Job Cost’s
Import Commitments – Print Selection window opens.
Proceed to the next section for information on how to bring the exported commitment file into Job Cost.
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Receiving the Buyout or Purchasing commitment transaction file Into
Job Cost
Whether you import commitments from Buyout or Purchasing, the procedure in Job Cost is the same:
Note: If Sage 300 Construction and Real Estate security is active, imported commitments are
automatically released to accounting.

To import commitments:
1 In Job Cost, select Tools > Import > Commitments. The Import Commitment – Print Selection
window appears.
Alternately, if you selected Buyout’s Auto-launch Job Cost import after creating the commitment file
check box (Buyout: Interface > Export Commitments > Options) or Purchasing’s Auto Import after
Sending check box (Purchasing: File > Data Folder Settings > File Locations), the Import
Commitment – Print Selection window appears automatically.
2 Verify that the Import file field contains the path to the file you want to import.
p

p

If you selected Buyout’s Auto-launch Job Cost import after creating the commitment file check
box or Purchasing’s Auto Import after Sending check box, the Import file field prefills with the name
of the exported file. If the commitment file comes from Purchasing, the file name will be Jccommit.txt.
However, if you did not select Buyout’s Auto-launch Job Cost import after creating the
commitment file check box or Purchasing’s Auto Import after Sending check box, the Import file
field prefills with the name of the last imported file.

You can also type the path to the file you want to import, or click

(the browse button) to locate the file.

3 For the Rejected records file, type a path and file name to hold any records that are rejected during the
import process. Examples of things that cause record rejections are when:
p

You do not have security permissions to access the job contained in the import file.

p

The job is not set up in Job Cost.

4 Click [Options] if you need to override the Warning Response or Commit Method settings (File > Data
Folder Settings > JC Settings > [Import]) and you selected Allow override of default options (File >
Data Folder Settings > JC Settings > [Import]).
5 Click [OK] when done. The Import Commitment – Print Selection window appears.
6 Click [Printer Setup]. The Printer Setup – Import Commitments Journal window appears.
7 Mark Print to file.
8 Click [OK]. The Import Commitments – Print Selection window appears.
9 Click [Start]. The Print File Selection – Import Commitments Journal window appears.
10 Enter a file name.
11 Click [Save].
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12 Once the export process is underway, click the Background Tasks icon on the menu bar to see whether
the import finishes normally. Even if the import finishes normally, that does not guarantee there were no
errors.
13 Examine the journal generated by Import Commitments.

To locate the import commitments journal:
1 From the File menu, select Printouts.
2 Locate the file you created in the previous procedure.
3 Double-click on the file name to open the file.
The journal shows any records rejected during import and the reason for the rejection. If you find rejected
records, correct the indicated errors, then import the reject file.
Caution! If you import a Buyout commitment file which contains a purchase order number Job Cost
already uses, Job Cost rejects the commitment itself but the commitment items are appended to the
purchase order that exists in Job Cost. This occurs because Buyout does not number commitment items.
(Purchasing does number commitment items.)
Thus, purchase orders that come from Buyout into Job Cost behave as though they are blanket purchase
orders.
When exporting commitments from Buyout, be very careful you do not use a purchase order number that
already exists in Job Cost.

Tip:
To get additional help for how to correct errors that occur during the import:
1 In Job Cost, select Help > Help Topics.
2 On the Index tab, type correcting errors, import commitments.
3 Click [Display].
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To view the new transactions in Job Cost:
1 Select Inquiry > Entries > Cost/Estimate Entries.
2 Select New.
3 Click [Go to] and enter the job number.
4 Click [Transactions]. All of the commitment information contained in the import file displays.
Note: If commitments are committed during the Import Commitments process, such as when the
Commit method (File > Data Folder Settings > JC Settings > [Import]) is set to Determined by
record or Auto commit, the transactions always go into the New.jct file and the commitment record is
created in the Master.jcm, regardless of whether Job Cost is set to post automatically. To move the
transactions from the New.jct to the Current.jct, post them in Job Cost using Tasks > Post Entries.

Recommendations for a trouble-free interface
To help ensure a smooth data transfer between Estimating, Buyout, Purchasing, and Job Cost, follow these
guidelines:

Estimating
p

Reserve a bank of purchase order numbers for your project. This ensures unique purchase order
numbers are sent to Purchasing and Job Cost.

Buyout
p

Ensure that Buyout’s quote summary names contain no more than 30 characters.

p

Ensure that Buyout’s vendor item descriptions contain no more than 30 characters.

p

p

Ensure that if you select to send a Buyout Sort to Job Cost as an extra (Interface > Export
Commitments > [Options] > Job Cost Extra Setup), the sort name contains no more than 10
characters. In Job Cost, the extra ID is limited to 10 characters. A sort name containing more than 10
characters is truncated to 10 characters in Job Cost.
When Buyout interfaces with Purchasing, the price code (which comes from Estimating into Buyout)
translates to the inventory item code in Purchasing. If your Estimating staff members use the price code
field to track something unrelated to inventory, you must come to an agreement with them on how to use
this field in the future.

Purchasing
p

Ensure all purchase order numbers are unique across Buyout, Purchasing, and Job Cost.

Job Cost
p

When Buyout sends commitment information to Job Cost, the amount field is blank for non-lump-sum
items. Job Cost calculates the amount by multiplying the quote item quantity by the quote item price.
However, for lump-sum items, the amount is included in the export file so that the amount in Buyout
always matches the resulting amount in Job Cost.

Address Book
p

Ensure all companies are set up as Estimating and Accounts Payable vendors in Address Book.
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Troubleshooting
A common import error message is listed below, along with the resolution to correct the error’s cause.

This job exists only in Project Management (not in Job Cost).
The Project Management application can create jobs that the Job Cost application cannot access.
To correct the situation, in Project Management, select the Create JC Job check box on the job (in PJ: Setup
> Jobs) and reimport the estimate.

File layouts
This section contains detailed information about the file layouts for the .jce file Estimating creates, the .jcc
and .txt files Buyout creates, and the .txt file format needed for Purchasing to successfully import.

Estimating transaction file layout
If you open the .jce file that Estimating’s Job Cost Transfer Wizard creates, you see something that looks
like this:
p

The asterisk at the beginning of the file indicates the start of a job record.

p

The next character, the comma, is used to separate each field in the record.

p

The field following the comma is the job number.

p

The next field is the job description, and so on.

On subsequent lines, the P indicates the start of a phase record, the C indicates the start of a category record,
and the E indicates the start of an extra record.

Viewing a list of fields contained in the estimating transaction file
In Job Cost Help, you can see a list of fields contained in the estimate transaction file:
1 In Job Cost, select Help > Help Topics.
2 On the Index tab, type importing, estimate file.
3 Click [Display].
4 Click the button next to each record to see the exact file layout.
In Estimating Help, you can also find a list of fields contained in the transaction file:
1 In Estimating , select Help > Help Topics.
2 On the Index tab, type transaction files for job cost.
3 Click [Display].
4 Select Transaction file for Sage 300 Construction and Real Estate.
5 Click [Display].
6 Click [job], [phase], or [category], as needed.
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Commitment transaction file layout
If you open the commitment file that Buyout creates, whether the file is a .jcc file for Job Cost or a .txt file for
Purchasing, you see something that looks like this:
p

The C at the beginning of the file indicates the start of a Commitment record.

p

The next character, a comma, is used to separate each field in the record.

p

The field following the comma is the purchase order number.

p

On subsequent lines, the CI indicates the start of a commitment item record.

The only difference between the two types of export files Buyout creates is found in field 21 of the export file.
Into the 21st field of the .txt file for Purchasing, the software embeds a price code for each item. The price
code comes into Buyout from Estimating. Not all items have price codes, so this field does not have to
contain a value in order for the file to successfully import.
Caution! The Estimating price code information is used in Purchasing as the inventory number. Please
check with your estimating staff to ensure they have set up the price code fields appropriately.
Also, when Purchasing takes in an export file, it appends numbers to each commitment item. So, when
sending data on to Job Cost, the JC Commit.txt file contains commitment item line numbers that the .jcc file
does not.

To see a list of fields contained in the commitment transaction file
1 In Buyout, select Help > Help topics.
2 On the Index tab, type commitments, commitment file format.
3 Select commitment file format.
4 Click [Display].
5 Click Commitment record details and Commitment item record details.
Note: Be sure to note the maximum size limits for each field. The quote summary name is limited to 30
characters, as is the vendor item description. Information that exceeds the maximum size limit for a field
is truncated when you import it to Job Cost. Additionally, any separators that you enter for the job number
or cost code are stripped out during the export process.
In Purchasing, you can find a similar list in Help:
1 In Purchasing, select Help > Help Topics.
2 On the Index tab, type importing orders.
3 Click [Display].
4 Select either Commitment Item or Commitment Record.
5 Click [Display].
In Job Cost, you can also see a list of fields contained in the commitment transaction file:
1 In Job Cost, select Help > Help Topics.
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2 On the Index tab, type importing, commitments file.
3 Click [Display].
4 Click the button next to each record to see the exact file layout.
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