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Chapter 1: System Guidance
General
Document Management is an application that electronically stores, organizes, shares, and retrieves your
documents. ASG DocuVault is the database that Document Management uses to store documents.

Develop a Plan to Back Up and Validate Files
We strongly recommend that you use third-party software to back up the entire DocuVault database and
selected Document Management program files to external media on a daily basis. Do not perform
incremental backups. Incremental backups will not work due to the nature of the DocuVault database.
We strongly recommend routinely validating the state of your DocuVault using the validate command.
NOTE: For information about backing up Sage Timberline Office, see the Technical System
Reference for Accounting and Management Products 9.8 and Estimating Products 9.8 located in the
Sage Timberline Desktop Tasks pane under Tasks > Sage Timberline Office > Sage Timberline
Office Documents > TechnicalSystemReference.
Consider the following requirements as you develop your backup plan:
n

n

n

n

n

n

n

Choose between a manual or automated backup process. For more information about manual and
automated backup processes, see “Backing Up Document Management” on page 22.
Verify that your backup software supports the wildcard character (*).
Verify that when a folder is included in a backup, the backup software also includes the subfolders. In
other words, the backup software should support recursive backups.
Schedule backups during off-peak hours since all users must close Document Management before you
back up the database and program files. When performing a backup, you must also stop the hub service
and put it in offline dump mode.
Always backup the entire DocuVault, including all data files, log files, and the control file. Do not
perform incremental backups.
Review where you store application data and back up all data, even if it is outside default folders. The
default folder paths and files that you want to back up include the following:
p

[Drive]:\TSDV\

p

[Drive]:\Documents and Settings\All Users\Application Data\Sage\

Run all pre-backup, backup, and post-backup commands at the server. If your backup software runs on
a separate server, you may install a backup agent on the server. (For more information about prebackup, backup, and post-backup commands, see “Backing Up With an Automated Backup” on
page 23.
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n

n

n

For an automated backup, verify that the pre-backup, backup, and post-backup commands do not
produce errors. Given the critical role of backup files, you must verify that the return code
(ERRORLEVEL) for all db_prog commands is zero.
Store backup media in a secure location outside your building.
Test backups by restoring them to test folders. These tests are important because backup media may
have a limited life, backup devices may malfunction, and you may have incorrect software settings in
your backup software.
CAUTION: When you test a backup, keep the restored data separate from your production data.

Validating DocuVault Integrity
The DocuVault scan utility allows you to validate the data records and key fields within DocuVault. We
recommend that you run this utility periodically as part of the backup cycle to identify problems as soon as
they occur.

Stop the DocuVault Hub
To see Start Hub and Stop Hub from the Document Management menu, you must log on to the server
as the user who installed Document Management.
1 At the DocuVault server, select [Start] > All Programs > Sage > Sage Timberline Office >
Reporting and Other Tools > Document Management.
NOTE: For operating systems such as Windows Server 2008 that use UAC (User Account Control),
this option must be run as an administrator. To do this, right-click the menu item and select Run as
administrator.
2 Double-click Stop Hub.
3 When the “The Cypress service was stopped successfully” message appears, close the Stop Hub
window.

Scan and Validate DocuVault
1 Click Start > Run.
NOTE: For operating systems such as Windows Server 2008 that use UAC (User Account Control),
this option must be run as an administrator. To do this, right-click the menu item and select Run as
administrator.
2 Type: [Drive]:\TSDV\server\db_prog -scan_dv.
If the validation indicates there is corruption, contact Customer Support.

Start the DocuVault Hub
1 At the DocuVault server, select [Start] > All Programs > Sage > Sage Timberline Office >
Reporting and Other Tools > Document Management.
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NOTE: For operating systems such as Windows Server 2008 that use UAC (User Account Control),
this option must be run as an administrator. To do this, right-click the menu item and select Run as
administrator.
2 Double-click Start Hub.
3 When the “DocuVault READY” message appears, close the db_prog.exe and Start Hub windows.

Assign Full-Control User Rights to All Folders That Contain Document
Management and DocuVault Program Files and Data Files
To use Document Management, users must have full control of the following files and folders on the file
server, terminal server, and workstations that have Document Management installed.
CAUTION: Incorrectly modifying Microsoft Windows security may severely affect your system
operations. Sage is not responsible for operation problems caused by incorrectly modifying your
Microsoft Windows security settings. To set permissions on your network or Windows operating
system, you must have advanced knowledge of your network. Contact your system administrator for
assistance.
All Operating Systems
n

n

[Drive]:\Program Files\Timberline Office folder: This folder is located on the file server, terminal
server, and workstations where you installed Sage Timberline Office. It is the default installation
location for Sage Timberline Office. However, depending on your system configuration, your company
may have renamed this folder or installed it to a different location.
Company data folder: The data folder is located on the file server where you installed Sage Timberline
Office.

Windows XP, Windows Server 2003, and earlier
n

n

[Drive]:\Documents and Settings\[username] folder: This folder is located on the workstation or
terminal server where you use Sage Timberline Office. Sage Timberline Office installs necessary files
to this folder and requires that the user has full control of it. Typically, the user has full control of this
folder by default.
[Drive]:\Documents and Settings\All Users\Application Data\Sage\Timberline Office folder: This
folder is located on the server and on any workstations or terminal server where you install Sage
Timberline Office Accounting and Management programs. This folder must be shared on the server.
Sage Timberline Office installs necessary files to this folder and requires that all users have read/write
permissions to the folder and all of its subfolders. This folder may be hidden.
TIP: To view hidden folders, open Windows Explorer, select Tools > Folder Options, and select
the View hidden files and folders check box on the View tab.

Windows Vista, Windows 7
n

[Drive]:\Users\[username] folder: This folder is located on the workstation or terminal server where
you use Sage Timberline Office. Sage Timberline Office installs necessary files to this folder and
requires that the user has full control of it. Typically, the user has full control of this folder by default.
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n

[Drive]:\ProgramData\Sage\Timberline Office folder: This folder is located on the workstation or
terminal server where you use Sage Timberline Office Accounting and Management programs. This
folder must be shared on the server. Sage Timberline Office installs necessary files to this folder and
requires that all users have read/write permissions to this folder and all of its subfolders. This folder may
be hidden by default.
TIP: To view hidden folders, open Windows Explorer, select Tools > Folder Options, and select
the View hidden files and folders check box on the View tab.

Do Not Actively Scan Program Files and Data Files in Sage Timberline
Office for Viruses
IMPORTANT: Scan these files at a time when they are not in use (for example, schedule a daily
scan overnight).
If you actively scan Sage Timberline Office program files and data files for viruses, you may cause
Document Management to run slowly or to close unexpectedly. Typical folders that contain files that you
should not scan include:
n

Sage Timberline Office program files: [Drive]:\Program Files\Timberline Office

n

DocuVault program files: [Drive]:\TSDV\server

n

Sage Timberline Office data files: [Drive:]\[datafoldername]

n

Document Management data files: [Drive]:\Documents and Settings\All Users\Application
Data\Sage\

Domains
You must install Document Management on a client/server network that is part of a domain and has
domain services provided by a Windows server. A domain consists of a collection of computers on a
Microsoft Windows Server network that share a common domain database and security policy.
Restrictions:
n

You cannot install Document Management on a peer-to-peer network.

n

You cannot install Document Management on a stand-alone computer.

Comply With Windows User Account Control (UAC) Requirements
Sage Timberline Office is designed to work with the Windows User Account Control (UAC) security
scheme. Many Sage Timberline Office folders are stored in a shared location. To ensure Sage Timberline
Office applications work correctly, you must ensure you have read/write permissions to these files.
If you are upgrading Document Management, you do not need to move your files. Ensure you have
read/write permissions assigned to your Document Management and DocuVault folders.
You cannot save a file to a folder to which you do not have read/write permissions assigned. If such an
attempt is made, Sage Timberline Office applications present you with an error message if you try to save
a file to a non-compliant location.
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Windows File Servers and Operating Systems
The DocuVault database can be installed on a 32 or 64-bit server-class operating system. While the
DocuVault database is 64-bit compliant, it does require the Internet Information Services application pool
to function in 32-bit mode. For assistance with configuring IIS, see your system administrator.
IMPORTANT: When DocuVault is installed, it will enable 32-bit applications on the DefaultAppPool
for IIS. IIS 6.0 does not allow for the creation of separate application pools using 32-bit and 64-bit
simultaneously; this will cause an issue if Windows Server 2003 also hosts IIS applications that
require a 64-bit application pool. In these cases the DocuVault must be installed on a separate server
from the server hosting the application requiring the 64-bit application pool. This is not an issue with
IIS 7.0 and later.
If you install DocuVault on Windows Server 2008 and use MS Office 2007 or later, you must configure
DocuVault to run under an administrative user account.
NOTE: Within this document, “Windows Server 2008,” "Windows 7," and "Windows Vista" refer to
all supported editions unless specifically noted.
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Operating System

Minimum
Service
Pack

Windows Server 2008 Enterprise Edition
Windows Server 2008 Standard Edition

DM

DV

SP2

X

X

SP2

X

X

Windows Server 2008 R2

X

X

Windows 7 Professional

X

Windows 7 Ultimate

X

Windows 7 Enterprise

X

Windows Server 2003 Small Business Server R2

SP2

X

X

Windows Server 2003 Enterprise Edition R2

SP2

X

X

Windows Server 2003 Standard Edition R2

SP2

X

X

Windows Vista Business

SP2

X

Windows Vista Ultimate

SP2

X

Windows XP Professional

SP3

X

Document Management is compatible with both 64 and 32-bit versions for all supported operating systems
listed above.

Do Not Use NTFS File Compression on Data or Program Files for
Document Management
Using Microsoft Windows NTFS file system to compress files causes Document Management to run very
slowly.

Terminal Services
Configure Terminal Services to Maintain an Operator’s Session During
Connection Breaks
Configuring Windows Terminal Services to maintain an operator’s session during connection breaks
prevents a program from closing unexpectedly and helps preserve data integrity. To set up this aspect of
Terminal Services, use the Terminal Services Configuration program. For more information, see “Chapter
5: Terminal Services” on page 19.
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Mail Servers
Mail Server Environment
We test Document Management in a Microsoft Exchange Server environment. Document Management
does not support Simple Mail Transfer Protocol (SMTP) and Post Office Protocol (POP).

Windows Workstations
Obtain Full-Control User Rights to All Folders That Contain Document
Management and DocuVault Program Files and Data Files on the Local
Workstation
To use Document Management, you must have full control of specific files and folders on the local
workstation. This is because you must be able to create or modify files in your [Drive]:\Winnt and
[Drive]:\Windows system folders. For more information about required folder rights, see “Assign FullControl User Rights to All Folders That Contain Document Management and DocuVault Program Files
and Data Files” on page 3.

Firewalls
Resolving Firewall Message During Installation of DocuVault
If you receive a firewall warning message during the installation of DocuVault, work with your network
administrator to allow the DocuVault to communicate through your firewall software. For example, if a
Microsoft Windows Firewall Security Alert window appears, confirm with your network administrator
that you wish to proceed. Then, select Unblock this program and click [OK].

Document Management Technical System Reference

Page 7

Chapter 2: Frequently Asked
Questions
Is Document Management 64-bit compliant?
Yes. As of 9.6.1, both Document Management and DocuVault are 64-bit compliant.
While the DocuVault database is 64-bit compliant, it does require the Internet Information Services
application pool to function in 32-bit mode. For assistance with configuring IIS, see your system
administrator.

Can I install DocuVault on a server with Windows Server 2008?
Yes. As of 9.6.1, DocuVault is compatible with Windows Server 2008. For a complete list of compatible
server-class operating systems, see “Windows File Servers and Operating Systems” on page 5.

What rights do I need for Document Management and DocuVault?
To install Document Management and DocuVault, you must have administrator rights.
Unlike other Sage Timberline Office products, you can only open Document Management through Sage
Timberline Desktop. Therefore, you must have the same rights to Document Management that you have
for Sage Timberline Desktop.
To use Document Management, you must have full control of specific files and folders on the local
workstation. This is because you must be able to create or modify files in your [Drive]:\Winnt and
[Drive]:\Windows system folders. For more information, see “Assign Full-Control User Rights to All
Folders That Contain Document Management and DocuVault Program Files and Data Files” on page 3.
You do not need special rights to use DocuVault, because it runs as a service.

Can I install DocuVault to a location other than the Sage Timberline Office server?
Yes, you can install DocuVault to a server with Windows Server 2008 or Windows Server 2003 that is
separate from the server that hosts Sage Timberline Office. However, you must install Document
Management to the same server as other Sage Timberline Office products. If you install DocuVault to a
separate server, Document Management will prompt you for the DocuVault server name during
installation. For specific server requirements, see “Windows File Servers and Operating Systems” on
page 5.

Can I install DocuVault on a workgroup-only network?
No, we do not support a workgroup-only network configuration. DocuVault requires domain services or
active directory services on the local area network.
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If Document Management stops responding during the workstation installation, how
can I resolve this?
Try the following:
n

n

Verify that you have full user rights to the parent folder of the application data folders containing files
needed so that Timberline Office can run correctly. For Accounting and Management applications, the
default location is [Drive]:\Documents and Settings\All Users\Application Data\Sage on Windows
XP, Windows Server 2003, and earlier operating systems, or [Drive]:\ProgramData\Sage on Windows
Vista, Windows 7, and Windows Server 2008.
Turn off antivirus software and unnecessary programs before you install.

Which files and folders do I need to access to use Document Management?
To use Document Management, you must have full control of the certain files and folders on the file server,
terminal server, and workstations that have Document Management installed.
For a list of files and folders, see “Assign Full-Control User Rights to All Folders That Contain Document
Management and DocuVault Program Files and Data Files” on page 3.

What rights do I need to set up Document Management operators?
To use Settings in Document Management when security is on in Sage Timberline Office, your
permission level must be Unlimited (privileged operator) under Tools > Security > Task
(operator/groups).
In addition, you must be a Privileged Operator in Document Management to set up and manage
Document Management operators.

What determines the use of a DocuVault license?
DocuVault bases its licensing on the workstation name. For each workstation that is open, Document
Management uses one license.
When you print to DocuVault from a Microsoft Office program, DocuVault uses an extra license until you
close the Microsoft Office program.

What are the best batch settings when OCR is enabled?
When you select the OCR-Enabled format (DM > Scan > Batch Setting > General), the recommended
batch settings (DM > Scan > Batch Setting > Scan) are a 300 dpi (dots per inch) resolution and a BW
(1-bit) (black and white) or a Grayscale (8-bit) color.

How do I troubleshoot problems that occur when I start Document Management?
Search the Knowledgebase at Sage Timberline Online. To access the Knowledgebase, open
https://customers.sagenorthamerica.com. After you log on to Sage Timberline Online, type a question for
a specific issue in the Knowledgebase Search box or click Solve for advanced search options.
If you do not find what you need in the Knowledgebase, contact Customer Support. For more information,
see “Chapter 8: Further Assistance” on page 31.
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What file types can I send as attachments?
Beginning with the 9.8 release, any file type can be sent as an attachment from select Sage Timberline
Office Project Management tasks.
NOTE: Only the following file types can be previewed in Document Management:
l

ASCII: *.txt

l

Microsoft Excel: *.xls, *.xlsx

l

Microsoft PowerPoint: *.ppt, *.pptx

l

Microsoft Word: *.doc, *.docx

l

PDF: *.pdf

l

RTF: *.rtf

l

Image types: *.jpeg, *.png, *.bmp, *.tif, *.tiff, *.jpg, *.gif

Can I batch my approval emails so I receive one email periodically instead of multiple
emails?
Beginning with the 9.8 release, you can batch your approval emails. This enables you to receive one email
that contains a collection of individual emails instead of receiving a series of individual emails. The batch
email is sent periodically based on settings you specify.
You can set up your email batch preferences in Batches DM > Settings > Operator Details > Routing
E-mail Notification by selecting Scheduled In Batch from the list.
You can then use the Windows Task Scheduler to schedule the notifications, as follows:
1 Open Start > All Programs > Accessories > System Tools > Task Scheduler.
2 In the Actions panel, open Create Basic Task.
3 Enter a name, such as John Smith's email schedule. Click [Next].
4 Select how often you want to receive your batch of email. Click [Next].
5 Enter the time of day you want to receive your batch of email. Click [Next].
6 In Action, select Start a program. Click [Next].
7 In Program/script browse to [Drive] :\Program Files\Timberline
Office\Shared\SendSummaryRoutingNotifications.exe.
8 In Add arguments, enter -a for everyone or enter the individual's email address. Click [Next].
9 Click [Finish].

Is Document Management compatible with Microsoft Office 2010?
As of the 9.8 release, Document Management is compatible with the 32-bit version of Microsoft Office
2010.
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NOTE: The 64-bit version of Microsoft Office is not compatible with Document Management, as
several DM features do not work in that environment. Note, however, that the 32-bit version of
Microsoft Office can be installed on 64-bit operating systems. Refer to Microsoft Office
documentation for more information.

Can the DocuVault be used in a virtual environment?
Yes, but for the DocuVault to be used in a virtual environment, you must use a USB redirection program
(for example, USB Anywhere) for the virtual machine to use the physical USB protection device. Sage
does not offer customer support for USB redirection programs--any support needed must come from the
program vendor.
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Document Management installs the following third-party components automatically as needed at the
beginning of the Document Management installation.
NOTE: You must install Accounting and Management Products or Estimating Products before you
install Document Management. For more information about the prerequisites for these Sage
Timberline Office products, see the User's Guide.

Overview
Installation
Order

Software

1

Microsoft Windows Installer 3.1

2

Microsoft Internet Explorer 6.0 with Service Pack
1

3

.NET 3.5 SP1

4

DocuVault

Description of Third-Party Components
Microsoft Windows Installer 3.1
This is an installation and configuration service required by Sage Timberline Office’s InstallShield®
installation program.

Microsoft Internet Explorer 6.0 With Service Pack 1
Document Management opens in the Sage Timberline Desktop. Sage Timberline Desktop requires
Internet Explorer.

.NET 3.5 SP1
If .NET 3.5 SP1 is not present on your system, it will be automatically installed with Document
Management or DocuVault. .NET 3.5 SP1 will restart your server and workstations after the prerequisites
are installed.

DocuVault
ASG DocuVault® is the database that Document Management uses to store the documents.
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Prerequisites not Found in the DM Installation
The following prerequisites are required, but not installed automatically with your Document Management
or DocuVault software:

Internet Information Service (IIS)
DocuVault 9.6.1 and later requires IIS to be installed and active on the DocuVault and Accounting servers
if they are separate. IIS may be installed with a computer’s operating system. Even though it is installed, it
may be inactive.
Activating the Internet Information Service (IIS)
To verify that IIS is installed and active on the DocuVault server:
1 Open Control Panel > Administrative Tools > Internet Information Services.
2 Verify that World Wide Web Publishing Service is present and started.
If IIS is not already installed on the DocuVault or Accounting server, you can install it from your original
operating system CD. If the CD is unavailable, you can download IIS from www.microsoft.com.
Download the version of IIS that is compatible with your operating system:
OS Version

IIS Version

Windows XP

5.1

Windows Server 2003

6.0

Windows Server 2008

7.0

Windows Vista

7.0

Windows 7

7.5

Microsoft ISA Server uses an Internet configuration script which prevents Document Management from
accessing DocuVault through the IIS service. If you use the Microsoft ISA Server firewall client on your
workstations, disable the use of configuration scripts in Internet Explorer as follows:
1 In Internet Explorer, open the Tools > Internet Options > Connections tab.
2 Click [LAN Settings].
3 Clear Use automatic configuration scripts.
4 Click [OK], and close Internet Explorer.
5 Close and reopen the Sage Desktop.
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IMPORTANT: When DocuVault is installed it will enable 32-bit applications on the DefaultAppPool
for IIS. IIS 6.0 does not allow for the creation of separate application pools using 32-bit and 64-bit
simultaneously, this will cause an issue if the server also hosts IIS applications that require a 64-bit
application pool. In these cases, the DocuVault must be installed on a separate server from the
server hosting the application requiring the 64-bit application pool. This is not an issue with IIS 7.0
and later.

Microsoft Office Programs
If you wish to import, route, and work with documents created using Microsoft Office in the original file
format, you must install those programs on the DocuVault server before installing DocuVault 9.6.1 or later.

Installing Microsoft Office After Installing 9.6.1 or Later Versions
The following steps allow you to use native file functionality on files you have already scanned if you
installed DocuVault 9.6.1 or later versions before installing Microsoft Office.
1 Delete the native file documents (for example, Word, Excel, PowerPoint, text files, or PDFs) that were
routed before installing Microsoft Office. If you no longer have the original copy, you can right-click and
select Save as before deleting each document.
2 Stop the Cypress Service at the DocuVault server:
a Open Control Panel > Administrative Tools > Services.
b Select Cypress.
c Click Stop the service.
3 Install Microsoft Office 2003 or later.
4 Restart the Cypress service at the DocuVault server:
a Open Control Panel > Administrative Tools > Services.
b Select Cypress.
c Click Stop the service.
5 Rescan the documents you deleted and reclassify them.
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DocuVault Printer
After you install DocuVault and Document Management on the server, set up the DocuVault printer driver
from the Document Management installation at each workstation. You use the DocuVault printer to send
documents to DocuVault and to inboxes in Document Management. See Get Started with Document
Management for detailed instructions about installing DocuVault and Document Management.

Windows Printers
You can print documents to a local printer or network printer from the Inbox window or Query Results
window in Document Management. When printing from the Inbox window, most printer settings are
unavailable. When printing from the Query Results window, you can select additional printer settings.

Scanners
Use TWAIN-Compliant Scanners with Document Management
Sage supports TWAIN-compliant scanners for use with Document Management.
In multi-function scanner/printers, the scanner function works correctly with Document Management if the
scanner is TWAIN-compliant. However, we do not test the printer function of multi-function
scanner/printers. The printer function may not work correctly with Sage Timberline Office.

Scanning in a Terminal Services Environment
If you use Document Management in a Terminal Services environment, you need third-party scanner
redirection software. This software must be TWAIN-compliant and must allow Terminal Services direct
access to scanners that are attached directly to remote computers. We do not test these products.

Decreasing Document Size
The amount of disk space that Document Management uses depends on the resolution and color values
that you select in the batch settings and scanner settings.
Keep resolution settings and color settings at appropriate values to manage disk usage effectively. For
example, do not use color settings to scan black and white documents. Keep resolution values at the
default of 300 dots per inch (dpi), unless you require an increased resolution.
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Windows Terminal Services is a component of Microsoft Windows Server. Terminal Services consists of
a terminal server and one or more remote workstations. It allows users to access programs or data stored
on a remote computer by a phone, network, Internet connection, or other communication methods.
Remote network connections do not provide adequate bandwidth to run Sage Timberline Office products,
such as Document Management, without the use of Terminal Services. Terminal Services provides
remote users with a stable and well-performing experience with Sage Timberline Office.

Terminal Services Configuration
You can use Document Management and DocuVault with Windows Terminal Services.
We do not support the Remote Administration Mode of Terminal Services with Sage Timberline Office
products, because it is a partially configured version of Terminal Services.

Scanning in a Terminal Services Environment
If you use Document Management in a Terminal Services environment, you need third-party scanner
redirection software that is TWAIN-compliant and that allows Terminal Services access to scanners that
are attached directly to remote computers. We do not test these products.
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DocuVault Maintenance utilities enable you to perform administrative functions, including changing
Document Management uses and registration, starting DocuVault, and stopping DocuVault. In addition,
DocuVault Maintenance provides commands that are necessary for backup and recovery of Document
Management data.
CAUTION: You should not use other DocuVault Maintenance utilities other than the ones discussed
in this section without assistance from Customer Support.

Changing Document Management Uses and Registration
IMPORTANT: Do not remove the USB security key before or during this process.
1 At the DocuVault server, select [Start] > All Programs > Sage > Sage Timberline Office >
Reporting and Other Tools > Document Management > Change Uses and Registration.
2 A Document Management Uses and Registration window appears next. Enter your Registration
name and Activation code.
3 On the Set up DocuVault administrator tab, enter:
User name—The user name you enter here will be set up as the DocuVault administrator for function
and maintenance. Click [Browse] to open a window that lists all users on the domain. Select a user with
local administrative privileges on the DocuVault server.
Password—Enter the password that you used when you set up this user name as an administrator.
The password you enter here does not expire. You must update this password manually if your system
requires a periodic password change. To change the Document Management administrator password
manually:
a Log on to the DocuVault server.
b From the Start menu, open Programs > Sage > Sage Timberline Office > Reporting and Other
Tools > Document Management > Change Uses and Registration.
c Enter the new system password.
If your group policy does not allow you to change the logon account for the Cypress service, you can
manually change the credentials and restart the service:
i

From the Start menu, open Control Panel > Administrative Tools > Services.

ii Right-click on Cypress and select Properties > Logon.
iii Select This account, and enter the user name and password.
iv Close the Properties window.
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4 Right-click Cypress, and select Restart.
5 A Document Management Uses and Registration window appears that says You have
successfully activated Document Management. Click [Finish].

Starting and Stopping DocuVault Hub Services
Typically, the DocuVault service starts automatically when your server starts. However, when necessary,
you can start or stop DocuVault manually.
IMPORTANT: To see Start Hub and Stop Hub from the Document Management menu, you must
log on to the server as the user who installed Document Management.

Starting the DocuVault Hub
To start the DocuVault services, follow these steps:
1 At the DocuVault server, select [Start] > All Programs > Sage > Sage Timberline Office >
Reporting and Other Tools > Document Management.
NOTE: For operating systems such as Windows Server 2008 that use UAC (User Account Control),
this option must be run as an administrator. To do this, right-click the menu item and select Run as
administrator.
2 Double-click Start Hub.
3 When the “DocuVault READY” message appears, close the db_prog.exe and Start Hub windows.

Stopping the DocuVault Hub
To stop the DocuVault services, follow these steps:
1 At the DocuVault server, select [Start] > All Programs > Sage > Sage Timberline Office >
Reporting and Other Tools > Document Management.
NOTE: For operating systems such as Windows Server 2008 that use UAC (User Account Control),
this option must be run as an administrator. To do this, right-click the menu item and select Run as
administrator.
2 Double-click Stop Hub.
3 When the “The Cypress service was stopped successfully” message appears, close the Stop Hub
window.

Backing Up Document Management
You should back up the DocuVault database and selected program files every day. For more information,
please see the following topics:
n

“Backing Up Manually” on page 23.
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n

n

“Backing Up With an Automated Backup” on page 23. For additional assistance with this method,
consult your network administrator.
“Restoring a Backup” on page 24.

Backing Up Manually
1 Ask everyone to close Document Management.
2 At the server that contains DocuVault, open the file [Drive]:\TSDV\Server\DocuVaultMaintain.exe.
3 In the DocuVault Maintenance window, click the Backup tab.
4 Select Prepare for Offline Backup; then click [Execute Command].
CAUTION: Before you perform a manual backup, you must execute the Prepare for Offline
Backup command. Any backup that you make without first executing this command is unusable.
5 When the command finishes, the lower right area of the DocuVault Maintenance window displays
Ready for offline backup.
6 With third-party backup software, create a new backup job. In the job name, indicate that this is a full
DocuVault backup.
7 Back up the following:
p

[Drive]:\TSDV\

p

[Drive]:\Documents and Settings\All Users\Application Data\Sage\

p

For Windows Server 2008: [Drive]:\programdata\sage\documentmanagement for server 2008.

8 After the backup finishes, return to the DocuVault Maintenance window.
9 Select Resume from Offline Backup; then click [Execute Command].
When the command finishes, a db_prog.exe window that says DocuVault READY may be in front of
the DocuVault Maintenance window. If this is the case, close or minimize the db_prog.exe window.
The DocuVault Maintenance window displays DocuVault is back online in the lower right corner.
10 Click [Close].

Backing Up With an Automated Backup
1 If you are performing the backup at a time when operators might be using Document Management, ask
everyone to close Document Management.
2 With third-party backup software, create a new backup job. In the job name, indicate that the job is a full
DocuVault backup.
3 Add the following pre-backup command to your backup script: c:\tsdv\server\hub_service-stop
or
net stop cypress
This command stops the hub service, which makes DocuVault inaccessible to all users.
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CAUTION: Before you perform a backup, stop the hub service and put the hub service in offline
dump mode, as described in this step and in step 4. Any backup that you make while DocuVault is
running is unusable.
NOTE: The pre-backup, backup, and post-backup commands (steps 3, 4, 6, 7, and 8) must execute
on the server. If your backup software runs on a separate server, you may install a backup agent on
the server.
4 Add the following pre-backup command to the next line of your backup script:
[Drive]:\TSDV\Server\db_prog.exe -start_offline_dump
This command moves all log files to the TSDV\Server\db_prog.exe_collateral directory. In addition, it
ensures that no transaction data writes to DocuVault during the backup.
5 Verify that the pre-backup commands do not produce errors. Given the critical role of backup files, you
must verify that the return code (ERRORLEVEL) for all db_prog commands is zero. For example, if your
backup software uses batch files for its pre-backup and post-backup steps, the pre-backup step might
look like this:
hub_service –stop
c:\TSDV\Server\db_prog.exe -start_offline_dump
if not ERRORLEVEL 0 goto mark_dump_failed...
:mark_dump_failed
rem do whatever is needed to log a failure
6 In the backup software, type the directory paths and files that you want to backup:
p

[Drive]:\TSDV\

p

[Drive]:\Documents and Settings\All Users\Application Data\Sage\
NOTE: Verify that your backup software supports the wildcard character (*). You must backup all
files and folders underneath the designated folders.

7 Add the following post-backup command to your backup script: [Drive]:\TSDV\Server\db_prog.exe cancel_offline_dump
This closes the DocuVault backup and makes DocuVault ready for use.
8 Add the following post-backup command to the next line of your backup script: net start cypress
This step starts the DocuVault service.
9 As with the pre-backup commands, verify that the return codes for each command are zero.
10 Perform any other steps to complete the job definition, (for example, define a backup schedule).
11 Save the backup job.

Restoring a Backup
1 Ask everyone to close Document Management.
2 At the server that contains DocuVault, open the file [Drive]:\TSDV\Server\DocuVaultMaintain.exe.
3 In the DocuVault Maintenance window, click the Backup tab.
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4 Select Prepare for Offline Backup; then click [Execute Command].
When the command finishes, the lower right area of the DocuVault Maintenance window displays
Ready for offline backup.
CAUTION: Before you restore a backup, you must execute the Prepare for Offline Backup
command. Any restore that you make without first executing this command is unusable.
5 As a precaution, change the name of a file and several folders on your hard drive.
For example, add “_temp” to the following file and folder names:
p

[Drive]:\TSDV\

p

[Drive]:\Documents and Settings\All Users\Application Data\Sage\

6 Navigate to the location of the backup that you want to restore.
7 Restore backed up folders and files.
8 Return to the DocuVault Maintenance window.
9 Select Resume from Offline Backup; then click [Execute Command].
When the command finishes, a db_prog.exe window that says DocuVault READY may be in front of
the DocuVault Maintenance window. If this is the case, close or minimize the db_prog.exe window.
The DocuVault Maintenance window displays DocuVault is back online in the lower right corner.
10 Click [Close].
11 Verify that your restored data is acceptable.
12 If your restored data is acceptable, delete the file and folders that you renamed in step 5.

Moving DocuVault to a New Server
CAUTION: Incorrectly moving DocuVault may severely damage your system. Sage is not
responsible for damage to your data caused by incorrectly moving DocuVault. Before making
changes to DocuVault, contact your system administrator for assistance and make a backup copy of
all valued data.
1 Follow steps 1 through 8 for “Backing Up Manually” on page 23.
2 Install DocuVault at the new server with your installation download. See Get Started with Document
Management for detailed instructions about installing DocuVault.
NOTE: You must have a valid USB security key to install DocuVault to your new server. Following
the installation instructions, remove the USB key from your old DocuVault server and use it to install
DocuVault on the new server.

3 Restore the backup of your DocuVault to the new server. Follow the steps for See "Restoring a
Backup".
4 If you installed DocuVault to a path that differs from the path for the previous installation, follow these
steps:
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a At the new DocuVault server, select [Start] > All Programs > Command Prompt.
b Type chdir [Drive]:\TSDV\Server to change the drive and path to your new DocuVault server.
c Type the command in this format:
db_prog -update [Drive:\path]\TSDV\Logs * * *
The asterisks are for items that are not changing (the log file size, the DocuVault cache, and the log
file disposition).
For example, if you previously installed DocuVault to C:\TSDV on your old server and you installed
DocuVault to D:\Sage\TSDV on your new server, you would type this command from
D:\Sage\TSDV\Server:
db_prog -update D:\Sage\TSDV\Logs * * *

5 Reactivate your USB security key. For reactivation instructions, see the Technical Support
Knowledgebase article “I Moved Document Management and I Need to Reactivate My USB Key.” For
information about using the Knowledgebase, see “Sage Customer Portal” on page 32.
6 Update each workstation and other servers which integrate with DocuVault; for example, the
Accounting Server.
n

n

For Windows XP and Windows Server 2003–Go to Documents and Settings\All Users\Application
Data\Sage\DocumentManagement\Version 3.0\DMClient.
For Windows Vista, Window 7, and Windows Server 2008—Go to
\ProgramData\Sage\DocumentManagement\Version 3.0\DMClient.
Open DMServerName.xml and replace the existing ServerName attribute with the new server name.

Managing Disk Space
Decreasing Document Size
The amount of disk space that Document Management uses depends on the resolution and color values
that you select in the batch settings and scanner settings.
Keep resolution settings and color settings at appropriate values to manage disk usage effectively. For
example, do not use color settings to scan black and white documents. Keep resolution values at the
default of 300 dots per inch (dpi), unless you require an increased resolution.

Calculating Current Disk Space Requirements
We recommend that you check your current Document Management storage requirements monthly at
your DocuVault server to ensure that you have adequate disk space.
To view the size of your DocuVault database, follow these steps:
1 From the taskbar, right-click [Start] and select Explore.
2 Browse to your DocuVault database folder. (The default location is [Drive]:\TSDV\Server\db_
prog.exe_collateral.)
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3 Right-click db_prog.exe_collateral and select Properties.
4 From the General tab, note the Size of the folder.
5 Compare the size of the folder to the size of your drive.

Calculating Future Disk Space Requirements
The Storage Information utility enables you to calculate the current disk space used by DocuVault to
predict the future disk space requirements. Use it to identify when you may need additional disk space.
To run the Storage Information utility, follow these steps:
1 At the DocuVault server, select [Start] > All Programs > Accessories > Command Prompt.
NOTE: We recommend running the Storage Information utility from the DocuVault server for faster
performance. However, when working with a small DocuVault, you may run the utility from a
network-connected workstation.
2 Type chdir [Drive]:\TSDV\Server to change the drive and path to your DocuVault server.
3 Type the command in this format:
storage_prog [number of days] [DocuVault@servername] [Drive:\path\filename.csv]
n

n

n

n

storage_prog: This command starts the Storage Information utility.
[number of days]: Type the number of days you want to analyze. The more days you specify, the
longer it will take to complete the report.
[DocuVault@servername]: TypeDocuvault@ followed by the name of the server. This parameter is
case sensitive. If the server name contains spaces, you must enclose the parameter in quotation
marks.
[Drive:\path\filename.csv]: If you want to save the storage report as a spreadsheet, type the path and
file name followed by .csv. If you want to view the report in the Command Prompt window, skip this
step.
For example, if you want to create a storage report forecasting the next 30 days of activity based on the
last 30 days and if you want to save the report, you would type a command similar to this:
storage_prog 30 DocuVault@ABC1234567Z C:\storage_usage.csv

4 If you saved the report to a spreadsheet, browse to the file name you specified in step 3, bullet 4, and
open the report.

Locating the Document History Log
Document Management logs the details of any document that is deleted from DocuVault. In addition, it
logs the details of an AP Invoice document that is disassociated from an Account Payable invoice. The log
is located at [Drive]:\Documents and Settings\All Users\Application
Data\Sage\DocumentManagement\Version 2.0\DMServer\LogFiles\ServerLog.xml.
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Batch Settings with Optical Character Recognition (OCR)
When you select the OCR-Enabled format (DM > Scan > Batch Setting > General), the recommended
batch settings (DM > Scan > Batch Setting > Scan) are a 300 dpi (dots per inch) resolution and a BW
(1-bit) (black and white) or a Grayscale (8-bit) color.

Burning Documents to CD or DVD
This feature is available only from the Query Results window in Document Management.
NOTE: You must burn entire documents. In the Query Results window, if you select individual
pages within a multi-page document, Document Management still burns the entire document.
To burn a document to CD or DVD:
1 Insert a blank CD-R, CD-RW, or DVD±R into your CD or DVD drive.
2 From the Query Results window, in the tree view, select the check boxes of one or more documents.
3 Right-click anywhere in the tree view; then select Burn CD/DVD.
4 From the Burn CD/DVD window, in the Drive Name box, select a drive.
5 In the Volume Label box, type a volume label.
6 Click [Burn]. Document Management burns the document in PDF format.
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Setting Security in Sage Timberline Office
Beginning with the 9.5 release, you must enable Sage Timberline Office Security Administration before
you can manage Document Management users and configure Document Management security. The Sage
Timberline Office Security Administration includes two roles: a Security Administrator and an Application
Administrator. The person setting up Document Management must be a member of both roles to configure
DM users and settings in DM. When you set up Sage Timberline Office Security Administration, ensure
you assign the DM privileged operator responsible for configuring DM users and settings to both roles.
The Sage Timberline Office Security Administration is available from Desktop.
If you are upgrading from Document Management 9.4.x, all Document Management operators must be
mapped to Sage Timberline Office security users. DM offers a wizard (Tasks > Setup Security) that
walks you through the process of setting up this one-time mapping.
NOTE: You must turn on Sage Timberline Office Security in order to use Document Management. If
you are not using Sage Timberline Office Security with Document Management, you need to
temporarily turn on Sage Timberline Office Security and set up or upgrade Document Management,
and then you can turn off Sage Timberline Office Security.

Assigning Operator and Privileged Operator Rights
Operators have restricted rights in Document Management. For example, operators only have access to
the queues and documents specified in Settings (Tasks > Document Management > Settings).
Privileged operators have unlimited rights. For example, privileged operators have access to all queues, all
inboxes, all queried documents, the Settings task, and the permanent delete feature. You must have at
least one privileged operator.
Power operators have all the same rights as an operator with added administration rights. Power operators
can manage the list of operators, but are restricted from managing document security and task security.
You are not required to have power operators set up in Document Management.

Destroying DocuVault Documents
If you have privileged operator rights in Document Management (Settings > Privileged Operators), you
can destroy DocuVault documents. That is, you can permanently delete documents from DocuVault.
From the Query Results window, click [X] on the DocuVault toolbar to destroy the documents that you
have selected.
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NOTE: You cannot destroy AP invoice documents. First, you must unlink the AP invoice document.
Then, you can destroy the unlinked document.
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Online Help
Document Management includes online help, which provides answers to your questions about procedures
as well as items in the windows.
To access the online help:
n

In a window, click the Help button or icon, or press F1 to display the help topic for that window.

n

In the Desktop, select Help > Search for help on, and then choose the desired module.

To aid you in finding the information you need, the online help for each module includes the following
panes:
n

Contents pane containing links to the help topics.

n

Index pane containing keywords that link to help topics related to that keyword.

n

Search pane, where you can type text and click [Search] to locate that text in the help topics.

For more information about using the online help, see the Sage Timberline Office Desktop help (in the
Desktop, select Help > Sage Timberline Office Desktop Help).
We would like your feedback about the online help so we can make improvements. Each help topic
contains an area where you can indicate whether the topic was helpful and provide additional comments.
To protect your privacy, all comments are anonymous.
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Depending on your Sage Service Plan, you may be able to take advantage of the following services:

Sage Customer Portal
You may log onto the Sage Customer Portal at
https://customers.sagenorthamerica.com/irj/portal/anonymous/login to access any of the following:
n

n

n

Knowledgebase: Find answers to your questions, access downloads, and subscribe to your favorite
articles. This service is available online 24/7.
Live Chat: Chat online with a customer support analyst - a great option for quick questions. Chat hours
are Monday through Friday from 6 a.m. to 3 p.m. Pacific Time, with the same exceptions as our
telephone support (see below).
Online Support Request: Submit an online support ticket when you have a less urgent question. One
of our call center support analysts will assist you. Online support hours are the same as our customer
support call center hours (see below).

Sage Customer Support Call Center
Telephone Support: When you have a more urgent question or would prefer to speak to a customer
support analyst directly, call us at 800-551-8307. Telephone support is available Monday through Friday
from 6 a.m. to 5 p.m. Pacific Time with the following exceptions:
n

Every Thursday from 2 p.m. to 3 p.m. Pacific Time (closed for customer support staff meetings)

n

Standard United States holidays

n

Quarterly company meetings

Training Information
Sage University offers online and classroom training sessions to help you get the most out of your Sage
Timberline Office software. To access Sage University, from the Sage Timberline Office Desktop, visit
www.sageu.com.
You can also get access to Sage University from the Sage Timberline Desktop from Help > Sage
Timberline Office on the Web > Sage Software University.

Upgrading Your Service Plan
If your service plan does not provide online technical support and you would like to add or upgrade a
service plan, please call 800-858-7098.
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