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Chapter 1: Introduction
This guide covers the steps for closing the year in your Sage 300 Construction and Real Estate software.
For government reporting, you need to close the Payroll year (see page 10) in January.
When it is time to close your fiscal year, close the fiscal year in the following applications (in any order) before
closing the fiscal year in General Ledger (see page 25).
l

Accounts Payable; see page 14

l

Accounts Receivable; see page 21

l

Cash Management; see page 22

l

Contracts; see page 22

l

Equipment Cost; see page 23

l

Job Cost; see page 23

l

Property Management; see page 18

l

Residential Management; see page 21

l

Service Management; see page 24

If your fiscal year is the same as the calendar year, close them in January.
This guide also covers the steps for producing the following government forms:
p

T4 forms from Payroll; see page 30

p

T5018 forms from Accounts Payable; see page 39

p

ROE forms from Payroll; see page 44
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Important reminders for year-end processing
Supported version
For year-end 2019, you need to be using version 18.
Before you generate year-end government forms, install the year-end software version, which is version 18.4.
Log into the Sage Knowledgebase and see Knowledgebase article 102056.

Backups
You must back up your data and system files before you begin any year-end procedures. Make a complete
backup on external media, such as CD-ROM or DVD-ROM, and store this backup off site permanently. See
“Appendix A: Backup Procedures” on page 49 for more information, including the file names to back up in each
application. Be sure to show file extensions to ensure proper operation.
Caution! Partial backups will not be useful if you need to restore your data. A complete backup is
required.

Security
If you are using security, make sure your staff has the correct security settings to access year-end tasks. In
Sage Desktop, select Tools > Security Administration, and click Security Settings to set up and review
the settings. If there were any staff changes during the year, you may need to change the security
permissions.

Tax forms and electronic filing
We have partnered with Aatrix Software to use the data from Sage 300 Construction and Real Estate to print
or electronically file year-end government forms. Aatrix is a leading provider of online filing for payroll and tax
forms. Aatrix generates the federal forms using information extracted from Payroll and Accounts Payable.
In Aatrix, you can review and edit the reports on screen. You can then select to print and mail the forms
yourself, electronically file (eFile) your forms, or have Aatrix print and mail employee/vendor forms for you.To
learn more, visit the Aatrix website.
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You can process the following Canadian forms:
p

Form T4 from Payroll

p

Form T5018 from Accounts Payable

p

Record of Employment (ROE) forms from Payroll

Things to know before you begin using Aatrix
n

n

n

n

n

n

n

You must have an internet connection to use Aatrix.
You can complete the Aatrix enrollment form now or after you complete your processing. You will not be
able to eFile until you have enrolled with Aatrix. See “Aatrix Enrollment” on page 5.
You may need to manually adjust some settings in third-party firewalls to ensure you receive the Aatrix form
updates; see the next section for more information.
You can save reports in progress, then come back to work on them at any time.
Modifications you make to forms and information in Sage 300 Construction and Real Estate are reflected in
Aatrix forms. However, changes you make to reports and data in Aatrix are not written back to Sage 300
Construction and Real Estate.
We use a variety of terms for your tax ID number in the software and in this manual, including Canadian tax
ID and account number.
Back up your Sage 300 Construction and Real Estate files before you begin.
Note: You can edit, print, or eFile T4 forms using Aatrix either before or after closing the Payroll year.

Firewall settings
You may need to manually adjust some settings in third-party firewalls to ensure you receive the Aatrix form
updates and ensure you can electronically file the tax forms.
Firewalls often need to have access allowed through specific ports.
p

p

p

The Tax forms and eFiling Updater uses standard HTTP port 80 to access the site
http://updates.aatrix.com.
The eFiling component uses secure HTTPS on port 443 to access the site https://efile.aatrix.com.
The registration component uses HTTP to access the site http://soapregcode.aatrix.com, IP Address
68.178.93.201

By allowing access to aatrix.com, you will allow both updates and eFiling. Occasionally the restrictions are
even tighter and only allow access to these ports by specific programs. Tax Forms and eFiling uses the
following programs to access the Internet:
For Updating using http on port 80 to http://updates.aatrix.com:
l aatrixforms.exe
l updater.exe
l updater2.exe
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For eFiling using secure http on port 443 to https://efile.aatrix.com:
l builder.exe
l viewer.exe
For a full list of the required firewall and permission requirements, see
http://aatrix.com/updateshome/techinfo/.

Getting help with year-end issues
Assistance at year-end
During year end, it can be hard to reach a customer support analyst at the Sage Customer Support Call Center
as quickly as you need. We recommend utilizing your software’s in-product Help system or viewing the
product documentation first to answer your technical questions.
You can also visit Sage City for answers to year-end questions: https://sagecity.na.sage.com/p/yearend
When you need additional assistance, refer to the How do I get technical support for Sage 300 Construction
and Real Estate? article to determine what service works best for you.

Upgrading your service plan
If you would like to add, renew, or upgrade your service plan (such as to add telephone support), please call
800-858-7098.

Determining your software version
If you need to contact Sage, you should know your software version. To determine which version of the
software you use, in any application, select Help > About <application>.
Make a note of your software version for reference.

Getting training to help with year-end tasks
To see step-by-step instructions about year-end closing tasks, register for one of the following complimentary
Year-end Procedures Anytime Learning subscriptions on Sage University:
l

2019 Year-end Procedures (U.S. Edition) Anytime Learning

l

2019 Year-end Procedures (Canada Edition) Anytime Learning

You can also sign up for a $99 instructor lead course that is applicable to either edition.
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Aatrix Enrollment
If you plan to eFile any of your tax forms, you must enroll with Aatrix. If you have not already created an
account with Aatrix, you can enroll any time before you begin. You will be prompted to enroll when you attempt
to eFile your forms.
1 Access Aatrix by visiting the following website:
https://efileca.aatrix.com/pages/public/publicCAN.aspx
2 To create your Aatrix account, click "Enroll" in the upper-right corner.

3 Enter the following information for your Aatrix account, and then click [Save Changes].
p

The username and password that you want to use

p

Your filer type (filing for your company or as a third-part Tax Preparer)

p

Sage 300 CRE for Accounting Package

p

Your contact information (name, email address, and phone)

p

Your company EIN or account number

p

Your company name and address

p

The employee/recipient count
Tip: If you want to receive automatic reminders of important events on your cell phone, add your phone
information and select the Click here to accept SMS/Text alerts from Aatrix check box.

4 Log into Aatrix by entering your password and clicking [Continue].
5 Select your security question and image, and then click [Continue].
6 Read the enrollment information, and then click [Continue].
7 On the Home page of your account page, click the Companies tab.
8 If desired, make any other changes on this or the other tabs. You can see a history of each filing on the
Filings tab.
9 When finished, click [Log Out].
After your Aatrix enrollment is complete, you can select the option to eFile any of your completed forms.
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Forms update
You may receive a prompt to update tax forms when you open the eFile and Reporting window from Payroll
or Accounts Payable. To ensure you are always in compliance with the latest federal or provincial mandated
changes, select [Automatic Update].
Note: You may need to manually adjust some settings in third-party firewalls to ensure you receive the
Aatrix form updates. For more information, see page 3.
Aatrix continually updates all forms with any changes such as calculations, rates, or filing dates to meet
compliance standards. If you have expired forms or if an updated version of Aatrix is available, you will
receive a prompt to perform an update when you open Aatrix.
To perform the update:
1 In the Forms Update window, select one of the following options:
p

p

p

If your computer is connected to the internet, click [Automatic Update].
If your computer is not connected to the internet, click [Download Update] to display instructions about
downloading the updated forms to a computer with internet access and then transfer them to the
computer where your software is installed.
If your service plan has expired, you can click [Continue Expired]. You are still able to retrieve, review,
and print copies of the forms you need for your records, but you are not able to file the forms. An
EXPIRED watermark appears on the report printouts and the eFile command is also unavailable.
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2 If you clicked [Automatic Update], Aatrix lists the forms that need to be updated. Click [Next >] to begin
the forms update.

3 After Aatrix updates the files, it displays "Update Complete" in the Aatrix Update Client window. Click
[Close].
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When it is time to close the calendar in Payroll, perform the steps outlined in this chapter.

Year-end closing checklist for Payroll
Tasks

Comments

Prepare for the calendar year end.
□

Run and post the final payroll for the year you are closing.

□

Reconcile employee totals and payroll tax totals.

□

Reconcile Payroll to General Ledger.

□

Print management reports.

□

Make a backup copy of your entire database, if you have not already done
so.

See page 49.

□

Generate T4 forms (before or after closing the Payroll year).

See page 30.

□

Close the Payroll year.

See page 10.

□

Create an annual archive after completing your calendar-year processing.
This archive can be used for restoring data or reporting purposes.

See page 49.

□

Perform file maintenance.

See page 12.

In January, prepare for the first payroll of the new year.

See page 11.

□

Download and update taxes for the new year.

□

If necessary, modify personal tax credit amounts.
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Payroll year-end workflow

Preparing for closing the year in Payroll
Perform the following steps before closing the Payroll year:
1 Run and post the final payroll of the year.
2 Reconcile reports based on your cutoff date of 31/12/2019 and make corrections.
Note: If the last pay period extends beyond the calendar year-end date of 31/12/2019, you may want to
create Billing, Equipment Cost, General Ledger, and Job Cost accrual entries for the earnings expense
portion of the time entered to get a clearer picture of year-end costs. Select Tasks > Generate Accrual
Entries. For more information, refer to “Generating Accrual Entries” in Payroll Help.
3 Perform the standard steps for a month-end closing.
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4 Decide if you need to retain year-to-date totals for any pays, fringes, or deductions. For example, you may
want to retain totals for accrued vacation time or employee loans that have not been paid in full. When you
retain year-to-date totals, the retained amounts become the accumulated totals in the employee setup for
the new Payroll year.
If you want to retain year-to-date totals, verify each pay, deduction, and fringe to see if the setting is correct
for Retain YTD totals at close year. Review the settings as follows:
a Select Setup > Pays.
b Click [Next].
c Select or clear the Retain YTD totals at close year check box, as appropriate.
d Press TAB twice.
e Select or clear the Retain YTD totals at close year check box.
f Click [Save].
g Click [Next] to review the next pay.
h When finished, click [Close].
i Select Setup > Deductions, and then repeat steps b–f to review each deduction.
j Select Setup > Fringes, and then repeat steps b–f to review each fringe.
5 Make a backup copy of your Payroll files. See “Appendix A: Backup Procedures” on page 49 for more
information.
Note: We recommend you back up your entire data base before closing the year. This archive can be
used for restoring data or reporting purposes.

Closing the year in Payroll
To close the year, select Tasks > Close Year. This task:
p

Reminds you to back up your Payroll master file.

p

Clears MTD, QTD, and YTD totals in the Payroll master file.

p

Moves employee totals to the prior period fields.

p

Changes the Current Month to January and the year-end date to 31/12/2020 in the Payroll Settings
window.
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Preparing for the first payroll of the new year
You can enter time for the new year, however, do not process your payroll until you have:
n

Completely finished employee payment processing through 2019.

n

Performed the Close Year task, which resets the employee year-to-date accumulators to zero.

n

Downloaded the Payroll tax update, available in late December, by selecting Tools > Download Taxes.

n

Updated the taxes by selecting Tools > Update Taxes prior to processing your first payroll.

n

Verified that the taxes are updated and the year-end date is 2020.

Payroll calculations are based on year-to-date totals. Therefore, if you did not close the year prior to
processing payroll, your pays, taxes, fringes, and deductions may not calculate correctly. For example, an
employee may have already met the limit for a tax so it does not calculate.
If you processed payroll without closing the year or updating taxes, you can still perform those two tasks.
Then perform the Process Payroll task again with the Reprocess Cheques check box selected.
If you updated taxes too early, then you should restore prior payroll taxes using File Tools.

Modifying personal tax credit amounts
If the federal or provincial personal tax credits have changed for the new year, update your employees' tax
credits:
1 Make a backup copy of your Payroll files. See “Appendix A: Backup Procedures” on page 49 for more
information.
2 Select Tools > Modify Personal Tax Credits Amounts.

3 Choose Federal or Provincial for the tax level. If you choose the provincial level, also choose the province.
4 Enter the current personal credit amount for Current Basic Personal Amount.
5 Enter the new personal credit amount for New Basic Personal Amount.
6 Select the PR Master file has been backed up check box and click [Start].
7 Repeat these steps until the personal tax credit amounts have been updated for all tax levels.

2019 Year-End Procedures and Government Forms Guide

Page 11

Chapter 2: Closing the year in Payroll

Maintaining your files
You can use the Move Cheques tool to archive the past year's cheques. You can use the Move Employees
tool to archive information about terminated employees. These tools reduce the amount of the data in your
current files and speeds processing. For detailed instructions, see “Payroll archive procedures” on page 73 in
Appendix B.
Caution! Do not move checks or employees until you have generated all year-end government forms.
After you successfully move cheques and terminated employees, compact your Payroll master file and
Payroll current transaction file. See “Compacting files using File Doctor” on page 55 in Appendix A for more
information.
Note: This compacting process may be lengthy, depending on the size of your files and your system.
Please allow sufficient time to complete the process.

Common Payroll questions and answers
Do I need to close the month before I close the year in Payroll?
No. If your current Company folder month is December, select Tasks > Close Year. The software
prevents you from closing the month if it is December, since December is the last month of the year.

How can I void and reissue a cheque from the previous year?
You must perform a sequence of steps to void and reissue cheques. However, there are several
considerations before voiding and reissuing cheques from the previous year:
p

p

p

p

p

p

p

p

If you have already updated taxes for the current year, then taxes have the current year’s rates and
limits.
When you process a cheque, the system uses the year-to-date (YTD) totals on the master file. These
totals are for the current year and help determine when an employee meets the limit for a tax.
If the employee met the limit for a tax in the prior year, the original cheque may not include this tax. When
you process the reissued cheque, the tax, taxable, and subject-to-tax amounts may calculate if the
employee has not met the limit in the current year.
You can manually zero out the tax amount in Enter Cheques, but this does not clear the taxable and
subject-to amounts. The taxable and subject-to amounts accumulate to the prior year taxable and
subject-to master file totals when you post the cheque to the prior year. This will affect government
reports. You cannot change the taxable or subject-to amounts in Enter Cheques.
We do not recommend the use of Audit Setup Activity to correct the taxable and subject-to totals on the
master file, because this causes the master file to be out of balance with the transaction file.
If the tax amounts withheld on the cheque change, you may need to print your year-end tax reports again
and file amended reports to the provincial and federal governments. Consult your tax accountant or tax
attorney for information on the tax laws and regulations that apply to your situation.
The cheque stub for the reissued cheque displays the current year’s YTD totals, not the prior year totals.
If you need to void a cheque for the prior year and reissue it with corrections, the corrections affect the
totals used for government reporting.
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Perform these steps to void and reissue the cheque to the prior year:
a Create a backup. See “Appendix A: Backup Procedures” on page 49 for more information.
b If you have closed the General Ledger period for the accounting date of the cheque, open the period; (in
General Ledger, select Tasks > Open/Close Posting Period).
c Print the Cheque Activity with Detail report in Payroll (by selecting Reports > Pay Period Processing)
and determine if the limit was met for any of the taxes.
d Void the cheque by selecting Tasks > Void Cheques.
e In Enter Cheques, determine if any tax amounts changed, and make any necessary adjustments to tax
amounts. For example, if the limit for a tax has been met, adjust the tax amount to zero.
f Click [Process].
g Print the cheque with a cheque date for the prior year, then post the cheque.
h Select Tools > Recalculate Subject-to and then select Prior year in the Recalculate Subject-to Print Selection window.
i Print government forms using prior period fields.

I just downloaded the new year's tax changes. When should I update them?
Select Update Taxes after you complete the last payroll for the year but before you process cheques for the
first payroll of the next year.

When I ran Payroll > Tools > Update Taxes, I got an error message that reads, "NEW.PRX
not found." What does it mean?
This message usually means that you have already selected Update Taxes or you have not yet
downloaded the new tax files. The New.prx file is installed during Download Taxes and deleted after you
select Update Taxes.

When I ran Payroll > Tools > Update Taxes, I got an error message that reads, "PR Tax
file is incompatible. The file will be upgraded now." What does it mean?
This message means that the Tax.prx file needs to be upgraded. Click [OK] to upgrade the tax file.

How can I verify that my taxes updated?
To verify that the latest tax rates were installed or updated, select Setup > Taxes > Tax Rates. Enter the
tax ID for one of the taxes for the current tax release. If the Effective date in the Tax Rate Setup window
matches the effective date of the current release, taxes updated correctly. If the effective dates do not
match, review the installation instructions provided in the Payroll Tax Release Notes and repeat any steps
necessary.
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When it is time to close the calendar year or fiscal year, perform the steps outlined in this chapter.

Year-end closing checklist for Accounts Payable
Tasks

Comments

□

Enter and post all invoices, cheques (manual and computer),
electronic payments, and credit card payments for 2019.

□

Reconcile Accounts Payable to itself and to General Ledger.

□

Print management reports.

□

Verify the Accounts Payable fiscal year-ending date in the AP
Settings window.

□

Make a backup copy of your entire database, if you have not already
done so.

See page 49.

□

Install the 2019 year-end software update, if needed.

See page 2.

□

Verify the T5018 totals.

□

Generate T5018 forms for your vendors (before or after closing the
year in Accounts Payable).

See page 39.

□

Close the Accounts Payable year at the end of your fiscal year.

See page 16.

□

Create an annual archive after completing your year-end processing.
This archive can be used for restoring data or reporting purposes.

See page 57.

□

Perform file maintenance.

See page 17.
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Accounts Payable year-end workflow

Preparing for year end in Accounts Payable
Perform the standard month-end steps. Even though Accounts Payable does not have a close month task,
you need to complete reconciliation steps based on your cutoff date of 31/12/2019. These steps should
include the following:
1 Be sure to enter all invoices and approve pending invoices for the year.
2 Select the Post Invoices task and verify that all invoices posted.
3 Enter all payments (manual and computer cheques, electronic payments, and credit card payments)
through December 2019.
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4 Reconcile Accounts Payable to itself and then to General Ledger. (General Ledger should be current and
posted.) Use the Reconciliation Tool to reconcile AP to itself. Use the following reports to reconcile
Accounts Payable to General Ledger:
p

Period End Report for AP Accts.

p

Entries by Batch for AP Accts.

p

Period End Report for RP Accts.

p

Entries by Batch for RP Accts.

5 Print month-end reports (such as Open Invoice, Invoice Aging, Cheque Register) and any other reports that
you print as part of your normal month-end procedures. Also print year-end reports as needed.
6 Make a backup copy of your Accounts Payable files. See “Appendix A: Backup Procedures” on page 49 for
more information.
Note: We recommend you back up your entire data base, creating an annual archive after completing
your year-end processing. This archive can be used for restoring data or reporting purposes.
7 If you want to remove inactive vendors from your database, you should do this before closing the year. See
“Removing vendors” on page 61 for more information.

Closing the Accounts Payable year (fiscal year)
Note: Do not close the Accounts Payable year at the end of the calendar year unless it is also the end of
your fiscal year.
To close the Accounts Payable year at the end of your fiscal year:
1 Verify that invoices and payments for the fiscal year were entered.
2 Generate the year-end reports.
3 Verify that the Year ending date in the AP Settings window is set to the correct date.
Note: If the Year ending date is already set to next year, this process was already performed.
4 In Accounts Payable, select Tasks > Close Year.
When you close the fiscal year, the system:
p

Moves the amounts in the This Year fields to the Last Year fields that appear in the Vendor Setup Totals window for each vendor.

p

Moves the Next Year fields to the This Year fields in the same window for each vendor.

p

Updates the Year Ending Date field in the AP Settings window with the new year.
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Maintaining your files
Use Move Payments to move payments and their related invoice information to a history file. This keeps your
historical payments separate from your current payments. It also decreases the size of your data file and
speeds processing time. After the payments have been transferred to history, they can be used for reporting
purposes; they can no longer be voided or edited.
For detailed instructions, see “Accounts Payable archive procedures” on page 59 in Appendix B.
After you successfully move payments and remove unused vendors, compact your Accounts Payable master
file and Accounts Payable current transaction file. See “Compacting files using File Doctor” on page 55 in
Appendix A for more information.
Note: This compacting process may be lengthy, depending on the size of your files and your system.
Please allow sufficient time to complete the process.
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When it is time to close the calendar year or fiscal year, perform the steps outlined in this chapter.

Year-end closing checklist for Property Management
Tasks

Comments

□

Reconcile Property Management receivables to General Ledger.

□

Print management reports.

□

Make a backup copy of your entire database, if you have not already
done so.

See page 49.

□

Advance to a new calendar year (and new fiscal year if applicable) by
selecting Tasks > Close Current Period.

See the next section.

□

(Optional) Archive Property Management data.

See page 77

□

(Optional) Perform file maintenance

See page 20.

Closing the calendar or fiscal year
Property Management tracks year-to-date totals based on both the calendar year end and the fiscal year end
specified during property setup. If you operate on a calendar year, the process is triggered when you select
Tasks > Close Current Period and the period-end date is advanced from December to January. The fiscal
year-end process is triggered when you advance to the new fiscal year.
Data changes that occur during either the calendar or fiscal year-end are built into Close Current Period
process. In addition to monthly changes, which occur during Close Current Period, changes are made to your
Property Management data when a current period end advances to a new calendar or fiscal year.
Be sure to print the necessary reports you typically print each month before you close the current billing period
and advance to January. As usual, confirm that you have backed up your Property Management files before
you select Close Current Period.
The following table describes the data changes that occur during each type of year-end process. These tasks
are performed in addition to the tasks you perform every period.
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Calendar Year-End

Changes the Annual Interest totals on the lease
deposit fields:
n

n

n

The value in Interest Paid YTD is moved to
Interest Paid Last Year.

Fiscal Year-End
Changes the totals in the Miscellaneous Income
fields: (Tax fields appear only if you are tracking
taxes.)
n

n

The amount stored in Income YTD is moved to
Income Last Year.
Tax YTD is moved to Tax Last Year.
The amount stored in Income Next Year is
moved to Income YTD.

The value in Interest Paid Next year is moved to
Interest Paid YTD.

n

Interest Paid Next Year is set to zero.

n

Tax Next year is moved to Tax YTD.

n

Income Next Year is set to zero.

n

Tax Next Year is set to zero.

Deletes old Property Calendar Year Occupancy
records, if appropriate, based on the number of
years that you retain occupancy.

Deletes old Property Fiscal Year Occupancy
records, if appropriate, based on the number of
years that you retain occupancy.

Deletes old Property Calendar Year Accumulator
records, if appropriate, based on the number of
years that you retain each accumulator.

Deletes old Property Fiscal Year Accumulator
records, if appropriate, based on the number of
years that you retain each accumulator.

Deletes old Unit Calendar Year Accumulator
records, if appropriate, based on the number of
years that you retain each accumulator.

Deletes old Unit Fiscal Year Accumulator
records, if appropriate, based on the number of
years that you retain each accumulator.

Deletes old Lease Calendar Year Accumulator
records, if appropriate, based on the number of
years that you retain each accumulator.

Deletes old Lease Fiscal Year Accumulator
records, if appropriate, based on the number of
years that you retain each accumulator.

Deletes old Lease Calendar Year Sales Volume
records, if appropriate, based on the number of
years that you retain sales volume history.

Deletes old Lease Recovery Expense Amount
records.
Advances fiscal year-end date on the property.

Note: Occupancy records and accumulator records are retained for the number of years you specify
during their respective setup. If you specify zero years, the record totals are retained indefinitely.
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Maintaining your files
Use Clear Paid Items to clear open items that are completely paid and move all the related entries from the
current transaction file to a history transaction file. Miscellaneous Income, Accumulator Adjustment,
Reference, Vacancy Loss, and Straight Line Rent entries are also moved. Enter a cutoff date to limit the
entries that are affected. You should only clear paid items that are no longer accessed on a daily basis.
Move Entries allows you to move transaction records from one history file to another. Transactions are moved
from Current to History through the Clear Paid Items process.
Use Archive Leases to move canceled or historical leases and their related records to archive files within your
live data folder.
For detailed instructions, see “Property Management archive procedures” on page 77 in Appendix B.
After you successfully move paid items, compact your Property Management current transaction file. See
“Compacting files using File Doctor” on page 55 in Appendix A for more information.
Note: This compacting process may be lengthy, depending on the size of your files and your system.
Please allow sufficient time to complete the process.
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When it is time to close the fiscal year, use the instructions in this chapter to close the fiscal year in the
following applications:
l

Accounts Receivable; see the next section

l

Cash Management; see page 22

l

Contracts; see page 22

l

Equipment Cost; see page 23

l

Job Cost; see page 23

l

Service Management; see page 24

It is not necessary to close the fiscal year for these applications in this order. However, close the fiscal year in
General Ledger last, as explained in the next chapter.
Note: Do not close the fiscal year at the end of the calendar year in these applications unless your fiscal
year also ends on December 31.

Accounts Receivable
To close the fiscal year:
1 Enter and post all invoices and cash receipts for the fiscal year.
2 Print the month-end and year-end reports that are required by your company.
3 Back up your Accounts Receivable files. See “Backing up files using File Tools” on page 53 for more
information.
4 Select Tasks > Close Year, verify the year-end dates, and click [Start].
Accounts Receivable clears the year-to-date fields and then moves the next year totals into the year-todate fields. In addition, the Year-end date in the AR Settings window is changed to the new year.
5 Move paid invoices to a history file. See “Accounts Receivable archive procedures” on page 62 for more
information.
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Cash Management
Cash Management tracks interest received on an annual basis by bank account. You can view the Year to
date, Next year to date, and Last year to date interest for a bank account on the Interest tab of the Bank
Accounts window; (select Setup > Bank Accounts). The accumulation in these fields is controlled by the
Year-ending date in the CM Settings window.
Before closing the year, verify that all interest received has been recorded. Compare the Year to date interest
shown in the Bank Accounts window is the same as the year-to-date interest on your December bank
statement.
To close the year:
1 If needed, make adjustments to a bank register; (select Tasks > Edit Register, select the bank account,
click [OK], make changes in the Edit Register window, and click [Finish]).
2 Post any cheques and files for the current year by selecting Tasks > Post Entries.
3 Select File > Company Settings > CM Settings and verify that the current date is displayed for Yearending date in the CM Settings window.
Note: If the year in this window is earlier than 2019, close the year until this year-end date is correct.
4 Reconcile your December bank statement. See “Reconciling” in the Cash Management Help for more
information.
5 Back up your Cash Management files. See “Backing up files using File Tools” on page 53 for more
information.
6 Select Tasks > Close Year, verify the year-end dates, select the CM Master file has been backed up
check box, and click [OK].
Cash Management moves the interest amounts into the appropriate year-to-date fields in the Bank
Accounts windows. In addition, the Year-ending date in the CM Settings window is changed to the new
year.
7 Move entries from the register file to a history file. See “Cash Management archive procedures” on page 64
for more information.

Contracts
Although the Contracts application has no official year-end procedures (because the data is processed on a
contract-to-contract basis), you may want to perform the following steps:
1 Print the month-end and year-end reports that are required by your company.
2 Back up your Contracts data files. See “Backing up files using File Tools” on page 53 for more information.
3 Post entries (by selecting Task > Post and clicking [Start]) and verify that the transactions were posted by
reviewing the posting journal.
4 Select Tasks > Close Month, verify the months, and click [Start].
If the month that you are closing is the last month in the fiscal year, the application clears the year-to-date
fields and changes the fiscal year-end date in the CN Settings window.
5 For those contracts that are complete, change their status to Closed:
a Select File > Open Contract, highlight the contract, and click [OK].
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b Click the General tab.
c Move the Status slider to Closed.
d Repeat these steps for each completed contract.
6 Move closed contracts to a history file. See “Contracts archive procedures” on page 65 for more
information.

Equipment Cost
Although the Equipment Cost application has no official year-end procedures (because the data is processed
on an equipment-by-equipment basis), you may want to perform the following steps:
1 Enter and post all transactions.
2 Print the month-end and year-end reports that are required by your company.
3 Back up your Equipment Cost files. See “Backing up files using File Tools” on page 53 for more information.
4 Select Tasks > Close Month, verify the months, and click [Start].
When you close the last month of the fiscal year, the application clears the year-to-date and month-to-date
fields.
5 If desired, move transactions to a history file. See “Equipment Cost archive procedures” on page 66 for
more information.

Job Cost
Although the Job Cost application has no official year-end procedures, you may want to perform the following
steps:
1 Print the month-end and year-end reports that are required by your company.
2 Back up your Job Cost data files. See “Backing up files using File Tools” on page 53 for more information.
3 Select Tasks > Close Month, verify the months, and click [Start].
If the month that you are closing is the last month in the fiscal year, the application clears the year-to-date
fields and changes the fiscal year-end date in the JC Settings window.
4 If desired, either:
p

p

Move transactions for closed jobs to a history file in your active data folder and moving closed jobs to an
archive folder.
Move closed jobs and their transactions to an archive data folder.

See “Job Cost archive procedures” on page 68 for more information.
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Service Management
To close the fiscal year:
1 Enter and post all entries for the year.
2 Print the month-end and year-end reports that are required by your company.
3 Back up your Service Management files. See “Backing up files using File Tools” on page 53 for more
information.
4 If desired, move work orders to a history file. See “Service Management archive procedures” on page 81 for
more information.
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When it is time to close the fiscal year, close the fiscal year in your other applications before closing the fiscal
year in General Ledger.

Year-end closing checklist for General Ledger
Task

Comments

1. Prepare for fiscal year end

See page 26

□

Record and post all entries for the current fiscal year. Review and
correct rejected entries.

□

Verify that all suspense-type accounts have a zero balance.

□

Print a trial balance, current ledger, and any other month-end reports.
Verify they are in balance.

□

Reconcile other applications to General Ledger.

□

Print financial statements.

□

Make a backup copy of your entire database, if you have not already
done so.

See page 49.

2. Perform final General Ledger year-end closing steps

See page 26

□

Print a year-to-date ledger.

□

Close the fiscal year by selecting Tasks > Close Fiscal Year.

□

3. Make adjustments to prior fiscal year if necessary

See page 28

4. (Optional) Perform file maintenance

See page 28

□

Archive General Ledger data.

See page 67

□

Compact files.

See page 55
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Preparing for year end
Perform the standard steps for a normal month-end closing. These steps should include the following:
1 Be sure that all Sage 300 Construction and Real Estate entries are completed.
2 Post all new files.
3 Use the journal to verify that no entries for the current year were rejected. Review and correct any rejected
entries.
4 Verify that all suspense-type accounts have a zero balance. This is necessary for Close Fiscal Year to
move balances properly and post to retained earnings.
5 Print a trial balance, current ledger, and any other month-end reports.
6 Balance General Ledger and reconcile it with other applications.
7 Print financial statements.
8 Back up your General Ledger files. See “Backing up files using File Tools” on page 53 for more information.

Closing the fiscal year
Note: Do not close the fiscal year at the end of the calendar year unless it is also the end of your fiscal
year.
Typically, General Ledger will be the last application you close. You can close Accounts Payable, Payroll,
Property Management, and other applications first and then continue posting entries for the new year because
General Ledger stores up to six months of future activity.
This process lets you print all of the standard reports (current ledger, trial balance, and financial statements)
for each period in the new fiscal year. When you receive adjusting entries for the previous year, you will post
them as prior year adjustments. You may then print adjusted financial statements for the prior year and each
period in the new year, as well as reprint the prior year’s year-to-date ledger.
Caution! Make adjustments to the suspense accounts to bring the suspense account balances to zero
for the year before you select Tasks > Close Fiscal Year. This task will not close out the suspense
account, and the retained earnings entry may be incorrect.
1 Complete your monthly closing procedures.
2 Back up your General Ledger files to store off-site. See “Backing up files using File Tools” on page 53 for
more information.
3 Print your current ledger and financial statements reports.
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4 Print a year-to-date ledger.
Note: If you have transactions in a history transaction file (History.glt), you should select the
appropriate option in Tran files for YTD ledger in the GL Settings - Ledger Settings window before
you print the year-to-date ledger.
Caution! Before you close the fiscal year, back up your General Ledger files. The process of closing
the fiscal year is intensive. If it fails, you must restore from a backup. Remember that the General
Ledger master file cannot be used by other applications while you close the year in General Ledger.
5 Select Tasks > Close Fiscal Year to close the year. If you have multiple prefixes, select the appropriate
prefix level to close.
Use a copy of your income statement to verify the amount posting to retained earnings. If the amounts
agree, proceed. Otherwise, cancel and determine the problem before you proceed. Be sure to check the
suspense account, because entries in suspense will not close to retained earnings at year-end.
If both fiscal percentages (on the retained earnings account) and partner percentages (in the GL Settings–
Partners window) exist, the partner percentages will override fiscal percentages to distribute the retained
earnings. For more details see “Close Fiscal Year” in General Ledger Help.
The Close Fiscal Year process:
p

p

Creates the entries that close the income and expense account balances to the retained earnings
accounts in the history transaction file (History.glt).
Clears the current balance of the income and expense accounts and posts the net income or loss to the
retained earnings accounts in the General Ledger master (.glm) file. The closing entries are not reflected
in the activity field for the last month of the fiscal year. This allows the system to retain the activity totals
for reporting purposes. Closing transactions are posted to the History.glt file.

p

Advances the year-end balances one year.

p

Advances the fiscal year-ending and period-ending dates.

p

Advances the account activity fields one period, changes the current activity on all accounts to zero, and
moves in any posted future activity.

p

Advances future activity one period.

p

Prints a Close Fiscal Year journal that lists the closing entries.

6 Back up your General Ledger files again after you select Tasks > Fiscal Year, and store this backup copy
off site.
7 We recommend you back up your entire data base, creating an annual archive after completing your yearend processing. This archive can be used for restoring data or reporting purposes.
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Making prior year adjustments
To make prior year adjustments:
1 Back up your General Ledger files before making any prior year adjustments. See “Backing up files using
File Tools” on page 53 for more information.
2 Select Tasks > Open/Close Posting Period.
3 Select the entity that you want to use.
4 Click the appropriate Closed Period check box to clear it.
5 Select Tasks > Record Entries to enter all prior year adjustments using the prior year accounting date.
6 Select Tasks > Post Entries to post the entries.
7 Back up your General Ledger files again before you proceed.
Caution! The process of closing the fiscal year is intensive. If it fails, you must restore from a backup.
8 Select Tasks > Close Fiscal Year to close the prior year adjustments to retained earnings.
9 Reprint financial statements for the prior year. Enter the number of periods to roll back in the Rollback field.
10 Reprint financial statements for the current year periods to reflect the prior year adjustments using the
rollback option.
11 Reprint the year-to-date ledger with the date range set to the prior fiscal year.
12 Re-close the prior period by selecting Tasks > Open/Close Posting Period and selecting the Closed
Period check box that you cleared in step 4.
13 If desired, move the prior year transactions to the History.glt file with Tools > Move > Transactions >
Current to History.
14 Be sure to transfer only prior-year transactions. Also, be sure to enter the fiscal year-ending date as the
cutoff date.

Maintaining your files
If you have more than two years of transactions in the History.glt file, you may want to move the oldest year to
an archived history file. For detailed instructions, see “General Ledger archive procedures” on page 67 in
Appendix B.
After you successfully move transactions, compact your General Ledger current transaction file. See
“Compacting files using File Doctor” on page 55 in Appendix A for more information.
Note: This compacting process may be lengthy, depending on the size of your files and your system.
Please allow sufficient time to complete the process.

Common General Ledger questions and answers
How do I clear the balance in a suspense account?
Make reversing entries to a suspense account. Refer to “Correcting suspense account entries” in General
Ledger Help.
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If I close General Ledger, will I still be able to post prior year adjusting entries that my
accountant sends me?
Yes. If you want to close the year in order to print current financial statements in the new year, you can
always open the prior period and post those entries. Just do not forget to close the fiscal year again if it is an
entry to an income or expense account. Also, do not forget to go back and close the posting period again
(Tasks > Open/Close Posting Period). For more information, see “Closing the fiscal year” on page 26.

How do you close the last period of the year?
Select Tasks > Close Fiscal Year.
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Follow the instructions in this chapter to generate T4 forms in preparation for eFiling your forms using Aatrix
services. The T4 forms report the taxable wages earned by your employees during the previous calendar year.
Before producing the T4 forms, all 2013 payroll cheques must be posted. You may also want to close the
Payroll year, but you can produce the T4 forms before or after closing the Payroll year.

T4 forms checklist
Task

Comments

□

Create or modify your T4 template. Aatrix uses these settings to
produce your T4 forms.

See page 30.

□

Back up the Payroll information.

See page 49 in Appendix A.

□

Generate the T4 forms.

See page 32.

Note: If you have Indian employees, their Code 71 year-to-date earnings should be subtracted from their
provincial year-to-date gross on the T4 form for their primary province. For more information, see Sage
Knowlegebase article 96713.

Creating or modifying your T4 formats
You can control the information that prints on the T4 form. You can modify the standard T4 format already
designed for you, or you can create an entirely new one.
Note: For more information about T4 formats, see the "Modifying T4 formats" topic in Payroll Help.
To create or modify a T4 format:
1 In Payroll, select Tools > Modify Forms > T4 Formats.
2 In the Modify T4 Formats window you can choose or create a T4 format:
p

To select an existing format, click [List], select the format, and click [OK].

p

To create a new T4 format, enter a format name for T4 form and a description for the new format.

3 Press TAB to access the Controls tab.
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4 If appropriate, change the Employee minimum, which is the minimum amount of taxable earnings that the
employee must have for the T4 form to be generated. For example, if this is 0.01, the software does not
generate a T4 form for an employee with zero taxable earnings. If this is 0.00, the software generates a T4
form for all employees.

5 Click the Amounts tab. Most of the required information for the T4 form is automatically filled in for you.
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6 If you need to report additional information, use tax boxes 44, 46, 50, and 52. See the Payroll Help for more
information.
p

p

To add any other pays, deductions, or fringes, select the appropriate tax box, click [Pays], [Deducts], or
[Fringes], select the desired item, and then click [OK].
If needed, use the Other Information Boxes area of this window to enter up to six codes and amounts
that relate to employment commissions, taxable allowances and benefits, deductible amounts, and other
entries. See the Employers' Guide - Filing the T4 and T4F Slip and Summary Forms (available from the
Canada Customs and Revenue Agency) for a list of valid codes and their descriptions.

7 Click [Save] and then click [Close].

Before you begin processing the T4 forms
n

n

n

Back up your Payroll information. See page 49 in Appendix A for instructions.
If you plan to electronically file your tax forms, you must enroll with Aatrix. For more information, see
page 5.
Make any desired changes to the T4 formats, as described on page 30. Aatrix uses these formats to
generate the T4 forms.
Tip: If you do not want to generate T4 forms for employees with zero taxable withholdings, set the
Employee minimum amount to .01 in the Modify T4 Formats window; see page 31 for more
information.
Notes:
l

l

Changes you make in Aatrix are not written back to the Sage 300 Construction and Real Estate
Payroll database.
Since eFiling can take up to two days, schedule accordingly.

Processing data for the T4 forms
1 In Payroll, select Tasks > eFile and Reporting.
If you receive a prompt to update tax forms, select [Automatic Update] to ensure you have the latest
updates so you are in compliance with the latest CCRA-mandated changes. For more information, see
page 6.
If you previously saved a report, the system displays two choices.
l

l

If you want to create a new report, select New report and click [Next].
If you want to use a saved report, select Saved reports, click [Next], verify your Canadian Tax ID
number, click [Open], select the desired report in the Open Report window, and click [Edit].
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2 In the Federal eFile and Reporting window, select the report, select the year, and click [Next >].

3 If more than one T4 format was set up, select the T4 format that you want to use for this report in the T4
Format Selection window .
4 In the Employees to Process window, select the check box before the employees that you want to
include, and then click [Next >].

Tip: To clear all of the check boxes, click [Select None]. To select all of the check boxes, click
[Select All]. To select a range of check boxes, highlight the check boxes and then click one of the
highlighted check boxes; to highlight the rows, you can highlight the first row of the range, and then hold
down SHIFT as you click the last row of the range.
5 If you are asked to select a report, select the T4 Official Report (not the Québec RL-1 Official Report)
and then click [OK].
Note: If you select the Québec RL-1 Official Report, you will need to type the information in
manually.
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6 In the Generate Federal Report window, click [Generate] to open the T4 Setup Wizard. If you have
already set up your T4 report, the wizard will not appear.

Using the T4 Setup Wizard
The first time you generate a T4, a wizard opens to help you set up your report.
Tip: For information about windows in the Canada Setup Wizard, click
the Aatrix help system.

(the help button) to access

Repeat the process in this section for each company account number you will use to file T4 forms. If you have
more than one company account number, but only one Payroll master file, you can repeat this process
multiple times. With each run, change the Employer ID, then begin the eFiling process. Select which
employees to include for each company account number in accordance with step 4 of the preceding section.
1 If you are asked to select a report, select the T4 Official Report (not the Québec RL-1 Official Report)
and then click [OK].
2 Select one of the processing options, and then click [Next]. You may want to select "test drive" mode to run
through the process first.
Note: In test drive mode, no information is saved after you print your forms. Do not use test drive mode
when processing your final T4 forms.
3 Verify your Account Number, and then click [Next >].
Caution! If you need to change this number, close the Setup Wizard. In Payroll, select Setup > Taxes
> Tax Groups, and type the correct number for Employer ID in the Tax Group Setup window.
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4 The Company Information window displays information included on the forms you are filing. Verify that all
information is correct, enter missing information, and then click [Next >].

Tip: Click

(the Help button) for detailed information about what to enter in this window.

5 In the T4 Summary Information window, enter the remittances that will appear in Box 82 of the T4
Summary, and then click [Next >].

6 In the Multiple Payroll Data Files window, select either:
p

Yes if you use multiple payroll data files for the same federal account number.

p

No if you use a single payroll data file.
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Verifying employee information
The grid in the Canadian Preparer window displays employee information in rows and columns. The columns
in the grid correspond to the boxes on the T4 forms.
During each step of the verification process, you can review, make corrections, and add information to the
cells. Missing or incorrect information is indicated with a red cell.
Click

(the Help button) for a full description of the grid functions.

1 Verify and correct the employee names and addresses that are highlighted.
A red cell in the grid contains an error. You must correct the errors before you can continue.
Note: Any changes you make in this grid are not written back to your Payroll database. You must also
correct the data within Payroll.

After verifying or correcting the employee information, click

.

2 Verify that the information in the right side of the grid is correct, make any corrections, and then click [Next
Step]

2019 Year-End Procedures and Government Forms Guide

Page 36

Chapter 7: Producing T4 forms

Selecting filing options and generating the forms
1 The T4 Printing and Filing Options window displays your options for eFiling and printing the T4 forms as
well as the associated costs. Select the desired options.

2 Click [Next] and follow the on-screen instructions.
3 In the Review your Action List window, review the list of reports, and then click [Next >].
4 You will now see each of the reports displayed in Aatrix. Follow the on-screen instructions to review, make
corrections, and print the forms.
p

p

In the Review/Edit step, fill in the required fields, which are highlighted in red. You can also make
changes to the fields highlighted in blue.

If desired, print a copy of the form by clicking
, making selections in the Print window, and
clicking [OK]. Even if you choose to eFile, print copies of the forms for your office records.

When you have completed your review and edits of each page, click
Click

.

(the Help button) for more information about the windows.
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Common T4 form questions and answers
Will the period-end date of my last payroll affect my T4 forms?
Payroll always posts by cheque date. T4 forms should only include the dollars paid to the employee during
the year being reported (2019). Cheques dated January 2020 or later, regardless of the period-end date,
are not included in the T4 totals for 2019.

If I have multiple Payroll master files, should I move all my employees into one Payroll
master file before producing the T4 forms?
You are required to combine employees in all master files only if the same business number and location
code applies to all master files. If you have multiple location codes, see the Knowledgebase for articles
containing additional information about generating and eFiling the T4 forms. Log into the Sage
Knowledgebase and search for articles containing "location codes" in their titles.
If any employees were terminated in 2019, do not use the Move Employees tool to archive the terminated
employee information until after you produce their T4 forms.
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Follow the instructions in this chapter to generate T5018 forms in preparation for eFiling your forms using
Aatrix services.

Before you begin processing the T5018 forms
n

n

n

n

Ensure that all invoices and cheques for the reporting year have been posted for the vendors.
Verify vendors are set up to receive T5018 forms. (This is set on the T5018 Settings tab of the Vendor
Setup window.)
Back up your Accounts Payable files. See “Appendix A: Backup Procedures” on page 49 for more
information.
If you plan to electronically file your tax forms, you must enroll with Aatrix. For more information, see
page 5.
Notes:
l

l

Changes you make in Aatrix are not written back to the Sage 300 Construction and Real Estate
database.
Since eFiling can take up to two days, schedule accordingly.

Processing data for the T5018 forms
1 In Accounts Payable, select Tasks > Government eFile and Reporting > Form T5018 (CAN).
You may receive a prompt to update tax forms when you select this task. To ensure you are always in
compliance with the latest government-mandated changes, select [Automatic Update] in the Update
Forms window. See “Forms update” on page 6 for more information.
2 If you already saved a T5018 report, you can create a new report or you can open a saved report. To open a
saved report:
a In the Form T5018 (CAN) window, select Saved T5018 report, and then click [Next].
b Select the form and the Canadian Tax ID number, and then click [Open].
c In the Open Report window, select the report you want to open and click [Edit].
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3 If you are creating a new T5018 report, verify or enter the following items in the Form T5018 (CAN)
window, and then click [Next >]:
p

p

p

p

p

T5018 Amounts to Report: Select whether to generate the report by the total paid to vendors or by
fiscal entity. If you select Fiscal Entity, you must also select the GL Prefix; the Canadian Tax ID for
that GL prefix will be used for your forms.
Start Date: Select the beginning date of the reporting period. If your reporting period is the same as the
calendar year, select January 1.
End Date: Select the end date of the reporting period. If your reporting period is the same as the calendar
year, select December 31.
Minimum Reporting Amount: Type the minimum reporting amount. Only vendors with income that
equals or exceeds this amount will be included on the report.
Canadian Tax ID: Type the number you want to use when filing the T5018 form. It must be 9 digits,
followed by 2 letters, followed by 4 digits.

2019 Year-End Procedures and Government Forms Guide

Page 40

Chapter 8: Producing T5018 forms

4 In the Vendors to Process window, select the check box in front of each vendor that you want to include,
and then click [Next >].

5 In the Generate Form T5018 (CAN) window, click [Generate] to generate the data and open the T5018
Setup Wizard

Using the T5018 Canada Setup Wizard
Tip: For information about windows in the Canada Setup Wizard, click
the Aatrix help system.

(the help button) to access

1 Choose whether to test drive the T5018 wizard or to start processing the T5018 forms.
2 Verify your Account Number, and then click [Next >]. (To change this number, close the Setup Wizard. In
Accounts Payable, select Tasks > Government eFile and Reporting > Form T5018 (CAN) and type the
correct number for Canadian Tax ID in the Form T5018 (CAN) window.)
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3 The Company Information window displays information included on the forms you are filing. Verify that all
information is correct, enter missing information, and then click [Next >].

4 In the Multiple T5018 Data Files window select whether you need to merge multiple T5018 data files for
this report, and then click [Next >].
Select No if you use one data file in Accounts Payable.
Select Yes if you want to merge multiple data files.

Verifying recipients
The Canadian Preparer window displays information in a grid. The columns in the grid correspond to the
boxes on the form. Verify information highlighted for each step. Missing or incorrect information is indicated
with a red cell.
For information about this window, click

(the help button) to access the Aatrix help system.

1 Verify or correct each recipient's Taxpayer Identification Number (TIN), and then click
through the grid.

to proceed

Note: Any changes you make in this grid do not correct your accounting data. You must correct the
data within Sage 300 Construction and Real Estate for the changes to be permanent.
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2 Verify or correct the recipients' names and addresses, and then click [Next Step].
3 Verify or correct the payments box, and then click [Next Step].
The T5018 Printing and Filing Options window opens.

Selecting printing and eFiling options
The T5018 Printing and Filing Options window displays your options for eFiling and printing the T5018
forms as well as the associated costs, if any.

1 Select the desired options, and then click [Next >].
2 Review the list of reports, and then click [Next >].
3 You will now see each of the reports displayed in Aatrix. Follow the on-screen instructions to review, make
corrections, and print the forms. Even if you choose to eFile, print copies of the forms for your office
records.
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Follow the instructions in this chapter to generate ROE (Record of Employment) forms. You can either:
n

Generate and eFile your forms using Aatrix services.

n

Generate a file containing the forms within Sage 300 Construction and Real Estate.
Note: When a ROE form is submitted after 3 p.m. Central time, Aatrix processes it the next day.
Although this still meets Canadian government requirements, the delay may affect some contract
requirements that ROE forms be processed within 24 hours of the employee being laid off. If your
company has this requirement, generate the forms within Sage 300 Construction and Real Estate.

Entering employee termination information
When an employee is terminated, enter the Termination date and Reason on the Misc Info tab of the
Employee Setup window. The termination reason will be included on the ROE form for the employee.
Caution! If you rehired an employee who was laid off, but did not enter a Rehire date on the Misc Info
tab of the Employee Setup window, the ROE could report the same earnings twice in error.

Modifying your ROE forms
To set up or modify the information that most frequently applies to ROE forms:
1 In Payroll, select Tools > Modify Forms > ROE Forms.
2 In the Modify ROE Forms window, enter the applicable pay IDs for:
p

Vacation pay

p

Holiday pay

p

Other monies

p

Special payments (such as sick, maternity, parental leave, or group wage loss indemnity payments).

Also select the type for vacation pay, other monies, and special payments.
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3 Click the Other tab, enter the current contact information, issuer information, and comments (if needed) to
include in Box 18 on the ROE form.
Note: Because the comments are reviewed manually by a Service Canada agent, only include
comments if there are specific details about exceptional circumstances that you want to explain.

4 Click [OK].
Note: Changes made in the Modify ROE Forms window are included when you generate the ROE form
in Tasks > eFile and Reporting. Changes made while generating or eFiling the ROE form in Aatrix
are not written back to Payroll.
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Generating and eFiling your ROE forms with Aatrix
To generate and eFile the ROE forms:
1 In Payroll, select Tasks > eFile and Reporting.
2 In the Federal eFile and Reporting window, select the ROE Record of Employment report, select the
ROE Date, and click [Next >].

3 In the Employees to Process window, select the check box before the employees that you want to
include, and then click [Next >].

4 In the Generate Federal Report window, click [Generate].
5 Aatrix displays the first form. Verify or correct the content on the forms. Missing or incorrect information is
indicated with a red rectangle.
Tip: Click

(the Aatrix Help button) for more information.

6 When you have finishing correcting the forms, click
Complete window.

7 Click

, and then click [Agree] in the Verify Report

to print a copy for your records, and then click

.

8 In the Filing Options window, click the icon for the desired options, and then follow the directions in Aatrix.
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Generating the forms within Sage 300 Construction and Real
Estate
When you generate ROE forms, you can select up to six current and/or history Payroll Transaction files from
which to pull data for the ROE forms. For example, you may have moved all of your Payroll data for the
previous year to a history transaction file. Until the end of the current year, you will need to be able to print
ROE forms using data from the history file and data from the current file. You will be able to access both files
simultaneously for purposes of generating ROE forms.
ROE forms can be generated for one or multiple employees in a single run. Any information that you enter in
the Print ROE Forms - Print Selection window or in the ROE Forms - Printed Form Options window will
be used for all ROE forms generated during the current run.
To print the ROE forms:
1 In Payroll, select Tasks > Generate ROE.
2 Select the oldest Payroll transaction file that you want to use, and then click [OK]. If you want to add
another transaction file, click [Yes]. When you are finished adding transaction files, click [No] in the prompt
to add another file.
3 In the Generate ROE - Print Selection window:
a Enter your company's business number and verify your company's address.
b If needed, change the issue status or ROE date.
c Make a selection for Expected Date of Recall. If the employees will be recalled on a specific date,
select Date and specify the expected date.
d Specify the name of the export file to create.
e Select the Generate export file for employees without errors check box if you want the program to
create the export file for all employees that do not have errors. Otherwise, clear the check box.
f To select the employees to include, click [Ranges], select the employees, and click [OK].
g To specify conditions to limit the employees included on the ROE forms (such as those who have a
specific termination date), click [Conditions], set up the condition, click [OK], verify the condition
selection, and click [OK].
Caution! If you do not limit the employees included (by using ranges or conditions), all employees will
be included in the ROE export file (unless they have errors).
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4 If you want to override ROE settings for the current ROE run:
a Click [Options],
b In the ROE Forms - Printed Form Options window, make the desired changes.
Note: These changes will apply to the current run only.
c Click [OK].
5 In the Generate ROE - Print Selection window, click [Start]. If your program is set up to save the journal
as a file, specify the file name.
6 Review the journal.
7 If there are no errors, upload the export file to the Service Canada website.
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Throughout this guide you are asked to back up and copy files. These copies are important:
p

To preserve an off-site copy in case of damage to your building.

p

To eliminate the need to re-key data in case of damage to your system.

p

To ensure that you have a copy of your files for reference before you close the current year.

Important! With any backup tool, we recommend that you validate and test the backup to ensure that the
process is working properly. Environmental issues and files in use can affect the integrity of a backup.
Restoring your business data requires advanced knowledge of the Actian Pervasive, Microsoft SQL (if
using), and Sage 300 Construction and Real Estate file systems. We strongly recommend you undertake
this process with a knowledgeable professional, such as your business partner, certified consultant, or
Sage Customer Service representative.

Files to copy
This section lists the file names to back up or copy in each application.
l

l

l

Be sure to show file extensions to ensure proper operation.
These procedures use default file names (for example, Current.glt and History.glt). If you use
named files, substitute your named files for the default names.
History files such as History.apt or History.glt are created when you select Tools > Move to move a
file to history. For more information on moving files to history, see the topics on "File Maintenance" in
each section of this book.

Refer to the list on the following pages when you are instructed to back up or copy files for a specific
application.
Note: The files in the list are required for reporting. When you back up your entire database, these files
will be included. If you need to restore your Sage 300 Construction and Real Estate database, you should
restore the backup of your entire database.
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Accounts Receivable
Accounts Payable
l

l

l

l

l

l

l

l

l

l

Activity.ara

l

Billed.bli

l

Current.art

l

Billed.blw

l

History.ara

l

History.blt

l

History.art

l

History.blw

l

Master.arm

l

Master.blm

Master.txm
(if using taxes)

l

l

New.art

l

New.blt

l

Standard.ars

l

Standard.bls

l

Ts.ctl

l

Ts.ctl

l

User.frm

l

Unbilled.bli

l

View.arv

l

Unbilled.blw

l

User.frm

Current.apt
History.api
History.apt
Master.apm
Master.txm
(if using taxes in AP)

l

New.api
Standard.aps
Ts.ctl
User.frm
(in the Formula folder)

Cash Management

Billing

Contracts

Master.txm
(if using taxes)

Equipment Cost

l

History.cmt

l

Contracts

l

Current.eqt

l

Master.cmm

l

Active.cna

l

History.eqt

l

Register.cmt

l

Active.cnc

l

Master.eqm

l

Ts.ctl

l

Active.cnt

l

New.eqt

l

User.frm

l

Settings.cns

l

Standard.eqs

l

Ts.ctl

l

Ts.ctl

l

User.frm

l

User.frm

General Ledger

Job Cost

Payroll

l

Current.glt

l

Current.jct

l

Current.prt

l

History.glt

l

History.jct

l

History.prt

l

Master.glm

l

Master.jcm

l

Master.prm

l

Ts.ctl

l

New.jct

l

Pr.frm

l

User.frm

l

Ts.ctl

l

System.prs

l

User.frm

l

Tax.prx

l

Ts.ctl

l

User.frm
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Property Management
l

Accum.pma

l

Current.pmt

l

History.pmt

l

Issue.pmz

l

Lease.pml

l

Master.txm
(if using taxes)

l

New.pmt

l

Property.pmp

l

Recovery.pmv

l

Retail.pmr

l

System.pms

l

Tenant.pmn

l

Ts.ctl

l

User.frm

Note: Files that can be named will have the same extension as those listed in the table above. For
example, January.api would be a named invoice file.
Other data folders to back up include:
l

l

Purchasing and Inventory files, which are located in the POIVData folder under your company data
folder.
Service Management files, which are located in the SMData folder under your company data folder. If
you have SM files in a different location, note the location by selecting File > Data Folder Settings >
File Locations > SM Data.
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Backing up files using System Administrator
We recommend that you use the backup operation in the System Administrator tool to back up your company
data (including the global, Service Management, Purchasing, and Inventory data) on a regular basis. See the
Using System Administrator to back up and restore your data video for more information.
Note: Although you can still use File Tools to back up and restore your company data stored in
Pervasive, File Tools does not back up and restore the SQL data.
Important! Perform the backup during off hours so that nobody is accessing or changing the data. If
someone is using the software, some data files may be locked and the backup will fail.

To use System Administrator to back up data:
1 On the server, access the tool by selecting the Sage Administration program group (from the Start menu)
and then selecting System Administrator.
2 Click the Backup tab.
3 Your company folders are shown in a table. Select the Backup check box in front of the companies to
include in the backup.
If you have more than one company, we recommend that you back up all of them.
4 In the Files column, select the type of files to back up:
l

l

All: Includes print files or other file types that were saved inside the company folder as well as the
data files.
Data only: Only includes the Pervasive files and folders (not other file types such as .bmp and .txt
files) inside the company's data folder.
Note: We recommend that you select All. The Sage\Timberline Office\9.5 folder is always
included in the backup.

5 If you need to add other folders or files to the backup, click [Add Folder] or [Add File] and then select the
folder or file; it will be listed in the table.
Note: You may want to include folders containing attachments that are not already in the data folders.
6 Select the folder to store the backed-up data by either:
l

Typing the path.

l

Clicking [Browse] and selecting the folder.

7 To schedule a time every day for an automatic backup, select the Automatically back up every day at
check box, select the time, and click [Save].
Tip: The automatic backup selection creates a Task in the Windows Task Scheduler. You may be
able to use that tool to adjust the timing and days of the week to back up the data automatically.
8 To back up your data immediately, click [Save] and then [Back Up Now].
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When the backup runs, success and failure messages display on your screen. If there is a failure, click
[View Log] to view the log file to determine the issue.
The backup process creates a zip file named backup<DATE>_<TIME>.zip that contains:
l

The Pervasive data folders for the companies you selected in step 3

l

The SQL database (if your data was replicated)

l

The 9.5 folder (without Wininst)

l

Any additional folders or files that you selected in step 5

l

Log files with the backup information

Backing up files using File Tools
Although we recommend that you use the backup operation in the System Administrator (as described on
page 52), you can use File Tools to back up the entire Sage 300 Construction and Real Estate data folder or
selected data files.
Note: When you use File Tools, the folder options of Windows Explorer should be set to display file
extensions.

To use File Tools to back up data:
1 Open Sage Desktop and select Applications > Common Tools > Tools > File Tools.
2 In the Operation Selection window, select Backup and click [Next].
3 In the Backup Operation window, select the folder or files you want to include.
p

To back up an entire folder, click [Add Folder] and then select the folder that contains the files to be
backed up. When you select a folder, all sub-folders are included. Use the down arrow at the right to open
a list of available drives and folders. You can navigate to a higher folder on the same drive or change the
search to another drive by selecting the applicable drive or folder. You can navigate one level upward by
clicking the folder icon with the up arrow. Perform this step for each data folder you want included in the
backup.
Tip: To back up your Purchasing and Inventory files separately, click [Add folders] and choose the
POIVData folder located under your company data folder. To back up your Service Management files
separately, click [Add folders] and choose the SMData folder located under your company data
folder. However, if you have SM files in a different location, note the location by selecting File >
Data Folder Settings > File Locations > SM Data.

p

To back up additional files (in folders that are not already selected), click [Add Files]. Select the files to
be backed up by holding down the CTRL key and clicking each file to highlight it. You can highlight all
files by pressing the CTRL + A keys. Click a file again to remove the selection highlight.

4 Click [Next].
5 For Destination, specify the name and location for the backup file or click [Browse] to locate the
destination folder.
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6 For Archive Name, type the name of the new archive file you want to create. You can click [Append] to
insert either a date and time stamp or to add a unique numeric value to the file. The .tsZip2 extension will be
used if you do not enter an extension.
Note: Be aware that if the .tsZip2 file you specify already exists, it will be overwritten by the new file.
7 (Optional) For Comment, type a comment that will appear with this backup if the backup is restored.
8 Click [Next] to begin the validation.
9 When the Validation Summary window appears, click [Next].
10 When the Verify Files window appears, verify that the correct folders and files are included, and then click
[Next].
11 When the Execution Summary window appears, verify that the process is correct, and then click [Next]
to start the backup.
12 When the Operation Journal window appears, review the processes that were performed, and then click
[Save] to save the journal or click [Print] to print the journal.
13 Click [Finish] to exit File Tools.

Copying files using File Tools
You can also use File Tools to copy selected Sage 300 Construction and Real Estate data files to another
location. These copies are meant to restore files immediately if a process does not finish successfully. They
are not meant to replace your full backup. When you use File Tools, show file extensions to ensure proper
operation.

To use File Tools to copy files:
1 Open Sage Desktop and select Applications > Common Tools > Tools > File Tools.
2 In the Operation Selection window, select Copy and click [Next].
3 To copy your entire data folder, click [Add Folder] then select the folder that contains the files to be copied.
Use the down arrow at the right to open a list of available drives and folders. You can then navigate to a
higher folder on the same drive or change the search to another drive by selecting the applicable drive or
folder. You can navigate one level upward by clicking the folder icon with the up arrow.
4 To copy individual files, click [Add Files] to open the list of files eligible for copying; then select the files to
be copied by holding down the CTRL key and clicking each file to highlight it. To remove a highlight, click
the file again. You can highlight all files by pressing the CTRL + A keys.
5 For Destination, specify the full path where files will be copied or click [Browse] to locate the destination
folder. If you are copying to a CD, choose the CD drive as the destination folder.
6 Click [Next].
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7 If any of the files being copied already exist in the destination location, a warning will appear for each one.
Select one of the following options for each warning:
l

l

l

l

[Yes]: Overwrite the file named in the warning.
[Yes to All]: Overwrite this file and any additional files that already exist and have duplicate names of
those being copied. No more warnings will appear.
[No]: Do not overwrite; remove this file from the list to be copied.
[No to All]: Do not overwrite this file or any additional files that already exist and have duplicate
names of those being copied. No more warnings will appear.

As the files are copied, the status is shown in the Progress window. If the validation process finds issues
that need to be resolved, the wizard will instruct you how to fix them.
Note: If you click [Back] before an operation is complete, the program returns to the previous window
without completing the operation. If you click [Cancel], you cancel any further operations and exit File
Tools; if any previous operations were already completed successfully, they are not canceled.
8 When the copy operation is complete for all files, review the processes that were performed, and then click
[Save] to save the journal or click [Print] to print the journal.
9 Click [Finish] to exit File Tools.

Compacting files using File Doctor
After successfully performing the archive procedures, use File Doctor to compact your data files. This
reduces the size of these files by compacting the unused space left behind by deleting or moving data.
Caution! You should only use File Doctor at the server so it is run on data stored on the local drive of the
computer. Using File Doctor over your network can severely damage your data. Do not run File Doctor
from a workstation on data stored on a server. Sage is not responsible for damage caused to your data as
a result of using File Doctor over the network.
To run File Doctor:
1 Back up your data files.
2 At the server, open Sage Desktop and select Applications > Common Tools > Tools > File Doctor.
3 Verify that you have a current backup of your data files and click [Yes].
4 In the Check files in section, select Current data folder.
Note: If you are using multiple data folders or you want to also compact your archive folder, select All
data folders instead. Compacting all data folders can take a considerable amount of time.
5 In the Tasks section, select the Compact good files check box.
6 In the Files list, select the files that you want to compact or click [All] to compact your entire data folder.
The files are grouped by application.
7 Click [Start] to start the compact process and print the report to a file or printer.
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Tip: The progress of File Doctor can be viewed in Background Tasks.
8 When the status is Completed Normally, review the report. If there are any errors, be prepared to restore
from backup.
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This appendix includes information about year-end file and disk maintenance (in the next section) and general
data archiving information. It also includes detailed considerations and procedures for the following
applications:
l Accounts Payable (page 59)
l Accounts Receivable (page 62)
l Cash Management (page 64)
l Contracts (page 65)
l Equipment Cost (page 66)
l General Ledger (page 67)
l Job Cost (page 68), Payroll (page 73)
l Project Management (page 75)
l Property Management (page 77)
l Purchasing and Inventory (page 79)
l Service Management (page 81)
There are no archive capabilities for Address Book or Billing.
For specific guidelines for your company or for additional assistance, contact your local Sage 300 Certified
Consultant or Sage Professional Services at Professional.Services@Sage.com.

Optional year-end file and disk maintenance
This appendix describes year-end file and disk maintenance routines that you may consider performing to help
keep your system running at optimum performance. You can also incorporate these procedures into your
monthly and quarterly procedures.
1 Archive and delete any print files (.prn) from your hard disk left from the previous year. For copying
instructions, see “Copying files using File Tools” on page 54.
2 Test backups by restoring them to test folders. These tests are important because backup media may have
a limited life, backup devices may malfunction, and you may have incorrect software settings in your
backup software. Also, if you use a tape drive, be sure to clean your tape device regularly, as
recommended by your tape device manufacturer.
3 Archive your data files. For more information, see “Archiving your data” in the next section.
4 Store your archived data in an off-site location.
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Archiving your data
When you archive your data, you move the data from your current files to history files, or from one history file
to another history file. You may create an archive data folder to perform some archiving tasks or to separate
historical data from current data. This is not the same as backing up your data (also called creating an archive
or archiving); backups protect your data from catastrophic loss. A good policy for doing both (backing up and
archiving data) will protect and enhance the performance of your data.
Archive your data on a regular basis to:
p

Reduce file size, which reduces processing and reporting time.

p

Reduce time requirements when you upgrade your current data.

p

Combine historical and current data for reporting purposes or enable you to report on each separately.

p

Streamline your selection lists to include only current records (jobs, employees, vendors, etc.).

p

Organize historical data.

We recommend that you develop a company-wide plan to archive your data. If your company has a
procedures guide, you may want to integrate this plan into your current procedures. Consider the following
items when you create this company-wide archive plan:
p

p

How frequently do you need to archive data in each application?
Do you move entries from your current transaction files to history files in the same data folder or to an
archive folder?

p

If you use named files, what is your naming convention for archived data files?

p

What is the naming convention of your archive data folders?

p

Where do you store your archived data?

Before you archive your data, perform the following tasks:
p

Back up your data before you archive your files. See “Appendix A: Backup Procedures” on page 49 for
more information.

p

Make sure that you have the proper permissions in the application and on the network.

p

Run any necessary reports. Your report results may change after you archive your data.

p

p

p

Some archive processes require that you create a new data folder by selecting File > New Company.
This creates a Ts.ctl file and enables you to access your archived data. Enter a new company name that
distinguishes the archive folder from your current data folder. Enter the correct data folder path name
according to your procedures. Select the Use current setup check box so the setup options are the
same in the archive folder as for the live data.
Assess the time it will take to archive your data. You must stop processing in the application in this data
folder while you are archiving the data. You may want to archive over the weekend so there is less
impact on daily processing.
Use File Doctor (by selecting Tools > File Doctor in the application) to identify any potential issues.
Note: File Doctor is not available in Purchasing / Inventory or Service Management.
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If you are moving data to an archive folder, make sure that all custom fields are available for general use. This
ensures that custom fields will be available in your archive folder if you need them for reporting purposes. For
example, if you use custom fields for jobs:
1 In Job Cost, select File > Company Settings> Custom Fields.
2 In the Custom Fields - Record Selection window, select a record (such as Job) and then click [Edit].
3 If you see the Do you want to make these custom fields available for general use? message, click
[Yes].
4 In the Custom Fields window, click [Close].
5 Repeat these steps for all of the records.
After you archive your data, perform the following tasks:
p

p

p

Back up your data files. See “Appendix A: Backup Procedures” on page 49 for more information. You
may need to modify your backup procedures to include archive data folders.
Reduce the size of your current files by compacting them. See “Compacting files using File Doctor” on
page 55 for more information.
Document which files were archived and where the data is stored. You may want to retain copies of the
archive journals as part of your documentation.

Accounts Payable archive procedures
In Accounts Payable, you can move payments and remove vendors you no longer use.

Moving payments
You can use the Move Payments tool to move payments and their related invoice information to a history file.
This keeps your historical payments separate from your current payments. It also decreases the size of your
data files and speeds processing time. After the payments are transferred to history, they can be used for
reporting purposes, but they can no longer be voided or edited.
When you move payments from current to history, transaction records in the Current.apt file move to the
History.apt file. The corresponding invoice, distribution, payment, tax distribution, invoice payment,
distribution payment, and tax distribution payment records move from the Master.apm file to the History.api
file. When you move payments from history to history to decrease the size of your historical file, invoice,
distribution, payment, tax distribution, invoice payment, distribution payment, and tax distribution payment
records move from the History.api file to another History.api file. Transaction records are not moved when
moving payments from history to history.
Before you move payments, review the following considerations:
p

p

Reports that use invoice detail from the AP master file (such as the JC Committed Cost with Detail
report), any Job Cost reports, or custom reports may be affected by moving payments. You may not
want to move payments until the related jobs are complete, depending on the level of detail required on
your Job Cost reports.
Using Report Designer, you can modify any report that uses the invoice detail from the Accounts
Payable master file to also include invoice detail from the history file. Refer to the “Data File Selection”
topic in Report Designer Help for more information.
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p

p

p

The Move Payments process in Accounts Payable moves cheques and other payments that have
cleared in Cash Management—but it does not move payments in Cash Management. See “Cash
Management archive procedures” on page 64 for more information.
The Move Payments process can be time intensive. Schedule adequate time to complete the process.
Because you cannot reprint the Accounts Payable Move Payments Report, these steps instruct you to
print to a file. To view the print file after the task completes, select File > Printouts, and then locate and
open the named print file.

Caution! Payments that are moved to history cannot be moved back to the current file. You cannot void
those payments or change the information for related invoices. We recommend that you make a backup
copy of your Accounts Payable data files before you move payments to history.

To move payments:
1 Make a backup of your Accounts Payable files. See “Appendix A: Backup Procedures” on page 49 for more
information.
2 In Accounts Payable, select Tools > Move > Payments > Current to History.
3 If a history file does not exist, click [OK] to create the file.
4 In the Move Payments - Cur/Hist - Print Selection window, enter the cutoff date for the cheques and
other payments to be moved. You can also click [Ranges] or [Conditions] to further narrow the payments
to move.
5 If you want the Move Payments Report to print details about the payments that move, select the Print
payment detail check box.
Note: This report can be very long if you select to print details.
6 Specify that the Move Payments Report is printed to a file by clicking [Printer Setup], selecting the Print
to file check box, and clicking [OK].
7 Click [Start], specify the name and location of the report, and click [OK] to begin the process.
8 Select File > Printouts, open the Move Payments Report, and verify that the payments moved
successfully.
Note: If some cheques or payments did not move to history, read the “About setting criteria for moving
payments” and “Correcting errors in Move Payments” topics in Accounts Payable Help.
9 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
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Removing vendors
You can use the Remove Vendors tool to remove vendors you no longer use. The vendors are permanently
removed; they are not archived.
To avoid removing active vendors, run the Remove Vendors tool before you close the fiscal year so that
vendors that were paid during the current year are not removed. You can also specify conditions in the
Remove Vendors - Print Selection window (by using [Ranges] and [Conditions]) to further control which
vendors are removed. A new vendor with no invoices or payments may be removed if just the default criteria
are used
Caution! Once vendors are removed, they cannot be moved back. We recommend that you make a
backup copy of your Accounts Payable data files before you remove vendors.

To remove vendors:
1 Make a backup of your Accounts Payable files. See “Appendix A: Backup Procedures” on page 49 for more
information.
2 In Accounts Payable, select Tools > Remove Vendors.
3 In the Remove Vendors - Print Selection window, select the Preview only option to verify which
vendors will be removed.
4 Select the check boxes to only process vendors with no current T5018 activity and no current year activity.
5 You can also click [Ranges] or [Conditions] to further narrow the vendors to remove.
Caution! If you do not select ranges or conditions, all vendors without current activity are removed.
6 Click [Start].
7 Examine the results of the preview.
p

p

If the correct vendors are listed, go to step 8.
If vendors are included that you do not want to remove or the preview does not include vendors that you
want to remove, repeat steps 2 onward while making the necessary adjustments to the criteria.

8 Select Tools > Remove Vendors.
9 In the Remove Vendors - Print Selection window, select the Remove vendor records option. This
permanently deletes vendors with no current year activity based on the ranges and conditions you
specified.
10 Click [Start] to permanently delete the vendors that meet the criteria.
11 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
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Accounts Receivable archive procedures
In Accounts Receivable, you can move invoices that are fully paid or voided to a history file.

Moving invoices
You can use the Move Invoices tool to move invoices from the current to history file. Only fully paid or voided
invoices can be moved. Invoices that are moved to history can be moved back to current if needed.
Before you move invoices, review the following considerations:
p

p

p

p

p

p

p

The invoices must have a status of Paid or Voided. Negative invoices must also be paid.
Retainage must be billed. Keep the original invoice where the retainage was held and the retainage billed
invoice together in the same file (current or history).
The invoice date must fall between the start and end dates entered in the Move Invoices window.
When invoices are moved, their related payment, adjustment, cash receipt, and deposit entries are
moved.
When moving from current to history, entries are moved from Activity.ara to History.ara and from
Current.art to History.art.
You can also move invoices from history files back to current files.
You can view entries moved to the history files by selecting the history files when using inquiries or
reports.

To review invoices that are fully paid and eligible to be moved to history:
1 In Accounts Receivable, select Reports > Aging and select one of the aging detail reports:
p

Detail by Customer: to see all invoices for a customer

p

Detail by Job: to see results sorted by Job

p

Detail by Contract: to see results sorted by Contract

2 In the Data File Selection window, select only the current transaction file to use for the report, and then
click [OK].
3 In the Print Selection window:
a For Aging As Of Date, either enter a specific cut-off date or enter a future date (to see all activity).
b Select the Include Retainage Column check box.
c Clear the Unpaid Only check box.
d Click [Ranges] and select the customers that you want included in the report.
e Click [Start] to generate the report.
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4 Review the report.
p

p

Confirm that the cash receipt amounts equal the invoice amounts. Only invoices that are paid in full can
move to history.
If the invoices have retainage, the retainage held must be equal to the retainage released before those
invoices can move to history.

To move invoices:
Important! Do not move large chunks of invoices at one time as this can take hours to finish. Instead,
use ranges to move 10-20 jobs at a time or 10-20 customers at a time. It is best to only move invoices for
jobs that are paid in full (so reports on a job will include all of the job information). After the move finishes,
backup both the activity and current files as well as both history files before doing the next move.
Tip: When you make the first move of the year, start by moving one voided invoice to history with the
Move unassociated entries check box selected and a large date range. The initial move of unassociated
items will take the longest time. Click [Ranges] and slide the bottom scroll bar to the right to see the last
column, and then select a voided invoice for moving. Run an aging report before moving to history and
after and compare the totals, which should not change.
1 Make a backup of your Accounts Receivable files. See “Appendix A: Backup Procedures” on page 49 for
more information.
2 Run an aging report with a future date (such as 12/31/9999) for Aging As Of Date. You can compare this
report to the report generated after the move (in step 10).
3 In Accounts Receivable, select Tools > Move Invoices > Current to History.
4 If prompted, confirm that you have posted all transactions.
5 In the Current to History - Print Selection window, enter the start and end date for the invoices to be
moved.
Tip: Make the date range large (such as 1/1/1901 - 12/31/9999) to include all paid invoices that fall
within those dates. Paid invoices up to the end date will be moved.
6 Select the Move unassociated entries check box to move misc cash receipts and other transactions that
are not associated with invoices.
7 Click [Ranges] to select a group or range of invoices to move. Only invoices with a status of Paid or
Voided display in the range of invoices.
Note: Do not use conditions, since it may be hard to decipher the resulting journal to see which
invoices did not move to history.
8 Click [Start] to begin the process.
9 Review the journal to verify the move was successful.
10 Run an aging report and compare the totals to the aging report you ran before moving to history (in step 2).
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Notes: If the totals changed, these is an issue that will require restoring to the backup made prior to
moving (or moving all items back from history and starting over).
11 Repeat steps 1 - 10 to move another set of fully-paid invoices.
12 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.

Cash Management archive procedures
In Cash Management, you can move reconciled transactions to a history file.

Moving entries
You can use the Move Entries tool to move transactions from the register file to a history file, or from one
history file to another. When you move entries from a register file to a history file, reconciled transactions
(along with their corresponding cash detail, deposit items, deposit item detail, withdrawal detail, batch, and
transaction attachment records) move from the Register.cmt file to a History.cmt file. When you move
entries from history to history, the same records move from the History.cmt file to another History.cmt file.
Before you move entries, review the following considerations:
p

Transactions in the history file cannot be un-reconciled or edited.

p

A cheque cannot be voided after it is moved to history.

p

In order to be moved, the transaction must be reconciled.

p

During the move process, only entries with a transaction statement date between the specified
Beginning statement date and Ending statement date are moved. If no Beginning statement date is
entered, all entries prior to the Ending statement date are moved.

Caution! Transactions that are moved to history cannot be moved back to the register file.

To move entries:
1 Make a backup of your Cash Management files. See “Appendix A: Backup Procedures” on page 49 for more
information.
2 In Cash Management, select Tools > Move Entries > Register to History.
3 If a history file does not exist, click [OK] to create the file.
4 In the Move Entries to History - Print Selection window, enter the Ending statement date for the
entries to be moved. You can instead click [List] and select an available statement date.
5 If desired, enter the Beginning statement date. If you do not enter a beginning statement date, all
reconciled transactions with a statement date prior the ending statement date move to the history file.
6 You can also click [Ranges] or [Conditions] to further narrow the entries to move.
7 Click [Start] to begin the process.
8 Review the Move Entries report to verify the transactions moved successfully.
9 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
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Contracts archive procedures
In Contracts, you can move closed or paid contracts to a history file.

Moving contracts
You can use the Move Contracts tool to move closed or paid contracts from the current to history file. When a
contract is moved, all related records are also moved. All contract information is moved from the Active.cnc
(contract file), Active.cna (derived file), and Active.cnt (transaction file) into to the History.cnc, History.cna,
and History.cnt. You can view contracts that have been moved to the history file through inquiries and reports
by selecting these files. You can also move contracts from history back to current as long as a contract with
the same ID does not exist in the current file
Before you move contracts, review the following considerations:
p

p

If you do not select a range or enter a condition in the Move Contracts to History - Print Selection
window, all paid and closed contracts are moved.
Only contracts with a status of either Closed or Paid in Full can be moved.
Note: The contract items for the contract can be any status.

p

p

p

p

A contract with the same ID must not exist in the history file.
The contract cannot have unposted entries. You can use the Unposted Transactions inquiry (by
selecting Inquiry > Other > Unposted Transactions).
Retainage for the contract must be completely billed.
The receivables amount must equal the billed amount. The receivables amount includes cash receipts
and receivable adjustments. The billed amount includes total billed, total tax billed, add-ons billed, and
deductions billed.

To move contracts:
1 Make a backup of your Contracts data files. See “Appendix A: Backup Procedures” on page 49 for more
information.
2 In Contracts, select Tools > Move Closed Contracts > Current to History.
3 If history files do not exist, click [OK] to create the files.
4 In the Move Contracts to History - Print Selection window, you can click [Ranges] or [Conditions] to
narrow the contracts to move.
Note: If you do not select a range or enter a condition, all paid and closed contracts will be moved.
5 Click [Start] to begin the process.
6 Review the Move Contracts journal, which identifies the contracts that were moved or rejected (and the
reason why a contract was not be moved).
7 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
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Equipment Cost archive procedures
In Equipment Cost, you can move retires equipment transactions to a history file.

Moving transactions
You can use the Move Transactions tool to move transactions from the new to new file, current to current file,
current to history file, or history to history file. You may choose to move transactions for pieces of equipment
that have been retired or at the end of each fiscal year.
Caution! Transactions that are moved to history cannot be moved back to the current file.

To move transactions from current to history:
1 Make a backup of your data files. See “Appendix A: Backup Procedures” on page 49 for more information.
2 In Equipment Cost, select Tools > Move transactions > Current to History.
3 If a history file does not exist, click [OK] to create the file.
4 In the Move Transactions - Cur/Hist - Print Selection window, you can click [Ranges] or [Conditions]
to narrow the transactions to move. For example, you can set a condition to move transactions with an
accounting date less than 01/01/2019.
Note: f you do not select ranges or conditions, all transactions are moved from the current file to the
history file.
5 Click [Start] to begin the process.
6 Review the journal to verify the correct transactions were moved.
7 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
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General Ledger archive procedures
In General Ledger, you can move old transactions and batch records to a history file.

Moving transactions
You can use the Move Transactions tool to move transactions from the new to new file, current to current file,
current to history file, or history to history file. Since the current and year-to-date ledgers cannot process
transactions older than two years old, consider moving transactions older than two years to a history file.
When generating a report or inquiry, you can select a history file to include those transactions.
Caution! Transactions that are moved to a history file cannot be moved back to a current file. You cannot
use Change Entries to edit transactions in a history file.

To move transactions:
1 Make a backup of your data files. See “Appendix A: Backup Procedures” on page 49 for more information.
2 In General Ledger, select Tools > Move Transactions > Current to History.
3 If you use named files, select the current file that contains the transactions you want to move and select the
history file. If you do not use named files, the transactions will move to the History.glt file in your current
data folder.
4 In the Move Transactions Curr to Hist - Print Selection window, enter the cutoff date for the
transactions to be moved. You can also click [Ranges] or [Conditions] to further narrow the transactions
to move.
5 Click [Start] to begin the process.
6 Review the journal to verify the move was successful.
7 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
Note: If your current or year-to-date ledgers do not print correctly after you move transactions, verify that
your ledger settings are set to include the history files if needed. To specify the ledger settings, select File
> Company Settings > GL Settings and click [Ledger Settings].
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Job Cost archive procedures
In Job Cost, you can move transactions, jobs, and commitments to a history file or a special archive data
folder that you set up for holding archived JC information.

Creating an archive data folder
If you do not already have an archive folder, create one (or more) before you move transactions, jobs, and
commitments. You will need to have one archive folder per company data folder for archiving purposes.
Note: The archive folders must be upgraded whenever you upgrade your Sage 300 Construction and
Real Estate software.

To create an archive data folder:
1 In Job Cost, select File > New Company.
2 In the New Company window, type the name for the archive folder (such as Job Archive) for Company
name and press TAB.
3 For Data folder path name, type the data folder path for the archive folder or click [Browse] and select the
path.
4 For Data folder description, type a description that will help you identify this archive folder in the list of
available companies.
5 Select the Use current setup check box to ensure that all custom descriptions are maintained. Clear the
Use setup wizard check box.
6 Click [OK].

Closing jobs
Before moving a job and its transactions, post any remaining costs and billings associated with the job, and
then change the job status to Closed. After you move the job, you cannot post transactions to it.

To close a job:
1 In Job Cost, select Setup > Jobs.
2 In the Job Setup window, type the job ID or select the job from the list.
3 Click the Status tab.
4 For the Status, select Closed.
5 Click [OK].
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Moving transactions
You can use the Move Transactions tool to move transactions to an archive data folder or to another file within
your live data folder. You can move transactions from the new to new file, current to current file, current to
history file, history to history file, or history to current file. Transactions that have been moved to an archive
folder can be moved back to the live data folder. Transactions that have been moved to a history file can also
be moved back to the current file. You can also use Move Transactions to reduce the size of the data stored in
the current file for active jobs.

To move transactions related to closed jobs to an archive folder:
1 Make a backup of your data files. See “Appendix A: Backup Procedures” on page 49 for more information.
2 In Job Cost, select Tools > Move > Transactions > Current to Current.
3 In the Move Transactions Cur/Cur - Destination File Selection window, select your archive data folder
(such as Job Archive), select CURRENT for Destination File, and then click [Open].
Note: If the Current.jct file does not exist in the destination folder, click [Yes] to create the file.
4 In the Move Transactions Cur/Cur - Print Selection window, specify conditions to limit the transactions
to be moved to those for closed jobs:
a Click [Conditions].
b In the Add Condition window in the Field area, click [Index], select JC - Job, and click [OK].
c In the list in the Field area, select Status.
d In the Operator area, select Equal to.
e In the Value area, select Closed.

f Click [OK].
g In the Condition Selection window, click [OK].
5 If desired, click [Ranges] to further narrow the transactions to move.
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Note: If you do not select ranges or conditions, all transactions for all jobs are moved to the archive
folder.
6 In the Move Transactions Cur/Cur - Print Selection window, click [Start] to begin the move process.
7 Review the journal to verify that the correct transactions moved to the archive current file.
8 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.

Moving jobs and commitments
You can use the Move Jobs tool to move closed and outdated jobs to an archive data folder, which also
moves the associated extra, cost code, category, draw, changes order, compliance, and custom field
records. You can also move the associated commitments items, commitment change orders, commitment
change order items, and commitment custom fields to another file within your live data folder.
Jobs cannot be moved to another master file within the same data folder. Jobs that have been moved to an
archive folder can be moved back to the live data folder as long as the job ID was not reused.

To move jobs and certain commitments to an archive folder:
1 Make a backup of your data files. See “Appendix A: Backup Procedures” on page 49 for more information.
2 In Job Cost, select Tools > Move > Jobs.
3 In the Move Jobs - Destination File Selection window, select your archive data folder (such as Job
Archive), select MASTER for Destination File, and then click [Open].
Notes: If the MASTER.jct file does not exist in the destination folder, click [Yes] to create the file.
4 In the Move Jobs - Print Selection window, select the Move Commitments check box if you want to
move all commitments associated with these jobs.
Note: This does not move commitments that are assigned to multiple jobs.
5 To only move specific jobs:
a Click [Ranges].
b In the Job Range Selection window, select the jobs or range of jobs to move.
c Click [OK].
6 To only move jobs that meet specific conditions, such as jobs that are closed:
a Click [Conditions].
b In the Add Condition window in the list in the Field area, select Status.
c In the Operator area, select Equal to.
d In the Value area, select Closed.
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e Click [OK].
f In the Condition Selection window, click [OK].
Note: If you do not select ranges or conditions, all jobs are moved to the archive folder.
7 Click [Start] to begin the move process.
8 Review the journal to verify that the correct jobs (and their commitments) were moved.
9 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.

Moving commitments
You can use the Move Commitments tool to move commitments to an archive data folder, which moves the
commitments, commitment items, commitment change orders, commitment change order items, and
commitment custom fields. Use the Move Commitments tool when you assign multiple jobs to a single
commitment and they did not move when moving jobs.
Commitments cannot be moved to another master file within the same data folder. Commitments that have
been moved to an archive folder can be moved back to the live data folder as long as the commitment ID
was not reused.

To move commitments to an archive folder:
1 Make a backup of your data files. See “Appendix A: Backup Procedures” on page 49 for more information.
2 In Job Cost, select Tools > Move > Commitments.
3 In the Move Commitments - Destination File Selection window, select your archive data folder (such as
Job Archive), select MASTER for Destination File, and then click [Open].
Notes: If the MASTER.jct file does not exist in the destination folder, click [Yes] to create the file.
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4 In the Move Commitments - Print Selection window, to only move specific commitments:
a Click [Ranges].
b In the Commitment Range Selection window, select the commitments or range of commitments to
move.
c Click [OK].
5 In the Move Commitments - Print Selection window, to only move commitments that meet specific
conditions, such as commitments for closed jobs:
a Click [Conditions].
b In the Add Condition window in the Field area, click [Index], select JC - Job, and click [OK].
c In the list in the Field area, select Status.
d In the Operator area, select Equal to.
e In the Value area, select Closed.
f Click [OK].
g In the Condition Selection window, click [OK].
Note: If you do not select ranges or conditions, all commitments are moved to the archive folder.
6 Click [Start] to begin the move process.
7 Review the journal to verify that the correct commitments were moved.
8 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
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Payroll archive procedures
In Payroll, you can move cheques and employees to a history file.

Moving cheques
You can use the Move Cheques tool to archive the past year's cheques, which reduces the amount of the data
in your current files and speeds processing. When you move cheques, the following records are moved from
the current payroll transaction file to another current file or to a history file: Time, Cheque, Cheque Pay,
Cheque Tax, Cheque Deduct, Cheque Fringe, Cheque Workers Comp, Daily Distribution, Batch, and Burden
Detail. You can move cheques from Current to Current, Current to History, or History to History.
When Payroll cheques are transferred to history:
p

They can still be used for reporting purposes but you cannot move them back to the current status.

p

They cannot be voided or corrected.

p

They do not move in Cash Management. See “Cash Management archive procedures” on page 64 for
more information.

This process may be lengthy, depending on the size of your files and your system. Please allow sufficient
time to complete this process.
Caution! Do not move checks until you have generated all year-end government forms.

To move cheques:
1 Make a backup of your Payroll data files. See “Appendix A: Backup Procedures” on page 49 for more
information.
2 If you want to retain burden and daily distribution detail in the history file, select File > Company Settings
> PR Settings, and then select the Retain distributions in history check box. Otherwise, the daily
distribution and burden detail records are deleted when cheques are moved from the current file to a history
file.
3 In Payroll, select Tools > Move > Cheques > Current to History or select Tools > Move > Cheques >
Current to Current to move the cheques to an archive folder.
4 If a history file does not exist, click [OK] to create the file. Otherwise, navigate to your archive data folder
(such as Payroll Archive).
5 In the Move Cheques - Print Selection window, click [Conditions] and specify
Cheque Date Less Than 01/01/2019 so only cheques with a date earlier than the date specified are
moved.
Caution! If you do not enter a condition, all cheques will be moved.
6 Click [Start] to begin the process.
7 Review the journal to verify the cheques moved successfully.
8 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
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Moving employees
You can use the Move Employees tool to archive the terminated employee information, which reduces the
amount of the data in your current files and speeds processing. When you move employees, the following
records are moved from one master file to another master file: Employee, Employee State, Employee Pay,
Employee Tax, Employee Deduct, Employee Fringe, and Employee Custom Fields.
You can move employees to a named master file within your live data or to a master file in an archive folder.
This can be the same archive folder you use for jobs or a separate folder just for Payroll. You can move
employees from one master file to another as long as that employee ID is not in use in the destination
file. Employees in an archive folder or in a separate master file in your live data folder can still be processed if
needed.
You can use the Move Employees tool to move seasonal employees, rehires, etc. back to the original folder
for reporting purposes.
Caution! Do not move employees until you have generated all year-end government forms.

To move employees:
1 Make a backup of your Payroll data files. See “Appendix A: Backup Procedures” on page 49 for more
information.
2 Create an archive folder for your payroll data if you have not already done so.
3 In Payroll, select Tools > Move > Employees.
4 In the Move Employees - Destination File Selection window, select your archive data folder (such as
Payroll Archive) if you do not use named files. If you use named files, select the master file you are moving
employees from (Source File Name), then select the master file that you want to move employees to
(Destination File). To create a new master file, type the file name for Destination File.
5 Click [Open].
6 If the Payroll master file does not exist, click [OK] to create the file. Otherwise, navigate to your archive
data folder (for example Payroll Archive).
7 In the Move Employees - Print Selection window, select the Move only terminated employees check
box to move only employees with a termination date. Employees with both a rehire date and a termination
date only move if the termination date is later than the rehire date.
Tip: You can review employees with a termination date by running a report, using an inquiry, or
selecting Setup > Employees > Misc Info.
8 If desired, click [Ranges] or [Conditions] to narrow the employees to move. For example, you can click
[Conditions] and create the following condition to employees who have not been paid since a certain date:
Last Cheque Date Less than 01/01/2019
Caution! If you do not enter a range, enter a condition, or select the Move only terminated
employees check box, all employees will be moved.
9 Click [Start] to begin the process.
10 Review the journal to verify the employees moved successfully.
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11 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
If you want to access terminated employee records in the archive data folder, such as to run reports or move
an employee record back to your live data folder, use File Tools to copy the following files from your live data
folder to your archive data:
l

ts.ctl

l

system.prs

l

tax.prx

Note: Some reports require additional files such as the Master.glm and Master.cmm files. Use File
Tools to copy these files into the archive folder.

Project Management archive procedures
In Project Management, you can move closed jobs to a history file.

Moving jobs
You can use the Move Jobs tool to move Project Management jobs from your live data folder to an archive
folder, which also moves the associated job spec. sections, job contacts, attachments, custom fields,
transmittals, correspondence log entries, drawing logs, meeting minutes, RFIs, submittals, field reports,
custom logs, change requests, change orders, and commitment change order records.
Note: The PJ Master file that is created through the archive process is an archive file, so tasks functions
are disabled. Jobs moved to an archive folder are available for reporting and inquiry only, but they are not
available for processing. Before moving jobs to an archive folder, be sure that the jobs are no longer
needed for processing. You can move Project Management jobs from the archive folder back to your live
folder if needed.

To move jobs:
1 Make a backup of your Project Management files. See “Appendix A: Backup Procedures” on page 49 for
more information.
2 Make sure that all custom logs are available for general use.
3 In Project Management, select Setup > Custom Logs.
4 If the "Update System Information" message displays, click [Yes].
5 In the Custom Log Setup window, click [Close].
6 In Project Management, select Tools > Move Jobs.
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7 Follow the instructions in the wizard to move jobs. On each page, click [Next] to continue to the next page.
The following pages are included:
Welcome: Introduction to Move Jobs.
Important Reminders: Verify that you completed steps 1, 2, and 3. Click [Yes] to confirm that you
completed the steps.
Select Destination: Type or browse to the destination folder where you want the jobs to move. The
destination can be an existing archive data folder or a new folder.
Destination Folder Information: Displays information about the destination folder that you selected on
the previous page. If it is a new folder, type a description for the destination folder for Destination Folder
Description, such as "Prior Year Archive." Later, the destination folder will be updated with information
from the current folder. This description will help you distinguish the new folder from the current folder.
Select Jobs: Select the jobs that you want to include in the move by clicking All, by clicking Closed, or by
selecting individual jobs using the check box in the first column.
Log: Select a location for the Move Jobs journal. You can send it to a PDF or text file or print the log.
Review: Review the summary of the jobs to be moved. If you selected more than 500 jobs (which is the
maximum that we recommend), the system displays a message. To change your selection, click [Back]. If
you want to send the job information to an Excel spreadsheet, select the jobs that you want to export and
then click [Export to Excel]. Note that the path for the log file appears beneath the grid. Click [Start] to
continue.
Important Post-Move Instructions: Displays a reminder that you should move the corresponding Job
Cost jobs and compact your data files. Click [Yes] to continue.
Preparing to Move Jobs: Prepares the destination folder that you selected by updating information from
the current folder. The wizard then begins to move the selected jobs.
Moving Data: Displays the move progress and the approximate time remaining. If you want to stop the
move, click [Cancel Move]; any jobs that were not already moved will remain in the original folder.
Finished or Cancel (if you canceled the move): To view the jobs that were moved, click [View Log]. Click
[Finish] to close the wizard.
8 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.
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Property Management archive procedures
In Property Management, you can move open items that are completely paid, transaction records, and
canceled or historical leases to a history file.

Moving paid items
Use Clear Paid Items to clear open items that are completely paid and move all the related entries from the
current transaction file to a history transaction file. Miscellaneous Income, Accumulator Adjustment,
Reference, Vacancy Loss, and Straight Line Rent entries are also moved. Enter a cutoff date to limit the
entries that are affected. You should only clear paid items that are no longer accessed daily.
Review the following considerations before you clear paid items:
p

Clear Paid Items can be very time intensive, especially if it has not been done on a regular basis.

p

Items may not move if all related items do not fall before the cutoff date entered.

Caution! After the items are moved to history, you can no longer change them in Change Entries.

To move paid items:
1 Make a backup of your Property Management files. See “Appendix A: Backup Procedures” on page 49 for
more information.
2 Select Tools > Clear Paid Items.
3 Enter a Cutoff date to limit which paid items and transactions will be cleared.
4 Click [Conditions] to limit the move to one or more properties, leases, or tenants. Click [OK].
5 Click [Start] to begin the process.
6 Review the Clear Paid Items journal and print the Transactions by Lease report (Reports >
Reconciliation) to verify that all transactions moved.

Moving entries
Move Entries allows you to move transaction records from one history file to another. Transactions are moved
from Current to History through the Clear Paid Items process.

To move paid items:
1 Make a backup of your Property Management files. See “Appendix A: Backup Procedures” on page 49 for
more information.
2 Select Tools > Move Entries.
3 Enter the Cutoff date to limit which paid items and transactions will be moved.
4 Click [Conditions]; select transactions for one or more properties, leases, or tenants; and then click [OK].
5 Under From, verify the source History.pmt from which you want to move entries.
6 Under To, click [...] and select the location of the new or existing History.pmt file to which you want to
move entries.
7 Click [Start].
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8 Review the journal to verify that transactions moved as expected.

Archiving leases
Use Archive Leases to move canceled or historical leases and their related records to archive files within your
live data folder.
Review the following considerations before archiving leases:
p

Archived leases are available for reporting and inquiry; they are not available for any processing.

p

You can only include leases with a status of Historical or Canceled.
Note: Review the "Terminating a Lease" topic in the Property Management help for steps on how to
mark a lease as Historical.

p

All revisions for the leases must also have the status of Historical or Canceled.

p

No transactions for the leases you plan to archive can exist in the current transactions file.

p

Archiving more than 2000 leases at once may take considerable time. You will have the opportunity to
specify which leases to archive during the archive session.

To prepare your data for archiving:
1 Use Clear Paid Items to move all related charges, payments, applied credits, refunds, etc., to the Property
Management history transaction file. You cannot archive a lease that has transactions in the current file.
2 If you use chargebacks in Accounts Payable, stop processing in Accounts Payable as well as Property
Management.
3 Make a backup of your Property Management files. See “Appendix A: Backup Procedures” on page 49 for
more information.

To archive leases:
1 Select Tools > Archive Leases to open the Archive Leases wizard.
2 If this is the first time that leases are to be archived, you are prompted to create the new archive files. Click
[OK] to the message "The PM Archive [Name] file was not found. The file will be created."
3 If you use custom fields, a message displays advising you to upgrade the PM Archive files.
4 The wizard moves you through the following pages. Click [Next] to move through each page of the wizard:
Welcome: Click [Next].
Important Reminder: Click the appropriate responses to the questions. Click [Next].
Lease Cutoff Date/Properties: This is the first of two criteria pages. In this page, you can enter cutoff
dates and select properties to narrow down the number of leases you want to move.
Select Leases: In this window, you can select the exact leases you want to move based on the dates and
properties criteria you established on the previous window. You can click [Back] to go back and change
criteria if necessary.
Log: This page allows you to select a location for the log (Archive Leases journal). You can enter or browse
for a path for the log or you can select to print the log. The log file defaults to a new file name, which you can
overwrite with the name you want to use. The file type must be PDF or text (.txt extension) format.
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Review: This page allows you to view the leases that will be moved. If you need to make any changes, you
can click [Back] to move back through the wizard. If you have more leases selected to move than fit into
the grid, you can scroll as necessary to view all of the information. Click [Export to Excel]to send the lease
information to an Excel spreadsheet. You can export line by line or export the entire grid. The path for the log
file appears below the grid. When you have reviewed the lease information and you are ready to begin the
process, select [Yes] and then click [Start].
Note: This page displays the number of leases that meet the criteria for leases you want to include in
the archive. If the number of leases is more than 2000, it will take a long time for the process to
complete. You can click [Back] to change the criteria if you want to reduce the number of leases in this
archive session.
Moving: This page provides a status of the archive progress and the approximate time remaining. You can
click [Cancel Move] to stop the process. If you cancel the move, a Canceled window appears and any
leases that were not moved up to the point of canceling will remain in the current files. You can view the log
to see which leases were moved.
Finished: This page appears when the archive is complete. If you canceled the archive process in the
previous window, the title of this window will display as Canceled.
5 Once the Archive Wizard is complete, you can view the log file for a record of the archived leases.
6 Click [Finish] to close the wizard.
7 Compact your files. See “Compacting files using File Doctor” on page 55 for more information.

Purchasing and Inventory archive procedures
In Purchasing and Inventory, you can move purchase order, change orders, receipts, and invoices to a history
file.

Moving purchase orders and change orders
There are two move options in Purchasing:
p

Move POs & COs To History

p

Move Receipts & Invoices To History

Data moves from your current data files to history files within the same purchasing and inventory data folder
(POIVData). This data is separate from the accounting data for other applications.
Caution! After data is moved to history it cannot be moved back. These records are no longer available
for processing.
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Use Move POs & COs To History to move purchase orders and change orders. Only orders and change
orders that meet certain criteria will be moved. Purchasing uses the following rules when archiving:
p

p

p

p

The order date is less than or equal to the cutoff date you select on the Move to History window.
The status of the order is either Completed or Voided. This status is achieved if you receive the order
and create and invoice, or if you use the Close Orders task. If you do not generate invoices in Purchasing
or do not close the order, you cannot archive orders or change orders. Review the PO Order Status report
for orders that meet these criteria (by selecting Reports > Status > Order Status).
The order or change order has been sent to Job Cost. To see which orders were not sent to Job Cost,
select Tasks> Send Orders to Job Cost, and then click [Preview] to see the purchase orders and
change orders that have not been sent to Job Cost.
The order has no uncommitted change orders.

To move purchase orders and change orders:
1 Make a backup of your Purchasing and Inventory data files. See “Appendix A: Backup Procedures” on
page 49 for more information.
2 Select Tools > Move Data > Move POs & COs To History.
3 Enter a date for Move Cutoff Date. Orders prior to or equal to this date will move.
4 Select the Trial Run check box if you want to preview the orders that will be moved.
5 Click [Start]. If you did not select the Trial Run check box, the system displays a warning that this process
will permanently remove orders and change orders to history; click [Yes] to continue.
6 The status bar indicates the progress of the move. When the process is complete, a message appears
detailing the number of orders and change orders that have been moved. Click [OK] to continue.
7 Click [View Log] to view the text file. To print to file, select the check box and select the desired file format.
8 Click [Close] to close the window.

Moving receipts and invoices
The Move Receipts & Invoices to History command allows you to move receipts and invoices from your
current data files to history files. This allows you to store historical receipts and invoices separately from
current receipts and invoices. Only receipts and invoices that meet certain criteria are moved. Purchasing
uses the following rules when archiving:
For receipts:
p

The receipt date is less than or equal to the cutoff date you select on the Move to History window

p

The status of the receipt is Posted.

p

The receipt has been posted as an invoice or confirmed.
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For invoices:
p

The invoice date is less than or equal to the cutoff date you select on the Move to History window.

p

The status of the invoice is Posted.

p

The invoice has been posted to Accounts Payable.

p

The posting sequence on the invoice is less than the last posting sequence.

p

The receipt associated with the invoice has a status of Complete.

Note: You can preview the data that will be moved before you actually move it. Select the Trial Run
check box and click [Start]. You can then preview or print the report from this trial run to verify that the
correct data is being moved.

To move receipts and invoices:
1 Make a backup of your Purchasing and Inventory data files. See “Appendix A: Backup Procedures” on
page 49 for more information.
2 Select Tools > Move Data > Move Receipts & Invoices To History.
3 Select a cut-off date from the drop-down calendar or enter the date to limit the invoice and receipts that are
moved.
4 Click [Start]. The status bar indicates the progress of the move. When the process is complete, a message
appears detailing the number of receipts and invoices that have been moved. Click [OK] to continue.
5 Click [View Log] to view the log text file. To print to file, select the check box and specify the desired file
format.
6 Click [Close] to close the window.
7 Select Tools > Upgrade Files to compact the files.
Note: To print reports for data that has been moved, select Reports > History. To view data on an
inquiry, go to Inquiry > Archived Orders. To modify or create custom reports on historical data use the
data tables with Hist or Hst in the table name for example Histpod.dat contains the historical PO detail,
Hstrecd.dat contains the historical receipts detail. Refer to the Purchasing & Inventory Data Dictionary
for more information.

Service Management archive procedures
In Service Management, you can move work orders to a history file.

Moving work orders
Use the Archive Wizard to select work orders to move from current to history or from history back to current.
The work order and related records are moved from the SMData folder DAT files to the History data folder
DAT files within the SMData folder.
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Information about the work orders that have been moved and rejected is saved to a log file after the move
process finishes. Any work order that is rejected will be listed in the errors section. Each rejection will include
the Work Order ID and an explanation of the rejection. If the work order is rejected due to an associated
record, the reason for the associated record’s rejection is included. The explanation can be quite lengthy, if
there is a long "chain" of associated records to get to the rejection.

To move work orders:
1 Make a backup of your Service Management files. See “Appendix A: Backup Procedures” on page 49 for
more information.
2 Select Tools > Archive Wizard.
3 Follow the instructions in the wizard to move work orders. On each page, click [Next] to continue to the
next page. The pages include the following:
Welcome page: Introduction to move work orders.
Warning page: Do not move work orders when other users are in Service Management.
Archive or Unarchive page: Select to move work orders from Current to History or from History to
Current.
Set Criteria page: Select the status of the work orders you want to move, the date range or a range of work
order numbers.
Note: If you do not enter any criteria all work orders can be moved to history.
Review page: Shows you the number of work orders that meet the criteria that you have entered. Listed at
the bottom of the window is where the log will be stored when the move is complete. Click [Start] to begin
moving the selected data.
Moving page: Indicates the progress of the move process and an estimated time remaining.
Finish page: If there are rejections, you will see a message that says “You moved some work orders, but
some could not be moved”. View the log file for details on what work orders were moved and the reason for
the rejections. The path where the log is stored is listed here. Click [Finish] to close the wizard.

Viewing archived work orders
Use the following reports to view archived work orders:
l

Work Order Status

l

Work Order Profitability by Location,

l

Labor Analysis by Call Type

l

Labor Analysis by Problem

l

Labor Detail
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