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Preparation

This guide provides the information you need to install Sage Timberline Enterprise 
on your network—including system requirements, configuration instructions for 
the prerequisite software, and instructions for creating your company’s database. 

 This Preparation section gives you an installation checklist to keep track of 
your progress; the system requirements; and instructions for configuring your 
network. 

 The Server Installation section walks you through each of the steps for 
installing Microsoft SQL Server, IIS, Sage Timberline Enterprise, and the 
additional Payroll and Estimating modules on the server.

 The Server Configuration section shows you how to activate your licenses, set 
up administrators, and get started with a sample database. It also gives you the 
information you need to start developing a security plan for your company’s 
business database.

 The Client Components Installation section walks you through setting up 
client workstations.

 In the System Maintenance section, learn about the routine maintenance tasks 
you’ll perform on your Sage Timberline Enterprise system.

Read through this guide carefully and make sure you have all of the components 
necessary to ensure a successful installation.

This guide and related materials will be updated periodically with new information 
and posted on the Sage Customer Portal.

For Further Assistance

If you have a question about about the installation process, be sure to check this 
document.  If you have questions about how to complete a task, check the 
application’s Help system. When you need further assistance, contact 
Sage Timberline Enterprise Customer Support by calling 866-991-5606. Support is 
available Monday through Friday from 6:00 a.m. to 5:00 p.m. Pacific time, with the 
following exceptions:

 Every Thursday from 2:00 p.m. to 3:00 p.m. Pacific Time, when Customer 
Support is closed for staff meetings.

 Standard United States holidays.

 Staff development days, during which support analysts are involved in 
additional product training and professional development (three days per year).

 Quarterly company meetings.

https://customers.sagenorthamerica.com/irj/go/km/docs/sageKM/Assets/help_4_Login_Customer_Portal.html
https://customers.sagenorthamerica.com/irj/go/km/docs/sageKM/Assets/help_4_Login_Customer_Portal.html
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Installation Checklist

Complete these steps to install Sage Timberline Enterprise on a client/server 
network.

Task Information

❑ Review the system specifications for Sage Timberline Enterprise and 
complete any necessary upgrades.

page 7

❑ Prepare your hardware and network environment. page 15

❑ Determine the location for your database, spools, and attachments 
folders.

page 17

❑ Install Microsoft SQL Server 2008 and configure it to work with Sage 
Timberline Enterprise.

page 24

❑ Install and configure Microsoft Internet Information Services. page 61

❑ Install Sage Timberline Enterprise server software. page 65

❑ Install Payroll on the server (optional). page 73

❑ Install Estimating and License Manager (optional). page 80

❑ Run the Sage System Administration Configuration Wizard. page 82

❑ Activate Your Sage Timberline Enterprise licenses. page 89

❑ Set up a sample database and configure user access. page 91

❑ Develop your security plan. page 105

❑ Set up roles, features, and users in Sage System Administration. page 109

❑ Install Sage Timberline Enterprise client software on the server and 
workstations. (Note that this step is required on the server as well as 
client machines.)

page 120

❑ Test the installation by opening Sage Timberline Enterprise on a 
workstation.

page 125

❑ Check for Sage Timberline Enterprise updates. page 153
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System Requirements

The performance of your Sage Timberline Enterprise system depends on having 
sufficient resources, including processor speed, memory, hard drive capacity, disk 
I/O, and network bandwidth.

Below are the minimum requirements for installing Sage Timberline Enterprise on 
your network. Note that other software products, including the operating system, 
also have minimum requirements which you will need to consider alongside those 
for Sage Timberline Enterprise.

Review your overall system infrastructure needs to ensure that your hardware and 
software have the resources necessary to meet your business demands. If you are 
considering obtaining new servers for Sage Timberline Enterprise or any of its 
components, request the Sage Timberline Enterprise Server Buying Guide from 
your business parter.

Network Requirements

Your network must meet the following requirements.

 You must install Sage Timberline Enterprise on a server that is a member of a 
Windows domain (Windows Server 2003, 2008, or 2008 R2). 

 Sage Timberline Enterprise must not be installed on your domain controller. 
Windows domains require a server that functions as a domain controller. The 
domain controller cannot be the same as the server that hosts Sage Timberline 
Enterprise.

WARNING:  Once you install Sage Timberline Enterprise in a production environment, do 
not restart the Active Directory server (the domain controller) while Sage Timberline 
Enterprise is in use. This can disrupt connections and cause loss of data. If you need to 
reboot the domain controller, allow users to complete active tasks and log out of Sage 
Timberline Enterprise first. 

 If you have enabled a firewall on the server that will hold 
Sage Timberline Enterprise and SQL Server, you must configure it as follows 
to allow access to and from the workstations.

 Allow HTTP and HTTPS incoming traffic (ports 80 and 443).

 Allow HTTPS outgoing traffic (port 443) to the outside Internet. (This is a 
requirement of the Entitlement Service.)

 Allow these ports, which are used by the Sage Installation Manager. 
(Further details are provided in the preparation section of this guide.)
ClientManagementPort 9190
StreamingDownloadPort 9191
ServerCallbackPort 9192
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ManagementConsoleServicePort 9193
ManagementConsoleCallbackPort 9194

 If you use only one SQL Server named instance on the server, in most cases 
it uses port 1433. Edit your firewall exceptions to allow port 1433 (if using 
the default settings) or whichever port you selected for the instance. If you 
have multiple named instances, the firewall ports are set dynamically. You 
may want to configure a fixed port for use with your firewall. For more 
information, see this article:
http://msdn.microsoft.com/en-us/librarycc646023.aspx

 Add the Sage Installation Manager service to the list of allowed applications 
on both the server and client. This service is called 
Sage.LS1.SIM.Server.WindowsService.exe

 You must have Internet connectivity for license activation. Once licenses are 
activated you do not have to remain connected to the Internet, but other 
frequently performed functions such as software updates, Payroll updates, and 
email require connectivity.

 You can install Sage Timberline Enterprise on a different server than the 
database server. If you do this, you must set up delegation correctly in Active 
Directory. 

 You can set up Sage Timberline Enterprise on a virtual server, and you can 
access it through a terminal server.

Servers

Server Operating Systems

These operating systems are supported for Sage Timberline Enterprise production 
servers:

NOTE:  Windows Small Business Server is not a supported operating system for 
Sage Timberline Enterprise servers. Windows Foundation editions are also not supported.

Operating System Edition/Version Service Pack

Windows Server 2008 (x86/x64) Standard, Enterprise SP2

Windows Server 2008 R2 (x64 only) Standard, Enterprise SP1

Windows Server 2003 (x86/x64) Standard, Enterprise SP2

Windows Server 2003 R2 (x86/x64) Stardard, Enterprise SP2
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Minimum Server Hardware Specifications

Following are the minimum hardware requirements for servers in a production 
environment.

Item Minimum Notes

Processor 
speed

Quad-Core, 
1.8Ghz Xeon 
or equivalent

Processor speed is important on both the server and 
workstation. The majority of Sage Timberline 
Enterprise processing occurs on the workstation, but 
in future releases, the server will take on additional 
processing duties. 

Random Access 
Memory (RAM)

4 GB RAM System performance is directly affected by the 
amount of RAM on the server. We recommend that 
you install as much RAM as possible. 

If you plan to use more than 4 GB RAM, you will 
need to use a 64-bit operating system to take 
advantage of the greater memory.

If you plan to run terminal services as well as Sage 
Timberline Enterprise on the same server, you need 
more than 4 GB RAM.  See the section 
“Recommendations for Sage Timberline Enterprise 
Servers.”

Free Disk 
Space

For the first year of usage:

 20 GB for Sage Timberline Enterprise and SQL Server (without 
Payroll) for applications plus database.

 22 GB for Sage Timberline Enterprise and SQL Server (with 
Payroll) for applications plus database.

For subsequent years:

 Allow for at least 10 GB free space for database growth in the 
future. 

 Plan for free space based on the expected lifespan of the hard 
drives.

We strongly recommend that you configure your system with 
redundant disk arrays (RAID), and that you separate the system and 
data files onto different RAID arrays. This can protect you from loss of 
data due to failed hard drives, and can also maximize performance.

Screen 
resolution

1024 x 768 NOTE:  In Windows Server 2008, if you set the 
Display Setting (in the Control Panel) to anything 
other than 100%, Sage Timberline Enterprise does 
not display correctly. 

DVD drive Required for installation of Sage Timberline Enterprise. If you plan to 
install Sage Timberline Enterprise on a virtual machine, the virtual 
machine must be able to access the DVD drive or ISO image on the 
host.
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Recommendations for Sage Timberline Enterprise 
Servers

Before you install Sage Timberline Enterprise, Sage Timberline Enterprise Payroll, 
or any prerequisites (IIS and SQL Server 2008), finalize the name of the server or 
servers you plan to use for these applications. Renaming any of these servers after 
installation causes issues with IIS, SQL Server 2008, Sage Timberline Enterprise, 
and Sage Timberline Enterprise Payroll. Renaming the server is not supported.

Server Operating System

If you plan to purchase a server to use with Sage Timberline Enterprise, we strongly 
recommend that you select Windows Server 2008 R2 for your operating system 
because of its support for RAM configurations greater than 4 GB. Ask your 
business partner for a copy of the Sage Timberline Enterprise Server Buying Guide 
to see more detailed recommendations.

Terminal Servers

If you will use Remote Desktop Services (terminal services) with 
Sage Timberline Enterprise, you must consider the server resources required for the 
added client sessions on the terminal server in addition to the server processing 
needs of Sage Timberline Enterprise and SQL Server. We recommend Windows 
Server 2008 R2 because of its support for RAM configurations greater than 4 GB.

Virtual Servers

You can install Sage Timberline Enterprise on a virtual machine. The virtual 
machine must meet the operating system and configuration requirements for server 
installations of Sage Timberline Enterprise. To accommodate this, the host 
hardware may require more resources than the minimum to support the overhead 
associated with running the host operating system and other applications or virtual 
machines. Consider increasing the CPU speed, amount of RAM, hard disk speed, 
and network bandwidth to support this configuration. If an issue is discovered while 
using a virtual machine and customer support is not able to reproduce it in a non-
virtual environment, work with your business partner or virtual machine 
manufacturer to resolve the issue.

NOTE:  If you use a USB drive on a virtual machine, you may need to obtain third-party 
hardware or software such as AnywhereUSB.

Estimating License Manager Server

See the installation instructions that come with your Estimating software for server 
specifications. 

http://www.digi.com/products/usb/anywhereusb.jsp#overview
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Required Supporting Software on the Server

The following are third-party components required by Sage Timberline Enterprise. 
You must install these components on your system before you can install Sage 
Timberline Enterprise. 

Microsoft SQL Server

You must obtain a license for SQL Server. You can use either of these versions:

 Microsoft SQL Server 2008 with Service Pack 3.

 Microsoft SQL Server 2008 R2 with Service Pack 1.

Either the Standard or Enterprise editions of SQL Server are supported. Either the 
32-bit or 64-bit versions are acceptable. 

SQL Server Express and the Workgroup edition of SQL Server are not supported 
for use with Sage Timberline Enterprise. 

You can install Microsoft SQL Server on a different server than Sage Timberline 
Enterprise.  This guide lists some configuration requirements for that scenario at the 
relevant points.

Microsoft Internet Information Services (IIS)

Sage Timberline Enterprise requires IIS. If you install Sage Timberline Enterprise 
on a different server than the database server, install IIS on the server with 
Sage Timberline Enterprise.

Installation details for IIS are provided in the section on installing IIS starting on 
page 57. Your operating system determines which version of IIS you install.

 Windows Server 2008 or Windows Server 2008 R2 come with IIS 7.0. 

 Windows Server 2003 comes with IIS 6.0.
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Microsoft Office 2007 with Service Pack 3, or Office 2010 (32-bit) with 
Service Pack 1

Sage Timberline Enterprise integrates with Microsoft Office 2007 or 2010 (32-bit). 
If you plan to use the integration features, you must install the corresponding 
version of Microsoft Office on workstations. This is also true for terminal server 
uses. 

 The Microsoft Office 2007 or 2010 (32-bit) version of Excel is used to integrate 
with Job Management worksheets, RFIs, and transmittals—as well as with 
General Ledger financial statements. Apply Service Pack 3 to the Microsoft 
Office 2007 installation, or Service Pack 1 to the Microsoft Office 2010 (32-bit) 
installation.

 To send emails (such as transmittals in Job Management), Outlook 2007 or 2010 
(32-bit) is required. Apply Service Pack 2 to Microsoft Office 2007.

NOTE:  Sage Timberline Enterprise requires that Service Pack 2 or greater be applied to 
Microsoft Office 2007. Do not use the 64-bit version of Microsoft Office 2010 with Sage 
Timberline Enterprise.
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Workstations

Workstation Operating Systems

These operating systems are supported for Sage Timberline Enterprise 
workstations.

Fast User Switching

Sage Timberline Enterprise does not support fast user switching, which is used on 
Microsoft Windows XP Professional, Windows Vista, and Windows 7 to allow 
multiple user accounts to log on to a computer simultaneously.

Minimum Workstation Hardware Specifications

Following are the minimum hardware requirements for workstations.

Operating System Edition Service Pack

Windows 7 (x86 and x64) Ultimate, Enterprise, Professional SP1

Windows Vista (x86 and x64) Ultimate, Business SP2

Windows XP (x86) Professional SP3

Item Minimum Notes

Processor 
speed

Dual core, 
2.4 GHz 

Processor speed is important on both the server 
and workstation. The majority of Sage Timberline 
Enterprise processing occurs on the workstation, 
but in future releases, the server will take on 
additional processing duties. 

Random 
Access Memory 
(RAM)

4 GB RAM 
(Windows 7 or 
Windows Vista)

2 GB RAM 
(Windows XP)

System performance is directly affected by the 
amount of RAM. We recommend that you install 
as much RAM as possible. 

Windows 7 and Vista use large amounts of 
memory, so we recommend that you have more 
RAM on these types of machines.

Hard drive 
space

750 MB for Sage Timberline Enterprise only.

2 GB for Sage Timberline Enterprise and Payroll.

Screen 
resolution

1024 x 768 NOTE:  In Windows 7, if you set the Display 
Setting (in the Control Panel) to anything other 
than 100%, Sage Timberline Enterprise does not 
display correctly. 

Printer Use a Microsoft certified print driver.
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Additional Components Installed Automatically

The following are third-party components required by Sage Timberline Enterprise 
that are included as part of the installation process if they do not already exist on 
your machine. This information is only for your reference. You do not need to 
obtain these components separately.

Component Version and Notes

Microsoft Visual C++ Runtime 9.0 SP1

Microsoft .NET Framework .NET 3.5 SP1

Microsoft Management Console (MMC) 3.0

VSTO Runtime 3.0

Infragistics 2008 WPF Vol. 1
2008 Vol. 2 
2007 Vol. 3

Aatrix Installed for 1099 forms used by Accounts 
Payable and for other forms used by the 
optional Payroll module.

Additional Components Installed with the Optional Payroll Module

Pervasive.SQL data engine (server)

Microsoft Visual C++ Runtime 8.0 SP1

Microsoft Core XML Services 6.0 SP1

Microsoft Web Services Extensions 3.0

Amyuni PDF Converter
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Prepare Your Hardware and Network 
Environment

Complete these tasks to prepare your network environment for 
Sage Timberline Enterprise installation.

1. Verify that all servers and workstations meet the minimum hardware and 
operating system requirements as outlined in the previous section.

2. If you do not have a Windows domain set up on your network, create a domain 
now and configure the Active Directory. Consider the following:

 All Sage Timberline Enterprise servers, workstations, and users must be set 
up in Active Directory with access to this domain.

 The server that functions as your domain controller cannot be the same as 
the Sage Timberline Enterprise server. You may need to obtain a new server 
or set up a virtual machine environment for Sage Timberline Enterprise.

3. Decide whether your employees will access Sage Timberline Enterprise 
through a terminal server. If so, will the terminal server also be the application 
server, or will you have separate servers for each function?  Obtain the 
necessary servers and configure them on your domain. (If you will use 
Estimating License Manager, the terminal server cannot be the license server.)

4. If you plan to install Sage Timberline Enterprise on a different server than the 
database server, you must set delegation correctly in Active Directory to avoid 
problems on the workstations.

a. Log on to the domain controller as domain administrator, and open 
Active Directory Users and Computers.

b. Locate the computer object for the IIS server. Right-click the computer and 
select Properties.

c. Click the Delegation tab, and select the option Trust this computer for 
delegation to any service (Kerberos only).  Click OK. 

NOTE:  You can limit this delegation to the IIS Service (W3SVC) for maximum security.

5. Designate at least one person to be the system administrator for 
Sage Timberline Enterprise. Considering the following: 

 The administrator is the person who will configure Sage System 
Administration, including creating and configuring the database, granting 
access to software features, and assigning users to roles.

 The Sage Timberline Enterprise administrator is also a SQL Server system 
administrator for the instance on which you configure Sage Timberline 
Enterprise.
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 The Sage Timberline Enterprise administrator must be able to log on to the 
server with Administrator privileges in order to open Sage System 
Administration.

6. Configure your firewall settings.

If you have enabled a firewall on the server that will hold 
Sage Timberline Enterprise and SQL Server, you must configure it to allow 
access to and from the workstations.

 Allow HTTP and HTTPS incoming traffic (ports 80 and 443).

 Allow HTTPS outgoing traffic (port 443) to the outside Internet. (This is a 
requirement of the Entitlement Service.)

 Allow these ports, which are used by the Sage Installation Manager:

 If you use only one SQL Server named instance on the server, in most cases 
it uses port 1433. Edit your firewall exceptions to allow port 1433 (if using 
the default settings) or whichever port you selected for the instance. If you 
have multiple named instances, the firewall ports are set dynamically. You 
may want to configure a fixed port for use with your firewall. For more 
information, see this article:
http://msdn.microsoft.com/en-us/librarycc646023.aspx

 Add the Sage Installation Manager service to the list of allowed applications 
on both the server and client. This service is called 
Sage.LS1.SIM.Server.WindowsService.exe

7. Verify your Internet connection. You must have Internet connectivity for license 
activation. Once licenses are activated you do not have to remain connected to 
the Internet, but other frequently performed functions such as software updates, 
Payroll updates, and email require connectivity.

Port and Notes

9190 ClientManagementPort

Incoming on server, receiving data from client.

9191 StreamingDownloadPort

Incoming on client, receiving data from server.

9192 ServerCallbackPort

Incoming on client, receiving data from server.

9193 ManagementConsoleServicePort

Incoming and outgoing

9194 ManagementConsoleCallbackPort

Incoming and outgoing
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Determine the Location of Data and Shared 
Folders

Sage Timberline Enterprise and SQL Server will access certain folders that store 
files related to your databases.  You specify the location of these folders during 
installation. You should decide upon the location of these folders now based on your 
network and security requirements. 

The folders you will create for Sage Timberline Enterprise and SQL Server usage 
are as follows:

 Default Data and Log folder for SQL—This is the default location for all 
databases and log files associated with a given SQL Server instance. 

 Attachments folder—This location stores files that you associate with records 
in Sage Timberline Enterprise. For example, you might have blueprint drawings 
attached to a job. We recommend that you have a separate Attachments folder 
for each database that you set up in Sage Timberline Enterprise.

 Spool folder—This location stores print output files from reports if you send 
them to the print spool. We recommend that you have a separate Spool folder 
for each database that you set up in Sage Timberline Enterprise.

NOTE:  If you plan to install Payroll, additional folder permissions must be set on the server 
and workstations. See “Additional Permissions Required for Payroll” on page 20.
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Default Data and Log Folder

Create the folder that will hold your data and logs before you install SQL Server, 
because you will specify its location during installation. This folder should not be 
on the root of a drive. (For example, do not specify it as simply C:\. A common 
practice is to place these folders inside a parent folder, such as the appropriate 
subdirectory of C:\ProgramData.)

SQL Server requires that the data and log files be stored on a physical drive located 
on the same machine as the SQL Server instance. The drive on which these folders 
are stored must have sufficient space to hold your database as it grows.

WARNING:  When you install SQL Server, you see a default folder path for data and log 
files, but you must change it to the location you set up for your default data and log files. 

The permissions on the data and log folders, including any subfolders, must allow 
access to SQL Server administrators as well as Sage Timberline Enterprise 
administrators. Follow these steps:

1. Create the default data and log folder in the location you determine, which must 
be on the same physical machine as the SQL Server instance.

2. Open the Properties window for the folder and click the Security tab. (The 
steps to do this differ according to your Windows operating system.  Consult the 
Windows Help topic on changing folder properties.)



Determine the Location of Data and Shared Folders Installation and Maintenance Guide

© 2012 Sage Software, Inc. 19

3. Add the appropriate administrator groups or individuals to the permissions list. 
At a minimum, these individuals should have Read and Write permissions to 
the folders.

4. Verify that the same permissions are applied to all subfolders, not just the top 
level folder.

Attachments and Spool Folders

Create the Attachments and Spool folders before you set up databases in Sage 
System Administration. You will specify the location of these folders when you set 
up Sage Timberline Enterprise databases.

If you will have multiple company databases, we recommend that you create 
separate Attachments and Spool folders for each database. This prevents users of 
one database from having access to attachments and spool files from another 
database.

These folders should not be on the root of a drive. For example, do not specify them 
as simply C:\Attachments or C:\Spool. A common practice is to place these folders 
inside a parent folder, such as the appropriate subdirectory of C:\ProgramData..

You must share the Attachments and Spool folders with all users of the company 
database to which the folders correspond. (Sage Timberline Enterprise users who 
do not need to access attachments or spool files do not need this access.)

NOTE:  Consider creating Active Directory groups for your Sage Timberline Enterprise 
users so that you can add the group to the folder permissions. This facilitates security 
maintenance by letting you control group membership in Active Directory only.

To configure the Attachments and Spool folders, follow these steps. 

1. Create the Attachments and Spool folders in the location you determine. 



Determine the Location of Data and Shared Folders Sage Timberline Enterprise

20 © 2012 Sage Software, Inc.

2. Open the Properties window for each folder and click the Sharing tab. (The 
steps to do this differ according to your Windows operating system.  Consult the 
Windows Help topic on changing folder properties.)

3. Share the folder.

4. Set the permissions on the sharing to include each of the users with whom you 
want to share the folder. At a minimum, these individuals should have Read and 
Write permissions.

NOTE:  If the Attachments and Spool folders are subfolders of the data directories, make 
sure that all users can access these subfolders. Setting permissions on the parent folder 
does not cause the settings to be applied to subfolders unless you explicitly propagate 
them.

Additional Permissions Required for Payroll

If you plan to install Payroll, additional folder permissions must be set on the server 
and workstations. These folders are created during the installation process. 
Complete the Payroll installation and then apply the necessary permissions before 
users open Payroll from their workstations.

Full control of the following folders and registry keys must be granted to each 
Payroll user. In the path names that follow, C:\ represents the drive on which the 
applicable software or operating system is installed.

Company Data Folder

Typically, the company data folder is located on server where you install Sage 
Timberline Enterprise.

Timberline Office Folder (in Program Files)

This folder is created on the file server, terminal server, and all workstations during 
Sage Timberline Enterprise Payroll installation. The default location is 
C:\Program Files\Timberline Office. If you selected a different location than the 
default, apply the needed permissions to the correct location.

Users’ Folders

Network domain users each have a user’s folder on all servers, workstations or 
terminal servers that they use. During Payroll installation, necessary files are 
written to this folder. By default, users have full control of this folder. If these 
settings have changed, grant full control of the user’s folder to the user on all 
servers, terminal servers, and workstations. Depending on the operating system, 
this folder’s location is one of these:

 Windows 2003 Server or Windows XP: 
C:\Documents and Settings\[username]
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 Windows 2008 Server, 2008 R2 Server, Windows 7, or Vista:
C:\Users\[Username] 

Timberline Office Folder (in Program or Application Data Folder)

This folder is created with necessary files during Payroll installation, and must be 
shared. Depending on the operating system, this folder’s location is one of these:

 Windows 2003 Server or Windows XP: 
C:\Documents and Settings\All Users\Application Data\Sage\
Timberline Office 

 Windows 2008 Server, 2008 R2 Server, Windows 7, or Vista:
C:\ProgramData\Sage\Timberline Office

NOTE:  If you cannot locate this folder, you need to configure Windows Explorer to show 
hidden folders. In Windows Explorer, select Organize > Folder and Search Options. On 
the View tab, select Show hidden files and folders.

Aatrix Installation Folders

Aatrix installation folders are placed on each workstation. Users must have full 
control of these two folders in order to run and update Aatrix reporting. Depending 
on the operating system, the folders are in these locations: 

 Windows 2003 Server or Windows XP:

 C:\Program Files\Aatrix Software

 C:\Documents and Settings\All Users\Application Data\
Aatrix Software 

 Windows 2008 Server, 2008 R2 Server, Windows 7, or Vista:

 C:\Program Files\Aatrix Software

 C:\ProgramData\Aatrix Software 

Pervasive Installation Folders

All Payroll operators need full control of the Pervasive installation and data 
directories on the file server, terminal server, and all workstations. The default 
Pervasive installation location is C:\Program Files\Pervasive Software (where C 
is the installation drive). Additionally, Pervasive installs some files to the program 
or application data folder, depending on the operating system:

 Windows 2003 Server or Windows XP:
C:\Documents and Settings\All Users\Application Data\
Pervasive Software

 Windows 2008 Server, 2008 R2 Server, Windows 7, or Vista:
C:\ProgramData\Pervasive Software
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Registry Keys

Payroll operators must have full control of the following Windows registry keys on 
the file server, terminal server, and all workstations. 

NOTE:  Propagate full control to all subkeys. Contact your system administrator for 
assistance before you modify Windows Registry permissions. 

 HKEY_Current_User 

 HKEY_Local_Machine\Software\Timberline 

 HKEY_Local_Machine\Software\Pervasive Software 

 HKEY_Local_Machine\Software\ODBC 
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Server Installation

This section guides you through the server installation steps for 
Sage Timberline Enterprise and related components. You should already have 
completed all of the steps in the Preparation section.

This section includes the following procedures:

 Install and configure Microsoft SQL Server, starting on page 24.

 Install and configure Internet Information Services, starting on page 61.

 Install Sage Timberline Enterprise on the server, starting on page 65.

 Install Payroll on the server, starting on page 73.

 Install Estimating, starting on page 80.

 Install the Sage Timberline Enterprise client components on the server, starting 
on page 120.

NOTE:  You must run the client installation on the server as well as workstations. If you do 
not run the client installation, you will not be able to access the applications at the server.
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Install Microsoft SQL Server 2008

You must install a supported version Microsoft SQL Server 2008 (listed in the 
“System Requirements” section), specify the default database location, and 
configure it to use TCP/IP before you install Sage Timberline Enterprise. 

You may already have SQL Server installed. If so, confirm that you have the correct 
version, upgrade if necessary, and configure it for Sage Timberline Enterprise.

For more information on SQL Server, visit Microsoft’s Web site:
http://msdn.microsoft.com/en-us/sqlserver/default.aspx.

Before you Begin

Complete these tasks before you begin the installation of SQL Server.

 Decide on a SQL Server administrator password. Make note of this password, 
as you will need it to perform SQL Server administrative tasks. 

 Have your product key for SQL Server available. (You may not have a product 
key if you obtained SQL Server as a bundled product with Sage Timberline 
Enterprise.)

 Verify your firewall settings, as described below.

 Decide which SQL Server instance you will use (see considerations on the next 
page). 

Verify your Firewall Settings

You should have already configured your firewall as described in the section 
“Prepare Your Hardware and Network Environment” on page 15. If your firewall is 
not configured correctly when you install SQL Server, you may not be able to 
establish communication between the server and clients. 

If you use only one SQL Server instance on the server, in most cases it will use port 
1433 for SQL Server traffic. If you have multiple named instances, the firewall 
ports are set dynamically. You may want to configure a fixed port for use with your 
firewall, for security. 

To allow incoming SQL traffic to access your server in a client-server environment, 
you must edit your firewall exceptions to allow port 1433 (if using the default 
settings) or whichever port you selected for the instance. 

For more information, see this article
http://msdn.microsoft.com/en-us/library/cc646023.aspx. 

http://msdn.microsoft.com/en-us/sqlserver/default.aspx
http://msdn.microsoft.com/en-us/library/cc646023.aspx
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Decide Which SQL Server Instance You Will Use

Each time you install SQL Server, you create an instance, or a copy of SQL Server 
running on the computer. Each computer has at least one instance, and you can add 
additional instances if you want. 

Before you install SQL Server to work with Sage Timberline Enterprise, decide 
whether to use an existing instance or a new named instance. This table helps you 
compare these two options:

Using an Existing Instance

Results in the simplest installation if you have no other applications running on SQL 
Server.

Requires you to grant SQL Server administrative privileges to the Sage System 
Administrator, opening all databases (regardless of associated application) to that 
administrator.

Requires that all SQL Server applications running on the existing instance be compatible 
with a SQL Server version that is supported by Sage Timberline Enterprise.

Using a Named Instance (Recommended)

Allows you to keep database access and security for other applications separate from 
Sage Timberline Enterprise databases.

May require you to open additional firewall ports to enable SQL Server communication 
with the client.

Allows you to limit administrative access to databases for applications other than 
Sage Timberline Enterprise. All Sage system administrators also have administrator 
permissions in SQL Server for the Sage Timberline Enterprise instance.

Requires additional resources for each added instance on the computer. Consider using 
an existing instance if application performance is a concern.

Requires that all SQL applications running on that instance be compatible with a 
SQL Server version that is supported by Sage Timberline Enterprise.
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Install SQL Server 2008

NOTE:  These instructions cover the SQL Server 2008 installation (not the installation for 
SQL Server 2008 R2, which begin on page 41).

1. Insert the SQL Server 2008 DVD. The installation should start automatically.  If 
it does not, browse to the DVD drive and double-click Setup.exe.

2. If you see a message about known compatibility issues, click Run program. 
(This message simply reminds you to install updates, which you will do as part 
of this procedure.)

3. If you are asked to install prerequisites, click OK for each message about 
prerequisites. 

NOTE:  You may need to download some prerequisites to install them. The downloads are 
available from www.microsoft.com. 

4. If you are prompted to install Windows updates, click OK.

5. If you are prompted to restart the computer after installing updates, close any 
open programs and click Restart Now before continuing.

http://www.microsoft.com/
http://www.microsoft.com/
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6. After restarting the computer, double-click Setup.exe again. The SQL Server 
Installation Center window opens.

7. In the left panel, click Installation.

8. Click New SQL Server stand-alone installation or add features to an 
existing installation.
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9. If you see a message about known compatibility messages again, click 
Run program.

10. The Setup Support Rules window opens. If any problems appear here, they 
must be corrected before you can continue. If the operation finishes 
successfully, click OK.

11. In the Product key window, enter the product key for your SQL Server 
software, and then click Next.
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NOTE:  Your product key may already be present if you obtained SQL Server as part of a 
bundle with Sage Timberline Enterprise.

12. In the License Terms window, click I accept the license terms, and then click 
Next.
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13. In the Setup Support Files window, click Install. 

14. The Setup Support Rules window appears.

NOTE:  If you see a warning about the firewall, see “Verify your Firewall Settings” on 
page 20.
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15. Click Next to proceed to the Feature Selection window. Select 
Database Engine Services, Management Tools - Basic, and 
Management Tools - Complete, as shown here:

NOTE:  You can select additional features if you wish.  The features shown are the 
minimum required.
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16. Click Next to proceed to the Instance Configuration window, and select either 
Default instance or Named instance. If you select a named instance, type an 
instance name (up to 16 characters and beginning with a letter). 

NOTE:  If you are unsure whether to use a default or named instance, see “Decide Which 
SQL Server Instance You Will Use” on page 21.
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17. Click Next to proceed to the Disk Space Requirements window.

18. Click Next to proceed to the Server Configuration window. 

19. Click Use the same account for all SQL Server services. 

20. In the window that opens, select the Account Name of NT Authority\Network 
Service and click OK.
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21. Verify that each service shows a Startup Type of Automatic. 

22. Click Next to proceed to the Database Configuration window. 

23. Select Mixed Mode (SQL Server authentication and Windows 
authentication).

24. Enter a password for the built-in SQL Server system administrator account. 

WARNING:  Make note of this password, as you must have it in order to perform 
administrative functions within SQL Server. 

25. Click Add Current User to add yourself as a SQL Server administrator. To add 
additional users, click Add and enter the names. Your Sage system 
administrators must also be SQL Server administrators.

NOTE:  Consider adding the local administrators group as administrators for this instance. 
To add this group, click Add, type \\ServerName\Administrators, and then click OK. 

26. Click the Data Directories tab. Next to User database directory and User 
database log directory, enter the path to the folder or folders you designated 
for default SQL databases.
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NOTE:  The installation process does not automatically create the folders listed next to 
User database directory or the User database log directory. You must create them in 
the desired location as described in the “Determine the Location of Data and Shared 
Folders” on page 13. If you do not create the folders, errors result when you run the 
Configuration Wizard.

27. Click Next to proceed to the Error and Usage Reporting window.



Install Microsoft SQL Server 2008 Sage Timberline Enterprise

36 © 2012 Sage Software, Inc.

NOTE:  Depending upon whether you selected other options in step 15, you may see 
additional screens at this point.  Continue through the selections until you see the screen 
shown here.

28. Select a reporting option if you want to send reports to Microsoft. Click Next to 
proceed to the Installation Rules window.
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29. Confirm that the installation process will not be blocked, and then click Next to 
proceed to the Ready to Install window.

30. Click Install to start the installation process, which may take several minutes.
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31. When the installation is complete, the Installation Progress window shows 
that it completed successfully.

32. Click Next.

33. Click Close.
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34. In the SQL Server Installation Center window, select Search for product 
updates.

35. Follow the prompts to install any necessary updates. 

36. Restart your computer.

Install Service Pack 3 for SQL Server 2008

NOTE:  You do not need to do this if you installed SQL Server 2008 R2.

When you run the installation routine for Service Pack 3, the process applies 
Service Pack 3 only to the instance (named or default) that you specify.  If you have 
more than 1 instance running on your computer, be sure to apply Service Pack 3 to 
the instance supporting Sage Timberline Enterprise. (You can apply it to other 
instances as needed.) SQL Server 2008 Service Pack 3 is required to run 
Sage Timberline Enterprise. 

If you installed updates as recommended in the step 35 above, you should already 
have this service pack installed.

Confirm That Service Pack 3 is Installed

1. Log on to the server on which SQL Server 2008 is installed. You must have 
administrative permissions to SQL Server. 

2. Select Start > All Programs > Microsoft SQL Server 2008 > 
SQL Server Management Studio.
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3. In the Connect to Server window, enter Localhost and click Connect.

4. The top node of the tree should say SQL Server 10.0.5500 or greater. If the last 
number is lower than 5500, install Service Pack 3.

To Install SQL Server 2008 Service Pack 3

1. In Internet Explorer, go to this location:
http://www.microsoft.com/en-us/download/details.aspx?id=27594

2. Download the appropriate file for your operating system and run it.

3. Follow the prompts to install the update.

4. After the installation is complete, restart your computer. 

http://www.microsoft.com/en-us/download/details.aspx?id=27594
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Install SQL Server 2008 R2

NOTE:  These instructions cover the SQL Server 2008 R2 installation (not the installation 
for SQL Server 2008, which begins on page 26).

1. Insert the SQL Server 2008 R2 DVD. The installation should start 
automatically.  If it does not, browse to the DVD drive and double-click 
Setup.exe.

2. If you see a message about known compatibility issues, click Run program. 
(This message simply reminds you to install updates, which you will do as part 
of this procedure.)

3. If you are asked to install prerequisites, click OK for each message about 
prerequisites. 

NOTE:  You may need to download some prerequisites to install them. The downloads are 
available from www.microsoft.com. 

4. If you are prompted to install Windows updates, click OK.

5. If you are prompted to restart the computer after installing updates, close any 
open programs and click Restart Now before continuing.

6. After restarting the computer, double-click Setup.exe again. 

http://www.microsoft.com/
http://www.microsoft.com/
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7. In the SQL Server Installation Center window, in the left panel, click 
Installation.

8. Click New installation or add features to an existing installation.

9. If you see a message about known compatibility messages again, click 
Run program.
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10. Any problems listed in the Setup Support Rules window must be corrected 
before you can continue. If the operation finishes successfully, click OK.

11. In the Product key window, enter the product key for your SQL Server 
software, and then click Next.
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NOTE:  Your product key may already be present if you obtained SQL Server as part of a 
bundle with Sage Timberline Enterprise.

12. In the License Terms window, click I accept the license terms, and then click 
Next.
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13. In the Setup Support Files window, click Install. 

14. In the Setup Support Rules window, click Next.

NOTE:  If you see a warning about the firewall, see “Verify your Firewall Settings” on 
page 20.
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15. In the Setup Role window, select the first option, SQL Server Feature 
Installation, and click Next.

16. Select Database Engine Services, Management Tools - Basic, and 
Management Tools - Complete, as shown here, and click Next.
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NOTE:  You can select additional features if you wish.  The features shown are the 
minimum required.

17. In the Installation Rules window, click Next.
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18. In the Instance Configuration window, select either Default instance or 
Named instance. If you select a named instance, type an instance name (up to 
16 characters and beginning with a letter). Click Next.

NOTE:  If you are unsure whether to use a default or named instance, see “Decide Which 
SQL Server Instance You Will Use” on page 21.
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19. In the Disk Space Requirements window, click Next.

20. In the Server Configuration window, click Use the same account for all SQL 
Server services.

21. In the window that opens, select the Account Name of NT Authority\Network 
Service and click OK.
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22. Verify that each service shows a Startup Type of Automatic, and then click 
Next. 

23. In the Database Configuration window, select Mixed Mode (SQL Server 
authentication and Windows authentication).

24. Enter a password for the built-in SQL Server system administrator account. 

WARNING:  Make note of this password, as you must have it in order to perform 
administrative functions within SQL Server. 

25. Click Add Current User to add yourself as a SQL Server administrator. To add 
additional users, click Add and enter the names. Your Sage system 
administrators must also be SQL Server administrators.

NOTE:  Consider adding the local administrators group as administrators for this instance. 
To add this group, click Add, type \\ServerName\Administrators, and then click OK. 

26. Click the Data Directories tab. Next to User database directory and User 
database log directory, enter the path to the folder or folders you designated 
for default SQL databases, and then click Next.
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NOTE:  The installation process does not automatically create the folders listed next to 
User database directory or the User database log directory. You must create them in 
the desired location as described in the “Determine the Location of Data and Shared 
Folders” on page 13. If you do not create the folders, errors result when you run the 
Configuration Wizard.

27. In the Error Reporting window, select a reporting option if you want to send 
reports to Microsoft. 
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NOTE:  Depending upon whether you selected other options in step 15, you may see 
additional screens at this point.  Continue through the selections until you see the screen 
shown here.

28. Click Next to proceed to the Installation Configuration Rules window.

29. Confirm that the installation process will not be blocked, and then click Next.
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30. In the Ready to Install window, click Install to start the installation process, 
which may take several minutes.

31. When the installation is complete, the Installation Progress window shows 
that it completed successfully. Click Next.
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32. Click Close.

33. A message indicates that you must restart the computer. Click OK.

34. After the computer restarts, return to the SQL Server Installation Center 
window and click Search for product updates.

35. Follow the prompts to install any necessary updates. 
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36. Restart your computer.

Install Service Pack 1 for SQL Server 2008 R2

When you run the installation routine for Service Pack 1, the process applies the 
service pack only to the instance (named or default) that you specify.  If you have 
more than 1 instance running on your computer, be sure to apply Service Pack 1 to 
the instance supporting Sage Timberline Enterprise. (You can apply it to other 
instances as needed.) SQL Server 2008 R2 Service Pack 1 is required to run 
Sage Timberline Enterprise. 

If you installed updates as recommended in the step 35 above, you should already 
have this service pack installed.

Confirm That Service Pack 1 is Installed

1. Log on to the server on which SQL Server 2008 R2 is installed. You must have 
administrative permissions to SQL Server. 

2. Select Start > All Programs > Microsoft SQL Server 2008 R2 > 
SQL Server Management Studio.

3. In the Connect to Server window, enter Localhost and click Connect.

4. The top node of the tree should say SQL Server 10.50.2500 or greater. If the 
last number is lower than 2500, install Service Pack 1.

To Install SQL Server 2008 R2 Service Pack 1

1. In Internet Explorer, go to this location:
http://www.microsoft.com/en-us/download/details.aspx?id=26727

2. Download the appropriate file for your operating system and run it.

3. Follow the prompts to install the update.

4. After the installation is complete, restart your computer. 

http://www.microsoft.com/en-us/download/details.aspx?id=26727
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Verify That SQL Server is Configured to use TCP/IP

Use this procedure to verify that TCP/IP is enabled. The SQL Server 2008 
installation enables TCP/IP by default.

1. Select Start > All Programs > Microsoft SQL Server 2008 > 
Configuration Tools > SQL Server Configuration Manager.

2. Expand the SQL Server Network Configuration node, and select 
Protocols for instance name.

3. Ensure that TCP/IP is Enabled. If it is not enabled, right-click on TCP/IP and 
change the status to Enabled.

4. If you enabled TCP/IP, restart the service. To do this, select 
SQL Server Services, and for each of the services listed, right-click and select 
Restart.
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5. Verify that the SQL Server Browser service is running.  If it is not running, 
right-click it and select Start.

Configure the SQL Server Default Database Location

Once you have installed SQL Server, you must configure the default database 
location for the instance that will run Sage Timberline Enterprise.

1. Select Start > All Programs > Microsoft SQL Server > SQL Server 
Management Studio and connect to the server.

2. Right-click the top-level node where your SQL Server instance appears, and 
then select Properties. 

3. In the Server Properties window, select Database Settings.
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4. Under Database default locations, select the default data and log folders that 
you set up in the section “Determine the Location of Data and Shared Folders” 
on page 17.

WARNING:  Do not leave these locations set to the default entries unless you have verified 
that those folders are present and the necessary access has been set up.

5. Click OK to save your changes.

Configure SQL Server Memory Usage (Optional)

By default, SQL Server uses all available memory. If you need to limit the amount 
of memory available to SQL Server, while still in the Server Properties window, 
click the Memory page and select the maximum server memory (in megabytes) that 
you want to allow.
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Install and Configure IIS

Internet Information Services (IIS) are Internet-based services for servers. These 
services must be installed and configured on the server that will hold the 
Sage Timberline Enterprise server installation. If you plan to install 
Sage Timberline Enterprise on a different server than Microsoft SQL Server, install 
IIS on the server with Sage Timberline Enterprise.

IIS must be set up to be compatible with IIS 6.0. 

Depending upon your system configuration, the steps to set up IIS vary. Follow the 
steps in this guide careful to ensure that your server is set up correctly.

 Install IIS on Windows Server 2008 or 2008 R2—page 61.

 Install IIS on Windows Server 2003 or 2003 R2—page 62.

IIS and ASP.NET are features of Microsoft products. For more information, see 
www.iis.net or www.microsoft.com.

Log On as Administrator

In order to install IIS, log on to the computer that will hold the server installation of 
Sage Timberline Enterprise with the built-in Administrator account. Members of 
the local administrators group do not have the necessary administrative privileges 
to perform these steps.

Install IIS on Windows Server 2008 or 2008 R2

Install IIS by Adding the Web Server (IIS) Role

1. Select Start > Administrative Tools.

2. Right-click Server Manager and select Run as administrator. Enter your 
administrator name and password, and then click Yes.

3. Right-click Roles and select Add Roles. 

4. In the Roles wizard, click Next to proceed to the list of server roles that can be 
added.

5. Select Web Server (IIS) and Application Server.

6. Click Install.

Add the Role Service

1. Select Start > Administrative Tools and right-click Server Manager. 

2. Select Run as administrator.

http://www.iis.net/
http://www.microsoft.com/
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3. Expand the Roles node on the tree, and select Web Server (IIS).

4. Right-click Web Server (IIS) and select Add Role Services. Select the 
following:

 Application Development: ASP.NET, ASP

 Security: Windows Authentication

 Management Tools: IIS 6 Management Compatibility

5. Click Next. 

6. Click Install.

Reset IIS

1. Select Start > All Programs > Accessories.

2. Right-click on Command Prompt and select Run as administrator.

3. When asked if you want to allow the program to make changes, click Yes.

4. Type IISRESET and then press ENTER.

5. Close the command prompt window.

Install IIS on Windows Server 2003 or 2003 R2

Run IIS in 32-bit Mode if Necessary

If you are using Windows Server 2003 R2 on a 64-bit machine, and IIS is already 
installed, do the following.

1. Open a command prompt and run this command to change it to 32-bit mode.

cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/
AppPools/Enable32bitAppOnWin64 1

2. Next, run this command to register ASP.NET.

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727 aspnet_regiis -i 

NOTE:  If you have other applications that rely on the 64-bit version of IIS on the server, 
you may experience problems with those applications.

3. Restart IIS.

Install IIS and ASP.NET

1. Select Start > Control Panel > Add or Remove Programs.

2. Click Add/Remove Windows Components. 

3. Select Application Server.
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4. Click Details. 

5. Select ASP.NET. Notice that Enable network COM+ access and Internet 
Information Services (IIS) are selected automatically.

6. Click OK. 

7. Click Next.

8. Click Finish.

Confirm the status of ASP.NET

1. Select Start > Administrative Tools > Internet Information Services (IIS) 
Manager.

2. Expand the folder for your server and then select Web Service Extensions.

3. Under Web Service Extension, verify that ASP.NET v2.0 05727 has a status of 
Allowed.

4. Close the Internet Information Services (IIS) Manager window.

Register ASP.NET and reset IIS

1. Select Start > Run.

2. Type CMD in the Open box, and then click OK to open the command prompt.

3. Type C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis 
-i and then press ENTER. Confirm that ASP.NET is registered properly.

4. At the command prompt, type IISRESET and then press ENTER.

5. Close the command prompt window.
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Install Sage Timberline Enterprise on the 
Server

If you do not have an earlier version of Sage Timberline Enterprise installed, follow 
the instructions to “Install Sage Timberline Enterprise on the Server” on page 65. 
This installs version 10.2 on your server, after which you’ll upgrade. 

Once you install version 10.2 (or if you already have an installation of Sage 
Timberline Enterprise installed), update to the latest version as follows: 

 If you have a current installation of version 10.2.x through 10.3.x, you must 
upgrade your software and databases to version 10.4.0, and then upgrade to the 
current version. See “Update the Sage Timberline Enterprise Server and 
Databases” on page 69.

 If you have a current installation of version 10.4.0 or later, you can upgrade to 
the current version directly. See “Update the Sage Timberline Enterprise Server 
and Databases” on page 69.

NOTE:  To determine your software version, start Sage Timberline Enterprise and select 
Help > About Sage Timberline Enterprise.

WARNING:  If you are upgrading from a previous version of Sage Timberline Enterprise, 
Internet Information Services are reset as part of the upgrade process. If you are using 
other Web services, the reset stops those services. We recommend that you stop all Web 
services prior to upgrading Sage Timberline Enterprise to avoid interruptions during the 
upgrade.

Install Sage Timberline Enterprise on the Server

Follow these instructions if you do not have an earlier version of Sage Timberline 
Enterprise installed on your server. This installs version 10.2 on your server. You 
will upgrade to the latest version once you complete the new installation.

1. Insert your Sage Timberline Enterprise installation DVD at the server. In the 
Setup and Installation window, click Perform system verification.
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2. In the Sage System Verifier window, click Scan System.

3. If any issues are found, you must address them before you can continue with the 
installation. The Details section of the window provides information about 
issue resolution. If no issues are found, click Close.

4. In the Setup and Installation window, under Install, click Server components 
and tools. 

5. You may be asked to install prerequisites. Click Install to install each 
prerequisite. 
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6. In the Sage Timberline Enterprise Server Setup window, click Next. 

7. In the End-User License Agreement window, select I accept the terms in the 
License Agreement, and then click Next. 

8. In the Destination Folder window, select the installation destination to which 
you want to install the software, and then click Next. 
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9. Click Install. 

10. When the setup wizard completes the installation, click Finish. 

NOTE:  Before you can access the application at the server, you must complete the 
Configuration Wizard and also run the client installation at the server. The Configuration 
Wizard steps start on page 82. The client installation steps start on page 106. 
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Update the Sage Timberline Enterprise Server and 
Databases

Once you have installed Sage Timberline Enterprise, upgrade to the latest version 
as follows:

1. Upgrade your software and databases to version 10.4.0 or 10.4.1.

2. Upgrade to the current version.

WARNING:  The database upgrade may require considerable time. Plan for one hour per 
database. Also, the upgrade process requires a large amount of free hard drive space. The 
files might grow to 50 GB or more. Before you upgrade the databases, ensure that you have 
adequate disk space available.

NOTE:  To determine your software version, start Sage Timberline Enterprise and select 
Help > About Sage Timberline Enterprise.

 To Update the Server and Databases to Version 10.4.0 or 10.4.1

Use this procedure if your current version of Sage Timberline Enterprise is earlier 
than 10.4.0. You must first upgrade to 10.4.0 or 10.4.1, and then upgrade to the 
latest version.

WARNING:  Before you start the update, verify that you have a full backup of your 
Sage Timberline Enterprise databases and report designs. You can create backups using 
the tools in SQL Server Management Studio.

1. Log on to your Sage Timberline Enterprise server with full administrative 
permissions.

2. Open System Administration (Start > All Programs > Sage > 
Sage System Administration).

3. Close all open instances of Sage Timberline Enterprise and Microsoft Excel.

a. Click License Administration and click the Active users tab.

b. Click Restrict logon to prevent further connections. (This will not close any 
current connections.)

c. Contact any users listed as active and instruct them to log off of 
Sage Timberline Enterprise.

4. Open an Internet browser and download the update file (STE_10.4.0.exe) from 
the following location. Save the file to a shared network location that all servers 
and workstations can access:
http://cdn.updates.timberline.com/SoftwareAlerts/STE_10.4.0.exe.

http://cdn.updates.timberline.com/SoftwareAlerts/STE_10.4.0.exe
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5. Browse to location at which you stored the file. Right-click it and select 
Run as administrator.

6. Follow the instructions to update the software. If asked whether you want to 
uninstall the Excel client, click Yes. This component is reinstalled at the end of 
the upgrade. 

NOTE:  The update file detects whether you are installing on a server or a workstation and 
performs the appropriate changes.

7. Upgrade the Sage Timberline Enterprise databases.

a. Open Sage System Administration.

b. Click Database Administration.

c. Click the database you want to upgrade, and then click Upgrade database.

d. Repeat the upgrade for each database.

NOTE:  After the server and databases have been updated, you must update each 
workstation. Instructions for updating the workstations start on page 120.

8. Revise roles if necessary. As new features and reports are added to Sage 
Timberline Enterprise software, they are not automatically added to the existing 
roles in System Administration. To add features and reports to a role:

a. In System Administration, Database Administration, click the Roles tab. 

b. Click Authorize features and select the features and reports you want to 
add.

c. Click OK.

NOTE:  Consult the release notes to identify new features and reports to add.



Install Sage Timberline Enterprise on the Server Installation and Maintenance Guide

© 2012 Sage Software, Inc. 71

 Update the Server and Databases to the Current Version 

Use this procedure to upgrade Sage Timberline Enterprise from version 10.4.0 or 
later to the latest version.

WARNING:  Before you start the update, verify that you have a full backup of your 
Sage Timberline Enterprise databases and report designs. You can create backups using 
the tools in SQL Server Management Studio.

1. Log on to your Sage Timberline Enterprise server with full administrative 
permissions.

2. Open System Administration (Start > All Programs > Sage > 
Sage System Administration).

3. Close all open instances of Sage Timberline Enterprise and Microsoft Excel.

a. Click License Administration and click the Active users tab.

b. Click Restrict logon to prevent further connections. (This will not close any 
current connections.)

c. Contact any users listed as active and instruct them to close Sage Timberline 
Enterprise.

4. Click Update Administration.

5. Click the Sage Timberline Enterprise update to select it.

6. If you are not set up to download updates automatically, click Download. (If the 
update downloaded automatically, you see the Install Server button.)

7. Click Install Server. When the update is finished, System Administration re-
opens so that you can upgrade your databases.

8. Upgrade the Sage Timberline Enterprise databases.

NOTE:  If you attempt to start the database upgrade while users are connected to the 
database, a message appears giving details about the connection. 

a. In System Administration, click Database Administration.

b. Click the database you want to upgrade, and then click Upgrade database.

WARNING:  The database upgrade may require considerable time. Plan for one hour per 
database. Also, the upgrade process requires a large amount of free hard drive space. The 
files might grow to 50 GB or more. Before you upgrade the databases, ensure that you have 
adequate disk space available.

c. Repeat the upgrade for each database.

9. Revise roles if necessary.
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NOTE:  As new features are reports are added to Sage Timberline Enterprise software, 
they are not automatically added to the existing roles in System Administration. Consult the 
release notes to identify new features and reports to add.

To add features and reports to a role:

a. In System Administration, Database Administration, click the Roles tab. 

b. Click Authorize features and select the features and reports you want to 
add.

c. Click OK.

NOTE:  After the server and databases have been updated, you must update each 
workstation. When you start Sage Timberline Enterprise on each workstation, you are 
prompted to install the update. You will not be able to connect the workstation to the server 
until you update the workstation. Follow the prompts to complete the process. See 
page 105 for more information.
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Install or Update Payroll on the Server

Payroll is an optional module that you can use with Sage Timberline Enterprise. 
Payroll uses a Pervasive.SQL database, rather than a SQL Server database.

If you do not have an earlier version of Payroll installed, follow the instructions to 
“Install Payroll on the Server” on page 73. This installs Payroll version 9.7.100 for 
Sage Timberline Enterprise 10.2.0. 

Once you install version 9.7.100 (or if you already have a Payroll installation), 
update to the newest version as follows: 

 If you have a current installation of Payroll earlier than 9.7.102 (compatible 
with Sage Timberline Enterprise 10.4), you must upgrade your software and 
databases to version 9.7.102, and then upgrade to the current version.

 If you have an installation of Payroll 9.7.102 or later, you can upgrade to the 
current version. See “Update the Payroll Software and Databases” on page 78.

NOTE:  To determine your software version, start Payroll and select Help > About. 

Permissions Required for Payroll

To install and use Payroll, all operators must have full control of several folders and 
registry keys on servers and workstations. You may have already assigned these 
permissions as part of determining your folder locations in an earlier section. If not, 
see “Additional Permissions Required for Payroll” on page 20.

Install Payroll on the Server

Follow these instructions if you do not have an earlier version of Payroll installed 
on your server. This installs version 9.7.100 (compatible with Sage Timberline 
Enterprise 10.2.0) on your server. You will upgrade to the latest version once you 
complete the new installation.

1. At the server, insert your Sage Timberline Enterprise installation DVD. 

NOTE:  Payroll cannot be installed from a network location.
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2. In the Setup and Installation window, under Install, select Additional 
Installs.

3. Open the STE Payroll folder.

4. Open the AccountingServer folder, and then double-click Install.exe.

5. Click Install Enterprise Payroll Server software. 
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6. Read and perform the steps listed in the Preparation window. Select I have 
read and completed these steps, and then click Next. 

7. In the Prerequisites window, you can view the status of the additional software 
that is required to run Payroll. Click Next to continue. 
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8. In the License Agreement window, click Yes to agree to the terms of the 
software.

9. In the Ready to Install the Program window, click Install. 
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10. When the installation is complete, click Finish.

11. A message tells you that you must restart your computer.  Click Yes.

12. After the computer restarts, the Sage Configuration Manager starts 
automatically to complete security upgrades.  Wait for the process to finish, and 
then click OK.
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Update the Payroll Software and Databases

Once you have installed Payroll 9.7.100, you will upgrade to the latest version as 
follows:

1. Upgrade your software and databases to version 9.7.102, which is compatible 
with Sage Timberline Enterprise 10.4 (page 78).

2. Upgrade to the version compatible with your current Sage Timberline 
Enterprise installation.

 To Update the Server and Databases to Version 9.7.102

1. Log on to the Payroll server with full administrative privileges.

2. Open System Administration (Start > All Programs > Sage > 
Sage System Administration).

3. Verify that no users are connected to Payroll or to Sage Timberline Enterprise.

a. Click License Administration and click the Active users tab. 

b. Contact any users listed as active and instruct them to log off of 
Sage Timberline Enterprise.

c. Click Restrict logon to prevent further connections. 

This will not close current connections, but it will prevent users from 
connecting while you run the Payroll application upgrade. 

4. Open an Internet browser and download the update file (STE_PR_10_4_0.exe) 
from the following location. Save the file to a shared network location that all 
servers and workstations can access:
http://cdn.updates.timberline.com/SoftwareAlerts/STE_PR_10_4_0.exe.

5. Browse to the location in which you stored the file. Right-click it and select Run 
as administrator.

6. Follow the instructions to update the software.

 To Update the Server and Databases to the Current Version

NOTE:  Before you can complete this procedure, you must upgrade Sage Timberline 
Enterprise to the current version.

http://cdn.updates.timberline.com/SoftwareAlerts/STE_PR_10_4_0.exe.
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WARNING:  Before you start the update, verify that you have a complete backup of your 
Payroll database and report designs.

1. Log on to the Payroll server with full administrative permissions.

2. Open System Administration (Start > All Programs > Sage > 
Sage System Administration).

3. Verify that no users are connected to Payroll or to Sage Timberline Enterprise.

a. Click License Administration and click the Active users tab. 

b. Contact any users listed as active and instruct them to log off of 
Sage Timberline Enterprise.

c. Click Restrict logon to prevent further connections. 

This will not close current connections, but it will prevent users from 
connecting while you run the Payroll application upgrade. 

4. Click Update Administration.

5. Click the Sage Timberline Enterprise Payroll update to select it.

If you are not set up to download updates automatically, click Download. (If the 
update has been downloaded, you see the Install Server button.)

6. Click Install Server, and then click OK. When the update is finished, you’ll 
upgrade the databases.

7. Upgrade the Payroll databases. 

a. In System Administration, click License Administration and click the 
Active users tab. 

For this set of steps, you will need to allow logons so that the system can 
access the Payroll data to upgrade it. Users should be instructed to remain 
logged out of the system while this happens.

b. Click Allow logon. 

c. Open Payroll (Start > All Programs > Sage > Sage Timberline 
Enterprise Payroll).

d. Select Tools > Upgrade Files.

e. Click Select All, and then click Start.

f. Repeat this for all of your Payroll databases.

NOTE:  After the server and databases are updated, you must update each of the 
workstations. Operators will be prompted to complete the workstation update when they 
next start Sage Timberline Enterprise. They can follow the prompts to complete the update.



Install Sage Timberline Estimating Sage Timberline Enterprise

80 © 2012 Sage Software, Inc.

Install Sage Timberline Estimating

You can integrate Sage Timberline Enterprise with Estimating and then send your 
estimates to Job Management, where you monitor progress against each job.

FOR MORE INFORMATION:  See the Estimating Help topic “Integrate with Sage 
Timberline Enterprise” to learn about the integration with Sage Timberline Enterprise.

You can install the Sage Timberline Estimating application on the server, or you can 
store only the databases on the server. Follow the installation instructions that 
accompany your Estimating software to install the application and databases.

Before you can open Estimating and configure it to work with Job Management, 
you’ll need to configure your licensing.

 If you will use License Manager to manage your Estimating licenses, install 
License Manager as directed by the Estimating installation instructions.

 If you will not use License Manager, attach the Sentinel protection device to the 
computer’s parallel or USB port before you open Estimating.  (If you are using 
a parallel port, first remove any devices connected to the parallel port. Attach 
the protection device to the parallel port and then reconnect your other devices 
to the back of the protection device.

Configure Estimating for Use with Enterprise Job 
Management

Once you have installed Estimating, configure the interface with 
Sage Timberline Enterprise Job Management. You need to do this only if you have 
existing databases that you will use with Job Management. If you are creating a new 
database, you do not need to complete these steps.

1. Open Estimating Tools (Start > Programs > Sage > Sage Timberline Office 
> Estimating > Estimating Tools).

2. Select Setup > Change Job Cost Information.

3. Select the Estimating database that you want to use with Sage Timberline 
Enterprise.

4. In the Job Cost Interface Type field, select Sage Timberline Enterprise.

5. Click OK. The database is configured.



Installation and Maintenance Guide

© 2012 Sage Software, Inc. 81

Server Configuration

This section shows you how to configure your licenses, databases, and users in 
Sage System Administration once you have installed all of the server components 
described in the last section. Complete the tasks in this section in order for best 
results:

 In Sage System Administration, run the Configuration Wizard (page 82).

 Activate your Sage Timberline Enterprise licenses (page 89).

 Set up the sample database (page 91).

 Develop and implement a Sage Timberline Enterprise security plan (page 105).
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Configure Sage System Administration

After you install Sage Timberline Enterprise, you must configure the Sage System 
Administration settings by running the Configuration Wizard. 

Important Points about the Configuration Wizard

The wizard starts automatically the first time you start Sage System Administration. 
To run the Configuration Wizard successfully:

 You must first be set up as a system administrator in SQL Server. 

 You must run the Configuration Wizard at the server on which you installed 
Sage Timberline Enterprise and the Internet Information Services. (Although 
you can open System Administration from a workstation, you must complete 
this procedure at the server.)

Run the Configuration Wizard

1. At the server, open Sage System Administration by selecting Start 
> All Programs > Sage > Sage System Administration.)
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2. When the window opens, click the Sage Timberline Enterprise SA node to 
bring up the Log on window.

3. In the Log on window, type the name of the Web server (or you can type 
localhost, because you are at the server), and then click OK. 

4. In the Select Mode window, choose the mode in which you want to configure 
your Sage System Administration software. 

 If you have only one SQL Server instance is installed, you can select 
Simple Mode to set up Sage System Administration with the most common 
configuration options. 
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 If more than one SQL Server instance is installed on the server, you must 
select Advanced Mode. This option gives you more control over the 
configuration process.

5. Click Next to continue. A warning message appears regarding SQL Server 
updates.

6. Click OK.

 If you selected Simple Mode, click Configure and wait for the wizard to 
finish.
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 If  you selected Advanced Mode, you see the Database Log On window. 
Continue with this procedure.

7. In the Server name box, select the SQL Server instance that you set up when 
you installed SQL Server for Sage Timberline Enterprise. Click Next.

8. The next window differs based on whether you have had an earlier installation 
of Sage Timberline Enterprise or run the configuration wizard before.
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 If you have had an earlier installation of Sage Timberline Enterprise, or you 
have run the configuration wizard on this computer before, select the 
configuration options for the SAAConfiguration database.

Select Rename the existing database or Delete the existing database and 
click Next.

 If you have never run the configuration wizard on this computer before, you 
see the Web Services Check window.

9. In the Web Service Check window, click Next.

10. The next window again differs based on previous configuration.
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 If you have have run the configuration wizard on this computer before, 
select Rename the existing web service or Delete the existing web service 
and click Next.

 If you have never run the configuration wizard on this computer before, you 
see the Configure window.

11. In the Configure window, click Configure. 

12. When the process is finished, the web service connection is established and you 
are logged on to the System Administration server again.



Configure Sage System Administration Sage Timberline Enterprise

88 © 2012 Sage Software, Inc.



Activate Your Sage Timberline Enterprise Licenses Installation and Maintenance Guide

© 2012 Sage Software, Inc. 89

Activate Your Sage Timberline Enterprise 
Licenses

Once you install Sage Timberline Enterprise, you must activate your licenses in 
order to use the software. You must be connected to the Internet to activate licenses.

Each license has a specific number of associated uses, which are distributed 
amongst workstations. This section covers the following options for activating 
licenses and distributing uses:

 Activate licenses on a single server (most common scenario). 

 Activate licenses on multiple servers.

Understand the Default License Activation Process

When your server first connects to Sage to activate licenses, all of your available 
uses are assigned to that server. (If you use the optional Payroll module, your 
Payroll licenses are activated at the same time.) If you take no further action, uses 
remain allocated to that server. If you use only one server, this is the appropriate 
configuration. 

However, if you use multiple servers, you must use the multi-server licensing 
procedure described below to ensure that each of your servers can access the 
software.

If you mistakenly allocate all uses to a single server and you need to correct the 
issue, open License Administration at the server that has all the licenses. 
Distribute licenses as needed according to the instructions for multi-server licenses.

Plan for Hardware Changes to the Server

If you need to make any hardware changes to the Sage Timberline Enterprise server, 
plan to deactivate licenses before you make the change, and then re-activate them 
when you are finished. This avoids issues with licensing after you bring the new 
hardware configuration online. For instructions to deactivate licenses, see page 150.

Activate Licenses on a Single Server

In a standard client/server environment, you install Sage Timberline Enterprise on 
a single server and then activate the server’s license. The uses allocated to that 
license are assigned to each workstation in succession as they connect. 

1. In System Administration, select License Administration.

2. Click Edit Registration Information. Type your client ID exactly as provided 
to you by Sage.
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3. In the Registration name box, type the name exactly as provided to you by 
Sage and click OK. The license is activated. If you use the optional Payroll 
module, your Payroll license is activated as well.

NOTE:  If the client ID and registration name do not exactly match those you received from 
Sage, the license activation does not succeed.

How Uses are Distributed in the Single-Server Scenario

If five uses are assigned to your license, the first five workstations to connect to the 
server are allowed to connect.  The sixth workstation that requests simultaneous 
access is denied.

Activate Licenses on Multiple Servers

If you have more than one server with the Sage Timberline Enterprise software 
installed (for example, if you have multiple corporate offices, each with a local 
server to which users will connect), you can distribute the available uses amongst 
these servers. Each server assigns only the uses allocated to it. 

1. In System Administration, select License Administration.

2. In the Sage client ID box, type your client ID exactly as provided to you by 
Sage.

3. In the Registration name box, type the name exactly as provided to you by 
Sage. The license activation occurs automatically when you enter the 
information correctly.  If you use the optional Payroll module, your Payroll 
license is activated as well.

NOTE:  If the client ID and registration name do not exactly match those you received from 
Sage, the license activation does not succeed.

4. Click Multi-server licensing. 

5. Select Manually specify license allocations for this server.

6. Enter the number of uses for this server for each module in the Uses for server 
name column.

7. Click OK to allocate the licenses.

How Uses are Distributed in the Multiple-Server Scenario

If ten uses are assigned to your license, you might allocate five to each of two 
servers (Server1 and Server2). The first five workstations to connect to Server1 
are allowed to connect.  The sixth workstation to try connect to Server1 is denied. 
However, it can connect to Server2 if uses remain available on that server.
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Set Up the Sample Database

Before you can start using Sage Timberline Enterprise, you need to set up your 
databases, users, and roles. These tasks require you to develop your security plan 
for the software—which you may not have done yet. 

This section gets you started by showing you how to set up a system administrator 
for Sage Timberline Enterprise, attach the sample database, and give access to a 
user. When you are ready to develop a complete security plan for your organization, 
the section “Develop and Implement a Security Plan” starting on page 105 covers 
all of the details and decisions you’ll want to consider in your plan.

NOTE:  You can complete the following procedures at the server or at a workstation (if Sage 
Timberline Enterprise is already installed on the workstation). You must be logged on to 
Windows as a Sage Timberline Enterprise administrator in order to set up the sample 
database, users, and roles.

Set Up a System Administrator

Your first task is to set up a system administrator for Sage Timberline Enterprise. 
This individual manages the databases, users, and roles for the entire 
Sage Timberline Enterprise system, and also has administrative permissions for the 
SQL Server instance on which Sage Timberline Enterprise is installed. 

To set up the system administrator, follow these steps:

1. Start Sage System Administration if it is not already open (Start > All 
Programs > Sage > Sage System Administration). 
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2. Expand the tree on the left and click System Administrators. 

3. Click Add new administrator.

4. Select the Domain and Logon name for the administrator. Click the Refresh 
button to refresh the list.

5. Leave the System Administration window open so you can return to it.

Attach the Sample Database

The sample database is provided on the software DVD, in the folder called 
Sample Data, to help you learn its functions and plan your implementation. It is the 
same database that is used in Sage Timberline Enterprise training classes.

To attach an existing database, you first place the database file in your default data 
folder and attach it in SQL Server. Then you add the database to Sage System 
Administration so that you can associate users with it. If you will also need a Payroll 
sample database, you can use an existing Payroll database which you prepare and 
copy.

Move the training data files to the default data folder

1. Insert the software DVD into the server’s DVD-ROM drive and browse to the 
folder called Sample Data at the root of the DVD.

2. Unzip the Service_Specialty.zip file. Place the contents in your default data 
folder (the one you specified when installing SQL Server.

Attach the database in SQL Server Management Studio

1. Select Start > All Programs > Microsoft SQL Server 2008 > SQL Server 
Management Studio.
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2. Verify that the correct server and instance are selected, and then click Connect 
to log on.

3. Right-click the Databases folder and select Attach.

4. Click Add, and then browse to your default data folder.

5. Click the .mdf file for the database you want to attach, and then click OK.

6. In the lower grid, if the Message column shows Not Found for either the data 
or log folder, click the browse button and browse to your default data and log 
folder. If you do not have a log (.ldf) file, click the row for the log file and then 
click Remove.

NOTE:  If you remove the log file, a new one is created automatically once you attach the 
database.
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7. Click OK. When the window closes you should see the new database in the list.

8. Close SQL Server Management Studio.

Add the Database to Sage System Administration

1. Open Sage System Administration and log on if it is not already open.

2. Click Database Administration.

3. Click Create New Database.

4. Enter a display name for the database, and then enter the path to the attachments 
and spool folders that you created and shared earlier (page 17).

NOTE:  When you enter the path name, use the format \\ServerName\FolderName rather 
than specifying a drive letter path. The attachments and spool folders must be shared in the 
folder Properties.

5. Next to server, enter the server and the SQL Server instance name in the format 
ServerName\InstanceName.

6. Next to Database Name, click the refresh button and select the database from 
the list.

7. Click OK.

8. If you have installed or upgraded the optional Payroll module, complete these 
steps to to link to the correct Payroll database. 

a. Open Payroll and select the Payroll database.

b. In the Select Accounting Database window, select the correct database, 
and click OK.

9. Click OK. Note that before you can use the database, you must add at least one 
user and one role to the Sage Timberline Enterprise database in System 
Administration.
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Prepare a Payroll Testing Database

By default, a Payroll sample data set is installed on your server, in the location 
C:\ProgramData\Sage\TIMBERLINE OFFICE\Data\STE Payroll Sample Data. 

If you need to use a copy of your existing Payroll database for testing (rather than 
the sample database), follow these instructions.

1. Open Payroll and select the company that you want to copy to use for testing.

2. Select File > New Company.

3. Enter the company name and address, and then press TAB.

4. Accept the default company folder path (this is automatically entered based on 
the company name)—or enter a new path.

5. Indicate whether to use the current company folder settings: 

 Select Use current setup to apply the current company folder settings to the 
new folder. This includes the following settings:

 Leave the check box cleared if you want to establish settings different from 
the current company folder.

6. Click OK.

7. You are asked to select an accounting database. Select the database to which you 
want to link to and click OK. The database is created, and it becomes your 
current database.

8. Select Tools > File Tools and create a copy of the data set that you want to use 
for testing.

Settings applied when Use Current Setup is selected

Accounting method

Batch control settings

All settings in Batch Control Settings window

File locations

Custom descriptions, including sections for:

 AR Invoices

 Contracts

 Contract items

 General Ledger accounts

 Job Cost jobs and cost codes

 Post and interface settings
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9. When the copy is finished, open Windows Explorer and browse to the copy that 
you just created (the path you entered in the Destination box).

10. Select all files in this folder except the ts.ctl file, and press CTRL + C to copy 
them.

11. In Windows Explorer, browse to the folder for the new company that you 
created in step 2.

12. Press CTRL + V to paste the files into the new folder (except for the ts.ctl file). 
Use the new company folder for your testing.

Add a User and a Role to the Database

You must add at least one user and one role to the database in order to begin using 
Sage Timberline Enterprise. You add users using their Windows domain logon 
name.

Add a User

1. In System Administration, click Database Administration.
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2. Under Databases, select the database.

3. On the Users tab, click Add new user.

4. Your domain should already be selected. Type the user logon name or click the 
Refresh button to select from a list of domain users, and then click OK.

NOTE:  For more information about adding or maintaining users, see the System 
Administration Help topics called “Users tab” and “Maintaining users.”
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Add a Role

Roles let you assign user permissions according to the tasks they perform.

1. In Database Administration, click the Roles tab.

2. Click Add new role.

3. In the Role name box, type Training so that you can use this role for training 
purposes. 

4. Click OK.
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5. In the Authorize Features For Role window, select the Features check box, 
so that all features will be selected for the Training role. 

6. Click OK.

7. In the Members of box, select the user that you want to add to the role.  

NOTE:  For more information about roles and features, see the System Administration Help 
topics called “Roles tab” and “Authorize Features for Role window.”
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Create and Assign Custom Menus

Custom menus let you create groupings of tasks or reports and then assign them to 
users or roles. For example, you might want to organize daily, weekly, and monthly 
tasks for Accounts Payable specialists.

1. In Database Administration, click the Menus tab. Notice the STE Default 
menu. This menu is present by default, and cannot be changed.

NOTE:  You can copy this menu by clicking Copy menu if you want to use the default menu 
as a starting point for further modifications.

2. Click Create new menu.

3. In the New menu name box, type a name for the menu and click OK.

4. On the Menu tab, click Edit menu.
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5. In the Edit Menu window, click Create menu folder to create a new grouping. 

6. In the Create Menu Folder window, enter a name for the menu and click OK.

7. In the Edit Menu window, click Create menu item.

8. In the Create Menu Item window, browse to the menu item you want to add, 
and click OK. 
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9. Continue adding menu items and folders as needed by repeating steps 
5 through 8.

10. Click OK when you are finished. The menu now appears in the list. 

11. To assign the menu to user, verify that the correct menu is selected in the Menus 
list, and select the check box next to the users under Menu users.

NOTE:  Each user can be assigned to only one menu. When you select a user’s check box, 
other menus to which that user was assigned previously are cleared. 
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Users Assigned to Custom Menus

When a user assigned to a custom menu next opens Sage Timberline Enterprise, the 
items in that menu are the only available options. The folder groupings act as 
modules in the left navigation pane.
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Develop and Implement a Security Plan

If you have set up the sample database to work with Sage Timberline Enterprise, 
you already have at lease one user, role, and system administrator set up in System 
Administration. To develop a complete security plan for your organization, you’ll 
need to create lists of employees and the tasks they perform regularly, and then 
organize these lists into roles, features, and menus.

This section walks you through each of the security planning steps and 
considerations, with examples from the sample database, and then shows you how 
to implement your plan in System Administration.

Understand Security in Sage Timberline Enterprise

Sage Timberline Enterprise security can be as simple or as robust as you need it to 
be. You define the level of access that each of your employees has to the modules 
and workflow tasks, as well as which databases they can access. If you have several 
employees who perform similar functions, you can assign each of them to the same 
role, facilitating your setup work.

NOTE:  You can complete the procedures in this section at the server or at a workstation 
(if Sage Timberline Enterprise is already installed on the workstation). You must be logged 
on to Windows as a SQL Server administrator in order to complete the steps.

Security in Sage Timberline Enterprise is composed of the following elements, 
each of which are managed in System Administration.

 System administrators. The system administrator manages the databases, users, 
roles, and features for the entire Sage Timberline Enterprise system. This 
individual also has administrative permissions for the SQL Server instance on 
which Sage Timberline Enterprise is installed. Consider appointing more than 
one individual to this role so that you have adequate coverage. 

 Databases. Databases hold your Sage Timberline Enterprise data. All users that 
you add in System Administration are associated with a particular database. 

 Users. Sage Timberline Enterprise operators must be added to the database to 
which they will have access. You use Windows domain logon names to add 
users to the system. 

 Roles. A role defines a set of permissions accessible to a user associated with 
that role. In order to access features in the software, users must be assigned to 
at least one role.

 Features. Tasks that you can perform in the software, such as entering invoices 
or entering transactions into General Ledger, are features that you can assign to 
roles.

 Menus. You can create custom menus that include specific tasks and reports.
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Understand Security in Payroll

The optional Payroll module has its own security setup. 

 To learn about Payroll security, open Payroll and select Help > Documents. 
Open SecurityGuide.pdf and read the document before planning your Payroll 
security model.

 To enable Payroll security, select Tools > Security Setup and then click 
Security Settings. Press F1 at any time for help with the active window.

NOTE:  If you enable Payroll security, you’ll designate a user as the Application 
Administrator as part of the setup. That user must also be added to the Payroll Settings 
tab in Sage Timberline Enterprise System Administration (Database Administration > 
Database Properties).

Establish Your System Administrators

The system administrator for Sage Timberline Enterprise manages the databases, 
users, and roles for the entire Sage Timberline Enterprise system, and also has 
administrative permissions for the SQL Server instance on which 
Sage Timberline Enterprise is installed. When you installed the software, at least 
one system administrator was added. Considering assigning more than one 
individual to this role so that you have adequate coverage.

To set up the system administrator, follow these steps:

1. Start Sage System Administration if it is not already open (Start > All 
Programs > Sage > Sage System Administration). 
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2. Expand the tree on the left and click System Administrators. 

3. Click Add new administrator.

4. Select the Domain and Logon name for the administrator. Click the Refresh 
button to refresh the list.

5. Leave the System Administration window open so you can return to it.
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Create a Database

Except for system administrators, all users that you add in the System 
Administration module are associated with a particular database. Before you can 
add the users, you must create the database. 

Note that the configuration settings for your database require careful consideration. 
We recommend that you work with a certified consultant and reference the setup 
documentation we provide to facilitate this process. However, if you are ready to 
start setting up security, you can create the database now and plan to refine the 
configuration settings later. Alternately, you can apply your security plan to the 
sample database for practice. 

1. In System Administration, click Database Administration.

2. Click Create New Database.

3. On the Database Settings tab, enter a name for the database and the location of 
the Attachments and Spool folders. (For more information about these folders, 
see page 17.)

4. Next to Server, enter the name of the server.

5. Next to Database name, enter the name to use for your database files.

6. Click OK, and answer Yes to the confirmation message.
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7. Select the starting month for your fiscal year, and then click OK. After a 
moment, the database appears in the list.

Establish the List of Users

Sage Timberline Enterprise is integrated with Windows security, so you’ll use 
Windows logon names to set up users in System Administration.  Your users must 
already be set up in the domain’s Active Directory before you can add them to 
System Administration.

NOTE:  Users with access to a database can access all records in that database through 
reporting and third party data access tools, including ODBC, SQL queries, Crystal Reports, 
and others.

To begin planning, create a list of users. Your list should include every employee in 
your organization who will have access to Sage Timberline Enterprise. 

Add Users to the Database

1. In System Administration, click Database Administration.
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2. Under Databases, select the database. (Whenever you add a user, you associate 
the user with the database you have selected.)

3. On the Users tab, click Add new user.

4. Your domain should already be selected. Type the user logon name or click the 
Refresh button to select from a list of domain users, and then click OK.

5. Notice that the Users tab shows you the list of users that you have added so far.  
When you click a user, you see the roles to which that user is assigned, as well 
as the corresponding features.

NOTE:  For more information about adding or maintaining users, see the System 
Administration Help topics called “Users tab” and “Maintaining users.”
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Establish a List of Roles

Roles are used to set permissions more efficiently, by grouping sets of features. For 
example, you might have an Accounts Payable role, a Dispatcher role, and a Service 
Agreements role, each with access to different tasks in the software.

Establish a list of roles to which each user will be assigned. You will probably find 
that you need to refine the features associated with each role, or even add new roles, 
as you learn about how your workflows are best accommodated. 

Add Roles and Authorize Features

Roles let you assign user permissions according to the tasks they perform. You 
specify the features (tasks you can perform in the software) that are available to 
users associated with that role. For example, a user associated with a role called 
Accounts Payable might be able to set up vendors and enter invoices. 

1. In Database Administration, click the Roles tab.

2. Click Add new role.

3.  In the Role name box, type a name for the role.
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4. Click OK.

5. In the Authorize Features For Role window, select the check boxes for the 
features that you want to assign to this role.

6. Click OK.

7. In the Members of box, select the users that you want to add to the role. 
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8. Click the Features tab, and notice that you can manage users and roles by 
feature from this tab.

NOTE:  For more information about roles and features, see the System Administration Help 
topics called “Roles tab” and “Authorize Features for Role window.”



Develop and Implement a Security Plan Sage Timberline Enterprise

114 © 2012 Sage Software, Inc.

Create and Assign Custom Menus

Custom menus let you create groupings of tasks or reports and then assign them to 
users or roles. For example, you might want to organize daily, weekly, and monthly 
tasks for Accounts Payable specialists.

1. In Database Administration, click the Menus tab. Notice the STE Default 
menu. This menu is present by default, and cannot be changed.

NOTE:  You can copy this menu by clicking Copy menu if you want to use the default menu 
as a starting point for further modifications.

2. Click Create new menu.

3. In the New menu name box, type a name for the menu and click OK.

4. On the Menu tab, click Edit menu.
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5. In the Edit Menu window, click Create menu folder to create a new grouping. 

6. In the Create Menu Folder window, enter a name for the menu and click OK.

7. In the Edit Menu window, click Create menu item.

8. In the Create Menu Item window, browse to the menu item you want to add, 
and click OK. 
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9. Continue adding menu items and folders as needed by repeating steps 
5 through 8.

10. Click OK when you are finished. The menu now appears in the list. 

11. To assign the menu to user, verify that the correct menu is selected in the Menus 
list, and select the check box next to the users under Menu users.

NOTE:  Each user can be assigned to only one menu. When you select a user’s check box, 
other menus to which that user was assigned previously are cleared. 
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Users Assigned to Custom Menus

When a user assigned to a custom menu next opens Sage Timberline Enterprise, the 
items in that menu are the only available options. The folder groupings act as 
modules in the left navigation pane.
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Client Components Installation

Once you have installed the server components and configured your software, you 
are ready to install the Sage Timberline Enterprise client components on your 
server and workstations. This section shows you how to:

 Install or update the Sage Timberline Enterprise client components on the 
server or workstation (page 120).

 Install or update the Payroll client components on a workstation (page 127)

 Test your installations (page 125).
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Install Client Components on the Server and 

Workstations

If you have not yet installed Sage Timberline Enterprise on your workstations, 
follow the next procedure, “Install Sage Timberline Enterprise Client Components 
on the Server and Workstations,” to install them.

If you have an existing installation of Sage Timberline Enterprise and you have 
completed the server update (see page 69), you can update your client components 
on the workstations using the procedure “Update the Client Components” on 
page 124. 

Install Sage Timberline Enterprise Client Components on 
the Server and Workstations

Insert your Sage Timberline Enterprise installation DVD at the workstation. 

1. In the Setup and Installation window, click Perform system verification.
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2. In the Sage System Verifier window, click Scan System.

3. If any issues are found, you must address them before you can continue with the 
installation. The Details section of the window provides information about 
issue resolution. If no issues are found, click Close.

4. In the Setup and Installation window, under Install, click Workstation 
components and tools.
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5. You may be asked to install missing prerequisites. Click Accept to continue. 

6. If you are asked whether you want to install the Sage Timberline Enterprise 
MSExcel AddIn, click Install. 

NOTE:  As of the 10.7.0 release, the Excel add-in is no longer installed as part of the client 
installation. The add-in is installed automatically the first time you open a task that uses it. 
If you need to install the add-in manually, you can do so by running 
\\ServerName\STE\Sage.MSExcel\Setup.exe, where ServerName is the name of your 
Sage Timberline Enterprise server.
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7. In the Sage Timberline Enterprise Client Setup window, select Next. 

8. In the End-User License Agreement window, select I accept the terms in the 
License Agreement, and then click Next.

9. In the Destination Folder window, select the installation destination to which 
you want to install the software, and then click Next. 
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10. In the Ready to Install Sage Timberline Enterprise Client window, click 
Install.

11. When the setup wizard completes the installation, click Finish.

Update the Client Components

 Update to Version 10.4.0 From an Earlier Version

If your server has been updated to the latest version of Sage Timberline Enterpriser, 
you may not need to complete this procedure. You may be prompted to install an 
update next time you start Sage Timberline Enterprise at the workstation. Follow 
the prompts to complete the update.

NOTE:  If the update file for version 10.4.0 was downloaded to a shared network location 
as described in the section “Update the Sage Timberline Enterprise Server and Databases” 
(page 69), you will access the file in that location to complete this procedure.

1. Log on to the workstation that you are updating with full administrative 
permissions.
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2. Close any open connections to Sage Timberline Enterprise on that computer.

3. Access the update file:

 If the file was downloaded to a shared network location, browse to that 
location now.

 If the file has not yet been downloaded, download it from this location: 
http://cdn.updates.timberline.com/SoftwareAlerts/STE_10.4.0.exe.

4. Right-click the STE_10.4.0.exe file and select Run as administrator.

5. Follow the instructions to complete the update.

6. Complete this process on each workstation.

 Update to the Latest Version

Once the server is updated, the next time you start Sage Timberline Enterprise at 
each workstation, you are prompted to install the update. Follow the prompts to 
complete the update.

http://cdn.updates.timberline.com/SoftwareAlerts/STE_10.4.0.exe
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Install or Update Payroll on Workstations

If you have not yet installed Payroll on your workstations, follow the next 
procedure, “Install Payroll on Workstations.”

If you already have an installation of Payroll, you must first update the server and 
databases (see page 78 for instructions). You can then follow the procedure “Update 
Payroll from an Earlier Version” on page 131.

If you Also Use Estimating

If you plan to install Payroll and Estimating on the same workstation, the versions 
of these modules must match. For example, you cannot install Estimating version 
9.8 on a workstation that has Payroll version 9.7. You can, however, use different 
versions of the modules on separate workstations (Estimating version 9.8 on one 
workstation and Payroll version 9.7 on a different workstation).

Permissions Required for Payroll

Full Control Required on Folders and Keys

To install and use Payroll, all operators must have full control of several folders and 
registry keys on servers and workstations. You may have already assigned these 
permissions as part of determining your folder locations in an earlier section. If not, 
see “Additional Permissions Required for Payroll” on page 20.

Elevate Permissions on Windows Vista or Windows 7

Before installing or upgrading Payroll workstation components, you must elevate 
your permissions on Windows Vista or Windows 7. You can usually do this by 
right-clicking the installation file and selecting Run as Administrator.

NOTE:  During certain installation tasks you see further prompt to elevate permissions. You 
must acknowledge these prompts in order to complete the installation. If you do not 
acknowledge a prompt within two minutes, the installation process stops and you see a 
message asking to retry the task. Click Retry and then elevate your privileges at the 
prompt.
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Install Payroll on Workstations

If you have not yet installed Payroll at the workstations, follow this procedure.

NOTE:  You must install Payroll on the server before you can install it on the workstations. 
If you have not yet installed Payroll on the server, do so before following this procedure. 

1. Verify that Sage Timberline Enterprise has been installed on the workstation. 
You must install the client components on any workstation on which you plan 
to install Payroll. Complete the Sage Timberline Enterprise client installation, 
and upgrade to the current version, before continuing with this procedure.

2. At the workstation, browse to the shared Timberline Office folder drive on the 
server. (The Payroll server installation automatically shares this folder.)

3. In the shared folder, browse to 9.5\Accounting\WinInst.

4. Double-click Install.exe.

5. Click Install Enterprise Payroll Client software.



Install or Update Payroll on Workstations Sage Timberline Enterprise

128 © 2012 Sage Software, Inc.

6. If you see a message that your system’s Windows Installer service must be 
upgraded, click Yes and complete that installation before continuing. (The 
installation will require you to restart the computer.)

7. Read and perform the steps listed in the Preparation window. Select I have 
read and completed these steps, and then click Next. 

8. In the Prerequisites window, you can view the status of the additional software 
that is required to run Payroll. Click Next to continue. 
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9. In the License Agreement window, click Yes to agree to the terms of the 
software.

10. In the Product Options window, select the first option, and then click Install.
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11. When the installation is complete, in the End window, click Finish.

12. A message indicates that you must restart your computer.  Click Yes and allow 
the computer to restart before continuing.
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Update Payroll from an Earlier Version

 Update Payroll to Version 9.7.102 From an Earlier Version

NOTE:  If the update file was downloaded to a shared network location as described in the 
section “Update the Payroll Software and Databases” (page 78), you will access the file in 
that location to complete this procedure.

1. Log on to the workstation with full administrative permissions.

2. Close all open instances of Sage Timberline Enterprise, including Payroll.

3. If the update file was downloaded to a shared network location, browse to that 
location now. Otherwise, download it from this location: 
http://cdn.updates.timberline.com/SoftwareAlerts/STE_PR_10_4_0.exe.

4. Right-click the STE_PR_10_4_0.exe file and select Run as administrator.

5. Follow the instructions to update the software.

 Update Payroll to the Latest Version

Once the server is updated, the next time you start Sage Timberline Enterprise 
Payroll at each workstation, you are prompted to install the update. Follow the 
prompts to complete the update.

Install Estimating on Workstations

If you use Estimating, install it on your workstations by following the instructions 
in the installation guide that accompanies the Estimating software.

NOTE:  If you plan to install both Estimating and Payroll, see “If you Also Use Estimating” 
on page 126.

Test Your Software Installation

Complete these steps at a workstation to verify your installations.

1. Select Start > All Programs > Sage > Sage Timberline Enterprise.

2. In the the Logon screen, enter your Windows password.

3. Select the Server and Database to which you want to connect.

4. Click OK. Sage Timberline Enterprise should open successfully.

http://cdn.updates.timberline.com/SoftwareAlerts/STE_PR_10_4_0.exe
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System Maintenance

Once you have installed Sage Timberline Enterprise and begun using it for daily 
business, you will have an ongoing need to complete certain system administration 
and maintenance tasks. Some of these tasks, such as backing up your data, should 
happen at regularly scheduled times. Others will happen as needed, based on events 
such as upgrades, employee turnover, and hardware replacement. 

The remainder of this guide provides information about system maintenance tasks.

Task Information

❑ Back up your databases on a regular basis. page 135

❑ Move the Sage Timberline Enterprise installation to a different server. page 145

❑ Download and install software updates. page 153
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Back Up Your Data

Backing up your data regularly is a critical component of disaster-recovery 
planning. You can lose data because of power outages, hardware failures, natural 
disasters, malicious acts, and many other causes. How much business information 
can you afford to lose? One day? One week? Your backup plan should take this into 
account and mitigate your risk of losing more than your specified tolerance.

Work with your certified consultant and information technology professionals to 
implement a backup schedule that protects you from catastrophic loss. Consider 
each of these factors:

 Types of backups

 Frequency of backups

 Storage location for backup media

 Testing and recovery

For information about which files to include in a backup of Sage Timberline 
Enterprise, see “Locations to Include in a Backup” on page 138.

About SQL Server Databases

Data and Transaction Log Files

Each SQL Server database has at least two disk files associated with it: a data file 
and a transaction log file.

 The data (.mdf) file contains the actual data tables and related information. 

 The transaction log (.ldf) file contains all transactions and database 
modifications made by each transaction since the last full backup of the 
database. The transaction log contains data that has not necessarily been 
committed to the data files yet. 

Together, the data file and the transaction log file constitute the current state of the 
database. In the event of a system failure, both of these files are needed to restore 
the database back to its state before the failure. For example, if you have a backup 
of the data (.mdf) file but not the transaction log (.ldf) file, you can restore the 
database to the last point at which data was committed, but you will lose any 
transactions that were not yet committed at the time of the failure.

FOR MORE INFORMATION:  Consult SQL Server’s online Help for more information about 
transaction log file maintenance.
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Database Recovery Model

SQL Server database properties include an option called the Recovery Model, 
which can be set to Full or Simple. This choice affects the type of backups you can 
perform and how the transaction log files are administered by SQL Server.

The Full recovery model, combined with frequent full backups (not differential 
backups), is the safest option for protecting against data loss. Typically, the 
recovery model is set to Full when you create a database in Sage System 
Administration. We recommend that you verify that all Sage Timberline Enterprise 
production databases are set to the Full recovery model, and that you perform 
backups according to the instructions on page 139 at regular intervals.

WARNING:  If the recovery model is set to Full but you do not back up the transaction log 
file as a separate step, the log file continues to grow indefinitely instead of being truncated. 
This can cause performance and disk space issues as well as putting your data at risk. 

If the recovery model is set to Simple, you can back up only the data file—not the 
transaction log file. Under this model the transaction log is cleared frequently to keep the 
database size small. This means that any changes made to the database since the last 
backup are unprotected. 

NOTE:  If you have not backed up your transaction log files as a separate step along with 
data backups, your log file may be very large. Backing up your transaction log file frequently 
will allow the log file to truncate properly but will not shrink the physical size of the file. 
Consult SQL Server’s online Help for instructions on log truncation and shrinking the 
transaction log. 

Summary of Backup Recommendations

We recommend that you leave the recovery model set to Full on your Sage 
Timberline Enterprise database, and that you create regular full and transaction log 
backups of your databases. Consult SQL Server’s online Help for more information 
on backing up and restoring databases in SQL Server.

If you use Payroll, we recommend that you create regular full backups of the 
Pervasive database as well. We do not support restoring a Payroll database from 
differential or incremental backups.

Backup Scheduling and Frequency

We recommend that you implement a backup maintenance plan to automate 
backups and regular intervals. Consult SQL Server’s online Help for more 
information.

When you back up or restore a database, all users must exit Sage Timberline 
Enterprise and any other application that accesses the data (such as Crystal Reports 
or System Administration). If users are processing tasks while you back up the 
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database, data integrity is compromised because changes may or may not have been 
committed to the database.

In addition to regularly scheduled backups, perform backups immediately 
following significant events such as month-end or year-end processing, software 
upgrades, or server migrations.

If you Use the Optional Payroll Module

Sage Timberline Enterprise Payroll stores data in Pervasive databases rather than 
SQL Server databases. Pervasive does not give you the option of restoring 
databases to a certain point in time; you can restore only to the date and time of the 
last full backup. If you need to restore both types of databases, you must restore 
them to the same point in time, even if you have a backup of the SQL transaction 
log file from a later time. 

Storage Locations for Backup Media

Store backups on different physical media than their original location.  If you lose 
data because of disk failure, a backup stored on the same disk will not be any more 
accessible than the original data.

Periodically, media containing a full backup should be transferred to a separate, 
secure physical location such as a safety deposit box or a secure data storage and 
management company. Media stored on-site can be restored in the case of hardware 
failure—but in the case of a natural disaster, you might have to retrieve off-site 
media. Many companies store periodic full backups in a different geographic region 
to protect from regional disasters. 

Testing and Recovery

Every viable backup plan must include restoring full backups to a test environment 
on a regular basis. Until you have tested a particular backup set, you don’t know for 
certain that the files were not corrupted, lost, skipped, or otherwise rendered 
unusable. If any of these conditions exist, you might as well not have a backup at 
all. An inaccessible or unusable backup does not protect your business the way it’s 
supposed to.

As part of your regular backup schedule, restore backups to a testing environment 
and run data checks such as inquiries or reports. If your restored data does not meet 
your standards, you need to find the cause of the problem, fix it, and run another 
backup before your disaster-recovery plan can be considered effective.

If you use the optional Payroll module, as part of your testing and recovery plan 
verify that you can restore both databases to a satisfactory point in time. Pervasive 
does not allow you to select a later restore point for the Payroll databases.
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Locations to Include in a Backup

In addition to your database files, several other folder locations contain files that 
you will need in the event that you must restore a system from backup. Note the 
following:

 Most of your Sage Timberline Enterprise data is stored in SQL Server data and 
transaction log files. These are usually the .mdf and .ldf files in the default SQL 
data location, but could include other files depending upon your 
implementation. You can use SQL Server’s backup tools to back up these files. 
Consult the instructions starting on page 139.

 The SAAConfiguration database should be backed up along with your other 
Sage Timberline Enterprise data. This is a SQL Server database that the system 
uses to store changes to system administrators or company database 
configurations. Use SQL Server’s backup tools to back up this database along 
with the others.

 Each Sage Timberline Enterprise database has associated Attachments and 
Spool folders. These folders are not included in backups created by SQL 
Server’s backup tools. Plan to archive them separately at the same time you 
back up your SQL database files. To locate these folders for each database, in 
System Administration, select the database and click Database Properties.

 If you have the optional Payroll module, the payroll data is stored in a Pervasive 
database. Back up your Pervasive and SQL Server databases at the same time 
to keep them synchronized. Note that Pervasive does not offer the log file 
functionality that allows you to restore to a certain point in time. In the event 
that you need to restore both databases, you must restore them to the same date 
and time (governed by the time of the Pervasive backup) for data consistency.

 The Sage program data folder, which contains additional Sage Timberline 
Enterprise information:

 In Windows Server 2003: Documents and Settings\All Users
\Application Data\Sage. 

 In Windows Server 2008: ProgramData\Sage
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Back up SQL Server Databases

The steps below outline a procedure for backing up your SQL Server databases.  
Modify these steps as needed based on your company’s internal requirements and 
system configuration. Consult SQL Server’s online Help for more in-depth 
information on backing up and restoring databases in SQL Server.

Complete a Full Backup of the Database

1. When the scheduled backup time arrives, ensure that all users are disconnected 
from Sage Timberline Enterprise. 

a. In Sage System Administration, go to License Administration and click 
the Active Users tab to see the list of active users. Ask each of the users 
listed on this tab to log out of the software.

b. Click Restrict Logon. (This prevents new connections to any 
Sage Timberline Enterprise database, but it does not close existing 
connections.)

2. Start SQL Server Management Studio (Start > Programs > Microsoft 
SQL Server > SQL Server Management Studio) and connect to the server 
that hosts the database you want to back up. 

3. Expand Databases under the SQL Server instance.

4. Right-click the database and select Tasks > Back Up.
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In the Back Up Database window, notice that a default .bak file name and 
destination is provided. The system recognizes.bak files as SQL Server backup 
files.)

If the .bak file indicated already exists, the new backup will be appended to it—
as opposed to overwriting it. The resulting .bak file will contain multiple backup 
sets, each of which is a full backup. This causes the .bak file to grow quite large, 
which can in turn lead to data corruption or lengthy restore times. For this 
reason, we recommend that you place each backup in its own .bak file.

5. In the Back Up window, click Remove to remove the default entry.

NOTE:  Clicking Remove does not delete the existing .bak file from disk—it simply removes 
the location from the destination of the backup.

6. Click Add to specify a new file name and location. In the Select Backup 
Destination window, you must indicate a local destination rather than a 
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network location. Click the browse button and select a location and name. 
Include the .bak extension when you type the name. 

7. Click OK, and then click OK again to begin the back up process. 

The completed backup contains both the data file and the transaction log file. 
However, the log file is not truncated during a full backup, which means that it 
will continue to grow. Next you’ll back up the transaction log file, which allows 
SQL Server to truncate it.
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 Back Up the Transaction Log File

WARNING:  This procedures shows you how to back up the transaction log file, but it does 
not guarantee the integrity of the chain of log backups. If you lose a transaction log backup, 
or if the chain of log backups is broken, you might not be able to restore the database past 
the preceding backup. Consult SQL Server’s online Help for further cautions and 
recommendations regarding transaction log file backups.

1. Right-click the database and select Tasks > Back Up.

2. In the Back Up Database window, next to Backup type, select Transaction 
log.

3. Under Destination, click Remove to remove the default entry. Click Add and 
enter the name and location for the transaction log file backup. Include .trn as 
the file extension (the typical extension for transaction log file backups).

4. Repeat this process for all databases that you need to back up, including the 
SAAConfiguration database.

5. In System Administration, click Allow logon when you are finished to allow 
users back in to the software.
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Back up Pervasive Databases

Backup up Pervasive databases using File Tools, a utility included with Payroll. 

1. In Payroll, select Tools > File Tools. 

2. Select Backup, and then click Next.

3. Click Add Folder and select your company data folder.

4. Click OK, and then click Next.

5. Next to Destination, click Browse to select the location to save the backup file. 
In the Archive Name box, enter a name for the file.

6. Click Next to start the process, and continue clicking Next to complete the 
wizard.

7. When the process is complete, click Finish. 
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Move Sage Timberline Enterprise to a New 
Server

You might decide to move your Sage Timberline Enterprise installation to a 
different server in order to take advantage of newer hardware or system resources. 
With planning, you can complete this transition smoothly. Review the tasks in this 
checklist before you begin a server migration.

Prepare the New Server for the Migration

Complete the following preparation tasks on the new server, referring to the pages 
listed for more information.

1. Review the system specifications for Sage Timberline Enterprise and verify that 
your new server meets the minimum requirements (page 7).

2. Verify that your new server is part of a Windows domain, and add it if necessary 
(page 15). If you are moving Sage Timberline Enterprise to a different 
Windows domain, add all users to Active Directory for the new domain.

3. Configure the new server’s firewall as needed (page 15).

4. If you are also moving the Microsoft SQL Server 2008 installation, determine 
the new location for your database, spools, and attachments folders (page 17).

5. Install SQL Server on the new server and configure it to work with Sage 
Timberline Enterprise (page 24). 

Task Information

❑ Prepare the new server for the migration page 145

❑ Back up your data page 135

❑ Schedule the migration page 146

❑ Develop a complete migration plan page 146

❑ Disconnect all users page 147

❑ Move your databases to the new location page 147

❑ Deactivate your Sage Timberline Enterprise licenses on the old 
server

page 150

❑ Install remaining software on the new server page 150

❑ Configure users on the new database if necessary page 151

❑ Verify that your users and workstations can connect to the new 
server

page 151
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Schedule the Migration

The migration process requires that all users be disconnected from the 
Sage Timberline Enterprise database you are moving. Schedule a time when this 
will be least disruptive to your business, such as an evening or weekend. The time 
required will vary according to the size of your databases and the speed of your 
network.

If your SQL Server instance also contains other databases, you can select a 
migration method that allows the other databases to remain in use during the 
migration. This is true whether the other databases are associated with 
Sage Timberline Enterprise or another application. The available methods are 
outlined below.

If you have more than one database associated with Sage Timberline Enterprise, 
consider whether you will migrate all databases during the same scheduled time 
frame (requiring all users to close Sage Timberline Enterprise), or you will migrate 
databases at different scheduled times to allow some databases to remain active.

Develop a Complete Migration Plan

The instructions in this section do not account for the following items. Work with 
your certified consultant to develop a complete migration plan that addresses all of 
your customizations and configurations.

 Custom reports you may have developed for Sage Timberline Enterprise. Copy 
these reports to the same location on the new server. The default location for 
reports is as follows.

 In Windows 2003 Server: Documents and Settings\All Users\
Application Data\Sage\Sage Timberline Enterprise\Reports.

 In Windows 2008 Server: ProgramData\Sage\Sage Timberline 
Enterprise\Reports.

If your custom reports are not in the default location on the existing server and 
you need to locate them, open System Administration and go to Database 
Administration. Click the database, and click the Features tab. Right-click a 
custom report and select Edit Custom Report. (Note that you can change the 
reports location on the new server by editing this entry if the report path 
changes.)

 Custom formats for checks, lien waivers, and so on.

 Payroll customizations, including custom fields and custom formulas, Payroll 
tax files (if stored in the Misc folder), custom reports, security, and inquiries. 
You may have other customizations as well. 
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Disconnect all Users

When the scheduled migration time arrives, ensure that all users are disconnected 
from Sage Timberline Enterprise.

1. In Sage System Administration, go to License Administration and click the 
Active Users tab to see the list of active users. Ask each of the users listed on 
this tab to log out of the software.

2. Click Restrict Logon. (This prevents new connections to any 
Sage Timberline Enterprise database, but it does not close existing 
connections.)

Move Your Databases to the New Server

If you plan to move your installation of Microsoft SQL Server to a new server (as 
well as the Sage Timberline Enterprise installation), you must move your databases 
to the new database server. 

WARNING:  Do not attempt to move the SAAConfiguration database to a new server. This 
database stores specific server names and file locations, which will be invalid if you move 
the existing database. Running the Configuration Wizard (as described on page 150, 
step 5) ensures that the configuration database is correct.

Verify that you have a reliable backup of your databases, and that all users are 
logged out of the database. Then, use one of the following methods to move the 
databases. (Instructions for each of these start on the next page.)

 Back up and restore the databases. Backup files are smaller than the original 
files, so this method may result in less time needed to copy the database to the 
new location. 

 Detach and move the databases. This method allows all SQL Server databases 
on the server to remain in use, except for the database you are moving. The files 
are not compressed in this option, so moving the data may require more time.

 Stop the SQL Server services and copy the databases. This method prevents 
users from accessing any database on the SQL Server instance that hosts 
Sage Timberline Enterprise. If you have other databases that use the same SQL 
Server instance and you need them to remain available, select one of the other 
options.

 If you use the optional Payroll module, move your Payroll databases as well 
using File Tools.

To Back Up and Restore the Database

1. At your current server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).
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2. Expand Databases. Right-click a Sage Timberline Enterprise database and 
select Tasks > Back Up. Specify the Backup type as Full, and enter the 
location to store the backup. This process creates a .bak file in the location you 
specified. (See page 140 for more information about entering the backup file 
name.)

3. At the new server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

4. Right-click Databases and select Restore Database. Select the .bak file from 
step 2.

To Detach and Move the Database

1. At your current server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

2. Expand Databases. Right-click a Sage Timberline Enterprise database and 
select Tasks > Detach.

3. In the Detach Database window, select Drop Connections and click OK. 
(Selecting Drop Connections causes Sage Timberline Enterprise to close 
automatically on all workstations. All users should be logged out of the software 
before you do this.)

4. In Windows Explorer, browse to the database (.mdf and .ldf) files. Copy them 
to the new default data location.  (See “Determine the Location of Data and 
Shared Folders” on page 17 for help determining this location.)

5. At the new server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

6. Right-click Databases and select Attach. Click Add, and add the database.

To Stop SQL Server Services and Copy the Database

1. At your current server, open SQL Server Configuration Manager (Start > 
Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL 
Server Configuration Manager.)

2. Click SQL Server Services.

3. Right-click each of the services listed and select Stop. (This closes all 
connections to Sage Timberline Enterprise automatically. All users should be 
logged out.)
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4. In Windows Explorer, browse to the database (.mdf and .ldf) files. Copy them 
to the new default data location.  (See “Determine the Location of Data and 
Shared Folders” on page 17 for help determining this location.)

5. At the new server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

6. Right-click Databases and select Attach. Click Add, and add the database.

To Move Payroll Databases

WARNING:  If you have custom reports, formulas, security setup, or tax import files in 
Payroll, work with your certified consultant to move all of these items along with the 
databases. This procedure does not include moving these items.

1. Open Payroll (Start > All Programs > Sage > Sage Timberline Enterprise 
Payroll).

2. Select Tools > File Tools and select Backup.

3. Click Next and click Add Folder. Select the folder.

4. Click Next and specify the destination for the archive. You’ll restore from this 
location on the new server.

5. Complete the steps as instructed in the wizard.



Move Sage Timberline Enterprise to a New Server Sage Timberline Enterprise

150 © 2012 Sage Software, Inc.

Deactivate Licenses on the Current Server

Before you can move Sage Timberline Enterprise to a new server, you must first 
deactivate the licenses on the existing server. If you are unable to access the original 
server due to a hardware failure, you must contact Sage customer support to have 
your server licenses deactivated.

1. Log on to the existing Sage Timberline Enterprise server using the Sage system 
administrator account.

2. Start Sage System Administration (Start > All Programs > Sage > Sage 
System Administration).

3. Select License Administration.

4. Click Restrict logon to prevent new users from logging on. This does not 
remove active users. If any users are currently active, ask them to close 
Sage Timberline Enterprise. When all users have logged off, continue with this 
procedure.

5. On the License information tab, click Deauthorize license server. You will 
receive a message that the server is no longer authorized. 

6. Click OK. 

Install Remaining Software on the New Server

Complete the remaining installation tasks on the new server, referring to the pages 
listed for more information.

1. Install and configure Microsoft Internet Information Services on the server that 
will hold Sage Timberline Enterprise (page 61).

2. Install Sage Timberline Enterprise on the new server (page 65).

3. Install Payroll (optional, page 73). If you have custom reports, formulas, 
security setup, or tax import files in Payroll, work with your certified consultant 
to move your installation from the existing server rather than installing Payroll 
from scratch.

4. Install Estimating and License Manager (optional, page 80).

5. Run the Sage System Administration Configuration Wizard (page 82).

6. Activate Your Sage Timberline Enterprise Licenses (page 89).

7. Add system administrators to the new server (page 91).
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Add the Databases and Configure Users in Sage System 
Administration

1. At the new server, open Sage System Administration.

2. Click Database Administration. 

3. For each of the databases that you moved, click Create New Database and set 
them up as follows:

 Enter the Display name.

 Enter the location of the new Attachments and Spool folders.

 For the Server, type the name of the new server.

 Next to Database name, select the database that you are adding from the 
list.

4. Click OK. 

5. If you use the optional Payroll module, open Payroll. To restore the databases 
that you backed up on page 149:

a. Select Tools > File Tools.

b. Select Restore, and restore the database.

c. Select File > Open Company and open the database. Map it to the correct 
accounting database.

6. If your new Sage Timberline Enterprise installation is on a different Windows 
domain than previously:

a. Verify that all users who will access Sage Timberline Enterprise have been 
added to Active Directory for the new domain.

b. Click the first user to select it. Click Add user, and add the corresponding 
user from the new domain.  Reassign this user to the necessary roles.

c. Click the original user, and click Remove user. Only the new user should 
remain.

d. Complete this procedure for each user associated with the database.

Test the New Installation 

To verify that the server migration was successful, follow this procedure.

1. At each workstation, select Start > All Programs > Sage > Sage Timberline 
Enterprise.

2. In the the Logon screen, enter your Windows password.
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3. Verify that the new server and database are listed.

4. Click OK. Sage Timberline Enterprise should open successfully.
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Check for Software Updates

Periodically, Sage releases software updates that include items such as new features 
or updated Payroll tax files. You can download these updates automatically or 
manually from System Adminsitration, and can choose when you want to install 
them to your server. Once you install an update on the server, you can install it on 
the workstations.

NOTE:  You must complete this procedure at the server, and you must be logged on to 
Windows as a Sage Timberline Enterprise administrator. Although System Administration 
is installed on workstations, the Update Administration options are available only on the 
server.

Download and Install an Update

1. Back up your databases and other important files before you install an update. 
(See “Back Up Your Data.”)

2. Open System Administration (Start > All Programs > Sage > 
Sage System Administration).

3. Make sure that no workstations are connected to Sage Timberline Enterprise. 
You can see active users in System Administration by clicking License 
Administration and then clicking the Active Users tab. 

4. Click Restrict Logon to prevent any further connections.
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5. Click Update Administration. The appearance of the next window differs 
according to whether automatic downloads are enabled. (By default, automatic 
updates are enabled. Instructions to change this setting are on page 160, 
step 14.)

NOTE:  Update Administration requires the service Sage Timberline Enterprise Installation 
Manager. If you do not see updates after checking for them, verify that this service is started 
by opening Computer Management (right-click My Computer and select Manage) and go 
to Services and Applications > Services. The status of the service should be Started.

 If automatic updates are enabled and updates are present, they are listed in 
this window. The top right button says Install Server and the status of the 
update is Ready to install server update.

 If automatic updates are enabled but no updates are listed in the window, 
you can click Check to check for updates and download any that are found.
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 If automatic updates are disabled, click Check to check for updates. 
Updates will be listed, but not downloaded. 

The top right button says Download, and the status of the update is Ready 
to download. Click Download to obtain the update.
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6. Once an update is downloaded, click the Details button to see the details of an 
update. 

From this window, you can click Update Folder to browse to the location of 
your updates.

7. Click OK to close the Details window.

8. Once updates are downloaded, select an update to install, and then click 
Install Server.

9. Click Yes to confirm that you want to install the update. 

The installation takes a couple of moments, and you may see other confirmation 
messages while it runs. The process closes System Administration. It also stops 
several services and restarts them.

10. When the update is finished, open System Administration again (Start > 
All Programs > Sage > Sage System Administration).
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11. Expand the folder and click Update Administration. Notice that the status for 
the update you installed is Update Complete.

NOTE:  All computers (servers and workstations) must have the same version of Sage 
Timberline Enterprise. When each workstation next connects to the server, a message is 
displayed indicating that the workstation needs to be updated. You can update the 
workstation at that time. You will not be able to use Sage Timberline Enterprise at a given 
workstation until the update is installed.

Configure Automatic Software Updates and Notification

You can configure System Administration to notify you automatically whenever an 
update to Sage Timberline Enterprise is available.

1. Open the System Administration (Start > All Programs > Sage > 
Sage System Administration).

2. Click Update Administration.
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3. Click the Settings tab, and then click the Email Notifications subtab. 

4. Click Add.

5. Add the email address and select the type of emails you want to receive.

6. Click Add. The new email address appears under Subscribers.

7. To test an email address, under Settings, click Email.

8. Supply a valid email address, user name, and password. 
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9. Enter the information about your email server.

10. Click Send Test Email. A test email is sent to the account listed next to 
Email address.

11. Click the Frequency subtab. This tab lets you indicate how often the 
Installation Manager should check for new updates.
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12. Click Settings to specify the frequency. The default setting is Every 7 days.

13. Click OK, and then click the Downloads subtab. This tab lets you enable or 
disable automatic downloads.

14. Click Settings to change the download setting. The default setting is to 
automatically download updates.
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View Update History

1. Open the System Administration (Start > All Programs > Sage > 
Sage System Administration).

2. Click Update Administration, and then click the History tab. The page shows 
information about updates that have been downloaded or installed.
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Further Assistance

If you need further assistance with Sage Timberline Enterprise, these additional 
resources are available to you.

Additional documentation

The Sage Timberline Enterprise release notes provide additional information 
about the current release, including release features and any known issues. The 
latest copy of the release notes is available on the Sage Customer Portal.

If any important issues were found immediately prior to release that were not 
included in any of the release documentation, they will be described in an 
Important Document that is included in your installation materials. 

Support Knowledgebase

Access the Sage Knowledgebase 24 hours a day, 7 days a week, for answers to your 
questions about Sage Timberline Enterprise. It is available on the 
Sage Customer Portal.

Online Help

Each Sage Timberline Enterprise module includes online help, which provides 
answers to many of your questions. To use help, from the 
Sage Timberline Enterprise Desktop, select Help, and then choose the module for 
which you want further assistance. 

More often, you will want to access the help links in the various 
Sage Timberline Enterprise windows. Press F1 at any point to display the help 
topics for that window.

Each help project includes a full table of contents that describes the features and 
functions of the module. The help also includes index and search capability so you 
can find the information you need. For more information on using the help system, 
see Sage Timberline Enterprise Desktop help (in the Desktop, select Help > Sage 
Timberline Enterprise Desktop Help). 

Each help topic displays a help feedback section, where you are invited to tell us 
whether the topic was helpful, and to provide additional comments to assist us in 
improving our help system. 

https://customers.sagenorthamerica.com
https://customers.sagenorthamerica.com
https://customers.sagenorthamerica.com
https://customers.sagenorthamerica.com
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Enroll in Training Classes

Sage University offers online training sessions to help you get the most out of your 
Sage Timberline Enterprise software. To access Sage University, from the 
Sage Timberline Enterprise Desktop, select Help > Sage Timberline Enterprise 
on the Web > Sage Software University or visit www.sageu.com.

Contact Customer Support

If you would like assistance with a solution and your service plan provides online 
customer support:

1. Log on to the Sage Customer Portal. 

2. Click Support > Self Service. 

3. On the My Requests tab under Create, click Customer Support Ticket. 

4. Complete the form to submit a support ticket directly to Customer Support.

Telephone Support

If you prefer to speak to customer support and your service plan provides telephone 
assistance, call 866-991-5606. Telephone support is available Monday through 
Friday from 6 a.m. to 5 p.m. Pacific Time with the following exceptions:

 Every Thursday from 2 p.m. to 3 p.m. Pacific Time, closed for customer support 
staff meetings.

 Standard United States holidays.

 Quarterly company meetings.

Upgrade Your Service Plan

If your service plan does not provide online or telephone customer support and you 
would like to add or upgrade a service plan:

1. Call 800-858-7098, or log on to the Sage Customer Portal.

2. Select Anonymous Portal Access on right. 

3. Click Support > Self Service. 

4. On the My Requests tab under Create, click Customer Service Request. 

5. Complete the form to submit a service request.

http://sageu.com/
https://customers.sagenorthamerica.com/irj/portal/anonymous/login
https://customers.sagenorthamerica.com/irj/portal/anonymous/login
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Submit Enhancement Requests

We want to hear your suggestions for improving the software. To send us your 
comments, select Help > Sage Timberline Enterprise on the Web >Submit 
Enhancement Request.
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