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Chapter 1: Introduction
Integration Between Estimating and Sage 100
Contractor Overview
The estimating integrationmodule allows you tomove Sage 100 Contractor Estimating
Standard and Extended data to your Sage 100 Contractor accounting applications. You can
create proposals, budgets, and change orders from estimate data using the Estimating
application. In addition, you can create subcontracts and proposals using the Buyout
application. Sage 100 Contractor jobs, cost codes, cost types, and vendors will all be
imported into your Estimating system and be available to you when creating estimates. The
Sage 100 Contractor Application Program Interface (API) is used as the bridge to facilitate
the flow of data between the two systems.The API is installed automatically with your Sage
100 Contractor software.

Figure 1: Sage 100 Contractor and Sage 100 Contractor Estimating

This document is your guide for setting up both systems to share data. In it you will learn
how to:

n Install Estimating.

- 1 -



Sage 100 Contractor Estimating Installation and Integration Guide

n Set up the Sage 100 Contractor, the Sage 100 Contractor API, Estimating, and Buyout to
share data.

n Create Sage 100 Contractor proposals, budgets, change orders, purchase orders, and
subcontracts using a simple wizard in Estimating and Buyout.

NOTES:

l Youwill notice references to Sage Timberline Office Estimating throughout the
software, product and support documentation. This is due to the fact that the core
functionality of the Sage 100 Contractor Estimating products was derived from the
Sage Timberline Office Estimating applications.

l The term “Estimating” used throughout this book refers to Sage 100 Contractor
Estimating Extended and Standard unless otherwise noted.

Documentation
This guide describes how to integrate Sage 100 Contractor versions 18.3 and 19.2 with Sage
Estimating (Pervasive) versions 13.1.

Be sure to read the following supporting documentation before you install Estimating:

n EstimatingRelease Notes provide details about new features, database changes, known
issues, and fixes. This document is available on your DVD in theDocuments folder.
Release Notes for earlier releases are available on your DVD in the Documents\Archives
folder. These documents are current at the time of the release.

n The Estimating Installation Guide provides detailed information about system and
environment considerations to ensure your network is ready to install Estimating. You will
also find what you need to prepare before you install. This document is available in the
Documents folder on your Estimating DVD.

n For information specific to your Sage 100 Contractor software, refer to your Sage 100
Contractor Installation & License Administration Guide (available on the documentation
CD) and the Sage 100 Contractor Help found in the software.

n Getting Started with Estimating provides information on setting up a database, creating an
estimate, performing takeoff, and working with spreadsheets. This guide is available as a
.pdf file in theDocuments folder of your Estimating DVD.
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n Getting Started with Buyout provides information on setting up a database, creating an
estimate, performing takeoff, and working with spreadsheets. This guide is available as a
.pdf file in theDocuments folder of your Estimating DVD.

Online Help
Each Sage 100 Contractor Estimating Extended or Standard application includes Help,
which provides many answers and instructions at the click of your mouse. To use Help,
select Help Topics from theHelpmenu. An important feature of the Help system is What’s
This? Help. For detailed information about each field in an application, press F1 or click the
questionmark that appears on the toolbar or in the title bar of each window. Position the
questionmark over the area in question, and click.

Training Information
Learn about the Anytime Learning and Realtime Learning sessions that are available, view
schedules of online sessions, or look for classroom training near you.

You can directly access Sage University from the Helpmenu in applications (Help >Sage
Timberline Office on the Web >Sage University). This website offers a variety of
professional product training options.

Contact Customer Support
Depending on your Sage Service Plan, youmay be able to take advantage of the following
services:

Sage Customer Portal
Youmay log on to the Sage Customer Portal at
https://customers.sagenorthamerica.com/irj/portal/anonymous/login to access any of the
following services:

n Knowledgebase: Find answers to your questions, access downloads, and subscribe to
your favorite articles. This service is available online 24/7.

n Live Chat:Chat online with a customer support analyst - a great option for quick
questions. Chat hours areMonday through Friday from 6 a.m. to 3 p.m. Pacific time, with
the same exceptions as telephone support (see below).
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n Online Support Request: Submit an online support ticket when you have a non-urgent
question. One of our call center support analysts will assist you. Online support hours are
the same as our customer support call center hours (see below).

Sage Customer Support Call Center
Telephone Support:When you have amore urgent question or would prefer to speak to a
customer support analyst directly, call us at 800-551-8307. Telephone support is available
Monday through Friday from 6 a.m. to 5 p.m. Pacific time with the following exceptions:

n Every Thursday from 2 p.m. to 3 p.m. Pacific time (closed for customer support staff
meetings)

n Standard United States holidays

n Quarterly company meetings

Upgrading Your Service Plan
If your service plan does not provide online or telephone customer support and you would
like to add or upgrade a service plan, please call 800-858-7098.
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Products
Sage 100 Contractor and Estimating
In order for the integration to be successful, youmust install Sage 100 Contractor and Sage
100 Contractor Estimating Standard or Extended on the same computer.

Refer to the Sage 100 Contractor Installation and License Administration Guide for
supported operating systems and instructions on installing Sage 100 Contractor.

Refer to the Sage Timberline Office Installation Guide for supported operating systems and
instructions on installing Sage 100 Contractor Estimating.

Compatibility
Sage Estimating version 13.1 is compatible with Sage 100 Contractor versions 18.3 and
19.2.
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Overview
After installing Estimating and Sage 100 Contractor on the same computer, youmust
perform a few setup steps which will allow data to be sent between the twomodules. As
described earlier, the API (Application Program Interface) is the bridge between Estimating
and Sage 100 Contractor. Before you set up Estimating to interface with Sage 100
Contractor, you need tomodify the Sage 100 Contractor security settings to work properly
with the API. Also, you need to ensure that the API is properly configured to create and
modify data in Sage 100 Contractor. When you have completed these steps, set your
Estimating database to interface with a Sage 100 Contractor company. After the connection
to the company has been established, the following occurs:

n Sage 100 Contractor Estimating imports cost codes, cost types, and job numbers,
making them available in both Estimating and Buyout.

n Sage 100 Contractor Estimating imports vendors into the Sage Timberline Office Address
Book as Company contacts.

Figure 2: Bridging Sage 100 Contractor and Estimating
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NOTES:

l The term “Estimating” used throughout this guide refers to Sage 100 Contractor
Estimating Standard and Extended unless otherwise noted.

l This section assumes you are familiar with Sage 100 Contractor Estimating
Standard or Extended. Please refer to theGetting Started with Estimating and
Getting Started with Buyout guides found in theDocuments folder of your
Estimating DVD. Contact your business partner for information about training.

In this section you will set up your Estimating and Sage 100 Contractor systems to integrate
with each other by performing the following steps:

1 Configure the Sage 100 Contractor Company Security to include the API security group
and include any users into this group.

2 Create a new Address Book for the Sage 100 Contractor vendors and link to it from your
Estimating database.

3 Configure your Estimating database to interface with Sage 100 Contractor.

4 Apply Sage 100 Contractor cost codes and cost types to the database Items in
Estimating.

5 Configure and setup the Buyout application to interface with Sage 100 Contractor.

Before you Begin:
n Sage 100 Contractor, Sage 100 Contractor application programming interface (API), and
Estimatingmust be installed on the same computer.

n Sage recommends that you back up your data.

n Become familiar with the differences in terminology found in the two programs.
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Sage 100 Contractor and Estimating terminology
Table 1: Comparison of Sage 100 Contractor and Estimating Terminology

Sage 100 Contractor Estimating

Cost Code Job Cost Phase

Cost Type Job Cost Category

Phase Sort Level

A sort level can be any of the following:

n Work Breakdown Structure Codes

n Location

n Group Phase

n Phase

n Assembly

n Model

n Material Class

n Subcontractor

n Price Code

Bid Item

A. Set Up the Sage 100 Contractor Company
Security to Work With the API
In order for the integration between Estimating and Sage 100 Contractor to work, an API
security group needs to be created. Any user intending to use the integration needs to have
the API group assigned to their profile.
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Create the API Security Group
The API security group is created under Company Security in Sage 100 Contractor. Any
company intending to have data created from Estimating will be required to create the API
security group.

1 Start Sage 100 Contractor and select the company you intend to integrate with.

2 Log in using theSupervisor account.

3 Open 7-3-1 Security Groups.

4 In theGroup# cell, type a group number, such as 51.

5 In theGroup Name cell, typeAPI.

6 In theSave cell, typeY.

7 In theDelete cell, typeY.

8 To store information that may be relevant or important to that specific group, type a note in
theNotes cell.

9 On the Filemenu, click Save.

Setting up an API User And Password
Youmust be amember of the API security group if you will use the integration between
Estimating and Sage 100 Contractor. Security groups are assigned underCompany
Security in Sage 100 Contractor.

NOTES:

l Only the Supervisor can access andmodify user security settings.

l Youmust be set up as a user on at least one other security group in order to be a
member of the API security group.

For Existing Users
1 Open 7-3-2 User List.

2 In the next availableGroup cell, click once in the cell, and from the drop-down list, select
the API group for the user(s) who will be using the integration.

- 9 -



Chapter 3: Integration Setup

- 10 -

Creating New Users
1 Open 7-3-2 User List.

2 Select theDisplay Passwords check box.

3 In theUser Name cell, enter a user name, such as APIUser.

4 In thePassword cell, enter a password.

5 In each numberedGroup cell, click once in the cell, and from the drop-down list, select
the API group.

6 Repeat step 6 for each new API user.

7 Click File >Save.

B Setting Up the Address Book
Address Book is an application that stores a company-wide database of contacts that can
be shared by applications such as Estimating and Buyout. You can open Address Book
everywhere you need to access contact information for subcontractors, vendors, and
customers in Estimating and Buyout.

The Address Book is used to store and access all of your Sage 100 Contractor Vendors from
Estimating and Buyout. When you specify a Sage 100 Contractor Company to interface
with, all of the vendors will be imported into your newly created Address Book and be
available to you.

Before you connect to a Sage 100 Contractor Company, you will need to first create an
Address Book to store your vendor information, and second, link it to your Estimating
database.

Create a New Address Book
Creating a new Address Book requires that you create a new Company Folder from an
application called TSMain. In this instance the Address Book and Company Folder are
synonymous - when you create a new Company Folder, you are creating a new Address
Book.

1 Open TS Main. Start >Programs >Sage >Sage Timberline Office >Estimating
>TS Main.
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2 On theSelect Data Folderwindow, click [Specify Folders].

3 Under theData Folder Path, enter or browse to the location where you want to store the
Address Book. This is where the new Address Book will be located and stored on your
computer. We recommend you use the same location as your Estimating database.

4 Enter pertinent information for the Address Book, verify theData Folder Path name is
correct, select theUse Current Setup checkbox, and click [OK].
TheUse Current Setup checkbox is not available for the first company you set up.

5 Youwill notice the new company now appears in theSpecified Folder list. Click [OK] on
theSpecify Data Folders Pathswindow.

6 Highlight the newly createdCompany Folder in theSelect Data Folderwindow and
click [OK].

7 TS-Main opens. You can open Address Book by clicking on the AB icon in the toolbar, or
by clickingApplications >Address Book from themenu.

Linking to the Address Book from the Estimating Database
In order to use the Address Book, youmust link the Estimating database to the Address
Book company folder. This is done from Database Settings.

1 In Estimating, click Database >Database Settings >Company tab.

2 Click [Select] in theCompany Folder area.

3 Select the company folder you created in the steps above.

For more information about using Address Book with Estimating, refer to Estimating Help.

C. Setting up the Estimating database to interface
with Sage 100 Contractor
Before you can exchange data between Estimating and Sage 100 Contractor youmust
specify Sage 100 Contractor as the job cost interface type for the Estimating database. The
job cost interface type is specified using the Sage Timberline Office Estimating Tools
program.
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Specify the Job Cost Interface Type
To specify the job cost interface type for your Estimating database:

1 Open Sage Timberline Office Estimating Tools. (Start >Programs >Sage >Sage
Timberline Office >Estimating >Estimating Tools).

2 Click Setup >Change Job Cost Information.

3 Browse to the location of your Estimating database and select the database file. The
primary file for the an Estimating database is the PEI.DAT file. To select a database,
highlight the pei.dat and click Open.

4 In theChange Job Cost Informationwindow, from the Job cost interface type list,
select Sage 100 Contractor.

5 Select Add JC cost categories to items. This assigns the cost types you just entered to
all items in your database.
Under the Job Cost Categories section, enter the Sage 100 Contractor cost types as
follows:

Table 2: Sage 100 Contractor Cost Types

Job Cost Category Cost Type

Labor 2-L

Material 1-M

Sub 4-S

Equipment 3-E

Other 5-O

After you have set the job cost interface type, you can see it listed in the database in
Estimating: Database >Database Settings >Job Cost tab.
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D. Specify a Sage 100 Contractor Company
When you have specified Sage 100 Contractor as your job cost interface type, you can then
choose a specific Sage 100 Contractor company to integrate the Estimating database with.
Along with selecting the Company you will be required to enter your user name and
password.

After you have set theCompany, User Name, andPassword correctly, Estimating will
import the cost codes, cost types, job numbers, into the database and import the vendors
into the Address Book from the API. This process may take some time depending on the
amount of data that needs to flow into your estimating system.

NOTES:

l Transferring job costing and vendor informationmay take several minutes.

Specify a Sage 100 Contractor Company, User Name, And
Password
1 Open Estimating:Database >Database Settings >Job Cost tab.

2 Verify that Sage 100 Contractor is the job cost interface type.

4 Set the Data Drive to “C,” or the drive where your company data is installed.

3 Under Sage 100 Contractor, select the company that contains your Sage 100 Contractor
accounting data.

4 In theUser Name box, type the user name you set up in “Setting up an API User And
Password,” on page 9. Your user name cannot be “Supervisor.”

5 In thePassword box, type your password for that company. Your password cannot be
“Supervisor.”

6 Click [OK] to begin the transfer of data.

Refresh Data
If youmake changes to your Sage 100 Contractor data after you have established the
connection with Estimating described in “Specify a Sage 100 Contractor Company, User
Name, And Password,” on page 13, youmust update the data in Estimating as well by
refreshing your data.
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1 Open Estimating:Database >Database Settings.

2 Click [Refresh Data].

NOTES:

l Refreshing datamay take several minutes.

F. Assigning Sage 100 Contractor Cost Codes and
Cost Types in Estimating
In order to successfully create proposals, budgets, change orders, purchase orders, and
subcontracts from Estimating to Sage 100 Contractor, youmust first assign Sage 100
Contractor cost codes and cost types to the Estimating database items. The Sage 100
Contractor cost codes and cost types will be entered in the Job Cost Phase and Job Cost
Category fields on each item. As you create estimates and takeoff the database items, the
Sage 100 Contractor cost code and cost type information will be included in the estimate and
used during the export process.

The following sections describe how to assign Sage 100 Contractor job cost data to the
items usingmultiple methods.

n Use the Database Editor application to assign cost codes and cost types tomultiple
database items in a spreadsheet format.

n Access the job cost information for an individual item in the database.

n Work with the job cost data on an estimate.

Using the Database Editor to Assign Cost Codes and Cost
Types
The Database Editor application presents the database phase and item records in a
spreadsheet grid format to allow for easy maintenance andmodification. It allows you to
quickly assign Sage 100 Contractor cost codes and cost types tomultiple items without
having to enter the values for each item.

1 OpenDatabase Editor (Start >Programs >Sage >Sage Timberline Office
>Estimating >Database Editor).

2 Locate and select the Estimating database folder. Double-click the pei.dat file to open the
database.
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Assign Cost Codes at the Phase Level
If all of the items in a particular phase are going to be using the same cost code, you can
assign the cost code to the phase and have it propagate down to the items underneath. First,
assign the cost code to the phases, then on the Items view select Inherit JC Phase for the
items. If the items are to be assigned to different cost codes, see the "Assign Cost Codes
Directly to Items" section below.

1 To access the phases, select View >Go To >Phases. Select theDefault layout from
the drop-down list on the toolbar.

2 For the selected phase, select the Sage 100 Contractor cost code from the available list or
type the cost code in the JC Phase field. If you need to assign the cost code tomore than
one phase, you can use the Fill Down feature to rapidly copy data from one cell to cells
beneath it. Type the data you want to copy into a cell. Highlight the cell and cells below it.
Right-click and select Fill Down. To select cells that are not next to each other in the
column, press CTRLwhile you use themouse to select cells.

3 Click the Items icon in the navigation bar or select View > Go To > Items to open the
Items view.

4 To propagate the cost codes from the phase record to the corresponding item records,
highlight the row header for all items, right-click and select Inherit JC Phase.

Assign Cost Codes Directly to Items
If the items within a phase have different cost codes, you can assign the cost codes directly
on the item.

1 Select View >Go To >Items.

2 Select Job Cost - All Categories from the Layout drop down list. This will show only
those columns that pertain to the job cost data. Scroll to the Job Cost Phase cell for each
category, such as Labor,Material, Equipment, etc.

3 Select the Sage 100 Contractor cost code from the list. You can rapidly copy data from
one cell to cells beneath it. Type the data you want to copy into a cell. Select the cell and
cells below it. Right-click and select Fill Down. To select cells that are not next to each
other in the column, press CTRLwhile you use themouse to select cells.
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Assign Cost Types to the Item Categories
You canmodify the cost types assigned to the items using the Database Editor. If you
chose not to add the JC cost categories to the items (step 6 under section D), you will need
to assign a cost type for each category on the items.

1 Select View >Go To >Items.

2 Select the Job Cost-All Categories layout in the toolbar.

3 Scroll over to the Labor Job Cost Category column.

4 Scroll down to the items to which the labor cost type should be assigned.

5 Click in the first white cell and select 2-L from the drop-down list.

6 Repeat steps 3, 4, and 5 forEquipment,Material, Sub, andOther. Scroll to the
appropriate Job Cost Category column and select the cost types as follows:

Table 3: Job Cost Categories and Corresponding Cost Types

Job Cost Category Cost Type

Labor 2-L

Material 1-M

Sub 4-S

Equipment 3-E

Other 5-O

Transferring Labor Hours
Both budgets and change orders require the Labor Hours in Sage 100 Contractor. To properly
send over the budget hours, the labor cost category needs to be configured to transfer the
Order Quantity.

1 Select View >Go To >Items.

2 Select the Job Cost-All Categories layout in the toolbar.

3 Scroll over to the Labor Qty to Job Cost column.
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4 Scroll down to items to which the labor cost type has been assigned.

5 Click in the first white cell and select Order Quantity from the drop-down list.

6 Close the Database Editor.

Modifying Cost Code and Cost Type data in Estimating
Cost codes, and cost types are stored and can be accessed for any item in the database on
the Job Cost tab of the item record. You canmodify the job cost information at any time for
the individual item. Access the items by clicking Database >Items. Navigate to the item
you want to work with. In order to enter or modify the job cost data, click on the Job Cost
tab.

Making Adjustments to the Estimate
If the estimate was created before you updated the database with Sage 100 Contractor cost
codes, or if you wish to add or change the cost code assignments on items in your estimate
youmust add the cost codes directly in the estimate.

NOTE: Instructions for creating an estimate are found in Getting Started with
Estimating, which you can find in theDocuments folder of your Estimating DVD.
Estimating Help contains complete instructions for working with Estimating.

After you perform takeoff for existing estimates, you canmake adjustments to the job cost
codes that are assigned to the estimate items in theDetail window. For example, youmay
want to perform the adjustments for job-specific cost codes.

1 Open an estimate, and select the item in theDescription column.

2 Right-click and select Detail window. Select theUnit Costs tab.

3 Enter the appropriate Sage 100 Contractor cost code in the Job Cost Phase box.

G. Setting up Buyout
Buyout is an application that allows you to take thematerial and subcontractor items from an
estimate, assign the items to quote sheets, create requests for quotes, select the vendor
you want to purchase from and create subcontracts or purchase orders. For more
information on Buyout functions and workflow see Buyout Help andGetting Started with
Buyout guide found in theDocuments folder of your Estimating DVD.
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Because the Buyout work file is based on estimate data, if you have set up Estimating
correctly to interface with Sage 100 Contractor, you will have very little to do in Buyout. All of
the job cost data from the items will flow into the work file. If necessary, you canmodify the
job cost data for the items in Buyout. However, you will need to set up your Buyout database
to integrate with a Sage 100 Contractor Company.

Before you can create a subcontract or a purchase order using estimate data in Buyout, you
must set the job cost interface type for the Buyout database.

1 In Buyout, click Database >Database Settings >Company Setup tab > [Job Cost
Setup].

2 Select Sage 100 Contractor as the Job cost interface type.

3 In theCompany box, select a Sage 100 Contractor company.

4 In theUser Name box, enter your user name for the Sage 100 Contractor company.

5 In thePassword box, type your password for the Sage 100 Contractor company.

6 Click [OK].

After performing these set up steps to integrate Estimating and Buyout with Sage 100
Contractor, you are ready to create proposals, budgets, change orders, purchase orders, and
subcontracts. The next chapter details the workflow and considerations necessary to export
the estimate data into Sage 100 Contractor.
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Export Estimating Data to Sage 100 Contractor
In this section, you will learn how to employ the wizards in:

n Estimating to create proposals, budgets, change orders.

n Buyout to create purchase orders and subcontracts.

Table 4: Exporting Data from Estimating to Sage 100 Contractor

Using the Estimating interface wizards
Each point of integration - proposal, budget, and change order - has its own four-step wizard
that captures information specific for what you are trying to create. The fundamental
appearance and operation of each wizard is the same. In some cases, the steps between
the threemay appear identical. Each wizard also requires different information be collected.
The following sections describe the four steps in the wizard required for creating proposals,
budgets, and change orders.
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Sage 100 Contractor Estimating Installation and Integration Guide

Create Proposals, Budgets, or Change Orders

Starting the interface wizards
In Estimating, select Proposal, Budget, orChange Order from the Interfacemenu.

Introduction
Each of the three interface wizards opens with an Introduction tab. The information
presented on this tab is specific to what you are creating - a proposal, budget, or change
order - and provides an overview of the creation process as well as any specific instructions.
Read through this carefully.

Step 1: Company Settings and Job Number
The first step in all three interface wizards is identical. In this window, the company you are
integrating with and either confirm or enter your user name and password for that company.
(Enter the user name you used in “Setting up an API User And Password,” on page 9.) Also
in this step, enter a transaction date and specify the job number for which you are creating
the proposal, budget, or change order.

If the job does not yet exist in Sage 100 Contractor, create that job from the interface wizard.
If type a a job number that does not exist in Sage 100 Contractor, you are prompted to either
create that job or select a different job. If you continue to create the job, youmust enter:

n Status

n Short Name

n Job Name

Step 2: Round Quantities and Allocate Addons
The second step gathers information on rounding and allocating addons.

Rounding

The rounding options for an item are set up on that item in the database or on the estimate.
Rounding does not show up on the estimate, but can be included in reports.

- 20 -



Chapter 4: Workflow

- 21 -

Allocating Addons

To allocate an addonmeans to spread the addon amount back through the estimate items.
Allocate an addon when you don’t want themarkup to show as a line in the estimate totals,
for example. You can allocate an addon in theEstimate Totalswindow. (With an estimate
open, press F4 on your keyboard.)

It is important to note that addons can also be sent to Sage 100 Contractor as their own line
item. You can add a cost code and cost type to each addon you insert into an estimate. Any
addon with job cost information will always be included in the interface.

Addon allocation and quantity rounding has a different effect on proposals, budgets, and
change orders as discussed in the following paragraphs.

n Proposal: For the proposal, answer ‘Yes’ to both rounding quantities and allocating
addons if you want to include all costs associated with the project.

n Budget: Select to round quantities for the budget to reflect the actual amounts. Youmay
not want to include addons in the budget, as they are not a reflection of the direct cost.
However, you can select to allocate some addons and not others, by selecting or clearing
the addon allocation box on theEstimate Totalswindow. (With an estimate open, press
F4 on your keyboard).

n Change Order:Step 2 for the change order does not ask whether or not you want to
allocate addons. All addons marked as allocatable will be allocated for the change side of
the change order. The budget side of the change order will not include allocated addons.
Whether an addon is allocatable or not is controlled on theEstimate Totalswindow. (With
an estimate open, press F4 on your keyboard).

Step 3: Interface Options
The third step is unique for each wizard type.

Proposal:You have the option to create the proposal by Cost Code or by Bid Item. If you
select to create the proposal by Bid Item, a second selection box becomes available,
prompting you to designate the estimate sort level that will be used as the Bid Item in Sage
100 Contractor.

n Bid Item considerations: If you choose to generate the proposal by bid item, you need
to specify what estimating element will be used as the bid item in Sage 100 Contractor.
You have a list of available estimate sorts that you can pick from that include all WBS
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codes, location, group phase, and phase among others. Select an estimate sort level that
will make an appropriate bid item.

n Include a Sage 100 Contractor Phase: You also have the option in the proposal to
include a Sage 100 Contractor phase. If you choose to do so, you will need to select an
estimate sort level that will appropriately translate into a phase. When the proposal has
been created, you will see the estimate sort you selected as a phase on the proposal.

Budget: Step 3 for the budget interface simply asks if you want to include a Sage 100
Contractor phase. If you select to do so, you will need tomake an appropriate selection of an
estimate sort level.

Change Order: The ChangeOrder interface requires multiple selections.

n Change Order Id:Select the estimate sort level that will be used as the change order ID.
For each change order ID, a change order is created in Sage 100 Contractor. The best
implementation practice is to dedicate aWBS code to use as the change order ID.

n Include Sage 100 Contractor Phase: Like the proposal and budget wizards, you have
the option to include a Sage 100 Contractor phase during the change order interface. If you
choose to include a Phase, select the estimate sort level.

n Select from the available change orders: After designating the change order ID, the list
of available change orders becomes available. Select the change orders you would like to
create in Sage 100 Contractor.

n Addon considerations: If you have addons assigned with a non-allocatable cost code
and cost type, additional fields become available. Enter the change order and phase to
which the addon amount should be included.

Step 4: Create Proposal, Budget, Change Order
For all three wizards, the final step is identical. A transaction report prints out cost codes,
amounts and any warnings that may come up during the interface. To initiate the export,
click [Create]. You will receive a confirmationmessage when the proposal, budget, and
change order is created.

NOTES:

l Proposal: You can create only one proposal per job. If you have already created a
proposal for the specified job, you will be given a warning if you want to overwrite it.
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l Budget: You can only create one budget per job. If you have already created a
budget for the specified job, you will be given a warning if you attempt to overwrite it.

l Change Orders: Sage 100 Contractor allows you to create the same change order
more than once. This is to minimize the risk of potentially overwriting an open and
active change order. When creating change orders, be aware of what you have
already created.

Create Purchase Orders and Subcontracts
Purchase orders and subcontracts are created in Buyout using the Sage 100 Contractor
vendor information you sent over to the Address Book.

Each point of integration—purchase order and subcontract—has its own two-step wizard
that captures information specific for what you are trying to create. Each wizard has the
same fundamental appearance and operation. The following sections describe each of the
two steps in the wizards.

Starting the interface wizards
In Buyout, select Purchase Order orSubcontract from the Interfacemenu.

Introduction
Each of the two interface wizards opens with an Introduction tab. The information
presented on this tab is specific to what you are creating - a purchase order or subcontract -
and provides an overview of the creation process as well as any specific instructions. Read
through this carefully.

Step 1: Company Settings and Transaction Date
InStep 1 you will confirm the company you are integrating with and either confirm or enter
your user name and password for that company. Also in this step, you enter a transaction
date.
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NOTE: Buyout allows you to import multiple estimate files into the samework file. As
the estimate files are imported, the job number that is assigned to that estimate follows
the items into the work file. If however, the estimate does not have a job number
assigned, you will be given amessage alerting you to the estimatemissing a job or
containing an invalid job number. You will need to go toActions >Work File
Information > General tab and enter a JC Job Number for that estimate before you
can create a purchase order or subcontract.

Step 2: Select Purchase Orders or Subcontracts
In step 2 for both the purchase order and subcontract interface wizards, you select the
purchase orders or subcontracts you want to create from the available list. Optionally, you
can choose to include a Sage 100 Contractor Phase with the purchase order or subcontract.

If you have already exported the purchase order or subcontract to Sage 100 Contractor, the
interface wizard will indicate to you which of the quotes have been exported.

NOTE: If you have added or created a new company to the Address Book that you
have selected to create a purchase order or subcontract for, the interface wizard will
prompt you to create that vendor in Sage 100 Contractor.

Troubleshooting
As you use the interface wizards to create the different data elements in Sage 100
Contractor, a series of validation checks is performed on the estimate and work file data.
When the interface wizard encounters data that is invalid it will alert you with amessage that
indicates which item is invalid and exactly what on that item is invalid. You will also be given
an explanation as to what you could do to fix the issue.

In order to complete the interface wizard, you will need to exit the wizard (click [Cancel]), fix
the issue, and restart the interface wizard. You have the ability to print the error list right from
the error window. We recommend that you use the print-out to address the invalid items.

The following errors may appear:

"Invalid Cost Code"
For each cost category that is included on the estimate item, the validation check will verify
that the assigned cost code exists in Sage 100 Contractor. If the cost code on an item is
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invalid, you can:

n Select a different cost code for that category. In Estimating, select the item on the
spreadsheet. Click View >Detail window >Unit Costs tab. Select the correct Job Cost
phase.

n If the cost code doesn’t exist in Sage 100 Contractor and you want that item to go the
specified cost code, you will need to create the cost code in Sage 100 Contractor.

"Invalid Cost Type"
For each cost category that is included on the estimate item, the validation check will verify
that the assigned cost type exists in Sage 100 Contractor. If the cost type on an item is
invalid, you will need to assign a valid cost type for the specified category. In Estimating,
select the item on the spreadsheet. Click View > Detail window > Unit Costs tab > [Job
Cost Phase]. Select the correct cost type in the Job Cost Category column.

Verify Data in Sage 100 Contractor
The last step in the integration process is to verify that the data has been created in Sage
100 Contractor. With each interface wizard, you receive a confirmationmessage that the
data has been successfully created in Sage 100 Contractor. You can then open Sage 100
Contractor Proposals, Budgets, ChangeOrders, PurchaseOrders, and Subcontracts to
verify the data.
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