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Introduction
Sage is pleased to provide you with multiple options for expanding Sage Estimating's capabilities and
features. Read the applicable chapters in this manual to learnmore information about your Sage
Estimating options.

Available Options for Sage Estimating
The following options are available for Sage Estimating:

n RS Means Integrator. The RS Means Integrator lets you add RS Means item pricing databases to your
Sage Estimating software. Using the RS Means Integrator, you can also update your Means price
databases on a recurring basis.

n On-Screen (ePlan) Takeoff Integrator. TheOn-Screen Takeoff (OST) Integrator lets you perform item
and assembly takeoff in Sage Estimating from drawings you create in On-Screen Takeoff.

n License Manager. LicenseManager provides ameans for managing licensing for Sage Estimating
operators. Installation and configuration instructions are found in chapter three of the Installation Guide.
Read this manual for LicenseManager operating instructions.
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Read the Supporting Documentation Before You Begin
Be sure to read supporting documentation before you install and configure your Sage Estimating options:

n This Options Guide provides installation, setup, and operating instructions for each of the available
Sage Estimating options, such as the OnScreen Takeoff Integrator or LicenseManager.

n The Installation & Administration Guide includes an overview of the latest Sage Estimating release,
installation instructions, system requirements, and contact information. This document is available in
theDocuments folder of your Sage Estimating installation files.

n TheRelease Notes provide details about new features, database changes, known issues, and fixes.
This document is available in theDocuments folder of your Sage Estimating installation files.

n TheGetting Started Guide provides an operational overview of the Sage Estimating software. This
document is available in theDocuments folder of your Sage Estimating installation files.

n TheSQL Server Guide gives you an overview of the significant differences between the new
SQL Server databases and the Pervasive databases used in previous Sage Estimating releases. This
document is available in theDocuments folder of your Sage Estimating installation files.

These documents are current at the time of the release. To learn about issues that have arisen since this
document was published, go to www.sagecre.com.

Conventions Used in this Document
This document uses the following conventions:

n Information you type into the software is shown in bold font. For example: TypeMiscellaneous in the
box.

n The names of screens, windows, fields, and other features displayed by the software are shown in bold
font.

n The names of buttons you can click are enclosed in brackets with bold font. For example: [OK] or
[Post].

n Names of keys are shown in capital letters. For example: ENTER or TAB. A plus sign (+) between two
key names indicates you should press the keys simultaneously.

n Variable names or names that are specific to your installationmay appear in italics and brackets. For
example: [Drive]\\[Server].

Symbols

NOTE: This symbol is used when presenting information that is supplemental to the adjacent text.

TIP: This symbol is used when presenting helpful information for using the software.

CAUTION: This symbol is used when presenting important information to help you avoid a loss of
critical data.
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IMPORTANT: This symbol is used when presenting information that is critical to understand or that
requires you to take action.

Menu Paths
In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font
with angle brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Online Help
The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To access the online Help in the Sage Estimating software, click the Help button or icon, or press [F1] to
display the Help topic for that window.

To aid you in finding the information you need, the online Help for eachmodule includes the following
panes:

n Contents pane containing links to the Help topics

n Index pane containing keywords that link to Help topics related to that keyword

n Search pane, where you can type text and click [Search] to locate that text in the Help topics

For more information about using the online Help, see the Sage Estimating Help.

Wewould like your feedback about the online Help so we canmake improvements. Each Help topic
contains an area where you can indicate whether the topic was helpful and provide additional comments.
To protect your privacy, all comments are anonymous.

Training
Sage University offers online and classroom training sessions to help you get themost out of your Sage
Estimating software. To access Sage University, visit www.sageu.com.

You can also get access to Sage University from the File menu by selectingHelp > Sage Estimating on
the Web > Sage University.

Technical Assistance
Depending on your support plan, you can access any of the following online services.

Sage Customer Portal
n Knowledgebase: Find answers to your questions, access downloads, and subscribe to your favorite
articles. This service is available online 24/7.

Introduction
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n Live Chat:Chat online with a customer support analyst - a great option for quick questions. Chat hours
are the same as our telephone support hours (see below).

n Online Support Request:Submit an online support ticket when you have a non-urgent question. One
of our call center support analysts will assist you. Online support hours are the same as our customer
support call center hours (see below).

Sage Customer Support Call Center
Telephone Support: When you have amore urgent question or would prefer to speak to a customer support
analyst directly, call us at 866-991-3359. Telephone support is available Monday through Friday from 6
a.m. to 5 p.m. Pacific time with the following exceptions:

n Every Thursday from 2 p.m. to 3 p.m. Pacific time (closed for customer support staff meetings)

n Standard United States holidays

n Quarterly company meetings

Upgrading Your Service Plan
If your service plan does not provide online or telephone customer support and you would like to add or
upgrade a service plan, please call 800-858-7098.

Submitting Enhancement Requests
Wewant to hear your suggestions for improving the software. To send us your comments, click on the File
menu button and select Help > Sage Estimating on the Web > Submit Enhancement
Requests.
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Means Integrator
Sage Estimating offers several item databases for purchase, including RSMeans databases. If you use
RSMeans database items in your estimates, read this chapter to review the changes and the instructions
for updating the following affected databases:

n Means Databases

n Construction Knowledgebase

n Residential Knowledgebase

New in This Release
RSMeans databases have been updated with current pricing information.

MasterFormat 1995 Format Support for 13.1
As of this release, support for theMF95 database format has been discontinued.

MasterFormat 2010 Format
RSMeans has adopted the Construction Specifications Institute (CSI) MasterFormat 2010 (MF10) data
structure for all of their databases. Previously, RSMeans databases used theMasterFormat 2004 (MF04)
or theMasterFormat 1995 (MF95) data structure.

NOTE: If you are already using RSMeans databases in theMF04 format, you do not need to
upgrade your databases to theMF10 format.

Overview
The RSMeans databases correspond to the RSMeans Cost Data Books you receive with your shipment.

With Sage EstimatingMeans Integrator, you can create a single database or combinemultiple databases
into one composite database or you can update the pricing on an existing database with current RSMeans
pricing.

1 Install or upgrade to Sage Estimating 13.1 if you do not already have it installed on your computer.

2 If you plan to use existing RSMeans data, migrate it to Sage Estimating 13.1.
You can select an existing RSMeans database for transferring or updating; however, youmust first
migrate the database to Sage Estimating 13.1. See the Sage Estimating Installation & Administration
Guide for datamigration instructions.

3 Insert the 2012Means Integrator installation CD into the CD drive of the workstation or server where
Sage Estimating 13.1 is installed.
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4 From the installation browser:

a Select theMeans Integrator application for Sage Estimating 13.1.

b Click [Browse] and browse to the server or workstation where you want to store your RSMeans
databases.

c Select the check box next to each RSMeans database you want to install then click [Install].

5 After the installation is finished, start the 2012Means Integrator by clickingStart > All Programs >
Sage > Sage Estimating > Means Integrator.

6 Follow the steps through theMeans Integrator wizard.

2012 Means Integrator Workflows
Integrating your RSMeans data is a five step process.

Step One: Prepare Database
In theMeans Integrator wizardPrepare Databasewindow, you can select whether to transfer data or
update data. The following information describes the outcome of these options.

Transfer Data

Select Transfer Data if you are ready tomove RSMeans 2012 data to a new database or to an existing
Sage Estimating database.

n Transfer Data—New Database

Select this option to create a new Sage Estimating database and populate it with all of the RSMeans
2012 items in theMF10 format.

NOTE: You cannot set job cost interface specifications for a new database using this option. Youmust
first create a new database and set up the job cost specifications (such as phase suffix and company)
then transfer RSMeans data to the new database using theExisting Database option in this window.
See theMeans Integrator Help for more information.

n Transfer Data—Existing Database

Select this option when you want to transfer theMeans 2012 items to an existing Sage Estimating
database inMF10 format.

If you select this option, theMeans Integrator transfers the RSMeans 2012 items directly to the
selected database. The resulting database will contain both your existing phases and items and the
RSMeans phases and items.

NOTE: Addition of RSMeans 2012 phases and items could cause your phase sort to appear differently
in Sage Estimating.

If you are transferring RSMeans data to a new database, also select a company to associate with the
data, then specify the length of the normal work periods and the default crew pricingmethod. Sage
Estimating displays the specified information in theDatabase Settingswindow whenever you open the
database.
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Update Data

Select Update Data if you have RSMeans items in a current Sage Estimating database that need to be
updated with 2012 prices.

If you want to update RSMeans items in a database created in a prior Estimating version (such as Sage
Timberline Office Estimating 9.6), ensure youmigrate your data to Sage Estimating version 13.1 before
performing this update in Means Integrator.

See the Installation & Administration Guide for datamigration instructions.

NOTES:

l 2012 data provides price updates in theMF10 format.

l Migrate any existing RSMeans databases to Sage Estimating 13.1 if you want to perform the
update or transfer process on them.

Step Two: Select Data
Select the RSMeans divisions and items that you want to update in or transfer to your selected Sage
Estimating database.

You can select items and divisions individually or select all available items and divisions at one time.

Step Three: Select Pricing
Select whether to use RSMeans national average pricing for item pricing or base item pricing on a regional
cost index.

n If you choose to use theRSMeans Standard National Averge Pricing option, theMeans Integrator
uses the RSMeans standard national average as the base price for each item during the integration. The
Means Integrator then imports any city cost indexes associated with the RSMeans items so you can
use them later with the Sage Estimating Cost Index feature.

n If you select theRSMeans City Cost Index option, theMeans Integrator calculates and sets item
pricing based on the region you specify in theState andCity boxes. It does not import any city cost
index information for use in Sage Estimating.

Step Four: Select Options
Select a variety of options to apply to the database, including pricing options (Crew, Hourly, orUnit),
audit report options, and what to do with any duplicate items.

Step Five: Finish
Review the summary information and click [Finish] to transfer or update the selected database with
RSMeans information.

You canmake changes as necessary by clicking [Back] and editing the desired information.

Means Integrator
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Help and Information
The 2012Means Integrator contains updated Help to assist you in converting and updating your
databases. To use Help, click [Help] from theMeans Integrator.
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License Manager
LicenseManager tracks and updates network licenses for Sage Estimating. Use LicenseManager to
share pools of licenses between operators on the network. For example, if you have seven estimators who
are connected to the network and you own five network licenses for Sage Estimating, up to five of the
seven estimators can use the software concurrently.

After a few installation steps, LicenseManager works behind the scenes tomanage concurrent uses for
Sage Estimating.

Read this chapter to learn how tomanage licenses, use environment variables, and troubleshoot any
issues that youmay encounter. For instructions on installing and configuring LicenseManager, see the
Installation & Administration Guide in theDocuments folder of your Sage Estimating setup and
installation DVD.

License Management Components
The following table describes the components required to install andmanage Sage Estimating licenses.

TheDocumentation column lists sources for component-use information.
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Table 1: Required LicenseManager Components

Component Function Documentation

LicenseMan-
ager

Tracks program
uses on the net-
work

These files are in theDocuments folder of your
Sage Estimating setup and installation DVD:

n Installation & Administration Guide

n Sage Estimating Options Guide

This file is in the
AdditionalInstalls\LicenseManager\SysAdminHelp
folder of your Sage Estimating setup and
installation DVD.

n Sentinel LicenseManager System
Administrator Online Help (Default.html).

LicenseMan-
ager pro-
tection device

Attaches to the
USB or parallel port
of the server host-
ing LicenseMan-
ager. It is a security
device that author-
izes LicenseMan-
ager to distribute
licenses.

n Sentinel License Manager System Administrator
Online Help

n Installation & Administration Guide

n Sage Estimating Options Guide

License Tools Perform tasks,
such as check
licenses in and out
(WCommute.exe);
check licenses in
and out remotely
(Wrcommute.exe);
test the protection
device
(Wechoid.exe); and
monitor licenses
(Wlmadmin.exe).

l Sentinel LicenseManager System
Administrator Online Help

l Sage Estimating Options Guide

l Sentinel LicenseManager System
Administrator Online Help (index.html).

Sentinel driver Allows com-
munication
between License
Manager and the
LicenseManager
protection device.

l Sentinel LicenseManager System
Administrator Online Help
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NOTE: Due to changes in software environments, some options in Sentinel License Manager System
Administrator Online Helpmay not be supported. Please contact Customer Support if you experience
issues viewing the LicenseManager System Administrator Online Help.

Work With Commuter Licenses
Commuter licenses allow you to start estimating products in a stand-alone environment (no network
connections, no protection device). While you are connected to the network, use Commuter License
Manager (WCommute.exe) to check licenses in and out from the licensemanager in order to make them
available when you are not connected to the network.

NOTE: If you have an unexpired commuter license, you do not need a protection device.

Check Out Licenses
1 From the workstation or notebook computer you will use when disconnected from the network, select
Start > All Programs > Sage > Sage Estimating > License Manager > Commuter License
Manager.
If this menu option is not available to you, you can start the program by inserting your Sage Estimating
setup and installation DVD into your DVD-ROM drive and browsing toAdditional Installs\License
Manager\Admin.Net\Wcommute.exe.

2 From the Filemenu, select Search Subnet.

Figure 1: The Commuter LicenseWindow

3 From the list of programs with available licenses, select the program that you want to check out.

NOTE: The list displays one line for each program that is available. If you want to see the status of all
licenses, useWlmAdmin. For more details, see “Monitor Licenses” on page 12.

LicenseManager
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4 Enter the number of days (1 to 180) that you will need the license.

5 Click [Check Out]. You will see a red check mark next to the program that you just checked out.

6 Repeat this process to check out licenses for all the programs that you will need while you are
disconnected from the network.

7 When you finish, close theCommuter Licensingwindow.

Check In Licenses
You can check licenses in before or after their time limits expire so that they are available for others.

1 When you are once again connected to the network, select Start > All Programs > Sage > Sage
Estimating > License Manager > Commuter License Manager.
If this menu option is not available to you, you can start the program by inserting your Sage Estimating
setup and installation DVD into your DVD-ROM drive and browsing toAdditional Installs\License
Manager\Admin.Net\Wcommute.exe.

2 From the Filemenu, select Search Subnet. A list of programs with licenses appear.

p Programs with checked out licenses appear in the list with a red checkmark.

p Programs with licenses that have expired appear in the list with a red “x.”

3 From the list of licenses, select the program for which you want to check in a license and click [Check
In].

4 When you finish, close theCommuter Licensingwindow.

Monitor Licenses
TheWlmAdmin program is amonitoring tool used to check the number of licenses, confirm how many are
in use, check the status, and see to who is using the licenses. It is useful for determining why a license
manager or available license cannot be found. WlmAdmin allows you to view:

n A list of licensed programs.

n The names of the users (if any) who are currently using the licenses.

n The total number of licenses purchased for each program. (WlmAdmin refers to programs as “features.”)

To start WlmAdmin, select Start > All Programs > Sage > Sage Estimating > License Manager > LM
Admin. If this menu option is not available to you, you can start the program by inserting your Sage
Estimating setup and installation DVD into your DVD-ROM drive and browsing to Additional
Installs\License Manager\Admin.Net\WlmAdmin.exe.
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Figure 2: TheWlmAdminWindow

TheWlmAdmin window has the following features:

n The left pane shows a list of all licensed programs. For example, PWX-ENU identifies Sage Estimating.
Double-click on a program to expand it and view the names of those who currently have licenses
checked out.

n The right pane shows details about the selected program (for example, the total number of licenses
available and the number of licenses in use).

Environment Variables
In certain circumstances, youmay need to use an environment variable to resolve one of themessages
outlined in Section 3. For example, if you usemultiple licensemanagers to run other programs, youmay
want to specify which licensemanager to use when obtaining available estimating licenses. For
instructions on setting these variables, see “How to Set Environment Variables ” on page 14.

LicenseManager
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Valuable Environment Variables
LSFORCEHOST

This variable is a valuable troubleshooting tool to use when license acquisition issues arise. The variable
can be used to direct client stations to a specific LicenseManager server. If that licensemanager is not
found, the program stops searching and returns an error message; it does not check every computer on the
network for a license server.

LSPROTOCOL

This variable allows you tomatch the communications protocol of the licensemanager and the client.
Because youmust be certain that the licensemanager and the client both use the same protocol,
LSPROTOCOL is especially helpful in multi-protocol environments. For example, if the licensemanager
uses only IPX and the client uses IPX and TCP, you would use LSPROTOCOL to set the client to IPX.
The value to set for IPX/SPX is IPX. The value for TCP/IP is UDP.

LSHOST

This variable is used when you want the client to search from a list of potential servers. If none of those
servers are found, the client looks to the network for any license server.
For a complete list of environment variables with more detail, seeSentinel LM System Administrator
Help, located on the Sage Estimating setup and installation DVD at
[Drive]:\AdditionalInstalls\LicenseManager\SysAdminHelp\index.html ([Drive] represents the letter
assigned to the CD drive).

NOTE: Due to changes in software environments, some options listed in Sentinel LM System
Administrator Helpmay not be supported. Please contact Customer Support for more information.

How to Set Environment Variables
You should configure environment variables properly for your network. For more information, seeSentinel
LM System Administrator Help, located on the Sage Estimating setup and installation DVD at
[Drive]:\AdditionalInstalls\LicenseManager\SysAdminHelp\index.html ([Drive] represents the letter
assigned to the CD drive).

To Set LSFORCEHOST or LSHOST
1 Determine the IP address or name of the computer that hosts LicenseManager.

p To determine the IP address of the computer, type ipconfig at a command prompt.

p To determine the name of the computer:

l In Windows XP and Windows Server 2003:Right-click onMy Computer and select
Properties. Find the Full Computer Name on theComputer Name tab.

l In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > System.

l In Windows 7:Select Start > Control Panel > System and Security > System.

2 Set environment variables:
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p In Windows XP and Windows Server 2003:Select Start > Settings > Control Panel > System >
Advanced tab, [Environment Variables].

p In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > System > Advanced tab, [Environment Variables].

p In Windows 7:Select Start > Control Panel > System and Security > System > Advanced
System Settings > Advanced tab, [Environmental Variables].

3 Select [New] underSystem variables (to avoid creating a user variable).

Figure 3: Setting the LSFORCEHOST Variable

4 In theVariable Name box, type the variable LSFORCEHOST or LSHOST.

5 In theVariable Value box, type the value. The value should be either the static IP address or the name
of the computer.

6 When you finish, click [OK].

7 Restart your computer for these changes to take effect.

To Set LSPROTOCOL
1 Set environment variables:

p In Windows XP and Windows Server 2003:Select Start > Settings > Control Panel > System >
Advanced tab, [Environment Variables].

p In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > System > Advanced tab, [Environment Variables].

p In Windows 7:Select Start > Control Panel > System and Security > System > Advanced
System Settings > Advanced tab, [Environmental Variables].

2 Select [New] underSystem variables (to avoid creating a user variable).

LicenseManager
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Figure 4: Setting the LSPROTOCOLVariable

3 In theVariable Name field, type the variable LSPROTOCOL.

4 In theVariable Value field, type the appropriate protocol.

5 The value to set for IPX/SPX is IPX. The value for TCP/IP is UDP.

6 When you finish, click [OK].

Error Messages
When an program cannot find a workstation protection device or an available network license, youmay
receive one of the following error messages. Use the information in this section to resolve the issue.

"A network error occurred"
A network error usually means that the workstation is not attached to the network. To resolve this
message, make sure that the workstation is attached to the network (browse to the computer on which
LicenseManager is installed); then try again to start a program.

Youmay also receive this message because neither TCP/IP nor IPX/SPX protocols are installed. To
resolve the issue, verify that LicenseManager is installed on aWindows- based operating system. (You
can use LicenseManager on a network with a Novell server andWindows workstations, provided it is
installed on one of theWindows workstations.) Also, verify that the LicenseManager computer and the
workstations contacting it are using the same communications protocol (TCP/IP or IPX/SPX).

If any of the workstations contacting LicenseManager have both TCP/IP and IPX/SPX installed and the
LicenseManager computer has only IPX/SPX installed, set the LSPROTOCOL to IPX on those
workstations. For more information on how to do this, see “Environment Variables” on page 13. After you
set the environment variable, try again to start the program.

If you still cannot resolve themessage, contact your network administrator.

"All licenses are in use"
This message indicates that network licenses for the program were found, but all of the licenses were in
use. To resolve the issue:

1 UseWlmAdmin to verify this information (see “Monitor Licenses” on page 12).

2 Try to start the program again when a license is available.
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3 If you need additional licenses, contact your business partner.

"Cannot acquire a license"
This messagemeans that either an incompatible version of the program is installed or LicenseManager is
installed incorrectly. To resolve the issue:

1 Verify that you used the default installation path when you installed LicenseManager (C:\Program
Files\Common Files\SafeNet Sentinel\Sentinel RMS LicenseManager\WinNT).

2 If you installed it to another location, verify that LicenseManager was installed to a local drive. It cannot
be installed to a network drive.

3 Make sure that themost recent program versions are installed.

4 Verify that the correct version of the Sentinel protection device driver is installed and running (see
“LicenseManager” following this section).

5 Test the protection device (see “Testing the protection device” on page 20). If a device is not found, try
setting the parallel port mode to nonbidirectional, standard, SPP, or normal in the BIOS.

6 Try removing and then reinstalling LicenseManager to the server.

NOTE: Before you remove LicenseManager, youmust stop the LicenseManager service.

Checking the Sentinel protection device

To check the Sentinel Protection Device:

1 Start the DeviceManager, as follows:

p In Windows XP and Windows Server 2003:Select Start > Settings > Control Panel > System >
Hardware tab > [Device Manager].

p In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > System > Device Manager.

p In Windows 7:Select Start > Control Panel > System and Security > System > Device
Manager.

2 From theViewmenu, select Show hidden devices.

3 ExpandNon-Plug and Play Drivers in the list. Double-click Sentinel, and select theDriver tab.

NOTE: If Sentinel does not appear in the list, install the correct version of the Sentinel driver for your
operating system (see the Installation & Administration Guide available on theDocuments folder of
your Sage Estimating setup and installation DVD).

4 Under theCurrent Status verify that the status is started; if not click [Start].

"Error: Sentinel error 8. Cannot return the token or feature XXX-ENU."
This error appears when a server has two network interface cards (NICs) installed and enabled. The dual
network interface cards cause LicenseManager to check licenses out to one IP address and try to check
them in to another. To resolve this issue, remove LicenseManager and then install it to a workstation that
does not have dual network interface cards.

LicenseManager
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To remove License Manager
1 From the workstation, verify that no commuter licenses currently checked out; they must be checked in
before you remove LicenseManager. UseWlmAdmin to verify that all licenses are checked in. (Start
WlmAdmin from Start > All Programs > Sage > Sage Estimating > License Manager > LM Admin).
If this menu option is not available to you, you can start the program by inserting your Sage Estimating
setup and installation DVD into your DVD-ROM drive and browsing to Additional Installs\License
Manager\Admin.Net\WlmAdmin.exe.

2 From the server, stop the LicenseManager service.

p In Windows XP and Windows Server 2003:Select Start > Settings > Control Panel. Click
Administrative Tools; then click Services. Select Sentinel LM, right-click, and then click [Stop].

p In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > Administrative Tools; then click Services. Select Sentinel LM, right-click, and
then click [Stop].

p In Windows 7:Select Start > Control Panel > System and Security > Administrative Tools
> Services. Select Sentinel LM, right-click, and then click [Stop].

3 Remove the service.

p In Windows XP and Windows Server 2003:Select Start > Settings > Control Panel >
Add/Remove Programs. Scroll down toSentinel LM Server 8.1.0; select it and then click
[Remove].

p In Windows Vista and Windows 2008 Server, and Windows 7:Select Start > Control Panel >
Uninstall a program (underPrograms). Scroll down toSentinelLM Server 8.1.0; right-click and
click Uninstall.

4 InWindows Explorer, browse to C:\Program Files\Common Files\SafeNet Sentinel\Sentinel LM
Server\WinNT; select the folder and then delete it.

5 Restart your computer.

To install License Manager

See chapter three of the Installation & Administration Guide available on theDocuments folder of your
Sage Estimating setup and installation DVD for instructions.

"No servers running on this subnet"
Both the licensemanager and its clients must be in the same subnet, or youmust use LSFORCEHOST. If
you start WlmAdmin and no licensemanagers are found, youmay have a connection barrier (see “Monitor
Licenses” on page 12 for more information on runningWlmAdmin).

To resolve the issue:

1 Verify that the workstation is attached to the network (browse to the computer on which License
Manager is installed).

2 If you cannot browse to the computer and you use TCP/IP, ping that licensemanager (see “Using the
Ping utility” on page 19 following this section).
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The ping utility sends four communications packets to the target computer. If received, the four packets
are sent back to the source computer. The round trip process is timed to benchmark communication
performance.

3 Start WlmAdmin from the licensemanager. You should see the computer’s host name, the IP or IPX
address, and what licenses (if any) have already been installed.

4 If none of the above helps resolve the issue, contact Customer Support.

Using the Ping utility

To use the Ping utility:

1 Determine the IP address or name of the computer that hosts LicenseManager.

2 To determine the IP address of the computer, type ipconfig at a command prompt.
To determine the name of the computer:

p In Windows XP and Windows Server 2003:Right-click onMy Computer and select Properties.
Find the Full Computer Name on theComputer Name tab.

p In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > System.

p In Windows 7:Select Start > Control Panel > System and Security > System.

3 From the command prompt on the client workstation from which you want to test communications, type
ping and the name or address of the computer on which LicenseManager is installed and running (for
example, type ping 192.168.40.193). Make sure to type a space after the word ping.

4 Examine the ping results to determine whether there is a connection barrier:

Figure 5: Ping Results

p IP Address: The IP address should be static andmatch the address you retrieved with Ipconfig. If
the IP address is different, the name resolution processes will not work. Use the computer name
instead to ping the computer where LicenseManager is installed.

LicenseManager
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p Packets Sent and Received:All four packets that were sent should have returned successfully. If
packets were lost, this is an indicator of failing network hardware or a situation in which a high level of
packet collisions occur, possibly due to overloaded hardware. Contact your local system
administrator to resolve this issue.

"Unable to install license code..."
This message continues with the name of the license code and this statement: “The code is invalid,
already loaded in the license server, or the license server is not running.” Themessagemay alsomean
that LicenseManager is running but cannot be found by the installer program. To resolve the issue:

Be sure the code was entered exactly as it appears on the packing slip or in the *.lic file (license codes are
not case sensitive). Reenter the code if necessary.

1 Run LM Admin to verify that LicenseManager is actually running.
You cannot enter a license code unless LicenseManager is running. You can also check to see if the
SentinelLM service is started:

p In Windows XP and Windows Server 2003: Select Start > Control Panel > Administrative
Tools > Services.

p In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > Administrative Tools > Services.

2 Search for the LSERVRC file and open it with a text editor, such as Notepad, to see whether the code
has already been installed or entered.

3 All license codes in LSERVC will have # as their last character. Youmay also use LM Admin to view
the installed license codes (“Monitor Licenses” on page 12).

4 Use the LSPROTOCOL environment variable to set the communication protocol (IPX/SPX or TCP/IP)
to match that of the licensemanager. For more information, see “Environment Variables” on page 13.

If you still cannot resolve themessage, remove the protection device, restart the computer, and then try to
reinstall the license code. If this works, use the following procedure to determine whether you have a bad
device, in which case you should contact Customer Support.

Testing the protection device

To test the protection device:

To verify that the LicenseManager protection device is being detected, runWechoid.exe from the
computer on which LicenseManager and the protection device are installed. Wechoid is a utility you can
use to determine the locking code of a LicenseManager server.

1 Insert the Sage Estimating setup and installation DVD into the DVD drive of the LicenseManager
server.

2 Locate and then double-clickWechoid.exe. It can be found at
[Drive]:\AdditionalInstalls\LicenseManager\Admin.net ([Drive] represents the letter assigned to the
DVD drive).

3 In theWechoidwindow, clear all check boxes except Computer ID.

4 Under Locking Data, confirm the following:
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p Selector: 0x80

p Code: 0x1FB03
If any other information appears, the device cannot be found or is not working.

Figure 6: TheWechoidWindow

5 Click [OK] to exit. (It is not necessary to reselect the check boxes.)

"Unable to locate a protection device or obtain a license for this
application/feature"
Make sure that the driver is installed (for more information on the driver, see the Installation &
Administration Guide available on theDocuments folder of your Sage Estimating setup and installation
DVD). If you are not connected to the network, be certain that you have either a workstation protection
device securely attached to your computer's USB or parallel port or an unexpired commuter license. Try
running the program again.

If you receive this message and you are connected to the network, one of the followingmay be true:

n LicenseManager is not running on your network. To resolve the issue, useWlmAdmin (see “Monitor
Licenses” on page 12) to verify that LicenseManager is running on your network. If LicenseManager
has been installed but is not currently running, that computer and its features will not appear in
WlmAdmin.

To start LicenseManager, do the following:

LicenseManager
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p In Windows XP and Windows 2003 Server:Select Start > Settings > Control Panel >
Administrative Tools > Services; then select SentinelLM, right-click, and click [Start].

p In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > Administrative Tools > Services; then select SentinelLM, right-click, and click
[Start].

p In Windows 7:Select Start > Control Panel > System and Security > Administrative Tools
> Services. Select Sentinel LM, right-click, and then click [Start].

n LicenseManager may not be installed. Install LicenseManager if you determine that it has not already
been installed (see the Installation & Administration Guide available in theDocuments folder of your
Sage Estimating setup and installation DVD).

n The network may have timed out while trying to locate LicenseManager. To resolve the issue, you can
use the LSFORCEHOST environment variable (see “Environment Variables” on page 13) to select a
specific licensemanager. After you set the variable, try to start the program again.

n Youmay have a bad protection device (see “Testing the protection device” on page 20).

"You do not have a license for the application you are trying to run"
This messagemay indicate that:

n No license codes were installed. UseWlmAdmin (see “Monitor Licenses” on page 12) to check whether
the license codes were installed. Themessage “No licenses installed on this server!” indicates that you
must install the license codes (see the Installation & Administration Guide available on theDocuments
folder of your Sage Estimating setup and installation DVD). Install the license codes then try again to
start the program.

If you determine that you do not have a license for the program you are trying to use, contact your
business partner to obtain a license.

n You havemultiple licensemanagers and the program found the wrong licensemanager. To resolve the
issue, use the LM Admin program to display licensemanager information (see “Monitor Licenses” on
page 12).

If you determine that you havemultiple licensemanagers, you can use the LSFORCEHOST
environment variable to select a specific licensemanager (see “Environment Variables” on page 13).
After you set the environment variable, try to start the program again.

"Your commuter license for this application/feature has expired"
UseCommuter LicenseManager to check in or renew your commuter license. For details, “License
Manager” on page 9.
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Sage 300 Construction and Real Estate
Job Cost Integration
If you use Sage 300 Construction and Real Estate Job Cost, you can transfer estimate information directly
into your job costing application. This allows you to access budget and transaction data without reentering
the information. This section covers the interface between Sage Estimating and Sage 300 Construction
and Real Estate Job Cost, which enables the information transfer.

Overview
When Sage Estimating sends estimate information to Sage 300 Construction and Real Estate Job Cost, it
sends the information directly to the Job Cost application's New.jct file. Sage 300 Construction and Real
Estate Job Cost can then access the estimate data without having to import it first.

Figure 7: The Sage Estimating-Job Cost Interface

For detailed information about Job Cost concepts, see the in-product Help in Sage 300 Construction and
Real Estate Job Cost.
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Setup Guidelines
To help ensure a smooth data transfer between Sage Estimating and Job Cost, follow these guidelines:

Sage 300 Construction and Real Estate Job Cost
Before you export data from Sage Estimating, ensure that in Job Cost:

n Standard cost codes exist for each cost code sent from Sage Estimating.

n If you use categories, standard categories exist for each category sent from Sage Estimating.

n Operators working with estimate data have the appropriate security permissions for the following:

p Job Cost Enter Estimates or Import tasks

p File access (to the .jct file)

p Company security

p Job record security

Sage Estimating
Before you create an estimate to send to Job Cost, make sure the database settings for phases, items,
and addons are set up correctly for your needs. Any changes made to these settings after an estimate is
created do not affect existing phases, items, or addons. Existing phases, items, and addons must be
changed individually if you want the new settings to be reflected in Job Cost.

Before you send estimate information to Job Cost, ensure that:

n Database Phase settings aremapped to the desired Job cost phase.

n Database Item settings aremapped to the desired Job Cost Phase and Job Cost Category.

n Database Addon settings aremapped to the correct Job Cost Phase and Category.

n The BOM description for the items are 30 characters or less. Job Cost can only accept up to 30
characters for the bill of materials description.

Prepare Sage 300 Construction and Real Estate Job Cost to
Receive Estimates
Youmust verify two items in Sage 300 Construction and Real Estate Job Cost to successfully transfer
estimate information from Sage Estimating:

n All needed standard cost codes are set up. To see a list of standard cost codes that are already set
up in Job Cost, from the Job Cost Reports menu, select Lists > Standard Cost Codes. If you do not
see a cost code that you know exists in the estimate or estimates, select Setup > Standard Cost
Codes to set up the standard cost code.
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n Standard categories are set up (if your company uses categories). Using categories is optional. If
you do not use categories, you do not need to verify that they exist. To see a list of standard categories
that are already set up, from the Job Cost Reportsmenu select Lists > Standard Categories. If you do
not see a standard category listed that you know exists in the estimate or estimates, select Setup
> Standard Categories to set up that category.

Prepare Sage Estimating to Send Estimates
Perform the following tasks in the Sage Estimating software to send estimate information to Sage 300
Construction and Real Estate Job Cost.

n Enable the Job Cost interface.

n Verify standard database phase settings.

n Verify the standard database item settings.

n Verify the standard database addon settings.

Enable the Job Cost interface
Set up standard databases individually to interface with Sage 300 Construction and Real Estate Job Cost
by enabling the interface in the Sage Estimating EstimatingManagement Console:

1 Click on the EstimatingManagement Console desktop icon .

2 In the EstimatingManagement Console, click on theStandard Databases tab.

3 Select the desired standard database from the list of standard databases in theStandard Database
Catalog pane.

4 If desired, you can also create a new standard database by clicking [New Standard Database]. Fill out
the new standard database details on the provided tabs in the detail pane and click [Create].

5 Select Sage 300 Construction and Real Estate as the job cost interface in the Job Cost Info area of
the detail pane.

Figure 8: The Job Cost Area

Sage 300 Construction and Real Estate Job Cost Integration
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6 Click [Setup] (Job Cost Info area) to open the Job Cost Integrator window in Sage 300 Construction
and Real Estate Job Cost.

7 In the Job Cost Integrator window, select the Sage 300 Construction and Real Estate company you
want to associate with the standard database.

Figure 9: The Job Cost IntegratorWindow

8 Select a default JC category cost code in the Labor,Material, Subcontractor, Equipment, andOther
boxes.
Sage Estimating prefills the JC category box in each new item you create with the applicable selected
default category.
For example, if you select a labor cost code of 03-0100 for the Labor box, each time you create a new
labor item for the estimate or standard database, the item's JC category box automatically displays a
cost code of 03-0100.

9 If you want to overwrite the cost code information in existing items in your standard database, select the
Add Job Cost categories to items check box.

10 Click [OK] to return to the EstimatingManagement Console.

11 Verify that the Sage 300 Construction and Real Estate company you selected in step 6 appears in the
Company name box of the Job Cost Info area of the EstimatingManagement Console.

Verify standard database phase settings
Both Sage Estimating and Sage 300 Construction and Real Estate Job Cost use the concept of phases.

NOTE: In Job Cost, phases are often called cost codes.
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It is possible that the phase structure used in Sage Estimating is not the same as the cost code structure
used in Job Cost. Using theDatabase Phase window in Sage Estimating, you tell the software how you
want the two structures to align. In essence, you create amap for the software to use when you transfer
data from a phase in Sage Estimating to a cost code in Job Cost.

To verify standard database phase settings:

1 From the Database tab in Sage Estimating, select Phases from thePhase/Item group (in classic view,
select Databasemenu > Phases).
TheDatabase Phasewindow opens.

Figure 10: The Database PhaseWindow

2 Click the list button located to the right of Job cost phase to select the Sage Estimating phase to be
mapped to a cost code in Job Cost.
The Database Phase Listwindow opens.

Sage 300 Construction and Real Estate Job Cost Integration
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Figure 11: The Database Phase List Window

3 Double-click on the desired phase.
You are returned to theDatabase Phasewindow. The selectedPhase, its Description, Unit
description, and any previously selected Job Cost phase display in theDatabase Phasewindow
initially.

NOTE: You can use the same Job Cost phase number for many different estimating phases.

4 Click [Close] when you are finished.

Verify standard database item settings
TheDatabase Item window is where you define the Job Cost phase and Job Cost Category to use with a
standard database item, and specify which quantity to send to Job Cost.

To verify standard database item settings:

1 In Sage Estimating, select Database tab > Phase/Item group > Items (in classic view, select
Database menu > Items) to open theDatabase Item window then click on the Job Cost tab.
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Figure 12: The Job Cost Tab of the Database ItemWindow

The information you enter on this tab creates amap for the software to use when you transfer
information from Sage Estimating to Job Cost. For each item in the standard database, you can select a
Job Cost phase (remember, in the Job Cost application, phases are often referred to as cost codes) and
a Job Cost category. When Sage Estimating sends this estimate item to Job Cost, the item and its
associated information appears under the cost code and category you select on this tab.

NOTE: As with phases, you can use the same Job Cost Phase and Job Cost Category for any
number of estimate items.

2 Click in the Job Cost Phase field, and then click the list button.
TheDatabase Job Cost Phase Listwindow opens.

3 Locate and double-click the Job Cost phase you want to receive the item information when Sage
Estimating interfaces with Job Cost.
When you double-click on an item, the Database Job Cost Phase Listwindow closes and you are
returned to theDatabase Item window. The Job Cost phase you selected appears in the Job Cost
Phase box.

NOTE: You can alsomanually enter a phase. Be sure to follow the format set up in Job Cost. If the
phase does not exist in Job Cost, you can create it during the import.

4 Click in the Job Cost Category box and then select the category from the list to receive the Sage
Estimating item information.

Sage 300 Construction and Real Estate Job Cost Integration
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Figure 13: The Job Cost Category List

NOTES:
l You can alsomanually enter a category.

l Be sure to click in the Job Cost Category box, not the standard database item Category box.
The database item Category box is used for pricing and does not have any impact on the Job Cost
interface.

5 Select the item quantity to send to the selected Job Cost category by selecting the item quantity from
theQty to Job Cost list.
Your cost accounting needs should dictate which option you choose.

p Takeoff qty: Sends to Job Cost the takeoff item quantity for the category.

p Order qty:Sends to Job Cost the order item quantity for the category.

p None:Sends to Job Cost the total dollar amount for the job cost phase and job cost category. It does
not send quantities, so the unit price field in Job Cost will be blank.

6 Click [OK] and [Close] when you are done.

NOTE: You can alsomake changes to the Job Cost phase and category from the estimating
spreadsheet itself.

Verify standard database addon settings
To view the database addon settings:

1 From theDatabase tab, select Addons from theMiscellaneous group (in classic view, select
Databasemenu > Addons).
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2 In theDatabase Addonwindow, select theAllocatable check box tomake an addon cost eligible for
allocation when the estimate information is sent to Job Cost.

NOTE: To actually allocate the addon, select the Allocate addons check box in step 2 of the Job
Cost Exportwizard (in the Sage Estimating software).

3 To send the addon costs to a specific Job Cost cost code and category, click [Job Cost] and select the
Job cost phase and category to receive the addon information.

Figure 14: Selecting a Phase and Category for Job Cost

Export Estimate data to Sage 300 Construction and Real
Estate Job Cost
Use theExport to Job Cost feature in Sage Estimating to send estimate data to Sage 300 Construction
and Real Estate Job Cost:

1 In Sage Estimating, select Interface tab > Job Cost Options > Export to Job Cost (in classic view,
select Interfacemenu > Job Cost).

2 The Job Cost Transferwizard opens. Use the Job Cost Exportwizard to export the following
estimate data:

p Each phase for which you have entered a phase quantity in the spreadsheet.

p Each item category with an amount. The item setup determines whether the transaction includes the
takeoff quantity or order quantity.

p Each addon that is not allocated. The cost of allocated addons is found in the items used to calculate
those addons.

Sage 300 Construction and Real Estate Job Cost Integration
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Figure 15: Job Cost Export Wizard Introduction

3 Click [Next].

Figure 16: Job Cost Export Wizard Step 1

4 Enter (type or click the calendar button next to the Transaction date box) the date to appear on the
transactions contained within the transaction file.

NOTE: TheSage 300 Construction and Real Estate JC job number box displays the job number
entered in theEstimate Informationwindow in Sage Estimating.

5 Click [Next].

6 Select how you want item quantities to be rounded and how to allocate addons.
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Figure 17: Job Cost Export Wizard Step 2

7 Click [Next].

Figure 18: Job Cost Export Wizard Step 3

8 Select theMap estimate information to extras in Job Cost check box if you want to map estimate
information to Job Cost extras.

NOTE: If you do not use extras in Job Cost you do not need to do anything on this tab.
In Job Cost, extras are sub-jobs of themain job. Extras allow you to track cost, revenue, and
commitments separately from themain job, while still being able to accumulate to themain job.
Some reasons youmight need to use extras in Job Cost are:

Sage 300 Construction and Real Estate Job Cost Integration
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p The owner or architect requested additional work after the original contract was signed.

p Youmust track income from certain cost codes separately from themain job.

p Certain costs are billed and tracked separately from themain job.

NOTE: In Job Cost, you can change the name "extra." For information about how to change the name
of this item, refer to "custom descriptions" in the Job Cost in-product Help.

9 If desired, attach information from awork breakdown structure or location to an item as an extra:

a Select theMap estimate information to extras in Job Cost check box.

Each item is mapped to a specific cost code and category in Job Cost using theDatabase Item
window in Sage Estimating. Themapping you enter sends a location or work breakdown structure
(WBS) code to Job Cost as an extra.

In Sage Estimating, WBS codes enable you to attach additional information to each item. EachWBS
code has values underneath it. For example, if you had aWBS code of CSI Phase, the values
underneath that WBS codemight be field supervision, project administration, safety coordination, and
so forth.

NOTE: In Job Cost, theExtra ID entry is limited to 10 characters.

Additionally, you can use a location to relate an item to a specific job area. For example, if you build
an office, youmight want to assign one item to the first floor and another item to the second floor.

b Select theWBS code or location from theSort Level list to send to Job Cost as an extra.

NOTE: When you select a Sort Level, you receive a warning. If you choose a sort level, non
allocatable add-ons will not be exported. Select [Cancel] instead to export all. Also, if you want all
addons included in the export, click [Cancel].

If you select aWBS code for theSort Level, theWBS values area becomes available.

NOTE: If you selected Location as the Sort Level, the name of this area is Location Selection. Its
function is the same nomatter whichSort Level you select.

c UnderWBS values, choose whether to send all WBS values to Job Cost or only selectedWBS
Values.

10 Click [Finish] to export the specified estimate data to Job Cost.

Sage Estimating sends the exported estimate information directly to the Sage 300 Construction and Real
Estate Job Cost New.jct file.
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On-Screen Takeoff Integration
If you useOn-Screen Takeoff (OST) estimating software, you can set OST to interface with Sage
Estimating through theOn-Screen Takeoff Integrator. TheOST Integrator lets you perform takeoff to
estimates in Sage Estimating from drawings you create and store in OST.

Learning About Integration
TheOST software organizes parts andmaterials required for a job into collections known as conditions.
Sage Estimating, however, organizes materials in its databases into individual items and collections
called assemblies. Youmust convert or integrate OST conditions into items and assemblies before you
can create estimates in Sage Estimating throughOST takeoff.

Integration involves three primary steps:

1 Select a condition for takeoff in OST.

2 In the OST Integrator, select a Sage Estimating item or assembly that is comparable or the equivalent of
the OST condition. For example, if you select "Drywall sheeting" for takeoff in OST, find a Sage
Estimating item or assembly that most closely matches the selected drywall sheeting.

3 Note the physical properties of the selected OST condition, such as length or height, and type any
conversion factors as necessary to equate it with the assigned Sage Estimating item or assembly. For
example, if the drywall board length in OST is measured inmeters, and the assigned Sage Estimating
itemmeasures length in feet, type the conversion factor required to equate the two.

Figure 19: Illustration of the Integration Principle

On-Screen Takeoff Integrator Features
Start the OST Integrator from within Sage Estimating by selecting Interface tab > On-Screen Takeoff
group > OST Integrator (in classic view, select Interfacemenu > Open OST Integrator).

Themain window of the On-Screen Takeoff Integrator is divided into three separate panes.
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Figure 20: TheOn-Screen Takeoff Integrator MainWindow

Condition Assignment Pane
The Condition Assignment pane provides a list from which you canmatch or assign items or assemblies in
Sage Estimating with conditions in anOST database.

For example, if you are working with anOST project or drawing that has a condition for 30 square feet of
ceramic floor tile, and the closest equivalent in a Sage Estimating database is the 04-00-10 Masonry, Tile
assembly, select the ceramic floor condition in the list, click the Assign Assembly button , and select
the 04-00-10 assembly to assign it to the ceramic floor condition.

Sage Estimating items and assemblies appear in the list beneath the OST conditions to which they are
assigned.

Condition Properties Pane
The Condition Properties pane displays the physical qualities of any OST condition selected in the
Condition Assignment pane, such as depth, height, or count (number). Youmust "map" these properties to
their Sage Estimating equivalents in the Integration grid when you assign an item or assembly to anOST
condition.

For example, if the selected OST condition has a length of 30 meters as a physical property or dimension,
and the Sage Estimating assembly you assign to it measures length in feet, youmust map the
OST condition's length (using the Integration grid) to the assigned assembly's length and indicate the
conversion factor frommeters to feet.
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Mapping condition properties enables the OST Integrator to create accurate estimates when performing
takeoff from anOST condition.

Integration Grid
Use the Integration grid to "map" or convert the properties of an OST condition to the variable equivalent of
its assigned Sage Estimating item or assembly.

For example, if you are working with a "drywall ceiling" condition from anOST drawing that has a length of
30meters, and you assign the 09-00-10 Drywall assembly from Sage Estimating to it, youmust ensure
the Sage Estimating assembly has a variable equivalent for length in meters.

To beginmapping, select any condition from the Condition Assignment pane that already has a Sage
Estimating item or assembly assigned to it. The grid displays the estimating variables andOST condition
properties associated with the selected condition.

Refer to the OST Integrator in-product Help for information about specific columns in the grid.

Performing Integration
Before integrating OST items and conditions with Sage Estimating items and assemblies, select both an
OST database and a Sage Estimating database you want to use for the integration and takeoff processes.

You can open either aMicrosoft Access-basedOST database or aMicrosoft® SQL Server®-based
OST database for integration. See theOST Integrator Help for more information.

To integrate OST conditions with Sage Estimating items and assemblies:

NOTE: Ensure you open anOST database before performing this procedure.

1 Select a condition for takeoff in OST.

2 In the OST Integrator, click theGoto button to view the selected condition and its associated items
in the Condition Assignment pane of the OST Integrator.

3 In the Condition Assignment pane, expand theOST condition to view any items or assemblies already
assigned to it.

NOTE: You can right-click on any condition and select Expand condition to expand it.

4 Click the assign item button to open the Item Listwindow or the assign assembly button to open
theAssembly Listwindow.
This window lists all available Sage Estimating items or assemblies in the selected Sage Estimating
standard database.

5 Select an item from the list in the Item Listwindow or an assembly from theAssembly List window
and click [OK].
The assigned item or assembly then appears in theCondition Assignment pane beneath the condition
to which you assigned it.

On-Screen Takeoff Integration
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6 The variables associated with the assigned Sage Estimating item or assembly appear in the Integration
grid. The properties associated with the selected OST condition appear in the Condition Properties
pane. Youmust "map" or match one or more condition properties to a Sage Estimating variable:

a For the first variable listed in theEstimating Variable column, select an equivalent condition
property from the list in theCondition Property column.

For example, if the first Sage Estimating variable isWidth, select a width-based condition property
from theCondition Property list.

You can also select a condition property by clicking on a property in theProperty column of the
Condition Properties pane and "dragging" it to theCondition Property column of the Integration
grid.

Figure 21: Mapping Properties

If no equivalent condition property is available, leave theCondition Property column blank.

b If you select a condition property, and a conversion factor is required, type it in theConversion
Factor column.

For example, if the Sage Estimating variable Length is measured in Inches but the condition
property Length is measured in Feet, the conversion factor is 12/1 or 12.

c If you did not select an equivalent condition property in step a, specify the Sage Estimating
variable's value by typing directly in theValue column.

d Repeat steps a-c for each Sage Estimating variable in the grid.

7 Repeat steps 1-6 for eachOST condition you expect to use during takeoff.

8 Click [Save] to save your changes.

Performing One-Time Integration
You can integrate values from anOST condition property with an item or assembly dimension in Sage
Estimating on a one-time basis. You can do this by dragging the OST condition into the dimension grid of
the Item Takeoffwindow, Assembly Takeoffwindow, or Quick Takeoffwindow in the Sage Estimating
software.

For example, if you are taking off an assembly in Sage Estimating that requires theSingle Ply Roof
condition from OST to be added to it, you can select each associated property Value from theCondition
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Property pane in the OST Integrator and "drag" it to theAssembly Takeoff window in Sage Estimating.
TheSingle Ply Roof condition properties are then added to the assembly.

The Sage Estimating items and assemblies retain the OST condition value integration for one takeoff only.
If you want to integrate OST conditions and Sage Estimating items and assemblies for more than one
takeoff, youmust perform the integration in the OST Integrator using the procedure in “Performing
Integration” on page 37.

To perform a one-time integration with a Sage Estimating estimate:

1 In Sage Estimating, open the Item Takeoff, Assembly Takeoff, orQuick Takeoffwindow.

2 In the OST Integrator, open theOST project containing the condition or conditions you want to add to the
estimate.

3 Select the condition you want to add from the Condition Assignment pane of the OST Integrator.

4 From the Condition Properties pane, select the condition property Value that you want to add to the
estimate—for example, the values associated with the "width," "height," or "quantity"—and "drag" it to
the dimension grid of the Item Takeoff window, Assembly Takeoffwindow, orQuick Takeoffwindow
in Sage Estimating.

Figure 22: Selecting a Value for Integration

5 Repeat steps 2-4 to integrate all desired OST conditions with the estimate.

Performing Takeoff to Estimates
After you integrate OST conditions with Sage Estimating items and variables, the OST Integrator allows
you to create estimates in Sage Estimating using conditions and items you take off from OST projects.

To take off OST items and conditions to an estimate:

1 Select an OST project from the list in the Condition Assignment pane.

2 Click the new estimate button to create a new estimate.

Alternatively, you can open an existing estimate by clicking the update estimate button.
If you are creating a new estimate: Type a name for the new estimate in theNew Estimate window;
then specify an estimate database for storing it, a standard database to associate with it (optional), and
the estimate "branch" where you want it displayed then click [OK] to create the new estimate.

On-Screen Takeoff Integration
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If you are opening an existing estimate:Select the existing Sage Estimating estimate from the
estimate list then click [Open] to open it.

TheOST Integrator adds items and assemblies already assigned to conditions in the OST project to the
new or existing estimate. If desired, you open the estimate immediately after creating it.

NOTE: For existing estimates only: If you previously generated items and assemblies from theOST
project to the selected estimate, the OST Integrator deletes the items and assemblies before adding
new ones.

Using Condition Style Libraries
Using the OST software, you can create a library of condition styles that you can then use inmore than
one project. A corresponding condition style library appears in the Condition Assignment pane of the OST
Integrator.

If, for example, you create a condition in anOST project for right-hand doors calledRH Door, you can
choose to save the condition in the OST style library for use in other projects. In the OST Integrator, the
RH Door condition automatically appears in theStyle Library of the Condition Assignment pane.

Figure 23: Condition Styles in the Condition Assignment Pane

After saving conditions as styles in the condition style library, you can assign Sage Estimating items and
assemblies to them in the OST Integrator (see “Performing Integration” on page 37 for instructions).

You can then use the integrated condition styles in future projects whenever they are required.

You can create and edit condition style libraries only in On-Screen Takeoff.

NOTE: EachOST database has only one condition style library.
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Importing and Exporting Condition Assignments
You can import and export integrated condition assigments in extensible markup language (XML) files.
Use this feature when you want to transfer integrated condition assigments from a Sage Estimating
standard database in one location to a standard database in another location.

For example, if you assign OST conditions to Sage Estimating items and assemblies in a standard
database on your local computer, and you want to integrate those same assignments into another
standard database (such as a shared standard database on a server, for example), export the integrated
conditions to file then import them into the shared database.

To export assignments to a file
1 In the OST Integrator, open the standard database containing the assignments you want to export.

2 Select Import/Export group > Export the assignments to a file (in classic view, select File >
Export).

3 Type a file name for the export file in the File Name box and browse to the location where you want the
file saved.

4 Click [Save].

TheOST Integrator saves the condition assignments to an XML file (.osti extension) that you can import
later.

To import assignments to a file
1 In the OST Integrator, open the standard database where you want the condition assignments imported.

NOTE: The target standard database you select must have the same items and assemblies as those in
the .osti file or an error results during import.

2 Select Import/Export group > Import an assignments file (in classic view, select File > Import).

3 Select the import file containing the assignments you want to import (.osti extension).

4 Click [Yes] at the prompt.

CAUTION: TheOST Integrator overwrites all current condition assignments in the standard
database when you import the assignments from file.

5 Right-click on the OST database in the Condition Assignment pane and select Change the Database
Path.

6 Browse to the location of the OST database containing the integrated conditions click [Open] to update
its location relative to the imported condition assignments.

On-Screen Takeoff Integration
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