This is a publication of Sage Software, Inc.

Copyright © 2013. Sage Software, Inc. All rights reserved.

Sage, the Sage logos, and the Sage product and service names mentioned herein are registered trademarks or trademarks of Sage Software, Inc. or its affiliated entities. All other trademarks are the property of their respective owners.

Microsoft ©SQL Server®, Windows Vista® and the Windows logo are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or in other countries.

The names of all other products and services are property of their respective owners.

Your use of this document and the Sage product(s) described herein is governed by the terms and conditions of the Sage End User License Agreement ("EULA") or other agreement that is provided with or included in the Sage product. Nothing in this document supplements, modifies or amends those terms and conditions. Except as expressly stated in those terms and conditions, the information in this document is provided by Sage "AS IS" and Sage disclaims all express, implied or statutory warranties of any kind, including but not limited to the warranties of merchantability, fitness for a particular purpose or of non-infringement. No implied license is granted to you under any Sage intellectual property or trade secret right. Sage reserves the right to revise, supplement or remove information in this document at any time without notice to you or others.

Sage End User License: http://na.sage.com/sage-na/eula
Contents

Chapter 1—Introduction ............................................................................................................. 1
  Available Options for Sage Estimating .................................................................................. 1
  Read the Supporting Documentation Before You Begin ....................................................... 1
  Conventions Used in this Document ...................................................................................... 2
    Symbols ............................................................................................................................. 2
    Menu Paths ...................................................................................................................... 2
    Online Help ....................................................................................................................... 2
    Training .............................................................................................................................. 3
    Technical Assistance ......................................................................................................... 3
    Submitting Enhancement Requests .................................................................................. 3

Chapter 2—Means Integrator ..................................................................................................... 4
  Overview ............................................................................................................................... 4
  Means Integrator Workflows ................................................................................................ 5
    Step One: Prepare Database .............................................................................................. 5
    Step Two: Select Data ....................................................................................................... 6
    Step Three: Select Pricing ............................................................................................... 6
    Step Four: Select Options ............................................................................................... 6
    Step Five: Finish ............................................................................................................. 6
  Help and Information ............................................................................................................ 7

Chapter 3—License Manager .................................................................................................... 8
  License Management Components ....................................................................................... 8
  Work With Commuter Licenses ............................................................................................ 9
  Check Out Licenses ............................................................................................................. 9
  Check In Licenses ............................................................................................................... 10
  Monitor Licenses ............................................................................................................... 11
  Environment Variables ...................................................................................................... 12
  Valuable Environment Variables ....................................................................................... 12
Chapter 4—Sage 300 Construction and Real Estate Job Cost Integration ........................................21
Overview .........................................................................................................................21
Setup Guidelines .............................................................................................................22
   Sage 300 Construction and Real Estate Job Cost ......................................................22
   Sage Estimating ........................................................................................................22
Prepare Sage 300 Construction and Real Estate Job Cost to Receive Estimates ..........22
Prepare Sage Estimating to Send Estimates .................................................................23
   Enable the Job Cost interface ...................................................................................23
   Verify standard database phase settings .................................................................24
   Verify standard database item settings ...................................................................26
   Verify standard database addon settings ...............................................................28
Export Estimate data to Sage 300 Construction and Real Estate Job Cost ..................29

Chapter 5—On-Screen Takeoff Integration .................................................................33
Learning About Integration ..........................................................................................33
On-Screen Takeoff Integrator Features ..........................................................................33
   Condition Assignment Pane ....................................................................................34
   Condition Properties Pane ....................................................................................34
   Integration Grid .......................................................................................................35
Performing Integration .................................................................................................35
Performing One-Time Integration ..............................................................................36
Chapter 1—Introduction

Sage is pleased to provide you with multiple options for expanding Sage Estimating’s capabilities and features. Read the applicable chapters in this manual to learn more information about your Sage Estimating options.

Available Options for Sage Estimating

The following options are available for Sage Estimating:

- **RS Means Integrator.** The RS Means Integrator lets you add RS Means item pricing databases to your Sage Estimating software. Using the RS Means Integrator, you can also update your Means price databases on a recurring basis.

- **On-Screen (ePlan) Takeoff Integrator.** The On-Screen Takeoff (OST) Integrator lets you perform item and assembly takeoff in Sage Estimating from drawings you create in On-Screen Takeoff.

- **License Manager.** License Manager provides a means for managing licensing for Sage Estimating operators. Installation and configuration instructions are found in chapter three of the *Installation Guide*. Read this manual for License Manager operating instructions.

Read the Supporting Documentation Before You Begin

Be sure to read supporting documentation before you install and configure your Sage Estimating options:

- This *Options Guide* provides installation, setup, and operating instructions for each of the available Sage Estimating options, such as the OnScreen Takeoff Integrator or License Manager.

- The *Installation & Administration Guide* includes an overview of the latest Sage Estimating release, installation instructions, system requirements, and contact information. This document is available in the Documents folder of your Sage Estimating installation files.

- The *Release Notes* provide details about new features, database changes, known issues, and fixes. This document is available in the Documents folder of your Sage Estimating installation files.

- The *Getting Started Guide* provides an operational overview of the Sage Estimating software. This document is available in the Documents folder of your Sage Estimating installation files.

- The *SQL Server Guide* gives you an overview of the significant differences between the new SQL Server databases and the Pervasive databases used in previous Sage Estimating releases. This document is available in the Documents folder of your Sage Estimating installation files.

These documents are current at the time of the release. To learn about issues that have arisen since this document was published, go to [www.sagecre.com](http://www.sagecre.com).
Conventions Used in this Document

This document uses the following conventions:

- Information you type into the software is shown in bold font. For example: Type Miscellaneous in the box.
- The names of screens, windows, fields, and other features displayed by the software are shown in bold font.
- The names of buttons you can click are enclosed in brackets with bold font. For example: [OK] or [Post].
- Names of keys are shown in capital letters. For example: ENTER or TAB. A plus sign (+) between two key names indicates you should press the keys simultaneously.
- Variable names or names that are specific to your installation may appear in italics and brackets. For example: [Drive]\[Server].

Symbols

NOTE: This symbol is used when presenting information that is supplemental to the adjacent text.

TIP: This symbol is used when presenting helpful information for using the software.

CAUTION: This symbol is used when presenting important information to help you avoid a loss of critical data.

IMPORTANT: This symbol is used when presenting information that is critical to understand or that requires you to take action.

Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with angle brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Online Help

The Sage Estimating software includes online Help, which provides answers to your questions about procedures as well as items in the windows.

To access the online Help in the Sage Estimating software, click the Help button or icon, or press [F1] to display the Help topic for that window.

To aid you in finding the information you need, the online Help for each module includes the following panes:

- Contents pane containing links to the Help topics
Index pane containing keywords that link to Help topics related to that keyword

Search pane, where you can type text and click [Search] to locate that text in the Help topics

For more information about using the online Help, see the Sage Estimating Help.

We would like your feedback about the online Help so we can make improvements. Each Help topic contains an area where you can indicate whether the topic was helpful and provide additional comments. To protect your privacy, all comments are anonymous.

Training

Sage University offers online and classroom training sessions to help you get the most out of your Sage Estimating software. To access Sage University, visit www.sageu.com.

You can also get access to Sage University from the File menu by selecting Help > Sage Estimating on the Web > Sage University.

Technical Assistance

When you need assistance, refer to the Knowledgebase article How do I get technical support for Sage Estimating? to determine which service works best for you.

Submitting Enhancement Requests

We want to hear your suggestions for improving the software. To send us your comments, click the File menu button and select Help > Sage Estimating on the Web > Submit Enhancement Requests.
Chapter 2—Means Integrator

Sage Estimating offers Means Integrator cost data files that you can use to create, extend, or update item costs in your Estimating Standard databases with current costs for corresponding items in the RSMeans Cost Data Books. If you use RSMeans cost data in your estimates, read this chapter for instructions on updating the following Estimating Standard databases:

- **Construction Knowledgebase.** The Construction Knowledgebase is a Sage Estimating Standard database that contains Means items and other data. You can use the Building and Construction Cost Data (BCCD) Means cost data file to update prices in this database.
- **Residential Knowledgebase.** The Residential Knowledgebase is a Sage Estimating Standard database that contains Means items and other data. You can use the Residential Cost Data Prices (DB1-20) Means cost data file to update prices in this database.
- Any Estimating Standard databases that were created or extended using Means cost data files.

**Overview**

The Means Integrator cost data files correspond to the RSMeans Cost Data Books you receive with your shipment.

With Sage Estimating Means Integrator, you can create or extend Estimating Standard databases with items that match those in the RSMeans Cost Data Books. You can also update prices for your existing Estimating Standard databases that contain RSMeans items.

1. Install or upgrade to Sage Estimating version 14.11 if you do not already have it installed on your computer.
2. Insert the Means installation CD into the CD drive of the workstation or server where Sage Estimating is installed.
3. From the installation browser:
   b. Click [Browse], and then browse to the server or workstation where you want to store your Means Integrator cost data files.
   c. Select the check box next to each Means Integrator cost data file you want to install, and then click [Install].
4. After the installation is finished, start the Means Integrator by clicking Start > All Programs > Sage > Sage Estimating 14.11 > Sage Means Integrator 14.11. (In Windows 8, select Start > All apps > Sage > Means Integrator.)
5. Follow the steps through the Means Integrator wizard.
**Means Integrator Workflows**

Integrating your RSMeans Cost Data is a five-step process.

**Step One: Prepare Database**

In the Means Integrator wizard **Prepare Database** window, you can select whether to transfer data or update data. The following information describes the outcome of these options.

**Transfer Data**

Select **Transfer Data** if you want to move RSMeans items to a new or existing Sage Estimating database.

- **Transfer Data—New Database**
  
  Select this option to create a new Sage Estimating Standard database and populate it with all of the RSMeans items.

  **NOTE:** You cannot set job cost interface specifications for a new Standard database using this option. You must first create a new Standard database, set up job cost specifications (such as phase suffix and company), and then transfer RSMeans data to the new database using the **Existing Database** option in this window. See the Means Integrator Help for more information.

- **Transfer Data—Existing Database**
  
  Select this option when you want to transfer the Means items to an existing Sage Estimating Standard database.

  If you select this option, the Means Integrator transfers the RSMeans items directly to the selected Sage Estimating Standard database. The resulting database will contain both your existing phases and items and the RSMeans phases and items.

  **NOTE:** Addition of RSMeans phases and items could cause your phase sort to appear differently in Sage Estimating if the RSMeans items have a different phase format than those already in the Standard database.

If you are transferring RSMeans Cost Data to a new database, also select a company to associate with the data, then specify the length of the normal work periods and the default crew pricing method. Sage Estimating displays the specified information in the **Database Settings** window whenever you open the database.

**Update Data**

Select **Update Data** if you need to update the prices of RSMeans items in an existing Sage Estimating Standard database.

If you want to update RSMeans items in a Standard database created using an earlier version of Sage Estimating (such as Sage Estimating 9.8 or 13.1), ensure you migrate your data to Sage Estimating version 14.11 before performing this update in Means Integrator.

**Selecting Means Integrator Cost Data Files**

To select the Means Integrator cost data files:
1. Click the [Browse] button, and then navigate to the folder where you installed the Means Integrator cost data files.

2. Select the file or files you want to use.

You can use the [Browse] button again to add files to the selection.

Use the [Remove] button to remove files from the selection.

See the Installation and Administration Guide for data migration instructions.

[NOTES:]

- Items in the Means Integrator cost data files use Master Format 2012 (MF12) coding, which is compatible with the previous MF10 and MF04 formats.

**Step Two: Select Data**

Select the RSMeans divisions and items that you want to update in or transfer to your selected Sage Estimating Standard database.

You can select items and divisions individually or select all available items and divisions at one time.

**Step Three: Select Pricing**

Select whether to use RSMeans national average pricing for item pricing or base item pricing on a regional cost index.

- If you choose to use the **RSMeans Standard National Average Pricing** option, the Means Integrator uses the RSMeans standard national average as the base price for each item during the integration. The Means Integrator then imports any city cost indexes associated with the RSMeans items so you can use them later with the Sage Estimating Cost Index feature.

- If you select the **RSMeans City Cost Index** option, the Means Integrator calculates and sets item pricing based on the region you specify in the State and City boxes. It does not import any city cost index information for use in Sage Estimating.

**Step Four: Select Options**

Select a variety of options to apply to the database, including pricing options (Crew, Hourly, or Unit), audit report options, and what to do with any duplicate items.

**Step Five: Finish**

Review the summary information and click [Finish] to transfer or update the selected database with RSMeans information.

You can make changes as necessary by clicking [Back] and editing the desired information.
Help and Information

The Means Integrator contains updated Help to assist you in converting and updating your databases. To use Help, click [Help] from the Means Integrator.
Chapter 3—License Manager

License Manager tracks and updates network licenses for Sage Estimating. Use License Manager to share pools of licenses between operators on the network. For example, if you have seven estimators who are connected to the network and you own five network licenses for Sage Estimating, up to five of the seven estimators can use the software concurrently.

After a few installation steps, License Manager works behind the scenes to manage concurrent uses for Sage Estimating.

Read this chapter to learn how to manage licenses, use environment variables, and troubleshoot any issues that you may encounter. For instructions on installing and configuring License Manager, see the Installation & Administration Guide in the Documents folder of your Sage Estimating setup and installation files.

License Management Components

The following table describes the components required to install and manage Sage Estimating licenses.

The Documentation column lists sources for component-use information.

Table 1: Required License Manager Components

<table>
<thead>
<tr>
<th>Component</th>
<th>Function</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Manager</td>
<td>Tracks program uses on the network</td>
<td>These files are in the Documents folder of your Sage Estimating setup and installation files:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Installation and Administration Guide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Sage Estimating Options Guide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This file is in the AdditionalInstalls\LicenseManager\SysAdmin Help folder of your Sage Estimating setup and installation files.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Sentinel License Manager System Administrator Online Help (Default.html).</td>
</tr>
<tr>
<td>Component</td>
<td>Function</td>
<td>Documentation</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
<td>---------------</td>
</tr>
</tbody>
</table>
| License Manager protection device | Attaches to the USB port of the server hosting License Manager. It is a security device that authorizes License Manager to distribute licenses. | Sentinel License Manager System Administrator Online Help  
*Installation and Administration Guide*  
*Sage Estimating Options Guide* |
| License Tools | Perform tasks, such as check licenses in and out (WCommute.exe); check licenses in and out remotely (Wrcommute.exe); test the protection device (Wechoid.exe); and monitor licenses (Wlmadmin.exe). | Sentinel License Manager System Administrator Online Help  
*Sage Estimating Options Guide*  
*Sage License Manager System Administrator Online Help (index.html).* |
| Sentinel driver | Allows communication between License Manager and the License Manager protection device. | Sentinel License Manager System Administrator Online Help |

**NOTE:** Due to changes in software environments, some options in Sentinel License Manager System Administrator Online Help may not be supported. Please contact Customer Support if you experience issues viewing the License Manager System Administrator Online Help.

## Work With Commuter Licenses

Commuter licenses allow you to start estimating products in a stand-alone environment (no network connections, no protection device). While you are connected to the network, use Commuter License Manager (*WCommute.exe*) to check licenses in and out from the license manager in order to make them available when you are not connected to the network.

**NOTE:** If you have an unexpired commuter license, you do not need a protection device.

## Check Out Licenses

1. From the workstation or notebook computer you will use when disconnected from the network, select  
   **Start** > **All Programs** > **Sage** > **Sage Estimating** > **License Manager** > **Commuter License Manager**.

   If this menu option is not available to you, you can start the program by browsing to `\Additional Installs\License Manager\Admin.Net\Wcommute.exe` in your Sage Estimating setup and installation files.

2. From the **File** menu, select **Search Subnet**.
3 From the list of programs with available licenses, select the program that you want to check out.

**NOTE:** The list displays one line for each program that is available. If you want to see the status of all licenses, use WlmAdmin. For more details, see “Monitor Licenses” on page 11.

4 Enter the number of days (1 to 180) that you will need the license.

5 Click [Check Out]. You will see a red check mark next to the program that you just checked out.

6 Repeat this process to check out licenses for all the programs that you will need while you are disconnected from the network.

7 When you finish, close the Commuter Licensing window.

### Check In Licenses

You can check licenses in before or after their time limits expire so that they are available for others.

1 When you are once again connected to the network, select Start > All Programs > Sage > Sage Estimating > License Manager > Commuter License Manager.

   If this menu option is not available to you, you can start the program by browsing to ```\Additional Installs\License Manager\Admin.Net\Wcommute.exe``` in your Sage Estimating setup and installation files.

2 From the *File* menu, select *Search Subnet*. A list of programs with licenses appear.

   - Programs with checked out licenses appear in the list with a red checkmark.
   - Programs with licenses that have expired appear in the list with a red “x.”

3 From the list of licenses, select the program for which you want to check in a license and click **[Check In]**.
4 When you finish, close the Commuter Licensing window.

Monitor Licenses

The WlmAdmin program is a monitoring tool used to check the number of licenses, confirm how many are in use, check the status, and see who is using the licenses. It is useful for determining why a license manager or available license cannot be found. WlmAdmin allows you to view:

- A list of licensed programs.
- The names of the users (if any) who are currently using the licenses.
- The total number of licenses purchased for each program. (WlmAdmin refers to programs as “features.”)

To start WlmAdmin, select Start > All Programs > Sage > Sage Estimating > License Manager > LM Admin.

If this menu option is not available to you, you can start the program by browsing to \Additional Installs\License Manager\Admin.Net\WlmAdmin.exe in your Sage Estimating setup and installation files.

Figure 2: The WlmAdmin Window

The WlmAdmin window has the following features:
The left pane shows a list of all licensed programs. For example, PWX-ENU identifies Sage Estimating. Double-click on a program to expand it and view the names of those who currently have licenses checked out.

The right pane shows details about the selected program (for example, the total number of licenses available and the number of licenses in use).

**Environment Variables**

In certain circumstances, you may need to use an environment variable to resolve one of the messages outlined in Section 3. For example, if you use multiple license managers to run other programs, you may want to specify which license manager to use when obtaining available estimating licenses. For instructions on setting these variables, see "How to Set Environment Variables" on page 12.

**Valuable Environment Variables**

**LSFORCEHOST**

This variable is a valuable troubleshooting tool to use when license acquisition issues arise. The variable can be used to direct client stations to a specific License Manager server. If that license manager is not found, the program stops searching and returns an error message; it does not check every computer on the network for a license server.

**LSPROTOCOL**

This variable allows you to match the communications protocol of the license manager and the client. Because you must be certain that the license manager and the client both use the same protocol, LSPROTOCOL is especially helpful in multi-protocol environments. For example, if the license manager uses only IPX and the client uses IPX and TCP, you would use LSPROTOCOL to set the client to IPX. The value to set for IPX/SPX is IPX. The value for TCP/IP is UDP.

**LHOST**

This variable is used when you want the client to search from a list of potential servers. If none of those servers are found, the client looks to the network for any license server. For a complete list of environment variables with more detail, see Sentinel LM System Administrator Help, located in the Sage Estimating setup and installation files at \AdditionalInstalls\LicenseManager\SysAdminHelp\index.html.

**NOTE:** Due to changes in software environments, some options listed in Sentinel LM System Administrator Help may not be supported. Please contact Customer Support for more information.

**How to Set Environment Variables**

You should configure environment variables properly for your network. For more information, see Sentinel LM System Administrator Help, located in the Sage Estimating setup and installation files at \AdditionalInstalls\LicenseManager\SysAdminHelp\index.html.

**To Set LSFORCEHOST or LHOST**

1. Determine the IP address or name of the computer that hosts License Manager.
To determine the IP address of the computer, type `ipconfig` at a command prompt.

To determine the name of the computer:

- **In Windows 7:** Select Start > Control Panel > System and Security > System.
- **In Windows 8:** Select Start > All apps > Windows System > Control Panel > System and Security > System.

2 Set environment variables:

- **In Windows Vista and Windows 2008 Server:** Select Start > Control Panel > System and Maintenance > System > Advanced tab, [Environment Variables].
- **In Windows 7:** Select Start > Control Panel > System and Security > System > Advanced System Settings > Advanced tab, [Environmental Variables].
- **In Windows 8:** Select Start > All apps > Windows System > Control Panel > System and Security > System > Advanced System Settings > Advanced tab, [Environmental Variables].

3 Select [New] under System variables (to avoid creating a user variable).

*Figure 3: Setting the LSFORCEHOST Variable*

4 In the **Variable Name** box, type the variable LSFORCEHOST or LSHOST.

5 In the **Variable Value** box, type the value. The value should be either the static IP address or the name of the computer.

6 When you finish, click [OK].

7 Restart your computer for these changes to take effect.

**To Set LSPROTOCOL**

1 Set environment variables:

- **In Windows Vista and Windows 2008 Server:** Select Start > Control Panel > System and Maintenance > System > Advanced tab, [Environment Variables].
- **In Windows 7:** Select Start > Control Panel > System and Security > System > Advanced System Settings > Advanced tab, [Environmental Variables].
- **In Windows 8:** Select Start > All apps > Windows System > Control Panel > System and Security > System > Advanced System Settings > Advanced tab, [Environmental Variables].

2 Select [New] under System variables (to avoid creating a user variable).
3 In the Variable Name field, type the variable LSPROTO\_COLL.  
4 In the Variable Value field, type the appropriate protocol. 
5 The value to set for IPX/SPX is IPX. The value for TCP/IP is UDP.  
6 When you finish, click [OK].

**Error Messages**

When a program cannot find a workstation protection device or an available network license, you may receive one of the following error messages. Use the information in this section to resolve the issue.

"A network error occurred"

A network error usually means that the workstation is not attached to the network. To resolve this message, make sure that the workstation is attached to the network (browse to the computer on which License Manager is installed); then try again to start a program.

You may also receive this message because neither TCP/IP nor IPX/SPX protocols are installed. To resolve the issue, verify that License Manager is installed on a Windows-based operating system. (You can use License Manager on a network with a Novell server and Windows workstations, provided it is installed on one of the Windows workstations.) Also, verify that the License Manager computer and the workstations contacting it are using the same communications protocol (TCP/IP or IPX/SPX).

If any of the workstations contacting License Manager have both TCP/IP and IPX/SPX installed and the License Manager computer has only IPX/SPX installed, set the LSPROTO\_COLL to IPX on those workstations. For more information on how to do this, see "Environment Variables" on page 12. After you set the environment variable, try again to start the program.

If you still cannot resolve the message, contact your network administrator.

"All licenses are in use"

This message indicates that network licenses for the program were found, but all of the licenses were in use. To resolve the issue:

1 Use WImAdmin to verify this information (see "Monitor Licenses" on page 11).
2 Try to start the program again when a license is available.
3 If you need additional licenses, contact your business partner.

"Cannot acquire a license"

This message means that either an incompatible version of the program is installed or License Manager is installed incorrectly. To resolve the issue:

1 Verify that you used the default installation path when you installed License Manager (C:\Program Files \x86\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\WinNT).
2 If you installed it to another location, verify that License Manager was installed to a local drive. It cannot be installed to a network drive.
3 Make sure that the most recent program versions are installed.
4 Verify that the correct version of the Sentinel protection device driver is installed and running (see “Chapter 3—License Manager” following this section).
5 Test the protection device (see “Testing the protection device” on page 18). If a device is not found, try setting the parallel port mode to nonbidirectional, standard, SPP, or normal in the BIOS.
6 Try removing and then reinstalling License Manager to the server.

NOTE: Before you remove License Manager, you must stop the License Manager service.

Checking the Sentinel protection device

To check the Sentinel Protection Device:

1 Start the Device Manager, as follows:
   - In Windows 7: Select Start > Control Panel > System and Security > System > Device Manager.
   - In Windows 8: Select Start > All apps > Windows System > Control Panel > System and Security > System > Device Manager.
2 From the View menu, select Show hidden devices.
3 Expand Non-Plug and Play Drivers in the list. Double-click Sentinel, and select the Driver tab.
   NOTE: If Sentinel does not appear in the list, install the correct version of the Sentinel driver for your operating system (see the Installation & Administration Guide available on the Documents folder of your Sage Estimating setup and installation files).
4 Under the Current Status verify that the status is started; if not click [Start].

"Error: Sentinel error 8. Cannot return the token or feature XXX-ENU."

This error appears when a server has two network interface cards (NICs) installed and enabled. The dual network interface cards cause License Manager to check licenses out to one IP address and try to check
them in to another. To resolve this issue, remove License Manager and then install it to a workstation that does not have dual network interface cards.

To remove License Manager

1. From the workstation, verify that no commuter licenses currently checked out; they must be checked in before you remove License Manager. Use WlmAdmin to verify that all licenses are checked in. (Start WlmAdmin from Start > All Programs > Sage > Sage Estimating > License Manager > LM Admin). If this menu option is not available to you, you can start the program by browsing to \Additional Installs\License Manager\Admin.Net\WlmAdmin.exe in your Sage Estimating setup and installation files.

2. From the server, stop the License Manager service.
   - In Windows Vista and Windows 2008 Server: Select Start > Control Panel > System and Maintenance > Administrative Tools; then click Services. Select Sentinel LM, right-click, and then click [Stop].
   - In Windows 7: Select Start > Control Panel > System and Security > Administrative Tools > Services. Select Sentinel LM, right-click, and then click [Stop].
   - In Windows 8: Select Start > All apps > Windows System > Control Panel > System and Security > Administrative Tools > Services. Select Sentinel LM, right-click, and then click [Stop].

3. Remove the service.
   - In Windows Vista and Windows 2008 Server, and Windows 7: Select Start > Control Panel > Uninstall a program (under Programs). Scroll down to SentinelLM Server 8.1.0; right-click and click Uninstall.
   - In Windows 8: Select Start > All apps > Windows System > Control Panel > Uninstall a program (under Programs). Scroll down to SentinelLM Server 8.1.0; right-click and select Uninstall.

4. In Windows Explorer, browse to C:\Program Files\Common Files\SafeNet Sentinel\Sentinel LM Server\WinNT; select the folder and then delete it.

5. Restart your computer.

To install License Manager

See chapter three of the Installation and Administration Guide available on the Documents folder of your Sage Estimating setup and installation files for instructions.

"No servers running on this subnet"

Both the license manager and its clients must be in the same subnet, or you must use LSFORCEHOST. If you start WlmAdmin and no license managers are found, you may have a connection barrier (see "Monitor Licenses" on page 11 for more information on running WlmAdmin).

To resolve the issue:

1. Verify that the workstation is attached to the network (browse to the computer on which License Manager is installed).
2 If you cannot browse to the computer and you use TCP/IP, ping that license manager (see “Using the Ping utility” on page 17 following this section).

The ping utility sends four communications packets to the target computer. If received, the four packets are sent back to the source computer. The round trip process is timed to benchmark communication performance.

3 Start WlmAdmin from the license manager. You should see the computer’s host name, the IP or IPX address, and what licenses (if any) have already been installed.

4 If none of the above helps resolve the issue, contact Customer Support.

Using the Ping utility

To use the Ping utility:

1 Determine the IP address or name of the computer that hosts License Manager.

2 To determine the IP address of the computer, type `ipconfig` at a command prompt.

   To determine the name of the computer:

   - **In Windows Vista and Windows 2008 Server:** Select Start > Control Panel > System and Maintenance > System.
   - **In Windows 7:** Select Start > Control Panel > System and Security > System.
   - **In Windows 8:** Select Start > All apps > Windows System > Control Panel > System and Security > System.

3 From the command prompt on the client workstation from which you want to test communications, type `ping` and the name or address of the computer on which License Manager is installed and running (for example, type `ping 192.168.40.193`). Make sure to type a space after the word `ping`.

4 Examine the ping results to determine whether there is a connection barrier:

   *Figure 5: Ping Results*
Chapter 3—License Manager

- **IP Address**: The IP address should be static and match the address you retrieved with Ipconfig. If the IP address is different, the name resolution processes will not work. Use the computer name instead to ping the computer where License Manager is installed.

- **Packets Sent and Received**: All four packets that were sent should have returned successfully. If packets were lost, this is an indicator of failing network hardware or a situation in which a high level of packet collisions occur, possibly due to overloaded hardware. Contact your local system administrator to resolve this issue.

"Unable to install license code…"

This message continues with the name of the license code and this statement: “The code is invalid, already loaded in the license server, or the license server is not running.” The message may also mean that License Manager is running but cannot be found by the installer program. To resolve the issue:

Be sure the code was entered exactly as it appears on the packing slip or in the *.lic file (license codes are not case sensitive). Reenter the code if necessary.

1 Run LM Admin to verify that License Manager is actually running.
   You cannot enter a license code unless License Manager is running. You can also check to see if the SentinelLM service is started:

   - **In Windows 8**: Select Start > All apps > Windows System > Control Panel > System and Maintenance > Administrative Tools > Services.

2 Search for the LSERVRC file and open it with a text editor, such as Notepad, to see whether the code has already been installed or entered.

3 All license codes in LSERV will have # as their last character. You may also use LM Admin to view the installed license codes ("Monitor Licenses" on page 11).

4 Use the LSPROTOCOL environment variable to set the communication protocol (IPX/SPX or TCP/IP) to match that of the license manager. For more information, see "Environment Variables" on page 12.

If you still cannot resolve the message, remove the protection device, restart the computer, and then try to reinstall the license code. If this works, use the following procedure to determine whether you have a bad device, in which case you should contact Customer Support.

**Testing the protection device**

To test the protection device:

To verify that the License Manager protection device is being detected, run Wechoid.exe from the computer on which License Manager and the protection device are installed. Wechoid is a utility you can use to determine the locking code of a License Manager server.

1 Locate and then double-click Wechoid.exe. It can be found at \AdditionalInstalls\LicenseManager\Admin.net in your Sage Estimating setup and installation files.

2 In the Wechoid window, clear all check boxes except Computer ID.

3 Under Locking Data, confirm the following:
Selector: 0x80
Code: 0x1FB03

If any other information appears, the device cannot be found or is not working.

Figure 6: The Wechoid Window

4 Click [OK] to exit. (It is not necessary to reselect the check boxes.)

"Unable to locate a protection device or obtain a license for this application/feature"

Make sure that the driver is installed (for more information on the driver, see the Installation and Administration Guide available on the Documents folder of your Sage Estimating setup and installation files). If you are not connected to the network, be certain that you have either a workstation protection device securely attached to your computer's USB or parallel port or an unexpired commuter license. Try running the program again.

If you receive this message and you are connected to the network, one of the following may be true:

- License Manager is not running on your network. To resolve the issue, use WlmAdmin (see "Monitor Licenses" on page 11) to verify that License Manager is running on your network. If License Manager has been installed but is not currently running, that computer and its features will not appear in WlmAdmin.

To start License Manager, do the following:
Chapter 3—License Manager

- **In Windows Vista and Windows 2008 Server**: Select Start > Control Panel > System and Maintenance > Administrative Tools > Services; then select SentinelLM, right-click, and click [Start].
- **In Windows 7**: Select Start > Control Panel > System and Security > Administrative Tools > Services. Select Sentinel LM, right-click, and then click [Start].
- **In Windows 8**: Select Start > All apps > Control Panel > System and Security > Administrative Tools > Services. Select Sentinel LM, right-click, and then click [Start].

License Manager may not be installed. Install License Manager if you determine that it has not already been installed (see the *Installation and Administration Guide*, available in the Documents folder of your Sage Estimating setup and installation files).

The network may have timed out while trying to locate License Manager. To resolve the issue, you can use the LSFORCEHOST environment variable (see "Environment Variables" on page 12) to select a specific license manager. After you set the variable, try to start the program again.

You may have a bad protection device (see "Testing the protection device" on page 18).

"You do not have a license for the application you are trying to run"

This message may indicate that:

- No license codes were installed. Use WlmAdmin (see "Monitor Licenses" on page 11) to check whether the license codes were installed. The message “No licenses installed on this server!” indicates that you must install the license codes (see the *Installation and Administration Guide* available on the Documents folder of your Sage Estimating setup and installation files). Install the license codes then try again to start the program.

  If you determine that you do not have a license for the program you are trying to use, contact your business partner to obtain a license.

- You have multiple license managers and the program found the wrong license manager. To resolve the issue, use the LM Admin program to display license manager information (see "Monitor Licenses" on page 11).

  If you determine that you have multiple license managers, you can use the LSFORCEHOST environment variable to select a specific license manager (see "Environment Variables" on page 12). After you set the environment variable, try to start the program again.

"Your commuter license for this application/feature has expired"

Use Commuter License Manager to check in or renew your commuter license. For details, "Chapter 3—License Manager" on page 8.
Chapter 4—Sage 300 Construction and Real Estate Job Cost Integration

If you use Sage 300 Construction and Real Estate Job Cost, you can transfer estimate information directly into your job costing application. This allows you to access budget and transaction data without reentering the information. This section covers the interface between Sage Estimating and Sage 300 Construction and Real Estate Job Cost, which enables the information transfer.

Overview

When Sage Estimating sends estimate information to Sage 300 Construction and Real Estate Job Cost, it sends the information directly to the Job Cost application’s New.jct file. Sage 300 Construction and Real Estate Job Cost can then access the estimate data without having to import it first.

Figure 7: The Sage Estimating-Job Cost Interface

For detailed information about Job Cost concepts, see the in-product Help in Sage 300 Construction and Real Estate Job Cost.
Setup Guidelines

To help ensure a smooth data transfer between Sage Estimating and Job Cost, follow these guidelines:

**Sage 300 Construction and Real Estate Job Cost**

Before you export data from Sage Estimating, ensure that in Job Cost:

- Standard cost codes exist for each cost code sent from Sage Estimating.
- If you use categories, standard categories exist for each category sent from Sage Estimating.
- Operators working with estimate data have the appropriate security permissions for the following:
  - Job Cost Enter Estimates or Import tasks
  - File access (to the .jct file)
  - Company security
  - Job record security

**Sage Estimating**

Before you create an estimate to send to Job Cost, make sure the database settings for phases, items, and addons are set up correctly for your needs. Any changes made to these settings after an estimate is created do not affect existing phases, items, or addons. Existing phases, items, and addons must be changed individually if you want the new settings to be reflected in Job Cost.

Before you send estimate information to Job Cost, ensure that:

- Database Phase settings are mapped to the desired Job cost phase.
- Database Item settings are mapped to the desired Job Cost Phase and Job Cost Category.
- Database Addon settings are mapped to the correct Job Cost Phase and Category.
- The BOM description for the items are 30 characters or less. Job Cost can only accept up to 30 characters for the bill of materials description.

**Prepare Sage 300 Construction and Real Estate Job Cost to Receive Estimates**

You must verify two items in Sage 300 Construction and Real Estate Job Cost to successfully transfer estimate information from Sage Estimating:

- **All needed standard cost codes are set up.** To see a list of standard cost codes that are already set up in Job Cost, from the Job Cost Reports menu, select Lists > Standard Cost Codes. If you do not see a cost code that you know exists in the estimate or estimates, select Setup > Standard Cost Codes to set up the standard cost code.
Standard categories are set up (if your company uses categories). Using categories is optional. If you do not use categories, you do not need to verify that they exist. To see a list of standard categories that are already set up, from the Job Cost Reports menu select Lists > Standard Categories. If you do not see a standard category listed that you know exists in the estimate or estimates, select Setup > Standard Categories to set up that category.

Prepare Sage Estimating to Send Estimates

Perform the following tasks in the Sage Estimating software to send estimate information to Sage 300 Construction and Real Estate Job Cost.

- Enable the Job Cost interface.
- Verify standard database phase settings.
- Verify the standard database item settings.
- Verify the standard database addon settings.

Enable the Job Cost interface

Set up standard databases individually to interface with Sage 300 Construction and Real Estate Job Cost by enabling the interface in the Sage Estimating Estimating Management Console:

1. Click on the Estimating Management Console desktop icon.
2. In the Estimating Management Console, click on the Standard Databases tab.
3. Select the desired standard database from the list of standard databases in the Standard Database Catalog pane.
4. If desired, you can also create a new standard database by clicking [New Standard Database]. Fill out the new standard database details on the provided tabs in the detail pane and click [Create].
5. Select Sage 300 Construction and Real Estate as the job cost interface in the Job Cost Info area of the detail pane.

Figure 8: The Job Cost Area
6 Click [Setup] (Job Cost Info area) to open the Job Cost Integrator window in Sage 300 Construction and Real Estate Job Cost.

7 In the Job Cost Integrator window, select the Sage 300 Construction and Real Estate company you want to associate with the standard database.

*Figure 9: The Job Cost Integrator Window*

8 Select a default JC category cost code in the Labor, Material, Subcontractor, Equipment, and Other boxes.

Sage Estimating prefills the JC category box in each new item you create with the applicable selected default category.

For example, if you select a labor cost code of 03-0100 for the Labor box, each time you create a new labor item for the estimate or standard database, the item's JC category box automatically displays a cost code of 03-0100.

9 If you want to overwrite the cost code information in existing items in your standard database, select the Add Job Cost categories to items check box.

10 Click [OK] to return to the Estimating Management Console.

11 Verify that the Sage 300 Construction and Real Estate company you selected in step 6 appears in the Company name box of the Job Cost Info area of the Estimating Management Console.

**Verify standard database phase settings**

Both Sage Estimating and Sage 300 Construction and Real Estate Job Cost use the concept of phases.

**NOTE:** In Job Cost, phases are often called *cost codes.*
It is possible that the phase structure used in Sage Estimating is not the same as the cost code structure used in Job Cost. Using the Database Phase window in Sage Estimating, you tell the software how you want the two structures to align. In essence, you create a map for the software to use when you transfer data from a phase in Sage Estimating to a cost code in Job Cost.

To verify standard database phase settings:

1. From the Database tab in Sage Estimating, select Phases from the Phase/Item group (in classic view, select Database menu > Phases).
   The Database Phase window opens.

   **Figure 10: The Database Phase Window**

2. Click the list button located to the right of Job cost phase to select the Sage Estimating phase to be mapped to a cost code in Job Cost.
   The Database Phase List window opens.
3 Double-click on the desired phase.

You are returned to the Database Phase window. The selected Phase, its Description, Unit description, and any previously selected Job Cost phase display in the Database Phase window initially.

**NOTE:** You can use the same Job Cost phase number for many different estimating phases.

4 Click [Close] when you are finished.

**Verify standard database item settings**

The Database Item window is where you define the Job Cost phase and Job Cost Category to use with a standard database item, and specify which quantity to send to Job Cost.

To verify standard database item settings:

1 In Sage Estimating, select Database tab > Phase/Item group > Items (in classic view, select Database menu > Items) to open the Database Item window then click on the Job Cost tab.
The information you enter on this tab creates a map for the software to use when you transfer information from Sage Estimating to Job Cost. For each item in the standard database, you can select a Job Cost phase (remember, in the Job Cost application, phases are often referred to as cost codes) and a Job Cost category. When Sage Estimating sends this estimate item to Job Cost, the item and its associated information appears under the cost code and category you select on this tab.

**NOTE:** As with phases, you can use the same Job Cost Phase and Job Cost Category for any number of estimate items.

2. Click in the Job Cost Phase field, and then click the list button. The Database Job Cost Phase List window opens.

3. Locate and double-click the Job Cost phase you want to receive the item information when Sage Estimating interfaces with Job Cost. When you double-click on an item, the Database Job Cost Phase List window closes and you are returned to the Database Item window. The Job Cost phase you selected appears in the Job Cost Phase box.

**NOTE:** You can also manually enter a phase. Be sure to follow the format set up in Job Cost. If the phase does not exist in Job Cost, you can create it during the import.

4. Click in the Job Cost Category box and then select the category from the list to receive the Sage Estimating item information.
Figure 13: The Job Cost Category List

NOTES:
- You can also manually enter a category.
- Be sure to click in the Job Cost Category box, not the standard database item Category box. The database item Category box is used for pricing and does not have any impact on the Job Cost interface.

5 Select the item quantity to send to the selected Job Cost category by selecting the item quantity from the Qty to Job Cost list.

Your cost accounting needs should dictate which option you choose.
- **Takeoff qty**: Sends to Job Cost the takeoff item quantity for the category.
- **Order qty**: Sends to Job Cost the order item quantity for the category.
- **None**: Sends to Job Cost the total dollar amount for the job cost phase and job cost category. It does not send quantities, so the unit price field in Job Cost will be blank.

6 Click [OK] and [Close] when you are done.

NOTE: You can also make changes to the Job Cost phase and category from the estimating spreadsheet itself.

**Verify standard database addon settings**

To view the database addon settings:

1 From the Database tab, select Addons from the Miscellaneous group (in classic view, select Database menu > Addons).
2 In the **Database Addon** window, select the **Allocatable** check box to make an addon cost eligible for allocation when the estimate information is sent to Job Cost.

**NOTE:** To actually allocate the addon, select the **Allocate addons** check box in step 2 of the **Job Cost Export** wizard in the Sage Estimating software.

3 To send the addon costs to a specific Job Cost cost code and category, click **[Job Cost]** and select the Job cost phase and category to receive the addon information.

*Figure 14: Selecting a Phase and Category for Job Cost*

![Database Addon window with Allocatable check box highlighted](image)

---

**Export Estimate data to Sage 300 Construction and Real Estate Job Cost**

Use the **Export to Job Cost** feature in Sage Estimating to send estimate data to Sage 300 Construction and Real Estate Job Cost:

1 In Sage Estimating, select **Interface tab > Job Cost Options > Export to Job Cost** (in classic view, select **Interface menu > Job Cost**).

2 The **Job Cost Transfer** wizard opens. Use the **Job Cost Export** wizard to export the following estimate data:
   - Each phase for which you have entered a phase quantity in the spreadsheet.
   - Each item category with an amount. The item setup determines whether the transaction includes the takeoff quantity or order quantity.
   - Each addon that is not allocated. The cost of allocated addons is found in the items used to calculate those addons.
3 Click [Next].

4 Enter (type or click the calendar button next to the Transaction date box) the date to appear on the transactions contained within the transaction file.

   **NOTE:** The Sage 300 Construction and Real Estate JC job number box displays the job number entered in the Estimate Information window in Sage Estimating.

5 Click [Next].
6 Select how you want item quantities to be rounded and how to allocate addons.

*Figure 17: Job Cost Export Wizard Step 2*

7 Click [Next].

*Figure 18: Job Cost Export Wizard Step 3*

8 Select the **Map estimate information to extras in Job Cost** check box if you want to map estimate information to Job Cost extras.

**NOTE:** If you do not use extras in Job Cost you do not need to do anything on this tab.
In Job Cost, **extras** are sub-jobs of the main job. Extras allow you to track cost, revenue, and commitments separately from the main job, while still being able to accumulate to the main job. Some reasons you might need to use extras in Job Cost are:

- The owner or architect requested additional work after the original contract was signed.
- You must track income from certain cost codes separately from the main job.
- Certain costs are billed and tracked separately from the main job.

**NOTE:** In Job Cost, you can change the name "extra." For information about how to change the name of this item, refer to "custom descriptions" in the Job Cost in-product Help.

9 If desired, attach information from a work breakdown structure or location to an item as an extra:

a Select the **Map estimate information to extras in Job Cost** check box.

Each item is mapped to a specific cost code and category in Job Cost using the **Database Item** window in Sage Estimating. The mapping you enter sends a location or work breakdown structure (WBS) code to Job Cost as an extra.

In Sage Estimating, WBS codes enable you to attach additional information to each item. Each WBS code has values underneath it. For example, if you had a WBS code of **CSI Phase**, the values underneath that WBS code might be field supervision, project administration, safety coordination, and so forth.

**NOTE:** In Job Cost, the **Extra ID** entry is limited to 10 characters.

Additionally, you can use a location to relate an item to a specific job area. For example, if you build an office, you might want to assign one item to the first floor and another item to the second floor.

b Select the WBS code or location from the **Sort Level** list to send to Job Cost as an extra.

**NOTE:** When you select a **Sort Level**, you receive a warning. If you choose a sort level, non allocatable add-ons will not be exported. Select [Cancel] instead to export all. Also, if you want all addons included in the export, click [Cancel].

If you select a WBS code for the **Sort Level**, the **WBS values** area becomes available.

**NOTE:** If you selected **Location** as the **Sort Level**, the name of this area is **Location Selection**. Its function is the same no matter which **Sort Level** you select.

c Under **WBS values**, choose whether to send all WBS values to Job Cost or only selected WBS Values.

10 Click [Finish] to export the specified estimate data to Job Cost.

Sage Estimating sends the exported estimate information directly to the Sage 300 Construction and Real Estate Job Cost New.jct file.
Chapter 5—On-Screen Takeoff Integration

If you use On-Screen Takeoff (OST) estimating software, you can set OST to interface with Sage Estimating through the On-Screen Takeoff Integrator. The OST Integrator lets you perform takeoff to estimates in Sage Estimating from drawings you create and store in OST.

Learning About Integration

The OST software organizes parts and materials required for a job into collections known as conditions. Sage Estimating, however, organizes materials in its databases into individual items and collections called assemblies. You must convert or integrate OST conditions into items and assemblies before you can create estimates in Sage Estimating through OST takeoff.

Integration involves three primary steps:

1. Select a condition for takeoff in OST.
2. In the OST Integrator, select a Sage Estimating item or assembly that is comparable or the equivalent of the OST condition. For example, if you select "Drywall sheeting" for takeoff in OST, find a Sage Estimating item or assembly that most closely matches the selected drywall sheeting.
3. Note the physical properties of the selected OST condition, such as length or height, and type any conversion factors as necessary to equate it with the assigned Sage Estimating item or assembly. For example, if the drywall board length in OST is measured in meters, and the assigned Sage Estimating item measures length in feet, type the conversion factor required to equate the two.

Figure 19: Illustration of the Integration Principle

On-Screen Takeoff Integrator Features

Start the OST Integrator from within Sage Estimating by selecting Interface tab > On-Screen Takeoff group > OST Integrator (in classic view, select Interface menu > Open OST Integrator).
The main window of the On-Screen Takeoff Integrator is divided into three separate panes.

Figure 20: The On-Screen Takeoff Integrator Main Window

**Condition Assignment Pane**

The Condition Assignment pane provides a list from which you can match or assign items or assemblies in Sage Estimating with conditions in an OST database.

For example, if you are working with an OST project or drawing that has a condition for 30 square feet of ceramic floor tile, and the closest equivalent in a Sage Estimating database is the 04-00-10 Masonry, Tile assembly, select the ceramic floor condition in the list, click the Assign Assembly button, and select the 04-00-10 assembly to assign it to the ceramic floor condition.

Sage Estimating items and assemblies appear in the list beneath the OST conditions to which they are assigned.

**Condition Properties Pane**

The Condition Properties pane displays the physical qualities of any OST condition selected in the Condition Assignment pane, such as depth, height, or count (number). You must “map” these properties to their Sage Estimating equivalents in the Integration grid when you assign an item or assembly to an OST condition.

For example, if the selected OST condition has a length of 30 meters as a physical property or dimension, and the Sage Estimating assembly you assign to it measures length in feet, you must map the
OST condition’s length (using the Integration grid) to the assigned assembly’s length and indicate the conversion factor from meters to feet.

Mapping condition properties enables the OST Integrator to create accurate estimates when performing takeoff from an OST condition.

**Integration Grid**

Use the Integration grid to “map” or convert the properties of an OST condition to the variable equivalent of its assigned Sage Estimating item or assembly.

For example, if you are working with a "drywall ceiling" condition from an OST drawing that has a length of 30 meters, and you assign the 09-00-10 Drywall assembly from Sage Estimating to it, you must ensure the Sage Estimating assembly has a variable equivalent for length in meters.

To begin mapping, select any condition from the Condition Assignment pane that already has a Sage Estimating item or assembly assigned to it. The grid displays the estimating variables and OST condition properties associated with the selected condition.

Refer to the OST Integrator in-product Help for information about specific columns in the grid.

**Performing Integration**

Before integrating OST items and conditions with Sage Estimating items and assemblies, select both an OST database and a Sage Estimating database you want to use for the integration and takeoff processes.

You can open either a Microsoft Access-based OST database or a Microsoft® SQL Server®-based OST database for integration. See the OST Integrator Help for more information.

To integrate OST conditions with Sage Estimating items and assemblies:

- **NOTE:** Ensure you open an OST database before performing this procedure.
- **1** Select a condition for takeoff in OST.
- **2** In the OST Integrator, click the Goto button to view the selected condition and its associated items in the Condition Assignment pane of the OST Integrator.
- **3** In the Condition Assignment pane, expand the OST condition to view any items or assemblies already assigned to it.

  **NOTE:** You can right-click on any condition and select Expand condition to expand it.

- **4** Click the assign item button to open the Item List window or the assign assembly button to open the Assembly List window.

  This window lists all available Sage Estimating items or assemblies in the selected Sage Estimating standard database.

- **5** Select an item from the list in the Item List window or an assembly from the Assembly List window and click [OK].

  The assigned item or assembly then appears in the Condition Assignment pane beneath the condition to which you assigned it.
The variables associated with the assigned Sage Estimating item or assembly appear in the Integration grid. The properties associated with the selected OST condition appear in the Condition Properties pane. You must "map" or match one or more condition properties to a Sage Estimating variable:

a) For the first variable listed in the Estimating Variable column, select an equivalent condition property from the list in the Condition Property column.

For example, if the first Sage Estimating variable is Width, select a width-based condition property from the Condition Property list.

You can also select a condition property by clicking on a property in the Property column of the Condition Properties pane and "dragging" it to the Condition Property column of the Integration grid.

Figure 21: Mapping Properties

If no equivalent condition property is available, leave the Condition Property column blank.

b) If you select a condition property, and a conversion factor is required, type it in the Conversion Factor column.

For example, if the Sage Estimating variable Length is measured in Inches but the condition property Length is measured in Feet, the conversion factor is 12/1 or 12.

c) If you did not select an equivalent condition property in step a, specify the Sage Estimating variable's value by typing directly in the Value column.

d) Repeat steps a-c for each Sage Estimating variable in the grid.

7) Repeat steps 1-6 for each OST condition you expect to use during takeoff.

8) Click [Save] to save your changes.

Performing One-Time Integration

You can integrate values from an OST condition property with an item or assembly dimension in Sage Estimating on a one-time basis. You can do this by dragging the OST condition into the dimension grid of the Item Takeoff window, Assembly Takeoff window, or Quick Takeoff window in the Sage Estimating software.

For example, if you are taking off an assembly in Sage Estimating that requires the Single Ply Roof condition from OST to be added to it, you can select each associated property Value from the Condition
Property pane in the OST Integrator and "drag" it to the Assembly Takeoff window in Sage Estimating. The Single Ply Roof condition properties are then added to the assembly.

The Sage Estimating items and assemblies retain the OST condition value integration for one takeoff only. If you want to integrate OST conditions and Sage Estimating items and assemblies for more than one takeoff, you must perform the integration in the OST Integrator using the procedure in “Performing Integration” on page 35.

To perform a one-time integration with a Sage Estimating estimate:

1. In Sage Estimating, open the Item Takeoff, Assembly Takeoff, or Quick Takeoff window.
2. In the OST Integrator, open the OST project containing the condition or conditions you want to add to the estimate.
3. Select the condition you want to add from the Condition Assignment pane of the OST Integrator.
4. From the Condition Properties pane, select the condition property Value that you want to add to the estimate—for example, the values associated with the "width," "height," or "quantity"—and "drag" it to the dimension grid of the Item Takeoff window, Assembly Takeoff window, or Quick Takeoff window in Sage Estimating.

**Figure 22: Selecting a Value for Integration**

![Condition Properties Table]

5. Repeat steps 2-4 to integrate all desired OST conditions with the estimate.

**Performing Takeoff to Estimates**

After you integrate OST conditions with Sage Estimating items and variables, the OST Integrator allows you to create estimates in Sage Estimating using conditions and items you take off from OST projects.

To take off OST items and conditions to an estimate:

1. Select an OST project from the list in the Condition Assignment pane.
2. Click the new estimate button to create a new estimate.

Alternatively, you can open an existing estimate by clicking the update estimate button.

**If you are creating a new estimate:** Type a name for the new estimate in the New Estimate window; then specify an estimate database for storing it, a standard database to associate with it (optional), and the estimate "branch" where you want it displayed then click [OK] to create the new estimate.
If you are opening an existing estimate: Select the existing Sage Estimating estimate from the estimate list then click [Open] to open it.

The OST Integrator adds items and assemblies already assigned to conditions in the OST project to the new or existing estimate. If desired, you open the estimate immediately after creating it.

**NOTE:** For existing estimates only: If you previously generated items and assemblies from the OST project to the selected estimate, the OST Integrator deletes the items and assemblies before adding new ones.

### Using Condition Style Libraries

Using the OST software, you can create a library of condition styles that you can then use in more than one project. A corresponding condition style library appears in the Condition Assignment pane of the OST Integrator.

If, for example, you create a condition in an OST project for right-hand doors called RH Door, you can choose to save the condition in the OST style library for use in other projects. In the OST Integrator, the RH Door condition automatically appears in the Style Library of the Condition Assignment pane.

*Figure 23: Condition Styles in the Condition Assignment Pane*

After saving conditions as styles in the condition style library, you can assign Sage Estimating items and assemblies to them in the OST Integrator (see “Performing Integration” on page 35 for instructions).

You can then use the integrated condition styles in future projects whenever they are required.

You can create and edit condition style libraries only in On-Screen Takeoff.

**NOTE:** Each OST database has only one condition style library.
Importing and Exporting Condition Assignments

You can import and export integrated condition assignments in extensible markup language (XML) files. Use this feature when you want to transfer integrated condition assignments from a Sage Estimating standard database in one location to a standard database in another location.

For example, if you assign OST conditions to Sage Estimating items and assemblies in a standard database on your local computer, and you want to integrate those same assignments into another standard database (such as a shared standard database on a server, for example), export the integrated conditions to file then import them into the shared database.

To export assignments to a file

1. In the OST Integrator, open the standard database containing the assignments you want to export.
2. Select Import/Export group > Export the assignments to a file (in classic view, select File > Export).
3. Type a file name for the export file in the File Name box and browse to the location where you want the file saved.
4. Click [Save].

The OST Integrator saves the condition assignments to an XML file (.osti extension) that you can import later.

To import assignments to a file

1. In the OST Integrator, open the standard database where you want the condition assignments imported.
2. Select Import/Export group > Import an assignments file (in classic view, select File > Import).
3. Select the import file containing the assignments you want to import (.osti extension).
4. Click [Yes] at the prompt.

**CAUTION:** The OST Integrator overwrites all current condition assignments in the standard database when you import the assignments from file.

5. Right-click on the OST database in the Condition Assignment pane and select Change the Database Path.
6. Browse to the location of the OST database containing the integrated conditions click [Open] to update its location relative to the imported condition assignments.
Index

C

commuter licenses
  checking in 10
  checking out 9
  description 9
Condition Assignment pane
  description 34
  viewing assignments 35
condition properties
  mapping 36
  purpose 34
Condition Properties pane
  description 34
condition style libraries 38
conditions
  purpose 33
  reusing 38
contacting Sage 3

D

documents, list 1

E

error messages
  License Manager 14

F

features 1

I

integration
  item 35
  outline 33
Integration grid
  description 35
  item integration 35

J

Job Cost interface
  enabling 23
  Estimating prerequisites 23
  guidelines 22
  outline 21

L

library, condition style 38

License Manager
  commuter licenses 9
  error messages 14
  installation 16
  ping utility 17
  protection device 9
purpose 8 ..............................
LSFORCEHOST variable 12 ..............
LSHOST variable 12 ........................
LSPROTOCOL variable 12 ..............

M
Means databases
integration 5 ..........................
list 4 ..........................
updating 5 ..........................

O
On-Screen Takeoff (OST)
conditions 33 ..........................
description 33 ..........................
integrating conditions 35 ..........................
integration 33 ..........................
performing takeoff 37 ..........................
one-time integration 36 ..........................
online help 2 ..........................
options
list 1 ..........................
OST Integrator
description 33 ..........................
features 33 ..........................

P
ping utility, License Manager 17 ..........................
product help 2 ..........................

R
related documents 1 ..........................
release overview 1 ..........................
RSMeans databases
list 4 ..........................
updating 5 ..........................

S
Sage contact information 3 ..........................
Sentinel driver
purpose 9 ..........................
transferring data 5 ..........................
updating database prices 5 ..........................

T
transferring data 5 ..........................

U
updating database prices 5 ..........................

V
variable
LSFORCEHOST 12 ..........................
LSHOST 12 ..........................
LSPROTOCOL 12 ..........................

W
wechoid 18 ..........................
WlmAdmin program, description 11 ..........................

Sage Estimating Options Guide  Page 41