NOTICE

This document and the Sage Timberline Office software may be used only in accordance with the accompanying Sage Timberline Office End User License Agreement. You may not use, copy, modify, or transfer the Sage Timberline Office software or this documentation except as expressly provided in the license agreement.

©2011 Sage Software, Inc. All rights reserved. Sage, the Sage logos and the Sage product and service names mentioned herein are registered trademarks or trademarks of Sage Software, Inc., or its affiliated entities. All other trademarks are the property of their respective owners.

08/2011 Document Number: 200012000401000
# Contents

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1: Welcome to Estimating</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>About This Booklet</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Ways to Get Help</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Contact Customer Support</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>Chapter 2: Some Basic Concepts</td>
<td></td>
<td>4</td>
</tr>
<tr>
<td>Work With the Database and Estimates</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Learn About The Database</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Learn About Estimates</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>Chapter 3: Use the Database Builder Wizard</td>
<td></td>
<td>7</td>
</tr>
<tr>
<td>Start the Database Builder Wizard</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>Start Here</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>Choose Your Industry/Choose a Database</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>Learn About Database Structure</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>Plan your Database: Phase Structure</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>Open in Database Editor: Phase Structure</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>Plan Your Database Structure: Items</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>Learn About Estimating</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>Chapter 4: Create a New Estimate</td>
<td></td>
<td>10</td>
</tr>
</tbody>
</table>
Create a New Estimate ................................................................. 10

**Chapter 5: Perform Takeoff** ......................................................... 12
  Perform Takeoff ................................................................. 12
  Quick Takeoff ................................................................. 12
  Item Takeoff ................................................................. 14
  Assembly Takeoff ............................................................... 14
  Review Assemblies ............................................................ 16
  One-Time Item Takeoff .......................................................... 17
  Add New Item ................................................................. 18

**Chapter 6: Work with the Spreadsheet** ................................. 20
  The Spreadsheet Window ....................................................... 20
  Change the Appearance of the Spreadsheet .......................... 23
  Change Item Prices and Quantities ........................................ 24
  Find Incomplete Items ......................................................... 24
  The Detail Window ............................................................... 25
  The Totals Window .............................................................. 26
  Format the Totals Window ..................................................... 26
  Create Totals Page Templates ................................................. 29
  Docking the Totals Page ....................................................... 29

**Chapter 7: Print Reports** ......................................................... 31
  Print Reports ................................................................. 31

**Chapter 8: Use Address Book** .................................................. 34
  Use Address Book ............................................................. 34
# Contents

## Chapter 9: Extended-Only Features

- Use WBS Codes ................................................................. 37
- Include the Cost of Crews .................................................. 38
- Crews and Items .............................................................. 40
- Rate Tables ................................................................. 40
- Spreadsheet Sequences .................................................. 40
- Subcontractor Bids ......................................................... 41
- Adjust Spreadsheet Columns ............................................ 42
- Model Takeoff .............................................................. 44
- Move/Copy Items .......................................................... 46
- Multi Currency ............................................................. 47

## Chapter 10: Use Database Editor

- Start Database Editor ...................................................... 48
- Open a Database .......................................................... 48
- Create and Edit Database Elements ................................. 49
- Save and Select Column Layouts ..................................... 50
- About Filters .............................................................. 51

## Appendix: Keyboard Shortcuts

- ................................................................. 52
Chapter 1: Welcome to Estimating

Sage is pleased to welcome you as a client. Use this booklet to find out how Estimating can help you organize, manage, and analyze hundreds of estimates.

Estimating gives you the flexibility, speed, and accuracy to generate competitive estimates, bids, and budgets. An innovative spreadsheet interface is supported by fast takeoff tools, a comprehensive price database, and a wide range of ways to analyze and fine-tune your project.

About This Booklet

This booklet covers the following topics:

- Get Help—a discussion of the Help system and useful contact information.
- Learn Basic Concepts—the concepts and philosophy behind Estimating.
- Use the Database Builder Wizard—easily modify an existing database or create a new one.
- Create a New Estimate—learn how to create a new estimate.
- Perform Takeoff—instructions for copying information from a database into an estimate.
- Work with the Spreadsheet—learn how to navigate the Estimating spreadsheet.
- Print Reports—learn how to prepare and print reports.
- Use Address Book—learn how to set up Address Book to store contact information.
- Extended-Only Features—learn how to use features that are only available in the Extended version of Estimating.
- Use Database Editor—learn how to maintain databases with Database Editor.

Ways to Get Help

Use Estimating Help or the Sage Customer Portal to get answers to your questions. You can also call Customer Support. See the following sections for more information.
The Help System

Estimating’s efficient Help system provides faster access to more information than most manuals. With a click of the mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.

To Get Help on a Window Option

Help is available on virtually every option within a window. To access it, do one of the following:

- Click [What’s This?] on the toolbar or on the title bar and then click the option.
- Select What’s This? from the Help menu and then click the option.
- Select the option and press [F1].

To Get Help for the Whole Window

For information about the window, such as the window’s purpose and what tasks you can perform in it, click [Help] at the bottom of the window.

To Use Help to Learn How to Do Tasks

- Click [Help] on the toolbar or select Help Topics from the Help menu.

Contact Customer Support

Depending on your Sage Service Plan, you may be able to take advantage of the following services:

Sage Customer Portal

You may log on to the Sage Customer Portal at https://customers.sagenorthamerica.com/irj/portal/anonymous/login to access any of the following services:

- Knowledgebase: Find answers to your questions, access downloads, and subscribe to your favorite articles. This service is available online 24/7.
■ **Live Chat:** Chat online with a customer support analyst - a great option for quick questions. Chat hours are Monday through Friday from 6 a.m. to 3 p.m. Pacific time, with the same exceptions as telephone support (see below).

■ **Online Support Request:** Submit an online support ticket when you have a non-urgent question. One of our call center support analysts will assist you. Online support hours are the same as our customer support call center hours (see below).

**Sage Customer Support Call Center**

When you have a more urgent question or would prefer to speak to a customer support analyst directly, call us at 800-551-8307. Telephone support is available Monday through Friday from 6 a.m. to 5 p.m. Pacific time with the following exceptions:

■ Every Thursday from 2 p.m. to 3 p.m. Pacific time (closed for customer support staff meetings)

■ Standard United States holidays

■ Quarterly company meetings

**Upgrading Your Service Plan**

If your service plan does not provide online or telephone customer support and you would like to add or upgrade a service plan, please call 800-858-7098.

**Training Information**

Learn about the Anytime Learning and Realtime Learning sessions that are available, view schedules of online sessions, or look for classroom training near you.

You can directly access Sage University from the Help menu in applications ([Help > Sage Timberline Office on the Web > Sage Software University](#)). This website offers a variety of professional product training options.
Chapter 2: Some Basic Concepts

Work With the Database and Estimates

Estimating stores information in two places: in a database of cost items and in your estimates. The database is like a resource book that contains your estimating knowledge, including information about items, prices, calculation methods, and conversions. Each estimate contains everything needed for a particular project, including the quantity and cost of material, labor, equipment, subcontractors, and other items.

The database is the original source of the information for each estimate, but the database and estimates are completely separate. If you update the database, information in the estimate remains unchanged. However, you can automatically update an estimate with price changes made in the database. Similarly, if you change the estimate, the database is not affected.

Learn About The Database

The database contains all the standard cost items you use, including item productivity factors, waste factors, and prices. In addition, there are phases for organizing items, formulas for calculating quantities, assemblies for taking off groups of items, subcontractors, crews, work breakdown structures, and markups for adding special costs to the estimate.

Without a database, you would have to enter information over again for every estimate. But if you set up a database, you can enter the information once and find just what you need for each estimate. You simply copy information from the database into the estimate (a process known as takeoff), and enter dimensions and specifications as required.

Access the Database From the Estimate

You can easily access the database when you are working on an estimate. This lets you change or add new information to the database without closing the estimate. While changes made in the database do not affect items that are already in the estimate, the new information appears in the estimate the next time you perform takeoff.
Learn About Estimates

In essence, the Estimating spreadsheet is the estimate. It presents the items, quantities, and monetary amounts that make up an estimate, in a format designed specifically for estimating. Because the Estimating spreadsheet is disk-based, your estimates are saved automatically as you work.

The database and estimates are stored in separate files. Before you make changes, be sure to note where your changes will be stored.

The Advantages of a Disk-Based Spreadsheet

In Estimating, every entry you make to the spreadsheet is saved to the hard disk immediately. There is no Save or Save As command on the File menu. This prevents you from losing data.

View Estimate Information

The spreadsheet window is the primary place where you view estimate information. From there, you can open other windows to see totals for the estimate or the details associated with each item.

In the spreadsheet, you control the placement of columns, whether they are visible, and even what labels appear in the column header. You can also use a spreadsheet layout when you create estimate reports.
Figure 1: The Estimating Spreadsheet
Chapter 3: Use the Database Builder Wizard

The process of setting up a complete and accurate database can be lengthy and time consuming. The Database Builder is designed to walk you through the necessary steps of setting up your database more quickly and efficiently, saving you time and money and allowing you to take full advantage of the Estimating software.

Start the Database Builder Wizard

To start the Database Builder Wizard, open the Sage Desktop (Start > Programs > Sage > Sage Desktop). In the Tasks pane, select Sage Timberline Office\Common Tasks\Tools\Database Builder Wizard.

NOTE: You must have Database Editor installed in order to use the Database Builder Wizard. The Database Editor is an available option when you install Estimating products. For more information about installing Estimating products, see the “Install Estimating Products” section of the GetStarted.pdf, which is located in the Documents folder on your Estimating DVD.

The next section gives you a brief description of several of the windows in the wizard. The actual windows you see and the order that they appear vary depending on the options you select.

Start Here

Select the most appropriate method of creating or modifying your database. There are three starting points from which you can choose. Each is tailored to how you want to build your database. After you select the starting point, the remaining windows follow the same general pattern.
Choose from the following:

- **Use an industry-specific database template**: Use a pre-built database template as the basis for your database. Each template is based on industry specific elements. You can preview each database template before you make a selection to find the one that works best for you.

- **Use an existing or partially-built database**: If you have purchased a database, installed a database but have not worked with it, or started building your own database from scratch, select this option to locate that database. You can modify the database and bring it up to date.

- **Create a new empty database**: If you would like to start from scratch to build a database, select this option. The wizard provides tips and suggestions to help you get started building your database.

### Choose Your Industry/Choose a Database

#### Choose Your Industry

If you select to use an industry specific database template, this window is named **Choose Your Industry**. Select the database template that best fits your company. There are ten industry specific database templates from which to choose. Each template has two different formats, both based on the Construction Specifications Institute (CSI) MasterFormat numbering scheme. MasterFormat 1995 organizes the database into 16 divisions and MasterFormat 2010 uses 48 divisions. Preview the template to choose the database that best suits your needs.

After you select the database template, browse to the location where you want to store the database and give it a name.

#### Choose a Database

If you select to use an existing or partially built database, this window is named **Choose a Database**. You can browse to the database location or select **Scan** to find it.

### Learn About Database Structure

Learn about how an Estimating database is structured. There are onscreen definitions and links to Help topics that provide instruction on the organization of group phases, phases and items. Take some time to become familiar with this structure as you get ready to plan how your own database will look.
Plan your Database: Phase Structure

If you are using a database template or an existing database, your database already contains phases. However, there may be missing phases, unnecessary phases, phases that are not numbered in the way you need, or phases with different descriptions than you want to use. In this window, you can preview and print a report that list all of the phases that exist in your database. Use it to plan how you want your database to look.

If you are creating a new database, your database is empty and you will not see this step.

Open in Database Editor: Phase Structure

The Database Editor application opens for you to modify the phases in your database. In Database Editor you can add, delete, rename, and renumber your phases. If you are using a database template or an existing database, your phase table may include many phases. If you are creating a new database, your phase table is empty and you can start adding phases.

Plan Your Database Structure: Items

Use this window to:

- Print the **Items** report. Use this report to preview the existing items in your database and plan changes them.
- Click [Modify Items] to make changes to the items in your database. You can add, delete, change, move, rename, or renumber the items.

Learn About Estimating

The tutorials help you learn how to perform basic tasks in Estimating, such as creating an estimate, performing takeoff, and updating the database from the estimate.

NOTE: For Windows 2000, you must have Windows Media Player version 9 or later to view the tutorials. You can download Windows Media Player from Microsoft’s Web site.
Chapter 4: Create a New Estimate

Create a New Estimate

To start an estimate, you must specify a folder and file name for the new estimate. Use the File menu to start a new estimate from scratch, create a duplicate of an existing estimate, or merge several existing estimates into one new estimate.

To create a new estimate:

2. Enter a name for the estimate on the Estimate File Name tab.
3. Click the Folders tab and specify:
   - The folder in which you want to store the estimate.
   - The folder containing the database that you want to use for the new estimate.
4. Click [OK]. The Estimate Information window opens.
Getting Started With Estimating Extended

**Figure 2: The Estimate Information Window**

5 Complete the fields on the tabs. At a minimum, you need to complete the **Project name** field. The **Job size** field is required if you want Estimating to calculate the unit cost for the job in the **Totals** window.

6 When you finish entering information about the estimate, click **[OK]**.
Chapter 5: Perform Takeoff

Perform Takeoff

After you create an estimate, you select items and specify their estimated quantities. You can enter takeoff quantities or have Estimating calculate them for you. When you perform takeoff, Estimating copies everything associated with the selected items into the estimate and calculates their takeoff quantities.

Quick Takeoff

Quick takeoff is a fast, easy way to get items into your estimates. You have the option to specify takeoff quantities before or after items are in the spreadsheet. Once there, you can specify the item quantities by:

- Using the formula attached to each item.
- Using the Estimating or Microsoft Windows calculator.
- Using one value to fill in other quantities.
- Using Enter Dimensions.
- Making manual entries.

To perform quick takeoff:

1. Click [Quick Takeoff] on the toolbar to open the Quick Takeoff window.
2. (Optional) Click [Item Takeoff Settings] on the toolbar to set a location and work breakdown structure (WBS) for the items you are going to take off.

3. Select an item and take it off using one of the following methods:
   - Locate the item in the list and then double-click (or drag and drop) the item to take it off.
   - Click [Search] to open the Search field, in which you can enter search criteria for the item. After you find it, double-click (or drag and drop) the item to take it off.
   - Select an option from the Sort item list by drop-down list to organize the list in a different sort order. You can sort by phase/item or description. You can also use a custom sort based on WBS codes. Locate the item in the list and then double-click (or drag and drop) the item to take it off.

4. Take off additional items in the same manner. You can select multiple items in the list.

5. Enter or calculate the item takeoff quantities. To calculate quantities you can:
   - Use the calculator.
   - Use formulas.
   - Manually enter quantities.
   You can also right-click in the takeoff Quantity column to select these additional options:
     - Use Enter Dimensions. This option is only available after you use your mouse to select multiple cells in the Quantity column.
Use Digitizer (if you own Digitizer).
Use ePlan Takeoff (if you own ePlan Takeoff).

Item Takeoff

Item takeoff is a convenient way to take off groups of items and quickly calculate their takeoff quantities. You can review items and modify them for use in the current estimate before you generate them to the spreadsheet.

To perform item takeoff:

1. Click [Item Takeoff] on the toolbar to open the Item Takeoff window.

2. (Optional) Click [Item Takeoff Settings] on the toolbar to set a location and work breakdown structure (WBS) for the items you are going to take off.

3. Select an item and take it off.

4. (Optional) Right-click on the item list and select Sort item list by to organize the list in a different sort order. Or select Search to find a specific item in the list.
   If you have formulas assigned to your takeoff items, Estimating displays the variables (dimensions and specifications) for them in the variable pane.

5. Enter the item takeoff quantities in the takeoff grid.

6. Review the items in the takeoff grid. If necessary, you can change an item description, change item details, delete an item from the grid, and save the items as an assembly.

7. Click [OK] to generate the items to the spreadsheet.

Assembly Takeoff

You can streamline the takeoff process by taking off assemblies. For example, instead of taking off each item that makes up a standard-sized wall, you can take off an assembly containing all the items needed to construct the wall.

To perform assembly takeoff:

1. Click [Assembly Takeoff] on the toolbar to open the Assembly Takeoff window.
Getting Started With Estimating Extended

**Figure 4: The Assembly Takeoff Window**

2  (Optional) Click [**Item Takeoff Settings**] on the toolbar to set a location and work breakdown structure (WBS) for the assemblies you are going to take off.

3  Select an assembly and take it off.
   If you use formulas in your assemblies, Estimating displays the variables (dimensions and specifications) for the assembly in the variable pane.

4  Enter the variable amounts in the variable pane or enter a takeoff quantity in the takeoff grid. Click [**Add Pass**] to calculate quantities for items with formulas.

5  Review the items in the takeoff grid. If necessary, you can change an item description, change item details, add an item to the assembly, delete an item from the grid, or substitute an item in the grid.
6 When you are ready to generate the assembly to the spreadsheet, click [OK] in the **Assembly Takeoff** window.

### Review Assemblies

You can review and change assemblies already in the estimate. Estimating tracks all of the passes generated during assembly takeoff and lets you:

- Check the dimensions entered for each pass.
- Change dimensions and make additional passes for the same items.
- Change dimensions and replace existing passes.
- Add or delete items.
- Attach a note to any pass.

**To review a pass:**

1. From the **Takeoff** menu, select **Review Assemblies**.
2. Double-click the assembly that you want to review.

**Figure 5: Reviewing an Assembly**

3. Click the pass that you want to review.
To revise an existing pass:
1 In the variable pane, change the dimensions in the Quantity, Length, and Width boxes.
2 Click [Replace Pass] to revise the existing pass.
3 Click [OK] to send the changes to the spreadsheet.

NOTE: You can also add a pass [Add Pass], add notes to a pass [Pass Note], or undo a pass [Undo Last Pass].

One-Time Item Takeoff

One-time items are items that do not already exist in your database. They may be unusual items that you want to include in an estimate without first having to set them up in the database.

To perform one-time item takeoff:

1 Click [One-Time Item] on the toolbar. The One-time Item window opens.

Figure 6: The One-Time Item Window

2 Complete the fields in the window. At a minimum, you need to complete the Phase, Description, and Takeoff unit fields to set up a one-time item.

3 (Optional) Click [Go to Detail] to enter more information about the item.
4 When you finish setting up the item, click [OK] in the **One-time Item** window. The item appears on the spreadsheet or in the takeoff grid if you are taking off a one-time item from the **Item Takeoff** window. Hyphens in the **Item** column (----) identify a one-time item in the spreadsheet. If you did not select [Go to Detail] in step 3, you can enter details directly to the item in the spreadsheet.

**NOTE:** If you want to add your one-time items to your database, you can easily do so by selecting **Pricing > Update Database > Save One-time Items to Database.**

### Add New Item

You can add new items to your estimate from within quick takeoff, item takeoff, or assembly takeoff, if your settings allow it.

To review your settings, select **Edit > Options.** On the **Takeoff** tab, confirm that the **Include Add New Item** entry on takeoff lists check box is selected, and then click [OK].

**To add new items in quick takeoff:**

1. Click [Quick Takeoff] on the toolbar to open the **Quick Takeoff** window.
2. Double-click on the group phase and then phase where you want the new item to appear.
3. Double-click **Add New Item.** This creates a new row on the estimate, under the phase you selected.
4. Close the **Quick Takeoff** window.
5. Enter the item information in the new row on the spreadsheet.

**To add new items in item takeoff:**

1. Click [Item Takeoff] on the toolbar to open the **Item Takeoff** window.
2. Double-click on the group and then phase where you want the new item to appear.
3. Select **Add New Item.** This adds a row to the item takeoff grid, where you can enter information for the item.
4. Enter the item information in the takeoff grid.
5. Click [OK] and then [Close] to add the item to your estimate.
To add new items in assembly takeoff:

1. Click [Assembly Takeoff] on the toolbar to open the Assembly Takeoff window.
2. Select an assembly and take it off.
3. Right-click in the assembly pane, and then select List Items.
4. Select the group phase and then phase where you want to add the new item, and then click Add New Item. This creates a new row on the assembly grid, where you can enter information about the item.

Figure 7: Adding New Items to the Assembly Takeoff

5. Enter information about the new item in the assembly grid.

6. When you are ready to generate the assembly to the spreadsheet, click [OK] in the Assembly Takeoff window.

 NOTE: If you want to add your new items (which are now one-time items) to your database, you can easily do so by selecting Pricing > Update Database > Save One-time Items to Database.
Chapter 6: Work with the Spreadsheet

The Spreadsheet Window

The spreadsheet window contains columns with the quantities and category information for all items in the estimate.
Figure 8: The Estimating Spreadsheet

<table>
<thead>
<tr>
<th>Group</th>
<th>Phase</th>
<th>Description</th>
<th>Takeoff Quantity</th>
<th>Labor Cost/Unit</th>
<th>Labor Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>02000.000</td>
<td>SITE CONSTRUCTION</td>
<td>Borrow, select structural fill, spread w/200 HP</td>
<td>504.00 cy</td>
<td>$1.09/cy</td>
<td>$531.15/hr</td>
</tr>
<tr>
<td>02200.000</td>
<td>SITE PREPARATION</td>
<td>Soldier beams &amp; lagging, no hydro, head L in place</td>
<td>33,000.00 sq</td>
<td>11.28 sq/ft</td>
<td>$45.68/hr</td>
</tr>
<tr>
<td>02300.000</td>
<td>EARTHWORK</td>
<td>Soldier beams &amp; lagging, trench only, based on to-backs in length</td>
<td>4,700.00 ft</td>
<td>23.76 ft/lin</td>
<td>$42.96/hr</td>
</tr>
</tbody>
</table>

NOTE: In this booklet, instructions that include these commands often include a picture of the icon as well.
### Table 1: Spreadsheet Command Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Command</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Expand</td>
<td>Displays the spreadsheet with one more level of detail.</td>
</tr>
<tr>
<td></td>
<td>Collapse</td>
<td>Displays the spreadsheet with one less level of detail.</td>
</tr>
<tr>
<td></td>
<td>Find/Goto</td>
<td>Lets you search for items that match the sort level or description you specify.</td>
</tr>
<tr>
<td></td>
<td>Spreadsheet Layout</td>
<td>Lets you create, modify, delete, or apply a custom layout to the spreadsheet.</td>
</tr>
<tr>
<td></td>
<td>Quick Takeoff</td>
<td>Perform takeoff directly from the item list. Available only when a database is open.</td>
</tr>
<tr>
<td></td>
<td>Item Takeoff</td>
<td>Opens the Item Takeoff window, in which you choose the items and specify their takeoff quantities. Available only when a database is open.</td>
</tr>
<tr>
<td></td>
<td>Assembly Takeoff/Review</td>
<td>Opens the Assembly Takeoff window, in which you choose an assembly and specify the takeoff quantities for its items. Available only when a database is open.</td>
</tr>
<tr>
<td></td>
<td>One-time Item</td>
<td>Creates a one-time item for the current estimate. You enter the phase, description, takeoff quantity, unit, and categories.</td>
</tr>
<tr>
<td></td>
<td>Item Takeoff Settings</td>
<td>Controls the automatic assignment of location and WBS values during takeoff.</td>
</tr>
<tr>
<td></td>
<td>Detail</td>
<td>Lets you view and modify the information about an item in the estimate spreadsheet or takeoff grid.</td>
</tr>
<tr>
<td></td>
<td>Totals</td>
<td>Lets you view the overall total and category totals for the current estimate and assign addons (markups).</td>
</tr>
<tr>
<td></td>
<td>Combine</td>
<td>Lets you combine matching items in the spreadsheet.</td>
</tr>
<tr>
<td></td>
<td>Scan</td>
<td>Lets you find incomplete items in the spreadsheet.</td>
</tr>
<tr>
<td></td>
<td>What’s This?</td>
<td>Displays Help for a button, command, or window.</td>
</tr>
</tbody>
</table>
Change the Appearance of the Spreadsheet

The spreadsheet includes over 100 columns of information. Estimating makes it easy for you to adjust the appearance of the spreadsheet to suit your needs.

You decide:

- Which columns are visible and where they are positioned.
- What names appear as column headers and how wide each column is.
- Whether you want to organize items by phase, location, takeoff order, assembly, or a customized spreadsheet sequence.
- How many levels of detail you want to see.
- What fonts and colors are used for text and numbers.

In addition, you can set up an unlimited number of layouts. For example, you can design a labor-only layout or a material-only layout.

To set up the spreadsheet layout:

1. Click [Spreadsheet Layout] on the toolbar to open the Spreadsheet Layouts window. This window lists the layouts set up for the current spreadsheet sequence.

   Figure 9: The Modify Spreadsheet Layout Window

2. Click a button in the Spreadsheet Layouts window to continue.
   - To set up a new layout, click [Add].
   - To modify an existing layout, select the layout in the list and click [Edit].
   - To save the current layout, select <Current layout> in the list and click [Edit].
   - To delete a layout from the list, select the layout in the list and click [Delete].
3 Set the options in the Modify Spreadsheet Layout window.
   - To show a column in the spreadsheet, select the corresponding Visible check box.
   - To hide a column, clear the corresponding Visible check box.
4 Click [OK] to save the spreadsheet layout and close the Modify Spreadsheet Layout window.

Change Item Prices and Quantities

As you work on an estimate, you can change prices and quantities to reflect the latest information. For example, you can enter quotes for materials.

To change prices and quantities:

1 On the spreadsheet, click the appropriate category price cell for the item. For example, to enter a quote for an item's material price, click the Material Price cell.
2 Enter the new price.
3 If other items in the spreadsheet are linked to this item, the following question appears: Would you like to update prices for linked items?
   - Click [Yes] to change the prices of linked items too.
   - Click [No] to change the price of this item only.
4 If the spreadsheet contains duplicates of this item, the following question appears: Would you like to update prices for duplicate items?
   - Click [Yes] to change the prices of duplicate items too.
   - Click [No] to change the price of this item only.

Find Incomplete Items

To make sure your estimate is complete, you can scan it for missing takeoff quantities, prices, amounts, or subcontractor names (if an item has a subcontract amount).

To scan for incomplete items:

1 Position the cursor anywhere on the spreadsheet.
2 Click [Scan] on the toolbar.
3 Estimating stops at the first cell that is empty or contains a zero. Fill in the missing quantity, amount, price, or subcontractor name. If you need to do more research before you supply a value, leave the cell blank for now.

4 Repeat step 2 until no more incomplete entries are found. (When Estimating reaches the bottom of the spreadsheet, it resumes scanning from the beginning of the spreadsheet.)

The Detail Window

The Detail window lets you view the information about a row in the estimate spreadsheet or takeoff grid. This window contains information about the selected spreadsheet row as specified for the estimate. Estimating saves your entries when you click [OK]. Changes you make are saved with the estimate and do not affect the database.

To open the Detail window:

1 On the toolbar, click [Detail].
2 From the keyboard, press [CTRL] + [D].

Figure 10: The Detail Window
The Totals Window

The **Totals** window shows a summary of the cost category and estimate totals. It also lets you include addon costs (markups) in the estimate.

**To open the Totals window:**

1. Click [Totals] on the toolbar or press F4.

2. The Totals window opens. You can see the totals for each cost category, markup and subtotal along with the total cost of the estimate.

**Figure 11: The Totals Window**

3. To print the totals, click the print icon on the toolbar. If the toolbar does not appear, click [Show Toolbar].

**Format the Totals Window**

You can format the **Totals** window to change its visual appearance. You can also hide fields to prevent them from printing on reports. Any layout changes you make to the window print on your report if the option to print totals is selected on your report.
To format a column in the Totals window:

1. With the Totals window open, right-click on a column heading and select Format Column. The Format Column window appears.

2. Make changes to the column. Changes you can make include:
   - Column name
   - Column width
     - Alignment
     - Number of decimals
     - Background color
     - Font

3. Click [OK] to save your column changes.

**NOTE:** You can also format rows or individual cells. To format a row, right-click on the row header and select Format [row name] Rows. To format a cell, right-click in the cell and then select Format Cell.

To hide a column on the Totals window:

Hiding columns prevents them from showing up on reports, but does not remove the amounts from the totals.

1. With the Totals window open, right-click on a column heading and select Hide On Reports.

2. If you receive a warning that hidden numbers may cause some totals to appear incorrect, click [OK]. (This does not mean the numbers are incorrect, only that they may appear to be, because numbers that are used in the total calculation are not visible.)

3. Click [OK].

**NOTE:** You can also hide rows or individual cells. To hide a row, right-click on the row header and select Hide on Reports. To hide a cell, right-click in the cell and then select Hide on Reports.

To insert addons:

Addons represent the additional cost or markup that contractors add to their estimates. It is cost over and above the actual cost to contractors and represents their indirect costs and budgeted profit. Types of addons include overhead, taxes, profit, and other costs.
You can choose addons for the estimate before or after takeoff. Some estimators like to set them up before takeoff so that they can see how the overall estimate is shaping up as they work.

Where you insert each addon determines which estimate costs are used to calculate the addon amount. An addon should come after the subtotals and addons you want to include. This is especially important for addons based on subtotals.

1. Right-click on the row header where you want to create the addon.

2. Select **Insert Addon**.

*Figure 12: Inserting an Addon*

3. Double-click the addon to select it. You can select multiple addons if necessary.

4. When finished, click [Close].

5. Click [OK].

**To insert subtotals:**

Where you insert a subtotal determines which estimate and addon costs it includes. Each subtotal is the sum of the amounts between it and the previous subtotal.

1. Right-click on the row header where you want the subtotal to appear.
2 Select **Insert Subtotals**.

3 (optional) Type a description in the **Description** column.

**Create Totals Page Templates**

Changes you make to the **Totals** window are stored with the estimate. You can also save the **Totals** window format to the database as a template so that it is available to use on other estimates.

1 With the **Totals** window open, click **[Totals Pages Templates] > Save As Totals Page Template**.

2 In the **Template name** box, type the name for this template.

3 If you want to use this template for all new estimates, click the **Use this totals page template for new estimates** check box.

4 Click **[OK]**.

[NOTE]: To revert back to the system default template, select **[Totals Page Template] > Use System Default Template**.

**Docking the Totals Page**

You can dock the totals page, which places it in a location on the screen that you select.

**Dock the Totals page:**

1 With the **Totals Page** open, click **[Dock]**.
2 Select the location where you want the **Totals Page** to appear. The page automatically moves to the location you select. If you dock the page and later want to undock it, repeat these steps and select **Undock**.
Chapter 7: Print Reports

Print Reports

You can print a report on paper, preview it on your screen, or export it to a PDF file, an Excel file, or an ASCII text file. The printing procedure is similar no matter which report you choose to print.

You can also set up customized cover pages, headers, footers, and a signature block for each estimate report. After you have a presentation you like, you can save it to a named layout for printing that report in the future.

To print a report:

1. Open an estimate. (You must have an estimate open because the report information comes from the current estimate.)

2. On the Reports menu, select the report you want to print.

3. (Optional) To customize the report, click [Report Options] to open the report options window. In this window you can select which records print, sort the report information, change the fonts or colors, change the page setup, set up headers and footers, or set up a signature block.
Figure 14: Selecting the Report Options

NOTE: For the Spreadsheet report, you can click [Prefill from Spreadsheet] to change the report options to match the current layout of the spreadsheet. This is an easy way to get a printout that looks the same as the spreadsheet on the screen. If you prefer a different layout for the report, you can change the spreadsheet layout before you print.

4 (Optional) To check the appearance of the report before you print it, click [Preview].

5 (Optional) To save your changes for the future, click [Save Layout] and give the layout a name. You can select this layout name in the future to use these changes.

6 Click [Print].

To save a report as a file:

1 In the report window, click [Export].

2 In the Export Report File window, select the drive or directory in which you want to save the report. Then enter a name for the report in the File Name field.

3 In the Save as type field, choose a file format. Your choices are:
   - Portable Document Format (*.pdf)
   - Microsoft Excel Workbook (*.xls)
Chapter 7: Print Reports

- Microsoft Excel XML (*.xml)
- Comma Separated Values (*.csv)
- Tab Separated Values (*.tsv)
- Text Files (*.txt)

4 Click [Save].

To preview a report:
1 From the Reports menu, select the report you want to preview.
2 Click [Preview].
3 In the preview window, use the buttons at the top of the window to manipulate the display.

Table 2: Preview Button Functions

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Print]</td>
<td>Starts printing the report.</td>
</tr>
<tr>
<td>[Next Page]</td>
<td>Previews the next page.</td>
</tr>
<tr>
<td>[Prev Page]</td>
<td>Previews the previous page.</td>
</tr>
<tr>
<td>[One Page]</td>
<td>Shows one page at a time.</td>
</tr>
<tr>
<td>[Two Page]</td>
<td>Shows two pages at a time.</td>
</tr>
<tr>
<td>[Zoom In]</td>
<td>Makes the pages larger.</td>
</tr>
<tr>
<td>[Close]</td>
<td>Returns to the previous window.</td>
</tr>
</tbody>
</table>
Chapter 8: Use Address Book

Use Address Book

Address Book is a company-wide database of company and person contact information that can be shared by other Sage Timberline Office applications. Contacts for Estimating include the subcontractors, clients, engineers, and architects you work with, as well as your own company information.

Address Book is available in Estimating wherever you need contact information. For example, when you need to assign a subcontractor to an item, you can open the Address Book contact selection list from the estimate and select the subcontractor you want to use.

Other tasks in which you access Address Book from Estimating include:

- Edit a subcontractor, company contact, or person contact.
- Select your company (Company tab in the Database Settings window).
- Select the client's company (Client tab in the Estimate Information window).
- Select the architect's company (Architect/Engineer tab in the Estimate Information window).
- Select the engineer's company (Architect/Engineer tab in the Estimate Information window).
- Select the default subcontractor or vendor for a material class (Material Class window).

Select a Company Data Folder

The company data folder contains an Address Book database, Job Cost data, and other information that is used in Estimating. You need to select a company data folder to access this information. You do not have to connect to a company folder to work with Estimating; you can enter contact and job cost information and save it to the estimate instead. However, if you want consistent information in your estimates or need to make contact information available in other Sage Timberline Office applications, you must connect to a company folder.
NOTE: If you want to select a shared data folder on a mapped drive, map a drive letter to the data folder before you begin. Use the same drive letter and path that other workstations use to access the folder.

To select a company data folder:

1. From the Database menu, select Database Settings.
2. On the Company tab, select the location of the company data folder that contains your Address Book and Job Cost information. Click [Select] to choose from a list of company folders.

NOTE: If you cannot find a folder, you may not have access to the company folders that are used by your accounting department because you do not have a Sage Timberline Office accounting application installed on your workstation. Address Book requires certain program files when accessing databases used by both Estimating and accounting applications. You can set up your workstation to recognize accounting data folders without installing an accounting application. Refer to the Help topic “Setting up a workstation to recognize Sage Timberline Office accounting data folders” for more information.

3. (Optional) To configure your database to use Job Cost data stored in this folder, click on the Job Cost tab. Select Sage Timberline Office as the job cost interface type, and click the Use Sage Timberline’s Job Cost data option.

4. When you finish making changes, click [OK] to save them.

5. Click [Close].

Set Up Subcontractors

You create a subcontractor in Address Book when you want to use the subcontractor in more than one estimate or to make the subcontractor available in other Sage Timberline Office applications.

To set up a subcontractor in Address Book:

1. In the estimate, right-click in an empty cell in the Sub Name column and select Create Subcontractor > Create Subcontractor in Address Book from the shortcut menu.

2. Complete the information for the subcontractor in the Company Setup window.

3. Click [Save & Close].
NOTE: You can use Edit Subcontractor in Estimate from the shortcut menu to add an existing estimate subcontractor to Address Book.

Refresh Estimate Subcontract Information in Address Book

When you refresh the subcontractors in an estimate, Estimating copies the appropriate information from the specified company data folder (Database Settings window) to the estimate and identifies any new contacts in your estimate that are not in Address Book. You should refresh your estimate subcontractor information if you have opened a new database to work with the estimate or if you think the subcontractor information in the estimate is out of date.

NOTE: You cannot refresh your offline copy of Address Book if the shared network Address Book is in use. Before you refresh your offline copy, make sure other users are not using the shared network Address Book.

To refresh estimate subcontract information:

1. If your database is not connected to a company folder that contains Address Book or Job Cost data, connect it now.

2. From the Takeoff menu, select Refresh Estimate Subs from Address Book. Estimating opens the Refresh Vendors and Subs from Address Book window and begins refreshing the subcontractor or vendor information in your estimate.

   During the process, a progress bar appears at the bottom of the window. If Estimating encounters any conflicts between your estimate and Address Book, it creates a report that you can print when the update is complete. This report identifies any new contacts in the estimate that are not in Address Book. You can use this list to quickly identify the new subcontractors in the estimate and add them to Address Book.

3. When the process is complete, click [Close].
Chapter 9: Extended-Only Features

Estimating Extended offers several advanced features that are not available in Estimating Standard. For example:

- WBS (work breakdown structure) codes
- Crews
- Customizable Spreadsheet Sequences
- Subcontractor Bid Grids
- Adjust Spreadsheet Columns
- Model Takeoff (if you own Model Estimating)
- Move/Copy Items

Use WBS Codes

Estimating Extended lets you define as many as forty work breakdown structure (WBS) codes to provide custom spreadsheet and report sequences. WBS codes let you sort estimate items based on a scheme of your own. For example, you might want to list items by estimator, department, or bid item.

Within each WBS, you create numerous WBS values and assign them to items. After you set up a WBS code and its values, you can assign it to items at takeoff or enter it in the WBS column for items already in the spreadsheet. For example, you can set up a WBS code activity and create multiple values for the code, such as door or window installation. During item or assembly takeoff, activity appears in the takeoff grid and the values appear in drop-down list from which you can choose the one you need.

To set up WBS codes:

1. From the Database menu, select Database Settings.
2. In the Database Settings window, select the WBS tab and enter the information for each type of WBS code you want to create.
3 In the grid, right-click on a cell and select **Edit WBS Values** from the menu.

4 Complete the fields in the **Adding WBS Value** window. You can use [Copy] and [Prefill] for this purpose. At a minimum, you need to complete the **Select WBS code** and **WBS Value** fields to enter a new WBS value.

5 Click **[OK]**.

### Include the Cost of Crews

Crews, which are comprised of the resources necessary to construct an item, let you include the cost of labor and equipment in item prices. Rate tables provide the hourly rates and benefits for each resource used by your crews. You can set up special rate tables to handle local labor rates or overtime pay scales.
For example, a framing crew might consist of two labor resources, a lead carpenter and an apprentice carpenter, each with different hourly wages and benefits stored in a rate table. You assign this crew to your 2x6 stud items and Estimating then includes the cost of that crew when calculating the item price. In the spreadsheet, 2x6 stud items display item prices that include crew costs. Depending on your database settings, the included crew costs are based on the average cost for each person in the crew or on the total cost of the crew.

**To set up resources and crews:**

1. From the **Database** menu, select **Crews > Crews** to open the **Database Crew** window.
2. Click [Add] to create a new crew.
3. Enter a name and description for the crew.

**Figure 16: Setting up a Database Crew**

4. To add existing resources to the crew, click [Resources] and select the labor and equipment resources that you want to add.
5. To add new resources, right-click in the crew resource grid and select **Create Resource**.
6. Click [OK].
**Crews and Items**

You can set up items with a default crew that comes into the estimate at takeoff, or you can specify crews as you build an estimate. Any changes you make to a crew in the spreadsheet become part of that estimate but have no effect on the database.

**To assign crews to items in the estimate:**

1. From the View menu, select Spreadsheet Layout.
2. In the Spreadsheet Layout window, select the current layout and then click [Edit].
3. In the Visible column, select the Crew check box.
4. Click [OK] twice.

**NOTE:** To assign the crew to multiple items, use the Fill Down feature.

**Rate Tables**

Estimating lets you specify the rate tables at the database, estimate, and item levels. Although most items in an estimate typically use the same labor and equipment rate tables, you can easily apply a different table to individual items. You can also make changes to an existing rate table in the database and then recalculate crew costs in an estimate.

**To specify a default rate table for this estimate:**

1. From the Takeoff menu, select Estimate Information.
2. On the Main tab, enter the rate tables information.

**Spreadsheet Sequences**

Estimating lets you organize items in the spreadsheet to suit your specific needs. You can define four additional spreadsheet sequences with as many as ten sort levels each.

Once defined, the sequences appear as tabs at the bottom of the spreadsheet. You can also display the descriptions of the sort levels in the Spreadsheet Level column. Sort levels also appear when you print reports, move or copy items, and use the Find/Goto command.

As you work, you can change the sequences and sort levels at any time. You can use your favorite sequence as the default for all new estimates that you create.
To define a spreadsheet sequence and specify the sort levels:

1. From the Takeoff menu, select Estimate Information.
2. Click the Spreadsheet Sequences tab.
3. In the Sequence box, select a number and enter a brief description of the sequence.
4. Use the buttons in the Available Sorts area to add and remove the selected sort levels and to move sort levels up and down.
5. Click [OK].

NOTE: Use the Minimized Overlines option on the View menu to see all sequence levels in a single column.

Subcontractor Bids

You can enter bids submitted by various subcontractors for a group of items. After you compare the bids, you can specify the bid that you want to use for the estimate.

To enter subcontractor bids:

1. In the Sub Amount column, select the items in the estimate covered by the bid.
2. Right-click and select Open Bid Grid.

Figure 17: The Bid Grid

3. Use the default name for the bid grid, or enter a more descriptive name of your own.
4. For each bid, enter the subcontractor’s name and bid amount. Optionally, you can enter the bid quantity and unit cost to have the bid amount calculated.
5. Right-click on the Sub Name cell and select List Address Book or Estimate Subcontractors for a list of available subcontractors.
To select a subcontractor bid:

After you enter information in the bid grid for each subcontractor and compare the amounts, you can select the subcontractor that you want to use for the job.

1. Right-click the name of the subcontractor whose bid you want to use for the estimate and select **Use Subcontractor**.

2. If the included items have labor, material, other, or equipment amounts in the spreadsheet, you have the option of removing or keeping the original category amounts.
   - **Clear the labor, material, equipment, and other amounts**: This changes these category amounts to zero.
   - **Keep the existing labor, material, equipment, and other amounts**: This changes only the Sub amount; amounts in other categories remain unchanged.

3. Click [Close].

The selected subcontractor appears in the estimate in the **Sub Name** cell for all items included in the bid.

Adjust Spreadsheet Columns

You can adjust columns to modify quantities, amounts, and prices for selected cells within a spreadsheet column. For example, if certain portions of a project are duplicated, you can avoid taking the items off a second time by simply adjusting selected takeoff quantities.

There are several ways to adjust selected values: increase or decrease by a percentage, multiply or divide by an amount, replace the current amount with another, add an amount, or spread an amount to each selected cell based on its percentage of the original total. Because you decide when to make the adjustment final, you can safely try various methods until you get the result you want.

To adjust a Spreadsheet Column:

1. In the estimate, select the cells that you want to adjust. You can change cells in any one of the following spreadsheet columns: **Takeoff Quantity, Productivity** (labor and equipment categories only), **Price** (all categories), **Amount** (all categories), and **Totals**.

2. Right-click and select **Adjust Column**.
Figure 18: Adjusting a Spreadsheet Column

Choose an adjustment type and specify the amount to use to recalculate the selected cells. The following adjustment types are available:

- Percent
- Multiply
- Divide
- Replace
- Add
- Spread

4 Click [OK].

Estimating applies the adjustment, which is pending, to the selected cells.

**NOTE:** You can also adjust all the items by typing an amount at the overline level, which proportionately spreads the amount to the items beneath the overline.
To finalize an adjustment:

1 In the estimate, select the adjustments that you want to finalize. Pending adjustments are marked by a red triangle.

2 Right-click and select Adjust Column.

3 Select Finalize Adjustment as the Adjustment Type and click [OK].

After you have finalized productivity adjustments, Estimating removes the red triangle from the selected cells. The spreadsheet adjustments are now permanent and cannot be undone.

Model Takeoff

If you own Model Estimating, you can streamline the takeoff process. A model is like a template for an estimate or work element (for example, substructure or building shell). Pre-designed, it is ready to be filled in at takeoff and can be used again for similar projects. You create models in the database using questions, items, assemblies, and default values. Then during takeoff, you respond to the questions. Your answers feed values to items and assemblies and provide input for formula calculations and set conditions that determine other values in the model. What results is an estimate or work element that is created efficiently and consistently.

To perform model takeoff:

1 Click [Model Takeoff] on the toolbar to open the Model Takeoff window.

2 Select a model and take it off.
3 In the **Create Interview** window, enter a model reference.

4 Answer the questions in the interview and enter in any missing values. Your responses provide the variable information for the included assemblies and items.

5 Click [OK].

Estimating saves the model but does not send the information to the estimate.

**To generate a model to the estimate:**

1 ![Model Takeoff] Click [Model Takeoff] on the toolbar to open the **Model Takeoff** window.

2 Select **Estimate as the Source** and select the model you want to generate.

3 Click [Generate].

4 In the **Generate Models** window, the model you selected in step 3 is marked to be generated to the estimate. Click [OK]. Estimating begins generating items and assemblies into the spreadsheet.
During the process, a progress bar appears at the bottom of the window and the generation log lists the model name with its items and assemblies.

5 When processing is complete, click [OK].

6 Click [Close] to return to the Model Takeoff window.

7 Click [Close] again to return to the spreadsheet. All items and assemblies from the model are now included in the estimate. You can later modify the model and regenerate it to the spreadsheet, if necessary.

Move/Copy Items

You can move or copy items to another spreadsheet level in the estimate when the spreadsheet items are not combined and the current spreadsheet sequence includes one of these levels:

- Work Breakdown Structure (WBS)
- Location
- Subcontractor
- Material Class
- Model
- Job Cost Phase
- Unassigned—Items that appear under the Unassigned level do not correspond to the current spreadsheet sequence levels. For example, if the current spreadsheet sequence is Location, items under the Unassigned level do not have a location code assigned to them.

Move/Copy is not available for the first three spreadsheet sort tabs: Phase/Item, Takeoff Order, or Assembly.

Move or copy items, as follows:

1 In the estimate spreadsheet, right-click on the row header and select Move/Copy, or click [Move/Copy] on the spreadsheet toolbar.

2 The field labels in the window correspond to the current spreadsheet sort sequence. Select the appropriate primary and/or secondary level.

3 Click Move or Copy, as appropriate.

4 Click [OK].
Multi Currency

You can use multiple foreign currencies on your estimates. This allows you to change an estimate from its base currency to any foreign currency you need. It also allows you to accept bids in a currency other than the base currency.

To turn on the multi currency feature and set up your base currency on the estimate, select Takeoff > Estimate Settings. On the Miscellaneous tab, select Enable Multi Currency and type the base currency. When multiple currencies are used, additional columns appear in the spreadsheet and on the bid grid for the currency amount, price, and conversion factor.

The estimate inherits the base currency that is set up on the database. If no base currency is set up on the database, you can select a base currency on the estimate in the estimate settings, as described above. To set up your base currency on the database, select Database > Database Settings and on the Miscellaneous tab, type the base currency.

You can set up your multiple currencies on the multi currency table. This table can be password protected to prevent changes from being made. To set up your multiple currencies, select Takeoff > Multi Currency Table.

You can apply foreign currencies to any cost category on an item. To do so, select the desired foreign currency from the [Category] Foreign Currency column on the spreadsheet. Estimating calculates the foreign currency price and amount based on the base price and amount. You can enter either a foreign currency price or foreign currency amount and Estimating does a reverse calculation to determine the base price and amount.

You can view the foreign currency totals in the Totals window.

If you update the currency conversion factor in the table and you want your estimate to use the current conversion factors, you can update the estimate from the multi currency table. To update the estimate from the multi currency table, select Pricing > Update Estimate from Multi Currency Table.
Chapter 10: Use Database Editor

Database Editor is a Microsoft Windows-based editor for Estimating databases. You can use a familiar spreadsheet interface to:

- View, create, edit, and delete group phases, phases, and items.
- Filter and find data elements.
- Replace text within all data elements or a range of data elements.
- Undo edits.
- Renumber phases or items to move them in the database.
- Save and select layouts for phases and items.

Start Database Editor

From the Windows Start menu, select Program Files > Sage Timberline Office > Estimating > Database Editor.

Open a Database

You can open only Estimating database files. Use the steps that follow to open a database:

1. From the File menu, select Open.
2. Navigate to a folder that contains an Estimating database.
3. Select pei.dat.
4. Click [Open].
Create and Edit Database Elements

Database Editor validates the formatting of data when you create and edit records.

To create data:

1. Open the Phases or Items table.
2. Select a row or cell.
3. From the Edit menu, select Insert row or right-click and select it from the menu. Database Editor inserts a row above the one you selected.
4. Type data in each required cell.
5. When you finish typing data in the row, press ENTER. Database Editor validates the data, writes it to the database, and inserts a new blank row.
6. When you finish creating data, press ESC in a blank new row (you can also select a cell in another row). Database Editor exits insert mode.
NOTE: When you finish entering data in a new row, Database Editor re-sorts the table and inserts a second row at the place you started. For example, you finish inserting phase 100.000 above phase 500.000; the new row remains above phase 500.000 and phase 100.000 moves to its place in the sort order.

To edit existing data:
1 Select a cell.
2 Type data in the cell.
3 Select a new cell. Database Editor validates the data and writes it to the database when you leave the row.

Save and Select Column Layouts

You can save column layouts under different names and apply them at will. When you save a column layout, Database Editor remembers:

- The column widths and locations.
- The column names.
- Whether or not columns are visible or locked.

To save a new column layout:

1 Right-click a column header and select Save Layout As.
2 In the Save Layout As window, type a name for the layout. You can type up to 30 characters.

Figure 21: Saving a New Column Layout

3 Click [OK].
About Filters

Filters let you display only the data that you want to view. For example, you can create a filter to display phases within a certain range or items with the word concrete in the description. You can also use a filter to easily locate empty fields. This allows you to quickly focus on only the items you need to modify.

To modify filters:

Use the Modify Filter window to create new or edit existing filters.

1. Open the Manage Filters window.
2. From the Tools menu, select Manage Filters.

Figure 22: The Manage Filters Window

3. Click [New] to create a new filter or select a filter and click [Edit] to modify an existing filter. If you create a new filter, type a name for the filter in the Filter box. The first character must be a letter or a number. You can type up to 30 characters.

4. Select a field from the Field Name list.

5. Select an operator from the Test list.

6. Type a filter value in the Value column. You can type as many characters as you want.

7. Continue setting up rules in the filter using either And or Or to separate them. You can set up to ten rules for one filter.

8. Click [OK].
Appendix: Keyboard Shortcuts

Estimating offers many keyboard shortcuts that you can use to access commands. The shortcuts available depend on your cursor placement; some shortcuts are specific to certain windows or spreadsheet columns.
**Table 3: General Shortcuts and Hotkeys**

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Displays Help for a field or button.</td>
</tr>
<tr>
<td>SHIFT+F1</td>
<td>Displays Help for toolbars and screen areas.</td>
</tr>
<tr>
<td>F2</td>
<td>Lets you edit the contents of a cell or field.</td>
</tr>
<tr>
<td>F4</td>
<td>Opens the <strong>Totals</strong> window.</td>
</tr>
<tr>
<td>CTRL + F4</td>
<td>Closes the active window.</td>
</tr>
<tr>
<td>ALT + F4</td>
<td>Closes all Estimating windows.</td>
</tr>
<tr>
<td>F7</td>
<td>Scans for the next incomplete cell.</td>
</tr>
<tr>
<td>F8</td>
<td>Lets you edit database records.</td>
</tr>
<tr>
<td>F9</td>
<td>Starts Digitizer (if you own Digitizer).</td>
</tr>
<tr>
<td>F10</td>
<td>Opens a list.</td>
</tr>
<tr>
<td>F12</td>
<td>Starts ePlan Takeoff (if you own ePlan Takeoff).</td>
</tr>
<tr>
<td>SHIFT + F10</td>
<td>Opens the shortcut menu.</td>
</tr>
<tr>
<td>CTRL + F12</td>
<td>Shows information about the database and the locale.</td>
</tr>
<tr>
<td>ALT + F</td>
<td>Displays a drop-down list.</td>
</tr>
<tr>
<td>ESC</td>
<td>Ends the field edit without saving your entry.</td>
</tr>
<tr>
<td></td>
<td>Expands an entry in a list.</td>
</tr>
<tr>
<td></td>
<td>Collapses an entry in a list.</td>
</tr>
<tr>
<td>Underlined letter</td>
<td>Executes a menu command or button when you type ALT and then the letter.</td>
</tr>
<tr>
<td>[Ctrl]+[A]</td>
<td>Opens the <strong>Cuts and Adds</strong> window (from the <strong>Totals</strong> window).</td>
</tr>
<tr>
<td>Shortcut</td>
<td>Result</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------------------------------</td>
</tr>
<tr>
<td>[Alt]+[S]</td>
<td>Opens the <strong>Search</strong> area for a list.</td>
</tr>
<tr>
<td>[Alt]+[R]</td>
<td>Moves your cursor to the <strong>Search</strong> field.</td>
</tr>
</tbody>
</table>
Table 4: Spreadsheet Shortcuts and Hotkeys

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + 1</td>
<td>Opens the <strong>One-time Item</strong> window.</td>
</tr>
<tr>
<td>CTRL + A</td>
<td>Opens the <strong>Cuts and Adds</strong> window (from the <strong>Totals</strong> window).</td>
</tr>
<tr>
<td>CTRL + D</td>
<td>Opens the <strong>Detail</strong> window.</td>
</tr>
<tr>
<td>CTRL + E</td>
<td>Goes to the first visible equipment column.</td>
</tr>
<tr>
<td>CTRL + F</td>
<td>Opens the <strong>Find/Goto</strong> window.</td>
</tr>
<tr>
<td>CTRL + I</td>
<td>Lets you edit the selected item in the database.</td>
</tr>
<tr>
<td>CTRL + L</td>
<td>Goes to the first visible labor column.</td>
</tr>
<tr>
<td>CTRL + M</td>
<td>Goes to the first visible material column.</td>
</tr>
<tr>
<td>CTRL + N</td>
<td>Opens the <strong>Notes</strong> window.</td>
</tr>
<tr>
<td>CTRL + O</td>
<td>Goes to the first visible other column.</td>
</tr>
<tr>
<td>CTRL + P</td>
<td>Lets you edit the selected phase in the database.</td>
</tr>
<tr>
<td>CTRL + Q</td>
<td>Goes to the <strong>Takeoff Quantity</strong> column.</td>
</tr>
<tr>
<td>CTRL + S</td>
<td>Goes to the first visible subcontractor column.</td>
</tr>
<tr>
<td>CTRL + T</td>
<td>Goes to the first visible total column.</td>
</tr>
<tr>
<td>F2</td>
<td>Lets you edit a cell.</td>
</tr>
<tr>
<td>F3</td>
<td>Finds the next item that matches the current search criteria.</td>
</tr>
<tr>
<td>F4</td>
<td>Opens the <strong>Totals</strong> window.</td>
</tr>
<tr>
<td>F11</td>
<td>Opens the <strong>Calculator</strong> window.</td>
</tr>
<tr>
<td>Shortcut</td>
<td>Result</td>
</tr>
<tr>
<td>----------------</td>
<td>----------------------------------------------------------</td>
</tr>
<tr>
<td>ESC</td>
<td>Cancels your changes to a cell.</td>
</tr>
<tr>
<td>CTRL + PAGE DOWN</td>
<td>Goes to the next spreadsheet sequence tab.</td>
</tr>
<tr>
<td>CTRL + PAGE UP</td>
<td>Goes to the previous spreadsheet sequence tab.</td>
</tr>
</tbody>
</table>