
Chapter 1—Introduction
Sage is pleased to provide you with multiple options for expanding Sage Estimating's capabilities and
features. Read the applicable chapters in this manual to learnmore information about your Sage
Estimating options.

Available Options for Sage Estimating
The following options are available for Sage Estimating:

n RS Means Integrator. The RS Means Integrator lets you add RS Means item pricing databases to your
Sage Estimating software. Using the RS Means Integrator, you can also update your Means price
databases on a recurring basis.

n On-Screen (ePlan) Takeoff Integrator. TheOn-Screen Takeoff (OST) Integrator lets you perform item
and assembly takeoff in Sage Estimating from drawings you create in On-Screen Takeoff.

n License Manager. LicenseManager provides ameans for managing licensing for Sage Estimating
operators. Installation and configuration instructions are found in chapter three of the Installation Guide.
Read this manual for LicenseManager operating instructions.

Read the Supporting Documentation Before You Begin
Be sure to read supporting documentation before you install and configure your Sage Estimating options:

n This Options Guide provides installation, setup, and operating instructions for each of the available
Sage Estimating options, such as the OnScreen Takeoff Integrator or LicenseManager.

n The Installation & Administration Guide includes an overview of the latest Sage Estimating release,
installation instructions, system requirements, and contact information. This document is available in
theDocuments folder of your Sage Estimating installation files.

n TheRelease Notes provide details about new features, database changes, known issues, and fixes.
This document is available in theDocuments folder of your Sage Estimating installation files.

n TheGetting Started Guide provides an operational overview of the Sage Estimating software. This
document is available in theDocuments folder of your Sage Estimating installation files.

n TheSQL Server Guide gives you an overview of the significant differences between the new
SQL Server databases and the Pervasive databases used in previous Sage Estimating releases. This
document is available in theDocuments folder of your Sage Estimating installation files.

These documents are current at the time of the release. To learn about issues that have arisen since this
document was published, go to www.sagecre.com.
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Conventions Used in this Document
This document uses the following conventions:

n Information you type into the software is shown in bold font. For example: TypeMiscellaneous in the
box.

n The names of screens, windows, fields, and other features displayed by the software are shown in bold
font.

n The names of buttons you can click are enclosed in brackets with bold font. For example: [OK] or
[Post].

n Names of keys are shown in capital letters. For example: ENTER or TAB. A plus sign (+) between two
key names indicates you should press the keys simultaneously.

n Variable names or names that are specific to your installationmay appear in italics and brackets. For
example: [Drive]\\[Server].

Symbols

NOTE: This symbol is used when presenting information that is supplemental to the adjacent text.

TIP: This symbol is used when presenting helpful information for using the software.

CAUTION: This symbol is used when presenting important information to help you avoid a loss of
critical data.

IMPORTANT: This symbol is used when presenting information that is critical to understand or that
requires you to take action.

Menu Paths
In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font
with angle brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Online Help
The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To access the online Help in the Sage Estimating software, click the Help button or icon, or press [F1] to
display the Help topic for that window.
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To aid you in finding the information you need, the online Help for eachmodule includes the following
panes:

n Contents pane containing links to the Help topics

n Index pane containing keywords that link to Help topics related to that keyword

n Search pane, where you can type text and click [Search] to locate that text in the Help topics

For more information about using the online Help, see the Sage Estimating Help.

Wewould like your feedback about the online Help so we canmake improvements. Each Help topic
contains an area where you can indicate whether the topic was helpful and provide additional comments.
To protect your privacy, all comments are anonymous.

Training
Sage University offers online and classroom training sessions to help you get themost out of your Sage
Estimating software. To access Sage University, visit www.sageu.com.

You can also get access to Sage University from the File menu by selectingHelp > Sage Estimating on
the Web > Sage University.

Technical Assistance
When you need assistance, refer to the Knowledgebase article How do I get technical support for Sage
Estimating? to determine which service works best for you.

Submitting Enhancement Requests
Wewant to hear your suggestions for improving the software. To send us your comments, click the File
menu button and select Help > Sage Estimating on the Web > Submit Enhancement
Requests.

Training
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Chapter 2—Means Integrator
Sage Estimating offers Means Integrator cost data files that you can use to create, extend, or update item
costs in your Estimating Standard databases with current costs for corresponding items in the RSMeans
Cost Data Books. If you use RSMeans cost data in your estimates, read this chapter for instructions on
updating the following Estimating Standard databases:

n Construction Knowledgebase. The Construction Knowledgebase is a Sage Estimating Standard
database that contains Means items and other data. You can use theBuilding and Construction
Cost Data (BCCD) Means cost data file to update prices in this database.

n Residential Knowledgebase. The Residential Knowledgebase is a Sage Estimating Standard
database that contains Means items and other data. You can use theResidential Cost Data Prices
(DB1-20) Means cost data file to update prices in this database.

n Any Estimating Standard databases that were created or extended usingMeans cost data files.

Overview
TheMeans Integrator cost data files correspond to the RSMeans Cost Data Books you receive with your
shipment.

With Sage EstimatingMeans Integrator, you can create or extend Estimating Standard databases with
items that match those in the RSMeans Cost Data Books. You can also update prices for your existing
Estimating Standard databases that contain RSMeans items.

1 Install or upgrade to Sage Estimating version 15.11 if you do not already have it installed on your
computer.

2 Insert theMeans installation CD into the CD drive of the workstation or server where Sage Estimating is
installed.

3 From the installation browser:

a Select theMeans data for Sage Estimating.

b Click [Browse], and then browse to the server or workstation where you want to store your Means
Integrator cost data files.

c Select the check box next to eachMeans Integrator cost data file you want to install, and then click
[Install].

4 After the installation is finished, start theMeans Integrator by clickingStart > All Programs > Sage >
Sage Estimating 15.11  > Sage Means Integrator 15.11. (InWindows 8 andWindows 8.1, select
Start > All apps > Sage > Means Integrator.)

5 Follow the steps through theMeans Integrator wizard.
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Means Integrator Workflows
Integrating your RSMeans Cost Data is a five-step process.

Step One: Prepare Database
In theMeans Integrator wizardPrepare Databasewindow, you can select whether to transfer data or
update data. The following information describes the outcome of these options.

Transfer Data

Select Transfer Data if you want to move RSMeans items to a new or existing Sage Estimating database.

n Transfer Data—New Database

Select this option to create a new Sage Estimating Standard database and populate it with all of the
RSMeans items.

NOTE: You cannot set job cost interface specifications for a new Standard database using this option.
Youmust first create a new Standard database, set up job cost specifications (such as phase suffix and
company), and then transfer RSMeans data to the new database using theExisting Database option in
this window. See theMeans Integrator Help for more information.

n Transfer Data—Existing Database

Select this option when you want to transfer theMeans items to an existing Sage Estimating Standard
database.

If you select this option, theMeans Integrator transfers the RSMeans items directly to the selected
Sage Estimating Standard database. The resulting database will contain both your existing phases and
items and the RSMeans phases and items.

NOTE: Addition of RSMeans phases and items could cause your phase sort to appear differently in
Sage Estimating if the RSMeans items have a different phase format than those already in the Standard
database.

If you are transferring RSMeans Cost Data to a new database, also select a company to associate with
the data, then specify the length of the normal work periods and the default crew pricingmethod. Sage
Estimating displays the specified information in theDatabase Settingswindow whenever you open the
database.

Update Data

Select Update Data if you need to update the prices of RSMeans items in an existing Sage Estimating
Standard database.

Chapter 2—Means Integrator
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Chapter 3—License Manager
LicenseManager tracks and updates network licenses for Sage Estimating. Use LicenseManager to
share pools of licenses between operators on the network. For example, if you have seven estimators who
are connected to the network and you own five network licenses for Sage Estimating, up to five of the
seven estimators can use the software concurrently.

After a few installation steps, LicenseManager works behind the scenes tomanage concurrent uses for
Sage Estimating.

Read this chapter to learn how tomanage licenses, use environment variables, and troubleshoot any
issues that youmay encounter. For instructions on installing and configuring LicenseManager, see the
Installation & Administration Guide in theDocuments folder of your Sage Estimating setup and
installation files.

License Management Components
The following table describes the components required to install andmanage Sage Estimating licenses.

TheDocumentation column lists sources for component-use information.

Table 1: Required LicenseManager Components

Component Function Documentation

LicenseManager Tracks program uses on the
network

These files are in theDocuments folder of your Sage
Estimating setup and installation files:

n Installation and Administration Guide

n Sage EstimatingOptions Guide

This file is in the
AdditionalInstalls\LicenseManager\SysAdminHelp
folder of your Sage Estimating setup and installation
files.

n Sentinel LicenseManager System Administrator
Online Help (Default.html).

LicenseManager
protection device

Attaches to the USB port of
the server hosting License
Manager. It is a security
device that authorizes
LicenseManager to
distribute licenses.

n Sentinel LicenseManager System Administrator
Online Help

n Installation and Administration Guide

n Sage EstimatingOptions Guide

License Tools Perform tasks, such as n Sentinel LicenseManager System Administrator
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Component Function Documentation

check licenses in and out
(WCommute.exe); check
licenses in and out remotely
(Wrcommute.exe); test the
protection device
(Wechoid.exe); andmonitor
licenses (Wlmadmin.exe).

Online Help

n Sage EstimatingOptions Guide

n Sentinel LicenseManager System Administrator
Online Help (index.html).

Sentinel driver

Allows communication
between LicenseManager
and the LicenseManager
protection device.

n Sentinel LicenseManager System Administrator
Online Help

NOTE: Due to changes in software environments, some options in Sentinel LicenseManager
System Administrator Online Helpmay not be supported. Please contact Customer Support if you
experience issues viewing the LicenseManager System Administrator Online Help.

Work With Commuter Licenses
Commuter licenses allow you to start estimating products in a stand-alone environment (no network
connections, no protection device). While you are connected to the network, use Commuter License
Manager (WCommute.exe) to check licenses in and out from the licensemanager in order to make them
available when you are not connected to the network.

NOTE: If you have an unexpired commuter license, you do not need a protection device.

Check Out Licenses
1 From the workstation or notebook computer you will use when disconnected from the network, select
Start > All Programs > Sage > Sage Estimating > License Manager > Commuter License
Manager.

If this menu option is not available to you, you can start the program by browsing to \\Additional
Installs\License Manager\Admin.Net\Wcommute.exe in your Sage Estimating setup and installation
files.

2 From the Filemenu, select Search Subnet.
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Figure 1: The Commuter LicenseWindow

3 From the list of programs with available licenses, select the program that you want to check out.

NOTE: The list displays one line for each program that is available. If you want to see the status of all
licenses, useWlmAdmin. For more details, see “Monitor Licenses” on page 11.

4 Enter the number of days (1 to 180) that you will need the license.

5 Click [Check Out]. You will see a red check mark next to the program that you just checked out.

6 Repeat this process to check out licenses for all the programs that you will need while you are
disconnected from the network.

7 When you finish, close theCommuter Licensingwindow.

Check In Licenses
You can check licenses in before or after their time limits expire so that they are available for others.

1 When you are once again connected to the network, select Start> All Programs >Sage>Sage
Estimating > License Manager > Commuter License Manager.

If this menu option is not available to you, you can start the program by browsing to \\Additional
Installs\License Manager\Admin.Net\Wcommute.exein your Sage Estimating setup and installation
files.

2 From the Filemenu, select Search Subnet. A list of programs with licenses appear.

p Programs with checked out licenses appear in the list with a red checkmark.

Work With Commuter Licenses
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p Programs with licenses that have expired appear in the list with a red “x.”

3 From the list of licenses, select the program for which you want to check in a license and click [Check
In].

4 When you finish, close theCommuter Licensingwindow.

Monitor Licenses
TheWlmAdmin program is amonitoring tool used to check the number of licenses, confirm how many are
in use, check the status, and see to who is using the licenses. It is useful for determining why a license
manager or available license cannot be found. WlmAdmin allows you to view:

n A list of licensed programs.

n The names of the users (if any) who are currently using the licenses.

n The total number of licenses purchased for each program. (WlmAdmin refers to programs as “features.”)

To start WlmAdmin, select Start> AllPrograms > Sage > Sage Estimating > License Manager> LM
Admin.

If this menu option is not available to you, you can start the program by browsing to \\Additional
Installs\License Manager\Admin.Net\WlmAdmin.exe in your Sage Estimating setup and installation
files.

Chapter 3—LicenseManager

11 Sage Estimating (SQL)

This
 ve

rsi
on

 of
 th

e s
oft

ware
 

ha
s b

ee
n r

eti
red



Figure 2: TheWlmAdminWindow

TheWlmAdmin window has the following features:

n The left pane shows a list of all licensed programs. For example, PWX-ENU identifies Sage Estimating.
Double-click on a program to expand it and view the names of those who currently have licenses
checked out.

n The right pane shows details about the selected program (for example, the total number of licenses
available and the number of licenses in use).

Environment Variables
In certain circumstances, youmay need to use an environment variable to resolve one of themessages
outlined in Section 3. For example, if you usemultiple licensemanagers to run other programs, youmay
want to specify which licensemanager to use when obtaining available estimating licenses. For
instructions on setting these variables, see “How to Set Environment Variables ” on page 13.

Environment Variables
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Valuable Environment Variables
LSFORCEHOST

This variable is a valuable troubleshooting tool to use when license acquisition issues arise. The variable
can be used to direct client stations to a specific LicenseManager server. If that licensemanager is not
found, the program stops searching and returns an error message; it does not check every computer on the
network for a license server.

LSPROTOCOL

This variable allows you tomatch the communications protocol of the licensemanager and the client.
Because youmust be certain that the licensemanager and the client both use the same protocol,
LSPROTOCOL is especially helpful in multi-protocol environments. For example, if the licensemanager
uses only IPX and the client uses IPX and TCP, you would use LSPROTOCOL to set the client to IPX.
The value to set for IPX/SPX is IPX. The value for TCP/IP is UDP.

LSHOST

This variable is used when you want the client to search from a list of potential servers. If none of those
servers are found, the client looks to the network for any license server.

For a complete list of environment variables with more detail, seeSentinel LM System Administrator
Help, located in the Sage Estimating setup and installation files at
\\AdditionalInstalls\LicenseManager\SysAdminHelp\index.html.

NOTE: Due to changes in software environments, some options listed in Sentinel LM System
Administrator Helpmay not be supported. Please contact Customer Support for more information.

How to Set Environment Variables
You should configure environment variables properly for your network. For more information, seeSentinel
LM System Administrator Help, located in the Sage Estimating setup and installation files at
\\AdditionalInstalls\LicenseManager\SysAdminHelp\index.html.

To Set LSFORCEHOST or LSHOST

1 Determine the IP address or name of the computer that hosts LicenseManager.

p To determine the IP address of the computer, type ipconfig at a command prompt.

p To determine the name of the computer:

l In Windows 7:Select Start > Control Panel > System and Security > System.

l In Windows 8 and Windows 8.1:Select Start > All apps > Windows System > Control
Panel > System and Security > System.

2 Set environment variables:

Chapter 3—LicenseManager
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Figure 4: Setting the LSPROTOCOLVariable

3 In theVariable Name field, type the variable LSPROTOCOL.

4 In theVariable Value field, type the appropriate protocol.

5 The value to set for IPX/SPX is IPX. The value for TCP/IP is UDP.

6 When you finish, click [OK].

Error Messages
When a program cannot find a workstation protection device or an available network license, youmay
receive one of the following error messages. Use the information in this section to resolve the issue.

"A network error occurred"
A network error usually means that the workstation is not attached to the network. To resolve this
message, make sure that the workstation is attached to the network (browse to the computer on which
LicenseManager is installed); then try again to start a program.

Youmay also receive this message because neither TCP/IP nor IPX/SPX protocols are installed. To
resolve the issue, verify that LicenseManager is installed on aWindows- based operating system. (You
can use LicenseManager on a network with a Novell server andWindows workstations, provided it is
installed on one of theWindows workstations.) Also, verify that the LicenseManager computer and the
workstations contacting it are using the same communications protocol (TCP/IP or IPX/SPX).

If any of the workstations contacting LicenseManager have both TCP/IP and IPX/SPX installed and the
LicenseManager computer has only IPX/SPX installed, set the LSPROTOCOL to IPX on those
workstations. For more information on how to do this, see “Environment Variables” on page 12. After you
set the environment variable, try again to start the program.

If you still cannot resolve themessage, contact your network administrator.

Chapter 3—LicenseManager
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To install License Manager

See chapter three of the Installation and Administration Guide available on theDocuments folder of your
Sage Estimating setup and installation files for instructions.

"No servers running on this subnet"
Both the licensemanager and its clients must be in the same subnet, or youmust use LSFORCEHOST. If
you start WlmAdmin and no licensemanagers are found, youmay have a connection barrier (see “Monitor
Licenses” on page 11 for more information on runningWlmAdmin).

To resolve the issue:

1 Verify that the workstation is attached to the network (browse to the computer on which License
Manager is installed).

2 If you cannot browse to the computer and you use TCP/IP, ping that licensemanager (see “Using the
Ping utility” on page 18 following this section).

The ping utility sends four communications packets to the target computer. If received, the four packets
are sent back to the source computer. The round trip process is timed to benchmark communication
performance.

3 Start WlmAdmin from the licensemanager. You should see the computer’s host name, the IP or IPX
address, and what licenses (if any) have already been installed.

4 If none of the above helps resolve the issue, contact Customer Support.

Using the Ping utility

To use the Ping utility:

1 Determine the IP address or name of the computer that hosts LicenseManager.

2 To determine the IP address of the computer, type ipconfig at a command prompt.

To determine the name of the computer:

p In Windows Vista and Windows 2008 Server:Select Start > Control Panel > System and
Maintenance > System.

p In Windows 7:Select Start > Control Panel > System and Security > System.

p In Windows 8 and Windows 8.1:Select Start > All apps > Windows System > Control Panel
> System and Security > System.

3 From the command prompt on the client workstation from which you want to test communications, type
ping and the name or address of the computer on which LicenseManager is installed and running (for
example, type ping 192.168.40.193). Make sure to type a space after the word ping.

4 Examine the ping results to determine whether there is a connection barrier:

Error Messages
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3 All license codes in LSERVC will have # as their last character. Youmay also use LM Admin to view
the installed license codes (“Monitor Licenses” on page 11).

4 Use the LSPROTOCOL environment variable to set the communication protocol (IPX/SPX or TCP/IP)
to match that of the licensemanager. For more information, see “Environment Variables” on page 12.

If you still cannot resolve themessage, remove the protection device, restart the computer, and then try to
reinstall the license code. If this works, use the following procedure to determine whether you have a bad
device, in which case you should contact Customer Support.

Testing the protection device

To test the protection device:

To verify that the LicenseManager protection device is being detected, runWechoid.exe from the
computer on which LicenseManager and the protection device are installed. Wechoid is a utility you can
use to determine the locking code of a LicenseManager server.

1 Locate and then double-clickWechoid.exe. It can be found at
\\AdditionalInstalls\LicenseManager\Admin.net in your Sage Estimating setup and installation files.

2 In theWechoidwindow, clear all check boxes exceptComputer ID.

3 Under Locking Data, confirm the following:

p Selector: 0x80

p Code: 0x1FB03
If any other information appears, the device cannot be found or is not working.

Error Messages
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Chapter 4—Sage 300 Construction and
Real Estate Job Cost Integration
If you use Sage 300 Construction and Real Estate Job Cost, you can transfer estimate information directly
into your job costing application. This allows you to access budget and transaction data without reentering
the information. This section covers the interface between Sage Estimating and Sage 300 Construction
and Real Estate Job Cost, which enables the information transfer.

Overview
When Sage Estimating sends estimate information to Sage 300 Construction and Real Estate Job Cost, it
sends the information directly to the Job Cost application's New.jct file. Sage 300 Construction and Real
Estate Job Cost can then access the estimate data without having to import it first.

Figure 7: The Sage Estimating-Job Cost Interface

For detailed information about Job Cost concepts, see the in-product Help in Sage 300 Construction and
Real Estate Job Cost.
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Setup Guidelines
To help ensure a smooth data transfer between Sage Estimating and Job Cost, follow these guidelines:

Sage 300 Construction and Real Estate Job Cost
Before you export data from Sage Estimating, ensure that in Job Cost:

n Standard cost codes exist for each cost code sent from Sage Estimating.

n If you use categories, standard categories exist for each category sent from Sage Estimating.

n Operators working with estimate data have the appropriate security permissions for the following:

p Job Cost Enter Estimates or Import tasks

p File access (to the .jct file)

p Company security

p Job record security

Sage Estimating
Before you create an estimate to send to Job Cost, make sure the database settings for phases, items,
and addons are set up correctly for your needs. Any changes made to these settings after an estimate is
created do not affect existing phases, items, or addons. Existing phases, items, and addons must be
changed individually if you want the new settings to be reflected in Job Cost.

Before you send estimate information to Job Cost, ensure that:

n Database Phase settings aremapped to the desired Job cost phase.

n Database Item settings aremapped to the desired Job Cost Phase and Job Cost Category.

n Database Addon settings aremapped to the correct Job Cost Phase and Category.

n The BOM description for the items are 30 characters or less. Job Cost can only accept up to 30
characters for the bill of materials description.

Prepare Sage 300 Construction and Real Estate Job Cost to
Receive Estimates
Youmust verify two items in Sage 300 Construction and Real Estate Job Cost to successfully transfer
estimate information from Sage Estimating:

Chapter 4—Sage 300 Construction and Real Estate Job Cost Integration
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n All needed standard cost codes are set up. To see a list of standard cost codes that are already set
up in Job Cost, from the Job Cost Reports menu, select Lists > Standard Cost Codes. If you do not
see a cost code that you know exists in the estimate or estimates, select Setup > Standard Cost
Codes to set up the standard cost code.

n Standard categories are set up (if your company uses categories). Using categories is optional. If
you do not use categories, you do not need to verify that they exist. To see a list of standard categories
that are already set up, from the Job Cost Reportsmenu select Lists > Standard Categories. If you do
not see a standard category listed that you know exists in the estimate or estimates, select Setup
> Standard Categories to set up that category.

Prepare Sage Estimating to Send Estimates
Perform the following tasks in the Sage Estimating software to send estimate information to Sage 300
Construction and Real Estate Job Cost.

n Enable the Job Cost interface.

n Verify standard database phase settings.

n Verify the standard database item settings.

n Verify the standard database addon settings.

Enable the Job Cost interface
Set up standard databases individually to interface with Sage 300 Construction and Real Estate Job Cost
by enabling the interface in the Sage Estimating EstimatingManagement Console:

1 Click on the EstimatingManagement Console desktop icon .

2 In the EstimatingManagement Console, click on theStandard Databases tab.

3 Select the desired standard database from the list of standard databases in theStandard Database
Catalog pane.

4 If desired, you can also create a new standard database by clicking [New Standard Database]. Fill out
the new standard database details on the provided tabs in the detail pane and click [Create].

5 Select Sage 300 Construction and Real Estate as the job cost interface in the Job Cost Info area of
the detail pane.

Prepare Sage Estimating to Send Estimates
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Figure 14: Selecting a Phase and Category for Job Cost

Export Estimate data to Sage 300 Construction and Real
Estate Job Cost
Use theExport to Job Cost feature in Sage Estimating to send estimate data to Sage 300 Construction
and Real Estate Job Cost:

1 In Sage Estimating, select Interface tab > Job Cost Options > Export to Job Cost (in classic view,
select Interfacemenu > Job Cost).

2 The Job Cost Transferwizard opens. Use the Job Cost Exportwizard to export the following
estimate data:

p Each phase for which you have entered a phase quantity in the spreadsheet.

p Each item category with an amount. The item setup determines whether the transaction includes the
takeoff quantity or order quantity.

p Each addon that is not allocated. The cost of allocated addons is found in the items used to calculate
those addons.

Chapter 4—Sage 300 Construction and Real Estate Job Cost Integration
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Figure 20: TheOn-Screen Takeoff Integrator MainWindow

Condition Assignment Pane
The Condition Assignment pane provides a list from which you canmatch or assign items or assemblies in
Sage Estimating with conditions in anOST database.

For example, if you are working with anOST project or drawing that has a condition for 30 square feet of
ceramic floor tile, and the closest equivalent in a Sage Estimating database is the 04-00-10 Masonry, Tile
assembly, select the ceramic floor condition in the list, click the Assign Assembly button , and select
the 04-00-10 assembly to assign it to the ceramic floor condition.

Sage Estimating items and assemblies appear in the list beneath the OST conditions to which they are
assigned.

Condition Properties Pane
The Condition Properties pane displays the physical qualities of any OST condition selected in the
Condition Assignment pane, such as depth, height, or count (number). Youmust "map" these properties to
their Sage Estimating equivalents in the Integration grid when you assign an item or assembly to anOST
condition.

For example, if the selected OST condition has a length of 30 meters as a physical property or dimension,
and the Sage Estimating assembly you assign to it measures length in feet, youmust map the
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OST condition's length (using the Integration grid) to the assigned assembly's length and indicate the
conversion factor frommeters to feet.

Mapping condition properties enables the OST Integrator to create accurate estimates when performing
takeoff from anOST condition.

Integration Grid
Use the Integration grid to "map" or convert the properties of an OST condition to the variable equivalent of
its assigned Sage Estimating item or assembly.

For example, if you are working with a "drywall ceiling" condition from anOST drawing that has a length of
30meters, and you assign the 09-00-10 Drywall assembly from Sage Estimating to it, youmust ensure
the Sage Estimating assembly has a variable equivalent for length in meters.

To beginmapping, select any condition from the Condition Assignment pane that already has a Sage
Estimating item or assembly assigned to it. The grid displays the estimating variables andOST condition
properties associated with the selected condition.

Refer to the OST Integrator in-product Help for information about specific columns in the grid.

Performing Integration
Before integrating OST items and conditions with Sage Estimating items and assemblies, select both an
OST database and a Sage Estimating database you want to use for the integration and takeoff processes.

You can open either aMicrosoft Access-basedOST database or aMicrosoft® SQL Server®-based
OST database for integration. See theOST Integrator Help for more information.

To integrate OST conditions with Sage Estimating items and assemblies:

NOTE: Ensure you open anOST database before performing this procedure.

1 Select a condition for takeoff in OST.

2 In the OST Integrator, click theGoto button to view the selected condition and its associated items
in the Condition Assignment pane of the OST Integrator.

3 In the Condition Assignment pane, expand theOST condition to view any items or assemblies already
assigned to it.

NOTE: You can right-click on any condition and select Expand condition to expand it.

4 Click the assign item button to open the Item Listwindow or the assign assembly button to open
theAssembly Listwindow.

Performing Integration
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This window lists all available Sage Estimating items or assemblies in the selected Sage Estimating
standard database.

5 Select an item from the list in the Item Listwindow or an assembly from theAssembly List window
and click [OK].

The assigned item or assembly then appears in theCondition Assignment pane beneath the condition
to which you assigned it.

6 The variables associated with the assigned Sage Estimating item or assembly appear in the Integration
grid. The properties associated with the selected OST condition appear in the Condition Properties
pane. Youmust "map" or match one or more condition properties to a Sage Estimating variable:

a For the first variable listed in theEstimating Variable column, select an equivalent condition
property from the list in theCondition Property column.

For example, if the first Sage Estimating variable isWidth, select a width-based condition property
from theCondition Property list.

You can also select a condition property by clicking on a property in theProperty column of the
Condition Properties pane and "dragging" it to theCondition Property column of the Integration
grid.

Figure 21: Mapping Properties

If no equivalent condition property is available, leave theCondition Property column blank.

b If you select a condition property, and a conversion factor is required, type it in theConversion
Factor column.

For example, if the Sage Estimating variable Length is measured in Inches but the condition
property Length is measured in Feet, the conversion factor is 12/1 or 12.

c If you did not select an equivalent condition property in step a, specify the Sage Estimating
variable's value by typing directly in theValue column.

d Repeat steps a-c for each Sage Estimating variable in the grid.

7 Repeat steps 1-6 for eachOST condition you expect to use during takeoff.
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8 Click [Save] to save your changes.

Performing One-Time Integration
You can integrate values from anOST condition property with an item or assembly dimension in Sage
Estimating on a one-time basis. You can do this by dragging the OST condition into the dimension grid of
the Item Takeoffwindow, Assembly Takeoffwindow, or Quick Takeoffwindow in the Sage Estimating
software.

For example, if you are taking off an assembly in Sage Estimating that requires theSingle Ply Roof
condition from OST to be added to it, you can select each associated property Value from theCondition
Property pane in the OST Integrator and "drag" it to theAssembly Takeoff window in Sage Estimating.
TheSingle Ply Roof condition properties are then added to the assembly.

The Sage Estimating items and assemblies retain the OST condition value integration for one takeoff only.
If you want to integrate OST conditions and Sage Estimating items and assemblies for more than one
takeoff, youmust perform the integration in the OST Integrator using the procedure in “Performing
Integration” on page 39.

To perform a one-time integration with a Sage Estimating estimate:

1 In Sage Estimating, open the Item Takeoff, Assembly Takeoff, orQuick Takeoffwindow.

2 In the OST Integrator, open theOST project containing the condition or conditions you want to add to the
estimate.

3 Select the condition you want to add from the Condition Assignment pane of the OST Integrator.

4 From the Condition Properties pane, select the condition property Value that you want to add to the
estimate—for example, the values associated with the "width," "height," or "quantity"—and "drag" it to
the dimension grid of the Item Takeoff window, Assembly Takeoffwindow, orQuick Takeoffwindow
in Sage Estimating.

Figure 22: Selecting a Value for Integration

5 Repeat steps 2-4 to integrate all desired OST conditions with the estimate.

Performing One-Time Integration
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Performing Takeoff to Estimates
After you integrate OST conditions with Sage Estimating items and variables, the OST Integrator allows
you to create estimates in Sage Estimating using conditions and items you take off from OST projects.

To take off OST items and conditions to an estimate:

1 Select an OST project from the list in the Condition Assignment pane.

2 Click the new estimate button to create a new estimate.

Alternatively, you can open an existing estimate by clicking the update estimate button.

If you are creating a new estimate: Type a name for the new estimate in theNew Estimate window;
then specify an estimate database for storing it, a standard database to associate with it (optional), and
the estimate "branch" where you want it displayed then click [OK] to create the new estimate.

If you are opening an existing estimate:Select the existing Sage Estimating estimate from the
estimate list then click [Open] to open it.

TheOST Integrator adds items and assemblies already assigned to conditions in the OST project to the
new or existing estimate. If desired, you open the estimate immediately after creating it.

NOTE: For existing estimates only: If you previously generated items and assemblies from theOST
project to the selected estimate, the OST Integrator deletes the items and assemblies before adding
new ones.

Using Condition Style Libraries
Using the OST software, you can create a library of condition styles that you can then use inmore than
one project. A corresponding condition style library appears in the Condition Assignment pane of the OST
Integrator.

If, for example, you create a condition in anOST project for right-hand doors calledRH Door, you can
choose to save the condition in the OST style library for use in other projects. In the OST Integrator, the
RH Door condition automatically appears in theStyle Library of the Condition Assignment pane.
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Figure 23: Condition Styles in the Condition Assignment Pane

After saving conditions as styles in the condition style library, you can assign Sage Estimating items and
assemblies to them in the OST Integrator (see “Performing Integration” on page 39 for instructions).

You can then use the integrated condition styles in future projects whenever they are required.

You can create and edit condition style libraries only in On-Screen Takeoff.

NOTE: EachOST database has only one condition style library.

Importing and Exporting Condition Assignments
You can import and export integrated condition assignments in extensible markup language (XML) files.
Use this feature when you want to transfer integrated condition assignments from a Sage Estimating
standard database in one location to a standard database in another location.

For example, if you assign OST conditions to Sage Estimating items and assemblies in a standard
database on your local computer, and you want to integrate those same assignments into another
standard database (such as a shared standard database on a server, for example), export the integrated
conditions to file then import them into the shared database.

To export assignments to a file
1 In the OST Integrator, open the standard database containing the assignments you want to export.

2 Select Import/Export group > Export the assignments to a file (in classic view, select File >
Export).

3 Type a file name for the export file in the File Name box and browse to the location where you want the
file saved.

Importing and Exporting Condition Assignments
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4 Click [Save].

TheOST Integrator saves the condition assignments to an XML file (.osti extension) that you can import
later.

To import assignments to a file
1 In the OST Integrator, open the standard database where you want the condition assignments imported.

NOTE: The target standard database you select must have the same items and assemblies as those in
the .osti file or an error results during import.

2 Select Import/Export group > Import an assignments file (in classic view, select File > Import).

3 Select the import file containing the assignments you want to import (.osti extension).

4 Click [Yes] at the prompt.

CAUTION: TheOST Integrator overwrites all current condition assignments in the standard
database when you import the assignments from file.

5 Right-click on the OST database in the Condition Assignment pane and select Change the Database
Path.

6 Browse to the location of the OST database containing the integrated conditions click [Open] to update
its location relative to the imported condition assignments.
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