Sage Estimating (SQL)
(formerly Sage Timberline Estimating)
Release Notes
Version 15.12
This is a publication of Sage Software, Inc.

Copyright © 2015. Sage Software, Inc. All rights reserved.

Sage, the Sage logos, and the Sage product and service names mentioned herein are registered trademarks or trademarks of Sage Software, Inc. or its affiliated entities. All other trademarks are the property of their respective owners.

Microsoft® SQL Server® and the Windows logo are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or in other countries.

Your use of this document and the Sage product(s) described herein is governed by the terms and conditions of the Sage End User License Agreement (“EULA”) or other agreement that is provided with or included in the Sage product. Nothing in this document supplements, modifies or amends those terms and conditions. Except as expressly stated in those terms and conditions, the information in this document is provided by Sage “AS IS” and Sage disclaims all express, implied or statutory warranties of any kind, including but not limited to the warranties of merchantability, fitness for a particular purpose or of non-infringement. No implied license is granted to you under any Sage intellectual property or trade secret right. Sage reserves the right to revise, supplement or remove information in this document at any time without notice to you or others.

Sage End User License: http://na.sage.com/sage-na/eula

Date: 3/22/2016
# Contents

**Version 15.12 Release Notes** .......................................................... 1

**Installation Notes** ............................................................................. 1
- System Requirements ........................................................................ 1
- Update or Migrate your Data? ......................................................... 1

**New Features and Enhancements** .................................................. 2
- New Model Estimating Features ....................................................... 2
- Security enhancements .................................................................. 3

**Fixes Since the Previous Version** .................................................. 3
- Fixes included in revision 2 ............................................................ 3
- Fix included in revision 3 ............................................................... 4

**Known Issues** .................................................................................. 4
- Installation Fails to Create an Instance for Microsoft SQL Server 2014 4
- SQL Server Management Studio Express Installation Quits ............... 4
- Checking in a Standard Database from the Database Editor Closes the Database for Concurrent Users ................................................. 4
- Windows 10 Does Not Recognize Your USB Protection Device .......... 5

**Further Assistance** ........................................................................ 5
- Online Help ................................................................................... 5
- Training ....................................................................................... 5
- Technical Assistance ................................................................. 6
- Submitting Enhancement Requests ............................................... 6
Version 15.12 Release Notes

This document provides important information regarding new features and changes in your Sage Estimating 15.12 software. Read these release notes carefully before installing Sage Estimating 15.12.

Installation Notes

System Requirements

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 71213, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213.

Update or Migrate your Data?

Sage Estimating 15.12 uses a Microsoft® SQL Server®-based database platform. If you are migrating from Pervasive-based Sage Estimating (versions 9.6 and later), you must migrate your data before you can use it in Sage Estimating 15.12. Refer to the Installation and Administration Guide in the Documents folder of your Sage Estimating installation files for migration instructions.

However, if you previously installed SQL-based Sage Estimating version 11.1 or later, you are only required to upgrade your data prior to using it with Sage Estimating 15.12.

To upgrade your data:

1. Install Sage Estimating 15.12 in accordance with the Installation and Administration Guide.

2. Start the Configuration wizard by selecting Start > All Programs > Sage > Estimating 15.12 > Configuration Wizard or by clicking the desktop icon.
   
   In Windows 8.1, select the Configuration Wizard icon from the Tile Desktop, or right-click outside the tile area, and then click All apps > Sage > Configuration Wizard.

3. Follow the Configuration wizard’s on-screen instructions and upgrade your data when prompted.

Refer to the Installation and Administration Guide for more information about migrating and upgrading your data.
New Features and Enhancements

Sage Estimating version 15.12 includes:

- **New Model Estimating Features**
- **Security enhancements**

The following sections provide more details about these changes.

**New Model Estimating Features**

Version 15.12 introduces Sage Estimating Models, an array of features and capabilities that can help to streamline the takeoff process, comparable to Model Estimating that you may have used in the Sage Estimating (Pervasive) product.

**Overview of Models**

Model Estimating streamlines the estimating process by providing most of the details needed during takeoff. Because each model includes a complete set of items and assemblies for a structural element, you can take off everything for that element at once. In addition, the model may even include the logic to feed the proper values into its items and assemblies.

During takeoff, input can come from questions, such as 'What is the height of each story?' and 'Is an alarm system required?' Or the input can simply come from existing variables that are part of each item and assembly. You have control over whether those variables appear (for input purposes) or are hidden (with default values which act as assumptions).

The resulting estimate contains all the details (costs, crews, hours, waste factors, etc.) generated from the assemblies and items that make up the model. And because this is an Estimating spreadsheet, you have the power to make changes to the estimate after takeoff.

By using models for takeoff, you gain the ability to:

- Group multiple items and assemblies as a single object
- Set up common, global variables for items and assemblies
- Ask questions to obtain dimensions and specifications
- Pre-load the location, WBS values, and productivity adjustment for items and assemblies
- Take off multiple occurrences of items and assemblies within a model
- Take off multiple passes of items and assemblies within a model

**TIP:** The sample database SampleExtendedCommercialGeneralContracting includes two models designed to show you how to use and build some of the Models functions. For example, make a pass through Model 101 (Test and training model), and then refer to **Edit Models** to see how the model was built.
Security enhancements

Assign general security permissions

If you have an Administrator role for Sage Estimating, you can now assign general security permissions allowing all users to view and edit estimates, according to their roles, without having to assign View and Edit permissions individually to each user for each estimate.

Using general security assignments

To turn on general security:

1. In the Estimating Management Console, click the [Security] button.
2. On the Estimates tab, select the Allow all users to view and edit all estimates check box.

**NOTE:** Turning on general security overrides existing security assignments, but it does not delete them. To restore individual user and estimate assignments, you simply clear the Allow all users to view and edit all estimates check box.

Copy view and edit rights from a source estimate to a new estimate

When using the Copy Estimate pane to create a new estimate from a source estimate, you can now use a new check box to choose whether the copy will use the same view and edit access rights as the source estimate, or access to the copy will be restricted to you and administrators.

Fixes Since the Previous Version

Version 15.12 includes the following fixes:

- Opening an estimate in a very large Estimates database is now much faster.
- Highlighted price columns now appear correctly when previewed or printed on a spreadsheet report.

Fixes included in revision 2

This revision to version 15.12 includes fixes we have made since the initial release:

- When you change the unit price of an item in the Detail window, the estimate totals are now updated correctly on the Totals Page.
- When you substitute or clear a crew on the spreadsheet, the Totals page is now updated correctly.
- When you generate models that include assembly details, items are now generated correctly for all phases, including Select-At-Takeoff detail lines with zero quantities.
Fix included in revision 3

Revision 3 fixed an issue with subcategories where, if you associated subcategories with items in your database, those subcategories were not reflected properly on your spreadsheet once they were taken off. Also, if an add-on referred to another add-on that used a cost basis of subcategory, the Totals page could become unresponsive.

Known Issues

Installation Fails to Create an Instance for Microsoft SQL Server 2014

If you are using Microsoft SQL Server 2014 for your Sage Estimating database, the server machine must have Microsoft .NET Framework 4.5.2 installed. If you try to install a new SQL Server instance during Estimating installation and .NET Framework 4.5.2 is not installed, the installation program cannot create the instance.

SQL Server Management Studio Express Installation Quits

In some circumstances, attempts to install SQL Server Management Studio Express from the Sage Estimating setup and installation files separately are unsuccessful if you do not install Sage Estimating first.

If you want to install just SQL Server Management Studio from the Sage Estimating setup and installation files, Sage recommends either installing Sage Estimating first or ensuring you have .NET 3.51 installed and enabled on the workstation or server where you want to install SQL Server Management Studio Express.

Checking in a Standard Database from the Database Editor Closes the Database for Concurrent Users

You can work on a Standard database in the Estimating Database Editor while other users perform takeoff using the same database in the Sage Estimating program.

When you try to check in the Standard database while other users have the database open, you receive a warning that if you continue to check the file in, there may be unpredictable results for the concurrent users.

If you continue to check the file in despite the warning, the Estimating program stops working for the other users. However, the data is not corrupted and the Estimating program is not damaged.
Windows 10 Does Not Recognize Your USB Protection Device

If you are using Windows 10 and a Sentinel USB driver that shipped with an earlier version of Estimating, you may find that Windows no longer recognizes your USB protection device.

If Windows 10 does not recognize this device, you must either update the driver and then apply it to the unrecognized device in Device Manager, or reinstall the driver. For more information about this issue, and for instructions on updating the driver, see the Knowledgebase article ID 70005, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=70005.

Further Assistance

Sage provides you with the following resources for obtaining assistance with Sage Estimating.

Online Help

The Sage Estimating software includes online Help, which provides answers to your questions about procedures as well as items in the windows.

To access the online Help in the Sage Estimating software, click the Help button or icon, or press [F1] to display the Help topic for that window.

To help you find the information you need, the Help for each module includes the following panes:

- **Contents** pane containing links to the help topics
- **Index** pane containing keywords that link to help topics related to that keyword
- **Search** pane, where you can type text and click [Search] to locate that text in the help topics

For more information about using the online Help, see the Sage Estimating Help.

Training

Sage University offers online and classroom training sessions to help you get the most out of your Sage Estimating software. To access Sage University, visit www.sageu.com.

You can also get access to Sage University from the File menu by selecting Help > Sage Estimating on the Web > Sage University.
Technical Assistance

When you need assistance, contact your Sage business partner and/or refer to the Knowledgebase article How do I get technical support for Sage Estimating? to determine which service works best for you.

Submitting Enhancement Requests

We want to hear your suggestions for improving the software. To send us your comments, click on the File menu button and select Help > Sage Estimating on the Web > Submit Enhancement Requests.