This version of the software has been retired
This is a publication of Sage Software, Inc.

Copyright © 2015. Sage Software, Inc. All rights reserved.

Sage, the Sage logos, and the Sage product and service names mentioned herein are registered trademarks or trademarks of Sage Software, Inc. or its affiliated entities. All other trademarks are the property of their respective owners.

Microsoft® SQL Server® and the Windows logo are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or in other countries.

Your use of this document and the Sage product(s) described herein is governed by the terms and conditions of the Sage End User License Agreement ("EULA") or other agreement that is provided with or included in the Sage product. Nothing in this document supplements, modifies or amends those terms and conditions. Except as expressly stated in those terms and conditions, the information in this document is provided by Sage "AS IS" and Sage disclaims all express, implied or statutory warranties of any kind, including but not limited to the warranties of merchantability, fitness for a particular purpose or of non-infringement. No implied license is granted to you under any Sage intellectual property or trade secret right. Sage reserves the right to revise, supplement or remove information in this document at any time without notice to you or others.

Sage End User License: http://na.sage.com/sage-na/eula

Date: 12/10/2015
# Contents

## Chapter 1—Microsoft SQL Server and Sage Estimating ........................................... 5
- Microsoft SQL Server and Pervasive ................................................................. 5
- The SAGE_ESTIMATING Instance ...................................................................... 6
- Microsoft SQL Server Files ............................................................................... 7
- SQL Database Permissions and Access ............................................................ 8
- Read the Supporting Documentation Before You Begin ..................................... 8
- Conventions Used in this Document .................................................................. 9
- Online Help ......................................................................................................... 10
- Training .............................................................................................................. 10
- Technical Assistance .......................................................................................... 10

## Chapter 2—Technical Information .......................................................................... 11
- Supported Editions of SQL Server ...................................................................... 11

## Chapter 3—Installation ........................................................................................ 12
- Overview ............................................................................................................ 12
- SQL Server Express Installation ......................................................................... 12
- Modified Installation ......................................................................................... 14

## Chapter 4—Back Up and Restore Procedures ........................................................ 15
- Backing Up SQL Server Databases ................................................................. 15
- Backing up the SQL Database .......................................................................... 15
- Restoring the SQL Database ............................................................................ 17

## Chapter 5—FAQs .................................................................................................. 20

## Chapter 6—Troubleshooting SQL Server ................................................................ 22
- Installation Issues ............................................................................................ 22
- Connection Issues ............................................................................................ 23
- Determining the path to the SQL Server program ........................................... 29
Chapter 1—Microsoft SQL Server and Sage Estimating

Sage is pleased to provide you with this guide to understanding Microsoft® SQL Server®. Read this guide carefully to learn the basic principles of SQL Server and how it supports Sage Estimating operation.

Sage Estimating uses SQL Server as its database platform. Previous releases used Pervasive as the database platform for storing Sage Estimating data. This database platform change is intended to offer you increased security, performance, and flexibility for your reports, queries, and daily operations.

This document provides information on the impact of these changes. It is important to understand these differences so that you can effectively manage and protect your Sage Estimating data.

Although this document is current as of the time of its distribution, a newer version may be available. For the most recent version, log on to https://customers.sagenorthamerica.com/irj/portal/anonymous/login and search for this document in the Technical Support Knowledgebase.

Microsoft SQL Server and Pervasive

Microsoft SQL Server represents a change from the Pervasive database platform used in previous Sage Estimating releases. It is important to understand how the new SQL Server database platform is structured.

SQL Server stores database information in database (.mdf) and log (.ldf) files. Previously, Sage Timberline Office Estimating created separate estimate files that you could store in any desired Windows file structure. With the new SQL Server database, Sage Estimating stores all your estimates in the same .mdf database file on a single server known as an instance.

Figure 1: Comparison of Pervasive and SQL Server

A Sage Estimating instance (sometimes referred to as a "server") consists of three primary components:
An Address Book database
An estimate database
One or more standard databases

You configure security for the instance and apply it to all contents, including the Address Book, all standard databases, and all estimates within the estimate database.

Estimates are stored entirely within the estimate database. With the new Sage Estimating, you can use the Estimating Management Console feature to arrange your estimates in a hierarchy of tiers or "branches." The branches you create in the Estimating Management Console are for organizational purposes only; they do not change the structure of your database.

The location of your SQL Server database files (.mdf and .ldf files) depends in part on your operating system. See "SQL Server Express Installation" on page 12 for more information.

The allowable database size in SQL Server is unlimited. However, if you are operating SQL Server Express, the database size is limited to 10 gigabytes (GB). Sage Estimating provides you with a warning if your database size nears the limit.

During the Sage Estimating install, if you choose to install SQL Server 2008 R2 Express from the Sage Estimating installation and setup files, the installation process automatically creates a new instance for you. The default name for the instance is SAGE_ESTIMATING; however, you have the option of giving the instance any name you want.

If you choose not to install SQL Server Express from the setup and installation files but elect to create your own instance using an existing SQL Server installation, it must meet certain requirements. See "Modified Installation" on page 14" for more information.

The SAGE_ESTIMATING Instance

Sage Estimating allows the use of just one active SQL Server instance at a time. The active instance is a "closed" SQL Server instance; Sage Estimating does not recognize databases (Address Book or standard databases) transferred or copied from other SQL Server instances unless they are added by way of the Search For feature in the Estimating Management Console.

For example, if you have two Sage Estimating installs, Install A and Install B, you cannot copy Address Book databases by copying them from Install A's SQL Server instance to Install B's SQL Server instance alone (using SQL Server Management Studio's built-in Copy Databases wizard, for example). You must also open the Estimating Management Console and use the Search For button in the Address Book Companies/Contacts toolbar.
Any database you add to an instance must have the same Sage Estimating version as the other operating databases. For example, if you are using Sage Estimating 15.12, and you want to add a standard database from a previous Sage Estimating installation, upgrade the standard database to version 15.12 before adding it to the new instance. Refer to the Estimating Management Console in-product Help for instructions on adding databases using the Search For feature.

The allowable database size in SQL Server is unlimited. However, if you are operating SQL Server Express, the database size is limited to 10 gigabytes (GB). Sage Estimating provides you with a warning if your database size nears the limit.

During the Sage Estimating install, if you choose to install SQL Server 2008 R2 Express from the Sage Estimating installation and setup window, the installation process automatically configures a new Sage Estimating-compatible instance for you. The default name for the instance is SAGE_ESTIMATING; however, you have the option of giving the instance any name you want.

If you choose not to install SQL Server Express from the setup and installation files but elect to create your own instance using an existing SQL Server installation, it must meet certain requirements. See “Modified Installation” on page 14 for more information.

**Microsoft SQL Server Files**

Every SQL Server database has at least two files associated with it:

- A file that stores the actual data (.mdf)
- A transaction log file (.ldf)
SQL Server stores your Sage Estimating data in the database file (.mdf). For details, see “SQL Server Express Installation” on page 12.

The transaction log (.ldf) records all changes to the data in the database. This log ensures data integrity by keeping track of data that has changed and can be used to roll the data back to a previous state in the event of a database failure.

It is important to make regular backups of these files. For more information, see “Backing Up SQL Server Databases” on page 15.

Collation settings for use with Sage Estimating

Sage Estimating requires a special collation setting. Collation settings in SQL Server must be set to:

- Latin1_General
- Case-sensitive
- Accent-sensitive

See “Collation Settings,” on page 35 for more information.

SQL Database Permissions and Access

You must give each Sage Estimating operator permissions to the Sage Estimating features that he or she is expected to use. Assign database and feature permissions using the security feature of the Estimating Management Console. For more information, see the Estimating Management Console in-product Help.

**CAUTION:** Do not change the owner of any databases in the Sage Estimating instance.

Read the Supporting Documentation Before You Begin

Be sure to read supporting documentation before you begin:

- This SQL Server Guide gives you an overview of the significant differences between the new SQL Server databases and the Pervasive databases used in previous Sage Estimating releases.

- The Installation and Administration Guide includes an overview of this release, installation instructions, and contact information. This document is available in the Documents folder of your Sage Estimating installation files.

- The Release Notes provide details about new features, database changes, known issues, and fixes. This document is available in the Documents folder of your Sage Estimating installation files.

- The Getting Started Guide provides an operational overview of the Sage Estimating software. This document is available in the Documents folder of your Sage Estimating installation files.
The Options Guide provides installation, setup, and operating instructions for each of the available Sage Estimating options, such as the OnScreen Takeoff Integrator or License Manager. This document is available in the Documents folder of your Sage Estimating installation files.

**IMPORTANT:** For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 71213, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213.

These documents are current at the time of the release. To learn about issues that have arisen since this document was published, go to www.sagecre.com.

## Conventions Used in this Document

This document uses the following conventions:

- Information you type into the software is shown in bold font. For example: Type **Miscellaneous** in the box.
- The names of screens, windows, fields, and other features displayed by the software are shown in bold font.
- The names of buttons you can click are enclosed in brackets with bold font. For example: `[OK]` or `[Post]`.
- Names of keys are shown in capital letters. For example: ENTER or TAB. A plus sign (+) between two key names indicates you should press the keys simultaneously.
- Variable names or names that are specific to your installation may appear in italics and brackets. For example: `[Drive]\[Server]`.

### Symbols

- **NOTE:** This symbol is used when presenting information that is supplemental to the adjacent text.
- **TIP:** This symbol is used when presenting helpful information for using the software.
- **CAUTION:** This symbol is used when presenting important information to help you avoid a loss of critical data.
- **IMPORTANT:** This symbol is used when presenting information that is critical to understand or that requires you to take action.

### Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with angle brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."
Online Help

The Sage Estimating software includes online Help, which provides answers to your questions about procedures as well as items in the windows.

To access the online Help in the Sage Estimating software, click the Help button or icon, or press [F1] to display the Help topic for that window.

To aid you in finding the information you need, the online Help for each module includes the following panes:

- **Contents** pane containing links to the Help topics
- **Index** pane containing keywords that link to Help topics related to that keyword
- **Search** pane, where you can type text and click [Search] to locate that text in the Help topics

For more information about using the online Help, see the Sage Estimating Help.

We would like your feedback about the online Help so we can make improvements. Each Help topic contains an area where you can indicate whether the topic was helpful and provide additional comments. To protect your privacy, all comments are anonymous.

Training

Sage University offers online and classroom training sessions to help you get the most out of your Sage Estimating software. To access Sage University, visit [www.sageu.com](http://www.sageu.com).

You can also get access to Sage University from the File menu by selecting Help > Sage Estimating on the Web > Sage University.

Technical Assistance

When you need assistance, refer to the Knowledgebase article [How do I get technical support for Sage Estimating?](#) to determine which service works best for you.

Submitting Enhancement Requests

We want to hear your suggestions for improving the software. To send us your comments, click on the File menu button and select Help > Sage Estimating on the Web > Submit Enhancement Requests.
Chapter 2—Technical Information

Supported Editions of SQL Server

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 71213, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213.

A copy of SQL Server Express Edition is provided free of charge with Sage Estimating. This edition is sufficient for most Sage Estimating customers. However, customers with large databases may need to upgrade to the Standard Edition. For information on Microsoft SQL Server editions, visit www.microsoft.com.

The following table offers a brief comparison of the Express and Standard versions of SQL Server.

Table 1: Comparison of SQL Server Standard and Express Versions

<table>
<thead>
<tr>
<th>Feature</th>
<th>Express</th>
<th>Standard</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concurrent workload governor (throttle)¹</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Database size</td>
<td>10 GB²</td>
<td>Unlimited</td>
</tr>
<tr>
<td>RAM support</td>
<td>1 GB</td>
<td>Operating system maximum</td>
</tr>
<tr>
<td>CPUs supported</td>
<td>1³</td>
<td>4</td>
</tr>
<tr>
<td>Windows 7/8.1 support</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

¹ This governor limits the performance of applications to approximately 5 users.

² This database size applies to only SQL Server database files (.mdf) and not to log files (.ldf).

³ Your computer can have multiple CPUs, but only one is used by SQL Server.
Chapter 3—Installation

Overview

Before installing Sage Estimating, you have two primary SQL Server scenarios to consider:

- **SQL Server Express Installation.** Installing Sage Estimating also installs SQL Server Express when you select certain installation options. Follow this scenario for these conditions:
  - You are installing Sage Estimating on a standalone workstation or a workgroup server.
  - You are installing to a server on a domain and you want to use the copy of SQL Server Express that comes with the Sage Estimating install package.

  The Sage Estimating install package installs and configures a new SQL Server instance of SQL Server Express whenever you select one of these install options. You can operate the new SQL Server instance alongside an existing SQL Server instance.

- **Modified Installation.** You have a supported version of SQL Server installed (or plan to have one installed) and you want to manually create a new instance to use with that version.

  Use the **Security** feature in the Estimating Management Console to assign database permissions to each operator after installing your SQL Server instance.

  For more information on setting up SQL Server security for Sage Estimating, see the *Installation and Administration Guide*.

  **NOTE:** You can install an approved instance of SQL Server side by side on a computer where SQL Server 2012 is also installed. Be aware that installing Sage Estimating may then result in an "Install completed with errors" message; however, the resulting Sage Estimating install operates correctly.

SQL Server Express Installation

Microsoft SQL Server Express comes as an optional component with the Sage Estimating install package. It installs automatically when you select certain Sage Estimating installation options.

Follow the instructions below to install SQL Server Express from the install package.

1. Open the **Select Installation Options for Sage Estimating** window by double-clicking SetMeUp.exe in your local install folder.

   The install folder is created wherever you download the Sage Estimating install files. For example, if you download the install files to C:\Users\Public\Public Documents, look in this folder for the SetMeUp.exe file.


2 In the **Select installation options for Sage Estimating** window, select one of the following options:

- **Complete Sage Estimating system.** This option installs everything you need to operate Sage Estimating on your local workgroup server, offline workstation, or standalone computer, including a new instance of SQL Server 2008 R2 Express. Select this option if you are installing Sage Estimating on a standalone computer or a workgroup server.

  **NOTE:** If you are operating in a workstation/server environment, you do not need to install SQL Server on the workstations. However, you can install SQL Server optionally if you want to maintain a local copy of your estimating data.

- **Sage Estimating Server and new instance.** Select this option if you are installing to a server on a domain and you want to use the SQL Server 2008 R2 Express copy that comes with the Sage Estimating install. Selecting this option automatically installs and configures a new instance of SQL Server 2008 R2 Express for you. This option is unavailable if you already have installed Sage Estimating components on the workstation or server.

- **Create new local SQL Server instance.** This option appears only if you have already installed Sage Estimating components on the workstation or server. Select this option to install and configure a new instance of SQL Server 2008 R2 Express.

3 In the **Enter new instance name** box, type a name for the new SQL Server instance (database server) in the box and click [OK].

   The default instance name is **SAGE_ESTIMATING** but you can give the instance any name you want provided you do not give it the same name as any existing SQL Server instance on the computer.

4 Click [Next] and follow the on-screen instructions for installing Sage Estimating or Sage Estimating server.
The software installer creates the new instance as part of the Sage Estimating installation and notifies you when the process is finished.

**NOTE:** If you are installing SQL Server on a computer with Windows 2008 Server, Windows 7, or Windows 8.1, ensure you elevate your privileges at the prompt within two minutes of its appearance or the installation will quit.

Installing SQL Server Express also installs SQL Server Management Studio Express, a tool for performing database back up and restoration procedures and for assigning database permissions.

## Modified Installation

You may use a version of SQL Server that already exists on your computer, but it must be a supported version. (For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 71213, available at [https://support.na.sage.com/selfservice/viewdocument.do?externallId=71213](https://support.na.sage.com/selfservice/viewdocument.do?externallId=71213).)

If you want to use your existing installation of SQL Server, create a new instance to operate alongside your existing SQL Server instances. You can give the new instance any name you want. However, Sage recommends naming the new instance an easily identified name such as SAGE_ESTIMATING.

After creating your new instance, ensure you assign the appropriate database permissions as outlined in the *Installation and Administration Guide*.

**NOTES:**

- If you plan to migrate existing data from a Pervasive-based version of Sage Estimating, you must install SQL Server or SQL Server Express on the destination computer or server.

- Reboot your server or workstation after creating the new instance.

**CAUTION:** Do not change the owner of any databases in the Sage Estimating instance.
Chapter 4—Back Up and Restore Procedures

Backing Up SQL Server Databases

Performing a complete backup of your Sage Estimating data requires using SQL Server Management Studio or Management Studio Express to back up your Microsoft® SQL Server® databases. It is critical that you modify your back up procedures to include all the necessary steps.

Your SQL Server database backup copy is generated in two steps:

1. Use SQL Server Management Studio (or Management Studio Express) to make a backup copy of the database into a file folder.

   The default location for this folder is C:\Program Files\Microsoft SQL Server\MSSQL10_50.SAGE_ESTIMATING\MSSQL\Backup. (The actual number and instance name that appears in the path may be different if you have multiple instances of SQL Server installed or if you named your instance a different name.)

2. Make sure to include the SQL backup folder (referenced in step 1) when you perform your tape or third-party backup.

   **NOTES:**
   - Be sure to perform regular tests of your backups to ensure they are working properly.
   - You can perform backup and restore functions using SQL Server Management Studio or Management Studio Express. Installing SQL Server 2008 R2 Express from the Sage Estimating setup and installation files installs a copy of SQL Server Management Studio Express.
   - SQL Server 2008 R2 Management Studio Express automatically detaches and attaches the database when you back up and restore.

   **CAUTION:** The restore process overwrites any changes you make to the database between creation of backup copies.

Backing up the SQL Database

1. Start Microsoft SQL Server Management Studio Express (Start > All Programs > Microsoft SQL Server 2008 Express > SQL Server Management Studio Express).

   In Windows 8.1, select Start > All apps > Microsoft SQL Server 2008 Express > SQL Server Management Studio.

2. Select the database you want to back up from the Object Explorer pane.
3 Right-click on the database and select **Tasks > Back Up** to open the **Back Up Database** window.

**Figure 4: Database List in the Object Explorer Pane**

![Database List in the Object Explorer Pane](image)

**Figure 5: The Back Up Database Window**

![Back Up Database Window](image)
4 Under **Source** (in the right-hand pane of the **Back Up Database** window), select the database to be backed up from the **Database** list.
   - For the backup type, select **Full**.
   - For the backup component, select **Database**.

5 Under **Backup Set**, type a name for the database backup you are creating in the **Name** box. If desired, also type a description for the backup in the **Description** box.

6 Set the desired expiration criteria for the backup in the **Backup set will expire** section.

7 Select the backup destination from the **Destination** list.
   
   **Note:** This list displays previously defined backup file paths and file names. The backup utility selects the **Backup** folder in your SQL Server instance folder by default but you can add a new file path as a destination by clicking [Add].

8 Click [OK]. A **Backup of database completed successfully** message appears when the backup operation is finished.

You may now perform your normal tape or third-party back up procedures.

Be sure to include the SQL back up folder (or the folder where your backup copy is stored if you selected another location in step 7). The default location for this folder is `C:\Program Files\Microsoft SQL Server\MSSQL10_50.SAGE_ESTIMATING\MSSQL\Backup`. (The actual number and the name that appears in the path may be different if you have multiple instances of SQL Server installed or if you named the instance a different name.)

### Restoring the SQL Database

#### CAUTION: The restore process overwrites any changes you make to the database between creation of backup copies.

1 Start Microsoft SQL Server Management Studio Express. *(Start > All Programs > Microsoft SQL Server 2008 Express > SQL Server Management Studio)*.

   **Note:** In Windows 8.1, select **Start > All apps > Microsoft SQL Server 2008 Express > SQL Server Management Studio**.

2 Select the database you want to restore from the **Object Viewer** pane.
3 Right-click on the database and select Tasks > Restore > Database to open the Restore Database window.
Figure 7: The Restore Database Window

4 Select the database you wish to restore in the To database box.  
If you want to create a new database, type the name of the database in the To database box.

5 Under Source for restore, select From database then select the name of the backup database copy you want to use for the restore operation.

6 Select the check box of the database you wish to restore from the Select the backup sets to restore table.

7 Click Options (from the Select a page pane in the upper left-hand corner of the window).

8 In the Restore Options area, select the Overwrite the existing database check box.

9 Click [OK].

A Restore of database completed successfully message appears when the restoration operation is finished.

NOTE: The restore process overwrites any changes you made to the database since the last time you created the backup copy.
Chapter 5—FAQs

I already use a version of Microsoft® SQL Server® on my computer. Can I use this version with Sage Estimating?

You must use a version of SQL Server that Sage Estimating supports, and you must create a new instance for Sage Estimating that conforms to our recommended security settings. See “The SAGE_ESTIMATING Instance” on page 6 for more information.

**NOTE:** You can install an approved instance of SQL Server side by side on a computer where SQL Server 2012 is also installed. Be aware that installing Sage Estimating may then result in an "Install completed with errors" message; however, the resulting Sage Estimating install operates correctly.

If I already have a version of SQL Server installed, does installing Sage Estimating upgrade my existing SQL Server version?

No. However, you can install SQL Server Express from the Sage Estimating setup and installation files for use with Sage Estimating. You can then use both SQL Server versions in a side-by-side configuration (meaning both versions are installed).

What are the minimum system requirements to install SQL Server?

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 71213, available at [https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213](https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213).

Which operating systems are supported with SQL Server?

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 71213, available at [https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213](https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213).

Are 64-bit platforms supported?

Yes, you can install SQL Server Express on the several 64-bit Windows platforms.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 71213, available at [https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213](https://support.na.sage.com/selfservice/viewdocument.do?externalId=71213).

Can SQL Server Express Edition installations be performed on substitute, mapped, or compressed drives?

No, installations cannot be used on any of these configurations.
Can I use File Tools or other utilities to back up my SQL databases?

No. You must detach your databases and then back them up after the process is complete. File Tools and other utilities do not perform this function.

Use SQL Server Management Studio or SQL Server Management Studio Express to back up your SQL data. Microsoft SQL Server Management Studio Express attaches and detaches the database automatically during back up and restore procedures. For more information, see "Backing Up SQL Server Databases" on page 15.

Will running a virus scanner on the SQL Server host machine affect performance?

For performance reasons, if you plan to run a virus scanner on the machine that hosts the SQL Server instance, you should exclude files that have MDF, LDF, NDF, BAK, TRN, and TRC extensions. You should also exclude additional processes for the version of SQL Server that you are running. For more information about the files and processes to exclude, see Microsoft Knowledgebase article 309422 at http://support2.microsoft.com/kb/309422.

How can I test whether SQL Server is working in Sage Estimating?

The first time you start Sage Estimating or the Estimating Management Console after installing the Sage Estimating software, you should be able to use the Configuration wizard to locate your SQL Server instance. If you are able to use the Configuration wizard to successfully locate at least one SQL Server instance, your installation of SQL Server is operating correctly.

If you are able to open or create estimates and databases in the Sage Estimating software, SQL Server is operating correctly.

What do I need to be able to manage user access rights in SQL Server?

For Sage Estimating, security is managed entirely from within the Security feature of the Estimating Management Console. You can create roles and their corresponding permissions to access various Sage Estimating tasks and features.

You must be belong to the Sage Estimating administrator role to create roles and assign them to other operators. For more information about creating roles and permissions, refer to the Sage Estimating Installation & Administration Guide or the Estimating Management Console in-product Help.

I can connect to a SQL Server instance on my local computer but why can't I connect to a SQL Server instance on a remote server?

You may need to reconfigure your firewall settings. See "Firewall settings" on page 24.
Chapter 6—Troubleshooting SQL Server

This section provides additional information if you have any difficulty installing or connecting to a supported version of Microsoft® SQL Server®.

Installation Issues

The following paragraphs provide troubleshooting tips for installation issues.

Collation

Sage Estimating requires a special collation setting. Collation settings in SQL Server must be set to:

- Latin1_General
- Case-sensitive
- Accent-sensitive

These settings are configured automatically when you create the SQL Server 2008 R2 Express instance from the Sage Estimating install. You may sometimes see this listed in SQL Server as SQL_Latin1_General_CS_AS.

**NOTE:** If you performed an upgrade to SQL Server 2008 R2, your collation settings may not correctly match the settings required by Sage Estimating.

Compatibility

Sage Estimating requires SQL Server 2008 + SP1 or higher. However, SQL Server 2012 is only compatible with Sage Estimating 13.2 and later.

SQL Server is designed so that multiple instances may exist on a single computer. Each instance is independent of the others, and may use different versions or service packs. The following can be used alongside the instance you create for Sage Estimating:

- MSDE 2000 + SP3 or higher
- SQL Server 2000 + SP3 or higher

**NOTE:** Multiple versions of SP3 exist. The only compatible version of SQL Server 2000 is 8.00.760.0.

You may need to remove the existing version to resolve the compatibility issue. However, be aware that other software may be using the incompatible version. Contact your system administrator before attempting to remove any incompatible version.

If you determine that the version can be removed safely, use Windows’ Add or Remove Programs to remove it (note that you may have to remove several entries to completely remove the version).
Connection Issues

The following paragraphs provide troubleshooting tips for connection issues.

Authentication mode

The authentication mode for the SQL Server instance you create for Sage Estimating must be set to Windows Authentication and SQL Server Authentication (also referred to as "Mixed Mode") to work with Sage Estimating. In this mode, SQL Server creates and maintains your login information. See “Chapter 6—Troubleshooting SQL Server” on page 22 for more information.

Changing the authentication mode

If the authentication mode is not set correctly, you can resolve this issue in SQL Server Management Studio Express, as follows:

1 Start SQL Server Management Studio Express (Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server Management Studio Express).
   In Windows 8.1, select Start > All apps > Microsoft SQL Server 2008 R2 > SQL Server Management Studio Express.

2 Confirm that the correct Server type, Server name, and Authentication settings are correct, and then click [Connect]. For example:
   - **Server type**: Database Engine
   - **Server name**: Machine_name\instance_name
   - **Authentication**: Windows Authentication

   **NOTE:** If Windows Authentication does not work, try SQL Server Authentication. You must have security permission in SQL Server to access the database using this authentication.

3 In the Object Explorer pane, right-click on the server name and select Properties.

4 You must select the server name, not the folders below it, in order to see the Security option in the next step.

5 Select Security.

6 Select SQL Server and Windows Authentication.

7 Click [OK] twice.

If the authentication mode is set correctly and you are still experiencing problems, contact your system administrator to review your permission settings in Windows or SQL Server. See “Security Administration” on page 28 for more information.
Database location
Your default database location may not be set correctly in the system registry. See “Appendix—SQL Server Instance Settings” on page 34 for verification instructions.

Firewall settings
If you experience communication issues with a remote SQL Server instance, you may be using a firewall that is set up to block network traffic between your computer and the SQL Server instance. To allow communication, you need to set two firewall exceptions:

- The SQL Server Database Engine service
- The SQL Server browser service

NOTES:
- The following instructions are for use with Windows Firewall. If you are using another firewall for your system, contact the firewall manufacturer for instructions on setting service exceptions.
- Sage recommends contacting your system administrator if you need to change firewall settings.
- This procedure does not cover setting firewall exceptions for installations on a workgroup. If you are using SQL Server on a workgroup server, you must set separate firewall exceptions to allow your workstations to communicate with the SQL Server instance. Refer to the Installation & Administration Guide for instructions.

Setting the SQL Server Database Engine exception
Set up a SQL Server Database Engine exception for each instance of SQL Server you use with Sage Estimating.

1 Determine the path to your SQL Server computer.

   a On the computer or server where SQL Server is installed, open the SQL Server Configuration Manager by selecting Start > All Programs > Microsoft SQL Server 2008 R2 (or Microsoft SQL Server 2008) > Configuration Tools > SQL Server Configuration Manager (in Windows 8.1, select Start > All apps > Microsoft SQL Server 2008 R2 > SQL Server Configuration Manager).

      The SQL Server Configuration Manager opens.
In the left-hand pane of the SQL Server Configuration Manager, select **SQL Server Services**.

In the right-hand pane, right-click on **SQL Server (INSTANCE)**, where (INSTANCE) is the SQL Server instance for which you are creating the firewall exception, and select **Properties**.

In the SQL Server Properties window, click on the **Service** tab.
In the Binary Path entry, note or record the path described within the quotation marks. This is the file path to the SQL Server instance binary files (the path is contained only within the quotation marks—ignore the text outside the quotes).

2 Open Windows Firewall by selecting Start > Control Panel > System and Services > Administrative Tools > Windows Firewall with Advanced Settings.

If you are using Windows 8.1, select Start > All apps > Windows System > Control Panel > System and Services > Administrative Tools > Windows Firewall > Advanced Settings.

3 In the left-hand pane of the Windows Firewall with Advanced Security window, right-click on Inbound Rules and select New Rule.

4 In the New Inbound Rule wizard, select the Program option and click [Next].

5 Select the This program path option.

6 Click [Browse] and locate the sqlservr.exe file at the binary file path you recorded in step 1 then click [Open].

7 Select the Allow the connection option then click [Next].

8 Select the Domain, Public, and Private check boxes then click [Next].
9 Type the name of your SQL Server instance in the Name box.

10 Click [Finish] to create the firewall exception for the SQL Server Database Engine service. The Windows Firewall with Advanced Security window opens.

*Figure 10: Windows Firewall with Advanced Security Window*

Setting the SQL Server browser service exception

1 Open Windows Firewall by selecting Start > Control Panel > System and Services > Administrative Tools > Windows Firewall with Advanced Settings.

If you are using Windows 8.1, select Start > All apps > Windows System > Control Panel > System and Services > Administrative Tools > Windows Firewall > Advanced Settings.

2 In the left-hand pane of the Windows Firewall with Advanced Security window, right-click on Inbound Rules and select New Rule.

3 In the New Inbound Rule wizard, select the Port option and click [Next].

4 Select UDP as the protocol type.

5 Select the Specific local ports option and type 1434 in the corresponding box.

6 Click [Next].

7 Select the Allow the connection option and click [Next].

8 Select the Domain, Public, and Private check boxes then click [Next].

9 Type SQL Server Browser Exception in the Name box.
10 Click [Finish] to create the firewall exception for the SQL Server browser service.

Network configuration

To connect with SQL Server, you must have TCP/IP enabled.

Enable TCP/IP

If you are receiving network configuration errors, make sure that TCP/IP is enabled, as follows:

1 Select Start > Control Panel > Administrative Tools > Windows Firewall with Advanced Security.

2 Start SQL Server Configuration Manager (Start > All Programs > Microsoft SQL Server 2008 R2 > Configuration Tools > SQL Server Configuration Manager).

   In Windows 8.1, select Start > All apps > Microsoft SQL Server 2008 R2 > SQL Server Configuration Manager.

3 Expand SQL Server 2008 Network Configuration.

4 Select Protocols for SAGE_ESTIMATING (or the name of your instance).

5 Right-click on TCP/IP and select Enable.

6 Click [OK].

   NOTE: You must stop and restart the SQL Server services for this change to take effect. See “SQL Server services” on page 28 for more information.

Running a virus scanner on the SQL Server host machine

For performance reasons, if you plan to run a virus scanner on the machine that hosts the SQL Server instance, you should exclude files that have MDF, LDF, NDF, BAK, TRN, and TRC extensions. You should also exclude additional processes for the version of SQL Server that you are running. For more information about the files and processes to exclude, see Microsoft Knowledgebase article 309422 at http://support2.microsoft.com/kb/309422.

Security Administration

Operators using Sage Estimating must have SQL Server permissions to the databases they are expected to use. You assign permissions using the Roles and Permissions features in the Estimating Management Console. For more information, see the Installation & Administration Guide.

If an operator is experiencing connection issues with a database, verify the operator belongs to a role with the appropriate permissions.

SQL Server services

You may have several SQL Server services or instances, depending on the version of SQL Server you are using. For SQL Server 2008 R2 Express, the following are used:
To Start the SQL Server Engine Using SQL Server Configuration

1. Start SQL Server Configuration Manager (Start > All Programs > Microsoft SQL Server 2008 (or Microsoft SQL Server 2008 R2) > Configuration Tools > SQL Server Configuration Manager).

   If you are using Windows 8.1, select Start > All apps > Microsoft SQL Server 2008 R2 > SQL Server Configuration Manager.

2. Select SQL Server Services.

3. Right-click the service (for example, SQL Server (<instance name>)) and then click Start.

To Stop the SQL Server Engine Using SQL Server Configuration

1. Start SQL Server Configuration Manager (Start > All Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL Server Configuration Manager).

   If you are using Windows 8.1, select Start > All apps > Microsoft SQL Server 2008 R2 > SQL Server Configuration Manager.

2. Select SQL Server Services.

3. Right-click the service (for example, SQL Server (<instance name>)) and then click Stop.

Determining the path to the SQL Server program

If you have multiple instances of SQL Server installed, each instance is independent of the others. To determine the location of the SQL Server program for a particular instance, do the following:

1. Start SQL Server Management Studio Express (Start > All Programs > Microsoft SQL Server 2008 R2 > SQL Server Management Studio or SQL Server Management Studio Express).

   In Windows 8.1, select Start > All apps > Microsoft SQL Server 2008 R2 > SQL Server Management Studio.

2. In the Connect to Server window, confirm that the correct Server type, Server name, and Authentication are selected, and then click [Connect]. For example:

   - Server type: Database Engine
   - Server name: Computer_name\instance_name
   - Authentication: Windows Authentication

   If Windows Authentication does not work, try SQL Server Authentication. You must have security permission in SQL Server to access the database using this authentication.
3. Right-click on the server name, and then select Properties.

The path is listed on the General page next to Root Directory. Make note of this path.

4. Click [Cancel] and then close the SQL Server Management Studio Express window to exit without making any changes.

The program exists in the Binn directory, which is below the root directory you noted in step 4. For example: `C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe`. The actual number in the path may be different depending on how many instances you have installed on the computer.
Chapter 7—Additional Information

The following is provided as additional resource material. It is included for reference only and is not meant to imply that Sage supports, controls, or endorses any of the content. Be aware that titles, links, and content can change and may not always be pertinent to your situation.

General Information

Instance Configuration:


Microsoft SQL Server 2008 Security Datasheet:


Collation or Corruption

How to Rebuild the Master Database for SQL Server 2008:


Security

Password Policy:


SQL Server 2008 Security White Papers:

http://www.microsoft.com/sql/technologies/security/whitepapers.mspx
Strong Passwords:


Services

How to Verify a Successful Installation of SQL Server 2008 Reporting Services:


Managing the Database Engine Services:


Managing Services Using SQL Server Management Studio:

Chapter 8—Glossary

**BOL/Books On Line**


**Instance/Named Instance**

A complete database environment, including the relational database management system software, table structure, stored procedures, and other functionality.

**Microsoft Desktop Engine (MSDE)**

A database engine compatible with earlier versions of SQL Server.

**sa**

The system administrator for SQL Server.

**SQL**

Structured Query Language, the standardized language used in virtually all relational databases.

**SQL Server Management Studio (SSMS)**

The configuration tool used to manage all aspects of the SQL server.

**SQL Server Management Studio Express (SSMSE/SSMS Express)**

A limited version of SQL Server Management Studio.

**Stored Procedures**

Database functions that allow advanced pre-compiled queries.

**Transact-SQL**

A robust scripting language supported by Microsoft SQL Server.

**User Account Control (UAC)**

A method of adding security to Windows by creating different access levels for administrators and standard users. It also prevents standard users from changing system settings or affecting sensitive system information.
Appendix—SQL Server Instance Settings

If you have an existing instance of a supported version of Microsoft® SQL Server® installed, you can set up another instance to work with Sage Estimating. (Options described in this section may vary slightly depending on the edition you are installing.)

**NOTE:** If you choose to uninstall your existing instance first, reboot your server before reinstalling to avoid problems with the new installation.

**CAUTION:** Do not change the owner of any databases in the Sage Estimating instance.

Set your new SQL Server 2008, SQL Server 2008 R2, SQL Server 2008 R2 Express, or (for Sage Estimating 13.2 and later) SQL Server 2012 instance to the settings as outlined in the following sections.

**SAGE_ESTIMATING Instance**

*Figure 11: Instance Configuration Settings*

<table>
<thead>
<tr>
<th>Instance Name</th>
<th>Instance ID</th>
<th>Features</th>
<th>Edition</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAGE_ESTIMATING</td>
<td>MSSQL10.50.50001</td>
<td>SQLServer</td>
<td>Express with Advanced Features</td>
<td>10.50.1000.1</td>
</tr>
<tr>
<td>&lt;Shared Company&gt;</td>
<td>ISMS</td>
<td>SQLServer</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You must use a named instance. You can give the instance any name you want. However, Sage recommends giving the instance a name that makes it easily identified (such as SAGE_ESTIMATING).
The instance must support **Mixed Mode authentication** (*Windows Authentication and SQL Server Authentication*). This means either Windows authentication or SQL Server authentication can be used to access the database information.

When Windows authentication is used, the operator must have permissions to use SQL Server or be a member of a group that has those permissions. In Windows authentication mode, SQL Server validates the account name and password using information from the Windows operating system.

When SQL Server authentication is used, the operator must have system administrator (*sysadmin*) rights in SQL Server. The SQL Server authentication is used for backward-compatibility and requires a strong password.

**Collation Settings**

Collation settings must be **Latin1_General, case-sensitive, and accent-sensitive** (*Latin1_General_CS_AS*).

You can customize the collation settings during the server configuration portion of the SQL Server install. In the SQL Server collation customization window, make the following selections:
Select the Windows collation designator and sort order option (instead of SQL collation, which is the default)

- Latin1_General (for the collation designator)
- Case-sensitive
- Accent-sensitive
- Clear all other options

**Additional Recommendations**

To ensure accurate performance, Sage strongly recommends making changes and verifications to the following settings in SQL Server Management Studio and SQL Server Configuration Manager. Failure to make these changes may result in poor Sage Estimating performance or communication issues.

**Memory**

Determine the amount of available memory on the server or workstation where SQL Server is installed. To prevent SQL Server from consuming all available memory, use SQL Server Management Studio to set the maximum amount of memory (in the instance properties) to a reasonable limit (such as 4 GB) as follows:

1. Right-click on the SQL Server instance and select Properties.
2. In the Server Properties window, click Memory (left-hand pane).
3. Set the Maximum server memory amount to 4000 (or whatever limit you determine).

**Communication protocol**

Set the communication protocol settings for the Sage Estimating SQL Server instance as follows:

1. Start the SQL Server Configuration Manager by selecting Start > All Programs > SQL Server 2008 (or SQL Server 2008 R2) > Configuration Tools > SQL Server Configuration Manager.
   - In Windows 8.1, select Start > All apps > SQL Server 2008 > SQL Server Configuration Manager.
2. In the left-hand pane of the SQL Server Configuration Manager window, click the arrow next to SQL Server Network Configuration to display all local SQL Server instances.
4. In the right-hand pane right-click on a communication protocol and select Disable.
5. Repeat step 4 for all communication protocols except TCP/IP. Leave this protocol Enabled.
6. In the left-hand pane of the SQL Server Configuration Manager window, click the arrow next to SQL Native Client 10.0 Configuration or SQL Native Client 11.0 Configuration (depending on your SQL Server instance).
7 Click Client Protocols (left-hand pane).

8 In the right-hand pane right-click on a communication protocol and select Disable.

9 Repeat step 8 for all communication protocols except TCP/IP. Leave this protocol Enabled.

10 Close the SQL Server Configuration Manager and restart the service.
# Index

## 6
- 64-bit system compatibility 20

## A
- assigning permissions 12
- authentication mode 23, 35

## B
- backing up files 15

## C
- changing authentication mode 23
- collation settings 22, 35
- compatible SQL Server editions 11, 20, 22
- contacting Sage 10

## D
- database permissions 12
- databases
  - backing up 15
  - restoring files 17

## E
- Estimating installation window 12

## F
- file backups 15
- file restorations 17
- file structure, SQL Server 7
- firewall settings 24

## I
- installation
  - collation settings 35
  - database permissions 12
  - modified 14
  - scenarios 12
  - standard 12

## M
- managing user permissions 21
- mixed mode authentication 35
- modified installation 14

## O
- online help 10

## P
- permissions 12
- Pervasive
  - differences with SQL Server 5
  - previous uses 5
- product help 10

## R
- restoring SQL Server files 17

## S
- Sage contact information 10
- SAGE_ESTIMATING instance 6
Index

services, starting and stopping  28
Setup and Installation window  12
SQL Server
  backing up files  15
  compatible editions  11, 20, 22
  restoring files from backup  17
SQL Server file path  29
SQL Server file structure  7
SQL Server Mgt Studio Express  14
standard installation  12

W

Windows authentication  35
Windows x64 compatibility  20