## Contents

### Chapter 1—Introduction
- Available Options for Sage Estimating ................................................................. 1
- Read the Supporting Documentation Before You Begin .............................................. 1
- Conventions Used in this Document ............................................................................ 3
- Ways to Get Help ........................................................................................................... 4
- Training .......................................................................................................................... 7
- Technical Assistance ...................................................................................................... 7
- Submitting Enhancement Requests .............................................................................. 8

### Chapter 2—Means Integrator ....................................................................................... 9
- Overview ....................................................................................................................... 9
- Means Integrator Workflows ....................................................................................... 10
- Help and Information ..................................................................................................... 12

### Chapter 3—Sage 300 Construction and Real Estate Job Cost Integration .................. 13
- Overview ....................................................................................................................... 13
- Setup Guidelines .......................................................................................................... 14
- Prepare Sage 300 Construction and Real Estate Job Cost to Receive Estimates .......... 15
- Prepare Sage Estimating to Send Estimates ............................................................... 15
- Export Estimate data to Sage 300 Construction and Real Estate Job Cost .................. 23

### Chapter 4—On-Screen Takeoff Integration ............................................................... 28
- Learning About Integration .......................................................................................... 28
- On-Screen Takeoff Integrator Features ....................................................................... 29
- Performing Integration ................................................................................................. 31
- Performing One-Time Integration ............................................................................... 32
- Performing Takeoff to Estimates .................................................................................. 34
- Using Condition Style Libraries .................................................................................. 34

Options Guide 3
Chapter 1—Introduction

Sage is pleased to provide you with multiple options for expanding Sage Estimating's capabilities and features. Read the applicable chapters in this manual to learn more information about your Sage Estimating options.

Available Options for Sage Estimating

The following options are available for Sage Estimating:

**RS Means Integrator.** The RS Means Integrator lets you add RS Means item pricing databases to your Sage Estimating software. Using the RS Means Integrator, you can also update your Means price databases on a recurring basis.

**On-Screen (ePlan) Takeoff Integrator.** The On-Screen Takeoff (OST) Integrator lets you perform item and assembly takeoff in Sage Estimating from drawings you create in On-Screen Takeoff.

**Note:** This feature is available only if you have a license to use ePlan Takeoff.

Read the Supporting Documentation Before You Begin

Be sure to read supporting documentation before you install and configure your Sage Estimating options:

- The *Installation and Administration Guide* includes an overview of this release, installation instructions, system requirements, and contact information.
- The *Release Notes* provide details about new features, database changes, known issues, and fixes.
- The *Getting Started Guide* provides an operational overview of the Sage Estimating software.
- The *SQL Server Guide* gives you an overview of the significant differences between the new SQL Server databases and the Pervasive databases used in previous Sage Estimating releases.
- The *Options Guide* provides installation, setup, and operating instructions for each of the available Sage Estimating options, such as the OnScreen Takeoff Integrator.
The *Sage 100 Contractor (SQL) Integration Guide* describes how to integrate Sage Estimating with Sage 100 Contractor (SQL), making certain data in that program available in Sage Estimating, and it explains how to use the interface wizards to send proposals, budgets, and change orders you create in Sage Estimating to Sage 100 Contractor (SQL).
Notes:

- For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 86064, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=86064.

Conventions Used in this Document

This document uses the following conventions:

- Information you type into the software is shown in bold font. For example: Type **Miscellaneous** in the box.
- The names of screens, windows, fields, and other features displayed by the software are shown in **bold font**.
- Names of keys are also shown in bold font. For example: **Enter** or **Tab**. A plus sign (+) between two key names indicates you should press the keys simultaneously.
- The names of buttons you can click are shown in bold font and enclosed in brackets. For example: **[OK]** or **[Post]**.
- Variable names or names that are specific to your installation may appear in italics and brackets. For example: **[Drive]\[Server]**.

Notes, Tips, and Cautions

- **Note**: This style shows that the information supplements the adjacent text.
- **Tip**: This style indicates helpful points about using the software.
- **Caution!** This style indicates important information to help you avoid a loss of critical data.
- **Important!** This style indicates critical information that you need to understand or important steps you need to take.
Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with square brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Ways to Get Help

Use Sage Estimating Help or a variety of self-help resources to get answers to your questions. You can also call Customer Support.

The Help System

Sage Estimating Help provides more efficient access to information than most manuals. With a click of the mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.

Sage Estimating displays Help in your default browser. If you have an Internet connection, it displays the most current Help for your version of Sage Estimating available from a hosted Help server. If you have no connection (you are working offline), it displays Help that was current when the software was released, and is installed on your computer when you install Sage Estimating.

**Important!** Because the Microsoft Edge browser does not display locally installed help properly, we recommend that you select a different default browser when working offline.

To get Help on a window option

Help is available on virtually every option within a window. To display Help, do one of the following:

- Click 🕹️ What's This? on the toolbar or on the title bar, and then click the option.
- Select What's This? from the Help menu, and then click the option.
- Select the option, and then press F1.

To get Help for the whole window

For information about the window, such as the window's purpose and what tasks you can perform in it, click [Help] at the bottom of the window.

*Window Help Button*
To use Help to learn how to do tasks

Click [Help] on the toolbar, or select the Home tab > Help group > Help (or select Help menu > Help topics in classic view).

The Help Window
Use one of these tabs on the navigation pane to begin looking for a topic.

- **Contents** contains Help subjects organized within books.
- Click the **Glossary** heading on the Contents tab to view an alphabetical list of definitions of terms used throughout the Sage Estimating software.
- **Index** contains an alphabetical list of Help subjects.

When you see the topic you want, double-click it to display it.

Use the **Search** box to find articles that match the keywords you enter.

**Additional Self-help Resources**

The Help menus available in ribbon view and in classic view provide convenient links to a variety of self-help resources.

*The Help menu in Ribbon view*
Training

Sage University offers online and classroom training sessions to help you get the most out of your Sage Estimating software. To visit Sage University, go to www.sageu.com.

You can also click **File > Help > Sage University**.

Technical Assistance

When you need assistance, refer to the Knowledgebase article How do I get technical support for Sage Estimating? to determine which service works best for you.
Submitting Enhancement Requests

We want to hear your suggestions for improving the software. To send us your comments, click the File menu button and then select Help > Submit Product Idea.
Chapter 2—Means Integrator

Sage Estimating offers Means Integrator cost data files that you can use to create, extend, or update item costs in your Estimating Standard databases with current costs for corresponding items in the RSMeans Cost Data Books. If you use RSMeans cost data in your estimates, read this chapter for instructions on updating the following Estimating Standard databases:

- **Construction Knowledgebase.** The Construction Knowledgebase is a Sage Estimating Standard database that contains Means items and other data. You can use the Building and Construction Cost Data (BCCD) Means cost data file to update prices in this database.

- **Residential Knowledgebase.** The Residential Knowledgebase is a Sage Estimating Standard database that contains Means items and other data. You can use the Residential Cost Data Prices (DB1-20) Means cost data file to update prices in this database.

Any Estimating Standard databases that were created or extended using Means cost data files.

Overview

The Means Integrator cost data files correspond to the RSMeans Cost Data Books you receive with your shipment.

With Sage Estimating Means Integrator, you can create or extend Estimating Standard databases with items that match those in the RSMeans Cost Data Books. You can also update prices for your existing Estimating Standard databases that contain RSMeans items.

1. Install or upgrade to Sage Estimating version 17.12 if you do not already have it installed on your computer.

2. Insert the Means installation CD into the CD drive of the workstation or server where Sage Estimating is installed.

3. From the installation browser:
   b. Click [Browse], and then browse to the server or workstation where you want to store your Means Integrator cost data files.
   c. Select the check box next to each Means Integrator cost data file you want to install, and then click [Install].

5. Follow the steps through the Means Integrator wizard.

Means Integrator Workflows

Integrating your RSMeans Cost Data is a five-step process.

Step One: Prepare Database

In the Means Integrator wizard Prepare Database window, you can select whether to transfer data or update data. The following information describes the outcome of these options.

Transfer Data

Select Transfer Data if you want to move RSMeans items to a new or existing Sage Estimating database.

- **Transfer Data—New Database**

  Select this option to create a new Sage Estimating Standard database and populate it with all of the RSMeans items.

  **Note:** You cannot set job cost interface specifications for a new Standard database using this option. You must first create a new Standard database, set up job cost specifications (such as phase suffix and company), and then transfer RSMeans data to the new database using the Existing Database option in this window. See the Means Integrator Help for more information.

- **Transfer Data—Existing Database**

  Select this option when you want to transfer the Means items to an existing Sage Estimating Standard database.

  If you select this option, the Means Integrator transfers the RSMeans items directly to the selected Sage Estimating Standard database. The resulting database will contain both your existing phases and items and the RSMeans phases and items.

  **Note:** Addition of RSMeans phases and items could cause your phase sort to appear differently in Sage Estimating if the RSMeans items have a different phase format than those already in the Standard database.
If you are transferring RSMeans Cost Data to a new database, also select a company to associate with the data, then specify the length of the normal work periods and the default crew pricing method. Sage Estimating displays the specified information in the Database Settings window whenever you open the database.

Update Data

Select Update Data if you need to update the prices of RSMeans items in an existing Sage Estimating Standard database.

If you want to update RSMeans items in a Standard database created using an earlier version of Sage Estimating (such as Sage Estimating 9.8 or 13.1), ensure you migrate your data to Sage Estimating version 17.12 before performing this update in Means Integrator.

Selecting Means Integrator Cost Data Files

To select the Means Integrator cost data files:

1. Click the [Browse] button, and then navigate to the folder where you installed the Means Integrator cost data files.
2. Select the file or files you want to use.
   - You can use the [Browse] button again to add files to the selection.
   - Use the [Remove] button to remove files from the selection.

See the Installation and Administration Guide for data migration instructions.

**Note:** Items in the Means Integrator cost data files use Master Format 2014 (MF14) coding, which is compatible with the previous MF10 and MF04 formats.

Step Two: Select Data

Select the RSMeans divisions and items that you want to update in or transfer to your selected Sage Estimating Standard database.

You can select items and divisions individually or select all available items and divisions at one time.

Step Three: Select Pricing

Select whether to use RSMeans national average pricing for item pricing or base item pricing on a regional cost index.
• If you choose to use the **RSMeans Standard National Average Pricing** option, the Means Integrator uses the RSMeans standard national average as the base price for each item during the integration. The Means Integrator then imports any city cost indexes associated with the RSMeans items so you can use them later with the Sage Estimating **Cost Index** feature.

• If you select the **RSMeans City Cost Index** option, the Means Integrator calculates and sets item pricing based on the region you specify in the **State** and **City** boxes. It does not import any city cost index information for use in Sage Estimating.

**Step Four: Select Options**

Select a variety of options to apply to the database, including pricing options (**Crew, Hourly**, or **Unit**), audit report options, and what to do with any duplicate items.

**Step Five: Finish**

Review the summary information and click [**Finish**] to transfer or update the selected database with RSMeans information.

You can make changes as necessary by clicking [**Back**] and editing the desired information.

**Help and Information**

The Means Integrator contains updated Help to assist you in converting and updating your databases. To use Help, click [**Help**] from the Means Integrator.
Chapter 3—Sage 300 Construction and Real Estate Job Cost Integration

If you use Sage 300 Construction and Real Estate Job Cost, you can transfer estimate information directly into your job costing application. This allows you to access budget and transaction data without reentering the information. This section covers the interface between Sage Estimating and Sage 300 Construction and Real Estate Job Cost, which enables the information transfer.

Overview

When Sage Estimating sends estimate information to Sage 300 Construction and Real Estate Job Cost, it sends the information directly to the Job Cost application’s New.jct file. Sage 300 Construction and Real Estate Job Cost can then access the estimate data without having to import it first.

*The Sage Estimating-Job Cost Interface*
For detailed information about Job Cost concepts, see the in-product Help in Sage 300 Construction and Real Estate Job Cost.

Setup Guidelines

To help ensure a smooth data transfer between Sage Estimating and Job Cost, follow these guidelines:

Sage 300 Construction and Real Estate Job Cost

Before you export data from Sage Estimating, ensure that in Job Cost:

- Standard cost codes exist for each cost code sent from Sage Estimating.
- If you use categories, standard categories exist for each category sent from Sage Estimating.
- Operators working with estimate data have the appropriate security permissions for the following:
  - Job Cost Enter Estimates or Import tasks
  - File access (to the .jct file)
  - Company security
  - Job record security

Sage Estimating

Before you create an estimate to send to Job Cost, make sure the database settings for phases, items, and addons are set up correctly for your needs. Any changes made to these settings after an estimate is created do not affect existing phases, items, or addons. Existing phases, items, and addons must be changed individually if you want the new settings to be reflected in Job Cost.

Before you send estimate information to Job Cost, ensure that:

- Database Phase settings are mapped to the desired Job cost phase.
- Database Item settings are mapped to the desired Job Cost Phase and Job Cost Category.
- Database Addon settings are mapped to the correct Job Cost Phase and Category.
- The BOM description for the items are 30 characters or less. Job Cost can only accept up to 30 characters for the bill of materials description.
Prepare Sage 300 Construction and Real Estate Job Cost to Receive Estimates

You must verify two items in Sage 300 Construction and Real Estate Job Cost to successfully transfer estimate information from Sage Estimating:

- **All needed standard cost codes are set up.** To see a list of standard cost codes that are already set up in Job Cost, from the Job Cost Reports menu, select Lists > Standard Cost Codes. If you do not see a cost code that you know exists in the estimate or estimates, select Setup > Standard Cost Codes to set up the standard cost code.

- **Standard categories are set up (if your company uses categories).** Using categories is optional. If you do not use categories, you do not need to verify that they exist. To see a list of standard categories that are already set up, from the Job Cost Reports menu select Lists > Standard Categories. If you do not see a standard category listed that you know exists in the estimate or estimates, select Setup > Standard Categories to set up that category.

Prepare Sage Estimating to Send Estimates

Perform the following tasks in the Sage Estimating software to send estimate information to Sage 300 Construction and Real Estate Job Cost.

- Enable the Job Cost interface.
- Verify standard database phase settings.
- Verify the standard database item settings.
- Verify the standard database addon settings.

Enable the Job Cost interface

Set up standard databases individually to interface with Sage 300 Construction and Real Estate Job Cost by enabling the interface in the Sage Estimating Estimating Management Console:

1. Click the Estimating Management Console desktop icon.
2. In the Estimating Management Console, click the Standard Databases tab.
3. Select the desired standard database from the list of standard databases in the Standard Database Catalog pane.
4. If desired, you can also create a new standard database by clicking [New Standard Database].
Fill out the new standard database details on the provided tabs in the detail pane and click [Create].

5. Select **Sage 300 Construction and Real Estate** as the job cost interface in the **Job Cost Info** area of the detail pane.

**The Job Cost Area**

6. Click [Setup] (Job Cost Info area) to open the **Job Cost Integrator** window in Sage 300 Construction and Real Estate Job Cost.

7. In the **Job Cost Integrator** window, select the Sage 300 Construction and Real Estate company you want to associate with the standard database.
The Job Cost Integrator Window

8. Select a default JC category cost code in the Labor, Material, Subcontractor, Equipment, and Other boxes.

Sage Estimating prefills the JC category box in each new item you create with the applicable selected default category.

For example, if you select a labor cost code of 03-0100 for the Labor box, each time you create a new labor item for the estimate or standard database, the item's JC category box automatically displays a cost code of 03-0100.

9. If you want to overwrite the cost code information in existing items in your standard database, select the Add Job Cost categories to items check box.

10. Click [OK] to return to the Estimating Management Console.

11. Verify that the Sage 300 Construction and Real Estate company you selected in step 6 appears in the Company name box of the Job Cost Info area of the Estimating Management Console.

Verify standard database phase settings

Both Sage Estimating and Sage 300 Construction and Real Estate Job Cost use the concept of phases.
Note: In Job Cost, phases are often called *cost codes*.

It is possible that the phase structure used in Sage Estimating is not the same as the cost code structure used in Job Cost. Using the Database Phase window in Sage Estimating, you tell the software how you want the two structures to align. In essence, you create a map for the software to use when you transfer data from a phase in Sage Estimating to a cost code in Job Cost.

**To verify standard database phase settings:**

1. Open the **Database Phase** window.
   - On the ribbon, from the Phase/Item group on the Data tab, click Phases.
   - In classic view, click Database > Phases.
   - From the spreadsheet, right-click in a phase row, and then click **Edit Phase** on the shortcut menu.

**The Database Phase Window**

2. Click the list button located to the right of Job cost phase to select the Sage Estimating phase to be mapped to a cost code in Job Cost.

**The Database Phase List** window opens.
3. Double-click the desired phase.

You are returned to the Database Phase window. The selected Phase, its Description, Unit description, and any previously selected Job Cost phase display in the Database Phase window initially.

**Note:** You can use the same Job Cost phase number for many different estimating phases.

4. Click [Close] when you are finished.

**Verify standard database item settings**

The Database Item window is where you define the Job Cost phase and Job Cost Category to use with a standard database item, and specify which quantity to send to Job Cost.

**To verify standard database item settings:**

1. Open the Database Item window:
   - On the ribbon, from the Phase/Item group on the Data tab, click Items.
   - In classic view, click Database > Items.
2. In the **Database Item** window, click the **Job Cost** tab.

*The Job Cost Tab of the Database Item Window*

![Database Item window with Job Cost tab highlighted](image)

The information you enter on this tab creates a map for the software to use when you transfer information from Sage Estimating to Job Cost. For each item in the standard database, you can select a Job Cost phase (remember, in the Job Cost application, phases are often referred to as *cost codes*) and a Job Cost category. When Sage Estimating sends this estimate item to Job Cost, the item and its associated information appears under the cost code and category you select on this tab.

**Note:** As with phases, you can use the same **Job Cost Phase** and **Job Cost Category** for any number of estimate items.

3. Click in the **Job Cost Phase** field, and then click the list button.

*The Database Job Cost Phase List window opens.*

4. Locate and double-click the Job Cost phase you want to receive the item information when Sage Estimating interfaces with Job Cost.

When you double-click on an item, the **Database Job Cost Phase List** window closes and you are returned to the **Database Item** window. The Job Cost phase you selected appears in the **Job Cost Phase** box.
**Note:** You can also manually enter a phase. Be sure to follow the format set up in Job Cost. If the phase does not exist in Job Cost, you can create it during the import.

5. Click in the **Job Cost Category** box and then select the category from the list to receive the Sage Estimating item information.

*The Job Cost Category List*

![Job Cost Categories List](image)

You can also manually enter a category.

Be sure to click in the **Job Cost Category** box, not the standard database item **Category** box. The database item **Category** box is used for pricing and does not have any impact on the Job Cost interface.

6. Select the item quantity to send to the selected Job Cost category by selecting the item quantity from the **Qty to Job Cost** list.

Your cost accounting needs should dictate which option you choose.

- **Takeoff qty** sends to Job Cost the takeoff item quantity for the category.
- **Order qty** sends to Job Cost the order item quantity for the category.
- **None** sends to Job Cost the total dollar amount for the job cost phase and job cost category. It does not send quantities, so the unit price field in Job Cost will be blank.
7. Click [OK] and [Close] when you are done.

**Note:** You can also make changes to the Job Cost phase and category from the estimating spreadsheet itself.

## Verify standard database addon settings

### To view the database addon settings:

1. Open the **Database Addons** window:
   
   - On the ribbon, from the **Miscellaneous** group on the **Data** tab, click **Addons**.
   
   - In classic view, click **Database menu > Addons**.
   
   - From the **Totals** window, click ![add-on icon] or select **Edit Addon** from the shortcut menu.

2. In the **Database Addon** window, select the **Allocatable** check box to make an addon cost eligible for allocation when the estimate information is sent to Job Cost.

   **Note:** To actually allocate the addon, select the **Allocate addons** check box in step 2 of the **Job Cost Export** wizard (in the Sage Estimating software).

3. To send the addon costs to a specific Job Cost cost code and category, click [**Job Cost**] and select the Job cost phase and category to receive the addon information.

### Selecting a Phase and Category for Job Cost
Export Estimate data to Sage 300 Construction and Real Estate Job Cost

Use the Export to Job Cost wizard to send the following estimate data to Sage 300 Construction and Real Estate Job Cost:

- Each phase for which you have entered a phase quantity in the spreadsheet.
- Each item category with an amount. The item setup determines whether the transaction includes the takeoff quantity or order quantity.
- Each addon that is not allocated. The cost of allocated addons is found in the items used to calculate those addons.

To export to job cost:

1. Open the Job Cost Transfer wizard in one of the following ways:
   - On the ribbon, from the Export to Job Cost on the Advanced tab, click Export to Job Cost.
   - In classic view, click Interface > Job Cost).

   Job Cost Export Wizard Introduction

   Create or add to a job cost budget from an estimate

   This wizard consists of three steps:
   1. Specify a job number and transaction date.
   2. Select markups and rounding options.
   3. Specify optional WBS or location information.

   Click 'Next' to start. You can cancel at any time.

2. Click [Next].
3. Enter (type or click the calendar button next to the **Transaction date** box) the date to appear on the transactions contained within the transaction file.

   The **Sage 300 Construction and Real Estate JC job number** box displays the job number entered in the **Estimate Information** window in Sage Estimating.

4. Click [Next].

5. Select how you want item quantities to be rounded and how to allocate addons.
6. Click [Next].

Job Cost Export Wizard Step 3

7. Select the **Map estimate information to extras in Job Cost** check box if you want to map estimate information to Job Cost extras.
If you do not use extras in Job Cost you do not need to do anything on this tab.

In Job Cost, extras are sub-jobs of the main job. Extras allow you to track cost, revenue, and commitments separately from the main job, while still being able to accumulate to the main job.

Some reasons you might need to use extras in Job Cost are:

- The owner or architect requested additional work after the original contract was signed.
- You must track income from certain cost codes separately from the main job.
- Certain costs are billed and tracked separately from the main job.

In Job Cost, you can change the name "extra." For information about how to change the name of this item, refer to "custom descriptions" in the Job Cost in-product Help.

8. If desired, attach information from a work breakdown structure or location to an item as an extra:

9. Select the Map estimate information to extras in Job Cost check box.

Each item is mapped to a specific cost code and category in Job Cost using the Database Item window in Sage Estimating. The mapping you enter sends a location or work breakdown structure (WBS) code to Job Cost as an extra.

In Sage Estimating, WBS codes enable you to attach additional information to each item. Each WBS code has values underneath it. For example, if you had a WBS code of CSI Phase, the values underneath that WBS code might be field supervision, project administration, safety coordination, and so forth.

In Job Cost, the Extra ID entry is limited to 10 characters.

Additionally, you can use a location to relate an item to a specific job area. For example, if you build an office, you might want to assign one item to the first floor and another item to the second floor.

10. Select the WBS code or location from the Sort Level list to send to Job Cost as an extra.

When you select a Sort Level, you receive a warning. If you choose a sort level, non allocatable add-ons will not be exported. Select [Cancel] instead to export all. Also, if you want all addons included in the export, click [Cancel].

If you select a WBS code for the Sort Level, the WBS values area becomes available.

If you selected Location as the Sort Level, the name of this area is Location Selection. Its function is the same no matter which Sort Level you select.

11. Under WBS values, choose whether to send all WBS values to Job Cost or only selected WBS
Values.

12. Click [Finish] to export the specified estimate data to Job Cost.

Sage Estimating sends the exported estimate information directly to the Sage 300 Construction and Real Estate Job Cost New.jct file.
Chapter 4—On-Screen Takeoff Integration

Note: This feature is available only if you have a license to use ePlan Takeoff.

If you use On-Screen Takeoff (OST) estimating software, you can set OST to interface with Sage Estimating through the On-Screen Takeoff Integrator. The OST Integrator lets you perform takeoff to estimates in Sage Estimating from drawings you create and store in OST.

Learning About Integration

The OST software organizes parts and materials required for a job into collections known as conditions. Sage Estimating, however, organizes materials in its databases into individual items and collections called assemblies. You must convert or integrate OST conditions into items and assemblies before you can create estimates in Sage Estimating through OST takeoff.

Integration involves three primary steps:

1. Select a condition for takeoff in OST.

2. In the OST Integrator, select a Sage Estimating item or assembly that is comparable or the equivalent of the OST condition. For example, if you select "Drywall sheeting" for takeoff in OST, find a Sage Estimating item or assembly that most closely matches the selected drywall sheeting.

3. Note the physical properties of the selected OST condition, such as length or height, and type any conversion factors as necessary to equate it with the assigned Sage Estimating item or assembly. For example, if the drywall board length in OST is measured in meters, and the assigned Sage Estimating item measures length in feet, type the conversion factor required to equate the two.

Illustration of the Integration Principle
On-Screen Takeoff Integrator Features

To start the OST Integrator from Sage Estimating:

- On the ribbon, from the On-Screen Takeoff group on the Advanced tab, click On-Screen Takeoff Integrator.
- In classic view, click Interface > Open OST Integrator.

The On-Screen Takeoff Integrator Main Window

The main window of the On-Screen Takeoff Integrator is divided into three separate panes.
Condition Assignment Pane

The Condition Assignment pane provides a list from which you can match or assign items or assemblies in Sage Estimating with conditions in an OST database.

For example, if you are working with an OST project or drawing that has a condition for 30 square feet of ceramic floor tile, and the closest equivalent in a Sage Estimating database is the 04-00-10 Masonry, Tile assembly, select the ceramic floor condition in the list, click the Assign Assembly button, and select the 04-00-10 assembly to assign it to the ceramic floor condition.

Sage Estimating items and assemblies appear in the list beneath the OST conditions to which they are assigned.

Condition Properties Pane

The Condition Properties pane displays the physical qualities of any OST condition selected in the Condition Assignment pane, such as depth, height, or count (number). You must "map" these properties to their Sage Estimating equivalents in the Integration grid when you assign an item or assembly to an OST condition.

For example, if the selected OST condition has a length of 30 meters as a physical property or dimension, and the Sage Estimating assembly you assign to it measures length in feet, you must map the OST condition’s length (using the Integration grid) to the assigned assembly’s length and indicate the conversion factor from meters to feet.

Mapping condition properties enables the OST Integrator to create accurate estimates when performing takeoff from an OST condition.

Integration Grid

Use the Integration grid to "map" or convert the properties of an OST condition to the variable equivalent of its assigned Sage Estimating item or assembly.

For example, if you are working with a "drywall ceiling" condition from an OST drawing that has a length of 30 meters, and you assign the 09-00-10 Drywall assembly from Sage Estimating to it, you must ensure the Sage Estimating assembly has a variable equivalent for length in meters.

To begin mapping, select any condition from the Condition Assignment pane that already has a Sage Estimating item or assembly assigned to it. The grid displays the estimating variables and OST condition properties associated with the selected condition.

Refer to the OST Integrator in-product Help for information about specific columns in the grid.
Performing Integration

Before integrating OST items and conditions with Sage Estimating items and assemblies, select both an OST database and a Sage Estimating database you want to use for the integration and takeoff processes.

You can open either a Microsoft Access-based OST database or a Microsoft® SQL Server®-based OST database for integration. See the OST Integrator Help for more information.

**Note:** Ensure you open an OST database before performing this procedure.

To integrate OST conditions with Sage Estimating items and assemblies:

1. Select a condition for takeoff in OST.

2. In the OST Integrator, click the **Goto** button to view the selected condition and its associated items in the Condition Assignment pane of the OST Integrator.

3. In the Condition Assignment pane, expand the OST condition to view any items or assemblies already assigned to it.

   **Note:** You can right-click on any condition and select **Expand condition** to expand it.

4. Click the assign item button to open the **Item List** window or the assign assembly button to open the **Assembly List** window.

   This window lists all available Sage Estimating items or assemblies in the selected Sage Estimating standard database.

5. Select an item from the list in the **Item List** window or an assembly from the **Assembly List** window and click [OK].

   The assigned item or assembly then appears in the **Condition Assignment** pane beneath the condition to which you assigned it.

6. The variables associated with the assigned Sage Estimating item or assembly appear in the Integration grid. The properties associated with the selected OST condition appear in the Condition Properties pane. You must "map" or match one or more condition properties to a Sage Estimating variable:
a. For the first variable listed in the Estimating Variable column, select an equivalent condition property from the list in the Condition Property column.

For example, if the first Sage Estimating variable is Width, select a width-based condition property from the Condition Property list.

b. You can also select a condition property by clicking on a property in the Property column of the Condition Properties pane and "dragging" it to the Condition Property column of the Integration grid.

Mapping Properties

If no equivalent condition property is available, leave the Condition Property column blank.

c. If you select a condition property, and a conversion factor is required, type it in the Conversion Factor column.

For example, if the Sage Estimating variable Length is measured in Inches but the condition property Length is measured in Feet, the conversion factor is 12/1 or 12.

If you did not select an equivalent condition property in step a, specify the Sage Estimating variable's value by typing directly in the Value column.

d. Repeat steps a-c for each Sage Estimating variable in the grid.

7. Repeat steps 1-6 for each OST condition you expect to use during takeoff.

8. Click [Save] to save your changes.

Performing One-Time Integration

You can integrate values from an OST condition property with an item or assembly dimension in Sage Estimating on a one-time basis. You can do this by dragging the OST condition into the
To perform a one-time integration with a Sage Estimating estimate:

1. In Sage Estimating, open the **Item Takeoff**, **Assembly Takeoff**, or **Quick Takeoff** window.
2. In the OST Integrator, open the OST project containing the condition or conditions you want to add to the estimate.
3. Select the condition you want to add from the Condition Assignment pane of the OST Integrator.
4. From the Condition Properties pane, select the condition property **Value** that you want to add to the estimate—for example, the values associated with the "width," "height," or "quantity"—and "drag" it to the dimension grid of the **Item Takeoff** window, **Assembly Takeoff** window, or **Quick Takeoff** window in Sage Estimating.

5. Repeat steps 2-4 to integrate all desired OST conditions with the estimate.
Performing Takeoff to Estimates

After you integrate OST conditions with Sage Estimating items and variables, the OST Integrator allows you to create estimates in Sage Estimating using conditions and items you take off from OST projects.

**To take off OST items and conditions to an estimate:**

1. Select an OST project from the list in the Condition Assignment pane.
2. Click the new estimate button to create a new estimate.

Alternatively, you can open an existing estimate by clicking the update estimate button.

- **If you are creating a new estimate:** Type a name for the new estimate in the New Estimate window; then specify an estimate database for storing it, a standard database to associate with it (optional), and the estimate "branch" where you want it displayed then click [OK] to create the new estimate.

- **If you are opening an existing estimate:** Select the existing Sage Estimating estimate from the estimate list then click [Open] to open it.

The OST Integrator adds items and assemblies already assigned to conditions in the OST project to the new or existing estimate. If desired, you open the estimate immediately after creating it.

Note: For existing estimates only: If you previously generated items and assemblies from the OST project to the selected estimate, the OST Integrator deletes the items and assemblies before adding new ones.

Using Condition Style Libraries

Using the OST software, you can create a library of condition styles that you can then use in more than one project. A corresponding condition style library appears in the Condition Assignment pane of the OST Integrator.

If, for example, you create a condition in an OST project for right-hand doors called RH Door, you can choose to save the condition in the OST style library for use in other projects. In the OST Integrator, the RH Door condition automatically appears in the Style Library of the Condition Assignment pane.

*Condition Styles in the Condition Assignment Pane*
After saving conditions as styles in the condition style library, you can assign Sage Estimating items and assemblies to them in the OST Integrator (see "Performing Integration" (page 31) for instructions).

You can then use the integrated condition styles in future projects whenever they are required.

You can create and edit condition style libraries only in On-Screen Takeoff.

**Note:** Each OST database has only one condition style library.

### Importing and Exporting Condition Assignments

You can import and export integrated condition assignments in extensible markup language (XML) files. Use this feature when you want to transfer integrated condition assignments from a Sage Estimating standard database in one location to a standard database in another location.

For example, if you assign OST conditions to Sage Estimating items and assemblies in a standard database on your local computer, and you want to integrate those same assignments into another standard database (such as a shared standard database on a server, for example), export the integrated conditions to file then import them into the shared database.

**To export assignments to a file:**

1. In the OST Integrator, open the standard database containing the assignments you want to export.

2. Select Import/Export group > Export the assignments to a file (in classic view, select File > Export).

3. Type a file name for the export file in the File Name box and browse to the location where you
want the file saved.

4. Click [Save].

The OST Integrator saves the condition assignments to an XML file (.osti extension) that you can import later.

**To import assignments to a file**

1. In the OST Integrator, open the standard database where you want the condition assignments imported.

   The target standard database you select must have the same items and assemblies as those in the .osti file or an error results during import.

2. Select **Import/Export group > Import an assignments file** (in classic view, select **File > Import**).

3. Select the import file containing the assignments you want to import (.osti extension).

4. Click [Yes] at the prompt.

   The OST Integrator overwrites all current condition assignments in the standard database when you import the assignments from file.

5. Right-click on the OST database in the Condition Assignment pane and select **Change the Database Path**.

6. Browse to the location of the OST database containing the integrated conditions click [Open] to update its location relative to the imported condition assignments.
Index

C
Condition Assignment pane
  description 30
  viewing assignments 31
condition properties
  mapping 31
  purpose 30
Condition Properties pane
  description 30
  condition style libraries 34
conditions
  purpose 28
  reusing 34
contacting Sage 7

D
documents, list 1

E
exporting data to Job Cost 23

F
features 1

H
help
  using the in-product Help 4

I
integration
  item 31
  outline 28
Integration grid
  description 30
  item integration 31

J
Job Cost interface
  enabling 15
  Estimating prerequisites 15
  guidelines 14
  outline 13

L
library, condition style 34

M
Means databases
  integration 10
  list 9
  updating 11
O

On-Screen Takeoff (OST)
  conditions 28
  description 28
  integrating conditions 31
  integration 28
  performing takeoff 34
  one-time integration 32
  options
    list 1

OST Integrator
  description 28
  features 29

R

related documents 1
release overview 1
RSMMeans databases
  list 9
  updating 11

S

Sage contact information 7

T

transferring data 10

U

updating database prices 11