# Contents

Chapter 1—Microsoft SQL Server and Sage Estimating .............................................. 1  
  Microsoft SQL Server and Pervasive ........................................................................... 1  
  The SAGE_ESTIMATING Instance ............................................................................. 3  
  Microsoft SQL Server Files ....................................................................................... 4  
  SQL Database Permissions and Access ...................................................................... 4  
  Read the Supporting Documentation Before You Begin ............................................. 5  
  Conventions Used in this Document .......................................................................... 5  
  Ways to Get Help ......................................................................................................... 6  
  Training ....................................................................................................................... 8  
  Technical Assistance ................................................................................................... 9  
  Submitting Enhancement Requests ........................................................................... 9  

Chapter 2—Technical Information ................................................................. 10  
  Supported Editions of SQL Server ........................................................................... 10  

Chapter 3—Installation .................................................................................. 11  
  Overview .................................................................................................................. 11  
  SQL Server Express Installation ............................................................................ 11  
  Modified Installation ............................................................................................... 13  

Chapter 4—FAQs ....................................................................................... 14  

Chapter 5—Troubleshooting SQL Server .................................................. 17  
  Installation Issues ...................................................................................................... 17  
  Connection Issues ..................................................................................................... 18  
  Determining the path to the SQL Server program .................................................. 24  

Chapter 6—Additional Information ......................................................... 26  
  General Information ................................................................................................ 26  
  Corruption ............................................................................................................... 26
Chapter 1—Microsoft SQL Server and Sage Estimating

Sage Estimating uses SQL Server as its database platform. Previous releases used Pervasive as the database platform for storing Sage Estimating data. This database platform change is intended to offer you increased security, performance, and flexibility for your reports, queries, and daily operations.

This document provides information on the impact of these changes. It is important to understand these differences so that you can effectively manage and protect your Sage Estimating data.


Microsoft SQL Server and Pervasive

Microsoft SQL Server represents a change from the Pervasive database platform used in previous Sage Estimating releases. It is important to understand how the new SQL Server database platform is structured.

SQL Server stores database information in database (.mdf) and log (.ldf) files. Previously, Sage Timberline Office Estimating created separate estimate files that you could store in any desired Windows file structure. With the new SQL Server database, Sage Estimating stores all your estimates in the same .mdf database file on a single server known as an instance.
Comparison of Pervasive and SQL Server

**Pervasive**

- Server
  - Folder
    - Database
  - Estimate
  - Estimate
  - Estimate

**SQL Server**

- Server (instance)
  - Standard Db
  - Address Book Db
  - Estimate Db
    - Estimate
    - Estimate
    - Estimate
    - Estimate

A Sage Estimating instance (sometimes referred to as a "server") consists of three primary components:

- An Address Book database
- An estimate database
- One or more standard databases

You configure security for the instance, and then apply it to all contents, including the Address Book, all standard databases, and all estimates within the estimate database.

Estimates are stored entirely within the estimate database. With Sage Estimating (SQL), you can use the Estimating Management Console to arrange your estimates in a hierarchy of tiers or "branches." The branches you create in the Estimating Management Console are for organizational purposes only. They do not change the structure of your database.

The location of your SQL Server database files (.mdf and .ldf files) depends in part on your operating system. See "SQL Server Express Installation" (page 11) for more information.

SQL Server allows an unlimited database size. However, SQL Server Express limits the database size to 10 gigabytes (GB). Sage Estimating warns you if your database size nears the limit.

If you select the option to create a new SQL Server instance in the Select installation options for Sage Estimating window, the installation process automatically configures a new Sage Estimating-compatible instance for you. The default name for the instance is SAGE_ESTIMATING. However, you can name the instance anything you want.

If you do not select the option to create a new SQL Server instance in the Select installation options for Sage Estimating window, you can create your own instance using an existing SQL Server installation. The new instance must meet the requirements stipulated in "Modified Installation" (page 13)."
The SAGE_ESTIMATING Instance

Sage Estimating allows the use of just one active SQL Server instance at a time. The active instance is a "closed" SQL Server instance. Sage Estimating does not recognize databases (Address Book or standard databases) transferred or copied from other SQL Server instances unless they are added by way of the Search For feature in the Estimating Management Console.

For example, if you have two Sage Estimating installations, Install A and Install B, you cannot copy Address Book databases by copying them from Install A's SQL Server instance to Install B's SQL Server instance alone (using SQL Server Management Studio's built-in Copy Databases wizard, for example). You must also open the Estimating Management Console and use the Search For $ button in the Address Book Companies/Contacts toolbar.

Copying Databases From One SQL Server Instance to Another

Any database you add to an instance must have the same Sage Estimating version as the other operating databases. For example, if you are using Sage Estimating 19.12, and you want to add a standard database from a previous Sage Estimating installation, upgrade the standard database to version 19.12 before adding it to the new instance. Refer to the Estimating Management Console in-product Help for instructions on adding databases using the Search For feature.

SQL Server allows an unlimited database size. However, SQL Server Express limits the database size to 10 gigabytes (GB). Sage Estimating warns you if your database size nears the limit.

If you select the option to create a new SQL Server instance in the Select installation options for Sage Estimating window, the installation process automatically configures a new Sage Estimating-compatible
instance for you. The default name for the instance is SAGE_ESTIMATING. However, you can give the instance any name you want, provided it is not the same as an existing SQL Server instance on the computer.

If you do not select the option to create a new SQL Server instance in the Select installation options for Sage Estimating window, you can create your own instance using an existing SQL Server installation. The new instance must meet the requirements stipulated in "Modified Installation" (page 13).

**Microsoft SQL Server Files**

Every SQL Server database has at least two files associated with it:

- A file that stores the actual data (.mdf)
- A transaction log file (.ldf)

SQL Server stores your Sage Estimating data in the database file (.mdf). For details, see "SQL Server Express Installation" (page 11).

The transaction log (.ldf) records all changes to the data in the database. This log ensures data integrity by keeping track of data that has changed and can be used to roll the data back to a previous state in the event of a database failure.

It is important to make regular backups of these files. For more information, see "Backing Up SQL Server Databases" (page 36).

**Collation settings for use with Sage Estimating**

Sage Estimating requires a special collation setting. Collation settings in SQL Server must be set to:

- Latin1_General
- Case-sensitive
- Accent-sensitive

See "Server Configuration: Collation Settings" (page 31) for more information.

**SQL Database Permissions and Access**

You must give each Sage Estimating operator permissions to the Sage Estimating features that they are expected to use. Assign database and feature permissions using the security feature of the Estimating Management Console. For more information, see the Estimating Management Console in-product Help.

**Caution!** Do not change the owner of any databases in the Sage Estimating instance.
Read the Supporting Documentation Before You Begin

Be sure to read the supporting documentation before you begin. The following guides are available at http://cdn.na.sage.com/Docs/en/customer/estimating/SageEstimatingDocs.htm for each supported version:

- This SQL Server Guide gives you an overview of the significant differences between the new SQL Server databases and the Pervasive databases used in previous Sage Estimating releases.
- The Installation and Administration Guide includes an overview of this release, installation instructions, and contact information.
- The Release Notes provide details about new features, database changes, known issues, and fixes.
- The Options Guide provides installation, setup, and operating instructions for each of the available Sage Estimating options, such as the OnScreen Takeoff Integrator or License Manager.
- The Sage 100 Contractor Integration Guide describes how to integrate Sage Estimating with Sage 100 Contractor, making certain data in that program available in Sage Estimating, and it explains how to use the interface wizards to send proposals, budgets, and change orders you create in Sage Estimating to Sage 100 Contractor.

Important! For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 99187, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

Conventions Used in this Document

This document uses the following conventions:

- Information you type into the software is shown in bold font. For example: Type **Miscellaneous** in the box.
- The names of screens, windows, fields, and other features displayed by the software are shown in **bold font**.
- Names of keys are also shown in bold font. For example: **Enter** or **Tab**. A plus sign (+) between two key names indicates you should press the keys simultaneously.
- The names of buttons you can click are shown in bold font and enclosed in brackets. For example: **[OK]** or **[Post]**.
- Variable names or names that are specific to your installation may appear in italics and brackets. For example: **[Drive]\[Server]**.
Notes, Tips, and Cautions

**Note:** This style shows that the information supplements the adjacent text.

**Tip:** This style indicates helpful points about using the software.

**Caution!** This style indicates important information to help you avoid a loss of critical data.

**Important!** This style indicates critical information that you need to understand or important steps you need to take.

Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with square brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Ways to Get Help

Use Sage Estimating Help or a variety of self-help resources to get answers to your questions. You can also call Customer Support.

The Help System

Sage Estimating Help provides more efficient access to information than most manuals. With a click of the mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.

Sage Estimating displays Help in your default browser. If you have an Internet connection, it displays the most current Help for your version of Sage Estimating available from a hosted Help server. If you have no connection (you are working offline), it displays Help that was current when the software was released, and is installed on your computer when you install Sage Estimating.

**Important!** Because the Microsoft Edge browser does not display locally installed help properly, we recommend that you select a different default browser when working offline.

To get Help on a window option

To display Help for an option in a window, do one of the following:
- Click **What's This?** on the toolbar or on the title bar, and then click the option.
- Select **What's This?** from the **Help** menu, and then click the option.
- Select the option, and then press F1.

To get Help for the whole window

For information about the window, such as the window’s purpose and what tasks you can perform in it, click [Help] at the bottom of the window.

*The Window Help Button*
To use Help to learn how to do tasks

1. Click [Help] on the toolbar, or select the Home tab > Help group > Help (or select Help menu > Help topics in classic view).

   The Help Window

2. Use one of these tabs on the navigation pane to begin looking for a topic.
   a. Contents contains Help subjects organized within books.
   b. Click the Glossary heading on the Contents tab to view an alphabetical list of definitions of terms used throughout the Sage Estimating software.
   c. Index contains an alphabetical list of Help subjects.

   When you see the topic you want, double-click it to display it.

3. Use the Search box to find articles that match the keywords you enter.

Training

Sage University offers online and classroom training sessions to help you get the most out of your Sage Estimating software. To visit Sage University, go to www.sageu.com.

You can also click File > Help > Sage University.
Technical Assistance

When you need assistance, refer to the Knowledgebase article How do I get technical support for Sage Estimating? to determine which service works best for you.

Submitting Enhancement Requests

We want to hear your suggestions for improving the software. To send us your comments, click the File menu button and then select Help > Submit Product Idea.
Chapter 2—Technical Information

Supported Editions of SQL Server

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 99187, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

A copy of SQL Server Express Edition is provided free of charge with Sage Estimating. This edition is sufficient for most Sage Estimating customers. However, customers with large databases may need to upgrade to the Standard Edition. For information on Microsoft SQL Server editions, visit www.microsoft.com.
Chapter 3—Installation

Overview

Before installing Sage Estimating, you have two primary SQL Server scenarios to consider:

- **SQL Server Express Installation.** Installing Sage Estimating also installs SQL Server Express when you select certain installation options. Follow this scenario for these conditions:
  - You are installing Sage Estimating on a standalone workstation or a workgroup server.
  - You are installing to a server on a domain and you want to use the copy of SQL Server Express that comes with the Sage Estimating install package.

  The Sage Estimating installation package installs and configures a new SQL Server instance of SQL Server Express whenever you select the option to create a new instance. You can operate the new SQL Server instance alongside an existing SQL Server instance.

- **Modified Installation.** You have already installed a supported version of SQL Server (or plan to install one), and you want to manually create a new instance to use with that version.

Use the **Security** feature in the Estimating Management Console to assign database permissions to each operator after installing your SQL Server instance.

For more information on setting up SQL Server security for Sage Estimating, see the *Installation and Administration Guide*.

**Note:** You can install an approved instance of SQL Server side by side on a computer where SQL Server 2012 is also installed. Be aware that installing Sage Estimating may then result in an "Install completed with errors" message. However, the resulting Sage Estimating installation operates correctly.

**SQL Server Express Installation**

Microsoft SQL Server Express comes as an optional component with the Sage Estimating install package. It installs automatically when you select certain Sage Estimating installation options.

**Note:** If you are operating in a workstation/server environment, you do not need to install SQL Server on the workstations. However, you can install SQL Server locally if you want to maintain a copy of your estimating data.

Follow the instructions below to install SQL Server Express from the install package.
1. Open the **Select Installation Options for Sage Estimating** window by double-clicking **SetMeUp.exe** in your local install folder.

2. The install folder is created wherever you download the Sage Estimating install files. For example, if you download the install files to C:\Users\Public\Public Documents, look in this folder for the **SetMeUp.exe** file.

*The Select Installation Options for Sage Estimating Window*

3. In the **Select installation options for Sage Estimating** window, select **Create a new local SQL Server instance**.

4. In the **Enter new instance name** box, type a name for the new SQL Server instance (database server) in the box and click **[OK]**.

5. The default name for the instance is SAGE_ESTIMATING. However, you can give the instance any name you want, provided it is not the same as an existing SQL Server instance on the computer.

6. Click **[Next]**, and then follow the on-screen instructions for installing Sage Estimating or Sage Estimating server.

   The software installer creates the new instance, and notifies you when the process is finished.

   **Note:** Be sure to elevate your privileges at the prompt within two minutes of its appearance or the installation will quit.
Installing SQL Server Express also installs SQL Server Management Studio Express, a tool for performing database back up and restoration procedures and for assigning database permissions.

Modified Installation

You may use a version of SQL Server that already exists on your computer, but it must be a supported versions. (For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 99187, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.)

If you want to use your existing installation of SQL Server, create a new instance to operate alongside your existing SQL Server instances. You can give the new instance any name you want. However, Sage recommends naming the new instance an easily identified name such as SAGE_ESTIMATING.

After creating your new instance, ensure you assign the appropriate database permissions as outlined in the Installation and Administration Guide.

Notes:

- If you plan to migrate existing data from a Pervasive-based version of Sage Estimating, you must install SQL Server or SQL Server Express on the destination computer or server.
- Restart your server or workstation after creating the new instance

Caution! Do not change the owner of any databases in the Sage Estimating instance.
Chapter 4—FAQs

I already use a version of Microsoft® SQL Server® on my computer. Can I use this version with Sage Estimating?

You must use a version of SQL Server that Sage Estimating supports, and you must create a new instance for Sage Estimating that conforms to our recommended security settings. See "The SAGE_ESTIMATING Instance" (page 3) for more information.

Note: You can install an approved instance of SQL Server side by side on a computer where SQL Server 2012 is also installed. Be aware that installing Sage Estimating may then result in an "Install completed with errors" message. However, the resulting Sage Estimating install operates correctly.

If I already have a version of SQL Server installed, does installing Sage Estimating upgrade my existing SQL Server version?

No. However, you can install SQL Server Express from the Sage Estimating setup and installation files for use with Sage Estimating. You can then use both SQL Server versions in a side-by-side configuration (meaning both versions are installed).

What are the minimum system requirements to install SQL Server?

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 99187, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

Which operating systems are supported with SQL Server?

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 99187, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

Are 64-bit platforms supported?

Yes, you can install SQL Server Express on the several 64-bit Windows platforms.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our
Can SQL Server Express Edition installations be performed on substitute, mapped, or compressed drives?

No, installations cannot be used on any of these configurations.

Can I use File Tools or other utilities to back up my SQL databases?

No. You must detach your databases and then back them up after the process is complete. File Tools and other utilities do not perform this function.

Use SQL Server Management Studio or SQL Server Management Studio Express to back up your SQL data. Microsoft SQL Server Management Studio Express attaches and detaches the database automatically during back up and restore procedures. For more information, see "Backing Up SQL Server Databases" (page 36).

Will running a virus scanner on the SQL Server host machine affect performance?

Important! For performance reasons, if you plan to run a virus scanner on the machine that hosts the SQL Server instance, you should exclude files that have MDF, LDF, NDF, BAK, TRN, and TRC extensions. You should also exclude additional processes for the version of SQL Server that you are running. For more information about the files and processes to exclude, see Microsoft Knowledgebase article 309422 at http://support2.microsoft.com/kb/309422.

How can I test whether SQL Server is working in Sage Estimating?

The first time you start Sage Estimating or the Estimating Management Console after installing the Sage Estimating software, you should be able to use the Configuration wizard to locate your SQL Server instance. If you are able to use the Configuration wizard to successfully locate at least one SQL Server instance, your installation of SQL Server is operating correctly.

If you are able to open or create estimates and databases in the Sage Estimating software, SQL Server is operating correctly.

What do I need to be able to manage user access rights in SQL Server?

For Sage Estimating, security is managed entirely from within the Security feature of the Estimating Management Console. You can create roles and their corresponding permissions to access various Sage Estimating tasks and features.

You must be belong to the Sage Estimating administrator role to create roles and assign them to other operators. For more information about creating roles and permissions, refer to the Sage Estimating Installation & Administration Guide or the Estimating Management Console in-product Help.
I can connect to a SQL Server instance on my local computer but why can't I connect to a SQL Server instance on a remote server?

You may need to reconfigure your firewall settings. See "Firewall settings" (page 19).
Chapter 5—Troubleshooting SQL Server

This section provides additional information if you have any difficulty installing or connecting to a supported version of Microsoft® SQL Server®.

Installation Issues

The following paragraphs provide troubleshooting tips for installation issues.

Collation

Sage Estimating requires a special collation setting. Collation settings in SQL Server must be set to:

- Latin1_General
- Case-sensitive
- Accent-sensitive

These settings are configured automatically when you create the SQL Server Express instance from the Sage Estimating install. You may sometimes see this listed in SQL Server as SQL_Latin1_General_CS_AS.

**Note:** If you upgraded to SQL Server Express 2014, your collation settings may not correctly match the settings required by Sage Estimating.

Compatibility

Sage Estimating requires SQL Server 2008 R2, or higher.

SQL Server is designed so that multiple instances may exist on a single computer. Each instance is independent of the others, and may use different versions or service packs.

You may need to remove the existing version to resolve any compatibility issues. However, be aware that other software may be using the incompatible version. Contact your system administrator before attempting to remove any incompatible version.

If you determine that the version can be removed safely, use Windows' Add or Remove Programs to remove it (note that you may have to remove several entries to completely remove the version).
Connection Issues

The following paragraphs provide troubleshooting tips for connection issues.

Authentication mode

The authentication mode for the SQL Server instance you create for Sage Estimating must be set to **Windows Authentication and SQL Server Authentication** (also referred to as "Mixed Mode") to work with Sage Estimating. In this mode, SQL Server creates and maintains your login information. See "Chapter 5—Troubleshooting SQL Server" (page 17) for more information.

Changing the authentication mode

If the authentication mode is not set correctly, you can resolve this issue in SQL Server Management Studio Express, as follows:

1. Start Microsoft SQL Server Management Studio Express.
   
   In **Windows 7**: Click **Start > All Programs > Microsoft SQL Server Express > SQL Server Management Studio Express**.
   
   In **Windows 8.1 or Windows 10**: Click **Start > All apps > Microsoft SQL Server Express > SQL Server Management Studio**.

2. Confirm that the correct Server **type**, **name**, and Authentication settings are correct, and then click [Connect]. For example:
   
   - **Server type**: Database Engine.
   - **Server name**: `Machine_name\instance_name`
   - **Authentication**: Windows Authentication

   **Note:** If Windows Authentication does not work, try SQL Server Authentication. You must have security permission in SQL Server to access the database using this authentication.

3. In the **Object Explorer** pane, right-click on the server name and select **Properties**. You must select the server name, not the folders below it, to see the Security option in the next step.

4. Select **Security**.

5. Select **SQL Server and Windows Authentication**.

6. Click [OK] twice.
If the authentication mode is set correctly and you are still experiencing problems, contact your system administrator to review your permission settings in Windows or SQL Server. See "Security Administration" (page 23) for more information.

Database location

Your default database location may not be set correctly in the system registry. See "Appendix A–SQL Server Instance Settings" (page 30) for verification instructions.

Firewall settings

If you experience communication issues with a remote SQL Server instance, you may be using a firewall that is set up to block network traffic between your computer and the SQL Server instance. To allow communication, you need to set two firewall exceptions:

- The SQL Server Database Engine service
- The SQL Server browser service

Notes:
- The following instructions are for use with Windows Firewall. If you are using another firewall for your system, contact the firewall manufacturer for instructions on setting service exceptions.
- Sage recommends contacting your system administrator if you need to change firewall settings.
- This procedure does not cover setting firewall exceptions for installations on a workgroup. If you are using SQL Server on a workgroup server, you must set separate firewall exceptions to allow your workstations to communicate with the SQL Server instance. Refer to the Installation & Administration Guide for instructions.

Setting the SQL Server Database Engine exception

Set up a SQL Server Database Engine exception for each instance of SQL Server you use with Sage Estimating.

1. Determine the path to your SQL Server computer.
2. On the computer or server where SQL Server is installed, open the SQL Server Configuration Manager.
3. Start the SQL Server Configuration Manager.

   In Windows 7: Click Start > All Programs > Microsoft SQL Server > Configuration Tools > SQL Server Configuration Manager.

   In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server > SQL Server
Configuration Manager.

The SQL Server Configuration Manager opens.

4. In the left-hand pane of the SQL Server Configuration Manager, select **SQL Server Services**.

5. In the right-hand pane, right-click on **SQL Server (INSTANCE)**, where (INSTANCE) is the SQL Server instance for which you are creating the firewall exception, and select **Properties**.

6. In the **SQL Server Properties** window, click the **Service** tab.
7. In the **Binary Path** entry, note or record the path described within the quotation marks. This is the file path to the SQL Server instance binary files (the path is contained only within the quotation marks—ignore the text outside the quotes).

8. Open Windows Firewall.

   If you are using Windows 7, select **Start > Control Panel > System and Security > Administrative Tools > Windows Firewall with Advanced Settings**.

   If you are using Windows 8.1 or Windows 10, select **Start > All apps > Windows System > Control Panel > System and Security > Administrative Tools > Windows Firewall > Advanced Settings**.

   a. In the left-hand pane of the **Windows Firewall with Advanced Security** window, right-click **Inbound Rules**, and then select **New Rule**.

   b. In the **New Inbound Rule** wizard, select the **Program** option, and then click [Next].

   c. Select the **This program path** option.

   d. Click [Browse] and locate the **sqlservr.exe** file at the binary file path you recorded in step 1, and then click [Open].

   e. Select the **Allow the connection** option, and then click [Next].
f. Select the **Domain**, **Public**, and **Private** check boxes, and then click **[Next]**.

g. Type the name of your SQL Server instance in the **Name** box.

h. Click **[Finish]** to create the firewall exception for the SQL Server Database Engine service.

The *Windows Firewall with Advanced Security* window opens.

Setting the SQL Server browser service exception

1. Open Windows Firewall.

   If you are using Windows 7, select **Start > Control Panel > System and Security > Administrative Tools > Windows Firewall with Advanced Settings**.

   If you are using Windows 8.1 or Windows 10, select **Start > All apps > Windows System > Control Panel > System and Security > Administrative Tools > Windows Firewall > Advanced Settings**.

2. In the left-hand pane of the *Windows Firewall with Advanced Security* window, right-click **Inbound Rules**, and then select **New Rule**.

3. In the **New Inbound Rule** wizard, select the **Port** option, and then click **[Next]**.

4. Select **UDP** as the protocol type.

5. Select the **Specific local ports** option, and then type 1434 in the corresponding box.

6. Click **[Next]**.

7. Select the **Allow the connection** option, and then click **[Next]**.
8. Select the **Domain**, **Public**, and **Private** check boxes, and then click **[Next]**.

9. Type **SQL Server Browser Exception** in the **Name** box.

10. Click **[Finish]** to create the firewall exception for the SQL Server browser service.

**Network configuration**

To connect with SQL Server, you must have TCP/IP enabled.

**Enable TCP/IP**

If you are receiving network configuration errors, make sure that TCP/IP is enabled, as follows:

1. Select **Start > Control Panel > Administrative Tools > Windows Firewall with Advanced Security**.
2. Start the SQL Server Configuration Manager.
   
   **In Windows 7:** Click **Start > All Programs > Microsoft SQL Server > Configuration Tools > SQL Server Configuration Manager**.
   
   **In Windows 8.1 or Windows 10:** Click **Start > All apps > Microsoft SQL Server > SQL Server Configuration Manager**.
3. Expand **SQL Server Network Configuration**.
4. Select **Protocols for SAGE_ESTIMATING** (or the name of your instance).
5. Right-click on **TCP/IP** and select **Enable**.
6. Click **[OK]**.

**Note:** You must stop and restart the SQL Server services for this change to take effect. See "SQL Server services" (page 24) for more information.

**Running a virus scanner on the SQL Server host machine**

For performance reasons, if you plan to run a virus scanner on the machine that hosts the SQL Server instance, you should exclude files that have MDF, LDF, NDF, BAK, TRN, and TRC extensions. You should also exclude additional processes for the version of SQL Server that you are running. For more information about the files and processes to exclude, see Microsoft Knowledgebase article 309422 at http://support2.microsoft.com/kb/309422.

**Security Administration**

Operators using Sage Estimating must have SQL Server permissions to the databases they are expected to use. You assign permissions using the Roles and Permissions features in the Estimating Management...
Console. For more information, see the *Installation & Administration Guide*.

If an operator is experiencing connection issues with a database, verify the operator belongs to a role with the appropriate permissions.

**SQL Server services**

You may have several SQL Server services or instances, depending on the version of SQL Server you are using. For SQL Server Express, the following are used:

- SQL Server (the name you assigned to the SQL Server instance)
- SQL Server Browser

If the service is not running, you can start it using SQL Server Configuration Manager.

**To start the SQL Server Engine using SQL Server Configuration:**

Start the SQL Server Configuration Manager.

**In Windows 7:** Click *Start > All Programs > Microsoft SQL Server > Configuration Tools > SQL Server Configuration Manager*.

**In Windows 8.1 or Windows 10:** Click *Start > All apps > Microsoft SQL Server > SQL Server Configuration Manager*.

3. Select **SQL Server Services**.

4. Right-click the service (for example, **SQL Server (<instance name>)**), and then click **Start**.

To stop the SQL Server Engine using SQL Server Configuration

Start the SQL Server Configuration Manager.

**In Windows 7:** Click *Start > All Programs > Microsoft SQL Server > Configuration Tools > SQL Server Configuration Manager*.

**In Windows 8.1 or Windows 10:** Click *Start > All apps > Microsoft SQL Server > SQL Server Configuration Manager*.

5. Select **SQL Server Services**.

6. Right-click the service (for example, **SQL Server (<instance name>)**), and then click **Stop**.

**Determining the path to the SQL Server program**

If you have multiple instances of SQL Server installed, each instance is independent of the others. To determine the location of the SQL Server program for a particular instance, do the following:
1. Start Microsoft SQL Server Management Studio Express.

   In Windows 7: Click Start > All Programs > Microsoft SQL Server Express > SQL Server Management Studio Express.

   In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server Express > SQL Server Management Studio.

2. In the Connect to Server window, confirm that the correct **Server type**, **Server name**, and **Authentication** are selected, and then click [Connect]. For example:
   - **Server type**: Database Engine
   - **Server name**: `Computer_name\instance_name`
   - **Authentication**: Windows Authentication
     
     If Windows Authentication does not work, try SQL Server Authentication. You must have security permission in SQL Server to access the database using this authentication.

3. Right-click the server name, and then select **Properties**.

   The path is listed on the **General** page next to **Root Directory**. Make note of this path.

4. Click [Cancel] and then close the **SQL Server Management Studio Express** window to exit without making any changes.

   The program exists in the Binn directory, which is below the root directory you noted in step 4. For example: `C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe`. The actual number in the path may be different depending on how many instances you have installed on the computer.
Chapter 6—Additional Information

The following is provided as additional resource material. It is included for reference only and is not meant to imply that Sage supports, controls, or endorses any of the content. Be aware that titles, links, and content can change and may not always be pertinent to your situation.

General Information

Instance Configuration:

Microsoft SQL Server Datasheet:

Corruption

How to Rebuild the Master Database for SQL Server:

Security

Password Policy:

SQL Server Security White Papers:

Strong Passwords:

Services

How to Verify a Successful Installation of SQL Server Reporting Services:
Managing the Database Engine Services:

Managing Services Using SQL Server Management Studio:
Chapter 7—Glossary

BOL/Books On Line


Instance/Named Instance

A complete database environment, including the relational database management system software, table structure, stored procedures, and other functionality.

Microsoft Desktop Engine (MSDE)

A database engine compatible with earlier versions of SQL Server.

sa

The system administrator for SQL Server.

SQL

Structured Query Language, the standardized language used in virtually all relational databases.

SQL Server Management Studio (SSMS)

The configuration tool used to manage all aspects of the SQL server.

SQL Server Management Studio Express (SSMSE/SSMS Express)

A limited version of SQL Server Management Studio.

Stored Procedures

Database functions that allow advanced pre-compiled queries.

Transact-SQL

A robust scripting language supported by Microsoft SQL Server.
User Account Control (UAC)

A method of adding security to Windows by creating different access levels for administrators and standard users. It also prevents standard users from changing system settings or affecting sensitive system information.
Appendix A—SQL Server Instance Settings

If you have an existing instance of a supported version of Microsoft® SQL Server® installed, you can set up another instance to work with Sage Estimating. (Options described in this section may vary slightly depending on the edition you are installing.)

**Note:** If you choose to uninstall your existing instance first, restart your server before reinstalling to avoid problems with the new installation.

**Caution!** Do not change the owner of any databases in the Sage Estimating instance.

Configure your new SQL Server instance using the settings outlined in the following sections.

### Instance Configuration: SAGE_ESTIMATING Instance

You name your instance as part of Instance Configuration during the SQL Server installation.

**Instance Configuration Settings**

![Instance Configuration Screen](image-url)
You must use a named instance. You can give the instance any name you want. However, Sage recommends giving the instance a name that makes it easy to identify (such as SAGE_ESTIMATING).

**Server Configuration: Collation Settings**

You customize collation settings as part of the Server Configuration during the SQL Server installation.

In the **Server Configuration** dialog, on the **Collation** tab, click **[Customize]**.
Collation settings must be **Latin1_General**, **case-sensitive**, and **accent-sensitive** (Latin1_General_CS_AS).

**In the SQL Server collation customization window:**

1. Select the **Windows collation designator and sort order** option (instead of **SQL collation**, which is the default)
   - **Latin1_General** (for the collation designator)
   - **Case-sensitive**
   - **Accent-sensitive**
2. Clear all other options.

**Database Engine Configuration: Authentication Mode**

You specify the authentication mode as part of Database Engine Configuration during the SQL Server installation.

*Authentication Mode Settings*
The instance must support **Mixed Mode** authentication (**Windows Authentication and SQL Server Authentication**). This means either Windows authentication or SQL Server authentication can be used to access the database information.

When Windows authentication is used, the operator must have permissions to use SQL Server or be a member of a group that has those permissions. In Windows authentication mode, SQL Server validates the account name and password using information from the Windows operating system.

When SQL Server authentication is used, the operator must have system administrator (**sysadmin**) rights in SQL Server. The SQL Server authentication is used for backward-compatibility and requires a strong password.

**Additional Recommendations**

To ensure accurate performance, Sage **strongly** recommends making changes and verifications to the following settings in SQL Server Management Studio and SQL Server Configuration Manager. Failure to make these changes may result in poor Sage Estimating performance or communication issues.
Memory

Determine the amount of available memory on the server or workstation where SQL Server is installed. To prevent SQL Server from consuming all available memory, use SQL Server Management Studio to set the maximum amount of memory (in the instance properties) to a reasonable limit (such as 4 GB) as follows:

1. Right-click on the SQL Server instance and select Properties.
2. In the Server Properties window, click Memory (left-hand pane).
3. Set the Maximum server memory amount to 4000 (or whatever limit you determine).

Recovery Model

Sage recommends that you use the Simple recovery model for your Estimating database.

During the upgrade process, the program now shrinks the existing log file, which can become very large, and it removes invalid estimates. However, it does so only if the database recovery model is set to Simple in the SQL Server software. We do not recommend that you change the recovery model unless your business requires features available only in a different model.

Communication protocol

Set the communication protocol settings for the Sage Estimating SQL Server instance as follows:

1. Start the SQL Server Configuration Manager.
   - In Windows 7: Click Start > All Programs > Microsoft SQL Server > Configuration Tools > SQL Server Configuration Manager.
   - In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server > SQL Server Configuration Manager.
2. In the left-hand pane of the SQL Server Configuration Manager window, click the arrow next to SQL Server Network Configuration to display all local SQL Server instances.
4. In the right-hand pane right-click on a communication protocol and select Disable.
5. Repeat step 4 for all communication protocols except TCP/IP. Leave this protocol Enabled.
6. In the left-hand pane of the SQL Server Configuration Manager window, click the arrow next to SQL Native Client 10.0 Configuration or SQL Native Client 11.0 Configuration (depending on your SQL Server instance).
7. Click Client Protocols (left-hand pane).
8. In the right-hand pane right-click on a communication protocol and select **Disable**.

9. Repeat step 8 for all communication protocols **except TCP/IP**. Leave this protocol **Enabled**.

10. Close the SQL Server Configuration Manager, and then restart the service.
Appendix B—Backing Up and Restoring Using SQL Management Studio

**Important!** Sage Estimating Management Console includes Backup and Restore tools that we recommend you use for backing up and restoring your Sage Estimating data. They are very efficient processes that minimize the possibility of error. In addition, the Restore process automatically upgrades databases to your current version if you backed them up using an earlier version, which can save you time. For more information and step-by-step instructions, see the Estimating Management Console help.

If you prefer to use SQL Server Management Studio or Management Studio Express to back up your Microsoft® SQL Server® databases, follow the instructions in this appendix.

*Note:* To copy standard databases or address books, you must use the Estimating Management Console Backup and Restore tools.

**Backing Up SQL Server Databases**

If you choose to back up and restore your Sage Estimating data using the SQL Server tools, make sure you include all the necessary steps in your back up procedures.

Your SQL Server database backup copy is generated in two steps:

1. Use SQL Server Management Studio (or Management Studio Express) to make a backup copy of the database into a file folder.
   
   The default location for this folder is C:\Program Files\Microsoft SQL Server\MSSQL10_50.SAGE_ESTIMATING\MSSQL\Backup. (The actual number and instance name that appears in the path may be different if you have multiple instances of SQL Server installed or if you named your instance a different name.)

2. Make sure to include the SQL backup folder (referenced in step 1) when you perform your tape or third-party backup.

**Notes:**
Be sure to perform regular tests of your backups to ensure they are working properly.

You can perform backup and restore functions using SQL Server Management Studio or Management Studio Express. Installing SQL Server Express from the Sage Estimating setup and installation files installs a copy of SQL Server Management Studio Express.

SQL Server Management Studio Express automatically detaches and attaches the database when you back up and restore.

**Caution!** The restore process overwrites any changes you make to the database between creation of backup copies.

**Backing up the SQL Database**

1. Start Microsoft SQL Server Management Studio Express.

   **In Windows 7:** Click Start > All Programs > Microsoft SQL Server Express > SQL Server Management Studio Express.

   **In Windows 8.1 or Windows 10:** Click Start > All apps > Microsoft SQL Server Express > SQL Server Management Studio.

1. Select the database you want to back up from the **Object Explorer** pane.

2. Right-click the database, and then select **Tasks > Back Up** to open the **Back Up Database** window.
3. Under **Source** (in the right-hand pane of the Back Up Database window), select the database to be backed up from the **Database** list.

4. For the backup type, select **Full**.

5. For the backup component, select **Database**.

6. Under **Backup Set**, type a name for the database backup you are creating in the **Name** box.

7. If desired, also type a description for the backup in the **Description** box.

8. Set the desired expiration criteria for the backup in the **Backup set will expire** section.

9. Select the backup destination from the **Destination** list.

10. This list displays previously defined backup file paths and file names. The backup utility selects the **Backup** folder in your SQL Server instance folder by default but you can add a new file path as a destination by clicking [Add].

11. Click [OK]. A **Backup of database completed successfully** message appears when the backup operation is finished.

12. You may now perform your normal tape or third-party back up procedures.

13. Be sure to include the SQL back up folder (or the folder where your backup copy is stored if you
selected another location in step 7). The default location for this folder is C:\Program Files\Microsoft SQL Server\MSSQL10.50.SAGE_ESTIMATING\MSSQL\Backup. (The actual number and the name that appears in the path may be different if you have multiple instances of SQL Server installed or if you named the instance a different name.)

Restoring the SQL Database

**Caution!** The restore process overwrites any changes you make to the database between creation of backup copies.

a. Start Microsoft SQL Server Management Studio Express.
   
   **In Windows 7:** Click **Start > All Programs > Microsoft SQL Server Express > SQL Server Management Studio Express.**
   
   **In Windows 8.1 or Windows 10:** Click **Start > All apps > Microsoft SQL Server Express > SQL Server Management Studio.**

2. Select the database you want to restore from the **Object Viewer** pane.

3. Right-click the database, and then select **Tasks > Restore > Database** to open the **Restore Database** window.
4. Select the database you want to restore in the To database box. If you want to create a new database, type the name of the database in the To database box.

5. Under Source for restore, select From database, and then select the name of the backup database copy you want to use for the restore operation.

6. In the Select the backup sets to restore table, select the check box for the database you want to restore.

7. In the Select a page pane (in the upper left-hand corner of the window), click Options.

8. In the Restore Options area, select the Overwrite the existing database check box.

9. Click [OK].

A Restore of database completed successfully message appears when the restoration operation is finished.

The restore process overwrites any changes you made to the database since the last time you created a backup.

After restoring a database
If you restored an Estimates database, you must run the security.fix procedure as follows:

1. In SQL Management Studio, locate and then expand the folder for the estimates database that you restored.
2. Click Programmability -> Stored Procedures.
3. Scroll to the security.fix stored procedure, right click the file, and then click Execute Stored Procedure.
4. Click [OK].

Restored databases are automatically added to your Estimating system when you next run Estimating, provided you have administrator privileges and your estimates and address book are configured properly for the current version.

Note: You must close and reopen Estimating to view the restored database.
Index

6
64-bit system compatibility 14

A
assigning permissions 11
authentication mode 18, 33

B
backing up files 36

C
changing authentication mode 18
collation settings 17, 32
compatible SQL Server editions 10, 14, 17
contacting Sage 9

D
database permissions 11
databases
  backing up 36
  restoring files 39

E
Estimating installation window 11

F
file backups 36
file restorations 39
file structure, SQL Server 4
firewall settings 19

H
help
  using the in-product Help 6

I
installation
  collation settings 32
database permissions 11
  modified 13
  scenarios 11
  standard 11

M
managing user permissions 15
mixed mode authentication 33
modified installation 13

P
permissions 11
Pervasive
  differences with SQL Server 1
  previous uses 1
Recovery Model 34
restoring SQL Server files 39

Sage contact information 9
SAGE_ESTIMATING instance 3
services, starting and stopping 24
Setup and Installation window 11
SQL Server
  backing up files 36
  compatible editions 10, 14, 17
  restoring files from backup 39
SQL Server file path 24
SQL Server file structure 4
SQL Server Mgt Studio Express 13
standard installation 11

Windows authentication 33
Windows x64 compatibility 14