Sage Estimating (SQL) v19.12

Sage 100 Contractor (SQL) Integration Guide

November 2019
# Contents

## Chapter 1: Introduction
- Integrating Sage Estimating and Sage 100 Contractor – Overview ........................................ 1
- Ways to Get Help ........................................................................................................... 2
- Training ......................................................................................................................... 6
- Technical Assistance .................................................................................................... 6
- Submitting Enhancement Requests ............................................................................. 6
- Conventions Used in this Document ........................................................................... 7

## Chapter 2: Install Estimating Products ........................................................................... 8
- Compatibility ................................................................................................................ 8

## Chapter 3: Integration Setup .......................................................................................... 9
- Comparing Sage 100 Contractor and Sage Estimating terminology ............................... 10
- A. Allow Sage Estimating (SQL) access to your Sage 100 Contractor database .................. 10
- B. Set up security in the Sage 100 Contractor company to work with the API ................... 12
- B. Update the Sage Estimating Address Book (optional) ............................................... 14
- C. Connecting the Sage Estimating database to a Sage 100 Contractor company .............. 14
- D. Assigning Sage 100 Contractor cost codes and cost types in Sage Estimating ............... 18

## Chapter 4: Workflow ..................................................................................................... 25
- Export Estimating Data to Sage 100 Contractor .......................................................... 25
- Creating proposals, budgets, and change orders using the Export to Job Cost wizards ........ 25
- Troubleshooting ............................................................................................................ 29
- Verify Data in Sage 100 Contractor ............................................................................. 29

## Index ............................................................................................................................. 31
Chapter 1: Introduction

Integrating Sage Estimating and Sage 100 Contractor – Overview

Sage Estimating is fully integrated with Sage 100 Contractor (SQL), enabling you to exchange Sage Estimating data with your Sage 100 Contractor accounting applications.

The Sage 100 Contractor Application Program Interface (API), which is installed automatically with your Sage 100 Contractor software, serves as the bridge between the two applications.

You must be a member of the API security group in Sage 100 Contractor to set up or use the integration between Sage Estimating and Sage 100 Contractor. (Security groups are assigned under Company Security in Sage 100 Contractor.)

**Important!** To change user security settings in Sage 100 Contractor, you must be a company administrator for the company you are integrating with Sage Estimating.

When you integrate a Sage Estimating database with a Sage 100 Contractor company, jobs, cost codes, cost types, and vendors are imported into your Sage Estimating system, where they are available when you create estimates.

You can also create proposals, budgets, and change orders from estimate data using Sage Estimating.
Ways to Get Help

Sage Estimating and Sage 100 Contractor

This document is your guide for setting up both systems to share data. In it you will learn how to:

- Install Sage Estimating (SQL).
- Set up Sage 100 Contractor (SQL), the Sage 100 Contractor (SQL) API, and Sage Estimating (SQL) to share data.
- Create Sage 100 Contractor (SQL) proposals, budgets, and change orders using simple wizards in Estimating.

Important! Throughout this guide, when we refer to “Sage Estimating” and "Sage 100 Contractor," we mean Sage Estimating (SQL) and Sage 100 Contractor(SQL), respectively. You can integrate Sage Estimating (SQL) with Sage 100 Contractor (SQL). You cannot integrate Sage Estimating (SQL) with earlier versions of Sage 100 Contractor.

Ways to Get Help

Use Sage Estimating Help or a variety of self-help resources to get answers to your questions. You can also call Customer Support.

The Help System

Sage Estimating Help provides more efficient access to information than most manuals. With a click of the mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.

Sage Estimating (SQL) displays Help in your default browser. If you have an Internet connection, it displays the most current Help for your version of Sage Estimating (SQL) available from a hosted Help server. If you have no connection (you are working offline), it displays Help that was current when the software was
Ways to Get Help

released, and is installed on your computer when you install Sage Estimating (SQL).

**Important!** Because the Microsoft Edge browser does not display locally installed help properly, we recommend that you select a different default browser when working offline.

To get Help on a window option

Help is available on virtually every option within a window. To display Help, do one of the following:

- Click What's This? on the toolbar or on the title bar, and then click the option.
- Select What’s This? from the Help menu, and then click the option.
- Select the option, and then press F1.

To get Help for the whole window

For information about the window, such as the window’s purpose and what tasks you can perform in it, click [Help] at the bottom of the window.

*Window Help Button*
Ways to Get Help

To use Help to learn how to do tasks

1. Click [Help] on the toolbar, or select the Home tab > Help group > Help (or select Help menu > Help topics in classic view).

The Help Window

Use one of these tabs on the navigation pane to begin looking for a topic.

- **Contents** contains Help subjects organized within books.
- Click the **Glossary** heading on the Contents tab to view an alphabetical list of definitions of terms used throughout the Sage Estimating software.
- **Index** contains an alphabetical list of Help subjects.

When you see the topic you want, double-click it to display it.

Use the **Search** box to find articles that match the keywords you enter.

Read the supporting documentation

This guide describes how to integrate Sage 100 Contractor (SQL) with Sage Estimating version 19.12.

Be sure to read the following supporting documentation before you install Sage Estimating:
Ways to Get Help

- The *Getting Started Guide* provides an operational overview of the Sage Estimating software.
- The *Installation and Administration Guide* includes an overview of this release, installation instructions, and contact information.
- The *Release Notes* provide details about new features, database changes, known issues, and fixes.
- The *SQL Server Guide* gives you an overview of the significant differences between the new SQL Server databases and the Pervasive databases used in previous Sage Estimating releases.
- The *Options Guide* provides installation, setup, and operating instructions for each of the available Sage Estimating options, such as the On-Screen Takeoff Integrator and License Administration.

**Notes:**

- For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®, and other software, and about system requirements for servers and client workstations, refer to our Knowledgebase article ID 99187, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

**Additional Self-help Resources**

The Help menus available in ribbon view and in classic view provide convenient links to a variety of self-help resources.

*The File > Help menu in Ribbon view*
Training

The Help menu in Classic view

<table>
<thead>
<tr>
<th>Help</th>
<th>Knowledgebase</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help Topics</td>
<td>Live Chat</td>
</tr>
<tr>
<td>What's This?</td>
<td>Remote Support Session</td>
</tr>
<tr>
<td>Product Documents</td>
<td></td>
</tr>
<tr>
<td>Sage Support</td>
<td></td>
</tr>
<tr>
<td>Online Community</td>
<td></td>
</tr>
<tr>
<td>The Users Group</td>
<td></td>
</tr>
<tr>
<td>Sage University</td>
<td></td>
</tr>
<tr>
<td>Sage Estimating Home</td>
<td></td>
</tr>
<tr>
<td>Submit Product Idea</td>
<td></td>
</tr>
<tr>
<td>About Sage Estimating</td>
<td></td>
</tr>
</tbody>
</table>

Training

Sage University offers online and classroom training sessions to help you get the most out of your Sage Estimating software. To visit Sage University, go to www.sageu.com.

You can also click File > Help > Sage University.

Technical Assistance

When you need assistance, refer to the Knowledgebase article How do I get technical support for Sage Estimating? to determine which service works best for you.

Submitting Enhancement Requests

We want to hear your suggestions for improving the software. To send us your comments, click the File menu button and then select Help > Submit Product Idea.
Conventions Used in this Document

This document uses the following conventions:

- Information you type into the software is shown in bold font. For example: Type **Miscellaneous** in the box.
- The names of screens, windows, fields, and other features displayed by the software are shown in bold font.
- Names of keys are also shown in bold font. For example: **Enter** or **Tab**. A plus sign (+) between two key names indicates you should press the keys simultaneously.
- The names of buttons you can click are shown in bold font and enclosed in brackets. For example: **[OK]** or **[Post]**.
- Variable names or names that are specific to your installation may appear in italics and brackets. For example: **[Drive]\[Server]**.

Notes, Tips, and Cautions

**Note:** This style shows that the information supplements the adjacent text.

**Tip:** This style indicates helpful points about using the software.

**Caution!** This style indicates important information to help you avoid a loss of critical data.

**Important!** This style indicates critical information that you need to understand or important steps you need to take.

Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with square brackets around buttons. For example:

"If the program does not automatically start, click **[Start] > Run**."
Chapter 2: Install Estimating Products

**Important!** To integrate Sage 100 Contractor (SQL) and Sage Estimating (SQL), you must install Sage 100 Contractor (SQL) and Sage Estimating (SQL) on the same computer.

For instructions on installing Sage Estimating, see the *Sage Estimating Installation and Administration Guide*.

For instructions on installing Sage 100 Contractor, see the *Sage 100 Contractor Installation and License Administration Guide*.

**Notes:**


**Compatibility**

Sage Estimating version 19.12 is compatible with Sage 100 Contractor (SQL) through version 22.1.
Chapter 3: Integration Setup

Important! This chapter assumes that you are familiar with Sage Estimating (SQL) and Sage 100 Contractor (SQL).

Before you start

- You must Install Sage 100 Contractor and Sage Estimating on the same computer.
- Back up your data.
- Become familiar with the differences in terminology between the two programs, as described in the section “Comparing Sage 100 Contractor and Sage Estimating terminology” (page 10).

After installing Sage Estimating and Sage 100 Contractor on the same computer, you must:

1. In Database Administration for Sage 100 Contractor, allow Sage Estimating (SQL) to connect to your Sage 100 Contractor database.

2. In Sage 100 Contractor:
   a. Create an API security group using the 7-2-1 Security Groups window.
   b. Assign the API security group to users who require access to integration features in Sage Estimating.
   c. If the Sage 100 Contractor company uses field security, do one of the following:
      - Assign all job, proposal, budget and change order fields to the API security group.
      - Assign a security group that allows access to all job, proposal, budget, and change order fields to all users who require access to integration features in Sage Estimating.


You select Sage Estimating cost categories from the list of Sage 100 Contractor cost types, and you can choose to import them into the database items.

Vendors are also imported into the Sage Estimating Address Book as Company contacts.
Comparing Sage 100 Contractor and Sage Estimating terminology

<table>
<thead>
<tr>
<th>Sage 100 Contractor</th>
<th>Sage Estimating</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Code</td>
<td>Job Cost Phase</td>
</tr>
<tr>
<td>Cost Type</td>
<td>Job Cost Category</td>
</tr>
<tr>
<td>Phase</td>
<td>Sort Level</td>
</tr>
<tr>
<td></td>
<td>A sort level can be any of the following:</td>
</tr>
<tr>
<td></td>
<td>- Work Breakdown Structure Codes</td>
</tr>
<tr>
<td></td>
<td>- Location</td>
</tr>
<tr>
<td></td>
<td>- Group Phase</td>
</tr>
<tr>
<td></td>
<td>- Phase</td>
</tr>
<tr>
<td>Bid Item</td>
<td>Assembly</td>
</tr>
<tr>
<td></td>
<td>Vendor</td>
</tr>
<tr>
<td></td>
<td>Material Class</td>
</tr>
<tr>
<td></td>
<td>Subcontractor</td>
</tr>
<tr>
<td></td>
<td>Price Code</td>
</tr>
</tbody>
</table>

The rest of this chapter guides you through the process of integrating your Sage Estimating and Sage 100 Contractor systems, which involves the following general steps:

- Ensuring that Sage Estimating can connect to the Microsoft SQL Server instance that hosts your Sage 100 Contractor database.
- Adding an API security group to the Sage 100 Contractor company you are integrating with Sage Estimating, and assigning this group to users who need to work with integration features.
- Connecting your Sage Estimating standard database to a Sage 100 Contractor company.
- Applying Sage 100 Contractor cost codes and cost types to database items in Sage Estimating.

A. Allow Sage Estimating (SQL) access to your Sage 100 Contractor database

You must configure your Sage 100 Contractor SQL Server instance to allow Sage Estimating (SQL) to connect to your Sage 100 Contractor database. You use settings in Database Administration for Sage 100 Contractor to do so.
A. Allow Sage Estimating (SQL) access to your Sage 100 Contractor database

1. Open Database Administration for Sage 100 Contractor.

   ![Connect to SQL Server window](image)

   - SQL Server name: V-W10-42516-G\SAGE100CON
   - Authentication: SQL Server Authentication
   - Login: [Input]
   - Password: [Input]

   - Connect
   - Cancel

2. In the Connect to SQL Server window:
   - In the SQL Server name box, type the name of the SQL Server instance that hosts your Sage 100 Contractor database, or select the server from the list.
   - From the Authentication list, select the method you use for this SQL Server instance.
   - If you selected SQL Server Authentication as the Authentication method, type your Login name and password in the boxes provided.

   **Note:** If you selected Windows Authentication, you do not need to type your Login name and password here.

3. Click Advanced Settings > Advanced SQL Server Settings.
4. Select the Limit access to this SQL Server instance to approved applications check box, and then click [Edit Approvals].
5. In the Enable Access from Other Applications window, select Sage Estimating.
6. Click [OK]

   **Note:** You do not need to click [Save Changes] unless you made other changes to Advanced SQL Server Settings.
B. Set up security in the Sage 100 Contractor company to work with the API

The Sage 100 Contractor API is installed with Sage 100 Contractor. The API acts as a bridge, enabling communication between Sage 100 Contractor and Sage Estimating, as shown in the following diagram:

![Diagram showing integration between Sage Estimating and Sage 100 Contractor via the API]

Before you can integrate Sage Estimating and Sage 100 Contractor, you need to create an API security group in Sage 100 Contractor, and assign the group to users who require access to integration functions.

You create the API security group using the 7-2-1 Security Groups window in Sage 100 Contractor.

**Note:** You must create an API security group in each Sage 100 Contractor company you intend to integrate with Sage Estimating.

**To create the API security group:**

1. Start Sage 100 Contractor, and connect to the SQL Server instance that hosts the Sage 100 Contractor database.
2. Select the company you intend to integrate with Sage Estimating.
3. Log in as a company administrator.
4. Open 7-2-1 Security Groups.
5. In the **Group#** cell, type a group number, such as 51.
6. In the **Group Name** cell, type **API**.
7. In the **Save** cell, type **Y**.
8. In the **Delete** cell, type **Y**.
B. Set up security in the Sage 100 Contractor company to work with the API

9. To store information that may be relevant or important to that specific group, type a note in the **Notes** cell.
10. On the **File** menu, click **Save**.

**Setting up an API user and password**

You must be a member of the API security group to set up or use the integration between Sage Estimating and Sage 100 Contractor. Security groups are assigned under **Company Security** in Sage 100 Contractor.

**Important!** To change user security settings in Sage 100 Contractor, you must be a company administrator for the company you are integrating with Sage Estimating.

To assign existing users to the API security group:

1. Start Sage 100 Contractor, and then connect to the SQL Server instance that hosts the Sage 100 Contractor database.
2. Open the Sage 100 Contractor company you are integrating with Sage Estimating with Administrator rights.
3. Open **7-2-2 User List**.
4. On the row for a user who requires access to integration features, click in the next available **Group** cell, and then select the API group from the drop-down list.
5. Click **File > Save**.

To assign a new user to the API security group:

1. Start Sage 100 Contractor and connect to the SQL Server instance that hosts the Sage 100 Contractor database.
2. Open the Sage 100 Contractor company you are integrating with Sage Estimating with Administrator rights.
3. Open **7-2-2 User List**.
4. For each new user:
   a. On the first blank row, in the **User Name** cell, enter the user name.
   b. In the **Password** cell, enter a password.
   c. In the first numbered **Group** cell, click once in the cell, and then select the API group from the drop-down list.
   d. Click **File > Save**.
B. Update the Sage Estimating Address Book (optional)

Integrated Sage 100 Contractor companies use the Address Book in Sage Estimating.

When you set up a standard database to interface with Sage 100 Contractor, you can choose to import your Sage 100 Contractor contacts automatically into the Address Book as Company contacts.

Import vendors into Address Book option

Note: Sage Estimating (SQL) uses a single Address Book, which you define when you install Sage Estimating with a new SQL Server instance. You can change this selection in the Estimating Management Console by doing a search while in the Address Book pane.

For more information about using the Address Book with Sage Estimating, refer to the Sage Estimating Help.

C. Connecting the Sage Estimating database to a Sage 100 Contractor company

Before you can exchange data between a Sage Estimating standard database and a Sage 100 Contractor company, you must establish a connection between the two applications.
C. Connecting the Sage Estimating database to a Sage 100 Contractor company

You make this connection for a selected database in the Estimating Management Console. After specifying Sage 100 Contractor as the **Job Cost System Name**, you can set up a connection to a Sage 100 Contractor company by specifying:

- The SQL Server instance that hosts Sage 100 Contractor.
- Your Sage 100 Contractor user name and password.
- The Sage 100 Contractor company you want to integrate with the Sage Estimating standard database.
- Whether to add Sage 100 Contractor job cost types to items in your standard database as job cost categories. (This could overwrite existing categories in your item database in Sage Estimating.)

**Note:** The settings you specify in the Estimating Management Console become the default job costing settings for estimates that use the same database. However, you can override these settings for individual estimates in the **Estimate Information** window in Sage Estimating.

**To connect a Sage Estimating standard database to a Sage 100 Contractor company:**


2. In the Estimating Management Console, click **Standard DB** on the ribbon.

3. In the Standard Database catalog, select the database you want to connect to Sage 100 Contractor.
   a. In the **Job Cost Information** section, from the **Job Cost System Name** list, select **Sage 100 Contractor**.
   b. Click the [Setup] button. The Sage 100 Contractor Integration Settings window appears.
C. Connecting the Sage Estimating database to a Sage 100 Contractor company

In the **Sage 100 Contractor Integration Settings** window:

i. In the **SQL Server Instance** box, type the name of the SQL Server instance for the Sage 100 Contractor company you are integrating with Sage Estimating, or click the [Select] button to select it from a list.

ii. Enter your user name and password.

**Important!** If your Sage 100 Contractor ID uses Integrated Security (Windows authentication), enter the Windows domain and your ID in the form `[domain]
[YourID]`, and do not enter a password.

iii. Click [Select], and then select the Sage 100 Contractor company you are integrating with Sage Estimating from the list.

iv. Click [OK].

The cost types used for the company in Sage 100 Contractor appear as default cost categories in the integrator window, as shown here:
You can select a different user-defined code, if necessary. These codes are used as default job cost category codes for new items you create.

For example, if you set 2-L as the **Labor** category in this window, each time you create a new labor item, 2-L is used as the job cost category for the new item.

v. To assign these categories to all the existing items in the selected Sage Estimating database, select the **Add cost categories to items** check box.

   **Tip:** Sage recommends that you select this option to update your database automatically.

vi. If you want to import Sage 100 Contractor vendors into your Sage Estimating Address Book, select the **Import vendors into Address Book** check box.

   If you check this option, the program imports Sage 100 Contractor vendors that do not already exist for the same company in the Address Book,

vii. Click [OK].

The Sage 100 Contractor company is now connected to the selected Sage Estimating database. Sage Estimating imports the cost codes, cost types, and job numbers into the selected standard database, and imports the vendors into the Address Book.
D. Assigning Sage 100 Contractor cost codes and cost types in Sage Estimating

To create proposals, budgets, and change orders from Sage Estimating to Sage 100 Contractor, you need to associate Sage 100 Contractor cost codes and cost types with Sage Estimating database items. If you selected the Add cost categories to items option when you set up the integration, Sage Estimating automatically assigns the Sage 100 Contractor cost types to the Job Cost Category fields for each item. As you create estimates and take off the database items, the Sage 100 Contractor cost code and cost type information are included in the estimate and used during the export process.

The following sections describe how to assign Sage 100 Contractor job cost data to items in the following ways:

- Accessing the job cost information for an individual item in the database.
- Using Sage Estimating to connect to a Sage 100 Contractor company for a particular estimate.
- Working with the job cost data on an estimate.

Modifying cost code and cost type data in Sage Database Editor

You can add or modify cost codes, cost types, and labor directly on Estimating phases and items, or indirectly through the Database Editor.

Using the Database Editor can simplify cost code assignment to items in your database. If all of the items in a particular phase will use the same cost code, you can assign the cost code to the phase and have it propagate down to the items in the phase.

Assigning cost codes at the phase level

First, assign the cost code to the phases. Then, on the Items view, select Inherit JC Phase for the items. If the items are to be assigned to different cost codes, see the "Assign Cost Codes Directly to Items" section below.

1. Start the Database Editor.
2. Click Open, select your standard database, and then click [OK].
D. Assigning Sage 100 Contractor cost codes and cost types in Sage Estimating

3. To display the phases:
   a. Click View>Go To>Phases.
   b. Select the Default layout (<all columns>) from the list on the toolbar.

4. For the selected phase, select the Sage 100 Contractor cost code from the list, or type the cost code in the JC Phase field.

   If you need to assign the cost code to more than one phase, you can use the Fill Down feature to rapidly copy data from one cell to cells beneath it:
   a. Type the data you want to copy into a cell.
   b. Select the cell and the cells below it.
      To select cells that are not next to each other in the column, press Ctrl while you use the mouse to select cells.
   c. Right-click, and then select Fill Down.

5. To open the Items view, on the Home menu, select View > Items.

6. To propagate the cost codes from the phase record to the corresponding item records, highlight the row header for all items, right-click, and then select Inherit JC Phase.

Assign cost codes directly to items

If the items in a phase have different cost codes, you can assign the cost codes directly on the item.

1. In the Database Editor, on the Home menu, click View > Items.

2. Scroll over to the Labor Job Cost Phase column.

3. Scroll down to the items to which the labor cost type should be assigned, and then:
   a. Click the first cell to which you want to assign a cost code.
   b. Press the Spacebar to activate the cost code list.
   c. Select the cost code from the list.

4. Repeat steps 2 and 3 as necessary.

5. Assign cost types.

Assign cost types to the item categories

You can modify the cost types assigned to the items using the Database Editor.
D. Assigning Sage 100 Contractor cost codes and cost types in Sage Estimating

If you chose not to add the job cost categories to the items (step 6 under section D), you need to assign a cost type for each category on the items.

1. In the Database Editor, on the Home menu, click View > Items.
2. Scroll to the Labor Job Cost Category column.
3. Scroll down to the items to which the labor cost type should be assigned.
4. Click in the first white cell, use the Spacebar to activate the list, and then select 2-L from the drop-down list.
5. Repeat steps 3 and 4 for Equipment, Material, Sub, and Other.

Scroll to the appropriate Job Cost Category column, and then select the cost types as follows:

<table>
<thead>
<tr>
<th>Job Cost Category</th>
<th>Cost Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Labor</td>
<td>2-L</td>
</tr>
<tr>
<td>Material</td>
<td>1-M</td>
</tr>
<tr>
<td>Sub</td>
<td>4-S</td>
</tr>
<tr>
<td>Equipment</td>
<td>3-E</td>
</tr>
<tr>
<td>Other</td>
<td>5-O</td>
</tr>
</tbody>
</table>

Using Sage Estimating to connect an estimate to a Sage 100 Contractor company

You can connect to a Sage 100 Contractor company and assign categories to items for a particular estimate using the Manage Estimates window in Sage Estimating.

1. Open the Manage Estimates window:
   a. Click Start > All Apps > Sage Estimating.
   b. Click File > Manage Estimates.
2. In the Estimate Catalog pane, select the estimate that you want to integrate with Sage 100 Contractor.
   a. In the Job Cost Information section, from the Job Cost System Name list, select Sage 100 Contractor.
   b. Click the [Setup] button. The Sage 100 Contractor Integration Settings window appears.
D. Assigning Sage 100 Contractor cost codes and cost types in Sage Estimating

![Sage 100 Contractor Job Cost Integrator](image)

C. In the **Sage 100 Contractor Integration Settings** window:

i. In the **SQL Server Instance** box, type the name of the SQL Server instance for the Sage 100 Contractor company you are integrating with Sage Estimating, or click the **[Select]** button to select it from a list.

ii. Enter your user name and password.

**Important!** If your Sage 100 Contractor ID uses Integrated Security (Windows authentication), enter the Windows domain and your ID in the form **[domain]\[YourID]**, and do not enter a password.

iii. Click **[Select]**, and then select the Sage 100 Contractor company you are integrating with Sage Estimating from the list.

iv. Click **[OK]**.

The cost types used for the company in Sage 100 Contractor appear as default cost categories in the integrator window, as shown here:
D. Assigning Sage 100 Contractor cost codes and cost types in Sage Estimating

You can select a different user-defined code, if necessary. These codes are used as default job cost category codes for new items you create.

For example, if you set 2-L as the Labor category in this window, each time you create a new labor item, 2-L is used as the job cost category for the new item.

v. To assign these categories to all the existing items in the selected Sage Estimating database, select the Add cost categories to items check box.

**Tip:** Sage recommends that you select this option to update your database automatically.

vi. If you want to import Sage 100 Contractor vendors into your Sage Estimating Address Book, select the Import vendors into Address Book check box.

If you check this option, the program imports Sage 100 Contractor vendors that do not already exist for the same company in the Address Book,

vii. Click [OK].

The Sage 100 Contractor company is now connected to the selected Sage Estimating database. Sage Estimating imports the cost codes, cost types, and job numbers into the selected standard database, and imports the vendors into the Address Book.
Note: This process may take some time depending on the amount of data you are importing into your Sage Estimating database.

Transferring labor hours

Regardless of the Labor Qty to Job Cost setting for the database item in Sage Estimating, Sage 100 Contractor uses the order quantity as the labor quantity. All labor hours are included in budgets and change orders, unless the order quantity unit type for labor is None.

To edit unit fields for an estimate, you use the Edit Unit command for an item on the estimate spreadsheet or in the Database Item window.

Modifying cost code and cost type data in Sage Estimating

Cost codes and cost types are available for any item in the database on the Job Cost tab of the item record.

You can modify the job cost information at any time for the individual item. Access the items by clicking Database>Items. Navigate to the item you want to work with. In order to enter or modify the job cost data, click the Job Cost tab.

Adjusting the estimate

If the estimate was created before you updated the database with Sage 100 Contractor cost codes, or if you wish to add or change the cost code assignments on items in your estimate you must add the cost codes directly in the estimate.


After you perform takeoff for existing estimates, you can make adjustments to the job cost codes that are assigned to the estimate items in the Detail window. For example, you may want to perform the adjustments for job-specific cost codes.

1. Open an estimate, and select the item in the Description column.
2. Right-click, and then select Detail window. Select the Unit Costs tab.
3. Enter the required Sage 100 Contractor cost code in the Job Cost Phase box.
D. Assigning Sage 100 Contractor cost codes and cost types in Sage Estimating

**Where to now?**

After performing integrating Sage Estimating with Sage 100 Contractor, you can create proposals, budgets, and change orders. The next chapter details the workflow and considerations necessary to export estimate data to Sage 100 Contractor.
Chapter 4: Workflow

Export Estimating Data to Sage 100 Contractor

In this section, you will learn how to use the wizards in Estimating to create proposals, budgets, and change orders:

*Exporting Data from Estimating to Sage 100 Contractor*

Creating proposals, budgets, and change orders using the Export to Job Cost wizards

Each point of integration—proposal, budget, and change order—has its own four-step wizard that captures information specific for what you are trying to create. The following sections describe the four-step procedures required for creating proposals, budgets, and change orders using these wizards.

The appearance and operation of each wizard is substantially the same, and the steps may appear identical from one wizard to the next. However, you enter different types of information for each wizard.
Starting the Export to Job Cost wizards

In Sage Estimating, on the Advanced tab, click one of the following buttons:

- Proposals
- Budgets
- Change Orders

Each wizard opens with an Introduction tab. The information presented on this tab is specific to what you are creating—a proposal, budget, or change order—and provides an overview of the creation process as well as any specific instructions.

Read this information before clicking [Next] to proceed through the wizard.

Step 1: Company Settings and Job Number

**Note:** This step is identical in all three export wizards.

Enter information in this window as follows:

- **SQL Server instance.** The SQL Server instance specified when you integrated Sage 100 Contractor with the standard database or estimate appears in this box. Accept the entry, or click [Select] to specify a different instance.

- **User Name** and **Password.** Enter the user name and password you set up in "Setting up an API User And Password" in Chapter 3.

- **Company.** This is the Sage 100 Contractor company to which you are exporting the data. Accept the entry, or click [Select] to specify a different company.

- **Transaction date.** Enter the transaction date to use for the exported data.

- **Sage 100 Contractor job number.** Click the icon beside this field, select the job from the list, and then click [OK].

If the job does not exist, you can create it by first clicking the [Create New] button in the job list window, and then entering the:

- Job Number (numeric characters only)
- Status
- Short Name
- Job Name
Step 2: Round Quantities and Allocate Addons

The second step gathers information on rounding and allocating addons.

Rounding

The rounding options for an item are set up on that item in the database or on the estimate. Rounding does not show up on the estimate, but can be included in reports.

Rounding may affect the amounts that are sent to Sage 100 Contractor.

Allocating Addons

To allocate an addon means to spread the addon amount back through the estimate items. Allocate an addon when you don’t want the markup to show as a line in the estimate totals, for example. You can allocate an addon in the Estimate Totals window. (With an estimate open, press F4 on your keyboard.)

Important! Addons can also be sent to Sage 100 Contractor as their own line item. You can add a cost code and cost type to each addon you insert into an estimate. Any addon with job cost information will always be included in the interface.

Add-on allocation and quantity rounding affect proposals, budgets, and change orders as follows:

- **Proposal**: For the proposal, answer 'Yes' to both rounding quantities and allocating addons if you want to include all costs associated with the project.

- **Budget**: Select to round quantities for the budget to reflect the actual amounts. You may not want to include addons in the budget, as they are not a reflection of the direct cost. However, you can select to allocate some addons and not others, by selecting or clearing the addon allocation box on the Estimate Totals window. (With an estimate open, press F4 on your keyboard.)

- **Change Order**: Step 2 for the change order does not ask whether or not you want to allocate addons. All addons marked as allocatable will be allocated for the change side of the change order. The budget side of the change order will not include allocated addons. Whether an addon is allocatable or not is controlled on the Estimate Totals window. (With an estimate open, press F4 on your keyboard.)

Step 3: Export Options

The third step is unique for each wizard type.

- **Proposal**: You have the option to create the proposal by Cost Code or by Bid Item. If you select to create the proposal by Bid Item, a second selection box becomes available, prompting you to designate the estimate sort level that will be used as the Bid Item in Sage 100 Contractor.
Creating proposals, budgets, and change orders using the Export to Job Cost wizards

- **Bid Item considerations:** If you choose to generate the proposal by bid item, you need to specify what estimating element will be used as the bid item in Sage 100 Contractor. You have a list of available estimate sorts that you can pick from that include all WBS codes, location, group phase, and phase among others. Select an estimate sort level that will make an appropriate bid item.

- **Include a Sage 100 Contractor Phase:** You also have the option in the proposal to include a Sage 100 Contractor phase. If you choose to do so, you will need to select an estimate sort level that will appropriately translate into a phase. When the proposal has been created, you will see the estimate sort you selected as a phase on the proposal.

- **Budget:** Step 3 for the budget export simply asks if you want to include a Sage 100 Contractor phase. If you select to do so, you will need to make an appropriate selection of an estimate sort level.

- **Change Order:** The Change Order export requires multiple selections.
  - **Change Order Id:** Select the estimate sort level that will be used as the change order ID. For each change order ID, a change order is created in Sage 100 Contractor. The best implementation practice is to dedicate a WBS code to use as the change order ID.
  - **Include Sage 100 Contractor Phase:** Like the proposal and budget wizards, you have the option to include a Sage 100 Contractor phase during the change order interface. If you choose to include a Phase, select the estimate sort level.
  - **Select from the available change orders:** After designating the change order ID, the list of available change orders becomes available. Select the change orders you would like to create in Sage 100 Contractor.
  - **Addon considerations:** If you have addons assigned with a non-allocatable cost code and cost type, additional fields become available. Enter the change order and phase to which the addon amount should be included.

**Step 4: Create Proposal, Budget, Change Order**

For all three wizards, the final step is identical. A transaction report prints out job, phases, cost types, and amounts. If any errors occur during the interface, an Export Error window will display with the errors found with information about resolving the errors.

To initiate the export, click [Finish].

You receive a confirmation message when the proposal, budget, or change order is created.

**Notes:**

- You can maintain only one proposal per job. If you have already exported a proposal to a job in Sage 100 Contractor, any subsequent proposal exports to that job will overwrite it.

- You can maintain only one budget per job. If you have already exported a budget to a job in Sage 100 Contractor, any subsequent budget exports to that job will overwrite it.
If a proposal or budget has previously been exported to Sage 100 Contractor, you receive a warning message giving the date and time of the export, although there is no record of the job to which it was exported.

Sage 100 Contractor allows you to create the same change order more than once, minimizing the risk of overwriting an open and active change order. When creating change orders, be aware of what you have already created.

Troubleshooting

As you use the export wizards to create the different data elements in Sage 100 Contractor, a series of validation checks is performed on the estimate and work file data. When the wizard encounters data that is invalid, it will alert you with a message that indicates the problem and suggests a potential resolution.

To complete the export wizard, you must exit the wizard (click [Cancel]), fix the issue, and then restart the wizard. You can print the error list right from the error window. We recommend that you use the printout to address the invalid items.

The following errors may appear:

"The cost code ‘xx.xx’ does not exist"

For each cost category that is included on the estimate item, the validation check will verify that the assigned cost code exists in Sage 100 Contractor. If the cost code on an item is invalid, you can:

Select a different cost code for that category. In Estimating, select the item on the spreadsheet. Click View > Detail window > Unit Costs tab. Select the correct Job Cost phase.

If the cost code doesn’t exist in Sage 100 Contractor and you want that item to go the specified cost code, you will need to create the cost code in Sage 100 Contractor.

"The category ‘X’ is invalid"

For each cost category that is included on the estimate item, the validation check will verify that the assigned cost type exists in Sage 100 Contractor. If the cost type on an item is invalid, you will need to assign a valid cost type for the specified category. In Estimating, select the item on the spreadsheet. Click View > Detail window > Unit Costs tab > [Job Cost Phase]. Select the correct cost type in the Job Cost Category column.

Verify Data in Sage 100 Contractor

The last step in the integration process is to verify that the data has been created in Sage 100 Contractor. With each export wizard, you receive a confirmation message that the data has been successfully created.
Verify Data in Sage 100 Contractor

in Sage 100 Contractor. You can then open Sage 100 Contractor Proposals, Budgets, and Change Orders to verify the data.
Index

A

API user
  setting up in Sage 100 Contractor 13

C

compatibility with Sage 100 Contractor
  versions 8
  contacting Sage 6
  Customer Support, contacting 4

H

help
  Customer Support, contacting 4
  using the in-product Help 2

J

Job Cost System Name 15

S

Sage 100 Contractor company
  connecting to a standard database 14
  Sage contact information 6