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Introduction
Release information
Along with this User's Guide, see the following documentation for additional information that will help you
install and use version 13.1:

n The Installation Checklist contains a brief description of the steps involved in upgrading your software.

n The Important document contains critical topics.

n TheRelease Notes provide details about new features, database changes, resolved issues, and known
issues.

You can access a complete library of supported product documents.

About this guide
This User's Guide is designed to help you learn about system requirements and install the software. It
contains information about systems, security, Crystal reports, ODBC, andmore.

Conventions used in this document

This document uses the following conventions:

l The names of windows, fields, and other features displayed by the software are bold.

l Text that you type into the windows is bold, as in the following example:
TypeMiscellaneous forAmount Type.

l Names of keys are shown in capitals; for example, ENTER, TAB. A plus sign (+) between two key
names indicates that you should press both keys at the same time; for example, SHIFT + TAB.

l The names of buttons that you can click with your mouse are bold and enclosed in brackets; for
example, [OK] and [ Post].

TIP: Helpful information tomake your experience better.

NOTE: Information of particular interest, such as information not included in steps.

CAUTION: Information that can help you avoid a costly or time-consuming error.

IMPORTANT: Information that is of critical importance.

http://cdn.na.sage.com/sagemail/zCRE131/Acct_Est_DM_Checklist.pdf
http://cdn.na.sage.com/sagemail/zCRE131/Acct_Est_DM_Checklist.pdf
http://cdn.na.sage.com/sagemail/zCRE131/131IMPORTANT.pdf
http://cdn.na.sage.com/sagemail/zCRE131/ReleaseNotesAcctMgmt.pdf
http://cdn.na.sage.com/sagemail/zCRE131/ReleaseNotesAcctMgmt.pdf
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html


Menu paths

In this document, menu paths show you the steps required to start a task. Here is a samplemenu path:

PR: Tools > Download Taxes

To follow this path, open the Payroll module. From the Toolsmenu, select Download Taxes.

Support and assistance

Online help
Each Sage 300 Construction and Real Estate application includes online help, which provides answers to
your questions about procedures as well as items in the windows.

To access the online help in Sage 300 Construction and Real Estate:

l In a window, click the [Help] button, click (the help icon button), or press F1 to display the help
topic for that window.

l In an application, select Help > Help Topics.

l In the Desktop, select Help > Application Help, and then choose the desired application.

To aid you in finding the information you need, the online for each application includes the following tabs:

l Contents tab with an outline of the help with links to the help topics.

l Index tab with keywords that link to help topics related to that keyword.

l Search tab, where you can type text and click [Search] to locate that text in the help topics.

Wewould like your feedback about the online help so we canmake improvements. Each help topic
contains an area where you can indicate whether the topic was helpful and provide additional comments.
To protect your privacy, all comments are anonymous.

Training
Sage University offers live and recorded online training sessions to help you get themost out of your
software. To access Sage University, either:

l From an application, select Help > Web Resources > Sage University

l From your browser, visit https://sageu.csod.com/

Contact your business partner for local training.

Technical assistance
When you need assistance, refer to the How do I get technical support for Sage 300 Construction and
Real Estate? article to determine which service works best for you.
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Chapter 1: System Requirements
For assistance in selecting the right business-class computers for your Sage 300 Construction and Real
Estate software, contact your authorized business partner. For information about system environments,
see “Chapter 6: System Guidance,” on page 48.

In order to install and use Sage 300 Construction and Real Estate version 13.1, your server and
workstations must have Internet access due to Pervasive licensing requirements.

Operating systems

Supported operating systems
Sage 300 Construction and Real Estate supports the operating systems and service packs listed in the
following table. The service packs listed are theminimum required for installing Sage 300 Construction
and Real Estate version 13.1. You will realize optimal system performance by using up-to-date computer
hardware.

    CAUTION:
AlthoughWindows Server 2012 andWindows 8 are included in the table, there are two exceptions:
l Residential Management is not currently supported on these operating systems.

l Estimating Explorer is not currently supported on these operating systems.

If you use Residential Management or Estimating Explorer, we recommend that you install them on
workstations withWindows 7 (or earlier).

Operating system Service pack

Windows Server 2012 Standard*
Windows Server 2012 Essentials*

Windows 8 Enterprise Edition*
Windows 8 Professional Edition*

Windows Small Business Server 2011

Windows Server 2008 Small Business Server**
Windows Server 2008 Enterprise Edition**
Windows Server 2008 Standard Edition**

SP2

Windows Server 2008 R2 Enterprise Edition**
Windows Server 2008 R2 Standard Edition**

SP1



Operating system Service pack

Windows 7 Professional
Windows 7 Ultimate
Windows 7 Enterprise

SP1

Windows Server 2003 Small Business Server
Windows Server 2003 Enterprise Edition
Windows Server 2003 Standard Edition

SP2

Windows Server 2003 R2 Small Business Server
Windows Server 2003 R2 Enterprise Edition
Windows Server 2003 R2 Standard Edition

Windows Vista Business
Windows Vista Ultimate

SP2

Windows XP Professional (32-bit) SP3

* Before installing Sage 300 Construction and Real Estate on computers with theWindows Server 2012 or
Windows 8 operating system, youmust install .NET 3.5. For instructions, see
http://cdn.na.sage.com/SageMail/install_dotNet_3-5.html.

** See the “Windows Server 2008 compatibility” section later in this chapter.

Unsupported operating systems
Windows XP X64 is not supported.

64-bit compatibility
Sage 300 Construction and Real Estate, Sage Estimating, and Sage Residential Management
applications are compatible with 64-bit operating systems.

NOTE: Sage 300 Construction and Real Estate version 13.1 is compatible with 32-bit MS Office
2010. When you install Microsoft Office 2010, select to install the 32-bit version. Sage 300
Construction and Real Estate will not work with the 64-bit version.

Incompatibility with 64-bit operating systems

At the time of this release, the following Sage and third-party software products were not supported on
64-bit operating systems:

l SageMaster Builder v13.3 and earlier

l Primavera Project Planner (P3) 3.1 and earlier

For more information, visit the website for that software.
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Windows Server 2008 compatibility
Sage 300 Construction and Real Estate, Sage Estimating, Sage Document Management, and Sage
Residential Management are compatible withWindows Server 2008.

At the time of this release, the following Sage and third-party software products were not supported on
Windows Server 2008:

l Sage Estimating Cut and Fill 5.23.0
l SageMaster Builder v13.3 and earlier
l GTCOTabletWorks 10.08 driver
l Primavera Project Planner (P3) 3.0

For more information, visit the website for that software.

NOTE: Estimating Database Editor is not supported onWindows Terminal Services.

Hardware requirements
This section includes recommendations for the following hardware on the server and workstations:

l Processor
l Random access memory
l Hard disk space

Processor
Having a fast processor on both the server and workstations will improve your system’s performance.

Recommendation

Server A quad-core processor with aminimum of 3 gigahertz (GHz) processing speed is
recommended for the server that hosts Sage 300 Construction and Real Estate.

Workstation A minimum of 2 GHz is recommended for the workstations using Sage 300
Construction and Real Estate.

Random access memory (RAM)
As a general rule, themore RAM you have on the server and workstations, the better your performance will
be. Workstations with Vista orWindows 7 operating systems usemorememory, so youmay want to
increase the RAM on Vista orWindows 7 workstations.

Recommendation

Server A minimum of 8 gigabytes (GB) of RAM is recommended for the server that hosts
Sage 300 Construction and Real Estate.

Workstation A minimum of 4 GB is recommended for the workstations using Sage 300
Construction and Real Estate.
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Hard disk space
Hard disk space is required for installation of program files as well as for the database.

Hard disk space required for program files

The following tables list the hard disk space necessary to install the program files on a server, stand-alone
computer, and workstation. Use this information to calculate your hard disk space requirements based on
the applications that you install. Having adequate free space on the hard disk, a fast processing speed,
and adequate RAM can improve your performance.

IMPORTANT: Do not install Sage 300 Construction and Real Estate products until you have
sufficient hard disk space available.

Server or stand-alone computer

Product Hard disk space Purpose and considerations

Accounting and
Management products

Up to 2.2 GB For program files, not including prerequisites. Depends
on the number of applications installed.

Third-party components Up to 1.2 GB Prerequisites installed by Sage 300 Construction and
Real Estate as necessary.

Estimating products Up to 2.1 GB For program files.

Residential
Management

Up to 580MB For program files.

Document Management Up to 400MB For program files. Depends on configuration.

Workstations

Product Hard disk space Purpose and considerations

Accounting and
Management products

Up to 800MB For program files, not including prerequisites. Depends
on the number of applications installed. This assumes
that a server hosts Accounting andManagement data.

Third-party components Up to 600MB Prerequisites installed by Sage 300 Construction and
Real Estate as necessary.

Estimating products Up to 2.1 GB For program files.

Residential
Management

Up to 580MB For program files.

Document Management Up to 200MB For program files. Depends on configuration.
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Hard disk space required for database growth

The following table lists general guidelines regarding the hard disk space necessary for the growth of the
Sage 300 Construction and Real Estate database. Use this information to calculate your hard disk space
requirements per year based on usage. Your actual requirements will vary based on your actual usage.

Product Hard disk space per year Usage definitions and considerations

Accounting and
Management products

Database size primarily varies based on
usage.

Active usage: 1 GB 10 ormore data entry clerks.

Modest usage: 400MB 1 or 2 active data entry clerks.

Estimating
products

Database size primarily varies based on
estimate complexity and usage.

Active usage: 6-9 GB Average estimate size of 10MB.
No estimate archive.

Residential
Management

Active usage: 500MB Database size primarily varies based on
usage.

Modest usage: 100MB

Document
Management

Database size primarily varies based on
scanning resolution and usage.

Active usage: 10GB Scans 1700 black and white pages per
week with 200-300 dots per inch (DPI)
resolution.

Modest usage: 1 GB Scans a few hundred black and white
pages per week with 300 DPI resolution .

Chapter 1: System Requirements

Sage 300 Construction and Real Estate User's Guide                                                                                                        Page 7



Additional hardware
Sage 300 Construction and Real Estate requires the following hardware.

Hardware Purpose and specifications

Network adapter Connects computer to a network.
Must be a high-quality device.

Ports 443 and 80 For connecting hardware, such as a printer, to the computer.
Set up your firewall to accept these ports.

Port 25 To send email with Sage InstallationManager, Sage 300 Construction and
Real Estate, and Document Management.

Ports 8101 and 8102 Sage Service Host

Ports 3351/TCP,
1583/TCP, and 137-139

Pervasive

Printer A Microsoft Certified printer driver is recommended.

Sound adapter For audio playback.

Super VGA monitor For high-resolution color display.
1024 pixels by 768 pixels is recommended.
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Software requirements
Sage 300 Construction and Real Estate requires the following software:

Software Purpose, specifications, and notes

Adobe Reader 5.0
or later

For viewing software documentation in Adobe PDF format.
For faxing and sending documents from Sage 300 Construction and
Real Estate.

Free downloads are available at www.adobe.com.

Crystal Reports Professional
11.5 SP 3 or Crystal Reports
11.5 SP 3 for Sage

Formodifying and creating Crystal Reports designs.

Crystal Reports for Sage is installed as a prerequisite.

Faxing service SimpleMail Transfer Protocol (SMTP) fax solution, Vista fax solution.
For sending faxes in applications with this feature.

Microsoft Internet Explorer
6.0 Service Pack 1 or later

For software updates, customer support, and Help.

Microsoft .NET 3.5 Service
Pack 1

Installed as a prerequisite. If not already installed, it will restart your
server and workstations after the prerequisites are installed.

ForWindows 8 andWindows Server 2012, youmust install .NET 3.5
before installing Sage 300 Construction and Real Estate. For
instructions, see http://cdn.na.sage.com/SageMail/install_dotNet_3-
5.html.

Microsoft Office 2003 SP 3
or later

For Correspondence Log features in Project Management.
For importing data into Microsoft Excel or Microsoft Query.

In order to useMS Office 2010 with Correspondence Log and
Document Management, youmust have Sage 300 Construction and
Real Estate version 12.1 or 13.1.

Sage 300 Construction and Real Estate is compatible with:

l The 32-bit version of Office 2010 but not the 64-bit version.

l The 32-bit version of Office 2013 but not the 64-bit version.

Microsoft Outlook 2003 SP3
Microsoft Outlook 2007 SP2
Microsoft Outlook 2010 SP1
Microsoft Outlook 2013

Microsoft Outlook is used for email features.

Sage 300 Construction and Real Estate is compatible with:

l The 32-bit version of Outlook 2010 but not the 64-bit version.

l The 32-bit version of Outlook 2013 but not the 64-bit version.

Chapter 1: System Requirements
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Software Purpose, specifications, and notes

UniMessage Pro For online faxing in Purchasing and Inventory.

Windows Services Print service for printing.
Log Viewer for troubleshooting.

Print service and Log Viewermust be available on the server and
workstations.

Supported protocols

Protocol Purpose

Transmission Control
Protocol/Internet Protocol
(TCP/IP)

Microsoft servers default to this protocol.

Remote Display Protocol
(RDP) 6.1

Microsoft remote protocol, which is used in its remote connection
applications.

Independent Computing
Architecture (ICA)

Citrix remote protocol, which is used in its remote connection
application.

SMTP Email protocol used in Document Management, Sage 300
Construction and Real Estate applications, and Sage Installation
Manager.

Required privilege settings
The following sections describe the access rights you need to successfully install and use Sage 300
Construction and Real Estate.

Elevate permissions on Windows Vista and Windows 7

Youmust elevate your permissions before upgrading Sage 300 Construction and Real Estate .

You can usually start a program with elevated privileges by right-clicking the application and selectingRun
as Administrator. In Sage 300 Construction and Real Estate, the application is usually installed in the
following path: /Program Files/Sage Timberline Office/Accounting.

During certain installation tasks, you will receive another prompt to elevate your privileges. If you do not
acknowledge each prompt within twominutes, the installation process will quit the task. If this occurs, you
will receive a separate prompt asking you to retry the task. Click [Retry] and then elevate your privileges
at the prompt.
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Sage 300 Construction and Real Estate program files and data files

Youmust have full control access rights to all folders or shares that contain Sage 300 Construction and
Real Estate program files and data files.

Windows XP Professional, Windows Server 2003, Windows Vista, Windows 7, andWindows Server
2008 have stricter default access rights settings than earlier Microsoft operating systems.

When you create a share for a folder, users get read access instead of full control access. For example,
when you create a shared folder to which you will install Sage 300 Construction and Real Estate, youmust
manually grant full control access to users who will access this folder.

Full control of specific files and folders required

To use Sage 300 Construction and Real Estate, youmust have full control of the following files and folders
on your file server, terminal server, and workstations that have Sage 300 Construction and Real Estate
installed as well as full control of all the subfolders and files.

Product Operating
systems

Required folders
and files Location and specifications

Sage 300
Construction
and Real
Estate

All 32-bit:
[Drive]:
\Program Files
\Timberline Office

64-bit:
Program Files (86)
\Timberline Office

This folder is located on the server,
terminal server, and workstations where
you installed Sage 300 Construction and
Real Estate. It is the default installation
location for Sage 300 Construction and
Real Estate. However, depending on your
system configuration, your company may
have renamed this folder or installed it to a
different location.

Sage 300
Construction
and Real
Estate

Windows
Vista
Windows 7
Windows
Server 2008

[Drive]:
\Users
\[username]

This folder is located on the workstation
or terminal server where you use Sage
300 Construction and Real Estate. Sage
300 Construction and Real Estate installs
necessary files to this folder and requires
that the user has full control of it.
Typically, the user has full control of this
folder by default.

Sage 300
Construction
and Real
Estate

Windows XP
Windows
Server 2003

[Drive]:
\Documents and
Settings
\[username]

This folder is located on the workstation
or terminal server where you use Sage
300 Construction and Real Estate. Sage
300 Construction and Real Estate installs
necessary files to this folder and requires
that the user has full control of it.
Typically, the user has full control of this
folder by default.
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Product Operating
systems

Required folders
and files Location and specifications

Sage 300
Construction
and Real
Estate

All Company data folder Typically, the data folder is located on the
server where you installed Accounting
andManagement Products.

Sage 300
Construction
and Real
Estate

Windows
Vista
Windows 7
Windows
Server 2008

[Drive]:
\ProgramData
\Sage
\Timberline Office

This folder is located on the server or host
machine where you use Accounting and
Management Products. This folder must
be shared. Sage 300 Construction and
Real Estate installs necessary files to
this folder and requires that all users have
full control permissions to this folder and
all of its subfolders.

Sage 300
Construction
and Real
Estate

Windows XP
Windows
Server 2003

[Drive]:
\Documents and
Settings
\All Users
\Application Data
\Sage
\Timberline Office

This folder is located on the server or host
machine where you use Accounting and
Management Products. This folder must
be shared. Sage 300 Construction and
Real Estate installs necessary files to
this folder and requires that all users have
full control permissions to this folder and
all of its subfolders.

Sage
Estimating

All Database and
estimates

Typically, these files are located on the
server and the workstation where you
installed Estimating Products.

Sage
Estimating

Windows
Vista
Windows 7
Windows
Server 2008

[Drive]:
\Users
\Public
\Estimating

This folder is located wherever you use
Estimating Products. Sage 300
Construction and Real Estate installs
necessary files to this folder and requires
that all users have read/write permissions
to this folder and all of its subfolders.

Sage
Estimating

Windows XP
Windows
Server 2003

[Drive]:
\Documents and
Settings
\All Users
\Estimating

This folder is located wherever you use
Estimating Products. Sage 300
Construction and Real Estate installs
necessary files to this folder and requires
that all users have read/write permissions
to this folder and all of its subfolders.
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NOTE: Some of these folders may be hidden. To view them on:

l Windows XP Professional orWindows Server 2003: OpenWindows Explorer, select Tools >
Folder Options, click theView tab, and then select theView hidden files and folders check
box.

l Windows Vista, Windows 7, orWindows Server 2008: OpenWindows Explorer, select Organize
> Folder and Search Options, click theView tab, and then select Show hidden files and
folders.

l Windows 8 orWindows Server 2012: OpenWindows Explorer, click theView tab, and then select
theHidden items check box.

Full control of and read access to specific registry keys required

To use Sage 300 Construction and Real Estate, youmust have full control of the followingWindows
registry key on your file server, terminal server, and workstations that have Sage 300 Construction and
Real Estate installed. Make sure that your system administrator also gives you full control of all subkeys.

l HKEY_CURRENT_USER

l HKEY_Local_Machine\Software\ODBC

l HKEY_Local_Machine\Software\Pervasive Software

l HKEY_Local_Machine\Software\Timberline

CAUTION: Incorrectly editing theMicrosoft Windows registry may severely damage your system.
Sage is not responsible for damage to your system caused by editing the registry. Beforemaking
changes to the registry, contact your system administrator for assistance andmake a backup copy
of all valued data. System administrators should seeMicrosoft Registry Editor Help topics for
detailed instructions.

Compatible versions
The following versions of Sage 300 Construction and Real Estate are compatible with each of the others:

n Sage 300 Construction and Real Estate (formerly Sage Timberline Office)13.1

n Sage Document Management 13.1

n Sage Estimating 13.1 (Pervasive)

n Sage Estimating (SQL)

n Sage Residential Management 13.1

If you use both Residential Management and Estimating, install Estimating before you install Residential
Management.

CAUTION: Residential Management and Estimating Explorer are not currently supported on
Windows 8 andWindows Server 2012 operating systems.

Chapter 1: System Requirements
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Supported upgrade paths
This section covers the upgrade paths for the following products:

l Accounting

l Estimating

Accounting upgrade paths

Youmust be running Sage 300 Construction and Real Estate version 9.7 or later in order to upgrade to
version 13.1. If you are running a version that is earlier than 9.7, we recommend that you upgrade to
version 9.8 before you upgrade to version 13.1. Contact your Business Partner for assistance.

Upgrade from Upgrade path

12.1 Upgrade to 13.1.

9.8 Upgrade to 13.1.

9.7 Upgrade to 13.1.

9.4.1* - 9.6 1 Upgrade to 9.8.

2 Upgrade to 13.1.

8.3.x - 9.3.x 1 Upgrade to 9.4.x.

2 Upgrade to 9.8.

3 Upgrade to 13.1.

7.5.0 - 8.2.3 1 Upgrade to 8.3.x or 9.1.x.

2 Upgrade to 9.4.x.

3 Upgrade to 9.8.

4 Upgrade to 13.1.

7.0.0 - 7.4.0 1 Upgrade to 7.5.x or 7.6.x.

2 Upgrade to 8.3.x or 9.1.x.

3 Upgrade to 9.4.x.

4 Upgrade to 9.8.

5 Upgrade to 13.1.

* If you are upgrading from 9.4.x, use Report or Inquiry Manager to rename duplicates of reports and
inquiries within the same application so that each report has a unique report or inquiry name. Starting in
version 9.5, Security Administration applies security settings to only one instance of a report or inquiry. By
using unique report and inquiry names, you can ensure that the security settings applied in previous
versions are carried forward. Otherwise, other instances of the report or inquiry will be unsecured after
upgrading.
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Upgrade from Upgrade path

5.4.x or earlier 1 From TS-Main, select Tools > File Doctor and apply the utility to all files before
you upgrade your 5.4.x installation. (You cannot wait until after the upgrade to
perform this check because later versions of File Doctor are not compatible with
5.4.x data.)

2 Upgrade to 7.5.x or 7.6.x.

3 Upgrade to 8.3.x or 9.1.x.

4 Upgrade to 9.4.x.

5 Upgrade to 9.8.

6 Upgrade to 13.1.

Estimating upgrade path

You can upgrade any Windows-based version of Estimating products (beginning with 1.0) to
Estimating 13.1.

Required data file upgrades
Youmust upgrade all Accounting andManagement application data files after you install version 13.1.

NOTE: You can upgrade the data files for Accounting applications (except for ServiceManagement,
Purchasing, and Inventory) by using TS Main > Tools > Upgrade files or Desktop > Tasks >
Common Tasks > Tools > Upgrade files.

CAUTION: ServiceManagement, Purchasing, and Inventory data files upgrade the first time you
open those applications. Youmust open the application and perform the upgrade at the server.
Upgrading this data on a workstation will incorrectly set DSNs and cause data access errors after the
upgrade is performed.
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Chapter 2: Install Sage 300
Construction and Real Estate
A. Before you install

l Read theRelease Notes for more details about this release of Sage 300 Construction and Real
Estate.

l Read and understand the system requirements.

l Review the Installation Checklist.

IMPORTANT: If you use third-party products that integrate with Sage 300 Construction and Real
Estate, check with your software vendor prior to upgrading to ensure their product is fully compatible
with this release. We do not support rolling Sage 300 Construction and Real Estate back to a
previous version and do not recommend it.

Special installation considerations
p Estimating: If you use Sage Estimating, install Sage 300 Construction and Real Estate version 13.1
before installing Sage Estimating version 13.1.

p Document Management:During the Accounting installation, AP invoice batches that are in the
Document Management Scan queue will be locked. These batches are then automatically moved
from the Scan queue to DocuVault during the installation of DocuVault 13.1. If you want to send
these batches to an Inbox prior to the upgrade, youmust complete that action before installing Sage
300 Construction and Real Estate.

p Project Management Correspondence Log: If you use Correspondence Log andWindows Office
2010, youmust install Project Management components on your server and workstations after you
install Sage 300 Construction and Real Estate. See “Installing Project Management components” on
page 21 for more information.

1 If you are upgrading, create a complete backup of all Sage 300 Construction and Real Estate data and
program files.

2 Install the appropriate operating system service pack, make sure sufficient hard disk space is available,
and verify that your server and workstations meet all other hardware and software requirements. For
example, Sage 300 Construction and Real Estate requires up to 2.2 GB of available hard disk space in
the following location on your server:

l Windows XP orWindows Server 2003: X:\Documents and Settings

l Windows Vista, Windows 7, orWindows Server 2008: X:\ProgramData
If you are upgrading from 9.7 or earlier, the upgrade to 9.8, 12.1, or 13.1may cause file sizes to increase
up to 200% of the current size of your data. Be sure and allow for increased disk space requirements
when you upgrade. Do not install Sage 300 Construction and Real Estate products unless you have
sufficient hard disk space available.

3 Make sure that you have full control of the required folders, files, and registry keys on your file server,
terminal server, and workstations that will have Accounting andManagement Products installed. For a

http://cdn.na.sage.com/sagemail/zCRE131/ReleaseNotesAcctMgmt.pdf
http://cdn.na.sage.com/sagemail/zCRE131/ReleaseNotesAcctMgmt.pdf
http://cdn.na.sage.com/sagemail/zCRE131/Acct_Est_DM_Checklist.pdf
http://cdn.na.sage.com/sagemail/zCRE131/Acct_Est_DM_Checklist.pdf


list of the required folders, files, and registry keys for your operating system, see “Required privilege
settings ” on page 10.

4 Quit all programs and services for the duration of the installation. This includes programs that may be
running in the background, such as antivirus, email, and backup programs.

5 Windows Vista, Windows 7, and Windows Server 2008:Youmust elevate your permissions before
installing version 13.1. During certain installation tasks, you will receive a prompt to elevate your
privileges. If you do not acknowledge each prompt within twominutes, the installation process will quit
the task. If this occurs, you will receive a separate prompt asking you to retry the task. To retry the task,
click [Retry] and then elevate your privileges at the prompt.

6 Verify the upgrade path. If you are upgrading from an older version, you will need to install several
versions to become current.

7 Determine which installation instructions to read in this document. Most users should start with “B.
Install to a server or stand-alone computer” on page 17. If you have a terminal server or peer network,
start with “D. Other installation scenarios” on page 21. If you are installing Sage Estimating only, see
“Chapter 3: Install Sage Estimating ” on page 27.

B. Install to a server or stand-alone computer
IMPORTANT: Do not install Sage 300 Construction and Real Estate unless you have sufficient
hard disk space available. See "Hard disk space" for more information.

The installation process may restart your server or stand-alone computer several times.

1 At the server or stand-alone computer, log on with full administrative rights. Full administrative rights are
defined as write access to theWindows registry and all folders on the computer (including rights to the
root of all hard drives). If you are unsure whether you have full administrative rights, ask your network
administrator for assistance. Alternately, you can ask your network administrator to log on with the
network administrator ID before you start the installation.

2 Follow the instructions you received in the 13.1 download notice.

3 Open the 131_Rev1_Accounting folder and double-click Install.exe to begin the installation process.

4 In theWelcomewindow, click Install Software, then follow the on-screen instructions to accept the
License Agreement, enter your company's Registration name andClient number, and begin installing
prerequisites.

   ABOUT INSTALLING PREREQUISITES:
p If you receive a firewall warningmessage during the installation of the Pervasive database engine,
work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if a Microsoft Windows Firewall Security Alertwindow
lists theDatabase Service Manager by Pervasive Software Inc., confirm with your network
administrator that you want to proceed. Then, select Unblock this program and click [OK].

p Youmay receive a similar message during the installation of Sage Service Host. Follow the same
steps to proceed.

p If you are required to restart your computer, remember to stop antivirus, backup, and other services
that may have automatically started again after you restart your computer.
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5 After the prerequisites are successfully installed , click [Continue] to begin themain installation. If this
is a new installation or amigration, follow the on-screen prompts to enter your activation codes, and
select appropriate industry reports and data sets. Click [Install] to begin installing Sage 300
Construction and Real Estate.

6 At the conclusion of the installation, you will be prompted to restart your computer. After you restart and
log on with the same user name that you used when you installed (user namemust have full
administrative rights), wait until themessageAll configuration tasks for Sage 300 Construction
and Real Estate completed successfully. Do not attempt to start any Sage 300 Construction and
Real Estate applications until after you have received this message. It may take a few minutes before
you see themessage.

7 Some of the data and report folders and files will be hidden by default. At the end of the installation, you
can view these hidden files and folders. To view them on:

l Windows XP Professional orWindows Server 2003: OpenWindows Explorer, select Tools >
Folder Options, click theView tab, and then select theView hidden files and folders check
box.

l Windows Vista, Windows 7, orWindows Server 2008: OpenWindows Explorer, select Organize
> Folder and Search Options, click theView tab, and then select Show hidden files and
folders.

l Windows 8 orWindows Server 2012: OpenWindows Explorer, click theView tab, and then select
theHidden items check box.

Installing Project Management components
If you useMicrosoft Office 2010 and the Project Management Correspondence Log, youmust install
additional components after installing Sage 300 Construction and Real Estate on your server and
workstations.

1 Browse to the location where you installed 13.1 Accounting.
Default locations for the Accounting server:

o 64-bit operating system: C:\Program Files (x86)\Timberline Office\Shared
o 32-bit operating system: C:\Program Files\Timberline Office\Shared

2 Double-click PJOffice2010Shared.exe. The program will automatically install the needed components.

3 Youwill be prompted to restart your computer after the Correspondence Log components are installed.
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Automatic creation of Timberline Office Share
The installation automatically creates a shared Timberline Office folder at the following locations on the
server if one does not already exist.

l Windows XP orWindows Server 2003:
[Drive]:\Documents and Settings\All Users\Application Data\Sage\Timberline Office

l Windows Vista, Windows 7, orWindows Server 2008:
[Drive]:\ProgramData\Sage\Timberline Office

Read and write permissions are automatically granted toEveryone for this folder. If the Timberline Office
folder is already present and shared, the installation will skip this step. The system will not change any
permissions you have already set up.

You will connect your workstations to the shared Timberline Office folder in the next section.

C. Install to a workstation connected to a network
After you install to a server (“B. Install to a server or stand-alone computer” on page 17), you can install to
your workstations or to a computer that functions as a terminal server.

IMPORTANT: Do not install Sage 300 Construction and Real Estate unless you have sufficient
hard disk space available. See “Hard disk space” on page 6 for more information.

NOTE: The installation process may restart your workstations several times.

Installing to a terminal server
If you are installing to a computer that will be used as a terminal server, follow the preceding installation
steps A, B, and C.

If your terminal server does not host Sage 300 Construction and Real Estate programs and data files, after
installing, verify that the Pervasive.SQL database service on the terminal server uses an account with
access to all Sage 300 Construction and Real Estate program and data files on the server.

To verify your account and access rights, select Start > Programs > Administrative Tools > Services
on the terminal server. In theServiceswindow, right-click thePervasive.SQL service and select
Properties. Then, on the Log On tab, select [Use this account].

Work with your network administrator to enter an account that has the access rights of the Local System
account and access to all Sage 300 Construction and Real Estate program and data files on the file server;
for example, a domain administrator account.

NOTE: If you use an account with insufficient access rights, youmay receive a Pervasive status
code 94 or 3119 error.
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Installing to a workstation
1 At the workstation, log on with full administrative rights. Full administrative rights are defined as write
access to theWindows registry and all folders on the computer (including rights to the root of all hard
drives). If you are unsure whether you have full administrative rights, ask your network administrator for
assistance. Alternately, you can ask your network administrator to log on with the network administrator
ID before you start the installation.

2 Click [Start] > Run, click [Browse], navigate to the \\[Server name]\Timberline
Office\9.5\Accounting\WinInst\Install.exe folder on the server, and then double-click Install.exe.

3 In the Installationwindow, click Install Software to install components necessary to run Sage 300
Construction and Real Estate applications.

NOTE: If you receive a firewall warningmessage during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if aWindows Firewall Security Alertwindow lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].

Youmay also receive this message during the installation of Sage Service Host. Follow the same steps
to proceed.

4 Repeat steps 1–5 for each workstation.

5 At the conclusion of the installation, you will be prompted to restart your workstation.

6 Some of the data and report folders and files will be hidden by default. At the end of the installation, you
can view these hidden files and folders: To view them on:

l Windows XP Professional orWindows Server 2003: OpenWindows Explorer, select Tools >
Folder Options, click theView tab, and then select theView hidden files and folders check
box.

l Windows Vista, Windows 7, orWindows Server 2008: OpenWindows Explorer, select Organize
> Folder and Search Options, click theView tab, and then select Show hidden files and
folders.

l Windows 8 orWindows Server 2012: OpenWindows Explorer, click theView tab, and then select
theHidden items check box.

7 If you had a shortcut to Desktop, youmay need to re-create it after installing version 13.1 by double-
clickingDesktop.exe in theC:\ProgramFiles\Timberline Office\Shared folder. All other application
shortcuts will continue to work after installing 13.1.
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Installing Project Management components
If you useMicrosoft Office 2010 and the Project Management Correspondence Log, youmust install
additional components after installing Sage 300 Construction and Real Estate on your server and
workstations.

1 Browse to the location where you installed 13.1 Accounting.
Default location for the Accounting workstation:

o 64-bit operating system: C:\Program Files (x86)\Timberline Office\Shared
o 32-bit operating system: C:\Program Files\Timberline Office\Shared

2 Double-click PJOffice2010Shared.exe. The program will automatically install the needed components.

3 Youwill be prompted to restart your computer after the Correspondence Log components are installed.

D. Other installation scenarios

Peer server networks with Estimating products
Follow installation steps A, B, and C, but perform this step after the installation:

At the peer server, browse to the same shared folder that the workstations use. Use this path to access
Address Book data.

E. Upgrade data files
If you upgraded to a new version of Sage 300 Construction and Real Estate, read and follow the
information in this section. If this is a first-time installation, skip to “F. Install Crystal Reports XI (optional)”
on page 23.

CAUTION: ServiceManagement, Purchasing, and Inventory have specific upgrade requirements.
First, log onto the file server as an administrator. Then open and upgrade ServiceManagement,
Purchasing, and Inventory data files at the server the first time you open these applications.
Upgrading this data on a workstation will incorrectly set DSNs and cause data access errors after the
upgrade is completed.

Prepare to upgrade files
For optimal performance, we recommend that you upgrade your data from the server. If you prefer to
upgrade your data from aworkstation instead, youmust ensure that the same version and update are
installed on both the server and the workstation before starting theUpgrade Files process.

1 Back up your data files.

2 Make sure all users have closed Sage 300 Construction and Real Estate applications.

3 Log in to Sage 300 Construction and Real Estate as the application administrator.
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4 Open TS-Main.

a If you are prompted to select a company but you do not see your company, click [Specify Folders].

b In theSpecify Data Folders Path window, click [Browse]. Then, select the UNC path to the folder
that contains your Sage 300 Construction and Real Estate data and click [OK].

c Select your data folder from theSpecified Folders area and click [OK].

d Select your company from the list of companies in theSelect Companywindow and click [OK].

5 If you use File Locations and the path is not accessible from the server (for example, you usemapped
drives instead of specific paths), modify the locations to point to files on the local hard drive of your
server.

TIP: We recommend that you convert your mapped drives to the equivalent UNC paths using the
following instructions. If you convert now, you will not have to perform this step during future upgrades,
and you can skip to “Restore file locations ” on page 23.

a In TS-Main, select File > Company Settings > File Locations.

b In the File Locationswindow, look for network paths in theData Folder column.

c If you have network paths, write them down. You need this information for a later step.

d In the File Locationswindow, modify each network path to point to the appropriate file on the local
hard drive of your server.

e Close the File Locationswindow.

6 Repeat steps 4 and 5 for each data folder you will upgrade.

Upgrade files
Files cannot be in use while they are being upgraded.

1 In TS-Main, select Tools > Upgrade Files.

NOTE: To save processing time, theUpgrade Files feature only updates files that have dictionary
changes. You can, however, select the Force file upgrades check box (TS-Main: Tools > Upgrade
Files) if you want to upgrade all of your data files.

2 Select to upgrade the current data folder or all data folders.

p If you select Current data folder, you upgrade files in the data folder in which you currently work.

p If you select All data folders, you upgrade files in all data folders that appear in theOpen Company
window. This may include data folders on other drives. With this option, the upgrade process can
take a long time if you havemany data folders.

3 Click [All Files]. Youmust upgrade all data files after you install version 13.1.

4 Click [Start].

5 In thePrint File Selectionwindow for File name, type a name for the upgrade report file, and then click
[Save].
The upgrade process begins in the background.

6 When the process is complete, review the report.
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Restore file locations
If you use UNC paths, you can skip this step now and in future upgrades.

If you usemapped drives instead of UNC paths and themodified file locations and path are not accessible
from the server, restore the previous file location entries.

1 In TS-Main, select File > Company Settings > File Locations.

2 In the File Locationswindow, find the file locations you changed previously and change them back to
the original network path.

3 Close the File Locationswindow.

F. Install Crystal Reports XI (optional)
If you ownCrystal Reports XI and have already installed it, you can skip this step. For more information
about setting up Crystal Reports with Sage 300 Construction and Real Estate, see “Chapter 9: Crystal
Reports,” on page 95.

Crystal Reports XI is installed from three separate CDs. The first two CDs install the Crystal Reports XI
software. The third CD installs a service pack. This service pack ensures Crystal Reports XI is
compatible with Sage 300 Construction and Real Estate. Follow these steps to install Crystal Reports XI.

1 Ensure all Windows programs are closed.

1 Insert the first CD into the drive of the server or workstation where your report designs are kept.

2 When the setup wizard appears, click [Next] and follow the on-screen instructions to run the installation.

3 When prompted, insert the second CD and click [OK] to continue.

4 Click [Finish] after the Crystal Reports installation is finished and remove the second CD.

5 Insert the service pack CD into the drive, openWindows Explorer, browse to the CD, and double-click
Setup.exe to begin the service pack installation.

NOTE: This step assumes you are installing Crystal Reports XI for Sage. If you are installing Crystal
Reports XI from aCD supplied by another vendor, contact themanufacturer for instructions on applying
the service pack update.

6 Follow the on-screen instructions to install the Crystal Reports service pack.

7 Restart your computer when prompted.
Do not remove the CD; it must remain in your computer during restart for the installation to continue.

8 After the service pack installation is finished, remove the service pack CD.

Sage 300 Construction and Real Estate User's Guide                                                                                                        Page 23

Chapter 2: Install Sage 300 Construction and Real Estate



G. After you install
Some of the data and report folders and files will be hidden by default. At the end of the installation, you
can view these hidden files and folders. To view them on:

l Windows XP Professional orWindows Server 2003: OpenWindows Explorer, select Tools >
Folder Options, click theView tab, and then select theView hidden files and folders check
box.

l Windows Vista, Windows 7, orWindows Server 2008: OpenWindows Explorer, select Organize
> Folder and Search Options, click theView tab, and then select Show hidden files and
folders.

l Windows 8 orWindows Server 2012: OpenWindows Explorer, click theView tab, and then select
theHidden items check box.

Elevated permission levels after installing
If you install ServiceManagement (SM), Purchasing (PO), and Inventory (IV) onWindows Vista,
Windows 7, orWindows Server 2008, you should elevate your permission level. Crystal Reports may not
run correctly in these applications if the permission level is set too low. If you encounter an error message
when starting SM, PO, or IV for the first time after installation, close the application, elevate your
permission level, and start the application again. To do this:

1 Close the PervasiveWorkgroup engine (Right-click the Pervasive Database icon in the systems tray
and select Stop Engines and Exit.)

2 Navigate toSM.exe, PO.exe, or IV.exe. The default location for these files is C:\Program Files (x86)
\Timberline Office\Shared.

3 Select Run as Administrator.

4 Open each company data set at the server.

5 Repeat these steps for each company data folder.

If you have Purchasing, Inventory or Service Management data in
Program Files
If, before upgrading, your company data folder was inside theProgram Files folder in Purchasing (PO),
Inventory (IV), or ServiceManagement (SM), follow these steps at the server to move your data to a
shared location andmake the data available to your users.

1 Move the data files to a shared location. The default shared location is:
\\[Server name]\Timberline Office\Data

2 At the server, remove all Pervasive System DSNs and User DSNs for each Sage 300 Construction and
Real Estate installation:

a Click Start > All Programs > ODBC > 32bit ODBC Administrator.

b In theODBC Data Source Administratorwindow on theSystem DSN tab, select the first Name
associated with aPervasive ODBC Engine Interface Driver, and then click [Remove].
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c Repeat this process to remove eachName associated with aPervasive ODBC Engine Interface
Driver.

d On theUser DSN tab, select the first Name associated with aPervasive ODBC Client Interface
Driver, and then click [Remove].

e Repeat this process to remove eachName associated with aPervasive ODBC Client Interface
Driver.

f Click [OK].

3 At the server, delete theDBNAMES.CFG file:

a From \\[Server name]\WINDOWS, right-click DBNAMES.CFG, and select Delete.

b In theConfirm File Deletewindow, click [Yes].

4 Add each company to the company list:

a In TS-Main, select File > Open Company.

b Click [Specify Folders].

c Click [Browse] and browse to the shared location from step 1.

d Select a folder and click [OK].

e At the server, open the SM, PO, or IV applications for each Sage 300 Construction and Real Estate
company.

f Repeat these steps for each company folder that you want to add.

5 If you use security, give the appropriate users rights to the companies; (select Sage Desktop > Tools
> Security Administration > User Setup > Companies).

If you have Estimating-only workstations
To access Address Book, Job Cost, and tax data on a server, seeAdditional Steps for Network
Installations in “D. Other installation scenarios,” on page 21. Workstations that have both Estimating and
Sage 300 Construction and Real Estate have already been configured as part of the Sage 300
Construction and Real Estate installation and do not require these steps. The steps apply to both upgrades
and first-time installations.
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H. Final steps
1 Restart all programs and services that you shut down for the installation.

2 Review the following guidelines for custom reports or custom third-party applications.

a If you have custom reports that use the Crystal Reports format, be sure to open these reports in
Crystal Reports Professional, select Database > Verify Database, and then save the report.

b If you use Inventory, Purchasing, or ServiceManagement custom Crystal reports, see page 125 or
page 129 in Chapter 9 for special information and detailed instructions about upgrading these reports.

c As with any release, database changes in Sage 300 Construction and Real Estate applications may
affect your custom report designs or custom third-party applications. Contact your authorized
business partner to discuss any issues relating to custom reports or third-party applications.

3 If you set up a shortcut to Desktop, youmust re-create it after installing version 13.1 by selecting the
Desktop.exe inC:\ProgramFiles\Timberline Office\Shared. All other application shortcuts will
continue to work after installing version 13.1.

4 Click [Help] in any window for more information.
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Chapter 3: Install Sage Estimating
A. Before You Install or Upgrade
1 Review the Estimating Release Notes for information regarding this release of Sage Estimating.

2 If you are upgrading, create a complete backup of all Sage 300 Construction and Real Estate data and
program files.

3 If you are upgrading from 9.8, ensure that you are running Estimating 9.8 Rev 3 before upgrading to
version 13.1. Verify your software version inHelp > About.
Modifying or uninstalling the original 9.8.0 Rev. 2may result in a loss of data. 9.8.0 Rev 3 corrects the
issue and overwrites Rev 2. Download Estimating 9.8 Rev 3 and install it over Rev 2. Software Notice
11-S contains a link to 9.8 Rev 3.

4 Install the appropriate operating system service pack level, make sure that there is sufficient hard disk
space available, andmake sure that your server and workstations meet all other hardware and software
requirements. For example, Estimating requires up to 650MB of available hard disk space. See
“Chapter 1: System Requirements” on page 3 for more information.
CAUTION: Estimating Explorer is not currently supported on theWindows Server 2012 orWindows 8
operating systems.
If you use the Extended version of Estimating Explorer, we recommend that you install it on
workstations withWindows 7 (or earlier).
If you use the Standard version of Estimating Explorer, you have the option of either installing it on
workstations withWindows 7 (or earlier) or switching to the SQL version of Estimating (where you can
use the EstimatingManagement Console).

5 Make sure that you have full control of the necessary folders, files, and registry keys on your file server,
terminal server, and workstations that will have Sage 300 Construction and Real Estate installed. For a
list of the required folders, files, and registry keys for your operating system, see “Required privilege
settings ” on page 10.

6 Windows Vista, Windows 7, and Windows Server 2008:Youmust elevate your permissions before
installing Sage 300 Construction and Real Estate. During certain installation tasks, you will receive
another prompt to elevate your privileges. If you do not acknowledge each prompt within twominutes,
the installation process will quit the task. If this occurs, you will receive a separate prompt asking you to
retry the task. To retry the task, click [Retry] and then elevate your privileges at the prompt.

7 Quit all programs and services for the duration of the installation. This includes programs that may be
running in the background, such as antivirus, email, and backup programs.

8 If Sentinel protection devices are not already attached to your computer, delay attaching these devices
until after you install Estimating. If you already have Sentinel protection devices attached, you can
leave these devices in place during the Estimating installation.

9 Decide which installation instructions to read in this document. Most readers should start with “B.
Install to aWorkstation” on page 28. If you have Sage 300 Construction and Real Estate, a terminal
server, or a peer network, start with “D. Other Installation Scenarios” on page 30.
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B. Install to a Workstation
IMPORTANT: Do not install Estimating until you have sufficient hard disk space available. See
"Hard disk space" for more information.

NOTE: The installation process may restart your workstations several times.

1 At the workstation, log on with full administrative rights. Full administrative rights are defined as write
access to theWindows registry and all folders on the computer (including rights to the root of all hard
drives). If you are unsure whether you have full administrative rights, ask your network administrator for
assistance. Alternately, you can ask your network administrator to log on with the network administrator
ID before you start the installation.

2 Follow the instructions you received in the 13.1 download notice.

3 Open the 131_Rev1_Estimating folder and double-click Install.exe to begin the installation process.

4 Click Install Software, then follow the on-screen instructions to accept the License Agreement and
begin installing the prerequisites.

5 After the prerequisites are installed, click [Continue] to start themain installation. Follow the on-screen
prompts to install Estimating 13.1 and enter which location, features, activation codes, and whether you
want to install databases. You can install databases to your workstations, or you can install databases
to a server. Install databases at your server if you want to share databases across your network.

NOTE: If you receive a firewall warningmessage during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if aWindows Firewall Security Alertwindow lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].

6 If you are upgrading from Estimating 9.5 or later, you can skip to step 8. After restarting, Estimating will
automatically bring up theEstimating User Account Control and Configuration Setupwindow.
This process sets up all default User Account Control (UAC) compliant folders, transfers all Windows
registry settings, scans and copies any data found in Program Files, and copies relevant application
data to a UAC-compliant location.

n If this is the first time Estimating is being installed on your computer, this process ensures that your
data will be stored in a UAC-compliant location and your computer is configured properly.

n If you are upgrading from a previous version of Estimating, this process ensures any data stored in
a non-UAC compliant location is copied to a UAC-compliant location.

Select [Click to Begin] to start the upgrade process.

7 Windows Vista, Windows 7, and Windows Server 2008: Youmust elevate your permissions before
installing Sage 300 Construction and Real Estate. During certain installation tasks, you will receive
another prompt to elevate your privileges. If you do not acknowledge each prompt within twominutes,
the installation process will quit the task. If this occurs, you will receive a separate prompt asking you to
retry the task. To retry the task, click [Retry] and then elevate your privileges at the prompt.

NOTE: Formore information on User Account Control, see the User Account Control topics included
in Estimating Help.

8 Repeat steps 1–6 for each workstation to which you want to install Estimating.
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9 At the conclusion of the installation, you will be prompted to restart your computer. After you restart your
computer and log on with full administrative rights, wait until themessageAll configuration tasks
completed successfully. Do not attempt to start Estimating until after you have received this
message.

NOTE: It may take awhile before you see themessageAll configuration tasks completed
successfully.

10 If you set up a shortcut to Desktop, youmust re-create it after installing 13.1. Select the Desktop.exe in
C:\ProgramFiles\Timberline Office\Shared.

11 If you plan to install Estimating to a server or if you plan to share estimates and databases from a
server, continue with “C. Install to a Server,” on page 29. Otherwise, skip to “E. Set up Stand-Alone
Security Devices” on page 32.

C. Install to a Server
IMPORTANT: Do not install Estimating unless you have sufficient hard disk space available. See
"Hard disk space" for more information.

NOTE: The installation process may restart your server several times.

Many users choose to share databases and estimates across their network. They also install Estimating
to their server so they canmore efficiently perform file maintenance on their data. Follow these steps if you
want to install Estimating or share databases or estimates from your server.

Even if you do not install Estimating on your server, you still need to follow these steps to install required
components that allow you to access data.

1 At the server or stand-alone computer, log on with full administrative rights. Full administrative rights are
defined as write access to theWindows registry and all folders on the computer (including rights to the
root of all hard drives). If you are unsure whether you have full administrative rights, ask your network
administrator for assistance. Alternately, you can ask your network administrator to log on with the
network administrator ID before you start the installation.

2 Follow the instructions you received in the 13.1 download notice.

3 Open the 131_Rev1_Estimating folder and double-click Install.exe to begin the installation process.

4 If you want to install Estimating on the server, skip to step 5. If you want to access databases and
estimates from the server, but you do not want to install Estimating, cancel the installation when the
License Agreementwindow appears. Pervasive SQLDatabase Engine and SQL Server Express are
automatically installed with the prerequisites.

n After you have canceled the installation, run the Sage System Verifier (SSV). This sets the
Pervasive settings to the recommendedminimums. If Sage 300 Construction and Real Estate is
installed, you can run the Sage System Verifier (SSV) from Desktop > Tasks > Tools > System
Verification.

n Run SSV by browsing to and double-clicking
\...\Estimating\AdditionalInstalls\SSV\SageSystemVerifierSA.exe.
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5 In the Installationwindow, click Install Software. In the resulting installation, choose to install
databases, Estimating products, or both .
You can install Estimating to a server in order to perform file maintenance, but you should not perform
other Estimating tasks at the server. These tasks should be performed at workstations.

NOTE: If you receive a firewall warningmessage during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if aWindows Firewall Security Alert window lists the
Database ServiceManager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].

D. Other Installation Scenarios

Additional Steps for Network Installations That Have Sage 300
Construction and Real Estate
To access Accounting data on a server, follow these steps on each Estimating-only workstation.
(Workstations that have both Estimating and Sage 300 Construction and Real Estate have already been
configured as part of the Sage 300 Construction and Real Estate installation and do not require these
steps.)

The following steps apply to both upgrades and first-time installations.

1 Note the shared Timberline Office folder on the server or peer server where the Sage 300 Construction
and Real Estate data folder is installed. This shared folder should be the parent to the folder where the
application data is installed.

n Windows XP, Windows Server 2003
[Drive]:\Documents and Settings\All Users\Application Data\Sage\Timberline Office.

n Windows Vista, Windows 7, and Windows Server 2008
[Drive]:\ProgramData\Sage\Timberline Office.

2 Click [Start] > Run.

3 In theRunwindow, click [Browse]. Browse to \\[Server name]\Timberline
Office\9.5\Accounting\WinInst\Install.exe. Click [Open]. Then, click [OK]..

4 In the Installationwindow, click Install Sage Estimating and follow the instructions as they appear in
the windows.

NOTE: If you receive a firewall warningmessage during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if aWindows Firewall Security Alertwindow lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you want to proceed. Then, select Unblock this program and click [OK].
Youmay also receive this message during the installation of Sage Service Host. Follow the same steps
to proceed.

5 Repeat steps 1–4 for each Estimating-only workstation. When finished, follow the steps in “B. Install to
aWorkstation” on page 28.
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6 At the conclusion of the installation, you will be prompted to restart your computer. After you restart your
computer and log on with full administrative rights, wait until themessageAll configuration tasks
completed successfully. Do not attempt to start any Sage 300 Construction and Real Estate
applications until after you have received this message. It may take several minutes before you see the
messageAll configuration tasks completed successfully.

7 Some of the data and report folders and files will be hidden by default. At the end of the installation,
show hidden files and folders.

n OnWindows XP Professional orWindows Server 2003, openWindows Explorer, select Tools >
Folder Options, and select View hidden files and folders on theView tab.

n OnWindows Vista orWindows Server 2008, select Organize > Folder and Search Options, and
then select Show hidden files and folders on theView tab.

8 If you set up a shortcut to other applications, youmust re-create them after installing 13.1. Locate the
application.exe file inC:\ProgramFiles\Timberline Office\Shared. Right-click and select Create
shortcut.

Terminal Server
Follow the installation steps for aWindows server, with these exceptions:

n If you install on aWindows Server 2008 terminal server, begin the installation by selectingControl
Panel > Install Application on Terminal Server. Follow the prompts and browse to the
install.exe file.

n InWindows Server 2008 R2, "terminal services" is called "Remote Desktop ".
OpenStart > Control Panel > Install Application on Remote Desktop
orStart > Control Panel > Programs > Install Application on Remote Desktop.

Follow the prompts and browse to the install.exe file.

n If you use another server to host Estimating databases, you can install only Estimating applications
to the terminal server.

NOTE: If you install Estimating Products on a terminal server that uses Windows Server 2003, you
must log on to the terminal server with full administrative rights when you use Estimating Products. This
ensures that Estimating Products have proper access to theWindows registry.

Pervasive Manual Installation
The Pervasive database engines are installed automatically with other prerequisite software when you
install Sage 300 Construction and Real Estate.

Tomanually install this program, download the software and install the prerequisites. Then, cancel the
installation at the License Agreementwindow. Pervasive SQLDatabase Engine is automatically
installed with the prerequisites.

After you have canceled the installation, you should run the Sage System Verifier (SSV), which will set
Pervasive settings to the Sage 300 Construction and Real Estate recommendedminimums.
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If Sage 300 Construction and Real Estate is installed, you can run the Sage System Verifier (SSV) from
Desktop > Tasks > Tools > System Verification.

If Sage 300 Construction and Real Estate is not installed, run SSV by browsing to and double-clicking
...\Estimating\AdditionalInstalls\SSV\SageSystemVerifierSA.exe.

NOTE: SomeSage System Verifier checks may not pass if Sage 300 Construction and Real Estate is
not installed. This is acceptable provided that you ensure theSage Timberline Office—Pervasive
PSQL License andSage Timberline Office—Pervasive PSQL Settings checks are completed
successfully when you run the Sage System Verifier.

E. Set up Stand-Alone Security Devices
If you use LicenseManager to provide license security, skip to “F. Set up LicenseManager” on page 33.

If you already use stand-alone security devices, skip to “G. Upgrade Estimates and Databases” on
page 35.

Install the Sentinel Driver
The Estimating installation program automatically installed a Sentinel driver if you did not have one. For
instructions to install the Sentinel driver manually, access the Support Portal at
https://support.na.sage.com, log on, and search the Knowledgebase for Article ID 22112.

Attach Protection Devices to Workstations
1 If you have a parallel port protection device, disconnect any hardware or peripheral devices attached to
the parallel port of a workstation.

2 Plug a protection device into the parallel port or USB port of the workstation.

3 If you disconnected devices in step 1, reconnect these devices.

4 Repeat steps 1–3 for each workstation. Then, skip to “G. Upgrade Estimates and Databases” on
page 35.
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F. Set up License Manager
If you use stand-alone security devices to provide license security, see “E. Set up Stand-Alone Security
Devices” on page 32.

Guidelines
Please note the following:

n Youmust install LicenseManager to aWindows server or workstation.

n All license-managed servers and workstations must use the same network protocol (TCP/IP).

n You cannot install LicenseManager to a terminal server. If you have a terminal server, install to a
workstation.

n If you use firewall software on your license server, youmay not be able to use theWlmAdmin or
WCommute applications to view or check out licenses. To resolve this issue, discuss the server’s
firewall security with your network administrator. If you are willing to adjust your firewall security
settings on the licensemanager server, consider granting access to the lservnt.exe file.

n Check in any licenses before upgrading.

For more information:

n Getting StartedWith LicenseManagement

n Sentinel LicenseManager System Administrator Online Help (index.html). This file is in the
...\Estimating\AdditionalInstalls\LicenseManager\SysAdminHelp.

Install the Sentinel Driver
The Estimating installation program automatically installed a Sentinel driver if you did not have one. For
instructions to install the Sentinel driver manually, access the Support Portal at
https://support.na.sage.com, log on, and search the Knowledgebase for Article ID 22112.

Attach a Protection Device to the Computer That Will Have License
Manager
1 If you have a parallel port protection device, disconnect any hardware or peripheral devices attached to
the parallel port.

2 Plug the protection device into the parallel port or USB port.

3 If you disconnected devices in step 1, reconnect these devices.
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Install License Manager
If you already have LicenseManager installed, skip to “Upgrade LicenseManager,” on page 35.

1 Log on with full administrative rights. Full administrative rights are defined as write access to the
Windows registry and all folders on the computer (including rights to the root of all hard drives). If you are
unsure whether you have full administrative rights, ask you network administrator for assistance.
Alternately, you can ask your network administrator to log on with the network administrator ID before
you start the installation.

2 Open and double-click ...\Estimating\AdditionalInstalls\LicenseManager\Server\Setup\Setup.exe.

3 Follow the on-screen prompts. The installation automatically installs the appropriate software for the
operating system.

NOTE: Be sure to accept the default installation path when you install LicenseManager. If you need to
change the default installation path, change it to a local drive. You cannot install LicenseManager to a
network drive.

Install License Codes
The number of network licenses purchased for an application indicates the total number of concurrent
network uses allowed for that application. To install license codes, follow these steps:

1 Verify that the Sentinel LicenseManager service is running. Click [Start]. Then select Settings >
Control Panel > Administrative Tools > Services (orStart > Control Panel > System and
Maintenance > Administrative Tools > Services inWindows Vista). Look for Sentinel RMS
License Manager in the list of services.

2 Download the software.

NOTE: Consider copying the entire License Tools folder to your local hard drive. This makes License
Tools more accessible for futuremaintenance.

3 Expand "Subnet Servers".

4 Install license codes using one of the followingmethods.

n To enter license codes from a file: In theWlmAdminwindow, right-click your server and select
Add Feature > From a File > To Server and Its File. In theOpen window, select your license
file and click [Open]. This installs all license codes in the file.

n To type license codes: In theWlmAdminwindow, right-click your server and select Add
Feature > From a String > To a Server and its File. In theAdd feature to serverwindow, type
your license code exactly as it appears in the license file or on the packing slip. (The code is not
case-sensitive.) Be sure to select theAdd feature to server’s file check box.

When you enter a license code, the software adds this code to a file named Lservrc (which has no file
extension) in the Licensemanager installation path.

5 If you receive amessage that a license is invalid or already exists, review the information inGetting
StartedWith LicenseManagement .

6 Enter license codes.
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Upgrade License Manager
To upgrade LicenseManager, youmust use the following steps to remove the previous version of License
Manager and then install the new version (version 8.3). Perform these steps at the computer where
LicenseManager is installed.

1 Check in any licenses before upgrading.

2 Run LoadLS.exe, located in the folder where you installed the previous version of LicenseManager
(typically, C:\Program Files\Rainbow Technologies\SentinelLM7x.x.xServer\English). Click [Remove],
and then click [OK] to remove the Sentinel LM licensemanager.

3 Remove the previous LicenseManager version (in XP: Start > Settings > Control Panel > Add or
Remove Programs; inWindows Vista: Start > Control Panel > Programs > Uninstall a Program).
RemoveSentinel LM x.x.x.x. Server.

4 Install the new version of LicenseManager. See "Install LicenseManager".

5 Copy the Lservrc file from the directory you identified in step 2 to the 8.1 directory of LicenseManager.
Typically, the 8.1 directory is C:\Program Files\Common Files\SafeNetSentinel\Sentinel RMS License
Manager\WinNT.

6 Click [Start] and then select Settings > Control Panel > Administrative Tools > Services. Find
Sentinel RMS License Manager in the list of services, right-click the service, and then select
[Restart].

G. Upgrade Estimates and Databases
If you upgraded to a new version of Estimating Products, read the information in this section. If this is a
first-time installation of Estimating Products, skip to “H. After You Install” on page 36.

NOTE: If youmanually create a backup, clear the check box to auto-create a backup.

1 If you access data on another computer, map a drive to the network shared folder in which you have
data. Use the same drive letter for all workstations. To avoid network disruptions and tomaximize
performance, upgrade files at the computer that hosts your data.

2 Back up your data files.

3 In Estimating Tools, select Upgrade Files.

4 In theUpgrade Fileswindow, select theUpgrade - For current users of Estimating for Windows
option.

5 Select the folder containing the estimates or databases that you want to upgrade. Click [Browse] to
browse for a folder.

6 Complete the remaining fields in the window.

7 Click [Finish] to upgrade the selected files. During the upgrade, a progress bar in the lower right corner
of theEstimating Toolswindow shows the name and path of each file as well as the name of each
record type. Afterwards, you can print (File > Print Audit) or save (File > Save Audit) the information
shown in the window.
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8 If you are prompted to upgrade Address Book data, follow the steps in “E. Upgrade data files” on
page 21.

TIP: Keep the following inmind if you are upgrading from an earlier version:

l If you are upgrading from a version earlier than 6.0, youmust upgrade databases before you
upgrade estimates. The update occurs automatically if the database and the estimates are in the
same folder. If Estimating Tools cannot upgrade an estimate because it cannot find the associated
database, use File > File Tools to move the estimate and database to the same folder; then,
upgrade the single estimate. Click [Yes] when asked if you want to use the database that is in the
same folder as the estimate.

l When youmove a database to a different location, the estimates that were createdmust be re-
associated with the database’s new location.

H. After You Install
1 Restart all programs and services that you shut down for the installation.

2 If necessary, configure Estimating to access the Sage 300 Construction and Real Estate data folder.
For instructions, see “Selecting a company data folder for Address Book and Job Cost information” in
Estimating Help or “Select a company data folder for Address Book and accounting information” in
Buyout Help.

3 If you upgraded and your Estimating data resided in theProgram Files folder, your Estimating data was
copied to a shared location. Verify proper operation of your files after upgrading, and then delete the
original data in theProgram Files folder. Update any workstationmaps to point to the new shared
location.

4 Click [Help] in any window for detailed procedural information. Click Help > Product Documents for
release notes and technical information about your system.

I. Upgrade Your Estimating Explorer Data
If upgrading from 9.4.x, perform a back-up and restore operation to upgrade your existing Estimating
Explorer data fromMSDE to SQL Server Express.

Backup Estimating Explorer
1 Have all users close Estimating.

2 Log on to the computer where you store your Estimating data.

3 Start Explorer on the computer where the data source resides.

4 Close any open data sources by selectingClose Data Source from the Estimating Explorer Filemenu.

5 From the Filemenu, select Data Source Tools. Click [Next] in theData Source Toolswindow.

6 Select the name or address of the SQL Server where the data source you want to back up resides. If
you do not see the server in the list, click [Refresh] to update the list of available servers or type the
server’s computer name; for example, [Server name] or [Server name]\instance.

7 Click [Next].
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8 Select Back up the Explorer data source and click [Next].

9 Browse to the location of the folder where you want to create the backup. Youmust select a folder
located on the computer that hosts the data source.

10 Click [Start]. If a backup copy already exists in the folder, Estimating Explorer warns you that the
backup copy will be overwritten. If you get this warning, click [OK] to continue. Otherwise, click
[Cancel].

11 When you finish working with the data source tools, click [Finish].

Restore Estimating Explorer Data
1 Close any open data sources by selectingClose Data Source from the Filemenu.

2 From the Filemenu, select Data Source Tools.

3 In theRun Aswindow, select the user account to use withData Source Tools. Note that the user
account you select must be an administrator account on the local computer.

4 If you select Current user, clear theProtect my computer and data from unauthorized program
activity check box.

5 Click [OK], and then click [Next] in theData Source Toolswindow.

6 Select the name or address of the SQL server on the destination computer.
If you do not see the server in the list, click [Refresh] to update the list of available servers or type the
server’s computer name. For example, type [Server name]\SQLEXPRESS for the default instance of
SQL Server Express or [Server name]\instance for a named instance of SQL Server Express.

7 Click [Next]. Select Restore an Explorer data source from a previous backup and click [Next]
again.

8 Click [...] to browse to the folder that contains the data source backup. Then, click [Start].
If an Explorer data source already exists on the server, Explorer warns you that the existing data source
will be overwritten.

9 To overwrite the existing data source, click [OK]. Otherwise, click [Cancel].

10 Click [Finish] to closeData Source Tools.
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Automated Installation

Streamline the Process of Installing Accounting and Management
Updates
Sage InstallationManager enables you to install software updates on numerous workstations from your
Accounting server. Sage InstallationManager is installed on your Accounting server and workstations
when you install Accounting andManagement Products 9.7 or later . We recommend that you set up and
begin using Sage InstallationManager to install software updates after you have upgraded to 9.7 or later.

You can use Sage InstallationManager to:

n check regularly for Sage 300 Construction and Real Estate updates.

n notify you when a new update is available.

n download new updates automatically or manually to your server.

n install updates on your Accounting server and Accounting andManagement workstations.

After an update has been downloaded to the server, you can install it on your server and workstations at
your convenience.

Email Notification
Sage InstallationManager comes with an automatic email notification system. You can set upmembers of
your staff to receive system notifications about software updates. In addition, you can use Sage
InstallationManager’s messaging capability to communicate with members of your staff. For example,
you can broadcast a scheduled installation time, and ask your staff to close Sage 300 Construction and
Real Estate applications on their workstations before they leave for the day.

NOTES:

l Although Sage InstallationManager notifies you when an update is available, we will continue to
send email notification of software updates as well.

l The use of Sage InstallationManager is optional. You can continue to update your server and each
workstationmanually.

l Sage InstallationManager works with Sage 300 Construction and Real Estate Accounting
versions 9.7.0 and later.



Before You Begin
n All workstations and servers must be on the same domain.

n The account logon you use for Sage InstallationManager must have administrator privilege on the
Accounting server and all workstations which will receive updates from it.

n An SMTP email server must be available in order to use the automatic email notification system in Sage
InstallationManager.

n On your server and workstation firewall, open the following ports:

Server Workstation

8110 8110

8111 8111

8112 8112

8113

8114

Set Up Sage Installation Manager
In theChange Settings tabs, you can set up your email system, and determine who will receive various
notifications about updates. You can also control when to download Sage 300 Construction and Real
Estate updates to your Accounting server.

Set Up the Email System
1 Open Sage InstallationManager.
From theStartmenu, click Programs > Sage > Installation Manager.

2 Click theChange Settings > Email Notifications tab, and then click [Email] in theSubscribers
panel.

3 In theEmail Accountwindow, type information in the following sections:

Account Information

l Email address–Type the address to appear in the “From” box in emails sent by the system.

l User Name–Type a user namewho is allowed to send emails from your email server.

l Password–Type the password associated with the user name.

Server Information

l Outgoing email server (SMTP)–Type the name of the server you use to send email.

l Port–Type the port you use for email. The default is port 25.

l Use Secure Sockets Layer–Select if your email server requires the use of secure sockets.

4 Click [Send Test Email]to open a window from which you can test the system you just set up.
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Set Up Email Notifications and Subscribers
1 In theChange Settingswindow, click Email Notifications tab. In theSubscribers panel, click [Add].

2 Enter the email address of the person who will receive email messages from the system.

3 Select the type of notifications that person should receive:

p New Update Available–An update is available for downloading to your server.

p Download Complete–The update was successfully downloaded to your server.

p Installation Successful–The update was successfully installed on your server and workstations.

p Installation Error–An error caused the installation to quit on your server or a workstation. See the
Manage updates orCheck workstation status panes for more information.

4 Click [Add].

5 Repeat steps 2 - 4 for each subscriber who will receive notifications.

Set Up the Monitoring Frequency
You can select how often Sage InstallationManager checks for updates. When a new update is available,
the people who are set up for a subscription to new updates (see “Set Up Email Notifications and
Subscribers”, above) will be notified.

NOTE: Sage will continue to send email notification of new updates.

1 In theChange Settingswindow, click the Frequency tab, then [Settings].

2 Select whether you want the system to check for new updates every 7, 14, or 28 days. The default
setting checks for updates every 7 days.

Enable Automatic Downloads
You can set up Sage InstallationManager to automatically download new updates to your server when
they become available. Downloading Sage 300 Construction and Real Estate updates will not affect your
server’s performance or function.

1 In theChange Settingswindow, click theDownloads tab, then [Settings].

2 Select whether to enable the system to automatically download Sage 300 Construction and Real Estate
updates to your server. Automatic downloads are enabled by default.

Set Up Administrator Credentials
The account logon you use for Sage InstallationManager must have administrator privileges on the server
and all workstations that will receive updates.

1 In theChange Settingswindow, click theAdministrator Credentials tab, then [Settings].

2 Enter theDomain, User Name, andPassword you use as your administrator logon.
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Work with Sage Installation Manager
Installing updates with Sage InstallationManager is a simple process:

a Download the update to your server.

b Install the update on your server.

c Install the update on your workstations.

Things to know before you begin working with Sage InstallationManager:

n We recommend that you restart your workstations before you install updates. You can use Sage
InstallationManager to restart workstations.

n All servers and workstations on your systemmust have the same version of Sage 300 Construction and
Real Estate (including updates). If you install an update on your server, workstations will not be able to
connect to Sage 300 Construction and Real Estate until they have installed the same update.

n You can use the notification feature to let workstation users know that an update is pending.

n Typical installations may take several minutes for the server and each workstation.

n If an update does not install on a particular workstation, Sage InstallationManager sends a notice to
subscribers of Installation Error and logs the error on theCheck workstation status pane. The
system will then attempt to install the update on the next workstation.

n You can review a detailed log for each workstation installation on theCheck Workstation Status pane.

n An overview of the server and workstation updates is provided inReview update history.

Check for Updates
When a new Sage 300 Construction and Real Estate update becomes available, the system notifies those
teammembers who have a subscription for new update availability. See “Set Up Email Notifications and
Subscribers” on page 40.

Set up the frequency with which the system checks for updates inChange settings > Frequency. You
can also check for new updates at any time. Click Manage updates > [Check]. If an update is available,
it will appear in theUpdates pane.

You can learn about the content of an update by clicking it inManage updates, then clicking [Details].
TheDescription lists the items and features that are included in the update.

Download an Update to the Server
Downloading updates to your server is automatic if you enabled automatic downloads inChange Settings
> Downloads. If you have not enabled automatic downloads, you canmanually download an update to
your server:

1 In theManage Updateswindow, select the new update and click [Download].

2 The system sends amessage on completion of the download if you set up email notification inChange
settings > Email Notifications tab > [Settings].
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Notify Workstation Users
After an update has been installed on the server, workstation use is not permitted until the same update
has also been installed to the workstations. Send amessage to workstation users notifying them that an
update is pending, and that they should restart their workstations at a scheduled time.

1 Click Manage updates > [Send Message].
[Send Message] becomes available when you have selected an update or a workstation.

2 Type amessage; for example, “A new update will be installed on your workstation tonight. Please close
all Sage 300 Construction and Real Estate applications before leaving for the day.” Messages have a
100 character limit.

3 Select the workstations that you want to receive themessage. All available workstations are selected
by default.

4 Click [Send].

Install an Update on the Server
1 In theManage updates pane, select the update.

2 Click [Install Server].

3 Follow the prompts to install the update.

4 View the status of the installation in theUpdates pane.
Select Show Completed to view the status of updates that have been installed on the server and all
workstations.

5 The system sends amessage to subscribers of Installation Successful when the update has been
installed on the server and workstations.

Install an Update on Workstations
We recommend that you check the status of all workstations before installing an update. OpenCheck
workstation status to verify that all available workstations are online.

1 In theManage updates pane, select the update.

2 Click [Install Workstations].

3 View the status of the installation in theUpdates pane.
Select Show Completed to view the status of updates that have been installed on the server and all
workstations.

4 The system sends amessage to subscribers of Installation Successful when the update has been
installed on all available workstations.
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Restart a Workstation
You can restart a workstation remotely using Sage InstallationManager. We recommend that you
communicate with the workstation user prior to restarting their computer.

1 Select a workstation in theManage updates pane.

2 Click [Restart].

3 Click [OK] when prompted to restart the workstation.

4 A message is displayed on the selected workstation advising the user to save their work.

5 After a 30-second delay, the workstation is restarted.

Initiate a Remote Desktop Session
1 In theManage updates pane, select a workstation.

2 Click [Remote Desktop] to openMicrosoft Remote Desktop for the selected workstation.

Upgrading Data
If a data upgrade is necessary, it must be performed using Tools > Upgrade Files. See “E. Upgrade data
files,” on page 21 for detailed information on performing data upgrades.
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Chapter 5: Server Migration
The server and datamigration tool enables you to easily copy and transfer your Sage 300 Construction and
Real Estate Accounting data and customizations to a new server. Items transferred include:

l Company data
l Security settings
l Custom fields
l User formulas
l Reports and reports menu
l Inquiries
l Macros
l Attachments

You can select which companies you want to copy, giving you the flexibility to include all companies or
only selected companies.

TIP: Click [Help] in any of the server migration windows for more information.

Things to know before you begin
n Youmust first install Sage 300 Construction and Real Estate Accounting version 13.1 on your new

server to access the server migration tool.

n The server migration process copies data from the old server to the new server. Data is not
removed from the old server.

n You canmigrate data from Sage 300 Construction and Real Estate version 9.6 or later.

n Youmust have administrative rights to the new server and aminimum of read permission to the old
server.

n Your new server must have enough disk space to hold the information from the old server.

n If you added reports to theReportmenus on your old server usingmapped drives, create identical
drivemapping for reports on your new server before performing themigration.

n Macros that you want to migratemust be in theCompany folder on the old server prior to migration.
You can copy themacros to theCompany folder, if necessary. If themacros are not in the
Company folder, you will need to recreate them on the new server after themigration.

n If you are using File Locations (File>Company Settings>File Locations) and the path to the file
points to the old server location, you should update this path prior to upgrading your data. During a
data upgrade, the program follows the path selected in File Locations to upgrade the data file. If that
path is the old location, data files in the old location/server are upgraded instead of data in the new
location/server.

n We recommend that you perform a test migration, then validate that all of your data, reports,
macros and settings work properly on the new server. You can then stop work on the old server and
perform themigration again with the latest files.



n Themigration will overwrite companies and security on the new server. You should perform the
migration before setting up companies and security (for example, before setting up a new job).

n Most of themigration tasks are performed in a few minutes. However, moving attachments can
takemore time. If you have a large number of attachments, consider transferring them during non-
business hours.

n Estimating and Document Management items are not included in themigration.

n Estimating and Document Management items are not included in themigration. For additional
information, access the Support Portal at https://support.na.sage.com, log on, and search for the
following Knowledgebase articles:

n Document Management—Article ID: 22160

n Estimating—Article ID: 23263

n Migration—Article ID: 22043

After youmigrate your server, youmust uninstall and then reinstall Sage 300 Construction and Real
Estate on all workstations so they interact with the data on the new server instead of the old.

Recommended Procedure

Preparing your new server
If you have not already installed and run Sage 300 Construction and Real Estate, do so now.

1. Install Sage 300 Construction and Real Estate Accounting version 13.1 on your new server.

2. Click Start > All Programs > Sage > Sage System Verifier.

3. In theSage System Verifierwindow, click [Scan System].

4. When the system verification has completed, click [Close].

5. Set up administrative rights on the new server.

6. Set up existing or new printers on your new server. The TS PDF printer cannot be the only printer on
your system and cannot be selected as the default.

Migrating your server
1. On the new server, open your program files folder and \Timberline Office\Shared, and then

double-click Sage.STO.ServerMigrator.exe.

2. In theServer Migration Tool window forOld server location, type the path or browse to the
location where Sage 300 Construction and Real Estate installed on your old server.
For example: \\oldservername\Timberline Office\9.5

3. Verify or change the server migration log path (on the new server) for Log file path. For example:
\\newservername\Timberline Office\9.5\Accounting\Migration\ServerMigrationLog 1.pdf

4. Click [Validate] to perform a test of the files to be transferred.
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5. When you see theValidation completemessage and the validation is successful, click [Migrate].

6. When you see theMigration completemessage, view the server migration log (that you set up in
Step 3) to ensure that all files were transferred correctly.

Migrating your data folders
1. On the new server, open your program files folder and \Timberline Office\Shared, and then

double-click Sage.STO.ServerDataMigrator.exe.

2. In theServer Data Locationwindow, verify or change the data folder migration log name and path
(on the new server) for Log file path. For example:\\newservername\Timberline
Office\9.5\Accounting\Migration\ServerDataMigrationLog 1.pdf

3. Select the companies whose data you want to copy.

4. Click [Validate] to perform a test of the files to be copied.

5. When you see theValidation completemessage and the validation is successful, click [Migrate
data folders].

6. When you see theMigration completemessage, view the server datamigration log (that you set
up in Step 2) to ensure that all files were copied correctly.

Migrating your macros
Any macros that you havemust be in the Company folder on the old server prior to migration. You can
copy themacros to the Company folder, if necessary. If themacros are not in the Company folder, you will
need to recreate them on the new server after themigration.

1. If theServer Data Locationwindow is not already open on the new server, open your program files
folder and \Timberline Office\Shared, and then double-click Sage.STO.ServerDataMigrator.exe.

2. In theServer Data Locationwindow, verify or change themacromigration log name and path (on
the new server) for Log file path. For example: \\newservername\Timberline
Office\9.5\Accounting\Migration\MacroMigration.pdf

3. Select the companies whosemacros you want to copy.

4. Click [Migrate Macros].

5. In theMacro Printer Listwindow, verify the printers that you want to use are listed. Click
[Change] if you want to select different printers.

6. Click [Migrate Macros].

7. When you see theMacro migration completemessage, view themacromigration log (that you
set up in Step 2) to ensure that all macros were transferred correctly.
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Migrating your attachments

NOTE: Migrating attachments can take some time. If you have a large number of attachments, you
may want to consider migrating them during non-business hours.

1. If theServer Data Locationwindow is not already open on the new server, open your program files
folder and \Timberline Office\Shared, and then double-click Sage.STO.ServerDataMigrator.exe.

2. In theServer Data Locationwindow, verify or change the attachment migration log name and path
(on the new server) for Log file path. For example: \\newservername\Timberline
Office\9.5\Accounting\Migration\AttachmentMigration.pdf

3. Select the companies whose attachments you want to copy.

4. Click [Migrate attachments].

5. In theAttachment Pathswindow, review the table showing the old and new locations for each set
of attachments. You can change the new location.

a. If you want to change the new attachment path for all rows to the default location on the new
server, click [Use default location].

b. If you want to replace portions of the new paths in specific rows, select the check box in
front of the rows that you want to change, click [Replace selected], type the old text (for
Find), type the new text (forReplace), and then click [OK].

c. If you want to change the new path for one row, either:

l Click in theNew attachment path column and type the new path.

l Click [Change], specify the new path, and then click [OK].

6. When the rows display the desired new attachment paths, click [Migrate attachments].

7. When you see theAttachment migration completemessage, view the attachment migration log
(that you set up in Step 2) to ensure that all attachments were transferred correctly.

Updating your workstations
After youmigrate your server, youmust uninstall and then reinstall Sage 300 Construction and Real
Estate on all workstations so they interact with the data on the new server instead of the old.

1. On the workstation, uninstall the program by opening theControl Panel, selectingUninstall a
program, right-clickingSage 300 Construction and Real Estate and selectingUninstall.

2. Follow the instructions on page 20 for installing Sage 300 Construction and Real Estate on a
workstation.

3. Repeat these steps for every workstation running Sage 300 Construction and Real Estate.
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General information
For information about system requirements, prerequisites, and details about installing Sage 300
Construction and Real Estate , see “Chapter 1: System Requirements” on page 3.

We strongly recommend that you use third-party software to back up all Sage 300 Construction and Real
Estate data files to external media on a daily basis.

NOTE: For information about backing up Document Management, see the Document Management
User's Guide.

Consider the following as you develop your backup plan:

n Use third-party backup software for all backups.

n Verify that when a folder is included in a backup, the backup software also includes the subfolders. The
backup software should support recursive backups.

n Schedule the backup during off-peak hours, since all users must close Sage 300 Construction and Real
Estate before you back up files.

n Always back up your entire Sage 300 Construction and Real Estate dataset. Do not perform
incremental backups.

n Review the backup to be sure all data has been included. Back up all data and files, even if they are
outside the default folders. For most Accounting andManagement products, you can see a list of folders
that are outside the current data folder.

In TS-Main, select File > Company Settings > File Locations and review entries in theData Folder
column.
In the Sage 300 Construction and Real Estate Desktop Tasks pane, click Timberline Office >
Common Tasks >
File > Company Settings > File Locations.

n Back up all data and application files within the Sage folder:

p On XP andWindows 2003–[Drive:]\Documents and Settings\All Users\Application Data\Sage

p On Vista, Windows 2008, and Windows 7–[Drive:]\Program Data\Sage

n Store backupmedia in a secure location outside your building.

n Test backups by restoring them to test folders. These tests are important because backupmediamay
have a limited life, backup devices may malfunction, and youmay have incorrect software settings in
your backup software.

CAUTION: When you test a backup, keep the restored data separate from your production data.

http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html
http://cdn.na.sage.com/SageMail/zCREDocs/CREDocs.html


Follow Special File Tools Instructions for Inventory, Purchasing, and Service
Management

Follow these instructions when you use File Tools with Inventory, Purchasing, and ServiceManagement.

n To perform File Tools operations on Inventory or Purchasing files, start File Tools from TS-Main,
Desktop, or another Accounting andManagement product and include the POIV Data folder in the File
Tools operation. You cannot start File Tools from Inventory or Purchasing.

n To perform File Tools operations on ServiceManagement files, start File Tools from TS-Main, Desktop,
or another accounting andmanagement product and include the SMData folder in the File Tools
operation. You cannot start File Tools from ServiceManagement.

NOTE: To use Sage 300 Construction and Real Estate, users must have full control of the
Pervasive installation folder and subfolders. For information on using Pervasive, see “Pervasive
Database Engines” on page 51.

Do Not Actively Scan Pervasive Program Files, Sage 300 Construction and Real Estate
Program Files, or Sage 300 Construction and Real Estate Data Files for Viruses

IMPORTANT: Scan these files at a time when they are not in use (for example, schedule a daily
scan overnight).

If you actively scan Pervasive program files, Sage 300 Construction and Real Estate program files, or
Sage 300 Construction and Real Estate data files for viruses, this may cause Sage 300 Construction and
Real Estate to run slowly or to close unexpectedly. Typical folders that contain files that you should not
scan include:

n Sage 300 Construction and Real Estate program files: (for example, [Drive]:\Program
Files\Timberline Office)

n Sage 300 Construction and Real Estate data files: (for example, [Drive]:\TSData)

n Pervasive program files:

Windows XP and Server 2003: C:\Program Files\Pervasive Software
C:\Documents and Settings\All Users\Application Data\Pervasive Software

Server 2008, Vista, andWindows 7: C:\Program Data\Pervasive Software

Windows User Account Control (UAC)

Sage 300 Construction and Real Estate is designed to work with theWindows User Account Control
(UAC) security scheme. WithWindows Vista, Windows 7, andWindows Server 2008, you cannot save a
file to a folder to which you do not have read/write permissions assigned. If such an attempt is made,
Windows security diverts your data to a copy of the data file or report and associates the copy with your
user profile, thereby possibly compromising the integrity of your application. To prevent this, Sage 300
Construction and Real Estate applications present you with an error message if you try to save a file to
such a location. See page 54 for more information about moving your data folders for compliance with
UAC.
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Accounting and Management Products
n New installations of Sage 300 Construction and Real Estate onWindows Vista, Windows 7, or
Windows Server 2008 operating systems will place data files in the [Drive]:\ProgramData\Timberline
Office folder.

n New installations onWindows XP orWindows Server 2003 will place data files in the
[Drive]:\Documents and Settings\All Users\Application Data\Sage\Timberline Office folder.

n Upgrades to existing installations onWindows XP orWindows Server 2003 will not move existing data
folders. You do not need tomove your data folders in this scenario.

n Upgrades to existing installations onWindows Vista, Windows 7, orWindows Server 2008 require you
to share the data folders and assign read/write permissions or move the folders to a shared location and
assign read/write permission to the shared location.

NOTE: You can share the data files before installing the upgrade. You canmove data folders after
completing the upgrade installation. If youmove your data files and you use File Locations (File >
Company Settings > File Locations) to allow other data folders to access the folder's data files, be
sure you update the locations using File Locations for each affected data folder.

If you install in a client/server environment, note that theWinInst folder and corresponding Install.exe file
was moved in 9.5. The path to theWinInst folder is:

n Windows XP andWindows 2003: [Drive]:\Documents and Settings\All Users\Application
Data\Sage\Timberline Office\9.5\Accounting\WinInst\Install.exe

n Windows Vista, Windows 7, andWindows 2008: [Drive]:\ProgramData\Sage\Timberline
Office\9.5\Accounting\WinInst\Install.exe

Estimating Products

If you are upgrading Sage 300 Construction and Real Estate Estimating, all of the Sage 300 Construction
and Real Estate Estimating data files and reports previously residing in the Program Files folder will be
copied automatically to a shared location.

n InWindows Vista, Windows 7, andWindows Server 2008, these files will be copied to the
[Drive]:\Users\Public\Estimating folder.

n InWindows XP andWindows Server 2003, these files will be copied to [Drive]:\Documents and
Settings\All Users\Estimating folder.

After installation, verify your application operates correctly and you have access to your data then remove
the original data files from the Program Files folder.
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View Hidden Folders

Some folders may be hidden. To view them on:

l Windows XP Professional orWindows Server 2003: OpenWindows Explorer, select Tools >
Folder Options, click theView tab, and then select theView hidden files and folders check
box.

l Windows Vista, Windows 7, orWindows Server 2008: OpenWindows Explorer, select Organize
> Folder and Search Options, click theView tab, and then select Show hidden files and
folders.

l Windows 8 orWindows Server 2012: OpenWindows Explorer, click theView tab, and then select
theHidden items check box.

Do Not Use NTFS File Compression on Data or Program Files for Sage 300
Construction and Real Estate

UsingMicrosoft Windows NTFS file system to compress files causes Sage 300 Construction and Real
Estate to run very slowly.

Terminal Services

Configure Terminal Services to Maintain an Operator’s Session During Connection
Breaks

Configuring terminal services tomaintain an operator’s session during connection breaks prevents a
program from closing unexpectedly and helps preserve data integrity. To set up this aspect of Windows
Terminal Services, use the Terminal Services Configuration program.

For more information about using terminal services, see “Terminal services” on page 56

Do Not Use Fast User Switching

Sage 300 Construction and Real Estate does not support fast user switching onWindows XP, Windows
Vista, andWindows 7.

Pervasive Database Engines

The Pervasive database engines provide access to Sage 300 Construction and Real Estate data files. To
use Sage 300 Construction and Real Estate, users must have full control of the Pervasive installation
folder and subfolders.

Do Not Use the Subst or Netdrv Commands in Windows

The Subst and Netdrv commands may cause Pervasive status code 11 or 116 errors.

Do Not Exclusively Use the NetBEUI Network Protocol

Wedo not support the NetBEUI network protocol. If NetBEUI is your only network protocol, youmust
install TCP/IP before you install Sage 300 Construction and Real Estate. If no applications require the
NetBEUI protocol, consult with a network technician about removing it.
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Firewalls and Sage Service Host

Beginning with Sage 300 Construction and Real Estate version 9.5, the Sage Service Host uses TCP
instead of named pipes for inter-machine communication. Sage Service Host is aWindows service that
runs on Sage 300 Construction and Real Estate servers and workstations. This service facilitates
communication between Sage 300 Construction and Real Estate applications.

If you useWindows Firewall, you do not need to take any action, as Windows Firewall is configured during
installation to work correctly with Sage 300 Construction and Real Estate. However, if you use a non-
Windows firewall, youmay need tomanually adjust some settings in order to ensure proper performance.

Setting Up Sage Service Host on Firewalls Other Than Windows Firewall

If you use a firewall other thanWindows Firewall, youmay be prompted during installation that the Sage
Service Host is attempting to access the internet or is attempting to act as a server. The Sage Service
Host must be given permission to perform these types of activities.

If you need tomanually set up this exception, make the following changes on every machine where Sage
300 Construction and Real Estate is installed:

n Set up your firewall to allow an exception for the Sage Service Host. Refer to theWindows Firewall
instructions below and your firewall documentation for specific instructions.

n If you have other software that uses TCP ports 8101 and 8102, youmay need tomanually configure
either the other software or the Sage Service Host to use different port numbers.

The Sage Service Host port numbers can be configured in theSage.STO.9.5.xml file. This file is
located inDocuments and Settings\All Users\Application
Data\Sage\LS1\ServiceHost\1.0\Configuration. If you need to change the default port numbers for
Sage Service Host, this file should be changed on every machine on the network where Sage 300
Construction and Real Estate is being installed, including the accounting server.

Setting Up Sage Service Host on a Windows Firewall

Windows Firewall is automatically configured during installation to work correctly with Sage Service Host.
However, if you need tomanually set up Sage Service Host to communicate on aWindows Firewall, do
the following:

n OpenWindows Firewall and select theExceptions tab. If Sage Service Host is not on the list, you can
add it by selecting [Add Program], and then browsing to the following path: [Drive]:\Program
Files\Common Files\Sage\LS1\ServiceHost\1.0\ Sage.LS1.ServiceHost.exe.

n By default, the exception is set for any computer on the network. You can adjust this setting by
selecting [Change Scope].

n If you have other software that uses TCP ports 8101 and 8102, youmay need tomanually configure
either the other software or the Sage Service Host to use different port numbers.

The Sage Service Host port numbers can be configured in theSage.STO.9.5.xml file. This file is
located inDocuments and Settings\All Users\Application
Data\Sage\LS1\ServiceHost\1.0\Configuration. If you need to change the default port numbers for
Sage Service Host, this file should be changed on every computer on the network where Sage 300
Construction and Real Estate is being installed, including the accounting server.
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Troubleshooting
This section contains answers to the following questions:

l “If Sage 300 Construction and Real Estate stops responding during the workstation installation,
how can I resolve this?”

l “When I start Estimating or Buyout onmy workstation, amessage that begins with “Unable to
connect to the Address Book database” appears. How do I connect to the Address Book
database?”

l “How do I move Accounting andManagement products from one server to another?” on page 54

l “I upgraded from Sage 300 Construction and Real Estate 9.4. Do I need tomovemy data folders or
reports to comply with User Account Control (UAC) requirements?” on page 54

l “Which Accounting andManagement files weremoved for Sage 300 Construction and Real
Estate?” on page 55

l “Why am I getting an error message when I try to save data or reports?” on page 56

Depending on your service plan, youmay be able to take advantage of the technical support offered by
Sage 300 Construction and Real Estate.

If Sage 300 Construction and Real Estate stops responding during the workstation
installation, how can I resolve this?

Try the following:

n Turn off antivirus software and unnecessary programs before you install.

n Verify that you have full user rights to the parent folder of the application data folders containing files
needed so that Sage 300 Construction and Real Estate can run correctly.

For Accounting andManagement applications, the default location is:

p Windows XP andWindows Server 2003: [Drive]:\Documents and Settings\All Users\Application
Data\Sage.

p Windows Vista, Windows 7, andWindows Server 2008: [Drive]:\Program Data\Sage.

For Estimating applications, the default location is:

p Windows XP andWindows Server 2003: [Drive]:\Documents and Settings\All Users\Estimating.

p Windows Vista, Windows 7, andWindows Server 2008: [Drive]:\Users\Public\Estimating.

When I start Estimating or Buyout on my workstation, a message that begins with
“Unable to connect to the Address Book database” appears. How do I connect to the
Address Book database?

Youmust perform an additional installation and then configure Estimating and Buyout to access shared
Address Book, Job Cost, and tax data.

For instructions about the additional installation, see the ““D. Other Installation Scenarios” on page 30”.
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For instructions about configuring Estimating and Buyout to access shared Address Book, Job Cost, and
tax data, see “Selecting a company data folder for Address Book and Job Cost information” in Estimating
Help or “Select a company data folder for Address Book and accounting information” in Buyout Help.

How do I move Accounting and Management products from one server to another?

Use the server migration tool found in Sage 300 Construction and Real Estate.

CAUTION: Incorrectly moving Sage 300 Construction and Real Estate data folders may severely
damage your system. Sage Software is not responsible for damage to your data caused by
incorrectly moving your Sage 300 Construction and Real Estate data folders. Beforemaking changes
to your Sage 300 Construction and Real Estate data, contact your system administrator for
assistance andmake a backup copy of all valued data.

For detailed instructions, access the Support Portal at https://support.na.sage.com, log on, and search the
Knowledgebase for Article ID 22043.

NOTE: Versions of Sage 300 Construction and Real Estate prior to 9.5 will not install correctly on a
Vista, Windows 2007, or Microsoft Server 2008 operating system.

I upgraded from Sage 300 Construction and Real Estate 9.4. Do I need to move my
data folders or reports to comply with User Account Control (UAC) requirements?

For Accounting & Management applications, you do not need tomove folders to comply with UAC
requirements unless you also install theWindows Vista orWindows Server 2008 operating system.

If you install Vista, Windows Server 2008 orWindows 7, you do not need tomove folders if they are
already shared. If your data and report folders are not already shared, you will need to share the location or
move them to a shared location and then update their location at File > Open Company > [Specify
Folders]. Refer to “Which Accounting andManagement files weremoved for Sage 300 Construction and
Real Estate?” on page 55 for information on folder locations.

The Sage 300 Construction and Real Estate folder continues to exist under Program Files but contains
only the essential binary files required for the applications to operate.

For Estimating applications, your folders will be copied automatically to a shared location during upgrade.

InWindows Vista, these files will be copied to the [Drive]:\Users\Public\Estimating folder.

InWindows XP andWindows Server 2003, these files will be copied to [Drive]:\Documents and
Settings\All Users\Estimating folder.

In Purchasing (PO) and Inventory (IV), if you originally set up your company (data) folder inside the
Program Files folder, your data will not be accessible after you upgrade.

To prevent this issue, you shouldmove your data from the Program Files folder to a different location prior
to upgrading, as described in “Windows User Account Control (UAC) ” on page 49.

Opening Purchasing or Inventory from aworkstation before opening on a server will cause the DSN to be
set incorrectly. After Purchasing or Inventory has been opened at the server, the applications can be
opened at any workstation.

This issue is not specific toWindows Vista or UAC but the solution to resolve it is the same.
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After installation, verify your application operates correctly and you have access to your data, then remove
the original data files from the Program Files folder.

Which Accounting and Management files were moved for Sage 300 Construction and
Real Estate?

Many Sage 300 Construction and Real Estate folders weremoved from the Program Files folder to a
shared location beginning with the 9.5 release. A list of the affected Accounting & Management application
folders is provided in the tables below.

NOTE: Some folders may be hidden. To view them in:

l Windows XP Professional orWindows Server 2003: OpenWindows Explorer, select Tools >
Folder Options, click theView tab, and then select theView hidden files and folders check
box.

l Windows Vista, Windows 7, orWindows Server 2008: OpenWindows Explorer, select Organize
> Folder and Search Options, click theView tab, and then select Show hidden files and
folders.

l Windows 8 orWindows Server 2012: OpenWindows Explorer, click theView tab, and then select
theHidden items check box.

File/Original Location New Location (Windows XP and Windows 2003)

[Program Files]\Timberline
Office\Accounting\Formula

Documents and Settings\All Users\Application
Data\Sage\TimberlineOffice\9.5\Accounting\Formula

[Program Files]\Timberline
Office\Accounting\Inquiry

Documents and Settings\All Users\Application
Data\Sage\TimberlineOffice\9.5\Accounting\Inquiry

[Program Files]\Timberline
Office\Accounting\Report

Documents and Settings\All Users\Application
Data\Sage\TimberlineOffice\9.5\Accounting\Report

[Program Files]\Timberline
Office\Accounting\Template

Documents and Settings\All Users\Application
Data\Sage\TimberlineOffice\9.5\Accounting\Template

[Program Files]\Timberline
Office\Accounting\
[Sample Data Folders]

Documents and Settings\All Users\Application
Data\Sage\TimberlineOffice\Data\[Sample Data Folders]

[Program Files]\Timberline
Office\Accounting\WinInst

Documents and Settings\All Users\Application
Data\Sage\TimberlineOffice\9.5\Accounting\WinInst

[Program Files]\Timberline
Office\Documents

Documents and Settings\All Users\Application
Data\Sage\TimberlineOffice\9.5\Documents
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File/Original Location New Location (Windows Vista and Windows Server 2008)

[Program Files]\Timberline
Office\Accounting\Formula

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Formula

[Program Files]\Timberline
Office\Accounting\Inquiry

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Inquiry

[Program Files]\Timberline
Office\Accounting\Report

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Report

[Program Files]\Timberline
Office\Accounting\Template

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Template

[Program Files]\Timberline
Office\Accounting\
[Sample Data Folders]

ProgramData\Sage\TimberlineOffice\Data\[Sample Data
Folders]

[Program Files]\Timberline
Office\Accounting\Wininst

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Wininst

[Program Files]\Timberline
Office\Documents

ProgramData\Sage\TimberlineOffice\9.5\Documents

Why am I getting an error message when I try to save data or reports?

You cannot save data or report files to a location for which you do not have read/write permissions. This is
to comply withWindows security requirements. To save the file, youmust first have read/write
permissions assigned or else save the file to another location to which you already have these
permissions.

Terminal services
Windows Terminal Services is a component of Microsoft Windows Server. Terminal Services consists of
a terminal server and one or more remote workstations. It enables users to access programs or data stored
on a remote computer by a phone, network, Internet connection, or other communicationmethods.

Remote network connections do not provide adequate bandwidth to run Sage 300 Construction and Real
Estate products without the use of Terminal Services. Terminal Services provides remote users with a
stable and well-performing experience.

NOTE: Youmust use LicenseManager in order to use Estimating with Terminal Services.

IMPORTANT: If you use Citrix MetaFrame, youmust install it before you install Sage 300
Construction and Real Estate.

You can install Sage 300 Construction and Real Estate applications on your terminal server, or you can
use Terminal Services in conjunction with a server for Sage 300 Construction and Real Estate.
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NOTE: Sage does not support the administrative configuration of Terminal Services with Sage 300
Construction and Real Estate products because it is a partially configured version of Terminal
Services.

Printers
General guidelines

Sage 300 Construction and Real Estate supports the use of business-class laser printers.

We no longer support the use of dot matrix printers for printing 1099 andW-2 forms.

Instead, use a laser printer or dot matrix printer. Some reports that use the Crystal Reports® format require
a laser printer. For example, youmust use a laser printer to generate cost and contract invoices (AIA
documents) in Billing, ServiceManagement, Purchasing, and Inventory.

You should use inkjet or bubble jet printers only as backup printers; we do not test inkjet or bubble jet
printers.

Printer driver

We strongly recommend that you use a PCL 5e printer driver.

Most new printers also support a PCL 6 printer driver. A PCL 6 driver supports higher resolutions than a
PCL 5e driver (1200 dots per inch versus 600 dots per inch). However, because of its higher resolution
(and, thus, greater memory needs), PCL-6-based printing uses more toner, is slower, and is sometimes
unstable.

Many printers comewith both PCL 5e drivers and PCL 6 drivers. If your printer does not comewith a PCL
5e driver, your printer manufacturer probably offers one for free online.

Try using the PCL 5e driver first. Switch to a PCL 6 driver only if your printer does not function properly
with a PCL 5e driver.

Margins

The followingmargins work with most laser printers.

Products Top margin Bottom margin Left margin Right margin

Accounting andManagement
products

0.25 inches 0.5 inches 0.25 inches 0.5 inches

Estimating products with
portrait printouts

0.2 inches 0.2 inches 0.3 inches 0.3 inches

Estimating products with
landscape printouts

0.3 inches 0.3 inches 0.2 inches 0.2 inches
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Install, move, or remove Sage 300 Construction and Real
Estate products
Sage 300 Construction and Real Estate uses Microsoft Installer (MSI) for the installation, repair,
modification, and removal of Accounting andManagement Products.

Installation

TheMSI installation occurs automatically when you install Accounting andManagement Products. Use
theMicrosoft® Event Viewer to review the final status of the installation. You can find theEvent Viewer in
theControl Panel > Administrative Tools folder.

Install Accounting andManagement

Install Estimating

Auto-repair feature

This feature occurs automatically when you start an application and does not require any action or
response. MSI tracks important groupings of files that are necessary for an application to run. If an
important component is missing, MSI restores these files from the original installation source.

If MSI detects missing components, youmay notice a brief delay of approximately twominutes while MSI
validates them. In a Sage 300 Construction and Real Estate server configuration, you will be prompted for
the installation DVD unless the installation source was copied and installed from the hard drive. On a
workstation running Sage 300 Construction and Real Estate, the utility retrieves themissing files from the
shared Sage 300 Construction and Real Estate server if a valid network connection exists.

Use theMicrosoft Event Viewer to review the changes made to the installation. You can find theEvent
Viewer in theControl Panel > Administrative Tools folder.

Modify option

Use to add new programs or change program uses. This option is available when you reinstall a currently
installed version of Accounting andManagement Products on the server.

This utility proceeds through the traditional installation routine with the exception that you cannot change
your registration name or client number.

To start the utility, begin the installation process by double-clicking Install.exe . In theAccounting Server
- InstallShield Wizardwindow, selectModify.

Remove utility

Use theRemove utility to permanently remove Sage 300 Construction and Real Estate products from a
server or workstation. For additional information, see “Removing Accounting andManagement products
entirely” on page 59

This utility removes application files and application registry folders which are created during the
application installation process. It does not necessarily return the server or workstation to its original state.
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Files and registry values modified or created during the use of Accounting andManagement products will
still exist (for example, \HKEY_CURRENT_USER\Software\Timberline).

To start the utility, open theWindows Add or Remove Programs option, select Timberline Accounting
Server or Timberline Accounting Client, and then click [Remove].

Removing Accounting and Management products entirely

A complete removal of the Accounting andManagement Products includes running the uninstall program
first, thenmanually deleting the Program folder for Sage 300 Construction and Real Estate, manually
deleting the application data folder for Sage 300 Construction and Real Estate, manually deleting the
Current User registry keys for Sage 300 Construction and Real Estate, and uninstalling any third-party
prerequisite products. If you decide to reinstall after doing a complete removal of Accounting and
Management Products, youmust restore all Accounting andManagement Products folders and files from
a backup and then reinstall the Accounting andManagement Products.

Summary of removal steps
1 Back up the Sage 300 Construction and Real Estate program folder and all company data. Confirm that
the backup was successful before continuing.

2 Remove Sage 300 Construction and Real Estate as described above.

3 UseWindows Explorer to delete the Sage 300 Construction and Real Estate folder (typically installed at
X:\Program Files\Timberline Office).

4 UseWindows Explorer to delete the Sage application data folder (typically installed at
[Drive]:\Documents and Settings\All Users\Application Data\Sage forWindows XP andWindows
Server 2003 and [Drive]:\Program Data\Sage forWindows Vista andWindows Server 2008.

5 (Optional)Use theMicrosoft Registry Editor to delete the registry key \HKEY_CURRENT_
USER\Software\Timberline.

6 UseWindows Add or Remove Programs to remove Pervasive.SQL Server from the Sage 300
Construction and Real Estate Server. UseWindows Add or Remove Programs to remove
Pervasive.SQLWorkgroup from Sage 300 Construction and Real Estate workstations.
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Chapter 7: Security
Security overview
If you havemany people working in your office, youmay not want each one to have access to all the
features of the software. For instance, youmay not want all staff members to be able to print checks or to
print reports that include sensitive data.

You can use the security function in Sage 300 Construction and Real Estate to restrict access to various
areas of the software.

Sage 300 Construction and Real Estate security is set up through the Security Administration tool in
Desktop (Tools > Security Administration).

User types

The Security Administration tool for Sage 300 Construction and Real Estate includes three types of users:
security administrators, application administrators, and Sage 300 Construction and Real Estate users.

n Security administrators set up andmaintain accounts for users. For a complete list of tasks that a
security administrator can perform, see “Setting up security ” on page 69

n Application administrators can restrict access to software features and data that each user has
permission to access. They define roles and assign users to the roles. For a complete list of tasks that
an application administrator can perform, see “Setting up security ” on page 69

n Users’ task permissions are defined by the application administrator. These permissions can range
from none to almost as extensive as an application administrator. Users can have the same level of file
and record access as an application administrator. Users can have access to one or more companies.

n A role represents a group of users who have the same security requirements. A role has its own user
name and its own task, record, file, and company permissions.

The use of roles often saves setup time, because the application administrator can assign permissions
to new users simply by assigning them to an existing role. The use of roles can also clarify your
company's security plan because the application administrator can create roles that correspond to the
company's organizational structure. For example, the application administrator can create roles for
Accounts Payable clerks, Payroll clerks, property managers, and project managers.

Types of security
n Task security restricts access tomenu items and certain tasks. For example, you can control who can
set up vendors in Accounts Payable.

With task security, an application administrator can restrict access tomenu items and certain tasks
found within windows. For example, task security can control access to theSetup > Vendors menu
item in Accounts Payable (AP.) Also, task security can control whether you can approve a change order
in the Item Status field of theEnter Change Order Items - Scope of Change window in Job Cost.



In the following example of task security, an application administrator assigns task permissions based
on the tasks that the employees need to perform.

Role Permission to
AP Settings?

Permission to
Post Invoices?

Permission to
AP Reports?

CONTROL (controller) Yes Yes Yes

APCLERK (AP clerk) Yes Yes

PROJMGR (project manager) Yes

n File security blocks all access to a file and restricts ODBC access. For example, you can restrict
access to sensitive payroll files.

File security allows application administrators to block all access to a file. This includes access through
open database connectivity and through all related tasks, reports, and inquiries. This differs from task
security, which allows application administrators to block tasks selectively and does not allow them to
control ODBC access.

In the following example of file security, a company has two Payroll (PR)master files. One is for the
executive staff and the other is for the field staff. In order to keep the executive payroll information
private, the company creates a separate role for users that handle the executive PR master file.

Role Users Access to Exec
PR Master File?

Access to Field
PR Master File?

EXECPR
(executive payroll)

Controller and a
senior payroll clerk

Yes, for all users
assigned to this role

FIELDPR
(field payroll)

Controller and all
payroll clerks

Yes, for all users
assigned to this role

In this example, the senior payroll clerk is amember of both the EXECPR and FIELDPR roles. A user
can belong tomore than one role.

n Record security controls access to certain records so that reports and inquiries display only the
records to which the user has security access. For example, you can restrict reporting and inquiries on
jobs or bank accounts.

n Company security restricts access to which companies a user can see. Application administrators
can grant a user access to specific companies. Security administrators and application administrators
have access to all companies.

n Application security prevents unauthorized users from accessing Sage 300 Construction and Real
Estate. When application administrators turn on application security, all users must enter a user name
and password to access the software. They can restrict access to software features and data that each
user has permission to access. Security Administration offers four types of application security: task,
file, record, and company.
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Application security also lets application administrators hide applications from users and roles. When an
application administrator uses the Security Administration tool to deny a user or role access to all tasks
in an application and sets securedmenu items to not display, users cannot see the application in TS-
Main or in the Sage Desktop.

Log settings

By default, logging is turned on. Security administrators can turn off Application, Security, orSetup
logging.

TheAudit Setup, Field Report, andSystem logs are required. You cannot turn them off.

ThePosting Recap and Task Summary logs are for future use. No logs are created at this time.

Required Log Log Type Description

No Application Logs the start and end of Accounting applications and tasks.

Yes Audit Setup Logs changes when the audit setup activity is selected in an
Accounting application.

Yes Field Report Logs changes to finalized field reports in Project Management.

Yes Posting Recap Logs recaps created while posting entries in Accounting. (For
future use.)

No Security Logs events in the Security Administration tool.

No Setup Logs changes to setup information in Accounting.

Yes System Logs Accounting system events.

Yes Task Summary Logs summaries created during an Accounting task. (For future
use.)

Applications with Security Administration

The following applications feature Security Administration:

n Accounts Payable n Equipment Cost n Payroll

n Accounts Receivable n Financial Statements n Project Management

n Address Book n General Ledger n Property Management

n Billing n Information Assistant n Remote Time

n CashManagement n Inquiry Designer n Report Designer

n Contacts n Job Cost
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The following applications have limited Security Administration:

n Document Management security features aremanaged in two areas: Security Administration and
Document Management settings. Security administrators manage Document Management users and
roles in Security Administration. Application administrators manage Document Management task
security (inbox, scan queue, and query) in Security Administration. Privileged operators manage
document security and document type security in Document Management settings. For more
information, see Document Management Help.

n Estimating is affected by file security and task security. Application administrators cannot set up
Security Administration for Estimating but, if Security Administration has been set up in one of the
applications listed previously, youmust type a user name and password before you use Estimating.

Estimating offers its own form of file security on estimate and database files. Although similar to
Security Administration, it is different because it is not set up from the Security Administration tool and it
requires a password but not a user name.

n Purchasing and Inventory are affected by task security. Like Estimating, application administrators
cannot set up Security Administration for these applications but youmust type your user name and
password if Security Administration is on. Purchasing and Inventory also offer their own form of task
security. For more information, see Help in these applications.

n Service Management uses task security. Application administrators can create users and roles and
set up task security for ServiceManagement just as you would in the bulleted list of applications above.

Record security
With record security, you can control access to four records:

n CashManagement bank account

n General Ledger prefix

n Job Cost and Project Management job

n Property Management property

In addition, you can select or clear theGive all users access to records with blank security IDs check
box. Select the box if you want records with blank security IDs to be accessible to all users. Clear the box
if you want only application administrators to access these records. For more information, see “Set up
record security” on page 73.

When record security is active, reports and inquiries display only the records to which the user has
access. For more information, see “Effect of record security on reports” on page 64 and see “Effect of
record security on inquiries” on page 66.

Record security also affects Job Cost, Contracts, and Project Management tasks. In these applications,
you can type or select only jobs to which you have access. For more information, see “Effect of record
security on tasks” on page 68.
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Example of using record security

In the following example, a property manager, Accounts Payable (AP) clerk, and Property Management
(PM) clerk work as a team on certain properties. Another project manager, AP clerk, and PM clerk work as
a team on different properties.

With the following record security setup, these employees have access to only their team's properties.

Role Users Access to TEAM1
Properties?

Access to TEAM2
Properties?

TEAM1 Proj Mgr 1
AP Clerk 1
JC Clerk 1

Yes, for all TEAM1 users
assigned to this role

TEAM2 Proj Mgr 2
AP Clerk 2
JC Clerk 2

Yes, for all TEAM2 users
assigned to this role

Effect of record security on reports

When record security is active on a report, the report displays only the records that are accessible to the
current user. Moreover, totals on the report adjust to reflect only the accessible records.

For example, in Job Cost, aCost Entries by Job report (simplified for this example) would look like the
following to an application administrator:

Job Cost Code Category Amount

01-002 3-110 L (labor) 100.00

01-003 2-520 M (material) 350.00

Report Total 450.00

To a user with permissions to only job 01-002, the same report would look like the following:

Job Cost Code Category Amount

01-002 3-110 L (labor) 100.00

Report Total 100.00

NOTE: Some reports list information from several different records on the same line. If you lack
access rights to the report’s driving record (the primary record upon which the report is based), the
report skips the entire line. If you lack access rights to one of the non-driving records, the report skips
only the information from that record.
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Report record security settings

Each report has security settings that control whether record security can affect the report. If you own
Report Designer, you canmodify these settings (Report Designer >Design Security). If you do not own
Report Designer, an application administrator can control record security on reports only by turning on or
turning off record security. (For more information, see “Turn off record security,” on page 78.)

Sage 300 Construction and Real Estate defines the security settings on stock reports based on whether
(a) the report contains sensitive information or (b) the report's content should be tailored to the user. For
example, Sage 300 Construction and Real Estate allows the bank record on the CashManagement Check
Register report to be secured so that, if record security is on, you can generate reports that list only the
entries for the banks to which the current user has access.

In some cases, for practical reasons, Sage 300 Construction and Real Estate does not allow record
security to affect a report. For example, in CashManagement, you can type any bank in data entry tasks
(bank account record security currently only affects reports and inquiries). Therefore, Sage 300
Construction and Real Estate does not secure the bank account record on the CashManagement Journal
report.

Indicators that record security affects a report

Record security always affects a Crystal report, which has a “(CR)” in its name, unless the report uses a
special formula to disable record security. To check for this formula, youmust open the report in Crystal
Decisions Crystal Reports. (You cannot use a Sage 300 Construction and Real Estate application to
check for this formula.) Add to Crystal section or link to/from

NOTE: If you create reports in Report Designer, then you can secure those reports with Security
Administration. Youmust be an application administrator and ownReport Designer to modify
security settings on new report designs.

If you do not own Report Designer: the report's cover page indicates whether record security is on. You
have the following options regarding cover pages:

n If you want to print a cover page every time you print any report, select Tools > Options. On the
Reports tab, select Attach to report.

n If you want to print a cover page only some of the time, youmust choose to print a cover page at the
time of printing. From an applications Toolsmenu, select the report and from thePrint Selection
window, click [Page Setup]. Then select Attach to report.

If you own Report Designer: in addition to the report cover page (see above), record security information
can appear in three additional areas.

n A report's design information (Tools > Design Info) lists the report's record security settings.

n A report's page heading (defined in File > Page Setup > Page Headings) indicates whether record
security is on.

n If you open a report created in Report Designer 7.x or earlier and the report contains secured records,
you will receive an on-screenmessage that lists the secure records on that report. Once you save the
report, you will no longer receive this message.
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Effect of an upgrade on reports

When you upgrade from Sage 300 Construction and Real Estate Accounting products 7.x or earlier to
Sage 300 Construction and Real Estate 8.0 or later, the following changes take place with reports.

Stock Reports

New stock reports replace your existing stock reports. The new reports have settings that control whether
record security can affect the reports. However, these settings take effect only if you activate record
security.

Custom Reports

If you open a custom report created in Report Designer 7.x or earlier, the software displays amessage that
lists the secure records on that report. Once you save the report, you no longer receive this message.

The software alsomodifies the report's security settings. It changes these settings to allow record
security, if active, to affect all securable records on the report.

Youmust use Report Designer to change a report's settings. If you do not ownReport Designer, the only
way to control record security on a report is for an application administrator to turn on or turn off record
security.

Effect of record security on inquiries

When record security for an inquiry is on, the inquiry displays only records that are accessible to the
current user.

For example, in CashManagement, a Bank List inquiry would look like the following to an application
administrator:

Bank Account Description Account Number Register Balance

First First Bank 042134526 56,650.97

Liberty Liberty S&L 874613754 91,450.44

To a user with permissions to only First Bank, the same inquiry would look like the following:

Bank Account Description Account Number Register Balance

First First Bank 042134526 56,650.97

NOTE: Some inquiries list information from several different records on the same line. If you lack
access rights to the inquiry's driving record (the primary record upon which the inquiry is based), the
inquiry skips the entire line. If you lack access rights to one of the non-driving records, the inquiry
skips only the information from that record.
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Inquiry record security settings

Each inquiry has record security settings that control whether record security can affect the inquiry. These
settings take effect in the following scenarios:

n New installations of Sage 300 Construction and Real Estate 8.0 or later.

n Subsequent upgrades of a new 8.0 or later installation.

If you upgrade from Sage 300 Construction and Real Estate Accounting andManagement products 7.x or
earlier to Sage 300 Construction and Real Estate 8.0 or later, these settings do not take effect. Instead,
record security automatically affects your inquiries if it is on. For more information, see “Effect of an
upgrade on inquiries,” on page 67.

Sage 300 Construction and Real Estate selects inquiry record security settings based on whether the
inquiry contains sensitive information or whether its information should be tailored to the user. For
example, Sage 300 Construction and Real Estate allows the bank record on the CashManagement Bank
Register inquiry to be secured so that, if record security is on, your inquiry displays entries for only the
banks to which you have access.

If you own Inquiry Designer, you canmodify inquiry security settings. For more information, see “Change
design security on an inquiry” on page 81.

If you do not own Inquiry Designer, application administrators can control record security on inquiries
only by turning on or turning off record security. For more information, see “Turn off record security,” on
page 78.

Indicators that record security affects an inquiry

A button with a lock on it appears in the upper right corner of the inquiry. If you click this button, a Record
Security window appears that lists which records are secured on the inquiry.

NOTE: In this window, an application administrator can select or clear records to secure. However,
the selections affect only the current user's session. Therefore, selections are inconsequential
because an application administrator already has permission to view all records.

Effect of an upgrade on inquiries

If your Sage 300 Construction and Real Estate Accounting products installation started with 7.x or earlier,
record security affects your stock and custom inquiries to the extent that it is on. (Installations that started
with 8.0 or later are different; see next section). For example, if record security is on for the Cash
Management bank account record and the Job Cost and Project Management job records, these records
are automatically secured on the inquiry. If record security is on for only the CashManagement bank
account record, only this record is secured on the inquiry.

If you own Inquiry Designer, you can specify settings on each inquiry that control whether record security
affects the inquiry.
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Difference between upgrades and new installations

New installations of Sage 300 Construction and Real Estate (and subsequent upgrades) use Sage 300
Construction and Real Estate’s predefined inquiry record security settings. These settings control whether
record security can affect an inquiry. For example, if an inquiry’s settings do not allow CashManagement
bank account record security, this record is not secured on the inquiry (even if record security is on). For an
upgrade, record security automatically affects the bank account record because the inquiry does not use
the predefined record security settings.

Effect of record security on tasks

Record security can restrict access to the job record in certain Job Cost (JC), Contracts (CN), and Project
Management (PJ) tasks. When record security is turned on for jobs, you cannot view a job in a list or type
a job unless you have security access for that job. For example, in thePJ Job Setupwindow (PJ > Setup
> Jobs), when you click [Find] to list jobs that have been previously set up, you see only jobs to which
you have access.

In addition, you can select or clear theGive all users access to records with blank security IDs check
box. Select the box if you want records with blank security IDs to be accessible to all users. Clear the box
if you want only application administrators to access these records. For more information, see “Set up
record security” on page 73.

Job record security affects the following tasks:

Contracts
p Edit > Link

p Edit > Add/Edit JC CO link

p Edit > JC CO Item Link Details

Job Cost
p Setup > Jobs

p Tasks > Enter Estimates

p Tasks > ChangeOrders

p Tasks > Commitments

p Tasks > Commitment ChangeOrders

p Tasks > Enter Misc Worksheets

Project Management

All tasks that involve the job record (for example, job setup and document creation).
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Setting up security
This section contains the tasks that security administrators and application administrators need to perform
to set up security. Some tasks can be performed by either administrator role. Other tasks must be
performed by a specific administrator role. The best practice is for the security administrator to perform
steps 1 through 8 and for the application administrator to perform steps 9 through 13. Steps 6, 12, and 13
are optional.

You can perform task if you have this role: Security
Administrator

Application
Administrator

1 “Turn on security” Yes No

2 “Add a security administrator” Yes No

3 “Add an application administrator” Yes No

4 “Log on” Yes No

5 “Restart Sage 300 Construction and Real Estate” Yes No

6 “Turn off logging” (optional) Yes No

7 “Add roles” Yes No

8 “Add users” Yes No

9 “Add users to roles” Yes Yes

10 “Add tasks to roles” Limited Yes

11 “Grant users access to companies” No Yes

12 “Restrict access to files” (optional) No Yes

13 “Set up record security” (optional) No Yes

Turn on security

To prevent unauthorized users from accessing your software, we recommend that you turn on application
security. When you turn on application security, all users must enter a user name and password to access
the software. Application administrators can restrict access to software features and data that each user
has permission to access.

NOTE: Youmust be a security administrator to turn on security.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Security Settings.

3 Select Turn on application security.

4 Click [OK].
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Add a security administrator

When you turn on security, youmust add a security administrator. Security administrators set up and
maintain accounts for users. For back-up purposes, we recommend adding at least two security
administrators.

To add or change a security administrator later, go toSecurity Administration > User Setup. Youmust
be a security administrator to add another security administrator.

Add an application administrator

When you turn on security, youmust add an application administrator. Application administrators define
roles and assign users to the roles. For back-up purposes, we recommend adding at least two application
administrators.

To add or change an application administrator later, go toSecurity Administration > User Setup.

Log on
1 From the Log Onwindow, type yourUser name.

2 Type yourPassword.

3 Click [Log On].

Restart Sage 300 Construction and Real Estate

For the security settings to take effect, all users must restart Sage 300 Construction and Real Estate.

1 When theRestartmessage appears, click [OK].

2 Close Sage 300 Construction and Real Estate (File > Exit), and then reopen it.

3 Request all users to restart Sage 300 Construction and Real Estate.

Turn off logging

This task is optional.

Security administrators can only turn off Application, Security, orSetup logging.

TheAudit Setup, Field Report, andSystem logs are required. You cannot turn them off.

The Posting Recap and Task Summary logs are for future use. No logs are created at this time.

NOTE: Youmust be a security administrator to turn on logging.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Log Settings.

3 In theOn column, clear the types of logs that you want to turn off.

4 Click [OK].
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Add roles
1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Role Setup.

3 On theRoles pane, click [Add].

4 On theRole Details pane, type theName of the role (for example, AP Clerk.)

5 (Optional) Type theDescription for this role.

6 (Optional)Select the tasks for this role. For more information, see “Add tasks to roles,” on page 72.

7 (Optional)Select the users for this role. For more information, see “Add users to roles” on page 71.

8 Click [Save Changes].

Add users
1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click User Setup.

3 On theUsers pane, click [Add].

4 On theUser Details pane, type theUser name.

5 (Optional) Type the Full name andWindows user associated with the user name.

6 (Optional)On theSettings tab, select theUser Account Settings andPassword Settings.

7 Click theRoles tab, and then select or add roles for the user.

8 (Optional)Click theCompanies tab, and then select the companies for the user. For more information,
see “Grant users access to companies” on page 72.

NOTE: Youmust be an application administrator to grant a user access to companies. If you cannot
perform this step, the application administrator must do it before the user can log on to Sage 300
Construction and Real Estate.

9 Click [Save Changes].

Add users to roles
1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click User Setup.

3 On theUsers pane, select theUser Name.

4 Click theRoles tab, and then select roles for the user.

5 Click [Save Changes].

6 For the change to take effect, the users associated with this role must restart Sage 300 Construction
and Real Estate.
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Add tasks to roles

Application administrators can add all tasks to roles.

Security administrators can only add the following tasks to a role:

p Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

p Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup Activity)

p View System Activity (Tasks > Common Tasks > Security > View System Activity)

p Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit Setup Fields)

You cannot change the tasks for the application administrator and security administrator roles.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Role Setup.

3 On theRoles pane, select the role that you want to edit.

4 On theRoles Details pane, click the Tasks tab.

5 In the tasks tree, navigate to the tasks or sub-tasks that you want to add and select the tasks.

6 Click [Save Changes].

7 For the change to take effect, the users associated with this role must restart Sage 300 Construction
and Real Estate.

Grant users access to companies

Youmust be an application administrator to grant a user access to companies.

Security administrators and application administrators have access to all companies.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Company.

3 On theCompanies pane, select theCompanyName to which you want to add users.

4 On theCompany Security Details pane, click [Add].

5 In theCompany Setup - Add Users window, select the users.

6 Click [OK].

7 Click [Save Changes].

8 For the change to take effect, the user associated with this company must restart Sage 300
Construction and Real Estate.
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Restrict access to files

This step is optional.

NOTE: Youmust be an application administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Files.

3 Select theCompany for which you want to restrict access to files.

4 Select theRole that will have access to the corresponding File Name.

5 Click [OK].

6 After securing a file, make sure that users can still perform their required tasks.

7 For the file restriction to take effect, all users not assigned to the role must restart Sage 300
Construction and Real Estate.

Set up record security

This step is optional.

NOTE: Youmust be an application administrator to perform these tasks.

Setting up record security
1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, select Records. TheRecord Security window opens.

3 On theActivation tab, select Activate record security.

4 Select or clear theGive all users access to records with blank security IDs check box. Select the
box if you want records with blank security IDs to be accessible to all users. Clear the box if you want
only application administrators to access these records.

5 In theSecurable record types box, select the records that you want to secure.

Assigning security IDs to records
1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, select Records. TheRecord Securitywindow opens.

3 Select the tab for the record to which you want to assign security IDs.

4 In theSecurity ID column, type the ID of a role. You can type only a single ID.

5 Click [OK].

NOTE: Record tabs in theRecord Securitywindow are accessible only if you have turned on
record security for that record on theActivation tab.
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Modifying security
This section contains the following topics:

n “Change password settings” on page 74

n “Delete a user” on page 76

n “Delete a role” on page 76

n “Copy a user” on page 77

n “Copy a role” on page 77

n “Turn off security” on page 77

n “Remove file restrictions” on page 78

n “Turn off record security” on page 78

n “Turn on tasks” on page 78

n “Turn off tasks” on page 79

n “Add a role to a task” on page 79

n “Remove a role from a task” on page 79

n “Restrict access to files” on page 80

n “Restrict access to additional files” on page 80

n “Modify record security permissions” on page 81

n “Change design security on reports” on page 81

n “Change design security on an inquiry” on page 81

n “Review record security settings” on page 82

Change password settings

NOTE: Youmust be a security administrator to change the password settings.

When you turn on security, youmust set up password strengths and requirements for all users. To change
these settings later, go toSecurity Administration > Security Settings.

To change the password settings for a user name, go toSecurity Administration > User Setup >
Settings.

For the password settings to take effect, all users must restart Sage 300 Construction and Real Estate.
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Set strong passwords

To prevent unauthorized users from accessing your software, we recommend that you require strong
passwords. Strong passwords must meet the following conditions for complexity:

n Passwords must be at least eight characters long.

n Passwords must contain at least three of the following four character groups:

p English uppercase characters (A through Z)

p English lowercase characters (a through z)

p Numbers (0 through 9)

p Special characters (~ ! @ # $ % ^ & * ( ) - + = { } [ ] | \ : ; < , > . ? /)

n Passwords expire every 90 days.

n You are warned 10 days before your password expires.

n You cannot reuse your three previous passwords.

n Youmust wait 10 days before changing your password.

When you turn on security, the password settings default to these strong password conditions.

Change password strengths and requirements for all users

NOTE: Youmust be a security administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Security Settings.

3 If security is turned off, select Turn on application security.

4 InPassword Settings, move the slider to select the password strength.

5 If you chooseCustom, set the requirements.

a Click [Custom Password Settings].

b From thePassword Settingswindow, clear the options that you do not want or change the
requirements for the settings.

c Click [OK].

6 Click [OK].

7 If you are strengthening the password requirements, the followingmessage appears, “Existing
passwords may not meet the new requirements. Do you want users to create new passwords the next
time they log on?” Click [Yes].

8 For the password settings to take effect, all users must restart Sage 300 Construction and Real Estate.
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Change password settings for a user name

NOTE: Youmust be a security administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click User Setup.

3 On theUsers pane, select theUser Name for which you want to change the password settings.

4 On theUser Details pane, click theSettings tab.

5 Select or clear thePassword Settings options.

6 If you want to add or change the password for the user, do the following:

a Click [Set Password].

b From theSet Passwordwindow, type the same password in thePassword andConfirm password
fields.

c Click [OK].

NOTE: When you add or change the password, theUser must change password at next log on
option is automatically selected.

7 Click [Save Changes].

8 For the password settings to take effect, the user must restart Sage 300 Construction and Real Estate.

Delete a user

NOTE: Youmust be a security administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click User Setup.

3 On theUsers pane, select theUser Name that you want to delete.

4 Click [Delete].

5 When you receive a confirmationmessage, click [Yes].

Delete a role
1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Role Setup.

3 On theRoles pane, select the role that you want to delete.

4 Click [Delete].

5 When you receive the confirmationmessage, click [Yes].
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Copy a user

Use the copy feature when you want a new user to have the same permissions as an existing user.

NOTE: Youmust be a security administrator and an application administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click User Setup.

3 On theUsers pane, select theUser Name that you want to copy.

4 Click [Copy].

5 On theUser Details pane, type theUser name.

6 (Optional) Type the Full name andWindows user associated with the user name.

7 Click [Save Changes].

Copy a role

Use the copy feature when you want a new role to have the same tasks and users as an existing role.

NOTE: Youmust be an application administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Role Setup.

3 On theRoles pane, select the role that you want to copy.

4 Click [Copy].

5 On theRole Details pane, type theName of the role (for example, AP Clerk.)

6 (Optional) Type theDescription for this role.

7 Click [Save Changes].

Turn off security

NOTES:

l Youmust be a security administrator to turn off application security.

l To prevent unauthorized users from accessing your software, we recommend that you leave
application security turned on.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Security Settings.

3 Clear Turn on application security.

4 Click [OK].

5 For the security settings to take effect, all users must restart Sage 300 Construction and Real Estate.

Sage 300 Construction and Real Estate User's Guide                                                                                                        Page 77

Chapter 7: Security



Remove file restrictions

NOTE: Youmust be an application administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Files.

3 Select theCompany for which you want to remove a file restriction.

4 In theRole column for the corresponding File Name, select (None.)

5 Click [OK].

6 For the file setting to take effect, all users must restart Sage 300 Construction and Real Estate.

Turn off record security

NOTE: Youmust be an application administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, select Records. TheRecord Security window opens.

3 Select theActivation tab.

4 If you want to turn off all record security, clear theActivate record security check box.

5 If you want to turn off record security for a particular record, clear the check box for that record.

6 Click [OK].

NOTES:

l When you turn off record security, theSecurity ID field disappears from related record setup
windows. However, Sage 300 Construction and Real Estate security saves your security ID
assignments. If you reactivate record security, these settings take effect again.

l In addition to record security settings in Security Administration, each Sage 300 Construction and
Real Estate report and inquiry has record security settings.

Turn on tasks
1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Tasks.

3 On the Tasks pane, navigate to the tasks or sub-tasks that you want to turn on.

4 On the Task Security Details pane, clear Turn off task.

5 Click [Save Changes].

6 For the task settings to take effect, all users must restart Sage 300 Construction and Real Estate.
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Turn off tasks

NOTE: You cannot turn off tasks for the security administrator and application administrator roles.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Tasks.

3 On the Tasks pane, navigate to the tasks or sub-tasks that you want to turn off.

4 On the Task Security Details pane, select Turn off task.

5 If theRestart Sage 300 Construction and Real Estatemessage displays, click [OK].

6 Click [Save Changes].

Add a role to a task

Application administrators can add roles to all tasks.

Security administrators can only add roles to the following tasks:

p Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

p Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup Activity)

p View System Activity (Tasks > Common Tasks > Security > View System Activity)

p Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit Setup Fields)

To add a role to a task:

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Tasks.

3 On the Tasks pane, navigate to the task or sub-task to which you want to add a role.

4 On the Task Security Details pane, select the roles that you want to add.

5 Click [Save Changes].

Remove a role from a task

Application administrators can remove roles from all tasks.

Security administrators can only remove roles from the following tasks:

p Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

p Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup Activity)

p View System Activity (Tasks > Common Tasks > Security > View System Activity)

p Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit Setup Fields)

To remove a role from a task:

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Tasks.
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3 On the Tasks pane, navigate to the task or sub-task that you want to remove from a role.

4 On the Task Security Details pane, clear the roles.

5 Click [Save Changes].

Restrict access to files

NOTE: Youmust be an application administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Files.

3 Select theCompany for which you want to restrict access to files.

4 Select theRole that will have access to the corresponding File Name.

5 Click [OK].

6 After securing a file, make sure that users can still perform their required tasks.

7 For the file restriction to take effect, all users not assigned to the role must restart Sage 300
Construction and Real Estate.

Restrict access to additional files

Application administrators will only see additional files if named files are selected for a securable file type
(Sage 300 Construction and Real Estate > Common Tasks > File > Company Settings > File
Locations > Ask Name.)

NOTE: Youmust be an application administrator to perform this task.

To restrict a file that is not in the File Security Setup grid:

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, click Files.

3 Select theCompany for which you want to restrict access to files.

4 Click [Find Files].

5 From the File Security Setup - Find File window, select the File Type.

6 Click [OK].

7 Browse to the file location and select the File name that you want to restrict.

8 Click [Open]. The file is added to the grid.

9 Select the Role that will have access to the corresponding File Name.

10 Click [OK].

11 After securing a file, make sure that users can still perform their required tasks.

12 For the file restriction to take effect, all users not assigned to the role must restart Sage 300
Construction and Real Estate.
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Modify record security permissions

Change the security ID in a Record Security window

NOTE: Youmust be an application administrator to perform this task.

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, select Records. TheRecord Securitywindow opens.

3 Select the tab for the record you want to change.

4 In theSecurity ID column, change the security ID.

5 Click [OK].

NOTE: Record tabs in the Record Securitywindow are available only if you have turned on record
security for that record.

Change the security ID in a Record Setup window

NOTE: Youmust be an application administrator or have security access to the Change Security
ID task.

1 Open the record setup window of a securable record (CashManagement bank account, General Ledger
prefix, Job Cost and Project Management job, and Property Management property.)

2 Click theSecurity ID field and change the ID.

Change design security on reports

NOTE: Youmust be an application administrator to modify report design security.

1 Start Report Designer.

2 Open the report design (File > Open Design.)

3 From the Tools menu, select Security > Design.

4 In theDesign Record Security box, select or clear the check boxes.

5 Click [OK].

NOTE: TheDesign Record Security box lists all available records regardless of whether the report
uses all the records. If record security is off, the check box for that record will be unavailable.

Change design security on an inquiry

NOTE: Youmust be a application administrator to modify the inquiry design security.

1 Start Inquiry Designer.

2 From the Inquirymenu, select Inquiry Manager.

3 In theApplicationswindow, select an application and click [OK].

4 In the Inquiry Managerwindow, select the inquiry; then click [Change].
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5 In theChange Inquirywindow, click [Record Security].

6 In theRecord Securitywindow, select or clear the check boxes.

7 Click [OK] in successive windows; then click [Close].

NOTE: TheRecord Securitywindow lists all available securable records regardless of whether the
inquiry uses all the records. If record security is not selected, the check box for that record will be
unavailable.

Review record security settings

NOTE: Youmust be an application administrator to perform this task

1 From the Sage Desktop, select Tools > Security Administration.

2 On theSecurity Administration tab, select Records. TheRecord Securitywindow opens.

3 Review the selections on theActivation tab. They control whether record security is on and how the
software interprets blank security IDs.

4 Select one of the record tabs.

5 Review the users and roles in theSecurity ID column.

6 Repeat steps 4 and 5 for each record.

NOTE: Every report and inquiry has settings that control whether record security can affect the
report or inquiry.
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Troubleshooting security
This section contains information about the following issues:

l “I cannot see a security ID in a Record Setup window”

l “I cannot change a security ID in a Record Setup window”

l “I know a job was set up, but I cannot see it in the software”

l “I forgot my password” on page 84

l “My report or inquiry is missing information” on page 84

l “Menu items and fields are unavailable” on page 84

l “I cannot delete a user name” on page 84

l “I cannot make an account unavailable” on page 85

l “I cannot end account availability” on page 85

l “I cannot remove a user name” on page 85

l “I cannot turn on security” on page 85

l “I cannot save changes” on page 86

I cannot see a security ID in a Record Setup window

TheSecurity ID field appears in a record setup window only if record security is on for that record. For
more information, see “Set up record security” on page 73.

I cannot change a security ID in a Record Setup window

During the setup of a new record, anyone can type a security ID. Once the record has been saved, only
application administrators or users with permission to access theChange Security ID task can change
the security ID.

I know a job was set up, but I cannot see it in the software

In most Sage 300 Construction and Real Estate applications, record security affects only reports and
inquiries. In certain Contracts, Job Cost, and Project Management tasks, however, record security also
affects whether you can type jobs or select jobs from lists. For more information, see “Effect of record
security on tasks” on page 68.

Jobs may not appear for several reasons:

n The jobmay have a status of closed; some lists do not display closed jobs.

n The jobmay have beenmoved to a different file, such as a history file.

n Record security may be active on the job and you do not have permission to access that job.
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I forgot my password

If you are an application administrator or user, request a new password from one of your company's
security administrators.

If you are the only security administrator and you forgot your password, youmust call Customer Support to
restore access to your software. See “Technical assistance” on page 2.

NOTE: For back-up purposes, we recommend having at least two security administrators.

My report or inquiry is missing information

A report or inquiry can bemissing information for several reasons. One explanation could be that you lack
record security permissions. To investigate this possibility, see the following topics.

Reports

p See "Effect of an upgrade on reports"

p See "Indicators that record security affects a report"

p See "Report record security settings"

p See "Review record security settings"

Inquiries

p See "Effect of record security on inquiries"

p See "Indicators that record security affects an inquiry"

p See "Inquiry record security settings"

Menu items and fields are unavailable

Menu items and fields can be unavailable for two reasons.

First, the task associated with themenu item or field requires a previous task that has not been performed.
For example, theEdit > Paste menu is unavailable if you have not previously cut or copied anything.

Second, you lack task security permissions (for example, access toPM > Setup > Properties.)

I cannot delete a user name

NOTE: Youmust be a security administrator to delete a security administrator.

If security is on and only one user name is assigned to the Security Administrator role, you cannot delete
the user name assigned to that role.

To delete the user name, youmust assign another user name to the Security Administrator role. For more
information, see “Add a security administrator” on page 70.

For back-up purposes, we recommend adding at least two security administrators.
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I cannot make an account unavailable

If security is on and only one available user name is assigned to the security administrator or application
administrator role, you cannot make the account unavailable.

Tomake the account unavailable, youmust assign another available user to that administrator role.

NOTE: Youmust be a security administrator to assign a user to an administrator role.

For back-up purposes, we recommend adding at least two security administrators and two application
administrators. If necessary, you can assign two user accounts to both roles.

I cannot end account availability

If security is on and only one user name is assigned to the security administrator or application
administrator role as of this date, you cannot end account availability.

To end account availability, youmust assign another available user name to that administrator role.

NOTE: Youmust be a security administrator to assign a user to an administrator role.

For back-up purposes, we recommend adding at least two security administrators and two application
administrators. If necessary, you can assign two user accounts to both roles.

I cannot remove a user name

NOTE: Youmust be a security administrator to delete a security administrator.

If security is on and only one user name is assigned to the Security Administrator role, you cannot remove
the user name assigned to that role.

To remove the user name, youmust assign another user name to the Security Administrator role. For more
information, see “Add a security administrator” on page 70.

For back-up purposes, we recommend adding at least two security administrators.

I cannot turn on security

NOTE: Youmust be a security administrator to turn on application security.

If a user name is not assigned to the Security Administrator role, you cannot turn on application security.

To turn on security, youmust assign a user name to the Security Administrator role. For more information,
see “Add a security administrator” on page 70.

For back-up purposes, we recommend adding at least two security administrators.

For the security settings to take effect, all users must restart Sage 300 Construction and Real Estate.
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I cannot save changes

NOTE: Youmust be a security administrator to remove users from the Security Administrator role.

If security is on, you cannot remove all users from the Security Administrator role.

To remove all the existing users from the Security Administrator role, first youmust assign another user
name to that role. For more information, see “Add a security administrator” on page 70.

For back-up purposes, we recommend having at least two security administrators.

Security tips
This section contains the following tips:

n “Be careful with print files” on page 86

n “Create separate roles for task and record security” on page 86

n “Consider limiting access to Crystal Decisions Crystal Reports” on page 87

n “Specify how secured tasks appear” on page 87

Be careful with print files

If you print to a folder that is not secure, others may have access to your reports.

By default, Sage 300 Construction and Real Estate prints files to your data folder. If you run the software
over a network, all users print to this location. Although you can change the default file location in File >
Data Folder Settings > File Locations > Printouts, all network users will still print to whatever location
you designate.

To print to a different folder, youmust redirect the print job at the time of printing. From aPrint Selection
window, click [Printer Setup]. Then, click [Select File] and browse to the desired location.

Create separate roles for task and record security

Administrators may need to create certain roles for task security and other roles for record security. For
example, a company has the following users:

p Project Manager 1

p Project Manager 2

p Accounts Payable (AP) Clerk 1

p AP Clerk 2

Project Manager 1 and AP Clerk 1 always work together on jobs. Project Manager 2 and AP Clerk 2
always work together on a different set of jobs. In terms of record security, these two teams of users
should bemembers of different roles because they need access to different jobs.

Project Managers 1 and 2 perform tasks such as approving change orders (COs.) AP Clerks 1 and 2
perform tasks such as entering invoices. In terms of task security, the project managers should be in one
role and the AP clerks should be in a different role.
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The overall security assignment for these users should look like the following:

Role Users Task Permissions Record Permissions

PROJMGR Proj managers Approve COs

APCLERK AP clerks Enter invoices

TEAM1 Proj Mgr 1 and AP Clerk 1 Team 1 jobs

TEAM2 Proj Mgr 2 and AP Clerk 2 Team 2 jobs

Consider limiting access to Crystal Decisions Crystal Reports

A user can use Crystal Decisions Crystal Reports to disable record security settings on Crystal reports. If
you ownCrystal Decisions Crystal Reports, guard against unwantedmodification of reports by limiting
who can use this software. Youmay want to allow only administrators of Sage 300 Construction and Real
Estate security to use Crystal Decisions Crystal Reports.

Specify how secured tasks appear

Most securable tasks have an associatedmenu item or field. Application administrators can specify how
thesemenu items and fields appear to a user who does not have access to them. You can specify whether
themenu items and fields are hidden or whether they appear gray (which indicates that they are
unavailable.)

1 From the Toolsmenu, select Options.

2 In theOptionswindow, look in theSecured Menu Items box. Select Don't display orDisplay as
disabled.

3 Click [OK].

NOTES:

l Youmust be an application administrator to perform this task.

l The Tools > Optionsmenu is subject to task security. Youmay not be able to see this menu item
if the application administrator has selectedDon't display in theSecured Menu Items box.

l Application administrators need to specify this setting in only one application for the effect to be
seen in all applications.
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Glossary of security terms
Application Administrator
An application administrator has unrestricted access to all features in Sage 300 Construction and Real
Estate. They can set up task security and set upmost aspects of record security in the Security
Administration tool. For a complete list of tasks that an application administrator can perform, see “Setting
up security ,” on page 69.

Like other users, an application administrator has a user name and password. If security is on, application
administrators must type this user name and password after they start an application.

Only security administrators can create users.

Application Log
Logs the start and end of Accounting applications and tasks.

Application Security
Application administrators can prevent unauthorized users from accessing Sage 300 Construction and
Real Estate by turning on application security. When application administrators turn on application
security, all users must enter a user name and password to access the software. They can restrict access
to software features and data that each user has permission to access. Security Administration offers four
types of application security: task, file, record, and company.

Application security also lets application administrators hide applications from users and roles. When an
application administrator uses the Security Administration tool to deny a user or role access to all tasks in
an application and sets securedmenu items to not display, users cannot see the application in TS-Main or
in the Sage Desktop.

Audit Setup Log
Logs changes when the audit setup activity is selected in an Accounting application.

Company Security
Company security allows an application administrator to grant a user access to specific companies.

Security administrators and application administrators have access to all companies.

Estimating Security
Estimating products allow you to secure certain files. This file security is similar to Security Administration
file security but is different in that it uses only a password and not a combination of user name and
password.

You can assign a full access password to all securable Estimating files. This password allows you to both
read a file and write to a file.

With Estimating databases, you can also assign a read-only password. This password allows you to take
off items from a database but not modify a database.

Field Report Log
Logs changes to finalized field reports in Project Management.
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File Security
File security allows application administrators to block all access to a file. This includes access through
open database connectivity and through all related tasks, reports, and inquiries. This differs from task
security, which allows application administrators to block tasks selectively and does not allow them to
control ODBC access.

Open Database Connectivity (ODBC)
OpenDatabase Connectivity (ODBC) allows a Sage 300 Construction and Real Estate database and a
third party program such as Microsoft Access to communicate. Once you set up anODBC connection
(which requires a special ODBC driver), you can send data between the two programs.

Posting Recap Log
Logs recaps created while posting entries in Accounting. (For future use. No logs are created at this time.)

Record Security
With record security, you can control access to the CashManagement bank account, General Ledger
prefix, Job Cost and Project Management job, and Property Management property records.

When record security is active, reports and inquiries display only the records to which the user has
access.

Record security also affects Job Cost, Contracts, and Project Management tasks. In these applications,
you can type or select only jobs to which you have access.

Roles
A role represents a group of users who have the same security requirements. A role has its own user
account and its own task, record, file, and company permissions.

Security Administration
With Security Administration, application administrators can restrict access to tasks, files, records, and
companies. For example, they can use task security to restrict who can set up vendors in Accounts
Payable. With file security, they can restrict access to sensitive payroll files. With record security, they
can produce reports that display only the jobs to which the user has security access. Finally, with
company security, they can restrict access to which company information a user sees.

Security Administrator
Security administrators set up andmaintain accounts for users. For a complete list of tasks that a security
administrator can perform, see “Setting up security ,” on page 69.

Security Log
Logs events in the Security Administration tool.

Setup Log
Logs changes to setup information in Accounting.
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Strong Passwords
Strong passwords must meet the following conditions for complexity:

n Passwords must be at least eight characters long.

n Passwords must contain at least three of the following four character groups:

p English uppercase characters (A through Z)

p English lowercase characters (a through z)

p Numbers (0 through 9)

p Special characters (~ ! @ # $ % ^ & * ( ) - + = { } [ ] | \ : ; < , > . ? /)

n Passwords expire every 90 days.

n You are warned 10 days before your password expires.

n You cannot reuse your three previous passwords.

n Youmust wait 10 days before changing your password.

System Log
Logs Accounting system events.

Task Security
With task security, an application administrator can restrict access tomenu items and certain tasks found
within windows.

Task Summary Log
Logs summaries created during an Accounting task. (For future use. No logs are created at this time.)

User
A user has restricted access to the Sage 300 Construction and Real Estate. A user can have security
permissions that range from very restrictive to almost as complete as an application administrator.

All users have a user name and password. If Security Administration is on, youmust type a user name and
password immediately after you start an application.
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Real Estate ODBC
This chapter presents an overview of Sage 300 Construction and Real Estate open database connectivity
(ODBC). After you install ODBC, you should refer to the ODBC Help for detailed information about how to
use the driver to access databases.

ODBC overview
ODBC is a standard interface that serves as a translator between different database file structures and
different software. TheODBC driver lets applications collect data from databases in other applications.
Applications that are capable of accessing data via ODBC are commonly referred to as front-end
applications and can include databases (for example, Microsoft® Access), word processors (for example,
Microsoft Word), and spreadsheets (for example, Microsoft Excel). Applications such as Sage 300
Construction and Real Estate that make their data available throughODBC are referred to as back-end
applications. Both the front-end and back-end applications must support the ODBC protocol for them to
communicate with one another.

The Sage 300 Construction and Real Estate ODBC driver lets you readmost Accounting and
Management Products and Estimating Products records as well as create and delete some selected
records. You cannot delete individual fields, but you can replacemany fields with new data. See the
ODBC Help topic About record topics for a list of records and fields that you can edit. To access the Help
file, click Start > All Programs > Sage > Sage 300 Construction and Real Estate > Accounting >
ODBC Help.

NOTE: You cannot use the Sage 300 Construction and Real Estate ODBC driver to access
Purchasing, Inventory, or ServiceManagement data. To access Purchasing, Inventory, or Service
Management data throughODBC, use the Pervasive ODBC Engine Interface and Pervasive ODBC
Client Interface drivers. For more information, see the Pervasive Help at Start > All Programs >
Pervasive.PSQL 10 > Control Center and Documentation. UnderDocumentation Library click
User’s Guide > Using Pervasive PSQL > Setting Up ODBC Database Access.

Important issues for ODBC users
This section contains important information. You should read it before you use the Sage 300 Construction
and Real Estate ODBC driver.

ODBC Support Policy

Sage 300 Construction and Real Estate ODBC interfaces with a variety of third-party products. Because
other products are involved, Sage cannot guarantee that our Customer Support can resolve all ODBC-
related problems. Any multiple-vendor software arrangement requires a significant level of technical
expertise. Technical conflicts between databases from different vendors may require you to seek
assistance from a vendor other than Sage.



IMPORTANT: Currently, we test only Microsoft Office (Access, Word, and Excel) for compatibility
with the Sage 300 Construction and Real Estate ODBC driver. We do not test for compatibility with
any other products or programming languages, includingMicrosoft Visual Basic for Applications,
which can be run from amacro within Microsoft Office. Although youmay find success using another
product, Customer Support can address only issues and problems that relate to the use of Microsoft
Office (Access, Word, and Excel) to access data via the ODBC driver.

Data loss
ODBC processing leaves no audit trail of changes made, and its misuse can create untraceable data
discrepancies. If Customer Support is unable to reproduce a data-dependent problem using Sage 300
Construction and Real Estate software and data, it is assumed that the problem is specific to a data
discrepancy introduced with ODBC.

Points to consider before you use ODBC
For fields like notes andmemos, Sage 300 Construction and Real Estate software simply stores the
values. Some fields have a data dependency (the value in one field can affect the value of another field). In
other fields, the software requires the value to have a certain format or be within a specified range. When
youmake changes through a Sage 300 Construction and Real Estate application, the software handles
dependencies automatically. ODBC does not handle dependencies. It is up to you to be aware of these
issues andmake any necessary edits. To be safe, you should always back up any database before you
modify it throughODBC.

Consider the issues that follow before you write changes to a data file throughODBC:

n Data Dependencies: the values in some fields change based on the value contained in another field.

An example of data dependency in Estimating is the item record’s labor and equipment price fields.
These two price fields require the item to have an empty crew field. When you enter a labor or equipment
crew into the item’s crew field, Estimating removes the corresponding cost category’s price, because
the price is now derived from the labor/equipment rate table for that crew. ODBC will allow you to write a
crew to the item record without removing the cost category’s price. This results in an invalid record.

n Referential Integrity: some records which reside in one data file relate to records in another file.

An example of referential integrity in Estimating is the item record. The item record (pei) references its
phase record, which is stored in the standards file (pes.dat). This same itemmay be part of an
assembly, which exists in the assembly file (pwa.dat). With ODBC, you can write a change to the
phase of a given item record. This change would not automatically carry through to the assembly file.
The assembly would then reference a phase or item that no longer existed. It would even be possible to
assign a phase to the item for which there was no corresponding phase record in the standards file.

An example of referential integrity in Accounting is the relationship between a job record and one of its
subsidiary category records. Amounts that you enter through amiscellaneous worksheet into a
category’s miscellaneous category amount field directly affect the total miscellaneous category amount
field in the job record. If youmodify one of those fields throughODBC and do not modify the other, the
Job Cost Master file becomes out of balance.
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n Formatting:Sage 300 Construction and Real Estate applications expect the value stored in some
fields to be formatted in a certain way.

An example of expected formatting in Estimating Products is the phase record. TheGeneral Information
screen in your database displays the value entered in the Estimating phase suffix field. Phases you
enter through Estimating will automatically conform to this setting. ThroughODBC, you can to enter a
phase which does not match the formatting specified in your General Information.

Proper use of ODBC requires a thorough understanding of these dependencies tomake sure referential
integrity is preserved.

Special considerations for Sage Estimating users
The following is a brief sample of fields and record types with which Estimating users should be thoroughly
familiar before they useODBC. This list is not complete and is no substitute for an in-depth understanding
of the application’s records and fields. Estimating software is continually enhanced to keep up with
customer requests and industry trends. As a result of these enhancements, fields and their attributes
change. Refer to ODBC Help for lists of Estimating records and fields.

n If you create or add to an existing price link, youmust alsomake applicable changes to the item prices.

n Each record has one or more key fields, and some records have alternate keys. These fields distinguish
one record from another andmust be unique. For instance, on the subcontractor record, the key field is
the sub number. While two or more subcontractors may have the same address or sub type, eachmust
possess a unique sub number and spreadsheet name (alternate key). You should be familiar with the
key fields for any records you intend tomodify throughODBC. In ODBC Help, key fields aremarked
with (k).

n Avoid changing hierarchical flags on existing records. For example, the Group phase field on the phase
record and theGroup workpackage field on the workpackage record.

n Do not change values that result from a calculation. For instance, do not change the estimate total
amount or sequence numbers in an estimate.

n Delphi users should be aware that the Delphi Database Engine supports the read capabilities of Sage
300 Construction and Real Estate ODBC, but does not fully support the write capabilities.

n Refer to the ODBC Help topic About the possible characters in Estimating database records for detailed
information on allowable entries to specific fields.

n ODBC provides the ability to use non-Estimating tools for datamanipulation and reporting. When you
useODBC to write to Estimating files, you become responsible for many tasks which Estimating
handles automatically.

ODBC adds power and flexibility, but demands care and knowledge. If you elect to write to your
Estimating files, use caution and a realistic assessment of your own knowledge of the Estimating system
as a guide.
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Set up a data source
Before you can use theODBC driver, youmust first set up a link to a Sage 300 Construction and Real
Estate data source. The data source contains the data a user wants to access and its associated
DatabaseManagement System. The data is pulled from a back-end application, for example, General
Ledger. The data is then sent to a front-end application, such as Microsoft Excel. Each data source you
set up has a data source name (DSN), which you provide.

When you set up a data source, you specify a particular ODBC driver to be attached to the data source.
These drivers are programs that access the information in the database and translate it into a format that
the front-end application (Microsoft Excel, for example) can read.

Youmust set up a DSN for each Sage 300 Construction and Real Estate database. For example, your
company might maintain one database for its construction business and another for its remodeling
business. Because these databases are stored in separate folders, youmust set up a DSN for each
database folder.

For detailed instructions on how to set up a DSN, see “DSN setup options in ODBC,” on page 95 .

Use the ODBC driver
After you install ODBC and set up a data source, you can use the driver to access Sage 300 Construction
and Real Estate information from the database. Procedures to collect this data depend on the front-end
application being used. ODBC Help provides detailed instructions for accessing and inserting Sage 300
Construction and Real Estate data into Microsoft Query, Excel, Access, andWord. Refer to the How To
section on the Help Contents tab for links to the applicable topics.

Other softwaremanufacturers’ ODBC-compliant products can access data through the Sage 300
Construction and Real Estate ODBC driver. Refer to thosemanufacturers’ ODBC documentation for
instructions on using ODBC.
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Chapter 9: Crystal Reports
Introduction
If you already have technical experience using Crystal Reports®, this chapter will help you customize
reports and invoices that you use in Sage 300 Construction and Real Estate applications. Please review
the entire chapter beforemaking changes to your reports.

If you do not have experience using Crystal Reports, contact your Sage certified consultant for help with
upgrading custom reports and creating custom reports that fit your business needs.

Training information

Learn about the Anytime Learning and Realtime Learning sessions covering Crystal Reports, view
schedules of online sessions, or look for classroom training near you at SageU.

You can directly access Sage University from the Helpmenu in applications. (Help > Sage on the Web
> Sage Software University). This website offers a variety of professional product training options.

DSN setup options in ODBC
The Timberline Data Source is automatically created the first time you open Sage 300 Construction and
Real Estate. However, youmust configure the Timberline Data Source before you customize reports and
invoices.

To set up portability options for a report in theODBC Setupwindow, follow these steps.

1 From theStart menu, select All Programs > ODBC > 32bit ODBC Administrator to open theData
Source Administrator window.

2 From theUser DSN, System DSN, or File DSN tab, select Timberline Data Source and click
[Configure].

3 In the Timberline Data ODBC Setupwindow, click [Options] to open theData Source Options.

NOTE: Crystal report designs in Sage 300 Construction and Real Estate that use the Timberline
Data Source use the following options: Standard descriptions for Table and Field Naming, Use
maximum table segment size selected, andShorten field and table names cleared.

http://www.sageu.com/


The Table and Field Naming selection determines how table and field names appear when you access
data using this data source name (DSN). Three options are available:

Naming
Option Description

Custom
descriptions

Use this mode when you design reports for a specific database. If you create a
report in Crystal Reports and use the custom descriptions from your Sage 300
Construction and Real Estate database, the custom descriptions appear on the
report when you print it from Sage 300 Construction and Real Estate. If you select
this option, the report is only portable to databases that use the same custom
descriptions as the original database used when creating the report.

Standard
descriptions

Use this mode when you design a report for use inmultiple databases. The default
descriptions appear on the report design in Crystal Reports, but the operators’
custom descriptions appear when the report runs from Sage 300 Construction and
Real Estate. If you select this option, you can use this report with all databases.

Dictionary
names

Use this mode tomodify only Billing invoice reports and reports that were designed
in Crystal Reports with dictionary names for Sage 300 Construction and Real Estate
software earlier than version 8.0.0. Dictionary names are internal table and field
names. They are less descriptive than the standard descriptions but provide the
same functionality. If you select this option, you can use this report with all
databases.

The following table uses the Accounts Receivable customer field as an example to show how different
Table and Field Naming options affect how the field appears.

Naming
Option Display Table and Field Name Comments

Custom
descriptions

MASTER_ARM_
CUSTOMER.Customer

If the custom description for AR
Customer is “client,” the field appears as
MASTER_ARM_CLIENT.client

Standard
descriptions

ARM_MASTER_
CUSTOMER.Customer

No change regardless of custom
descriptions for AR Customer. Standard
descriptions are always the default
descriptions.

Dictionary
names

MASTER_ARM_RECORD_1.CUST No change regardless of custom
descriptions. Internal names always
appear in dictionary names.
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To use reports in Sage 300 Construction and Real Estate that were designed using the Timberline Data
Source, youmust select theUse maximum table segments size check box when you design the
reports. If you clear the Usemaximum table segment size check box and you access a table with more
than 255 columns, the table is split into two tables. If you select this option, tables remain intact regardless
of size.

For example, the Job Cost JC job record contains more than 255 columns. If you clear theUse maximum
table segment size check box, the table splits into two tables (JCM_Master_Job_1 and JCM_Master_
Job_2). If you select theUse maximum table segment size check box, the table does not split
(JCM_Master_Job).

IMPORTANT: Some programs, includingMicrosoft® Access, do not support the use of maximum
table segment size. Clear the check box when you use DSNs associated with those programs. You
should set up a separate DSN for these programs.

Before ODBC 8.00.3 (you can find the version number on theDrivers tab of theODBC Data Source
Administrator), the Timberline ODBC driver shortened table names longer than 36 characters and
shortened field names longer than 25 characters. With the Accounting andManagement Products 8.0.0
and Estimating Products 6.5.0 release, the ODBC driver stopped shortening table and field names. This
change could cause previously designed reports and queries created with ODBC to stop working. A new
option has been added to the ODBC driver setup to let you select the appropriate mode for the data source.

Select theShorten field and table names check box to create a DSN compatible with reports that were
designed with versions of the software earlier than Accounting andManagement Products 8.0.0 and
Estimating Products 6.5.0. Clear the check box to create a DSN compatible with reports that were
designed later (for which the table and field names were not shortened).

Crystal Reports integration
Requirements

Youmust use Crystal Reports 9 or later to modify or create report designs for Accounting and
Management Products. For instructions on upgrading custom reports that were created in a previous
version, see “Upgrade custom reports” on page 122.

Youmust use Timberline Data Source as the data source name (DSN) for all Crystal reports that you
will use with Accounting andManagement report menus. However, for reports that you will use as designs
for Billing invoices, youmust use TS Billing Field Names as the DSN. For more information on the TS
Billing Field NamesDSN, see “Billing considerations” on page 124.

Setting up printers

By default, the “No Printer” option (Crystal Reports: File > Page Setup) is selected for all Crystal report
designs that ship with Sage 300 Construction and Real Estate. We recommend selecting this option for all
Crystal reports you use to avoid potential printer error messages when using Sage 300 Construction and
Real Estate applications with theWindows Vista orWindows 7 operating system.

When printing a report in Crystal Reports, the datamay print as cryptic symbols even though the report
displays correctly in preview mode. This is because Crystal Reports requires Unicode functions to print. If
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your printer driver does not support Unicode, youmust update your printer driver. To determine whether
your printer driver supports Unicode, see the printer driver manufacturer's support web site.

NOTE: In Crystal Reports, youmust select Crystal Syntax as theDefault Formula Language
(File > Options > Formula Editor tab > Default Formula Language).

Integration formulas
This section provides a list of acceptable formulas to use for generating reports.

Designs created in Crystal Reports use formulas to convey required report information to Sage 300
Construction and Real Estate. These formulas query the Sage 300 Construction and Real Estate
application for, or provide it with, required information that is not already in a database table field. For
example, youmay need to set themargins of the report when it prints. You use a formula to provide the
margin information to the application.

CAUTION: Name the formulas exactly as they are named in this document. Formulas may be
case sensitive andmay not work unless the formula namematches the corresponding formula
written in Sage 300 Construction and Real Estate code.

IMPORTANT: Do not type@ in front of formula fields. In Crystal Reports, “@” automatically
appears in front of formula fields; for example, when you create a formula and type tsDesignMode,
the formula appears as @tsDesignMode.

NOTE: Integration formulas need only to be included in the report design to function. You do not
need to include these formulas on the report itself.

Formula: tsAlternateSMFolder

Description This formula allows you to select whether you want a ServiceManagement report
to include current or historical information.

Syntax None. Leave the formula value blank.

Example @tsAlternateSMFolder=

Formula: tsApp

Description Use this formula to specify the application abbreviation for the report. This formula
is required on all ServiceManagement primary reports and subreports. The formula
is not required on any report that uses the ODBC driver to access Sage 300
Construction and Real Estate data.

Syntax “<Two-letter application abbreviation>”

Example @tsApp = “SM”
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Formula: tsAskFile

Description Use the tsAskFile formula to limit the file types the operator can choose when the
report runs. This formula applies to themain report. It also applies to all subreports
unless you use the tsSubAskFile formula on the subreports. This formula does not
have file merging capabilities. If you use the following formula example on a report
design, the report will prompt the operator to choose between the New.glt file and
the Current.glt file when the report runs. Without the formula on the report, the
operator could choose whatever file codes are available.
For more information click “Formula: tsSubAskFile”

Syntax “[<file type>(<file code name>[,<file code name>]*)]”
<file type> = the abbreviation of the data file type; for example: BLI, GLT, APT,
etc.
<file code name> = the file code name of the data file; for example: new, current,
history, active, standard, etc.

Example @tsAskFile = “GLT(new,current)” or “GLT(new, current)JCT(current)”

NOTE: You can also use one file code name in the tsAskFile function to force the report to use a
specific file; for example, use@tsAskFile = “JCT(new)”.

Formula: tsDataFolder

Description This formula specifies the current data folder the report uses and relays the data
folder information to any user-defined functions in the report. When you run a report
from Sage 300 Construction and Real Estate, the value is set to the current data
folder path by the tsCrystal interface when the report is initialized.

Syntax

Example @tsDataFolder = “C:\Timberline Office\YourCompanyDataFolder”

CAUTION: If you place this formula on a primary report and you want to use it on a subreport, you
must pass the formula to the subreport as a shared variable. Subreports do not automatically read the
formula from the primary report.
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You can use the tsDataFolder formula with any of the following functions:

tsarContractCustomerDetail tsarContractOnlyDetail

tsarCustomerDetailWithRetainage tsarJobCustomerDetail

tsarJobOnlyDetail tsControlData

tsCustomDescription tsFieldSection

tsFieldSectionDesc tsglFiscalEntityInfo

tsHeaderData tsItemDesc

tsLetterheadStyle

For more information on these functions, see “User-defined functions” on page 103.

Set the tsDataFolder formula to the same data path appearing in theDatabase box of theODBC Setup
window for the DSN if the report uses any of these user-defined functions:

n tsControlData

n tsHeaderData

n tsCustomDescription

Formula: tsDesignMode

Description This formula specifies the DSN mode used to create the report design. The DSN
mode of the report designmust match themode selected for the Table and Field
Naming option when you access or process the report.
Do not use this formula on report designs that use custom descriptions as the
naming option. When you run the report from Sage 300 Construction and Real
Estate, the tsCrystal interface looks to the report design for the tsDesignMode
formula. If the formula exists on the design, the system takes the value of the
formula and sets the Table and Field Naming option tomatch it. If the formula is not
on the report, the Table and Field Naming option automatically sets to custom
descriptions.

Syntax “<mode>”; mode can be “Dictionary” (dictionary names) or “SDesc” (standard
description)

Example @tsDesignMode = “SDesc”

NOTE: Custom Billing invoice formats and subreports must include the tsDesignMode formula with
a value of “Dictionary”. See “Customizing Crystal Reports” on page 120 for more information.
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Formula: tsDesktopId

Description If you use security and you link a Desktop home page to an estimate, Sage 300
Construction and Real Estate will ask for your user name and password when you
open the estimate. Use the tsDesktopId formula together with the
TSEstimatingDKM function to suppress the request for user name and password
when you open an estimate from a home page. See "Function: tsEstimatingDKM"
for more information on applying this function.
Add the tsDesktopId function to themain report. Add the TSEstimatingDKM
function to hyperlinks that link to estimates.

Syntax

Example @tsDesktopId = “”

Formula: tsLetterhead

Description Use this formula in conjunction with the tsLetterheadStyle function.
This formula dynamically places the letterhead image when the report runs. This
formula is not required. This formula dynamically places the letterhead image only
when the formula is set to “Y” and you have selected the Use this letterhead image
below for my forms option in the Options window (Tools > Options > Letterhead tab
> Use the letterhead image below for my forms). Sage 300 Construction and Real
Estate will not dynamically place the letterhead image if any of the following
conditions are true:

You set the formula to “N.”

You select one of the other letterhead options in the Options window

You do not include the formula on the report.
For more information on the tsLetterheadStyle function, see “Function:
tsLetterheadStyle” on page 115.

Syntax

Example
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Formula: tsMargins

Description Use the tsMargins formula to display the [Page Setup] button on thePrint
Selection window when you run the report from theReport menu in Sage 300
Construction and Real Estate. The tsMargins formula allows you to the set
margins for the report.

Syntax

Example @tsMargins =

Formula: tsReportType

Description Use this formula to identify the report type with the SQL Server database.

Syntax SQL

Example @tsReportType = “SQL”

Formula: tsSubAskFile

Description Use the tsSubAskFile formula on subreports only. Use this formula to limit the file
types the operator can choose for the subreport when it runs.
To limit the file types the operator can choose for themain report, use the tsAskFile
formula. See “Formula: tsAskFile” on page 99 for more information.
The tsSubAskFile formula applies to only the subreport on which you use it, not to
other subreports. This formula does not have file merging capabilities. If you use
the following formula example on a report design, the report will prompt the operator
to choose between the New.jct file and the Current.jct file when the report runs.
Without the formula on the report, the operator could choose from the new, current,
or history file.

Syntax “[<file type>(<file code name>[,<file code name>]*)];Prompt Text”
<file type> = the abbreviation of the data file type; for example: BLI, GLT, APT, etc.
<file code name> = the file code name of the data file; for example: new, current,
history, active, standard, etc.
Prompt Text = Text to inform the person that runs the report. You can use the
prompt text to indicate which subreport requires this selection.

Example @tsSubAskFile = “JCT(new,current);Select a file for the Job Cost Transaction
subreport”

NOTE: You can also use one file code name in the tsSubAskFile function to force the report to use a
specific file: for example, use@tsSubAskFile = “JCT(new)”.
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User-defined functions
You can use the Sage 300 Construction and Real Estate user-defined functions in conjunction with
Crystal Reports formulas on all reports. These user-defined functions instruct the application how to
transform the data retrieved by a formula. To select a user-defined function, in the Formula Editor, click
Functions > Additional Functions.

Function: pjLastJobUsed

Description If you use this function on a field in the report design and if you selected theUse
last job option in PJ Settings (Project Management: File > Company/Data Folder
Settings > PJ Settings), the field retrieves the job number from of the last job used.

Syntax pjLastJobUsed

Example pjLastJobUsed()

Function: rmCurrentPropertyID

Description Use to retrieve the current Residential Management (RM) property. The current
property is the property currently open or the last property opened in the RM
application.

Syntax

Example rmCurrentPropertyID()

Function: rmSetupInfo

Description Use to retrieve setting information based on the Residential Management property
you specify. The design retrieves the setting for the property if it is specific to the
property; otherwise, it retrieves the system setting.

Syntax rmSetupInfo(property, setting)

Property: The Property ID
Setting: The system setting you want to retrieve

Example rmSetupInfo(rmCurrentPropertyID()”DefaultDepositCode”)
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Function: tsarContractCustomerDetail

Description Use this function to determine whether Accounts Receivable (AR) details should
print for the specified contract and customer.

Syntax tsarContractCustomerDetail(Data Folder, AR Activity File, AR Transaction File,
Contract, Customer, Aging As Of Date, Aging Basis, Include Retainage, Unpaid
Only, Age Finance Charge)

Data Folder: The report designmust use the tsDataFolder formula, which stores
the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art)
file.
Contract: The Contract ID.
Customer: The Customer ID.
Aging as of Date: The cutoff date based on the Aging Basis date.
Include Retainage: True or False value. A True value takes retainage
transactions into account. A False value bypasses retainage transactions.
Unpaid Only: True or False: A True value considers transactions at the invoice
(status) level. A False value considers transactions at the activity level.
Age Finance Charge: True or False value. A True value includes finance
charges. A False value bypasses finance charges.

Example (From report AR Statement of Account(CR).rpt)
tsarContractCustomerDetail({tsDataFolder},{@tsFileName(ARA)},{@tsFileName
(ART)},{ART_CURRENT_TRANSACTION.Contract},{ART_CURRENT_
TRANSACTION.Customer},{?Aging Date},{?Aging Basis},{?Include Retainage?},
{?Unpaid only?},{?Include Finance Charges?})
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Function: tsarContractOnlyDetail

Description Use this function to determine whether Accounts Receivable (AR) details should
print for the specified contract.

Syntax tsarContractOnlyDetail(Data Folder, AR Activity File, AR Transaction File,
Contract, Aging As Of Date, Aging Basis, Include Retainage, Unpaid Only, Age
Finance Charge)

Data Folder: The report designmust use the tsDataFolder formula, which stores
the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art)
file.
Contract: The Contract ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis date.
Aging Basis: The date that the Aging as of Date uses to determine the cutoff date.
Include Retainage: True or False value. A True value takes retainage transactions
into account. A False value bypasses retainage transactions.
Unpaid Only: True or False. A True value considers transactions at the invoice
(status) level. A False value considers transactions at the Activity level.
Age Finance Charge: True or False value. A True value includes finance charges.
A False value bypasses finance charges.

Example (From report AR Statement of Account (CR).rpt)
tsarContractOnlyDetail({@tsDataFolder},{@tsFileName(ARA)},{@tsFileName
(ART)},{ART_CURRENT_TRANSACTION.Contract},{?Aging Date},{?Aging
Basis},{?Include Retainage?},{?Unpaid only?},{?Include Finance Charges?})
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Function: tsarCustomerDetailWithRetainage

Description Use this function to determine whether Accounts Receivable details should print
for the specified customer.

Syntax tsarCustomerDetailWithRetainage(Data Folder, AR Activity File, AR Transaction
File, Customer, Aging As Of Date, Aging Basis, Include Retainage, Unpaid Only,
Age Finance Charge)

Data Folder: The report designmust use the tsDataFolder formula, which stores
the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art)
file.
Customer: The Customer ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis date.
Aging Basis: The date that the Aging as of Date uses to determine the cutoff
date.
Include Retainage: True or False value. A True value takes retainage
transactions into account. A False value bypasses retainage transactions.
Unpaid Only: True or False. A True value considers transactions at the invoice
(status) level. A False value considers transactions at the Activity level.
Age Finance Charge: True or False value. A True value includes finance
charges. A False value bypasses finance charges.

Example (From report AR Statement of Account (CR).rpt)
tsarCustomerDetailWithRetainage({@tsDataFolder},{@tsFileName(ARA)},
{@tsFileName(ART)},{ART_CURRENT_TRANSACTION.Customer},{?Aging
Date},{?Aging Basis},{?Include Retainage?},{?Unpaid only?},{?Include Finance
Charges?})
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Function: tsarJobCustomerDetail

Description Use this function to determine whether Accounts Receivable details should print
for the specified job and customer.

Syntax tsarJobCustomerDetail(Data Folder, AR Activity File, AR Transaction File, Job,
Customer, Aging As Of Date, Aging Basis, Include Retainage, Unpaid Only, Age
Finance Charge)

Data Folder: The report designmust use the tsDataFolder formula, which stores
the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art)
file.
Job: The Job ID.
Customer: The Customer ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis date.
Aging Basis: The date that the Aging as of Date uses to determine the cutoff
date.
Include Retainage: True or False value. A True value takes retainage transactions
into account. A False value bypasses retainage transactions.
Unpaid Only: True or False. A True value considers transactions at the invoice
(status) level. A False value considers transactions at the Activity level.
Age Finance Charge: True or False value. A True value includes finance charges.
A False value bypasses finance charges.

Example (From report AR Statement of Account (CR).rpt)
tsarJobCustomerDetail({@tsDataFolder},{@tsFileName(ARA)},{@tsFileName
(ART)},{ART_CURRENT_TRANSACTION.Job},{ART_CURRENT_
TRANSACTION.Customer},{?Aging Date},{?Aging Basis},{?Include Retainage?},
{?Unpaid only?},{?Include Finance Charges?})
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Function: tsarJobOnlyDetail

Description Use this function to determine whether Accounts Receivable details should print
for the specified job.

Syntax tsarJobOnlyDetail(Data Folder, AR Activity File, AR Transaction File, Job, Aging
As Of Date, Aging Basis, Include Retainage, Unpaid Only, Age Finance Charge)

Data Folder: The report designmust use the tsDataFolder formula, which stores
the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction (current.art)
file.
Job: The Job ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis date.
Aging Basis: The date that the Aging as of Date uses to determine the cutoff date.
Include Retainage: True or False value. A True value takes retainage transactions
into account. A False value bypasses retainage transactions.
Unpaid Only: True or False. A True value considers transactions at the invoice
(status) level. A False value considers transactions at the Activity level.
Age Finance Charge: True or False value. A True value includes finance charges.
A False value bypasses finance charges.

Example (From report AR Statement of Account (CR).rpt)
tsarJobOnlyDetail({@tsDataFolder},{@tsFileName(ARA)},{@tsFileName(ART)},
{ART_CURRENT_TRANSACTION.Job},{?Aging Date},{?Aging Basis},{?Include
Retainage?},{?Unpaid only?},{?Include Finance Charges?})
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Function: tsControlData

Description Use this function to retrieve information such as company name, address, and
phone number from the Ts.ctl file.

Syntax tsControlData(Data Folder Name, Field Name, Flags)

Data Folder Name: The report designmust use the tsDataFolder formula, which
stores the folder path information.
Field Name:You can type (case sensitive):

l “Name”
l “Address” or “Address 1” and “Address 2”
l “City”
l “State”
l “Zip”
l “Phone”
l “Fax”
l “Email”
l “Web Address”
l “AccountingMethod”
l “Assign Batch Name”

Flags: You can type
l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize the first letter only.
l “L” for all lowercase.
l “” to print as it is in the database.

Example tsControlData(@tsDataFolder, “Name”, “A”) prints the company name in all capital
letters.
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Function: tsCustomDescription

Description This function retrieves custom descriptions from the ts.fld file.

Syntax tsCustomDescription(Data Folder Name, Code, Flags)

Data Folder Name: The report designmust use the tsDataFolder formula, which
stores the folder path information.
Code: The custom description field code.
Flags:You can type:

l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize the first letter only.
l “L” for all lowercase.
l “” to print as it is in the database.

Example tsCustomDescription(@tsDataFolder, 13, “A”) prints the JC ChangeOrder
custom description in all capital letters.

NOTE: All custom description codes are stored in the Ts.fld file. Custom descriptions are listed
when you print an available fields report (TR:Tools > Available Fields) and you select the Include
information for ODBC reporting? check box in the Print Available Fields – Print Selection window.

The tsCustomDescription function was new on Accounting andManagement Products 8.0.0 and is used
on new Crystal Reports designs. Earlier versions stored a function with a slightly different syntax called
tsCustomDesc. The Billing invoice reports still use the older function. Both functions are stored in the
u2lts.dll file on Accounting andManagement Products 8.0.0 and later.

Function: tsEstimatingDKM

Description If you use security and you link a report design used as a Sage 300 Construction
and Real Estate Desktop home page to an estimate, Sage 300 Construction and
Real Estate will ask for your user name and password when you open the
estimate. Use the tsEstimatingDKM function to suppress the request for user
name and password when you open an estimate from a home page in Desktop.

Syntax tsEstimatingDKM({@tsDesktopID}, {Detail.PATH} & “\” &
{Detail.FILENAME});
Detail.PATH and Detail.FILENAME are fields that store the estimate’s path and
file name in the Estimating Explorer database.

Example

NOTE: Youmust add the tsDesktopId formula to themain report when you use the
tsEstimatingDKM function in a hyperlink to an estimate.
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Function: tsFieldSection

Description Use this function to determine the value in a customer-specified field section. A
field section is any portion of the GL Account, JC Job, or AR Customer that you
define. For example, you can define up to 3 prefixes, the base, and the suffix of a
GL Account. Therefore, these are field sections. Using the tsFieldSection function,
you can retrieve the prefix, base, or suffix field information from theGL Account.

Syntax tsFieldSection(Data Folder Name, File Type, Field Name, Section, Value)

Data Folder Name: Type a path to the data folder or use the tsDataFolder formula,
which stores the folder path information.
File Type: The type of file. For example, type “GLM” for the General Ledger
account file or “JCM” for the Job Cost master file.
Field Name: The name of the field. For example, type “AACCT” for the General
Ledger account field.
Section:Section 1, Section 2, or Section 3; Base; Suffix
Value: TheODBC field name on which to act.
For example, GLT_CURRENT_TRANSACTION.Account for the Account
number from theGLT current transaction file, GLM_MASTER_
ACCOUNT.Account for the Account number from theGLMMaster account
record, or JCM_MASTER_JOB.Job for the job number from the JCM Job record.

Example tsFieldSection(@tsDataFolder, “GLM”, “AACCT”, “Section 1”, GLM_
MASTER_ACCOUNT.Account) prints the information in section 1 of theGL
Master Account field.
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Function: tsFieldSectionDesc

Description Use this function to determine the description in a customer-specified field section.
A field section is any portion of the GL Account, JC Job, or AR Customer that you
define. For example, you can define up to 3 prefixes, the base, and the suffix of a
GL Account. Therefore, these are field sections. Using the tsFieldSection function,
you can retrieve the prefix, base, or suffix field description information from theGL
Account.

Syntax tsFieldSectionDec(Data Folder Name, File Type, Field Name, Section, Flags)

Data Folder Name: Type a path to the data folder or use the tsDataFolder formula,
which stores the folder path information.
File Type: The type of file. For example, type “GLM” for the General Ledger
account file or “JCM” for the Job Cost master file.
Field Name: The name of the field. For example, type “AACCT” for the General
Ledger account field.
Section: Section 1, Section 2, or Section 3; Base; Suffix
Flags: You can type:

l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize the first letter only.
l “L” for all lowercase.
l “” to print as it is in the database.

Example tsFieldSectionDesc(@tsDataFolder, “GLM”, “AACCT”, “Section 1”, “A”)
prints the section 1 description of theGL Master Account field in all caps.
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Function: tsglFiscalEntityInfo

Description Use this function to report on the Australian Business Number (ABN) for General
Ledger or Accounts Payable accounts. For General Ledger accounts, you can
report on the ABN for a General Ledger prefix or the entire account number.

Syntax tsglFiscalEntityInfo(Data Folder Name, Field Name, Prefix or Account, Account
Section)

Data Folder Name: Type the path to the data folder or use the tsDataFolder
formula, which stores folder path information.
Field Name:Youmust use “abn” as the field name.
Prefix or Account: Type a valid prefix number or account number from the general
ledger chart of accounts or type a valid accounts payable account number.
Account Section: Type the section of the account to use. You can type:

l “account”
l “prefix a”
l “prefix b”
l “prefix c”
l “full prefix”

Example tsglFiscalEntityInfo(@tsDataFolder,”abn”,”10-1201”,”account”)

Function: tsHeaderData

Description Use to determine the header information, such as header records in the BLM file.

Syntax tsHeaderData(Data Folder Name, File Name, Header Number, Field Name, Flags)

Data Folder Name: The report designmust use the tsDataFolder formula, which
stores the folder path information.
Name:Use the actual file name; for example, Master.apm orMaster.blm.
Header Number: Identifies the header record from which the field is retrieved.
Field Name:Use the internal field name; for example, SATXT or PABN.
Flags: You can type:

l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize only the first letter.
l “L” for all lowercase.
l “” to print as it is in the database.

Example tsHeaderData(@tsDataFolder, “Master.blm”, 2,”SATXT”, “PA”) retrieves theAuto
Text field from theBL Settings Header, adds an “s” to the end, and prints in all
capital letters.
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NOTES: Internal field names are listed when you print an available fields report (TR: Tools >
Available Fields) and you select the Include information for ODBC reporting? check box in the
Print Available Fields – Print Selectionwindow.

To retrieve a date field, youmust use the Crystal Reports ToDate function to convert the string value
to a date. To retrieve a number, youmust use the Crystal Reports ToNumber function to convert the
string value to a number.

Function: tsItemDesc

Description This function returns the description of a list field. Use this function to perform
string comparisons on list fields that contain custom descriptions.

Syntax tsItemDesc(Data Folder Name, File Type, Field Name, Item Name, Format)

Data Folder Name: Type a path to the data folder or use the tsDataFolder formula,
which stores the folder path information.
File Type: The type of file. For example, type “ART” for the accounts receivable
transaction file.
Field Name: The name of the custom list field. For example, type “TATYPE” for
the accounts receivable Amount Type custom list.
Item Name: The short description of the custom list item. For example, type “PMT”
for the cash receipt accounts receivable amount type.
Format:

l “P” to pluralize.
l “A” for all capital letters.
l “I” for initial capital letters.
l “F” to capitalize the first letter only.
l “L” for all lowercase.
l “” to print as it is in the database.

Example tsItemDesc(@tsDataFolder, “ART”, “TATYPE”,”Lab”,”A”) returns LAB

NOTE: When you use tsItemDesc for literal string comparisons, set the Format parameter to
nothing (““) to return the description unchanged.
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Function: tsLetterheadStyle

Description This function retrieves your Sage 300 Construction and Real Estate letterhead
settings (TS-Main: Tools > Options > Letterhead tab) and returns one of the
following values:

“NONE”—No logo prints. The company name and address print in the header
section.

“PREPRINTED”—No logo prints. Header is blank to accommodate letterhead
stationery.

“CUSTOM”—Logo prints on the left. Company address prints on the right.
To accommodate the use of different database-specific Sage 300 Construction and
Real Estate letterhead settings, all report designs created in Crystal Reports and
included in the software have separate header sections for all three letterhead
options. The tsLetterheadStyle function is used as a suppress condition on a
header section. The function determines which letterhead to use and suppresses
the unused letterheads when the report prints.
TS-Main: Tools > Options > Letterhead

Syntax

Example (Page Header—Suppress Condition)
Custom: tsLetterheadStyle({@tsDataFolder}) <> “CUSTOM”
Preprinted: tsLetterheadStyle({@tsDataFolder}) <> “PREPRINTED”
None: tsLetterheadStyle({@tsDataFolder}) <> “NONE”
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Function: tsOperator

Description Use to determine the identity or the description of the operator printing the report

Syntax tsOperator(“Id”) or tsOperator(“Desc”)
Id: The identifier for the operator.
Desc: The description for the operator. For example, the name of the operator.

Example tsOperator(“Id”) prints the Sage 300 Construction and Real Estate Security Id and
tsOperator(“Desc”) prints the Sage 300 Construction and Real Estate Security
operator description.

Function: tsRange

Description Use this function to add range values to custom Crystal Report designs that you
use in Sage 300 Construction and Real Estate applications. You can select the
range values from a database list.
To view the database list, do the following:

Select Report Designer: Tools > Available Fields.

Select the record that you want to use, and then click [OK]. For example, AP -
Vendor.

On thePrint Available Fields window, select Include information for ODBC
reporting?, and then click [Start].

NOTE: Use the report created in step 3 above to determine the values to use
in the formulas listed below.

Important: The tsRange parameter must be the last parameter on the report
design.

Syntax Formula 1: "File Abbreviation, Record Number, Internal Name, Standard Order
Number, Internal Name 2"
Parameter: tsRange(Formula 1 Name)
Formula 2: IsNull({?tsRange(Formula 1 Name)}) or

Database Field = {?tsRange(Formula 1 Name)}
Database Field: {Table.Field}
Expert: Formula 2 Name is True.
Formula Name: The name of the formula can be whatever you choose.
File Abbreviation: The three-letter abbreviation for the data file type.
Record Number: The number of the record in the file.
Internal Name: This is the key field. For example, VENDOR or JOB.
Standard Order Number: Optional. This is the alternative key. Use it for sorting
the records.
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Function: tsRange

Internal Name 2: Optional. This is the description field. For example, VNAME.
Database Field: The field in the database to which the parameter is attached.
Value options for the parameter should be set as follows:
Allow custom values: True
Allow multiple values: True
Allow discrete values: True
Allow range values: False (This is because you are using a Sage 300
Construction and Real Estate range rather than a Crystal range.)
Steps to create function:

1 Name the formula and select the fields for the formula (Formula Workshop >
Formula Editor).

2 Edit the value options for the parameter (Edit Parameter).

3 Attach the parameter to the database field (Select Expert).

Example Formula 1 Name:VendorRangeSelection
Formula 1: “APM,9,VENDOR,1,VNAME”
Parameter: tsRange(VendorRangeSelection)
Formula 2 Name: SELECT - Vendor Range or NULL
Formula 2: IsNull({?tsRange(VendorRangeSelection)}) or APM_MASTER__
VENDOR. Vendor = {?tsRange(VendorRangeSelection)}
Expert:@SELECT - Vendor Range or NULL is True.
Provides a range in vendor number order with a description of vendor name.
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Special parameters in process reports
Process reports are reports that print forms and are printed directly from application tasks. This section
describes the procedure for defining the process reports to print using Crystal Reports. Althoughmost
applications print process reports, only the Job Cost (JC) and Project Management (PJ) applications use
Crystal Reports currently to print process reports.

Project Management uses the process reports that follow:

n Change order forms

n Change request forms

n Commitment change order forms

n Drawing logs

n Meetingminutes

n RFI forms

n Submittal forms

n Transmittal forms

Job Cost uses the process reports that follow:

n Change order forms

n Purchase order change order forms

n Purchase order forms

n Subcontract change order forms

n Subcontract forms

NOTE: Do not type “?” in front of parameter fields. In Crystal Reports, “?” automatically appears in
front of parameter fields; for example, when you create a parameter and type tsDocIndex, the
parameter appears as ?tsDocIndex.

Parameter: tsContactIndex

Description Only transmittal forms require this additional parameter to retrieve the contact ID
created by the process for the report.

In Crystal Reports, create the tsContactIndex string parameter.

Link the ?tsContactIndex parameter on themain report to the Contact ID on the
subreport to print the To contact information.

Syntax

Example

Sage 300 Construction and Real Estate User's Guide                                                                                                        Page 118

Chapter 9: Crystal Reports



Parameter: tsDocIndex

Description Process reports require this parameter to retrieve the document ID created by the
process for the report.
Use a tsDocIndex parameter when you want a document to print for only a specific
document ID.
This parameter is stored in the u2lxx.dll files. These files are installed in different
locations depending on the version of Crystal Reports that you use. If you use
Timberline Registry Editor (TSRegEdit) to switch between different versions of
Sage 300 Construction and Real Estate applications, always use the latest version
of the Registry Editor to ensure that u2lxx.dll files are in the proper location.
Create a parameter named tsDocIndex. Use Select Expert (Report > Select
Expert) to set the document index field equal to ?tsDocIndex. For each report type,
use the settings that follow:

RFIs: {PJD_DOCUMENT_RFI.RFI_INDEX} = {?tsDocIndex}

Submittals: {PJD_DOCUMENT_SUBMITTAL.SUBMITTAL_INDEX} =
{?tsDocIndex}

Transmittals: {PJD_DOCUMENT_TRANSMITTAL.TRANSMITTAL_INDEX} =
{?tsDocIndex}

Purchase orders and subcontracts: {JCM_MASTER_COMMITMENT.doc_
ID} = {?tsDocIndex}

Change orders: {JCM_MASTER_CHANGE_ORDER.doc_ID} =
{?tsDocIndex}

Purchase order COs and subcontract COs: {JCM_MASTER_COMMITMENT_
CO.doc_ID} = {?tsDocIndex}

Syntax

Example

Could not open data folder error

If you set the location on all tables and try to preview the report in Crystal, you still may receive an error
message stating: Could not open data folder. Data folder does not exist, it is not a Timberline data
folder, or the current operator does not have access.

This message refers to the path in the report’s tsDataFolder formula. The tsDataFolder formulamust have
a valid path to be previewed from Crystal.

To correct this error, follow these steps:

1 Click [OK] to this message.

2 Close the Formula Workshopwindow.

3 Under Field Explorer, double-click Formula Fields and select tsDataFolder.
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4 Right-click and select Edit.

Change the path tomatch your accounting data folder path.

Customizing Crystal Reports
Add, modify, and create custom report designs

UseReport Manager to add Crystal Reports designs to yourReportsmenu.

All Crystal report designs available on theReportsmenu in Sage 300 Construction and Real Estate use
the following options with the Timberline Data Source: Standard descriptions for Table and Field
Naming, Use maximum table segment size selected, Shorten field and table names cleared.

NOTE: Crystal Reports integration features are compatible only with Crystal Report designs
created with a DSN named “Timberline Data Source.” Currently, the only exception is for Billing
invoices, which use a DSN named TS Billing Field Names. For more information on the TS Billing
Field NamesDSN, see “Billing considerations” on page 124.

If you do not use the Timberline Data Source, then youmust do the following:

n On the computer from which you process the report:

p Youmust create a data source name (DSN) with the same nameDSN name used with the original
report.

p The DSN must use same table and field naming option as the DSN you used to create the original
design.

n If the original report design used the custom description naming option, your custom descriptions must
match the custom descriptions used to create the report design.

If you use the Timberline Data Source, follow these steps to add, modify, and create custom report
designs.

1 From theStart menu, select Control Panel > Administrative Tools > Data Sources (ODBC)) to
open the ODBC Data Source Administrator window.

2 From theUser DSN tab, select Timberline Data Source.

3 Click [Configure].

4 Click [Select Folder] and select your Sage 300 Construction and Real Estate data folder. Click [OK].

5 Click [Options].

a In the Table and Field Naming list, select Standard descriptions.

b Select theUse maximum table segment size check box.

c Clear theShorten field and table names check box.

d Click [OK] twice.

6 OpenCrystal Reports.
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7 Log on to a Timberline data source.

a If you do not have the report open, from the Filemenu, select Log On or Off Server. If you have the
report open, from theDatabasemenu, select Log On or Off Server.

b In theData Explorerwindow, double-click Create New Connection.

c Double-click ODBC (RDO).

d Select Timberline Data Source and click [Next].

e If necessary, type yourUser ID andPassword for Sage 300 Construction and Real Estate.

f Click [Finish].

g Click [Close].

8 Open the report design you want to modify and proceed to step 9 If you want to create a new report
design, select File > New. Select the tables and fields that you want to use on the report; then design
the report.

9 Set the location of the database.

a From theDatabasemenu, select Set Datasource Location.

b UnderCurrent Data Source, select the first data source.

c UnderReplace with, select Timberline Data Source.

d Click [Update].

e Verify that all table locations in theSet Datasource Locationwindow use the same data folder path.
You know that all table locations point to the same path if only one group of tables appears under
Current Data Source.

f Click [Close].

10 Repeat step 9 for each table in the report.

11 From theDatabasemenu, select Verify Database. Click [OK] when themessage appears that states,
“The database is up to date.” Repeat step 9 if the database is not up to date.

12 Review the list of formulas, functions, and parameters from section 3. See "Crystal Reports
integration" to determine which to add or modify.

13 When you finish, save the report. Use Reports Manager to add new reports to your Sage 300
Construction and Real Estate Reports menu.
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Upgrade custom reports

IMPORTANT: Upgrading reports requires knowledge of Crystal Reports software. If you do not
have experience using Crystal Reports, contact your Sage 300 Construction and Real Estate
certified consultant for help with upgrading custom reports and creating custom reports that fit your
business needs.

Follow the steps in the following sections to upgrade custom reports that were created in a previous
version of Sage 300 Construction and Real Estate. Upgrading reports to the latest version of Sage 300
Construction and Real Estatemay improve the performance of your reports.

Verify that the Timberline Data Source is set up correctly
1 From theStart menu, select All Programs > ODBC > 32bit ODBC Administrator.

2 Click theUser DSN tab and select Timberline Data Source.

3 Click [Configure] and then [Select Folder].

4 Select your data folder and click [OK].

5 Click [Options].

6 In the Table and Field Naming list, select Standard descriptions.

NOTE: If the report was not created using standard descriptions, select the same table and field
naming type used to create the original report.

7 Select theUse maximum table segment size check box.

8 Clear theShorten field and table names check box.

9 Click [OK] twice.

Connect to the Timberline Data Source
1 If the report that you want to modify is not open, select File > Log On or Off Server. If you already
have the report open, from theDatabasemenu, select Log On or Off Server.

2 In theData Explorerwindow, double-click Create New Connection.

3 Double-click ODBC (RDO).

4 Select Timberline Data Source and click [Next].

5 If necessary, type yourUser ID andPassword for Sage 300 Construction and Real Estate.

6 Click [Finish].

7 Click [Close].
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Set the data source location

Youmay need tomodify your custom reports to reflect Sage 300 Construction and Real Estate database
changes. Refer to Accounting andManagement Release Notes to review database changes by
application.

If there are no database changes listed in theRelease Notes that affect your custom reports, see
“{hypertext}Verify the database{Default ¶ Font}” on page 123.

If theRelease Notes list changes to the fields that are on your custom reports, follow these steps.

1 In theSet Datasource Locationwindow (Database > Set Datasource Location), underReplace
with, select Timberline Data Source.

2 Click [Update].

3 Repeat these steps for each subreport.

Verify the database

If you are upgrading custom reports that were created in a previous version of Sage 300 Construction and
Real Estate, you need to follow these steps for each report design. Perform these steps for each subreport
design you use also. Verifying the database in this manner may improve the performance of your reports
and subreports.

1 From theDatabase menu, select Verify Database.

2 Click [OK] whenever amessage appears that states, “The database file has changed.”

3 Click [OK] whenever amessage appears that states, “The database is now up to date.”

4 Answer the remainder of themessages as they appear.

5 From theDatabase menu, select Verify Database again.

6 Click [OK] when themessage appears that states, “The database is up to date.”

7 Save the report design.

Add new tables to custom reports

If theRelease Notes list new tables and you want to add these new tables to a custom report, follow these
steps.

1 Select Database > Database Expert.

2 From theAvailable Data Sources list, select the new table that you need to add to the report, click [>]
to add the table to theSelected Tables list, and then click [OK].

3 On the Links tab, verify that the new table is linked correctly to the existing data tables, and then click
[OK].

4 As necessary, replace or add fields to the report and report formulas, and revise theSelect Criteria.

5 Save the report design.
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Billing considerations
When upgrading, changing, or creating Billing invoice designs, youmust first set the location and verify the
database against a DSN that must be called TS Billing Field Names. To set up this DSN, follow the
instructions below:

Create the TS Billing field names DSN
1 From theStartmenu, select All Programs > ODBC > 32bit ODBC Administrator.

2 Click theUser DSN tab.

3 Click [Add].

4 Select Timberline Data as the new data source.

5 Click [Finish].

6 In theData Source Name box, type TS Billing Field Names.

7 Click [Select Folder].

8 Select the folder where the Sage 300 Construction and Real Estate data is located and click [OK].

9 Click [Options].

10 In the Table and Field Naming list, select Dictionary names.

11 Select theUse maximum table segment size check box.

NOTE: If the report was created in a version before Accounting andManagement Products 8.0.0,
youmay need to clear theUse maximum table segment size check box.

12 Clear theShorten field and table names check box.

13 Click [OK] to accept the new DSN.

14 Click [OK] to close the ODBC Administrator.

tsDesignMode formula

The Billing invoice format invoice design and all subreports must contain the tsDesignMode formula. The
value in this formulamust be “Dictionary”.

If you use a custom Crystal design for your Billing invoice task and it does not contain the tsDesignMode
formula, you will receive the following error messages: “Print Engine error 7: unable to connect to
database” and “File [report design] is not a valid invoice design.”

NOTE: The invoice format designs provided with your Sage 300 Construction and Real Estate
software already include these changes.
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Purchasing and Inventory considerations
Database record changes

Youmay need tomodify Purchasing and Inventory custom reports to reflect Sage 300 Construction and
Real Estate database changes. Refer to the Release Notes to review database changes. You can also
view the Release Notes by selectingHelp > Documents > ReleaseNotesAccMgmt.pdf.

CAUTION: Upgrading reports requires knowledge of Crystal Reports software. If you do not have
experience using Crystal Reports, contact your Sage certified consultant for help with upgrading
custom reports and creating custom reports that fit your business needs.

NOTES:

l Sage 300 Construction and Real Estate creates the “Timberline Office Data PO” and “Timberline
POData” data sources when you open Purchasing. Sage 300 Construction and Real Estate
creates the” Timberline Office Data IV” and “Timberline IV Data” data sources when you open
Inventory. These data sources will not be available until you open Purchasing or Inventory.

l Purchasing and Inventory reports have a .crs extension. When you open one of these reports in
Crystal Reports, make sure to select All files in the Files of type list box. This ensures that files
with the .crs extensions appear in theOpenwindow.

Modify or upgrade custom reports

Follow these steps tomodify or upgrade custom Purchasing and Inventory reports that were created in a
previous version of Crystal Reports.

1 Open the report in the current version of Crystal Reports.

2 For Purchasing or Inventory tables:

a From theDatabasemenu, select Set Datasource Location.

b UnderReplace with, double-click theCreate New Connection folder.

c Double-click theODBC (RDO) folder.

d In theODBC (RDO)window, select Select Data Source.

e In theData Source Name list, select Timberline POData or Timberline IV Data. (Select Timberline
POData if you are using a PO report; select Timberline IV Data if you are using an IV report).

f Click [Finish].

g For each table listed underCurrent Data Source, select the table, select the corresponding table in
theReplace with area, and click [Update]. (If all the data sources are the same, you can do this at
the data source level instead.)

h Click [Close].

NOTE: Youmay have tomanually map changed fields.
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3 For Sage 300 Construction and Real Estate tables:

a From theDatabasemenu, select Set Datasource Location.

b UnderReplace with, double-click theCreate New Connection folder.

c Double-click theODBC (RDO) folder.

d Click Make New Connection if theConnection Informationwindow does not appear.

e In theODBC (RDO)window, select Select Data Source.

f In theData Source Name list, select Timberline Office Data PO or Timberline Office Data IV.
(Select Timberline Office Data PO if you are using a PO report; select Timberline Office Data IV if you
are using an IV report). Click [Finish].

g For each table listed underCurrent Data Source, select the table, select the corresponding table in
theReplace with area, and click [Update]. (If all the data sources are the same, you can do this at
the data source level instead.)

h Click [Close].

NOTE: Youmay need to rename the report with a .crs extension after you save the report.

Formatted field formulas

Formatted fields are fields that you can format with sections separated by characters. You can create
formulas that will print the following as formatted fields on reports:

n Job

n Job cost code

n Equipment

n Equipment cost code

n GL account

Formula content for formatted fields contains only the field name.

Formula Contents
and Field Name Formula Name

Job FMTJOB + at least one character

Job Cost Code FMTJCC + at least one character

Equipment FMTEQU + at least one character

Equipment Cost Code FMTECC + at least one character

GL Account FMTGLA + at least one character
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If you create a report that has several occurrences of the same fields from different records, you can
createmultiple formulas with different names; for example, if you create a report that uses the job and job
cost code fields from both thePODetail andPOHeader records, you could create the following formulas:

Field Record Formula Name

Job PODetail FMTJOB1

Job POHeader FMTJOB2

Job Cost Code PODetail FMTJCC1

Job Cost Code POHeader FMTJCC2

NOTE: Formatting does not print from within Crystal Reports. Formatting does print when you print
the report from the Reports menu in Purchasing or Inventory.

Ts.ctl formulas

You can create formulas to include the general company information stored in the control (Ts.ctl) file.
Follow these steps.

CAUTION: If your existing reports contain Purchasing or Inventory control file fields (for example.,
Companyname, Address1, Address2, etc.), youmust replace them with the formulas listed in the
following table.

1 Name the new formula according to the following table.

Ts.ctl Field Name Ts.ctl Formula Name

Company TSCOMPANY

Address TSADDRESS

Address 2 TSADDRESS2

City TSCITY

State TSSTATE

Zip TSZIP

Phone TSPHONE

Folder TSFOLDER

2 In the Formula Editorwindow, leave the contents of the formula blank.

3 Save the formula.
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NOTE: Return values for these formulas do not print from within Crystal. They do print when you
print the report from the Reports menu in Purchasing or Inventory.

Parameter fields

When you print a report with parameter fields, the parameters determine which prompts appear in the print
window. For example, if the parameter is a date field, the prompt uses the calendar control; if the
parameter is a logic (true or false) field, the prompt uses a check box. For Purchasing and Inventory, name
your parameters something specific if the design lets you see a list of available data for the parameter.

Preset parameter sets

All of the following parameter names allow use of drop-down selection lists to print.

Parameter

STARTDATE ENDDATE

FIRSTITEM LASTITEM

FIRSTLOC LASTLOC

FIRSTCLASS LASTCLASS

FIRSTJOB LASTJOB

FIRSTVENDOR LASTVENDOR

FIRSTPO LASTPO

FIRSTRECEIPT LASTRECEIPT

Purchase order form and purchase order change order form parameters

Parameter Purpose

PONUMBER Youwant the report (for example, a purchase order form) to print for a single
purchase order. Use also with the CONUMBER parameter as described below.

CONUMBER Youwant the report (e.g., a purchase order change order form) to print for a single
purchase order change order.

NOTE: Lists for these parameters do not appear from within Crystal. They work, but you have to
type a value, not select a value from a list. They do print when you print the report from the Reports
menu in Purchasing or Inventory.
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Add custom reports to the Purchasing or Inventory Reports menu

Use the steps that follow to add custom report designs to the Purchasing or Inventory Reportsmenu:

1 From theReportsmenu in Purchasing or Inventory, select Report Manager.

2 To add a new report, click [New]. To change a report, click [Change].

3 Type theReport Name (the name that will appear on the report menu).

4 Select aMenu Group from the list, or type the name for a new menu group.

5 Click [List] to browse for the report. Thesemust be Crystal Reports designs with a .crs extension.

6 Select the report, and then click [Open].

7 Click [OK] to close theAdd New Reportwindow.

8 Click [Close] to close theReports Managerwindow.

DSN error

If you install or upgrade Purchasing or Inventory on a computer that has theWindows Vista orWindows 7
operating system, youmay need to elevate your permissions level before starting the program or
Purchasing/Inventory may not be able to create the DSNs necessary to use Crystal Reports. If you
encounter an error message when starting Purchasing or Inventory for the first time after installation, close
the program, elevate your permissions level, and start Purchasing/Inventory again.

Service Management considerations
Database record changes

IMPORTANT: Upgrading reports requires knowledge of Crystal Reports software. If you do not
have experience using Crystal Reports, contact your Sage certified consultant for help with
upgrading custom reports and creating custom reports to fit your business needs.

Youmay need tomodify ServiceManagement custom reports to reflect Sage 300 Construction and Real
Estate database changes. To review database changes, see the Release Notes. You can also view the
Release Notes by selectingHelp > Documents > ReleaseNotesAccMgmt.pdf.

Modify or upgrade custom reports

There are two options for setting up Crystal Reports in ServiceManagement. If the report is designed to
switch between the current and history files, see “Option A” below. If the report is not designed to switch
between current and history files, see “Option B ,” on page 131.
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Option A
1 Verify the Timberline Data Source is set up correctly. Subreports that pull information from the
accounting database use theODBC Timberline Data Source DSN.

a From theStart menu, select Control Panel > Administrative Tools > Data Sources (ODBC) to
open the ODBC Data Source Administrator window.

b From theUser DSN tab, select Timberline Data Source.

c Click [Configure].

d Click [Select Folder] and select your Sage 300 Construction and Real Estate data folder. Click
[OK].

e Click [Options].

f UnderData Source Options, select Standard descriptions from the Table and Field Naming
list.

g Select theUse maximum table segment size check box.

h Clear theShorten field and table names check box.

i Click [OK] twice.

NOTE: If you will print this custom report from within Crystal Reports, this DSN must use a valid
Sage 300 Construction and Real Estate accounting data set.

2 Set the location to a valid data set.

a From Crystal Reports, open the custom report you are upgrading.

b From theDatabasemenu, select Set Datasource Location.

c UnderCurrent Data Source, select the first data source.

d UnderReplace with, double-click Create New Connection.

e Double-click Btrieve.

f In theOpenwindow, browse to the folder containing your ServiceManagement data.

g Select FILE.DDF and click [Open].

h Select the data source that should replace the original.

i Click [Update].

j Repeat steps b through i for all data sources listed underCurrent Data Source.

k Verify all table locations in theSet Datasource Locationwindow point to the same data folder path.
All table locations point to the same path if only one group of tables appears underCurrent Data
Source.

Youmust also set the location on all subreports. If a subreport retrieves ServiceManagement data,
follow the procedure in step 2. If a subreport retrieves data from the Timberline Data Source, follow the
procedure in step 3 below. TheCurrent Data Sourcewindow lists subreport data sources in a separate
group.
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3 Select the data source for the subreport.

a From theDatabasemenu, select Set Datasource Location.

b UnderCurrent Data Source, double-click Subreports and select the first data source.

c UnderReplace with, double-click Create New Connection.

d Double-click ODBC (RDO).

e Select Timberline Data Source.

f Click [Finish].

g If you have security enabled, type yourOperator ID andPassword.

h Click [Close].

4 After you useSet Datasource Location, verify the path on each table of the report is correct.

5 From theDatabasemenu, select Verify Database.

6 From the Filemenu, select Save.

Option B
1 Verify the Timberline Data Source is set up correctly. Subreports that pull information from the
accounting database use the Timberline Data Source.

a From theStart menu, select Control Panel > Administrative Tools > Data Sources (ODBC) to
open the ODBC Data Source Administrator window.

b From theUser DSN tab, select Timberline Data Source.

c Click [Configure].

d Click [Select Folder] and select your Sage 300 Construction and Real Estate data folder. Click
[OK].

e Click [Options].

f UnderData Source Options, select Standard descriptions from the Table and Field Naming
list.

g Select theUse maximum table segment size check box.

h Clear theShorten field and table names check box.

i Click [OK] twice.

2 Verify the Timberline SM Data DSN is set up correctly

a From theStartmenu, select Control Panel > Administrative Tools > Data Sources (ODBC) to
open theODBC Data Source Administratorwindow.

b If you are operating in a server/workstation environment, select theSystem DSN tab and verify there
is a Timberline SM DataDSN.

NOTE: If Timberline SM Data does not appear in the list of data sources, create it automatically by
the following steps: 1) Open ServiceManagement at the server and preview any standard report. 2)
Open ServiceManagement at each workstation and preview any standard report.
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c If you are operating on a standalone system, perform steps d-h to set up the Timberline SM Data
DSN manually; otherwise, continue with step 3.

d If you are on a standalone system, create the Timberline SM Data DSN manually by selectingStart >
Control Panel > Administrative Tools > Data Sources (ODBC) to open theODBC Data Source
Administratorwindow.

e From theSystem DSN tab, click [Add].

f Select thePervasive ODBC Engine Interface driver.

g Enter the following information in thePervasive ODBC Engine DSN Setupwindow:

l Data Source Name: Timberline SM Data

l Database Name: From the list, select the entry starting with the letters SM in its label (for
example, “SM1FE43AFDF79D459F”).

ServiceManagement creates two DSN GUIDs for each dataset. Youmay select any Service
Management DSN GUID when creating the Timberline SM Data DSN manually. During run time,
ServiceManagement automatically points to the correct ServiceManagement database.

h Click [OK].

NOTE: If you will print this custom report from within Crystal Reports, this DSN must use a valid
Sage 300 Construction and Real Estate accounting data set.

3 Set the location to a valid data set.

a From Crystal Reports, open the custom report you are upgrading.

b From theDatabasemenu, select Set Datasource Location.

c UnderCurrent Data Source, make note of any paths where *.ddf files exist (for example,
C:\Development\Testdata\Field.ddf).

d Click [Close] to close theSet Datasource Locationwindow without changing any locations.

e Based on the information you determined in step c, useWindows Explorer to browse to the location
referenced by the custom report. Confirm that these files exist:

l Field.ddf

l File.ddf

l Index.ddf

f If the files do exist there, copy the .ddf files from your Servmngt folder to the location you determined
in step c. Typically, your Servmngt folder is located at X:\Program Files\Timberline
Office\Accounting\Servmngt (whereX represents the drive where your Sage 300 Construction and
Real Estate programs are installed).

4 Verify the database.

a Open the report design in the current version of Crystal Reports and select Database > Verify
Database.

b Youmay receive several prompts at this point. Respond to thesemessages as instructed until the
Map Fieldswindow appears:
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l “The Database file ‘[file name]’ has changed. Proceeding to fix up the report!” Click [OK]
at this message.

l “The database is now up to date.” Click [OK] at this message.

l If you receivemessage other than these (for example, “Remove table” messages), do not proceed.
Close the design without saving your changes and then confirm that step 2 was done correctly
before proceeding.

5 Open the custom report design in the current version of Crystal Reports and update the data source as
follows:

a From theDatabasemenu, select Set Datasource Location.

b UnderReplace with, double-click theCreate New Connection folder.

c Double-click theODBC (RDO) folder.

d In theODBC (RDO)window, select Select Data Source.

e In theData Source Name list, select Timberline SM Data and then click [Finish].

f For each item listed underCurrent Data Source, select the corresponding table in theReplace with
area and click [Update].

g Click [Close].

6 Verify the database.

a Select Database > Verify Database.

b Respond to the prompts as appropriate.

7 Save the custom report design.
Youmust also set the location on all subreports. If a subreport retrieves ServiceManagement data,
follow the procedure in steps 3-7. If a subreport retrieves data from Timberline Data Source, use the
steps that follow. TheCurrent Data Sourcewindow lists subreport data sources in a separate group.

8 Select the data source for the subreport.

a From theDatabase menu, select Set Datasource Location.

b UnderCurrent Data Source, double-click Subreports and select the first data source. Many of the
subreports retrieve information from the Timberline Data Source.

c UnderReplace with, double-click Create New Connection.

d Double-click ODBC (RDO).

e Select Timberline Data Source.

f Click [Finish].

g If you have security enabled, type yourOperator ID andPassword.

h Click [Close].

i After you useSet Datasource Location, verify that the path on each table of the report is correct.

j From theDatabasemenu, select Verify Database.

k From the Filemenu, select Save.

Chapter 9: Crystal Reports

Sage 300 Construction and Real Estate User's Guide                                                                                                        Page 133



DSN error

If you install or upgrade ServiceManagement on a computer that has theWindows Vista orWindows 7
operating system, youmay need to elevate your permissions level before starting the program or Service
Management may not be able to create the DSNs necessary to use Crystal Reports. If you encounter an
error message when starting ServiceManagement for the first time after installation, close Service
Management, elevate your permissions level, and start ServiceManagement again.

Add custom reports to the Service Management Reports menu

Use the steps that follow to add custom report designs to the ServiceManagement Reportsmenu:

1 Open ServiceManagement.

2 From theReportsmenu, select Custom Reports Manager.

3 Click [New].

4 Type aName for the new report.

5 Click thePath button and select the path to the report.

6 Type aSubmenu name for the report.

7 To print the report automatically to a file, select thePrint to file check box and type a File name.

8 Click [Finish].

9 Click [Done].

NOTES:
If you want custom invoice formats in ServiceManagement 8.3.0 and later to be retrieved, add them
to the appropriate location. These custom formats include Call Type, Service Location, AR
Customer, and ServiceManagement Settings.

You can store custom reports in a subdirectory for reports calledCustom (file pathX:\Program
Data\Sage\Timberline Office\9.5\Accounting\Report\Service Management\Custom inWindows
Vista andWindows 2008, orX:\Documents and Settings\All Users\Application
Data\Sage\Timberline Office\9.5\Accounting\Report\Service Management\Custom in all other
supported operating systems). Youmust manually create this folder, but any reports you store there
will be retrieved by ServiceManagement before it retrieves the reports stored in the Service
Management folder. This prevents custom reports from being overwritten during the upgrade
process. This is most common for process-oriented reports like work orders and agreements. You
must use the same name as the original report.

tsAlternateSMFolder

You can select whether you want a ServiceManagement report to include current or historical information
by adding the tsAlternateSMFolder function to the report. You do not need to add a value to the formula.
For more information on the tsAlternateSMFolder function, see “Formula: tsAlternateSMFolder,” on page
98
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tsApp

All ServiceManagement reports designs and all subreports must contain the tsApp formula. The value in
this formulamust be “SM.” However, this formula is not required on any report that uses the ODBC driver
to access Sage 300 Construction and Real Estate data. For more information on the tsApp formula, see
“Formula: tsApp,” on page 98

Desktop considerations
You can use a Crystal Reports design as a home page in Sage 300 Construction and Real Estate
Desktop. You will want to keep some concepts in mind when you create Crystal Reports designs for use
as home pages.

General recommendations

The following recommendations will maximize the performance of Crystal Reports designs used as home
pages:

n If you use subreports, use on-demand subreports.

n Do not use named files.

n Do not use run-time parameters.

n Although you can use all of the functionality of Desktop while it processes a home page, if a report takes
a long time to process, youmay not want to assign it as your home page.

Disabled formulas for Desktop home pages

The formulas that follow do not function on Crystal Reports designs that you use as home pages:

n tsAskFile

n tsSubAskFile

n tsLetterhead

Recommendations for Estimating home pages

The sample Estimating home pages that install with Desktop use a file-based DSN named
“EosExplorer.dsn.” This DSN is created when Estimating is installed and points to the Estimating Explorer
database (EXPNG). We recommend that you use this DSN for any Crystal Reports that access
Estimating Explorer data.

NOTE: Open the Estimating Explorer application before you use the EosExplorer.dsn. The EXPNG
database is created the first time you open Explorer. If the EXPNG database does not exist, and you
try to use the DSN, you will get a login failuremessage.

If you use security and you link a Desktop home page to an estimate, Sage 300 Construction and Real
Estate will ask for your user name and password when you open the estimate. See “Formula:
tsDesktopId,” on page 101 and “Function: tsEstimatingDKM,” on page 110.
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Using Crystal Reports with SQL Server
Setting up PJ daily reports

As of the 9.5 release, the only reports using the SQL Server database are the PJ Daily Reports. Youmust
set up Crystal Reports to work with the SQL Server database before creating custom PJ Daily Reports.
Althoughmost reports currently use the Pervasive database, the number of applications using the SQL
Server database for reports will increase with subsequent Sage 300 Construction and Real Estate
releases.

To configure Crystal Reports for use with PJ Daily Reports:

1 Open the report design in the current version of Crystal Reports.

2 Select Database > Set Datasource Location.

3 UnderCurrent Data Source, select the data source.

4 UnderReplace with, double-click Create New Connection.

5 Double-click OLE DB (ADO).

6 In theOLE DB Providerwindow, selectMicrosoft OLE DB Provider for SQL Server from the
Provider list.

7 Click [Next].

8 Select the Integrated Security check box.

9 In the Server box, select the appropriate server. This server should use theSAGECRE named
instance.

10 Select a database from theDatabase list.

NOTE: A “View” is a database query that displays SQL Server data or a combination of Pervasive and
SQL Server data.
Each View database appears in this list as “COMPANY NAME”+”DATABASE VERSION NUMBER” +
“NUMBER TONUMBER” + “LINKSERVER.” For example, if you want to access the version 9.5
database for Summit Hardware, the View database would appear in the list as:

Summit Hardware9_5_1_to_3_LinkServer
Where “Summit Hardware” is the name of the company, “9_5” is database version, and “1_to_3_
LinkServer” is the name of the LinkServer.

NOTE: You can determine the LinkServer name associated with a database by looking inCompany
Tools > Company Details. Select the Company you want to generate reports for from theCompany
list and find the data folder you want to generate the reports from. The corresponding LinkServer is listed
in theView Name column on theData Folder Information tab.

11 Click [Finish].

12 Before generating PJ Daily Reports, set the report type for SQL Server using the tsReportType
formula. For more information, see “Formula: tsReportType,” on page 102
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Introduction
This section introduces you to the steps to transfer:

n Estimate information from Estimating to Job Cost.

n Estimate information to Project Management.

n Commitment information from Buyout to Job Cost or Purchasing.

n Commitment information from Purchasing to Job Cost.

NOTE: Before you begin, be sure Estimating, Job Cost, Buyout, and, if needed, Purchasing and
Project Management are set up and configured properly for your company. Contact your business
partner or consultant if you have questions.

Sage 300 Construction and Real Estate terminology
Terminology varies between the estimating and accounting disciplines, so the Estimating, Job Cost,
Buyout, and Purchasing applications use different terms to describe certain items. Please familiarize
yourself with the terms contained in the table below before you proceed.

Job Cost Estimating Buyout Purchasing

Cost Code
(custom description*)

Job Cost Phase Cost code Reads data from Job Cost

Commitment ID N/A PurchaseOrder # PurchaseOrder

*In Job Cost, you can define the description used for cost codes (File > Company Settings > Custom
Descriptions).

If your company uses different terms, you should substitute your company’s terms for the ones used
above.

Estimate processing
Introduction

If you transfer estimate information directly into your job costing application, you can efficiently access
budget and transaction data without rekeying the information. This section covers the interface between
Estimating and Job Cost, which enables this information transfer.

If you use Project Management, you can easily update your change requests by importing information from
Estimating.



The Estimating to Job Cost interface

When Estimating sends estimate information to Job Cost, the software creates a file with the extension
.jce. When Job Cost accesses the data contained in that file, it transfers the information into the New.jct
file.
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Prepare Job Cost to receive estimates

NOTE: For detailed information about Job Cost concepts, see Help in Job Cost.

To successfully transfer estimate information from Estimating to Job Cost, in Job Cost youmust verify
three things:

1 All needed standard cost codes are set up.

NOTE: When you import estimates into Job Cost, you can select the Allow creation of Cost Codes
not on standard Cost Code list check box (found in the Import Estimates – Print Selection window) to
have the software create cost codes not on the standard cost code list. When you set up a cost code
during the import, only the cost code itself is defined. To define additional attributes, such as the cost
code description and the cost and production unit descriptions, set up the standard cost codes ahead of
time using JC: Setup > Standard Cost Codes.

2 All needed standard categories are set up, if your company uses categories.

3 Import settings are configured appropriately for your company.

Verify standard cost codes

To see a list of standard cost codes that are already set up in Job Cost, from the Job Cost Reportsmenu,
select Lists > Standard Cost Codes.

If you do not see a cost code that you know exists in the estimate to be imported, you can set up the
standard cost code usingSetup > Standard Cost Codes.

To set up standard cost codes or group cost codes, from the Job Cost Setupmenu, select Standard Cost
Codes. For information about setting up standard cost codes, in the Job Cost Help index typeStandard
Cost Codes. Select the topic titled “setting up”.

Verify standard categories

NOTE: Using categories is optional. If you do not use categories, you do not need to verify that they
exist. Proceed to page See "Verify import settings".

To see a list of standard categories that are already set up, from the Job Cost Reportsmenu select Lists
> Standard Categories.

If you do not see a standard category listed that you know exists in the estimate to be imported, youmust
set up that standard category.

To set up a standard category, from the Job Cost Setupmenu, select Standard Categories.

For information about how to set up standard categories, in the Job Cost Help index, type Standard
Categories. Select the topic titled “setting up”.

NOTE: In Job Cost, if you try to import a record which contains a category that does not exist on the
standard category list, the import is rejected.
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Verify import settings

To verify Job Cost’s import settings:
1 From the Job Cost Filemenu, select Company Settings > JC Settings > [Import].

2 TheAllow override of default options check box affects imported commitments, not imported
estimates, so you do not need to set this option to import estimates.

3 Select theWarning Response option appropriate for your company. TheWarning response options
let you affect how the software responds if the contents of the import file generate a warning during the
import. Situations that would produce a warning during import include:

p The imported commitment contains a category that has already beenmarked as Bought Out in Job
Cost.

p The amount on the imported commitment causes the total amount committed to exceed the estimate.
TheWarning Response setting has no effect when a record generates an error. A record that
generates an error rejects during the import process.

4 TheCommit method affects only imported commitments, not imported estimates, so you do not need
to set this option to import estimates.

5 When you import estimate information, the software looks at the Estimating description for cost units
and compares it to the Job Cost description for cost units. If the two descriptions do not match, the
Override CUD: Reject if different Cost Unit Description check box controls how the software
responds.
Verify that this check box is selected or cleared, as appropriate for your needs.

To read more information about this setting:
1 From theHelp menu, select Help Topics > Search.

NOTE: If necessary, complete the SetupWizard usingMaximize search capabilities.

2 On theSearch tab, for step 1, type import cost unit.

3 For step 3, select the box for “About importing the cost unit description.”

4 Click [Display].

Youmay also want to read theWhat’s This? Help for theReject if different Cost Unit Description
check box.

Prepare Estimating to send estimates

For detailed information about Estimating concepts, seeHelp in Estimating.

To successfully send estimate information from Estimating to Job Cost, in Estimating youmust verify that
four settings are set appropriately for your company:

n Database settings

n Database phase settings

n Database item settings

n Database addon settings

Sage 300 Construction and Real Estate User's Guide                                                                                                        Page 140

Chapter 10: Estimating to Accounting Integration



NOTE: Any changes youmake to these settings do not affect phases, items, or addons for
estimates that already exist. Youmust change phases, items, and addons individually for each
estimate that already exists if you want those estimates to reflect the new settings.

Verify database settings

To verify the database settings:
1 From the EstimatingDatabasemenu, select Database Settings > Company.

Menu path—Estimating: Database > Database Settings > Company
2 In theCompany Folder area, verify that the listed path goes to your Sage 300 Construction and Real
Estate accounting data folder.

3 Click the Job Cost tab.

Menu path—Estimating: Database > Database Settings > Job Cost

To interface with Job Cost:
1 For Job cost interface type, verify that Sage Timberline Office is selected.

NOTE: To change the interface type from a previously selected option to Sage Timberline Office, you
must use Estimating Tools to make the change.

2 Select theUse Sage Timberline Office Job Cost data check box. Once selected, the information
displayed on the Job Cost tab updates to reflect the job and cost code formats for theCompany Folder
listed on theCompany tab.

3 Type the path for the estimating transaction file, the .jce file that Estimating creates, in theSpecify the
default folder for storing transaction files field.

4 Select the Transfer crew units as man hours check box if you want to convert the crew units to hours
for tracking labor and equipment in the estimate. If you want to keep the crew units the same between
Estimating and Job Cost, clear this check box. For more information about this check box’s function,
useWhat’s This? Help.

5 Click [OK] when you are finished.

Verify database phase settings

Both Estimating and Job Cost use the concept of phases. In Job Cost, phases are often called cost
codes. It is possible that the phase structure used in Estimating is not the same as the cost code structure
used in Job Cost. Using theDatabase Phasewindow, you tell the software how you want the two
structures to align. In essence, you create amap for the software to use when you transfer data from a
phase in Estimating to a cost code in Job Cost.

To verify database phase settings:
1 From theDatabasemenu, select Phases. TheDatabase Phasewindow opens.

Menu path—Estimating: Database > Phases
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2 Click the list button located to the right of Job cost phase to select the Estimating phase to be
mapped to a cost code in Job Cost. TheDatabase Phase Listwindow opens. If you don’t see the
correct phases, click [Refresh].

3 Double-click on the desired phase. You are returned to theDatabase Phasewindow. The selected
Phase, its Description, Unit description, and any previously selected Job cost phase prefill in the
Database Phasewindow. You can use the same Job Cost phase number for many different estimating
phases.

4 Click [Close] when you are finished.

Verify database item settings

The Database Item window is where you define the Job Cost phase and Job Cost Category to use with
the item, and specify which quantity to send to Job Cost.

To verify database item settings
1 From the EstimatingDatabasemenu, select Items, and then click the Job Cost tab.

Menu path—Estimating: Database > Items > Job Cost
The information you enter here creates amap for the software to use when you transfer information from
Estimating to Job Cost. For each item in the database, you can select a Job Cost Phase (remember, in
the Job Cost application, phases are often referred to as cost codes) and a Job Cost Category. When
Estimating sends this estimating item to Job Cost, the item and its associated information appears
under the cost code and category you select in this window.

NOTE: As with phases, you can use the same Job Cost Phase and Job Cost Category for any
number of estimating items.

2 Click in the Job Cost Phase field, and then click the list button. TheDatabase Job Cost Phase
Listwindow opens. If you don’t see the correct phases, click [Refresh].

3 Locate and double-click the Job Cost phase you want to receive the item information when Estimating
interfaces with Job Cost. When you double-click on an item, theDatabase Job Cost Phase List
window closes and you are returned to theDatabase Item window, shown on page See "Estimating:
Database > Items > Job Cost". The Job Cost phase you selected appears in the Job Cost Phase field.
You can alsomanually enter a phase. Be sure to follow the format set up in Job Cost, punctuation
included. If the phase does not exist in Job Cost, you can create it during the import if you select the
Allow creation of Cost Codes not on standard Cost Code list check box on the Import Estimates
- Print Selectionwindow in Job Cost (Tools > Import > Estimates).

4 Click in the Job Cost Category field and then click the drop-down arrow located on the right.
Select the category to receive the Estimating item information.
You can alsomanually enter a category. The category must already exist in Job Cost.
Be sure to select the Job Cost Category field, not the database item Category field. The database
item Category field is used for pricing and does not have any impact on the Job Cost interface.
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5 Choose the item quantity to send to the selected Job Cost category. Your cost accounting needs
should dictate which option you choose. Click in theQty to Job Cost field and then click the drop-down
arrow to select the item quantity.
Takeoff qty – sends to Job Cost the takeoff item quantity for the category.
Order qty – sends to Job Cost the order item quantity for the category.
None – sends to Job Cost the total dollar amount for the job cost phase and job cost category. It does
not send quantities, so the unit price field in Job Cost will be blank.

6 Click [OK] and [Close] when you are done.

NOTE: You can alsomake changes to the Job Cost phase and category from the estimating
spreadsheet itself.

Verify Database Addon Settings

To view the database addon settings:
1 From theDatabasemenu, select Addons.

Menu path—Estimating: Database > Addons > [Job Cost]
2 Select theAllocatable check box tomake an addon cost eligible* for allocation when the transaction
file is sent to Job Cost.
* To actually allocate the addon, inStep 2 of the Job Cost Transfer Wizard, select Yes for the
Allocate addons? option.

To send the addon costs to a specific Job Cost cost code and category, click [Job Cost] and select the
Job cost phase andCategory to receive the addon information.
For more information about the function of theAllocatable check box, useWhat’s This? Help.

To get additional information about this setting:
1 From the EstimatingHelpmenu, select Help Topics > Index.

2 Type addons.

3 Select the topic titled “Allocating” and click [Display]. The Topics Foundwindow appears.

4 Double-click the topic titled “Allocating addons.”

Create an Estimating Transaction File

NOTE: What’s This? Help is available for each item in the wizard.
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To create the transaction file in Estimating:
1 From Estimating’s Interface menu, select Job Cost. The Job Cost Transfer Wizard opens. The
wizard creates a .jce file with a transaction for:

p Each phase for which you have entered a phase quantity in the spreadsheet.

p Each item category with an amount. The item setup determines whether the transaction includes the
takeoff quantity or order quantity.

p Each addon that is not allocated. The cost of allocated addons is found in the items used to calculate
those addons.

To progress through each step of the wizard, click the tab at the top of the Job Cost TransferWizard
window.

2 Click theStep 1 tab.

On the Step 1 tab:
1 Enter a transaction file name and the date to appear on the transactions contained within the transaction
file.

2 Accept the prefilledSage Timberline Office JC job number. The field prefills based on the
information entered in the Job Cost job number field located in Takeoff > Estimate Information >
WBE & Misc. Alternately, you can enter a job number (punctuation included) for a job which already
exists in Job Cost, or click the list button to select a job.

NOTE: If you selectedUse Sage Timberline Office Job Cost data (Database > Database
Settings > Job Cost) and in Step 1 you enter a job number that does not exist in Job Cost, when you
click the Step 2 tab, you receive theSave Changes?message. Click [Yes] to advance to the Step 2
tab or [No] to stay on the Step 1 tab and enter a different job number.

3 Enter the path to the folder that you want to receive the .jce file this wizard creates. If you do not enter a
path for the transaction file folder, the file is created in theExport folder specified inDatabase >
Database Settings > Job Cost.

4 Click theStep 2 tab.

On the Step 2 tab:
1 Select how you want item quantities to be rounded and how to allocate addons.

2 Click theStep 3 tab.

On the Step 3 tab:

NOTE: If you do not use extras in Job Cost, you do not need to do anything on this tab.

Select whether you want to map estimate information to Job Cost extras and, if so, select which
information do you want to use.

In Job Cost, extras are sub-jobs of themain job. Extras allow you to track cost, revenue, and
commitments separately from themain job, while still being able to accumulate to themain job.
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Some reasons youmight need to use extras in Job Cost are:

n The owner or architect requested additional work after the original contract was signed.

n Youmust track income from certain cost codes separately from themain job.

n Certain costs are billed and tracked separately from themain job.

NOTE: In Job Cost, you can change the name “extra”. For information about how to change the
name of this item, from the Job Cost Helpmenu, select Help Topics > Index and type custom
descriptions, specifying.

To attach information from a work breakdown structure or location to an item as an
extra:
1 Select theMap estimate information to extras in Job Cost check box. The selected work
breakdown structure or location information you will select in step 3 then goes to Job Cost as an extra.
Each item is mapped to a specific cost code and category in Job Cost using Database > Items. The
mapping you enter on the Step 3 tab sends a location or work breakdown structure (WBS) code to Job
Cost as an extra.
In Estimating, WBS codes enable you to attach additional information to each item. EachWBS code
has values underneath it. For example, if you had aWBS code of CSI Phase, the values underneath
that WBS codemight be field supervision, project administration, safety coordination, etc.
In Job Cost, theExtra ID field is limited to 10 characters. If your EstimatingWBS codes contain more
than 10 characters, they are truncated to 10 characters when you import them into Job Cost.
Additionally, you can use a location to relate an item to a specific job area. For example, if you build an
office, youmight want to assign one item to the first floor and another item to the second floor.

2 Click theSort Level drop-down arrow to display a list of WBS codes and a location option.

3 Select theWBS code or location to send to Job Cost as an extra.

4 When you select a Sort Level, you receive a warning: If you choose a sort level, non-allocatable add-ons
will not be exported. Choose cancel to export all. If you want all addons included in the export, click
[Cancel].

5 If you select aWBS code for theSort Level, theWBS Value Selection area becomes available.

NOTE: If you selected Location as the Sort Level, the name of this area is Location Selection. Its
function is the same nomatter which Sort Level you select.

6 UnderWBS Value Selection, choose whether to send all WBS values to Job Cost or only selected
WBS Values.

7 Click theStep 4 tab.

On the Step 4 tab:
1 Select a report destination if you want the wizard to produce a report that lists job cost phases, units,
and amounts included in the transaction file.

2 Select theAutomatically launch Job Cost check box if you would like to have the wizard
automatically open the Job Cost Import Estimateswindow after you start to generate transactions.
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3 Click [Generate Transactions] to create the transaction file.
If you did not select theAutomatically launch Job Cost check box, when theGenerate
Transactions process completes the transfer wizard closes.
If you selected theAutomatically launch Job Cost check box, theSelect Companywindow opens.

4 Choose which data folder is to receive the transaction file and click [OK]. The Import Estimates –
Print Selectionwindow opens.

Proceed to the next section for information about how to bring the exported estimate file in to Job Cost.

Receive Estimate Transactions Into Job Cost
To bring the .jce file from Estimating into Job Cost:
1 From the Job Cost Toolsmenu, select Import > Estimates. The Import Estimates – Print Selection
window opens.
Alternately, if you selected theAutomatically launch Job Cost check box when you were in the
interface wizard, this window opens automatically after you click [Generate Transactions] and select a
data folder.

2 Verify that the Import file field contains the path to the file you want to import. If you selected
Estimating’s Automatically launch Job Cost check box, the Import file field prefills with the name of
the exported file.
However, if you did not select Estimating’s Automatically launch Job Cost check box, the Import
file field prefills with the name of the last imported file.

You can also type the path to the file you want to import, or click the browse button to locate the
file.

3 In theRejected records file field, enter a path and file name to hold any records that are rejected during
the import process. Examples of things that cause record rejections are when you:

p Do not have security permissions to access the job contained in the import file.

p Try to import a category that is not on the standard category list.

4 Select theAllow creation of Cost Codes not on standard Cost Code list check box if you want the
software to automatically create cost codes contained in the import file but not currently found in Job
Cost’s standard cost code list.
The job ID and description appear in theEstimate will be applied to: Job fields. If the job does not
exist in Job Cost, it can be created if the operator has security permission to set up jobs in Job Cost.

p If the import file contains data for a single job and a single extra, the extra ID and description appear in
theEstimate will be applied to: Extra fields. If the extra does not exist in Job Cost, it can be
created if the operator has security permission to set up extras in Job Cost.

p If you do not use extras in Job Cost, theExtra fields do not appear in the window.

p If the import file contains data for multiple extras, theEstimate will be applied to Extra fields are
unavailable and their corresponding descriptions display Extra specified in import file.
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p Additionally, if you want to map the information in the import file to a specific extra, you can type that
extra in theEstimate will be applied to: Extra field. If the extra does not exist in Job Cost, it can be
created if the operator has security permission to set up extras in Job Cost.

5 Click [Add Job] to add to or change job information contained in the import file,. Information entered in
the Add Job window overwrites the corresponding information in the import file.

6 Click [Printer Setup]. ThePrinter Setup – Import Estimates window appears.

7 Select Print to file.

8 Click [OK]. The Import Estimates – Print Selectionwindow appears.

9 Verify the information in the window is correct.

10 Click [Start]. ThePrint File Selection – Import Estimates window opens.

11 Type a file name in the File name field.

NOTE: If you are using security, youmay want to send this file to a folder that requires security in
order to access it.

12 Click [Save].

13 Once the import process is underway, click theBackground Tasks icon on themenu bar to see
whether the import finishes normally. Even if the import finishes normally, that does not guarantee there
were no errors.

14 Examine the journal generated by Import Estimates.

To locate the Import Estimates journal:
1 From the Job Cost Filemenu, select Printouts.

2 Navigate to the file you created in the previous procedure.

3 Double-click on the file name to open the file.
The journal shows records that were added or created, transactions that were created, any records that
rejected during import, and the reason for the rejection. If the journal shows rejected records, correct the
errors, then import the reject file.

To get additional help for how to correct errors that occur during the import:
1 From theHelpmenu in Job Cost, select Help Topics > [Index].

2 Type correcting errors, import estimates.

3 Click [Display].

To view the new transactions:
1 From the Inquirymenu Job Cost, select Entries > Cost/Estimate Entries.

2 Select New.

3 Click [OK].

4 Click [Go to].

5 Enter the job number.
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6 Click [Transactions].

NOTE: Imported estimate transactions always go into the New.jct file, regardless of whether Job
Cost is set up to post automatically. Tomove the transactions to the Current.jct andMaster.jcm,
post the transactions using Tasks > Post Entries in Job Cost.

Recommendations for a trouble-free interface

To help ensure a smooth data transfer between Estimating and Job Cost, follow these guidelines:

Job Cost

Before you create the transaction file in Estimating, ensure that in Job Cost:

n Standard cost codes exist for each cost code contained in the import file sent from Estimating.

n If you use categories, standard categories exist for each category contained in the import file sent from
Estimating.

n The import settings in JC Settings (File > Company Settings > JC Settings > [Import]) are set
correctly for your company.

n The operator doing the import has security permission in Job Cost to set up jobs and extras, if you track
extras.

Estimating

Before you create an estimate to send to Job Cost, make sure the database settings for phases, items,
and addons are set up correctly for your needs. Any changes made to these settings after an estimate is
created do not affect existing phases, items, or addons. Existing phases, items, and addons must be
changed individually if you want the new settings to be reflected in the transaction file.

Before you create the transaction file to send to Job Cost, ensure that:

n Database Settings are set to Job cost interface type: Sage Timberline Office and the Use Sage
Timberline Office Job Cost data check box is selected.

n Database Phase settings aremapped to the desired Job cost phase.

n Database Item settings aremapped to the desired Job Cost Phase and Job Cost Category.

n Database Addon settings aremapped to the correct Job Cost Phase andCategory.

n Each step of the Job Cost Transfer Wizard is configured the way you need it.

n TheBOM description for the items are 30 characters or less. Job Cost can only accept up to 30
characters for the bill of materials description. To change the description, open Buyout, select the item
in the Itemswindow, and then click Display Item Detail.
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Troubleshooting

Several common error messages are listed below, along with the resolutions to correct the error’s cause.

This job exists only in Project Management (not in Job Cost).

The Project Management application can create jobs that the Job Cost application cannot access.

To correct the situation, in Project Management, select theCreate JC Job check box on the job (in PJ:
Setup > Jobs) and reimport the estimate.

Cannot add cost code. Standard cost code not found.

To correct the situation, in Job Cost add the cost code to the standard cost code list using JC: Setup >
Standard Cost Codes or in the Import Estimates – Print Selectionwindow select theAllow creation
of Cost Codes not on the standard Cost Code list check box.

Different cost unit description on Cost Code.

This situation can occur when the file being imported into Job Cost contains a different cost unit
description from what Job Cost uses and the check box forOverride CUD: Reject if different Cost Unit
Description (JC: File > Company Settings > JC Settings > [Import]) is selected.

One way to correct the situation is clear the check box forOverride CUD: Reject if different Cost Unit
Description (JC: File > Company Settings > JC Settings > [Import]) and import the reject file. To
learn about what will happen as a result of this approach, read the Help topic titled “About importing the
cost unit description.”

Another way to correct the situation is to determine which cost unit description you want to use, the one in
Estimating or the one in Job Cost, and change cost unit description in the other application.

Import Estimates Into Project Management
Project Management change requests are used to capture details about changes in scope, price, and cost.
Often, estimates are created to budget for these changes. You can easily import an Estimating estimate
into a Project Management change request, saving time and reducing errors.

You can select an existing estimate to import, open and edit an existing estimate before import, or create a
new estimate to import.

During the import, the extra, cost code, category, and unit description will be validated. You will be given
the opportunity to make corrections during the import for the extra, cost code, or category. These changes
are automatically written back to the estimate. Unit description errors require additional review. See
“Import Validation” on page 150 for more information.

You can import an estimate into a change request multiple times, but only changes and new items are
added. All item information on the change request is removed and replaced with the information from the
imported estimate.
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NOTE: Always open the estimate from the change request to make changes, or make your changes
to the estimate in Estimating and then open the estimate from the change request. If youmake
changes on the change request but not the estimate, these will not be reflected in the estimate and
will be lost if you later import the estimate back into the change request.

Import an estimate into a change request
1 In Project Management, create the change request to which the estimate will be imported (Contract
Control > Change Request).

2 Select thePrice/Cost Estimate tab.

3 Click [Estimate Change Request] and select the appropriate option:

p Create New Estimate: Create a new estimate which can then be imported into a change request.

p Open Existing Estimate: View and edit an existing estimate in Estimating prior to importing it into
the change request. Or, if you have already imported the estimate into the change request, you can
open the imported estimate to view ormake changes. The import removes and replaces existing item
information on the change request.

p Select Existing Estimate: Import a selected estimate into the change request.

4 If you create a new estimate or open an existing estimate, youmust select Interface > Send to
Change Request in Estimating to start the import process. This option is only available on the
Estimatingmenu if you have accessed the estimate through the change request.

5 If any issues are found during the import, you can select [Yes] to fix the issues or [No] to cancel the
import and view a list of issues. For more information, see “Import Validation” on page 150.

NOTE: Changes youmake to the estimate in Estimating after importing are not automatically
reflected on the change request. To update the estimate information on the change request, youmust
first open the change request in Project Management and then click [Estimate Change Request] on
thePrice/Cost Estimate tab. This opens the estimate and refreshes the change request with any
changes that weremade outside of Project Management.

Import Validation

Import issues

When you import an estimate into a change request, if any of the following issues exist in the estimate,
you will be prompted to correct them:

n Extra length is too long (it must be 10 characters or less)

n Cost code format is incorrect

n Cost code does not exist

n Category does not exist

If you choose tomake corrections, these changes are written back to the estimate. For example, if you
change the length of the extra, this will change the location orWBS values on the estimate.

If you do not choose to fix the import issues, the import stops and issues that were not fixed are displayed.
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Unit description

In addition to the issues listed above, the cost unit description on the category in Job Cost must match the
item unit description on the estimate if the estimate is set up to send quantities to Job Cost. If these do not
match, the import will stop. To correct this issue, either:

n Change the unit description on the estimate tomatch the cost unit description on the category in Job
Cost, or

n Change the cost unit description on the category in Job Cost to match the estimate

After you correct the unit description, you can perform the import again.

NOTE: Ensure that the correct quantity type is being sent to Job Cost. In theCategory Detail
window of the estimate, you have the option of sending either the takeoff quantity or the order
quantity to Job Cost. The option you select determines which quantities and unit descriptions are
imported. To view theCategory Detail window, on the estimate, right-click and select Detail
Window, then on theExtensions tab, right-click and select Category Detail.

Commitment Processing
You can transfer commitment information from Buyout to Purchasing or from Buyout to Job Cost. If you
send the commitment information from Buyout to Purchasing, Purchasing can send that commitment
information on to Job Cost.
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The Buyout to Purchasing or Job Cost Interface
Estimating information is sent from Estimating to Buyout. In Buyout, once you have selected vendors and
subcontractors for commitments, you can send the commitment information to Purchasing or to Job Cost.

If you send commitments to Purchasing, Buyout creates a text file (.txt) for Purchasing to import. If
desired, you can then have Purchasing send the commitments on to Job Cost.

If you send commitments directly to Job Cost, Buyout creates a Job Cost commitment file (.jcc).
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Prepare Purchasing to Receive Commitments
To prepare Purchasing to receive commitments, verify that the File Locations setting for Location of
Export file is appropriate for your company.

Verify File Locations Setting

To verify Purchasing’s File Locations setting:
1 From Purchasing’s Filemenu, select Data Folder Settings > File Locations.

Menu path—Purchasing: File > Data Folder Settings > File Locations
2 Verify that the path for Location of Export file is correct for your company. The field prefills with the
location of your Sage 300 Construction and Real Estate data.

Prepare Job Cost to Receive Commitments
For detailed information about Job Cost concepts, see Job Cost Help.

To prepare Job Cost to receive commitments, whether from Buyout or from Purchasing, verify that Job
Cost’s import settings are set appropriately for your company.

Verify Import Settings

To verify Job Cost’s import settings:

1 From the Job Cost Filemenu, select Data Folder Settings > JC Settings > [Import].

2 Select theAllow override of default options check box if you want the person who imports the
commitments to have the ability to cancel the settings marked in this window forWarning response
andCommit method.

3 Select theWarning response appropriate for your company. TheWarning response options let you
affect how the software responds if the contents of the import file generate a warning during the import.
Situations that would produce a warning during import include:

p The imported commitment contains a category that has already beenmarked as Bought Out in Job
Cost.

p The amount on the imported commitment causes the total amount committed to exceed the estimate.
TheWarning Response setting has no effect when a record generates an error. A record that
generates an error rejects during the import process.

4 Select theCommit method appropriate for your company. TheCommit method options let you
determine how the software responds to the status on the commitment record. All commitment records
in the import file have a status of eitherYes (they are committed in Job Cost), orNo (they are not
committed in Job Cost). After you import the commitments, you can change their status.
In theCommit method area, you can select to:

p Never commit the commitment in Job Cost, regardless of its status in the import file.

p Allow the software to commit or not commit the commitment in Job Cost, based on the
commitment’s status in the import file.

p Automatically commit valid commitments in Job Cost as they are imported.
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NOTE: If Sage 300 Construction and Real Estate security is active, imported commitments are
automatically released to accounting.

Prepare Buyout to Send Commitments
For detailed information about Buyout concepts, see Buyout Help.

In Buyout, once you select a vendor for a quote sheet or issue a purchase order for a quote sheet, you can
send commitment information to Purchasing or Job Cost.

Before you send commitment information to either Purchasing or Job Cost, you need to verify that:

n Buyout’s database settings for company setup, Job Cost setup, and tax setup are appropriate for your
company.

n Buyout’s option for how purchase order numbers increment is set appropriately for your company.

Verify the Company Setup

The company folder assigned on this tab determines where Buyout gets its Address Book, Job Cost, and
other information.

To verify the company setup:
1 From Buyout’s Databasemenu, select Database Settings > Company Setup.

Menu path—Buyout: Database > Database Settings > Company Setup
2 In theCompany Folder area, verify that the displayed path reflects the company folder you want to use
with Buyout or click [Select] to locate the correct company folder.

Verify the Job Cost Setup

The Job Cost Setup window allows you to set up the interface between Buyout and Job Cost.

To verify the Job Cost setup:
1 From Buyout’s Databasemenu, select Database Settings > Company Setup > [Job Cost Setup].

2 Verify that the Job cost interface type is set to Timberline.

3 Verify that Setup Options is set toUse Timberline Job Cost data. When you select this option,
Buyout brings in from the Job Cost application the format for the job number and cost code. To see the
format, click [View Sections].

4 Verify that theSelect the application that commitments will be exported to field reflects the
application you plan to export to, either Job Cost orPO/IV. The export process creates a slightly
different file based on what you select here. For more information on file layouts, see Appendix B.

TIP: Job Cost can import both .jcc and .txt files. If you are going to send purchase orders to both
applications, select PO/IV in theSelect the application that commitments will be exported to field.
Then you can bring the exported commitment file in to either Job Cost or Purchasing.

5 Type the path to the folder you want to hold exported commitment files in theSpecify the default
location for storing new commitment files field. You can click [Browse] to locate the desired folder.
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Verify the Tax Setup
If you have tax groups set up in your Accounts Payable application, those tax groups can be used on
purchase orders in Buyout, included in the commitment information, and sent to Purchasing or Job Cost.
Verify your tax setup in the Tax Setup window.

To verify the tax setup:
1 From Buyout’s Databasemenu, select Database Settings > Company Setup > [Tax Setup].

2 The Tax Setup area contains two options. You can select to:

p Use Timberline tax groups, in which case tax groups from the Accounts Payable application are
used in Buyout. Tax groups assigned to items in Buyout go to Purchasing or Job Cost when you
export commitments.

NOTE: Only the tax group is included in the export file, not the tax rate or calculated tax amount. Job
Cost and Purchasing calculate the tax amount based on the tax group specified on the item.

p Use User-defined tax groups, in which case the tax groups are created and used only in Buyout.
User-defined tax groups are not included in the export file.

3 TheDefault tax group for new work files lets you define the tax group used for work files created
after you accept this setting.

For more information about tax groups, from theHelp menu, select Help Topics > Index and type tax
groups.

Once you set up the Job Cost and tax settings, Buyout is ready to send commitment information to
Purchasing or Job Cost.

NOTE: If you are using the Inventory application and want to take advantage of inventory codes that
come into Buyout from Estimating, youmust set up the Price Code in Estimating to contain the
appropriate inventory code in the Price Code field.

Verify Buyout’s Options

To verify Buyout’s options:
1 From Buyout’s Editmenu, select Options.

2 Click theMiscellaneous tab.

3 In thePO Numbers area, select or clear theAuto-increment purchase orders when issuing check
box, as appropriate for your company.
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Create a Commitment Transaction File in Buyout
Using theExport Commitments command in Buyout, you can create commitments from quote sheets
that have a selected vendor or that have been issued as purchase orders.

To create the commitment file in Buyout:
1 Select the quote sheet for which you want to export commitments.

2 From the worksheet view, select Interface > Export Commitments.
UnderQuotes to Commit, you will see a list of quote sheets with the status of Selected or Issued.
You can click [List Quotes] to see a complete list of quote sheets with the status Selected or Issued.

NOTE: Once the commitment is exported, the quote sheet’s status in Buyout changes to Issued.

3 Enter a purchase order number in thePO Number field, if necessary. ThePO Number field prefills in
one of three ways:

Quote Sheet Status Auto-increment check box* PO Number

Selected Selected Prefills, can be changed.

Selected Cleared Empty. Must enter PO numbermanually.

Issued irrelevant Prefills, cannot be changed.

* TheAuto-increment purchase orders when issuing check box is found at BO: Edit > Options >
Miscellaneous.

4 Click theOptions tab. Here you can change the export file name and select default settings.

5 The Job Cost commitment file name field prefills with the Buyout work file name, but you can change
it. Youmay want to manually change the file name if you send out in succession the commitments for a
single job. For example, once the concrete work is bought out for a job, you could create a commitment
file named Lakewood Commons Concrete. When the electrical work is bought out for that same job, you
could create a commitment file named Lakewood Commons Electrical.

NOTE: If theSelect the application that commitments will be exported to field (Database
Settings > Company Setup > [Job Cost Setup]) is set toPO/IV, the name of the Job Cost
commitment file name field is changed toPO/IV commitment file name.

6 TheCommitment export folder field prefills with the information provided in the Job Cost Setup
window (Database > Database Settings > Company Setup > [Job Cost Setup] > Specify the
default location for storing new commitment files). You can change the prefilled information.

7 Select the Include piece count check box if you want the piece count to appear on purchase orders.
The piece count is the item quantity expressed in the units by which the vendor sells the item. For
example, lumber is often priced by thousand board feet (mbf) but it is typically sold by piece. If you
select the Include Piece Count check box, when you print the purchase order it includes an extra line
for the order’s piece count.
Buyout calculates the piece count based on the takeoff-to-order unit conversion factor set in Estimating.
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If you include piece counts on the purchase order, Buyout rounds the piece count up to the nearest
whole number and recalculates the order quantity for the purchase order item.

NOTE: Buyout exports the order quantity shown on the purchase order.
8 Select theAuto-launch Job Cost import after creating the commitment file check box on the
Export Commitments Options tab if you would like the export commitment process to automatically
start the Import Commitments task in Job Cost.

NOTE: If you set the Select the application that commitments will be exported to field (Database >
Database Settings > Company Setup > [Job Cost Setup]) toPO/IV, the name of theAuto-launch
Job Cost import after creating the commitment file field is changed toAuto-launch Purchasing
import after creating the commitment file.

9 Select theMap workfile information to extras in Job Cost check box in the Job Cost Extra Setup
area if you track extras in Job Cost and want to create an association between Buyout items and Job
Cost extras. If you do not use extras in Job Cost, do not select this check box.

NOTE: In Job Cost, theExtra ID field is limited to 10 characters. Any sort you select here that has
more than 10 characters is truncated to 10 characters when you import in Job Cost.
In Buyout, you use sort sequences to organize items into different groupings for ease of viewing. The
sort you select heremaps items in Buyout to extras in Job Cost.
To learnmore about sort sequence set up, from the Buyout Helpmenu, select Help Topics. Click the
Search tab. Type sort sequence. Select the topic titled “Learn about sort sequences” and click
[Display].

10 Click [Export]. When the export file has been created, theExport Completemessage appears.

11 Click [OK].
If Buyout is configured to send commitments to PO/IV (Database > Database Settings > Company
Setup > [Job Cost Setup]) and you selected theAuto-launch Purchasing import after creating the
commitment file check box in theExport Commitmentswindow, the Purchasing Import CSV Orders
window opens.
If Buyout is configured to send commitments to Job Cost (Database > Database Settings >
Company Setup > [Job Cost Setup]) and you selected theAuto-launch Job Cost import after
creating the commitment file check box in theExport Commitments window, the Job Cost Import
Commitments – Print Selectionwindow opens.

Proceed to the next section for information on how to bring the exported commitment file in to Purchasing.

If you do not use the Purchasing application, turn to “Receive the Buyout or Purchasing Commitment
Transaction File Into Job Cost,” on page 160 for information on how to bring the exported commitment file
into Job Cost.

See Appendix B for more information on the commitment transaction file layout.

Receive a Commitment Transaction File Into Purchasing

NOTE: If you do not interface with the Purchasing application, proceed to “Receive the Buyout or
Purchasing Commitment Transaction File Into Job Cost,” on page 160.

For detailed information about Purchasing concepts, see PurchasingHelp.
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To import the Buyout commitment .txt file into Purchasing:
1 From the Toolsmenu in Purchasing, select Import Orders. The Import CSV Orderswindow opens.
Alternately, if you selected theAuto-launch Purchasing import after creating the commitment file
check box when you were in the Buyout Export Commitmentswindow, the Import CSV Orders
window opens automatically after you click [Export] and click [OK] to theExport Completemessage.

2 In the Import File field, type the path to the file you want to import, or click the browse button to
locate the file.

3 In thePO Number Assignment area, select whether to have the Purchasing application assign new
purchase order numbers to incoming POs or use the purchase order numbers from the import file.

NOTE: Purchasing does not allow duplicate purchase order numbers. If you select the Assign new
purchase order numbers option, imported Buyout commitments are renumbered in Purchasing. This
prevents import rejections caused by duplicate purchase order numbers.

4 Purchase orders are imported into Purchasing with aPending status unless you select the
Automatically Commit check box in the Import CSV Orderswindow. If you do not select this check
box, imported commitments must be committed before you send them to Job Cost.

5 Click [Import]. A message tells you how many valid and rejected purchase orders are in the selected
export file and asks you to confirm the export’s completion.

6 Click [Yes], if you choose to continue.

7 Click [OK] to the Finished importing recordsmessage.

8 Click [Print] to print the import journal.

If any records reject, you can edit the file.

To edit the rejected records file:
1 From the Import CSV Orders window, click [Rejects]. This opens the rejects.txt file where you can edit
the invalid records.

2 Make any necessary changes.

3 [Save] and [Close] the rejects.txt file after you complete your changes.

4 Run the import process again and select the rejects.txt file as the file to import.

To change the commitment’s status
1 From Purchasing’s Tasksmenu, select Process Pending Orders. TheDocument Selectionwindow
appears.

Menu path—PO: Tasks > Process Pending Orders.

2 Click the dropdown arrow next toUser ID to select the desired User ID, if you are using the
Extended Approval system. This field may be left blank.
If you are not using the Extended Approval system, leave this field blank.

3 Select All Uncommitted Orders.
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4 Click [OK]. TheProcess Pending Orderswindow appears.

5 Select theCommit? check box next to the commitments you want to commit.

NOTE: You can also usePO: Tasks > Enter Orders to commit commitments one at a time.

6 Click [Process Selected] when all of the commitments to commit are selected.

7 Click [Finish].

Prepare Purchasing to Send Commitments
To successfully transfer commitment information from Purchasing to Job Cost, in Purchasing youmust
verify that two things in File Locations are set appropriately for your company:

n TheAuto Import after Sending setting.

n The location entered in theExport file setting.

To access Purchasing’s File Locations window:
1 From Purchasing’s Filemenu, select Data Folder Settings > File Locations.

Menu path—PO: File > Data Folder Settings > File Locations
2 Select theAuto Import after Sending check box to have Purchasing automatically open the Job Cost
Import Commitments – Print Selection window after you start theSend Orders to Job Cost
process.
If you clear this check box, the first time you send commitments theAuto Importwindow will ask you if
you would like to enable the auto import function. Select [Enable] or [Cancel] as appropriate for your
company.

3 The Location of Export file field prefills from the information you entered inPO: File > Data Folder
Settings > File Locations. Youmay also type the path to the folder you want to hold exported
commitment files.

4 Click [OK] to close theData Folder Settingswindow.

Create a Commitment Transaction File in Purchasing
To send committed purchase orders from Purchasing to Job Cost:
1 From Purchasing’s Tasksmenu, select Send Orders to Job Cost. TheSend Purchase Orders to
Job Costwindow opens.

2 Select or clear theSend Orders as Committed check box as appropriate for your company.

3 TheDestination prefills from the information you entered inPO: File > Data Folder Settings >
File Locations. Youmay also type a different path or click the browse button to locate the folder to hold
the exported file.

4 Click [Post]. TheConfirm window opens.

5 Click [Yes] in theConfirm window.

Chapter 10: Estimating to Accounting Integration

Sage 300 Construction and Real Estate User's Guide                                                                                                        Page 159



If you selectedAuto Import after Sending in File > Data Folder Settings > File Locations, Job Cost’s
Import Commitments – Print Selectionwindow opens.

Proceed to the next section for information on how to bring the exported commitment file into Job Cost.

See Appendix B for more information on the commitment transaction file layout.

Receive the Buyout or Purchasing Commitment Transaction File Into
Job Cost
Whether you import commitments from Buyout or Purchasing, the procedure in Job Cost is the same:

NOTE: If Sage 300 Construction and Real Estate security is active, imported commitments are
automatically released to accounting.

To import commitments:
1 From the Tools menu, select Import > Commitments. The Import Commitment – Print Selection
window appears.
Alternately, if you selected Buyout’s Auto-launch Job Cost import after creating the commitment
file check box (Buyout: Interface > Export Commitments > Options) or Purchasing’s Auto Import
after Sending check box (Purchasing: File > Data Folder Settings > File Locations), the Import
Commitment – Print Selectionwindow appears automatically.

2 Verify that the Import file field contains the path to the file you want to import.

p If you selected Buyout’s Auto-launch Job Cost import after creating the commitment file check
box or Purchasing’s Auto Import after Sending check box, the Import file field prefills with the
name of the exported file. If the commitment file comes from Purchasing, the file namewill be
Jccommit.txt.

p However, if you did not select Buyout’s Auto-launch Job Cost import after creating the
commitment file check box or Purchasing’s Auto Import after Sending check box, the Import file
field prefills with the name of the last imported file.

You can also type the path to the file you want to import, or click the browse button to locate the
file.

3 For theRejected records file, type a path and file name to hold any records that are rejected during the
import process. Examples of things that cause record rejections are when:

p You do not have security permissions to access the job contained in the import file.

p The job is not set up in Job Cost.

4 Click [Options] if you need to override theWarning Response orCommit Method settings (File >
Data Folder Settings > JC Settings > [Import]) and you selectedAllow override of default
options (File > Data Folder Settings > JC Settings > [Import]).

5 Click [OK] when done. The Import Commitment – Print Selectionwindow appears.

6 Click [Printer Setup]. ThePrinter Setup – Import Commitments Journal window appears.

7 Mark Print to file.
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8 Click [OK]. The Import Commitments – Print Selectionwindow appears.

9 Click [Start]. ThePrint File Selection – Import Commitments Journal window appears.

10 Enter a file name.

11 Click [Save].

12 Once the export process is underway, click theBackground Tasks icon on themenu bar to see
whether the import finishes normally. Even if the import finishes normally, that does not guarantee there
were no errors.

13 Examine the journal generated by Import Commitments.

To locate the import commitments journal:
1 From the Filemenu, select Printouts.

2 Locate the file you created in the previous procedure.

3 Double-click on the file name to open the file.
The journal shows any records rejected during import and the reason for the rejection. If you find rejected
records, correct the indicated errors, then import the reject file.

CAUTION: If you import a Buyout commitment file which contains a purchase order number Job
Cost already uses, Job Cost rejects the commitment itself but the commitment items are appended
to the purchase order that exists in Job Cost. This occurs because Buyout does not number
commitment items. (Purchasing does number commitment items.)
As a result, purchase orders that come from Buyout into Job Cost behave as though they are blanket
purchase orders.
When exporting commitments from Buyout, be very careful you do not use a purchase order number
that already exists in Job Cost.

For additional help on how to correct errors that occur during the import and how to import the rejected
records file, from the Job Cost Help menu, select Help Topics > [Index]. Type correcting errors, import
commitments and click [Display].

To view the new transactions in Job Cost:
1 From the Inquirymenu, select Entries > Cost/Estimate Entries.

2 Select New.

3 Click [Go to] and enter the job number.

4 Click [Transactions]. All of the commitment information contained in the import file displays.

NOTE: If commitments are committed during the Import Commitments process, such as when the
Commit method (File > Data Folder Settings > JC Settings > [Import]) is set toDetermined by
record orAuto commit, the transactions always go into the New.jct file and the commitment record
is created in theMaster.jcm, regardless of whether Job Cost is set to post automatically. Tomove
the transactions from the New.jct to the Current.jct, post them in Job Cost using Tasks > Post
Entries.
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Recommendations For a Trouble-Free Interface
To help ensure a smooth data transfer between Estimating, Buyout, Purchasing, and Job Cost, follow
these guidelines:

Estimating
n Reserve a bank of purchase order numbers for your project. This ensures unique purchase order
numbers are sent to Purchasing and Job Cost.

Buyout
n Ensure that Buyout’s quote summary names contain nomore than 30 characters.

n Ensure that Buyout’s vendor item descriptions contain nomore than 30 characters.

n Ensure that if you select to send a Buyout Sort to Job Cost as an extra (Interface > Export
Commitments > [Options] > Job Cost Extra Setup), the sort name contains nomore than 10
characters. In Job Cost, the extra ID is limited to 10 characters. A sort name containingmore than 10
characters is truncated to 10 characters in Job Cost.

n When Buyout interfaces with Purchasing, the price code (which comes from Estimating into Buyout)
translates to the inventory item code in Purchasing. If your Estimating staff members use the price code
field to track something unrelated to inventory, youmust come to an agreement with them on how to use
this field in the future.

Purchasing
n Ensure all purchase order numbers are unique across Buyout, Purchasing, and Job Cost.

Job Cost
n When Buyout sends commitment information to Job Cost, the amount field is blank for non-lump-sum
items. Job Cost calculates the amount by multiplying the quote item quantity by the quote item price.
However, for lump-sum items, the amount is included in the export file so that the amount in Buyout
always matches the resulting amount in Job Cost.

Address Book
n Ensure all companies are set up as Estimating and Accounts Payable vendors in Address Book.

Troubleshooting
A common import error message is listed below, along with the resolution to correct the error’s cause.

This job exists only in Project Management (not in Job Cost).

The Project Management application can create jobs that the Job Cost application cannot access.

To correct the situation, in Project Management, select theCreate JC Job check box on the job (in PJ:
Setup > Jobs) and reimport the estimate.
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File Layouts
This section contains detailed information about the file layouts for the .jce file Estimating creates, the .jcc
and .txt files Buyout creates, and the .txt file format needed for Purchasing to successfully import.

Estimating Transaction File Layout
If you open the .jce file that Estimating’s Job Cost Transfer Wizard creates, you see something that
looks like this:

The asterisk at the beginning of the file indicates the start of a job record.

The next character, the comma, is used to separate each field in the record.

The field following the comma is the job number.

The next field is the job description, and so on.

On subsequent lines, theP indicates the start of a phase record, theC indicates the start of a category
record, and theE indicates the start of an extra record.

To see a list of fields contained in the estimate transaction file:

1 From theHelpmenu in Job Cost, select Help Topics > Index.

2 Type importing, estimate file.

3 Click [Display]. The “Import Estimates file” Help topic opens.

4 Click the button next to each record to see the exact file layout.

In EstimatingHelp, you can also find a list of fields contained in the transaction file.

1 From the EstimatingHelpmenu, select Help Topics > Index.

2 Type transaction files for job cost.

3 Click [Display].

4 Select Transaction file for Sage Timberline Office.

5 Click [Display].

6 Click [job], [phase], or [category], as needed.

Commitment Transaction File Layout
If you open the commitment file that Buyout creates, whether the file is a .jcc file for Job Cost or a .txt file
for Purchasing, you see something that looks like this:

TheC at the beginning of the file indicates the start of a Commitment record.

The next character, a comma, is used to separate each field in the record.

The field following the comma is the purchase order number.

On subsequent lines, theCI indicates the start of a commitment item record.
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The only difference between the two types of export files Buyout creates is found in field 21 of the export
file. Into the 21st field of the .txt file for Purchasing, the software embeds a price code for each item. The
price code comes into Buyout from Estimating. Not all items have price codes so this field does not have
to contain a value in order for the file to successfully import.

CAUTION: The Estimating price code information is used in Purchasing as the inventory number.
Please check with your estimating staff to ensure they have set up the price code fields
appropriately.

Also, when Purchasing takes in an export file, it appends numbers to each commitment item. So, when
sending data on to Job Cost, the JC Commit.txt file contains commitment item line numbers that the .jcc
file does not.

To see a list of fields contained in the commitment transaction file:
1 From theHelpmenu in Buyout, select Help topics > Index.

2 Type commitments, commitment file format.

3 Select commitment file format.

4 Click [Display]. The “Commitments file format” Help topic opens.

5 Then click Commitment record details andCommitment item record details.

NOTE: Be sure to note themaximum size limits for each field. In particular, the quote summary
name is limited to 30 characters, as is the vendor item description. Information that exceeds the
maximum size limit for a field is truncated when you import it to Job Cost. Additionally any separators
that you enter for the job number or cost code are stripped out during the export process.

In Purchasing, you can find a similar list in Help.

1 From the Helpmenu in Purchasing, select Help Topics > Index.

2 Type importing orders.

3 Click [Display].

4 Select eitherCommitment Item orCommitment Record.

5 Click [Display]. The windows shown below are for both the Commitment record and the Commitment
Item record.

In Job Cost, you can also find in Help a list of fields contained in the commitment transaction file.

1 From theHelpmenu in Job Cost, select Help Topics > Index.

2 Type importing, commitments file.

3 Click [Display]. The “Import Commitment file” Help topic opens.

4 Click the button next to each record to see the exact file layout.

Sage 300 Construction and Real Estate User's Guide                                                                                                        Page 164

Chapter 10: Estimating to Accounting Integration


	Introduction
	Release information
	About this guide
	Support and assistance
	Online help
	Training
	Technical assistance


	Chapter 1: System Requirements
	Operating systems
	Supported operating systems
	Unsupported operating systems
	64-bit compatibility
	Windows Server 2008 compatibility

	Hardware requirements
	Processor
	Random access memory (RAM)
	Hard disk space
	Additional hardware

	Software requirements
	Supported protocols
	Required privilege settings
	Compatible versions
	Supported upgrade paths
	Required data file upgrades

	Chapter 2: Install Sage 300 Construction and Real Estate
	A. Before you install
	B. Install to a server or stand-alone computer
	Installing Project Management components
	Automatic creation of Timberline Office Share

	C. Install to a workstation connected to a network
	Installing to a terminal server
	Installing to a workstation
	Installing Project Management components

	D. Other installation scenarios
	Peer server networks with Estimating products

	E. Upgrade data files
	Prepare to upgrade files
	Upgrade files
	Restore file locations

	F. Install Crystal Reports XI (optional)
	G. After you install
	Elevated permission levels after installing
	If you have Purchasing, Inventory or Service Management data in Program Files
	If you have Estimating-only workstations

	H. Final steps

	Chapter 3: Install Sage Estimating
	A. Before You Install or Upgrade
	B. Install to a Workstation
	C. Install to a Server
	D. Other Installation Scenarios
	Additional Steps for Network Installations That Have Sage 300 Construction and Real Estate
	Terminal Server
	Pervasive Manual Installation

	E. Set up Stand-Alone Security Devices
	Install the Sentinel Driver
	Attach Protection Devices to Workstations

	F. Set up License Manager
	Guidelines
	Install the Sentinel Driver
	Attach a Protection Device to the Computer That Will Have License Manager
	Install License Manager
	Install License Codes
	Upgrade License Manager

	G. Upgrade Estimates and Databases
	H. After You Install
	I. Upgrade Your Estimating Explorer Data
	Backup Estimating Explorer
	Restore Estimating Explorer Data


	Chapter 4: Sage Installation Manager
	Automated Installation
	Streamline the Process of Installing Accounting and Management Updates
	Email Notification

	Before You Begin
	Set Up Sage Installation Manager
	Set Up the Email System
	Set Up the Monitoring Frequency
	Enable Automatic Downloads
	Set Up Administrator Credentials

	Work with Sage Installation Manager
	Check for Updates
	Download an Update to the Server
	Notify Workstation Users
	Install an Update on the Server
	Install an Update on Workstations
	Restart a Workstation
	Initiate a Remote Desktop Session
	Upgrading Data


	Chapter 5: Server Migration
	Things to know before you begin
	Recommended Procedure
	Preparing your new server
	Migrating your server
	Migrating your data folders
	Migrating your macros
	Migrating your attachments
	Updating your workstations


	Chapter 6: System Guidance
	General information
	Troubleshooting
	Terminal services
	Printers
	Install, move, or remove Sage 300 Construction and Real Estate products

	Chapter 7: Security
	Security overview
	Record security
	Setting up security
	Modifying security
	Troubleshooting security
	Security tips
	Glossary of security terms

	Chapter 8: Sage 300 Construction and Real Estate ODBC
	ODBC overview
	Important issues for ODBC users
	Data loss
	Points to consider before you use ODBC
	Special considerations for Sage Estimating users
	Set up a data source
	Use the ODBC driver

	Chapter 9: Crystal Reports
	Introduction
	DSN setup options in ODBC
	Crystal Reports integration
	Integration formulas
	User-defined functions
	Special parameters in process reports

	Customizing Crystal Reports
	Billing considerations
	Purchasing and Inventory considerations
	Service Management considerations
	Desktop considerations
	Using Crystal Reports with SQL Server

	Chapter 10: Estimating to Accounting Integration
	Introduction
	Sage 300 Construction and Real Estate terminology
	Estimate processing
	Receive Estimate Transactions Into Job Cost
	Import Estimates Into Project Management

	Commitment Processing
	The Buyout to Purchasing or Job Cost Interface
	Prepare Purchasing to Receive Commitments
	Prepare Job Cost to Receive Commitments
	Prepare Buyout to Send Commitments
	Verify the Tax Setup
	Create a Commitment Transaction File in Buyout
	Receive a Commitment Transaction File Into Purchasing
	Prepare Purchasing to Send Commitments
	Create a Commitment Transaction File in Purchasing
	Receive the Buyout or Purchasing Commitment Transaction File Into Job Cost
	Recommendations For a Trouble-Free Interface
	Troubleshooting

	File Layouts
	Estimating Transaction File Layout
	Commitment Transaction File Layout



