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Chapter 1: Welcome to Sage 100
Contractor Installation
Welcome to Sage 100 Contractor installation. Sage 100 Contractor can run in many different software and
network environments, with implications you need to consider as you prepare to install the software. The more
you understand about the installation process and how it relates to your software and network environment,
the more likely your installation will proceed smoothly.
This chapter provides more information about customer resources, such as:
Other printed and printable guides
The user-assistance Help system
Contacts for Customer Support
Sage 100 Contractor training
Information about business partners.

How to read this document
This document uses the following conventions:
The names of screens, windows, fields, and other features displayed by the software are shown in bold
type.
Information you enter into the software is in bold type, as in the following example:
Enter Miscellaneous in the Amount Type box.
Names of keys are shown in capitals; for example, ENTER, TAB. A plus sign (+) between two key
names indicates that you should press both keys at the same time; for example, SHIFT + TAB.
The names of buttons you can click with your mouse are enclosed in bold type; for example, [OK] and
[Post].
TIP: This symbol draws your attention to helpful information to make it easier for you to use Sage 100
Contractor.
NOTE: This symbol draws your attention to information of particular interest, such as information not
included in steps.
CAUTION: This symbol draws your attention to information that is important because it can help you
avoid a costly or time-consuming error.
IMPORTANT: This symbol draws your attention to information that is of critical importance.
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Customer Support and resources
Before contacting Customer Support
Before you contact the Customer Support Call Center, be sure to take advantage of the resources available to
you. These services are available 24 hours a day, 7 days a week.

Sage 100 Contractor Help
From anywhere within the software, you can access this comprehensive library of easy-to-find topics to learn
more about specific procedures, topics, fields, or buttons.

Product documentation
The software comes with several PDF guides, including Release Notes, Installation and License
Administration Guide, and User Guide, among others.
To view the guides, click Home & Resources tab > Product Documentation or, if you have Activity
Centers hidden, click Resources > Printable Documentation.
You can also find the PDF files in the Documentation folder in \Program Files (or Program Files (x86))
\Sage\Sage 100 Contractor\.

Sage Knowledgebase
Depending on your Sage service plan, we offer a web-based Sage Knowledgebase and online user
community forums at www.na.sage.com or through the in-product menu. Our staff maintains an extensive
knowledge database of questions and answers covering everything from frequently asked questions to more
complex problems and solutions. In addition, we keep all product reference documentation available in the
Knowledgebase. This online tool is the same tool we use in our customer support call center to help answer
your call.

To log in to the Sage Knowledgebase:
1. Go to https://support.na.sage.com/.
2. In the upper-right section of the page, above the Search, click Login.
3. Enter your Customer Portal Username and Password.
4. Click Log on.

Contacting Customer Support
Depending on your Sage service plan, you may be able to contact the Sage Customer Support Call Center to
work with one of our highly trained customer support professionals. The Knowledgebase article How do I get
technical support for Sage 100 Contractor? provides contact information and hours of operation, and it can
help you to determine which service works best for you.
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Contacting Customer Support

Our analysts work with you to respond accordingly to the urgency of your issue.
Call urgency can range from a simple explanation of software settings to critical situations in which work is
stopped or data integrity is compromised. Some calls may warrant further research and followup, in which
case our support analyst will place your call in his/her in-progress work list. At every step of the way, we work
with you until we reach a resolution or agreement.
Depending on your Sage service plan, you may check the status or update, or even create a new support
ticket online:
1. Visit www.na.sage.com.
2. In the upper-right section of the page, above the Search, click Login.
3. Enter your Customer Portal Username and Password.
4. Click Log on.
5. On the right, select Submit a customer support case.
Before you call, be sure to have the following information on hand so we can handle your call efficiently.

Question

How to Find the Answer

What is your Sage client ID number?

Your client ID number can be found on correspondence you receive from Sage. If
you do not know your Sage client ID, contact the person at your company who
maintains your relationship with Sage.

What software version To find the version, open Sage 100 Contractor; click Help > About Sage
are you using?
100 Contractor and note the number listed.
What application or
area in the software
are you calling about?

On the menu list, identify the application and window where are you are
working (i.e. Selecting Invoices to Pay in 4-3-1, Accounts Payable Vendor
Payments).

How can we help you?

Walk through the exact steps you completed with as much detail and
accuracy as possible.

Is there an error message?

Write down the exact wording of the message.

Can you reproduce
the issue?

Were you able to walk through the same steps that led to the problem and
see whether it happened again?

Is this the first time the
problem has
happened? Does the
problem occur on one
workstation or several?

Ask other users if they have experienced the same problem. Have them
test at their workstation to see if they experience the same problem. Also,
have the original user try other workstations to see whether the problem is
specific to that user.
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Question

How to Find the Answer

Ask your network administrator for technical information regarding anyHas anything changed
thing that may have changed behind the scenes: upgrades to Sage 100
with your software,
Contractor, new third-party software installations, moving of data from
hardware, or workone server to another, new printers or print driver installation, or anything
flow?
else that might affect the network.
Does the problem hapSelect [File> Open Company], then change the drive letter on the droppen in the sample data
down to C:, select Sample Company.
sets?
What kind of network
are you using?

If you do not know, contact your network administrator.

What operating system is on your computer?

For Vista: Click [Start], type winver in the ‘start search’ window and click [OK].

What printers and print
If you do not know, contact your network administrator.
drivers are installed?
When was your last
backup?

If you do not know, contact your network administrator.

Training resources
When you choose to take online classes from Sage or work with a Sage business partner, you will learn how
to use Sage 100 Contractor to support your business. Contact your business partner to find out about training
options or visit Sage University at http://www.sageu.com.

Online classes
Online classes help you maximize your use of Sage 100 Contractor. Online classes are a convenient training
option for your company and new users to learn more about Sage 100 Contractor so you can get the most out
of the software. You can select from classes on all aspects of Sage 100 Contractor, including project
management, estimating, scheduling, service management and payroll. Each online class is led by an
instructor with years of experience using Sage 100 Contractor. During the class, you will be able to follow
along as the instructor demonstrates functions and workflows in Sage 100 Contractor. In the online live
session, you can ask questions and benefit from hearing answers to other students' questions.
For more information, visit http://www.sageu.com.

Getting started as a new user
We recommend that all new users should begin with our New Customer Training (NCT) series, which is
included in our Essentials Training Package in recorded format for 24/7 access. If you prefer live online

4 Sage 100 Contractor

Business partners

training led by an instructor, you can register for the Realtime Learning version of these NCT courses. For
more information, visit http://www.sageu.com.

Business partners
To serve you better, Sage 100 Contractor products and services are available to you through an authorized
network of business partners. Business partners have local expertise and regional knowledge working with
contractors in the region.
Your business partner is available to serve you, from simple how-to questions and hands-on demonstrations,
to installation, implementation, and training. They're fully equipped to help you get where you want to be. For
more information, contact your Sage 100 Contractor business partner.

Business forms
Sage 100 Contractor is designed to work with generic checks and forms that are available from many
sources. There is no single vendor that customers must use; however, you can get a complete portfolio of
forms, tax forms, and checks through Sage Construction and Real Estate Forms by calling 800-760-7929 or
by visiting www.sagecreforms.biz.
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This chapter presents technical information about how to configure Sage 100 Contractor for specific operating
systems.
For current information about supported operating systems, Internet browsers, and other software, and about
system requirements for servers and client workstations, refer to our Knowledgebase article ID 51899,
available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=51899.
Make sure your computers meet the system requirements before you install the software. Sage 100
Contractor may not run properly or at all on computers that do not meet the minimum requirements.

Internet access required for Sage 100 Contractor
Sage 100 Contractor features, such as printing or efiling tax forms, submitting enhancement requests,
accessing Help, or downloading periodic product or tax updates all require Internet access.
To take advantage of these features, ensure that any workstation or server that Sage 100 Contractor is
installed on has access to the Internet.
During installation of Sage 100 Contractor, the computer serving as the Sage license server must be able to
connect to the Internet to obtain licenses. Once installation is complete, you can check out license uses for
each computer where Sage 100 Contractor is installed, then disconnect the Sage license server from the
Internet.
NOTE: A static Internet connection using a compatible web browser is required for Sage Construction
Anywhere. For current information on supported browsers, supported Sage 100 Contractor versions, and
other system requirements, see the Sage Construction Anywhere help at
http://help.sageconstructionanywhere.com/sage100contractor/help/Default.htm#01_Setup/System_
requirements.htm.

Network configuration and licensing
About network configuration and TCP Remoting Channel
Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component, to enable
communication among computers on a network. By default, Sage 100 Contractor uses the TCP starting port
48750. Certain configurations can potentially disable the communication:
File sharing on computers running the Windows 8, Windows 7, Vista, Server 2008, Server 2008 R2, and
Server 2012 operating system must be enabled. To enable file sharing, follow the instructions in the
Windows Help.
TCP communication requires the selection of port numbers that are not in use by other processes on the
local computer.
Software firewalls running on the local computer can be configured to block processes from opening TCP
ports, which will prevent communication through the TCP Remoting Channel.
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Configuring Sage 100 Contractor Hosting Framework TCP port number
Sage 100 Contractor uses the TCP starting port number 48750 as the default. You can configure the port
number using the XML file Sage.CRE.HostingFramework.Service-InstanceConfig.xml, located in the
Programs (x86)\Sage\Sage 100 Contractor folder.
If you need to change the default port numbers for the Sage 100 Contractor Hosting Framework using the
Sage.CRE.HostingFramework.Service-InstanceConfig.xml file, you must change it on every computer on the
network where Sage 100 Contractor is installed. In addition, after making this change, the Sage 100
Contractor Hosting Framework on each computer running Sage 100 Contractor must be restarted.
NOTE: Consult your IT administrator for alternative port numbers.

To change the port numbers:
1. In Window Explorer, locate Sage.CRE.HostingFramework.Service-InstanceConfig.xml in the path
Programs(x86)\Sage\Sage 100 Contractor.
2. Right-click Sage.CRE.HostingFramework.Service-InstanceConfig.xml, then open it with a text editor,
such as Notepad.
3. Near the end of the file, between the <StartingPort> </StartingPort> tags, locate the port number.
4. Change the port number.
5. Save, and then close the file.
Repeat these steps on every computer running Sage 100 Contractor.

Configuring anti-virus software and third-party firewalls
During installation of the Sage 100 Contractor Hosting Framework, the Windows Firewall is configured
automatically to allow the Sage 100 Contractor Hosting Framework to act as a TCP server. If you use some
other firewall, however, you may need to manually adjust some settings in the firewall in order to ensure
proper operation.
You can use the following basic procedure to manually configure the Windows Firewall to allow the Sage 100
Contractor Hosting Framework to communicate with other computers. Use it as the basis for manually
configuring other third-party firewall products.

To configure the Windows Firewall:
1. For Windows Vista or Server 2008, click Start > Control Panel > Security.
For Windows 7, click Start > Control Panel > System and Security
For Windows 8, click Start > All apps > Control Panel > System and Security.
2. Open Windows Firewall, and then select Allow a program or feature through Windows Firewall.
3. If Sage 100 Contractor Hosting Framework is not on the list, you can add it by selecting Add Program,
then browsing to the following path:
\MB7\Programs\Sage.CRE.HostingFramework.Service-InstanceConfig.xml.
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Network configuration and licensing

NOTE: By default, the exception is set to allow access by any computer on the network. You can refine
this setting by selecting the Change Scope button. Be aware that restricting the scope incorrectly can
cause the computer to be unable to connect with some or all of the other machines on the network.

Files to exclude when manually configuring your firewall for Windows 8 Professional
32-bit
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files\Sage\Sage 100 Contractor
C:\ProgramData\Aatrix Software
C:\Program Files\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Files to exclude when manually configuring your firewall for Windows 8 Professional
64-bit
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files (x86)\Sage\Sage 100 Contractor
C:\Program Files (x86)\Aatrix Software
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Files to exclude when manually configuring your firewall for Windows Vista 32-bit
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files\Sage\Sage 100 Contractor
C:\ProgramData\Aatrix Software
C:\Program Files\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Files to exclude when manually configuring your firewall for Windows Vista 64-bit
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files (x86)\Sage\Sage 100 Contractor
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C:\Program Files (x86)\Aatrix Software
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Files to exclude when manually configuring your firewall for Windows 7 Professional
32-bit
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files\Sage\Sage 100 Contractor
C:\ProgramData\Aatrix Software
C:\Program Files\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Files to exclude when manually configuring your firewall for Windows 7 Professional
64-bit
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files (x86)\Sage\Sage 100 Contractor
C:\Program Files (x86)\Aatrix Software
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Files to exclude when manually configuring your firewall for Windows 8 Professional
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files (x86)\Sage\Sage 100 Contractor
C:\Program Files (x86)\Aatrix Software
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Files to exclude when manually configuring your firewall for Windows Server 2008, 2011,
2012
C:\MB7
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Windows permissions required for Sage 100 Contractor

C:\ProgramData\Sage\Sage 100 Contractor
C:\ProgramFiles (x86)\Sage\Sage 100 Contractor
C:\Program Files (x86)\Aatrix Software
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Windows permissions required for Sage 100 Contractor
When you install Sage 100 Contractor, work with your system administrator to configure the Windows-level
security that corresponds to the operating system installed on each workstation where Sage 100 Contractor
will be used. Without the correct permissions, users may have difficulty operating Sage 100 Contractor.
CAUTION: Always back up your data before changing Windows permissions! Setting Windows
security incorrectly can adversely affect system operations. Sage is not responsible for problems
caused by incorrectly configured Windows settings.
All the directories listed below must have Full Control, Modify, Read & execute, List folder contents,
Read, and Write permission. Special permissions are not required.

Permissions required
Windows component/
version

Directories
HKEY_Current_User\Software\Sage
HKEY_Local_Machine\Software\Wow6432node\Sage

Registry Keys
HKEY_Current Config\Software\Sage 100 Contractor PDF Export
HKEY_Current Config\Software\Sage 100 Contractor RTF Export
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files\Sage\Sage 100 Contractor

Windows 8 Professional 32-bit

C:\ProgramData\Aatrix Software
C:\Program Files\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Windows 8 Professional 64-bit

C:\MB7
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Windows component/
version

Directories
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files (x86)\Sage\Sage 100 Contractor
C:\Program Files (x86)\Aatrix Software
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files\Sage\Sage 100 Contractor

Windows 7 Professional 32-bit

C:\ProgramData\Aatrix Software
C:\Program Files\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data
C:\MB7 C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files (x86)\Sage\Sage 100 Contractor
C:\Program Files (x86)\Aatrix Software

Windows 7 Professional 64-bit
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\ProgramFiles (x86)\Sage\Sage 100 Contractor

Windows Server 2008, 2011,
2012

C:\Program Files (x86)\Aatrix Software
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data
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Report scheduling and faxing functionality

Windows component/
version

Directories
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files\Sage\Sage 100 Contractor

Windows Vista 32-bit

C:\ProgramData\Aatrix Software
C:\Program Files\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data
C:\MB7
C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files (x86)\Sage\Sage 100 Contractor

Windows Vista 64-bit

C:\Program Files (x86)\Aatrix Software
C:\ProgramData\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor
Network location of Sage 100 Contractor data

Report scheduling and faxing functionality
About setting up emailing and faxing through Sage 100 Contractor
Using the faxing functionality through the Sage 100 Contractor program requires:
Installation of the Windows operating system Fax Service component
A separate installation and setup of a fax modem in your workstation
Access to an analog phone line.
In addition, you will also have to set up the cover page information and the number of times that the fax re-tries
to send.
For more information about installing and setting up your fax modem, refer to the documentation that came
with your fax modem. Sage 100 Contractor does not provide support for installing or setting up a fax modem.
For more information about installing the Windows operating system Fax Service component, see Installing
the Window Fax Services component.
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Upgrade to the latest version of Adobe Reader
Adobe Reader supports faxing from Windows. To fax from Sage 100 Contractor, you should download and
install the latest version from http://get.adobe.com/reader/.

Disable automatic updating for Adobe Reader
If you are using the scheduling capability for sending faxes, we recommend that you disable the automatic
“check for updates” capability of Acrobat Reader as it will prevent scheduled reports from completing.
NOTE: Instructions for disabling automatic “check for updates” differ from version to version of Adobe
Reader. Refer to the Adobe Reader Help for instructions.

Report Scheduling and Email Functionality
IMPORTANT: Using the email capability of Sage 100 Contractor requires Microsoft Outlook or access
to a simple mail transfer protocol (SMTP) email server.
The Email Settings window provides a way for you to set up email. You can change the selections to
accommodate different emailing preferences.
You can access the Email Settings window through:
Any Report Printing window by clicking the Email button on the toolbar to open the Email Distribution
windows. Then, click the Email Settings button to open the Email Settings window.
7-9 Alerts Manager
Click on Settings in the Dispatch Board, then click on Email Setup.

Sage 100 Contractor and SMTP
IMPORTANT: The SMTP server may be located on your workstation PC, on a server on your
company’s network, or at your Internet service provider (ISP). If the email server is local, you may need
the assistance of an IT professional to properly identify or set up this capability. If the email server is
located at your ISP, you may need contact your ISP for assistance.
Using the ISP’s simple mail transfer protocol (SMTP) server to send email via Sage 100 Contractor typically
requires “user authentication” at the STMP server. An example of an SMTP email server name is
smtp.att.sbcglobal.net.
Different ISPs may use different terms when referring to user authentication. In general, however, user
authentication means verifying a user’s identity by means of a “user name” and “password.”
In the context of sending email through Sage 100 Contractor using an ISP’s SMTP server, user authentication
only refers to verifying the user’s identity at the ISP’s SMTP server. It does not refer to your:
Sage 100 Contractor user name and password
Network domain user name and password
Windows system user name and password.
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Sage 100 Contractor API

NOTE: We do not provide support for setting up or installing an email server. You set up user
authentication and your fax line access dial out number on 7-2 Company Information.

Installing the Windows Fax Services component
To fax from Sage 100 Contractor, you must install the Windows Fax Services component:

Vista:
1. Click Start > Control Panel > Programs > Turn Windows features on or off.
2. On the Windows Features window, locate the Windows fax and scan check box, then select it.
3. Click [OK].

Windows 7:
1. Click Start > Control Panel > Programs > Turn Windows features on or off.
2. On the Windows Features window, locate Print and Document Services, then click the Windows
fax and scan check box.
3. Click [OK].

Windows 8:
1. Click Start > All apps > Control Panel > Programs > Turn Windows features on or off.
2. On the Windows Features window, locate Print and Document Services, then click the Windows
fax and scan check box.
3. Click [OK].

Windows Server 2012
Detailed information from Microsoft

Sage 100 Contractor API
System requirements for Sage 100 Contractor API
If you are using the Sage 100 Contractor API, the minimum and recommended system requirements may
vary. These requirements must be considered in addition to the recommended system requirements for
running Sage 100 Contractor.
You may need to increase the processor speed, memory and/or disk space of your system depending upon
the requirements of the third-party application using the API. Consult your third-party vendor to determine
what changes, if any, you should make to your hardware configuration in order to meet your desired
performance criteria.

Installation and License Administration Guide 15

Chapter 3: Sage 100 Contractor
Installation
This chapter provides detailed information and instructions for installing Sage 100 Contractor software in
different environments, such as:
Single user
Peer-to-peer
Network

Installation preview
Pre-installation information for new customers
Implementing and running your business in Sage 100 Contractor must be thoroughly planned out in advance to
harness the power of this software. Your existing company data must be migrated before you start working in
the program. Your business partner can assist you with a data migration and business implementation plan.
For more information about implementing Sage 100 Contractor for your company, see the information about
business partners in Chapter 1 of this guide.
We recommend that you take full advantage of all the knowledge and advice found in Sage 100 Contractor
documentation and training classes. We also recommend that you work with your business partner and
accounting professionals before you begin to implement this software for your business.
IMPORTANT: We recommend that you install the Sage license server on a computer that is always
available to other computers on your network that are running Sage 100 Contractor.

Pre-installation information for existing customers
Because existing customers are working with company information and possibly with scheduled reports,
review these important points before you install the program.
NOTE: Before you install, make at least one backup copy, but consider making two backup copies of
your existing company data for an extra margin of safety.

Upgrade Paths
Upgrade
From

Upgrade Path

18.x

Upgrade directly to version 19.x

17.x

Upgrade to 18.x, reindex your data, and then upgrade to 19.x
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Upgrade
From

Upgrade Path

16.x

Upgrade to 18.x, reindex your data, and then upgrade to 19.x

15.x

Upgrade to 18.x, reindex your data, and then upgrade to 19.x

14.x

Upgrade to 18.x, reindex your data, and then upgrade to 19.x

13.x

Upgrade to 14.x, reindex your data, and then upgrade to 19.x

12.x

Upgrade to 13.x, reindex your data, and then upgrade to 19.x

11.x

Upgrade to 13.x, reindex your data, and then upgrade to 19.x

10.x

Upgrade to 13.x, reindex your data, and then upgrade to 19.x

Duration of the installation process
Plan on at least five and possibly up to 20 minutes per computer to install Sage 100 Contractor. The duration
of the Sage 100 Contractor installation depends a great deal upon each computer’s configuration. For
example, some newer computers are pre-installed with essential software required to run Sage 100 Contractor
software such as the .NET Framework 3.5 Service Pack 1. Installation to older computers may take more
time.

Additional required software
Microsoft .NET Framework 4.0 must be installed on all computers running Sage 100 Contractor software. The
installer determines if the .NET Framework 4.0 is already installed. If not, the installer installs the required
software automatically.
Plan for an additional 20 minutes per computer to install .NET Framework 4.0.
NOTE: It is very important that you understand the network environments and operating systems on the
computers and server computers where you install Sage 100 Contractor software. For detailed
information about installing to different environments, see Special Configurations—Operating Systems
and Services.

About installing the Sage 100 Contractor software to different
configurations
You can install Sage 100 Contractor software to many different configurations, for example, stand-alone,
network server, Citrix and Terminal Services servers, peer-to-peer, and workstations.

18 Sage 100 Contractor
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IMPORTANT: The optimal operational size of a peer-to-peer network running Sage 100 Contractor is
two to five workstations. Additional workstations may adversely impact Sage 100 Contractor response
times. Networks consisting of more than five (5) workstations may need to use one computer as a
dedicated server.
Sage 100 Contractor allows users to share data and reports stored on a network hard drive. From different
workstations, users can then access the server to share one set of data, one set of reports, and one set of
report forms.
During installation, the installer checks for the components necessary to run Sage 100 Contractor and then
copies the program modules and standard reports to the Programs (x86) folder and subfolders on the hard
disk. In addition, the installation process copies system files necessary for program operations to the
Windows and Windows System folders.
The installation process does not make any configuration changes to the computer. After installation is
complete, you must configure the stand-alone computer, server computer, or workstation for optimal
performance.
For detailed information about configuring each server and workstation depending on its operating system,
see Chapter 8 Special Configurations—Operating Systems and Services.

Connectivity across your network
For client workstations to be able to run Sage 100 Contractor, they must all be connected to the Sage license
server. If one user sees the “Sage 100 Contractor can’t communicate with the designated Sage license
server” message when all other people are connected, then you know that the connectivity problem is limited
to that one person. If you encounter a hardware failure with your license server, then no one will be able to run
Sage 100 Contractor.

Mapping a network drive to access a company
You may have to map to a network drive to access a Sage 100 Contractor company if it is not located on a
drive on your local computer. Let’s suppose that the company has been moved to network drive Z: Now to
access the company data, you have to map to drive Z.

To map a network drive to access a company:
1. On your Windows desktop, click Start > Explore.
2. On the toolbar, click Tools > Map Network Drive.
3. On the Map Network Drive window, click [Browse].
4. Locate the drive, and then click [OK].
5. On the Map Network Drive window, click [Finish].
6. On the Company List window, select drive Z.
7. Select the company, and then click [OK].
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Installing the Sample Company
The Sample Company provides the means for viewing and working with sample data in Sage 100 Contractor
windows. There are sample accounts, sample employees, sample takeoffs, and much more. By viewing and
working with this sample data, you can gain an understanding of how different windows interact with the
sample data when managing a construction business with Sage 100 Contractor.
Sage 100 Contractor master trainers use the Sample Company extensively during Sage 100 Contractor
training classes. We highly recommend that you load the Sample Company during your initial installation.
You can log on to the Sample Company using “Supervisor” as the user name. You do not need a password.
The Sample Company:
Allows you a safe way to try out new functions as you learn them.
Is used in many online and recorded classes.
Provides samples of many Sage 100 Contractor forms that are all filled in. This makes it easy to
understand many concepts.
Provides starter lists for many values you'll need to set up: cost codes, cost types, tasks, client status,
client type, employee positions, paygroups, and so on.
Provides you with live data to investigate the content of Sage 100 Contractor reports.
Takes very little space on your hard disk drive.
Installing the Sample Company overwrites any previous installations of the Sample Company. If you have
made changes in your Sample Company that you want to keep, rename this folder before installing a fresh
copy of the Sample Company.

New installations
A new installation is defined as installing the software on a computer that has never had Sage 100 Contractor
installed on it before.
NOTE: Instructions for reinstallation/upgrade installation over an existing installation are different. See
See "Upgrade pre-installation" on page 23.
You must designate one computer on your network as the Sage license server. This server will manage use of
Sage 100 Contractor (for example, the number of people who can use Sage 100 Contractor simultaneously on
your network). You must install the software on this computer first, and then activate your licenses before
installing Sage 100 Contractor on your other computers.
Copy the entire set of installation files (all files and folder) to a folder that you create on a network drive. Install
the program to each client workstation by launching the installation from the network folder from that client
workstation. We recommend that you install to the Sage license server computer first. Then, when you install
the program to your workstations, you can set up Sage 100 Contractor to find the Sage license server and run
the program using your license.
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The installation process also presents different installation windows depending on whether you are installing
Sage 100 Contractor as the Sage license server or you are just installing Sage 100 Contractor by itself.
IMPORTANT: Always start installing the program at the computer that will be your Sage license server,
which is likely to be your network server.

Basic steps for new installations are:
1. Install the program on your network server, the computer where all your company data is located. You
do this only once on your network.
Remember to write down the Sage license server computer’s IP Address and/or computer name, which
is displayed at the end of the installation.
2. Activate your licenses.
3. Install the program to all client workstations on your network.
4. From each client workstation, specify the Sage license server.

Installing Sage 100 Contractor on the Sage license server
Use these instructions when installing the software on the computer you’ll use as the Sage license server or if
you are running in a stand-alone environment. Stand-alone means that you are running Sage 100 Contractor
on one computer, or you are not networking with other computers running Sage 100 Contractor.

To install from a download package unzipped into a local or shared folder:
1. Close all open programs except for firewall and anti-virus programs.
2. Browse to the drive and folder where you downloaded and extracted the software package.
3. In the folder, locate the setup.exe file, and then double-click it.
4. On the installation option window, select the option This computer will be my Sage license server,
and then click [Next].
5. On the license agreement window, read the License Agreement carefully.
6. Select the check box to accept the terms, then click [Next] to continue the installation.
7. On the select product edition window, specify whether to install the US or Canada edition.
8. On the select additional options window, select the option Install the Sample Company for training
purposes. We recommend that you install the Sample Company.
9. Click [Install].
NOTE: The installer begins the installation process. It checks to see if the computer has .NET
Framework 4.0 installed. If this program is not found, the installer installs it.
At the end of the installation process, a confirmation window appears containing a list of installed
programs.
Sage 100 Contractor
License Administration for Sage 100 Contractor
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This window also displays the computer’s IP Address and its network name. You will use this
information to specify the Sage license server.
10. Review the list of installed programs, and write down the IP Address and network name of the
computer.
IMPORTANT: Write down and keep the Sage license server computer’s IP Address and name in
a convenient location. To select the Sage license server from client computers running Sage 100
Contractor, you need to select its name from a list or type the computer’s IP Address or name in a
text box.
11. Click [Next].
The activate your product licenses window appears. The Launch the License Administration
program check box is preselected to launch the License Administration program, so you can
activate your licenses.
12. Read the instructions about activating your product licenses, and then click [Finish], leaving the
Launch the License Administration program check box selected.
For information about this process, press F1 when viewing the main License Administration window.
NOTE: When Sage 100 Contractor is installed, an icon labeled License Administration is placed in the
Start > Programs > Sage 100 Contractor menu of Windows and a file named
Sage.SMB.LicenseAdministration.exe in the Programs (x86)\Sage\Sage 100 Contractor folder to
provide you with the convenience and ability to view license information or update license information for
your provisioned license server while on a machine other than the provisioned license server. You can
provision additional licenses you have recently acquired to the actual license server machine without
having to be present at the actual license server.

Installing Sage 100 Contractor on client workstations
IMPORTANT: Before installing the software, close all open programs except for firewall and anti-virus
programs.

To install Sage 100 Contractor from a download package unzipped into a local or shared
folder:
1. Browse to the drive and folder where you downloaded and extracted the software package.
2. In the folder, locate the setup.exe file and double-click it.
3. Read the instructions on the installation welcome window, and click [Next].
4. On the installation option window, select the option This computer will run Sage 100 Contractor only,
and click [Next].
5. On the license agreement window, read the License Agreement carefully.
6. Select the check box to accept the terms, then click [Next] to continue the installation.
The installer begins the installation process. It checks to see if the computer has .NET Framework 4.0.
If this program is not found, the installer installs it.
7. Install the Sample Company for training purposes.
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TIP: We recommend that you install the Sample Company.
An installation complete window appears. The Launch Sage 100 Contractor check box is preselected
so that you can launch Sage 100 Contractor and specify the Sage license server.
8. Read the important message and follow the instructions to launch Sage 100 Contractor.
9. Click [Finish].
10. Sage 100 Contractor begins its launch process by displaying the Specify Sage License Server window.
NOTE: When Sage 100 Contractor in installed, an icon labeled License Administration is placed in the
Start > Programs > Sage 100 Contractor menu of Windows and a file named
Sage.SMB.LicenseAdministration.exe in the \Program Files (or Program Files (x86))\Sage\Sage 100
Contractor folder to provide you with the convenience and ability to view license information or update
license information for your provisioned license server while on a machine other than the provisioned
license server. You can provision additional licenses you have recently acquired to the actual license
server machine without having to be present at the actual license server.

Upgrade installations
If you currently have Sage 100 Contractor installed on your network computers and you are going to reinstall
it, you could be either upgrading or updating the software.
Upgrade installations involve major changes, enhancements, and fixes to many parts of the program or to
modules such as licensing. For example, installing Version 19 over Version 18 is an upgrade installation
because there are major enhancements to the program.
Update installations, in contrast, usually involve changes to specific files, such as the
Sage.SMB.PayrollTax.dll file and report forms. These files can be changed and updated without any changes
to major parts of the program.
In addition, upgrade installations are different from new installations. During new installations (or reinstallation
after completely removing Sage 100 Contractor and Sage licensing), you can designate a computer to be
either the Sage license server or a client workstation.

Upgrade pre-installation
Upgrading your Sage 100 Contractor software requires that you complete preliminary tasks to ensure the
safety of your company data.
When upgrading, it is important that you choose a block of time when you can install the upgrade to all the
computers in your office beginning with your Sage license server. Depending on your computer’s hardware
and your network configuration, plan on 15 minutes per computer for the installation process alone. Additional
tasks may take extra time.
The following are steps to take before upgrading Sage 100 Contractor:
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1. Back up your company data. We suggest making two backup copies in case one of them is incomplete,
becomes corrupted, or is lost.
2. Exit Sage 100 Contractor and all other programs.
IMPORTANT: You must not install the Sage 100 Contractor upgrade when either Sage 100
Contractor or the Sage 100 Contractor API are running. We recommend that you shut down all
other programs when installing Sage 100 Contractor, but you do not have to shut down firewall and
anti-virus software.
3. Locate the computer on your network that is your Sage license server, and begin the upgrade
installation there.

Upgrade installation
Always begin all installations at the computer that is the Sage license server. After installing the upgrade to
the Sage license server, install the upgrade to your workstations from the image placed in a folder on the
network. For example, if you want to install Sage 100 Contractor to a network drive, you have to go to that
computer and install the program from there.
Sage 100 Contractor running on client workstations needs to connect to the Sage license server to access
your company data. If you do not change the designation of any computers on your network during an upgrade
installation, all client workstations will be able to locate the existing Sage license server again after
installation.

Installing the upgrade
When installing, use the same upgrade installation steps for both your Sage license server and your
workstation computers.
IMPORTANT: Install the upgrade to the existing Sage license server computer first. Install the upgrade
to all workstations only after the license server installation has been completed.
To install the upgrade from a download package unzipped into a local or shared folder:
1. Shut down Sage 100 Contractor and all open programs except for firewall and antivirus programs.
2. Browse to the drive and folder where you extracted the upgrade files.
3. Before you proceed further with installation, we recommend that you double-click the ReleaseNotes.pdf
to open it in your PDF viewer.
Review the Release Notes for information about enhancements, program fixes, known issues, and
other information that might affect your upgrade installation.
4. Double-click Setup.exe to begin the installation.
5. If you get a message asking if you want to allow the following program to make changes to this
computer, click [Yes].
6. On the welcome window, notice that a previous installation has been found, and click [Next].
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7. On the installation option window, select an option, and click [Next]:
a. This computer will be my Sage license server
b. This computer will run Sage 100 Contractor only
8. On license agreement window, read the license agreement carefully.
9. Select the check box to accept the terms, and then click [Next].
10. On the select additional options window, select the option to install the Sample Company. We
recommend that you install the Sample Company, which is used extensively in Sage 100 Contractor
training classes.
IMPORTANT: The upgrade installation overwrites the existing Sample Company. If you want to
save changes to the existing Sample Company, clear the check box. If you do not overwrite the
Sample Company, you must rebuild the indexes in the Sample Company database using 7-4
Rebuild Indexes after the upgrade installation. If you have made changes in your Sample
Company that you want to keep, rename this folder before installing a fresh copy of the Sample
Company.
11. Click [Next]. The installation proceeds.
12. On the Installation complete window, click [Finish] to launch Sage 100 Contractor.
13. Repeat steps 1 through 12 to upgrade all other computers running Sage 100 Contractor.
14. Follow the instructions for post-installation tasks to rebuild the indexes for your company database from
one computer, and reschedule your reports, as necessary.

Uninstalling Sage 100 Contractor from a Sage license server
When Sage 100 Contractor is uninstalled from an active license server, the server’s licenses are deauthorized
and made available to be acquired by another license server. If the Sage license server crashes and the
licenses are not deauthorized, contact Customer Support to have the licenses unlocked.
If uninstalling and then reinstalling to a Sage license server, the licenses need to be reactivated after
reinstallation.
NOTE: Sage 100 Contractor implemented the current License Administration program with Version
18.1. Any version of Sage 100 Contractor earlier than 18.1 is using a different license administration
program.
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This chapter provides information and instructions for installing the ACT! plug-in for use with Sage 100
Contractor.

Pre-installation information
For Sage 100 Contractor to integrate with ACT!, the following requirements must be met:
Sage 100 Contractor 2013 Version 18.1 or later must be installed
ACT! Premium or ACT! PRO (version 2011 or later) must be installed
ACT! plug-in license use must be obtained

Duration of the installation process
Plan on at least five to ten minutes per computer to install the ACT! plug-in. The duration of the Sage 100
Contractor installation depends a great deal upon each computer’s configuration. Installation to older
computers may take more time.

Additional required software
ACT! Premium or ACT! PRO (version 2011 or later) must be installed on all computers running Sage 100
Contractor software that use the ACT! plug-in.
Plan for an additional 10 to 15 minutes per computer to install ACT! Premium or ACT! PRO.
NOTE: It is very important that you understand the network environments and operating systems on the
computers and server computers where you install Sage 100 Contractor software. Chapter 6 Special
Configurations provides detailed information about installing to different environments.

Installing the ACT! Plug-in
Basic steps for installation are:
1. Verify Sage 100 Contractor and ACT! Premium or ACT! Pro (version 2011 and later) are already
installed.
2. Activate your ACT! plug-in license.
3. Install the ACT! plug-in on any client workstations where you use ACT!.

Installation of Sage 100 Contractor and ACT!
To install Sage 100 Contractor, refer to “Chapter 3: Sage 100 Contractor Installation” in this guide.
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To install ACT!, refer to the installation instructions that came with ACT! Premium or ACT! PRO (version
2011 or later) and see the ACT! Getting Started Resource Center at http://na.sage.com/SageACT/support/Getting-Started.

Activate your ACT! plug-in license use
To activate your ACT! plug-in license, refer to “Chapter 6: Managing Your License” in this guide.

To install the ACT! plug-in on client workstations:
1. Close all open programs except for firewall and antivirus programs.
2. Browse to the drive containing Sage 100 Contractor (for example, Programs (x86) > Sage > Sage 100
Contractor).
3. Double-click ACTPluginSetup.exe to begin the installation.
4. On the welcome window, click [Next].
5. On the Installation complete window, click [Finish].
6. Restart your computer as necessary.
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Installation
This chapter provides information about setting up Sage 100 Contractor for use with Sage Construction
Anywhere.

Additional required software
The Sage Construction Anywhere Connector should be installed on at least one computer running Sage
100 Contractor software that connect to Sage Construction Anywhere, but can also be installed to a
separate server. The Sage Construction Anywhere Connector connects your back office software to
your Sage Construction Anywhere site. The connector installation includes the Sage Construction
Anywhere Connector software and its required prerequisite software.
An Internet connection using a compatible web browser. See "Appendix A: System Requirements" for
supported browsers in the Getting Started Guide at .
NOTE: A static Internet connection using a compatible web browser is required for Sage Construction
Anywhere.
For current information on supported browsers, supported Sage 100 Contractor versions, and other system
requirements, see the Sage Construction Anywhere help at
http://help.sageconstructionanywhere.com/sage100contractor/help/Default.htm#01_Setup/System_
requirements.htm.

Duration of the installation process
Plan on at least five to ten minutes per computer to install the Sage Construction Anywhere Connector
software. The duration of the Sage 100 Contractor installation depends a great deal upon each computer’s
configuration. Installation to older computers may take more time.

Pre-installation information
To integrate Sage 100 Contractor with Sage Construction Anywhere, you must install and set up supported
versions of the following programs:
Sage 100 Contractor
Sage Construction Anywhere
For current information on supported browsers, supported Sage 100 Contractor versions, and other system
requirements, see the Sage Construction Anywhere help at
http://help.sageconstructionanywhere.com/sage100contractor/help/Default.htm#01_Setup/System_
requirements.htm.
NOTE: A static Internet connection using a compatible web browser is required for Sage Construction
Anywhere..
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Setting up Sage Construction Anywhere Integration
In order for Sage 100 Contractor to integrate with Sage Construction Anywhere, the following programs must
be installed and set up:
Sage 100 Contractor 2013 Version 18.3 or later must be installed
Supported version of Sage Construction Anywhere
In addition, an API user needs to be set up for any companies that are to be integrated.
In Sage 100 Contractor, in 7-3-1 Security Groups, an API security group must exist with the appropriate
save permissions. See See "Setting up an API security group and an API user in Sage 100 Contractor"
on page 30 to set up the API group.
In Sage 100 Contractor, in 7-3-2 User List, a user that is a member of the API group must be set up.

Setting up an API security group and an API user in Sage 100
Contractor
Security groups let you control users’ ability to open windows as well as perform specific actions within a
window. The 7-3-1 Security Groups window in Sage 100 Contractor contains a grid with numbered rows on
the left and eight columns:
Group# (User input is required to save the record.)
Group Name (User input is required to save the record.)
Save
Delete
Void
Chg Period
Print Checks
Notes
When you set up user groups, you type a group number and group name. Then you determine whether or not
that group will have rights to Save, Delete, and Void records, as well as to change the accounting period and
print checks. You may use the Notes column to add any pertinent information about each group.
You must create an API security group that is named exactly API. At least one user must be added to the API
security group. You have to set rights to save, void, and so on.
IMPORTANT: If you use security groups for the tasks performed by the employee in Sage 100
Contractor, make sure the Sage Construction Anywhere user has access to all areas of Sage 100
Contractor.
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To set up a security group for using the API
1. Open 7-3-1 Security Groups.
2. In the Group# cell, type a group number, such as 51.
3. In the Group Name cell, type API and do the following:
IMPORTANT: The API security group must be named exactly API.
a. In the Save, Delete, Void, Chg Period, and Print Checks cells, type Yes.
b. To store information that may be relevant or important to that specific group, type a note in the Notes
cell.
4. On the File menu, click Save.
TIPS:
Before you can use the API security group to access Sage 100 Contractor company data, you have
to assign a user to the API security group.
Security is set up for each individual company, not for the entire program. Each company can use
different user names and passwords. If you have more than one company, you have to set up
passwords for multiple companies.
Then you have to assign a user to the API security group using 7-3-2 User List.
The 7-3-2 User List window controls major features dealing with users and program security.
NOTE: The user name and password created are for administrative use only. This information is for use
by the Sage Construction Anywhere Connector program only, and is not needed by the individual
employee(s) using Sage Construction Anywhere.

To assign a new user to the API security group
1. Open 7-3-2 User List.
2. In the User Name cell, enter a user name, such as SCAUser.
3. In the Password cell, enter a password.
4. In the Group 1 cell, click once in the cell, and from the drop-down list, select the API group.
5. Click File > Save.
IMPORTANT: The API will not accept “supervisor” as a user name.

To assign an existing user to the API security group
1. Open 7-3-2 User List.
2. Find the User Name for the person who will use Sage Construction Anywhere.
3. In the Group 1, Group 2, Group 3, Group 4, or Group 5 cell, click once in the cell, and from the dropdown list, select the API group.
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4. Click File > Save.
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Chapter 6: Managing Your License
This chapter provides detailed information about:
Managing and activating your license
Using License Administration

License administration
When you purchase Sage 100 Contractor software, it includes the License Administration program. Using the
License Administration program, you can activate licenses and monitor the license uses. During software
installation, the License Administration program is automatically installed on the computer that the software
installer designates as the Sage license server.
IMPORTANT: Before you can use Sage 100 Contractor with your activated license, you have to
specify the computer on your network that is the Sage license server when you launch Sage 100
Contractor.

Where is the Sage license server located?
The Sage license server is software running on a computer on your network that manages the Sage 100
Contractor products and features that you purchased. Products and features can be a “core product,”
additional “modules,” and a number of “license uses.” The computers running your Sage 100 Contractor have
to be connected to the computer running the Sage license server so that the correct products, features, and
number of license uses are available to you.

Which versions of Sage 100 Contractor use License Administration?
Sage 100 Contractor implemented the current License Administration program with Version 18.1. Any version
of Sage 100 Contractor earlier than 18.1 will not work with the License Administration program described in
this chapter.

About managing licenses
Use the License Administration window to activate licenses and monitor license uses.

Activating licenses
In order to use Sage 100 Contractor, you have to activate your product licenses.
To activate your license:
1. On the License Administration window, click the Edit registration info link.
2. Enter your Sage client ID.
3. Enter your Registration name.
4. Click [OK].
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Contractor
This chapter provides all the necessary details about:
Specifying the Sage license server
Managing license attributes
Understanding license uses

Specify Sage License Server
What is a server?
There are many kinds of servers. Some servers are denoted by their hardware configuration and a specialized
operating system. Other servers consist of specialized software applications running on standard computers.
Some servers are called “file servers” and may be a powerful computer dedicated to storing files and data. For
example, Sage 100 Contractor company data can be stored on a file server. Any Sage 100 Contractor user on
the same network as the file server can access and store data there.
A server can also be a software application that provides a specific kind of service to client software running
on other computers. The term server can refer to a particular piece of software, such as the Sage license
server. When we refer to the Sage license server, we are describing a computer that is running the Sage
license server software.
Before you can use Sage 100 Contractor with your activated license, you have to specify the computer on
your network that is the Sage license server. There are two ways to specify the Sage license server:
You can select the computer from the list of computers on your network; or
You can enter the IP Address or name of the computer.

Selecting the Sage license server computer
One method is to select the computer running the Sage license server from the list of network computers.
NOTE: To use this method of selecting a server from the list of network computers, you must have
already clicked the appropriate link on the Specify Sage License Server window.

To select the computer running Sage license server from the list of network computers:
1. On the Select License Server window from the list of network computers, select the computer running
the Sage license server.
2. Click [OK].
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Entering the IP Address or name of the computer
One method is to enter the IP Address or name of the computer running the Sage license server.

To enter the IP Address or name of the computer running the Sage license server:
1. In the text box, type the IP Address or name of the computer.
2. Click [OK].

Determining the IP Address of a computer
NOTE: If you are trying to determine the IP Address computer running the Sage license server, you
must complete this procedure on that computer.

To determine the IP Address of a computer:
1. Click Start > Run.
2. In the Open text box, type cmd, and then click [OK].
The \Windows\...\cmd.exe window appears.
3. At the prompt, type ipconfig.
For example, you might see H:\. Type ipconfig after the drive letter.
4. Press the [Enter] key.
The system displays several addresses including the IP Address of the computer, similar to this line:
IP Address . . . . . . . .172.20.22.142

What is an IP Address?
Every computer connected to the Internet is assigned a unique number known as an Internet Protocol (IP)
address. This numeric address of a computer on the Internet is written as a set of four numbers separated by
periods (each number can range from 0 to 255). An example of an IP Address is 123.123.4.5.

Determining the name of a computer
NOTE: If you are trying to determine the name of the computer running the license server, you must
complete this procedure on that computer.

To determine the name of a computer:
1. On your Windows desktop, click Start > Settings> Control Panel.
2. From the list, scroll to and then double-click System.
The System Properties window appears.
3. Locate the line Full computer name, and then write down the name or type it into a note that you can
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print.
4. Click [Cancel].
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Operating Systems and Services
This chapter contains information about special configurations for specific operating systems, such as:
Windows 8 Professional and Server 2012 Standard
Windows® 7 Professional and Windows Server 2008® R2 Standard
Windows Vista® and Windows Server 2008
Citrix® and Terminal Servers

Windows 8 Professional and Server 2012 Standard Operating
Systems
Windows 8 Professional and Server 2012 Standard "Sleep Mode"
prevents computers from obtaining a license use
If a computer running the Windows 8 Professional or Server 2012 Standard operating system is used as a
license server, when it goes into sleep mode other computers on the network can’t obtain a license.
To avoid this possibility, set Sleep Mode on your license server computer to Never.

To set the Sleep Mode to “Never”:
1. Start > All apps > Control Panel > System and Security > Power Options.
2. Select Change when computer sleeps.
3. From the Put computer to sleep list, select Never.

Sage licensing (Sage 100 Contractor Hosting Framework) cannot autostart on Windows 8
The Sage licensing service (Sage 100 Contractor Hosting Framework) cannot auto-start on computers
running the Windows 8 Professional or Windows 8 Enterprise operating systems. If the service stops, the
program displays a message advising you to take further action to resolve this issue.

Solution for Server 2012 error message about mb7.kpr file
If you encounter an error message about opening the mb7.kpr file when launching Sage 100 Contractor on a
computer running Windows Server 2012, follow these steps to resolve the issue:
1. On the Window desktop, right-click Start, and then click Explore.
2. On the left side of the window, under Folders, right-click the MB7 folder, and then select Properties.
3. On the MB7 Properties window, click the Security tab.
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4. From the list under Group or User Names, select USERS, and then click [Edit].
5. On the Permissions window, select USERS again, and under Allow, select the Full control check
box.
(Selecting Full control selects all the check boxes necessary for this solution.)
6. On the Permissions window, click [OK].
7. On the MB7 Properties window, click [OK].

Server 2012 network configuration and TCP Remoting Channel
Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component to enable
communication among computers on a network. File and printer sharing on computers running the Server
2012 operating system must be enabled. To enable file sharing, follow the instructions in the Windows Server
2012 Help.

Windows 7 Professional and Server 2008 R2 Standard
Operating Systems
Windows 7 Professional, Windows 8 Professional, and Server 2008 R2
Standard "Sleep Mode" prevents computers from obtaining a license use
If a computer running the Windows 7 Professional, Windows 8, or Server 2008 R2 Standard operating system
is used as a license server, when it goes into sleep mode, other computers on the network can’t obtain a
license.
Set Sleep Mode on your license server computer to Never.

To set the Sleep Mode to “Never”:
1. Start > Control Panel > System and Security > Power Options.
2. Select Change when computer sleeps.
3. From the Put computer to sleep list, select Never.

Sage licensing (Sage 100 Contractor Hosting Framework) cannot autostart on Windows 7 Professional and Server 2008 R2 Standard
The Sage licensing service (Sage 100 Contractor Hosting Framework) cannot auto-start on computers
running the Windows 7 Professional or Server 2008 R2 Standard operating systems. If the service stops, the
program displays a message advising you to take further action to resolve this issue.

Solution for Server 2008 R2 error message about mb7.kpr file
If you encounter an error message about opening the mb7.kpr file when launching Sage 100 Contractor on a
computer running Windows Server 2008 R2, follow these steps to resolve the issue:
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1. On the Window desktop, right-click Start, and then click Open Windows Explorer.
2. On the left side of the window, under Computer > Local Disk, right-click the \MB7 folder, and then
select Properties.
3. On the MB7 Properties window, click the Security tab.
4. From the list under Group or User Names, select USERS, then click the [Edit] button.
5. On the Permissions window, select USERS again, and under Allow, select the Full control check
box.
Selecting Full control, selects all the check boxes necessary for this solution.
6. On the Permissions window, click [OK], and then on the MB7 Properties window, click [OK].

Server 2008 R2 network configuration and TCP Remoting Channel
Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component to enable
communication among computers on a network. File and printer sharing on computers running the Server
2008 R2 operating system must be enabled. To enable file sharing, follow the instructions in the Windows
Server 2008 R2 Help.

Windows Server 2008 R2 and Microsoft .NET 3.5.1
Microsoft .NET 3.5.1 must be available and enabled prior to installing Sage 100 Contractor on a Windows
Server 2008 R2 machine. Server 2008 R2 comes with .NET 3.5.1 loaded but not installed, so Sage 100
Contractor doesn’t install it automatically.
If you attempt to install Sage 100 Contractor without .NET 3.5.1 installed, you will receive the following
message during the licensing install: “Sage.CRE.HostingFramework.Service v3.2 has stopped working.”
When you click [OK], the installation continues, but the services have not been installed so Sage 100
Contractor cannot open. The Sage.CRE.HostingFramework Service will not install unless .NET 3.5.1 has
been installed. If you receive the above message during installation, install .NET Framework 3.5.1 and
reinstall Sage 100 Contractor.

To verify that .NET 3.5.1 is installed on Windows Server 2008 R2:
1. Click the Start button in the lower left corner of the display.
2. Highlight Administrative Tools and select Server Manager.
3. In the Server Manager interface, click Features to display all the installed Features in the right-hand
pane. Verify that .NET Framework 3.5.1 is listed.

To enable .NET 3.5.1 on Windows Server 2008 R2:
1. In the Server Manager interface, select Add Features to display a list of possible features.
2. In the Select Features interface, expand .NET Framework 3.5.1 Features.
3. Once you expand .NET Framework 3.5.1 Features, you will see two check boxes. Check the box next
to .NET Framework 3.5.1 and click Next.
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4. In the Confirm Installation Selections interface, review the selections and then click [Install].
5. Allow the installation process to complete and then click [Close].
NOTE: Enabling .NET Framework 3.5.1 may require a reboot.

Windows Vista and Server 2008 Operating Systems
Vista and Server 2008 “Sleep Mode” prevents computers from obtaining
a license use
If you are using a Vista or Server 2008 computer as the Sage license server and it goes into Sleep Mode, the
workstations cannot obtain a license use.
Use a different computer on your network to be the Sage license server. Any supported operating system can
be used in place of Vista or Server 2008.
Set Sleep Mode on your license server computer to Never.

To set the Sleep Mode to "Never":
1. Start > Control Panel > System and Maintenance > Power Options.
2. Select Change when computer sleeps.
3. From the Put computer to sleep list, select Never.

Sage licensing (Sage 100 Contractor Hosting Framework) cannot autostart on Vista, Windows 7, Windows 8, or Server 2008
IMPORTANT: Read this information if you are running Vista or Server 2008 operating systems on your
office computers.
The Sage licensing service (Sage 100 Contractor Hosting Framework) cannot auto-start on computers
running the Vista, Windows 7, Windows 8, or Server 2008 operating systems. If the service stops, the
program displays a message advising you to take further action to resolve this issue.

Solution for Server 2008 error message about mb7.kpr file
If you encounter an error message about opening the mb7.kpr file when launching Sage 100 Contractor on a
computer running Windows Server 2008, follow these steps to resolve the issue:
1. On the Window desktop, right-click Start, and then click Explore.
2. On the left side of the window, under Folders, right-click the MB7 folder, and then select Properties.
3. On the MB7 Properties window, click the Security tab.
4. From the list under Group or User Names, select USERS, then click [Edit].
5. On the Permissions window, select USERS again, and under Allow, select the Full control check
box.
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Selecting Full control selects all the check boxes necessary for this solution.
6. On the Permissions window, click [OK], and then on the MB7 Properties window, click [OK].

Vista, Windows 7, and Server 2008 network configuration and TCP
Remoting Channel
Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component to enable
communication among computers on a network. File sharing on computers running the Vista, Windows 7, or
Server 2008 operating system must be enabled. To enable file sharing, follow the instructions in the
Vista, Windows 7, or Server 2008 Help.

Vista, Windows 7, and Server 2008 and changing the Sage License
Server computer
On a Vista, Windows 7, or Server 2008 workstation, when you select File > Change Sage License Server >
Select the computer from the list of computers on your network, the command may fail to generate a list
of network computer names. To resolve this issue, click Enter the IP address or name of the computer,
and then type the IP address of the server computer in the box.

Citrix and Terminal Servers
Using Citrix and Terminal Server with Sage 100 Contractor
Many people use Citrix and Terminal Server to manage remote access to their local area network (LAN). If
Sage 100 Contractor is installed on the computer running Citrix or Terminal Server and on your laptop, then
you may log on to the computer running Citrix or Terminal Server with your laptop and work in Sage 100
Contractor on your LAN. This enables you to work from home, from a job site, or from any number of other
remote locations.
We recommend that you use DOS commands to change the operating mode from “execute” to “install” and
then back to “execute.” When using the DOS commands to install, you may install the Sage 100 Contractor
software as you would on any desktop or Windows server operating system that meets Sage 100 Contractor
requirements.

Installing on computers running Citrix and Terminal Server using DOS
commands
To install using DOS commands:
1. Click [Start] > Run.
2. On the Run window:
a. In the Open drop-down box, type cmd.
b. Press [Enter].
The \Windows\...\cmd.exe window appears.
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3. When prompted, type change user /install, and then press [Enter] to turn on the Install mode.
4. Install Sage 100 Contractor as you would on a typical workstation or Windows Server.
5. At the end of the installation process, launch License Administration Tool.
6. Use the License Administration Tool window to activate and manage your license.
7. After activation, click Start > Run.
8. On the Run window, in the Open drop-down box, type cmd, and then press [Enter].
The \Windows\...\cmd.exe window appears.
9. When prompted, type change user /execute to turn on the Execute mode, the default mode for running
Citrix and Terminal Server.
10. Exit the Run window.
11. Restart the server.
IMPORTANT: If this message appears: “Install mode does not apply to a terminal server configured for
remote administration,” then it is not necessary to enable the install mode. You may install the Sage 100
Contractor software as you would on a typical workstation.

Backing Up Your Data
With any computer system, there is the possibility for failure and loss of data.
CAUTION: Use a backup method and device suitable for your business requirements. We strongly
recommend that you maintain a routine backup schedule and store your data in a safe environment that
is separate from your server, preferably off site.

Which files to back up in Sage 100 Contractor
NOTE: This topic applies only to existing Sage 100 Contractor customers.
When you back up your company data, we recommend that you back up your company financial data as well
as all your custom reports and forms. If you are running multiple Sage 100 Contractor companies, back all of
them up.
When backing up data as part of the year-end close process, it is important to count the number of files and
folders in your company.
To see the number of files and folder in a company folder, in Windows Explorer, right-click the company folder
and select Properties. On the Properties window, the General tab, look in the list for the Contains line for the
number of files and folders. Write this number down so that you can refer to it after you have made the two
copies. The number of files and folders has to be exactly the same in both the company and the backup copy.
We strongly recommend that you back up:
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Each company folder that contains financial data (\MB7\Your Company\)
The Sage 100 Contractor folder (\Users\Username\AppData\Local\Sage\Sage 100 Contractor)
The Report Forms folder (\MB7\Report Forms)
The Custom Reports folder (\MB7\Custom Reports)
IMPORTANT: When backing up your data, be sure to make a full backup and not an incremental or
differential backup. An incremental or differential backup only records alterations to the data since the
last backup.

An example of one backup method
There are various methods for backing up your data. Depending on the amount of data you enter routinely,
consider making full daily backup copies. It is also a good idea to regularly take one copy off the business
premises or store your backed-up data in a fireproof safe. If a burglary or fire occurs, a copy of your data is
safe from harm.
One reliable procedure, requiring a tape drive and multiple sets of tapes, requires you to back up your data
daily and monthly.

Daily Backup Process
For the daily backup process, you need 10 tapes. Label five of the tapes as Week A, with a tape designated
for each weekday. Label the other five tapes as Week B, with a tape designated for each weekday.
Start with the set of tapes labeled Week A. Monday night when you make the backup use the tape labeled
Monday, on Tuesday use the tape labeled Tuesday, and so forth. At the start of the next week, use the set of
tapes labeled Week B to make your backup copies. At the end of two weeks, you will have backed-up data for
each day. Then at the start of the third week, use the set of tapes labeled Week A again. Over the course of a
year, you will cycle through the two sets of tapes. Be sure to store the most recent Friday backup off site.

Monthly Backup Process
For the monthly backup process, you need a separate set of three tapes labeled Month A, Month B, and Month
C respectively. Like the weekly backups, use each tape to back up the data for a different month, cycling
through each of the tapes over the course of the year. After making a monthly backup copy, write the month
and year on the label to help you track which tape to use next. Be sure to remove the most recent monthly
backup off site.

Backing up your data to a CD or DVD
This topic suggests a generic way to back up your data to a CD or DVD. Backing up to a CD or DVD
successfully depends on your computer system, including hardware and software. To back up to a CD or
DVD, you must have access to a CD or DVD (Read/ Write capability), and the appropriate CD or DVD media.
When backing up data as part of the year-end close process, it is important to count the number of files and
folders in your company. To see the number of files and folder in a company folder, in Windows Explorer, rightclick the company folder and select Properties. On the Properties window, the General tab, look in the list for
the Contains line for the number of files and folders. Write this number down so that you can refer to it after
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you have made the two copies. The number of files and folders have to be exactly the same in both the
company and the backup copy.
IMPORTANT: If you are working across a network, you must remember to backup company folders,
report folders, and form folders that reside at the server.

To back up your data to a CD or DVD
1. Place the CD or DVD media in the CD or DVD.
2. On your Windows desktop, right-click [Start] > Explore.
3. In Windows Explorer:
a. Locate and then right-click the \Users\Username\AppData\Local\Sage\Sage 100 Contractor folder.
b. From the menu, select Copy.
4. Locate and then click the CD or DVD drive.
5. In the right-pane, right-click and then select [Paste].
6. In Windows Explorer:
a. Locate and then right-click the \MB7\ folder.
b. From the menu, select Copy.
7. Locate and then click the CD or DVD drive.
8. In the right-pane, right-click and select [Paste].
Depending on your hardware and software, the folder will be copied to the CD or DVD media. For further
information or support, contact your CD or DVD manufacturer.

Configuring Windows Regional and Short Date Format
To specify regional formats for Windows:
1. Click the [Start] button, point to Control Panel, then click Clock, Language, and Region .
2. Click Region and Language.
3. On the Formats tab, select the format for your country.
4. Under Date and time formats, from the Short date format drop-down list, select the format used for
your country.
5. Click [OK].
6. Close the Clock, Language, and Region window.
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