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August 2018 Update (Build 21.1.113)
Fixes in the August 2018 Update
We have fixed several issues in this product update.

Fixes for Both Editions
l

Printed payment check stubs (for 4-3-2-21 and 4-3-2-23 vendor checks) now display the full invoice
number, up to 20 characters.

l

When you create an AP invoice from a PO, any PO job cost defaults are properly cleared after you
save the invoice, so that the next AP invoice you create does not display them.

l

In the 1-5 Bank Reconciliation window, you no longer receive an error message if you try to modify a
transaction that was previously matched to a bank feed.

Fixes for the U.S. Edition
The following issues were fixed specifically for the U.S. Edition of Sage 100 Contractor:
l

Sage 100 Contractor state tax reports exclude separate wages and amounts for the Oregon
Statewide Transit Tax (OR STT). Neither wages subject to OR STT nor the amount of OR STT
withheld are reported.

l

You no longer receive a message about entering a marital status when you save an employee
record with an OR STT calculation. \

l

The OR STT calculation computes correctly even if the calculation and rate is not in the employee
record. This means that tax is calculated automatically for non-resident employees working in
Oregon and subject to the tax.
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July 2018 Update (Build 21.1.111)
U.S. Payroll Tax Tables—July 2018 Update
Payroll tax tables have changed for the following jurisdiction:
l

New Mexico

Canadian Payroll Tax Tables—July 2018 Update
The following province mandated payroll tax changes, effective July 1, 2018:
l

Prince Edward Island

For detailed information on personal amounts, see the TD1 form for each province or territory.

Enhancements for the U.S. Edition
l

We have added support for the Oregon Statewide Transit Tax (OR STT). For more information
about how to apply this tax, see Knowledgebase article 91872. For steps on setting up a calculation
for the OR STT, you can also refer to the help topic "Oregon State Tax."

Enhancements for the Canadian Edition
l

The format for the EFT Header file has changed for the CIBC Settlement account, as required by the
Canadian Imperial Bank of Commerce. The Settlement Account# field position 1264-1275 in the
header record now includes 7 digits followed by 5 blanks, for a total of 12 digits.
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Fixes in the July 2018 Update
We have fixed several issues in this product update.

Fixes for Both Editions
l

l

You no longer receive an error when you print a report using a custom field to define the sort order.
When you open a window that has custom fields to which you do not have access, the window opens
properly, without displaying the custom fields.

API for Third-Party Developer Products
l

When the API is used to delete a line in a table, line numbers are re-ordered correctly, with no added
lines.
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Enhancements in version 21.1
This section describes the new features and enhancements you will find in version 21.1.

We've been listening to you!
Sage thanks you for your product ideas! In version 21.1, we have incorporated the following top-ranked
suggestions. Later sections describe changes that require more detailed explanation.
l

If you sign in with company administrator rights, you can permit (or deny) exclusive access to
selected non-administrative users.
Thank you Dan R. for suggesting this feature.

l

You can require users to enter a validated cost type when they record expenses to a direct cost
account.
In addition, you can print a new Job Cost Type Reconciliation report, making it easier for you to audit
and reconcile general ledger accounts with direct job costs.
Thank you Kay K. for this suggestion.

l

The cost code you enter on a purchase order is used on any invoices you record against the
purchase order, even if you do not choose to cost jobs automatically when you save an invoice.
(Previously, the default cost code from the vendor record was used on an invoice if you did not use
this function.)
Thank you Maureen D. for this idea.

l

When you enter invoices in the 4-2 Payable Invoices/Credits window, filtered lookup windows make
it much easier to find the purchase order or subcontract you are looking for.
Now, enter the Vendor# and/or Job# before opening the purchase order or subcontract lookup
window so that the lookup window displays only subcontracts or purchase orders for the specific
vendor or job.
Thank you Rik M. for submitting this idea on behalf of our customer.

l

In the 4-3-5 Accounts Payable Check report, we have added the invoice date to AP check stubs.
Thank you Ken K. for submitting this idea on behalf of our customer.
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l

We have also added the invoice date to 4-3-1-21, 4-3-1-31, and 4-3-1-41 Set To Pay reports.
Thank you Darcel B. for the suggestion.

l

You can now choose to find employees throughout the program by their last names, rather than by
their first names.
To use this feature, you first select the new Find Employee by Last Name option on the menu of
either the 5-2-2 Payroll Records window or the 5-5-1 Daily Payroll Entry window.
Thank you Stephanie S. and Melissa A. for these suggestions.

l

You can view an employee's pay raise history in the employee record.
Thank you Jordan D. for this suggestion.

l

In 5-5-1 Daily Payroll Entry, in the Create Timecards window, you can use a pick list to select
employees for whom to create timecards.
Thanks to Robin S., Heather J., and Jenna Y. for this suggestion.

l

When you generate a direct deposit for payroll, you can easily email the pay stubs at a later date
instead of the date you are running the payroll.
Thank you Melissa K. for this suggestion.

l

The 5-2-2 Payroll Records window provides a new Salaried Employees menu with options that
make it easy to create payroll records for salaried employees.
Thank you Curtis M. for this suggestion.

l

We have restored the ability to create timecards in 5-5-1 Daily Payroll for users who do not have
permission to use the 5-2-2 Payroll Records window directly.
Thank you Charlene D. for pointing out this omission.

l

In U.S. Payroll, sick leave is now accrued separately for federal jobs, up to a specified maximum.
(DT38789)
Thank you Erin G. and Tim G. for this suggestion.

l

Inactive, zero balance accounts no longer appear on financial reports. The Balance Sheet, Income
Statement, and Financial Reports automatically exclude zero balance inactive accounts, regardless
of whether you select the option to exclude zero balance accounts.

l

The default period is no longer filled in automatically for most Project Management reports.
Thanks to Kathy L., Jim W., and Alice M. for this suggestion.

l

When you export a report to Excel, the resulting worksheet is not automatically protected, enabling
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you to edit it without first "unprotecting" the worksheet.
Thank you Joe D. for suggesting this improvement.
l

We have increased the maximum duration for term-based fields to 60 months so, for example, you
can lengthen the Service Employee Training cycle.
Thank you Shelly G. for this suggestion.

Do you have a product idea you want to share with us?
We want to hear it!

To suggest a product enhancement when you're working with Sage 100 Contractor:
1. On the Sage 100 Contractor desktop, click the Home & Resources tab > Submit Product Idea.
2. Log in to the Sage 100 Contractor Ideas site (or sign up).
3. Describe your idea.
4. (optional) Browse through others' suggestions, and vote for the ones you love!
Or visit https://www5.v1ideas.com/TheSageGroupplc/Sage100Contractor any time you're online!
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Download bank transactions for easier reconciliation
Sage Bank Feeds enables you to download transaction records from your bank and let Sage 100
Contractor automatically match transactions from your bank with transactions entered in your Sage 100
Contractor system. (If you download transactions for the same period as your bank statement, you
essentially have an electronic copy of your bank statement.)
This automated matching process removes much of the tedium of bank reconciliation and ensures that
your company records match the transactions processed by your bank.

How it works
In the 1-5 Bank Reconciliation window, you select the account that you want to set up to use bank feeds,
and the date of the statement you are going to reconcile. Then, you use the Connect to Bank Feeds option
on the new Bank Feeds menu to establish a secure online connection with your bank and download
transactions.
Depending on which bank you use, Bank Feeds links to your bank using either the Sage Direct Bank Feeds
service or a secure, third-party data aggregation service, such as Yodlee (in Canada) or Plaid (in the U.S.).

Note: If you use Plaid or Yodlee to access your banking data, you must also provide them with your
online banking credentials. To protect this sensitive information, your credentials are not stored by Sage
or available within Sage 100 Contractor.
After downloading transactions from your bank, you match them to Sage 100 Contractor transactions in
the new Match Banking Transactions window, also available from the Bank Feeds menu. You also use this
window add new transactions that your bank may have processed to your account, such as interest
charges or bank fees, that are not yet recorded in Sage 100 Contractor.

Using Sage Bank Feeds to reconcile accounts involves the following general steps:
1. Connect your Sage 100 Contractor bank account to Sage Bank Feeds.
2. In the 1-5 Bank Reconciliation window, download the bank transactions for the bank statement you
want to reconcile.

Note: You click [Display] to download the transactions.
3. Use the Match Banking Transactions window to:
l

Match transactions from the bank feed with your Sage 100 Contractor bank account
transactions. (Sage 100 Contractor matches many transactions for you, but you may still need
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to reconcile some transactions manually.)
l

Enter any transactions missing from your Sage 100 Contractor account, such as bank
processing fees or interest charges.

Note: You click Bank Feeds > Match Banking Transactions to open this window.
The next sections describe these processes in more detail.

Connecting to Sage Bank Feeds
To connect to Sage Bank Feeds:
1. Open 1-5 Bank Reconciliation.
2. Select a bank account, and then:
a. (Optional) Select a statement cutoff. (Sage 100 Contractor does not display transactions
entered after the indicated date.)

b. From the Banks Feeds menu, click Connect to Bank Feeds.
Note: This option is available only after you select a bank account.
3. In the Bank Feed wizard that opens:
a. Enter a primary email address for Sage Bank Feeds.
b. Agree to the Terms and Conditions, and then click [Get Started].
c. Enter your banking credentials.
d. Select a Start date for your historical transactions.
Note: As long as the account is not "active" (connected), you can return to the Connect
option and edit the Admin Email and other bank information. Editing this information could
generate a new Bank Account ID.
Once the account is active, the Connect option is no longer available, and the Disconnect
option becomes available.

e. Click [Process].
Note: Whether you connect directly to your bank or through an aggregator service (such as
Plaid or Yodlee), retrieving historical transactions can take several days or just a few
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minutes, depending on how far back the historical transactions go.

f. Click [OK ] to close the message box that appears.

After connecting to your bank account
Once the account is active (that is, the bank has authorized the connection), you can click [Display Items]
to retrieve bank transactions, now and in future.

Automatically matching bank transactions with Sage transactions
After you download bank transactions, the Match Banking Transactions window appears. Automatically
matched transactions are displayed in the bottom portion of the Match Banking Transactions window.
The program automatically matches bank transactions with transactions in Sage 100 Contractor if they:
l

Are unique (if very similar or duplicate transactions exist in your system, they cannot be matched
automatically).

l

Have the same payee and amount.

l

Are dated earlier than the corresponding bank transaction.

If one Sage general ledger transaction matches a downloaded bank transaction, it is moved to the list of
matched transactions at the bottom of the window.
If there are multiple potential matches, you receive a message that tells you that the associated Sage
transactions remain open (unmatched).

Manually matching transactions to finish the reconciliation
To finish the reconciliation, you match any transactions remaining in the top part of the window manually.
Select each unmatched banking transaction on the left side of the window, and then click the
corresponding Sage 100 Contractor transaction (or transactions) on the right side of the window.
Use the buttons on the window to finish the reconciliation as follows:
l

Remove. You use this button to remove a selected transaction from the bank transaction list. For
example, if you downloaded a bank transaction that you reconciled previously, it is no longer
outstanding, so you can simply remove it from the transactions to be reconciled.

Note: Removing the transaction from the bank transaction list does not affect your Sage 100
Contractor transactions.
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If the transaction was matched previously, the Sage 100 Contractor transaction will appear in the 15 Bank Reconciliation window as a manually matched transaction.
l

l

Add to Sage. You use this button to add a selected bank transaction to your Sage 100 Contractor
ledger using the Post Bank Transaction to Sage window. You can add the following typical bank
transactions:
l

Bank fee

l

Bank service charge

l

Bank interest paid

l

Bank interest earned

Match. When matching bank transactions manually, you can select one or more Sage transactions.
(To select several Sage transactions, hold the Ctrl button down as you select transactions from the
list.) When the amount of the selected Sage transactions equals the bank transaction, the Match
button becomes available.

Note: The bank transaction type (Deposit or Payment) must match the type of Sage transaction
selected, or you will not be able to match the transactions.
Clicking [Match] moves the selected transactions to the list of matched transactions.
l

Unmatch. If you make a mistake while matching, or if an automatic match is not correct, you can
select the matched bank transaction, and then click [Unmatch] to remove the bank transaction and
the Sage transaction(s) from the list of matches, restoring the transactions to the upper part of the
window where you can match them with other transactions.

l

Confirm Matches. You can click this button whenever you have matched transactions that you want
to add to the 1-5 Bank Reconciliation window.
When you click this button, you are returned to the 1-5 Bank Reconciliation window.
Sage 100 Contractor displays the results in the grid in the 1-5 Bank Reconciliation window, and
marks automatically matched transaction with a double check mark, indicating that they have been
cleared through the Bank Feeds reconciliation process.
If you clear the check marks for a transaction, both the bank transaction and the previously matched
Sage transaction are restored to the Match Banking Transactions window, where you will need to
match them manually.

If you click Bank Feeds > Match Banking Transactions after beginning the reconciliation process, the
Match Banking Transactions window appears showing the current state of reconciliation, until you save a
Final reconciliation for the period.
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Saving the bank reconciliation
When you save a reconciliation, you can choose to save it as a Trial version or a Final version.
l

l

If you save a Trial reconciliation, when you next display the account, if you click [Display Items], all
previously matched transactions, as well as any new transactions, are displayed in the 1-5 Bank
Reconciliation window.
If you save a Final reconciliation, previously matched items are no longer available for
reconciliation.

Providing you have not done a Final save of the bank reconciliation, you can click Bank Feeds > Match
Banking Transactions at any time to return to the Match Banking Transactions window and continue the
reconciliation process.

Sample data includes sample bank feed records
Note: We updated the sample data to include records that demonstrate bank feed features. You will find
these transactions in General Ledger account 1000.

Email direct deposit stubs at a later date
When printing direct deposit stubs for payroll, you can choose to email the stubs at a later date, rather than
sending them on the same date you are running the payroll.
To enable you to use this different workflow, we have reorganized the 5-2-5 Direct Deposit File Manager
window, as follows:
l

You use the new Assign Check Numbers tab in the 5-2-5 Direct Deposit File Manager window to
select payroll records for direct deposit and to assign check numbers for the check stubs you plan to
email to employees later.
When you click [OK] on this tab, you can specify the starting check number for the direct deposit
batch, as well as the check date. You can also open a separate window if you want to preview a list of
the direct deposits and the check numbers that will be assigned to the check stubs.
You can also specify a whether to sort the direct deposit file by payroll record or employee name.

l

After selecting records for direct deposit, you use the Direct Deposit File tab to specify the check
date and deposit date for the direct deposit, and to generate the direct deposit file for your bank.
You click [Start] on this tab to generate the direct deposit file. Only computed or posted payroll is
included in the file.
This tab also displays the direct deposit batch number for your information.
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After assigning check numbers and generating the direct deposit file, you print or email the check stubs
using the 5-2-4 Payroll Checks window. To print the check stubs at any time after running the payroll,
select the Reprint Checks option.

Important! You should use the same criteria to print or email check stubs as you used to create the direct
deposit file.
For more information about direct deposit and emailing check stubs, see the Sage 100 Contractor help.

Enhanced cost type validation
You can now enforce the use of the cost type specified for the account (in the General Ledger Accounts
record) when users post direct or WIP expenses to General Ledger. This validation ensures that allocated
job costs do not exceed the sum of expenses posted to general ledger direct expense and WIP accounts
for any cost type.
To require users to enter valid cost types with journal transactions, select the new Require cost types on
expense accounts option on the Posting Accounts tab in the 1-8 General Ledger Setup window. You
define the cost type for each direct expense or WIP account in the 1-7 General Ledger Accounts window.
Cost types are then validated when you post, and in some cases when you save, transactions to direct
expense or WIP accounts in the following windows:
l

1-1 Checks and Bank Charges

l

1-2 Deposits and Interest

l

1-3 Journal Transactions

l

1-4 Recurring Journal Transactions (saving and posting)

l

3-2 Receivable Invoices/Credits (saving and posting)

l

3-11 Recurring Receivables (saving and posting)

l

4-2 Payable Invoices/Credits (also holdback billing)

l

4-6 Recurring Payables (saving and posting)

l

4-7-3 Enter Credit Card Receipts

l

6-6-1 Purchase Orders (you receive a warning if you save with an invalid cost code)

l

11-2 Work Orders/Invoices/Credits (validated in the Invoice Type window)

l

l

12-2 Inventory Allocation (for new shipped records, existing shipped records, and existing hold
stocks now shipped)
12-4 Purchase Order Receipts

Note: When you select the select the Require cost types on expense accounts option in the 1–8 General

Sage 100 Contractor 2018 (SQL) Version 21 Release Notes Canadian and U.S. Editions

12

Ledger Setup window, you cannot change the cost type for direct expenses in the 6-3 Job Cost window.
To audit and reconcile general ledger accounts that accept direct job costs, print the 6-3-41 Job Cost
Reconciliation and 6-3-42 Job Cost Type Reconciliation reports.

New and modified reports support auditing and reconciliation
Printed 1-8-21 General Ledger Setup reports now show the cost type specified for each account, as well
as the date and period.
We have relocated the Reconcile menu option from the 6-3 Job Costs window to a new 6-3-41 Job Cost
Reconciliation report. The 6-3-41 Job Cost Reconciliation report includes criteria that enable you to select
transactions by both accounting period and year.
In addition, a new 6-3-42 Job Cost Type Reconciliation report shows the amount for the GL by cost type
and to job costs by cost type and prints a line if there is a variance.

Enhanced Search (Find) in the 9-5 Jobs window
In version 21, the 9-5 Jobs window provides more powerful search capabilities, with finer control.
Previously, you could search only one grid at a time in a takeoff using the grid's Find feature, which was
time-consuming, particularly if you were looking for a specific piece of information in a takeoff that had
multiple bid items and phases.
Now, you can search the entire takeoff, including multiple grids, as well as the displayed bid item and
phase. You can choose whether to search in a selected column or all the columns in the current grid. In
addition, you can filter these searches by bid item or by phase. You can easily view search results and
navigate to the matches using a variety of filters.

To search using the enhanced search window:
1. Display the enhanced search window.
In the 9-5 Jobs grid, right-click in the column you want to begin searching, and then click Find on the
shortcut menu.

Sage 100 Contractor 2018 (SQL) Version 21 Release Notes Canadian and U.S. Editions

13

2. In the Search for box, type the text that you want the program to match in the searched records.
3. Choose whether to search only in the column you selected in step 1 or in all the columns. The default
search column is the one you right-clicked to begin the search. (The example shows the window for
a search beginning with the Description column, because that was the right-clicked column that
began this search.)
If you accept the default Search only the [Description] column option, you limit the scope of the
search to the original column.
If you want to widen the search to all visible columns in the grid, select Search all the columns in the
current view.

4. Use the Limit search to option to restrict the search to specific takeoff elements. You can select:
l

Bid Item, to search all the bid items for a selected phase.

l

Phase, to search all the phases for a given bid item.

l

Current Grid, to search only the currently selected bid item/phase.

l

Takeoff, to search the entire takeoff.

5. Start the search by clicking one of the following buttons:
l

Click [Find Next] to find the next occurrence of the specified search text.
You can continue to click Find Next until you find the instance you are looking for, or until you
receive a message saying that no more instances were found.

l

Click [Find All] to list all the matches in a separate results screen.
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Tip: In the results screen, you can double-click a row (or select the row and then click [Go To
Row]) to highlight the specific entry in the takeoff grid.

Move your Sage 100 Contractor Company to a New Drive
You can now move all your Sage 100 Contractor data to a different drive on the same computer. If you
want to host your data on a faster, bigger drive than the one you are currently using, you can use the new
Move Data to New Drive server management utility in Database Administration.

Important! Moving data to a new drive moves all Sage 100 Contractor data. Only one drive on a server
can contain Sage 100 Contractor data, and once you move your data, Sage 100 Contractor no longer
uses or references the old drive.
For more information about this new feature, see the Database Administration help.
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View an employee's pay raise history
You can now view an employee's pay raise history, and enter historical raise information for an employee,
in the employee record. Whenever you add an employee, or change an employee's compensation, Sage
100 Contractor automatically adds that information to the employee's raise history.

To view raise history for an employee:
1. Open the 5-2-1- Employees window.
2. Use the data control box to display the record for the employee whose pay history you want to view.
3. With the record displayed, click Options > Raise History or click the [Raise History] button.
4. If you need to add pay history, on the first blank line of the grid:
a. Click in the Date field, and then click the Down arrow to display the calendar.
b. In the calendar, navigate to the year and month, and then double-click the date that the
historical rate became effective.
c. In the Rate Type cell, type the code for the rate type (1-Regular, 2-Salary, or 3Commission%), and then press Tab.
d. In the Original Amount cell, the amount of regular pay, salary, or commission before the new
rate, and then press Tab.
e. Enter the amount or the percent to add (or subtract) from the original amount. Do one of the
following:
In the Change Amount cell, type the amount of regular pay, salary, or commission to
add to the original amount.

l

When you enter a change amount, Sage 100 Contractor calculates and displays the
change percent automatically for you.
In the Change Percent cell, type the percent by which to increase the regular pay,
salary, or commission.

l

When you enter a change percent, Sage 100 Contractor calculates and displays the
change amount automatically for you.

Tips:
l

If you make a mistake, you can click Edit > Undo Typing to undo your most recent
change.
To delete an entire row, click the row number, right-click, and then click Cut Row
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l

You can import history that you have stored in a separate file you created in another
program (for example, a comma delimited text file). Click File > Open > [format], and
then navigate to the file where the information is stored.
Consider saving a file (File > Save) first, to ensure that you create the external file
using the correct formats.

l

You can also print raise history.
Click File > Print to print the raise history for the selected employee.

Create timecards for individual employees in Daily Payroll
You can now process daily payroll for specific employees.
A new Employees pick list in the Create Timecards window enables you to select employees for whom to
create timecards. For example, you might want to process timecards for employees subject to different
reporting requirements on different days.

Create timecards for individual employees, as follows:
1. Open 5-5-1 Daily Payroll Entry.
2. On the Options menu, click Create Timecards.
3. In the Beginning Date box, enter the date of the first daily record you want to convert.
4. In the Ending Date box, enter the date of the last daily record you want to convert.
5. In the Payroll Quarter box, enter the payroll quarter.
6. If you want to select individual employees for whom to create timecards, click the arrow beside the
Employee Pick List, and then from the Employees pick list:

a. Double-click each employee for whom you want to create a timecard.
Selected records are indicated in red.

b. When you have finished selecting employees, click [Insert Selected Items].
7. Click Create Timecards.

Create Payroll records for salaried employees
The 5-2-2 Payroll Records window provides a selection on the Options menu that you use to create payroll
records easily for salaried employees.
The new Salaried Employees submenu includes the following options:
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l

Create Salaried Employee Records. You click this option to open a window where you select the
period start and end dates, a check date, and the salaried employees you want to pay.

l

Skip Salaried Employees in Next Employee Default. If you use the new Create Salaried Employee
Records, select this option to ignore salaried employees for the next employee default when you
enter new payroll records for hourly employees.

The general steps for creating payroll when you have salaried employees are as follows:

1. In the 5-2-2 Payroll Records window, from the Options menu:
a. Select Skip Salaried Employees in Next Employee Default.
b. Select Create Salaried Employees, and then create payroll records for the salaried
employees for the period you want to pay.
2. In the 5-2-2 Payroll Records window, create payroll for the non-salaried employees.

Restrict Exclusive Access for certain non-administrative users
The grid in the 7-2-2 User List window includes a new Permit Exclusive Access column where you indicate,
for each non-administrative user, whether they can open the company exclusively or not.
Users who do not have this permission do not see the option to open the company exclusively when they
select it in the Company List window.

Note: Company Administrators have exclusive access automatically by virtue of their role. You cannot
turn off this option for administrators. Also, existing users of companies created before this release have
this access automatically. After installing version 21, if you want to prohibit exclusive access for any of
these users, you must turn off the option for that user.

Fix attachments' file paths after moving data
If you move your data to a new server, the paths to attachment files located outside of the company file
structure will be incorrect. In the Database Administration Toolbox, Company Tools includes a new tool to
fix the paths to attachments after you move data to a new server.
When you select the new Assign new server name in file paths for linked file attachments option, two
boxes become available:
l

Old server name, from which you select the name of the old server.

l

New server name, in which you type the name of the new server.

After you enter the old and new server names, click [Update File Paths]
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Other Improvements
Version 21.1 also includes the following improvements:
l

l

A new View > Record History in the 1-8 General Ledger Setup window enables you to view a list of
changes to general ledger setup. (For example, you can check when you began to enforce cost
types to be entered with expense accounts.)
Effective immediately, Sage Payment Solutions is known as Paya.
You will notice this change when you use the Electronic Receipts Setup tab in the 7-1 Company
Information window to set up electronic receipts or validate your Merchant ID and Merchant Key.

l

If you want to be able to void progress billings or unitary billings directly in the 3-2 Receivables
Invoices/Credits window, a Company Administrator must first select a new Allow Direct Void of
Invoice option in the 3-7 Progress Billing and the 3-9 Unitary Billing windows.
By default, these options are not selected, blocking the accidental voiding of progress billing and
unitary billing invoices.
Unless these options are selected, when you try to void an invoice in the 3-2 Receivables
Invoices/Credits window that was created in the 3-7 Progress Billing or the 3-9 Unitary Billing
window, you receive an error message telling you that you must void the invoice in the source
window. (When you click [OK] to close the message the voiding process stops.)
See the "Voiding progress bills" and "Voiding unitary bills" help topics for steps on voiding these
billings.

l

l

In the 5-2-2- Payroll Records window, you receive an error message if you try to enter a Period End
date that falls before the Period Start date. You must enter valid start and end dates before you can
save the record.
In the 11-2 Work Orders/Invoices/Credits window, the Copy or Repeat this Record window provides
a new Include attachments option. Select this option if you want to include attachments from the
original work order on the new work orders.
Attachments are copied to the new orders if they are located in the Sage 100 Contractor
Attachments folder. If the attachments are links to external files, the links are copied instead.

l

You can use the new Remove Inventory Allocations option in the 12-2 Inventory Allocation window
to remove inventory allocations that are older than a specific date, provided they are not assigned to
jobs. All inventory allocations before that date are removed, including any attachments associated
with them. You can also choose to remove old inventory allocations during the archiving process.

Note: You need to sign in with Company Administrator rights to remove inventory allocations.
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Enhancements for the U.S. Edition
Tracking Federal Sick Leave Accruals
On U.S. federal jobs, employees must accrue sick leave at a certain rate per hour worked. (For example,
employees may be entitled to 1 hour of sick leave for every 30 hours they work on federal jobs, with a
maximum annual accrual of 56 hours a year.)
We have made several adjustments to Payroll screens to accommodate this federal requirement.
The 3-5 Jobs (Accounts Receivable) window includes a new Requires federal sick leave accrual check box
that you select to indicate that a job is a U.S. federal job.
In the 5-2-1 Employees window, the sick leave section on the Compensation tab includes the following new
fields to track federal sick leave entitlements and annual maximums:
l

Federal Rate. You enter this rate as a percent of each hour work the employee works on a federal
job.
For example, the employee is entitled to 1 hour for each 30 hours they work on a federal job, the
federal rate is 0.0333.

l

Federal Limit. Enter the maximum number of hours that the employee can accrue for sick leave
while working on federal jobs.

l

Federal YTD. Sage 100 Contractor tracks the year-to-date.

In addition, the sick leave and vacation sections include two new fields to track standard (independent of
federal) annual amounts:
l

Annual Limit. Enter the maximum number of hours that the employee can accrue as sick leave while
working on non-federal jobs.
Sage 100 Contractor calculates sick leave for federal and non-federal jobs separately. If the
employee is entitled (say, under state regulations) to more sick leave than required under federal
regulations, the additional entitlement is calculated and accrued as standard sick leave.

l

Accrued YTD.

Note: These standard annual fields are available in both U.S. and Canadian Payroll.

The Sick Days Earned and Used report
The 5-1-8-81 Sick Days Earned and Used report remains unchanged.
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Sick accruals are not broken out as standard sick leave accruals and federal sick leave accruals. Because
of the way that Sage 100 Contractor calculates sick time earned, accrued sick leave will never be less than
the amount required by federal or state authorities.
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U.S. Payroll Tax Tables—May 2018 Update
Payroll tax tables have changed for the following jurisdictions:
l

Colorado

l

Idaho

l

Kentucky

l

Utah
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Fixes in Version 21.1
Fixes in the U.S. and Canadian Editions
Version 21.1 includes the following software fixes in both editions:
l

l

l

l

Using the Autofit All Columns function in a grid where a cell uses bold text no longer changes all text
to bold text.
When you export grids to Excel, all the columns are exported regardless of how the columns are
justified and the order in which they appear.
In Database Administration, when you archive Payroll that includes an employee record with less
than -99 accrued sick time, the archive process finishes properly.
In the 9-5 Takeoffs window, if you just want to view a bid item, you do not have to save it when you
close the window.

l

When you save query results to a text file, internal references are no longer included in the saved
report. The report only includes what you see in the grid.

l

In the 10-3 Schedules window, when you import takeoff tasks from an exported file that includes
subcontractors, subcontractor tasks are included in the schedule.

l

In the 8-3 Equipment window, you can no longer delete an equipment record if the equipment is
referenced on another equipment's revenue record. (Previously, you received a cryptic error
message if you tried to delete equipment that was assigned to a job.)

l

In the 5-2-1 Employees window, the Licenses and Training options are always available from the
Options menu.

l

In the 4-4 Vendors window, you can use the F7 key to open the Field Properties window for the
Recipient Email box.

l

In 5-1-5 Worker's Comp Reports printed with both Separate Reports by Job and Totals Only
options, the report now prints the correct job on each report header.

l

In the 5-2-1 Employees window, on the human resource tab, users cannot enter a future year for a
birthday.

l

In the 3-5 Jobs window, you can delete jobs even if they have inventory allocations, or you can
delete these jobs during the archiving process. If the inventory allocation record has a Hold Status,
the hold is released and the part quantity available is adjusted accordingly .
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l

In the 9-3 Assemblies window, part quantities are shown with four decimal places, consistent with
the way these quantities are saved in the database.

l

When saving an approved change order in the 6-4-1 Change Orders window, if you receive a
message saying that the date does not match the period, you click No, don’t save, but you end up
saving the record anyway, the program no longer resets the approval period/year to the current
posting period.

l

You can now enter up to 30 characters in the Architect's Job# box in the Unitary Billing Setup
window.
Similarly, you can enter up to 50 characters in the Alpha Part# column in the 3-11 Recurring
Receivables window.

l

You can now update more than four part fields at once in the 9-7 Maintain Parts Database window.

l

In Database Administration, the Modify SQL Server Administrators tab now includes the Windows
NT AUTHORITY\SYSTEM user in the list of SQL Server Logins, so you can assign that login to the
sysadmin role.

l

The 5-2-2 Payroll Records window no longer finds inactive employees when you type names in the
Employee field.

l

We have fixed an issue that could occur with credit transactions in the 4-2 Payable Invoices/Credits
and the Invoice Payments windows.
If you applied a credit using a reference to the invoice (in the Reference# box), when you viewed the
transaction later in the Invoice Payments window, the credit appeared in the Amount Paid column,
rather than the Credit Taken column, and you could drill down to the original invoice, which was
confusing and incorrect.
Now the credit appears correctly in the Credit Taken column and drilldown is not available because
there was no general ledger transaction when the credit was applied.

Fixes for the U.S. Edition
The following issues were fixed specifically for the U.S. Edition of Sage 100 Contractor:
l

l

The Aatrix Missouri and California Certified Payroll Reports now separate double time (DT),
overtime (OT), and standard time (ST). Hours entered in timecards for Missouri and California as
Pay Type 3-Premium are no longer reported on the certified report in Aatrix as overtime hours.
Reports for states where premium time is reported as overtime remain unchanged.
The Cash Overtime Fringe Hourly Rate is now included correctly in the Aatrix 5-1-11 DOL WH-347
report.
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Upgrading from an Earlier version of Sage
100 Contractor (SQL)?
New Entitlement Server
Sage has moved its Entitlement server (used to allocate license uses based on the license you have
purchased) to a new, more secure server.
After installing this version of Sage 100 Contractor, you will need to open the License Manager and enter
your Sage Client ID and Registration Name even if you have been using an earlier version of Sage 100
Contractor.

Important! You must enter your Client ID and Registration Name exactly as they appear for your account
in the Customer Portal.

Tip: Before you install version 21, open License Administration, copy the Sage client ID and Registration
name from the License information tab, and then paste them into a text document. After installing
version 21, copy the Sage client ID and Registration name from the text document into the version 21
License Administration window.
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Upgrading from version 19.8?
New Microsoft SQL Server Platform
Although Sage 100 Contractor 2018 has the same look, feel, and functionality that you are familiar with, its
new SQL database structure affords much tighter security and an up-to-date technology on which to build
future releases. It also provides several other notable enhancements, including:
l

A new, separate Database Administration tool. You don't have to be an expert user of Microsoft SQL
Server to take advantage of its robust features! We designed Database Administration to optimize
your data for Sage 100 Contractor, for example, by keeping related data in expected locations and
creating backups automatically before performing certain critical processes. Many of its features are
not available through SQL Server Management Studio.
Significantly, Database Administration includes a migration utility that we have designed and tested
extensively to help ensure a smooth and painless transition to SQL Server.
We have relocated many administrative utilities and functions from the main Sage 100 Contractor
program to this new tool. However, we have boosted their capabilities considerably, and now
provide easily scheduled maintenance and backup functions to help you to keep your Sage 100
Contractor companies in good order.
In addition, Database Administration offers several powerful, new capabilities that enable you to
maintain tight security and exert fine control over user and program access to your SQL Server
instance.
For a comprehensive list of the utilities you will find in Database Administration, see Database
Administration for Sage 100 Contractor, later in this document.

Note: Database Administration comes with its own help system and a new Database and
Company Administration Guide to acquaint you with its features and to guide you in its use.
l

New views for creating reports with third-party report writers. Because the new views point to the
database tables, rather than pointing your reports directly to the tables, we encourage you to use
them when creating custom reports using third-party tools, such as Crystal Reports.
For example, in earlier versions, you would point directly to actpay.vndnme to include Accounts
Payable vendor names in custom reports. In the version 21.1 company database, this information
resides in dbo.actpay.vndnme. However, we recommend that rather than pointing directly to the
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table name, you point to the field in the new view: Reports_v1.actpay.vndnme. Report views are
located in the Views folder in your company database.

Tip: A compelling reason to use these views is that they may not be affected by many types of changes
to the underlying tables, so future database changes will not necessarily "break" your custom reports.

Software and hardware required to support Microsoft SQL Server
Version 21.1 requires an instance of Microsoft SQL Server. You can download and use Microsoft SQL
Express at no charge, or you can use the full version of Microsoft SQL Server. You can even start using
Microsoft SQL Express, and upgrade to the full version of Microsoft SQL Server later, if necessary.
When you first open the new Database Administration tool, the program tries to configure an instance of
Microsoft SQL Server with optimal settings for Sage 100 Contractor for you. If you do not already have an
instance of Microsoft SQL Server, you can let the Database Administration tool download, install, and
configure Microsoft SQL Express for you.
Refer to Knowledgebase article 90782 (available at available at

https://support.na.sage.com/selfservice/viewdocument.do?externalId=90782.) for detailed information
about supported operating systems and software, and for minimum hardware requirements.

Database Administration for Sage 100 Contractor
The new Database Administration tool is intended for designated system administrators and company
administrators. You use it to set up and maintain your company databases, and to select advanced
settings to manage communications with and access to your Microsoft SQL Server instance from other
programs.
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If you have used earlier versions of Sage 100 Contractor, several of these tasks will be familiar to you. For
example, Database Administration includes utilities for creating and deleting a company, backing up and
restoring company files, and archiving company data that you used in previous Sage 100 Contractor
versions.

Important! We highly recommend that you use Database Administration, rather than SQL Management
Studio®, to perform the database administration tasks listed below, even if you are an experienced SQL
Server user. Besides handling all the database tasks that you are likely to perform in a typical Sage 100
Contractor system, Database Administration was designed to optimize your data for Sage 100
Contractor, for example, by keeping related data in expected locations and creating backups
automatically before performing certain critical processes. In the rare event that you need to use SQL
Management Studio® to perform a task that is not provided in Database Administration, you should
contact Customer Support for assistance.
Database Administration includes the following database and company management utilities:
l

l

l

l

Create Company Based on Existing and Create Company create new Microsoft SQL Server
databases.
Rename Company and Delete Companyare convenient utilities when working with existing
companies.
Deploy Sample Company helps you install and refresh the sample data that comes with Sage 100
Contractor.
Tune Up Company Databases performs various maintenance tasks to keep your database
functioning efficiently.

l

Back Up Company Databases enables you to back up your data "on demand," whenever needed.

l

Restore Company from Backup restores a selected backed-up copy of your database.

l

l

l

l

l

Upgrade Company Databases enables you to upgrade your databases smoothly from an earlier
version of Sage 100 Contractor (SQL).
Archive Company Data utilities enable you to archive data for your oldest fiscal year and you Payroll
data.
Migrate Company Data and Migrate Custom Reports transfers your version 19.8 company data and
custom reports to a new location for Microsoft SQL Server. Migrated files are located in shared
folders under \\ServerName\CompanyName, organized using a folder structure similar to earlier
versions.
Schedule Nightly Maintenance utilities enable you to schedule backup and maintenance operations
for times when other users are not logged into the system. You can also select the number of
consecutive backups to keep.
Company Admins/SQL Logins utilities enable you to set up or delete logins to the SQL Server
database, and to designate a user as a company administrator for a specified Sage 100 Contractor
company.
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l

l

l

l

Server Management tools enable you to control the SQL Server instances you use with Sage 100
Contractor easily and efficiently. You can create a new instance on your computer, move companies
to the new instance, and remove an instance you no longer need.
Advanced Settings lets you specify how long to keep history about database changes for each
company, including details about changed records, such as the date and user ID of the employee
made the change. Details older than the retention period you specify are cleared during nightly
maintenance. (This history is maintained in separate audit tables, which you can query using SQL
Server Management Studio.)
The Toolbox provides a variety of troubleshooting tools to help you track changes in your database,
and to diagnose and fix certain types of problems.
Advanced SQL Server Settings includes convenient, sophisticated access and memory
management controls for your SQL database.

For detailed information about these utilities and how to use them, see the Database Administration help or
refer to the Database and Company Administration Guide.

Additional Changes for SQL Server
In addition to the new SQL database platform and the Database Administration tool, you should note the
following important differences from earlier versions:
l

Because each user must now identify themselves to SQL Server using a unique SQL login, there is
no longer a single Supervisor user. Instead, you designate as Company Administrators users who
require elevated privileges in Sage 100 Contractor.

Tip: You can copy supervisor preferences used in version 19.8 to individual users in the version
21.1 User List window.
l

When starting Sage 100 Contractor, you first log in to an instance of SQL Server using a new
Connect to SQL Server window, and then you select your company and type of access from the
Company List window.
If you need to change the type of access after logging into the company, you can return to the
Company List window using the Change Company/Access link on the Sage 100 Contractor desktop.

Note: If you want to log in as a different user, you must close Sage 100 Contractor completely first,
and then log in using a different user name.
l

l

You no longer need to reindex your data after upgrading. Now, you use the Database Administration
tool migrate your data from version 19.8 and to update it in future.
Version 21.1 and subsequent releases are installed to a different location than version 19.8 and
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earlier versions.
Having separate installation locations enables you to run version 21.1 and version 19.8 on the same
computer while you migrate your data to the new version.
l

You need to install the License Administration application and activate the software on the same
computer as your version 19.8 license server, choosing the option to use the computer as the
license server for version 21.1. After installing Sage 100 Contractor on other networked
workstations, point to this machine as the license server.
For more information, see the Installation and License Administration Guide.

Notice about Supported Windows Operating Systems
Sage 100 Contractor 2018 supports Windows Server 2008 R2, and later versions of Windows. However, it
does not support Windows Server 2008 and Small Business Server 2008 because they do not support
.NET 4.6.1, which this version of Sage 100 Contractor requires.
For current information about supported operating systems, Internet browsers, and other software, and
about system requirements for servers and client workstations, refer to our Knowledgebase article ID
90782, available at https://support.na.sage.com/selfservice/viewdocument.do?externalId=90782.

Installing Sage 100 Contractor 2018
Installing Sage 100 Contractor 2018 and upgrading your data involves a few more steps than in previous
editions because you must install two additional components. You need to:
l

l

Install the Database Administration tool on the machine you will use as your server.
Create a SQL Server instance for Sage 100 Contractor. This process is simplified if you use the
option to download Microsoft SQL Server and create an instance automatically when you first open

For detailed instructions on installing Sage 100 Contractor 2018, see "Chapter 3: Sage 100 Contractor
Installation," in:
l

The Sage 100 Contractor Installation and License Administration Guide (U.S. Edition)

l

The Sage 100 Contractor Installation and License Administration Guide (Canadian Edition)

Printable checklists help you get started
Two printable checklists are available to help you get started using Sage 100 Contractor 2018. Download
them from our website, print them, and then check off each step on the printed list as you complete the
necessary tasks.
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l

l

Use the Quick Start Checklist to help you stay on track when you set up your company or migrate
your company from version 19.8. It provides an overview of all the important steps you should
complete to install version 21.1
Use the "Going Live" Checklist when you are ready to start using Sage 100 Contractor 2018 in a
production environment (rather than a test environment). It lists all the important steps you should
complete to "go live" with Sage 100 Contractor 2018.

Earlier Enhancements in Sage 100 Contractor (SQL)
Earlier versions of Sage 100 Contractor provided a wide variety of new features, including a number of
enhancements that our customers have asked for.
This section describes several of the important new features introduced in previous versions. It also
provides a comprehensive list of additional features, the details of which you can read about in the Release
Notes for the respective version. For more information, see "Summary of Enhancements in Earlier

Versions of Sage 100 Contractor (SQL)" (page 47)

You Can Set Records "Inactive"
If you are a company administrator, you can now designate records Inactive. For example, you can mark
Inactive records that you no longer want to use, but cannot delete because they are referenced by other,
current records.

Note: To change Inactive settings, your login ID must be assigned the Company Admin role in the 7-22 User List. You do not need to select the Open company with Administrator rights option when you
sign into the company.
Sage 100 Contractor prevents entry to inactive records, so you cannot inadvertently process entries using
them. For example, you cannot use an inactive cost code on a new purchase order or change the code on
an existing record to an inactive cost code.
The 9-5 Takeoff and the 10-3 Schedules lookup windows do not display inactive records. Also inactive
records do not appear in data control boxes, and they are not visible when you search for records using the
F9, Page Up, or Page Down keys.

Note: Inactive records do not appear in lookup windows by default, but you can display them if you
choose to do so. (For information about displaying inactive records, see "Viewing Inactive Records"
(page 32).

Designating Inactive Records
You designate Inactive records in the following windows by selecting new Edit > Inactive Record for a
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selected record:
l

1-7 General Ledger Accounts

l

General Ledger Subaccounts

l

3-5 Jobs

l

3-6 Receivable Clients

l

4-4 Vendors

l

5-2-1 Employees

l

8-3 Equipment

l

9-2 Parts

l

9-3 Assemblies

In the following windows, which display records in a grid, you enter Y (for Yes) in the Inactive column to set
the record for the selected row Inactive:
l

5-3-2 Workers' Compensation

l

5-3-4 Paygroups

l

6-5 Cost Codes

If it is necessary to change the Inactive setting later, you simply clear the Inactive Record selection on the
Edit menu or the grid.

Viewing Inactive Records
From time to time, you may need to check which records of a given type are marked Inactive. For example,
when adding a new cost code, to check which codes are already in use, you need to view inactive codes.
You can display a list of Inactive records in a couple of ways:
l

For records that display a single record at a time (not in a grid format), you can view all Inactive
records of a selected type by opening the associated lookup window, and then clicking Options >
Show Inactive Records .

A check mark in the Inactive column indicates that a record is Inactive.
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l

In windows that display records in grid format, you view Inactive records by selecting the Show
Inactive Records check box below the grid. The following windows use a grid to display records:
l

5-3-2 Workers' Compensation

l

5-3-4 Paygroups

l

6-5 Cost Codes

Note: A Yes entry in the Inactive column indicates that a record is inactive. If you are a company
administrator, you can change this entry to change the status to and from Inactive.
Changing the Inactive Settings for Multiple Records at the Same Time

For windows that do not display records in a grid, you can use the lookup windows to set or clear the
Inactive setting for multiple records at once. For example, in the 3-5 Jobs window:

1. Open the job number lookup window. (Click the down arrow beside the job number data control.)
2. In the lookup window:
a. Click Options > Edit Inactive Setting.
b. Select or clear the check marks in the Inactive column to change the Inactive setting for the
records on the selected rows.

More efficient log-in
When you first log in to Sage 100 Contractor, the program creates and stores a personalized list of the
companies to which you have access rights, including archived companies.
The next time you log in, Sage 100 Contractor displays in the Company List window only companies from
your personal list—provided those companies still exist on the database server—making the log-in process
faster.
The program automatically updates personal company lists when companies are added, deleted,
renamed or archived in Database Administration. However, if you notice that your list includes a company
that you know has been deleted or renamed, or does not include a new company, click the
Refresh Company List link in the Company List window to recreate your personal company list, removing
obsolete companies and inserting the new ones.

Use new custom fields in most windows
With version 20.5, you can define an unlimited number of custom fields for most Sage 100 Contractor
windows.
Custom fields enable you to store additional information that you want to keep with Sage 100 Contractor
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records. As a company administrator, you can add, edit, or delete custom fields for any window that
supports them. You can create custom fields for most types of records, except ledger transactions,
accounts, daily payroll, and recurring transactions, and you can create an unlimited number of custom
fields for a window and for your Sage 100 Contractor company.
Custom fields are not the same as the user-defined fields (UserDef1 and UserDef2) that come with the
software. Custom fields are more versatile than the limited user-defined fields.

Note: Windows that support custom fields include a new Custom Fields option on the Edit menu, and an
[Enter Optional Fields] button

on the toolbar.

When you select the Edit > Custom Fields option or click the [Enter Custom Fields] button:
l

l

If any custom fields have been defined for the parent window, the Custom Fields window opens. You
can display the custom fields and change the custom field values for a record you are working with.
If no custom fields have been defined for a window and you are signed in as a company
administrator, the Custom Field Properties window opens.

The following sections describe how you use these windows to create and view custom fields for your Sage
100 Contractor company.

About the Custom Fields window
The Custom Fields window displays a list of the custom fields that have been defined for the parent
window. You use the Custom Fields window to view or to enter values for custom fields that have been
added to a parent window.
If you sign in to Sage 100 Contractor as a company administrator, you can also add new custom fields or
modify or delete existing ones:
l

l

You click the [Add] button in the Custom Fields window to open the Custom Field Properties window
where you can define a new custom field for the window you are working in.
You click the [Modify ] button to open the Modify Custom Fields window.
In the Modify Custom Fields window, use the icons beside the field you want to modify to:
l

Edit the properties of the field (

).

l

Delete the field (

l

Move the field up or down in the list (

).
).

Tip: If you want to keep the Custom Fields window open while you work with a record, click [Pin].
The window remains pinned to the top right edge of the parent window until you unpin it, even if
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you close and then reopen the parent window later. To unpin the window, click [Unpin] in the
Custom Fields window.

Defining Custom Fields for a Window
If you log on as a company administrator, you can define custom fields for any window that supports them.
Sage 100 Contractor does not limit the number of custom fields you can define for a window or for your
company.
You use the Custom Field Properties window to add, edit, and delete custom fields.
Before you start

Make sure you are logged into Sage 100 Contractoras a company administrator. You can add, edit, or
delete custom fields only if you are logged in as a Company Administrator:
To add a new custom field:

1. In a window that supports custom fields, click Edit > Enter Custom Fields , or click the Enter
custom fields
button on the taskbar.
If no custom fields have been defined for the window, the Custom Field Properties window appears
immediately.
If any custom fields exist for the window, the Custom Fields entry window appears. In the Custom
Fields window, click [Add].

Tip: If you want to modify or delete an existing field, you click the field in the Custom Fields
window, and then either:
l

Press F7 or

l

Click [Modify],

Then, on the Modify Custom Fields window, you click the Edit properties for this field
or the Delete

button

.button.

2. Fill in the fields in the Custom Field Properties window as follows:
a. In the Field Name box, type a unique name to identify the custom field, using six characters.
Note: You cannot save a custom field with the same name as an existing custom field that
has been defined for a window, and you cannot change the name after you save the
custom field.
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b. In the Description box, type a brief description for the custom field, using up to 30 characters.
c. From the Field Type list, select the type of data this field will contain. For example, if you will
use the field to store a type of number, select Number.
Note: You cannot change the field type after you save the custom field.
d. Depending on the Field Type you selected in the previous step, fill in additional attributes for
the custom field:
l

Length. For Character field types, enter maximum number of characters (use up to 255
characters) that the custom field can accept.

l

Decimal Places. For Number field types, select the number of decimal places (0, 2, 4,
or 6) that numeric entries will use.

l

Maximum Value / Minimum Value. If you want to track a standard currency value, you
need to set maximum and minimum values. The maximum value must be no greater
than 999,999,999 and the minimum value should be no less than -99,999,999, the
default values for these fields.
Numeric fields must have a maximum value greater than zero. You cannot use the
same values for Minimum Value and Maximum Value.

l

Prompt. For all field types, type a prompt to help users understand what to enter in the
custom field when they are processing records.

l

Default Entry. For all field types, type or select (if a list is available) the entry to display
as the default for the field.
Character fields can accept default entries, but not "Next" or "Previous."
Date fields display the date that occurs the number of days you specify after the current
date ("TODAY").
Check boxes can be selected, or not, by default.

e. Set other options as follows:
l

Require Entry. Requires an entry, or Sage 100 Contractor will not save the record.

l

Use Quick List. You can provide a Quick List control for a customer field by selecting the
Use Quick List check box.

l

Require List Match. Requires that the entry match an item on the Quick List.
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l

Lock Quick List. Prevents users from editing a Quick List. Only a company administrator
can edit the information.

l

Lock After Save. Prevents users from editing the information after saving the record.
Only a company administrator can edit the information.

l

Require Unique. Prevents users from entering duplicate information. This is available
for indexed text boxes that let you enter character-based information.

l

Check Spelling. Checks the spelling when you move to another text box or cell. If Sage
100 Contractor finds a misspelled word, it displays the Spelling dialog box.

l

Mixed Case. Allows text entry in upper and lower case.

l

Upper Case. Displays text only in upper case.

l

Lower Case. Converts entry to lower case text.

f. On the Permit Access to list, select the user groups that should have access to the field. If you
do not select any user group, all user groups have access.
3. Click [Save].

View Change History in Records
Many data entry windows in version 21.1 include a new View menu, with options that enable company
administrators to view the history of changes to a selected record.
This capability can be helpful when you need to determine the source or the timing of a change in a record.
l

l

The depth of the change history is determined by the retention policy set for your company in
Database Administration. History is retained for 180 days by default, but you can change the
retention period.
You do not have to log into the company with Administrator rights to view history, providing you
are set up as a company administrator in the 7-7-2 User List.

When you display a record in a window that has a View menu, you can select one of two options to view
history:
l

View > Record history. When you select this option, a separate View History window opens,
displaying a list of all the changes to the current record.
Initially, the list summarizes all the changes to the record, showing for each change
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l

The database table that was updated,

l

Whether new information was inserted or existing information was modified or deleted.

l

The date and time.

l

The login ID of the user who made the change.

l

The ID of the computer where the change originated.

l

The application where the change originated (for example, Sage 100 Contractor, Database
Administration, or SQL Server Management Studio).

Tip: If there were many changes, you can filter a long list to show only changes for a particular
table, user, or application.
To view the details of a particular change, click the row on which the change is listed. Sage 100
Contractor displays a History Details window that shows, for each field in the record, the value of
each field before and after the change.
l

View > Field history. When you select this option, field entries that have changed for the current
record are displayed against a yellow background.
To view change details for a particular field, click the field, and then press [F12]. Sage 100
Contractor displays a separate History window for the field that lists the ID of each person who
made a change, the date of the change, the field values before and after the change, and the
application where the change originated.

Note: With View Field History turned on, you cannot edit the record.
The view history options are turned off when you close the window or move to another record.

Note: Although the following windows include a View menu, some special conditions apply:
l

In 5-2-1 Employees, history is not provided for the ACA tab.

l

In 5-2-2 Payroll Records, history is not provided for the the Calculations tab.

Assign banking categories to bank-related journal transactions
You can now classify bank-related journal transactions as adjustments, checks, or deposits for bank
reconciliation.
The new Banking Category field in the 1-3 Journal Transactions and 1-4 Recurring Journal
Transactions windows lets you classify a bank-related transaction as a 0-Adjustment, 1-Check, or 2-
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Deposit. The category you assign to an entry determines its classification in the 1-5 Bank Reconciliation
grid.

Tip: You can drill down from a record in the 1-5 Bank Reconciliation window, change the category for the
transaction, and save it. When you refresh 1-5 Bank Reconciliation grid, the record appears correctly in
the new category.
The new Banking Category field is always present in the 1-4 Recurring Journal Transactions window,
but it appears in the 1-3 Journal Transactions window only for new records and for existing records that
use a 3, 4, 19 or 21 Source code (which are classified as adjustments by default).
When you post a record in the 1-4 Recurring Journal Transactions window, the Banking Category value
is passed automatically to the 1-3 Journal Transactions record.

Tag rows for follow-up in the 9-5 Takeoffs grid
You can tag rows in the 9-5 Takeoffs grid, marking them for future follow-up. When you tag a row, you can
add a note to remind you why you tagged the line (for example, “Check this number with subcontractor
XYZ”).
Headers for rows that you have tagged in the takeoff grid display a red triangle, helping you to identify
them.
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To tag a row in the 9-5 Takeoffs grid:

1. Right-click any field in the row that you want to tag.
2. On the shortcut menu, click Add/Edit Row tag.
A Row Tag window appears. It identifies the bid item, phase, and row number of the row you are
tagging. It also provides space to enter a note.

3. In the Tag Note box, type the reason you are tagging this takeoff detail.
4. Click [OK].
To view a single tag note later, you can open the Row Tag window for the detail, just as you did to tag the
detail.
To view a list of all the tag notes for the entire takeoff, click the [RowTags] button at the bottom of the
window. In the Takeoff Row Tags for Job# window that opens, you can select a row tag, and then:
l

Click [Go to Row] to go to that detail in the takeoff grid.

l

Click [Remove] to remove the note and the tag for one or more selected rows.

Replace Cost Codes, Vendors, Tasks, or Inventory Locations in a takeoff
A new replacement function in the 9-5 Takeoffs window enables you to replace cost codes, vendors,
tasks, or inventory locations in takeoffs quickly and efficiently. For example, if your takeoff template
contains “Inactive” cost codes, vendors, tasks, or inventory locations, you can easily replace these codes
with active ones.
To replace codes in a takeoff:

1. In the 9-5 Takeoffs window, click Update > Replace.
2. In the Replace Cost Codes, Vendors, Tasks, or Inventory Locations window:
a. Select the type of item you want to replace in the takeoff. (You can replace cost codes,
vendors, tasks, or inventory locations.)
b. In the Original Value box, select the value that you want to replace.
c. In the Replace with box, select the new value to use or type it.
3. Click [Replace].
Caution! You cannot undo this action, although the changes do not affect the database until you save
the takeoff. If you close the takeoff without saving, the replacement data is lost.
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When you click [Replace], the program replaces the specified original values for all takeoff grids for the
selected job.

Correct the period of a posted payroll transaction
If you post a payroll transaction to the wrong period, you can use the new Change Period for Posted
Records option in the 5-2-2 Payroll Records window to correct the period.
This procedure updates the existing record directly to move it to the new period, rather than reversing and
replacing the existing record.

Before you start
Note: You must log into the company as an administrator with exclusive access to use this feature.

To correct the period of a posted transaction:
1. Open the 5-2-2- Payroll Records window.
2. On the Options menu, click Change Period for Posted Records.
The Change Posted Payroll Period window opens.

3. Enter criteria to select the payroll records that you want to change.
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4. From the Change Period To box, select the correct period to which to post the payroll records.
5. Click [Preview Records] to view a list of the records that match your selection criteria, and verify that
these are the records you need to change.
If the list contains unexpected results, adjust the criteria until only the records you want to change
are included.

6. Click [Change Records] .
Sage 100 Contractor:
l

Updates all payroll records that have a ledger reference, including Void records.

l

Updates the general ledger and job and equipment costs with the new period and fiscal year.

l

Recalculates the ledger balances.

New Aging Reports
Combined Accounts Receivable and Service Receivables reports
If you are involved in both construction and services, you no longer have to print separate reports for
Accounts Receivable and for Service Receivables. You can print the following new combined Accounts
Receivable and Service Aging reports by due date or invoice date, as indicated:
l

81—Combined AR/SR Invoice Aging

l

86—Combined AR/SR Invoice Aging~Land

l

91—Combined AR/SR Invoice Aging~Aged by Invoice Date

l

96—Combined AR/SR Invoice Aging~Land; Aged by Invoice Date

You can print these locked reports using either the 3-1-3 Receivable Aging or the 11-1-3 Service Aging
report printing windows.

Print New Accounts Receivable Aging Reports by Invoice Date
You can print new AR Aging reports by invoice date. These new reports are:
l

51—AR Invoice Aging~Aged by Invoice Date (locked)

l

56—AR Invoice Aging~Land; Aged by Invoice Date (locked)

l

61—Job Current Aging~Aged by Invoice Date (U.S. only)

l

62—Job Current Aging~Alpha; Aged by Invoice Date

l

66—Job Current Aging~Land; Aged by Invoice Date

l

67—Job Current Aging~Land; Alpha; Aged by Invoice Date
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l

71—Job Period Aging~Aged by Invoice Date

l

72—Job Period Aging~Alpha; Aged by Invoice Date

l

76—Job Period Aging~Land; Aged by Invoice Date

l

77—Job Period Aging~Land; Alpha; Aged by Invoice Date

Print New Accounts Payable Aging Reports by Invoice Date
You can also print AP Aging reports by invoice date. The new reports are:
l

4-1-3-51—AP Invoice Aging~Aged by Invoice Date (locked)

l

4-1-3-56—AP Invoice Aging~Land; Aged by Invoice Date (locked)

l

4-1-3-61—Vendor Current Aging~Aged by Invoice Date

l

4-1-3-62—Vendor Current Aging~Alpha; Aged by Invoice Date

l

4-1-3-66—Vendor Current Aging~Land; Aged by Invoice Date

l

4-1-3-67—Vendor Current Aging~Land; Alpha; Aged by Invoice Date

l

4-1-3-71—Vendor Period Aging~Aged by Invoice Date

l

4-1-3-72—Vendor Period Aging~Alpha; Aged by Invoice Date

l

4-1-3-76—Vendor Period Aging~Land; Aged by Invoice Date

l

4-1-3-77—Vendor Period Aging~Land; Alpha; Aged by Invoice Date

Print New Service Invoice Aging Reports by Invoice Date
You can print the following new Service Invoice Aging reports by invoice date:
l

11-1-3-51—Service Invoice Aging~Aged by Invoice Date (locked)

l

11-1-3-56—Service Invoice Aging~Land; Aged by Invoice Date (locked, U.S. only)

l

11-1-3-61—Client Current Aging~Aged by Invoice Date (U.S. only)

l

11-1-3-62—Client Current Aging~Alpha; Aged by Invoice Date

l

11-1-3-66—Client Current Aging~Land; Aged by Invoice Date (U.S. only)

l

11-1-3-67—Client Current Aging~Land; Alpha; Aged by Invoice Date (U.S. only)

l

11-1-3-71—Client Current Aging~Aged by Invoice Date (U.S. only)

l

11-1-3-72—Client Current Aging~Alpha; Aged by Invoice Date (U.S. only)

l

11-1-3-76—Client Current Aging~Land; Aged by Invoice Date (U.S. only)

l

11-1-3-77—Client Current Aging~Land; Alpha; Aged by Invoice Date (U.S. only)
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Filter cost codes by Job and Phase in Lookup windows
When you search for cost codes in a lookup window, you can apply filters to include only the cost codes
that pertain to a specific job and phase or you can display all the cost codes you use for your company. A
filtered search is very efficient, especially if your company has a large number of cost codes and you are
interested only in cost codes for a particular job.
You can use three types of filters to search for cost codes:
l

All

l

Job

l

Job/Phase

When searching for cost codes, the filters that are available depend on the structure of the job and budget:
l

If a job has a budget, you can select a filter.

l

If the job has a budget but no phases, you cannot filter by Job/Phase.

l

If the job has no budget at all, no filter is available.

If you set up a job with phases, and each phase has a budget, the search yields only cost codes included in
the budget for that job and phase. If the job has a budget but no phases, the search yields only the cost
codes for the job. If there is no budget, the resulting list includes all the cost codes in your company
database.
Filtering rules also apply to cost divisions. If the budget has no cost codes for site work and you select the
site work division, the search yields no results. To see the site work cost codes, you must switch the filter to
All .

New Option for Company-Specific Custom Reports and Forms
You can now create reports and forms for a specific company that are accessible to all users when they
print reports for that company.
To modify an existing company-specific report or form, later, select Display Company Reports or Display
Company Forms.
Company-specific reports and forms are located in the Sage100Con > Company > [company] > Files >
Custom Reports or the Sage100Con > Company > [company] > Files > Custom Report Forms folder,
respectively.

Use a new standard calendar to select dates
Sage 100 Contractor now displays a standard calendar as the date picker for date fields.
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To select a date:

1. Press F5 or click the Display calendar button in a date field, or select Display calendar from the
shortcut menu on a date cell in a grid.
If you selected a date previously, that date is highlighted in the calendar.

2. Double-click the date you want to use.
You are returned to the date field, which now displays the date you selected.

Tip: If you prefer to use the old company calendar, simply press F2 after clicking in the date field.

Support for Customized Tables and Views
Administrators and third-party developers can now add customized tables and views to Sage 100
Contractor databases. Sage 100 Contractor reserves a special namespace designation for
customizations, preventing potential conflicts with future software development, or the creation of
incompatible customizations.
Before you can add tables and views, you must create a schema with a name that begins with dbx_ to
identify it as a custom schema. Dbx_ should be followed by your company name or another unique label
that will distinguish it from other third-party schemas. For example, Rupert Everett Consulting could create
a schema called dbx_REVERETT.
You can then add tables and views to this schema, and you can add multiple schemas, as needed.

More versatile Lookup windows
Sage 100 Contractor provides a consistent and versatile set of enhanced Lookup windows throughout the
program
Using the new Lookup windows, you can view information and select records in convenient new ways,
including:
l

Choose columns to display or hide in a Lookup window.
On the Options menu in any Lookup window, click Select Columns to Show, then select the check
boxes for each column you want to display in the Lookup window, or clear the check box to hide a
column from view.

l

View the names associated with columns that display certain numbered records, for example, the
vendor names for vendor numbers, job names for job numbers, account names for account
numbers, and so on.
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Sage 100 Contractor displays name columns automatically for these numbered records, identifying
them by enclosing the column heading in parentheses, for example "(Vendor Name)."

Note: You cannot hide these name columns while the associated number column is displayed,
although you can minimize the column width by dragging the right edge of the column header. If
you hide a number column, the associated name column is also hidden.
l

Change the order in which columns appear in a Lookup window.
Simply grab the column heading for a column you want to move, then drag it left or right until it is
positioned where you want it to be.

Note: If you separate a name column from its associated number column, the Lookup window
does not retain the new position the next time you open the Lookup window. The name column
always appears beside its associated number column when you open any Lookup window.
l

View more accurate results, and find records more quickly, when you begin typing a search term in a
data control box.
The new Lookup windows display only the records that begin with the characters you type, filtering
even more effectively as you continue typing.
When you see the record you want, select it on the list, and then press [Enter] to use it in the
transaction or other window you were working with.

When you close the window, Sage 100 Contractor automatically saves your display preferences, so
columns appear as you want them the next time you use Lookup features in that window.

Enhancements for the U.S. Edition
l

The Sales Tax Districts window now includes a column to show the effective tax rate for each tax
district. You can also add this column to the Tax Districts lookup window using the Options > Select
Columns to Show option in the lookup window.

Improved vacation tracking
Version 20.6 made it easier for you to administer vacation for your employees. It can also help to prevent
you from paying out vacation (or paid time off) when the employee has not accrued sufficient time or if they
have reached a specified maximum.
For example, suppose you establish a maximum vacation accrual of 1.5 times the annual accrual rate. If
an employee is entitled to 40 hours’ vacation per year, they would not be able to accrued more vacation
when they have accrued 60 hours. When they take vacation, dropping their accrued vacation below 60
hours, vacation begins to accrue again.
You use the 5-2-1 Employees window and the 5-2-2 Payroll Records window to track vacation accruals:
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l

The Compensation tab in the 5-2-1 Employee window includes new Accrual Maximum and Last
Year Carry Forward fields for vacation hours. Sage 100 Contractor uses these amounts as follows:
During payroll close, accrued vacation is copied to the Last Year Carry Forward field.

l

The 5-2-2 Payroll Records window now displays accrued Vacation available (in hours) for a selected
employee. You no longer need to refer to the employee record to obtain the vacation available.
When you select an employee in this window, Sage 100 Contractor displays their vacation available,
provided their pay is subject to vacation accrual. Negative vacation available is displayed in red.

Note: Vacation available is displayed only for new or Open status records.
During the payroll final compute, when calculating an employee’s accrued vacation, the program
includes the vacation accrued and vacation taken in the current period, while respecting the accrual
maximum from the employee record. The employee will not accrue more than the stipulated
maximum. Also, Sage 100 Contractor warns you if vacation for the current payroll record would
result in negative accrued vacation for the employee. If you choose to skip the final compute for that
payroll record, the transaction is rolled back, and that payroll record maintains an Open Status.
.

Summary of Enhancements in Earlier Versions of Sage 100 Contractor (SQL)
The following table is a comprehensive list of features introduced in earlier versions, details of which you
can read about in the Release Notes for the respective version.

Enhancements by version

U.S. Canada API
Only
Only

Version 20.7 enhancements
(Details are available in the v20.7 Release Notes)
Ability to print a new 5-1-8-86 Vacation Hours Earned and Used Report

X

Version 20.6 enhancements
(Details are available in the v20.6 Release Notes)
New Server Management Tools
Ability to set records "Inactive"
More efficient login
Ability to replace Cost Codes, Vendors, Tasks, or Inventory Locations in a
takeoff
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Enhancements by version

U.S. Canada API
Only
Only

New Combined Accounts Receivable and Service Receivables aging reports
Ability to print Accounts Receivable Aging Reports by Invoice Date
Ability to print Accounts Payable Aging Reports by Invoice Date
Ability to print Service Invoice Aging Reports by Invoice Date
New banking categories you can assign to bank-related journal transactions
Improved vacation tracking

X

A variety of customer-requested enhancements, including a new Refresh option
to update a report you are previewing with recent information, new access
buttons in the 3-5 Jobs window, and more!
Version 20.5 enhancements
(Details are available in the v20.5 Release Notes)
We implemented a variety of customer-suggested enhancements.
Ability to use new custom fields in most windows
Ability to tag rows for follow‐up in the 9‐5 Takeoffs grid
Audit Information is available in Advanced Company Settings
Numeric fields provide automatic calculation
Easier access to user subfolders in workgroups
Ability to correct the period of a posted payroll transaction
Ability to skip automatic calculation during takeoff
Ability to filter cost codes by Job and Phase in lookup windows
Ability to filter unassigned work orders on the Dispatch Board
There is a new option for saving and selecting company-specific custom reports
and forms
Ability to use a new standard calendar to select dates
Support for Microsoft SQL Server 2016 and Windows 2016 Server
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Enhancements by version

U.S. Canada API
Only
Only

Ability to copy user process maps
Ability to use high contrast display settings for Windows 10
Ability to print a new Payroll Check Register 5‐1‐2‐31 by check date
3‐7 Progress Billing and 12‐2 Inventory Allocation allow 5,000 rows
Tax and Workers' Comp rates in 4‐4 and 4‐2 use 4 decimal places

X

Workers' Comp Reports 21, 86, and 96 show Overtime Hours

X

Version 20.4 enhancements
(Details are available in the v20.4 Release Notes)
Ability to copy external files to other users
New option to approve the removal of employee records
Version 20.3 enhancements
(Details are available in the v20.3 Release Notes)
Ability to view change history in records
New option for closing purchase orders automatically
Support for Sage Exchange Desktop 2.0
Support for customized tables and views
Ability to use a new window to add client service locations quickly
Effective rate shown for Sales Tax Districts (U.S. only)

X

API supports adding and removing attachments

X

API enforces locks

X

Schema change for Global Variables

X

Version 20.2 enhancements
(Details are available in the v20.2 Release Notes)
Simplified schedules lookup
QueryJobCost (API Enhancement)
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Enhancements by version

U.S. Canada API
Only
Only

SetExclusive (API Enhancement)

X

Version 20.1 enhancements
(Details are available in the v20.1 Release Notes)
More versatile lookup windows
Unique Payroll record numbers

Notes for Third-Party Developers
API Support for Adding and Removing Attachments
The API supports adding and removing attachments on all Sage 100 Contractor forms that support
attachments and have API support for Add, Modify, and Delete.
As with the existing API for Work Orders, these changes do not include support for:
l

Changing the description on attachments

l

Web links

Other API Enhancements
The Sage 100 Contractor API now:
l

l

Supports custom fields, enabling third-party products to add custom fields and to add data to custom
fields through the API.
Blocks the use of Inactive records in new records and prevents changing an existing record to use
an Inactive-related field. (The returned error code is 14057.)

Migrating your company data from version 19.8
Important! You must be using Sage 100 Contractor version 19.8 to migrate your company to version
21.1. If you are using an earlier version of Sage 100 Contractor, you must first upgrade your company
data to version 19.8.
You use the migration utility in the new Database Administration tool to automatically migrate and upgrade
your data to version 21.1, including all company data in folders and subfolders of …\MB7\[CompanyName].
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Migrated files are located in shared folders under \\ServerName\CompanyName. These subfolders are
organized using a similar folder structure as in earlier versions, and include:
l

Aatrix Forms

l

Attachments

l

Direct Deposit

l

Images

l

Reports

The Direct Deposit and Reports folders are available as soon as you open the company in Sage 100
Contractor. The remaining folders are created as needed.

Note: For detailed, step-by-step instructions on migration, see the Database and Company
Administration Guide or the Database Administration help.

Preparing for migration in version 19.8
Migration should proceed smoothly in most cases. However, you should audit your accounting data and
your company payroll in version 19.8, and then fix any errors, before attempting migration to version 21.1.
Use the following audit tools to prepare your data in version 19.8:
l

1-6 Period and Fiscal Year Management > Audit Books

l

5-3-7 Payroll Audit

l

6-6-3 Purchase Order Audit

l

6-7-4 Subcontract Audit

l

12-5 Inventory Audit

Note: If your data includes serious audit errors, you may need assistance from your business partner or
consultant to prepare your database for migration.

Migrating reports
The new Database Administration tool also includes a utility to migrate and upgrade Sage 100 Contractor
reports and reports written with the Sage 100 Contractor report designer.
In version 21.1, shared custom reports and form designs are located in these folders:
l

\\ServerName\Sage100Contractor\Custom Reports

l

\\ServerName\Sage100Contractor\Report Forms
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Private custom reports and form designs are located in Sage 100 Contractor User Data folders
associated with each user name, as follows:
l

\\ServerName\Sage100Contractor\User Data\username\Custom Reports

l

\\ServerName\Sage100Contractor\User Data\username\Report Forms

Updating custom reports
You also need to update custom reports created with third-party software, such as Crystal Reports, so they
map to the new database.
We recommend that you use the new report views that come with version 21.1 to create or update reports.
The new views were created for your convenience, so that future database changes will not necessarily
break your custom reports.

After migrating your company data
After migrating your data, you will likely need to perform the following additional steps to prepare your
company for use in Sage 100 Contractor:

Important! Use Database Administration, not SQL Server Management Studio, for all these tasks.
l

l

Add company administrators. There is no longer a generic "supervisor" user as there was in earlier
versions. All users must sign into the company using their personal IDs, and only users designated
as company administrators have heightened privileges previously associated with the "supervisor"
role. You can designate one user as a company administrator during migration, but you can add
others later.
Add SQL logins for new users. If you have new users that did not exist in your version 19.8
company, add them as users to the SQL database.
You must also add them as users and assign security in Sage 100 Contractor.

l

Designate an additional SQL Server administrator. Only a user with system administrator privileges
for the SQL instance can administer users for SQL Server or assign the system administrator role to
another user. Therefore, it is vital at all times that more than one user has a system administrator
role. If the principal system administrator should suddenly fall ill, or leave your company, or
otherwise be unable to perform their duties, another person with administrative access to the SQL
Server database must be able to take over that role.

Note: The person who installs Sage 100 Contractor is automatically assigned a 'sysadmin' role in
SQL Server. When they designate a SQL Server administrator in Database Administration, that
person is also assigned the 'sysadmin' role in SQL Server.
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l

l

l

l

Switch your Sage Construction Anywhere to version 21.1. If you have been using Sage
Construction Anywhere with Sage 100 Contractor version 19.8 and want to use it with version 21.1,
you will need to switch the connection to version 21.1. For help on switching the connection, see the
instructions in the Installation and License Administration Guide.
Migrate your Sage ACT! settings to version 21.1. If you have been using Sage ACT! with Sage 100
Contractor version 19.8 and want to use it with version 21.1, you need to change your ACT! settings
to point to your new version 21.1 company database. For help on migrating your ACT! settings to
version 21.1, see the instructions in the Installation and License Administration Guide.
Migrate each user's scheduled reports from version 19.8. See the instructions in the Installation and
License Administration Guide.
Migrate each user's alerts from version 19.8. See the instructions in the Installation and License
Administration Guide.

Changes to converted data
During migration, the program may encounter problems that might prevent it from writing a particular
record to the new SQL Server database.
If the problem is one that the migration program can fix, it repairs the record, and then writes the updated
record to the SQL Server database. (For a list of the types of errors that can be fixed during migration, see
the Database and Company Administration Guide.)

Note: Not all errors can be fixed during migration. In these cases, the record is not written to the new
database.

The migration log file
The program keeps a log of all changed records and records that were not migrated because of an
unresolvable error, unless the record was invalid in version 19.8. (Invalid records are neither migrated nor
logged.)
After migration, you should check the log file to see what changes were made to your data during
conversion, or whether any records were not migrated to the new SQL database.
The _SQL_MIGRATION_LOG.TXT file is located in the source company's main folder (for example,
C:\MB7\Sample Company). A supplemental file, _SQL_MIGRATION_LOG_VERBOSE.TXT, includes
more detailed information about each error found.

Using Sage 100 Contractor Intelligence Reporting with Sage 100 Contractor 2018
Sage 100 Contractor Intelligence Reporting versions 20.2 and 19.7 are not designed to work side-by-side.
If you used Sage Intelligence Reporting with Sage 100 Contractor version 19.8 or earlier, follow the steps
in Knowledgebase article 75640 when upgrading to version 21.1.
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Known Issues and Comments
The following sections describe known issues and problems in Sage 100 Contractor Version 21.1.

General
Internet access required for Sage 100 Contractor
Sage 100 Contractor features, such as printing or efiling tax forms, submitting enhancement requests,
accessing Help, or downloading periodic product or tax updates all require Internet access.
To take advantage of these features, ensure that any workstation or server that Sage 100 Contractor is
installed on has access to the Internet.
During installation of Sage 100 Contractor, the computer serving as the Sage license server must be able
to connect to the Internet to obtain licenses. Once installation is complete, you can check out license uses
for each computer where Sage 100 Contractor is installed, then disconnect the Sage license server from
the Internet.

Note: A static Internet connection using a compatible web browser is required for Sage Construction
Anywhere. For current information on supported browsers, supported Sage 100 Contractor versions,
and other system requirements, see the Sage Construction Anywhere help at

http://help.sageconstructionanywhere.com/sage100contractor/help/Default.htm#01_Setup/System_
requirements.htm.

Configuring anti-virus software and third-party firewalls
During installation of the Sage 100 Contractor Hosting Framework, the Windows Firewall is configured
automatically to allow the Sage 100 Contractor Hosting Framework to act as a TCP server. If you use some
other firewall, however, you may need to manually adjust some settings in the firewall in order to ensure
proper operation.
You can use the following basic procedure to manually configure the Windows Firewall to allow the Sage
100 Contractor Hosting Framework to communicate with other computers. Use it as the basis for manually
configuring other third-party firewall products.
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To configure the Windows Firewall:
1. For Windows Server 2008, click Start > Control Panel > Security.
For Windows 7, click Start > Control Panel > System and Security.
For Windows 8.1 and Windows 10, click Start > All apps > Control Panel > System and Security.

2. Open Windows Firewall, and then select Allow a program or feature through Windows Firewall.
3. Select Sage 100 Contractor Hosting Framework on the list, if it is not selected..
Note: By default, the exception is set to allow access by any computer on the network. You can refine
this setting by selecting the Change Scope button. Be aware that restricting the scope incorrectly can
cause the computer to be unable to connect with some or all of the other machines on the network.

Files to exclude when manually configuring your firewall for Windows 8.1 Professional 32-bit
l

C:\ProgramData\Sage\Sage 100 Contractor

l

C:\Program Files\Sage\Sage 100 Contractor

l

C:\ProgramData\Aatrix Software

l

C:\Program Files\Aatrix Software

l

C:\%LocalAppData%\Sage\Sage 100 Contractor

l

Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 8.1 Professional 64-bit
l

C:\ProgramData\Sage\Sage 100 Contractor

l

C:\Program Files (x86)\Sage\Sage 100 Contractor

l

C:\Program Files (x86)\Aatrix Software

l

C:\ProgramData\Aatrix Software

l

C:\%LocalAppData%\Sage\Sage 100 Contractor

l

Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 7 Professional 32-bit
l

C:\ProgramData\Sage\Sage 100 Contractor

l

C:\Program Files\Sage\Sage 100 Contractor

l

C:\ProgramData\Aatrix Software
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l

C:\Program Files\Aatrix Software

l

C:\%LocalAppData%\Sage\Sage 100 Contractor

l

Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 7 Professional 64-bit
l

C:\ProgramData\Sage\Sage 100 Contractor

l

C:\Program Files (x86)\Sage\Sage 100 Contractor

l

C:\Program Files (x86)\Aatrix Software

l

C:\ProgramData\Aatrix Software

l

C:\%LocalAppData%\Sage\Sage 100 Contractor

l

Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 8.1 Professional
l

C:\ProgramData\Sage\Sage 100 Contractor

l

C:\Program Files (x86)\Sage\Sage 100 Contractor

l

C:\Program Files (x86)\Aatrix Software

l

C:\ProgramData\Aatrix Software

l

C:\%LocalAppData%\Sage\Sage 100 Contractor

l

Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows Server 2008 R2, 2011, 2012
l

C:\ProgramData\Sage\Sage 100 Contractor

l

C:\ProgramFiles (x86)\Sage\Sage 100 Contractor

l

C:\Program Files (x86)\Aatrix Software

l

C:\ProgramData\Aatrix Software

l

C:\%LocalAppData%\Sage\Sage 100 Contractor

l

Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Software and hardware required to support Microsoft SQL Server
Version 21.1 requires an instance of Microsoft SQL Server. You can download and use Microsoft SQL
Express at no charge, or you can use the full version of Microsoft SQL Server. You can even start using
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Microsoft SQL Express, and upgrade to the full version of Microsoft SQL Server later, if necessary.
When you first open the new Database Administration tool, the program tries to configure an instance of
Microsoft SQL Server with optimal settings for Sage 100 Contractor for you. If you do not already have an
instance of Microsoft SQL Server, you can let the Database Administration tool download, install, and
configure Microsoft SQL Express for you.
Refer to Knowledgebase article 90782 for detailed information about supported operating systems and
software, and for minimum hardware requirements.

Installation of Microsoft SQL Server on a domain controller is not recommended
Microsoft recommends against installing SQL Server on a domain controller, and does not support SQL
Server on a read-only domain controller should you encounter any problems with this configuration.
Because you must install Database Administration on the same machine as SQL Server, you should not
install Database Administration on a domain controller. To guard against inadvertent installation on a
domain controller and the potential for irrecoverable data losses, you will receive a warning if you attempt
to install Database Administration on a machine used as a domain controller .
For more information, see the Microsoft Knowledgebase article https://support.microsoft.com/enus/kb/2032911.

About .NET Framework
.NET 4.6.1 Framework is required
If Microsoft .NET 4.6.1 Framework is not already installed, it will be installed automatically when you install
Sage 100 Contractor. Installation of .NET 4.6.1 Framework alone may take up to 20 minutes per computer.
Make sure that both your client and server computers meet the minimum requirements for installing both
Sage 100 Contractor software and .NET 4.6.1 Framework.

Note: If Sage 100 Contractor requires an installation of .NET 4.6.1 Framework, the Sage 100 Contractor
installation process may continue automatically after the .NET Framework installation is completed. If
you are prompted to restart your computer after the .NET Framework installation, you must do so to
continue the Sage 100 Contractor installation.

.NET 3.5 is also required
In some situations, you may need to turn on .NET 3.5 manually by selecting the .NET 3.5 check box in the
Windows Features dialog box. For more information, see Knowledgebase article ID 68381, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=68381.
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Windows Small Business Server 2011 is not supported
Microsoft Small Business Server 2011 does not support .NET Framework 4.6.7, which Sage 100
Contractor (SQL) requires. Unfortunately, this means that Sage 100 Contractor (SQL) cannot support
Small Business Server 2011.

Turning on Microsoft .NET 3.5
Microsoft .NET 3.5 must be available and enabled prior to installing Sage 100 Contractor on a Windows
Server 2008 R2 machine. Server 2008 R2 comes with .NET 3.5 loaded but not installed, so Sage 100
Contractor does not install it automatically.
If you attempt to install Sage 100 Contractor without .NET 3.5 installed, you receive the following message
during the licensing install: “Sage.CRE.HostingFramework.Service v3.2 has stopped working.” When you
click [OK], the installation continues, but the services have not been installed so Sage 100 Contractor
cannot open. The Sage.CRE.HostingFramework Service will not install unless .NET 3.5 has been installed.
If you receive the above message during installation, install .NET Framework 3.5., and then reinstall Sage
100 Contractor.
The following instructions are for Windows Server 2008 R2.
To verify that .NET 3.5 is installed on Windows Server 2008 R2:

1. Click the Start button in the lower left corner of the display.
2. Highlight Administrative Tools and select Server Manager.
3. In the Server Manager interface, click Features to display all the installed Features in the right-hand
pane. Verify that .NET Framework 3.5.1 is listed.
To enable .NET 3.5 on Windows Server 2008 R2:

1. In the Server Manager interface, select Add Features to display a list of possible features.
2. In the Select Features interface, expand .NET Framework 3.5.1 Features.
3. Once you expand .NET Framework 3.5.1 Features, you will see two check boxes. Check the box
next to .NET Framework 3.5.1 and click Next.

4. In the Confirm Installation Selections interface, review the selections and then click [Install].
5. Allow the installation process to complete and then click [Close].
Note: Enabling .NET Framework 3.5.1 may require a reboot.
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About network configuration and TCP Remoting Channel
Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component, to
enable communication among computers on a network. By default, Sage 100 Contractor uses the
TCP starting port 48750. Certain configurations can potentially disable the communication:
l

l

l

You must enable file sharing on your computers. To enable file sharing, follow the instructions in the
Windows Help.
TCP communication requires the selection of port numbers that are not in use by other processes
on the local computer.
Software firewalls running on the local computer can be configured to block processes from opening
TCP ports, which will prevent communication through the TCP Remoting Channel.

Sage Advisor Update
Important! Sage Advisor Update is not available until further notice.
You can download Version 21.1 from the Knowledgebase using the link provided in the Software Notice
that announced the product download.

PCI DSS Compliance
PCI DSS stands for Payment Card Industry Data Security Standard. It was developed by the major credit
card companies as a guideline to help organizations that process card payments to prevent credit card
fraud, cracking, and other security weaknesses and threats.
A company processing, storing, or transmitting payment card data must be PCI-compliant or risk losing its
ability to process credit card payments and being audited and/or fined. (For more information about PCI
standards, see https://www.pcisecuritystandards.org/.)
Sage 100 Contractor payment processing works exclusively with Paya to enable merchants to seamlessly
process check and credit card transactions directly in Sage 100 Contractor. The payment processing
program uses Sage Exchange, a secure payment-processing application, to connect to Paya and process
check and credit card transactions.
Integrating your financial and operations system with Paya lets you process check and credit card
transactions without storing your customers’ sensitive card information in your database. Sage Exchange
transmits check and credit card details through a secure connection to Paya, where they are stored in a
PCI-compliant vault, protecting your from exposure to non-compliance penalties and credit card fraud.

Caution! To avoid non-compliance with PCI standards, do not store credit card information in Sage 100
Contractor. Such storage creates unnecessary risk for your business and your customers.
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Using Sage 100 Contractor Intelligence Reporting with Sage 100 Contractor 2018
Sage 100 Contractor Intelligence Reporting versions 20.2 and 19.7 are not designed to work side-by-side.
If you used Sage Intelligence Reporting with Sage 100 Contractor version 19.8 or earlier, follow the steps
in Knowledgebase article 75640 when upgrading to version 21.1.

Tax Forms and eFiling by Aatrix configuration requirements
Tax Forms and eFiling by Aatrix requires an Internet connection for two reasons:
l

For updating forms and executable files.

l

For electronic filing (eFiling) of the forms.

If you experience an Internet connection problem, it may be due to problems communicating through an
Internet firewall. Firewalls need to have access allowed through specific ports:
l

l

The Tax Forms and eFiling Updater uses standard SSL/HTTP port 80 to access the site
http://updates.aatrix.com.
The eFiling component uses secure HTTPS on port 443 to access the site https://efile.aatrix.com.

By allowing access to aatrix.com, you allow both updates and eFiling. Occasionally, restrictions are tighter
and only allow access to these ports by specific programs. Tax Forms and eFiling uses the following
programs to access the Internet.
For updating using http on port 80 to http://updates.aatrix.com:
l

aatrixforms.exe

l

updater.exe

l

updater2.exe

For eFiling using secure http on port 443 to https://efile.aatrix.com:
l

builder.exe

l

viewer.exe

Printing reports at year-end (U.S. Edition)
As of Version 19.2, in the U.S. Edition, if you pay retainage in the current year for a prior year invoice and
then you print a 4 1 3 26 AP Aging report for the prior year, the report shows a reduced retainage amount,
and the amount paid in the future period is allocated to the Current period or an aging period, depending
on the due date of the retainage and the date it was paid.
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Therefore, you should print these reports as part of your year-end processing to ensure that you have a
set of reports that reflect the true amount of retainage outstanding at year end.

Tip: If you archive your data at year end, you can also print the reports from the archive company, later.

Printing reports to PDF or exporting to Excel?
When you print reports to PDF, you may find that the size of the PDF file is unexpectedly large and the
resolution of the displayed PDF is not optimal.
To create a substantially smaller PDF file with good resolution, you can run Sage 100 Contractor in
Compatibility Mode (compatible with Windows 7), and then print the report.

Note: You cannot export to Microsoft Excel when running Sage 100 Contractor in Compatibility Mode if
you use Microsoft Office 2013.
We have not encountered this issue during testing, nor has it been reported for Windows Server 2012 R2.

Use Adobe Reader Version 8.1.3 or later for faxing
Customers have reported problems faxing from Sage 100 Contractor with versions of Adobe Reader
earlier than 8.1.3. Adobe Reader Version 8.1.3 and later support faxing from Windows and from Sage 100
Contractor.

Important! To fax from Sage 100 Contractor, the Windows Fax Service component must be installed
with your Windows operating system. For more information about installing the Windows Fax Service
component, see the Sage 100 Contractor Help topic, “Installing the Windows Fax Service component.”

Sage licensing (Sage 100 Contractor Hosting Framework) cannot auto-start on
Windows 8.1, Windows 7 Professional, Server 2008, or Server 2008 R2 Standard
The Sage licensing service (Sage 100 Contractor Hosting Framework) cannot auto-start on computers
running the Windows 8.1, Windows 7 Professional, Server 2008, or Server 2008 R2 Standard operating
systems. If the service stops, the program displays a message advising you to take further action to
resolve this issue.

Configuring Windows Regional and Short Date Format
To specify regional formats for Windows:

1. Click the [Start] button, point to Control Panel, then click Clock, Language, and Region .
2. Click Region and Language.
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3. On the Formats tab, select the format for your country.
4. Under Date and time formats, from the Short date format drop-down list, select the format used for
your country.

5. Click [OK].
6. Close the Clock, Language, and Region window.

Posting Status for a Company Created since Version 19.2
If you created a new company using version 19.2, or higher, in certain limited scenarios an issue can arise
after you advance the year to the first period of the new fiscal year. The new year may not be available
when you try to change the posting period.
A fix to prevent this issue is included in the January 2015 update. However, if you have already
encountered this issue, contact Customer Support for assistance.

Windows "Sleep Mode" prevents computers from obtaining a license use
If the computer you are using as a license server goes into sleep mode, other computers on the network
cannot obtain a license.
To avoid this possibility, set Sleep Mode on your license server computer to Never.

To set the Sleep Mode to “Never”:
1. In Windows 8.1 Professional, Windows 10, or Server 2012 Standard, click Start > All apps > Control
Panel > System and Security > Power Options.
In Windows 7, click Start > Control Panel > System and Security > Power Options

2. Select Change when computer sleeps.
3. From the Put computer to sleep list, select Never.

Windows 8.1 Professional and Server 2012 Standard Operating
Systems
Sage licensing (Sage 100 Contractor Hosting Framework) cannot auto-start on
Windows 8.1
The Sage licensing service (Sage 100 Contractor Hosting Framework) cannot auto-start on computers
running the Windows 8.1 Professional or Windows 8.1 Enterprise operating systems. If the service stops,
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the program displays a message advising you to take further action to resolve this issue.

Server 2012 network configuration and TCP Remoting Channel
Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component to enable
communication among computers on a network. File and printer sharing on computers running the Server
2012 operating system must be enabled. To enable file sharing, follow the instructions in the Windows
Server 2012 Help.

Windows 7 Professional and Server 2008 R2 Standard
Operating Systems
Launching Sage 100 Contractor to run as administrator for scheduling reports
Important! On computers running Windows 7 Professional or Server 2008 R2 Standard, scheduling
Sage 100 Contractor reports requires that you “run as administrator” or to “run the program as
administrator.”
Microsoft Windows changed security rules in the Windows 7 Professional and Server 2008 R2 Standard
operating systems to make your computer more secure. If you are running Sage 100 Contractor as a
typical user, then you have limited privileges in some areas of the program, such as saving a report
schedule. To save a report schedule, you must launch Sage 100 Contractor with the command to either
Run as administrator or Run this program as an administrator.
When you select either command, the settings are limited to you personally. Your settings to run Sage 100
Contractor as administrator do not affect the next person who logs on and launches Sage 100 Contractor
from this computer. Your settings on this computer can either be temporary or persistent. For example,
when you select Run as administrator, you run the program as administrator for that session only. When
you select Run this program as an administrator, you set program properties to always run the program as
administrator when you log on to this computer.

Note: "Run as administrator" and "Run this program as an administrator" are not related to Windows 7
Professional or Server 2008 R2 Standard operating systems user groups but are limited to a specific
program you are running.
To set "Run as administrator":

1. On your Windows desktop, right-click the Sage 100 Contractor program icon.
2. From the drop-down menu, to launch the program, click Run as administrator.
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Note: Selecting Run as administrator only runs the current session of running Sage 100 Contractor. The
setting does not persist after the session is over.
To set "Run this program as an administrator":

1. On your Windows desktop, right-click the Sage 100 Contractor program icon.
2. From the drop-down menu, click Properties.
3. On the Sage 100 Contractor Properties window, click the Compatibility tab.
4. Under Privileges Level, select Run this program as an administrator.
5. Click [Apply], and then click [OK].
Note: Selecting Run this program as an administrator always runs the program with these properties
when you launch the program on this computer. The setting persists.

Solution for Windows Server 2008 R2 "Permission Error Opening File"
If you see a permission error message when launching Sage 100 Contractor on a computer running the
Windows Server 2008 R2 operating system, follow these instructions:

1. On the Window desktop, right-click Start, and then click Open Windows Explorer.
2. On the left side of the window, under Computer > Local Disk, right-click the \Sage100Con folder, and
then select Properties.

3. On the Sage100Con Properties window, click the Security tab.
4. From the list under Group or User Names, select USERS, and then click the Edit button.
5. On the Permissions window, select USERS again, and under Allow, select the Full control check
box.
Selecting Full control selects all the check boxes necessary for this solution.

6. On the Permissions window, click [OK].
7. On the Sage100Con Properties window, click [OK].

Solution for Windows 2008 Server R2 Application Error Message
Under some circumstances, on servers operating Windows 2008 Server R2, you may see the following
error message when trying to open a photograph or image file in Sage 100 Contractor:
"No application is associated with the specific file associated with this application."
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This error message appears when you attempt to open an image file in Sage 100 Contractor but you have
not yet enabled the Desktop Experience feature in Windows 2008 Server R2. If you receive this error
message, install Desktop Experience using the Server Manager utility:

1. In Windows 2008 Server R2, select Start > All Programs > Administrative Tools > Server Manager.
2. In the Server Manager window, click Features (left-hand pane).
3. In the Features pane, click Add Features.
4. Select the Desktop Experience check box.
5. If you are prompted to add additional features, click [Add Required Features].
6. Click [Next].
7. Click [Install].
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