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July 2019 Update (Build 22.1.154)

This update includes some fixes and a U.S. tax update that are described in the following sections.

U.S. Payroll Tax Tables

Payroll tax tables have changed for Idaho in this update.

Enhancement for the U.S. Edition

New tax types for Washington State's Paid Family and Medical Leave contributions

We have created two new tax types required for reporting Washington State’s Paid Family and Medical
Leave contributions. The new tax types are:

« 20-Employee State Paid Leave. You use this tax type for payroll deductions for employees in
Washington State who contribute to that state's paid family and medical leave plan.

« 21-Employer State Paid Leave. You use this tax type for employer contributions to Washington
State's paid family leave plan. Employers that have more than 50 employees are required to make
contributions to the family leave plan.

The 5-4-2 State Tax Forms PFML report for Washington State relies on these tax types, and the report will
not print if no tax calculations use them, even if you previously set up calculations for Washington State’s
Paid Family and Medical Leave contributions.

When you run the 5-4-2 State Tax Forms PFML report for Washington State for the first time, Sage 100
Contractor displays a window where you identify the payroll calculations you have been using for
employees who work in Washington and for employers who must make contributions to the medical leave.
Sage 100 Contractor then automatically adjusts these calculations to use the new tax types.

Note: You need to run this utility only once. When the payroll calculations are up to date with the new tax
types, this window does not appear when you run the 5-4-2 State Tax Forms PFML report.
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Fixes in the July 2019 Update

Fixes for Both Editions

« When you create a new record from a template or copy and paste records in the 6-11-2 Requests
for Information window or the 6-11-8 Correspondence window, message boxes now include the
correct text from the template or the original record.

« Overriding a per diem calculation in the 5-2-2 Payroll Records window no longer produces an
incorrect calculation for the per diem expense.

» In windows that display only a grid (such as the 5-3-4 Paygroups and 6-5 Cost Codes windows), you
can insert a row into the middle of the grid without receiving a SQL Server error. In earlier releases of
version 22.1, you could only add a row at the end of a grid in these windows.
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Enhancements in Version 22.1

This section describes the new features and enhancements you will find in version 22.1.

We've Been Listening to You!

Sage thanks you for your product ideas! In version 22.1, we have incorporated the following top-ranked
suggestions from the Sage |deas site. Later sections in the Release Notes describe changes that require
more detailed explanation.

» You can look up previous bank reconciliations even if you do not save bank reconciliations
individually as PDFs when you save the final bank reconciliation.

You can now open, view, print, and even reverse previous final reconciliations.

We have added a new Sort by Item Amount option to the 1-5 Bank Reconciliation window, and we
have added totals by credit card to the 4-7-5 Reconcile Credit Card Statements window.

For more details about these changes, see "Save "Final" Bank and Credit Card Reconciliations for
Later Access" (page 8), later in this document.

Thanks for these suggestions Stacie S., McKay F., Valerie L., Jennifer S., Jodi J., Melinda A.

o As an administrator, you can set command-level security for many menu options and related
buttons, providing a finer degree of control over users' abilities to view sensitive information, such as
wage rates, net pay, and total costs. Where security is available for an option or a corresponding
button, highlight the command from the Options menu or the Post menu, press the F7 key, and then
use the Security window to control access for different types of users.

For more information about this new feature, see "Command-Level Security for Many Options and
Post Commands " (page 6), later in this document.

Thanks for this suggestion Roger B., Nancy K., and Tom O.

» Field-level security was inadvertently missing from several key text boxes in the 5-2-2 Payroll
Records window, so we've added field-level security to the summary Gross Pay, Adds, Deducts, Net
Pay, and Total Cost fields in the footer of this window.

Thanks for this suggestion Nicole R.

» In windows that have a View menu, you can view the fields and commands to which access is
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restricted in that window.

When you click View > Security, the program highlights the fields and commands for which security
is turned on. In this View Security mode, you cannot edit any of the fields in the window, although you
can still turn security off and on.

You can now sort most grids that you open using a button in a primary window. (The grid then opens
in a secondary window.) Select the header for the column you want to sort on, and then click the Sort
by option. For example, you can sort open invoices, paid invoices, and subcontractors in the 4-4
Vendors window. (

The few exceptions where you cannot sort grids are:

« T&M Job Costs (in 3-2 Receivable Invoices/Credits)
« Budget (in 3-5 Jobs)

o Proposal (in 3-5 Jobs)

« Routes (in 11-2 Work Orders/Invoices/Credits)

Thanks for this suggestion Libbie E. and Rhiannon T.
You can sort grids by name on columns that have a combined number and name.

The program warns you when you try to post an AP invoice without a subcontract reference or, if you
require a subcontract reference, it stops you from posting. This is similar to the existing PO Warning
set in the 4-4 Vendors window.

For more details about this change, see "Warning when Posting an AP Invoice with No
Subcontract" (page 11), later in this document.

Thanks for this suggestion Rik M. and Tara G.
You can easily transfer amounts between bank accounts.

For more details about this change, see "Easily Transfer Amounts between Bank Accounts" (page
10), later in this document.

Thanks for this suggestion Regina J.
In the U.S. Edition, you can now set up and report on use taxes paid on payable invoices.

For more details about this change, see "Easily Report on Use Taxes" (page 18), later in this
document.

Thanks for this suggestion Rhiannon T. and Kevin Q.
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« When you inactivate a credit card account record in the 1-7 General ledger Accounts or the General
Ledger Subaccounts window, you can no longer select the associated credit card in the following
windows:

4-3-2 Pay Vendors

4-7-2 Add/Edit Credit Cards

4-7-3 Enter Credit Card Receipts

4-7-4 Enter Recurring Charges

4-7-5 Reconcile Credit Card Statements
4-7-6 Pay Credit Cards

Thanks for this suggestion, Sharon S.

» Inthe 13-2 Project Review window, you can now include all jobs when you generate a graph by job
or by code. To include all jobs in the graph, leave the Job# selection blank.

Thanks for this suggestion Pam M.

o The 6-1-7-21 and 6-1-7-31 Over/Under reports now correctly report on all active jobs, including job
costs that are over budget. To include costs that exceed the budget, select the new Permit Costs to
Exceed Budget check box.

We have added a period selector to the 6-1-7-31 Over/Under~Extended report. You are no longer
required to specify a period.

Also, both reports now provide the following selection criteria:

Job Type

Job Status

Job Supervisor
Salesperson
Estimator

Period (the default is now less than or equal to the current fiscal year)

Note: Because the report criteria have changed, any saved criteria for the Over/Under reports will
be deleted during the upgrade.

Thanks for this suggestion Kenneth K.

o The 6-4-2 Print Change Orders™Approved reports correctly include previously approved changes
regardless of the order in which they were approved.
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The form designs for these two reports (System.Change_Prime and System.Change_Prime_
Request) have new calculated fields for Prior Approved, Prior Contract, and New Contract amounts.
If you customized these reports and you want to retain the previous style, which did not take the
approval date into account, you can keep them. However, if you want to take advantage of the new
calculated fields, you need to modify your form to replace the old calculations with the new ones.

Thanks for this suggestion Rik M.

e Inthe 4-7-3 Enter Credit Card Receipts and the 4-7-6 Pay Credit Cards windows, we have added a
quick list for the Payee box.

Thanks for this suggestion Charlene D.

» Inthe A/P Invoices grid associated with the 3-5 Jobs window, we added a Vendor column to identify
the vendor for an invoice.

Thanks for this suggestion Roxi M.

» When listing invoices in the 6-6-1 Purchase Orders window, the program no longer includes
amounts from void invoices.

Thanks for this suggestion Deborah B. and Susannah M.

« When displaying payment history in the 3-2 Receivable Invoices/Credits window, the program lists
the most recently paid invoices first.

Thanks for this suggestion Phyllis B.
¢ You can now sort the Combined AR/SR Aging reports alphabetically.

Thank you Jennifer L. for this suggestion.

Command-Level Security for Many Options and Post
Commands

In earlier versions, you could limit access to specific windows and fields in a window by setting security
access using the F7 key. However, this menu- and window-level security did not prevent a user from using
Option commands and buttons to view sensitive information in separate windows, or perform other
functions that you want to restrict.

Now, you can exercise a finer degree of control over who can use Options and Post menu commands and
related buttons to view sensitive information. You use this new feature to allow users to enter information in
a window while preventing them from viewing sensitive information in related windows. Restricting access
in this way can be especially useful for Payroll windows where users might need access to a data-entry
window, but should not be able to view employees' personal information or pay rates.

Where security is available for an Options menu or Post menu command or for a corresponding button,
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you click the command on the menu, and then press the F7 key to open the Security window for that
command. You use the Security window to allow access to different types of users. For example, in the 1-4
Recurring Transactions window, select Post > Multiple Transactions, press F7, and then select the check
box beside each security group that can post recurring transactions. Clearing all the check boxes removes
the security for the command.

Note: Only Options menu and Post menu commands that do not already require administrative rights
provide this command-level security.

Important! You must now use the new F7 security feature to provide security for the following buttons:

« 3-5Budget

o 3-5Purchase Order
« 3-5 Subcontracts

« 3-5Change Orders
« 3-5 A/R Invoices

o 3-5Payment History
o 3-5Proposal

o 3-5 A/P Invoices

« 3-5S/R Invoices

o 3-6 Job List

« 3-6 A/R Invoices

« 3-6 Service Invoices
« 3-6 Service Orders
« 3-6 Service Quotes
« 3-6 Payments

o 4-4 Subcontracts

e 4-40Open PO's

o 4-4 Closed PO's

o 4-4 Open Invoices

o 4-4 Paid Invoices

e 4-4 Invoice Payments
o 4-4 All Payments

e 5-2-1Earnings
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o 5-2-2 Payroll Records
o 6-4-1 Create A/R Invoice

¢ 6-4-1 Create Purchase Order

Security reports

The new 13-7-23 Security Settings report shows the security groups that have access to menu commands
and buttons. You can run this report for users and for security groups.

We have also added command and button security settings to the existing 13-7-22 Database
Security/User Def report.

Save "Final" Bank and Credit Card Reconciliations for Later
Access

When you save a final bank or credit card reconciliation, Sage 100 Contractor stores the current
reconciliation information in new database tables. This means you can now open, view, print, or even
reverse previous final reconciliations.

To save a bank reconciliation:
1. In the 1-5 Bank Reconciliation window, click File > Save.

2. In the Save Bank Reconciliation window that opens, select one of the following options depending
on the state of the reconciliation:

o Save as trial reconciliation.
e Save as final reconciliation.

3. Ifyou selected Save as final reconciliation:

a. If youwantto create a PDF copy of the reconciliation information, select Create a PDF.

b. Inthe Description box, type a description for the reconciliation that will help you to recognize it,
later, in the Select Bank Reconciliations window.

c. Inthe Statement Ending Date box, either accept the default ending date for the reconciliation
or type a different one.

4. Click [Save Trial] or [Save Final], depending on the type of reconciliation you are saving.

When you click [Save Final], the program saves the information in the reconciliation grid, along with
the description and statement ending date.
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Note: You save credit card reconciliations in the same way in the 4-7-5 Reconcile Credit Card
Statements window. After saving a final credit card reconciliation, a message invites you to make a
payment on the credit card. If you click [Yes], the 4-7-6 Pay Credit Cards window opens so that you can
enter the payment.

To view a saved reconciliation:
1. On the new Previous Reconciliations menu, click Saved Reconciliations.
2. Inthe Select Bank Reconciliations window that opens, double-click a saved reconciliation.

Sage 100 Contractor displays the reconciliation in the 1-5 Bank Reconciliation window.

Sort bank transactions by amount in the reconciliation grid

You can use a new Sort items by Amount option in the 1-5 Bank Reconciliation window to display
transactions by amount in the reconciliation grid.

Reverse an earlier bank reconciliation

With version 22.1, you can reverse a final bank reconciliation you saved earlier.

If you made an error in a bank reconciliation, or saved it prematurely as a final reconciliation, you can
reverse the reconciliation and continue to work with it, or correct the error.

To reverse a saved reconciliation:
1. In the 1-5 Bank Reconciliation window, click Previous Reconciliations > Saved Reconciliations.

2. Inthe Select Bank Reconciliation window that opens, double-click the reconciliation you want to
reverse.

Sage 100 Contractor displays the reconciliation in the 1-5 Bank Reconciliation window. At this point,
you can only:

o Printtransactions.
« Scroll through the transactions in the grid.

« Select a transaction on the grid, and then click [Go to transaction] to view it in the original entry
window.

o Start a new reconciliation.

« Click the [Undo Final]. button to reverse the reconciliation. Until you reverse the reconciliation,
you cannot work with the items in the grid.

3. Click [Undo Finall].
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When you click [Undo Final], the reconciliation reverts to a Trial state, so you can clear transactions
and enter adjustments.

Enhancements in the 4-7-5 Reconcile Credit Card Statements window

View totals for each cardholder

In the 4-7-5 Reconcile Credit Card Statements window, you can view subtotals for verified credit card
transactions for each cardholder whose transactions appear in the reconciliation grid. You select the
cardholder from a new Card Account Total list box. Then, Sage 100 Contractor displays the total Credits
Verified and Charges Verified in boxes below the Card Account Total box.

A clean start for new reconciliations

In version 22.1, when you start a new reconciliation (by clicking the New record button or File > New), only
the Card Issuer Account and the Statement Cutoff Date fields are available until you select the Card Issuer
Account. The program displays the current balance after you select the card issuer.

Other reconciliation enhancements

« Inthe 1-3 Journal Transactions window, you now receive a warning if you change the Cleared Credit
Card Reconciliation option.

« When you print transactions from the 1-5 Bank Reconciliation window, the report prints "Match" to
indicate matched records.

Easily Transfer Amounts between Bank Accounts

You can easily record cash transfers between two bank accounts.

You use either the 1-1 Checks/Bank Charges window or the 1-2 Deposits and Interest Charges window to
open the new Transfer Funds window, where you record funds transfers.

You use the new Transfer to Another Account option in the 1-1 Checks/Bank Charges window and the
new Transfer from Another Account option in the 1-2 Deposits and Interest Charges window to open the
Transfer Funds window.

In the Transfer Funds window, you specify the bank accounts involved in the transfer. You must specify the
two valid cash accounts that you are transferring funds from and to. Also, you specify a bank clearing
account to offset the debit and credit from the two-part transfer.

The transfer is actually posted as two transactions:
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« One transaction credits the account the funds you are transferring funds from and debits a cash
clearing account.

« The other transaction debits the account receiving the funds and credits the cash clearing account.
Note that the net effect of the transfer on the clearing account is zero.

You reconcile one transaction for each bank account. You reconcile the transaction in the "From" account
the same as you would for a check (cheque, in Canada). You reconcile the transaction in the "To" account
the same as for a deposit.

Note: If you try to void a transaction that is part of a transfer, the program warns you that the other
transfer transaction will also be voided. You can choose to proceed or not. However, you cannot void
one part of a transfer if the other transaction has been cleared.

Warning when Posting an AP Invoice with No Subcontract

In the 4-4 Vendors window, you can set a warning that appears when you try to post a payable invoice
without a subcontract reference. We renamed the existing PO Warning option PO/Contract Warning, and
you can now select:

o 0-None

o 1-Warnifno PO

e 2-Warn if no Subcontract

« 3-Warnif no PO or Subcontract
« 4-Require PO

« 5-Require Subcontract

« 6-Require PO or Subcontract.

During the database upgrade, any vendor records marked 2 - Require PO will be updated to 4 - Require
PO.

View Sage Messages in Sage 100 Contractor

Sage now delivers messages tailored to your specific version and edition right inside the software.

Sage 100 Contractor receives new messages from the Sage message server when you start the program,
and it continues to receive messages periodically while the program is open.

You can view these messages in the following ways:
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« The Message Carousel. You use the Message Carousel to view all new messages, and messages
that you have not yet dismissed using the [Don't show this message again] button. You use it to
scroll through messages one at a time.

» The Message Center. The Message Center lists all your unexpired messages in a grid, except
messages you discard.

A new [Message] button, located at the bottom left of the program desktop, alerts you when there are new
messages. A number at the top right corner of the button indicates the number of messages you have
received, but not dismissed or discarded.

The Message Carousel

If there are new messages, you click the [Message] button to open the Message Carousel.

The carousel displays new messages one at a time. Each message includes a title, a brief subject, and a
link to detailed message content.

You can decide what to do with each message, as follows:
o Click [Learn More] to display a detailed message on a web page.

» Click [Don’t show this message again] to dismiss the current message from the carousel.

Note: Messages continue to be available in the carousel until you dismiss or discard them, or they
expire.

o Click <or > at the edges of the window to scroll through multiple messages.
The message indicator at the bottom center of the carousel indicates the number of messages in the

carousel and the current one.

The Message Center

The Message Center displays all messages, including messages that you dismissed from the carousel and
messages that you prefer not to be notified about, until they expire or you discard them.

To open the Message Center, click Resources > Sage Messaging > Message Center.

To view a particular message, you click the Subject link. You can remove selected messages from the
system and you can view other properties about messages, such as the type and expiration date.

Notes:

« You cannot manually remove Critical messages, which are typically Support alerts.

» Messages continue to be available in the Message Center until you discard them or they expire.
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Sage Messaging Preferences

Each Sage 100 Contractor user can set their own preferences for notifications about different types of
Sage messages.

To open the Sage Messaging preferences window, click Resources > Sage Messaging > Preferences.

(8 Sage 100 Contractor X
9

Sage Messaging

Pericdically, Sage sends messages to Sage 100 Contractor users that you can read from within
the program. Most messages contain general information (such as newsletters, or special
premaotions from our Learning Services group), but some may contain critical infermation
that requires your immediate attention (like support alerts).

Sage 100 Contractor displays new critical messages automatically when you start the program.
An indicator on the Message button (on the program desktop) alerts you when you receive
new unread messages. You can choose whether to be alerted for all new messages, or for only
certain types of messages.

To be notified when new messages arrive, select the check box:

Message Type Notify Me
*Support Alerts

Newsletters
Promotions
Mew Releases / Product Updates
Renewal / Billing Notices
Other Communications
Customer Participation Requests

*¥ou cannot turn off notifications for support alerts.

Close

All message types are selected by default, but you can clear the check boxes for the message types for
which you do not want notifications. Messages for which you choose not to receive notification do not
appear in the Message Carousel, but they are available in the Message Center until you remove them or
they expire.

Note: You cannot turn off notifications for Support Alerts.

Critical Messages

Messages can be informational or critical. Critical messages differ from informational messages in these
ways:
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o When you start the program, Sage 100 Contractor automatically opens the carousel if there are new
critical messages.

Tip: You can dismiss a critical message, once you have read it, if you do not want the carousel to
open whenever you start the program until the message expires.

¢ You cannot discard critical messages in the Message Center.

If you receive a critical message after you have started Sage 100 Contractor, notification is the same as for
any other type of message. The carousel does not automatically open while you are working in the
program.

Note: You cannot turn off notifications for Support Alerts.

Create Job Templates to Use and Reuse in Takeoff

You can now create and use templates that contain all the data you need to generate takeoffs. Essentially,
takeoff templates are estimates that are not tied to a particular job until you choose to assign a template to
a job. Takeoff templates can save you considerable time, provide consistency, and help to ensure that
estimators do not overlook any aspects or opportunities for a job.

Because takeoff templates are not tied to a particular job or bid items, they provide greater flexibility than
standard takeoffs. For example, you can:

o Set up templates that represent typical job estimates with parts and costs from your database that
you can update, adapt, and assign to different jobs in future.

« Set up alternate cost scenarios using templates and bid items (active and inactive), enabling you to
prepare alternative bids before you assign the template to a job.

The ability to mark bid items active and inactive is what gives takeoff templates their power and versatility.
When you set bid items Inactive in a template, they are not displayed in the takeoff grid or used in
calculations when you assign the template to a job. You can set bid items Active or Inactive at any time,
depending on the job. Before you assign a template to a job, make sure all the bid items you need are
marked Active and those you do not need are marked Inactive. When you assign a template to a job, only
the active bid items are used in the job takeoff and saved to the database.

Important! Values for certain fields in the template must exist in the database before you can assign a
template to a Job. These required fields are Assemblies, Parts, Tax Districts, Vendor, Cost Code, Cost
Type, Task, and Inventory Locations. If any of these fields exist in the template, but have no values in the
database, Sage 100 Contractor will prompt you to resolve these issues before you can assign the
template to a job.

You create and modify takeoff templates as you would a regular takeoff, with the following differences:

Sage 100 Contractor 2019 (SQL) Version 22.1 Release Notes Canadian and U.S. Editions 14



« You use the 9-5 Takeoff Templates window to work with templates. (You use the Takeoff Launch
window to open takeoff templates.)

« Templates do not support attachments, custom fields, row tags, or printing.

« Templates do not support options that would modify the database (for example, you cannot export
purchase orders or budgets).

« Because templates do not write data to the database, there is no record or field history to track.
Therefore, the View menu does not exist for templates.

Tip: You don't always need to create templates from scratch. If an existing takeoff or takeoff template

contains elements that you frequently use in jobs, you can export the takeoff or template to create a new
takeoff template that you can modify as needed.

Assigning takeoff templates to a job

You assign templates to specific jobs using the 9-5 Takeoff Templates window. (After you open the
template, click File > Assign to Job.)

Changes to the Takeoff Launch window

We've added a new Templates tab and placed the existing takeoff information on a new Job Takeoffs tab
in the Takeoff Launch window. These separate tabs help you to distinguish between takeoffs that are
associated with specific clients and bids, and your takeoff templates.

Note: Before you can open the 9-5 Takeoffs window, you must either select an existing takeoff or
template or enter a job number in the Takeoff Launch window .

The new Templates tab

(B Takeoff Launch | Sample Company | V-HG-1\NEWS100C X
File  Help
| Create Shortcut

Job Takeoffs Templates

Mame

Select an existing template: (Show All) X

Mame Last Edit Edited By

Select the bid items to be set as active in the takeoff:

A s

You use the Templates tab to:
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o Create a takeoff template.
« Open an existing template.

« Setbid items active for a selected takeoff template.

To open an existing takeoff template:

1. Open the 9-5 Takeoff Launch window.
2. Select the Templates tab.

3. Double-click the template name on the template grid.

To create a new template:

—

Open the 9-5 Takeoff Launch window.

2. Click the Templates tab.

3. Inthe Name box, type a name for a template.
4. Click [New Template].
5

In the 9-5 Takeoff Templates window that opens, use the grid on the Template Details tab to enter
project information as you would for any takeoff.

B 9-5 Takeoff Templates | Sample Company | V-HG-1\NEWS100C = ] X
File Edit Options Recap Update Export Import  Grid Views  Help
Concrete Foundation Part Cost Default | Default Cost ~ H D k]
Project Values Template Details Recaps Insurance, Tax and Bending  Bid Summary [ TEMPLATE ]
Bid Iltem |0 - None v R Phase |0 - None (A View |All ~
Row Assembly# |, Part# | * Description Alpha Part# -~
2 .9 20463 2x4 Utility Grade Random
2 8 3102| 1x2x12" Forming Stakes
4 1.3 20423 1«6 Utility Grade Random
5 8 20404 1x2 Utility Grade Random
6 LS 3203 Tie Wire
T R 5429 8d Duplex
8 .9 5449/ 16d Duplex
9 K 3305|5-5ack Concrete
10 .9 3350 Concrete Pump Subcontractor
11 8 24260| 2x6 Redwood Con Heart Random
12 .4 5443 16d Galvanized Common
13 8 101 Carpenter
14 S 121| Concrete Labor
15 395 8" x 18" Standup Curb W
< >
Cost Total Owerhead Profit Ext Price Gross Margin
Current Grid 0.00 0.00 0.00 0.00 0.00%
All Grids 0.00 0.00 0.00 0.00 0.00%
Go to Part Go to Assembly Bid Amount: 0.00 [ TEMPLATE ]
Double-click to connect to assembly or previous part

6. Save the template.
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Tip: If you have a takeoff that represents a typical estimate, and you want to reuse it for takeoffs in the
future, you can save it as a template. Simply open the takeoff in the 9-5 Takeoffs window, and then click
Export > As Template.

To assign a template to a job:

1.
2.

Display the template in the 9-5 Takeoff Templates window.
Click File > Assign to Job.

In the Assign Template to Job window, click the down arrow (J: ) to open the job lookup window, and
then double-click the job on the list.

Tip: If the job does not yet exist, click the details button ( 3;') to open the 3-5 Jobs window, where

you can create the job on the fly.

Other Improvements

Version 22.1 also includes the following improvements:

In the 5-2-2 Payroll Records window, you can fix payroll that you posted to the wrong checking
account.

On the Options menu, we have renamed the Change Posted Payroll Period option Modify
Transactions for Posted Payroll. Clicking this option opens a renamed Modify Transactions for
Posted Payroll, which now includes a new Change Checking Account to box where you select the
correct checking account.

Two 5-1-8 Hours reports, 81 - Sick Days Earned and Used and Vacation Hours Earned and Used,
now include column totals for Sick Days Earned and Used.These reports also show subtotals for the
employee the Taken Hours, Hours Worked and Accrued hours.

You can resize the text in Notes windows.

On the Edit menu, click Text Size, and then click Smaller or Larger, as needed. You can also click
Ctrl - or Ctrl + until the text is the size you want. You can shrink the text to font size 6, or enlarge it to
font size 27.

If a nightly backup process fails for some reason, Sage 100 Contractor records that fact in the
Application log under Windows Logs in the Event Viewer.

The error is reported as "Nightly backup process failed for <<company name>>" followed by the
error information, showing the source of "Sage 100 Contractor Nightly Backup". You can filter the log
by Event source, "Sage 100 Contractor SQL Nightly Backup, as well as by event level.
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o Sage 100 Contractor now checks your spelling as you type in the Information Requested and
Information Supplied text boxes in the 6-11-2 Requests for Information window, and in the Message
text box in the 6-11-8 Correspondence window.

You turn on the spell checker in the Field Properties windows for the text boxes. Click in the text box,
press F7, and then select the Check Spelling option. Click [Save]. You must also close and then
reopen the 6-11-22 Requests for Information window or the 6-11-8 Correspondence window for the
change to take effect.

o To provide some flexibility in the layout of the 3-4-24 Combined Statements report (for example, to
prevent overlap when descriptions are long), we have added three new report options that you can
use to show or hide columns:

o Show All Columns
« Hide Paid/Credit Column
« Hide Job/Work Order Column

o We have updated Sample Company dates to the year 2019.

Enhancements for the U.S. Edition

Easily Report on Use Taxes

In the U.S. Edition, we have improved the tracking and reporting of use taxes. (These are taxes that you
must remit in some states when you purchase items or services on which no tax was collected by the
seller—for example, a tax on out-of-state purchases.)

Previously, to record use tax in the 4-2 Payable Invoice/Credits and the 4-7-3 Credit Card Receipts
windows, you had to complete the invoice grid entry, and then click the [Calculate Use Tax] button, which

added two lines to the AP invoice grid for use tax payable and use tax expense. There was no easy way to

report on use taxes due on the payable invoices.

Now, you set up separate use tax posting accounts in the 1-8 General Ledger Setup window. Instead of
carrying the use tax posting detail on the invoice grid lines, the ledger transaction for the payable invoice

contains the posting detail for the use tax, while the payable invoice includes the total amount of use tax as

well as the tax district it applies to.

Setting up use taxes

You use the 1-8 General Ledger Setup window to identify the posting accounts for use tax payable and the

associated WIP, direct, equipment, and overhead expenses.
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Note: You cannot specify an account that has subaccounts or departments for any use tax expense
accounts.

Setting up a warning in vendor records

If you want to warn users when they should include use tax on an invoice, or compel them to do so, set the
'Use Tax' Warning option to 1 - Warn if no Use Tax or 2 - Require Use Tax on the Invoice Defaults tab in the
4-4 Vendors record. (You can also accept the default 0-None entry if you do not want to warn users when a
use tax is applicable.)

During the upgrade to version 22.1, if an amount exists in the old ‘Use Tax’ Rate field, the warning is set to
1-Warn if No Use Tax.

Entering use taxes on payable invoices

The 4-2 Payable Invoices/Credits and 4-7-3 Enter Credit Card Receipts windows provide new ‘Use Tax’
District and Use Tax amount boxes for tracking use taxes payable.

In the ‘Use Tax’ District box, you select the sales tax district to which you owe the use taxes. When you
specify a use tax district for payable invoices and credit card receipts, use taxes are posted to the new WIP
expense, direct expense, and equipment expense accounts for that district proportionately, with any
residual amount posted to the Use Tax Overhead account.

When you specify a ‘Use Tax’ District and then either save an entry or select the Use Tax box, Sage 100
Contractor automatically calculates the tax amount and displays it in the Use Tax box. You can change this
amount.

Use tax calculations are not applied to sales taxes, if sales tax exists on the invoice. For cases where an
invoice also includes sales tax, you should set up a use tax district to apply only the difference in the rate
between the sales tax and the use tax.

Reporting use taxes

We have added a 4-1-7 Use Tax Report menu, from which you can print the new, customizable 4-1-7-21
Use Tax report that prints by ‘Use Tax’ District. You can filter the report by ranges of invoice dates,
vendors, and statuses.

Enhancements for the Canadian Edition

New Payroll Type for Retiring Allowances

In the 5-2-2 Payroll Records window, we have added a new payroll type that you can assign for severance
pay or retiring allowances.
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When you assign the new payroll type 7- Retiring Allowance:

« CPP and Employment Insurance are not deducted from the payment.
« The payment amount is reported in Box 66 - Eligible retiring allowances on T4s.

« Federal and provincial income tax are computed as lump-sum payments, as for bonuses.

We have updated the 5-3-7 Payroll Audit accordingly.

Do You Have a Product Idea You Want to Share with Us?

We want to hear it!

To suggest a product enhancement when you're working with Sage 100 Contractor:

On the Sage 100 Contractor desktop, click the Home & Resources tab > Submit Product Idea.

1.

2. Logintothe Sage 100 Contractor Ideas site (or sign up).

3. Describe your idea.

4. (optional) Browse through others' suggestions, and vote for the ones you love!

Or visit https://www5.v1ideas.com/TheSageGroupplc/Sage100Contractor any time you're online!

Delete this text and replace it with your own content.
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Fixes in Version 22.1

Fixes in both editions

Version 22.1 includes the following software fixes in both the U.S. and Canadian editions:

+ We have improved spell checking while you type in Notes windows. The program no longer slows
down after finding several spelling errors while you type. Also:

« The Spell Check on Save and Spell Check While Typing menu settings are saved by user,
rather than globally.

« We have removed the Spell Check menu item from the Edit menu because itis no longer
required.

« The Spell Check button on the toolbar now turns the Spell Check While Typing option on and
off.

o The Spell Check on Save option prevents you from saving if spelling errors exist when you
first save a note.

If you continue to try to save the note, you can choose whether to save it with spelling errors.

« When you export 5-2-8 Timecard Journal long reports (numbered 52, 61, 62, 71, and 72) to Excel,
the correct hours and rates are exported. We have also:

« Fixed the alignment in the report so that the rate and hours appear correctly.

« Moved the number of pieces in the summary section from the Hours column to a new Pieces
column.

« Inthe 11-2 Work Orders/Invoices/Credits window, setting the Lock After Save property of the Client
and Tax District fields ensures that users cannot change these fields in service quotes and work
orders.

e When you open a posted Payroll transaction from the Job or Equipment Cost window, and then
save changes in the 1-3 Journal Transactions window, Sage 100 Contractor voids the original
transaction and creates a new transaction with the correct employee and dates.

» When you search for records using the Job Costs Payroll Costs by Job query in the 6-3 Job Costs
window, the results no longer include void records.
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The 5-1-8-81 Sick Days Earned and Used and 5-1-8-86 Vacation Hours Earned and Used reports
no longer include payroll records that been reversed or voided.

In the grid in the 9-3 Assemblies window, double-clicking on the border between column headers no
longer changes the connection arrow in the first row.

In the 3-6 Receivable Clients window, we have improved the performance of the Client Locations
grid when you save a location, especially if you have a large number of client locations.

Multiple (duplicate) statements are no longer emailed to a client, which used to occur in some
situations.

Combined AR/SR Invoice Aging reports aged by Invoice date now report invoice dates in an Invoice
Date column.

You can now turn off Exclusive Access without having to switch companies first, even if you are
using a SQL login.

In the 9-5 Takeoffs window, the program displays overhead and profit rates properly when you
insert assemblies using Multi-Select Mode in the lookup window.

ixes for the Canadian Edition

The following issues were fixed specifically for the Canadian edition:

Receivable holdbacks are now reported in the Cash Position section of the dashboard.

In the 3-2 Receivable Credits/Invoices and the 4-2 Payable Credits/Invoices windows, when you bill
a job that has more than 20 invoices with a holdback, the holdback invoice amounts are correct.

ROEs printed for employees paid semi-monthly now accumulate amounts correctly by week.
Previously, in some circumstances, amounts did not print in each box, with amounts for two weeks
aggregated in one box, leaving one box blank.

When you specify Find queries using a range of dates that spans more than one month, the
program now properly returns all results that meet the date criteria. (Previously, if you used the date
format dd/mm/yyyy to specify a range of dates and the start day for the range was greater than the
end day, the query returned only results for the start date. For example, if the start date was
15/03/2019 and the end date was 14/04/2019, only records that used the date 15/03/2019 were
included.)
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Fixes for the U.S. Edition

The following issues were fixed specifically for the U.S. Edition of Sage 100 Contractor:

¢ You can now save calculations in the 5-3-1 Payroll Calculations window with Tax Type 0-None and
Calculation Method 2 - % Total Taxable Wages. You can also change any existing Tax Type 0 -
None calculations to Calculation Method 2 - % Total Taxable Wages, as necessary.

o The 5-1-11 California Certified Payroll report now reports fringe benefits as hourly rates, not as total
amounts.

However, if you want to continue to report fringe benefits as total amounts earned on a job, create a
blank file in the Sage100Contractor Global Settings folder
(C:\Users\Public\Documents\GlobalSettings\Sage 100Contractor) with the file name
ReportCaliforniaCertifiedPayrollFringeBenefitsAsTotalAmounts—with no file extension. This
existence of this file triggers the program to report the fringe benefits as total amounts on the
California Certified Payroll report, as before.

Note: This file affects only the California A-1-131 report.
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API for third-party developer products

This release provides the following fixes for and enhancements to the API:

» We have added a new Partner Data subfolder to \Sage100Con\Common for storing third-party
application files. We intend to keep this accessible location intact during future Sage 100 Contractor
development. Database Administration creates this folder, with the same security permissions as
the \Common folder, if it does not exist when you connect to the server.

When saving files to this folder, use the DBX_ extension to ensure that the files are easily identified
and kept in a defined structure.

Note: This folder is not included in the backup maintenance routines.

For more information, see the README.RTF file in this folder.

+ We have fixed the formatting of the error message that is displayed when a user tries to log into a
program that is not approved in Advanced SQL Server Settings in Database Administration.

o Using the API's SubcontractModRequest function does not clear change amounts and now
correctly calculates the New Subcontract and Remaining amounts and the totals for the subcontract
when change orders reference subcontractor lines.

Also, the Subcontract Over Budget report now correctly includes change amounts.
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Upgrading from Sage 100 Contractor
earlier than v217?

New Entitlement Server

For version 21, Sage moved its Entitlement server (used to allocate license uses based on the license you
have purchased) to a new, more secure server.

After installing this version of Sage 100 Contractor, you will need to open the License Manager and enter
your Sage Client ID and Registration Name even if you have been using an earlier version of Sage 100
Contractor.

Important! You must enter your Client ID and Registration Name exactly as they appear for your account
in the Customer Portal.

Tip: Before you install version 21, open License Administration, copy the Sage client ID and Registration
name from the License information tab, and then paste them into a text document. After installing
version 21, copy the Sage client ID and Registration name from the text document into the version 21
License Administration window.
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Summary of enhancements in earlier
versions of Sage 100 Contractor (SQL)

Earlier versions of Sage 100 Contractor (SQL) provided a wide variety of new features, including many
enhancements that our customers have requested.

The following table is a list of the most significant features introduced in earlier versions, details of which
you can read about in the Release Notes for the respective version.

U.S. Canada

Enhancements by version Only Only

Version 21.3 enhancements
(For details, see the v21.3 Release Notes)

Some minor enhancements plus U.S. tax updates.

Version 21.2 enhancements
(For details, see the v21.2 Release Notes)

Ability to merge client records

Ability to merge vendor records

Ability to include a record's attachments when you email forms

Ability to email statements to jobs and clients

Ability to record external vendor payments

Ability to specify a secondary backup location

Ability to track vendor certificates by job

More ways to list vendor invoices to pay

Version 21.1 enhancements
(For details, see the v21.1 Release Notes)

Bank feeds
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Canada

Enhancements by version 011\%

Ability to email direct deposit stubs at a later date

Enhanced cost type validation

Enhanced Search (Find) in the 9-5 Jobs window

Ability to move company to a new drive

Ability to view an employee's pay raise history

Ability to create timecards for individuals in Daily Payroll

Ability to create payroll records for salaried employees

Ability to restrict exclusive access for specific non-administrative users

Version 20.7 enhancements
(For details, see the v20.7 Release Notes)

Ability to print a new 5-1-8-86 Vacation Hours Earned and Used X
Report

Version 20.6 enhancements
(For details, see the v20.6 Release Notes)

New Server Management Tools

Ability to set records "Inactive"

More efficient login

Ability to replace Cost Codes, Vendors, Tasks, or Inventory Locations
in a takeoff

New Combined Accounts Receivable and Service Receivables aging
reports

Ability to print Accounts Receivable Aging Reports by Invoice Date

Ability to print Accounts Payable Aging Reports by Invoice Date

Ability to print Service Invoice Aging Reports by Invoice Date

New banking categories you can assign to bank-related journal
transactions
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uU.s. Canada

Enhancements by version Only Only

Improved vacation tracking X

Version 20.5 enhancements
(For details, see the v20.5 Release Notes)

Ability to use new custom fields in most windows

Ability to tag rows for followup in the 9 -5 Takeoffs grid

Audit Information is available in Advanced Company Settings

Numeric fields provide automatic calculation

Easier access to user subfolders in workgroups

Ability to correct the period of a posted payroll transaction

Ability to skip automatic calculation during takeoff

Ability to filter cost codes by Job and Phase in lookup windows

Ability to filter unassigned work orders on the Dispatch Board

A new option for saving and selecting company-specific custom
reports and forms

Ability to use a new standard calendar to select dates

Support for Microsoft SQL Server 2016 and Windows 2016 Server

Ability to copy user process maps

Ability to use high contrast display settings for Windows 10

Ability to print a new Payroll Check Register 5 -1 -2 -31 by check date

3 -7 Progress Billing and 12 -2 Inventory Allocation allow 5,000 rows

Tax and Workers' Comp rates in4 4 and 4 -2 use 4 decimal places X

Workers' Comp Reports 21, 86, and 96 show Overtime Hours X

Version 20.4 enhancements
(For details, see the v20.4 Release Notes)

Ability to copy external files to other users
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Canada

Enhancements by version 011\%

New option to approve the removal of employee records

Version 20.3 enhancements
(For details, see the v20.3 Release Notes)

Ability to view change history in records

New option for closing purchase orders automatically

Support for Paya Exchange Desktop 2.0

Support for customized tables and views

Ability to use a new window to add client service locations quickly

Effective rate shown for Sales Tax Districts (U.S. only) X

API supports adding and removing attachments X
APl enforces locks X
Schema change for Global Variables X

Version 20.2 enhancements
(For details, see the v20.2 Release Notes)

Simplified schedules lookup

QueryJobCost (APl Enhancement) X

SetExclusive (APl Enhancement) X

Version 20.1 enhancements
(For details, see the v20.1 Release Notes)

More versatile lookup windows

Unique Payroll record numbers
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Known issues and comments

The following sections describe known issues and problems in Sage 100 Contractor Version 22.1.

General

Compliance and Payroll Checks

Important! The sample check forms that come with Sage 100 Contractor may not be fully compliant with
all federal, state, and local laws, and other requirements that can differ from one jurisdiction to another. It
is your responsibility to familiarize yourself with all applicable laws and requirements, and to modify
check forms as needed to ensure compliance. For information about customizing check forms, see 13-5
Form/Report Page Design in the Sage 100 Contractor help, or contact your Sage business partner for
assistance.

Internet access required for Sage 100 Contractor

Sage 100 Contractor features, such as printing or efiling tax forms, submitting enhancement requests,
accessing Help, or downloading periodic product or tax updates all require Internet access.

To take advantage of these features, ensure that any workstation or server that Sage 100 Contractor is
installed on has access to the Internet.

During installation of Sage 100 Contractor, the computer serving as the Sage license server must be able
to connect to the Internet to obtain licenses. Once installation is complete, you can check out license uses
for each computer where Sage 100 Contractor is installed, then disconnect the Sage license server from
the Internet.

Note: A static Internet connection using a compatible web browser is required for Sage Construction
Anywhere. For current information on supported browsers, supported Sage 100 Contractor versions,
and other system requirements, see the Sage Construction Anywhere help at
http://help.sageconstructionanywhere.com/sage 100contractor/help/Default.htm#01_Setup/System_

requirements.htm.
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Configuring anti-virus software and third-party firewalls

During installation of the Sage 100 Contractor Hosting Framework, the Windows Firewall is configured
automatically to allow the Sage 100 Contractor Hosting Framework to act as a TCP server. If you use some

other firewall, however, you may need to manually adjust some settings in the firewall in order to ensure

proper operation.

You can use the following basic procedure to manually configure the Windows Firewall to allow the Sage

100 Contractor Hosting Framework to communicate with other computers. Use it as the basis for manually
configuring other third-party firewall products.

To configure the Windows Firewall:

1.

2.
3.

For Windows Server 2008, click Start > Control Panel > Security.

For Windows 7, click Start > Control Panel > System and Security.

For Windows 8.1 and Windows 10, click Start > All apps > Control Panel > System and Security.
Open Windows Firewall, and then select Allow a program or feature through Windows Firewall.

Select Sage 100 Contractor Hosting Framework on the list, if it is not selected..

Note: By default, the exception is set to allow access by any computer on the network. You can refine
this setting by selecting the Change Scope button. Be aware that restricting the scope incorrectly can
cause the computer to be unable to connect with some or all of the other machines on the network.

Files to exclude when manually configuring your firewall for Windows 8.1 Professional 32-bit

C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files\Sage\Sage 100 Contractor
C:\ProgramData\Aatrix Software

C:\Program Files\Aatrix Software
C:\%LocalAppData%\Sage\Sage 100 Contractor

Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 8.1 Professional 64-bit

C:\ProgramData\Sage\Sage 100 Contractor
C:\Program Files (x86)\Sage\Sage 100 Contractor
C:\Program Files (x86)\Aatrix Software
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o C:\ProgramData\Aatrix Software
o C:\%LocalAppData%\Sage\Sage 100 Contractor

« Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 7 Professional 32-bit

o C:\ProgramData\Sage\Sage 100 Contractor

o C:\Program Files\Sage\Sage 100 Contractor

« C:\ProgramData\Aatrix Software

o C:\Program Files\Aatrix Software

o C:\%LocalAppData%\Sage\Sage 100 Contractor

« Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 7 Professional 64-bit

« C:\ProgramData\Sage\Sage 100 Contractor

o C:\Program Files (x86)\Sage\Sage 100 Contractor
o C:\Program Files (x86)\Aatrix Software

o C:\ProgramData\Aatrix Software

o C:\%LocalAppData%\Sage\Sage 100 Contractor

« Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 8.1 Professional
« C:\ProgramData\Sage\Sage 100 Contractor
o C:\Program Files (x86)\Sage\Sage 100 Contractor
o C:\Program Files (x86)\Aatrix Software
« C:\ProgramData\Aatrix Software
o C:\%LocalAppData%\Sage\Sage 100 Contractor

« Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows Server 2008 R2, 2011, 2012

« C:\ProgramData\Sage\Sage 100 Contractor
o C:\ProgramFiles (x86)\Sage\Sage 100 Contractor
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o C:\Program Files (x86)\Aatrix Software
o C:\ProgramData\Aatrix Software
o C:\%LocalAppData%\Sage\Sage 100 Contractor

« Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Software and hardware required to support Microsoft SQL Server

Version 22.1 requires an instance of Microsoft SQL Server. You can download and use Microsoft SQL
Express at no charge, or you can use the full version of Microsoft SQL Server. You can even start using
Microsoft SQL Express, and upgrade to the full version of Microsoft SQL Server later, if necessary.

When you first open the new Database Administration tool, the program tries to configure an instance of
Microsoft SQL Server with optimal settings for Sage 100 Contractor for you. If you do not already have an
instance of Microsoft SQL Server, you can let the Database Administration tool download, install, and
configure Microsoft SQL Express for you.

Refer to Knowledgebase article 98460 for detailed information about supported operating systems and

software, and for minimum hardware requirements.

Installation of Microsoft SQL Server on a domain controller is not recommended

Microsoft recommends against installing SQL Server on a domain controller, and does not support SQL
Server on a read-only domain controller should you encounter any problems with this configuration.

Because you must install Database Administration on the same machine as SQL Server, you should not
install Database Administration on a domain controller. To guard against inadvertent installation on a
domain controller and the potential for irrecoverable data losses, you will receive a warning if you attempt
to install Database Administration on a machine used as a domain controller .

For more information, see the Microsoft Knowledgebase article https://support.microsoft.com/en-
us/kb/2032911.
About .NET Framework

.NET 4.6.1 Framework is required

If Microsoft .NET 4.6.1 Framework is not already installed, it will be installed automatically when you install
Sage 100 Contractor. Installation of .NET 4.6.1 Framework alone may take up to 20 minutes per computer.

Make sure that both your client and server computers meet the minimum requirements for installing both
Sage 100 Contractor software and .NET 4.6.1 Framework.
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Note: If Sage 100 Contractor requires an installation of .NET 4.6.1 Framework, the Sage 100 Contractor
installation process may continue automatically after the .NET Framework installation is completed. If
you are prompted to restart your computer after the .NET Framework installation, you must do so to
continue the Sage 100 Contractor installation.

NET 3.5 is also required

In some situations, you may need to turn on .NET 3.5 manually by selecting the .NET 3.5 check box in the
Windows Features dialog box. For more information, see Knowledgebase article ID 68381, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalld=68381.

Windows Small Business Server 2011 is not supported

Microsoft Small Business Server 2011 does not support .NET Framework 4.6.7, which Sage 100
Contractor (SQL) requires. Unfortunately, this means that Sage 100 Contractor (SQL) cannot support
Small Business Server 2011.

Turning on Microsoft NET 3.5

Microsoft .NET 3.5 must be available and enabled prior to installing Sage 100 Contractor on a Windows
Server 2008 R2 machine. Server 2008 R2 comes with .NET 3.5 loaded but not installed, so Sage 100
Contractor does not install it automatically.

If you attempt to install Sage 100 Contractor without .NET 3.5 installed, you receive the following message
during the licensing install: “Sage.CRE.HostingFramework.Service v3.2 has stopped working.” When you
click [OK], the installation continues, but the services have not been installed so Sage 100 Contractor
cannot open. The Sage.CRE.HostingFramework Service will not install unless .NET 3.5 has been installed.
If you receive the above message during installation, install .NET Framework 3.5., and then reinstall Sage
100 Contractor.

The following instructions are for Windows Server 2008 R2.

To verify that .NET 3.5 is installed on Windows Server 2008 R2:

1. Click the Start button in the lower left corner of the display.
2. Highlight Administrative Tools and select Server Manager.

3. Inthe Server Manager interface, click Features to display all the installed Features in the right-hand
pane. Verify that NET Framework 3.5.1 is listed.

To enable .NET 3.5 on Windows Server 2008 R2:

1. Inthe Server Manager interface, select Add Features to display a list of possible features.

2. Inthe Select Features interface, expand .NET Framework 3.5.1 Features.
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3. Once you expand .NET Framework 3.5.1 Features, you will see two check boxes. Check the box
nextto .NET Framework 3.5.1 and click Next.

4. Inthe Confirm Installation Selections interface, review the selections and then click [Install].

5. Allow the installation process to complete and then click [Close].

Note: Enabling .NET Framework 3.5.1 may require a reboot.

About network configuration and TCP Remoting Channel

Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component, to
enable communication among computers on a network. By default, Sage 100 Contractor uses the
TCP starting port 48760. Certain configurations can potentially disable the communication:

« You must enable file sharing on your computers. To enable file sharing, follow the instructions in the
Windows Help.

« TCP communication requires the selection of port numbers that are not in use by other processes
on the local computer.

« Software firewalls running on the local computer can be configured to block processes from opening
TCP ports, which will prevent communication through the TCP Remoting Channel.

Sage Advisor Update

Important! Sage Advisor Update is not available until further notice.

You can download Version 22.1 from the Knowledgebase using the link provided in the Software Notice
that announced the product download.

PCI DSS Compliance

PCI DSS stands for Payment Card Industry Data Security Standard. It was developed by the major credit
card companies as a guideline to help organizations that process card payments to prevent credit card
fraud, cracking, and other security weaknesses and threats.

A company processing, storing, or transmitting payment card data must be PCl-compliant or risk losing its
ability to process credit card payments and being audited and/or fined. (For more information about PCI
standards, see https://www.pcisecuritystandards.org/.)

Sage 100 Contractor payment processing works exclusively with Paya to enable merchants to seamlessly
process check and credit card transactions directly in Sage 100 Contractor. The payment processing
program uses Paya Exchange, a secure payment-processing application, to connect to Paya and process
check and credit card transactions.
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Integrating your financial and operations system with Paya lets you process check and credit card
transactions without storing your customers’ sensitive card information in your database. Paya Exchange
transmits check and credit card details through a secure connection to Paya, where they are stored in a
PCl-compliant vault, protecting your from exposure to non-compliance penalties and credit card fraud.

Caution! To avoid non-compliance with PCI standards, do not store credit card information in Sage 100
Contractor. Such storage creates unnecessary risk for your business and your customers.

Using Sage 100 Contractor Intelligence Reporting with Sage 100 Contractor 2019

Sage 100 Contractor Intelligence Reporting versions 20.2 and 19.7 are not designed to work side-by-side.

If you used Sage Intelligence Reporting with Sage 100 Contractor version 19.8 or earlier, follow the steps
in Knowledgebase article 75640 when upgrading to version 22.1.

Tax Forms and eFiling by Aatrix configuration requirements

Tax Forms and eFiling by Aatrix requires an Internet connection for two reasons:

« Forupdating forms and executable files.

« For electronicfiling (eFiling) of the forms.

If you experience an Internet connection problem, it may be due to problems communicating through an
Internet firewall. Firewalls need to have access allowed through specific ports:

o The Tax Forms and eFiling Updater uses standard SSL/HTTP port 80 to access the site
http://updates.aatrix.com.

« The eFiling component uses secure HTTPS on port 443 to access the site https://efile.aatrix.com.

By allowing access to aatrix.com, you allow both updates and eFiling. Occasionally, restrictions are tighter
and only allow access to these ports by specific programs. Tax Forms and eFiling uses the following
programs to access the Internet.

For updating using http on port 80 to http://updates.aatrix.com:

» aatrixforms.exe
e updater.exe

o updater2.exe
For eFiling using secure http on port 443 to https://efile.aatrix.com:

« builder.exe

e Vviewer.exe
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Use Adobe Reader Version 8.1.3 or later for faxing

Customers have reported problems faxing from Sage 100 Contractor with versions of Adobe Reader

earlier than 8.1.3. Adobe Reader Version 8.1.3 and later support faxing from Windows and from Sage 100

Contractor.

Important! To fax from Sage 100 Contractor, the Windows Fax Service component must be installed
with your Windows operating system. For more information about installing the Windows Fax Service
component, see the Sage 100 Contractor Help topic, “Installing the Windows Fax Service component.”

Sage licensing (Sage 100 Contractor Hosting Framework) cannot auto-start on
Windows 8.1, Windows 7 Professional, Server 2008, or Server 2008 R2 Standard

The Sage licensing service (Sage 100 Contractor Hosting Framework) cannot auto-start on computers
running the Windows 8.1, Windows 7 Professional, Server 2008, or Server 2008 R2 Standard operating
systems. If the service stops, the program displays a message advising you to take further action to
resolve this issue.

Configuring Windows Regional and Short Date Format

To specify regional formats for Windows:

1. Click the [Start] button, point to Control Panel, then click Clock, Language, and Region .
2. Click Region and Language.

3. Onthe Formats tab, select the format for your country.

4

. Under Date and time formats, from the Short date format drop-down list, select the format used for
your country.

Click [OK].

o

6. Close the Clock, Language, and Region window.

Windows "Sleep Mode" prevents computers from obtaining a license use

If the computer you are using as a license server goes into sleep mode, other computers on the network
cannot obtain a license.

To avoid this possibility, set Sleep Mode on your license server computer to Never.
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To set the Sleep Mode to “Never”:

1. In Windows 8.1 Professional, Windows 10, or Server 2012 Standard, click Start > All apps > Control
Panel > System and Security > Power Options.

In Windows 7, click Start > Control Panel > System and Security > Power Options

2. Select Change when computer sleeps.

3. From the Put computer to sleep list, select Never.

Windows 8.1 Professional and Server 2012 Standard Operating

Systems

Sage licensing (Sage 100 Contractor Hosting Framework) cannot auto-start on
Windows 8.1

The Sage licensing service (Sage 100 Contractor Hosting Framework) cannot auto-start on computers
running the Windows 8.1 Professional or Windows 8.1 Enterprise operating systems. If the service stops,
the program displays a message advising you to take further action to resolve this issue.

Server 2012 network configuration and TCP Remoting Channel

Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component to enab

le

communication among computers on a network. File and printer sharing on computers running the Server

2012 operating system must be enabled. To enable file sharing, follow the instructions in the Windows
Server 2012 Help.

Windows 7 Professional and Server 2008 R2 Standard
Operating Systems

Launching Sage 100 Contractor to run as administrator for scheduling reports

Important! On computers running Windows 7 Professional or Server 2008 R2 Standard, scheduling
Sage 100 Contractor reports requires that you “run as administrator” or to “run the program as
administrator.”

Microsoft Windows changed security rules in the Windows 7 Professional and Server 2008 R2 Standard
operating systems to make your computer more secure. If you are running Sage 100 Contractoras a
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typical user, then you have limited privileges in some areas of the program, such as saving a report
schedule. To save a report schedule, you must launch Sage 100 Contractor with the command to either
Run as administrator or Run this program as an administrator.

When you select either command, the settings are limited to you personally. Your settings to run Sage 100
Contractor as administrator do not affect the next person who logs on and launches Sage 100 Contractor
from this computer. Your settings on this computer can either be temporary or persistent. For example,
when you select Run as administrator, you run the program as administrator for that session only. When
you select Run this program as an administrator, you set program properties to always run the program as
administrator when you log on to this computer.

Note: "Run as administrator" and "Run this program as an administrator" are not related to Windows 7
Professional or Server 2008 R2 Standard operating systems user groups but are limited to a specific
program you are running.

To set "Run as administrator":

1. On your Windows desktop, right-click the Sage 100 Contractor program icon.

2. From the drop-down menu, to launch the program, click Run as administrator.

Note: Selecting Run as administrator only runs the current session of running Sage 100 Contractor. The
setting does not persist after the session is over.

To set "Run this program as an administrator":

1. On your Windows desktop, right-click the Sage 100 Contractor program icon.
2. From the drop-down menu, click Properties.

3. Onthe Sage 100 Contractor Properties window, click the Compatibility tab.
4. Under Privileges Level, select Run this program as an administrator.
5

. Click [Apply], and then click [OK].

Note: Selecting Run this program as an administrator always runs the program with these properties
when you launch the program on this computer. The setting persists.

Solution for Windows Server 2008 R2 "Permission Error Opening File"

If you see a permission error message when launching Sage 100 Contractor on a computer running the
Windows Server 2008 R2 operating system, follow these instructions:
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1. On the Window desktop, right-click Start, and then click Open Windows Explorer.

2. Onthe left side of the window, under Computer > Local Disk, right-click the \Sage100Con folder, and
then select Properties.

3. Onthe Sage100Con Properties window, click the Security tab.

4. From the list under Group or User Names, select USERS, and then click the Edit button.

5. On the Permissions window, select USERS again, and under Allow, select the Full control check
box.

Selecting Full control selects all the check boxes necessary for this solution.

6. On the Permissions window, click [OK].

7. Onthe Sage100Con Properties window, click [OK].

Solution for Windows 2008 Server R2 Application Error Message

Under some circumstances, on servers operating Windows 2008 Server R2, you may see the following
error message when trying to open a photograph or image file in Sage 100 Contractor:

"No application is associated with the specific file associated with this application."

This error message appears when you attempt to open an image file in Sage 100 Contractor but you have

not yet enabled the Desktop Experience feature in Windows 2008 Server R2. If you receive this error
message, install Desktop Experience using the Server Manager utility:

1. In Windows 2008 Server R2, select Start > All Programs > Administrative Tools > Server Manager.
In the Server Manager window, click Features (left-hand pane).

In the Features pane, click Add Features.

Select the Desktop Experience check box.

If you are prompted to add additional features, click [Add Required Features].

Click [Next].

Click [Install].
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