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Update 1 — October 2021 (Build 23.2.125)
Fixes in this Update (U.S. and Canada Editions)
l

We modified the nightly maintenance and backup process. If another backup system is running at the same
time as Sage nightly maintenance or some other process prevents Sage 100 Contractor from accessing the
database, nightly maintenance cannot perform an integrity check. Previously, this condition triggered a
warning telling you that you should restore your company from a backup because of a severe error.
Now, if nightly maintenance cannot perform a data integrity check, you receive a gentler warning pointing you
to KB article “Causes of SQL Server database inaccessibility.”

l

Keyboard shortcuts are working properly again in the 11-2 Work Orders/Invoices/Credits window.

Enhancement in this Update
In Database Administration, there is a new Check the logical and physical integrity of the database option in the
Company Tools toolbox. For more information about this option, see the Database Administration help.
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Compatibility with Sage Estimating
Important! Sage 100 Contractor version 23.2 is not compatible with Sage Estimating version 20.1 and
earlier versions. If you integrate Sage 100 Contractor with Sage Estimating, do not install Sage 100
Contractor version 23.2 until you install Sage Estimating version 21.1.
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U.S. Payroll Tax Tables—October 2021
Payroll tax tables have changed for the following jurisdictions:
l

Ohio
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Enhancements in Version 23.2
This section describes the new features and enhancements you will find in version 23.2.

We've been listening to you!
Sage thanks you for your product ideas! In version 23.2, we have incorporated the following top-ranked
suggestions from the Sage Ideas site. Later sections in the Release Notes describe changes that require more
detailed explanation.
l

General Ledger
l

In the 1-8 General Ledger Setup window, there is a new Set posting period from transaction date option that
you can select if you want to use the transaction date to set the default posting period for transactions.
Thank you for this suggestion, Jefferey C. and Kathy D.

l

In the 1-3 Journal Transactions window, when you void an Accounts Payable payment from a previous
period, you can choose to:
l

l

Void the payment, which affects the original posting period.
Reverse the payment in the current period, keeping intact your financial data from earlier periods, which
you may have already reconciled and closed.

Thank you for this suggestion, Judy S.
l

You use the new 1-10 Deposit Slips window to print a detailed list of the cash and checks that make up a
deposit, so that you can take this list to the bank when you make a physical deposit.
Note: For more information, see Printing Deposit Slips, later in this document.
Thank you for this suggestion, Rhiannon T.

l

Accounts Receivable
l

You can edit line descriptions on receivable invoices.
Thank you for this suggestion, Sandy R.

l

Accounts Payable
l

In the 4-2 Payable Invoices/Credits window, when you enter a duplicate invoice for a vendor for which you
do not allow duplicate invoices, Sage 100 Contractor now warns you as soon as you enter both the vendor
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number and a duplicate invoice number.
Thank you for this suggestion, Mark B., Becki W., and Trinity P.
l

In the 4-4 Vendors window, you can assign a preferred payment method to a vendor. Sage 100 Contractor
displays the payment method in the 4-3-2 Pay Vendors window and uses it to verify the selected payment
method.
Thank you for this suggestion, Jenna Y.

l

Credit card accounts and subaccounts that you set Inactive in the 1-7 General Ledger Accounts window are
not available to select in the 4-7-1 Add/Edit Issuer Accounts window or the 4-7-2 Add/Edit Credit Cards
window.
Thank you for this suggestion, Rhiannon T.

l

Payroll
l

In the 5-2-1 Employees window, you can view a complete hire history (including multiple Date Hired and
Date Inactive dates) for employees who are periodically laid off and then rehired.
You click a new [Hire History] button (beside the existing [Raise History] button) to view the hire history for
an employee in an Employee Hire History window.
Thank you for this suggestion, Monika S.

l

You can add a custom message to email messages you send for direct deposits.
When you select a direct deposit report in the 5-2-4 Report Printing window, select the Direct deposit email
settings option from the Options menu. Then, in the Direct Deposit Email Settings window that appears,
enter a message with any information you want—for example, advice about opening the attachment, alerts
about changes to benefit plans, and so on.
Thank you for this suggestion, Mary B.
Note: For more details about these changes, see "Custom Email Messages for Direct Deposits"
(page 9), later in this document.

l

You can change the job for timecard lines in computed payroll. Use the new Change Job for Computed
Payroll option that we've added to the Options menu in the 5-2-2 Payroll Records window.
Thank you for this suggestion, Cindy M.
For more details about this feature, see "Changing Jobs on Computed Payroll Records" (page 10), later in
this document.

l

Utilities
l

You can assign a specific logo for your company in the 7-1 Company Information window. The logo then
appears automatically on reports for the company.
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Click the arrow beside the Report Forms Logo box, and then in the Assign Picture dialog box, enter the path
to the file that stores your company's logo.
Note: You don’t need to select an image that already exists on the server. When you select a logo,
Sage 100 Contractor copies the file to the company data folder so the image is available to all users.
Thank you for this suggestion, Tim L.
l

Estimating

In the 9-5 Takeoffs window:
l

You can customize and save the column widths in the Recaps grid, so you don't have to readjust the
columns whenever you return to the Recaps tab.
Thank you for this suggestion, Michael R.

l

You can select a new Lock Edit check box when you want to prevent unauthorized users from editing or
deleting the details of a takeoff, while preserving the ability to view and export the takeoff.
Thank you for this suggestion, Chris H.

l

l

On the Options menu, you can select a new Do Not Calculate Assembly Cost option. This option enables
you to save takeoffs that have assemblies with a negative cost.

Project Management
l

In the 6-11-1 Requests for Proposal window, you can use a new [Create Subcontract] button to create a new
subcontract using the information from a selected RFP. When you click the button, Sage 100 Contractor
displays the 6-7-1 Subcontracts window using the information from the RFP as defaults.
Thank you for this suggestion, Chris B.

l

Review and Reporting
l

You can add shortcuts to the Sage 100 Contractor desktop for any queries you create.
From the Query List window in any module, select a query, click the [Create Shortcut] button, and then click
the tab where you want to place the shortcut.
Thank you for this suggestion, Jen B.

l

Service Receivables
l

You can create a client alert in a client record. Sage 100 Contractor then displays the alert whenever you
enter the client on a work order in the 11-2 Work Orders/Invoices/Credits window.
To enter a client alert, click the Enter client alert icon (
record.

) on the toolbar in the 3-6 Receivable Clients

Thank you for this suggestion, Brenda H.
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Help Provides More Tips on Using Existing Features
Some of your suggestions on the Sage Ideas site asked us for features that already exist in the product. We
welcome these suggestions, which are easier to satisfy than some others.
In version 23.2, help now provides tips showing you how to:
l

Select a range of check numbers or all check numbers to reconcile. In the 1-5 Bank Reconciliation window,
select the option to sort items by Transaction#, and then click [Display]. In the grid, scroll to the Checks
section. You can then either select a single check row or select multiple rows while holding down the Shift key
(to select a range) and then click [Clear].

l

Track purchase orders by amount, rather than quantity. To track purchase orders for non-inventory items by

amount, switch the quantity and the price. For each line item, change the quantity to the total amount for the
item and change the unit price to 1.
Example: Instead of 100 units at $10.00, change the item line to 1,000 units for a price of $1.00.
Note: This method is appropriate only for non-inventory items.
l

Print a report showing vacation and sick time, and how much was used. Print the 5-1-8-81 Sick Days Earned
and Used report and the 5-8-1-86 Vacation Hours Earned and Used report to see this information for a range

of periods, check dates, and employees, for all employees or for a specific payroll position.
l

Have Sage 100 Contractor alert you when an employee's license is about to expire. Use the Alert Wizard to

create an alert.
1. In the 7-6 Alerts Manager, click [New].
2. In step 1 of the wizard, enter a name for the alert (for example, Employee Licensing), and then click
[Next].
3. In step 2, expand 5-Payroll > 5-2-1 Employees > Employee Licenses, and then click [Next].
4. In step 3, double-click the tables and fields that you want to include in the notification (for example,
Exp. Date, Employee#, License Type, and License#), and then click [Next].
5. In step 4, select values for each variable you want to match to generate an alert (for example Exp.
Date Occurs during next Month), and then click [Next].
6. In step 5, select options to display the alert using your preferred method, and then click [Finish].
7. Select a time to process alert queries, if you have not already done so.
8. Click [Close].
l

Add shipping addresses for 3-5 Jobs. You can create a custom field, or several custom fields, to store the
shipping address. In the 3-5 Jobs window, from the Edit menu, select Custom Fields.

For help on adding custom fields, see the help for the Custom Fields window.
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l

Permit duplicate job names.If you have company admin rights, you can permit duplicate job names as follows:

1. In the 3-5 Jobs window, click inside the Job Name field, and then press the F7 key.
2. In the Field Properties dialog box, clear the Require Unique check box.
3. Click [Save]
Note: You need to be logged in with company administrator rights to use the F7 functions.

Printing Deposit Slips
You use the 1-10 Deposit Slips window to print a detailed list of the cash and checks that make up a deposit, so
that you can take this list to the bank when you make a physical deposit.
Note: As with checks, deposit slips are designed for use with preprinted deposit slip forms that you order
obtain through Sage.

To print deposit slips:
1. Open the 1-10 Deposit Slips window.
2. In the Checking Account box, enter a checking account number in the Cash Accounts range.
3. In the Transaction Dates boxes, enter the range of dates on which you received the checks that you are
taking to the bank.
4. In the Cash Amount box, enter the total amount of bills and coins that you are depositing.
5. In the Deposit Slip Date box, enter the date that you are making the deposit.
6. If you want to include general deposits (unrelated to receivables), select the Include 1-2 Deposits options.
7. If you have a license for Service Receivables and want to include customer deposits that were entered with
service work orders and quotes, select the Include Service Deposits option.
8. Click [Select Checks].
Sage 100 Contractor displays the Deposit Slip selection grid, listing the checks that match your selection
criteria.

9. In the selection grid, you can:
l

Sort the checks to in the order that you want to list them on the deposit slip.
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l

Add, edit, or delete rows in the grid
l

l

To delete a row from the deposit slip, select the row, and then press the Delete key.
To add a deposit that was not captured by your selection criteria, click in an empty row, and then enter the
check number, amount, and payer.

Note: Your changes are for the deposit slip only. They are not saved to the database.

10. When you are satisfied with the list of check deposits, click File > Print.
11. In the Report Criteria box of the 1-10 Report Printing window that appears, select 21-Deposit slip, and then
click File > Print to print the deposit slip.

Tracking for Service Deposit Transactions
When you receive a customer deposit for a service work order or quote in the 11-2 Work
Orders/Invoices/Credits window, you can now record a separate transaction number to track the deposit.
(Previously, these types of deposits were identified only by the work order number with which they were
associated.)
When you save a service work order or quote that includes a deposit, Sage 100 Contractor asks you to enter
the check number or transaction number to identify the deposit.

You can then select the amount in the 1-10 Deposit Slips window when you print a deposit slip to take to the
bank.

Custom Email Messages for Direct Deposits
You can specify a custom email message for employees to whom you send direct deposit emails from the 5-24 Payroll Checks window. For example, you could include advice about opening the attachment, alerts about
changes to benefit plans, and so on
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To create a custom message when emailing direct deposit stubs to employees:
1. In the 5-2-4 Payroll Checks window, select one of the following direct deposit reports:
l

22 - Payroll Checks~Direct Deposit

l

32 - Payroll Checks~Direct Deposit with Paygroup Year to Date

l

37 - Payroll Checks~Direct Deposit with Paygroup Compensation

2. Click Options > Direct deposit email settings.
Note: This option is available only when you select a direct deposit report.

3. In the Direct Deposit Email Settings window that appears:
a. Click [Email Settings].
i. In the Email Settings dialog specify how to send the email messages, including the email address from
which to send the messages.

ii. Click [Save].

b. In the Direct Deposit Email Settings window, enter the message you want to send with the emailed direct
deposit stubs.
c. When you are satisfied with the message, click [Save].
d. Click [Close].

Changing Jobs on Computed Payroll Records
From time to time, you might need to change the job referenced in timecard details.
Example: Say that at the start of a construction project, you need to pay site preparation costs before the
job is set up properly in Sage 100 Contractor. You set up a job as a placeholder to pay the employees
and record initial job costs. Later, when the complete job is set up, you realize it has been set up with a
different number, and now need to transfer the costs to the "real" job.
You use an option in the 5-2-2- Payroll Recordswindow to reassign payroll costs from timecard lines to a
different job. When you change jobs for timecard lines, Sage 100 Contractor:
l

Transfers only job costs from one job to another job.

l

Removes any phases used in the original timecard details.

Note: You can change jobs only for payroll that has been computed, including posted payroll.
It does not affect:
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l

Locales. You can reassign payroll costs only to a job in the same locality. (Changing locales affects local

taxes, which have already been processed.)
l

Paygroup and pay rate. You can reassign payroll costs only to a job that uses the same paygroup values.

(Changing paygroup or pay rates affects wages and benefits, which have already been processed.)
l

Jobs on equipment revenue records. Equipment revenue is recognized through a different process.

l

Other columns on the timecard.

Before you start
You need to log in to the company with administrator rights and exclusive access to change jobs for computed
payroll.

To reassign jobs for computed payroll records:
1. Open the 5-2-2 Payroll Records window.
2. Click Options > Change Job for Computed Payroll.
3. In the Change Job for Computed Payroll window:
a. Specify criteria for selecting the payroll records that you want to change. You can specify the:
l

Check date.

l

Pay Period Ending date.

l

A range of payroll records.

l

Specific records using the pick list.

b. In the Change from Job box, specify the original job used in the records that you want to change.
c. In the To Job box, specify the correct job to which you want to transfer the payroll costs.
d. When you are satisfied with your selections, click [Change Job] to process your change.
Sage 100 Contractor processes your request, displaying records that match your selection criteria in a Select
Timecard Lines to Change From Job x to Job y grid:
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Sage 100 Contractor displays records that cannot be changed in gray text.

4. Select the check box beside each record that you want to change, and then click [OK].
Important! Sage 100 Contractor updates the selected timecard lines and the associated job cost records
as a single transaction. If one of the updates cannot be processed, no changes are saved to the
database.

New Help Feedback Process
We have implemented a new help feedback system.
Click the Feedback button in a help topic to report your satisfaction with the topic or to tell us if you cannot find
answers to your questions.
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HomeBuilder and Remodeler download files
All HomeBuilder and Remodeler setup files are now available for download from Sage Knowledgebase article
112631.
Previously, the HomeBuilder and Remodeler files were installed with Sage 100 Contractor. They took up 242
MB of disk space, and were not only rarely used, but were used only to set up new companies.
Removing these files from the installation package has significantly reduced the size of the installation
program, making downloads of updates much quicker and easier.

Better Sorting on Grids
Previously, to sort a grid, you had to right-click the column header, and then select a sorting option from a
shortcut menu.
With version 23.2, you can also sort a grid by:
l

Double-clicking on the header

l

Double-clicking again to sort in reverse order

An arrow in the column header indicates which column is sorted and in which direction.
Note: Only grids with simple totals can be sorted. Grids that have groupings with separate totals cannot
be sorted.
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Other improvements
Version 23.2 also includes the following improvements:
l

When you try to archive payroll that has uncomputed or unposted payroll records, you now receive a
message telling you that you can only archive the company after you finish processing the payroll.

l

If an employee cannot be removed from the database during the archive process, Sage 100 Contractor sets
their record to Inactive.

l

In the 9-5 Takeoffs window, we added menu and button (F7) security to the options on the Update and Export
menus.

l

In the 9-5 Takeoffs window, you can take advantage of a new Do not calculate assembly cost option. You
select this option separately for each takeoff.

l

In the 3-5 Jobs window, you can add only time reviewers who are identified as mobile users in the 7-2-3
Mobile Users window.

Enhancements for the U.S. Edition
Support for New Oregon Local Taxes
Version 23.2 includes support for two new Oregon local taxes that came into effect January 1, 2021:
l

The Supportive Housing Services (SHS) tax. The Portland metro area tax covers parts of Multnomah,

Washington, and Clackamas counties. It includes a 1% income tax on personal income that meets certain
thresholds, depending on whether the employee files their taxes individually or jointly.
For more information about this tax, visit Supportive housing services: Addressing homelessness in greater
Portland.
l

The Multnomah County Preschool for All (PFA) tax. This Multnomah County tax is a 1.5% tax or a 3% tax on

personal income that meets certain thresholds, depending on the level of income and whether the employee
files their taxes individually or jointly.
For more information about this tax, see Preschool for all personal income tax,

For information about setting up local tax districts and payroll calculations, see Setting up local taxes for
Oregon in the Sage 100 Contractor help.
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Do you have a product idea you want to share with us?
We want to hear it!

To suggest a product enhancement when you're working with Sage 100 Contractor:
1. On the Sage 100 Contractor desktop, click the Home & Resources tab > Submit Product Idea.
2. Log in to the Sage 100 Contractor Ideas site (or sign up).
3. Describe your idea.
4. (optional) Browse through others' suggestions, and vote for the ones you love!
Or visit https://www5.v1ideas.com/TheSageGroupplc/Sage100Contractor any time you're online!
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Fixes in Version 23.2
Fixes in Both Editions
Version 23.2 includes the following software fixes in both the U.S. and Canadian editions:
l

In the 3-4 Statements window, when you save customized email settings as the default, Sage 100 Contractor
now retains the settings, including any message you entered.

l

In Database Administration, when you archive accounting or payroll data, Sage 100 Contractor displays all
companies in the list.
If you select a company for which you are not a company administrator, Sage 100 Contractor displays a
message telling you that you need administrator rights to archive the company.

l

Sage 100 Contractor now warns you if you try to archive a company database that was created using an
earlier version of the program than the one you are using to archive. You receive a message saying that you
need to update the database before you can run the archive process.

l

In the 10-3 Schedules window, blank rows inserted in a Gantt chart do not distort the alignment of tasks in the
grid or in the 10-1-5-21 Gantt Chart report.

l

l

Client workstations can again receive automatic updates through your server.
We have improved email messages that you send with fund transfers (by EFT in Canada or ACH in the U.S.)
and by direct deposit.
For example, when you email pay stubs to employees with direct deposits, Sage 100 Contractor displays a
message telling you which employees are set up to receive pay stubs by email. Sage 100 Contractor emails
pay stubs to these employees, and then prints pay stubs for other (non-direct deposit employees).
You can also now choose to print pay stubs for employees who receive their stubs by email.

l

In the 7-6 Alerts Manager, you can delete an alert query even if the alert exists on your or another user's
dashboard.

l

In the 7-2-3 Mobile Users window, we have reversed the order of the two top fields, so that Employee now
comes before Email. The email address from the employee record is used as the default email for their
Mobile User's record, so you don't have to enter the email address manually.

l

You can void Equipment Allocation transactions in the 1-3 Journal Transactions window.
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l

l

In the 3-5 Jobs (Accounts Receivable) window, you can delete a job even if it is referenced in:
l

An equipment revenue record

l

A payroll record (a timecard, daily Payroll, or simple time)

l

A service work order or invoice

l

A recurring job cost transaction

When the main desktop window loads, Sage 100 Contractor checks to ensure that it will be visible on your
screen. If the window was set for a different screen configuration the last time you used the application, Sage
100 Contractor centers the window on your current primary screen, instead of off-screen.

Fixes for the Canadian Edition
The following issues were fixed specifically for the Canadian edition:
l

The 3-1-3 Job Period Aging and 4-1-3 Vendor Period Aging reports list jobs that have only holdback in the
report details section of the report.
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Sage Construction Anywhere (SCA)
Retirement
As of September 30, 2019, Sage retired Sage Construction Anywhere (SCA).
Contact your Sage business partner to learn about alternative solutions.
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Summary of enhancements in earlier
versions of Sage 100 Contractor (SQL)
Earlier versions of Sage 100 Contractor (SQL) provided a wide variety of new features, including many
enhancements that our customers have requested.
The following table is a list of the most significant features introduced in earlier versions, details of which you
can read about in the Release Notes for the respective version.

Summary of enhancements by version
Enhancements by version

U.S.
Only

Canada
Only

API

Version 23.1 enhancements

(For details, see the v23.1 Release Notes)
Simple Time Entry
Sage Time mobile app
Easily Allocate Inventory-Related Use Taxes

x

Version 22.4 enhancements

(For details, see the v22.4 Release Notes)
Enhancements for 2020 1099 Reporting

x

Enhancements for 2020 ACA Reporting

x

Support for new T4 requirements related to COVID reporting

x

Version 22.3 enhancements

(For details, see the v22.3 Release Notes)
Reports on stored personal information
Support for new W-4 forms

x

Support for Covid-19 related absences and wages

Sage 100 Contractor 2021 (SQL) Version 23.2 Release Notes Canada and U.S. Editions

19

Enhancements by version

U.S.
Only

Canada
Only

API

Version 22.2 enhancements

(For details, see the v22.2 Release Notes)
Integration with eTakeoff Dimension
Refinements for 'Use Taxes'

x

Support for Equal Employment Opportunity Commission (EEOC)
Reports

x

Version 22.1 enhancements

(For details, see the v22.1 Release Notes)
Command-level security for many options and Post commands
Ability to save final reconciliations for later access
Ability to transfer amounts between bank accounts
Warning when posting an AP invoice with no subcontract
Ability to view Sage messages in Sage 100 Contractor
Job templates to use and reuse in takeoff
Ability to report on use taxes

x

New payroll type for retiring allowances

x

Several additional customer-requested enhancements
Version 21.3 enhancements

(For details, see the v21.3 Release Notes)
Some minor enhancements plus U.S. tax updates.
Version 21.2 enhancements

(For details, see the v21.2 Release Notes)
Ability to merge client records
Ability to merge vendor records
Ability to include a record's attachments when you email forms
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Enhancements by version

U.S.
Only

Canada
Only

API

Ability to email statements to jobs and clients
Ability to record external vendor payments
Ability to specify a secondary backup location
Ability to track vendor certificates by job
More ways to list vendor invoices to pay
Version 21.1 enhancements

(For details, see the v21.1 Release Notes)
Bank feeds
Ability to email direct deposit stubs at a later date
Enhanced cost type validation
Enhanced Search (Find) in the 9-5 Jobs window
Ability to move company to a new drive
Ability to view an employee's pay raise history
Ability to create timecards for individuals in Daily Payroll
Ability to create payroll records for salaried employees
Ability to restrict exclusive access for specific non-administrative
users
Version 20.7 enhancements

(For details, see the v20.7 Release Notes)
Ability to print a new 5-1-8-86 Vacation Hours Earned and Used
Report

x

Version 20.6 enhancements

(For details, see the v20.6 Release Notes)
New Server Management Tools
Ability to set records "Inactive"
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Enhancements by version

U.S.
Only

Canada
Only

API

More efficient login
Ability to replace Cost Codes, Vendors, Tasks, or Inventory Locations
in a takeoff
New Combined Accounts Receivable and Service Receivables aging
reports
Ability to print Accounts Receivable Aging Reports by Invoice Date
Ability to print Accounts Payable Aging Reports by Invoice Date
Ability to print Service Invoice Aging Reports by Invoice Date
New banking categories you can assign to bank-related journal
transactions
Improved vacation tracking

x

Version 20.5 enhancements

(For details, see the v20.5 Release Notes)
Ability to use new custom fields in most windows
Ability to tag rows for followup in the 9‐5 Takeoffs grid
Audit Information is available in Advanced Company Settings
Numeric fields provide automatic calculation
Easier access to user subfolders in workgroups
Ability to correct the period of a posted payroll transaction
Ability to skip automatic calculation during takeoff
Ability to filter cost codes by Job and Phase in lookup windows
Ability to filter unassigned work orders on the Dispatch Board
A new option for saving and selecting company-specific custom
reports and forms
Ability to use a new standard calendar to select dates
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Enhancements by version

U.S.
Only

Canada
Only

API

Support for Microsoft SQL Server 2016 and Windows 2016 Server
Ability to copy user process maps
Ability to use high contrast display settings for Windows 10
Ability to print a new Payroll Check Register 5‐1‐2‐31 by check date
3‐7 Progress Billing and 12‐2 Inventory Allocation allow 5,000 rows
Tax and Workers' Comp rates in 4‐4 and 4‐2 use 4 decimal places

x

Workers' Comp Reports 21, 86, and 96 show Overtime Hours

x

Version 20.4 enhancements

(For details, see the v20.4 Release Notes)
Ability to copy external files to other users
New option to approve the removal of employee records
Version 20.3 enhancements

(For details, see the v20.3 Release Notes)
Ability to view change history in records
New option for closing purchase orders automatically
Support for Paya Exchange Desktop 2.0
Support for customized tables and views
Ability to use a new window to add client service locations quickly
Effective rate shown for Sales Tax Districts (U.S. only)

x

API supports adding and removing attachments

x

API enforces locks

x

Schema change for Global Variables

x

Version 20.2 enhancements

(For details, see the v20.2 Release Notes)
Simplified schedules lookup
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Enhancements by version

U.S.
Only

Canada
Only

API

QueryJobCost (API Enhancement)

x

SetExclusive (API Enhancement)

x

Version 20.1 enhancements

(For details, see the v20.1 Release Notes)
More versatile lookup windows
Unique Payroll record numbers
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Known issues and comments
The following sections describe known issues and problems in Sage 100 Contractor Version 23.2.

Compliance and Payroll Checks
Important! The sample check forms that come with Sage 100 Contractor may not be fully compliant with
all federal, state, and local laws, and other requirements that can differ from one jurisdiction to another. It
is your responsibility to familiarize yourself with all applicable laws and requirements, and to modify
check forms as needed to ensure compliance. For information about customizing check forms, see 13-5
Form/Report Page Design in the Sage 100 Contractor help, or contact your Sage business partner for
assistance.

Internet access required for Sage 100 Contractor
Sage 100 Contractor features, such as printing or efiling tax forms, submitting enhancement requests,
accessing Help, or downloading periodic product or tax updates all require Internet access.
To take advantage of these features, ensure that any workstation or server that Sage 100 Contractor is
installed on has access to the Internet.
During installation of Sage 100 Contractor, the computer serving as the Sage license server must be able to
connect to the Internet to obtain licenses. Once installation is complete, you can check out license uses for
each computer where Sage 100 Contractor is installed, then disconnect the Sage license server from the
Internet.

Configuring anti-virus software and third-party firewalls
During installation of the Sage 100 Contractor Hosting Framework, the Windows Firewall is configured
automatically to enable the Sage 100 Contractor Hosting Framework to act as a TCP server. If you use some
other firewall, you may need to manually adjust some settings in the firewall in order to ensure proper
operation.
You can use the following procedure to configure the Windows Firewall manually to allow the Sage 100
Contractor Hosting Framework to communicate with other computers. Use it as the basis for manually
configuring other third-party firewall products.
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To configure the Windows Firewall:
1. Click Start > All apps > Control Panel > System and Security.
2. Open Windows Firewall, and then select Allow a program or feature through Windows Firewall.
3. Select Sage 100 Contractor Hosting Framework on the list, if it is not selected.
Note: By default, the exception is set to allow access by any computer on the network. You can refine
this setting by selecting the Change Scope button. Be aware that restricting the scope incorrectly can
cause the computer to be unable to connect with some or all of the other machines on the network.

Files to exclude when manually configuring your firewall for Windows 8.1 Professional and Windows
10 Professional 32-bit
l

C:\ProgramData\Sage\Sage 100 Contractor SQL

l

C:\Program Files\Sage\Sage 100 Contractor SQL

l

C:\ProgramData\Aatrix Software

l

C:\Program Files\Aatrix Software

l

C:\%LocalAppData%\Sage\Sage 100 Contractor SQL

l

Network location of Sage 100 Contractor SQLdata. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Files to exclude when manually configuring your firewall for Windows 8.1 Professional and Windows
10 Professional 64-bit
l

C:\ProgramData\Sage\Sage 100 Contractor SQL

l

C:\Program Files (x86)\Sage\Sage 100 Contractor SQL

l

C:\Program Files (x86)\Aatrix Software

l

C:\ProgramData\Aatrix Software

l

C:\%LocalAppData%\Sage\Sage 100 Contractor SQL

l

Network location of Sage 100 Contractor data. (If you install SQL Server Express using Database
Administration, this location is C:\Sage100Con\Company\.)

Software and hardware required to support Microsoft SQL
Server
Version 23.2 requires an instance of Microsoft SQL Server. You can download and use Microsoft SQL Express
at no charge, or you can use the full version of Microsoft SQL Server. You can even start using Microsoft SQL
Express, and upgrade to the full version of Microsoft SQL Server later, if necessary.
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When you first open the new Database Administration tool, the program tries to configure an instance of
Microsoft SQL Server with optimal settings for Sage 100 Contractor for you. If you do not already have an
instance of Microsoft SQL Server, you can let the Database Administration tool download, install, and
configure Microsoft SQL Express for you.
Refer to Knowledgebase article 111361 for detailed information about supported operating systems and
software, and for minimum hardware requirements.

Installation of Microsoft SQL Server on a domain controller is
not recommended
Microsoft recommends against installing SQL Server on a domain controller, and does not support SQL Server
on a read-only domain controller should you encounter any problems with this configuration.
Because you must install Database Administration on the same machine as SQL Server, you should not install
Database Administration on a domain controller. To guard against inadvertent installation on a domain
controller and the potential for irrecoverable data losses, you will receive a warning if you attempt to install
Database Administration on a machine used as a domain controller .
For more information, see the Microsoft Knowledgebase article https://support.microsoft.com/enus/kb/2032911.

About .NET Framework
.NET 4.8 Framework is required
If Microsoft .NET 4.8 Framework is not already installed, it will be installed automatically when you install Sage
100 Contractor. Installation of .NET 4.8 Framework alone may take up to 20 minutes per computer.
Make sure that both your client and server computers meet the minimum requirements for installing both Sage
100 Contractor software and .NET 4.8 Framework.
Note: If Sage 100 Contractor requires an installation of .NET 4.8 Framework, the Sage 100 Contractor
installation process may continue automatically after the .NET Framework installation is completed. If
you are prompted to restart your computer after the .NET Framework installation, you must do so to
continue the Sage 100 Contractor installation.

.NET 3.5 is also required
In some situations, you may need to turn on .NET 3.5 manually by selecting the .NET 3.5 check box in the
Windows Features dialog box. For more information, see Knowledgebase article ID 68381, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=68381.
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Turning on Microsoft .NET 3.5
Microsoft .NET 3.5 must be available and enabled prior to installing Sage 100 Contractor.
If you attempt to install Sage 100 Contractor without .NET 3.5 installed, you receive the following message
during the licensing install:
“Sage.CRE.HostingFramework.Service v3.2 has stopped working.”

When you click [OK], the installation continues, but the services have not been installed so Sage 100
Contractor cannot open. The Sage.CRE.HostingFramework Service does not install unless .NET 3.5 is
installed. If you receive the above message during installation, install .NET Framework 3.5., and then reinstall
Sage 100 Contractor.
The following instructions are for Windows Server 2008 R2.

To verify that .NET 3.5 is installed:
1. Click the Start button in the lower left corner of the display.
2. Highlight Administrative Tools and select Server Manager.
3. In the Server Manager interface, click Features to display all the installed Features in the right-hand
pane. Verify that .NET Framework 3.5.1 is listed.

To enable .NET 3.5:
1. In the Server Manager interface, select Add Features to display a list of possible features.
2. In the Select Features interface, expand .NET Framework 3.5.1 Features.
3. Once you expand .NET Framework 3.5.1 Features, you will see two check boxes. Check the box next to
.NET Framework 3.5.1 and click Next.
4. In the Confirm Installation Selections interface, review the selections and then click [Install].
5. Allow the installation process to complete and then click [Close].
Note: Enabling .NET Framework 3.5.1 may require a reboot.

About network configuration and TCP Remoting Channel
Sage 100 Contractor uses the TCP Remoting Channel, a Microsoft .NET Framework component, to enable
communication among computers on a network. By default, Sage 100 Contractor uses the TCP starting port
48760. Certain configurations can potentially disable the communication:
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l

You must enable file sharing on your computers. To enable file sharing, follow the instructions in the
Windows Help.

l

TCP communication requires the selection of port numbers that are not in use by other processes on the
local computer.

l

Software firewalls running on the local computer can be configured to block processes from opening
TCP ports, which will prevent communication through the TCP Remoting Channel.

PCI DSS Compliance
PCI DSS stands for Payment Card Industry Data Security Standard. It was developed by the major credit card
companies as a guideline to help organizations that process card payments to prevent credit card fraud,
cracking, and other security weaknesses and threats.
A company processing, storing, or transmitting payment card data must be PCI-compliant or risk losing its
ability to process credit card payments and being audited and/or fined. (For more information about PCI
standards, see https://www.pcisecuritystandards.org/.)
Sage 100 Contractor payment processing works exclusively with Paya to enable merchants to seamlessly
process check and credit card transactions directly in Sage 100 Contractor. The payment processing program
uses Paya Exchange, a secure payment-processing application, to connect to Paya and process check and
credit card transactions.
Integrating your financial and operations system with Paya lets you process check and credit card transactions
without storing your customers’ sensitive card information in your database. Paya Exchange transmits check
and credit card details through a secure connection to Paya, where they are stored in a PCI-compliant vault,
protecting your from exposure to non-compliance penalties and credit card fraud.
Caution! To avoid non-compliance with PCI standards, do not store credit card information in Sage 100
Contractor. Such storage creates unnecessary risk for your business and your customers.

Tax Forms and eFiling by Aatrix configuration requirements
Tax Forms and eFiling by Aatrix requires an Internet connection for two reasons:
l

For updating forms and executable files.

l

For electronic filing (eFiling) of the forms.

If you experience an Internet connection problem, it may be due to problems communicating through an
Internet firewall. Firewalls need to have access allowed through specific ports:
l

The Tax Forms and eFiling Updater uses standard SSL/HTTP port 80 to access the site
http://updates.aatrix.com.

l

The eFiling component uses secure HTTPS on port 443 to access the site https://efile.aatrix.com.
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By allowing access to aatrix.com, you allow both updates and eFiling. Occasionally, restrictions are tighter and
only allow access to these ports by specific programs. Tax Forms and eFiling uses the following programs to
access the Internet.
For updating using http on port 80 to http://updates.aatrix.com:
l

aatrixforms.exe

l

updater.exe

l

updater2.exe

For eFiling using secure http on port 443 to https://efile.aatrix.com:
l

builder.exe

l

viewer.exe

Use Adobe Reader Version 8.1.3 or later for faxing
Customers have reported problems faxing from Sage 100 Contractor with versions of Adobe Reader earlier
than 8.1.3. Adobe Reader Version 8.1.3 and later support faxing from Windows and from Sage 100 Contractor.
Important! To fax from Sage 100 Contractor, the Windows Fax Service component must be installed with
your Windows operating system. For more information about installing the Windows Fax Service
component, see the Sage 100 Contractor Help topic, “Installing the Windows Fax Service component.”

Configuring Windows Regional and Short Date Format
To specify regional formats for Windows:
1. Click the [Start] button, point to Control Panel, then click Clock, Language, and Region .
2. Click Region and Language.
3. On the Formats tab, select the format for your country.
4. Under Date and time formats, from the Short date format drop-down list, select the format used for your
country.
5. Click [OK].
6. Close the Clock, Language, and Region window.
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Windows "Sleep Mode" prevents computers from obtaining a
license use
If the computer you are using as a license server goes into sleep mode, other computers on the network
cannot obtain a license.
To avoid this possibility, set Sleep Mode on your license server computer to Never.

To set the Sleep Mode to “Never”:
1. In Windows 8.1 Professional, Windows 10, or Server 2012 Standard, click Start > All apps > Control Panel >
System and Security > Power Options.
In Windows 7, click Start > Control Panel > System and Security > Power Options

2. Select Change when computer sleeps.
3. From the Put computer to sleep list, select Never.

Sage licensing (Sage 100 Contractor Hosting Framework)
cannot auto-start on Windows 8.1
The Sage licensing service (Sage 100 Contractor Hosting Framework) cannot auto-start on computers running
the Windows 8.1 Professional or Windows 8.1 Enterprise operating systems. If the service stops, the program
displays a message advising you to take further action to resolve this issue.
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