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Subcontractor Compliance 

Management

Depending on the type of project and its location, the subcontractors and suppliers 
who work for you may be required to furnish proof of insurance, submit lien release 
documents, weekly certified payroll reports, and so on.

By using Job Cost with Accounts Payable, you can ensure that you have the proper 
documentation from your vendors on file before you pay them.

WARNING:  If you do not use Job Cost, you can track vendor insurance and vendor 
miscellaneous compliance items but you cannot track lien waivers or weekly certified labor 
reports.

In this lesson, you learn how to manage vendor compliance. Topics include:

 Setting up your software for compliance management.

 Incorporating compliance tracking into your Accounts Payable workflow.

 Upgrading lien waivers and insurance from a prior version of the software to 
version 12.1.
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Compliance Management Overview

You may need to track several different types of documents when you work with 
subcontractors and suppliers. Using your software’s compliance management 
system, you can monitor:

 Details of a subcontractor’s insurance policies, as well as specific policies that 
are required by job.

 Different types of lien waiver documents, such as:

 Pre-lien notice.

 Conditional waiver and release upon progress payment.

 Unconditional waiver and release upon progress payment.

 Conditional waiver and release upon final payment.

 Unconditional waiver and release upon final payment.

NOTE:  Lien waivers are governed primarily by state laws and vary from state to state. 
Depending on the state in which the project is located, you may not need to track all these 
types of lien waivers.

 Payments and lien waivers for secondary vendors (these are sub-tier vendors 
who do not work directly with you).

 Receipt of weekly certified labor reports.

In addition to the above, you can monitor other items. For example, a vendor’s trade 
license, completed W-9 form, drug test results, and so on. To create additional 
compliance items, select File > Company Settings > Custom Descriptions, and 
customize the list for AP Misc Compliance Type. 

Based on the compliance tracking requirements that you define, the software 
creates records of expectation during your Accounts Payable workflow. For 
example, it can automatically create records of conditional lien waivers after 
invoice entry, records of unconditional lien waivers after invoice payment, and 
records to track certified reports for each week they are due. These records of 
expectation are used to alert you when items are outstanding. It can warn you during 
invoice entry, invoice payment selection, and can even block invoice payment if a 
vendor has not turned the necessary documents.

When your vendors submit compliance documents, you can receive them during 
your normal Accounts Payable workflow tasks or use Tasks > 
Subcontractor Compliance Management to indicate that they are no longer 
outstanding.
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Set Up Your Software For Compliance Tracking

Because compliance requirements vary from state to state and even by job, the 
software allows you to customize compliance management settings based on your 
company’s needs.

The areas in which you define compliance management settings include:

 Accounts Payable settings (AP: File > Company Settings > AP Settings).

 Vendor setup (AP: Setup > Vendors).

 Job setup (JC: Setup > Jobs).

 Commitment setup (JC: Tasks > Commitments). 

NOTE:  Commitments are required if you want the software to automatically generate 
records of expectation to track when certified reports are due. See “Commitment Setup” on 
page 17.

In addition, if you want the system to automatically generate records that indicate 
when weekly certified labor reports are due from your vendors, you must enable the 
Certified Reports Service. This utility is automatically installed on the server 
where Sage 300 Construction and Real Estate is installed. To access it, select 
Start > All Programs > Sage > Sage 300 Construction and Real Estate > 
Reporting and Other Tools > Certified Report Service Setup. 

If you use security in Sage 300 Construction and Real Estate, you must supply the 
User name and Password of a software security administrator in order to enable 
the Certified Reports Service and configure when it runs. You enter the credentials 
in Account Name and Password in the Certified Report Service Settings 
window.

FOR MORE INFORMATION:  See the Help topic called “About certified reports” to learn 
how to set up the Certified Reports Service.
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Accounts Payable Settings

Open the AP Settings window and click Compliance Settings.

Menu Path—AP: File > Company Settings > AP Settings > Compliance Settings

Lien Waivers

Your software can automatically generate lien waiver records which are primarily 
used for tracking purposes. 

NOTE:  As an alternative, you can manually enter lien waivers in Accounts Payable instead 
of allowing the software to automatically generate the records. See “Subcontractor 
Compliance Management Task,” on page 20. Your system can still alert you when manually 
entered lien waivers are outstanding.

Conditional Lien Waivers—specify settings on this tab if you perform work in a 
state where conditional lien waiver forms are used. A vendor typically submits this 
signed release form prior to receiving payment.

Unconditional Lien Waivers—specify settings on this tab if you perform work in 
a state where unconditional lien waivers are used. A vendor typically submits this 
signed release form after receiving payment.
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On each tab:

 Select when lien waiver records are generated and how the 
Lien waiver through date is assigned. The option that you select depends on 
your business process. 

FOR MORE INFORMATION:  See “System Generated Lien Waiver Records” on page 23 
to learn how lien waiver amounts are created based on the option that you select in 
AP Settings.

 In the boxes next to Partial and Final, specify the report formats for printing 
lien waiver documents should you need to send them to your vendors to request 
their signature. These report formats are automatically used when you print 
forms in the Subcontractor Compliance Management task. However, you 
can change the format during print time to accommodate unique state 
requirements.

NOTE:  The software provides you with default report formats but you can use custom ones 
as long as the designs are created in SAP Crystal Reports. If your custom report formats 
for lien waiver documents are created in Sage 300 Construction and Real Estate Report 
Designer, you cannot print them in the Subcontractor Compliance Management task; 
you must add them to the Reports menu in order to print them.

 Select the amount that the software uses to generate final lien waivers.

FOR MORE INFORMATION:  See “Final Lien Waivers,” on page 27.

The Enable lien waivers on all vendors based on job compliance settings check 
box determines how lien waiver records are automatically generated.

 Select the check box to automatically generate lien waiver records for all 
vendors by vendor type as specified on the job (JC: Setup > Jobs > 
Job Compliance tab). In other words, if you select this check box and specify 
the Subcontractor vendor type on Job A, the software generates lien waiver 
records for any vendor that belongs to the vendor type Subcontractor when it is 
associated with Job A.

 If you do not want the software to generate lien waiver records for all vendors 
by vendor type, clear the check box. The software still generates lien waiver 
records for vendors by vendor type as specified on the job, however it only 
creates them for vendors with the Create lien waivers for this vendor based 
on job settings check box selected (AP: Setup > Vendors > Insurance/
Compliance tab).
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Certified Labor Reports

For certified jobs that require weekly labor reports, specify the date for 
Certified Reports compliance check. The software compares this date to the 
report due date and can issue a warning if a report is outstanding from your vendor. 

WARNING:  You must configure the Sage Certified Reports Service so that the system can 
generate records that indicate when weekly certified labor reports are due.

NOTE:  To track certified reports, you must indicate that they are required on the job—see 
“Job Setup,” on page 15. In addition, you must also enter the Actual Start date on 
commitments that are associated with the job—see “Commitment Setup,” on page 17.

Compliance Warning Settings

Click Compliance Warning Settings to specify when the software warns you if:

 Lien waivers, certified reports, and other items are outstanding.

 Proof of insurance is required but not received or policies have expired. The 
settings on the Insurance tab control warnings for insurance on vendors and 
commitments.

NOTE:  If you disable warnings during invoice entry, no visual warning indicators appear 
during invoice entry tasks and no warnings print on journals.

Menu Path—AP: File > Company Settings > AP Settings > Compliance Warning Settings
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Vendor Setup

You define the Vendor type for each vendor that you set up. Compliance 
requirements vary by vendor type for each job.

NOTE:  You customize the names for AP Vendor Type 1 to 4 in Custom Descriptions.

Menu Path—AP: Setup > Vendors > General tab

Other compliance settings are on the Insurance/Compliance tab of the 
Vendor Setup window. 
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Menu Path—AP: Setup > Vendors > Insurance/Compliance tab

Lien Waivers

The Create lien waivers for this vendor based on job settings check box 
determines whether or not lien waiver records are automatically generated for a 
vendor. You are only required to select this check box if the following two 
statements are true in AP Settings:

 The software is set up to automatically generate lien waiver records.

 The Enable lien waivers on all vendors based on job compliance settings 
check box is cleared.
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Insurance

Click the Insurance Certificates button and enter information about the various 
types of policies that the vendor is required to maintain. Four insurance types are 
already set up in the software—general liability, automobile, umbrella, and 
worker’s compensation. 

NOTE:  If you need to track additional types of insurance, use Custom Descriptions and 
customize the field names for AP Custom 1 and AP Custom 2. The insurance types are 
the same for vendors and commitments.

Menu Path—AP: Setup > Vendors > Insurance/Compliance tab > Insurance

If there is a type of insurance where the policy varies by job, select the 
Require per commitment check box—this automatically marks the insurance type 
as required for any commitment that you set up with the vendor. You will enter the 
details for this insurance type on the commitment setup.

Your software can warn you when a policy has expired or when the expiration date 
is missing for any insurance that requires proof.

If payment to a vendor is blocked because the insurance is not in compliance, you 
can select the Override check box to unblock it.
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Miscellaneous Compliance Items

There may be additional documentation that you require from your vendor such as 
a valid state trade license or a completed W-9 form. Click the 
Misc. Compliance Items button to specify such items.

Menu Path—AP: Setup > Vendors > Insurance/Compliance tab > Misc. Compliance Items

For each item that you want to track, select a Misc. Compl Type from the list. This 
is a list that you create in Custom Descriptions for AP Misc Compliance Type.

Your software can warn you if any item is past its expiration date or is marked 
required but not received.

For vendor compliance items that are job specific, select the Required on Job 
check box. This allows you to track such items on jobs that the vendor works on. 
For example, a signed contract with the vendor is required for every job so you mark 
the compliance item as Required on Job. When you set up a commitment for the 
vendor and commit it, that compliance item is automatically made required for the 
job that is specified on the commitment.

When appropriate, select the Jurisdiction for an item. For example, a subcontractor 
who performs work in multiple states need to provide a trade license for each state. 
The list of jurisdictions are defined in Custom Descriptions for the field 
AP Jurisdiction. 

NOTE:  You can customize the field name AP Jurisdiction in Custom Descriptions to use 
it for another purpose.

FOR MORE INFORMATION:  See “Jurisdiction” on page 16 to learn about specifying the 
jurisdiction on the job, and “Miscellaneous” on page 25 to learn about miscellaneous 
compliance items that are job specific.
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If there are items that are only due at the completion of the work that the vendor is 
contracted to do, select Required for Final Compliance.

FOR MORE INFORMATION:  See “Final Compliance Approval” on page 28 learn how this 
feature works.

If payment to a vendor is blocked because an item is not in compliance, you can 
select the Override check box to unblock it.

Job Setup

Open the Job Setup window and select the Job Compliance tab. For each job, you 
specify the compliance requirements by vendor type.

Menu Path—JC: Setup > Jobs > Job Compliance

Lien Waivers

If you specify in AP Settings that the software automatically generates lien waiver 
records, you must select the vendor type for which to generate lien waivers.

NOTE:  If the Enable lien waivers for all vendors based on job settings check box is 
cleared in AP Settings, you must also select the Create lien waivers for this vendor 
based on job settings check box on the vendors (refer to “Vendor Setup,” on page 11) for 
which you want the software to generate lien waiver records.
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If applicable:

 Enter the minimum amount that is required before lien waivers are created.

 Change the through date used on lien waiver records if it varies from job to job. 
The date type that is already selected comes from AP Settings.

Certified Labor Reports

Select the Require Certified Reports check box for the vendor types that are 
expected to submit weekly certified labor reports. 

Also, specify the day of the week that indicates the end of each certification week. 
The software uses this day in conjunction with the Actual Start date of the 
commitment schedule to establish when reports are due.

Final Compliance Approval

If you want to hold back a percentage of a commitment from payment until a final 
review of the work has been approved, select the Require Final Comp. Approval 
check box and enter the final percentage of the commitment that is held back.

When you invoice the final percent of the total revised commitment amount, the 
software requires an authorized user to select the Final Compliance Approval 
check box on the commitment (JC: Tasks > Commitments) before the invoice can 
be paid. 

FOR MORE INFORMATION:  See “Final Compliance Approval” on page 28 to learn how 
this feature works.

Jurisdiction

Select the jurisdiction for the job. The list of jurisdictions is the same as the one for 
vendor miscellaneous items (AP: Setup > Vendors > Insurance/Compliance tab 
> Misc Compliance Items).

FOR MORE INFORMATION:  See “Miscellaneous” on page 25 to learn how the jurisdiction 
on the job affects miscellaneous compliance items that are job specific.
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Commitment Setup

You must set up commitments for jobs if you want the software to:

 Establish when weekly certified labor reports are due.

 Track job specific insurance policies that the vendor maintains.

 Automatically generate records of expectation for lien waivers and weekly 
certified labor reports for secondary vendors.

Menu Path—JC: Tasks > Commitments

Certified Labor Reports

If the commitment is for a job that requires vendors to submit weekly certified labor 
reports, you must click Schedule and enter the Actual start date. The software uses 
this date in conjunction with the certified report week ending day on the job to 
establish the day of the week that is the week ending date for a prevailing wage job.

Menu Path—JC: Tasks > Commitments > Schedule

NOTE:  If the vendor works on several different jobs for which certified reports are required, 
set up a separate commitment for each job so you can enter the Actual start date for each.
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Insurance

Click Insurance to enter the policies that the vendor must have in order to work on 
a specific job. 

TIP:  In the Insurance for Commitment window, when you click View Vendor Insurance, 
it displays the policies from the vendor setup (AP: Setup > Vendors) but you cannot 
change them.

Select the Received check box if the insurance certificate is on file. This 
automatically sets the current system date as the Received date but you can change 
it. Your software can warn you when required insurance types have not been 
received or have expired.

Menu Path—JC: Tasks > Commitments > Insurance
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Secondary Vendors

Secondary vendors are suppliers or subcontractors who do not work directly with 
you. These sub-tier vendors work directly or indirectly with your vendor. You may 
need to issue joint checks to both primary and secondary vendors, or even require 
secondary vendors to submit compliance documents.

Click Secondary Vendors to specify sub-tier vendors, their relationship with your 
vendor, and what is required from them.

Menu Path—JC: Tasks > Commitments > Secondary Vendors

When you specify the Secondary Vendor, you can select from a list of Company 
or Person contacts in Address Book, or you can create a new one. Secondary 
vendors do not have to be linked to an Address Book Company or Person, nor do 
they have to be set up as an Accounts Payable vendor.

Use the Relationship column to specify the vendor relationship. A secondary 
vendor may work directly with the primary vendor or with another sub-tier vendor. 

You can associate a secondary vendor with a Commitment Item. The Description 
and Amount is automatically entered based on the commitment item but you can 
change it. For example, if the commitment item is $10,000 but the secondary vendor 
is only involved with $2,000 of that amount. Furthermore, if a commitment item 
involves several different sub-tier vendors, you can select the same commitment 
item for different secondary vendors.

Use the check boxes to indicate whether the secondary vendor is required to submit 
weekly certified labor reports or lien waivers. An additional check box is available 
for your reporting needs—you can customize the column name called 
JC Sec Vend Chkbx in Custom Descriptions.

If you are required to pay the primary and secondary vendor with a joint check, 
select the Joint Check check box. You can use this information on reports to 
indicate that a joint check is required for a specific commitment item.

NOTE:  When you enter an invoice against the commitment or select the invoice for 
payment, you can display a list of all the secondary vendors on the commitment and select 
the one to use on the joint check.
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Subcontractor Compliance Management Task

Records of expectation are used to alert you during various Accounts Payable 
workflow tasks when there are outstanding compliance items. When such warnings 
appear, you have the option to display additional information or to manage the 
items. In the example shown below, a list is shown when you click Details in the 
Compliance Warning window.

If you click Compliance Management in the Compliance Warning window, it 
starts the Subcontractor Compliance Management task. You use this task to:

 Access and manage compliance items.

 Display documents that were scanned and stored in Document Management. 

 Manage secondary vendors.

 Manually create and delete records of expectation.

NOTE:  Subcontractor Compliance Management is also accessible from the Tasks 
menu in Accounts Payable and from the Contract Control menu in Project Management.



Training Supplement for Version 12.1  Subcontractor Compliance Management

© 2013 Sage Software, Inc. Online Training and Workbooks at www.SageU.com 21

In the Subcontractor Compliance Management window, you select the Job and 
Vendor for which to display compliance items. 

TIP:  If you only select Job in the Subcontractor Compliance Management window, it 
displays compliance items for all vendors associated with the job.

Menu Path—AP: Tasks > Subcontractor Compliance Management

Compliance items are shown in a grid on four separate tabs: Lien Waivers, 
Certified Reports, Insurance, and Misc. 

NOTE:  The Subcontractor Compliance Management window displays compliance 
items for jobs in your current database. When you use Tools > Move > Job to archive a 
job, the associated compliance items are also moved.

If you use Document Management to scan and store images of compliance 
documents, you can display them from this task. When you click the 
Document Management Lookup link, it displays images for the document type of 
the tab that is selected. In other words, if you want to see all the scanned certified 
labor reports that the vendor submitted for the job, select the Certified Reports tab 
first, and then click the Document Management Lookup link.

When you receive compliance documents from your vendor, select the item in the 
grid, and then select the check box in the Received column. The Received Date is 
automatically entered with the current system date but you can change it. 

If your system is set up to warn you or block payments when there are outstanding 
compliance items, this is triggered by any item where the Received check box is 
cleared or it is past the item’s expiration date. Under certain circumstances, you may 
want to process a payment even when it is blocked—you can do so by selecting the 
Override check box.
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Lien Waivers

The Lien Waivers tab displays all the lien waiver records that the system 
automatically generates. 

FOR MORE INFORMATION:  See “System Generated Lien Waiver Records” on page 23.

If you do not allow the software to automatically generate lien waiver records but 
want to track them, you can manually enter the lien waiver information here. To 
create a lien waiver record:

 Click in the last empty row, as indicated by an asterisk in the left border, and 
enter the details.

 Press Tab or Enter to move to the next row to save the record.

You can change the information in any column except for Vendor and 
Commitment. For example, you need to indicate that the lien waiver is a final 
one—change the Type from Conditional Partial to Conditional Final.

FOR MORE INFORMATION:  See “Final Lien Waivers” on page 27.

You can also delete lien waiver records. If you delete lien waiver records, they are 
permanently removed from the database.

If your business process requires you to send lien waiver forms to your vendors to 
sign and return, select a lien waiver record from the grid and click Print to print a 
copy of it. It may be necessary to print several forms for a vendor, perhaps even 
different form types. To do so, select several lien waiver records and click Print. 

NOTE:  The lien waiver document is based on the report format defined in AP Settings 
(see “Accounts Payable Settings,” on page 8) but you can change it at print time. 

You can also email a lien waiver document by clicking Send. You can select 
multiple lien waivers for one email recipient at a time.
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System Generated Lien Waiver Records

When you allow the software to automatically generate lien waiver records, the 
option that you select in AP Settings determines when they are created and the 
amount. Using this example:

Lien waiver records are created as follows. Note that no lien waiver is generated for 
any invoice distribution that is not associated with a job.

Invoice #2012051

Pre-tax Tax Retainage Early 
Payment 
Discount

$10,000.00 $500.00 $650.00 $100.00

Distributions

Commitment Job Pre-tax Tax Retainage Early 
Payment 
Discount

-- -- $2,000.00 $100.00 -- $20.00

-- 13-001 $1,500.00 $75.00 -- $15.00

13001-01 13-001 $3,500.00 $175.00 $350.00 $35.00

13002-01 13-002 $3,000.00 $150.00 $300.00 $30.00

Lien waiver records 
created at: Invoice # Job Commitment

Lien Waiver 
Amount

Invoice Posting 20120501 13-001 -- $1,575.00

20120501 13-001 13001-01 $3,675.00

20120501 13-002 13002-01 $3,150.00

The lien waiver amount is the full amount of the distribution, including tax.

Invoice Selection for 
Payment

20120501 13-001 -- $1,575.00

20120501 13-001 13001-01 $3.325.00

20120501 13-002 13002-01 $2,850.00

The lien waiver amount is the amount selected for payment less retainage.

Invoice Payment 20120501 13-001 -- $1,560.00

20120501 13-001 13001-01 $3,290.00

20120501 13-002 13002-01 $2,820.00

The lien waiver amount is the net amount of the paid distribution.
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If you associate a secondary vendor with a commitment and indicate that lien 
waivers are required, the system generates a lien waiver record for the primary 
vendor and another one for the secondary vendor. However, the amount of the lien 
waiver for the secondary vendor is blank.

If the lien waiver is the final one, the amount is determined by the option selected 
in AP Settings. The final lien waiver amount is either the invoice amount, the 
payment amount, or the revised commitment total.

When you make changes to a posted invoice or invoice payment that affect the 
amount, job, commitment, or date, the software voids the original lien waiver 
records and generates new corrected ones. The new corrected lien waivers are not 
automatically marked as received even if the original ones were when the software 
voids them; use the Subcontractor Compliance Management task to receive 
them.

TIP:  The Receive Lien Waivers button in Tasks > Change Invoices works with receiving 
lien waivers for unposted invoices. 

If your vendor sends you a lien waiver that has a different amount from the one that 
is generated by the software and you want to match the amount in Accounts Payable 
to the actual document, you can change the system generated lien waiver record. 
This does not affect the associated invoice or invoice payment. For example, the 
early payment discount is not deducted from the amount on the lien waiver 
document from your vendor.

Certified Reports

If you set up your software to track weekly certified labor reports, each record on 
the Certified Reports tab indicates the weekly report due date. The 
Certified Report Service creates one record of expectation for each week that the 
report is due, from the Actual start date of the commitment to the current system 
date. 

NOTE:  The Certified Report Service is a utility that runs daily on your server. When you 
configure it, you specify the time that the service runs.

If necessary, you can:

 Create new records. For example, work commenced earlier than the specified 
Actual start date on the commitment and the system did not generate the 
necessary records.

 Delete records. For example, work commenced later than the specified 
Actual start date on the commitment and the system generated records are 
unnecessary.

 Change the Week Ending date if it is incorrect.
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If no report is submitted because no work is performed by the vendor during a 
specific week, select the check box in the No Work column to suppress outstanding 
compliance item warnings.

As the work comes to a completion and the vendor submits the final certified report, 
select the check box in the Final column so that the Certified Report Service stops 
generating future records for the commitment.

WARNING:  If you fail to mark the certified report as final, the system continues to generate 
records of expectation for certified reports for the commitment.

Insurance

On the Insurance tab:

 Select the Commitments sub-tab to display insurance policies on 
commitments.

 Select the Vendors sub-tab to display insurance policies on the vendor. If no 
vendor is selected in the Subcontractor Compliance Management window, it 
lists all the vendors associated with commitments for the job.

You can add, change, or delete insurance information on the Commitments and 
Vendors sub-tabs. This updates the insurance on the commitment or vendor record. 

WARNING:  If you delete insurance information on either sub-tab, it is permanently 
removed from the appropriate commitment or vendor record.

Miscellaneous

The Misc tab displays miscellaneous vendor compliance items as well as those that 
are job specific. These are also items that are defined on the vendor record (AP: 
Setup > Vendors > Insurance/Compliance tab > Misc. Compliance Items).

If a miscellaneous compliance item on the vendor record is marked as required on 
jobs, it is automatically created on the Jobs sub-tab when you commit a 
commitment that is associated with the vendor and the job, as long as:

 There is no jurisdiction for the miscellaneous compliance item on the vendor 
record.

 The jurisdiction for the miscellaneous compliance item on the vendor record 
matches the jurisdiction on the job.



 Subcontractor Compliance Management Sage 300 Construction and Real Estate

26 Local Training From Business Partners © 2013 Sage Software, Inc.

For example, the following miscellaneous compliance items on the vendor are 
required on jobs.

The jurisdiction is assigned to each job as follows.

When a commitment is created and committed for each job, the following 
miscellaneous job specific compliance items are created for the vendor:

You can add, change, or delete information on the Vendors sub-tab. This updates 
the information on the vendor record. 

WARNING:  If you delete an item on the Vendors sub-tab, it is permanently removed from 
the vendor record.

Miscellaneous Compliance Item Jurisdiction

Trade license OR

Trade license WA

Signed contract

Job Jurisdiction

12-001 OR

12-002 WA

12-003 ID

Job Miscellaneous Compliance Item

12-001 Trade license

Signed contract

12-002 Trade license

Signed contract

12-003 Signed contract



Training Supplement for Version 12.1  Subcontractor Compliance Management

© 2013 Sage Software, Inc. Online Training and Workbooks at www.SageU.com 27

Final Lien Waivers

Unless indicated, the conditional and unconditional lien waivers that the software 
generates are partial ones.

To create final lien waivers, use one of these methods:

 When you receive a signed lien waiver during invoice entry, you can mark it as 
final. See “Track Lien Waivers” on page 30.

 When you select invoices to pay:

 You can select the Final lien waivers check box. When the selected invoice 
distributions are paid, the lien waivers are marked as final.

Menu Path—Tasks > Select Invoices to Pay > On-screen List

 Select the invoice distribution and click Detail On, and then select the 
Create final lien waiver check box. Or, click Other and select 
Final Lien Waiver.
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When you use one of the above methods to generate final lien waivers, the amount 
depends on the option selected in AP Settings, see “Accounts Payable Settings” on 
page 8.

You can also use the Subcontractor Compliance Management task to indicate 
that a lien waiver record is the final one—select either Conditional Final or 
Unconditional Final as the Type. You may need to change the lien waiver amount.

NOTE:  When a conditional lien waiver for a secondary vendor is marked final for a 
commitment, the system no longer generates additional conditional lien waivers for that 
particular secondary vendor associated with the commitment. 

Final Compliance Approval

There may be some compliance requirements that are only necessary when the 
subcontractor’s work is done. For example, you want to hold back paying the last 
10% of the commitment amount until the work has been inspected and approved.

You specify the vendor types that require final compliance approval and enter the 
final compliance approval percentage on the job. In the example below, the final 
compliance approval is 10%.
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A punch list should be completed to ensure that the work is satisfactory. Because 
this miscellaneous compliance item is only due at the end of the job, it is marked as 
Required for Final Compliance.

When you have paid 90% of the revised commitment total, the software prevents 
you from making further payments until you select the 
Final Compliance Approval check box on the commitment setup.

TIP:  If you use final compliance approval, the software prevents you from paying the full or 
partial final amount even if the Block payment of invoice warning is disabled in 
AP Settings.

If you have not marked the punch list as received yet, a warning appears when you 
select the Final Compliance Approval check box on the commitment setup. You 
must select Tasks > Subcontractor Compliance Management to receive 
outstanding compliance items.
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Compliance Management Workflow Options

There is no prescribed workflow for managing compliance. Your company’s 
business process determines your procedure for compliance tracking.

You may use Tasks > Subcontractor Compliance Management to receive and 
manage compliance items, or you may do so during various Accounts Payable 
workflow tasks.

Some workflow options are listed below.

Track Lien Waivers

If you file a preliminary lien notice:

 On the commitment setup, click the Record Pre-liens button. Enter the details 
about the pre-lien, and then click Generate.

 Or, in the Subcontractor Compliance Management window, select the
Lien Waiver tab and create a new record with the type Pre-lien.

Lien waiver records with the type Pre-lien are automatically marked as received.

NOTE:  You can customize the field name JC Pre-lien in Custom Descriptions.
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If your vendors submit a signed conditional lien waiver form when they send you 
their invoice:

 Set up AP Settings to create partial conditional lien waivers at Invoice posting.

 During invoice entry, complete and accept the invoice distributions, and then 
click Receive Lien Waivers.

 In the Quick Receive Lien Waivers window, select the Received check box for 
each lien waiver. If the lien waiver is the final one, also select the Final check 
box.

 When you post the invoice, it creates a lien waiver record for the invoice and 
marks it as received.

If you send your vendors a conditional lien waiver to sign after your invoice 
payment selection:

 Set up AP Settings to create a partial conditional lien waiver at
Invoice payment selection.

 Complete your invoice payment selection in Select Invoices to Pay.

 Use Tasks > Subcontractor Compliance Management to print or email lien 
waiver forms to your vendors to sign.

 When you receive the signed forms, use the Subcontractor Compliance 
Management task to mark them as received.

TIP:  To prevent paying vendors who have not returned signed lien waiver documents, set 
up AP Settings to Block payment of invoice when there are outstanding lien waivers.

Track Weekly Certified Labor Reports

You should have received all the certified labor reports by their due dates before you 
pay the vendor. You can set up AP Settings to warn you of missing past due reports 
during invoice entry or invoice payment selection, and receive the items from the 
Compliance Warning window.

The example below demonstrates how the system warns you of outstanding 
compliance items during invoice payment selection. When you select invoices to 
pay by using an on-screen list, you see a compliance icon next to vendors, invoices, 
and distributions that are out of compliance. Click Compliance Management to 
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open the Compliance Warning window, and then click Compliance Management 
to receive these compliance items.
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Moving From a Previous Software Version

If you already use a prior version of the software to track insurance and lien waivers, 
read this section to learn how the upgrade to version 12.1 affects you.

Insurance on Commitments

After you upgrade to version 12.1, the insurance on existing commitments is not 
considered to be out of compliance. They are neither marked Required nor are they 
marked Received, even if the check box Insurance certified received is selected 
on the commitment prior to the software upgrade. 

AP Settings is automatically configured to display a warning message for out of 
compliance insurance during invoice entry. You can change the warning settings as 
needed, see “Compliance Warning Settings,” on page 10.

Lien Waivers

If your software is already set up to create lien waivers in a prior version, it 
continues to do so after you upgrade—there is no disruption to lien waivers being 
generated. Your software continues to generate unconditional lien waivers only for 
the vendors that are already set up to do so. 

If you want to continue using lien waivers as before, there is no need to make any 
changes to your setup except to disable the warning message during invoice entry—
read the next topic, Lien Waiver Setup.

Lien Waiver Setup

If you already use lien waivers in a previous version, your software is automatically 
setup as follows after upgrading to version 12.1:

 In AP Settings > Compliance Settings, on the Unconditional Lien Waiver 
tab:

 It is automatically set up to create partial lien waivers at 
Invoice payment.

 The Enable lien waivers on all vendors based on job compliance settings 
check box is automatically cleared.

 The amount type for final lien waivers that the software generates is 
Payment amount.

 For existing vendors with the Create lien waivers check box selected, they are 
automatically set up with the Create lien waivers for this vendor based on job 
settings check box selected.
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 For existing jobs that are set up to produce lien waivers:

 All the vendor types are selected.

 If there is already a lien waiver minimum specified, it is automatically 
carried over for all vendor types.

 In addition, AP Settings is automatically configured to display a warning 
message for outstanding lien waivers during invoice entry. 

To change your setup to use the new compliance management features in version 
12.1, read the various topics in this handout, starting with “Set Up Your Software 
For Compliance Tracking” on page 7.

Lien Waiver Records

In previous versions of the software, lien waivers are stored in the database tables 
named APL_CURRENT__LIEN_WAIVER and 
APL_HISTORY__LIEN_WAIVER. In version 12.1, lien waiver records are 
created and stored in a new database table named 
JCM_MASTER__LIEN WAIVER. When you upgrade your data, the software 
retains a copy of the records in the old tables and creates a copy in the new table.

WARNING:  If you have moved closed jobs to an archive data folder but still have lien 
waivers for these jobs in the current data folder, you should move the associated lien 
waivers to the same archive data folder as the closed jobs before you upgrade to version 
12.1.

Lien waivers that were marked as returned prior to version 12.1 are as marked as 
received after the upgrade.

Clear Lien Waivers and Change Lien Waivers are removed from the Accounts 
Payable Tasks menu. To view or manage lien waivers that were created before 
upgrading to version 12.1, use the Subcontractor Compliance Management task.

Lien Waiver Reports

Lien waiver reports that were shipped with the prior versions of the software—
AP Lien Waivers.rpt and AP Lien Waivers with Detail.rpt— are removed from the 
Accounts Payable Reports menu and from the Reports folder. 

WARNING:  If you want to retain these report designs, you should save them to another 
location before you upgrade to version 12.1.

There are several new lien waiver reports that ship with version 12.1. You can use 
these new reports to print a combination of the lien waiver records that were 
upgraded from a previous software version and new lien waiver records that you 
create.

If you use custom reports to print lien waivers and the designs are based on the old 
database table called APL_CURRENT__LIEN_WAIVER:



Training Supplement for Version 12.1  Subcontractor Compliance Management

© 2013 Sage Software, Inc. Online Training and Workbooks at www.SageU.com 35

 You can still print them for lien waiver records that were created before the 
software upgrade.

 You must create new custom reports if you want to print them for lien waiver 
records created in version 12.1.

You can use either Sage 300 Construction and Real Estate Report Designer or 
SAP Crystal Reports to create new lien waiver reports. However, if you want to 
create a report that combines lien waiver records with other compliance records 
such as certified report or miscellaneous compliance items, you should use 
SAP Crystal Reports.
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Quick Setup Guide

Use the tables in this section to help you set up the software to track compliance.

Customize Field Names

The table below lists fields that you can customize to meet your company’s 
compliance requirements.

Use File > Company Settings > Custom Descriptions to change a field name or 
to create a customized list for a field.

Field Name Usage Reference Your Customization

AP Vendor Type 1 Used to categorize 
vendors. You specify 
compliance requirements 
by vendor type for each 
job.

page 11

page 15
AP Vendor Type 2

AP Vendor Type 3

AP Vendor Type 4

AP Custom 1 Insurance type on Vendor 
and Commitment.

page 13

page 33
AP Custom 2

AP Jurisdiction May be used on 
miscellaneous 
compliance items and 
defined on job.

page 14

page 16

AP Misc Compliance 
Type

Create a list of 
miscellaneous 
compliance items.

JC Pre-lien Type of compliance form. page 30

JC Sec Vend Chkbx May be used to track an 
item on secondary 
vendors.

page 19

JC Release Recvd May be used to track an 
item on secondary 
vendors.

page 19
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Insurance

Lien Waivers

Use these steps as a guide to set up the software to automatically generate lien 
waivers.

Setup Comments Reference

1. Custom Descriptions Create up to two additional types of 
insurance that vendors are required 
to maintain.

2. Vendor Setup Enter the details of a vendor’s 
insurance policies.

page 13

3. Commitment Setup Enter insurance requirements on the 
commitment if the vendor is 
obligated to maintain a separate 
policy for the job.

page 18

NOTES:  If you want the system to warn you when there are vendors or commitments 
with insurance that is out of compliance, define the warning settings in AP Settings—see 
page 10.

Setup Comments Reference

1. AP Settings Define settings for when lien waivers 
are generated.

page 8

2. Vendor Setup May need to specify the vendors for 
which lien waivers are generated—
dependent on AP Settings.

page 11

3. Job Setup Specify the vendor types which are 
required to submit lien waivers and 
the minimum amount.

page 15

4. Commitment Setup Only necessary if you want the 
system to automatically generate 
lien waivers for secondary vendors.

page 17

NOTES:  If you want the system to warn you when there are lien waivers that are 
outstanding, define the warning settings in AP Settings—see page 10.
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Weekly Certified Labor Reports

Use these steps as a guide to set up the software to automatically establish when 
weekly certified labor reports are due.

Miscellaneous Compliance Items

Use these steps as a guide to set up the software to track other compliance items in 
the system.

Setup Comments Reference

1. Certified Reports 
Service

Enable this service on the server 
where your software is installed so 
that the system can generate 
records which indicate when 
certified reports are due.

page 8

2. AP Settings Define the date type that is used to 
determine if certified reports are past 
due.

page 10

3. Job Setup Specify the vendor types which are 
required to submit certified reports 
and the week ending day of the 
certified week.

page 15

4. Commitment Setup Enter the actual start date of the job. page 17

NOTES:  If you want the system to warn you when there are certified reports that are 
outstanding, define the warning settings in AP Settings—see page 10.

Setup Considerations Reference

1. Custom Descriptions Create a list of miscellaneous 
compliance items. If you use 
jurisdictions, create a list as well.

page 14

2. Vendor Setup Define the miscellaneous 
compliance items that are required 
and the jurisdiction (if applicable).

page 14

3. Job Setup If you use jurisdictions, define the 
jurisdiction for the job.

page 16

4. Commitment Setup Set up a commitment for the vendor 
and the job to generate 
miscellaneous compliance items for 
the vendor that are job specific.

page 25

NOTES:  If you want the system to warn you when there are outstanding miscellaneous 
compliance items, define the warning settings in AP Settings—see page 10.
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