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Version 18.11 Release Notes

This document provides important information regarding new features and changes in your Sage
Estimating 18.11 software. Read these release notes carefully before installing Sage
Estimating 18.11.
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Installation Notes

System Requirements
For current information about supported operating systems, Internet browsers, Microsoft®

SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article ID 91688, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=91688.

Note:While Sage Estimating continues to support 32-bit Microsoft SQL Server, the installation
package includes only the 64-bit Microsoft SQL Server Express application.

Installing Sage Estimating
Refer to the Installation and Administration Guide for complete instructions on installing the software
and migrating or upgrading your data.

Before Upgrading

Important!
If you are upgrading to version 18.11 and you are using third-party software that integrates with
Sage Estimating, check with the third-party software vendor to ensure that their software is
compatible with version 18.11 before you upgrade.

Installation Notes
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New Features and Enhancements

Sage Estimating version 18.11 includes the following significant improvements:

l Improved sort sequences and item sequences

l Improved spreadsheet layouts

l Unit conversions

l Added Assembly column on the spreadsheet

l Ability to add or edit items from the Item Table List

l Ability to create or edit a variable "on the fly" from the Variable List

l Ability to add or edit formulas from the Formula List

l Ability to copy standard databases and address books

l Ability to fill down overline values to items

l Improved Report Manager

l More enhancements to the ribbonmenus

In addition, it includes the following miscellaneous improvements:

l Disabled Common Language Runtime in SQL Server off for new installations

l Other changes and improvements

The following sections describe these changes in more detail.

New Features and Enhancements
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Improved sort sequences and item sequences

Unlimited sort sequences

With version 18.11, you are no longer limited to the sort sequences that come with Sage Estimating.
You can now create and share as many sort sequences as you want to display estimate information.

A new Edit Estimate Spreadsheet Sequences window provides a modernized interface that enables
you to easily add or remove sequences, or duplicate an existing sequence. All the spreadsheet
sequences for the estimate are listed in a grid, where you can edit the sequence names, change the
color for the sequence, specify whether a particular sequence appears in the spreadsheet, and
change the order in which the sequence tabs appear:

From this window, you open a new Edit Grouping Hierarchy window, where you define the sort levels
to include in each sequence:

New Features and Enhancements
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Note: The new Edit Standard Item Sequences window and its corresponding Grouping Hierarchy
window are very similar, except that they offer sorting levels appropriate for items.

In addition, you can now use a new shortcut menu (available when you right-click a sequence tab) to
specify attributes for a sequence tab "on the fly," or to open the Edit Estimate Spreadsheet
Sequences window:

Improved sort sequences and item sequences
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For more information about setting up sort sequences, see the Estimating help.

Improved spreadsheet layouts
In v18.11, we simplified the process of editing and applying spreadsheet layouts.

New ribbon icons now provide direct access to several Layout functions, making it much easier to:

l Select a layout from a list of layouts, applying it immediately to the current estimate.

l With a single click, save changes you made to the current spreadsheet display "on the fly."

l Save the current layout using a different name.

l Open the current layout directly in a new Edit Spreadsheet Layout Details window.

These icons are located in a new Spreadsheet Display group on the Home tab:

Important! Spreadsheet layouts are no longer tied to a single spreadsheet sequence. You can
apply your layouts to any sequence in your estimates, and you can add or edit layouts even when
no estimates are open.

The newEdit Spreadsheet Layouts windows

We have replaced the Modify Layouts window with a new, modernized Edit Spreadsheet Layouts
window with innovations similar to the modernized Edit WBS Values, Edit Locations, and Edit
Subcategories windows introduced in recent versions.

New Features and Enhancements
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You use the Edit Spreadsheet Layouts window to:

l View a list of existing layouts (shared and personal) that are available to you.

l Add a new layout.

l Open a new Edit Spreadsheet Layout Details window to define layout details.

l Remove an existing layout, or restore a layout you removed. (You can restore a layout only if
you have not yet closed the window since deleting the layout.)

l Share a selected custom layout with other Sage Estimating (SQL) users, or simply keep it for
your own use.

To open the Edit Spreadsheet Layouts window:

l On the ribbon, from the Spreadsheet Display group on the Home tab, click Layouts.

l In classic view, click View > Spreadsheet Layout, or click on the toolbar.

Note: You are no longer prompted to save layout changes when you close the Edit Spreadsheet
Layouts window (formerly Modify Layouts window).

You use the new Edit Spreadsheet Layout Details window to define a new or existing layout, or to
duplicate an existing layout.

You open this window by clicking the ellipsis [ ] button on the Edit Spreadsheet Layout window for
the layout you want to edit.

Improved spreadsheet layouts
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For more information about defining layouts using this new workflow, see the Estimating help.

Unit conversions
Sage Estimating (SQL) v18.11 enables you to convert unit quantities from imperial to metric (or
metric to imperial), and to display converted quantities within an estimate.

Sage Estimating includes predefined unit conversions, but you can add your own conversions, and
edit or remove existing built-in conversions. You use the new Edit Unit Conversions window to
specify conversion factors to use when converting defined units of measure from imperial to metric,
and from metric to imperial units.

When you want to convert and display estimate quantities from the current measurement system to
imperial or metric, select the Convert quantities to check box on the Miscellaneous tab of the
Estimate Settings window.

Sage Estimating (SQL) then:

l Automatically converts the estimate to the system of measurement you select, calculating
amounts using the conversion factors you specify in the Edit Unit Conversions window.

l Displays an additional set of columns in the spreadsheet that shows the converted quantities
and prices. (The conversions are marked by asterisks in the column headings.)

For more information, see the Estimating help.

New Features and Enhancements
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Added Assembly column on the spreadsheet
In version 17.13, to prepare for improvements to sort sequences in version 18.11, we removed the
Assembly overline from sort sequences. Because assembly overlines were no longer available in the
spreadsheet, our customers could no longer review assemblies from the spreadsheet.

In version 18.11, we have restored the assembly column so that you can again review assemblies
from the spreadsheet.

Thank you Paul D. for this suggestion!

Ability to add or edit item tables from the Item Table List
You can now quickly edit or create an item table before you assign it in the Edit Assembly window.
You no longer have to leave the Edit Assembly window in the middle of a takeoff, open the Database
Item Table window, and then add or edit the item table you want to assign to the assembly takeoff.

When you open the Item Table List from the Edit Assembly window, the following two new buttons
provide direct access to item tables:

l Click [Create Item Table] if you want to create a new table.

l Click [Edit Item Table] if you want to edit a selected existing table in the Edit Item Table
window.

You can also use the following shortcuts to open the Edit Item Table window:

l Right-click the list of item tables, and then select the Create Item Table or Edit Item Table
option from a shortcut menu.

l Press Alt-E to edit a selected table.

l Press Alt-C to create a new table

When you next open the Item Table window, it displays the last item table that you created or edited
as the default.

Ability to create or edit a variable from the Variable List
At Sage, we’re always looking for ways to make your workflow more efficient. In version 18.11, you
can create or edit a variable "on the fly" when you are working in windows or tables that require
variables that do not yet exist or require modification. You no longer have to close the window you

Added Assembly column on the spreadsheet
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were working in, create or edit the variable you need, reopen the window to select the variable, and
then continue what you were doing.

Now, you can use new buttons (or shortcut menu items) in the Variable List window to open the
Database Variable window and the Adding Database Formula window, where you can edit or add a
variable, respectively, with no disruption to your workflow.

For example, when working in the Formula Tables window, right-click a Return Value cell, and then
click Use Variable from the shortcut menu.

When the Variable List window opens, you can:

l Edit an existing variable by selecting it on the list, clicking [Edit Variable], and then using the
Database Variable window to change its properties. You can also right-click the variable, and
then select Edit Variable from the shortcut menu.

l Add a new variable by clicking [Create Variable], and then entering the properties for the new
variable in the Adding Database Variable window. You can also right-click anywhere in the list,
and then select Create Variable from the shortcut menu.

After adding or editing the variable, close the window to return to the Variable List, and continue
working.

New Features and Enhancements
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Ability to add or edit formulas from the Formula List
You can now add a formula more easily to a formula table by adding it from the Formula List window.
Two new buttons provide direct access to formula tables:

l Click [Create formula] to create a new formula.

l Click [Edit Item Table] to edit a selected existing formula.

You can also right-click the list of formulas, and then select the Create Formula or Edit Formula
option from a shortcut menu.

Ability to copy standard databases and address books
You can now back up and restore a standard database or address book to a different name,
provided you follow these steps:

1. Use the Estimating Management Console Backup tool to back up the database.

2. Using Windows Explorer, browse to the file location, and rename the backup file (with the BAK
extension).

3. Use the Estimating Management Console Restore tool to restore the renamed backup file.

Important! It is vital to rename the BAK file and to restore it using the Estimating Management
Console. If you attempt to restore the database using SQL Server Management Studio, Estimating
treats the renamed database as a duplicate, and does not display it in the database catalog.

The new database is then listed correctly in all Estimating applications.

Ability to copy overline or item values to other items
On the spreadsheet, you can easily copy the description, quantity, unit, or notes from an overline or
an item to selected items below the overline.

On the spreadsheet:

1. Select the Description, Quantity, Unit, or Notes cell you want to copy from, and then drag to
select the items in the same column that you want to copy to.

2. Right-click your selection, and then click Fill Down.

Note: If the estimate uses the Automatically calculate overline quantities option, and:

Ability to add or edit formulas from the Formula List

Release Notes 11



l The target cell is in an item row, only the absolute quantity is copied to that cell, regardless of
whether the source cell is aggregated or a lump sum.

l The target cell is in an overline row, if the source cell is aggregated, the target cell will be
aggregated, even if the target cell was initially aggregated.

If the initial cell contains a lump sum amount, all the cells you are copying to, including overlines,
are updated with the fixed amount.

Improved Report Manager

Custom Report Sequences

In the Estimating Management Console, you can now generate reportable views based on a
specified spreadsheet sequence. You are no longer restricted to generating report views for the
active sequence.

In the Report Manager, before you generate report data, you can use the new Sequence option to
specify whether to use the selected estimate’s current sequence or a different sequence that you

specify. When you select Custom for the option, and then click the browse button beside the
option, a new Edit Grouping Hierarchy window appears, enabling you to specify how to organize the
information on the report:

New Features and Enhancements
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From the left-hand pane, you select fields that represent the information you want to appear on the
report, clicking the right arrow key to add each one as a report element on the right-hand pane. You
can reorder the selected elements by selecting a field, and then using the up and down arrows to
place them in the desired sequence in the right pane. When you have finished customizing the report
hierarchy, click [OK].

Improved Report Manager
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More enhancements to the ribbonmenus
We are continuing the initiative begun in version 17 to reorganize the ribbon, making it more logical
and consistent.

It also includes a brand new group of Adjustment icons on the Data tab (CCI and Addons) and new
layout-related icons on the Home tab (Save, Save As, and Edit).

To compare the locations of functions on the new ribbon with the ribbon in version 16, see the help
topic,Comparing the new ribbon with the ribbon in version 16.11.

The Common Language Runtime in SQL Server is turned off
for new installations
Beginning with version 18.11, Sage Estimating no longer uses the Common Language Runtime
(CLR) integration feature in the Microsoft SQL Server instance, resulting in improved security and
performance, and a more future-proof application. For this reason, the CLR integration feature is not
automatically turned on for new installations of Sage Estimating.

When you upgrade from earlier versions of Sage Estimating, however, the upgrade process does not
turn off the CLR integration feature. This means that the CLR integration remains turned on for your
SQL Server instance. If you do not use the CLR integration feature in SQL Server and you have
database security concerns, you should consider turning off this feature.

For instructions on turning on or turning off CLR integration for Microsoft SQL Server, see Enabling
CLR Integration in the Microsoft developer’s library at https://technet.microsoft.com/en-
us/library/ms131048(v=sql.105).aspx.

Other changes and improvements
Version 18.11 includes the following additional improvements:

l WBS codes can now accept a maximum of 20 characters.

l Standard databases that you restore using Microsoft SQL Server are automatically added to
your Estimating system when you next run Estimating, provided you have administrator
privileges and your estimates and address book are configured properly for the current
version.

New Features and Enhancements
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Previously, you had to search for the restored database in the Estimating Management
Console, and add it manually to your Estimating system.

l In the Estimating Management Console, you can no longer remove a standard database from
the Estimating database catalog. (While the Remove option is no longer available for the
database catalog, you can continue to use the Delete option if you want to delete a standard
database entirely. If you want to move a database out of the instance, you can back it up, and
then restore it to a new instance.)

l We have added support for SQL Server 2017.

l We have improved the performance of the Scan Estimate tool, which now runs more
efficiently.

Other changes and improvements
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Fixes Since the Previous Version

Version 18.11 includes the following fixes:

l You can reinstall a database that you previously installed and renamed.

l Turning Alternates on or off no longer clears information from the Estimate Information page.

l The Edit Spreadsheet Layout window (formerly the Layouts window) now opens properly,
without lagging.

l WBS codes are now listed properly in the Item Sort window.

l Means Integrator assigns the Labor factor to Equipment when you copy city cost indexes.

l You can successfully merge estimates, even if you choose not to combine matching items.

l When you export to Sage 300 Job Cost, the units in the resulting estimate are correct.

l When you change a calculated amount on the spreadsheet to a lump sum amount, and then
undo your change, the program also reverts any background color and font specified for lump
sum amounts back to the original background and color.

l You no longer receive an error message during takeoff when you substitute an item that uses
a different unit of measure than the original item.

l When Alternates are turned on for an estimate, the column headers no longer flicker when you
switch between sequences.

l Generating a Spreadsheet report for a range of values generates data as expected.

l When entering notes for models, you can now enter line breaks in the notes.

l In the Variable List window, you can create a variable from the Variable List.

Fixes Since the Previous Version
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Known Issues

Compatibility with eTakeoff Bridge
eTakeoff Bridge is not compatible with version 18.11 by the Sage Estimating release date. We expect
a compatible version of eTakeoff Bridge to be available by mid-August 2018.

Caution! If you use eTakeoff Bridge, do not install Sage Estimating version 18.11 until a
compatible version of eTakeoff Bridge is available.

Problem withmigrated standard databases and estimates
that used a job cost interface
If you migrated a standard database or an estimate that was integrated with job cost in Estimating
(Pervasive), you need to perform a few additional steps to reintegrate the standard database or
estimate in Estimating (SQL).

Important! Until you perform the following steps, you will receive a Job Cost Interface Failure error
when you try to edit job cost settings for a standard database or an estimate that was integrated
with job cost in Estimating (Pervasive). Also, you will not be able to use the standard database with
new interfaced estimates in Estimating (SQL).

Before you start

You need to be assigned to a role with Run Management Console, Edit Standard Databases, Edit
Standard Database Settings permissions, and have Edit access to the estimates to use the job cost
system setup.

For each migrated standard database that used a job cost interface in Estimating
(Pervasive):

1. In the Estimating Management Console, click Standard DB on the ribbon.

2. In the Standard Database Catalog, select the migrated standard database.

Known Issues
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3. In the details pane to the right, click [Edit]

4. In the Job Cost Information section:

a. For the Job cost system name, select either None or Text.

b. Click [Save].

c. For the Job cost system name, select Sage 300 Construction.

d. Click [Setup], and enter the job cost settings required to reintegrate the database with
Sage 300 Construction.

5. Click [Save].

6. Repeat steps 2 through 5 for each migrated estimate that used the job cost interface in
Estimating (Pervasive).

Note: To edit estimates, you must first click Estimates on the ribbon, and then (in step 2) you
select the estimate from the Estimate Catalog.

You cannot install Microsoft SQL Server from a folder that
has a long path
If you start the Sage Estimating installer from a path that is longer than 100 characters, you will
receive the error “Exit Code 9 The storage control block address is invalid” in the log file when you
install the software.

To avoid this error, move the Install folder higher up in the tree (closer to the root folder).

Checking in a Standard Database from the Database Editor
Closes the Database for Concurrent Users
You can work on a Standard database in the Estimating Database Editor while other users perform
takeoff using the same database in the Sage Estimating program.

When you try to check in the Standard database while other users have the database open, you
receive a warning that if you continue to check the file in, there may be unpredictable results for the
concurrent users.

If you continue to check the file in despite the warning, the Estimating program stops working for the
other users. However, the data is not corrupted and the Estimating program is not damaged.

Known Issues
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Further Assistance

Sage provides you with the following resources for obtaining assistance with Sage Estimating.

Online Help
The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To view Help in the Sage Estimating software, click the Help button or icon, or press [F1] to display
the Help topic for that window.

For more information about using the online Help, see the Sage Estimating Help.

Training
Sage University offers online and classroom training sessions to help you get the most out of your
Sage Estimating software. To access Sage University, visitwww.sageu.com.

You can also get access to Sage University from the File menu by selecting Help > Sage University.

Technical Assistance
When you need assistance, refer to the Knowledgebase article How do I get technical support for
Sage Estimating? to determine which service works best for you.

Submitting Enhancement Requests
We want to hear your suggestions for improving the software. To send us your comments, click on
the File menu button and select Help > Submit Product Idea.

Further Assistance
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