The upgrade process consists of three steps:

1. Preparing your data for upgrading
2. Upgrading your data to version 2016
3. Converting your data to version 2016

This document contains the information you will need to upgrade and convert your data based on the version of your data. Proceed to the applicable section as follows:

- Upgrading from Version 2015 to Version 2016 on page 2
- Upgrading from Version 2014 to Version 2016 on page 8
- Upgrading from Version 2013 to Version 2016 on page 14
- Upgrading from Version 4.50 to Version 2016 on page 20
- Upgrading from Version 4.45 to Sage 100 Premium Version 2016 on page 26
- Upgrading from Version 4.40 to Version 2016 on page 31
- Upgrading from Version 4.30 to Version 2016 on page 37
- Upgrading from Version 4.20 to Version 2016 on page 45
- Upgrading from Version 4.10 to Version 2016 on page 53
- Upgrading from Version 4.00 or 4.05 to Version 2016 on page 60
Upgrading from Version 2015 to Version 2016

When upgrading to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2015 data for upgrading. This should be done for each company you plan to upgrade.

1. Process all pending credit card transactions.

2. Print and update all journals and registers. Failure to do so may result in loss of data.

3. Create a backup of your version 2015 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

4. If you use the Purchase Order module, you will have the option to start retaining purchase order history and to create history using records in your Purchase Order data entry files.

   If you plan to create history, consider running the following utilities to clear out records that you do not want to include:

   - Purge Completed Purchase Orders
   - Purge Obsolete Purchase Orders

   For more information on the utilities, see the help system.
Upgrading from Version 2015 to Version 2016

---

5. Rebuild all data files.
   - If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild Key Files and Rebuild Sort File utilities.
   - If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

You must answer Yes to all recalculation questions.

6. Print all customized form definitions.

7. If you are using eBusiness Manager, back up any templates, .htm files, and the IW folder before uninstalling the previous version of the Web Engine.

8. If you are upgrading Sage 100 Premium, configure your firewall to allow access to port number 1433 on the server with your version 2015 installation. Port 1433 is the default SQL Server port.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 2, you are now ready to migrate your data to your version 2016 system.

1. If you are upgrading Sage 100 Standard or Advanced, select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate your data.

   If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard using one of the methods below, and follow the steps in the Wizard.

   - If you are using Windows Server 2008, start the Parallel Migration Wizard from the Sage program group on the Start menu.
   - If you are using Windows Server 2012, start the Parallel Migration Wizard from the Start window.

The Migration Wizard will back up the Sage 100 SQL databases for your prior version of Sage 100, copy the backup files to the server where Sage 100 2016 SQL Server instance is installed, and then restore them in the new location. Administrative rights are required for both your prior version of Sage 100 and for version 2016. The person running the Migration Wizard must have rights to the following administrative share:

\sourceserver-name\c$
If local security settings prevent the wizard from migrating the databases, use SQL Server Management Studio to back up the MAS_System and company databases that you want to migrate. Then copy the .BAK files to the ..\MSSQL\Data folder on the server where the Sage 100 2016 SQL Server instance is installed.

2. After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

3. Review security tasks for new features in version 2016. Review ODBC security if it is used.

4. If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

5. If you customized your Desktop, review the customizations on the Custom toolbar.

**Data Conversion Checklist**

After completing the steps in the Pre-Upgrade Checklist on page 2 and the Upgrade Checklist on page 3, you are now ready to convert your data to version 2016.

1. If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2. Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.

   If the Purchase Order module is set up for a company, a window with options for retaining purchase order history appears. You can set up the feature and create history during data conversion or you can do so at a later time.

3. If you were not processing transactions through Sage Payment Solutions but plan to start doing so, contact your Sage Payment Solutions account executive to convert the Sage Exchange Vault-only account created during conversion to a processing account.

4. If your system is integrated with Sage CRM, go into CRM Server Options, and update the following information as needed.
   - Integration server port ID
Upgrading from Version 2015 to Version 2016

- Sage CRM SQL server name
- Sage CRM SQL database name

The server name and database name should reference the mirror installation that you created for integration with Sage 100 2016. For more information on this process, refer to the Installing Sage CRM chapter in the Sage 100 Installation and System Administrator’s Guide.

After updating the information, load the Sage CRM data.

5. If you synchronize payroll data between Sage Payroll Services and your general ledger, please contact Sage Payroll Services Support for assistance with resetting the link for your Sage 100 company.

You must complete this step before you can synchronize payroll data. This applies only if Sage Payroll Services is selected in the Payroll Service field in Sage Payroll Services Options.

6. Update customized panels by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

7. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

8. Verify that all module links are functional by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

9. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

10. Test your customized Crystal reports and forms.

If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

**NOTE**
Before modifying the graphical forms or reports found on the Custom Reports menu, you must be proficient in the use of SAP Crystal Reports.
To run the utility, select File menu > Run, and then type SYWFCU. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the Sage 100 Installation and System Administrators’ Guide for more information.

11___ If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

12___ If you use Sage Intelligence Reporting, create a new repository for use with Sage 100 2016 and import any custom reports into it. For detailed instructions, see Upgrading Sage Intelligence Reporting on page 67.

13___ If dictionary changes were made to any files used for import and export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

14___ Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

15___ Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

16___ To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine.
Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpup\wwwroot\images folder and restart the IIS Web service.

17. To unhide the Custom Financials menu and tasks, select File menu > Run and type *unhidegl* in the Run Program window.

18. Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.

19. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

20. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

21. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

22. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

23. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

24. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 2014 to Version 2016

When upgrading to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2014 data for upgrading. This should be done for each company you plan to upgrade.

1. Process all pending credit card transactions.

2. Print and update all journals and registers. Failure to do so may result in loss of data.

3. Create a backup of your version 2014 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

4. If you use the Purchase Order module, you will have the option to start retaining purchase order history and to create history using records in your Purchase Order data entry files.

   If you plan to create history, consider running the following utilities to clear out records that you do not want to include:

   - Purge Completed Purchase Orders
   - Purge Obsolete Purchase Orders

   For more information on the utilities, see the help system.

NOTE: You must print and update all journals and registers to prevent possible data loss during data upgrade.
5. Rebuild all data files.
   - If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild Key Files and Rebuild Sort File utilities.
   - If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

   You must answer Yes to all recalculation questions.

6. Print all customized form definitions.

7. If you are using eBusiness Manager, back up any templates, .htm files, and the IW folder before uninstalling the previous version of the Web Engine.

8. If you are upgrading Sage 100 Premium, configure your firewall to allow access to port number 1433 on the server with your version 2014 installation. Port 1433 is the default SQL Server port.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 8, you are now ready to migrate your data to your version 2016 system.

1. If you are upgrading Sage 100 Standard or Advanced, select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate your data.

   If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard using one of the methods below, and follow the steps in the Wizard.

   - If you are using Windows Server 2008, start the Parallel Migration Wizard from the Sage program group on the Start menu.
   - If you are using Windows Server 2012, start the Parallel Migration Wizard from the Start window.

   The Migration Wizard will back up the Sage 100 SQL databases for your prior version of Sage 100, copy the backup files to the server where Sage 100 2016 SQL Server instance is installed, and then restore them in the new location. Administrative rights are required for both your prior version of Sage 100 and for version 2016. The person running the Migration Wizard must have rights to the following administrative share: \(\backslash\{\text{sourceserver-name}\}\backslash c\$
Upgrading from Version 2014 to Version 2016

If local security settings prevent the wizard from migrating the databases, use SQL Server Management Studio to back up the MAS_System and company databases that you want to migrate. Then copy the .BAK files to the ..\MSSQL\Data folder on the server where the Sage 100 2016 SQL Server instance is installed.

2___ After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

3___ Review security tasks for new features in version 2016. Review ODBC security if it is used.

4___ If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

5___ If you customized your Desktop, review the customizations on the Custom toolbar.

Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 8 and the Upgrade Checklist on page 9, you are now ready to convert your data to version 2016.

1___ If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2___ Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.

   If the Purchase Order module is set up for a company, a window with options for retaining purchase order history appears. You can set up the feature and create history during data conversion or you can do so at a later time.

3___ If you were not processing transactions through Sage Payment Solutions but plan to start doing so, contact your Sage Payment Solutions account executive to convert the Sage Exchange Vault-only account created during conversion to a processing account.

4___ If your system is integrated with Sage CRM, go into CRM Server Options, and update the following information as needed.
   - Integration server port ID
Upgrading from Version 2014 to Version 2016

- Sage CRM SQL server name
- Sage CRM SQL database name

The server name and database name should reference the mirror installation that you created for integration with Sage 100 2016. For more information on this process, refer to the Installing Sage CRM chapter in the Sage 100 Installation and System Administrator's Guide.

After updating the information, load the Sage CRM data.

5. Update customized panels by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

6. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

7. Verify that all module links are functional by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

8. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

9. Test your customized Crystal reports and forms.

If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

To run the utility, select File menu > Run, and then type SYWFCU. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.
If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the Sage 100 Installation and System Administrators’ Guide for more information.

10 If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

11 If you use Sage Intelligence Reporting, create a new repository for use with Sage 100 2016 and import any custom reports into it. For detailed instructions, see Upgrading Sage Intelligence Reporting on page 67.

12 If dictionary changes were made to any files used for import and export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

13 Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

14 Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

15 To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpub\wwwroot\Images folder and restart the IIS Web service.

16 To unhide the Custom Financials menu and tasks, select File menu > Run and type *unhidegl in the Run Program window.
17____  Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.

18____  If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

19____  To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

20____  If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

21____  If you had task folders in your My Tasks area, re-create your Public and Private task folders.

22____  Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

23____  Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 2013 to Version 2016

When upgrading to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2013 data for upgrading. This should be done for each company you plan to upgrade.

1. Process all pending credit card transactions.

2. Print and update all journals and registers. Failure to do so may result in loss of data.

3. Create a backup of your version 2013 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

4. Rebuild all data files.
   - If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild Key Files and Rebuild Sort File utilities.
   - If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

   You must answer Yes to all recalculation questions.

5. Print all customized form definitions.

6. If you are using eBusiness Manager, back up any templates, .htm files, and the IW folder before uninstalling the previous version of the Web Engine.

7. If you are upgrading Sage 100 Premium, configure your firewall to allow access to port number 1433 on the server with your version 2013 installation. Port 1433 is the default SQL Server port.

NOTE
You must print and update all journals and registers to prevent possible data loss during data upgrade.
Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 14, you are now ready to migrate your data to your version 2016 system.

1. If you are upgrading Sage 100 Standard or Advanced, select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate your data.
   
   If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard using one of the methods below, and follow the steps in the Wizard.
   
   - If you are using Windows Server 2008, start the Parallel Migration Wizard from the Sage program group on the Start menu.
   - If you are using Windows Server 2012, start the Parallel Migration Wizard from the Start window.
   
   The Migration Wizard will back up the Sage 100 SQL databases for your prior version of Sage 100, copy the backup files to the server where Sage 100 2016 SQL Server instance is installed, and then restore them in the new location. Administrative rights are required for both your prior version of Sage 100 and for version 2016. The person running the Migration Wizard must have rights to the following administrative share:
     \(\{\text{sourceserver-name}\}\backslash c$.
   
   If local security settings prevent the wizard from migrating the databases, use SQL Server Management Studio to back up the MAS_System and company databases that you want to migrate. Then copy the .BAK files to the ..\MSSQL\Data folder on the server where the Sage 100 2016 SQL Server instance is installed.

2. After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

3. Review security tasks for new features in version 2016. Review ODBC security if it is used.

4. If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

5. If you customized your Desktop, review the customizations on the Custom toolbar.
Upgrading from Version 2013 to Version 2016

Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 14 and the Upgrade Checklist on page 15, you are now ready to convert your data to version 2016.

1. If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2. Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.

3. If you were not processing transactions through Sage Payment Solutions but plan to start doing so, contact your Sage Payment Solutions account executive to convert the Sage Exchange Vault-only account created during conversion to a processing account.

4. If your system is integrated with Sage CRM, go into CRM Server Options, and update the following information as needed.
   - Integration server port ID
   - Sage CRM SQL server name
   - Sage CRM SQL database name
   The server name and database name should reference the mirror installation that you created for integration with Sage 100 2016. For more information on this process, refer to the Installing Sage CRM chapter in the Sage 100 Installation and System Administrator's Guide.
   After updating the information, load the Sage CRM data.

5. Update customized panels by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

6. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.
7. Verify that all module links are functional by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

8. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

9. Test your customized Crystal reports and forms.

   If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

   To run the utility, select File menu > Run, and then type SYWFCU. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

   If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.

   If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

   If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the Sage 100 Installation and System Administrators’ Guide for more information.

10. If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

11. If you use Sage Intelligence Reporting, create a new repository for use with Sage 100 2016 and import any custom reports into it. For detailed instructions, see Upgrading Sage Intelligence Reporting on page 67.

12. If dictionary changes were made to any files used for import and export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.
To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

13. Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

14. Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

15. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine. Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpup\wwwroot\images folder and restart the IIS Web service.

16. To unhide the Custom Financials menu and tasks, select File menu > Run and type *unhidegl* in the Run Program window.

17. Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.

18. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

19. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

20. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

21. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

22. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.
23. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 4.50 to Version 2016

When upgrading to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for upgrading Sage CRM in the *Sage 100 Installation and System Administrators Guide*.

Pre-Upgrade Checklist

You must prepare your version 4.50 data for upgrading. This should be done for each company you plan to upgrade.

1. Process all pending credit card transactions.
2. Print and update all journals and registers. Failure to do so may result in loss of data.
3. Create a backup of your version 4.50 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.
4. If you use credit card processing, verify that you have a valid credit card encryption key in Company Maintenance for proper conversion of credit card data.
5. Rebuild all data files.
   - If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild Key Files and Rebuild Sort File utilities.
   - If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.
   You must answer Yes to all recalculation questions.
6. Print all customized form definitions.
7. If you are using eBusiness Manager, back up any templates, .htm files, and the IW folder before uninstalling the previous version of the Web Engine.

**NOTE**
You must print and update all journals and registers to prevent possible data loss during data upgrade.
8. If you are upgrading Sage 100 Premium, configure your firewall to allow access to port number 1433 on the server with your version 4.50 installation. Port 1433 is the default SQL Server port.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 20, you are now ready to migrate your data to your version 2016 system.

1. If you are upgrading Sage 100 Standard or Advanced, select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to migrate your data.

   If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard using one of the methods below, and follow the steps in the Wizard.

   • If you are using Windows Server 2008, start the Parallel Migration Wizard from the Sage program group on the Start menu.
   
   • If you are using Windows Server 2012, start the Parallel Migration Wizard from the Start window.

   The Migration Wizard will back up the Sage 100 SQL databases for your prior version of Sage 100, copy the backup files to the server where Sage 100 2016 SQL Server instance is installed, and then restore them in the new location. Administrative rights are required for both your prior version of Sage 100 and for version 2016. The person running the Migration Wizard must have rights to the following administrative share:

   \{sourceserver-name}\c$

   If local security settings prevent the wizard from migrating the databases, use SQL Server Management Studio to back up the MAS_System and company databases that you want to migrate. Then copy the .BAK files to the ..\MSSQL\Data folder on the server where the Sage 100 2016 SQL Server instance is installed.

2. After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

3. Review security tasks for new features in version 2016. Review ODBC security if it is used.

4. If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

5. If you customized your Desktop, review the customizations on the Custom toolbar.
Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 20 and the Upgrade Checklist on page 21, you are now ready to convert your data to version 2016.

1____ If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage Exchange Vault account, the Credit Card Conversion To Sage Exchange Vault Time Estimate window appears. This window provides an estimate of how long it will take to transfer the credit card data. This estimate is based on benchmark test results, but results will vary based on Internet connection speed, network traffic, and the number of customer credit card records stored in your system.

You may be able to decrease the estimate by updating credit card transactions and purging credit card data. If this window appears, click Yes to proceed with data conversion or click No to stop the conversion process.

Additional time is required to convert company data after the credit card records are transferred; that time is not included in the estimate shown on the window.

3____ Verify that credit card processing is enabled for each company in Company Maintenance if credit cards were previously being processed using Sage Payment Solutions. For more information, see Set Up the Credit Card Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions but plan to start doing so, contact your Sage Payment Solutions account executive to convert the Sage Exchange Vault-only account created during conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, and update the following information as needed.

- Integration server port ID
- Sage CRM SQL server name
Upgrading from Version 4.50 to Version 2016

- **Sage CRM SQL database name**

  The server name and database name should reference the mirror installation that you created for integration with Sage 100 2016. For more information on this process, refer to the Installing Sage CRM chapter in the *Sage 100 Installation and System Administrator's Guide*.

  After updating the information, load the Sage CRM data.

- **Update customized panels** by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

- **If you have customers with national accounts and credit cards are assigned to the sold-to customers**, review those records to determine whether the credit card information should be manually transferred to the bill-to customer.

- **If you have customized Advanced Lookup Engine (ALE) lookups**, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

- **Verify that all module links are functional** by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

- **Review your Payroll Tax Tables**. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

- **Test your customized Crystal reports and forms**.

  If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

  To run the utility, select File menu > Run, and then type SYWFCU. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

  If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.

**NOTE**

Before modifying the graphical forms or reports found on the Custom Reports menu, you must be proficient in the use of SAP Crystal Reports.
If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the *Sage 100 Installation and System Administrators’ Guide* for more information.

11 If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

12 If you use Sage Intelligence Reporting, create a new repository for use with Sage 100 2016 and import any custom reports into it. For detailed instructions, see Upgrading Sage Intelligence Reporting on page 67.

13 If dictionary changes were made to any files used for import and export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

14 Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

15 Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

16 To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpup\wwwroot\Images folder and restart the IIS Web service.

17 To unhide the Custom Financials menu and tasks, select File menu > Run and type "unhidegl" in the Run Program window.
18. Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.

19. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

20. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

21. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

22. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

23. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

24. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 4.45 to Sage 100 Premium Version 2016

Before upgrading your data to version 2016, you must perform a parallel installation and run the Parallel Migration utility from the Windows Start menu > All Programs > Sage program group. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

Pre-Upgrade Checklist

You must prepare your version 4.45 data for upgrade. This should be done for each company you plan to upgrade. Several steps should be completed by a SQL Server® administrator.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in loss of data.

3____ Create a backup of your version 4.45 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

4____ Rebuild all data files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.

5____ Print all customized form definitions.

6____ If you are upgrading Sage 100 Premium, configure your firewall to allow access to port number 1433 on the server with your version 4.45 installation. Port 1433 is the default SQL Server port.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on this page, you are now ready to migrate your data to your version 2016 system.

1____ Start the Parallel Migration Wizard using one of the methods below, and follow the steps in the wizard to migrate your data.

- If you are using Windows Server 2008, start the Parallel Migration Wizard from the Sage program group on the Start menu.
- If you are using Windows Server 2012, start the Parallel Migration Wizard from the Start window.

NOTE
You must print and update all journals and registers to prevent possible data loss during data upgrade.

WARNING
You must have administrator rights for the server with the installation you are migrating from and the server with your version 2016 installation.
Upgrading from Version 4.45 to Sage 100 Premium Version 2016

The Migration Wizard will back up the Sage 100 SQL databases for your prior version of Sage 100, copy the backup files to the server where Sage 100 2016 SQL Server instance is installed, and then restore them in the new location. Administrative rights are required for both your prior version of Sage 100 and for version 2016. The person running the Migration Wizard must have rights to the following administrative share: `\{sourceserver-name}\c$

If local security settings prevent the wizard from migrating the databases, use SQL Server Management Studio to back up the MAS_System and company databases that you want to migrate. Then copy the .BAK files to the `.\MSSQL\Data` folder on the server where the Sage 100 2016 SQL Server instance is installed.

2. After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.


4. If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: `Logon=True`.

5. If you customized your Desktop, review the customizations on the Custom toolbar.

Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 26 and the Upgrade Checklist on page 26, you are now ready to convert your data to version 2016.

1. If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2. Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.
If your data contains credit card records that will be transferred to a Sage Exchange Vault account, the Credit Card Conversion To Sage Exchange Vault Time Estimate window appears. This window provides an estimate of how long it will take to transfer the credit card data. This estimate is based on benchmark test results, but results will vary based on Internet connection speed, network traffic, and the number of customer credit card records stored in your system.

You may be able to decrease the estimate by updating credit card transactions and purging credit card data. If this window appears, click Yes to proceed with data conversion or click No to stop the conversion process.

Additional time is required to convert company data after the credit card records are transferred; that time is not included in the estimate shown on the window.

3. Verify that credit card processing is enabled for each company in Company Maintenance if credit cards were previously being processed using Sage Payment Solutions. For more information, see Set Up the Credit Card Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions but plan to start doing so, contact your Sage Payment Solutions account executive to convert the Sage Exchange Vault-only account created during conversion to a processing account.

4. Update customized panels by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

5. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

6. Verify that all module links are functional by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

7. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with 'Bill To' Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type "Utl") to populate the sales order bill-to address information with the bill-to customer’s address information.
8. Test your modified SAP Crystal reports and forms. Use SAP Crystal Reports Designer to modify reports as needed.

You must either be logged on using a Windows account that has read access to the applicable SQL Server database, or you must have a separate SQL Server authenticated logon ID and password. Integrated Security is used by default; if your Windows account does not have rights to the database, a logon dialog box appears, allowing you to enter a different logon ID and password for database access.

Before modifying forms or the standard Crystal reports found on the Custom Reports menu, you must be proficient in the use of SAP Crystal Reports.

9. If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

10. If you use Sage Intelligence Reporting, create a new repository for use with Sage 100 2016 and import any custom reports into it. For detailed instructions, see Upgrading Sage Intelligence Reporting on page 67.

11. If dictionary changes were made to any files used for import or export jobs created in the Visual Integrator module, those jobs will need to be manually updated.

   To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. Verify that the imported field names are consistent with the new file layouts.

12. Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

13. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in Accounts Payable Options.

14. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to set up tax schedules.

15. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

16. To unhide the Custom Financials menu and tasks, select File menu > Run and type *unhidegl in the Run Program window.
Upgrading from Version 4.45 to Sage 100 Premium Version 2016

17. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

18. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

19. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

20. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

21. Test all printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

22. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 4.40 to Version 2016

When upgrading to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 4.40 data for upgrading. This should be done for each company you plan to upgrade.

1. Process all pending credit card transactions.

2. Print and update all journals and registers. Failure to do so may result in loss of data.

3. Create a backup of your version 4.40 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

4. If you are upgrading from version 4.40 Product Update 4 and higher, verify that you have a valid credit card encryption key in Company Maintenance for proper conversion of credit card data.

5. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.

6. Print all customized form definitions.

7. If you are using eBusiness Manager, back up any templates, .htm files, and the IW folder before uninstalling the previous version of the Web Engine.
Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 31, you are now ready to migrate your data to your version 2016 system.

1. From your version 2016 installation, select Library Master Utilities menu > Pre Migration, and then enter the source path and company code for your version 4.40 system. Run the reports and utilities that appear. It is critical that you address everything listed in the Pre Migration window before you proceed to the next step. If nothing appears, no action is required.

2. Select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to upgrade your data.

3. After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

4. Review security tasks for new features in version 2016. Review ODBC security if it is used.

5. If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

6. If you customized your Desktop, review the customizations on the Custom toolbar.

Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 31 and the Upgrade Checklist on page 32, you are now ready to convert your data to version 2016.

1. If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2. Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.
If your data contains credit card records that will be transferred to a Sage Exchange Vault account, the Credit Card Conversion To Sage Exchange Vault Time Estimate window appears. This window provides an estimate of how long it will take to transfer the credit card data. This estimate is based on benchmark test results, but results will vary based on Internet connection speed, network traffic, and the number of customer credit card records stored in your system.

You may be able to decrease the estimate by updating credit card transactions and purging credit card data. If this window appears, click Yes to proceed with data conversion or click No to stop the conversion process.

Additional time is required to convert company data after the credit card records are transferred; that time is not included in the estimate shown on the window.

3. Verify that credit card processing is enabled for each company in Company Maintenance if credit cards were previously being processed using Sage Payment Solutions. For more information, see Set Up the Credit Card Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions but plan to start doing so, contact your Sage Payment Solutions account executive to convert the Sage Exchange Vault-only account created during conversion to a processing account.

4. If your system is integrated with Sage CRM, go into CRM Server Options, and update the following information as needed.
   - Integration server port ID
   - Sage CRM SQL server name
   - Sage CRM SQL database name

   The server name and database name should reference the mirror installation that you created for integration with Sage 100 2016. For more information on this process, refer to the Installing Sage CRM chapter in the Sage 100 Installation and System Administrator’s Guide.

   After updating the information, load the Sage CRM data.

5. Update customized panels by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.
6. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

7. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with 'Bill To' Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type "Utl") to populate the sales order bill-to address information with the bill-to customer's address information.

8. Verify that all module links are functional by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

9. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

10. Test your customized Crystal reports and forms.

    If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

    To run the utility, select File menu > Run, and then type SYWFCU. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

    If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.

    If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

    If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the Sage 100 Installation and System Administrators’ Guide for more information.
11. If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

12. If you use Sage Intelligence Reporting, create a new repository for use with Sage 100 2016 and import any custom reports into it. For detailed instructions, see Upgrading Sage Intelligence Reporting on page 67.

13. If dictionary changes were made to any files used for import or export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

14. Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

15. Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

16. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpub\wwwroot\images folder and restart the IIS Web service.

17. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in Accounts Payable Options.

18. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to set up tax schedules.

19. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

20. To unhide the Custom Financials menu and tasks, select File menu > Run and type *unhidegl* in the Run Program window.
21. Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.

22. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

23. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

24. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

25. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

26. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

27. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 4.30 to Version 2016

When upgrading to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 4.30 data for upgrading. This should be done for each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in loss of data.

3____ Create a backup of your version 4.30 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

4____ If you use credit card processing and are upgrading from version 4.30 Service Update 18 through 23, verify that you have a valid credit card encryption key in Company Maintenance for proper conversion of credit card data.

5____ Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ Correct and apply all negative tiers before upgrading. For more information, see Correct Negative Tiers in the Help system.

9. If you created reports using Business Insights Reporter, review the report names in the Business Insights Reporter selection window. If there are multiple reports with similar names, copy the reports within Business Insights Reporter and rename each report.


For more information, see Copy a Report in the Help system.

10. If you are using eBusiness Manager, back up any templates, .htm files, and the IW folder before uninstalling the previous version of the Web Engine.

### Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 37, you are now ready to migrate your data to your version 2016 system.

1. From your version 2016 installation, select Library Master Utilities menu > Pre Migration, and then enter the source path and company code for your version 4.30 system. Run the reports and utilities that appear.

   a. Select Item Code Validation Report to display missing item codes from your Warehouse Detail, Item Costing, and Transaction Detail files.

   - To fix the files, in your version 4.30 data, use Inventory Management Main menu > Inventory Maintenance.

   b. Select Inventory File Comparison Report to compare the quantity in your warehouse, tier, and transaction inventory data files.

   - Run this report by warehouse and save as an audit trail.
   - To correct any quantities, run the Inventory Balancing Utility.

   c. Select Inventory Balancing Utility to balance your inventory quantities.

   - Run this utility for each warehouse.
   - In the Action column, select the action to perform for each item, or apply a specific action based on valuation type.
Upgrading from Version 4.30 to Version 2016

- If the valuation is LIFO, FIFO, Lot, or Serial, in the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.

- If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.

- For more information, see Balance Inventory Quantities in the Help system.

- Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

2. Select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to upgrade your data.

3. After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

4. Review security tasks for new features in version 2016. Review ODBC security if it is used.

5. If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

6. If you customized your Desktop, review the customizations on the Custom toolbar.
Data Conversion Checklist

After completing the Pre-Upgrade Checklist on page 37 and the Upgrade Checklist on page 38, you are now ready to convert your data to version 2016.

1. If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2. Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.

   If your data contains credit card records that will be transferred to a Sage Exchange Vault account, the Credit Card Conversion To Sage Exchange Vault Time Estimate window appears. This window provides an estimate of how long it will take to transfer the credit card data. This estimate is based on benchmark test results, but results will vary based on Internet connection speed, network traffic, and the number of customer credit card records stored in your system.

   You may be able to decrease the estimate by updating credit card transactions and purging credit card data. If this window appears, click Yes to proceed with data conversion or click No to stop the conversion process.

   Additional time is required to convert company data after the credit card records are transferred; that time is not included in the estimate shown on the window.

3. Verify that credit card processing is enabled for each company in Company Maintenance if credit cards were previously being processed using Sage Payment Solutions. For more information, see Set Up the Credit Card Processing Module in the Help system.

   If you were not processing transactions through Sage Payment Solutions but plan to start doing so, contact your Sage Payment Solutions account executive to convert the Sage Exchange Vault-only account created during conversion to a processing account.

4. If your system is integrated with Sage CRM, go into CRM Server Options, and update the following information as needed.
   
   - Integration server port ID
   - Sage CRM SQL server name
Upgrading from Version 4.30 to Version 2016

- **Sage CRM SQL database name**

  The server name and database name should reference the mirror installation that you created for integration with Sage 100 2016. For more information on this process, refer to the Installing Sage CRM chapter in the *Sage 100 Installation and System Administrator’s Guide*.

  After updating the information, load the Sage CRM data.

5. Update customized panels by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

6. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

7. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with ‘Bill To’ Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

8. Verify that all module links are functional by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

9. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

10. Test your customized Crystal reports and forms.

    If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

**NOTE**

Before modifying the graphical forms or reports found on the Custom Reports menu, you must be proficient in the use of SAP Crystal Reports.
To run the utility, select File menu > Run, and then type SYWFCU. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the Sage 100 Installation and System Administrators’ Guide for more information.

11 If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

12 If dictionary changes were made to any files used for import or export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

13 Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

14 Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

15 To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpup\wwwroot\images folder and restart the IIS Web service.
16. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in Accounts Payable Options.

17. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to set up tax schedules.

18. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

19. To unhide the Custom Financials menu and tasks, select File menu > Run and type *unhidegl* in the Run Program window.

20. If you had the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

21. Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.

22. Compare the following version 4.30 and 2016 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report.

23. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

24. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

25. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

26. If you had task folders in your My Tasks area, re-create your Public and Private task folders.
Upgrading from Version 4.30 to Version 2016

27. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

28. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 4.20 to Version 2016

When upgrading to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 4.20 data for upgrading. This should be done for each company you plan to upgrade.

1. Process all pending credit card transactions.
2. Print and update all journals and registers. Failure to do so may result in loss of data.
3. Create a backup of your version 4.20 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.
4. If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, 941 forms, and governmental reports, perform the conversion to version 2015 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some data may require editing.
5. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.
6. Print all customized form definitions.
7. Correct and apply all negative tiers before upgrading. For more information, see Correct Negative Tiers in the Help system.
Upgrading from Version 4.20 to Version 2016

9. If you created reports using Business Insights Reporter, review
the report names in the Business Insights Reporter selection
window. If there are multiple reports with similar names, copy the
reports within Business Insights Reporter and rename each
report.

For example, if you have reports named CustomerSalesReport,
CustomerSalesReport2, and CustomerSalesReport3, copy
CustomerSalesReport2 as “SalesReportForCustomers” and
CustomerSalesReport3 as “ReportForCustomerSales.”

For more information, see Copy a Report in the Help system.

10. If you are using eBusiness Manager, back up any templates, .htm
files, and the IW folder before uninstalling the previous version of
the Web Engine.

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 45, you are now
ready to migrate your data to your version 2016 system.

1. From your version 2016 installation, select Library Master Utilities
menu > Pre Migration, and then enter the source path and
company code for your version 4.20 system. Run the reports and
utilities that appear.

   a. Select Item Code Validation Report to display missing item
codes from your Warehouse Detail, Item Costing, and
Transaction Detail files.

      • To fix the files, in your version 4.20 data, use Inventory
        Management Main menu > Inventory Maintenance.

   b. Select Inventory File Comparison Report to compare the
quantity in your warehouse, tier, and transaction inventory data
files.

      • Run this report by warehouse and save as an audit trail.
      • To correct any quantities, run the Inventory Balancing Utility.

   c. Select Inventory Balancing Utility to balance your inventory
quantities.

      • Run this utility for each warehouse.
      • At the Action column, select the action to perform for each
        item, or apply a specific action based on valuation type.
If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.

If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.

For more information, see Balance Inventory Quantities in the Help system.

d  Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

2___ Select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to upgrade your data.

3___ If you are printing bar codes, ensure that the Azalea fonts are installed on the workstation. The fonts can be installed from the WkSetup\Azalea folder where Sage 100 is installed on your server.

4___ After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

5___ Review security tasks for new features in version 2016. Review ODBC security if it is used.

6___ If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

7___ If you customized your Desktop, review the customizations on the Custom toolbar.
Data Conversion Checklist

After completing the Pre-Upgrade Checklist on page 45 and the Upgrade Checklist on page 46, you are now ready to convert your data to version 2016.

1____ If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2____ Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage Exchange Vault account, the Credit Card Conversion To Sage Exchange Vault Time Estimate window appears. This window provides an estimate of how long it will take to transfer the credit card data. This estimate is based on benchmark test results, but results will vary based on Internet connection speed, network traffic, and the number of customer credit card records stored in your system.

You may be able to decrease the estimate by updating credit card transactions and purging credit card data. If this window appears, click Yes to proceed with data conversion or click No to stop the conversion process.

Additional time is required to convert company data after the credit card records are transferred; that time is not included in the estimate shown on the window.

3____ Verify that credit card processing is enabled for each company in Company Maintenance if credit cards were previously being processed using Sage Payment Solutions. For more information, see Set Up the Credit Card Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions but plan to start doing so, contact your Sage Payment Solutions account executive to convert the Sage Exchange Vault-only account created during conversion to a processing account.

4____ If your system is integrated with Sage CRM, go into CRM Server Options, and update the following information as needed.

- Integration server port ID
- Sage CRM SQL server name
- Sage CRM SQL database name

The server name and database name should reference the mirror installation that you created for integration with Sage 100 2016. For more information on this process, refer to the Installing Sage CRM chapter in the Sage 100 Installation and System Administrator’s Guide.

After updating the information, load the Sage CRM data.

5. Update customized panels by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

Re-customize the customized libraries for all modules other than Accounts Payable, Accounts Receivable, Bank Reconciliation, eBusiness Manager, General Ledger, Job Cost, Material Requirements Planning, Payroll, Return Merchandise Authorization, Sales Order, TimeCard, and Work Order.

6. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

7. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with ‘Bill To’ Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

8. Verify that all module links are functional by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

9. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

10. Test your customized Crystal reports and forms.

If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

NOTE Before modifying the graphical forms or reports found on the Custom Reports menu, you must be proficient in the use of SAP Crystal Reports.
To run the utility, select File menu > Run, and then type **SYWFCU**. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the Sage 100 Installation and System Administrators’ Guide for more information.

11. If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

12. If dictionary changes were made to any files used for import or export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

13. Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

14. Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

15. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpup\wwwroot\images folder and restart the IIS Web service.
16. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in Accounts Payable Options.

17. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to set up tax schedules.

18. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

19. To unhide the Custom Financials menu and tasks, select File menu > Run and type `unhidegl` in the Run Program window.

20. If you had the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

21. Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.

22. Compare the following version 4.20 and 2016 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report.

23. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

24. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

25. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

26. If you had task folders in your My Tasks area, re-create your Public and Private task folders.
Upgrading from Version 4.20 to Version 2016

27. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

28. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What’s New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 4.10 to Version 2016

Prior to upgrading your version 4.10 data to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

Pre-Upgrade Checklist

You must prepare your version 4.10 data for upgrading. This should be done for each company you plan to upgrade.

1. Process all pending credit card transactions.
2. Print and update all journals and registers. Failure to do so may result in loss of data.
3. Create a copy of your version 4.10 MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.
4. If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, 941 forms, and governmental reports, perform the conversion to version 2015 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some data may require editing.
5. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.
6. Print all customized form definitions.
7. Correct and apply all negative tiers before upgrading. For more information, see Correct Negative Tiers in the Help system.
If you created reports using Business Insights Reporter, review the report names in the Business Insights Reporter selection window. If there are multiple reports with similar names, copy the reports within Business Insights Reporter and rename each report.


For more information, see Copy a Report in the Help system.

If you are using eBusiness Manager, back up any templates, .htm files, and the IW folder before uninstalling the previous version of the Web Engine.

### Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 53, you are now ready to migrate your data to your version 2016 system.

1. From your version 2016 installation, select Library Master Utilities menu > Pre Migration, and then enter the source path and company code for your version 4.10 system. Run the reports and utilities that appear.
   a. Select Item Code Validation Report to display missing item codes from your Warehouse Detail, Item Costing, and Transaction Detail files.
      - To fix the files, in your version 4.10 data, use Inventory Management Main menu > Inventory Maintenance.
   b. Select Inventory File Comparison Report to compare the quantity in your warehouse, tier, and transaction inventory data files.
      - Run this report by warehouse and save as an audit trail.
      - To correct any quantities, run the Inventory Balancing Utility.
   c. Select Inventory Balancing Utility to balance your inventory quantities.
      - Run this utility for each warehouse.
      - At the Action column, select the action to perform for each item, or apply a specific action based on valuation type.

The tasks that appear in the Pre Migration window are based on the version of your data.

The quantities in your warehouse, tier, and transaction inventory data files must match before you can upgrade your data to version 2016.
Upgrading from Version 4.10 to Version 2016

- If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.

- If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.

- For more information, see Balance Inventory Quantities in the Help system.

- Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

2. Select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to upgrade your data.

3. If you are printing bar codes, ensure that the Azalea fonts are installed on the workstation. The fonts can be installed from the WkSetup\Azalea folder where Sage 100 is installed on your server.

4. After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

5. Review security tasks for new features in version 2016. Review ODBC security if it is used.

6. If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

7. If you customized your Desktop, review the customizations on the Custom toolbar.
Data Conversion Checklist

After completing the Pre-Upgrade Checklist on page 53 and the Upgrade Checklist on page 54, you are now ready to convert your data to version 2016.

1. If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2. Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage Exchange Vault account, the Credit Card Conversion To Sage Exchange Vault Time Estimate window appears. This window provides an estimate of how long it will take to transfer the credit card data. This estimate is based on benchmark test results, but results will vary based on Internet connection speed, network traffic, and the number of customer credit card records stored in your system.

You may be able to decrease the estimate by updating credit card transactions and purging credit card data. If this window appears, click Yes to proceed with data conversion or click No to stop the conversion process.

Additional time is required to convert company data after the credit card records are transferred; that time is not included in the estimate shown on the window.

3. Update customized panels, by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

Re-customize the customized libraries for all modules other than Accounts Payable, Accounts Receivable, Bank Reconciliation, eBusiness Manager, General Ledger, Job Cost, Material Requirements Planning, Payroll, Return Merchandise Authorization, Sales Order, TimeCard, and Work Order.

4. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.
5. Verify that all module links are functional by selecting Library Master Utilities menu > Link Maintenance Utility. Links that appear in red are broken and will need to be fixed using the Relink button in Link Maintenance Utility. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

6. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with 'Bill To' Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

7. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

8. Test your customized Crystal reports and forms.

   If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

   To run the utility, select File menu > Run, and then type SYWFCU. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

   If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.

   If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

   If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the Sage 100 Installation and System Administrators’ Guide for more information.

9. If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.
Upgrading from Version 4.10 to Version 2016

10. If dictionary changes were made to any files used for import or export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.

To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

11. Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

12. Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

13. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpup\wwwroot\images folder and restart the IIS Web service.

14. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in Accounts Payable Options.

15. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to set up tax schedules.

16. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

17. To unhide the Custom Financials menu and tasks, select File menu > Run and type *unhidegl* in the Run Program window.

18. If you had the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.
19. Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.

20. Compare the following version 4.10 and 2016 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report.

21. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

22. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

23. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

24. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

25. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

26. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading from Version 4.00 or 4.05 to Version 2016

Prior to upgrading your version 4.00 or 4.05 data to version 2016, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to upgrade your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the upgrade process.

Pre-Upgrade Checklist

You must prepare your version 4.00 or 4.05 data for upgrading. This should be done for each company you plan to upgrade.

1. Process all pending credit card transactions.
2. Print and update all journals and registers. Failure to do so may result in loss of data.
3. Create a copy of your version 4.x MAS90 folder, which includes data for all of your companies. Perform this step following your usual backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.
4. If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, 941 forms, and governmental reports, perform the conversion to version 2015 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some data may require editing.
5. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.
6. Print all customized form definitions.
7. Correct and apply all negative tiers before upgrading. For more information, see Correct Negative Tiers in the Help system.
9. If you created reports using Business Insights Reporter, review the report names in the Business Insights Reporter selection window. If there are multiple reports with similar names, copy the reports within Business Insights Reporter and rename each report.


For more information, see Copy a Report in the Help system.

10. If you are using eBusiness Manager, back up any templates, .htm files, and the IW folder before uninstalling the previous version of the Web Engine.

**Upgrade Checklist**

After completing the Pre-Upgrade Checklist on page 60, you are now ready to migrate your data to your version 2016 system.

1. From your version 2016 installation, select Library Master Utilities menu > Pre Migration, and then enter the source path and company code for your version 4.00 or 4.05 system. Run the reports and utilities that appear.

   a. Select Item Code Validation Report to display missing item codes from your Warehouse Detail, Item Costing, and Transaction Detail files.
      
      - To fix the files, in your version 4.00 or 4.05 data, use Inventory Management Main menu > Inventory Maintenance.

   b. Select Inventory File Comparison Report to compare the quantity in your warehouse, tier, and transaction inventory data files.
      
      - Run this report by warehouse and save as an audit trail.
      - To correct any quantities, run the Inventory Balancing Utility.

   c. Select Inventory Balancing Utility to balance your inventory quantities.
      
      - Run this utility for each warehouse.
      - At the Action column, select the action to perform for each item, or apply a specific action based on valuation type.
Upgrading from Version 4.00 or 4.05 to Version 2016

- If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.

- If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.

- For more information, see Balance Inventory Quantities in the Help system.

d  Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

2___ Select Library Master Utilities menu > Parallel Migration. Follow the steps in the wizard to upgrade your data.

3___ If you are printing bar codes, ensure that the Azalea fonts are installed on the workstation. The fonts can be installed from the WkSetup\Azalea folder where Sage 100 is installed on your server.

4___ After the migration is complete, log into Sage 100 2016 as the Administrator. Use the tasks available from the Administrative Tools window to review user security and set up and assign the appropriate roles to your users.

5___ Review security tasks for new features in version 2016. Review ODBC security if it is used.

6___ If you are using Unified Logon and you upgraded your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

7___ If you customized your Desktop, review the customizations on the Custom toolbar.
Data Conversion Checklist

After completing the Pre-Upgrade Checklist on page 60 and the Upgrade Checklist on page 61, you are now ready to convert your data to version 2016.

1. If your company data contains credit card information, verify that the workstation you are using has a working Internet connection to automatically install the Sage Exchange Desktop and transfer credit card records to a Sage Exchange Vault account during conversion. Credit card records must be transferred to a Sage Exchange Vault account before company data can be converted.

2. Select Library Master Main menu > Company Maintenance to convert your data to version 2016. This must be done for each of your companies.

   If your data contains credit card records that will be transferred to a Sage Exchange Vault account, the Credit Card Conversion To Sage Exchange Vault Time Estimate window appears. This window provides an estimate of how long it will take to transfer the credit card data. This estimate is based on benchmark test results, but results will vary based on Internet connection speed, network traffic, and the number of customer credit card records stored in your system.

   You may be able to decrease the estimate by updating credit card transactions and purging credit card data. If this window appears, click Yes to proceed with data conversion or click No to stop the conversion process.

   Additional time is required to convert company data after the credit card records are transferred; that time is not included in the estimate shown on the window.

3. Update customized panels by selecting Custom Office Utilities menu > Update Customized Panels to Current Level. Review the placement of all user-defined fields.

   Re-customize the customized libraries for all modules other than Accounts Payable, Accounts Receivable, Bank Reconciliation, eBusiness Manager, General Ledger, Job Cost, Material Requirements Planning, Payroll, Return Merchandise Authorization, Sales Order, TimeCard, and Work Order.

4. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.
5. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with 'Bill To' Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

6. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

7. Test your customized Crystal reports and forms.

   If you need to troubleshoot issues with customized reports and forms, run the Crystal Form Comparison Report utility to compare your customized reports and forms to the standard ones in version 2016.

   To run the utility, select File menu > Run, and then type SYWFCU. The utility tells you which tables, if any, have been added to a report or form. It does not provide information about formatting changes, such as those affecting fonts, logos, and so forth.

   If you were previously using non-graphical forms, you will need to set them up using SAP Crystal Reports.

   If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see SAP Crystal Reports FAQs in the Help system. If you do not run the wizard now, it will automatically run the first time that someone runs a form or report.

   If you are using Sage 100 Premium, refer to the Converting Reports for Sage 100 Premium section in the Sage 100 Installation and System Administrators’ Guide for more information.

8. If your system has custom reports, review the Custom Reports menus to make sure they are available. If they are not, add them using Report Manager.

9. If dictionary changes were made to any files used for import or export jobs created in the Visual Integrator module, those jobs will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order.
To determine if manual updates are required, review the associated file layout information using the File Layouts and Program Information link on the Resources page of the Desktop. If you are upgrading from Sage 100 Standard or Sage 100 Advanced, review the Data Dictionary Listing accessed from the Visual Integrator Main menu. Verify that the imported field names are consistent with the new file layouts.

10. Review the Paperless Office module configuration for e-mailing statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

11. Review your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

12. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Web Engine. Copy the poweredby.gif image from the MAS90\Images folder to the IIS Inetpup\wwwroot\images folder and restart the IIS Web service.

13. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in Accounts Payable Options.

14. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to set up tax schedules.

15. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

16. To unhide the Custom Financials menu and tasks, select File menu > Run and type *unhidegl* in the Run Program window.

17. If you had the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

18. Print all customized form definitions and compare them to the ones previously printed. Default forms may be erased in the upgrade process.
**Upgrading from Version 4.00 or 4.05 to Version 2016**

19. Compare the following version 4.x and 2016 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report. If you purchased the Return Merchandise Authorization module, after setting up the data files for the first time, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

20. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

21. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

22. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

23. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

24. Install Sage Exchange Desktop on each workstation for each Windows user who needs to access credit card information in Sage 100. Download the installation program from the Sage Exchange Web site at: https://www.sageexchange.com/install

For information on what is new in this release, see the What's New chapter in the Sage 100 2016 Customer Upgrade Guide.
Upgrading Sage Intelligence Reporting

If you use Sage Intelligence Reporting, follow the steps in this document to create a new repository for Sage 100 2016. If you have custom reports, follow the instructions to export custom reports from your prior version of the program and import them into version 2016.

For detailed instructions on each step, see:

- Export Custom Reports on this page
- Create a New Repository on page 68
- Set Up Sage Intelligence Reporting in Sage 100 2016 on page 68
- Import Custom Reports on page 69

Report Compatibility

Reports can be imported only from an earlier version of the program or from another instance of the same version. For example, you can import a report created in version 2013 into version 2016. You cannot import a report created in version 2016 into version 2013.

Reports created in Sage 100 Standard and Sage 100 Advanced are not compatible with Sage 100 Premium. Likewise, reports created in Sage 100 Premium are not compatible with Sage 100 Standard and Sage 100 Advanced.

Export Custom Reports

In your prior version of Sage 100, export all of the custom reports that you want to use in version 2016.

To export custom reports

1. In your prior version of Sage 100, select Sage Intelligence Reporting Main menu > Report Manager.

2. Right-click a report and then click Export Report. (Alternately, select a report and then, on the Tools menu, click Export Report.)

3. Select the location where you want to save the file and then click Save. A file with an AL_ extension is created.

4. Repeat these steps for all custom reports that you want to use in version 2016.
Create a New Repository
Create a shared folder to use as the Sage Intelligence Reporting repository for Sage 100 2016. We recommend using a separate repository for each installation of Sage Intelligence Reporting.

To create a repository
1 Use Windows File Explorer to create a folder in the desired location.
2 Right-click the folder, point to "Share with," and click "Advanced sharing."
3 On the Sharing tab, select the "Share this folder" check box.
4 Enter a share name.
5 Click Permissions.
6 For all applicable users, select the Full Control or Read and Write check boxes.
7 Click OK.
8 If you use reporting trees or distribution settings, copy the following folders from the old repository to the new one:
   - Report Trees
   - Distribution

Set Up Sage Intelligence Reporting in Sage 100 2016
After creating the shared folder, enter its location in Sage 100 2016. If you haven’t already registered your 2016 version of Sage Intelligence Reporting, you will be asked to do so.

To set up Sage Intelligence Reporting
1 In Sage 100 2016, select Sage Intelligence Reporting Main menu > Report Manager.
2 Click File and then click Change.
3 Click Yes in the message window.
4 In the Network Repository Path field, type the UNC path to the shared folder that you created. For example: \ServerName\ReportRepository
5 Click OK.
6 If you receive a message asking you to register Sage Intelligence Reporting, click OK to open the License Manager window.
7 In the Account Number field, enter your Sage customer number.

8 In the Serial Number field, enter your unlocking key. This field is case-sensitive.

9 Click Apply and then click Perform Registration.

**Import Custom Reports**

After creating the new repository and registering Sage Intelligence Reporting, import any custom report files.

**To import custom reports**

1 If you want to create folders to organize your reports, on the Home tab, click Add Folder.

2 Right-click either the Home folder or any custom folder created in step 1, and click Import Report. (Alternately, you can click the Tools tab, and then click Import Report.)

3 Select one of the custom reports that you exported from your prior version.

4 In the Import Report window, in the Target Connection field, select a connection.
   - For consolidated reports, select Sage MAS Consolidation.
   - For any other type of report, select Sage MAS (Auto Connect).

5 In the Report Destination field, select the folder for the report.

6 Click Import.

7 On the Home tab in the Actions group, click Refresh.

8 Repeat these steps for any other custom reports that you exported from your prior version of Sage Intelligence Reporting.

---

**NOTE**

You must own the Sage 100 Intelligence Connector module to generate consolidated reports.