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Upgrading From Version 4.40 or Earlier
Checklists
Appendix A
Appendix B

These checklists provide instructions for migrating your data from your older Sage 
100 installation and then upgrading the data to version 2019.

The upgrade process consists of three steps:

1 Preparing your data for upgrading

2 Upgrading your data to version 2019

3 Converting your data to version 2019

Proceed to the applicable checklist based on the version of Sage 100 that you’re 
upgrading from.

 Upgrading from Version 2018 to Version 2019 on page 2

 Upgrading from Version 2017 to Version 2019 on page 12 

 Upgrading from Version 2016 to Version 2019 on page 22

 Upgrading from Version 2015 to Version 2019 on page 32

 Upgrading from Version 2014 to Version 2019 on page 42

 Upgrading from Version 2013 to Version 2019 on page 52

 Upgrading from Version 4.50 to Version 2019 on page 62

 Upgrading from Version 4.45 to Sage 100 Premium Version 2019 on page 71

Upgrading From Version 4.40 or Earlier
If you are upgrading from Sage 100 version 4.40 or earlier, you must first upgrade to 
version 4.50 and install Product Update 8. The upgrade checklist is included in the 
Sage 100 4.50 Upgrade Guide, which is available here: 
https://cdn.na.sage.com/docs/en/customer/100erp/4_5/open/UpgradeGuide.pdf 
Sage 100 2019 Upgrade Checklist                                                                                                                      Page 1



Upgrading from Version 2018 to Version 2019
Upgrading from Version 2018 to Version 2019
When upgrading to version 2019, you must perform a parallel installation, and use 
the Pre-Migration and Parallel Migration utilities from the Library Master Utilities 
menu to upgrade your data. For more information, consult with your Sage business 
partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2018 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ If you use the Payroll module:

 Update the Payroll Check Register.

 Complete and purge all direct deposit transactions.

Note that you must install the Payroll module in addition to installing 
Sage 100. Payroll is not part of the Sage 100 installation program. To 
avoid the need to run a separate data conversion for Payroll, install the 
module before proceeding to the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and 
Upgrade Guide available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

4____ Create a backup of your version 2018 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

       NOTE 
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 
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Upgrading from Version 2018 to Version 2019
5____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

8____ Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before 
migrating your data. For more information, see the Pre-Migration Utility help.

9____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2018 
installation. Port 1433 is the default SQL Server port.

10____ If you use the Payroll module, you must install it separately. For more 
information, see the Sage 100 Payroll Installation and Upgrade Guide 
available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

Upgrade Checklist 
After completing the Pre-Upgrade Checklist on page 2, you are ready to migrate 
your data to your version 2019 system.

 For Sage 100 Standard or Advanced, use the checklist below. 

 For Sage 100 Premium, see the checklist on page 4.

Upgrade Checklist for Sage 100 Standard and Advanced

1____ Create a backup of your version 2019 MAS90 folder. Creating a backup 
now will save time if you need to revert to the folder’s original sate. 

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to migrate your data. 

3____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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Upgrading from Version 2018 to Version 2019
5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations. 

Upgrade Checklist for Sage 100 Premium 

Use this checklist to migrate your Sage 100 Premium data.

1____ For your Sage 100 2019 installation, create a backup of the following:

 The Sage 100 MAS90 folder

 The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s 
original state. 

2____ Verify that the required rights and permissions are set up on the server(s) 
where SQL Server is installed. If the instance of SQL Server for Sage 100 
2019 is installed on a different server than the instance used for your prior 
version, you must complete these steps on both servers.

a Open the Control Panel, select Administrative Tools, and the select 
Services. 

b In the Services window, locate the SQL Server instance used for Sage 
100 Premium, right click it, and select Properties.  

c In the Properties window, click the Log On tab and select an option. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on the same server as the instance used for your prior 
version of Sage 100 Premium, select Local System Account. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on a different server than the one used for your prior version 
of Sage 100 Premium, select This Account.  

In the account field, enter: \\ServerName\Administrator 

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.

d Apply your changes and then stop and restart the services. 

e If you’re working with more than one server, make sure that all servers 
can access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

WARNING 
You must have 
administrator 
rights for the 
server with your 
prior version of 
Sage 100 and the 
server with your 
version 2019 
installation.
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Upgrading from Version 2018 to Version 2019
3____ Start the Parallel Migration Wizard using one of the methods below, and 
follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012 or later, start the Parallel 
Migration Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two 
SQL Server locations. The hidden shares are used to access the source 
databases to create the .back files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share 
of the destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the 
new SQL Server location and removes the .bak files from both the source 
and destination locations.

If permissions were not set correctly on both servers, you may receive the 
following error: "Error Number : 0x80040e14 Description: Access Denied 5 
or Access Denied 2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

4____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations. 

WARNING 
Clustered drives 
do not allow 
hidden shares. If 
you are using 
clustered drives, 
follow the 
instructions in the 
Manual 
Workaround 
section of article 
number 76993 in 
the Sage 
Knowledgebase.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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Upgrading from Version 2018 to Version 2019
Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 2 and the Upgrade 
Checklist on page 3, you are now ready to convert your data to version 2019.

1____ If your company data contains credit card information, install the latest 
version of Sage Exchange and verify that the workstation you are using has 
a working Internet connection. This is necessary so that credit card records 
can be transferred to a Sage Exchange Vault account during conversion. 
Credit card records must be transferred to a Sage Exchange Vault account 
before company data can be converted.

To install Sage Exchange:

a Start the Sage 100 installation program.

b Select your edition of Sage 100. 

c Click Productivity Applications. 

d Click Install Sage Exchange Desktop to start the installation wizard.

e Proceed through the wizard to install the program.  

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2019. This must be done for each of your companies. 

3____ If you are converting Payroll Data, the Payroll Data Conversion Wizard 
automatically opens. Companies that include Payroll data must be 
converted one by one. You’ll be guided through the following tasks:

 Mapping department numbers. If you use payroll departments and any 
of the departments numbers contain special characters, you must enter 
new department numbers containing only alphanumeric characters to 
replace them. 

 Selecting tax groups from the payroll tax database to replace your 
existing tax codes. If you are using local tax codes, each state and local 
tax code combination will be replaced by one tax group. Depending on 
which tax codes you’re using, the wizard offers suggestions for you to 
review and update as needed. 

 Adding tax groups to tax profiles. Tax profiles are collections of tax 
groups that you assign to employees to determine how their taxes are 
calculated. You can access Tax Profile Maintenance from the wizard to 
create tax profiles.

 Selecting filing statuses from the payroll tax database to replace your 
existing ones. The filing statuses in the database may differ from the 
ones that you are using. The wizard offers suggestions when possible 
for you to review and update as needed. 
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Upgrading from Version 2018 to Version 2019
4____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

5____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2019. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

6____ If you synchronize payroll data between your General Ledger module and 
Sage Payroll Services, verify that your Sage 100 company or companies 
are still linked to the service. 

a Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

b Sign in to Sage Payroll Services. 

c Proceed through the wizard. 

d Review the status messages shown in the Synchronizing Data with 
Sage Payroll Services window.   

If you see a "Synchronization Complete" message, no further action is 
required. 

If you see a "Synchronization failed" message, contact Sage Payroll 
Services Support for assistance with resetting the link. 

7____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

For the Job Cost and Payroll modules, you must manually recreate all of 
your customized panels. User defined fields will be automatically converted. 

8____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.
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Upgrading from Version 2018 to Version 2019
For the Job Cost and Payroll Modules, you must manually recreate all 
custom lookups. 

9____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

10____ If you use the Payroll Module, review the list of enhancements in the Sage 
100 Payroll What’s New guide, available here: 
http://cdn.na.sage.com/docs/en/customer/100erp/2018n/open/Payroll_Upgr
ade.pdf

After reviewing the guide, complete the following tasks:

 Select Payroll > Setup > Earnings Code Maintenance. For each 
earnings code, select a tax rule. 

 Select Payroll > Setup > Deduction Code Maintenance. For each 
pension or cafeteria plan deduction code, select a tax rule.

 Select Payroll > Setup > Company Tax Group Setup. For each tax group 
that you are using:

 Enter the tax ID number for state and local tax groups. For the 
Federal tax group, the tax ID number entered in Company 
Maintenance appears and can only be viewed. 

 Enter the general ledger account numbers to credit with the tax 
amounts withheld from employees’ pay.

 On the Main tab, enter any tax rates that are specific to your 
company and the associated effective dates. 

 On the Taxes tab, in the Tax field, select the tax(es) for the selected 
tax group. The taxes available are based on the selected tax group. 
Note: There may be more than one tax that needs to be set up.

 Select Payroll > Setup > Tax Profile Maintenance. Review the tax 
profiles that were created when converting payroll data, and make 
changes if needed. 

 Select Payroll > Main > Employee Maintenance. On the Taxes tab, enter 
at least one tax profile for each employee. Depending on the tax groups, 
you may need to enter a filing status, a Workers’ Compensation code, or 
other information.

 Also in Employee Maintenance, on the Additional tab, verify that the 
correct selection appears in the Ethnicity/Race field. 
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Upgrading from Version 2018 to Version 2019
 If you are using the security feature in Department Maintenance, you 
must recreate the lists of users who can access each department. 
Select Payroll > Setup > Department Maintenance, and click the 
Security tab.

 To ensure that your system can communicate with the tax calculation 
engine, add the following URL to your browser's trusted sites list: 
spa.na.sage.com

Complete this step on all workstations that will be used to process 
payroll, and also on the server where Sage 100 is installed if the 
Process Tax Calculation on the Server check box is selected in System 
Configuration.  

11____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2019. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

12____ For the Job Cost and Payroll modules, the Crystal Reports Conversion 
Wizard might partially convert your customized forms and reports. Test all of 
your customized forms and reports, and use Crystal Reports Designer to 
manually update or recreate them as needed.  

13____ If Sage 100 2018 is installed on the same computer as an earlier version of 
Sage 100, complete this step to avoid errors when printing forms and 
reports in the earlier version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 
2018 installation to the same folder in the earlier installation. You must 
complete this step on both the server and the workstation.

       NOTE 
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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Upgrading from Version 2018 to Version 2019
14____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

15____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2019 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 77.

16____ For the Job Cost and Payroll modules, recreate all Visual Integrator import 
and export jobs. 

17____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

18____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

19____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

20____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

21____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

22____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

23____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

24____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

25____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

26____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

27____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  
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Upgrading from Version 2018 to Version 2019
To run the utility, select Library Master > Utilities > Build Search Index. 

28____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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Upgrading from Version 2017 to Version 2019
Upgrading from Version 2017 to Version 2019
When upgrading to version 2019, you must perform a parallel installation, and use 
the Pre-Migration and Parallel Migration utilities from the Library Master Utilities 
menu to upgrade your data. For more information, consult with your Sage business 
partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2017 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ If you use the Payroll module:

  Update the Payroll Check Register.

 Complete and purge all direct deposit transactions.

 If you have set up departments, you must have a user account set up 
with access to all departments in all companies. Department access 
must be assigned to individual user logon ID, not by groups. Groups are 
no longer used to manage department access.

Note that you must install the Payroll module in addition to installing Sage 
100. Payroll is not part of the Sage 100 installation program. To avoid the 
need to run a separate data conversion for Payroll, install the module before 
proceeding to the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade 
Guide available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

4____ Create a backup of your version 2017 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

       NOTE 
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

       NOTE 
When converting 
data in version 
2019, you must 
be logged in with 
a user account 
that has access 
to all payroll 
departments; 
otherwise, you 
will not be able to 
complete data 
conversion. 
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Upgrading from Version 2017 to Version 2019
5____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

8____ Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before 
migrating your data. For more information, see the Pre-Migration Utility help.

9____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2017 
installation. Port 1433 is the default SQL Server port. 

10____ If you use the Payroll module, you must install it separately. For more 
information, see the Sage 100 Payroll Installation and Upgrade Guide 
available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

Upgrade Checklist 
After completing the Pre-Upgrade Checklist on page 12, you are ready to migrate 
your data to your version 2019 system.

 For Sage 100 Standard or Advanced, use the checklist below. 

 For Sage 100 Premium, see the checklist on page 14.

Upgrade Checklist for Sage 100 Standard and Advanced

1____ Create a backup of your version 2019 MAS90 folder. Creating a backup 
now will save time if you need to revert to the folder’s original sate. 

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to migrate your data. 

3____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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Upgrading from Version 2017 to Version 2019
5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations. 

Upgrade Checklist for Sage 100 Premium 

Use this checklist to migrate your Sage 100 Premium data.

1____ For your Sage 100 2019 installation, create a backup of the following:

 The Sage 100 MAS90 folder

 The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s 
original state. 

2____ Verify that the required rights and permissions are set up on the server(s) 
where SQL Server is installed. If the instance of SQL Server for Sage 100 
2019 is installed on a different server than the instance used for your prior 
version, you must complete these steps on both servers.

a Open the Control Panel, select Administrative Tools, and the select 
Services. 

b In the Services window, locate the SQL Server instance used for Sage 
100 Premium, right click it, and select Properties.  

c In the Properties window, click the Log On tab and select an option. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on the same server as the instance used for your prior 
version of Sage 100 Premium, select Local System Account. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on a different server than the one used for your prior version 
of Sage 100 Premium, select This Account.  

In the account field, enter: \\ServerName\Administrator 

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.

d Apply your changes and then stop and restart the services. 

e If you’re working with more than one server, make sure that all servers 
can access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

WARNING 
You must have 
administrator 
rights for the 
server with your 
prior version of 
Sage 100 and the 
server with your 
version 2019 
installation.
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Upgrading from Version 2017 to Version 2019
3____ Start the Parallel Migration Wizard using one of the methods below, and 
follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012 or later, start the Parallel 
Migration Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two 
SQL Server locations. The hidden shares are used to access the source 
databases to create the .back files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share 
of the destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the 
new SQL Server location and removes the .bak files from both the source 
and destination locations.

If permissions were not set correctly on both servers, you may receive the 
following error: "Error Number : 0x80040e14 Description: Access Denied 5 
or Access Denied 2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

4____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations. 

WARNING 
Clustered drives 
do not allow 
hidden shares. If 
you are using 
clustered drives, 
follow the 
instructions in the 
Manual 
Workaround 
section of article 
number 76993 in 
the Sage 
Knowledgebase.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 12 and the 
Upgrade Checklist on page 13, you are now ready to convert your data to version 
2019.

1____ If your company data contains credit card information, install the latest 
version of Sage Exchange and verify that the workstation you are using has 
a working Internet connection. This is necessary so that credit card records 
can be transferred to a Sage Exchange Vault account during conversion. 
Credit card records must be transferred to a Sage Exchange Vault account 
before company data can be converted.

To install Sage Exchange:

a Start the Sage 100 installation program.

b Select your edition of Sage 100. 

c Click Productivity Applications. 

d Click Install Sage Exchange Desktop to start the installation wizard.

e Proceed through the wizard to install the program.  

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2019. This must be done for each of your companies. 

3____ If you are converting Payroll Data, the Payroll Data Conversion Wizard 
automatically opens. Companies that include Payroll data must be 
converted one by one. You’ll be guided through the following tasks:

 Mapping department numbers. If you use payroll departments and any 
of the departments numbers contain special characters, you must enter 
new department numbers containing only alphanumeric characters to 
replace them. 

 Selecting tax groups from the payroll tax database to replace your 
existing tax codes. If you are using local tax codes, each state and local 
tax code combination will be replaced by one tax group. Depending on 
which tax codes you’re using, the wizard offers suggestions for you to 
review and update as needed. 

 Adding tax groups to tax profiles. Tax profiles are collections of tax 
groups that you assign to employees to determine how their taxes are 
calculated. You can access Tax Profile Maintenance from the wizard to 
create tax profiles.

 Selecting filing statuses from the payroll tax database to replace your 
existing ones. The filing statuses in the database may differ from the 
ones that you are using. The wizard offers suggestions when possible 
for you to review and update as needed. 
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4____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

5____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2019. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

6____ If you synchronize payroll data between your General Ledger module and 
Sage Payroll Services, verify that your Sage 100 company or companies 
are still linked to the service. 

a Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

b Sign in to Sage Payroll Services. 

c Proceed through the wizard. 

d Review the status messages shown in the Synchronizing Data with 
Sage Payroll Services window.   

If you see a "Synchronization Complete" message, no further action is 
required. 

If you see a "Synchronization failed" message, contact Sage Payroll 
Services Support for assistance with resetting the link. 

7____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

For the Job Cost and Payroll modules, you must manually recreate all of 
your customized panels. User defined fields will be automatically converted. 

8____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.
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For the Job Cost and Payroll Modules, you must manually recreate all 
custom lookups. 

9____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

10____ If you use the Payroll Module, review the list of enhancements in the Sage 
100 Payroll What’s New guide, available here: 
http://cdn.na.sage.com/docs/en/customer/100erp/2018n/open/Payroll_Upgr
ade.pdf

After reviewing the guide, complete the following tasks:

 Select Payroll > Setup > Earnings Code Maintenance. For each 
earnings code, select a tax rule. 

 Select Payroll > Setup > Deduction Code Maintenance. For each 
pension or cafeteria plan deduction code, select a tax rule.

 Select Payroll > Setup > Company Tax Group Setup. For each tax group 
that you are using:

 Enter the tax ID number for state and local tax groups. For the 
Federal tax group, the tax ID number entered in Company 
Maintenance appears and can only be viewed. 

 Enter the general ledger account numbers to credit with the tax 
amounts withheld from employees’ pay.

 On the Main tab, enter any tax rates that are specific to your 
company and the associated effective dates. 

 On the Taxes tab, in the Tax field, select the tax(es) for the selected 
tax group. The taxes available are based on the selected tax group. 
Note: There may be more than one tax that needs to be set up.

 Select Payroll > Setup > Tax Profile Maintenance. Review the tax 
profiles that were created when converting payroll data, and make 
changes if needed. 

 Select Payroll > Main > Employee Maintenance. On the Taxes tab, enter 
at least one tax profile for each employee. Depending on the tax groups, 
you may need to enter a filing status, a Workers’ Compensation code, or 
other information.

 Also in Employee Maintenance, on the Additional tab, verify that the 
correct selection appears in the Ethnicity/Race field. 
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 If you are using the security feature in Department Maintenance, you 
must recreate the lists of users who can access each department. 
Select Payroll > Setup > Department Maintenance, and click the 
Security tab.

 To ensure that your system can communicate with the tax calculation 
engine, add the following URL to your browser's trusted sites list: 
spa.na.sage.com

Complete this step on all workstations that will be used to process 
payroll, and also on the server where Sage 100 is installed if the 
Process Tax Calculation on the Server check box is selected in System 
Configuration.  

11____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2019. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

12____ For the Job Cost and Payroll modules, the Crystal Reports Conversion 
Wizard might partially convert your customized forms and reports. Test all of 
your customized forms and reports, and use Crystal Reports Designer to 
manually update or recreate them as needed.  

13____ If Sage 100 2018 is installed on the same computer as an earlier version of 
Sage 100, complete this step to avoid errors when printing forms and 
reports in the earlier version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 
2018 installation to the same folder in the earlier installation. You must 
complete this step on both the server and the workstation.

       NOTE 
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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14____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

15____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2019 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 77.

16____ For the Job Cost and Payroll modules, recreate all Visual Integrator import 
and export jobs. 

17____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

18____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

19____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

20____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

21____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

22____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

23____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

24____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

25____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

26____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

27____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  
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To run the utility, select Library Master > Utilities > Build Search Index. 

28____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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Upgrading from Version 2016 to Version 2019
When upgrading to version 2019, you must perform a parallel installation, and use 
the Pre-Migration and Parallel Migration utilities from the Library Master Utilities 
menu to upgrade your data. For more information, consult with your Sage business 
partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2016 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ If you use the Payroll module:

  Update the Payroll Check Register.

 Complete and purge all direct deposit transactions.

 If you have set up departments, you must have a user account set up 
with access to all departments in all companies. Department access 
must be assigned to individual user logon ID, not by groups. Groups are 
no longer used to manage department access.

Note that you must install the Payroll module in addition to installing Sage 
100. Payroll is not part of the Sage 100 installation program. To avoid the 
need to run a separate data conversion for Payroll, install the module before 
proceeding to the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade 
Guide available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

4____ Create a backup of your version 2016 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

5____ Rebuild all data files. 

       NOTE 
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

       NOTE 
When converting 
data in version 
2019, you must 
be logged in with 
a user account 
that has access 
to all payroll 
departments; 
otherwise, you 
will not be able to 
complete data 
conversion. 
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 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

8____ Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before 
migrating your data. For more information, see the Pre-Migration Utility help.

9____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2016 
installation. Port 1433 is the default SQL Server port. 

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 22, you are ready to migrate 
your data to your version 2019 system.

 For Sage 100 Standard or Advanced, use the checklist below. 

 For Sage 100 Premium, see the checklist on page 24.

Upgrade Checklist for Sage 100 Standard and Advanced

1____ Create a backup of your version 2019 MAS90 folder. Creating a backup 
now will save time if you need to revert to the folder’s original sate. 

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to migrate your data. 

3____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations on the Custom 
toolbar.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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Upgrade Checklist for Sage 100 Premium

Use this checklist to migrate your Sage 100 Premium data. 

1____ For your Sage 100 2019 installation, create a backup of the following:

 The Sage 100 MAS90 folder

 The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s 
original state. 

2____ Verify that the required rights and permissions are set up on the server(s) 
where SQL Server is installed. If the instance of SQL Server for Sage 100 
2019 is installed on a different server than the instance used for your prior 
version, you must complete these steps on both servers.

a Open the Control Panel, select Administrative Tools, and the select 
Services. 

b In the Services window, locate the SQL Server instance used for Sage 
100 Premium, right click it, and select Properties.  

c In the Properties window, click the Log On tab and select an option. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on the same server as the instance used for your prior 
version of Sage 100 Premium, select Local System Account. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on a different server than the one used for your prior version 
of Sage 100 Premium, select This Account.  

In the account field, enter: \\ServerName\Administrator 

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.

d Apply your changes and then stop and restart the services. 

e If you’re working with more than one server, make sure that all servers 
can access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

3____ Start the Parallel Migration Wizard using one of the methods below, and 
follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

WARNING 
You must have 
administrator 
rights for the 
server with your 
prior version of 
Sage 100 and the 
server with your 
version 2019 
installation.
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 If you are using Windows Server 2012 or later, start the Parallel 
Migration Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two 
SQL Server locations. The hidden shares are used to access the source 
databases to create the .back files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share 
of the destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the 
new SQL Server location and removes the .bak files from both the source 
and destination locations.

If permissions were not set correctly on both servers, you may receive the 
following error: "Error Number : 0x80040e14 Description: Access Denied 5 
or Access Denied 2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

4____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations. 

Data Conversion Checklist
After completing the steps in the Pre-Upgrade Checklist on page 22 and the 
Upgrade Checklist on page 23, you are now ready to convert your data to version 
2019.

1____ If your company data contains credit card information, install the latest 
version of Sage Exchange and verify that the workstation you are using has 
a working Internet connection. This is necessary so that credit card records 
can be transferred to a Sage Exchange Vault account during conversion. 
Credit card records must be transferred to a Sage Exchange Vault account 
before company data can be converted.

To install Sage Exchange:

a Start the Sage 100 installation program.

b Select your edition of Sage 100. 

WARNING 
Clustered drives 
do not allow 
hidden shares. If 
you are using 
clustered drives, 
follow the 
instructions in the 
Manual 
Workaround 
section of article 
number 76993 in 
the Sage 
Knowledgebase.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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c Click Productivity Applications. 

d Click Install Sage Exchange Desktop to start the installation wizard.

e Proceed through the wizard to install the program.  

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2019. This must be done for each of your companies. 

3____ If you are converting Payroll Data, the Payroll Data Conversion Wizard 
automatically opens. Companies that include Payroll data must be 
converted one by one. You’ll be guided through the following tasks:

 Mapping department numbers. If you use payroll departments and any 
of the departments numbers contain special characters, you must enter 
new department numbers containing only alphanumeric characters to 
replace them. 

 Selecting tax groups from the payroll tax database to replace your 
existing tax codes. If you are using local tax codes, each state and local 
tax code combination will be replaced by one tax group. Depending on 
which tax codes you’re using, the wizard offers suggestions for you to 
review and update as needed. 

 Adding tax groups to tax profiles. Tax profiles are collections of tax 
groups that you assign to employees to determine how their taxes are 
calculated. You can access Tax Profile Maintenance from the wizard to 
create tax profiles.

 Selecting filing statuses from the payroll tax database to replace your 
existing ones. The filing statuses in the database may differ from the 
ones that you are using. The wizard offers suggestions when possible 
for you to review and update as needed. 

4____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

5____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2019. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.
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6____ If you synchronize payroll data between your General Ledger module and 
Sage Payroll Services, verify that your Sage 100 company or companies 
are still linked to the service. 

a Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

b Sign in to Sage Payroll Services. 

c Proceed through the wizard. 

d Review the status messages shown in the Synchronizing Data with 
Sage Payroll Services window.   

If you see a "Synchronization Complete" message, no further action is 
required. 

If you see a "Synchronization failed" message, contact Sage Payroll 
Services Support for assistance with resetting the link. 

7____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

For the Job Cost and Payroll modules, you must manually recreate all of 
your customized panels. User defined fields will be automatically converted. 

8____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

For the Job Cost and Payroll Modules, you must manually recreate all 
custom lookups. 

9____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

10____ If you use the Payroll Module, review the list of enhancements in the Sage 
100 Payroll What’s New guide, available here: 
http://cdn.na.sage.com/docs/en/customer/100erp/2018n/open/Payroll_Upgr
ade.pdf

After reviewing the guide, complete the following tasks:

 Select Payroll > Setup > Earnings Code Maintenance. For each 
earnings code, select a tax rule. 

 Select Payroll > Setup > Deduction Code Maintenance. For each 
pension or cafeteria plan deduction code, select a tax rule.
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 Select Payroll > Setup > Company Tax Group Setup. For each tax group 
that you are using:

 Enter the tax ID number for state and local tax groups. For the 
Federal tax group, the tax ID number entered in Company 
Maintenance appears and can only be viewed. 

 Enter the general ledger account numbers to credit with the tax 
amounts withheld from employees’ pay.

 On the Main tab, enter any tax rates that are specific to your 
company and the associated effective dates. 

 On the Taxes tab, in the Tax field, select the tax(es) for the selected 
tax group. The taxes available are based on the selected tax group. 
Note: There may be more than one tax that needs to be set up.

 Select Payroll > Setup > Tax Profile Maintenance. Review the tax 
profiles that were created when converting payroll data, and make 
changes if needed. 

 Select Payroll > Main > Employee Maintenance. On the Taxes tab, enter 
at least one tax profile for each employee. Depending on the tax groups, 
you may need to enter a filing status, a Workers’ Compensation code, or 
other information.

 Also in Employee Maintenance, on the Additional tab, verify that the 
correct selection appears in the Ethnicity/Race field. 

 If you are using the security feature in Department Maintenance, you 
must recreate the lists of users who can access each department. 
Select Payroll > Setup > Department Maintenance, and click the 
Security tab.

 To ensure that your system can communicate with the tax calculation 
engine, add the following URL to your browser's trusted sites list: 
spa.na.sage.com

Complete this step on all workstations that will be used to process 
payroll, and also on the server where Sage 100 is installed if the 
Process Tax Calculation on the Server check box is selected in System 
Configuration.  

11____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2019. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

       NOTE 
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

12____ For the Job Cost and Payroll modules, the Crystal Reports Conversion 
Wizard might partially convert your customized forms and reports. Test all of 
your customized forms and reports, and use Crystal Reports Designer to 
manually update or recreate them as needed.  

13____ If Sage 100 2018 is installed on the same computer as an earlier version of 
Sage 100, complete this step to avoid errors when printing forms and 
reports in the earlier version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 
2018 installation to the same folder in the earlier installation. You must 
complete this step on both the server and the workstation.

14____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

15____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2019 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 77.

16____ For the Job Cost and Payroll modules, recreate all Visual Integrator import 
and export jobs. 

17____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

18____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

19____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

20____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.
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21____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

22____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

23____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

24____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

25____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

26____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

27____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  

To run the utility, select Library Master > Utilities > Build Search Index. 

28____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

 

Sage 100 2019 Upgrade Checklist                                                                                                                      Page 31



Upgrading from Version 2015 to Version 2019
Upgrading from Version 2015 to Version 2019
When upgrading to version 2019, you must perform a parallel installation, and use 
the Pre-Migration and Parallel Migration utilities from the Library Master Utilities 
menu to upgrade your data. For more information, consult with your Sage business 
partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2015 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ If you use the Payroll module:

  Update the Payroll Check Register.

 Complete and purge all direct deposit transactions.

 If you have set up departments, you must have a user account set up 
with access to all departments in all companies. Department access 
must be assigned to individual user logon ID, not by groups. Groups are 
no longer used to manage department access.

Note that you must install the Payroll module in addition to installing Sage 
100. Payroll is not part of the Sage 100 installation program. To avoid the 
need to run a separate data conversion for Payroll, install the module before 
proceeding to the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade 
Guide available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

4____ Create a backup of your version 2015 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

       NOTE 
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

       NOTE 
When converting 
data in version 
2019, you must 
be logged in with 
a user account 
that has access 
to all payroll 
departments; 
otherwise, you 
will not be able to 
complete data 
conversion. 
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5____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

6____ Print all customized form definitions.

7____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

8____ Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before 
migrating your data. For more information, see the Pre-Migration Utility help.

9____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2015 
installation. Port 1433 is the default SQL Server port. 

10____ If you use the Payroll module, you must install it separately. For more 
information, see the Sage 100 Payroll Installation and Upgrade Guide 
available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

Upgrade Checklist
After completing the Pre-Upgrade Checklist on page 32, you are now ready to 
migrate your data to your version 2019 system.

For Sage 100 Standard or Advanced, use the checklist below. For Sage 100 
Premium, skip to the next section. 

Upgrade Checklist for Sage 100 Standard and Advanced

1____ Create a backup of your version 2019 MAS90 folder. Creating a backup 
now will save time if you need to revert to the folder’s original sate. 

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to migrate your data. 

3____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations. 

Upgrade Checklist for Sage 100 Premium

Use this checklist to migrate your Sage 100 Premium data. 

1____ For your Sage 100 2019 installation, create a backup of the following:

 The Sage 100 MAS90 folder

 The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s 
original state. 

2____ Verify that the required rights and permissions are set up on the server(s) 
where SQL Server is installed. If the instance of SQL Server for Sage 100 
2019 is installed on a different server than the instance used for your prior 
version, you must complete these steps on both servers.

a Open the Control Panel, select Administrative Tools, and the select 
Services. 

b In the Services window, locate the SQL Server instance used for Sage 
100 Premium, right click it, and select Properties.  

c In the Properties window, click the Log On tab and select an option. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on the same server as the instance used for your prior 
version of Sage 100 Premium, select Local System Account. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on a different server than the one used for your prior version 
of Sage 100 Premium, select This Account.  

In the account field, enter: \\ServerName\Administrator 

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.

d Apply your changes and then stop and restart the services. 

e If you’re working with more than one server, make sure that all servers 
can access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

WARNING 
You must have 
administrator 
rights for the 
server with your 
prior version of 
Sage 100 and the 
server with your 
version 2019 
installation.
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3____ Start the Parallel Migration Wizard using one of the methods below, and 
follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012 or later, start the Parallel 
Migration Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two 
SQL Server locations. The hidden shares are used to access the source 
databases to create the .back files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share 
of the destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the 
new SQL Server location and removes the .bak files from both the source 
and destination locations.

If permissions were not set correctly on both servers, you may receive the 
following error: "Error Number : 0x80040e14 Description: Access Denied 5 
or Access Denied 2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

4____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations. 

WARNING 
Clustered drives 
do not allow 
hidden shares. If 
you are using 
clustered drives, 
follow the 
instructions in the 
Manual 
Workaround 
section of article 
number 76993 in 
the Sage 
Knowledgebase.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 32 and the 
Upgrade Checklist on page 33, you are now ready to convert your data to version 
2019.

1____ If your company data contains credit card information, install the latest 
version of Sage Exchange and verify that the workstation you are using has 
a working Internet connection. This is necessary so that credit card records 
can be transferred to a Sage Exchange Vault account during conversion. 
Credit card records must be transferred to a Sage Exchange Vault account 
before company data can be converted.

To install Sage Exchange:

a Start the Sage 100 installation program.

b Select your edition of Sage 100. 

c Click Productivity Applications. 

d Click Install Sage Exchange Desktop to start the installation wizard.

e Proceed through the wizard to install the program.  

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2019. This must be done for each of your companies. 

3____ If you are converting Payroll Data, the Payroll Data Conversion Wizard 
automatically opens. Companies that include Payroll data must be 
converted one by one. You’ll be guided through the following tasks:

 Mapping department numbers. If you use payroll departments and any 
of the departments numbers contain special characters, you must enter 
new department numbers containing only alphanumeric characters to 
replace them. 

 Selecting tax groups from the payroll tax database to replace your 
existing tax codes. If you are using local tax codes, each state and local 
tax code combination will be replaced by one tax group. Depending on 
which tax codes you’re using, the wizard offers suggestions for you to 
review and update as needed. 

 Adding tax groups to tax profiles. Tax profiles are collections of tax 
groups that you assign to employees to determine how their taxes are 
calculated. You can access Tax Profile Maintenance from the wizard to 
create tax profiles.

 Selecting filing statuses from the payroll tax database to replace your 
existing ones. The filing statuses in the database may differ from the 
ones that you are using. The wizard offers suggestions when possible 
for you to review and update as needed. 
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4____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

5____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2019. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

6____ If you synchronize payroll data between your General Ledger module and 
Sage Payroll Services, verify that your Sage 100 company or companies 
are still linked to the service. 

a Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

b Sign in to Sage Payroll Services. 

c Proceed through the wizard. 

d Review the status messages shown in the Synchronizing Data with 
Sage Payroll Services window.   

If you see a "Synchronization Complete" message, no further action is 
required. 

If you see a "Synchronization failed" message, contact Sage Payroll 
Services Support for assistance with resetting the link. 

7____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

For the Job Cost and Payroll modules, you must manually recreate all of 
your customized panels. User defined fields will be automatically converted. 

8____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.
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For the Job Cost and Payroll Modules, you must manually recreate all 
custom lookups. 

9____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

10____ If you use the Payroll Module, review the list of enhancements in the Sage 
100 Payroll What’s New guide, available here: 
http://cdn.na.sage.com/docs/en/customer/100erp/2018n/open/Payroll_Upgr
ade.pdf

After reviewing the guide, complete the following tasks:

 Select Payroll > Setup > Earnings Code Maintenance. For each 
earnings code, select a tax rule. 

 Select Payroll > Setup > Deduction Code Maintenance. For each 
pension or cafeteria plan deduction code, select a tax rule.

 Select Payroll > Setup > Company Tax Group Setup. For each tax group 
that you are using:

 Enter the tax ID number for state and local tax groups. For the 
Federal tax group, the tax ID number entered in Company 
Maintenance appears and can only be viewed. 

 Enter the general ledger account numbers to credit with the tax 
amounts withheld from employees’ pay.

 On the Main tab, enter any tax rates that are specific to your 
company and the associated effective dates. 

 On the Taxes tab, in the Tax field, select the tax(es) for the selected 
tax group. The taxes available are based on the selected tax group. 
Note: There may be more than one tax that needs to be set up.

 Select Payroll > Setup > Tax Profile Maintenance. Review the tax 
profiles that were created when converting payroll data, and make 
changes if needed. 

 Select Payroll > Main > Employee Maintenance. On the Taxes tab, enter 
at least one tax profile for each employee. Depending on the tax groups, 
you may need to enter a filing status, a Workers’ Compensation code, or 
other information.

 Also in Employee Maintenance, on the Additional tab, verify that the 
correct selection appears in the Ethnicity/Race field. 
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 If you are using the security feature in Department Maintenance, you 
must recreate the lists of users who can access each department. 
Select Payroll > Setup > Department Maintenance, and click the 
Security tab.

 To ensure that your system can communicate with the tax calculation 
engine, add the following URL to your browser's trusted sites list: 
spa.na.sage.com

Complete this step on all workstations that will be used to process 
payroll, and also on the server where Sage 100 is installed if the 
Process Tax Calculation on the Server check box is selected in System 
Configuration.  

11____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2019. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

12____ For the Job Cost and Payroll modules, the Crystal Reports Conversion 
Wizard might partially convert your customized forms and reports. Test all of 
your customized forms and reports, and use Crystal Reports Designer to 
manually update or recreate them as needed.  

13____ If Sage 100 2018 is installed on the same computer as an earlier version of 
Sage 100, complete this step to avoid errors when printing forms and 
reports in the earlier version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 
2018 installation to the same folder in the earlier installation. You must 
complete this step on both the server and the workstation.

       NOTE 
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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14____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

15____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2019 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 77.

16____ For the Job Cost and Payroll modules, recreate all Visual Integrator import 
and export jobs. 

17____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

18____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

19____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

20____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

21____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

22____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

23____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

24____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

25____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

26____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

27____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  
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To run the utility, select Library Master > Utilities > Build Search Index. 

28____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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Upgrading from Version 2014 to Version 2019
When upgrading to version 2019, you must perform a parallel installation, and use 
the Pre-Migration and Parallel Migration utilities from the Library Master Utilities 
menu to upgrade your data. For more information, consult with your Sage business 
partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2014 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ If you use the Payroll module:

  Update the Payroll Check Register.

 Complete and purge all direct deposit transactions.

 If you have set up departments, you must have a user account set up 
with access to all departments in all companies. Department access 
must be assigned to individual user logon ID, not by groups. Groups are 
no longer used to manage department access.

Note that you must install the Payroll module in addition to installing Sage 
100. Payroll is not part of the Sage 100 installation program. To avoid the 
need to run a separate data conversion for Payroll, install the module before 
proceeding to the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade 
Guide available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

4____ Create a backup of your version 2014 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

5____ If you use the Purchase Order module, you will have the option to start 
retaining purchase order history and to create history using records in your 
Purchase Order data entry files. 

       NOTE 
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

       NOTE 
When converting 
data in version 
2019, you must 
be logged in with 
a user account 
that has access 
to all payroll 
departments; 
otherwise, you 
will not be able to 
complete data 
conversion. 
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If you plan to create history, consider running the following utilities to clear 
out records that you do not want to include:

 Purge Completed Purchase Orders

 Purge Obsolete Purchase Orders 

For more information on the utilities, see the help system.

6____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

7____ Print all customized form definitions.

8____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

9____ Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before 
migrating your data. For more information, see the Pre-Migration Utility help.

10____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2014 
installation. Port 1433 is the default SQL Server port.

11____ If you use the Payroll module, you must install it separately. For more 
information, see the Sage 100 Payroll Installation and Upgrade Guide 
available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

Upgrade Checklist

After completing the Pre-Upgrade Checklist on page 42, you are ready to migrate 
your data to your version 2019 system.

For Sage 100 Standard or Advanced, use the checklist below. For Sage 100 
Premium, skip to the next section.

Upgrade Checklist for Sage 100 Standard and Advanced

1____ Create a backup of your version 2019 MAS90 folder. Creating a backup 
now will save time if you need to revert to the folder’s original sate. 

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to migrate your data. 
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3____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations. 

Upgrade Checklist for Sage 100 Premium

Use this checklist to migrate your Sage 100 Premium data. 

1____ For your Sage 100 2019 installation, create a backup of the following:

 The Sage 100 MAS90 folder

 The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s 
original state. 

2____ Verify that the required rights and permissions are set up on the server(s) 
where SQL Server is installed. If the instance of SQL Server for Sage 100 
2019 is installed on a different server than the instance used for your prior 
version, you must complete these steps on both servers.

a Open the Control Panel, select Administrative Tools, and the select 
Services. 

b In the Services window, locate the SQL Server instance used for Sage 
100 Premium, right click it, and select Properties.  

c In the Properties window, click the Log On tab and select an option. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on the same server as the instance used for your prior 
version of Sage 100 Premium, select Local System Account. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on a different server than the one used for your prior version 
of Sage 100 Premium, select This Account.  

In the account field, enter: \\ServerName\Administrator 

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  

WARNING 
You must have 
administrator 
rights for the 
server with your 
prior version of 
Sage 100 and the 
server with your 
version 2019 
installation.
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d Apply your changes and then stop and restart the services. 

e If you’re working with more than one server, make sure that all servers 
can access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

3____ Start the Parallel Migration Wizard using one of the methods below, and 
follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012 or later, start the Parallel 
Migration Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two 
SQL Server locations. The hidden shares are used to access the source 
databases to create the .back files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share 
of the destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the 
new SQL Server location and removes the .bak files from both the source 
and destination locations.

If permissions were not set correctly on both servers, you may receive the 
following error: "Error Number : 0x80040e14 Description: Access Denied 5 
or Access Denied 2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

4____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations. 

WARNING 
Clustered drives 
do not allow 
hidden shares. If 
you are using 
clustered drives, 
follow the 
instructions in the 
Manual 
Workaround 
section of article 
number 76993 in 
the Sage 
Knowledgebase.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 42 and the 
Upgrade Checklist on page 43, you are now ready to convert your data to version 
2019.

1____ If your company data contains credit card information, install the latest 
version of Sage Exchange and verify that the workstation you are using has 
a working Internet connection. This is necessary so that credit card records 
can be transferred to a Sage Exchange Vault account during conversion. 
Credit card records must be transferred to a Sage Exchange Vault account 
before company data can be converted.

To install Sage Exchange:

a Start the Sage 100 installation program.

b Select your edition of Sage 100. 

c Click Productivity Applications. 

d Click Install Sage Exchange Desktop to start the installation wizard.

e Proceed through the wizard to install the program.  

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2019. This must be done for each of your companies. 

If the Purchase Order module is set up for a company, a window with 
options for retaining purchase order history appears. You can set up the 
feature and create history during data conversion or you can do so at a later 
time. 

3____ If you are converting Payroll Data, the Payroll Data Conversion Wizard 
automatically opens. Companies that include Payroll data must be 
converted one by one. You’ll be guided through the following tasks:

 Mapping department numbers. If you use payroll departments and any 
of the departments numbers contain special characters, you must enter 
new department numbers containing only alphanumeric characters to 
replace them. 

 Selecting tax groups from the payroll tax database to replace your 
existing tax codes. If you are using local tax codes, each state and local 
tax code combination will be replaced by one tax group. Depending on 
which tax codes you’re using, the wizard offers suggestions for you to 
review and update as needed. 

 Adding tax groups to tax profiles. Tax profiles are collections of tax 
groups that you assign to employees to determine how their taxes are 
calculated. You can access Tax Profile Maintenance from the wizard to 
create tax profiles.
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 Selecting filing statuses from the payroll tax database to replace your 
existing ones. The filing statuses in the database may differ from the 
ones that you are using. The wizard offers suggestions when possible 
for you to review and update as needed. 

4____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

5____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2019. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

6____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

For the Job Cost and Payroll modules, you must manually recreate all of 
your customized panels. User defined fields will be automatically converted. 

7____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

For the Job Cost and Payroll Modules, you must manually recreate all 
custom lookups. 

8____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

9____ If you use the Payroll Module, review the list of enhancements in the Sage 
100 Payroll What’s New guide, available here: 
http://cdn.na.sage.com/docs/en/customer/100erp/2018n/open/Payroll_Upgr
ade.pdf

After reviewing the guide, complete the following tasks:
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 Select Payroll > Setup > Earnings Code Maintenance. For each 
earnings code, select a tax rule. 

 Select Payroll > Setup > Deduction Code Maintenance. For each 
pension or cafeteria plan deduction code, select a tax rule.

 Select Payroll > Setup > Company Tax Group Setup. For each tax group 
that you are using:

 Enter the tax ID number for state and local tax groups. For the 
Federal tax group, the tax ID number entered in Company 
Maintenance appears and can only be viewed. 

 Enter the general ledger account numbers to credit with the tax 
amounts withheld from employees’ pay.

 On the Main tab, enter any tax rates that are specific to your 
company and the associated effective dates. 

 On the Taxes tab, in the Tax field, select the tax(es) for the selected 
tax group. The taxes available are based on the selected tax group. 
Note: There may be more than one tax that needs to be set up.

 Select Payroll > Setup > Tax Profile Maintenance. Review the tax 
profiles that were created when converting payroll data, and make 
changes if needed. 

 Select Payroll > Main > Employee Maintenance. On the Taxes tab, enter 
at least one tax profile for each employee. Depending on the tax groups, 
you may need to enter a filing status, a Workers’ Compensation code, or 
other information.

 Also in Employee Maintenance, on the Additional tab, verify that the 
correct selection appears in the Ethnicity/Race field. 

 If you are using the security feature in Department Maintenance, you 
must recreate the lists of users who can access each department. 
Select Payroll > Setup > Department Maintenance, and click the 
Security tab.

 To ensure that your system can communicate with the tax calculation 
engine, add the following URL to your browser's trusted sites list: 
spa.na.sage.com

Complete this step on all workstations that will be used to process 
payroll, and also on the server where Sage 100 is installed if the 
Process Tax Calculation on the Server check box is selected in System 
Configuration.  

10____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2019. 

       NOTE 
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

11____ For the Job Cost and Payroll modules, the Crystal Reports Conversion 
Wizard might partially convert your customized forms and reports. Test all of 
your customized forms and reports, and use Crystal Reports Designer to 
manually update or recreate them as needed.  

12____ If Sage 100 2018 is installed on the same computer as an earlier version of 
Sage 100, complete this step to avoid errors when printing forms and 
reports in the earlier version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 
2018 installation to the same folder in the earlier installation. You must 
complete this step on both the server and the workstation.

13____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

14____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2019 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 77.

15____  For the Job Cost and Payroll modules, recreate all Visual Integrator import 
and export jobs. 

16____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

17____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

18____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.
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19____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

20____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

21____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

22____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

23____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

24____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

25____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

26____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  

To run the utility, select Library Master > Utilities > Build Search Index. 

27____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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Upgrading from Version 2013 to Version 2019
When upgrading to version 2019, you must perform a parallel installation. Use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 2013 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ If you use the Payroll module:

  Update the Payroll Check Register.

 Complete and purge all direct deposit transactions.

 If you have set up departments, you must have a user account set up 
with access to all departments in all companies. Department access 
must be assigned to individual user logon ID, not by groups. Groups are 
no longer used to manage department access.

Note that you must install the Payroll module in addition to installing Sage 
100. Payroll is not part of the Sage 100 installation program. To avoid the 
need to run a separate data conversion for Payroll, install the module before 
proceeding to the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade 
Guide available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

4____ Create a backup of your version 2013 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

5____ If you use the Purchase Order module, you will have the option to start 
retaining purchase order history and to create history using records in your 
Purchase Order data entry files. 

       NOTE 
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

       NOTE 
When converting 
data in version 
2019, you must 
be logged in with 
a user account 
that has access 
to all payroll 
departments; 
otherwise, you 
will not be able to 
complete data 
conversion. 
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If you plan to create history, consider running the following utilities to clear 
out records that you do not want to include:

 Purge Completed Purchase Orders

 Purge Obsolete Purchase Orders 

6____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

7____ Print all customized form definitions.

8____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

9____ Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before 
migrating your data. For more information, see the Pre-Migration Utility help.

10____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 2013 
installation. Port 1433 is the default SQL Server port. 

11____ If you use the Payroll module, you must install it separately. For more 
information, see the Sage 100 Payroll Installation and Upgrade Guide 
available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

Upgrade Checklist
After completing the Pre-Upgrade Checklist on page 52, you are now ready to 
migrate your data to your version 2019 system.

For Sage 100 Standard or Advanced, use the checklist below. Skip to the next 
section for Sage 100 Premium.  

Upgrade Checklist for Sage 100 Standard and Advanced

1____ Create a backup of your version 2019 MAS90 folder. Creating a backup 
now will save time if you need to revert to the folder’s original sate. 

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to migrate your data. 
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3____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations. 

Upgrade Checklist for Sage 100 Premium

Use this checklist to migrate your Sage 100 Premium data. 

1____ For your Sage 100 2019 installation, create a backup of the following:

 The Sage 100 MAS90 folder

 The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s 
original state. 

2____ Verify that the required rights and permissions are set up on the server(s) 
where SQL Server is installed. If the instance of SQL Server for Sage 100 
2019 is installed on a different server than the instance used for your prior 
version, you must complete these steps on both servers.

a Open the Control Panel, select Administrative Tools, and the select 
Services. 

b In the Services window, locate the SQL Server instance used for Sage 
100 Premium, right click it, and select Properties.  

c In the Properties window, click the Log On tab and select an option. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on the same server as the instance used for your prior 
version of Sage 100 Premium, select Local System Account. 

 If the SQL Server instance that you’re using for version 2019 is 
installed on a different server than the one used for your prior version 
of Sage 100 Premium, select This Account.  

In the account field, enter: \\ServerName\Administrator 

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  

WARNING 
You must have 
administrator 
rights for the 
server with your 
prior version of 
Sage 100 and the 
server with your 
version 2019 
installation.
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d Apply your changes and then stop and restart the services. 

e If you’re working with more than one server, make sure that all servers 
can access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

3____ Start the Parallel Migration Wizard using one of the methods below, and 
follow the steps in the Wizard.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012 or later, start the Parallel 
Migration Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two 
SQL Server locations. The hidden shares are used to access the source 
databases to create the .back files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share 
of the destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the 
new SQL Server location and removes the .bak files from both the source 
and destination locations.

If permissions were not set correctly on both servers, you may receive the 
following error: "Error Number : 0x80040e14 Description: Access Denied 5 
or Access Denied 2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

4____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

5____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

6____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

7____ If you customized your Desktop, review the customizations. 

WARNING 
Clustered drives 
do not allow 
hidden shares. If 
you are using 
clustered drives, 
follow the 
instructions in the 
Manual 
Workaround 
section of article 
number 76993 in 
the Sage 
Knowledgebase.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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Data Conversion Checklist

After completing the steps in the Pre-Upgrade Checklist on page 52 and the 
Upgrade Checklist on page 53, you are now ready to convert your data to version 
2019.

1____ If your company data contains credit card information, install the latest 
version of Sage Exchange and verify that the workstation you are using has 
a working Internet connection. This is necessary so that credit card records 
can be transferred to a Sage Exchange Vault account during conversion. 
Credit card records must be transferred to a Sage Exchange Vault account 
before company data can be converted.

To install Sage Exchange:

a Start the Sage 100 installation program.

b Select your edition of Sage 100. 

c Click Productivity Applications. 

d Click Install Sage Exchange Desktop to start the installation wizard.

e Proceed through the wizard to install the program.  

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2019. This must be done for each of your companies.

If the Purchase Order module is set up for a company, a window with 
options for retaining purchase order history appears. You can set up the 
feature and create history during data conversion or you can do so at a later 
time.

3____ If you are converting Payroll Data, the Payroll Data Conversion Wizard 
automatically opens. Companies that include Payroll data must be 
converted one by one. You’ll be guided through the following tasks:

 Mapping department numbers. If you use payroll departments and any 
of the departments numbers contain special characters, you must enter 
new department numbers containing only alphanumeric characters to 
replace them. 

 Selecting tax groups from the payroll tax database to replace your 
existing tax codes. If you are using local tax codes, each state and local 
tax code combination will be replaced by one tax group. Depending on 
which tax codes you’re using, the wizard offers suggestions for you to 
review and update as needed. 

 Adding tax groups to tax profiles. Tax profiles are collections of tax 
groups that you assign to employees to determine how their taxes are 
calculated. You can access Tax Profile Maintenance from the wizard to 
create tax profiles.
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 Selecting filing statuses from the payroll tax database to replace your 
existing ones. The filing statuses in the database may differ from the 
ones that you are using. The wizard offers suggestions when possible 
for you to review and update as needed. 

4____ If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

5____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2019. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

6____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

For the Job Cost and Payroll modules, you must manually recreate all of 
your customized panels. User defined fields will be automatically converted. 

7____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

For the Job Cost and Payroll Modules, you must manually recreate all 
custom lookups. 

8____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

9____ If you use the Payroll Module, review the list of enhancements in the Sage 
100 Payroll What’s New guide, available here: 
http://cdn.na.sage.com/docs/en/customer/100erp/2018n/open/Payroll_Upgr
ade.pdf

After reviewing the guide, complete the following tasks:
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 Select Payroll > Setup > Earnings Code Maintenance. For each 
earnings code, select a tax rule. 

 Select Payroll > Setup > Deduction Code Maintenance. For each 
pension or cafeteria plan deduction code, select a tax rule.

 Select Payroll > Setup > Company Tax Group Setup. For each tax group 
that you are using:

 Enter the tax ID number for state and local tax groups. For the 
Federal tax group, the tax ID number entered in Company 
Maintenance appears and can only be viewed. 

 Enter the general ledger account numbers to credit with the tax 
amounts withheld from employees’ pay.

 On the Main tab, enter any tax rates that are specific to your 
company and the associated effective dates. 

 On the Taxes tab, in the Tax field, select the tax(es) for the selected 
tax group. The taxes available are based on the selected tax group. 
Note: There may be more than one tax that needs to be set up.

 Select Payroll > Setup > Tax Profile Maintenance. Review the tax 
profiles that were created when converting payroll data, and make 
changes if needed. 

 Select Payroll > Main > Employee Maintenance. On the Taxes tab, enter 
at least one tax profile for each employee. Depending on the tax groups, 
you may need to enter a filing status, a Workers’ Compensation code, or 
other information.

 Also in Employee Maintenance, on the Additional tab, verify that the 
correct selection appears in the Ethnicity/Race field. 

 If you are using the security feature in Department Maintenance, you 
must recreate the lists of users who can access each department. 
Select Payroll > Setup > Department Maintenance, and click the 
Security tab.

 To ensure that your system can communicate with the tax calculation 
engine, add the following URL to your browser's trusted sites list: 
spa.na.sage.com

Complete this step on all workstations that will be used to process 
payroll, and also on the server where Sage 100 is installed if the 
Process Tax Calculation on the Server check box is selected in System 
Configuration.  

10____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2019. 

       NOTE 
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
Sage 100 2019 Upgrade Checklist                                                                                                                      Page 58



Upgrading from Version 2013 to Version 2019
To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

11____ For the Job Cost and Payroll modules, the Crystal Reports Conversion 
Wizard might partially convert your customized forms and reports. Test all of 
your customized forms and reports, and use Crystal Reports Designer to 
manually update or recreate them as needed.  

12____ If Sage 100 2018 is installed on the same computer as an earlier version of 
Sage 100, complete this step to avoid errors when printing forms and 
reports in the earlier version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 
2018 installation to the same folder in the earlier installation. You must 
complete this step on both the server and the workstation.

13____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

14____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2019 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 77.

15____ For the Job Cost and Payroll modules, recreate all Visual Integrator import 
and export jobs. 

16____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

17____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

18____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.
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19____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

20____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

21____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

22____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

23____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

24____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

25____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

26____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  

To run the utility, select Library Master > Utilities > Build Search Index. 

27____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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Upgrading from Version 4.50 to Version 2019
When upgrading to version 2019, you must perform a parallel installation, and use 
the Pre-Migration and Parallel Migration utilities from the Library Master Utilities 
menu to upgrade your data. For more information, consult with your Sage business 
partner.

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrators Guide.

Pre-Upgrade Checklist

You must prepare your version 4.50 data for upgrading. This should be done for 
each company you plan to upgrade.

1____ If you haven’t installed Product Update 8 for version 4.50, install the update. 

2____ Process all pending credit card transactions.

3____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

4____ If you use the Payroll module:

  Update the Payroll Check Register.

 Complete and purge all direct deposit transactions.

 If you have set up departments, you must have a user account set up 
with access to all departments in all companies. Department access 
must be assigned to individual user logon ID, not by groups. Groups are 
no longer used to manage department access.

Note that you must install the Payroll module in addition to installing Sage 
100. Payroll is not part of the Sage 100 installation program. To avoid the 
need to run a separate data conversion for Payroll, install the module before 
proceeding to the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade 
Guide available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

5____ Create a backup of your version 4.50 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

       NOTE 
You must install 
Product Update 8 
for version 4.50 
before upgrading to 
version 2019.  

       NOTE 
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

       NOTE 
When converting 
data in version 
2019, you must 
be logged in with 
a user account 
that has access 
to all payroll 
departments; 
otherwise, you 
will not be able to 
complete data 
conversion. 
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6____ If you use credit card processing, verify that you have a valid credit card 
encryption key in Company Maintenance for proper conversion of credit 
card data.

7____ If you use the Purchase Order module, you will have the option to start 
retaining purchase order history and to create history using records in your 
Purchase Order data entry files. 

If you plan to create history, consider running the following utilities to clear 
out records that you do not want to include:

 Purge Completed Purchase Orders

 Purge Obsolete Purchase Orders 

For more information on the utilities, see the help system.

8____ Rebuild all data files. 

 If you are upgrading from Sage 100 Standard or Advanced, use the 
Rebuild Key Files and Rebuild Sort File utilities.

 If you are upgrading from Sage 100 Premium, use the Rebuild Sort File 
utility.

You must answer Yes to all recalculation questions.

9____ Print all customized form definitions.

10____ If you are using eBusiness Manager, back up any templates, .htm files, and 
the IW folder before uninstalling the previous version of the Web Engine.

11____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 4.50 
installation. Port 1433 is the default SQL Server port.

12____ If you use the Payroll module, you must install it separately. For more 
information, see the Sage 100 Payroll Installation and Upgrade Guide 
available online at: 
http://cdn.na.sage.com/docs/en/customer/100erp/Documentation.htm

Upgrade Checklist
After completing the Pre-Upgrade Checklist on page 62, you are now ready to 
migrate your data to your version 2019 system.

1____ Create a backup of your version 2019 MAS90 folder. Creating a backup 
now will save time if you need to revert to the folder’s original sate. 

2____ Select Library Master Utilities menu > Parallel Migration. Follow the steps in 
the wizard to migrate your data. 

If you are upgrading Sage 100 Premium, start the Parallel Migration Wizard 
using one of the methods below, and follow the steps in the Wizard.
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 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard will back up the Sage 100 SQL databases for your 
prior version of Sage 100, copy the backup files to the server where Sage 
100 2017 SQL Server instance is installed, and then restore them in the 
new location. Administrative rights are required for both your prior version of 
Sage 100 and for version 2017. The person running the Migration Wizard 
must have rights to the following administrative share: 
\\{sourceserver-name}\c$

If local security settings prevent the wizard from migrating the databases, 
use SQL Server Management Studio to back up the MAS_System and 
company databases that you want to migrate. Then copy the .BAK files to 
the ..\MSSQL\Data folder on the server where the Sage 100 2017 SQL 
Server instance is installed.

3____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

4____ Review security tasks for new features in version 2019.  Review ODBC 
security if it is used.

5____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

6____ If you customized your Desktop, review the customizations. 

Data Conversion Checklist
After completing the steps in the Pre-Upgrade Checklist on page 62 and the 
Upgrade Checklist on page 63, you are now ready to convert your data to version 
2019.

1____ If your company data contains credit card information, install the latest 
version of Sage Exchange and verify that the workstation you are using has 
a working Internet connection. This is necessary so that credit card records 
can be transferred to a Sage Exchange Vault account during conversion. 
Credit card records must be transferred to a Sage Exchange Vault account 
before company data can be converted.

To install Sage Exchange:

a Start the Sage 100 installation program.

b Select your edition of Sage 100. 

c Click Productivity Applications. 

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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d Click Install Sage Exchange Desktop to start the installation wizard.

e Proceed through the wizard to install the program.  

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2019. This must be done for each of your companies.

If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet connection 
speed, network traffic, and the number of customer credit card records 
stored in your system. 

You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 

Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 

If the Purchase Order module is set up for a company, a window with 
options for retaining purchase order history appears. You can set up the 
feature and create history during data conversion or you can do so at a later 
time. 

3____ If you are converting Payroll Data, the Payroll Data Conversion Wizard 
automatically opens. Companies that include Payroll data must be 
converted one by one. You’ll be guided through the following tasks:

 Mapping department numbers. If you use payroll departments and any 
of the departments numbers contain special characters, you must enter 
new department numbers containing only alphanumeric characters to 
replace them. 

 Selecting tax groups from the payroll tax database to replace your 
existing tax codes. If you are using local tax codes, each state and local 
tax code combination will be replaced by one tax group. Depending on 
which tax codes you’re using, the wizard offers suggestions for you to 
review and update as needed. 

 Adding tax groups to tax profiles. Tax profiles are collections of tax 
groups that you assign to employees to determine how their taxes are 
calculated. You can access Tax Profile Maintenance from the wizard to 
create tax profiles.

 Selecting filing statuses from the payroll tax database to replace your 
existing ones. The filing statuses in the database may differ from the 
ones that you are using. The wizard offers suggestions when possible 
for you to review and update as needed. 
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4____ Verify that credit card processing is enabled for each company in Company 
Maintenance if credit cards were previously being processed using Sage 
Payment Solutions. For more information, see Set Up the Credit Card 
Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

5____ If your system is integrated with Sage CRM, go into CRM Server Options, 
and update the following information as needed. 

 Integration server port ID

 Sage CRM SQL server name

 Sage CRM SQL database name

The server name and database name should reference the mirror 
installation that you created for integration with Sage 100 2019. For more 
information on this process, refer to the Installing Sage CRM chapter in the 
Sage 100 Installation and System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

6____  Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

For the Job Cost and Payroll modules, you must manually recreate all of 
your customized panels. User defined fields will be automatically converted. 

7____ If you have customers with national accounts and credit cards are assigned 
to the sold-to customers, review those records to determine whether the 
credit card information should be manually transferred to the bill-to 
customer.

8____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

For the Job Cost and Payroll Modules, you must manually recreate all 
custom lookups. 

9____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.
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10____ If you use the Payroll Module, review the list of enhancements in the Sage 
100 Payroll What’s New guide, available here: 
http://cdn.na.sage.com/docs/en/customer/100erp/2018n/open/Payroll_Upgr
ade.pdf

After reviewing the guide, complete the following tasks:

 Select Payroll > Setup > Earnings Code Maintenance. For each 
earnings code, select a tax rule. 

 Select Payroll > Setup > Deduction Code Maintenance. For each 
pension or cafeteria plan deduction code, select a tax rule.

 Select Payroll > Setup > Company Tax Group Setup. For each tax group 
that you are using:

 Enter the tax ID number for state and local tax groups. For the 
Federal tax group, the tax ID number entered in Company 
Maintenance appears and can only be viewed. 

 Enter the general ledger account numbers to credit with the tax 
amounts withheld from employees’ pay.

 On the Main tab, enter any tax rates that are specific to your 
company and the associated effective dates. 

 On the Taxes tab, in the Tax field, select the tax(es) for the selected 
tax group. The taxes available are based on the selected tax group. 
Note: There may be more than one tax that needs to be set up.

 Select Payroll > Setup > Tax Profile Maintenance. Review the tax 
profiles that were created when converting payroll data, and make 
changes if needed. 

 Select Payroll > Main > Employee Maintenance. On the Taxes tab, enter 
at least one tax profile for each employee. Depending on the tax groups, 
you may need to enter a filing status, a Workers’ Compensation code, or 
other information.

 Also in Employee Maintenance, on the Additional tab, verify that the 
correct selection appears in the Ethnicity/Race field. 

 If you are using the security feature in Department Maintenance, you 
must recreate the lists of users who can access each department. 
Select Payroll > Setup > Department Maintenance, and click the 
Security tab.

 To ensure that your system can communicate with the tax calculation 
engine, add the following URL to your browser's trusted sites list: 
spa.na.sage.com
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Complete this step on all workstations that will be used to process 
payroll, and also on the server where Sage 100 is installed if the 
Process Tax Calculation on the Server check box is selected in System 
Configuration.  

11____ Test your customized Crystal reports and forms. 

If you need to troubleshoot issues with customized reports and forms, run 
the Crystal Form Comparison Report utility to compare your customized 
reports and forms to the standard ones in version 2017. 

To run the utility, select File menu > Run, and then type SYWFCU. The 
utility tells you which tables, if any, have been added to a report or form. It 
does not provide information about formatting changes, such as those 
affecting fonts, logos, and so forth. 

If you were previously using non-graphical forms, you will need to set them 
up using SAP Crystal Reports.

If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For 
more information, see SAP Crystal Reports FAQs in the Help system. If you 
do not run the wizard now, it will automatically run the first time that 
someone runs a form or report.

If you are using Sage 100 Premium, refer to the Converting Reports for 
Sage 100 Premium section in the Sage 100 Installation and System 
Administrators’ Guide for more information. 

12____ For the Job Cost and Payroll modules, the Crystal Reports Conversion 
Wizard might partially convert your customized forms and reports. Test all of 
your customized forms and reports, and use Crystal Reports Designer to 
manually update or recreate them as needed.  

13____ If Sage 100 2018 is installed on the same computer as an earlier version of 
Sage 100, complete this step to avoid errors when printing forms and 
reports in the earlier version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 
2018 installation to the same folder in the earlier installation. You must 
complete this step on both the server and the workstation.

14____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

15____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2019 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 77.

16____ For the Job Cost and Payroll modules, recreate all Visual Integrator import 
and export jobs. 

       NOTE 
Before modifying 
the graphical 
forms or reports 
found on the 
Custom Reports 
menu, you must 
be proficient in 
the use of SAP 
Crystal Reports.
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17____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

18____ Review your Business Insights Dashboard pages. For more information, 
see Set Up Business Insights Dashboard in the Help system.

19____ To use the eBusiness Manager module, restore the copied templates back 
to the IW folder after re-installing the Web Engine.

Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

20____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.

21____ Print all customized form definitions and compare them to the ones 
previously printed. Default forms may be erased in the upgrade process.

22____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

23____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

24____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

25____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

26____ Test all printers, including Device Configurator printers, that you normally 
use for printing forms and reports. Each workstation must have a default 
printer defined.

27____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  

To run the utility, select Library Master > Utilities > Build Search Index. 

28____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.
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If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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Upgrading from Version 4.45 to 
Sage 100 Premium Version 2019
Before upgrading your data to version 2019, you must perform a parallel installation 
and run the Parallel Migration utility from the Windows Start menu > All Programs > 
Sage program group. For more information, consult with your Sage business 
partner.

If you have custom modules or modifications to any of your modules, consult your 
Sage business partner or development partner prior to beginning the upgrade 
process.

Pre-Upgrade Checklist
You must prepare your version 4.45 data for upgrade. This should be done for each 
company you plan to upgrade. Several steps should be completed by a SQL 
Server® administrator.

1____ Process all pending credit card transactions.

2____ Print and update all journals and registers. Failure to do so may result in 
loss of data.

3____ Create a backup of your version 4.45 MAS90 folder, which includes data for 
all of your companies. Perform this step following your usual backup 
process. For specific support on how to back up your data, refer to manuals 
for your backup software or contact the vendor from whom you purchased 
that product.

4____ Rebuild all data files using the Rebuild Sort File utility. You must answer Yes 
to all recalculation questions.

5____ Print all customized form definitions.

6____ If you are upgrading Sage 100 Premium, configure your firewall to allow 
access to port number 1433 on the server with your version 4.45 
installation. Port 1433 is the default SQL Server port. 

Upgrade Checklist

After completing the Pre-Upgrade Checklist on this page, you are now ready to 
migrate your data to your version 2019 system.

1____ Start the Parallel Migration Wizard using one of the methods below, and 
follow the steps in the wizard to migrate your data.

 If you are using Windows Server 2008, start the Parallel Migration 
Wizard from the Sage program group on the Start menu.

 If you are using Windows Server 2012, start the Parallel Migration 
Wizard from the Start window. 

       NOTE 
You must print 
and update all 
journals and 
registers to 
prevent possible 
data loss during 
data upgrade. 

WARNING 
You must have 
administrator 
rights for the 
server with the 
installation you 
are migrating 
from and the 
server with your 
version 2019 
installation.
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The Migration Wizard will back up the Sage 100 SQL databases for your 
prior version of Sage 100, copy the backup files to the server where Sage 
100 2019 SQL Server instance is installed, and then restore them in the 
new location. Administrative rights are required for both your prior version of 
Sage 100 and for version 2019. The person running the Migration Wizard 
must have rights to the following administrative share: 
\\{sourceserver-name}\c$ 

If local security settings prevent the wizard from migrating the databases, 
use SQL Server Management Studio to back up the MAS_System and 
company databases that you want to migrate. Then copy the .BAK files to 
the ..\MSSQL\Data folder on the server where the Sage 100 2019 SQL 
Server instance is installed.

2____ After the migration is complete, log into Sage 100 2019 as the 
Administrator. Use the tasks available from the Administrative Tools window 
to review user security and set up and assign the appropriate roles to your 
users.

3____ Review security tasks for new features in version 2019.

4____ If you are using Unified Logon and you upgraded your system files, you 
must add the following statement on one workstation SOTA.ini: Logon=Yes. 

5____ If you customized your Desktop, review the customizations. 

Data Conversion Checklist
After completing the steps in the Pre-Upgrade Checklist on page 71 and the 
Upgrade Checklist on page 71, you are now ready to convert your data to version 
2019.

1____ If your company data contains credit card information, install the latest 
version of Sage Exchange and verify that the workstation you are using has 
a working Internet connection. This is necessary so that credit card records 
can be transferred to a Sage Exchange Vault account during conversion. 
Credit card records must be transferred to a Sage Exchange Vault account 
before company data can be converted.

To install Sage Exchange:

a Start the Sage 100 installation program.

b Select your edition of Sage 100. 

c Click Productivity Applications. 

d Click Install Sage Exchange Desktop to start the installation wizard.

e Proceed through the wizard to install the program.  

2____ Select Library Master Main menu > Company Maintenance to convert your 
data to version 2019. This must be done for each of your companies.

       NOTE 
If you’re going to 
convert data for the 
Payroll module, 
you’ll need access 
to Tax Profile 
Maintenance. If you 
use Payroll 
departments, you 
must have access 
to all departments in 
each company.  
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If your data contains credit card records that will be transferred to a Sage 
Exchange Vault account, the Credit Card Conversion To Sage Exchange 
Vault Time Estimate window appears. This window provides an estimate of 
how long it will take to transfer the credit card data. This estimate is based 
on benchmark test results, but results will vary based on Internet connection 
speed, network traffic, and the number of customer credit card records 
stored in your system. 

You may be able to decrease the estimate by updating credit card 
transactions and purging credit card data. If this window appears, click Yes 
to proceed with data conversion or click No to stop the conversion process. 

Additional time is required to convert company data after the credit card 
records are transferred; that time is not included in the estimate shown on 
the window. 

3____ Verify that credit card processing is enabled for each company in Company 
Maintenance if credit cards were previously being processed using Sage 
Payment Solutions. For more information, see Set Up the Credit Card 
Processing Module in the Help system.

If you were not processing transactions through Sage Payment Solutions 
but plan to start doing so, contact your Sage Payment Solutions account 
executive to convert the Sage Exchange Vault-only account created during 
conversion to a processing account.

4____ Update customized panels by selecting Custom Office Utilities menu > 
Update Customized Panels to Current Level. Review the placement of all 
user-defined fields. 

5____ If you have customized Advanced Lookup Engine (ALE) lookups, after 
converting to the new version of the software and prior to accessing other 
modules, select Library Master Utilities menu > Lookup Conversion to 
convert your lookups.

6____ Verify that all module links are functional by selecting Library Master Utilities 
menu > Link Maintenance Utility. Links that appear in red are broken and 
will need to be fixed using the Relink button in Link Maintenance Utility. For 
more information on relinking files, see Copy/Move/Relink Files in your Help 
system.

7____ If you had the Extended Solution for customers with national accounts and 
the Populate Bill Address Block with ’Bill To’ Customer Block check box was 
selected in AR-1068 Setup Options, you must run the Sales Order Bill To 
Address Fix Utility (select File menu > Run, then type *Utl) to populate the 
sales order bill-to address information with the bill-to customer’s address 
information. 

8____ Test your modified SAP Crystal reports and forms. Use SAP Crystal Reports 
Designer to modify reports as needed. 
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You must either be logged on using a Windows account that has read 
access to the applicable SQL Server database, or you must have a 
separate SQL Server authenticated logon ID and password. Integrated 
Security is used by default; if your Windows account does not have rights to 
the database, a logon dialog box appears, allowing you to enter a different 
logon ID and password for database access.

Before modifying forms or the standard Crystal reports found on the Custom 
Reports menu, you must be proficient in the use of SAP Crystal Reports.

9____ If Sage 100 2018 is installed on the same computer as an earlier version of 
Sage 100, complete this step to avoid errors when printing forms and 
reports in the earlier version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 
2018 installation to the same folder in the earlier installation. You must 
complete this step on both the server and the workstation.

10____ If your system has custom reports, review the Custom Reports menus to 
make sure they are available. If they are not, add them using Report 
Manager.

11____ If you use Sage Intelligence Reporting, create a new repository for use with 
Sage 100 2019 and import any custom reports into it. For detailed 
instructions, see Upgrading Sage Intelligence Reporting on page 77.

12____ If dictionary changes were made to any files used for import or export jobs 
created in the Visual Integrator module, those jobs will need to be manually 
updated.

To determine if manual updates are required, review the associated file 
layout information using the File Layouts and Program Information link on 
the Resources page of the Desktop. Verify that the imported field names are 
consistent with the new file layouts.

13____ Review the Paperless Office module configuration for e-mailing statements, 
reports, journals, registers, and other forms. For more information, see Set 
Up Paperless Office in the Help system.

14____ If you do not use taxation for purchase orders, clear the Sales Tax Reporting 
check box in Accounts Payable Options.

15____ If you include sales tax on purchase orders and want to enter default tax 
schedules for vendors, use Accounts Payable Assign Vendor Tax 
Schedules to set up tax schedules.

16____ Confirm in Accounts Receivable Customer Maintenance that all customers 
that have exemption numbers still have the exemption number defined.

17____ To unhide the Custom Financials menu and tasks, select File menu > Run 
and type *unhidegl in the Run Program window.
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18____ If you purchased the Return Merchandise Authorization module, after 
setting up the data files for the first time, select Return Merchandise 
Authorization Setup menu > Create Customer Invoice Search Records to 
create customer invoice search records in RMA.

19____ To run Microsoft Script links, you must have the Microsoft Windows Script 
Host processor on your system. For information on installing the Microsoft 
Windows Script Host processor, refer to the Microsoft Download Center 
Web site.

20____ If you use Automatic Update or Task Scheduler, review your scheduled 
automatic updates and reschedule those updates by selecting Library 
Master Main menu > Automatic Update or Task Scheduler, as applicable.

21____ If you had task folders in your My Tasks area, re-create your Public and 
Private task folders.

22____ Test all printers, that you normally use for printing forms and reports. Each 
workstation must have a default printer defined.

23____ To use the auto-complete feature with enhanced search, run the Build 
Search Index utility to index your existing customer, vendor, and item 
records.  

To run the utility, select Library Master > Utilities > Build Search Index. 

24____ Install Sage Exchange Desktop on each workstation for each Windows user 
who needs to access credit card and ACH payment information in 
Sage 100. 

To install Sage Exchange Desktop for Sage 100 Standard: 

a Use Windows Explorer to browse to the MAS90\Wksetup folder.

If you are installing Sage Exchange Desktop on a workstation that 
connects to a Sage 100 Standard installation on a server, browser to 
the MAS90\Wksetup folder on the server.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.

c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.

To install Sage Exchange Desktop for Sage 100 Advanced and 
Premium:

a Use Windows Explorer to browse to the server where Sage 100 is 
installed, and locate the MAS90\Wksetup folder.

b Double-click Autorun.exe to open the Workstation Setup program; it 
takes a few seconds to launch.
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c Click Install Sage Exchange Desktop.

d Proceed through the steps in the Sage Exchange Desktop installation 
wizard to install the program.
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Upgrading Sage Intelligence Reporting
Appendix A

If you use Sage Intelligence Reporting, follow the steps in this chapter to create a 
new repository for Sage 100 2019. If you have custom reports, follow the instructions 
to export custom reports from your prior version of the program and import them into 
the new repository. 

For detailed instructions on each step, see:

 Export Custom Reports on this page

 Create a New Repository on page 78

 Set Up Sage Intelligence Reporting in Sage 100 2019 on page 78

 Import Custom Reports on page 79

Report Compatibility
Reports can be imported only from an earlier version of the program or another 
instance of the same version. For example, you can import a report created in 
version 2013 into version 2019. You cannot import a report created in version 2019 
into version 2013.  

Reports created in Sage 100 Standard and Sage 100 Advanced are not compatible 
with Sage 100 Premium. Likewise, reports created in Sage 100 Premium are not 
compatible with  Sage 100 Standard and Sage 100 Advanced.

Export Custom Reports
In your prior version of Sage 100, export all of the custom reports that you want to 
use in version 2019.

To export custom reports

1 In your prior version of Sage 100, select Sage Intelligence Reporting Main menu 
> Report Manager. 

2 Right-click a report and then click Export Report. (Alternately, select a report and 
then, on the Tools menu, click Export Report.)

3 Select the location where you want to save the file and then click Save. A file 
with an AL_ extension is created.  

4 Repeat these steps for all custom reports that you want to use in version 2019.
Sage 100 2019 Upgrade Checklist                                                                                                                      Page 77



Create a New Repository
Create a New Repository
Create a shared folder to use as the Sage Intelligence Reporting repository for 
Sage 100 2019. We recommend using a separate repository for each installation of 
Sage Intelligence Reporting. 

To create a repository 

1 Use Windows File Explorer to create a folder in the desired location.

2 Right-click the folder, point to "Share with," and click "Advanced sharing."

3 On the Sharing tab, select the "Share this folder" check box.

4 Enter a share name.

5 Click Permissions.  

6 For all applicable users, select the Full Control or Read and Write check boxes. 

7 Click OK. 

8 If you use reporting trees or distribution settings, copy the following folders from 
the old repository to the new one:

 Report Trees

 Distribution

Set Up Sage Intelligence Reporting in Sage 100 
2019

After creating the shared folder, enter its location in Sage 100 2019. If you haven’t 
already registered your 2019 version of Sage Intelligence Reporting, you will be 
asked to do so. 

To set up Sage Intelligence Reporting

1 In Sage 100 2019, select Sage Intelligence Reporting Main menu > Report 
Manager.

2 Click File and then click Change. 

3 Click Yes in the message window.

4 In the Network Repository Path field, type the UNC path to the shared folder that 
you created. For example: \\ServerName\ReportRpository

5 Click OK.

6 If you receive a message asking you to register Sage Intelligence Reporting, 
click OK to open the License Manager window.

       NOTE 
These steps may 
vary depending 
on what version 
of Windows you 
are using. Check 
with your network 
administrator if 
you need 
assistance. 
Sage 100 2019 Upgrade Checklist                                                                                                                      Page 78



Import Custom Reports
7 In the Account Number field, enter your Sage customer number.

8 In the Serial Number field, enter you unlocking key. This field is case-sensitive. 

9 Click Apply and then click Perform Registration. 

Import Custom Reports
After creating the new repository and registering Sage Intelligence Reporting, import 
any custom report files.

To import custom reports

1 If you want to create folders to organize your reports, on the Home tab, click Add 
Folder. 

2 Right-click either the Home folder or any custom folder created in step 1, and 
click Import Report. (Alternately, you can click the Tools tab, and then click 
Import Report.) 

3 Select one of the custom reports that you exported from your prior version.

4 In the Import Report window, in the Target Connection field, select a connection. 

 For consolidated reports, select Sage MAS Consolidation. 

 For any other type of report, select Sage MAS (Auto Connect).  

5 In the Report Destination field, select the folder for the report. 

6 Click Import.

7 On the Home tab in the Actions group, click Refresh.

8 Repeat these steps for any other custom reports that you exported from your 
prior version of Sage Intelligence Reporting. 

       NOTE 
You must own the 
Sage 100 
Intelligence 
Connector 
module to 
generate 
consolidated 
reports. 
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