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Upgrade Checklists
These checklists provide instructions for migrating your data from your older Sage 100 
installation and then upgrading the data to version 2023.

If you haven’t already, follow the instructions in the Sage 100 2023 Installation and 
System Administrator’s Guide to install and set up Sage 100 2023. The guide is in the 
Documents folder accessible within the installation program, and it’s also available on the 
Sage 100 Documents page.  

The data upgrade process consists of three steps:

 1. Preparing your data for upgrading

 2. Migrating your data to your version 2023 installation

 3. Converting your data to version 2023

This guide contains the information you'll need to migrate and convert your data. Use one 
of the following checklists based on the version of Sage 100 you're upgrading from. 

 l "Upgrading from Version 2022 to Version 2023" (page 2)

 l "Upgrading from Version 2021 to Version 2023" (page 13)

 l "Upgrading from Version 2020 to Version 2023" (page 24)

 l "Upgrading from Version 2019 to Version 2023" (page 35)

 l "Upgrading from Version 2018 to Version 2023" (page 46)

 l "Upgrading from Version 2017 to Version 2023" (page 57) 
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Upgrading from Version 2022 to Version 2023

Upgrading from Version 2022 to Version 
2023
When upgrading to version 2023, you must perform a parallel installation, and use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your Sage 
business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrator's Guide. 
You can find the guide on the Sage 100 Documents page. 

Pre-Upgrade Checklist
You must prepare your version 2022 data for upgrading. This should be done for each 
company you plan to upgrade.

Complete these steps in your version 2022 installation. 

 1. Process all pending credit card transactions.

 2. Print and update all journals and registers.             

Important! Failure to complete this step may result in loss of data.

 3. If you use the Payroll module:             

 l Update the Payroll Check Register.

 l Complete and purge all direct deposit transactions.

You must install the Payroll module in addition to installing Sage 100. Payroll is 
not part of the Sage 100 installation program. To avoid the need to run a 
separate data conversion for Payroll, install the module before proceeding to 
the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade Guide 
available on the Sage 100 Documents page. 
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 4. If you're upgrading the Work Order module to Production Management, run Work 
Order Purge to move closed work orders into the history files. Work Order Purge is 
located on the Work Order Main menu.     

 5. Create a backup of your version 2022 MAS90 folder, which includes data for all of 
your companies. Perform this step following your usual backup process. For 
specific support on how to back up your data, refer to manuals for your backup 
software or contact the vendor from whom you purchased that product.

 6. Rebuild all data files.             

 l If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild 
Key Files and Rebuild Sort File utilities.

 l If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

You must answer Yes to all recalculation questions.

 7. Print all customized form definitions.

 8. If you are using eBusiness Manager, back up any templates, .htm files, and the IW 
folder before uninstalling the previous version of the Web Engine.

 9. Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before migrating 
your data. For more information, see the Pre-Migration Utility help.

 10. If you are upgrading Sage 100 Premium, configure your firewall to allow access to 
port number 1433 on the server with your version 2022 installation. Port 1433 is the 
default SQL Server port

Upgrade Checklist 
After completing the "Pre-Upgrade Checklist" (page 2), you are ready to migrate your 
data to your version 2023 system.

Complete these steps in your version 2023 installation.

 l For Sage 100 Standard or Advanced, use the checklist below. 

 l For Sage 100 Premium, see "Upgrade Checklist for Sage 100 Premium " (page 4).

Note: If you’re going to convert data for the Payroll module, you’ll need access to 
Tax Profile Maintenance. If you use Payroll departments, you must have access 
to all departments in each company.

Sage 100 Upgrade Checklists 3

Upgrade Checklist



Upgrade Checklist

Upgrade Checklist for Sage 100 Standard and Advanced
 1. Create a backup of your version 2023 MAS90 folder. Creating a backup now will 

save time if you need to revert to the folder’s original state. 

 2. Log into Sage 100 2023 as the Administrator. From the Administrative Tools 
window:             

 a. Start Role Maintenance and create a role that you’ll use to run the Parallel 
Migration Wizard. 

 b. On the Tasks tab, expand Library Master > Miscellaneous Tasks, and then 
select the Parallel Migration check box.

 c. Start User Maintenance, create a logon, and select the role that you created.

 d. Close the Administrative Tools window.

 3. Log in to Sage 100 2023, and select Library Master > Utilities > Parallel Migration. 
Follow the steps in the wizard to migrate your data. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security and 
set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Upgrade Checklist for Sage 100 Premium 
Use this checklist to migrate your Sage 100 Premium data.
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Important!  

 l You must have administrator rights for the server with your prior version of Sage 
100 and the server with your version 2023 installation.

 l Clustered drives do not allow hidden shares. If you are using clustered drives, 
follow the instructions in the Manual Workaround section of article number 
76993 in the Sage Knowledgebase.

 1. For your Sage 100 2023 installation, create a backup of the following:             

 a. The Sage 100 MAS90 folder

 b. The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s original 
state. 

 2. Verify that the required rights and permissions are set up on the server(s) where 
SQL Server is installed. If the instance of SQL Server for Sage 100 2023 is installed 
on a different server than the instance used for your prior version, you must 
complete these steps on both servers.                  

 a. Open the Control Panel, select Administrative Tools, and then select 
Services. 

 b. In the Services window, locate the SQL Server instance used for Sage 100 
Premium, right-click it, and select Properties.

 c. In the Properties window, click the Log On tab and select an option.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on the same server as the instance used for your prior version of Sage 
100 Premium, select Local System Account.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on a different server than the one used for your prior version of Sage 
100 Premium, select This Account.

In the account field, enter: \\ServerName\Administrator  

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.
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Upgrade Checklist

 d. Apply your changes and then stop and restart the services.

 e. If you’re working with more than one server, make sure that all servers can 
access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

 3. Start the Parallel Migration Wizard using one of the methods below, and follow the 
steps in the wizard.             

 l If you are using Windows Server 2008, start the Parallel Migration Wizard from 
the Sage program group on the Start menu.

 l If you are using Windows Server 2012 or later, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two SQL 
Server locations. The hidden shares are used to access the source databases to 
create the .bak files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share of the 
destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the new SQL 
Server location and removes the .bak files from both the source and destination 
locations.

If permissions were not set correctly on both servers, you may receive the following 
error: "Error Number : 0x80040e14 Description: Access Denied 5 or Access Denied 
2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security and 
set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 
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You're now ready to convert your data to version 2023. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Data Conversion Checklist
Follow these steps to convert your data. 

 1. If your company data contains credit card information, install the latest version of 
Paya Connect Desktop and verify that the workstation you are using has a working 
internet connection. This is necessary so that credit card records can be transferred 
to a Paya Exchange Vault account during conversion. Credit card records must be 
transferred to a Paya Exchange Vault account before company data can be 
converted.                       
 
To install Paya Connect Desktop:

 a. Start the Sage 100 installation program.

 b. Click Productivity Applications.

 c. Click Install Paya Connect Desktop to start the installation wizard.

 d. Proceed through the wizard to install the program.

 2. Select Library Master Main menu > Company Maintenance. Select a company, and 
then click Convert to convert your data. You must convert data for each of your 
companies. In addition, you can select one or more of the following options:                              

 l Convert Data for All Companies: Select this check box to convert data for all of 
your companies instead of doing it one-by-one. This check box may be 
unavailable if you’re converting Payroll data, depending on which version of 
Payroll you’re upgrading from. 

 l Convert SAP Crystal Reports: Select this check box to convert all of your 
custom reports and forms. The time required to convert your reports and forms 
depends on how many of them you have that need to be converted. The 
process runs in the background, and you can continue working in Sage 100 
while it’s running. 
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Data Conversion Checklist

You can convert custom forms and reports later by running the Sage 100 
Crystal Report Conversion Wizard.

 l Update Custom Office Panels to Current Level: Select this check box to run the 
Custom Office panel update for any customized panels for the companies being 
converted. This update runs without any prompts.

You can update custom panels later by running the Update Customized Panels 
to Current Level utility on the Custom Office Utilities menu. 

 3. If you were not processing transactions through Paya but plan to start doing so, 
contact Paya to convert the Paya Exchange Vault-Only account created during 
conversion to a processing account.

 4. If your system is integrated with Sage CRM, go into CRM Server Options, and 
update the following information as needed.             

 l Integration server port ID

 l Sage CRM SQL server name

 l Sage CRM SQL database name

The server name and database name should reference the mirror installation that 
you created for integration with Sage 100 2023. For more information on this 
process, refer to the Installing Sage CRM section in the Sage 100 Installation and 
System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

 5. If you synchronize payroll data between your General Ledger module and Sage 
Payroll Services, verify that your Sage 100 company or companies are still linked to 
the service. 

 a. Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

 b. Sign in to Sage Payroll Services. 

 c. Proceed through the wizard. 

 d. Review the status messages shown in the Synchronizing Data with Sage 
Payroll Services window. 

If you see a "Synchronization Complete" message, no further action is 
required. 
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If you see a "Synchronization failed" message, contact iSolved Support for 
assistance with resetting the link.   

 6. Update customized panels by selecting Custom Office Utilities menu > Update 
Customized Panels to Current Level. Review the placement of all user-defined 
fields. 

 7. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to 
the new version of the software and prior to accessing other modules, select Library 
Master Utilities menu > Lookup Conversion to convert your lookups. 

 8. Verify that all module links are functional by selecting Library Master Utilities menu 
> Link Maintenance Utility. Links that appear in red are broken and will need to be 
fixed using the Relink button in Link Maintenance Utility. For more information on 
relinking files, see Copy/Move/Relink Files in your Help system.

 9. If you are also upgrading your Payroll Module, review the list of enhancements and 
upgrade instructions in the Sage 100 Payroll Installation and Upgrade Guide, 
available on the Sage 100 Documents page. 

 10. Test your customized Crystal reports and forms.             

 l If you need to troubleshoot issues with customized reports and forms, run the 
Crystal Form Comparison Report utility to compare your customized reports 
and forms to the standard ones in version 2023.

To run the utility, select File menu > Run, and then type SYWFCU. The utility 
tells you which tables, if any, have been added to a report or form. It does not 
provide information about formatting changes, such as those affecting fonts, 
logos, and so forth 

 l If you were previously using non-graphical forms, you will need to set them up 
using SAP Crystal Reports.

 l If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For more 
information, see SAP Crystal Reports FAQs in the Help system. If you do not 
run the wizard now, it will automatically run the first time that someone runs a 
form or report.

 l If you are using Sage 100 Premium, refer to the Converting Reports for Sage 
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Data Conversion Checklist

100 Premium section in the Sage 100 Installation and System Administrator's 
Guide for more information.

 11. If Sage 100 2023 is installed on the same computer as an earlier version of Sage 
100, complete this step to avoid errors when printing forms and reports in the earlier 
version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 2022 
installation to the same folder in your 2023 installation. You must complete this step 
on both the server and the workstation.

 12. If your system has custom reports, review the Custom Reports menus to make sure 
they are available. If they are not, add them using Report Manager.

 13. If you use Sage Intelligence Reporting, create a new repository for use with the 
latest version of Sage 100 and import any custom reports into it. For detailed 
instructions, see the "Upgrading Sage Intelligence Reporting" (page 71) checklist.

 14. Review the Paperless Office module configuration for e-mailing statements, reports, 
journals, registers, and other forms. For more information, see Set Up Paperless 
Office in the Help.

 15. Review your Business Insights Dashboard pages. For more information, see Set Up 
Business Insights Dashboard in the Help.

 16. To use the eBusiness Manager module:              

 a. Restore the copied templates back to the IW folder after re-installing the 
Web Engine.

 b. Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

 17. If you converted Work Order data to Production Management data, purchase orders 
that were linked to work orders must be manually relinked to work tickets. You can 
do this by selecting the purchase order in Purchase Order Entry and entering the 
applicable work ticket number in the Work Ticket No. field on the Lines tab. 

 18. If you use Custom Financials Reporting, you must unhide the menu and tasks. 
Select File menu > Run and type *unhidegl in the Run Program window.

 19. Print all customized form definitions and compare them to the ones previously 
printed. Default forms may be erased in the upgrade process.

 20. If you purchased the Return Merchandise Authorization module, after setting up the 
data files for the first time, select Return Merchandise Authorization Setup menu > 
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Create Customer Invoice Search Records to create customer invoice search 
records in RMA.

 21. To run Microsoft Script links, you must have the Microsoft Windows Script Host 
processor on your system. For information on installing the Microsoft Windows 
Script Host processor, refer to the Microsoft Download Center website.

 22. If you use Automatic Update or Task Scheduler, review your scheduled automatic 
updates and reschedule those updates by selecting Library Master Main menu > 
Automatic Update or Task Scheduler, as applicable.

 23. If you were using the classic Desktop, which is no longer available, and had task 
folders in your My Tasks area, you can add tasks to the Favorites list instead. For 
more information, see Add Items to the Favorites Content Group in the Help. 

 24. Test all printers, including Device Configurator printers, that you normally use for 
printing forms and reports. Each workstation must have a default printer defined.

 25. To use the auto-complete feature with enhanced search, run the Build Search Index 
utility to index your existing customer, vendor, and item records. To run the utility, 
select Library Master > Utilities > Build Search Index.             

 26. Install Paya Connect Desktop on each workstation for each Windows user who 
needs to access credit card and ACH payment information in Sage 100.             

To install Paya Connect Desktop for Sage 100 Standard: 

 a. Use File Explorer to browse to the MAS90\Wksetup folder.

If you are installing Paya Connect Desktop on a workstation that connects to 
a Sage 100 Standard installation on a server, browser to the 
MAS90\Wksetup folder on the server.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.

 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

To install Paya Connect Desktop for Sage 100 Advanced and Premium:

 a. Use File Explorer to browse to the server where Sage 100 is installed, and 
locate the MAS90\Wksetup folder.
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Data Conversion Checklist

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.

 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

 27. If you installed the 32-bit version of Sage 100 and need to convert to the 64-bit 
version, see "Converting to 64-bit Version of Sage 100" (page 70).
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Upgrading from Version 2021 to 
Version 2023
When upgrading to version 2023, you must perform a parallel installation, and use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your Sage 
business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrator's Guide. 
You can find the guide on the Sage 100 Documents page. 

Pre-Upgrade Checklist
You must prepare your version 2021 data for upgrading. This should be done for each 
company you plan to upgrade.

Complete these steps in your version 2021 installation. 

 1. Process all pending credit card transactions.

 2. Print and update all journals and registers.             

Important! Failure to complete this step may result in loss of data.

 3. If you use the Payroll module:             

 l Update the Payroll Check Register.

 l Complete and purge all direct deposit transactions.

You must install the Payroll module in addition to installing Sage 100. Payroll is 
not part of the Sage 100 installation program. To avoid the need to run a 
separate data conversion for Payroll, install the module before proceeding to 
the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade Guide 
available on the Sage 100 Documents page. 
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Upgrade Checklist

 4. If you're upgrading the Work Order module to Production Management, run Work 
Order Purge to move closed work orders into the history files. Work Order Purge is 
located on the Work Order Main menu.     

 5. Create a backup of your version 2021 MAS90 folder, which includes data for all of 
your companies. Perform this step following your usual backup process. For specific 
support on how to back up your data, refer to manuals for your backup software or 
contact the vendor from whom you purchased that product.

 6. Rebuild all data files.             

 l If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild Key 
Files and Rebuild Sort File utilities.

 l If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

You must answer Yes to all recalculation questions.

 7. Print all customized form definitions.

 8. If you are using eBusiness Manager, back up any templates, .htm files, and the IW 
folder before uninstalling the previous version of the Web Engine.

 9. Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before migrating 
your data. For more information, see the Pre-Migration Utility help.

 10. If you are upgrading Sage 100 Premium, configure your firewall to allow access to 
port number 1433 on the server with your version 2021 installation. Port 1433 is the 
default SQL Server port

Upgrade Checklist 
After completing the "Pre-Upgrade Checklist" (page 13), you are ready to migrate your 
data to your version 2023 system.

Complete these steps in your version 2023 installation.

 l For Sage 100 Standard or Advanced, use the checklist below. 

 l For Sage 100 Premium, see "Upgrade Checklist for Sage 100 Premium " (page 15).

Note: If you’re going to convert data for the Payroll module, you’ll need access to 
Tax Profile Maintenance. If you use Payroll departments, you must have access to 
all departments in each company.
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Upgrade Checklist for Sage 100 Standard and Advanced
 1. Create a backup of your version 2023 MAS90 folder. Creating a backup now will 

save time if you need to revert to the folder’s original state. 

 2. Log into Sage 100 2023 as the Administrator. From the Administrative Tools 
window:             

 a. Start Role Maintenance and create a role that you’ll use to run the Parallel 
Migration Wizard. 

 b. On the Tasks tab, expand Library Master > Miscellaneous Tasks, and then 
select the Parallel Migration check box.

 c. Start User Maintenance, create a logon, and select the role that you 
created.

 d. Close the Administrative Tools window.

 3. Log in to Sage 100 2023, and select Library Master > Utilities > Parallel Migration. 
Follow the steps in the wizard to migrate your data. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security 
and set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Upgrade Checklist for Sage 100 Premium 
Use this checklist to migrate your Sage 100 Premium data.
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Upgrade Checklist

Important!  

 l You must have administrator rights for the server with your prior version of Sage 
100 and the server with your version 2023 installation.

 l Clustered drives do not allow hidden shares. If you are using clustered drives, 
follow the instructions in the Manual Workaround section of article number 
76993 in the Sage Knowledgebase.

 1. For your Sage 100 2023 installation, create a backup of the following:             

 a. The Sage 100 MAS90 folder

 b. The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s original 
state. 

 2. Verify that the required rights and permissions are set up on the server(s) where 
SQL Server is installed. If the instance of SQL Server for Sage 100 2023 is installed 
on a different server than the instance used for your prior version, you must 
complete these steps on both servers.                  

 a. Open the Control Panel, select Administrative Tools, and then select 
Services. 

 b. In the Services window, locate the SQL Server instance used for Sage 100 
Premium, right-click it, and select Properties.

 c. In the Properties window, click the Log On tab and select an option.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on the same server as the instance used for your prior version of Sage 
100 Premium, select Local System Account.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on a different server than the one used for your prior version of Sage 
100 Premium, select This Account.

In the account field, enter: \\ServerName\Administrator  

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.
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 d. Apply your changes and then stop and restart the services.

 e. If you’re working with more than one server, make sure that all servers can 
access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

 3. Start the Parallel Migration Wizard using one of the methods below, and follow the 
steps in the wizard.             

 l If you are using Windows Server 2008, start the Parallel Migration Wizard from 
the Sage program group on the Start menu.

 l If you are using Windows Server 2012 or later, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two SQL 
Server locations. The hidden shares are used to access the source databases to 
create the .bak files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share of the 
destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the new SQL 
Server location and removes the .bak files from both the source and destination 
locations.

If permissions were not set correctly on both servers, you may receive the following 
error: "Error Number : 0x80040e14 Description: Access Denied 5 or Access Denied 
2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security 
and set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 
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Data Conversion Checklist

You're now ready to convert your data to version 2023. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Data Conversion Checklist
Follow these steps to convert your data. 

 1. If your company data contains credit card information, install the latest version of 
Paya Connect Desktop and verify that the workstation you are using has a working 
internet connection. This is necessary so that credit card records can be transferred 
to a Paya Exchange Vault account during conversion. Credit card records must be 
transferred to a Paya Exchange Vault account before company data can be 
converted.                       
 
To install Paya Connect Desktop:

 a. Start the Sage 100 installation program.

 b. Click Productivity Applications.

 c. Click Install Paya Connect Desktop to start the installation wizard.

 d. Proceed through the wizard to install the program.

 2. Select Library Master Main menu > Company Maintenance. Select a company, and 
then click Convert to convert your data. You must convert data for each of your 
companies. In addition, you can select one or more of the following options:                              

 l Convert Data for All Companies: Select this check box to convert data for all of 
your companies instead of doing it one-by-one. This check box may be 
unavailable if you’re converting Payroll data, depending on which version of 
Payroll you’re upgrading from. 

 l Convert SAP Crystal Reports: Select this check box to convert all of your 
custom reports and forms. The time required to convert your reports and forms 
depends on how many of them you have that need to be converted. The 
process runs in the background, and you can continue working in Sage 100 
while it’s running. 
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You can convert custom forms and reports later by running the Sage 100 
Crystal Report Conversion Wizard.

 l Update Custom Office Panels to Current Level: Select this check box to run the 
Custom Office panel update for any customized panels for the companies being 
converted. This update runs without any prompts.

You can update custom panels later by running the Update Customized Panels 
to Current Level utility on the Custom Office Utilities menu. 

 3. If you were not processing transactions through Paya but plan to start doing so, 
contact Paya to convert the Paya Exchange Vault-Only account created during 
conversion to a processing account.

 4. If your system is integrated with Sage CRM, go into CRM Server Options, and 
update the following information as needed.             

 l Integration server port ID

 l Sage CRM SQL server name

 l Sage CRM SQL database name

The server name and database name should reference the mirror installation that 
you created for integration with Sage 100 2023. For more information on this 
process, refer to the Installing Sage CRM section in the Sage 100 Installation and 
System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

 5. If you synchronize payroll data between your General Ledger module and Sage 
Payroll Services, verify that your Sage 100 company or companies are still linked to 
the service. 

 a. Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

 b. Sign in to Sage Payroll Services. 

 c. Proceed through the wizard. 

 d. Review the status messages shown in the Synchronizing Data with Sage 
Payroll Services window. 

If you see a "Synchronization Complete" message, no further action is 
required. 
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Data Conversion Checklist

If you see a "Synchronization failed" message, contact iSolved Support for 
assistance with resetting the link.   

 6. Update customized panels by selecting Custom Office Utilities menu > Update 
Customized Panels to Current Level. Review the placement of all user-defined 
fields. 

 7. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to 
the new version of the software and prior to accessing other modules, select Library 
Master Utilities menu > Lookup Conversion to convert your lookups. 

 8. Verify that all module links are functional by selecting Library Master Utilities menu > 
Link Maintenance Utility. Links that appear in red are broken and will need to be 
fixed using the Relink button in Link Maintenance Utility. For more information on 
relinking files, see Copy/Move/Relink Files in your Help system.

 9. If you are also upgrading your Payroll Module, review the list of enhancements and 
upgrade instructions in the Sage 100 Payroll Installation and Upgrade Guide, 
available on the Sage 100 Documents page. 

 10. Test your customized Crystal reports and forms.             

 l If you need to troubleshoot issues with customized reports and forms, run the 
Crystal Form Comparison Report utility to compare your customized reports 
and forms to the standard ones in version 2023.

To run the utility, select File menu > Run, and then type SYWFCU. The utility 
tells you which tables, if any, have been added to a report or form. It does not 
provide information about formatting changes, such as those affecting fonts, 
logos, and so forth 

 l If you were previously using non-graphical forms, you will need to set them up 
using SAP Crystal Reports.

 l If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For more 
information, see SAP Crystal Reports FAQs in the Help system. If you do not 
run the wizard now, it will automatically run the first time that someone runs a 
form or report.

 l If you are using Sage 100 Premium, refer to the Converting Reports for Sage 
100 Premium section in the Sage 100 Installation and System Administrator's 
Guide for more information.
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 11. If Sage 100 2023 is installed on the same computer as an earlier version of Sage 
100, complete this step to avoid errors when printing forms and reports in the earlier 
version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 2021 
installation to the same folder in your 2023 installation. You must complete this step 
on both the server and the workstation.

 12. If your system has custom reports, review the Custom Reports menus to make sure 
they are available. If they are not, add them using Report Manager.

 13. If you use Sage Intelligence Reporting, create a new repository for use with the 
latest version of Sage 100 and import any custom reports into it. For detailed 
instructions, see the "Upgrading Sage Intelligence Reporting" (page 71) checklist.

 14. Review the Paperless Office module configuration for e-mailing statements, reports, 
journals, registers, and other forms. For more information, see Set Up Paperless 
Office in the Help.

 15. Review your Business Insights Dashboard pages. For more information, see Set Up 
Business Insights Dashboard in the Help.

 16. To use the eBusiness Manager module:              

 a. Restore the copied templates back to the IW folder after re-installing the 
Web Engine.

 b. Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

 17. If you converted Work Order data to Production Management data, purchase orders 
that were linked to work orders must be manually relinked to work tickets. You can 
do this by selecting the purchase order in Purchase Order Entry and entering the 
applicable work ticket number in the Work Ticket No. field on the Lines tab. 

 18. If you use Custom Financials Reporting, you must unhide the menu and tasks. 
Select File menu > Run and type *unhidegl in the Run Program window.

 19. Print all customized form definitions and compare them to the ones previously 
printed. Default forms may be erased in the upgrade process.

 20. If you purchased the Return Merchandise Authorization module, after setting up the 
data files for the first time, select Return Merchandise Authorization Setup menu > 
Create Customer Invoice Search Records to create customer invoice search 
records in RMA.
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 21. To run Microsoft Script links, you must have the Microsoft Windows Script Host 
processor on your system. For information on installing the Microsoft Windows 
Script Host processor, refer to the Microsoft Download Center website.

 22. If you use Automatic Update or Task Scheduler, review your scheduled automatic 
updates and reschedule those updates by selecting Library Master Main menu > 
Automatic Update or Task Scheduler, as applicable.

 23. If you were using the classic Desktop, which is no longer available, and had task 
folders in your My Tasks area, you can add tasks to the Favorites list instead. For 
more information, see Add Items to the Favorites Content Group in the Help. 

 24. Test all printers, including Device Configurator printers, that you normally use for 
printing forms and reports. Each workstation must have a default printer defined.

 25. To use the auto-complete feature with enhanced search, run the Build Search Index 
utility to index your existing customer, vendor, and item records. To run the utility, 
select Library Master > Utilities > Build Search Index.             

 26. Install Paya Connect Desktop on each workstation for each Windows user who 
needs to access credit card and ACH payment information in Sage 100.             

To install Paya Connect Desktop for Sage 100 Standard: 

 a. Use File Explorer to browse to the MAS90\Wksetup folder.

If you are installing Paya Connect Desktop on a workstation that connects to 
a Sage 100 Standard installation on a server, browser to the 
MAS90\Wksetup folder on the server.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.

 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

To install Paya Connect Desktop for Sage 100 Advanced and Premium:

 a. Use File Explorer to browse to the server where Sage 100 is installed, and 
locate the MAS90\Wksetup folder.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.
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 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

 27. If you installed the 32-bit version of Sage 100 and need to convert to the 64-bit 
version, see "Converting to 64-bit Version of Sage 100" (page 70).
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Upgrading from Version 2020 to Version 2023

Upgrading from Version 2020 to Version 
2023
When upgrading to version 2023, you must perform a parallel installation, and use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your Sage 
business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrator's Guide. 
You can find the guide on the Sage 100 Documents page. 

Pre-Upgrade Checklist
You must prepare your version 2020 data for upgrading. This should be done for each 
company you plan to upgrade.

Complete these steps in your version 2020 installation. 

 1. Process all pending credit card transactions.

 2. Print and update all journals and registers.             

Important! Failure to complete this step may result in loss of data.

 3. If you use the Payroll module:             

 l Update the Payroll Check Register.

 l Complete and purge all direct deposit transactions.

You must install the Payroll module in addition to installing Sage 100. Payroll is 
not part of the Sage 100 installation program. To avoid the need to run a 
separate data conversion for Payroll, install the module before proceeding to 
the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade Guide 
available on the Sage 100 Documents page. 
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 4. If you're upgrading the Work Order module to Production Management, run Work 
Order Purge to move closed work orders into the history files. Work Order Purge is 
located on the Work Order Main menu.     

 5. Create a backup of your version 2020 MAS90 folder, which includes data for all of 
your companies. Perform this step following your usual backup process. For 
specific support on how to back up your data, refer to manuals for your backup 
software or contact the vendor from whom you purchased that product.

 6. Rebuild all data files.             

 l If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild 
Key Files and Rebuild Sort File utilities.

 l If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

You must answer Yes to all recalculation questions.

 7. Print all customized form definitions.

 8. If you are using eBusiness Manager, back up any templates, .htm files, and the IW 
folder before uninstalling the previous version of the Web Engine.

 9. Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before migrating 
your data. For more information, see the Pre-Migration Utility help.

 10. If you are upgrading Sage 100 Premium, configure your firewall to allow access to 
port number 1433 on the server with your version 2020 installation. Port 1433 is the 
default SQL Server port.

Upgrade Checklist 
After completing the "Pre-Upgrade Checklist" (page 24), you are ready to migrate your 
data to your version 2023 system.

Complete these steps in your version 2023 installation.

 l For Sage 100 Standard or Advanced, use the checklist below. 

 l For Sage 100 Premium, see "Upgrade Checklist for Sage 100 Premium " (page 26).

Note: If you’re going to convert data for the Payroll module, you’ll need access to 
Tax Profile Maintenance. If you use Payroll departments, you must have access 
to all departments in each company.
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Upgrade Checklist

Upgrade Checklist for Sage 100 Standard and Advanced
 1. Create a backup of your version 2023 MAS90 folder. Creating a backup now will 

save time if you need to revert to the folder’s original state. 

 2. Log into Sage 100 2023 as the Administrator. From the Administrative Tools 
window:             

 a. Start Role Maintenance and create a role that you’ll use to run the Parallel 
Migration Wizard. 

 b. On the Tasks tab, expand Library Master > Miscellaneous Tasks, and then 
select the Parallel Migration check box.

 c. Start User Maintenance, create a logon, and select the role that you created.

 d. Close the Administrative Tools window.

 3. Log in to Sage 100 2023, and select Library Master > Utilities > Parallel Migration. 
Follow the steps in the wizard to migrate your data. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security and 
set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Upgrade Checklist for Sage 100 Premium 
Use this checklist to migrate your Sage 100 Premium data.
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Important!  

 l You must have administrator rights for the server with your prior version of Sage 
100 and the server with your version 2023 installation.

 l Clustered drives do not allow hidden shares. If you are using clustered drives, 
follow the instructions in the Manual Workaround section of article number 
76993 in the Sage Knowledgebase.

 1. For your Sage 100 2023 installation, create a backup of the following:             

 a. The Sage 100 MAS90 folder

 b. The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s original 
state. 

 2. Verify that the required rights and permissions are set up on the server(s) where 
SQL Server is installed. If the instance of SQL Server for Sage 100 2023 is installed 
on a different server than the instance used for your prior version, you must 
complete these steps on both servers.                  

 a. Open the Control Panel, select Administrative Tools, and then select 
Services. 

 b. In the Services window, locate the SQL Server instance used for Sage 100 
Premium, right-click it, and select Properties.

 c. In the Properties window, click the Log On tab and select an option.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on the same server as the instance used for your prior version of Sage 
100 Premium, select Local System Account.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on a different server than the one used for your prior version of Sage 
100 Premium, select This Account.

In the account field, enter: \\ServerName\Administrator  

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.
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Upgrade Checklist

 d. Apply your changes and then stop and restart the services.

 e. If you’re working with more than one server, make sure that all servers can 
access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

 3. Start the Parallel Migration Wizard using one of the methods below, and follow the 
steps in the wizard.             

 l If you are using Windows Server 2008, start the Parallel Migration Wizard from 
the Sage program group on the Start menu.

 l If you are using Windows Server 2012 or later, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two SQL 
Server locations. The hidden shares are used to access the source databases to 
create the .bak files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share of the 
destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the new SQL 
Server location and removes the .bak files from both the source and destination 
locations.

If permissions were not set correctly on both servers, you may receive the following 
error: "Error Number : 0x80040e14 Description: Access Denied 5 or Access Denied 
2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security and 
set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 
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You're now ready to convert your data to version 2023. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Data Conversion Checklist
Follow these steps to convert your data. 

 1. If your company data contains credit card information, install the latest version of 
Paya Connect Desktop and verify that the workstation you are using has a working 
internet connection. This is necessary so that credit card records can be transferred 
to a Paya Exchange Vault account during conversion. Credit card records must be 
transferred to a Paya Exchange Vault account before company data can be 
converted.                       
 
To install Paya Connect Desktop:

 a. Start the Sage 100 installation program.

 b. Click Productivity Applications.

 c. Click Install Paya Connect Desktop to start the installation wizard.

 d. Proceed through the wizard to install the program.

 2. Select Library Master Main menu > Company Maintenance. Select a company, and 
then click Convert to convert your data. You must convert data for each of your 
companies. In addition, you can select one or more of the following options:                              

 l Convert Data for All Companies: Select this check box to convert data for all of 
your companies instead of doing it one-by-one. This check box may be 
unavailable if you’re converting Payroll data, depending on which version of 
Payroll you’re upgrading from. 

 l Convert SAP Crystal Reports: Select this check box to convert all of your 
custom reports and forms. The time required to convert your reports and forms 
depends on how many of them you have that need to be converted. The 
process runs in the background, and you can continue working in Sage 100 
while it’s running. 
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You can convert custom forms and reports later by running the Sage 100 
Crystal Report Conversion Wizard.

 l Update Custom Office Panels to Current Level: Select this check box to run the 
Custom Office panel update for any customized panels for the companies being 
converted. This update runs without any prompts.

You can update custom panels later by running the Update Customized Panels 
to Current Level utility on the Custom Office Utilities menu. 

 3. If you were not processing transactions through Paya but plan to start doing so, 
contact Paya to convert the Paya Exchange Vault-Only account created during 
conversion to a processing account.

 4. If your system is integrated with Sage CRM, go into CRM Server Options, and 
update the following information as needed.             

 l Integration server port ID

 l Sage CRM SQL server name

 l Sage CRM SQL database name

The server name and database name should reference the mirror installation that 
you created for integration with Sage 100 2023. For more information on this 
process, refer to the Installing Sage CRM section in the Sage 100 Installation and 
System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

 5. If you synchronize payroll data between your General Ledger module and Sage 
Payroll Services, verify that your Sage 100 company or companies are still linked to 
the service. 

 a. Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

 b. Sign in to Sage Payroll Services. 

 c. Proceed through the wizard. 

 d. Review the status messages shown in the Synchronizing Data with Sage 
Payroll Services window. 

If you see a "Synchronization Complete" message, no further action is 
required. 
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If you see a "Synchronization failed" message, contact iSolved Support for 
assistance with resetting the link.   

 6. Update customized panels by selecting Custom Office Utilities menu > Update 
Customized Panels to Current Level. Review the placement of all user-defined 
fields. 

 7. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to 
the new version of the software and prior to accessing other modules, select Library 
Master Utilities menu > Lookup Conversion to convert your lookups. 

 8. Verify that all module links are functional by selecting Library Master Utilities menu 
> Link Maintenance Utility. Links that appear in red are broken and will need to be 
fixed using the Relink button in Link Maintenance Utility. For more information on 
relinking files, see Copy/Move/Relink Files in your Help system.

 9. If you are also upgrading your Payroll Module, review the list of enhancements and 
upgrade instructions in the Sage 100 Payroll Installation and Upgrade Guide, 
available on the Sage 100 Documents page. 

 10. Test your customized Crystal reports and forms.             

 l If you need to troubleshoot issues with customized reports and forms, run the 
Crystal Form Comparison Report utility to compare your customized reports 
and forms to the standard ones in version 2023.

To run the utility, select File menu > Run, and then type SYWFCU. The utility 
tells you which tables, if any, have been added to a report or form. It does not 
provide information about formatting changes, such as those affecting fonts, 
logos, and so forth 

 l If you were previously using non-graphical forms, you will need to set them up 
using SAP Crystal Reports.

 l If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For more 
information, see SAP Crystal Reports FAQs in the Help system. If you do not 
run the wizard now, it will automatically run the first time that someone runs a 
form or report.

 l If you are using Sage 100 Premium, refer to the Converting Reports for Sage 
100 Premium section in the Sage 100 Installation and System Administrator's 
Guide for more information.
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Data Conversion Checklist

 11. If Sage 100 2023 is installed on the same computer as an earlier version of Sage 
100, complete this step to avoid errors when printing forms and reports in the earlier 
version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 2020 
installation to the same folder in your 2023 installation. You must complete this step 
on both the server and the workstation.

 12. If your system has custom reports, review the Custom Reports menus to make sure 
they are available. If they are not, add them using Report Manager.

 13. If you use Sage Intelligence Reporting, create a new repository for use with the 
latest version of Sage 100 and import any custom reports into it. For detailed 
instructions, see the "Upgrading Sage Intelligence Reporting" (page 71) checklist.

 14. Review the Paperless Office module configuration for e-mailing statements, reports, 
journals, registers, and other forms. For more information, see Set Up Paperless 
Office in the Help.

 15. Review your Business Insights Dashboard pages. For more information, see Set Up 
Business Insights Dashboard in the Help.

 16. To use the eBusiness Manager module:              

 a. Restore the copied templates back to the IW folder after re-installing the 
Web Engine.

 b. Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

 17. If you converted Work Order data to Production Management data, purchase orders 
that were linked to work orders must be manually relinked to work tickets. You can 
do this by selecting the purchase order in Purchase Order Entry and entering the 
applicable work ticket number in the Work Ticket No. field on the Lines tab. 

 18. If you use Custom Financials Reporting, you must unhide the menu and tasks. 
Select File menu > Run and type *unhidegl in the Run Program window.

 19. Print all customized form definitions and compare them to the ones previously 
printed. Default forms may be erased in the upgrade process.

 20. If you purchased the Return Merchandise Authorization module, after setting up the 
data files for the first time, select Return Merchandise Authorization Setup menu > 
Create Customer Invoice Search Records to create customer invoice search 
records in RMA.
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 21. To run Microsoft Script links, you must have the Microsoft Windows Script Host 
processor on your system. For information on installing the Microsoft Windows 
Script Host processor, refer to the Microsoft Download Center website.

 22. If you use Automatic Update or Task Scheduler, review your scheduled automatic 
updates and reschedule those updates by selecting Library Master Main menu > 
Automatic Update or Task Scheduler, as applicable.

 23. If you were using the classic Desktop, which is no longer available, and had task 
folders in your My Tasks area, you can add tasks to the Favorites list instead. For 
more information, see Add Items to the Favorites Content Group in the Help. 

 24. Test all printers, including Device Configurator printers, that you normally use for 
printing forms and reports. Each workstation must have a default printer defined.

 25. To use the auto-complete feature with enhanced search, run the Build Search Index 
utility to index your existing customer, vendor, and item records. To run the utility, 
select Library Master > Utilities > Build Search Index.             

 26. Install Paya Connect Desktop on each workstation for each Windows user who 
needs to access credit card and ACH payment information in Sage 100.             

To install Paya Connect Desktop for Sage 100 Standard: 

 a. Use File Explorer to browse to the MAS90\Wksetup folder.

If you are installing Paya Connect Desktop on a workstation that connects to 
a Sage 100 Standard installation on a server, browser to the 
MAS90\Wksetup folder on the server.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.

 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

To install Paya Connect Desktop for Sage 100 Advanced and Premium:

 a. Use File Explorer to browse to the server where Sage 100 is installed, and 
locate the MAS90\Wksetup folder.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.
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 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

 27. If you installed the 32-bit version of Sage 100 and need to convert to the 64-bit 
version, see "Converting to 64-bit Version of Sage 100" (page 70).
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Upgrading from Version 2019 to 
Version 2023
When upgrading to version 2023, you must perform a parallel installation, and use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your Sage 
business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrator's Guide. 
You can find the guide on the Sage 100 Documents page.

Pre-Upgrade Checklist
You must prepare your version 2019 data for upgrading. This should be done for each 
company you plan to upgrade.

Complete these steps in your version 2019 installation. 

 1. Process all pending credit card transactions.

 2. Print and update all journals and registers.             

Important! Failure to complete this step may result in loss of data.

 3. If you use the Payroll module:             

 l Update the Payroll Check Register.

 l Complete and purge all direct deposit transactions.

You must install the Payroll module in addition to installing Sage 100. Payroll is 
not part of the Sage 100 installation program. To avoid the need to run a 
separate data conversion for Payroll, install the module before proceeding to 
the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade Guide 
available on the Sage 100 Documents page. 
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Upgrade Checklist

 4. If you're upgrading the Work Order module to Production Management, run Work 
Order Purge to move closed work orders into the history files. Work Order Purge is 
located on the Work Order Main menu.     

 5. Create a backup of your version 2019 MAS90 folder, which includes data for all of 
your companies. Perform this step following your usual backup process. For specific 
support on how to back up your data, refer to manuals for your backup software or 
contact the vendor from whom you purchased that product.

 6. Rebuild all data files.             

 l If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild Key 
Files and Rebuild Sort File utilities.

 l If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

You must answer Yes to all recalculation questions.

 7. Print all customized form definitions.

 8. If you are using eBusiness Manager, back up any templates, .htm files, and the IW 
folder before uninstalling the previous version of the Web Engine.

 9. Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before migrating 
your data. For more information, see the Pre-Migration Utility help.

 10. If you are upgrading Sage 100 Premium, configure your firewall to allow access to 
port number 1433 on the server with your version 2019 installation. Port 1433 is the 
default SQL Server port.

Upgrade Checklist 
After completing the "Pre-Upgrade Checklist" (page 35), you are ready to migrate your 
data to your version 2023 system.

Complete these steps in your version 2023 installation.

 l For Sage 100 Standard or Advanced, use the checklist below. 

 l For Sage 100 Premium, see "Upgrade Checklist for Sage 100 Premium" (page 37).

Note: If you’re going to convert data for the Payroll module, you’ll need access to 
Tax Profile Maintenance. If you use Payroll departments, you must have access to 
all departments in each company.
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Upgrade Checklist for Sage 100 Standard and Advanced
 1. Create a backup of your version 2023 MAS90 folder. Creating a backup now will 

save time if you need to revert to the folder’s original state. 

 2. Log into Sage 100 2023 as the Administrator. From the Administrative Tools 
window:             

 a. Start Role Maintenance and create a role that you’ll use to run the Parallel 
Migration Wizard. 

 b. On the Tasks tab, expand Library Master > Miscellaneous Tasks, and then 
select the Parallel Migration check box.

 c. Start User Maintenance, create a logon, and select the role that you 
created.

 d. Close the Administrative Tools window.

 3. Log in to Sage 100 2023, and select Library Master > Utilities > Parallel Migration. 
Follow the steps in the wizard to migrate your data. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security 
and set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Upgrade Checklist for Sage 100 Premium
Use this checklist to migrate your Sage 100 Premium data.
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Upgrade Checklist

Important!  

 l You must have administrator rights for the server with your prior version of Sage 
100 and the server with your version 2023 installation.

 l Clustered drives do not allow hidden shares. If you are using clustered drives, 
follow the instructions in the Manual Workaround section of article number 
76993 in the Sage Knowledgebase.

 1. For your Sage 100 2023 installation, create a backup of the following:             

 a. The Sage 100 MAS90 folder

 b. The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s original 
state. 

 2. Verify that the required rights and permissions are set up on the server(s) where 
SQL Server is installed. If the instance of SQL Server for Sage 100 2023 is installed 
on a different server than the instance used for your prior version, you must 
complete these steps on both servers.                  

 a. Open the Control Panel, select Administrative Tools, and then select 
Services. 

 b. In the Services window, locate the SQL Server instance used for Sage 100 
Premium, right-click it, and select Properties.

 c. In the Properties window, click the Log On tab and select an option.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on the same server as the instance used for your prior version of Sage 
100 Premium, select Local System Account.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on a different server than the one used for your prior version of Sage 
100 Premium, select This Account.

In the account field, enter: \\ServerName\Administrator  

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.
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 d. Apply your changes and then stop and restart the services.

 e. If you’re working with more than one server, make sure that all servers can 
access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

 3. Start the Parallel Migration Wizard using one of the methods below, and follow the 
steps in the wizard.             

 l If you are using Windows Server 2008, start the Parallel Migration Wizard from 
the Sage program group on the Start menu.

 l If you are using Windows Server 2012 or later, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two SQL 
Server locations. The hidden shares are used to access the source databases to 
create the .bak files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share of the 
destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the new SQL 
Server location and removes the .bak files from both the source and destination 
locations.

If permissions were not set correctly on both servers, you may receive the following 
error: "Error Number : 0x80040e14 Description: Access Denied 5 or Access Denied 
2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security 
and set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 
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Data Conversion Checklist

You're now ready to convert your data to version 2023. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Data Conversion Checklist
Follow these steps to convert your data. 

 1. If your company data contains credit card information, install the latest version of 
Paya Connect Desktop and verify that the workstation you are using has a working 
internet connection. This is necessary so that credit card records can be transferred 
to a Paya Exchange Vault account during conversion. Credit card records must be 
transferred to a Paya Exchange Vault account before company data can be 
converted.                       
 
To install Paya Connect Desktop:

 a. Start the Sage 100 installation program.

 b. Click Productivity Applications.

 c. Click Install Paya Connect Desktop to start the installation wizard.

 d. Proceed through the wizard to install the program.

 2. Select Library Master Main menu > Company Maintenance. Select a company, and 
then click Convert to convert your data. You must convert data for each of your 
companies. In addition, you can select one or more of the following options:                              

 l Convert Data for All Companies: Select this check box to convert data for all of 
your companies instead of doing it one-by-one. This check box may be 
unavailable if you’re converting Payroll data, depending on which version of 
Payroll you’re upgrading from. 

 l Convert SAP Crystal Reports: Select this check box to convert all of your 
custom reports and forms. The time required to convert your reports and forms 
depends on how many of them you have that need to be converted. The 
process runs in the background, and you can continue working in Sage 100 
while it’s running. 
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You can convert custom forms and reports later by running the Sage 100 
Crystal Report Conversion Wizard.

 l Update Custom Office Panels to Current Level: Select this check box to run the 
Custom Office panel update for any customized panels for the companies being 
converted. This update runs without any prompts.

You can update custom panels later by running the Update Customized Panels 
to Current Level utility on the Custom Office Utilities menu. 

 3. If you were not processing transactions through Paya but plan to start doing so, 
contact Paya to convert the Paya Exchange Vault-Only account created during 
conversion to a processing account.

 4. If your system is integrated with Sage CRM, go into CRM Server Options, and 
update the following information as needed.             

 l Integration server port ID

 l Sage CRM SQL server name

 l Sage CRM SQL database name

The server name and database name should reference the mirror installation that 
you created for integration with Sage 100 2023. For more information on this 
process, refer to the Installing Sage CRM section in the Sage 100 Installation and 
System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

 5. If you synchronize payroll data between your General Ledger module and Sage 
Payroll Services, verify that your Sage 100 company or companies are still linked to 
the service. 

 a. Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

 b. Sign in to Sage Payroll Services. 

 c. Proceed through the wizard. 

 d. Review the status messages shown in the Synchronizing Data with Sage 
Payroll Services window. 

If you see a "Synchronization Complete" message, no further action is 
required. 
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Data Conversion Checklist

If you see a "Synchronization failed" message, contact iSolved Support for 
assistance with resetting the link.   

 6. Update customized panels by selecting Custom Office Utilities menu > Update 
Customized Panels to Current Level. Review the placement of all user-defined 
fields. 

 7. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to 
the new version of the software and prior to accessing other modules, select Library 
Master Utilities menu > Lookup Conversion to convert your lookups. 

 8. Verify that all module links are functional by selecting Library Master Utilities menu > 
Link Maintenance Utility. Links that appear in red are broken and will need to be 
fixed using the Relink button in Link Maintenance Utility. For more information on 
relinking files, see Copy/Move/Relink Files in your Help system.

 9. If you are also upgrading your Payroll Module, review the list of enhancements and 
upgrade instructions in the Sage 100 Payroll Installation and Upgrade Guide, 
available on the Sage 100 Documents page. 

 10. Test your customized Crystal reports and forms.             

 l If you need to troubleshoot issues with customized reports and forms, run the 
Crystal Form Comparison Report utility to compare your customized reports 
and forms to the standard ones in version 2023.

To run the utility, select File menu > Run, and then type SYWFCU. The utility 
tells you which tables, if any, have been added to a report or form. It does not 
provide information about formatting changes, such as those affecting fonts, 
logos, and so forth 

 l If you were previously using non-graphical forms, you will need to set them up 
using SAP Crystal Reports.

 l If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For more 
information, see SAP Crystal Reports FAQs in the Help system. If you do not 
run the wizard now, it will automatically run the first time that someone runs a 
form or report.

 l If you are using Sage 100 Premium, refer to the Converting Reports for Sage 
100 Premium section in the Sage 100 Installation and System Administrator's 
Guide for more information.
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 11. If Sage 100 2023 is installed on the same computer as an earlier version of Sage 
100, complete this step to avoid errors when printing forms and reports in the earlier 
version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 2019 
installation to the same folder in the 2023 installation. You must complete this step 
on both the server and the workstation.

 12. If your system has custom reports, review the Custom Reports menus to make sure 
they are available. If they are not, add them using Report Manager.

 13. If you use Sage Intelligence Reporting, create a new repository for use with the 
latest version of Sage 100 and import any custom reports into it. For detailed 
instructions, see the "Upgrading Sage Intelligence Reporting" (page 71) checklist.

 14. Review the Paperless Office module configuration for e-mailing statements, reports, 
journals, registers, and other forms. For more information, see Set Up Paperless 
Office in the Help.

 15. Review your Business Insights Dashboard pages. For more information, see Set Up 
Business Insights Dashboard in the Help.

 16. To use the eBusiness Manager module:              

 a. Restore the copied templates back to the IW folder after re-installing the 
Web Engine.

 b. Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

 17. If you converted Work Order data to Production Management data, purchase orders 
that were linked to work orders must be manually relinked to work tickets. You can 
do this by selecting the purchase order in Purchase Order Entry and entering the 
applicable work ticket number in the Work Ticket No. field on the Lines tab. 

 18. If you use Custom Financials Reporting, you must unhide the menu and tasks. 
Select File menu > Run and type *unhidegl in the Run Program window.

 19. Print all customized form definitions and compare them to the ones previously 
printed. Default forms may be erased in the upgrade process.

 20. If you purchased the Return Merchandise Authorization module, after setting up the 
data files for the first time, select Return Merchandise Authorization Setup menu > 
Create Customer Invoice Search Records to create customer invoice search 
records in RMA.
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 21. To run Microsoft Script links, you must have the Microsoft Windows Script Host 
processor on your system. For information on installing the Microsoft Windows 
Script Host processor, refer to the Microsoft Download Center website.

 22. If you use Automatic Update or Task Scheduler, review your scheduled automatic 
updates and reschedule those updates by selecting Library Master Main menu > 
Automatic Update or Task Scheduler, as applicable.

 23. If you were using the classic Desktop, which is no longer available, and had task 
folders in your My Tasks area, you can add tasks to the Favorites list instead. For 
more information, see Add Items to the Favorites Content Group in the Help. 

 24. Test all printers, including Device Configurator printers, that you normally use for 
printing forms and reports. Each workstation must have a default printer defined.

 25. To use the auto-complete feature with enhanced search, run the Build Search Index 
utility to index your existing customer, vendor, and item records. To run the utility, 
select Library Master > Utilities > Build Search Index.             

 26. Install Paya Connect Desktop on each workstation for each Windows user who 
needs to access credit card and ACH payment information in Sage 100.             

To install Paya Connect Desktop for Sage 100 Standard: 

 a. Use File Explorer to browse to the MAS90\Wksetup folder.

If you are installing Paya Connect Desktop on a workstation that connects to 
a Sage 100 Standard installation on a server, browser to the 
MAS90\Wksetup folder on the server.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.

 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

To install Paya Connect Desktop for Sage 100 Advanced and Premium:

 a. Use File Explorer to browse to the server where Sage 100 is installed, and 
locate the MAS90\Wksetup folder.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.
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 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

 27. If you installed the 32-bit version of Sage 100 and need to convert to the 64-bit 
version, see "Converting to 64-bit Version of Sage 100" (page 70).
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Upgrading from Version 2018 to Version 2023

Upgrading from Version 2018 to Version 
2023
When upgrading to version 2023, you must perform a parallel installation, and use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your Sage 
business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrator's Guide. 
You can find the guide on the Sage 100 Documents page. 

Pre-Upgrade Checklist
You must prepare your version 2018 data for upgrading. This should be done for each 
company you plan to upgrade.

Complete these steps in your version 2018 installation. 

 1. Process all pending credit card transactions.

 2. Print and update all journals and registers.             

Important! Failure to complete this step may result in loss of data.

 3. If you use the Payroll module:             

 l Update the Payroll Check Register.

 l Complete and purge all direct deposit transactions.

You must install the Payroll module in addition to installing Sage 100. Payroll is 
not part of the Sage 100 installation program. To avoid the need to run a 
separate data conversion for Payroll, install the module before proceeding to 
the Upgrade Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade Guide 
available on the Sage 100 Documents page. 
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 4. If you're upgrading the Work Order module to Production Management, run Work 
Order Purge to move closed work orders into the history files. Work Order Purge is 
located on the Work Order Main menu.     

 5. Create a backup of your version 2018 MAS90 folder, which includes data for all of 
your companies. Perform this step following your usual backup process. For 
specific support on how to back up your data, refer to manuals for your backup 
software or contact the vendor from whom you purchased that product.

 6. Rebuild all data files.             

 l If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild 
Key Files and Rebuild Sort File utilities.

 l If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

You must answer Yes to all recalculation questions.

 7. Print all customized form definitions.

 8. If you are using eBusiness Manager, back up any templates, .htm files, and the IW 
folder before uninstalling the previous version of the Web Engine.

 9. Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before migrating 
your data. For more information, see the Pre-Migration Utility help.

 10. If you are upgrading Sage 100 Premium, configure your firewall to allow access to 
port number 1433 on the server with your version 2018 installation. Port 1433 is the 
default SQL Server port.

Upgrade Checklist 
After completing the pre-upgrade and upgrade checklists, you are ready to migrate your 
data to your version 2023 system.

 l For Sage 100 Standard or Advanced, use the checklist below. 

 l For Sage 100 Premium, see "Upgrade Checklist for Sage 100 Premium " (page 48).

Note: If you’re going to convert data for the Payroll module, you’ll need access to 
Tax Profile Maintenance. If you use Payroll departments, you must have access 
to all departments in each company.
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Upgrade Checklist for Sage 100 Standard and Advanced
 1. Create a backup of your version 2023 MAS90 folder. Creating a backup now will 

save time if you need to revert to the folder’s original state. 

 2. Log into Sage 100 2023 as the Administrator. From the Administrative Tools 
window:             

 a. Start Role Maintenance and create a role that you’ll use to run the Parallel 
Migration Wizard. 

 b. On the Tasks tab, expand Library Master > Miscellaneous Tasks, and then 
select the Parallel Migration check box.

 c. Start User Maintenance, create a logon, and select the role that you created.

 d. Close the Administrative Tools window.

 3. Log in to Sage 100 2023, and select Library Master > Utilities > Parallel Migration. 
Follow the steps in the wizard to migrate your data. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security and 
set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Upgrade Checklist for Sage 100 Premium 
Use this checklist to migrate your Sage 100 Premium data.
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Important!  

 l You must have administrator rights for the server with your prior version of Sage 
100 and the server with your version 2023 installation.

 l Clustered drives do not allow hidden shares. If you are using clustered drives, 
follow the instructions in the Manual Workaround section of article number 
76993 in the Sage Knowledgebase.

 1. For your Sage 100 2023 installation, create a backup of the following:             

 a. The Sage 100 MAS90 folder

 b. The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s original 
state. 

 2. Verify that the required rights and permissions are set up on the server(s) where 
SQL Server is installed. If the instance of SQL Server for Sage 100 2023 is installed 
on a different server than the instance used for your prior version, you must 
complete these steps on both servers.                  

 a. Open the Control Panel, select Administrative Tools, and then select 
Services. 

 b. In the Services window, locate the SQL Server instance used for Sage 100 
Premium, right-click it, and select Properties.

 c. In the Properties window, click the Log On tab and select an option.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on the same server as the instance used for your prior version of Sage 
100 Premium, select Local System Account.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on a different server than the one used for your prior version of Sage 
100 Premium, select This Account.

In the account field, enter: \\ServerName\Administrator  

Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.

Sage 100 Upgrade Checklists 49

Upgrade Checklist

https://support.na.sage.com/selfservice/viewdocument.do?noCount=true&externalId=76993
https://support.na.sage.com/selfservice/viewdocument.do?noCount=true&externalId=76993


Upgrade Checklist

 d. Apply your changes and then stop and restart the services.

 e. If you’re working with more than one server, make sure that all servers can 
access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

 3. Start the Parallel Migration Wizard using one of the methods below, and follow the 
steps in the wizard.             

 l If you are using Windows Server 2008, start the Parallel Migration Wizard from 
the Sage program group on the Start menu.

 l If you are using Windows Server 2012 or later, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two SQL 
Server locations. The hidden shares are used to access the source databases to 
create the .bak files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share of the 
destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the new SQL 
Server location and removes the .bak files from both the source and destination 
locations.

If permissions were not set correctly on both servers, you may receive the following 
error: "Error Number : 0x80040e14 Description: Access Denied 5 or Access Denied 
2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security and 
set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 
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You're now ready to convert your data to version 2023. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Data Conversion Checklist
Follow these steps to convert your data. 

 1. If your company data contains credit card information, install the latest version of 
Paya Connect Desktop and verify that the workstation you are using has a working 
internet connection. This is necessary so that credit card records can be transferred 
to a Paya Exchange Vault account during conversion. Credit card records must be 
transferred to a Paya Exchange Vault account before company data can be 
converted.                       
 
To install Paya Connect Desktop:

 a. Start the Sage 100 installation program.

 b. Click Productivity Applications.

 c. Click Install Paya Connect Desktop to start the installation wizard.

 d. Proceed through the wizard to install the program.

 2. Select Library Master Main menu > Company Maintenance. Select a company, and 
then click Convert to convert your data. You must convert data for each of your 
companies. In addition, you can select one or more of the following options:                              

 l Convert Data for All Companies: Select this check box to convert data for all of 
your companies instead of doing it one-by-one. This check box may be 
unavailable if you’re converting Payroll data, depending on which version of 
Payroll you’re upgrading from. 

 l Convert SAP Crystal Reports: Select this check box to convert all of your 
custom reports and forms. The time required to convert your reports and forms 
depends on how many of them you have that need to be converted. The 
process runs in the background, and you can continue working in Sage 100 
while it’s running. 
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You can convert custom forms and reports later by running the Sage 100 
Crystal Report Conversion Wizard.

 l Update Custom Office Panels to Current Level: Select this check box to run the 
Custom Office panel update for any customized panels for the companies being 
converted. This update runs without any prompts.

You can update custom panels later by running the Update Customized Panels 
to Current Level utility on the Custom Office Utilities menu. 

 3. If you were not processing transactions through Paya but plan to start doing so, 
contact Paya to convert the Paya Exchange Vault-Only account created during 
conversion to a processing account.

 4. If your system is integrated with Sage CRM, go into CRM Server Options, and 
update the following information as needed.             

 l Integration server port ID

 l Sage CRM SQL server name

 l Sage CRM SQL database name

The server name and database name should reference the mirror installation that 
you created for integration with Sage 100 2023. For more information on this 
process, refer to the Installing Sage CRM section in the Sage 100 Installation and 
System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

 5. If you synchronize payroll data between your General Ledger module and Sage 
Payroll Services, verify that your Sage 100 company or companies are still linked to 
the service. 

 a. Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

 b. Sign in to Sage Payroll Services. 

 c. Proceed through the wizard. 

 d. Review the status messages shown in the Synchronizing Data with Sage 
Payroll Services window. 

If you see a "Synchronization Complete" message, no further action is 
required. 
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If you see a "Synchronization failed" message, contact iSolved Support for 
assistance with resetting the link.   

 6. Update customized panels by selecting Custom Office Utilities menu > Update 
Customized Panels to Current Level. Review the placement of all user-defined 
fields. 

 7. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to 
the new version of the software and prior to accessing other modules, select Library 
Master Utilities menu > Lookup Conversion to convert your lookups. 

 8. Verify that all module links are functional by selecting Library Master Utilities menu 
> Link Maintenance Utility. Links that appear in red are broken and will need to be 
fixed using the Relink button in Link Maintenance Utility. For more information on 
relinking files, see Copy/Move/Relink Files in your Help system.

 9. If you are also upgrading your Payroll Module, review the list of enhancements and 
upgrade instructions in the Sage 100 Payroll Installation and Upgrade Guide, 
available on the Sage 100 Documents page. 

 10. Test your customized Crystal reports and forms.             

 l If you need to troubleshoot issues with customized reports and forms, run the 
Crystal Form Comparison Report utility to compare your customized reports 
and forms to the standard ones in version 2023.

To run the utility, select File menu > Run, and then type SYWFCU. The utility 
tells you which tables, if any, have been added to a report or form. It does not 
provide information about formatting changes, such as those affecting fonts, 
logos, and so forth 

 l If you were previously using non-graphical forms, you will need to set them up 
using SAP Crystal Reports.

 l If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For more 
information, see SAP Crystal Reports FAQs in the Help system. If you do not 
run the wizard now, it will automatically run the first time that someone runs a 
form or report.

 l If you are using Sage 100 Premium, refer to the Converting Reports for Sage 
100 Premium section in the Sage 100 Installation and System Administrator's 
Guide for more information.
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 11. If Sage 100 2023 is installed on the same computer as an earlier version of Sage 
100, complete this step to avoid errors when printing forms and reports in the earlier 
version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 2018 
installation to the same folder in the 2023 installation. You must complete this step 
on both the server and the workstation.

 12. If your system has custom reports, review the Custom Reports menus to make sure 
they are available. If they are not, add them using Report Manager.

 13. If you use Sage Intelligence Reporting, create a new repository for use with the 
latest version of Sage 100 and import any custom reports into it. For detailed 
instructions, see the "Upgrading Sage Intelligence Reporting" (page 71) checklist.

 14. Review the Paperless Office module configuration for e-mailing statements, reports, 
journals, registers, and other forms. For more information, see Set Up Paperless 
Office in the Help.

 15. Review your Business Insights Dashboard pages. For more information, see Set Up 
Business Insights Dashboard in the Help.

 16. To use the eBusiness Manager module:              

 a. Restore the copied templates back to the IW folder after re-installing the 
Web Engine.

 b. Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

 17. If you converted Work Order data to Production Management data, purchase orders 
that were linked to work orders must be manually relinked to work tickets. You can 
do this by selecting the purchase order in Purchase Order Entry and entering the 
applicable work ticket number in the Work Ticket No. field on the Lines tab. 

 18. If you use Custom Financials Reporting, you must unhide the menu and tasks. 
Select File menu > Run and type *unhidegl in the Run Program window.

 19. Print all customized form definitions and compare them to the ones previously 
printed. Default forms may be erased in the upgrade process.

 20. If you purchased the Return Merchandise Authorization module, after setting up the 
data files for the first time, select Return Merchandise Authorization Setup menu > 
Create Customer Invoice Search Records to create customer invoice search 
records in RMA.
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 21. To run Microsoft Script links, you must have the Microsoft Windows Script Host 
processor on your system. For information on installing the Microsoft Windows 
Script Host processor, refer to the Microsoft Download Center website.

 22. If you use Automatic Update or Task Scheduler, review your scheduled automatic 
updates and reschedule those updates by selecting Library Master Main menu > 
Automatic Update or Task Scheduler, as applicable.

 23. If you were using the classic Desktop, which is no longer available, and had task 
folders in your My Tasks area, you can add tasks to the Favorites list instead. For 
more information, see Add Items to the Favorites Content Group in the Help. 

 24. Test all printers, including Device Configurator printers, that you normally use for 
printing forms and reports. Each workstation must have a default printer defined.

 25. To use the auto-complete feature with enhanced search, run the Build Search Index 
utility to index your existing customer, vendor, and item records. To run the utility, 
select Library Master > Utilities > Build Search Index.             

 26. Install Paya Connect Desktop on each workstation for each Windows user who 
needs to access credit card and ACH payment information in Sage 100.             

To install Paya Connect Desktop for Sage 100 Standard: 

 a. Use File Explorer to browse to the MAS90\Wksetup folder.

If you are installing Paya Connect Desktop on a workstation that connects to 
a Sage 100 Standard installation on a server, browser to the 
MAS90\Wksetup folder on the server.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.

 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

To install Paya Connect Desktop for Sage 100 Advanced and Premium:

 a. Use File Explorer to browse to the server where Sage 100 is installed, and 
locate the MAS90\Wksetup folder.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.
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 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

 27. If you installed the 32-bit version of Sage 100 and need to convert to the 64-bit 
version, see "Converting to 64-bit Version of Sage 100" (page 70).
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Upgrading from Version 2017 to 
Version 2023
When upgrading to version 2023, you must perform a parallel installation, and use the 
Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to 
upgrade your data. For more information, consult with your Sage business partner. 

If you have custom modules or modifications to any of your modules, consult your Sage 
business partner or development partner prior to beginning the upgrade process.

If your system is integrated with Sage CRM, you must follow the instructions for 
upgrading Sage CRM in the Sage 100 Installation and System Administrator's Guide. 
You can find the guide on the Sage 100 Documents page.

Pre-Upgrade Checklist
You must prepare your version 2017 data for upgrading. This should be done for each 
company you plan to upgrade.

Complete these steps in your version 2017 installation.

 1. Process all pending credit card transactions.

 2. Print and update all journals and registers.             

Important! Failure to complete this step may result in loss of data.

 3. If you use the Payroll module:

 l Update the Payroll Check Register.

 l Complete and purge all direct deposit transactions.

 l If you have set up departments, you must have a user account set up with 
access to all departments in all companies. Department access must be 
assigned to individual user logon ID, not by groups. Groups are no longer used 
to manage department access.

You must install the Payroll module in addition to installing Sage 100. Payroll is not 
part of the Sage 100 installation program. To avoid the need to run a separate data 
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conversion for Payroll, install the module before proceeding to the Upgrade 
Checklist. 

For more information, see the Sage 100 Payroll Installation and Upgrade Guide 
available on the Sage 100 Documents Page. 

 4. If you're upgrading the Work Order module to Production Management, run Work 
Order Purge to move closed work orders into the history files. Work Order Purge is 
located on the Work Order Main menu.     

 5. Create a backup of your version 2017 MAS90 folder, which includes data for all of 
your companies. Perform this step following your usual backup process. For specific 
support on how to back up your data, refer to manuals for your backup software or 
contact the vendor from whom you purchased that product.

 6. Rebuild all data files.             

 l If you are upgrading from Sage 100 Standard or Advanced, use the Rebuild Key 
Files and Rebuild Sort File utilities.

 l If you are upgrading from Sage 100 Premium, use the Rebuild Sort File utility.

You must answer Yes to all recalculation questions.

 7. Print all customized form definitions.

 8. If you are using eBusiness Manager, back up any templates, .htm files, and the IW 
folder before uninstalling the previous version of the Web Engine.

 9. Run the Pre-Migration Utility on the Library Master Utilities menu. The utility 
examines your data and displays a list of tasks that you should run before migrating 
your data. For more information, see the Pre-Migration Utility help.

 10. If you are upgrading Sage 100 Premium, configure your firewall to allow access to 
port number 1433 on the server with your version 2017 installation. Port 1433 is the 
default SQL Server port. 

Upgrade Checklist 
After completing the pre-upgrade checklist, you are ready to migrate your data to your 
version 2023 system.
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 l For Sage 100 Standard or Advanced, use the checklist below. 

 l For Sage 100 Premium, see "Upgrade Checklist for Sage 100 Premium " (page 60).

Note: If you’re going to convert data for the Payroll module, you’ll need access to 
Tax Profile Maintenance. If you use Payroll departments, you must have access 
to all departments in each company.

Upgrade Checklist for Sage 100 Standard and Advanced
 1. Create a backup of your version 2023 MAS90 folder. Creating a backup now will 

save time if you need to revert to the folder’s original state. 

 2. Log into Sage 100 2023 as the Administrator. From the Administrative Tools 
window:             

 a. Start Role Maintenance and create a role that you’ll use to run the Parallel 
Migration Wizard. 

 b. On the Tasks tab, expand Library Master > Miscellaneous Tasks, and then 
select the Parallel Migration check box.

 c. Start User Maintenance, create a logon, and select the role that you 
created.

 d. Close the Administrative Tools window.

 3. Log in to Sage 100 2023, and select Library Master > Utilities > Parallel Migration. 
Follow the steps in the wizard to migrate your data. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security 
and set up and assign the appropriate roles to your users.

 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.
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Upgrade Checklist for Sage 100 Premium 
Use this checklist to migrate your Sage 100 Premium data.

Important!  

 l You must have administrator rights for the server with your prior version of Sage 
100 and the server with your version 2023 installation.

 l Clustered drives do not allow hidden shares. If you are using clustered drives, 
follow the instructions in the Manual Workaround section of article number 
76993 in the Sage Knowledgebase.

 1. For your Sage 100 2023 installation, create a backup of the following:             

 a. The Sage 100 MAS90 folder

 b. The MAS_System SQL Server database

Creating backups now will save time if you need to revert to the installation’s original 
state. 

 2. Verify that the required rights and permissions are set up on the server(s) where 
SQL Server is installed. If the instance of SQL Server for Sage 100 2023 is installed 
on a different server than the instance used for your prior version, you must 
complete these steps on both servers.                  

 a. Open the Control Panel, select Administrative Tools, and then select 
Services. 

 b. In the Services window, locate the SQL Server instance used for Sage 100 
Premium, right-click it, and select Properties.

 c. In the Properties window, click the Log On tab and select an option.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on the same server as the instance used for your prior version of Sage 
100 Premium, select Local System Account.

 l If the SQL Server instance that you’re using for version 2023 is installed 
on a different server than the one used for your prior version of Sage 
100 Premium, select This Account.

In the account field, enter: \\ServerName\Administrator  
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Replace "ServerName" with the name of the server. Sage strongly 
recommends using the actual Administrator or Domain Administrator 
account. 

Enter the password for the account.

 d. Apply your changes and then stop and restart the services.

 e. If you’re working with more than one server, make sure that all servers can 
access each other through hidden shares. 

For example: \\ServerName\C$, \\ServerName\D$

 3. Start the Parallel Migration Wizard using one of the methods below, and follow the 
steps in the wizard.             

 l If you are using Windows Server 2008, start the Parallel Migration Wizard from 
the Sage program group on the Start menu.

 l If you are using Windows Server 2012 or later, start the Parallel Migration 
Wizard from the Start window.

The Migration Wizard creates .bak files in the ..\DATA folders for the two SQL 
Server locations. The hidden shares are used to access the source databases to 
create the .bak files. For example:

\\ServerName\c$\Program Files\Microsoft SQL 
Server\MSSQL12.MSSQLSERVER\MSSQL\Data

After the .bak files are created, the wizard copies them to the hidden share of the 
destination ..\DATA SQL Server folders. 

To complete the process, the wizard then restores the databases into the new SQL 
Server location and removes the .bak files from both the source and destination 
locations.

If permissions were not set correctly on both servers, you may receive the following 
error: "Error Number : 0x80040e14 Description: Access Denied 5 or Access Denied 
2 Setup will now terminate"

If this error occurs, see article number 76993 in the Sage Knowledgebase. 

 4. After the migration is complete, log into Sage 100 2023 as the Administrator. Use 
the tasks available from the Administrative Tools window to review user security 
and set up and assign the appropriate roles to your users.
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 5. Review security tasks for new features in version 2023. Review ODBC security if it 
is used.

 6. If you are using Unified Logon and you upgraded your system files, you must add 
the following statement on one workstation SOTA.ini: Logon=Yes. 

 7. If you customized your Desktop, review the customizations. 

You're now ready to convert your data to version 2023. 

Important! After migrating data for companies that are connected to Bank Feeds, 
you cannot use Bank Feeds in any pre-existing company that was not migrated 
and converted. You will not be able to connect or disconnect banks or process 
transactions.

Data Conversion Checklist
After completing the pre-upgrade and upgrade checklist, you are ready to convert your 
data to version 2023.

Note: If you use the Payroll module, you must log in with a user account that has 
access to all payroll departments; otherwise, you will not be able to complete data 
conversion.

 1. If your company data contains credit card information, install the latest version of 
Paya Connect Desktop and verify that the workstation you are using has a working 
internet connection. This is necessary so that credit card records can be transferred 
to a Paya Exchange Vault account during conversion. Credit card records must be 
transferred to a Paya Exchange Vault account before company data can be 
converted.                       
 
To install Paya Connect Desktop:

 a. Start the Sage 100 installation program.

 b. Click Productivity Applications.

 c. Click Install Paya Connect Desktop to start the installation wizard.

 d. Proceed through the wizard to install the program.

 2. Select Library Master Main menu > Company Maintenance. Select a company, and 
then click Convert to convert your data. You must convert data for each of your 
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companies. In addition, you can select one or more of the following options:                              

 l Convert Data for All Companies: Select this check box to convert data for all of 
your companies instead of doing it one-by-one. This check box may be 
unavailable if you’re converting Payroll data, depending on which version of 
Payroll you’re upgrading from. 

 l Convert SAP Crystal Reports: Select this check box to convert all of your 
custom reports and forms. The time required to convert your reports and forms 
depends on how many of them you have that need to be converted. The 
process runs in the background, and you can continue working in Sage 100 
while it’s running. 

You can convert custom forms and reports later by running the Sage 100 
Crystal Report Conversion Wizard.

 l Update Custom Office Panels to Current Level: Select this check box to run the 
Custom Office panel update for any customized panels for the companies being 
converted. This update runs without any prompts.

You can update custom panels later by running the Update Customized Panels 
to Current Level utility on the Custom Office Utilities menu. 

 3. If you are converting Payroll Data, the Payroll Data Conversion Wizard 
automatically opens. Companies that include Payroll data must be converted one 
by one. You’ll be guided through the following tasks:

 l Mapping department numbers. If you use payroll departments and any of the 
departments numbers contain special characters, you must enter new 
department numbers containing only alphanumeric characters to replace them. 

 l Selecting tax groups from the payroll tax database to replace your existing tax 
codes. If you are using local tax codes, each state and local tax code 
combination will be replaced by one tax group. Depending on which tax codes 
you’re using, the wizard offers suggestions for you to review and update as 
needed. 

 l Adding tax groups to tax profiles. Tax profiles are collections of tax groups that 
you assign to employees to determine how their taxes are calculated. You can 
access Tax Profile Maintenance from the wizard to create tax profiles.
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 l Selecting filing statuses from the payroll tax database to replace your existing 
ones. The filing statuses in the database may differ from the ones that you are 
using. The wizard offers suggestions when possible for you to review and 
update as needed. 

 4. If you were not processing transactions through Paya but plan to start doing so, 
contact Paya to convert the Paya Exchange Vault-Only account created during 
conversion to a processing account.

 5. If your system is integrated with Sage CRM, go into CRM Server Options, and 
update the following information as needed.             

 l Integration server port ID

 l Sage CRM SQL server name

 l Sage CRM SQL database name

The server name and database name should reference the mirror installation that 
you created for integration with Sage 100 2023. For more information on this 
process, refer to the Installing Sage CRM section in the Sage 100 Installation and 
System Administrator’s Guide. 

After updating the information, load the Sage CRM data.

 6. If you synchronize payroll data between your General Ledger module and Sage 
Payroll Services, verify that your Sage 100 company or companies are still linked to 
the service. 

 a. Select General Ledger > Payroll Services > Payroll Services 
Synchronization Wizard. 

 b. Sign in to Sage Payroll Services. 

 c. Proceed through the wizard. 

 d. Review the status messages shown in the Synchronizing Data with Sage 
Payroll Services window. 

If you see a "Synchronization Complete" message, no further action is 
required. 

If you see a "Synchronization failed" message, contact iSolved Support for 
assistance with resetting the link.   
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 7. Update customized panels by selecting Custom Office Utilities menu > Update 
Customized Panels to Current Level. Review the placement of all user-defined 
fields. 

For the Job Cost and Payroll modules, you must manually recreate all of your 
customized panels. User defined fields will be automatically converted.

 8. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to 
the new version of the software and prior to accessing other modules, select Library 
Master Utilities menu > Lookup Conversion to convert your lookups. 

For the Job Cost and Payroll Modules, you must manually recreate all custom 
lookups.

 9. Verify that all module links are functional by selecting Library Master Utilities menu 
> Link Maintenance Utility. Links that appear in red are broken and will need to be 
fixed using the Relink button in Link Maintenance Utility. For more information on 
relinking files, see Copy/Move/Relink Files in your Help system.

 10. If you are also upgrading your Payroll Module, review the list of enhancements and 
upgrade instructions in the Sage 100 Payroll Installation and Upgrade Guide, 
available on the Sage 100 Documents page. 
After reviewing the guide, complete the following tasks:

 a. Select Payroll > Setup > Earnings Code Maintenance. For each earnings 
code, select a tax rule. 

 b. Select Payroll > Setup > Deduction Code Maintenance. For each pension or 
cafeteria plan deduction code, select a tax rule.

 c. Select Payroll > Setup > Company Tax Group Setup. For each tax group 
that you are using:

 l Enter the tax ID number for state and local tax groups. For the Federal 
tax group, the tax ID number entered in Company Maintenance 
appears and can only be viewed. 

 l Enter the general ledger account numbers to credit with the tax 
amounts withheld from employees’ pay.
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 l On the Main tab, enter any tax rates that are specific to your company 
and the associated effective dates. 

 l On the Taxes tab, in the Tax field, select the tax(es) for the selected tax 
group. The taxes available are based on the selected tax group. Note: 
There may be more than one tax that needs to be set up.

 d. Select Payroll > Setup > Tax Profile Maintenance. Review the tax profiles 
that were created when converting payroll data, and make changes if 
needed. 

 e. Select Payroll > Main > Employee Maintenance. On the Taxes tab, enter at 
least one tax profile for each employee. Depending on the tax groups, you 
may need to enter a filing status, a Workers’ Compensation code, or other 
information.

 f. Also in Employee Maintenance, on the Additional tab, verify that the correct 
selection appears in the Ethnicity/Race field. 

 g. If you are using the security feature in Department Maintenance, you must 
recreate the lists of users who can access each department. Select Payroll 
> Setup > Department Maintenance, and click the Security tab.

 h. To ensure that your system can communicate with the tax calculation 
engine, add the following URL to your browser's trusted sites list: 
spa.na.sage.com

Complete this step on all workstations that will be used to process payroll, 
and also on the server where Sage 100 is installed if the Process Tax 
Calculation on the Server check box is selected in System Configuration.  

 11. Test your customized Crystal reports and forms.             

 l If you need to troubleshoot issues with customized reports and forms, run the 
Crystal Form Comparison Report utility to compare your customized reports 
and forms to the standard ones in version 2023.

To run the utility, select File menu > Run, and then type SYWFCU. The utility 
tells you which tables, if any, have been added to a report or form. It does not 
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provide information about formatting changes, such as those affecting fonts, 
logos, and so forth 

 l If you were previously using non-graphical forms, you will need to set them up 
using SAP Crystal Reports.

 l If you are using Sage 100 Standard or Sage 100 Advanced, use the Crystal 
Reports Conversion Wizard to convert your Crystal reports and forms. For more 
information, see SAP Crystal Reports FAQs in the Help system. If you do not 
run the wizard now, it will automatically run the first time that someone runs a 
form or report.

 l If you are using Sage 100 Premium, refer to the Converting Reports for Sage 
100 Premium section in the Sage 100 Installation and System Administrator's 
Guide for more information.

 12. For the Job Cost and Payroll modules, the Crystal Reports Conversion Wizard 
might partially convert your customized forms and reports. Test all of your 
customized forms and reports, and use Crystal Reports Designer to manually 
update or recreate them as needed.

 13. If Sage 100 2023 is installed on the same computer as an earlier version of Sage 
100, complete this step to avoid errors when printing forms and reports in the earlier 
version: 

Copy the pvxwin32.exe.config file from the ..\MAS90\Home folder in your 2017 
installation to the same folder in your 2023 installation. You must complete this step 
on both the server and the workstation.

 14. If your system has custom reports, review the Custom Reports menus to make sure 
they are available. If they are not, add them using Report Manager.

 15. If you use Sage Intelligence Reporting, create a new repository for use with the 
latest version of Sage 100 and import any custom reports into it. For detailed 
instructions, see the "Upgrading Sage Intelligence Reporting" (page 71) checklist.

 16. For the Job Cost and Payroll modules, recreate all Visual Integrator import and 
export jobs. 

 17. If you converted Work Order data to Production Management data, purchase orders 
that were linked to work orders must be manually relinked to work tickets. You can 
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do this by selecting the purchase order in Purchase Order Entry and entering the 
applicable work ticket number in the Work Ticket No. field on the Lines tab. 

 18. Review the Paperless Office module configuration for e-mailing statements, reports, 
journals, registers, and other forms. For more information, see Set Up Paperless 
Office in the Help.

 19. Review your Business Insights Dashboard pages. For more information, see Set Up 
Business Insights Dashboard in the Help.

 20. To use the eBusiness Manager module:              

 a. Restore the copied templates back to the IW folder after re-installing the 
Web Engine.

 b. Copy the poweredby.gif image from the MAS90\Images folder to the IIS 
Inetpup\wwwroot\images folder and restart the IIS Web service.

 21. If you use Custom Financials Reporting, you must unhide the menu and tasks. 
Select File menu > Run and type *unhidegl in the Run Program window.

 22. Print all customized form definitions and compare them to the ones previously 
printed. Default forms may be erased in the upgrade process.

 23. If you purchased the Return Merchandise Authorization module, after setting up the 
data files for the first time, select Return Merchandise Authorization Setup menu > 
Create Customer Invoice Search Records to create customer invoice search 
records in RMA.

 24. To run Microsoft Script links, you must have the Microsoft Windows Script Host 
processor on your system. For information on installing the Microsoft Windows 
Script Host processor, refer to the Microsoft Download Center website.

 25. If you use Automatic Update or Task Scheduler, review your scheduled automatic 
updates and reschedule those updates by selecting Library Master Main menu > 
Automatic Update or Task Scheduler, as applicable.

 26. If you were using the classic Desktop, which is no longer available, and had task 
folders in your My Tasks area, you can add tasks to the Favorites list instead. For 
more information, see Add Items to the Favorites Content Group in the Help. 

 27. Test all printers, including Device Configurator printers, that you normally use for 
printing forms and reports. Each workstation must have a default printer defined.

 28. To use the auto-complete feature with enhanced search, run the Build Search Index 
utility to index your existing customer, vendor, and item records. To run the utility, 
select Library Master > Utilities > Build Search Index.             
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 29. Install Paya Connect Desktop on each workstation for each Windows user who 
needs to access credit card and ACH payment information in Sage 100.             

To install Paya Connect Desktop for Sage 100 Standard: 

 a. Use File Explorer to browse to the MAS90\Wksetup folder.

If you are installing Paya Connect Desktop on a workstation that connects to 
a Sage 100 Standard installation on a server, browser to the 
MAS90\Wksetup folder on the server.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.

 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

To install Paya Connect Desktop for Sage 100 Advanced and Premium:

 a. Use File Explorer to browse to the server where Sage 100 is installed, and 
locate the MAS90\Wksetup folder.

 b. Double-click Autorun.exe to open the Workstation Setup program; it takes a 
few seconds to launch.

 c. Click Install Paya Connect Desktop.

 d. Proceed through the steps in the Paya Connect Desktop installation wizard 
to install the program.

 30. If you installed the 32-bit version of Sage 100 and need to convert to the 64-bit 
version, see "Converting to 64-bit Version of Sage 100" (page 70).
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Converting to 64-bit Version of Sage 
100
If you installed the 32-bit version of Sage 100 on a computer running the 64-bit version of 
Windows, you can convert it to the 64-bit version. You should do this only if you are no 
longer using any earlier 32-bit versions of Sage 100 installed on the same computer, and 
if all of your Sage 100 workstations are running the 64-bit version of Windows. 

All versions of Sage 100 released before version 2021 are 32-bit. 

Warnings!

l If you have an earlier 32-bit version of Sage 100 installed on the computer, it will
no longer work after you convert version 2023 to 64-bit.

l If you have any Sage 100 workstations running the 32-bit version of Windows,
they will no longer be able to run Sage 100 after it has been converted to 64-bit.

Do not convert to 64-bit until after you’ve completed your testing and have created a 
backup of the data from your earlier version. 

To convert from 32-bit to 64-bit

1. On the computer where Sage 100 2023 is installed, open the folder where the Sage
100 installation program is located.

2. Click or double-click the 32_64_Bit_Switch_Utility.exe file.

3. Click Next and then enter the password for the Sage 100 Administrator account.

4. Click Convert.

Sage 100 is converted to the 64-bit version. 

The Workstation Synchronization program automatically upgrades the workstations 
the next time Sage 100 is started on the workstation.

If running the Application Server as a service, then the following steps are required to 
re-create the Windows Service after converting from either 32-bit to 64-bit or from 64-
bit to 32-bit:
1. Use the Uninstall Sage 100 Application Server Service shortcut to delete the 

existing service (a reboot may be necessary to complete this step).
2. Re-create the service using the Sage 100 Application Server Service Setup 

shortcut.
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Upgrading Sage Intelligence Reporting
If you use Sage Intelligence Reporting, follow the steps in this chapter to create a new 
repository for Sage 100 2023. If you have custom reports, follow the instructions to export 
custom reports from your prior version of the program and import them into the new 
repository. 

For detailed instructions on each step, see:

l "Export Custom Reports" (page 71)

l "Create a New Repository" (page 72)

l "Set Up Sage Intelligence Reporting in Sage 100 2023" (page 73)

l "Import Custom Reports" (page 73)

Report Compatibility
Reports can be imported only from an earlier version of the program or another instance 
of the same version. For example, you can import a report created in version 2013 into 
version 2023. You cannot import a report created in version 2023 into version 2013.  

Reports created in Sage 100 Standard and Sage 100 Advanced are not compatible with 
Sage 100 Premium. Likewise, reports created in Sage 100 Premium are not compatible 
with  Sage 100 Standard and Sage 100 Advanced.

Export Custom Reports
In your prior version of Sage 100, export all of the custom reports that you want to use in 
version 2023.

To export custom reports

1. In your prior version of Sage 100, select Sage Intelligence Reporting Main menu >
Report Manager.

2. Right-click a report and then click Export Report. (Alternately, select a report and
then, on the Tools menu, click Export Report.)
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Create a New Repository

 3. Select the location where you want to save the file and then click Save. A file with an 
AL_ extension is created.  

 4. Repeat these steps for all custom reports that you want to use in version 2023.

Create a New Repository
Create a shared folder to use as the Sage Intelligence Reporting repository for Sage 100 
2023. We recommend using a separate repository for each installation of Sage 
Intelligence Reporting. 

Note: These steps may vary depending on what version of Windows you are 
using. Check with your network administrator if you need assistance.

To create a repository 

 1. Use Windows File Explorer to create a folder in the desired location.

 2. Right-click the folder, point to "Share with," and click "Advanced sharing."

 3. On the Sharing tab, select the "Share this folder" check box.

 4. Enter a share name.

 5. Click Permissions.  

 6. For all applicable users, select the Full Control or Read and Write check boxes. 

 7. Click OK. 

 8. If you use reporting trees or distribution settings, copy the following folders from the 
old repository to the new one:

 l Report Trees

 l Distribution
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Set Up Sage Intelligence Reporting in Sage 
100 2023
After creating the shared folder, enter its location in Sage 100 2023. If you haven’t 
already registered your 2023 version of Sage Intelligence Reporting, you will be asked to 
do so. 

To set up Sage Intelligence Reporting

 1. In Sage 100 2023, select Sage Intelligence Reporting Main menu > Report 
Manager.

 2. Click File and then click Change. 

 3. Click Yes in the message window.

 4. In the Network Repository Path field, type the UNC path to the shared folder that 
you created. For example: \\ServerName\ReportRpository

 5. Click OK.

 6. If you receive a message asking you to register Sage Intelligence Reporting, click 
OK to open the License Manager window.

 7. In the Account Number field, enter your Sage customer number.

 8. In the Serial Number field, enter you unlocking key. This field is case-sensitive. 

 9. Click Apply and then click Perform Registration. 

Import Custom Reports
After creating the new repository and registering Sage Intelligence Reporting, import any 
custom report files.

To import custom reports

 1. If you want to create folders to organize your reports, on the Home tab, click Add 
Folder. 
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Import Custom Reports

 2. Right-click either the Home folder or any custom folder created in the prior step, and 
then click Import Report. (Alternately, you can click the Tools tab, and then click 
Import Report.) 

 3. Select one of the custom reports that you exported from your prior version.

 4. In the Import Report window, in the Target Connection field, select a connection. 

 l For consolidated reports, select Sage MAS Consolidation. 

Note: You must own the Sage 100 Intelligence Connector module to generate 
consolidated reports.

 l For any other type of report, select Sage MAS (Auto Connect).  

 5. In the Report Destination field, select the folder for the report. 

 6. Click Import.

 7. On the Home tab in the Actions group, click Refresh.

 8. Repeat these steps for any other custom reports that you exported from your prior 
version of Sage Intelligence Reporting. 
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