Version 4.50
Customer Upgrade Guide

for

Sage ERP MAS 90
Sage ERP MAS 200
Sage ERP MAS 200 SQL

This version of the software has been retired
## Contents

**Chapter 1 — Introduction**  
How to Use This Guide  1  
Enhancements  2  
Graphic Conventions  2  
Text Conventions  3

**Chapter 2 — What’s New in Version 4.50**  
Global Enhancements  4  
Choose an Installation Option  4  
Participate in the Product Enhancement Program  4  
Retain Report and Form Printer Information Setting  5  
Set Up System Security  5  
Accounts Receivable Enhancements  5  
Create National Accounts  5  
Define Default Price Levels by Customer and Product Line  6  
Purge Credit Card Data During Period-End Processing  6  
Define Split Commissions by Customer  7  
Recalculate Open Order Amounts  7  
Bar Code Enhancements  7  
Print Lot/Serial Distribution Information  7  
Inventory Management Enhancements  8  
View Lot/Serial Distribution Information  8  
Library Master Enhancements  8  
Define Credit Card Security Options  8  
Payroll Enhancements  9  
Recalculate Deductions in Payroll Data Entry  9  
Define Deduction Code Options  10  
Recalculate All Option for Payroll Imports  10  
Select Preconfigured Payroll Import Jobs  10  
Define Minimum Hours for Benefit Accrual  11  
Identify Business Type  11  
Purchase Order Enhancements  11  
View Sales Orders from Purchase Order Entry  11  
Generate Purchase Orders from Sales Orders  11  
Set Up Additional Purchase Order/Auto Generate Options  12
Contents

Sales Order Enhancements 13
   Set Up Additional Options for Job Cost 13
   Calculate Sales Commissions by Line Item 14
   Calculate Item Pricing by Total Quantity 14
   Distribute Lot/Serial Items from Sales Order Entry 15
   Generate Purchase Orders from Sales Orders 15
   Assign Vendors to Miscellaneous/Special Items 16

Chapter 3 — Workflow Changes in 4.50 17
Global Changes 17
   Security Requirement 17
   Manage Your System Window 17
Purchase Order Changes 17
   Auto Generate Purchase Orders 17
   Renamed Task 17
Retired Modules 18

Chapter 4 — Workflow Changes in 4.40.0.X 19
Installation Changes 19
   Changes in Version 4.40 19
      Upgrading 19
Global Changes 19
   Changes in Version 4.40 19
      Data File Multi-Segment 19
      Activity Log 20
      Advanced Lookup Engine (ALE) 20
      Batch Faxing 20
      Character-Based Forms 21
      Customized Crystal Forms 21
      Data Dictionary Changes 21
      Data Entry 21
      Desktop 22
      Expanded Customer Numbers 22
      Expanded Item Codes 22
      Printing 22
      Reports and Forms 23
Contents

Library Master Changes  24
   Changes in Version 4.40  24
      Changed Tasks  24
      Role Maintenance  24

Accounts Payable Changes  24
   Changes in Product Update 4.40.0.2  24
      ACH Electronic Payment Processing  24
      Renamed Tasks  25
   Changes in Product Update 4.40.0.1  25
      Renamed Tasks  25
   Change in Version 4.40  25
      Renamed Task  25

Accounts Receivable Changes  26
   Change in Version 4.40  26
      Renamed Task  26

Bank Reconciliation Changes  26
   Changes in Product Update 4.40.0.3  26
      Registers and Updates  26
      Renamed Task  26
   Change in Product Update 4.40.0.2  26
      Enter Checks, Deposits, and Adjustments On-the-Fly  26

Bar Code Changes  27
   Changes in Version 4.40  27
      Bar Code Options  27
      Unattended Bar Code Transaction Import  27
      Renamed Tasks  27

Bill of Materials Changes  27
   Changes in Version 4.40  27
      Global Changes  27
      Bill of Materials Options  28
      Data Entry  28
      Inquiry Changes  28
      Printing  28
      Reports and Forms  29
      Renamed, Removed, or Moved Tasks  29
Contents

Business Insights Changes 30
  Changes in Version 4.40 30
    Business Insights Reporter 30
Common Information Changes 30
  Change in Product Update 4.40.0.2 30
    Bank Code Maintenance 30
Changes in Version 4.40 30
  Miscellaneous Item Maintenance 30
    Common Information Options 31
  Renamed, Removed, or Moved Tasks 31
Customizer Changes 32
  Changes in Version 4.40 32
    Global Changes 32
eBusiness Manager Changes 33
  Changes in Version 4.40 33
    Sage Web Engine 33
General Ledger Changes 33
  Changes in Version 4.40 33
    Fiscal Year Maintenance 33
Inventory Management Changes 34
  Changes in Version 4.40 34
    Global Changes 34
      Inventory Management Options 34
      Product Line Maintenance 35
      Transaction Entry 35
      Item Maintenance 36
      Physical Count Changes 36
      Costing Changes 37
      Utilities Menu 37
      Period End Processing 38
      Printing 38
      Reports and Forms 39
        Renamed, Removed, or Moved Tasks 39
Job Cost Changes 40
  Changes in Version 4.40 40
    Job Cost Options 40
      Data Dictionary Changes 40
Contents

Payroll Changes 41
  Change in Product Update 4.40.0.5  41
    Quarterly 941 Printing  41
  Change in Version 4.40  41
    Quarterly 941 Printing  41
Purchase Order Changes 41
  Changes in Version 4.40  41
    Global Changes  41
    Purchase Order Options  42
    Purchases History  43
    Data Entry  43
    Utilities Menu  44
    Period End Processing  44
    Printing  45
    Registers and Updates  45
    Reports and Forms  46
    Renamed, Removed, or Moved Tasks  46
Return Merchandise Authorization Changes 47
  Change in Version 4.40  47
    Renamed, Removed, or Moved Tasks  47
Sales Order Changes 47
  Changes in Product Update 4.40.0.1  47
    Checking for Duplicate Customer PO Numbers  47
    Data Entry  47
    Expanded Quick Print Options  48
    Changes for Picking Sheet Printing  48
  Changes in Version 4.40  48
    Sales History Reports  48
    Security Option for Adding Inventory Items on the Fly  48
    Data Entry  49
    Renamed Tasks  49
Visual Integrator Changes 49
  Changes in Version 4.40  49
    Data Dictionaries  49
    Data Dictionary Listing  50
    Import Job Maintenance  50
Contents..............................................................................................................................................................................

Work Order Changes 52
   Changes in Version 4.40 52
      Renamed, Removed, or Moved Tasks 52
      File Layout 52
Report Master Changes 52
   Changes in Version 4.40 52
      Reports 52
Retired Modules 53

Chapter 5 — Workflow Changes in 4.30 54
Installation Changes 54
Global Changes 54
   Reports and Forms 54
   Selection Grids 54
Library Master Changes 55
   Role Maintenance 55
Accounts Receivable Changes 55
   Customer Statements 55
Business Insights Changes 56
   Business Insights Dashboard 56
   Business Insights Reporter 56
Common Information Changes 56
   Bank Code Maintenance 56
Payroll Changes 57
   Direct Deposits 57
Visual Integrator Changes 57
   Job Import 57
Report Master Changes 57

Chapter 6 — Workflow Changes in 4.20 58
Global Changes 58
   Advanced Lookup Engine (ALE) 58
   Desktop 58
   Help System and Online Manuals 58
   Inquiries 59
   Printing 59
   Printing to a Dot Matrix Printer 59
Contents

Library Master Changes 60
  Batch Faxing 60
  Role Maintenance 60
  Renamed Task 61
  Reports 61
  URL Maintenance 62
Accounts Payable Changes 62
  Global Changes 62
  Data Entry 63
  Period End Processing 63
  Reports and Forms 64
  Renamed, Removed, or Moved Tasks 65
Accounts Receivable Changes 65
  Memos 65
Business Insights Changes 66
  Global Changes 66
  Business Insights Explorer 66
  Renamed Tasks 67
Common Information Changes 67
  Renamed, Removed, or Moved Tasks 67
Customizer Changes 68
  Global Changes 68
Electronic Reporting for W2 and 1099 (Magnetic Media Reporting) 69
  Global Changes 69
Fixed Assets Changes 70
  Global Changes 70
Payroll Changes 70
  Taxes 70
  Reports 71
Visual Integrator Changes 71
  Data Dictionary Listing 71
  Import Job Maintenance 72
Retired Modules 72
Chapter 7 — Workflow Changes in 4.10  73
Accounts Receivable Changes  73
  Global Changes  73
  Period End Processing  74
  Renamed, Removed, or Moved Tasks  74
Business Insights Changes  75
  Renamed, Removed, or Moved Tasks  75
Common Information Changes  75
  Miscellaneous Item Maintenance  75
Customizer Changes  75
  Global Changes  75
eBusiness Manager Changes  78
  Global Changes  78
Return Merchandise Authorization Changes  79
  Renamed, Removed, or Moved Tasks  79
Sales Order Changes  79
  Global Changes  79
  Sales History  79
  Sales History Reports  80
  Period End Processing  80
  Job Cost Integration  81
Visual Integrator Changes  81
  Data Dictionaries  81
  Data Dictionary Listing  81
  Import Job Maintenance  82

Chapter 8 — Workflow Changes in 4.00  83
Installation Changes  83
Global Changes  83
  Advanced Lookup Engine (ALE)  83
  Desktop  83
  Help System and Online Manuals  83
  Migrating Level 3.x Data  83
  Module and Accounting Dates  84
  Registering Your Modules  84
  Security  84
Contents

Upgrading from Version 4.30 to Version 4.50 105
  Pre-Migration Checklist 105
  Migration Checklist 107
  Data Conversion Checklist 109
Upgrading from Version 4.20 to Version 4.50 113
  Pre-Migration Checklist 113
  Migration Checklist 115
  Data Conversion Checklist 117
Upgrading from Version 4.10 to Version 4.50 121
  Pre-Migration Checklist 121
  Migration Checklist 123
  Data Conversion Checklist 125
Upgrading from Version 4.00 or 4.05 to Version 4.50 129
  Pre-Migration Checklist 129
  Migration Checklist 132
  Data Conversion Checklist 133
Upgrading from Level 3.x to Version 4.50 138
  Pre-Migration Checklist 138
  Migration Checklist 142
  Data Conversion Checklist 143
Chapter 1

Introduction

Sage, the recognized leader in business management for small- and mid-size businesses, welcomes you to Sage ERP MAS 90, 200, and 200 SQL version 4.50.

How to Use This Guide

This guide has been created to ease the process of upgrading your software. While the extensive new features included in this release have been designed to improve your workflow and business processes, this means that the way you use your system may change.

Chapter 2 of this guide contains all the enhancements for this release. The remaining chapters specifically highlight the differences that you need to be aware of and the steps you need to take before you begin using the new system so you can take better advantage of the improvements. The appendix provides pre-installation and post-installation checklists to ease the upgrade process.

Review the information in this guide before installing the software. For more information, refer to your Installation and System Administrator’s Guide. The Installation and System Administrator’s Guide can be found in the Documents folder of the Sage ERP MAS product DVD, or by selecting a product from the Autorun screen, and then clicking Documentation on the product screen. The guide is in Adobe Acrobat (PDF) format and is named MAS_Install.pdf.
Chapter 1  Introduction

Enhancements

For a complete list of enhancements and changes to the software, after installing, refer to the What’s New page and the Release Notices. For the What’s New information, see What’s New in Version 4.50 on page 4.

You can also access the What’s New page by clicking What’s New on the Desktop’s Resources page. From the What’s New page, click Release Notices to view the Release Notices.

This guide contains the following information you need for a successful upgrade:

- Installation changes
- Global changes in the software
- Changes to the modules
- Pre-installation checklist
- Post-installation checklist
- Data conversion checklist

Graphic Conventions

The following icons are used throughout this guide to indicate different types of information.

- The NOTE symbol is followed by additional information about a topic.
- The WARNING symbol is followed by information to help you avoid costly mistakes.
Text Conventions

The following table describes the text conventions used in this guide.

<table>
<thead>
<tr>
<th>Text Convention</th>
<th>Explanation</th>
</tr>
</thead>
</table>
| **Menus**       | Menus are shown in this format: Select menu > menu task name.  
Examples:  
• Select File menu > Change Company.  
• Select General Ledger Budget menu > Budget Maintenance. |
| **Bold font**   | Indicates text entered at a field or text selected at a field.  
Examples:  
• At the Value field, type a search value, such as 01, for the lookup.  
• In the Filter window, to delete a filter, select <none> at a filter's Column field. |
| **Italic font** | Indicates references to other manuals.  
Example:  
• For more information, refer to your Installation and System Administrator’s Guide. |
Chapter 2

What's New in Version 4.50

Global Enhancements

Choose an Installation Option

You now have the option to perform an in-place or parallel upgrade installation. If you select to perform a parallel upgrade, use the Parallel Migration wizard to move your data. An in-place installation can only be performed for versions 4.40 and higher.

The following products are now available on one DVD:

- Sage ERP MAS 90
- Sage ERP MAS 200
- Sage ERP MAS 200 SQL
- SageCRM
- eBusiness Manager
- eBusiness Web Services
- Federal and State eFiling and Reporting
- Crystal Reports® Designer

Participate in the Product Enhancement Program

You can now participate in the Product Enhancement Program (PEP). Through PEP, Sage collects information that will help Sage identify trends and usage patterns to improve the quality of the products and services we offer. Sage will not collect sensitive information such as financial information or information on individual transactions.

When installing or upgrading to a new version of Sage ERP MAS, you will be automatically enrolled in PEP. You can opt out at any time using the Product Enhancement Program window accessed through the Administrative Tools window.
Retain Report and Form Printer Information Setting

You can now retain report and form printer information by workstation ID and form code. This new functionality enables multiple users to save the printer information specific to their workstation ID when selecting a form code or report setting. Previously, the printer used by the last user of a form code or report setting was saved for the next user.

Set Up System Security

Security for your Sage ERP MAS system is now required. When installing the software, you are now required to create an Administrator password. Each user must have a logon ID created in User Maintenance in order to access the system.

Accounts Receivable Enhancements

Create National Accounts

A new feature has been added that allows you to create national accounts. National accounts allow you to create relationships between a bill-to account and its sold-to customers. Various fields have been added to Accounts Receivable Options that enable the use of national accounts.

• Use the new Bill To Customer Maintenance task on the Accounts Receivable Setup menu to set up relationships between a national account and its sold-to customers. Any customer can be a national account or be a member of a national account.

• Use the new Bill To/Sold To Maintenance task accessed from the Customer Maintenance window to create tiers of bill-to and sold-to customers.

• You now have the option to print bill-to/sold-to information on various reports and forms. Additionally, bill-to/sold-to information can be printed in Statement Printing.
Chapter 2  What’s New in Version 4.50

Define Default Price Levels by Customer and Product Line

A new feature has been added that allows you to define default price levels by customer and product line. Default price levels for the customer can be set up by product line only, a combination of product line and price code, or product line and ship-to code. Two fields have been added to Sales Order Options that enable the default price level by customer and product line feature based on price codes or ship-to codes.

- A new task, Price Level by Customer Maintenance, accessed from either the Accounts Receivable Setup menu, from Customer Maintenance, or from Product Line Maintenance, allows you to establish default price levels to use when entering sales orders and one-step sales order invoices.

- You can copy all or specific product line/price level records from a customer to one or multiple customers using the new task, Price Level by Customer Copy, on the Accounts Receivable Setup menu, or by using the Copy button in Price Level by Customer Maintenance. You can also copy from a customer with existing records to a single customer by selecting Price Level from the drop-down menu in Customer Maintenance to open Price Level by Customer Maintenance and clicking Copy From.

- A new report, Customer Pricing Report, has been added to the Accounts Receivable Reports menu that allows you to produce a list of customers’ special pricing and discounts, including customers that have been set up with product line/price level records.

Purge Credit Card Data During Period-End Processing

You can now define what credit card data is purged during Accounts Receivable period-end processing and year-end processing. A new field in the Period End Processing window allows you to purge either data for expired credit cards only, credit card history only, expired credit card data and credit card history, or you can choose to not purge any credit card information.
Define Split Commissions by Customer

You can now define default percentage values for distributing sales order and invoice commissions among salespersons on a per-customer basis. Clicking the new Split Comm button in Customer Maintenance opens the Customer Split Commission Maintenance window, which allows you to distribute commissions among a maximum of five salespersons. The default values defined in this window appear in the Split Commission Entry window accessed through Sales Order Entry and Sales Order Invoice Data Entry, but they can be changed.

The Split Comm button is available in Customer Maintenance if the Split Commissions Between Salespersons check box is selected in Sales Order Options.

Recalculate Open Order Amounts

The Recalculate Open Order Amounts utility has been added to the Accounts Receivable Utilities menu. This utility allows you to recalculate the open order amounts from the Customer file for all customers based on open orders in the Sales Order data entry tasks.

Bar Code Enhancements

Print Lot/Serial Distribution Information

New fields in Sales Order Options allows you to enable lot/serial distribution for sales orders. When enabled, you now have the option to print the lot/serial number and distribution on sales orders and picking sheets.
Inventory Management Enhancements

View Lot/Serial Distribution Information

- In Item Maintenance/Item Inquiry, on the Cost Detail tab, you can now view the committed quantities to various data entry tasks as well as the quantity available if the Lot/Serial Distribution feature in Sales Order Options is enabled. Additionally, on the Orders tab, you can now view the order detail by lot/serial number when clicking the View/Lot Serial button.

- A new Lot/Serial Order Detail window has been added to the drop-down menu in Item Maintenance/Item Inquiry. This window displays the lot/serial distribution (including available quantities) for the selected item as well as the distribution already assigned to sales orders and the sales order items still waiting to be distributed.

- You now have the option to print lot and serial distributions from sales orders on the Stock Status Report, Open Sales Order Report, Open Orders by Item Report, Open Orders by Promise Date Report, and Open Orders by Job Report.

Library Master Enhancements

Define Credit Card Security Options

- Two new preferences have been added in User Maintenance to allow you to designate users that can print or display fully formatted credit card numbers. Users without those preferences will see only the masked credit card number.

- Two new security event roles have been added in Role Maintenance to allow you to designate which roles can change or delete the key used to encrypt credit card numbers. Industry standards recommend that you change this key at least annually to enhance security of the encrypted credit card numbers stored in your system.
PAYROLL ENHANCEMENTS

- The key used to encrypt the credit card information is now stored separately from your company data. By using the alternate directory feature, your key will be stored in a different physical location than your company data; thereby, increasing the security of the credit card information.

- A Credit Card Audit Log has been created. This log will show the following:
  - All credit card transaction requests sent to the payment server
  - Each time credit card numbers are encrypted or decrypted
  - Each time a user's print or display credit card preferences is changed
  - Each time a credit card key is changed or deleted

Payroll Enhancements

NOTE
The alternate directory feature is not available for Sage ERP MAS 200 SQL.

NOTE
Payroll enhancements are not available for Sage ERP MAS 200 SQL.

Recalculate Deductions in Payroll Data Entry

You now have multiple options for recalculating deductions that are based on earnings in Payroll Data Entry after changing, adding, or deleting data entry lines.

- Click the new Recalc Deductions button in Payroll Data Entry.

- Select Prompt at the new Recalc Deductions in Data Entry field in Payroll Options. When clicking Accept after changing, adding, or deleting a line in Payroll Data Entry, a message dialog box will appear asking if you want to recalculate deductions for the selected employee.

- Select Yes at the Recalc Deductions in Data Entry field in Payroll Options. Deductions will be automatically recalculated when clicking Accept after changing, adding, or deleting a line in Payroll Data Entry. You cannot manually overwrite a deduction if you select this option.
Define Deduction Code Options

Five new calculation methods are available in Deduction Code Maintenance; deductions can now be calculated as follows:

- A percentage of another deduction (for employer contributions)
- An amount multiplied by the total number of regular and overtime hours
- An amount multiplied by the total hours worked multiplied by the pay rate multiplier
- A percentage of the pay rate multiplied by the total hours worked
- An amount multiplied by the pay rate

You can now set up a deduction that is calculated based on selected earnings types.

Recalculate All Option for Payroll Imports

A Recalc All button has been added to the message dialog box that appears when importing payroll data through Visual Integrator. Click the button to recalculate automatic deductions for all records in the Payroll Data Entry file regardless of whether they exist in the current import. If you click the button, any previously calculated automatic deduction amounts will be removed.

Select Preconfigured Payroll Import Jobs

Five preconfigured import jobs are now available to select when importing payroll data using the Visual Integrator module.

- PR_ADP is configured to import delimited files in the ADP Paydata format.
- PR_FORMAT_2 is configured to import ASCII files that use a fixed field format and include a job number.
- PR_KRONOS is configured to import ASCII files in the Kronos Connect and Time Bank format.
PURCHASE ORDER ENHANCEMENTS

- **PR_KRONOS_NO_DP** is configured to import ASCII files in the Kronos Connect and Time Bank format.

- **PR_TIMETRAK** is configured to import ASCII files in the Timetrak version 8.0 format.

To make the jobs available in Import Job Maintenance, use the Job Import task to import the PayrollDataEntryImports.exp file, which is available in the \MAS90\PR folder. For more information, see Import Preconfigured Payroll Import Jobs in the Help system.

**Define Minimum Hours for Benefit Accrual**

A new field, Min Hrs/Check, has been added to Benefit Schedule Maintenance. This field allows you to define a minimum number of hours that must be worked per check before benefits will accrue.

**Identify Business Type**

A new field, Kind of Employer, has been added to the Federal eFiling and Reporting and State eFiling and Reporting tasks in the Payroll module, and the W2 Electronic Reporting task in the Electronic Reporting module. This new field allows you to identify your company’s type of business.

**Purchase Order Enhancements**

**View Sales Orders from Purchase Order Entry**

In Purchase Order Entry, you can now click the new Sales Order button on the Lines tab to access and view the sales order for the purchase order without having to return to the Desktop to open Sales Order Entry.

**Generate Purchase Orders from Sales Orders**

The Auto Generate from Sales Orders task has been renamed from Auto Generate Orders Selection, and it has been redesigned to facilitate the auto generation process.
Chapter 2  What's New in Version 4.50

Set Up Additional Purchase Order/Auto Generate Options

A new Generate tab has been added to Purchase Order Options. The tab features additional options for automatically generating purchase orders from sales orders. You now have the following options:

- Combine multiple sales orders for a vendor into one purchase order
- Use the sales order number as the purchase order number when automatically generating purchase orders from sales orders
- Increment the purchase order number at the beginning or end when using the sales order number as the purchase order number
- Select whether to base the purchase order header required date on the system date, purchase order date, sales order ship date, sales order order date, or to be prompted for a date prior to generating the purchase order
- Select whether to base the purchase order line required date on the system date, purchase order date, sales order promise date, or to be prompted for a date prior to generating the purchase order
- Print the Auto Generate from Sales Order Listing by customer number and print the Purchase Order Number Assignment Listing after generating the purchase orders
- Automatically open the Purchase Order Entry window after generating the orders or print the purchase orders after generating the orders
- Enable generating purchase orders from Sales Order Entry and elect to be prompted to generate purchase orders from Sales Order Entry for new sales orders
- Elect to include the sales order ship-to address, ship via, FOB, confirm to, e-mail address, line item’s cost of goods sold (COGS) account, and alias item number for general alias item types on the purchase orders during generation
Sales Order Enhancements

Set Up Additional Options for Job Cost

A new Job Cost tab has been added to Sales Order Options. The tab features additional options for integrating the Job Cost module with Sales Order. You now have the following options:

- Update invoice costs to job estimates
- Post costs for drop-ship lines to the Job Cost module
- If the Purchase Order module is set up and integrated with Job Cost, you can post costs for drop-ship lines in Purchase Order
- Have the job status automatically set to complete when the Sales Journal is updated
- Elect to relieve job costs from the work in process account and post them to the cost of sales account
- Have the quantity entered in Sales Order Entry update the quantity on sales order and quantity on hand values used in the Inventory Management module
- Include the job number and description in the general ledger posting comment
- Define how exploded kit component items and costs are updated to the Job Transaction Detail file
- Define how the system handles a discrepancy between the currently selected customer number and the job number entered in Sales Order Entry and Invoice Data Entry
- Define which cost of goods sold account and sales revenue account are used for line items in Sales Order Entry and Invoice Data Entry
Chapter 2  What’s New in Version 4.50

Also, the following fields have been relocated to the Job Cost tab:

- Post Invoice Costs to Job Cost
- Require Job Number
- Allow Jobs to be Created Automatically
- Require Cost Code

**Calculate Sales Commissions by Line Item**

A new task, Line Item Commission Maintenance, has been added to the Sales Order Setup menu. The task allows you to set up salesperson commission rates and amounts by combinations of salespersons, customers, inventory items, and effective dates.

**Calculate Item Pricing by Total Quantity**

New fields in Sales Order Options allow you to combine the ordered quantity for multiple sales order and invoice lines when calculating quantity pricing discounts. You can elect to use the total ordered quantity for all lines, or you can combine lines by product line or by the item categories defined in Inventory Management.

You can define which unit of measure to use for totaling the quantity ordered, and you can specify whether you want the item pricing by quantity applied automatically, when prompted, or for new entries only. Additionally, an Item Price button has been added to Sales Order Entry and Invoice Data Entry, which you can click to apply item pricing by quantity to the current order or invoice.

The rules that you set up for sales orders and Sales Order invoices will also be applied to eBusiness Manager shopping cart orders when they are accepted into Sales Order.
SALES ORDER ENHANCEMENTS

Distribute Lot/Serial Items from Sales Order Entry

Two new fields have been added to Sales Order Options that allow you to enable lot/serial distribution for sales orders and require that the sales order lines be fully distributed.

- You now have the option to distribute lot and serial numbers when creating sales orders, similar to S/O Invoice Data Entry, and print the lot and serial numbers on sales orders and picking sheets. This feature allows you to specify a lot and serial number and commit the item at the sales order level so they cannot be used by other tasks. The lot/serial distribution can then be pulled into Invoice Data Entry when the sales orders are invoiced.

- The new Lot/Serial Search button in Sales Order Entry allows you to find sales orders that are referencing specific lot/serial numbers. This feature allows you to easily select the lot/serial number and order for adjustments.

You can now elect to include or exclude lot and serial distribution from all Open Sales Order reports and the Inventory Stock Status Report. Additionally, you now have the option to print the lot/serial number and distribution on sales orders and picking sheets.

Generate Purchase Orders from Sales Orders

- You can now click the new Purchase Order button on the Lines tab to access and view the purchase order for the sales order without having to return to the Desktop to open Purchase Order Entry. Additionally, you can now generate a purchase order by clicking the Generate PO button on the Totals tab.

- You can now use a security event in Role Maintenance to prevent users from overriding the bill-to customer number during order entry.
Chapter 2  What’s New in Version 4.50

Assign Vendors to Miscellaneous/Special Items

- You can now select a vendor number for miscellaneous and special items so that a purchase order can be automatically generated for these item types. For regular inventory items, this field defaults to the item’s primary vendor but can be changed. For previously entered sales orders, the Vendor Number field will be blank.

- You can now use a security module option in Role Maintenance to allow users to view the vendor number during order entry.
Chapter 3

Workflow Changes in 4.50

This chapter describes the workflow changes incorporated in the product for the 4.50 release that you should be aware of. Installation and global changes are listed first followed by module changes and retirements.

Global Changes

Security Requirement

You are now required to set up security for your Sage ERP MAS system. When installing the software, you are now required to create an Administrator password. Each user must have a user logon created in User Maintenance in order to access the system.

Manage Your System Window

The Manage Your System Window no longer appears when starting your Sage ERP MAS system. The tasks that were available through this window, Company Maintenance, Role Maintenance, and User Maintenance, can be accessed from the Library Master Main menu or through the Administrative Tools window, which appears when you log on using the Administrator account.

Purchase Order Changes

Auto Generate Purchase Orders

Fields have been renamed in the newly renamed task Auto Generate from Sales Orders to make them more intuitive to the user.

Renamed Task

The Auto Generate Orders Selection task on the Main menu has been renamed Auto Generate from Sales Orders.
Chapter 3  Workflow Changes in 4.50

Retired Modules

The following modules have been retired as of version 4.50:

- StarShip (Freight and Parcel)
- FRx Reporting
- F9
- Business Alerts Select
Chapter 4

Workflow Changes in 4.40.0.X

This chapter describes the workflow changes incorporated in the product for the 4.40 release and product updates 4.40.0.1 through 4.40.0.5 that you should be aware of. Installation and global changes are listed first followed by module retirements.

Installation Changes

Changes in Version 4.40

Upgrading

- If you are upgrading from any level prior to 3.71, you must first upgrade to Level 3.71, and then perform a parallel installation with version 4.40.

- If you have Level 3.x software and version 4.40 software installed on the same workstation, only install Crystal Reports XI Release 2 for Sage ERP MAS 90 or 200 version 4.40 because only this version can read Crystal Reports in both level 3.x and version 4.x.

Global Changes

Changes in Version 4.40

Data File Multi-Segment

- Sage ERP MAS 90 and 200 now support segmented files. Data files that are reaching the 2 GB limit will now be segmented. Adding the segmented feature available in ProvideX will enhance the product’s ability to handle large data files. For example, the previous need to purge data from history files when the files reached the 2 GB limit has been eliminated.

NOTE
Contact your development partner if you have segmented files prior to version 4.40. Sage does not support the conversion of those segmented files.
The following is an example of how a segmented file would look in a company’s data folder:

- IM_ItemTransactionHistory.M4T
- IM_ItemTransactionHistory.M4T.001
- IM_ItemTransactionHistory.M4T.002

- Index and sort files for modules that have not been upgraded to the Business Framework will not be segmented.

- The Rebuild utilities are now enhanced to accommodate segmented files and a progress meter will appear when running the rebuild process.

**Activity Log**

The Activity Log provides a log of all data removed and the date used. Previously, the data removed and date used was not recorded for 4.x level.

**Advanced Lookup Engine (ALE)**

- When you are customizing a lookup in any module other than Job Cost, Material Requirements Planning, Payroll, and Work Order, you can add fields from linked files to the lookup.

- Customizations to lookups in any module other than Job Cost, Material Requirements Planning, Payroll, and Work Order will not be converted to your version 4.40 software. You will need to re-create lookup customizations in the affected modules. This includes customizations created in the User Lookup Wizard and by clicking Custom in a lookup window.

**Batch Faxing**

The fax number must include the area code to process a fax. Previously, if the fax number was within the local area, the area code was not required.
GLOBAL CHANGES

Character-Based Forms

Forms for all modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order are printed using Crystal Reports. You can no longer print character-based or nongraphical forms for those modules.

Customized Crystal Forms

- Customized Crystal forms in all modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order will need to be re-created after upgrading to version 4.40.

- Run the Form Comparison report to compare your customized forms to a default form from the prior version. This report prints the form name, folder, .rpt name, form code, and any fields (including user-defined fields) that were added or removed from the standard forms shipped with version 4.x. Use this report as a reference to modify the default version 4.40 Crystal forms. This report (SYWFCU) is available on the product CD and on the Sage Online Web site at: www.sagesoftwareonline.com

Data Dictionary Changes

The Job Cost, Material Requirements Planning, and Work Order file layouts have been changed to accommodate the expanded item code and expanded customer number options.

Data Entry

- To access the Record Count functionality in any module other than Job Cost, Material Requirements Planning, Payroll, and Work Order, right-click in a window and select System Info. The old method of pressing F8 is still available in all other modules.

- On the Lines tab of data entry windows in any module other than Job Cost, Material Requirements Planning, Payroll, and Work Order, at a field, press F2 or click the Lookup button to access the lookup window. After entering the field, the Lookup button no longer appears; however, you can still press F2 to access the lookup window.
Chapter 4  Workflow Changes in 4.40.0.X

Desktop

- Task folders in your Level 3.x Launcher’s My Tasks area will not be migrated to your version 4.40 Desktop. You will need to re-create your task folders.

- Buttons on your Level 3.x Launcher’s Custom toolbar will not be migrated to your version 4.40 Desktop’s Custom toolbar. You will need to re-create your buttons on the Custom toolbar.

Expanded Customer Numbers

Reports and forms have changed to accommodate the expanded customer number field.

Expanded Item Codes

Reports and forms have changed to accommodate the expanded item code field.

Printing

- All reports and listings in modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order now use Crystal Reports. Because of this, those modules no longer use the settings established in Library Master Report Format Maintenance.

- For reports and listings in modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order, the process for exporting or printing a report to a file has changed. In those modules, the Print to File option previously available in the Printer Setup window has been moved to the Export/E-mail option accessed from the Printer field and uses the Crystal Reports engine. For more information on how to export or print reports to a file in these modules, see Export or Print to a File in the Help system.
GLOBAL CHANGES

- For reports and listings in modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order the process for deferring the printing of a report has changed. In those modules, the Deferred option has been moved to the Deferred option accessed from the Printer field. This option was previously available in the Printer Setup window. For more information on how to defer the printing of a report in these modules, see Defer a Report in the Help system.

- Print jobs scheduled for deferred printing are now located in the following locations:
  - Job Cost, Material Requirements Planning, Payroll, and Work Order deferred files are located at ..\Home\Textout.
  - All other module files are located at ..\Home\Deferred.

Reports and Forms

- In modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order, report setting options now appear on the header area of the applicable report window. You can also define and save customized report settings. For more information, see Create a Report Setting in the Help system.

- The organization of reports on the Custom Reports menus will not be migrated from your Level 3.x software to version 4.40. Before upgrading, use the SUMNUA utility in your Level 3.x software to print copies of the existing Custom Reports menus’ organization to facilitate adding your reports to the Custom Reports menus in your version 4.40 software. To access the SUMNUA utility in your Level 3.x software, select File menu > Run. In the Run Program window, type SUMNUA.

WARNING
Reports on the Custom Reports menus will not be migrated from your Level 3.x to version 4.40 software.
Library Master Changes

Changes in Version 4.40

Changed Tasks

The Automatic Update process is now performed using Task Scheduler for modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order.

Role Maintenance

Override passwords previously maintained in Bill of Materials, Inventory Management, and Purchase Order Options are now handled as security events in Role Maintenance.

Accounts Payable Changes

Changes in Product Update 4.40.0.2

ACH Electronic Payment Processing

- In Accounts Payable Options, the following fields have been renamed:
  - The Check Register in Detail check box has been renamed Check and Electronic Payment Register in Detail.
  - The Check Comments Field has been renamed Check/Electronic Payment Comments.
  - The Print G/L Distribution on Check Register check box has been renamed Print G/L Distribution on Check/Electronic Payment Registers.
  - The Include Voided Checks and Include Wire Transfers fields have been removed from the Accounts Payable Check History Report window. They have been replaced with a Payment Types to Print section, which includes a Voided Checks check box and a Wire Transfers check box.
ACCOUNTS PAYABLE CHANGES

- The Include Wire Transfers field has been removed from the Payment History Report window. It has been replaced with a Payment Types to Print section, which includes a Wire Transfers check box.

**Renamed Tasks**

- The Check Printing Menu has been renamed Check Printing and Electronic Payment to reflect the ability to pay vendors electronically.
- Check Maintenance has been renamed Check and Electronic Payment Maintenance.
- Check Printing has been renamed Check Printing and Electronic Payment.
- Check Register has been renamed Check and Electronic Payment Register. If you are processing electronic payments, you will be prompted to print the Check Register and then the Electronic Payment Register.

**Changes in Product Update 4.40.0.1**

**Renamed Tasks**

- Manual Check Entry has been renamed Manual Check and Payment Entry to reflect the added ability to record and reverse wire transfers.
- The Manual Check Register task has been renamed Manual Check and Payment Register.

**Change in Version 4.40**

**Renamed Task**

The Detail Receipt History task in Vendor Maintenance has been renamed Vendor Receipt History.
Accounts Receivable Changes

Change in Version 4.40

*Renamed Task*

The Detail Sales History task in Customer Maintenance has been renamed Customer Sales History.

Bank Reconciliation Changes

Changes in Product Update 4.40.0.3

*Registers and Updates*

You can now use a security event in Role Maintenance to prevent users from updating the registers.

*Renamed Task*

The Bank Reconciliation Register task on the Main menu has been renamed to Bank Reconciliation Report.

Change in Product Update 4.40.0.2

*Enter Checks, Deposits, and Adjustments On-the-Fly*

In Reconcile Bank, you can now enter checks, deposits, and adjustments on the fly. Previously, you had to exit Reconcile Bank and enter additional checks, deposits, or adjustments in Check, Deposit and Adjustment Entry.
Bar Code Changes

Changes in Version 4.40

Bar Code Options

The Graphical Forms field has been removed as the Bar Code module now uses Crystal Reports to print forms and reports.

Unattended Bar Code Transaction Import

ODB files are no longer imported using the Unattended Bar Code Transaction Import task. ODB files must now be imported using Import Bill of Materials Transactions, Import Inventory Transactions, Import Purchase Order Transactions, and Import Sales Order Transactions.

Renamed Tasks

- The Period End Processing task has been renamed Purge Bar Code History.
- The Bar Code P/O Receiver Printing task has been renamed Purchase Order Printing.

Bill of Materials Changes

Changes in Version 4.40

Global Changes

- You must re-create all Visual Integrator jobs to import bill of materials data.
- You can now undo accidental data entry changes to a data entry screen. Previously, you could only save the changes or cancel the entry.
- You can now view all 30 characters of the item description. Previously, only the first 24 characters were displayed.
**Bill of Materials Options**

- The option to Allow Entry of Negative Quantities no longer applies to Option Interaction Maintenance.

- If the Allow Kit Bills and/or the Allow Phantom Bills check boxes are cleared, a message dialog box will now appear in Bill of Materials Options. Previously, the message dialog box displayed in Bill of Materials Maintenance.

- You can now enter a unique next automatic disassembly number. Previously, Production Entry and Disassembly Entry shared the same option.

**Data Entry**

In all data entry windows, the Item Inquiry window has been replaced with the Item Quantity Inquiry window.

**Inquiry Changes**

- The Bill of Materials Inquiry and Bill of Materials Where-Used Inquiry windows have been re-designed with new fields and drill downs.

- The Options button in Bill of Materials Inquiry and Bill of Materials Where-Used Inquiry has been replaced with radio buttons for the different selections to inquire on. Additionally, a tree view now displays when the Indented view is selected.

**Printing**

- Reports and listings now use Crystal Reports. Because of this, the Bill of Materials module no longer uses the settings established in Library Master Report Format Maintenance.

- The process for exporting or printing a report to a file has changed. The Print to File option previously available in the Printer Setup window has been moved to the Export/E-mail option accessed from the Printer field and uses the Crystal Reports engine. For more information on how to export or print reports to a file, see Export or Print to a File in the Help system.
• The process for deferring the printing of a report has changed. The Deferred option has been moved to the Deferred option accessed from the Printer field. This option was previously available in the Printer Setup window. For more information on how to defer the printing of a report, see Defer a Report in the Help system.

• The report and form windows now remain open when you receive the "Data is not selected for report printing" message dialog box, so you can resolve the issue without losing your settings.

• Print jobs scheduled for deferred printing are now located in the ..\Home\Deferred folder.

• The font size on some reports was changed to allow the report to remain in portrait format.

Reports and Forms

Report setting options now appear on the header area of the applicable report window. You can also define and save customized report settings. For more information, see Create a Report Setting in the Help system.

Renamed, Removed, or Moved Tasks

• All the inquiry windows on the Main menu have been moved to the Inquiries menu.

• The Replace/Delete Component Entry task on the Change Control menu has been renamed Replace and Delete Component Entry.

• The Replace/Delete Component Register has been renamed Replace and Delete Component Register.

• The Miscellaneous Charge Maintenance task on the Setup menu has been renamed Miscellaneous Item Maintenance. This task is also available from the Common Information Main menu.
Chapter 4  Workflow Changes in 4.40.0.X

Business Insights Changes

Changes in Version 4.40

Business Insights Reporter

After upgrading to version 4.40, you will need to re-create Business Insights Reporter reports used in Bill of Materials, Inventory Management, and Purchase Order.

- For custom reports previously created using version 4.30 or prior data from the Bill of Materials, Inventory Management, and Purchase Order modules, access Business Insights Reporter and select a report in the Business Insights Reporter Selection window. You are prompted to print the Business Insights Reporter Definition Listing and then delete the report. Repeat this process for each custom report previously created for the Bill of Materials, Inventory Management, and Purchase Order modules.

Common Information Changes

Change in Product Update 4.40.0.2

Bank Code Maintenance

In Role Maintenance, a new module option for Common Information has been created that controls which users can change the current balance for each bank defined in Bank Code Maintenance. Previously, there was no security for this function so all users could change the current balance.

Changes in Version 4.40

Miscellaneous Item Maintenance

Miscellaneous Item Maintenance has been added to the Common Information Main menu. This task remains on the Bill of Materials Setup menu and Purchase Order Setup menu.
**Common Information Options**

- The Number of Decimal Places fields, previously in the Inventory Management Options window on the Inventory Management Setup menu and in the Purchase Order Options window on the Purchase Order Setup menu, have been moved to the Common Information Options window on the Common Information Setup menu.

- The Years to Retain Item History field, previously in the Inventory Management Options window on the Inventory Management Setup menu, has been moved to the Common Information Options window on the Common Information Setup menu. Additionally, a minimum of two years is now required to retain history.

- If the Inventory Management module is not set up for a company, the Common Information period history will be accumulated based on the General Ledger fiscal year setup. If the Inventory Management module is set up, the history will be accumulated based on the selection made at the Base Inventory Periods On field in Inventory Management Options.

**Renamed, Removed, or Moved Tasks**

- The Unit of Measure Conversion Maintenance task, previously on the Inventory Management Setup menu, has been moved to the Common Information Setup menu.

- The Purge Miscellaneous Item History has been renamed Purge Item History.

- Purge Obsolete Extended Descriptions, previously on the Library Master Utilities menu, has been moved to the Common Information Utilities menu.

- Memo Manager Maintenance, previously on the Library Master Setup menu, has been moved to the Common Information Main menu. This task remains on the Purchase Order Setup menu and Inventory Management Setup menu.
Chapter 4  Workflow Changes in 4.40.0.X

Customizer Changes

Changes in Version 4.40

Global Changes

- Customized libraries for the Bill of Materials, Inventory Management, and Purchase Order modules will not be migrated and must be re-created after the migration process.

- Data entry user-defined fields (UDFs) must be re-created in User-Defined Field and Table Maintenance after upgrading to version 4.40. After re-creating UDFs, you must map the UDFs to their respective history files. For more information, see Map User-Defined Fields (UDFs) in the Help system.

- For Purchase Order Receipt of Goods, Receipt of Invoice, and Return of Goods, the new Purchase Order Invoice UDF migrated or converted to 4.40 from 4.20 or 4.30 is no longer needed. For UDFs that existed in the Purchase Order Invoice UDF file, these records will need to be imported into an AP Invoice History Header UDF. The Purchase Order Invoice UDFs are not automatically merged into the AP Invoice History Header UDF upon upgrading to 4.40.

- When upgrading from a previous version of 4.x, the following list of UDFs are updated to specific tables:
  - The Bill of Materials Header UDFs are now updated to the new BM Bill Header table.
  - The Bill of Materials Lines UDFs are now updated to the new BM Bill Detail table.
  - The Inventory Management Warehouse Detail UDFs are updated to the new IM Item Warehouse table.
  - The Purchase Order Receipt History UDFs are now updated to the new PO Receipt History Header table.
  - The Purchase Order Receipt/Return Lines UDFs are now updated to the new PO Receipt History Detail table.
• The Purchase Order UDFs are now updated to the new PO Purchase Order Header table.

• The Purchase Order Lines UDFS are now updated to the new PO Purchase Order Detail table.

**eBusiness Manager Changes**

**Changes in Version 4.40**

---

**Sage Web Engine**

• You must uninstall the Sage Web Engine, and then re-install it after upgrading to version 4.40.

• If you have customized templates in the IW folder, back them up in another location before uninstalling the Sage Web Engine. After uninstalling, you must merge your customized templates with the Standard templates as some have changed for corrections or enhancements.

• Enabling item code expansion (from 15 to 30 characters) can cause layout changes in your HTML templates when rendering in a browser. You should verify if your customized templates are affected.

---

**General Ledger Changes**

**Changes in Version 4.40**

---

**Fiscal Year Maintenance**

• In Fiscal Year Maintenance, if you change an existing period-end date and/or year, the Item History by Period information is now included as part of the recalculation. Previously, the system recalculated only the General Ledger Posting History by Period and Sales Order Recap information.
Chapter 4  Workflow Changes in 4.40.0.X

- The functionality of the Recalculate button has been changed to recalculate only the Sales Order Recap information. Previously, clicking this button recalculated the General Ledger summary information. You can now use the Recalculate Account Balances utility on the Utilities menu to recalculate the General Ledger information.

Inventory Management Changes

Changes in Version 4.40

Global Changes

- If the Inventory Management module is not set up for a company, the Common Information period history will be accumulated based on the General Ledger fiscal year setup. If the Inventory Management module is set up, the history will be accumulated based on the selection made at the Base Inventory Periods On field in Inventory Management Options.

- You can now undo accidental data entry changes to a data entry screen. Previously, you could only save the changes or cancel the entry.

- You can now view all 30 characters of the item description. Previously, only the first 24 characters were displayed.

- You can now print receipt labels after printing or previewing the Transaction Register. Previously, you could only print the receipt labels before the update process.

- You must re-create all Visual Integrator jobs to import inventory data.

Inventory Management Options

- The ability to sort physical count by bin location, previously in the Inventory Management Options window on the Setup menu has been moved to the Physical Count Worksheet and Physical Count Entry tasks on the Physical Count menu. You can now select to print by bin location.
INVENTORY MANAGEMENT CHANGES

- The Number of Decimal Places fields, previously in the Inventory Management Options window on the Inventory Management Setup menu has been moved to the Common Information Options window on the Common Information Setup menu.

- The Retain Transaction History check box has been removed from the Inventory Management Options window. You can now use the Purge Item History utility on the Inventory Management or Common Information Utilities menu to purge transaction history. Additionally, at least 2 years retention is required.

- The ability to add a not-on-file warehouse has been removed. Validation occurs now when the warehouse code is entered.

- The next automatic entry numbers options have been moved to the new Entry tab. In addition, you can now enter alphanumeric and special characters.

Product Line Maintenance

The Allow Back Orders check box must first be selected to enable the Allow Returns check box. Selecting the Allow Returns check box will now be the entry default selection for items in the Item Maintenance window and can be applied to existing inventory items by clicking Apply. Previously, the Allow Back Orders and Allow Returns check boxes were both enabled, and an inventory item created with this product line then inherited these settings.

Transaction Entry

- You can now use the batch entry feature to perform multiple entry sessions simultaneously.

- You can now clear a previous distribution to enter a new distribution in the Distribution Entry window when adjusting an item. Previously, you had to enter a 0 (zero) at the Distribute field to clear the FIFO/LIFO/Lot/Serial Number and Receipt No. fields.
Chapter 4  Workflow Changes in 4.40.0.X

**Item Maintenance**

- Some hot keys have been changed to provide convenient shortcuts to tasks that are otherwise accessed through menu navigation. For a list of the updated hot keys, see Using Hot Keys in Item Maintenance in the Help system.

- The Standard Cost field can no longer be changed for standard cost items with activity. If activity exists, this field can only be viewed. Instead, use the new Standard Cost Adjustment Entry task to adjust the standard cost.

- You can now view the information on a grid by quantity, sales, or receipts by selecting the Quantities, Sales, or Receipts option on the new History tab. Previously, you had to click the History button on the Main tab to view item quantity, sales, or receipt information.

- Quantity information previously in the Quantity on Hand and Reorder windows, is now available on the Quantity tab. Reorder information can be accessed by clicking the Reorder button on the Quantity tab and on the More button.

- Buttons on the Main tab have been moved to the More button.

**Physical Count Changes**

- You can now print the Physical Count Worksheet by bin location and quantity on hand. Previously, the worksheet could only be printed by item code and item description, and the quantity on hand was not available to print.

- The Physical Count Entry task now checks the Sales Order, Return Merchandise Authorization, Bill of Materials, Purchase Order, and Work Order modules and displays a warning if unprocessed inventory transaction entries exist when trying to freeze the items. Previously, it only checked Inventory Management.
Costing Changes

- If an average cost item has negative quantity on hand, when items are received, the cost is adjusted only for the quantity received. Previously, the cost was adjusted for the entire negative quantity.

- The Inventory Detail Transaction Report, Inventory Trial Balance Report, and Inventory Valuation Report by Period now print the historical standard cost by default and a selection to print the current or historical cost is now available in the report windows. Previously, only the current standard cost was provided.

- The Automatic Cost and Price Change task is no longer used to change the standard cost for standard cost items. You must use Standard Cost Adjustment Entry on the Inventory Management Utilities menu to change the standard cost for standard cost items.

Utilities Menu

A new Utilities menu has been added to the Inventory Management module. The tasks available in this menu are:

- Delete and Change Items
- Purge Item History
- Remove Zero Quantity Costing Tiers
- Recalculate Item History
- Item Valuation Change Selection
- Item Valuation Change Maintenance
- Item Valuation Change Register/Update
- Automatic Cost and Price Change
- Standard Cost Adjustment Selection
- Standard Cost Adjustment Entry
- Standard Cost Adjustment Register/Update
Chapter 4  Workflow Changes in 4.40.0.X

**Period End Processing**

Only full period-end processing can be performed in the Period End Processing task accessed from the Period End menu.

Various fields previously included in the Period End Processing window have been moved to the Utilities menu as follows:

- The Only Remove Detail History option has been replaced with the Purge Item History task on the Utilities menu.
- The Only Remove Costing Tiers with Zero Quantities option has been replaced with the Remove Zero Quantity Costing Tiers task on the Utilities menu.
- The Only Remove Transaction Detail option has been removed.

**Printing**

- You can now print receipt labels after printing or previewing the Transaction Register. Previously, you could only print receipt labels before the update process.
- The report and form windows now remain open when you receive the message dialog box stating there is no data in the range to print so you can resolve the issue without losing your settings.
- Reports and listings now use Crystal Reports. Because of this, the Inventory Management module no longer uses the settings established in Library Master Report Format Maintenance.
- The process for exporting or printing a report to a file has changed. The Print to File option previously available in the Printer Setup window has been moved to the Export/E-mail option accessed from the Printer field, and it uses the Crystal Reports engine. For more information on how to export or print reports to a file, see Export or Print to a File in the Help system.
INVENTORY MANAGEMENT CHANGES

- The process for deferring the printing of a report has changed. The Deferred option has been moved to the Deferred option accessed from the Printer field. This option was previously available in the Printer Setup window. For more information on how to defer the printing of a report, see Defer a Report in the Help system.

- Print jobs scheduled for deferred printing are now located in the ..\Home\Deferred folder.

- The font size on some reports was changed to allow the report to remain in portrait format.

Reports and Forms

- The report and form windows now remain open when you receive the “Data is not selected for report printing” message dialog box so you can resolve the issue without losing your settings.

- The Inventory Valuation Report by Period can now print items with zero balances and the unit cost for standard cost items can be viewed by current or historical transactions.

Renamed, Removed, or Moved Tasks

- The Inventory Maintenance and Inventory Inquiry tasks on the Main menu have been renamed Item Maintenance and Item Inquiry.

- The Transaction Journal on the Main menu has been renamed Transaction Register.

- The Automatic Cost/Price Change task has been moved to the Utilities menu and renamed Automatic Cost and Price Change.

- The Sales Kit Listing on the Kits menu has been renamed Sales Kit Report.

- The Inventory Memo Printing report on the Reports menu has been renamed Item Memo Printing.

- The Item Masterfile Audit Report on the Reports menu has been renamed Item Audit Report.
Chapter 4  Workflow Changes in 4.40.0.X

- The U/M Conversion Maintenance task on the Setup menu has been renamed Unit of Measure Conversion Maintenance and moved to the Common Information Setup menu.

- The Buyer/Planner Code Maintenance task on the Setup menu has been renamed Buyer and Planner Code Maintenance.

- The Bar Code Printer Maintenance task on the Setup menu has been moved to the Work Order Setup menu.

- The Item Delete/Reumber/Merge option in the Inventory Management Utilities window on the Setup menu has been moved to the Utilities menu and renamed Delete and Change Items.

- The Item Valuation Change Selection, Item Valuation Change Maintenance, and Item Valuation Change Register options in the Inventory Management Utilities task on the Setup menu have been moved to the Utilities menu.

- The name of the hidden utility, IMZBL1, has been changed to IM_BalanceQtyOnHand_UI.

Job Cost Changes

NOTE
The Job Cost module is not available for Sage ERP MAS 200 SQL.

Changes in Version 4.40

Job Cost Options

The Timberline Estimating and Directory for Estimating Database fields in the Job Cost Options window have been removed due to the retirement of Timberline Link.

Data Dictionary Changes

The file layouts have been changed to accommodate the expanded item code and expanded customer number options.
Payroll Changes

Change in Product Update 4.40.0.5

**Quarterly 941 Printing**

In the Quarterly 941 Printing window, the Tax Due on Unreported Tips field has been added.

Change in Version 4.40

**Quarterly 941 Printing**

In the Quarterly 941 Printing window, the Current Tax Withholding, Prior Quarter Social Sec/Medicare, Additions to Federal Tax, and Additions to Social Sec/Medicare fields have been removed. The COBRA Premium Assist. Payments and Individuals Provided COBRA Assist. fields have been added.

Purchase Order Changes

Changes in Version 4.40

**Global Changes**

- You must re-create all Visual Integrator jobs to import purchase order data.

- You can now undo accidental data entry changes to a data entry screen. Previously, you could only save the changes or cancel the entry.

- You can now view all 30 characters of the item description. Previously, only the first 24 characters were displayed.

- The Tabs button has been removed from data entry tasks and the settings are now available as part of the data entry grid.

**NOTE**

The Payroll module is not available for Sage ERP MAS 200 SQL.
Chapter 4  Workflow Changes in 4.40.0.X

- Batch processing is now handled through system Batch Manager programs. Previously, there was one Batch Processing option that applied to the data entry tasks. Receipt of Goods/Invoice Entry and Return Of Goods/Material Requisition Issue Entry tasks now have their own batch options.

- Previously, historical data was stored by the period to date (PTD), year to date (YTD), last year, and future period. Purchase Order purchases and receipt history are now stored by period by year. The conversion for purchases and receipts history is now performed as follows:
  - The PTD record is converted to the current period.
  - The YTD record is converted to the period before the current period (for example, if the current period is June, then the total YTD amount should be in May).
  - The prior year record is converted to the last fiscal period of the prior year.
  - The updating of files is now based on the posting date. Previously, the General Ledger fiscal year was used to determine the period and year.

**Purchase Order Options**

- The ability to create passwords or allow overrides to data entry security options has been removed from Purchase Order Options and replaced with security event options in Role Maintenance on the Library Master Main menu.

- The Number of Decimal Places fields, previously in the Purchase Order Options window on the Purchase Order Setup menu, have been moved to the Common Information Options window on the Common Information Setup menu.

- The ability to inquire on a memo from an entry task has been replaced with the Memo Manager Maintenance task on the Common Information Main menu.
**PURCHASE ORDER CHANGES**

- Entry options have been moved to the Entry tab, line entry options have been moved to the Line Entry tab, printing options have been moved to the Printing tab, and history options have been moved to the History tab.

- You can now display all drop-ship lines from a sales order, regardless of the assigned purchase order vendor. Previously, when a drop-ship purchase order was entered, the drop-ship lines on the sales order would display if the vendor matched one of the vendors assigned to the item.

- You can now remove purchase history from the Purchase Order file by selecting the Purge Purchases History Utility task on the Purchase Order Utilities menu. Previously, the purchase history was removed during period-end processing.

- You can now retain comment lines in receipt history. Previously, the Accounts Payable module controlled comments for receipt history.

- You can now select a format to use for posting comments to General Ledger.

- Additional fields have been added to print the Back Order Fill Report.

**Purchases History**

- Previously, purchase history was saved by period and month. With version 4.40 and higher, purchase history is now continuously saved by receipt date and posting date.

- You must now retain at least two years of purchase history at the Years to Retain Purchase History field in the Purchase Order Options window, with the option to retain up to 99 years.

**Data Entry**

- The Item Inquiry window has been replaced with the Item Quantity Inquiry window in Purchase Order Entry, Receipt of Goods Entry, and Receipt of Invoice Entry.

- The Tabs button has been removed and a Defaults button added to all data entry windows.
• You can now use a security event in Role Maintenance to prevent users from adding inventory items on the fly. Previously, the Allow On-the-Fly Additions of Inventory Items field was available in Purchase Order Options.

Utilities Menu

A new Utilities menu has been added to the Purchase Order module. The tasks available in this menu are:

• Purge Completed Purchase Orders
• Purge Expired Master/Repeating Orders
• Purge Completed or Cancelled PO Recap
• Purge Obsolete Purchase Orders
• Purge Purchase Order Receipt History
• Purge Purchases History

Period End Processing

Only full period-end processing can be performed in the Period End Processing task accessed from the Period End menu.

Various fields previously included in the Period End Processing window have been moved to the Utilities menu as follows:

• The Purge Completed Purchase Orders option has been replaced with the Purge Completed Purchase Orders task.

• The Purge Expired Master/Repeating Orders option has been replaced with the Purge Expired and Master Repeating Order task.

• The Purge Completed or Cancelled PO Recap option has been replaced with the Purge Completed or Cancelled PO Recap task.

• The Purge Obsolete Purchase Orders option has been replaced with the Purge Obsolete Purchase Orders task. Additionally, records dated on or before the purge date entered has been removed.

• The Purge Purchase Order Receipt History option has been replaced with the Purge Purchase Order Receipt History task.
The Purge Purchases History utility has been added to the Utilities menu to remove purchase history. Previously, the purchase history was removed during period-end processing.

**Printing**

- Reports and listings now use Crystal Reports. Because of this, the Purchase Order module no longer uses the settings established in Library Master Report Format Maintenance.
- The report and form windows now remain open when you receive the message dialog box stating there is no data in the range to print so you can resolve the issue without losing your settings.
- The process for exporting or printing a report to a file has changed. The Print to File option previously available in the Printer Setup window has been moved to the Export/E-mail option accessed from the Printer field and it uses the Crystal Reports engine. For more information on how to export or print reports to a file, see Export or Print to a File in the Help system.
- The process for deferring the printing of a report has changed. The Deferred option has been moved to the Deferred option accessed from the Printer field. This option was previously available in the Printer Setup window. For more information on how to defer the printing of a report, see Defer a Report in the Help system.
- Print jobs scheduled for deferred printing are now located in the ..\Home\Deferred folder.
- The font size on some reports was changed to allow the report to remain in portrait format.

**Registers and Updates**

The Purchase Order Variance Register now prints after the register and before the update. Previously, this register printed after the update.
Chapter 4  Workflow Changes in 4.40.0.X

**Reports and Forms**

- In the Back Order Fill Report, you can now print only the items that have a back ordered quantity on the sales order if the received quantity is not equal to zero. Previously, the report printed all items on the purchase order that had a back ordered quantity on the sales order.

- Report setting options now appear on the header area of the applicable report window. You can also define and save customized report settings. For more information, see Create a Report Setting in the Help system.

- The report and form windows now remain open when you receive the "Data is not selected for report printing" message dialog box so you can resolve the issue without losing your settings.

**Renamed, Removed, or Moved Tasks**

- The Purge Completed Purchase Orders, Purge Expired Master/Repeating Orders, Purge Completed or Cancelled PO Recap, and Purge Obsolete Purchase Order utilities have been moved from the Period End Processing window to the Utilities menu.

- The Purge Purchase Order Receipt History and Purge Purchases History utilities have been added to the Utilities menu.

- The Open PO by Item Report has been renamed Open Orders by Item Report.

- The Open PO by Job Report has been renamed Open Orders by Job Report.

- The Receipt History Report has been renamed Purchase Order Receipt History Report.

- The Open PO by Work Order Report has been renamed Open Orders by Work Order Report.

- The Automatic Reorder Selection option has been renamed Auto Reorder Selection.

- The Ship to Address Maintenance task has been renamed Ship-To Address Maintenance.
• The Miscellaneous Charge Maintenance task has been renamed Miscellaneous Item Maintenance.

Return Merchandise Authorization Changes

Change in Version 4.40

Renamed, Removed, or Moved Tasks

The Item Inquiry window has been replaced with the Item Quantity Inquiry window in RMA Entry and RMA Receipts Entry.

Sales Order Changes

Changes in Product Update 4.40.0.1

Checking for Duplicate Customer PO Numbers

• The Check for Duplicate Customer PO Numbers check box in the Sales Order Options window has been replaced with the Files to Check for Duplicate Customer PO Numbers section.

• You can now select which Sales Order and Accounts Receivable History and Entry files are searched when entering sales orders and invoices.

• In Role Maintenance you now have a module option to prevent the use of duplicate customer purchase order numbers.

Data Entry

When creating a sales order from a master or repeating order or quote, the payment type on the sales order will be defaulted from the default payment type in Customer Maintenance. Previously it would default from the payment type in the master or repeating order or quote.
**Expanded Quick Print Options**

The Quick Print button in Sales Order Entry has been replaced with the Print Order button, and the Print Pick button has been added. Based on selections in Sales Order Options, you can now quick print picking sheets in Sales Order Entry, and you can receive a prompt to quick print picking sheets and shipping labels immediately after quick printing sales orders.

**Changes for Picking Sheet Printing**

- A picking sheet is no longer printed if the source sales order is in use in Sales Order Entry during the picking sheet selection process.
- If the Print Pick Sheets check box for a sales order is not cleared after the picking sheet is printed because the order is in use by another user during the printing process, the message dialog box that appears now lists the affected orders. Also, you can now turn off this message in Sales Order Options; the order information will then be written to the Activity Log.

**Changes in Version 4.40**

**Sales History Reports**

The Customer Sales History Report now prints by invoice date or posting date depending on whether you base inventory periods by physical periods or calendar months. Previously, this report was printed by period or month. This same report also printed sales history by item or product line. Now you can print information using three new reports.

- Customer Sales History by Item
- Customer Sales History by Product Line
- Customer Sales History

**Security Option for Adding Inventory Items on the Fly**

You can now use a security event in Role Maintenance to prevent users from adding inventory items on the fly. Previously, the Allow On-the-Fly Additions of Inventory Items field was available in Sales Order Options.
**Data Entry**

- In the Sales Order Entry window, the user login ID is now displayed if security is set up. Previously, the user code displayed.

- The Item Inquiry window has been replaced with the Item Quantity Inquiry window in Sales Order Entry and Invoice Data Entry.

**Renamed Tasks**

- The Monthly Recap by Division has been renamed Sales Recap by Division.

- The Monthly Recap by Product Line has been renamed Sales Recap by Product Line.

- The Monthly Recap by Warehouse has been renamed Sales Recap by Warehouse.

- The Monthly Recap by Warehouse by Product Line has been renamed Sales Recap by Warehouse by Product Line.

**Visual Integrator Changes**

**Changes in Version 4.40**

**Data Dictionaries**

Before you use the Visual Integrator module, select Visual Integrator Main menu > Export Job Maintenance or Import Job Maintenance after installing version 4.40. This initiates the necessary update of the Data Dictionaries so that you can successfully create Visual Integrator jobs.
Chapter 4  Workflow Changes in 4.40.0.X

Data Dictionary Listing

File information for modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order is no longer included on the Data Dictionary Listing. To obtain file information for these modules, on the Desktop, access the Resources page and click the File Layouts and Program Information link. You must re-create Visual Integrator jobs for these modules.

Import Job Maintenance

- When you select Visual Integrator Main menu > Import Job Maintenance, the new window, V/I Import Job Selection appears. In the V/I Import Job Selection window, you can enter a new job name or select an existing job. For new jobs, you must select the table (previously referred to as File Name) for which the import will be prepared. After a table is selected, the Import Job Maintenance window appears.

  If a table for modules other than Job Cost, Material Requirements Planning, Payroll, or Work Order is selected in the V/I Import Job Selection window, only the tables for those modules are available for selection at the Table Name field (previously called File Name field) in the Import Job Maintenance window. If a table from Job Cost, Material Requirements Planning, Payroll, TimeCard, or Work Order module is selected in the V/I Import Job Selection window, files from only these modules are available at the File Name field in the Import Job Maintenance window.

  The Validation tab is no longer available because validation is done by the business object. When you create a job for the Job Cost, Material Requirements Planning, Payroll, TimeCard, or Work Order modules, the Validation tab is available.

  In the Import Job Maintenance window, when you create a job for modules other than Job Cost, Material Requirements Planning, Payroll, TimeCard, or Work Order, you cannot test or execute the import job until your system administrator gives you the rights to execute the job in Role Maintenance. Previously, system security did not prevent you from immediately executing jobs for these modules.
VISUAL INTEGRATOR CHANGES

- You must re-create all Visual Integrator jobs to import inventory, bill of materials, and purchase order data.

- All data entry business objects now allow an existing line item in the Detail file to be modified. The Line Key field is now displayed in red and its value must be provided to edit an existing detail line. If the value provided is blank or invalid, a new detail line will be added from the import record.

- The ability to import lot and serial distribution records is now included in the related header import. In the Available Fields section of the Data tab, tier distribution fields are now available and are preceded by the letters LL. Previously, importing lot and distribution records was available only in Sales Order Invoice Data Entry and required a tier distribution record type using a pre-defined tier distribution import layout.

- In the Import Job Maintenance window, in the Available Selections section of the Record tab, the Change Next On option has been removed.

  When evaluating the Header information in the Source file and a change is found, the next record is automatically created. It is important to have consistent Header information when importing multiple line and distribution records. For example, if the key value (sales order number) in the Source file is the same for three rows, and one field in each row has a different value, the subsequent row will replace the previous row imported with the same key.

- The Job Import Log now contains the record type to distinguish between Header, Line, and Distribution records. Previously, only the Header and Line records displayed. The Distribution records were appended to the Line records.
Chapter 4  Workflow Changes in 4.40.0.X

Work Order Changes

Changes in Version 4.40

Renamed, Removed, or Moved Tasks

The Bar Code Printer Maintenance task, previously on the Inventory Management Setup menu, has been moved to the Work Order Setup menu.

File Layout

The file layouts have been changed to accommodate the expanded item code and expanded customer number options.

Report Master Changes

Changes in Version 4.40

Reports

- Reports for modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order are now created using Business Insights Reporter. Report Master reports can no longer be generated for these modules.

- Sage recommends using Business Insights Reporter to create custom reports for modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order.

- Sage recognizes that you may have expended considerable time and effort creating custom reports for Job Cost, Material Requirements Planning, Payroll, and Work Order in Report Master. As a result, although Report Master has been removed, it can still be accessed by using a hidden utility. To access Report Master, select File > Run and type *unhiderm in the Run Program window.

NOTE

The Work Order module is not available for Sage ERP MAS 200 SQL.
Retired Modules

The following modules were retired as of version 4.40:

- Timberline
- ACT! Link
- SageCRM version 6.1 (This does not apply to Extended Enterprise Suite customers)
- Crystal Web Reports
Chapter 5

Workflow Changes in 4.30

This chapter describes the workflow changes incorporated in the product for the 4.30 release that you should be aware of. Installation and global changes are listed first followed by module retirements.

Installation Changes

The option for installing Microsoft Internet Explorer is removed because the version of Internet Explorer required is now available with the supported versions of Windows.

Global Changes

Reports and Forms

- The information previously on the Main and Select tabs in report windows is now conveniently on one screen.

- The report and form windows now remain open when you receive the "Data is not selected for report printing" message dialog box, so you can resolve the issue without losing your settings.

Selection Grids

In the selection grids, you can now enter the Value fields before selecting an operand.
Library Master Changes

Role Maintenance

- When defining a role in Role Maintenance to provide users with access to Business Insights Reporter, select the Business Insights Reporter check box under Library Master > Setup Options. This check box was previously located under the Business Insights folder in Role Maintenance.

- You can now set up access to the Business Insights Dashboard for each user using the Dashboard Maintenance Wizard. The module options for the Business Insights Dashboard are removed from Role Maintenance.

Accounts Receivable Changes

Customer Statements

You must now set up the Paperless Office module to e-mail statements to customers. Previously, to e-mail customer statements, you had to select the E-mail Statements check box in Customer Maintenance and then select the appropriate option at the Produce Statements For field in the Statement Printing window. For more information, see Set Up Paperless Office in the Help system.
Chapter 5  Workflow Changes in 4.30

Business Insights Changes

Business Insights Dashboard

- To take advantage of the Business Insights Dashboard's upgraded architecture, you must set up your Dashboard pages again. For more information, see Set Up Business Insights Dashboard in the Help system.

- Internet Explorer 6.0 or higher is required to view the Dashboard pages.

- You can now set up access to the Business Insights Dashboard for each user using the Dashboard Maintenance Wizard. The module options for the Business Insights Dashboard are removed from Role Maintenance.

- In the Top Customer view, the Year to Date field now excludes future-dated transactions that are in the same year. The new Business Insights Dashboard displays the information as of the date entered. If a date is not entered, the information is displayed as of the period-end date.

Business Insights Reporter

- You must activate the Business Insights module to use Business Insights Reporter.

- When defining a role in Role Maintenance to provide users with access to Business Insights Reporter, select the Business Insights Reporter check box under Library Master > Setup Options. This check box was previously located under the Business Insights folder in Role Maintenance.

Common Information Changes

Bank Code Maintenance

The Bank ID Number field in the Bank Code Maintenance window has been renamed Bank Account Number.
Payroll Changes

Direct Deposits

- In the Direct Deposit Interface Setup window, the account numbers can now only be viewed. The account numbers can be changed using Bank Code Maintenance.

- The Space Rather Than Dash in the Word ‘Pre-Note’ check box is now available in the Direct Deposit Interface Setup window. Previously, this check box was in the Extended Solution’s PR-1017 Setup Options window.

- During conversion, if there is a discrepancy between the bank ID (bank account) number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

Visual Integrator Changes

Job Import

You no longer need to run the VIWUD1 utility to update the data fields after you use Job Import to import Level 3.x jobs into Visual Integrator. This utility is now run automatically.

Report Master Changes

For printing reports from subsidiary modules that contain a general ledger account number greater than 20 characters, you will need to manually adjust the print position for the data fields following the account. This is because the maximum mask length in Report Master is 20 characters and that determines how much space Report Master defaults on the report.
Chapter 6

Workflow Changes in 4.20

This chapter describes the workflow changes incorporated in the product for the 4.20 release that you should be aware of. Installation and global changes are listed first followed by module retirements.

Global Changes

Advanced Lookup Engine (ALE)

The ALE Conversion Utility has been renamed Lookup Conversion.

Desktop

- The Business Desktop has been renamed Sage MAS 90 Desktop or Sage MAS 200 Desktop, as applicable.

- The Modules tab has been renamed Tasks.

- File layout and program information previously included in the Technical Reference and Support Guide is now accessible from the File Layouts and Program Information link on the Resources page.

- Tutorials have been moved to the new Tutorials page.

Help System and Online Manuals

- On the Contents tab of the Help system, the Module Help book contains links to individual Help systems for each module in Sage ERP MAS 90 or 200. Under each module’s main book, Help topics are further categorized into books of topics regarding procedures, information about printing forms and reports, and glossary terms. You can select any grouping of Help topics to print at one time, as well as print individual Help topics. For more information, see Print a Book of Help Topics in the Help system.
• Also available on the Contents tab of the Help system is the Module PDFs book which contains links to individual PDFs for each module in Sage ERP MAS 90 or 200. These PDFs have been specially constructed to allow you to easily print the overview information for each task in a module. The PDFs are organized according to the menu structure of the module. For more information, see Print a Module PDF in the Help system.

**Inquiries**

The Accounts Receivable Inquiry, RMA Inquiry, and Sales Order Inquiry tasks are available.

**Printing**

The font size on some reports was changed to allow the report to remain in portrait format.

**Printing to a Dot Matrix Printer**

You can print to a dot matrix printer as long as the printer has a corresponding Windows printer driver and supports draft mode font to enable high-speed printing.

A dot matrix form code is available for printing several forms. For more information, see Customize Dot Matrix Form Template in the Help system.
Library Master Changes

Batch Faxing

You can set up batch faxing for the following forms using Report Manager:

- Statement Printing
- Accounts Receivable Invoice Printing
- Customer RMA Printing
- RMA Receiver Printing
- Sales Order Printing
- Picking Sheet Printing
- Sales Order Invoice Printing
- Purchase Order Printing

Previously, batch faxing for these forms was set up in the Fax Form Definition window. To set up batch fax options for these forms, select Library Master Setup menu > Report Manager. In the Report Manager window, select a form and click the Maintain button. In the Maintain window, click the Maintain Fax Options button.

Role Maintenance

- Roles set up to establish access to tasks, security events, and module options for modules other than Job Cost, Material Requirements Planning, Payroll, and Work Order need to be verified after upgrading to version 4.40. New tasks, security events, and module options added for those modules are not selected for current roles after upgrading.

- If you are upgrading from version 4.10, roles need to be verified for the Accounts Payable module and for the Accounts Receivable Inquiry, RMA Inquiry, and Sales Order Inquiry tasks. New tasks, security events, and module options added for this module are not selected for current roles after upgrading.

- Override passwords previously maintained in Sales Order Options are now handled as security events in Role Maintenance.

- ODBC Security will not be migrated when upgrading to version 4.20 and needs to be re-created.
LIBRARY MASTER CHANGES

Renamed Task

The FAS Link module has been renamed Fixed Assets.

Reports

- The .rpt files for reports on the Custom Reports menu now have a new folder structure. To use your existing customized report files with version 4.00 or higher, you must add the .rpt files to the Custom Reports menu using the Menu wizard in Report Manager. The .rpt file names must end with "custom.rpt" to be added using the Menu Wizard. To access the Menu Wizard, select Library Master Setup menu > Report Manager. In the Report Manager window, click Add Report to Menu.

- The new folder structure for reports uses a combination of company code, task name, and form code or report setting name determined by the selections in the Add New Format window. Examples of the new folder structure are as follows:

  - For a specific company code, task name, and form code or report setting name:
    (...\MAS90\MAS_ABC\Reports\AR_InvoicePrinting\INVOICESSTD\*.rpt)

  - For a specific company code and task name and all form code or report setting names:
    (...\MAS90\MAS_ABC\Reports\AR_InvoicePrinting\*.rpt)

  - For all companies and specific task name and form code or report setting names:
    (...\MAS90\MAS_SYSTEM\Reports\AR_InvoicePrinting\INVOICESSTD\*.rpt)

  - For all companies, specific task name, and all form code or report setting names:
    (...\MAS90\MAS_SYSTEM\Reports\AR_InvoicePrinting\*.rpt)
Chapter 6  Workflow Changes in 4.20

URL Maintenance

You can use the URL Maintenance task to store URL information for the Electronic Reporting for W2 and 1099s module. Two URL codes and descriptions were created for the Social Security Administration (SSA) and the Internal Revenue Service (IRS).

Accounts Payable Changes

Global Changes

- Aging for all vendors is now recalculated using the system date during the conversion of version 4.20 and higher.

- The updating of files is now based on the posting date. Previously, the General Ledger fiscal year was used to determine the period and year.

- Previously, historical data was stored by the period to date (PTD), year to date (YTD), last year, and future period. Accounts Payable vendor history is now stored by period by year. The conversion for vendor sales history is now performed as follows:
  - The PTD record is converted to the current period.
  - The YTD record is converted to the period before the current period (for example, if the current period is June, then the total YTD amount should be in May).
  - The prior year record is converted to the last fiscal period of the prior year.
  - You can modify the history data by clicking the Fix button on the Vendor Maintenance History tab. This button is available only when security is enabled and the Allow Editing of History Data in Vendor Maintenance security event is selected in Role Maintenance.
  - The Number of Months to Retain Check History option was removed. To retain or display check history in Vendor Maintenance, select the Track Detailed Invoice/Payment History check box in the Accounts Payable Options window.
ACCOUNTS PAYABLE CHANGES

- You can now post payments of existing invoices to the general ledger in addition to payments of new invoices entered on the fly. Select the Manual Check Register in Detail check box in the Accounts Payable Options window.

- Certain memos can now flow from entity to entity based on the document. For example, an invoice memo would flow to invoice history.

- Time and Billing lines are no longer converted because they can cause out-of-balance invoice totals that do not match the line totals. If you have the Time and Billing module installed, contact your Sage business partner before installing the upgrade.

Data Entry

- In the Manual Check Entry window, you can now add multiple general ledger distribution lines using the Create G/L Distribution button.

- The Credit Card Payment Transfer Details window displays transfer information for payments processed in version 4.20 and higher.

Period End Processing

- Only full period-end processing can be performed in the Period End Processing task accessed from the Period End menu.

- Various fields previously included in the Period End Processing window have been moved to the Utilities menu as follows:
  - The Only Remove Invoices with Zero Balances option has been replaced by the Remove Zero Balance Invoices task.
  - The Only Remove Temporary Vendors with Zero Balances option has been replaced by the Remove Temporary Vendors task.
  - The Only Clear Check History File option and the Purge Detailed Invoice/Payment History File options have been replaced by the Purge Accounts Payable History task.
  - The Purge Sales Tax History File option has been replaced by the Purge Sales Tax History task.
Chapter 6  Workflow Changes in 4.20

**Reports and Forms**

- Report setting options now appear on the header area of the applicable report window. You can also define and save customized report settings. For more information, see Create a Report Setting in the Help system.

- Vendor Listing no longer prints the balance data. To print the balance information, print the new Vendor Listing with Balances.

- You can now print the remit-to address on checks using A/P Check Printing or Manual Check Printing without customizing the check form.

- Accounts Payable reports and listings now use Crystal Reports. Because of this, the Accounts Payable module no longer uses the settings established in Library Master Report Format Maintenance.

- The process for exporting or printing a report or listing to a file has changed. The Print to File option previously available in the Printer Setup window has been moved to the Export/E-mail option accessed from the Printer field and uses the Crystal Reports engine. For more information on how to export or print reports to a file in these modules, see Export or Print to a File in the Help system.

- The process for deferring the printing of a report or listing has changed. The Deferred option has been moved to the Deferred option accessed from the Printer field. This option was previously available in the Printer Setup window. For more information on how to defer the printing of a report in these modules, see Defer a Report in the Help system.

- The font size on some reports was changed to allow the report to remain in portrait format.

- Print jobs scheduled for deferred printing are now located at ...Home\Deferred.
Accounts Receivable Changes

Renamed, Removed, or Moved Tasks

- The Update Purchase Vendor task has been renamed Purchase Vendor Transfer.
- Information that was previously on the Vendor Maintenance History tab has been moved to the Statistics and Summary tabs. History information is now maintained using period-sensitive data which removes the requirement for future buckets and mandatory module closing.
- The Vendor Delete/Renumber/Merge task previously on the Setup menu has been moved to the Utilities menu and renamed Delete and Change Vendors.
- The Assign Vendor Schedules task previously on the Setup menu has been moved to the Utilities menu and renamed Assign Vendor Tax Schedules.
- The Sales Tax Calculation task previously on the Setup menu has been moved to the Utilities menu.

Memos

Certain memos can now flow from entity to entity based on the document. For example, an invoice memo would flow to invoice history.
Chapter 6  Workflow Changes in 4.20

Business Insights Changes

Global Changes

- After upgrading to version 4.20, you will need to re-create Business Insights Reporter reports used in a previous 4.x version of the software.

- For custom reports previously created using version 4.10 or prior data from the Accounts Payable module, access Business Insights Reporter and select a report in the Business Insights Reporter Selection window. You are prompted to print the Business Insights Reporter Definition Listing and then delete the report. Repeat this process for each custom report previously created for the Accounts Payable module.

- For custom reports previously created using version 4.05 or prior data from the Accounts Receivable, Bank Reconciliation, General Ledger, Library Master, Return Merchandise Authorization, or Sales Order modules, access Business Insights Reporter and select a report in the Business Insights Reporter Selection window. You are prompted to print the Business Insights Reporter Definition Listing and then delete the report. Repeat this process for each custom report previously created for the Accounts Receivable, Bank Reconciliation, Return Merchandise Authorization, and Sales Order modules.

- For custom reports previously created for all other modules, select Library Master Utilities menu > Rebuild Business Insights Reporter Views to rebuild custom reports created with Business Insights Reporter in a previous 4.x version of the software.

Business Insights Explorer

The new Business Insights Explorer, which provides an alternative method of accessing data, is now available from the Desktop Tree view and menu. Predefined views of customers, quotes, sales orders, and invoices are available, providing a way to quickly view related data and navigational links to other inquiries or tasks.
Renamed Tasks

Under the Business Insights Dashboard menu, the following tasks have been renamed:

- Business Insights Options has been renamed Dashboard Options.
- Dashboard Selection Wizard (previously named Business Insights Wizard) has been renamed Dashboard Maintenance Wizard.
- Dashboard Selection Listing (previously named Business Insights Listing) has been renamed Dashboard Maintenance Listing.
- Display Business Insights has been renamed Display Dashboard.
- Business Insights Automatic Update has been renamed Start Automatic Dashboard Update.

Common Information Changes

Renamed, Removed, or Moved Tasks

- Miscellaneous Item Maintenance has been added to the Common Information Main menu. This task remains on the Accounts Receivable Setup menu and Sales Order Setup menu.
- Bank Code Maintenance has been added to the Common Information Main menu. This task remains on the Accounts Payable Setup menu, Accounts Receivable Setup menu, Bank Reconciliation Main menu, and Payroll Setup menu.
- Memo Manager Maintenance, previously on the Library Master Setup menu, has been moved to the Common Information Main menu. This task remains on the Accounts Payable Setup menu, Accounts Receivable Setup menu, General Ledger Setup menu, Return Merchandise Authorization Setup menu, and Sales Order Setup menu.
- Sales Tax Account Maintenance has been added to the Common Information Main menu. This task remains on the Accounts Payable Setup menu and Accounts Receivable Setup menu.
Chapter 6  Workflow Changes in 4.20

- Purge Obsolete Extended Descriptions, previously on the Library Master Utilities menu, has been moved to the Common Information Utilities menu.

Customizer Changes

Global Changes

- For modules using the Business Framework architecture, the External Link Definition window now allows you to select business object columns available to the panel instead of the control names in the customized library. For example, to select the Customer No. field in the Sales Order Entry window, you can now select the business object name, SO_SalesOrder_bus_CustomerNo$, instead of the control name, ML_CUST$.

- Customized libraries for the Accounts Payable module must be re-customized.

- Data entry user-defined fields (UDFs) must be re-created in User-Defined Field and Table Maintenance. After re-creating UDFs, you must map the UDFs to their respective history files. For more information, see Map User-Defined Fields (UDFs) in the Help system.

- The Accounts Payable Invoice Entry UDFs for both header and lines will need to be re-created in User-Defined Field and Table Maintenance. After these UDFs have been created and updated, it is necessary to map the invoice entry UDFs to their respective history tables.

- For Purchase Order Receipt of Goods, Receipt of Invoice, and Return of Goods, the new Purchase Order Invoice UDF replaces the Accounts Payable Invoice UDF. If an Accounts Payable Invoice UDF exists on a customized Purchase Order .lib file migrated or converted to 4.20, it must be manually removed, and the Purchase Order Invoice UDF must be added.
When you have upgraded to version 4.20 and re-created UDFs, the following list of UDFs are updated to specific tables:

- The Accounts Payable Invoice UDFs are updated to the new AP Invoice History Header table.
- The Accounts Payable Invoice Lines UDFs are updated to the new AP Invoice History Detail table.
- The Accounts Payable Vendor UDFs are updated to the new AP Vendor Master table.

Electronic Reporting for W2 and 1099 (Magnetic Media Reporting)

Global Changes

- The Magnetic Media Reporting module has been renamed Electronic Reporting for W2 and 1099s to accurately reflect the new process required by the federal government.

- Starting from the 2006 tax year, the Internal Revenue Service (IRS) requires that all payroll and 1099 filings be performed electronically through the Internet. The federal government will no longer accept W2 and 1099 information on any type of magnetic media (diskette). In Sage ERP MAS 90 and 200, you can continue to create a data file compliant with the IRS published standards and save it on the hard disk.

- Some states may still require or accept filings submitted on magnetic media. If your state supports the Federal reporting format and accepts submissions on a diskette, you can create the state diskette by copying the data file you created to a 3.5" diskette. If your state does not support the Federal reporting format, the Electronic Reporting module cannot create your electronic file.

- The new Electronic File Transfer task allows you to launch the appropriate government Web site to submit W2 and 1099 files.
• You can store the URL information for Electronic Reporting in Library Master URL Maintenance. Two URL codes and descriptions were created for the Social Security Administration (SSA) and Internal Revenue Service (IRS).

• The 1099 Magnetic Media Reporting window was renamed 1099 Electronic Reporting. The default disk drive to use is now C.

• The W2 Magnetic Media Reporting window was renamed W2 Electronic Reporting. The default disk drive to use is now C.

• The Mag Media Tax Type Code field in the Payroll Tax Table Maintenance window was renamed Electronic Reporting Tax Type Code.

**Fixed Assets Changes**

**Global Changes**

• The FAS Link module has been renamed Fixed Assets.

• The new Fixed Assets Maintenance task is now available on the Fixed Assets Main menu if Sage ERP MAS 90 and 200 Fixed Assets is installed and the Fixed Assets module is activated.

**Payroll Changes**

**Taxes**

• In the Federal Tax Summary window, the Employee FICA Tips and Employer FICA Tips fields were added for wages. The Employee FICA Tip fields were added for payroll taxes.

• In Manual Payroll Tax Entry window, the FICA Tip Tax field was added.

• In Quarterly Tax Report window, the Print FICA Tip Data check box was added.
• The Mag Media Tax Type Code field in the P/R Tax Table Maintenance window was renamed Electronic Reporting Tax Type Code. The field name was changed to accurately reflect the new process required by the federal government.

Reports

To comply with new regulations regarding how Social Security tips are being reported, the following reports are modified to show FICA and FICA tips totals separately:

• Quarterly Governmental Report
• Payroll Data Entry Audit Report
• Payroll Check History Report
• Employee Listing
• Perpetual History Report
• Employee Listing
• Employer's Expense Summary
• Quarterly Pay Period Recap
• Payroll Check Printing
• Direct Deposit Stub Printing
• Quarterly Tax Report

Visual Integrator Changes

Data Dictionary Listing

File information for the Accounts Payable module is no longer included on the Data Dictionary Listing. To obtain file information for these modules, on the Desktop, access the Resources page and click the File Layouts and Program Information link. You must re-create Visual Integrator jobs for Accounts Payable.
Import Job Maintenance

If you select an Accounts Payable table for a new job in the V/I Import Job Selection window, corresponding tables are available for selection at the Table Name field in the Import Job Maintenance window. If a table from any other module is selected in the V/I Import Job Selection window, corresponding files from Accounts Payable are available for selection at the File Name field in the Import Job Maintenance window.

Retired Modules

The FAS Select module was retired.
Chapter 7

Workflow Changes in 4.10

This chapter describes the workflow changes incorporated in the product for the 4.10 release that you should be aware of. Installation and global changes are listed first followed by module retirements.

Accounts Receivable Changes

Global Changes

- Aging for all customers is now recalculated using the system date during the conversion of version 4.10 or higher data.

- The updating of files is now based on the posting date. Previously, the General Ledger fiscal year was used to determine the period and year.

- You can modify the history data by clicking the Fix button on the Customer Maintenance History tab. This button is only available when security is enabled and the Allow Editing of History Data in Customer Maintenance security event is selected in Role Maintenance.

- Previously, the historical data was stored by period to date (PTD), year to date (YTD), last year, and future period. Accounts Receivable customer sales history is now stored by period by year. The conversion for customer sales history is now performed as follows:
  - The PTD record is converted to the current period.
  - The YTD record is converted to the period before the current period (for example, if the current period is June, then the total YTD amount should be in May).
  - The prior year record is converted to the last fiscal period of the prior year.
Chapter 7  Workflow Changes in 4.10

**Period End Processing**

- The Salesperson Commission Purge task, previously on the Period End menu, has been moved to the Utilities menu.

- Only full period-end processing can be performed in the Period End Processing task accessed from the Period End menu.

- Various fields previously included in the Period End Processing window have been moved to the Utilities menu as follows:
  - The Only Remove Temporary Customers with Zero Balances option has been replaced by the Remove Temporary Customers task.
  - The Only Remove Invoices with Zero Balances option has been replaced by the Remove Zero Balance Invoices task.
  - The Only Purge Sales Tax History File option has been replaced by the Purge Sales Tax History task.
  - The Only Clear Invoice/Shipping History File option has been replaced by the Purge Accounts Receivable History task.
  - The Only Recalculate Customer High Balances option has been replaced by the Recalculate Customer High Balances task.

**Renamed, Removed, or Moved Tasks**

- Information that was previously on the Customer Maintenance History tab has been moved to the Customer Maintenance Statistics and Summary tabs. History information is now maintained using period-sensitive data which removes the requirement for future buckets and mandatory module closing.

- The following tasks previously on the Setup menu have been moved to the Utilities menu: Global Customer Field Change, Sales Tax Calculation, and Internet Customers Enable/Purge.

- The Delete/Renumber/Merge task previously on the Setup menu has been moved to the Utilities menu and renamed Delete and Change Customers.
Business Insights Changes

Renamed, Removed, or Moved Tasks

The Business Insights tasks are now on a separate module menu. Previously, the Business Insights tasks were located in a menu under the Library Master module. Business Insights is now organized on two submenus: Dashboard and Reporter.

Common Information Changes

Miscellaneous Item Maintenance

- Sales codes and miscellaneous items, part of the Accounts Receivable and Sales Order modules, are now referred to as Miscellaneous items and are stored in a common file shared by both modules.

- Miscellaneous items are now designated by the following item types: Miscellaneous items, Charge items, and Comment items. Comment codes are now referred to as Comment items and Miscellaneous Charges are now referred to as Charge items.

Customizer Changes

Global Changes

- When upgrading from Level 3.7x, customized libraries for the Accounts Receivable, Bank Reconciliation, General Ledger, eBusiness Manager, Return Merchandise Authorization, and Sales Order modules will not be migrated and must be re-created after the migration process.

- After upgrading to Version 4.10, data entry UDFs must be re-created in User-Defined Field and Table Maintenance. After re-creating UDFs, you must map the UDFs to their respective history files. For more information, see Map User-Defined Fields (UDFs) in the Help system.

- The link between the AR Invoice and Job Cost Header entity in Job Billing Entry has been replaced by a link between the Job Cost Billing entity and the Job Cost Header entity.
Chapter 7  Workflow Changes in 4.10

- The Accounts Receivable and Sales Order Invoice Data Entry UDFs for both header and lines will need to be recreated in UDF and Table Maintenance. After these UDFs have been established and updated, it is necessary to map the invoice entry UDFs to their respective history files.

- Job Cost Job Billing Entry has a new Job Cost Billing UDF that replaces the Accounts Receivable Invoice UDF. The Job Invoice UDF file is now the history file for Job Billing Entry’s Job Cost Billing UDF. The Accounts Receivable Invoice UDF is no longer available in Job Billing Entry. The ARI Entity UDF that exists on a customized lib and is migrated or converted to 4.10 will have to be manually removed from the 4.10 lib.

- The Inventory Master file UDF has been merged into the CI_Item file. Use the Common Item File in User-Defined Field and Table Maintenance to create UDFs and maintain existing UDFs. The IM_90 file is no longer available. Crystal Reports that previously used the IM_90 file should be modified to use the CI_Item file. The IM_90 UDF will need to be manually removed from the Inventory Maintenance .lib file.

- In User-Defined Field Maintenance, pound signs (###) previously used in the Mask field for a String data type UDF are now invalid. When editing an existing UDF with a mask, the pound signs will be replaced with Z.s and any separators will need to be retyped. Pound signs are only valid for Numeric data type UDFs. For more information, see Format Masks in the Customizer Help system.

- Previously, separators used in UDFs were saved to the applicable data files. In Version 4.10, separators are not saved. After upgrading to Version 4.10, use Crystal Reports to reformat UDF data on custom reports.

- Conversion with AP Invoices in AP Invoice Data Entry will leave orphan records in the AP_95 that are assigned the invoice data entry sequence number. These records need to be manually removed using the Data File Display and Maintenance task. To identify orphan records, the sequence number in the key field for invoices removed during conversion will start with a 99900001, etc.
- RA_91 UDFs will be added only to the Receipts History Header table. You will need to create new UDFs for the Receipts Header table, then go into the history table and map the new UDF to the existing UDF which was migrated.

- RA_96 UDFs will be added only to the Receipts History Detail table. You will need to create new UDFs for the Receipts Detail table, then go into the history table and map the new UDF to the existing UDF which was migrated.

- Pound signs (###) which were allowed for masking a String data type UDF are no longer allowed in Version 4.10 as this is an invalid format for a string (for more information, see String Format Table in the Help system). In Version 4.10, when editing a UDF with a Mask of #’s, the #’s are changed to Z’s. The separator will need to be re-added. Pound signs (###) are only allowed on Numeric data type UDFs.

- For modules upgrading to 4.10, some modules wrote the Mask separator to the UDF data file. UDF values for 4.x modules are written without the separator. During the 4.10 conversion, separators included in the UDF records in the UDF data file will be removed. This will only occur for String data type UDFs.

- When upgrading from a previous Version of 4.x, the following list of UDFs are updated to specific tables:
  - Accounts Receivable Invoice UDFs are updated to the AR Invoice History Header table.
  - Accounts Receivable Invoice Line UDFs are updated to the AR Invoice History Detail table.
  - The Sales Order Entry UDFs are updated to the SO Sales Order Header and the SO Sales Order History Header tables.
  - The Sales Order Detail UDFs are updated to the SO Sales Order Detail and the SO Sales Order History Detail tables.
  - The Return Merchandise Authorization Receipt Entry/History Header UDFs are updated to the RA Receipts History Header table.
Chapter 7  Workflow Changes in 4.10

- The Return Merchandise Authorization Receipt Entry/History Lines UDFs are updated to the RA Receipts History Detail table.

- The eBusiness Manager Customer UDFs are updated to the IT Shopping Cart Header and IT UID Customer Change tables.

- The eBusiness Manager Shopping Cart Item UDFs are updated to the IT Shopping Cart Item and IT Shopping Cart Items Selected tables.

**eBusiness Manager Changes**

**Global Changes**

- The Microsoft Web Publishing Wizard is no longer installed or supported. You must now publish eBusiness Manager images, JavaScripts, and style sheets to the Internet Information Server (IIS) using your own FTP software. For more information, see Publish Files to the Internet in the eBusiness Manager Help system.

- The Publish Files to Web task, which was located on the Setup menu, has been removed as it used the Microsoft Web Publishing Wizard which is no longer supported.

- The polling process that formerly performed the real-time automatic updates for user IDs, customers, and sales orders from the Sage Web Engine has been removed. The options that controlled how often the polling process polled for shopping cart entries and customer/user ID changes have therefore also been removed from IT Options.

- You can no longer enter the SMTP server address in IT Options. It must be entered in Company Maintenance in the Library Master module before you can generate e-mail in eBusiness Manager.
Return Merchandise Authorization Changes

Renamed, Removed, or Moved Tasks

Various options previously included in the RMA Utilities task have been moved to the Utilities menu as follows:

- The Purge Expired RMAs option has been replaced by the Purge Expired RMA task.
- The Purge Return Reason Detail option has been replaced by the Purge Return Reason Detail task.
- The Purge RMA Receipts History option has been replaced by the Purge RMA Receipts History task.
- The Create Customer Invoice Search Records option has been replaced by the Create Customer Invoice Search Records task.

Sales Order Changes

Global Changes

If the Inventory Management module is integrated with Sales Order, you can now retain a customer’s last purchase price information for both inventory items and miscellaneous items. Previously, you could retain the last purchase price information for inventory items only.

Sales History

- Previously, sales history was saved by period and month. With version 4.10 and higher, sales history is now continuously saved by invoice date and posting date.
- With version 4.10 and higher, you must retain at least two years of sales history at the Years to Retain Sales History field in the Sales Order Options window, with the option to retain up to 99 years.
• Because of the new method for saving history, the Enter Customer Sales History Option by Customer Type check box and the Customer Type/Option fields in Sales Order Options have been removed.

**Sales History Reports**

Because sales history is now saved by invoice date and posting date, four new reports, Sales Recap by Division, Sales Recap by Product Line, Sales Recap by Warehouse, and Sales Recap by Warehouse and Product Line replace the Monthly Recap by Division, Monthly Recap by Product Line, Monthly Recap by Warehouse, and Monthly Recap by Warehouse and Product Line reports. After upgrading to version 4.10 or higher, if you need to reference the Monthly Recap reports or the previous Customer Sales History report, select File > Run and type the following in the Run Program window:

- **SOWRJA** to access the Monthly Recap by Product Line report
- **SOWRKA** to access the Monthly Recap by Warehouse/Product Line report
- **SOWRLA** to access the Monthly Recap by Warehouse report
- **SOWRMA** to access the Monthly Recap by Division report
- **SOWRNA** to access the Customer Sales History report

**NOTE**

These reports contain data as of the date of the conversion to 4.10 or higher.

**Period End Processing**

Only full period-end processing can be performed in the Period End Processing task accessed from the Period End menu.

Various fields previously included in the Period End Processing window have been moved to the Utilities menu as follows:

- The Purge Sales Order History option has been replaced by the Purge Order/Quote History task.
- The Purge Expired Master/Repeating Orders and Purge Expired Price Quotes options have been replaced by the Purge Expired Orders/Quotes task.
• The Purge Sales Order Recap option has been replaced by the Purge Sales Order Recap task.

**Job Cost Integration**

Because the Job Cost module can now be integrated with Sales Order, the way that job costs are posted can affect statements of profitability. If you are upgrading from version 4.05 or prior, make sure you plan how to post job costs before upgrading.

• If job costs are posted from the Accounts Payable or Purchase Order module, do not select the Post Invoice Costs to Job Cost check box in the Sales Order Options window. If this check box is selected, costs can potentially be posted to the Job Cost module from more than one module, resulting in an understatement of profitability.

• If the Accounts Payable or Purchase Order modules are not integrated with Job Cost, select the Post Invoice Costs to Job Cost check box in the Sales Order Options window. If this check box is not selected, costs may not be posted to the Job Cost module at all, resulting in an overstatement of profitability.

**Visual Integrator Changes**

**Data Dictionaries**

After installing Version 4.10, before you use the Visual Integrator module, select Visual Integrator Main menu > Export Job Maintenance. This executes the necessary update of the Data Dictionaries so that you can successfully create Visual Integrator jobs.

**Data Dictionary Listing**

File information for the Accounts Receivable, Bank Reconciliation, eBusiness Manager, Return Merchandise Authorization, and Sales Order modules is no longer included on the Data Dictionary Listing. To obtain file information for these modules, on the Desktop, access the Resources page and click the File Layouts and Program Information link. You must re-create Visual Integrator jobs for these modules.
Chapter 7  Workflow Changes in 4.10

Import Job Maintenance

When you select Visual Integrator Main menu > Import Job Maintenance, the new window, V/I Import Job Selection appears. In the V/I Import Job Selection window, you can enter a new job name or select an existing job. For new jobs, you must select the table (previously referred to as File Name) for which the import will be prepared. After a table is selected, the Import Job Maintenance window appears. If an Accounts Receivable, Bank Reconciliation, Common Information, eBusiness Manager, Return Merchandise Authorization, or Sales Order table is selected in the V/I Import Job Selection window, only these tables are available for selection at the Table Name field (previously called File Name field) in the Import Job Maintenance window. If a table from a module other than Accounts Receivable, Bank Reconciliation, Common Information, eBusiness Manager, Return Merchandise Authorization, or Sales Order is selected in the V/I Import Job Selection window, files from any other module are available at the File Name field in the Import Job Maintenance window.
Chapter 8

Workflow Changes in 4.00

This chapter describes the workflow changes incorporated in the product for the 4.00 release that you should be aware of. Installation and global changes are listed first followed by module retirements.

Installation Changes

- The Sage ERP MAS 200 Host and Host Enterprise Manager are no longer used for the Sage ERP MAS 200 installation and are replaced by the Sage ERP MAS 200 Application Server. For more information, refer to your Installation and System Administrator’s Guide.
- If you are upgrading from version 4.00, you must perform an in-place upgrade.

Global Changes

Advanced Lookup Engine (ALE)

You can now resize ALE windows.

Desktop

The Launcher has been renamed Business Desktop.

Help System and Online Manuals

The Help system has been expanded and updated to provide immediate access to all of the information previously found in the online PDF manuals.

Migrating Level 3.x Data

The new file structures in versions 4.x provide flexibility for both Sage and development partners to make enhancements for you in the future. As a result, some steps must be taken to prepare your Level 3.x or 4.x data for migration to version 4.40.
• During the migration process, user codes with leading blanks or special characters will not be migrated. You will need to re-create these user codes after the migration process. After migrating your data, print and review the System Conversion log.

**Module and Accounting Dates**

• The Library Master module now uses the Windows system date.

• Your date formats are now based on the Windows Regional Settings from your workstation for consistency across your entire desktop. Therefore, the default settings for Year Display Format and Year 2000 Default have been removed. The software does not support the “year first” Windows date format. If you enter a two-digit year, the century is determined by the century preferences setting in the Windows Regional Settings for your workstation.

• The F6 functionality which allowed you to toggle between a 2-digit year (05/31/10) and a 4-digit year (05/31/2010) has been removed to accommodate the Windows Regional Settings.

**Registering Your Modules**

You now have 45 days to access unregistered modules. Previously, you could access the module 40 times only.

**Security**

Version 4.00 introduced a new security model, which is role based rather than menu based. Security in your Level 3.x software will not be migrated to your version 4.40 software; however, you can choose to migrate users from your Level 3.x software to your version 4.40 software, if you select the Standard Security option during installation. To enable security, refer to your Installation and System Administrator’s Guide.

When All is selected at the Operand field, the operand now changes automatically based on the Value fields entered. If you enter the first Value field only, the operand changes to Equal to, then if you enter the second Value field, the operand changes to Range.
Library Master Changes

Changed Tasks

- Reports, registers, and journals in the General Ledger, Library Master, and Customizer modules and the Daily Transaction Register from subsidiary modules except for Job Cost, Material Requirements Planning, Payroll, and Work Order are now Crystal Reports. As a result, printers defined in Device Configurator no longer apply to printing these Crystal Reports. Use a Windows printer for printing the Crystal Reports.

- The Data File Display and Maintenance task has been enhanced with a new program. The new program determines if data is for Level 3.x or version 4.x. A new field lists the different secondary keys available and sorts the records in the file being displayed according to the key selected.

Companies

A Copy button has been added to Company Maintenance, allowing you to copy data and forms from an existing company. As a result, the SVFCPY and SVDATA utilities have been removed.

Renamed, Removed, or Moved Tasks

- Information from the Preferences task has been moved to the User Maintenance, Company Maintenance, and System Configuration tasks. As a result, the Preferences task has been removed.

- Information from the Alternate Directory Maintenance task has been moved to the Change Data Location dialog box, which is accessed by clicking Change Data Location on the Company Maintenance Preferences tab. As a result, the Alternate Directory Maintenance task has been removed.

- The Role Maintenance task replaces the Menu Security Maintenance task.

NOTE
For information about changes to the date format settings that previously resided in the Preferences task, see Module and Accounting Dates on page 84.
Chapter 8  Workflow Changes in 4.00

- The functionality of the Resize Data Files task has been incorporated into the Rebuild Application Key Files task. As a result, the Resize Data Files task has been removed.

- The System Activity Log has been renamed Activity Log.

- The Uninstall Modules task has been added to the System Configuration task.

- The Chat functionality has been removed from the Master Console task.

- The functionality of the Visual Explorer task has been added to the right-click menu accessed from the Sage ERP MAS 90 and 200 Desktop Tree View. As a result, the Visual Explorer task has been removed. For more information, see Open a Task in a Secondary Company in the Help system.

- Registration information from the Product Registration Maintenance task has been moved to the System Configuration task. As a result, the Product Registration Maintenance task has been removed.

- The Installed Modules Listing on the Library Master Reports menu replaces the *part utility.

- The following Library Master tasks have been removed because they are no longer needed:
  - Convert Evolution/2 Data Files
  - Data Dictionary Transfer
  - Maintain Explorer Menu
  - Rebuild Alternate Directory Pointers
  - Task Menu Maintenance
  - SVMUPD, SVFCPY, and SVDATA utilities
**Business Insights Changes**

**Business Insights Reporter**

The Business Insights Reporter menu includes the tasks, Business Insights Reporter, and Business Insights Reporter Listing. You can use Business Insights Reporter to create Crystal Reports for all modules. These reports can optionally be added to the Custom Reports menu for a specified module.

**Customizer Changes**

**Global Changes**

- When upgrading to Version 4.00, General Ledger user-defined fields will be updated to the GL_Account data file; however, General Ledger library customizations will not be migrated and must be re-created after the migration process.

- The PostMaster Conversion Utility previously accessed from the Customizer Main menu has been removed because the PostMaster module has been retired.

**General Ledger Changes**

**Accounts**

The ability to have a general ledger account number of up to 32 characters and 10 segments means that the way in which accounts are maintained has changed. The main account (also known as the natural account) is now maintained separately from the other individual segments. As a result, the system has changed in the following ways:

- The copy function is no longer available in Account Maintenance. The copy function is now available in Main Account Maintenance and Sub Account Maintenance.
Chapter 8  Workflow Changes in 4.00

- The process for creating new accounts in Account Maintenance has changed. To create an account in Account Maintenance, you must enter a valid combination of an existing main account and sub accounts. For more information, see Create and Maintain Accounts in Account Maintenance in the Help system.

- Options that control how general ledger accounts can be created and added on the fly have changed in General Ledger Options. The Add new accounts from data entry check box has been removed and replaced with the Auto Create when all Segments are Valid field, Add Main Accounts in General Ledger check box, and Add Sub Accounts in General Ledger check box. For more information about these fields, see General Ledger Options in the Help system.

Allocations

To support new features in allocations, as well as to make the terminology more intuitive, the following changes were made in the system:

- The Allocation Maintenance task has been renamed Allocation Entry. The Allocation Entry task is accessed by selecting General Ledger Main menu > Allocation Entry.

- The Allocation Entry task has been renamed Manual Allocation Entry. The Manual Allocation Entry task is accessed by selecting General Ledger Main menu > General Journal Entry. In the General Journal Entry window, click Copy From. In the Copy From window, select the Allocation option and click OK.

- The method of calculating masked allocation distributions has changed. The allocation is now calculated first, then the total amount is distributed to all the accounts that match the masked account. Previously, the allocation percent/quantity entered was distributed to each account that matched the masked account.

- The activity or balance for Period, Quarterly, and Annual allocation cycles is now allocated based on the entire selected cycle rather than just the period ending that cycle. For example, now a quarterly allocation distributes the activity for the entire quarter. Previously, quarterly and
annual allocations used the activity for the current period as the allocation amount. For example, previously a quarterly allocation generated at the end of the third period used only the activity for period 3, not the activity for periods 1, 2, and 3.

- In Allocation Selection, there are now separate allocation totals for financial and nonfinancial allocations.

**Custom Financials**

In order to have maximum flexibility and customization capabilities, you should use Sage Management Intelligence (SMI) for your custom financial reporting needs; however, Sage recognizes that you may have expended considerable time and effort in creating custom financial reports and want to continue using them. Although the Custom Financials menu has been removed, it can still be accessed by using a hidden utility, as long as you do not expand your general ledger account beyond nine characters and three segments.

- You can access the Custom Financials menu and tasks by selecting File > Run and typing `unhidegl` in the Run Program window.
- The Custom Financials tasks can only be accessed if you have general ledger account numbers with nine or fewer characters and three or fewer segments.

**Standard Financials**

The Standard Financial Statements have been renamed Financial Reports and have been enhanced to include the former Monthly Trend Report.

**Data Entry**

- The system now calculates beginning balances for each fiscal year based on prior year data. As a result, the Beginning Balance (BB) source journal has been removed. To post beginning balances for a new company, you must enter them as journal entries to your general ledger accounts and update them.
In Transaction Journal Entry, the logic for the offset postings has changed. The Debit/Credit field has been renamed Offset field. During conversion, the source journal orientation will be changed to Credit if it was previously Debit, and it will be changed to Debit if it was previously Credit. Previously, the value selected at the Debit/Credit field determined the orientation of the lines. Now the value selected at the Offset field determines the orientation of the offset only.

When you use General Ledger Exchange to import transactions into the General Ledger module, transactions now import to the General Journal Entry files. Previously, transactions were imported directly to the history files. This change was made because of the large number of inter-related tables that must be updated and linked when each transaction is posted. After the import is complete, the General Journal must be printed and updated.

**Period End Processing**

Many of the functions previously found in Period End Processing have been moved. Only full period-end processing can be performed from this task. In addition, to support the reopening and closing of periods, the Fiscal Year Consolidation and Consolidate Detail Records logic has been removed. Previously, you could perform the following tasks from Period End Processing:

- Full period-end processing
- Consolidate General Ledger Detail Records
- Purge Transaction Detail History
- Purge Period Summary History

The new location of various functions follows:

- The Clear Next Year Current Budgets logic is now performed in Budget Maintenance.

- The Purge Transaction Detail History task has been renamed Purge General Ledger History and is now accessible from the General Ledger Utilities menu.
Journal and register numbers are now reset separately based on the selections at the Reset Journal Numbers During and Reset Register Numbers During fields in the General Ledger Options window.

The following changes have been made to year-end processing:

- The Years to Retain General Ledger History field in the General Ledger Options window now applies to both summary and detail history information. As a result, the Number of Years to Retain Summary History field in the General Ledger Options window has been removed.

- The Posting to Retained Earnings and Updating Beginning Balances logic has been removed as this is now done through the data entry update routines and the Daily Transaction Register. If the next fiscal year has not been created, year-end processing will create the next fiscal year and recalculate beginning balances.

- Zero budget accounts are now removed from the Period Budget Detail file when all periods for any year are zero.

- The Copy Budget at Year End option has been modified to use the new Copy Actual to Default Budget at Year End check box in the General Ledger Options window.

Reports

- The Budget and History Report has been separated into two reports, the Budget and History Report and the Budget and History Report by Period.

- The Standard Financial Statements have been renamed Financial Reports. The Financial Reports now include the former Monthly Trend Report.

Renamed and Removed Tasks

- To provide more flexibility in giving users access to tasks, the Account Inquiry task is now a security event. To give users access to Account Inquiry, use Library Master Role Maintenance to set up users with View Only access to Account Maintenance.
Chapter 8  Workflow Changes in 4.00

- The Account Maintenance task has been removed from all subsidiary modules because all installations require the General Ledger module.

- The Account Group Maintenance task replaces the Account Break Maintenance task. In Version 4.00, the term account group is now used in place of account break.

- The Sub Account Maintenance task replaces the Department Maintenance task.

Visual Integrator Changes

Data Dictionaries

After installing Version 4.00, before you use the Visual Integrator module, select Visual Integrator Main menu > Export Job Maintenance. This executes the necessary update of the Data Dictionaries so that you can successfully create Visual Integrator jobs.

Data Dictionary Listing


Import Job Maintenance

- When you select Visual Integrator Main menu > Import Job Maintenance, the new window, V/I Import Job Selection appears. In the V/I Import Job Selection window, you can enter a new job name or select an existing job. For new jobs, you must select the table (previously referred to as File Name) for which the import will be prepared. After a table is selected, the Import Job Maintenance window appears. If a General Ledger table is selected in the V/I Import Job Selection window, only General Ledger tables are available for selection at the Table Name field (previously called File Name field) in the Import Job Maintenance
window. If a table from a module other than General Ledger is selected in the V/I Import Job Selection window, files from all modules other than General Ledger are available at the File Name field in the Import Job Maintenance window.

• In the Import Job Maintenance window, when you create a General Ledger job the Records tab is no longer available because there are no record types in General Ledger. Also, the Validation tab is no longer available because validation is done by the system. When you create a job for a module other than General Ledger in the Import Job Maintenance window, the Records tab and Validation tab are available.

• In the Import Job Maintenance window, when you create a General Ledger job, you cannot test or execute the import job until your system administrator gives you the rights to execute the job in Role Maintenance. Previously, system security did not prevent you from immediately executing General Ledger jobs.

Export Jobs


Retired Modules

The following modules were retired:

• Client Write-Up (If you need Client Write-Up functionality, contact your Sage business partner)
• Import Master
• PostMaster
• TimeSlips Link
• Visual PostMaster
Appendix A

Checklists

Before beginning the installation, test and validate all the hardware and network configurations using the following:

- The *Installation and System Administrator’s Guide*, which can be found in the Documents folder of the Sage ERP MAS product DVD, or by selecting a product from the Autorun screen, and then clicking Documentation on the product screen. The guide is in Adobe Acrobat (PDF) format and is named MAS_Install.pdf.

- The Supported Platform Matrix, which can be found in the Support area of the Sage Online Web site at: www.sagesoftwareonline.com

- The current support library for any pertinent information, particularly the Hot Pre-Installation Information page, which can be found in the Support area of the Sage Online Web site at: www.sagesoftwareonline.com

Upgrade and Conversion Process

The upgrade process consists of three steps:

1. Preparing your data for migration
2. Migrating your data to version 4.50
3. Converting your data to version 4.50

This appendix contains the information you will need to upgrade and convert your data based on the version of your data. Proceed to the applicable section as follows:

- Upgrading from Version 4.45 to Sage ERP MAS 200 SQL Version 4.50 on page 95
- Upgrading from Version 4.40 to Version 4.50 on page 100
- Upgrading from Version 4.30 to Version 4.50 on page 105
- Upgrading from Version 4.20 to Version 4.50 on page 113
- Upgrading from Version 4.10 to Version 4.50 on page 121
- Upgrading from Version 4.00 or 4.05 to Version 4.50 on page 129
- Upgrading from Level 3.x to Version 4.50 on page 138
Upgrading from Version 4.45 to Sage ERP MAS 200 SQL Version 4.50

Prior to upgrading your version 4.45 data to Sage ERP MAS 200 SQL version 4.50, you can perform an in-place or parallel installation. If you perform a parallel installation, use the Parallel Migration utility from the Windows Start menu > All Programs > Sage program group to migrate your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the migration process.

Pre-Migration Checklist

After installing the current version of the software, you must prepare your version 4.45 data for migration. This should be done for each company you plan to migrate. Several steps should be completed by a SQL Server® administrator.

1. Create a copy of your version 4.45 companies by selecting Library Master Main menu > Company Maintenance. Use the Copy feature in this task. Create a backup of your MAS90 folder following your backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

2. Verify all data entry files are empty. Print and update all journals and registers. Any data in the data entry files during the migration will be lost (for example, Accounts Receivable Cash Receipts Entry).

3. Rebuild all data files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.

4. Run the Pre-Migration utility from the Library Master Utilities menu. This utility backs up some system files in your new installation before they are overwritten by the migration process. It is critical that this step is completed before performing any data migration steps.

NOTE
You must update or clear all data entry in progress to prevent the data from becoming cleared during data migration.
Appendix A  Checklists

5. Manually copy the databases to migrate to the new SQL Server instance.
   - The source MAS_System database must be copied to the new SQL Server instance when migrating system files. Migrating system files is required in the initial migration.
   - The source company database (for example, MAS_ABX) must be copied to the new SQL Server instance for each company to be migrated.

6. Select the Parallel Migration Wizard from the Windows Start menu > All Programs > Sage program group to migrate your data.

Migration Checklist

After preparing your version 4.45 data for migration following the Pre-Migration Checklist on page 95, you are now ready to migrate your data to your Sage ERP MAS 200 SQL version 4.50 system.

1. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

2. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

3. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

4. Test all printers that you normally use for printing forms and reports. Each workstation must have a default printer defined.

5. If you are printing bar codes, install the Azalea fonts from the WkSetup\Azalea folder on the Sage ERP MAS product DVD.

NOTE
The following modules are not available for Sage ERP MAS 200 SQL: eBusiness Manager, Fixed Assets, Job Cost, Material Requirements Planning, Payroll, TimeCard, Work Order, and the Business Insights Reporter.
When you launch Sage ERP MAS, log on as Administrator, review the security for your users, and set up and assign the appropriate roles to your users using tasks accessed through the Administrative Tools window. Set up security using Role Maintenance as follows:

- Create roles for all tasks you would like to secure in Role Maintenance. Review all roles and update permissions for all modules and features.
- For Common Information tasks that appear on multiple menus, security must be set up for the Common Information module using Role Maintenance.

Review your security tasks for new features in version 4.50.

If you are using Unified Logon and you migrated your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

If you customized your Desktop, re-create the customizations on the Custom toolbar.

If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with ‘Bill To’ Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

Data Conversion Checklist

After preparing your version 4.45 data for migration following the Pre-Migration Checklist on page 95 and Migration Checklist on page 96, you are now ready to convert your data to Sage ERP MAS 200 SQL version 4.50.

Select Library Master Main menu > Company Maintenance to convert your data to Sage ERP MAS 200 SQL version 4.50. This must be done for each of your companies.
Appendix A  Checklists

2. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

   Review customizations to lookups in all modules. This includes customizations created in the User Lookup Wizard and by clicking Custom in a lookup window.

3. Rebuild all application sort files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.

4. Verify that your modules do not have broken links by selecting Library Master Utilities menu > Link Maintenance. Links that appear in red are broken and will need to be fixed using the Relink Files button in Link Maintenance. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

5. Review the placement of all user-defined fields. Update the customized forms using Custom Office Update Customized Panels to Current Level. For more information, see Customizer Changes on page 32.

   Review the customized libraries for all modules.

6. Use Crystal Reports Designer to modify reports. You must either be logged on using a Windows account that has read access to the applicable SQL Server database, or you must have a separate SQL Server authenticated logon ID and password. Integrated Security is used by default; if your Windows account does not have rights to the database, a logon dialog box appears, allowing you to enter a different logon ID and password for database access.

   Test your modified Crystal reports and forms. Before modifying forms or the standard Crystal reports found on the Custom Reports menu, you must be proficient in the use of Crystal Reports.

   Use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see Crystal Reports FAQs in the Help system.
Add any custom reports to the Custom Reports menu using Report Manager.

7. If dictionary changes were made to any file used on an import created in the Visual Integrator module, those imports will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order. Review the appropriate file layout using the File Layouts and Program Information link on the Resources page of the Desktop and the Data Dictionary Listing accessed from the Visual Integrator Main menu to verify that the imported field names are consistent with the new file layout.

8. If you purchased the Return Merchandise Authorization module, after setting up Return Merchandise Authorization data files for the first time for a pre-existing Sage ERP MAS 200 SQL installation, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

For information on what is new in this release, see What’s New in Version 4.50 on page 4.
Appendix A  Checklists

Upgrading from Version 4.40 to Version 4.50

Prior to upgrading your version 4.40 data to version 4.50, you can perform an in-place or parallel installation. If you perform a parallel installation, use the Parallel Migration utility from the Library Master Utilities menu to migrate your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the migration process.

Pre-Migration Checklist

After installing the current version of the software, you must prepare your version 4.40 data for migration. This should be done for each company you plan to migrate.

1____ Create a copy of your version 4.40 companies by selecting Library Master Main menu > Company Maintenance. Use the Copy feature in this task. Create a backup of your MAS90 folder following your backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

2____ Verify all data entry files are empty. Print and update all journals and registers. Any data in the data entry files during the conversion will be lost (for example, Accounts Receivable Cash Receipts Entry).

3____ If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

4____ Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.

NOTE Consult with your Sage business partner if you are upgrading to Sage ERP MAS 200 SQL.

NOTE You must update or clear all data entry in progress to prevent the data from becoming cleared during data migration.
Migration Checklist

After preparing your version 4.40 data for migration following the Pre-Migration Checklist on page 100, you are now ready to migrate your data to your version 4.50 system.

1. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

2. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

3. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

4. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

5. If you are printing bar codes, install the Azalea fonts from the WkSetup\Azalea folder on the Sage ERP MAS product DVD.

6. When you launch Sage ERP MAS, log on as Administrator, review the security for your users, and set up and assign the appropriate roles to your users using tasks accessed through the Administrative Tools window. Set up security using Role Maintenance as follows:
   - Create roles for all tasks you would like to secure in Role Maintenance. Review all roles and update permissions for all modules and features.
   - For Common Information tasks that appear on multiple menus, security must be set up for the Common Information module using Role Maintenance.
   - Set up ODBC security using Role Maintenance.

7. Review your security tasks for new features in version 4.50.
Appendix A  Checklists

8. If you are using Unified Logon and you migrated your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

9. If you customized your Desktop, re-create the customizations on the Custom toolbar.

10. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with ‘Bill To’ Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

11. From your version 4.50 installation, select Library Master Utilities menu > Parallel Migration to migrate your data.

NOTE
The following modules are not available for Sage ERP MAS 200 SQL: eBusiness Manager, Fixed Assets, Job Cost, Material Requirements Planning, Payroll, TimeCard, Work Order, and the Business Insights Reporter.

Data Conversion Checklist

After preparing your version 4.40 data for migration following the Pre-Migration Checklist on page 100 and Migration Checklist on page 101, you are now ready to convert your data to version 4.50.

1. Select Library Master Main menu > Company Maintenance to convert your data to version 4.50. This must be done for each of your companies.

2. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

3. Rebuild all application sort files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.
4. Verify that your modules do not have broken links by selecting Library Master Utilities menu > Link Maintenance. Links that appear in red are broken and will need to be fixed using the Relink Files button in Link Maintenance. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

5. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

6. Review the placement of all user-defined fields. Update the customized forms using Custom Office Update Customized Panels to Current Level. For more information, see Customizer Changes on page 32.

   Review the customized libraries for all modules.

7. Use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see Crystal Reports FAQs in the Help system.

   Test your modified Crystal reports and forms. Before modifying graphical forms or the standard Crystal reports found on the Custom Reports menu, you must be proficient in the use of Crystal Reports.

   Add any custom reports to the Custom Reports menu using Report Manager.

8. If dictionary changes were made to any file used on an import created in the Visual Integrator module, those imports will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order. Review the appropriate file layout using the File Layouts and Program Information link on the Resources page of the Desktop and the Data Dictionary Listing accessed from the Visual Integrator Main menu to verify that the imported field names are consistent with the new file layout.
Appendix A  Checklists

9____ To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Sage Web Engine.

10____ Print and compare all customized form definitions, including your Payroll W-2 forms and quarterly governmental reports. Default forms may be erased in the migration process.

If you plan to use Federal and State eFiling and Reporting for the W-2 forms and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

11____ If you purchased the Return Merchandise Authorization module, after setting up Return Merchandise Authorization data files for the first time for a pre-existing Sage ERP MAS installation, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

For information on what is new in this release, see What’s New in Version 4.50 on page 4.

NOTE
If a tax limit type other than Annual is selected in Tax Table Maintenance, your limit values will not be calculated correctly in Federal and State eFiling and Reporting forms until the first payroll run after conversion to version 4.50.
Upgrading from Version 4.30 to Version 4.50

Prior to upgrading your version 4.30 data to version 4.50, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to migrate your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the migration process.

Pre-Migration Checklist

After installing the current version of the software, you must prepare your version 4.30 data for migration. This should be done for each company you plan to migrate.

1. Create a copy of your version 4.30 companies by selecting Library Master Main menu > Company Maintenance. Use the Copy feature in this task. Create a backup of your MAS90 folder following your backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

2. Verify all data entry files are empty. Print and update all journals and registers. Any data in the data entry files during the migration will be lost (for example, Accounts Receivable Cash Receipts Entry).

3. If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

4. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.

NOTE
Consult with your Sage business partner if you are upgrading to Sage ERP MAS 200 SQL.

NOTE
You must update or clear all data entry in progress to prevent the data from becoming cleared during data migration.
From your version 4.50 installation, select Library Master Utilities menu > Pre Migration, then enter the source path and company code for your version 4.30 system. Select the reports and utilities that appear.

a Select Item Code Validation Report to display missing item codes from your Warehouse Detail, Item Costing, and Transaction Detail files.
   - To fix the files, in your version 4.30 data, use Inventory Management Main menu > Inventory Maintenance.

b Select Inventory File Comparison Report to compare the quantity in your warehouse, tier, and transaction inventory data files.
   - Run this report by warehouse and save as an audit trail.
   - To correct any quantities, run the Inventory Balancing Utility.

c Select Inventory Balancing Utility to balance your inventory quantities.
   - Run this utility for each warehouse.
   - At the Action column, select the action to perform for each item, or apply a specific action based on valuation type.
   - If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.
   - If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.
   - For more information, see Balance Inventory Quantities in the Help system.
d Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

6___ Remove all negative tiers using Inventory Management Period End Processing.


8___ If you created reports using Business Insights Reporter, review the report names in the Business Insights Reporter selection window. If there are multiple reports with similar names, copy the reports and assign a distinct name for each report.


For more information, see Copy a Report in the Help system.

**Migration Checklist**

After preparing your version 4.30 data for migration following the Pre-Migration Checklist on page 105, you are now ready to migrate your data to your version 4.50 system.

1___ Select Library Master Utilities menu > Parallel Migration to migrate your data to your version 4.50 system.

When migrating from version 4.30 to Sage ERP MAS 200 SQL version 4.50, select Windows Start menu > All Programs > Sage program group > Parallel Migration Wizard to migrate your data.

2___ To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.
Appendix A  Checklists

3. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

4. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

5. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

6. If you are printing bar codes, install the Azalea fonts from the WkSetup\Azalea folder on the Sage ERP MAS product DVD.

7. When you launch Sage ERP MAS, log on as Administrator, review the security for your users, and set up and assign the appropriate roles to your users using tasks accessed through the Administrative Tools window. Set up security using Role Maintenance as follows:
   - Create roles for all tasks you would like to secure. Review all roles and update permissions for all modules and features.
   - For Common Information tasks that appear on multiple menus, security must be set up for the Common Information module using Role Maintenance.
   - Set up ODBC security using Role Maintenance.

8. If you are using Unified Logon and you migrated your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

9. If you customized your Desktop, re-create the customizations on the Custom toolbar.
10. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with ‘Bill To’ Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

Data Conversion Checklist

After preparing your version 4.30 data for migration following the Pre-Migration Checklist on page 105 and Migration Checklist on page 107, you are now ready to convert your data to version 4.50.

1. Select Library Master Main menu > Company Maintenance to convert your data to version 4.50. This must be done for each of your companies.

2. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

3. Rebuild all application sort files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.

4. Verify that your modules do not have broken links by selecting Library Master Utilities menu > Link Maintenance. Links that appear in red are broken and will need to be fixed using the Relink Files button in Link Maintenance. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

5. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.
Appendix A  Checklists

6. Review the placement of all user-defined fields. Update the customized forms using Custom Office Update Customized Panels to Current Level. For more information, see Customizer Changes on page 32.

Re-customize the customized libraries for all modules other than Accounts Payable, Accounts Receivable, Bank Reconciliation, eBusiness Manager, General Ledger, Job Cost, Material Requirements Planning, Payroll, Return Merchandise Authorization, Sales Order, TimeCard, and Work Order.

7. Run the Crystal Form Comparison Report utility (select File menu > Run, and then type SYWFCU) to compare your customized forms to a standard form from version 4.50. For more information, see Customized Crystal Forms on page 21. If you were previously using non-graphical forms, you will need to set them up in Crystal Reports.

Test your modified Crystal reports and forms. Before modifying graphical forms or the standard Crystal reports found on the Custom Reports menu, you must be proficient in the use of Crystal Reports.

Use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see Crystal Reports FAQs in the Help system.

Add any custom reports to the Custom Reports menu using Report Manager.

8. If dictionary changes were made to any file used on an import created in the Visual Integrator module, those imports will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order. Review the appropriate file layout using the File Layouts and Program Information link on the Resources page of the Desktop and the Data Dictionary Listing accessed from the Visual Integrator Main menu to verify that the imported field names are consistent with the new file layout.
9. Set up the Paperless Office module to e-mail statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

10. Set up your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

11. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Sage Web Engine.

12. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in the Accounts Payable Options window.

13. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to assign tax schedules.

14. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

15. To access the Custom Financials menu and tasks, select File menu > Run and type *unhidegl in the Run Program window. For more information, see Custom Financials on page 89.

16. Checks in the Payroll and Accounts Payable modules can now be printed in American National Standards Institute (ANSI) format.

   To print nongraphical payroll checks in ANSI format, clear the Graphical Forms check box for Checks in the Setup Options window. In the Payroll module, select the Print in ANSI Format check box in the Check Printing window.

   To print graphical payroll checks in ANSI format, select the Graphical Forms check box for Checks in the Payroll Options window.

   In the Accounts Payable module, select the Print in ANSI Format check box in the Check Printing or Manual Check Printing window.

   **NOTE**
   Be sure to first print the check and compare your check stock. Make any needed adjustments.
Appendix A  Checklists

17. If you have the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

18. Print and compare all customized form definitions, including your Payroll W-2 forms and quarterly governmental reports. Default forms may be erased in the migration process.

If you plan to use Federal and State eFiling and Reporting for the W-2 forms and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

19. Compare the following version 4.30 and 4.50 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report.

20. If you purchased the Return Merchandise Authorization module, after setting up Return Merchandise Authorization data files for the first time for a pre-existing Sage ERP MAS installation, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

For information on what is new in this release, see What’s New in Version 4.50 on page 4.
Upgrading from Version 4.20 to Version 4.50

Prior to upgrading your version 4.20 data to version 4.50, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to migrate your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the migration process.

Pre-Migration Checklist

After installing the current version of the software, you must prepare your version 4.20 data for migration. This should be done for each company you plan to migrate.

1. Create a copy of your version 4.20 companies by selecting Library Master Main menu > Company Maintenance. Use the Copy feature in this task. Create a backup of your MAS90 folder following your backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

2. Verify all data entry files are empty. Print and update all journals and registers. Any data in the data entry files during the migration will be lost (for example, Accounts Receivable Cash Receipts Entry).

3. If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

4. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.
5. From your version 4.50 installation, select Library Master Utilities menu > Pre Migration, then enter the source path and company code for your version 4.20 system. Select the reports and utilities that appear.

a. Select Item Code Validation Report to display missing item codes from your Warehouse Detail, Item Costing, and Transaction Detail files.
   - To fix the files, in your version 4.20 data, use Inventory Management Main menu > Inventory Maintenance.

b. Select Inventory File Comparison Report to compare the quantity in your warehouse, tier, and transaction inventory data files.
   - Run this report by warehouse and save as an audit trail.
   - To correct any quantities, run the Inventory Balancing Utility.

c. Select Inventory Balancing Utility to balance your inventory quantities.
   - Run this utility for each warehouse.
   - At the Action column, select the action to perform for each item, or apply a specific action based on valuation type.
   - If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.
   - If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.
   - For more information, see Balance Inventory Quantities in the Help system.

NOTE
The tasks that appear in the Pre Migration window are based on the version of your data.

NOTE
The quantities in your warehouse, tier, and transaction inventory data files must match before you can migrate your data to version 4.50.
d Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

6___ Remove all negative tiers using Inventory Management Period End Processing.


8___ If you created reports using Business Insights Reporter, review the report names in the Business Insights Reporter selection window. If there are multiple reports with similar names, copy the reports and assign a distinct name for each report.


   For more information, see Copy a Report in the Help system.

**Migration Checklist**

After preparing your version 4.20 data for migration following the Pre-Migration Checklist on page 113, you are now ready to migrate your data to your version 4.50 system.

1___ Select Library Master Utilities menu > Parallel Migration to migrate your data to your version 4.50 system.

   When migrating from version 4.20 to Sage ERP MAS 200 SQL version 4.50, select Windows Start menu > All Programs > Sage program group > Parallel Migration Wizard to migrate your data.

2___ To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.
Appendix A  Checklists

3___ If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

4___ If you had task folders in your My Tasks area, re-create your Public and Private task folders.

5___ Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

6___ If you are printing bar codes, install the Azalea fonts from the WkSetup\Azalea folder on the Sage ERP MAS product DVD.

7___ When you launch Sage ERP MAS, log on as Administrator, review the security for your users, and set up and assign the appropriate roles to your users using tasks accessed through the Administrative Tools window. Set up security using Role Maintenance as follows:
   • Create roles for all tasks you would like to secure. Review all roles and update permissions for all modules and features.
   • For Common Information tasks that appear on multiple menus, security must be set up for the Common Information module using Role Maintenance.
   • Set up ODBC security using Role Maintenance.

8___ If you are using Unified Logon and you migrated your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

9___ If you customized your Desktop, re-create the customizations on the Custom toolbar.
10___ If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with ‘Bill To’ Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

Data Conversion Checklist

After preparing your version 4.20 data for migration following the Pre-Migration Checklist on page 113 and Migration Checklist on page 115, you are now ready to convert your data to version 4.50.

1___ Select Library Master Main menu > Company Maintenance to convert your data to version 4.50. This must be done for each of your companies.

2___ If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

3___ Rebuild all application sort files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.

4___ Verify that your modules do not have broken links by selecting Library Master Utilities menu > Link Maintenance. Links that appear in red are broken and will need to be fixed using the Relink Files button in Link Maintenance. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

5___ Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.
Appendix A  Checklists

6. Review the placement of all user-defined fields. Update the customized forms using Custom Office Update Customized Panels to Current Level. For more information, see Customizer Changes on page 32.

Re-customize the customized libraries for all modules other than Accounts Payable, Accounts Receivable, Bank Reconciliation, eBusiness Manager, General Ledger, Job Cost, Material Requirements Planning, Payroll, Return Merchandise Authorization, Sales Order, TimeCard, and Work Order.

7. Run the Crystal Form Comparison Report utility (select File menu > Run, and then type SYWFCU) to compare your customized forms to a standard form from version 4.50. For more information, see Customized Crystal Forms on page 21. If you were previously using non-graphical forms, you will need to set them up in Crystal Reports.

Test your modified Crystal reports and forms. Before modifying graphical forms or the standard Crystal reports found on the Custom Reports menu, you must be proficient in the use of Crystal Reports.

Use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see Crystal Reports FAQs in the Help system.

Add any custom reports to the Custom Reports menu using Report Manager.

8. If dictionary changes were made to any file used on an import created in the Visual Integrator module, those imports will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order. Review the appropriate file layout using the File Layouts and Program Information link on the Resources page of the Desktop and the Data Dictionary Listing accessed from the Visual Integrator Main menu to verify that the imported field names are consistent with the new file layout.
9. Set up the Paperless Office module to e-mail statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

10. Set up your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

11. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Sage Web Engine.

12. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in the Accounts Payable Options window.

13. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to assign tax schedules.

14. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

15. To access the Custom Financials menu and tasks, select File menu > Run and type *unhidegl* in the Run Program window. For more information, see Custom Financials on page 89.

16. Checks in the Payroll and Accounts Payable modules can now be printed in American National Standards Institute (ANSI) format.

To print nongraphical payroll checks in ANSI format, clear the Graphical Forms check box for Checks in the Setup Options window. In the Payroll module, select the Print in ANSI Format check box in the Check Printing window.

To print graphical payroll checks in ANSI format, select the Graphical Forms check box for Checks in the Payroll Options window.

In the Accounts Payable module, select the Print in ANSI Format check box in the Check Printing or Manual Check Printing window.

**NOTE**
Be sure to first print the check and compare your check stock. Make any needed adjustments.
Appendix A  Checklists

17. If you have the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

18. Print and compare all customized form definitions, including your Payroll W-2 forms and quarterly governmental reports. Default forms may be erased in the migration process.

   If you plan to use Federal and State eFiling and Reporting for the W-2 forms and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

19. Compare the following version 4.20 and 4.50 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report.

20. If you purchased the Return Merchandise Authorization module, after setting up Return Merchandise Authorization data files for the first time for a pre-existing Sage ERP MAS installation, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

For information on what is new in this release, see What's New in Version 4.50 on page 4.
Upgrading from Version 4.10 to Version 4.50

Prior to upgrading your version 4.10 data to version 4.50, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to migrate your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the migration process.

Pre-Migration Checklist

After installing the current version of the software, you must prepare your version 4.10 data for migration. This should be done for each company you plan to migrate.

1. Create a copy of your version 4.10 companies by selecting Library Master Main menu > Company Maintenance. Use the Copy feature in this task. Create a backup of your MAS90 folder following your backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

2. Verify all data entry files are empty. Print and update all journals and registers. Any data in the data entry files during the migration will be lost (for example, Accounts Receivable Cash Receipts Entry).

3. If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

4. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.
From your version 4.50 installation, select Library Master Utilities menu > Pre Migration, then enter the source path and company code for your version 4.10 system. Select the reports and utilities that appear.

a Select Item Code Validation Report to display missing item codes from your Warehouse Detail, Item Costing, and Transaction Detail files.

- To fix the files, in your version 4.10 data, use Inventory Management Main menu > Inventory Maintenance.

b Select Inventory File Comparison Report to compare the quantity in your warehouse, tier, and transaction inventory data files.

- Run this report by warehouse and save as an audit trail.
- To correct any quantities, run the Inventory Balancing Utility.

c Select Inventory Balancing Utility to balance your inventory quantities.

- Run this utility for each warehouse.
- At the Action column, select the action to perform for each item, or apply a specific action based on valuation type.
- If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.
- If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.
- For more information, see Balance Inventory Quantities in the Help system.
d Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

6 Remove all negative tiers using Inventory Management Period End Processing.


8 If you created reports using Business Insights Reporter, review the report names in the Business Insights Reporter selection window. If there are multiple reports with similar names, copy the reports and assign a distinct name for each report.


For more information, see Copy a Report in the Help system.

**Migration Checklist**

After preparing your version 4.10 data for migration following the Pre-Migration Checklist on page 121, you are now ready to migrate your data to your version 4.50 system.

1 Select Library Master Utilities menu > Parallel Migration to migrate your data to your version 4.50 system.

When migrating from version 4.10 to Sage ERP MAS 200 SQL version 4.50, select Windows Start menu > All Programs > Sage program group > Parallel Migration Wizard to migrate your data.

2 To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.
Appendix A  Checklists

3. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

4. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

5. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

6. If you are printing bar codes, install the Azalea fonts from the WkSetup\Azalea folder on the Sage ERP MAS product DVD.

7. When you launch Sage ERP MAS, log on as Administrator, review the security for your users, and set up and assign the appropriate roles to your users using tasks accessed through the Administrative Tools window. Set up security using Role Maintenance as follows:
   - Create roles for all tasks you would like to secure. Review all roles and update permissions for all modules and features.
   - For Common Information tasks that appear on multiple menus, security must be set up for the Common Information module using Role Maintenance.
   - Set up ODBC security using Role Maintenance.

8. If you are using Unified Logon and you migrated your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

9. If you customized your Desktop, re-create the customizations on the Custom toolbar.
10. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with ‘Bill To’ Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

Data Conversion Checklist

After preparing your version 4.10 data for migration following the Pre-Migration Checklist on page 121 and Migration Checklist on page 123, you are now ready to convert your data to version 4.50.

1. Select Library Master Main menu > Company Maintenance to convert your data to version 4.50. This must be done for each of your companies.

2. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

3. Rebuild all application sort files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.

4. Verify that your modules do not have broken links by selecting Library Master Utilities menu > Link Maintenance. Links that appear in red are broken and will need to be fixed using the Relink Files button in Link Maintenance. For more information on relinking files, see Copy/Move/Relink Files in your Help system.

5. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.
6. Review the placement of all user-defined fields. Update the customized forms using Custom Office Update Customized Panels to Current Level. For more information, see Customizer Changes on page 32.

Re-customize the customized libraries for all modules other than Accounts Receivable, Bank Reconciliation, eBusiness Manager, General Ledger, Job Cost, Material Requirements Planning, Payroll, Return Merchandise Authorization, Sales Order, TimeCard, and Work Order.

7. Run the Crystal Form Comparison Report utility (select File menu > Run, and then type SYWFCU) to compare your customized forms to a standard form from version 4.50. For more information, see Customized Crystal Forms on page 21. If you were previously using non-graphical forms, you will need to set them up in Crystal Reports.

Test your modified Crystal reports and forms. Before modifying graphical forms or the standard Crystal reports found on the Custom Reports menu, you must be proficient in the use of Crystal Reports.

Use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see Crystal Reports FAQs in the Help system.

Add any custom reports to the Custom Reports menu using Report Manager.

8. If dictionary changes were made to any file used on an import created in the Visual Integrator module, those imports will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order. Review the appropriate file layout using the File Layouts and Program Information link on the Resources page of the Desktop and the Data Dictionary Listing accessed from the Visual Integrator Main menu to verify that the imported field names are consistent with the new file layout.
9. Set up the Paperless Office module to e-mail statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

10. Set up your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

11. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Sage Web Engine.

12. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in the Accounts Payable Options window.

13. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to assign tax schedules.

14. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

15. To access the Custom Financials menu and tasks, select File menu > Run and type *unhidegl in the Run Program window. For more information, see Custom Financials on page 89.

16. Checks in the Payroll and Accounts Payable modules can now be printed in American National Standards Institute (ANSI) format.

   To print nongraphical payroll checks in ANSI format, clear the Graphical Forms check box for Checks in the Setup Options window. In the Payroll module, select the Print in ANSI Format check box in the Check Printing window.

   To print graphical payroll checks in ANSI format, select the Graphical Forms check box for Checks in the Payroll Options window.

   In the Accounts Payable module, select the Print in ANSI Format check box in the Check Printing or Manual Check Printing window.

   **NOTE**
   Be sure to first print the check and compare your check stock. Make any needed adjustments.
Appendix A  Checklists

17. If you have the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

18. Print and compare all customized form definitions, including your Accounts Payable 1099 forms, Payroll W-2 forms, and quarterly governmental reports. Default forms may be erased in the migration process.

If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

19. Compare the following version 4.10 and 4.50 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report.

20. If you purchased the Return Merchandise Authorization module, after setting up Return Merchandise Authorization data files for the first time for a pre-existing Sage ERP MAS installation, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

For information on what is new in this release, see What’s New in Version 4.50 on page 4.
Upgrading from Version 4.00 or 4.05 to Version 4.50

Prior to upgrading your version 4.00 or 4.05 data to version 4.50, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to migrate your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the migration process.

Pre-Migration Checklist

After installing the current version of the software, you must prepare your version 4.00 or 4.05 data for migration. This should be done for each company you plan to migrate.

1. Create a copy of your version 4.00 or 4.05 companies by selecting Library Master Main menu > Company Maintenance. Use the Copy feature in this task. Create a backup of your MAS90 folder following your backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

2. Verify all data entry files are empty. Print and update all journals and registers. Any data in the data entry files during the migration will be lost (for example, Accounts Receivable Cash Receipts Entry).

3. If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

4. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.
Appendix A  Checklists

5____ Confirm in Accounts Receivable Customer Maintenance that all customers that have tax exempt numbers have a sales tax code defined. If a sales tax code is not defined, the tax exempt number will be deleted during the upgrade.

6____ From your version 4.50 installation, select Library Master Utilities menu > Pre Migration, then enter the source path and company code for your version 4.00 or 4.05 system. Select the reports and utilities that appear.

   a Select Item Code Validation Report to display missing item codes from your Warehouse Detail, Item Costing, and Transaction Detail files.
      • To fix the files, in your version 4.00 or 4.05 data, use Inventory Management Main menu > Inventory Maintenance.

   b Select Inventory File Comparison Report to compare the quantity in your warehouse, tier, and transaction inventory data files.
      • Run this report by warehouse and save as an audit trail.
      • To correct any quantities, run the Inventory Balancing Utility.

   c Select Inventory Balancing Utility to balance your inventory quantities.
      • Run this utility for each warehouse.
      • At the Action column, select the action to perform for each item, or apply a specific action based on valuation type.
      • If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.

NOTE
The tasks that appear in the Pre Migration window are based on the version of your data.

NOTE
The quantities in your warehouse, tier, and transaction inventory data files must match before you can migrate your data to version 4.50.
• If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.

• For more information, see Balance Inventory Quantities in the Help system.

d Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

7 Remove all negative tiers using Inventory Management Period End Processing.


9 If you created reports using Business Insights Reporter, review the report names in the Business Insights Reporter selection window. If there are multiple reports with similar names, copy the reports and assign a distinct name for each report.


For more information, see Copy a Report in the Help system.
Appendix A  Checklists

Migration Checklist

After preparing your version 4.00 or 4.05 data for migration following the Pre-Migration Checklist on page 129, you are now ready to migrate your data to your version 4.50 system.

1. Select Library Master Utilities menu > Parallel Migration to migrate your data to your version 4.50 system.

   When migrating from version 4.00 or 4.05 to Sage ERP MAS 200 SQL version 4.50, select Windows Start menu > All Programs > Sage program group > Parallel Migration Wizard to migrate your data.

2. To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

3. If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

4. If you had task folders in your My Tasks area, re-create your Public and Private task folders.

5. Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

6. If you are printing bar codes, install the Azalea fonts from the WkSetup\Azalea folder on the Sage ERP MAS product DVD.

7. When you launch Sage ERP MAS, log on as Administrator, review the security for your users, and set up and assign the appropriate roles to your users using tasks accessed through the Administrative Tools window. Set up security using Role Maintenance as follows:

   - Create roles for all tasks you would like to secure. Review all roles and update permissions for all modules and features.


\NOTE
The following modules are not available for Sage ERP MAS 200 SQL: eBusiness Manager, Fixed Assets, Job Cost, Material Requirements Planning, Payroll, TimeCard, Work Order, and the Business Insights Reporter.
• For Common Information tasks that appear on multiple menus, security must be set up for the Common Information module using Role Maintenance.

• Set up ODBC security using Role Maintenance.

8. If you are using Unified Logon and you migrated your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

9. If you customized your Desktop, re-create the customizations on the Custom toolbar.

10. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with 'Bill To' Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer's address information.

Data Conversion Checklist

After preparing your version 4.00 or 4.05 data for migration following the Pre-Migration Checklist on page 129 and Migration Checklist on page 132, you are now ready to convert your data to version 4.50.

1. Select Library Master Main menu > Company Maintenance to convert your data to version 4.50. This must be done for each of your companies.

2. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

3. Rebuild all application sort files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.
Appendix A  Checklists

4. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

5. Review the placement of all user-defined fields. Update the customized forms using Custom Office Update Customized Panels to Current Level. For more information, see Customizer Changes on page 32.

    Re-customize the customized libraries for all modules other than General Ledger, Job Cost, Material Requirements Planning, Payroll, TimeCard, and Work Order.

6. Run the Crystal Form Comparison Report utility (select File menu > Run, then type SYWFCU) to compare your customized forms to a standard form from version 4.50. For more information, see Customized Crystal Forms on page 21. If you were previously using non-graphical forms, you will need to set them up in Crystal Reports.

    Test your modified Crystal reports and forms. Before modifying graphical forms or the standard Crystal reports found on the Custom Reports menu, you must be proficient in the use of Crystal Reports.

    Use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see Crystal Reports FAQs in the Help system.

    Add any custom reports to the Custom Reports menu using Report Manager.
7. If dictionary changes were made to any file used on an import created in the Visual Integrator module, those imports will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order. Review the appropriate file layout using the File Layouts and Program Information link on the Resources page of the Desktop and the Data Dictionary Listing accessed from the Visual Integrator Main menu to verify that the imported field names are consistent with the new file layout.

8. Set up the Paperless Office module to e-mail statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

9. Set up your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

10. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Sage Web Engine.

11. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in the Accounts Payable Options window.

12. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to assign tax schedules.

13. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

14. To access the Custom Financials menu and tasks, select File menu > Run and type *unhidegl* in the Run Program window. For more information, see Custom Financials on page 89.
15. Checks in the Payroll and Accounts Payable modules can now be printed in American National Standards Institute (ANSI) format.

To print non-graphical payroll checks in ANSI format, clear the Graphical Forms check box for Checks in the Setup Options window. In the Payroll module, select the Print in ANSI Format check box in the Check Printing window.

To print graphical payroll checks in ANSI format, select the Graphical Forms check box for Checks in the Payroll Options window.

In the Accounts Payable module, select the Print in ANSI Format check box in the Check Printing or Manual Check Printing window.

16. If you have the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

17. Print and compare all customized form definitions, including your Accounts Payable 1099 forms, Payroll W-2 forms, and quarterly governmental reports. Default forms may be erased in the migration process.

If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.
Compare the following version 4.x and 4.50 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report.

If you purchased the Return Merchandise Authorization module, after setting up Return Merchandise Authorization data files for the first time for a pre-existing Sage ERP MAS installation, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

For information on what is new in this release, see What’s New in Version 4.50 on page 4.
Upgrading from Level 3.x to Version 4.50

Prior to upgrading your level 3.x data to version 4.50, you must perform a parallel installation. Use the Pre-Migration and Parallel Migration utilities from the Library Master Utilities menu to migrate your data. For more information, consult with your Sage business partner.

If you have custom modules or modifications to any of your modules, consult your Sage business partner or development partner prior to beginning the migration process.

Pre-Migration Checklist

After installing the current version of the software, you must prepare your level 3.x data for migration. This should be done for each company you plan to migrate.

1. Create a copy of your Level 3.x companies by selecting File menu > Run and typing SVDATA at the Program Name field. Create a backup of your MAS90 folder following your backup process. For specific support on how to back up your data, refer to manuals for your backup software or contact the vendor from whom you purchased that product.

   If your company code has special characters, run SVDATA to a new company code. Version 4.50 does not support special characters.

2. Verify all data entry files are empty. Print and update all journals and registers. Any data in the data entry files during the migration will be lost (for example, Accounts Receivable Cash Receipts Entry).

   You must update or clear all data entry in progress to prevent the data from becoming cleared during data migration.

3. If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.
4. If data exists in alternate directories, verify in Alternate Directory Maintenance that a UNC path exists for all alternate directories. If changes were made in Alternate Directory Maintenance, rebuild alternate directory pointers using the Library Master Repair menu.

5. Rebuild all data files using the Rebuild Key Files and Rebuild Sort File utilities. You must answer Yes to all recalculation questions.

6. Confirm in Accounts Receivable Customer Maintenance that all customers that have tax exempt numbers have a sales tax code defined. If a sales tax code is not defined, the tax exempt number will be deleted during the upgrade.

7. From your version 4.50 installation, select Library Master Utilities menu > Pre Migration, then enter the source path and company code for your Level 3.x system. Select the reports and utilities that appear.

   a. Select General Ledger Account Validation Report to display all missing general ledger accounts.
      - To fix the accounts, in your Level 3.x system, use General Ledger Main menu > Account Maintenance.

   b. Select General Ledger Special Character Report to display a list of all general ledger accounts with special characters.
      - To fix the accounts, in your Level 3.x system, use General Ledger Setup menu > Account Delete/Renumber/Merge.

   c. Select General Ledger Out of Balance Report to display a list all source journals that are out of balance.
      - To determine how to resolve the out of balance journals, in your Level 3.x system, select General Ledger Reports menu > General Ledger Detail Report and make any corrections to the journal entries as necessary.
      - Recalculate the account balances for each general ledger fiscal year that has transaction history using General Ledger Fiscal Year Maintenance.
Appendix A  Checklists

- Perform year-end processing for each year, beginning with the first year you have detail for and have recalculated.
- Print the General Ledger Trial Balance Report with the beginning and ending balance detail, and all Financial Statements.

**d** Select the General Ledger Future Years Utility to check for detail transactions, periodic summary totals, and future fiscal years.

- On the General Ledger Detail Transaction Utility window, accept all the field defaults and then click Log Only.
- Review the log to determine if you would like to remove the future dated data.
- If you want to remove data, run the utility again, and at the Highest Fiscal Year to Retain field, enter the highest year you want to retain future data. Click Log Only and print the report as an audit trail.
- To confirm your data was removed, run the utility again with the same year entered in the previous step. Click Delete to remove the detailed data for the future years.

**e** Select Item Code Validation Report to display missing item codes from your Warehouse Detail, Item Costing, and Transaction Detail files.

- To fix the files, in your level 3.x data, use Inventory Management Main menu > Inventory Maintenance.

**f** Select Inventory File Comparison Report to compare the quantity in your warehouse, tier, and transaction inventory data files.

- Run this report by warehouse and save as an audit trail.
- To correct any quantities, run the Inventory Balancing Utility.
g Select Inventory Balancing Utility to balance your inventory quantities.

- Run this utility for each warehouse.
- At the Action column, select the action to perform for each item, or apply a specific action based on valuation type.
- If the valuation is LIFO, FIFO, Lot, or Serial, at the Action column select Skip if the tier quantities are incorrect. You must perform a physical count to correct the tier quantity. After the tier quantity is correct, run this utility for these valuation methods.
- If the valuation is Average Cost or Standard Cost and the warehouse and transaction quantities are incorrect, you must perform a physical count to correct the warehouse quantity. After the warehouse quantity is correct, run this utility for those valuation methods.
- For more information, see Balance Inventory Quantities in the Help system.

h Run all Inventory Pre Migration tasks again to ensure corrections were made. Keep all reports as an audit trail.

8 Remove all negative tiers using Inventory Management Period End Processing.

Appendix A  Checklists

Migration Checklist

After preparing your level 3.x data for migration following the Pre-Migration Checklist on page 138, you are now ready to migrate your data to your version 4.50 system.

1____ Select Library Master Utilities menu > Parallel Migration to migrate your data to your version 4.50 system.

When migrating from version 4.00 or 4.05 to Sage ERP MAS 200 SQL version 4.50, select Windows Start menu > All Programs > Sage program group > Parallel Migration Wizard to migrate your data.

2____ To run Microsoft Script links, you must have the Microsoft Windows Script Host processor on your system. For information on installing the Microsoft Windows Script Host processor, refer to the Microsoft Download Center Web site.

3____ If you use Automatic Update or Task Scheduler, review your scheduled automatic updates and reschedule those updates by selecting Library Master Main menu > Automatic Update or Task Scheduler, as applicable.

4____ If you had task folders in your level 3.x Launcher’s My Tasks area, re-create your Public and Private task folders.

5____ Test all printers, including Device Configurator printers, that you normally use for printing forms and reports. Each workstation must have a default printer defined.

6____ If you are printing bar codes, install the Azalea fonts from the WkSetup\Azalea folder on the Sage ERP MAS product DVD.

7____ When you launch Sage ERP MAS, log on as Administrator, review the security for your users, and set up and assign the appropriate roles to your users using tasks accessed through the Administrative Tools window. Set up security using Role Maintenance as follows:

- Create roles for all tasks you would like to secure. Review all roles and update permissions for all modules and features.

NOTE
The following modules are not available for Sage ERP MAS 200 SQL: eBusiness Manager, Fixed Assets, Job Cost, Material Requirements Planning, Payroll, TimeCard, Work Order, and the Business Insights Reporter.
For Common Information tasks that appear on multiple menus, security must be set up for the Common Information module using Role Maintenance.

Set up ODBC security using Role Maintenance.

8. If you migrated data from your Level 3.x system, the entire user name was migrated to the Last Name field in the User Maintenance window. To use the First and Last Name functionality, modify each user name using User Maintenance.

9. If you are using Unified Logon and you migrated your system files, you must add the following statement on one workstation SOTA.ini: Logon=Yes.

10. If you customized your Launcher, re-create the customizations on the Custom toolbar of the new Desktop.

11. If you had the Extended Solution for customers with national accounts and the Populate Bill Address Block with ‘Bill To’ Customer Block check box was selected in AR-1068 Setup Options, you must run the Sales Order Bill To Address Fix Utility (select File menu > Run, then type *Utl) to populate the sales order bill-to address information with the bill-to customer’s address information.

Data Conversion Checklist

After preparing your level 3.x data for migration following the Pre-Migration Checklist on page 138 and Migration Checklist on page 142, you are now ready to convert your data to version 4.50.

1. Select Library Master Main menu > Company Maintenance to convert your data to version 4.50. This must be done for each of your companies.

2. If you have customized Advanced Lookup Engine (ALE) lookups, after converting to the new version of the software and prior to accessing other modules, select Library Master Utilities menu > Lookup Conversion to convert your lookups.

**NOTE**

If you migrated Level 3.x user logons and passwords, these passwords were converted to uppercase letters; therefore, they must now be entered as uppercase letters.
Appendix A  Checklists

3. Rebuild all application sort files using the Rebuild Sort File utility. You must answer Yes to all recalculation questions.

4. Click Reset on your Accounts Payable 1099 forms and Payroll W2 forms to apply new format changes. Use the Forms layout printed during the pre-migration process to reenter your modifications.

5. Review your Payroll Tax Tables. Installing the Payroll Tax Table Update replaces all of your current state and federal tax tables with new tables unless you have specifically excluded a state tax table from the update by selecting the Exclude this Table from Tax Update check box in Tax Table Maintenance. Local tax information is not updated.

6. Review the placement of all user-defined fields. Update the customized forms using Custom Office Update Customized Panels to Current Level. For more information, see Customizer Changes on page 32.

   Re-customize the customized libraries for all modules other than Job Cost, Material Requirements Planning, Payroll, TimeCard, and Work Order.

7. Run the Crystal Form Comparison Report utility (select File menu > Run, and then type SYWFCU) to compare your customized forms to a standard form from version 4.50. For more information, see Customized Crystal Forms on page 21. If you were previously using non-graphical forms, you will need to set them up in Crystal Reports.

   Test your modified Crystal reports and forms. Before modifying graphical forms or the standard Crystal reports found on the Custom Reports menu, you must be proficient in the use of Crystal Reports.

   Use the Crystal Reports Conversion Wizard to convert your Crystal reports and forms. For more information, see Crystal Reports FAQs in the Help system.

   If you are upgrading from a level prior to Level 3.41, you must manually convert your Crystal reports and forms.
Add any custom reports to the Custom Reports menu using Report Manager.

8. If dictionary changes were made to any file used on an import created in the Visual Integrator module, those imports will need to be manually updated for modules other than Job Cost, Payroll, Material Requirements Planning, TimeCard, and Work Order. Review the appropriate file layout using the File Layouts and Program Information link on the Resources page of the Desktop and the Data Dictionary Listing accessed from the Visual Integrator Main menu to verify that the imported field names are consistent with the new file layout.

9. Set up the Paperless Office module to e-mail statements, reports, journals, registers, and other forms. For more information, see Set Up Paperless Office in the Help system.

10. Set up your Business Insights Dashboard pages. For more information, see Set Up Business Insights Dashboard in the Help system.

11. To use the eBusiness Manager module, restore the copied templates back to the IW folder after re-installing the Sage Web Engine.

12. If you do not use taxation for purchase orders, clear the Sales Tax Reporting check box in the Accounts Payable Options window.

13. If you include sales tax on purchase orders and want to enter default tax schedules for vendors, use Accounts Payable Assign Vendor Tax Schedules to assign tax schedules.

14. Confirm in Accounts Receivable Customer Maintenance that all customers that have exemption numbers still have the exemption number defined.

15. To access the Custom Financials menu and tasks, select File menu > Run and type *unhidegl in the Run Program window. For more information, see Custom Financials on page 89.
Appendix A  Checklists

16. Checks in the Payroll and Accounts Payable modules can now be printed in American National Standards Institute (ANSI) format.

To print nongraphical payroll checks in ANSI format, clear the Graphical Forms check box for Checks in the Setup Options window. In the Payroll module, select the Print in ANSI Format check box in the Check Printing window.

To print graphical payroll checks in ANSI format, select the Graphical Forms check box for Checks in the Payroll Options window. If you have a check form that was created prior to Level 3.70, you can reset the form so that the ANSI Check Amount field appears in the Field Description list on the Detail tab; however, clicking Reset on the Header tab resets all the settings on the form. Print the form layout first, in case changes need to be reentered. As an alternative to resetting the form, you can create a new form.

In the Accounts Payable module, select the Print in ANSI Format check box in the Check Printing or Manual Check Printing window.

17. If you are upgrading from a level prior to Level 3.70, the way that completions are handled has changed in the Work Order module. If you have existing work order completions prior to Level 3.70, see Costing Methods for Unit Cost of Completion Entry in the Help system to review examples of cost completion methods.

18. The file structure for Warehouse Grouping Maintenance in the Material Requirements Planning module was modified in Level 3.70 to correct Material Requirements Planning generation problems that occurred from inconsistencies in the warehouse grouping data entry. Because changes to the Warehouse Grouping Maintenance file will be initialized if upgrading from Level 3.61 or prior to Level 3.70 or 3.71, the Warehouse Groupings must be reentered in Warehouse Grouping Maintenance after the Material Requirements Planning module has been upgraded.

NOTE
Be sure to first print the check and compare your check stock. Make any needed adjustments.
If you have the Extended Solution for direct deposits, verify the bank ID (bank account) number for each bank code. During conversion, if there is a discrepancy between the bank ID number in Bank Code Maintenance and the bank account number in Direct Deposit Information for a bank code, the account number in Direct Deposit Information replaces the number in Bank Code Maintenance. If an account number is not entered in Direct Deposit Information, the number in Bank Code Maintenance is entered in Direct Deposit Information. Account number changes are noted in the conversion log.

Print and compare all customized form definitions, including your Accounts Payable 1099 forms, Payroll W-2 forms, and quarterly governmental reports. Default forms may be erased in the migration process.

If you plan to use Federal and State eFiling and Reporting for the 1099 forms, W-2 forms, and governmental reports, perform the conversion to version 4.50 after the quarter end and before the first payroll in the current quarter to avoid values being placed in the wrong boxes on some forms. If conversion is performed mid-quarter, some forms may require editing.

Compare the following level 3.x and version 4.50 reports because sales tax may be recalculated during the conversion: Accounts Receivable Sales Tax Report, Accounts Receivable Repetitive Invoice Listing, Accounts Payable Repetitive Invoice Listing, Open Sales Order Report, and Open Purchase Order Report.

If you purchased the Return Merchandise Authorization module, after setting up Return Merchandise Authorization data files for the first time for a pre-existing Sage ERP MAS installation, select Return Merchandise Authorization Setup menu > Create Customer Invoice Search Records to create customer invoice search records in RMA.

For information on what is new in this release, see What’s New in Version 4.50 on page 4.
Index

A
accounting dates 84
accounts 87
Accounts Payable
  ACH payment 24
  changes in product update 4.40.0.2 24
  changes in version 4.20 62
  data entry 63
  global changes 62
  period-end processing 63
  renamed, removed, or moved tasks 25, 65
  wire transfers 24
Accounts Receivable
  changes in version 4.10 73
  changes in version 4.20 65
  changes in version 4.30 55
  changes in version 4.40 26
  enhancements in 4.50 5
  global changes 73
  national accounts 5
  period-end processing 74
  purge credit card data 6
  recalculate utility 6
  renamed, removed, or moved tasks 26, 74
  split commission 7
  utility 7
activity log 20
Advanced Lookup Engine
  changes in version 4.00 83
  changes in version 4.20 58
  changes in version 4.40 20
allocations 88

B
Bank Reconciliation
  changes in product update 4.40.0.2 26
  changes in product update 4.40.0.3 26
  on the fly 26
  registers 26
  renamed and removed tasks 26
Bar Code
  changes in version 4.40 27
  enhancements in 4.50 7
  lot/serial distribution 7
  renamed, removed, or moved tasks 27
batch fax 60
Bill of Materials
  changes in version 4.40 27
  data entry 28
  global changes 27
  inquiry changes 28
  options 28
  printing 28
  renamed, removed, or moved tasks 29
  reports and forms 29
Business Insights
  changes in version 4.00 87
  changes in version 4.05 85
  changes in version 4.20 66
  changes in version 4.30 56
  changes in version 4.40 30
  global changes 66
  renamed, removed, or moved tasks 67, 75
Business Insights Dashboard
  changes in version 4.30 56
  renamed tasks 67
Business Insights Explorer
  changes in version 4.20 66
Business Insights Reporter
  changes in version 4.00 87
  changes in version 4.30 56
C
checklists
  level 3.X data conversion 143
  level 3.X migration 142
  level 3.X pre-migration 138
  version 4.0 or 4.05 data conversion 133
  version 4.0 or 4.05 migration 132
  version 4.0 or 4.05 pre-migration 129
  version 4.10 data conversion 125
  version 4.10 migration 123
  version 4.10 pre-migration 121
  version 4.20 data conversion 117
  version 4.20 migration 115
  version 4.20 pre-migration 113
  version 4.30 data conversion 109
  version 4.30 migration 107
  version 4.30 pre-migration 105
  version 4.40 data conversion 102
  version 4.40 migration 101
  version 4.40 pre-migration 100
| checklists (continued)                          | version 4.45 data conversion | 97          |
|                                                | version 4.45 migration       | 96          |
|                                                | version 4.45 pre-migration   | 95          |
| commission                                    | by customer                  | 7           |
|                                                | by line item                 | 14          |
| Common Information                            | changes in product update    | 4.40.0.2 30 |
|                                                | changes in version 4.10      | 75          |
|                                                | changes in version 4.20      | 67          |
|                                                | changes in version 4.30      | 56          |
|                                                | changes in version 4.40      | 30          |
|                                                | options                      | 31          |
|                                                | renamed, removed, or moved   | 31, 56, 67  |
|                                                | tasks                        |             |
| reports                                       |                               |             |
| companies, copying data                       | 85                          |
| costing changes                               | 37                          |
| customer numbers, expanded                    | 22                          |
| customized Crystal forms                      | 21                          |
| Customizer                                    | changes in version 4.00      | 87          |
|                                                | changes in version 4.10      | 75          |
|                                                | changes in version 4.20      | 68          |
|                                                | changes in version 4.40      | 32          |
|                                                | global changes               | 32, 68, 75, 87 |
| data dictionaries                             | 49, 81, 92                   |
| data dictionary listing                       | 50, 71, 81, 92               |
| data entry                                    | General Ledger               | 89          |
|                                               | in version 4.40              | 21          |
|                                               | Sales Order                  | 47          |
| Data File Display and Maintenance             | 85                          |
| data file multi-segment                       | 19                          |
| dates, accounting and module                  | 84                          |
| Desktop                                       | 22, 58, 83                   |
| dot matrix printers                           | 59                          |
| E                                             | eBusiness Manager            |             |
|                                                | changes in version 4.10      | 78          |
|                                                | changes in version 4.40      | 33          |
|                                                | global changes               | 78          |
|                                                | Sage Web Engine              | 33          |
|                                                | Electronic Reporting        |             |
|                                                | changes in version 4.20      | 69          |
|                                                | global changes               | 69          |
|                                                | e-mail statements, setup     | 55          |
| Enhancements in 4.50                          | Accounts Receivable          | 5           |
|                                                | Bar Code                     | 7           |
|                                                | global                       | 4           |
|                                                | Inventory Management         | 8           |
|                                                | Library Master               | 8           |
|                                                | Payroll                      | 9           |
|                                                | Purchase Order               | 11          |
|                                                | Sales Order                  | 13          |
| expanded                                      | customer numbers             | 22          |
|                                                | item codes                   | 22          |
|                                                | export jobs                  | 93          |
| F                                             | fax, batch faxing            | 60          |
| Fixed Assets                                  | changes in version 4.20      | 70          |
|                                                | global changes               | 70          |
| G                                             | General Ledger               |             |
|                                                | changes in version 4.00      | 87          |
|                                                | changes in version 4.40      | 33          |
|                                                | custom financials            | 89          |
|                                                | data entry                   | 89          |
|                                                | period-end processing        | 90          |
|                                                | renamed and removed tasks    | 91          |
|                                                | reports                      | 91          |
|                                                | standard financials          | 89          |
| global changes                                | in version 4.00               | 83          |
|                                                | in version 4.20               | 58          |
|                                                | in version 4.30               | 54          |
|                                                | in version 4.40               | 19          |
|                                                | in version 4.50               | 17          |
|                                                | printing in version 4.40     | 22          |
|                                                | reports and forms in version | 23          |
|                                                | 4.40                         |             |
|                                                | graphic conventions         | 2           |
|                                                | H                            |             |
|                                                | Help system                  | 58, 83      |
Import Job Maintenance 50, 72, 82, 92
imported jobs in Payroll 10
inquiries 59
installation changes
  in version 4.00 83
  in version 4.30 54
  in version 4.40 19
installation, parallel or in-place 4
inventory items, on the fly 48
Inventory Management
  changes in version 4.40 34
  costing 37
  enhancements in 4.50 8
  global changes 34
  lot/serial distribution 8
  options 34
  period-end processing 38
  physical count 36
  printing 38
  product lines 35
  renamed, removed, or moved tasks 39
  reports and forms 39
  transactions 35
  utilities 37
item codes, expanded 22
Item Maintenance 36
item pricing by total quantity 14

Job Cost
  changes in version 4.40 40
  dictionary changes 40
  options 40
job import changes in version 4.30 57

Library Master
  changes in version 4.00 85
  changes in version 4.20 60
  changes in version 4.30 55
  changes in version 4.40 24
  credit card security 8
  enhancements in 4.50 8
  renamed, removed, or moved tasks 24, 85
Library Master (continued)

Manage Your System 17
manuals 58, 83
memos 65
migrate, Level 3.x data 83
Miscellaneous Item Maintenance 75
modules
  dates 84
  registering 84
  retired 53, 72, 93
national accounts 5
Operand field 54
Payroll
  changes in product update 4.40.0.5 41
  changes in version 4.20 70
  changes in version 4.30 57
  changes in version 4.40 41
  deduction options 10
  direct deposit 57
  enhancements in 4.50 9
  import jobs 10
  imports 10
  recalculate deductions 9
  reports 71
  taxes 70
PEP 4
  period-end processing, General Ledger 90
  physical count changes 36
  printer, report and form setting 5
  printing 59
Product Enhancement Program 4
Purchase Order
  auto generate 11, 17
  auto generate options 12
  changes in version 4.40 41
Purchase Order (continued)
changes in version 4.50 17
data entry 11, 43
enhancements in 4.50 11
global changes 41
options 42
period-end processing 44
printing 45
purchases history 43
registers and updates 45
renamed, removed, or moved tasks 17, 46
reports and forms 46
utilities 44

Sales Order (continued)
data entry 15, 47, 49
duplicate purchase order numbers 47
enhancements in 4.50 13
global changes 79
item pricing 14
job cost integration 81
job cost options 13
line item commission 14
lot/serial distribution 15
period-end processing 80
picking sheets 48
quick print options 48
renamed, removed, or moved tasks 49
reports 48, 80
security
credit card 8
in version 4.00 84
in version 4.50 17
requirement 17
Role Maintenance 24
roles 55
system 5
selection grids 54

R
Report Master
changes in version 4.30 57
changes in version 4.40 52
reports
Crystal Reports 85
General Ledger 91
global 54
retired modules
in version 4.00 93
in version 4.20 72
in version 4.40 53
in version 4.50 18
RMA
changes in version 4.10 79
changes in version 4.40 47
renamed, removed, or moved tasks 47, 79
roles, maintaining 55

S
Sage ERP MAS Desktop 22, 58, 83
Sage Web Engine 33
sales history 79
Sales Order
changes in product update 4.40.0.1 47
changes in version 4.10 79
changes in version 4.40 48

Value field 54
Visual Integrator
changes in version 4.00 92
changes in version 4.10 81
changes in version 4.20 71
changes in version 4.30 57
changes in version 4.40 49
data dictionaries 49, 57, 71, 81, 92

Work Order
changes in version 4.40 52
file layouts 52
renamed, removed, or moved tasks 52

Quarterly 941 Printing 41

REPORT MASTER
changes in version 4.30 57
changes in version 4.40 52
reports
Crystal Reports 85
General Ledger 91
global 54
retired modules
in version 4.00 93
in version 4.20 72
in version 4.40 53
in version 4.50 18
RMA
changes in version 4.10 79
changes in version 4.40 47
renamed, removed, or moved tasks 47, 79
roles, maintaining 55

Security
credit card 8
in version 4.00 84
in version 4.50 17
requirement 17
Role Maintenance 24
roles 55
system 5
selection grids 54

URL, maintaining 62
utility, recalculate amounts 6, 7

Visual Integrator
changes in version 4.00 92
changes in version 4.10 81
changes in version 4.20 71
changes in version 4.30 57
changes in version 4.40 49
data dictionaries 49, 57, 71, 81, 92