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Introduction

Release information
Along with this User's Guide, see the following documentation for additional information 
that will help you install and use version 24.1:

 l The Installation Checklist contains a brief description of the steps involved in 
upgrading your software.

 l The Important document contains critical topics.

 l The Release Notes provide details about new features, resolved issues, and known 
issues.

You can access a complete library of supported product documents. 

About this guide
This User's Guide is designed to help you learn about installing the software. It also 
contains information about systems, security, ODBC, and Crystal Reports.

Conventions used in this document

This document uses the following conventions:

 l The names of windows, fields, and other features displayed by the software are bold.

 l Text that you type into the windows is blue, as in the following example:
Type Miscellaneous.

 l Names of keys are shown in capitals; for example, ENTER, TAB. A plus sign (+) 
between two key names indicates that you should press both keys at the same time; 
for example, SHIFT + TAB.

 l The names of buttons that you can click with your mouse are bold and enclosed in 
brackets; for example, [OK] and [ Post].
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Tip: Helpful information to make your experience better.

Note: Additional information of interest, such as information not included in steps.

Caution! Information that can help you avoid a costly or time-consuming error.

Important! Information that is of critical importance.

Menu paths

In this document, menu paths show you the steps required to start a task, such as:
        PR: Tools > Download Taxes

To follow this path, open the Payroll module. From the Tools menu, select Download 
Taxes.

Support and assistance

Online help

Each Sage 300 Construction and Real Estate application includes online help, which 
provides answers to your questions about procedures as well as items in the windows.

To access the online help in Sage 300 Construction and Real Estate:

 l In a window, click the [Help] button, click   (the Help button), or press F1 to display 
the help topic for that window.

 l In an application or Desktop, select Help > Help Topics.

Tip: From Desktop, you can access the online help for an application by clicking 
Applications, clicking the name of the application, and then clicking Help  > Help 
Topics in the list of menu items for that application.

To aid you in finding the information you need, the online help includes the following tabs:

 l Contents tab with an outline of the help with links to the help topics.

 l Index tab with keywords that link to help topics related to that keyword.
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 l Search tab or Search text box, where you can type text and click [Search] to locate 
that text in the help topics.

Technical assistance

When you need more assistance, visit Sage Customer Resources, Sage 
Knowledgebase, Sage City, the Product Documents website, Live Chat, or Online Case 
submission.

Training

Sage University offers live and recorded online training sessions to help you get the most 
out of your software. To access Sage University, either:

 l From an application, select Help > Web Resources >  Sage University.

 l From Desktop, select Help > Sage University.

 l From your browser, visit http://www.sageu.com/Sage300CRE.

Contact your business partner for local training.
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Chapter 1: System Requirements
For assistance in selecting the right business-class computers for your Sage 300 
Construction and Real Estate software, contact your authorized business partner. For 
information about  system environments, see "Chapter 4: System Guidance" on page 30.

To install and use Sage 300 Construction and Real Estate  version 24.1, your server and 
workstations must have Internet access for Sage entitlement and Pervasive licensing 
requirements.

Refer to the System Requirements article in the Sage Knowledgebase  for information 
about:

 l Hardware requirements

 l Supported operating systems

 l Software requirements

This chapter includes the following sections:

 l Privilege settings required for installation and use (the next section)

 l "Compatible versions" on page 7

 l "Supported upgrade paths" on page 8

 l "Data file upgrades" on page 9

Privilege settings required for installation and use
The following sections describe the access rights you need to successfully install and use 
Sage 300 Construction and Real Estate.

Elevate permissions

You must elevate your permissions before upgrading Sage 300 Construction and Real 
Estate.
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You can usually start a program with elevated privileges by right-clicking the application 
and selecting Run as Administrator. In Sage 300 Construction and Real Estate, the 
application is usually installed in the following path: /Program Files (x86)/Sage 
Timberline Office/Accounting.

During certain installation tasks, you will receive another prompt to elevate your 
privileges. If you do not acknowledge each prompt within two minutes, the installation 
process will quit the task. If this occurs, you will receive a separate prompt asking you to 
retry the task. Click [Retry] and then elevate your privileges at the prompt.

Full control of specific files and folders required

You must have full control access rights to all folders or shares that contain Sage 300 
Construction and Real Estate program files and data files.

To use Sage 300 Construction and Real Estate, you must have full control of the following 
files and folders on your file server, terminal server, and workstations that have Sage 300 
Construction and Real Estate installed. Make sure that your system administrator also 
gives you full control of all the subfolders and files.

Required folders 
and files

Location and specifications

Program Files (86) 
\Timberline Office

This folder is located on the server, terminal server, and 
workstations where you installed Sage 300 Construction and 
Real Estate. It is the default installation location for Sage 300 
Construction and Real Estate. However, depending on your 
system configuration, your company may have renamed this 
folder or installed it to a different location.

[Drive]:
\Users
\[username]

This folder is located on the workstation or terminal server 
where you use Sage 300 Construction and Real Estate.Sage 
300 Construction and Real Estate installs necessary files to this 
folder and requires that the user has full control of it. Typically, 
the user has full control of this folder by default.

Locations of folders and files                 
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Required folders 
and files

Location and specifications

Company data folder
Typically, the data folder is located on the server where you 
installed Accounting and Management Products.

[Drive]:
\ProgramData
\Sage
\Timberline Office

This folder is located on the server or host machine where you 
use Accounting and Management Products. This folder must be 
shared.  The installer creates this shared folder and the 
appropriate permissions to this folder as well as its subfolders.

Note: Some  of these folders may be hidden. To view them, open Windows Explorer, 
click the View tab, and then select the Hidden items check box.

Full control of and read access to specific registry keys required

To use Sage 300 Construction and Real Estate, you must have full control of the 
following Windows registry key on your file server, terminal server, and workstations that 
have Sage 300 Construction and Real Estate installed. Make sure that your system 
administrator also gives you full control of all subkeys.

 l HKEY_CURRENT_USER

 l HKEY_Local_Machine\Software\Wow6432Node

 l HKEY_Local_Machine\Software\ODBC

 l HKEY_Local_Machine\Software\Pervasive Software

 l HKEY_Local_Machine\Software\Timberline

Caution! Incorrectly editing the Microsoft Windows registry may severely damage 
your system. Sage is not responsible for damage to your system caused by 
editing the registry. Before making changes to the registry, contact your system 
administrator for assistance and make a backup copy of all valued data. System 
administrators should see Microsoft Registry Editor Help topics for detailed 
instructions.
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Compatible versions
The following table shows which product versions are compatible, which is partly based 
on the Crystal Reports runtime SP they use. If you do not use compatible versions, you 
may not be able to run Crystal reports.

Product / Component   Version Version

Sage 300 Construction and Real Estate 24.1 23.1 22.1, 22.2

Sage Estimating (SQL) 23.1, 22.1* 22.1*, 21.1* 22.1, 21.1

Sage Fixed Assets

2018.1, 
2019.1, 
2020.1, 
2021.1, 
2022.1***, 
2023.1****

2018.1, 
2019.1, 
2020.1, 
2021.1, 
2022.1***, 
2023.1****

2018.1, 
2019.1, 
2020.1, 
2021.1, 
2022.1***, 
2023.1****

Crystal Reports runtime SP used by these 
products

SP22***, 
SP25 64-
bit**,                           
SP30****                        

SP22***, 
SP25 64-
bit**,                           
SP30****                        

SP22***

Compatible product versions                     

*Sage Estimating 22.1 and earlier does not support Windows 11 or Windows Server 
2022. Do not upgrade to Windows 11 or Windows Server 2022 if Sage 300 Construction 
and Real Estate and Sage Estimating are integrated on your system.

**Sage Estimating 21.1 and higher uses Crystal Reports SP25 64-bit.

*** Sage Fixed Assets 2018.1 to 2022.1 use Crystal Reports runtime SP21.  Although 
Crystal reports seem to run correctly when you  run these versions of Sage Fixed Assets 
on the same machine as Sage 300 Construction and Real Estate 18.2 and later or Sage 
Estimating (SQL) 18.12 or later, we recommend that you run Sage Fixed Assets on a 
different machine.

****Sage Fixed Assets 2023.1 uses Crystal Reports SP 30.
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Support for Crystal Reports 2020

Crystal Reports 2020 is now available as a 64-bit application which requires the use of 
64-bit DSNs. Sage 300 Construction and Real Estate version 24.1 and later supports 
Crystal Reports 2020 with the inclusion of a 64-bit ODBC driver, administrator, and 
support for existing 32-bit User Defined Libraries (UDFs).   Earlier 32-bit versions of 
Crystal Reports are still supported in Sage 300 Construction and Real Estate. 

 

Caution! Sage Estimating (Pervasive) - There is no version of Sage Estimating 
(Pervasive) that is  compatible with Sage 300 Construction and Real Estate 
version 22. However, you can use a compatible version of Sage Estimating 
(SQL) with Sage 300 Construction and Real Estate version 22.

Caution! Document Management - There is no Sage Document Management 
version 18.3, 18.4, 20, or 22. Document Management was retired on December 
31, 2019; see Knowledgebase article 91616 for more information about the 
retirement. 
You can still run Document Management in a standalone environment; see 
Knowledgebase article 91608 for more information. DO NOT install Sage 300 
Construction and Real Estate Accounting version 22 on the same machine as 
Document Management.

Supported upgrade paths
If you are on Sage 300 Construction and Real Estate (Accounting) version 20.5, or 18.1.3 
(Australia Release) or later, you can upgrade directly to 24.1.

If you are on  any other version 18, we recommend that you upgrade to 20.5 before 
upgrading to version 24.1.

 1.  Back up your data, upgrade to 20.5, and upgrade your data (including Inventory, 
Purchasing, and Service Management data).

 2.  Back up your data again and upgrade to version 24.1.
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Note: If you are on a version that is earlier than 16.1, we recommend that you 
contact your Business Partner or Sage Expert Services for assistance.

Data file upgrades
After you upgrade to 24.1, upgrade all Accounting and Management application data 
files.

You can upgrade the data files for Accounting applications (except for Service 
Management, Purchasing, and Inventory) from Sage Desktop. In the Applications pane, 
select Common Tasks > Tools > Upgrade files.

Caution! Service Management, Purchasing, and Inventory data files upgrade the 
first time you open those applications. You must open the application and perform 
the upgrade at the server. Upgrading this data on a workstation will incorrectly set 
DSNs and cause data access errors after the upgrade is performed. When 
running for the first time after an install or upgrade, run Service Management 
before Inventory on the server.

9
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Chapter 2: Install Sage 300 Construction 
and Real Estate
Version 24.1 includes application fixes and introduces an updated Sage SQL Replicator.

Important! If you use third-party products that integrate with Sage 300 
Construction and Real Estate, check with the vendor of the product to ensure their 
product is fully compatible with this release. We do not support rolling Sage 300 
Construction and Real Estate back to a previous version and do not recommend 
it.

A. Before you install
 1.  Review the following documents: 

 l Refer to the System Requirements article in the Sage Knowledgebase 

 l Read the Release Notes for more details about this release of Sage 300 
Construction and Real Estate.

 l Review the Installation Checklist.

 2.  Have your Registration Name and Sage Client ID (Account ID) handy. The ID is a 
10-digit number that starts with 4. See Knowledgebase article 86829 for more 
information.

Also review the number of uses your company has purchased for each application. 
You no longer enter activation codes when you install. Sage 300 Construction and 
Real Estate automatically accesses the licenses for the various applications for 
which your company is entitled. You can check this by logging onto the Sage 
Customer Portal; see Knowledgebase article 87017 for more information. If you 
need to purchase additional uses, contact your authorized Sage business partner or 
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your Sage customer account manager at 1-800-858-7095 (or email 
CREsales@sage.com). You can use the new License Administrator tool to manage 
the uses of these licenses.

 3.  Run File Doctor on all files in your current version before upgrading to the next 
version. Even if you do not receive a corrupt file message, there may be issues File 
Doctor finds that it will not be able to fix after upgrading to version 24.1.

 4.  Create a complete backup of all Sage 300 Construction and Real Estate data and 
program files.

 5.  If needed, install the appropriate operating system service pack, make sure 
sufficient hard disk space is available, and verify that your server and workstations 
meet all other hardware and software requirements.

If you are upgrading from 9.7 or earlier, the upgrade to 9.8 may cause file sizes to 
increase up to 200% of the current size of your data. Be sure to allow for increased 
disk space requirements when you upgrade. Do not install Sage 300 Construction 
and Real Estate products unless you have sufficient hard disk space available.

 6.  Make sure that you have full control of the required folders, files, and registry keys 
on your file server, terminal server, and workstations that will have Accounting and 
Management Products installed. For a list of the required folders, files, and registry 
keys for your operating system, see "Privilege settings required for installation and 
use" on page 4.

 7.  Quit all programs and services for the duration of the installation. This includes 
programs that may be running in the background, such as anti-virus, email, and 
backup programs.

Important! Before installing Sage 300 Construction and Real Estate close your 
anti-virus programs.  You will need to verify that you have disabled your anti-virus 
software during installation.

 8.  For certain operating systems, you must elevate your permissions  before installing 
version 24.1. During certain installation tasks, you will receive a prompt to elevate 
your privileges. If you do not acknowledge each prompt within two minutes, the 
installation process will quit the task. If this occurs, you will receive a separate 
prompt asking you to retry the task. To retry the task, click [Retry] and then elevate 
your privileges at the prompt.
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 9.  Verify the upgrade path (see page 8). If you are upgrading from an older version, 
you may need to install several versions to become current.

B. Install to a server or stand-alone computer
If you plan to use Sage SQL Replicator or any mobile applications, install Sage 300 
Construction and Real Estate on a machine connected to a domain, but this machine 
should not be the domain controller.

Important! Do not install Sage 300 Construction and Real Estate unless the 
machine has sufficient hard disk space available. Refer to the System 
Requirements article in the Sage Knowledgebase .

Note: The installation process may restart your server or stand-alone computer 
several times.

 1.  At the server or stand-alone computer, log on with full administrative rights. Full 
administrative rights are defined as write access to the Windows registry and all 
folders on the computer (including rights to the root of all hard drives). If you are 
unsure whether you have full administrative rights, ask your network administrator 
for assistance. Alternately, you can ask your network administrator to log on with the 
network administrator ID before you start the installation.

 2.  Follow the instructions  in the version 24.1 download article.

 3.  Open the folder with the appropriate version number and double-click Install.exe to 
begin the installation process.

 4.  In the Welcome window, click Next.

 5.  Follow the on-screen instructions to make the following selections. Click Next after 
each selection.

 l Accept the License Agreement.

 l Enter your company's  Registration name, Client number, and Software 
Country.

 l Choose the Industry Type.

 l Choose the Destination for your Sage 300 Construction and Real Estate files.
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Note: Beginning with 17.1 Rev 4, you no longer enter activation codes. Sage 300 
Construction and Real Estate automatically accesses the licenses for the various 
applications for which your company is entitled.

Before you click [Install], note the following:              

 l If you receive a firewall warning message during the installation of the 
Pervasive database engine, work with your network administrator to allow the 
Pervasive database engine to communicate through your firewall software. For 
example, if a Microsoft Windows Firewall Security Alert window lists the 
Database Service Manager by Pervasive Software Inc., confirm with your 
network administrator that you want to proceed. Then, select Unblock this 
program and click [OK].

 l You may receive a similar message during the installation of Sage Service 
Host. Follow the same steps to proceed.

 l If you are required to restart your computer, remember to stop antivirus, 
backup, and other services that may have automatically started again after you 
restart your computer.

 6.  Click [Install] to begin installing Sage 300 Construction and Real Estate.

 7.  At the conclusion of the installation, you will be prompted to restart your computer. 
Restart and then log on with the same user name that you used when you installed 
(user name must have full administrative rights).

Important! Wait until you see the All configuration tasks for Sage 300 
Construction and Real Estate completed successfully message. It may take a 
few minutes before you see the message. Do not attempt to start any Sage 300 
Construction and Real Estate applications until after you receive this message.

Note: Some of the data and report folders and files will be hidden by default. At 
the end of the installation, you can view these hidden files and folders. To view 
them, open Windows Explorer, click the View tab, and then select the Hidden 
items check box.
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Automatic creation of Timberline Office Share

The installation automatically creates a shared Timberline Office folder at the following 
location on the server if one does not already exist: 
[Drive]:\ProgramData\Sage\Timberline Office

Read and write permissions are automatically granted to Everyone for this folder. If the 
Timberline Office folder is already present and shared, the installation will skip this step. 
The system will not change any permissions you have already set up.

You will connect your workstations to the shared Timberline Office folder in Step C.

C. Install to a workstation connected to a network
After you install to a server ( as described in Step B), you can install to your workstations 
or to a computer that functions as a terminal server.

Important! Do not install Sage 300 Construction and Real Estate unless the 
machine has sufficient hard disk space available. Refer to the System 
Requirements article in the Sage Knowledgebase .

Note: The installation process may restart your server or stand-alone computer 
several times.

Installing to a terminal server                              

If you are installing to a computer that will be used as a terminal server, follow the 
preceding installation steps.  

If your terminal server does not host Sage 300 Construction and Real Estate programs 
and data files, after installing, verify that the Pervasive.SQL database service on the 
terminal server uses an account with access to all Sage 300 Construction and Real 
Estate program and data files on the server. 

To verify your account and access rights:

 1.  Click the Start icon, select the Windows Administrative Tools program group, and 
select Services.
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 2.  In the Services window, right-click the Pervasive.SQL service and select 
Properties.

 3.  On the Log On tab, select Use this account. 

Work with your network administrator to enter an account that has the access rights of the 
Local System account and access to all Sage 300 Construction and Real Estate program 
and data files on the file server; for example, a domain administrator account.

Note: If you use an account with insufficient access rights, you may receive a 
Pervasive status code 94 or 3119 error.

Installing to a workstation

Tip: If you have a large number of workstations, you can use a script to silently 
install the software on client workstations. For more information, see 
Knowledgebase article KB 83952.

 1.  At the workstation, log on with full administrative rights. Full administrative rights are 
defined as write access to the Windows registry and all folders on the computer 
(including rights to the root of all hard drives). If you are unsure whether you have 
full administrative rights, ask your network administrator for assistance. Alternately, 
you can ask your network administrator to log on with the network administrator ID 
before you start the installation.

 2.  Right click the Start icon and select Run.

 3.  In the Run window, click [Browse], browse to the \\[Server name]\Timberline 
Office\9.5\Accounting\WinInst\Install.exe folder on the server, and then double-
click Install.exe.

 4.  In the Welcome window, click Next.

 5.  Follow the on-screen instructions to make the following selections. Click Next after 
each selection.

 l Accept the License Agreement.

 l Choose the Destination for your Sage 300 Construction and Real Estate files.

 6.  In the Installation window, click Install.

 7.  At the conclusion of the installation, when you see the prompt, restart your 
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workstation.

 8.  Repeat steps 1–7 for each workstation.

Note: Some of the data and report folders and files will be hidden by default. At 
the end of the installation, you can view these hidden files and folders. To view 
them, open Windows Explorer, click the View tab, and then select the Hidden 
items check box.

D. Upgrade data files
If you upgraded to a new version of Sage 300 Construction and Real Estate, read and 
follow the information in this section. 

If this is a first-time installation, skip to "F. Install Crystal Reports Designer (optional)" on 
page 19.

Caution! Service Management, Purchasing, and Inventory data files upgrade the 
first time you open those applications. You must open the application and perform 
the upgrade at the server. Upgrading this data on a workstation will incorrectly set 
DSNs and cause data access errors after the upgrade is performed. When 
running for the first time after an install or upgrade, run Service Management 
before Inventory on the server.

Prepare to upgrade files

For optimal performance, we recommend that you upgrade your data from the server. If 
you prefer to upgrade your data from a workstation instead, you must ensure that the 
same version and update are installed on both the server and the workstation before 
starting the Upgrade Files process.

 1.  Back up your data files.

 2.  Make sure all users have closed Sage 300 Construction and Real Estate 
applications.

 3.  Log in to Sage 300 Construction and Real Estate as the application administrator.
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 4.  Open Sage Desktop, select your company, and click [OK]. If you do not see your 
company:

 a.  Click [Specify Folders].

 b.  In the Specify Data Folders Path window, click [Browse], select the UNC 
path to the folder that contains your Sage 300 Construction and Real Estate 
data, and click [OK].

 c.  Select your data folder from the Specified Folders area and click [OK].

 d.  Select your company from the list of companies in the Select Company 
window and click [OK].

 5.  If you use File Locations and the path is not accessible from the server (for example, 
you use mapped drives instead of specific paths), modify the locations to point to 
files on the local hard drive of your server.

Tip: We recommend that you convert your mapped drives to the equivalent UNC 
paths using the following instructions. If you convert now, you will not have to 
perform this step during future upgrades, and you can skip to "Restore file 
locations" on page 18.

 a.  From Sage Desktop in the Applications pane, select Common Tasks > File 
> Company Settings > File Locations.

 b.  In the File Locations window, look for network paths in the Data Folder 
column.

 c.  If you have network paths, write them down (you need this information when 
you restore the file locations later) and then modify each network path to 
point to the appropriate file on the local hard drive of your server. 

 d.  Click [OK] to close the File Locations window.

 6.  Repeat steps 4 and 5 for each company data folder you will upgrade.             

Upgrade files

Files cannot be in use while they are being upgraded.

 1.  In Sage Desktop in the Applications pane, select Common Tasks > Tools > 
Upgrade files.

 2.  In the Upgrade Files - Print Selection window, select the data folders to upgrade:
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 l Current data folder: Upgrades only the files in the data folder in which you 
currently work.

 l All data folders: Upgrades files in all data folders that appear in the Open 
Company window. This may include data folders on other drives. The upgrade 
process can take a long time if you have many data folders.

Note: We recommend that you upgrade all data folders after you install version 
24.1.

 3.  Click [Start].

 4.  In the Print File Selection window for File name, type a name for the upgrade 
report file, and then click [Save].
The upgrade process begins in the background.

 5.  When the process is complete, review the report.

Restore file locations

If you use UNC paths,  you can skip this step now and in future upgrades.

If you use mapped drives instead of UNC paths and the modified file locations and path 
are not accessible from the server, restore the previous file location entries:

 1.  From Sage Desktop in the Applications pane, select Common Tasks > File > 
Company Settings > File Locations.

 2.  In the File Locations window, find the file locations you changed previously and 
change them back to the original network path.

 3.  Click [OK] to close the File Locations window.

E. Upgrade custom Crystal Reports designs
If you upgraded from version 13.1 or earlier and have custom Crystal Reports designs, 
you must upgrade them before they can be used in Sage 300 Construction and Real 
Estate by running the Upgrade Crystal Reports Tool.

To access the tool, click the Start icon, select the Sage Administration program group, 
right-click Upgrade Crystal Reports, and then select Run as administrator.

For more information, click   (the help button) in the tool's window.
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F. Install Crystal Reports Designer (optional)
If you own Crystal Reports Designer, you must install Crystal Reports For Sage 2013 
SP2, which is compatible with Sage 300 Construction and Real Estate versions 14.1 
through 24.1. If you have already installed it, you can skip this step. For more information 
about setting up Crystal Reports with Sage 300 Construction and Real Estate, see 
"Chapter 7: Crystal Reports" on page 89.

Caution! Crystal Reports For Sage 2013 SP2 software only runs on Windows 7 SP1, 
Windows Server 2008 R2, or higher operating systems (not Windows Vista).

To install Crystal Reports For Sage 2013 SP2:

 1.  Ensure all Windows programs are closed.

 2.  On the server or workstation where your report designs are kept, open the email 
with the download information, click the download link, run the download, and select 
the folder for the download files.

 3.  Click [Yes] to run the setup wizard.

 4.  In the Crystal Reports For Sage 2013 SP2 setup window, click [Next] and follow 
the on-screen instructions to run the installation.

 5.  When you see the message that Crystal Reports For Sage 2013 SP2 has been 
successfully installed, click [Close].

G. Install SQL Server and Sage SQL Replicator 2.0 
(optional)
Sage SQL Replicator 2.0 is an improved version of the replicator that was introduced in 
Version 17.1. Use the replicator to copy your Pervasive data into a SQL database, which 
enables faster data access for reports. The data is also available for mobile applications, 
such as Sage Mobile Dashboard, Sage Mobile Reports, Sage Field Operations, and 
Sage Construction Project Center.

For detailed information, see the Sage SQL Replicator 2.0 Setup Guide. 
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Important! If you used an earlier version of Sage SQL Replicator, follow the steps in 
Knowlegebase article 104917 (Preparing your SQL data prior to upgrading to 
Replicator 2.0) before you install.

After you install Sage 300 Construction and Real Estate Version 20 or 21, you can install 
Sage SQL Replicator 2.0:

 1.  Use the Sage Universal SQL Installer to install an instance of the SQL database to 
hold your data.

Note: The size of the replicated data is larger than the original Pervasive data 
because replicator adds views and indexes the data. To determine if you can use 
SQL Server Express, add the size of the PVData, POIV Data, SM Data folders 
and the master.qxm file together for each company. If the sum is greater than 6 
GB, you must use full SQL Server.

 2.  Install SQL Replicator 2.0 by downloading the SageSQLReplicator.exe file and 
running the installation on your Sage 300 Construction and Real Estate Accounting 
server.

 3.  Configure the replicator. First, open the System Administrator tool (found in the 
Sage Administration program group). Next, click   (the Help button) and follow the 
instructions in the Replicating your company's data topic to connect and configure 
the replicator.

 4.  If your company plans to use any of the mobile applications, click [Link to Mobile].

Important! Because Sage SQL Replicator now has a separate installer, future updates 
to the replicator can be installed without having to install a new version of Sage 300 
Construction and Real Estate.

H. After you install
Some of the data and report folders and files will be hidden by default. At the end of the 
installation, you can view these hidden files and folders. To view them, open Windows 
Explorer, click the View tab, and then select the Hidden items check box.
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Elevated permission levels after installing

If you install Service Management (SM), Purchasing (PO), and Inventory (IV) on 
Windows 7, Windows Server 2008 R2, or later, you should elevate your permission level. 
Crystal Reports may not run correctly in these applications if the permission level is set 
too low. If you encounter an error message when starting SM, PO, or IV for the first time 
after installation, close the application, elevate your permission level, and start the 
application again. To do this:

 1.  Close the Pervasive Workgroup engine (Right-click the Pervasive Database icon in 
the systems tray and select Stop Engines and Exit.)

 2.  Navigate to SM.exe, PO.exe, or IV.exe. The default location for these files is 
C:\Program Files (x86)\Timberline Office\Shared.

 3.  Select Run as Administrator.

 4.  Open each company data set at the server.

 5.  Repeat these steps for each company data folder.

If you have Purchasing, Inventory, or Service Management data in 
Program Files

If, before upgrading, your company data folder was inside the Program Files folder in 
Purchasing (PO), Inventory (IV), or Service Management (SM), follow these steps at the 
server to move your data to a shared location and  make the data available to your users.

 1.  Move the data files to a shared location. The default shared location is:
\\[Server name]\Timberline Office\Data

 2.  At the server, remove all Pervasive System DSNs and User DSNs for each Sage 
300 Construction and Real Estate installation:

 a.  Click the Start icon, select the Windows Administrative Tools program 
group, and select ODBC Data Sources (32-bit).

 b.  In the ODBC Data Source Administrator window on the System DSN tab, 
select the first Name associated with a Pervasive ODBC Engine Interface 
Driver, and then click [Remove]. 

 c.  Repeat  this process to remove each Name associated with a Pervasive 
ODBC Engine Interface Driver.
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 d.  On the User DSN tab, select the first Name associated with a Pervasive 
ODBC Client Interface Driver, and then click [Remove]. 

 e.  Repeat this process to remove each Name associated with a Pervasive 
ODBC Client Interface Driver.

 f.  Click [OK].

 3.  At the server, delete the DBNAMES.CFG file:

 a.  From \\[Server name]\WINDOWS, right-click DBNAMES.CFG, and select 
Delete.

 b.  In the Confirm File Delete window, click [Yes].

 4.  Add each company to the company list:

 a.  In TS-Main, select File > Open Company.

 b.  Click [Specify Folders].

 c.  Click [Browse] and browse to the shared location from step 1.

 d.  Select a folder and click [OK].

 e.  At the server, open the SM, PO, or IV applications for each Sage 300 
Construction and Real Estate company.

 f.  Repeat these steps for each company folder that you want to add.

 5.  If you use security, give the appropriate users rights to the companies; in Sage 
Desktop, select Options > Security Administration, click User Setup, and then 
click Companies.             

I. Final steps
 1.  Restart all programs and services that you shut down for the installation.

 2.  Review the following guidelines for custom reports or custom third-party 
applications.

 l If you have custom reports that use the Crystal Reports format, be sure to open 
these reports in Crystal Reports Professional, select Database > Verify 
Database, and then save the report. 

 l If you use Inventory, Purchasing, or Service Management custom Crystal 
reports, see page 126 or page 132 for special information and detailed 
instructions about upgrading these reports.
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 l As with any release, database changes in Sage 300 Construction and Real 
Estate applications may affect your custom report designs or custom third-party 
applications. Contact your authorized business partner to discuss any issues 
relating to custom reports or third-party applications.
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Chapter 3: Server Migration
The server and data migration tool enables you to easily copy and transfer your Sage 300 
Construction and Real Estate Accounting data and customizations to a new server. Items  
transferred include:

 l Company data

 l Security settings

 l Custom fields

 l User formulas

 l Reports and reports menu

 l Inquiries

 l Macros

 l Attachments

You can select which companies you want to copy, giving you the flexibility to include all 
companies or only selected companies. 

Tip: Click [Help] in any of the server migration windows for more information.

Things to know before you begin
 n You must first install Sage 300 Construction and Real Estate Accounting version 

24.1 on your new server to access the server migration tool.

 n The server migration process copies data from the old server to the new server. Data 
is not removed from the old server. 

 n You can migrate data from Sage 300 Construction and Real Estate version 9.6 or 
later.
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 n You must have administrative rights to the new server and a minimum of read 
permission to the old server.

 n Your new server must have enough disk space to hold the information from the old 
server.

 n If you added reports to the Report menus on your old server using mapped drives, 
create identical drive mapping for reports on your new server before performing the 
migration.

 n Macros that you want to migrate must be in the Company folder on the old server 
prior to migration. You can copy the macros to the Company folder, if necessary. If 
the macros are not in the Company folder, you will need to recreate them on the new 
server after the migration.

 n If you are using File Locations (File>Company Settings>File Locations) and the 
path to the file points to the old server location, you should update this path prior to 
upgrading your data. During a data upgrade, the program follows the path selected in 
File Locations to upgrade the data file. If that path is the old location, data files in the 
old location/server are upgraded instead of data in the new location/server.

 n We recommend that you perform a test migration, then validate that all of your data, 
reports, macros and settings work properly on the new server. You can then stop 
work on the old server and perform the migration again with the latest files.

 n The migration will overwrite companies and security on the new server. You should 
perform the migration before setting up companies and security (for example, before 
setting up a new job).

 n Most of the migration tasks are performed in a few minutes. However, moving 
attachments can take more time. If you have many attachments, consider 
transferring them during non-business hours.

After you migrate your server, you must uninstall and then reinstall Sage 300 
Construction and Real Estate on all workstations so they interact with the data on the new 
server instead of the old.

Recommended procedure

Preparing your new server

If you have not already installed and run Sage 300 Construction and Real Estate, do so 
now.

25



User's Guide

 1.  Install Sage 300 Construction and Real Estate Accounting version 24.1 on your new 
server.

 2.  Click the Start icon, select the Sage Administration program group, and select  
Sage System Verifier.

 3.  In the Sage System Verifier window, click [Scan System].

 4.  When the system verification has completed, click [Close].

 5.  Set up administrative rights on the new server.

 6.  Set up existing or new printers on your new server. The TS PDF printer cannot be 
the only printer on your system and cannot be selected as the default.

Migrating your server

 1.  On the new server, open your program files folder and \Timberline Office\Shared, 
and then double-click Sage.STO.ServerMigrator.exe.

 2.  In the Server Migration Tool window for Old server location, type the path or 
browse to the location where Sage 300 Construction and Real Estate installed on 
your old server. 
For example: \\oldservername\Timberline Office\9.5

 3.  Verify or change the server migration log path (on the new server) for Log file path. 
For example:
 \\newservername\Timberline 
Office\9.5\Accounting\Migration\ServerMigrationLog 1.pdf

 4.  Click [Validate] to perform a test of the files to be transferred.

 5.  When you see the Validation complete message and the validation is successful, 
click [Migrate].

 6.  When you see the Migration complete message, view the server migration log (that 
you set up in Step 3) to ensure that all files were transferred correctly.

Migrating your data folders

 1.  On the new server, open your program files folder and \Timberline Office\Shared, 
and then double-click Sage.STO.ServerDataMigrator.exe.

 2.  In the Server Data Location window, verify or change the data folder migration log 
name and path (on the new server) for Log file path. For example:
\\newservername\Timberline 
Office\9.5\Accounting\Migration\ServerDataMigrationLog 1.pdf
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 3.  Select the companies whose data you want to copy.

 4.  Click [Validate] to perform a test of the files to be copied.

 5.  When you see the Validation complete message and the validation is successful, 
click [Migrate data folders].

 6.  When you see the Migration complete message, view the server data migration log 
(that you set up in Step 2) to ensure that all files were copied correctly.

Migrating your macros

Any macros that you have must be in the Company folder on the old server prior to 
migration. You can copy the macros to the Company folder, if necessary. If the macros 
are not in the Company folder, you will need to recreate them on the new server after the 
migration.

 1.  If the Server Data Location window is not already open on the new server, open 
your program files folder and \Timberline Office\Shared, and then double-click 
Sage.STO.ServerDataMigrator.exe.

 2.  In the Server Data Location window, verify or change the macro migration log 
name and path (on the new server) for Log file path. For example:
 \\newservername\Timberline 
Office\9.5\Accounting\Migration\MacroMigration.pdf

 3.  Select the companies whose macros you want to copy.

 4.  Click [Migrate Macros].

 5.  In the Macro Printer List window, verify the printers that you want to use are listed. 
Click [Change] if you want to select different printers.

 6.  Click [Migrate Macros].

 7.  When you see the Macro migration complete message, view the macro migration 
log (that you set up in Step 2) to ensure that all macros were transferred correctly.

Migrating your attachments

Note: Migrating attachments can take some time. If you have many attachments, 
you may want to consider migrating them during non-business hours.

 1.  If the Server Data Location window is not already open on the new server, open 
your program files folder and \Timberline Office\Shared, and then double-click 
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Sage.STO.ServerDataMigrator.exe.

 2.  In the Server Data Location window, verify or change the attachment migration log 
name and path (on the new server) for Log file path. For example:
 \\newservername\Timberline 
Office\9.5\Accounting\Migration\AttachmentMigration.pdf

 3.  Select the companies whose attachments you want to copy.

 4.  Click [Migrate attachments].

 5.  In the Attachment Paths window, review the table showing the old and new 
locations for each set of attachments. You can change the new location.

 a.  If you want to change the new attachment path for all rows to the default 
location on the new server, click [Use default location].

 b.  If you want to replace portions of the new paths in specific rows, select the 
check box in front of the rows that you want to change, click [Replace 
selected], type the old text (for Find), type the new text (for Replace), and 
then click [OK].

 c.  If you want to change the new path for one row, either:

 l Click in the New attachment path column and type the new path.

 l Click [Change], specify the new path, and then click [OK].

 6.  When the rows display the desired new attachment paths, click [Migrate 
attachments].

 7.  When you see the Attachment migration complete message, view the attachment 
migration log (that you set up in Step 2) to ensure that all attachments were 
transferred correctly.

Updating your workstations

After you migrate your server, you must uninstall and then reinstall Sage 300 
Construction and Real Estate on all workstations so they interact with the data on the new 
server instead of the old.

 1.  On the workstation, uninstall the program by opening the Control Panel, selecting 
Uninstall a program, right-clicking Sage 300 Construction and Real Estate and 
selecting Uninstall.

28



 2.  Follow the instructions on page 15 for installing Sage 300 Construction and Real 
Estate on a workstation.

 3.  Repeat these steps for every workstation running Sage 300 Construction and Real 
Estate.
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Chapter 4: System Guidance

General information
Review the hardware and software requirements. For details about installing, see 
"Chapter 2: Install Sage 300 Construction and Real Estate".

Backups

We strongly recommend that you back up all Sage 300 Construction and Real Estate 
data files to external media daily.

Consider the following as you develop your backup plan:

 l Use Sage System Administrator to back up and restore your data files. This is 
especially important if you use Sage SQL Replicator. The File Tools backup and 
restore operations do not back up and restore the SQL data, which may result in data 
integrity issues.

 l Verify that when a folder is included in a backup, the subfolders are also included.

 l Schedule the backup during off-peak hours. All users must close Sage 300 
Construction and Real Estate before you back up files.

 l Always back up your entire Sage 300 Construction and Real Estate dataset. Do not 
perform incremental backups.

 l Back up all data and application files within the Sage folder: [Drive:]\Program 
Data\Sage

 l Review the backup to be sure all data has been included. Back up all data and files, 
even if they are outside the default folders.

Tip: To see a list of folders that are outside the current data folder, from  the 
Applications pane in Sage Desktop, select Common Tasks > File > Company 
Settings > File Locations.
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 l Store backup media in a secure location outside your building.

 l Test backups by restoring them to test folders. Environmental issues and files in use 
can affect the integrity of a backup. These tests are important because backup media 
may have a limited life and backup devices may malfunction.

Caution! When you test a backup, keep the restored data separate from your 
production data.

Important! Restoring your business data requires advanced knowledge of the 
Actian Pervasive, Microsoft SQL, and Sage 300 Construction and Real Estate file 
systems. We strongly recommend you undertake this process with a 
knowledgeable professional, such as your business partner, certified consultant, 
or Sage Customer Service representative.

Virus scanning

Do not actively scan Pervasive program files, Sage 300 Construction and Real Estate 
program files, or Sage 300 Construction and Real Estate data files for viruses during 
production hours.

Important! Scan these files at a time when they are not in use. For example, 
schedule a daily virus scan at night.

Actively scanning Pervasive program files, Sage 300 Construction and Real Estate 
program files, or Sage 300 Construction and Real Estate data files for viruses may cause 
Sage 300 Construction and Real Estate to run slowly or to close unexpectedly. Typical 
folders that contain files that you should not scan include:

 l Sage 300 Construction and Real Estate program files:
[Drive]:\Program Files\Timberline Office

 l Sage 300 Construction and Real Estate data files:
[Drive]:\TSData

 l Pervasive program files:
C:\Program Data\Pervasive Software
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Windows User Account Control (UAC) 

Sage 300 Construction and Real Estate is designed to work with the Windows User 
Account Control (UAC) security scheme. With Windows 7, Windows Server 2008 R2, and 
later, you cannot save a file to a folder to which you do not have read/write permissions 
assigned. If such an attempt is made, Windows security diverts your data to a copy of the 
data file or report and associates the copy with your user profile, thereby possibly 
compromising the integrity of your application. To prevent this, Sage 300 Construction 
and Real Estate applications present you with an error message if you try to save a file to 
such a location. See page 37 for more information about moving your data folders for 
compliance with UAC.

Accounting and Management products

 l New installations of Sage 300 Construction and Real Estate on Windows 7, Windows 
Server 2008 R2, or later operating systems will place data files in the 
Drive]:\ProgramData\Timberline Office folder. 

 l Upgrades to existing installations on Windows 7, Windows Server 2008 R2, or later 
require you to share the data folders and assign read/write permissions or move the 
folders to a shared location and assign read/write permission to the shared location.

Note: You can share the data files before installing the upgrade. You can move data 
folders after completing the upgrade installation. If you move your data files and you 
use File Locations (File > Company Settings > File Locations) to allow other data 
folders to access the folder's data files, be sure you update the locations using File 
Locations for each affected data folder.

If you install in a client/server environment, note that the WinInst folder and 
corresponding Install.exe file was moved in 9.5. The path to the WinInst folder is:
 [Drive]:\Program Data\\Sage\Timberline Office\9.5\Accounting\WinInst\Install.exe 

Hidden folders

Some folders may be hidden. To view them, open Windows Explorer, click the View tab, 
and then select the Hidden items check box.
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NTFS file compression

Do not use NTFS file compression on data or program files for Sage 300 Construction 
and Real Estate. Using Microsoft Windows NTFS file system to compress files causes 
Sage 300 Construction and Real Estate to run very slowly.

Terminal services

For terminal services:

 l Configure terminal services to maintain an operator’s session during connection 
breaks. This prevents a program from closing unexpectedly and helps preserve data 
integrity. To set up this aspect of Windows Terminal Services, use the Terminal 
Services Configuration program. For more information about using terminal services, 
see "Terminal services" on page 40

 l Do not use fast user switching. Sage 300 Construction and Real Estate does not 
support fast user switching on Windows 7 or later. 

Pervasive database engines

The Pervasive database engines provide access to Sage 300 Construction and Real 
Estate data files. To use Sage 300 Construction and Real Estate, users must have full 
control of the Pervasive installation folder and subfolders.

 l Do not use the Subst or Netdrv commands in windows. These commands may cause 
Pervasive status code 11 or 116 errors.

 l Do not exclusively use the NetBEUI network protocol. This protocol is not supported.  
If NetBEUI is your only network protocol, you must install TCP/IP before you install 
Sage 300 Construction and Real Estate. If no applications require the NetBEUI 
protocol, consult with a network technician about removing it.

Firewalls and Sage Service Host

Beginning with Sage 300 Construction and Real Estate version 9.5, the Sage Service 
Host uses TCP instead of named pipes for inter-machine communication. Sage Service 
Host is a Windows service that runs on Sage 300 Construction and Real Estate servers 
and workstations. This service facilitates communication between Sage 300 Construction 
and Real Estate applications.
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If you use Windows Firewall, you do not need to take any action, as Windows Firewall is 
configured during installation to work correctly with Sage 300 Construction and Real 
Estate. However, if you use a non-Windows firewall, you may need to manually adjust 
some settings to ensure proper performance.

Setting up Sage Service Host on firewalls other than Windows Firewall

If you use a firewall other than Windows Firewall, you may be prompted during 
installation that the Sage Service Host is attempting to access the internet or is 
attempting to act as a server. The Sage Service Host must be given permission to 
perform these types of activities.

If you need to manually set up this exception, make the following changes on every 
machine where Sage 300 Construction and Real Estate is installed:

 l Set up your firewall to allow an exception for the Sage Service Host. Refer to the 
Windows Firewall instructions below and your firewall documentation for specific 
instructions.

 l If you have other software that uses TCP ports 8101 and 8102, you may need to 
manually configure either the other software or the Sage Service Host to use different 
port numbers.

The Sage Service Host port numbers can be configured in the Sage.STO.9.5.xml 
file. This file is located in Documents and Settings\All Users\Application 
Data\Sage\LS1\ServiceHost\1.0\Configuration. If you need to change the default 
port numbers for Sage Service Host, this file should be changed on every machine 
on the network where Sage 300 Construction and Real Estate is being installed, 
including the accounting server.

Setting up Sage Service Host on a Windows Firewall

Windows Firewall is automatically configured during installation to work correctly with 
Sage Service Host. However, if you need to manually set up Sage Service Host to 
communicate on a Windows Firewall, do the following:

 l Open Windows Firewall and select the Exceptions tab. If Sage Service Host is not on 
the list, you can add it by selecting [Add Program], and then browsing to the 
following path: [Drive]: \Program Files\Common Files\Sage\LS1\ServiceHost\1.0\ 
Sage.LS1.ServiceHost.exe.
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 l By default, the exception is set for any computer on the network. You can adjust this 
setting by selecting [Change Scope]. 

 l If you have other software that uses TCP ports 8101 and 8102, you may need to 
manually configure either the other software or the Sage Service Host to use different 
port numbers.

The Sage Service Host port numbers can be configured in the Sage.STO.9.5.xml 
file. This file is located in Documents and Settings\All Users\Application 
Data\Sage\LS1\ServiceHost\1.0\Configuration. If you need to change the default 
port numbers for Sage Service Host, this file should be changed on every computer 
on the network where Sage 300 Construction and Real Estate is being installed, 
including the accounting server.
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Troubleshooting
This section contains answers to the following questions:

 l "If Sage 300 Construction and Real Estate stops responding during the workstation 
installation, how can I resolve this?"

 l "How do I move Accounting and Management products from one server to another?"

 l "Why am I getting an error message when I try to save data or reports?" on page 37

 l "I upgraded from Sage 300 Construction and Real Estate 9.4. Do I need to move my 
data folders or reports to comply with User Account Control (UAC) requirements?" on 
page 37

 l "Which Accounting and Management files were moved for Sage 300 Construction 
and Real Estate?" on page 38

When you need more assistance, visit Sage Customer Resources for links to Sage 
Knowledgebase, Sage City, the Product Documents website, Live Chat, Online Case 
submission, and other resources.
 

If Sage 300 Construction and Real Estate stops responding during the 
workstation installation, how can I resolve this?

Try the following:

 l Turn off antivirus software and unnecessary programs before you install.

 l Verify that you have full user rights to the parent folder of the application data folders 
containing files needed so that Sage 300 Construction and Real Estate can run 
correctly.

For Accounting and Management applications, the default location is:
[Drive]:\Program Data\Sage.

How do I move Accounting and Management products from one server to 
another?

Use the server migration tool found in Sage 300 Construction and Real Estate. For 
detailed instructions, see "Chapter 3: Server Migration" on page 24.

36

http://www.sagecity.com/Resources
https://cdn.na.sage.com/docs/en/customer/300cre/Documentation.htm


Caution! Incorrectly moving Sage 300 Construction and Real Estate data folders may 
severely damage your system. Sage Software is not responsible for damage to your 
data caused by incorrectly moving your Sage 300 Construction and Real Estate data 
folders. Before making changes to your Sage 300 Construction and Real Estate data, 
contact your system administrator for assistance and make a backup copy of all valued 
data.

Note: Versions of Sage 300 Construction and Real Estate prior to 9.5 will not install 
correctly on machines with a Windows 2007, Microsoft Server 2008 R2, or later 
operating system.

Why am I getting an error message when I try to save data or reports?

You cannot save data or report files to a location for which you do not have read/write 
permissions. This is to comply with Windows security requirements. To save the file, you 
must first have read/write permissions assigned or else save the file to another location to 
which you already have these permissions.

I upgraded from Sage 300 Construction and Real Estate 9.4. Do I need to 
move my data folders or reports to comply with User Account Control 
(UAC) requirements?

For Accounting & Management applications, you do not need to move folders to comply 
with UAC requirements unless you also install the Windows Server 2008 R2 operating 
system. 

If you install on Windows Server 2008 R2 or Windows 7, you do not need to move folders 
if they are already shared. If your data and report folders are not already shared, you will 
need to share the location or move them to a shared location and then update their 
location at File > Open Company > [Specify Folders]. Refer to "Which Accounting and 
Management files were moved for Sage 300 Construction and Real Estate?" (the next 
question) for information on folder locations.

The Sage 300 Construction and Real Estate folder continues to exist under Program Files 
but contains only the essential binary files required for the applications to operate.

In Purchasing (PO) and Inventory (IV), if you originally set up your company (data) folder 
inside the Program Files folder, your data will not be accessible after you upgrade.
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To prevent this issue, you should move your data from the Program Files folder to a 
different location prior to upgrading, as described in "Windows User Account Control 
(UAC) " on page 32.

Opening Purchasing or Inventory from a workstation before opening on a server will 
cause the DSN to be set incorrectly. After Purchasing or Inventory has been opened at 
the server, the applications can be opened at any workstation.

This issue is not specific to UAC but the solution to resolve it is the same. 

After installation, verify your application operates correctly and you have access to your 
data, then remove the original data files from the Program Files folder.

Which Accounting and Management files were moved for Sage 300 
Construction and Real Estate?

Many Sage 300 Construction and Real Estate folders were moved from the Program 
Files folder to a shared location beginning with the 9.5 release. A list of the affected 
Accounting & Management application folders is provided in the following table.

Note: Some  folders may be hidden. To view them, open Windows Explorer, click the 
View tab, and then select the Hidden items check box.

File/Original Location New Location (Windows Server 2008 R2)

[Program Files]\Timberline 
Office\Accounting\Formul
a

ProgramData\Sage\TimberlineOffice\9.5\Accounting\For
mula

[Program Files]\Timberline 
Office\Accounting\Inquiry

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Inqui
ry

[Program Files]\Timberline 
Office\Accounting\Report

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Rep
ort

[Program Files]\Timberline 
Office\Accounting\Templa
te

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Tem
plate

Original and new locations                 
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File/Original Location New Location (Windows Server 2008 R2)

[Program Files]\Timberline 
Office\Accounting\
[Sample Data Folders]

ProgramData\Sage\TimberlineOffice\Data\[Sample Data 
Folders]

[Program Files]\Timberline 
Office\Accounting\Wininst

ProgramData\Sage\TimberlineOffice\9.5\Accounting\Wini
nst

[Program Files]\Timberline 
Office\Documents

ProgramData\Sage\TimberlineOffice\9.5\Documents
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Terminal services
Windows Terminal Services is a component of Microsoft Windows Server. Terminal 
Services consists of a terminal server and one or more remote workstations. It enables 
users to access programs or data stored on a remote computer by a phone, network, 
Internet connection, or other communication methods. 

Remote network connections do not provide adequate bandwidth to run Sage 300 
Construction and Real Estate products without the use of Terminal Services. Terminal 
Services provides remote users with a stable and well-performing experience. 

Important! If you use Citrix MetaFrame, you must install it before you install Sage 300 
Construction and Real Estate.

You can install Sage 300 Construction and Real Estate applications on your terminal 
server (as described on page 14), or you can use Terminal Services in conjunction with a 
server for Sage 300 Construction and Real Estate.

Note: Sage does not support the administrative configuration of Terminal Services with 
Sage 300 Construction and Real Estate products because it is a partially configured 
version of Terminal Services.

Printers

General guidelines

Sage 300 Construction and Real Estate supports the use of business-class laser printers.

We no longer support the use of dot matrix printers for printing 1099 and W-2 forms.

Instead, use a laser printer. Some reports that use the Crystal Reports® format require a 
laser printer. For example, you must use a laser printer to generate cost and contract 
invoices (AIA documents) in Billing, Service Management, Purchasing, and Inventory.

You should use inkjet or bubble jet printers only as backup printers; we do not test inkjet 
or bubble jet printers.
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Printer driver

We recommend that you use a PCL 5e printer driver.

Most new printers also support a PCL 6 printer driver. A PCL 6 driver supports higher 
resolutions than a PCL 5e driver (1200 dots per inch versus 600 dots per inch). However, 
because of its higher resolution (and, thus, greater memory needs), PCL-6-based printing 
uses more toner, is slower, and is sometimes unstable.

Many printers come with both PCL 5e drivers and PCL 6 drivers. If your printer does not 
come with a PCL 5e driver, your printer manufacturer probably offers one for free online.

Try using the PCL 5e driver first. Switch to a PCL 6 driver only if your printer does not 
function properly with a PCL 5e driver.

Margins

The following margins work with most laser printers.

Products Top margin Bottom margin Left margin Right margin

Accounting and 
Management products

0.25 inches 0.5 inches 0.25 inches 0.5 inches

Recommended margins                 

Installing, moving, or removing Sage 300 Construction 
and Real Estate products
Sage 300 Construction and Real Estate uses Microsoft Installer (MSI) for the installation, 
repair, modification, and removal of Accounting and Management Products.

Installation

The MSI installation occurs automatically when you install Accounting and Management 
Products. Use the Microsoft® Event Viewer to review the final status of the installation. 
You can find the Event Viewer in the Control Panel > Administrative Tools  folder. For 
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information about installing, see "Chapter 2: Install Sage 300 Construction and Real 
Estate" on page 10.      

Auto-repair feature

This feature occurs automatically when you start an application and does not require any 
action or response. MSI tracks important groupings of files that are necessary for an 
application to run. If an important component is missing, MSI restores these files from the 
original installation source.

If MSI detects missing components, you may notice a brief delay of approximately two 
minutes while MSI validates them. In a Sage 300 Construction and Real Estate server 
configuration, you will be prompted for the installation DVD unless the installation source 
was copied and installed from the hard drive. On a workstation running Sage 300 
Construction and Real Estate, the utility retrieves the missing files from the shared Sage 
300 Construction and Real Estate server if a valid network connection exists. 

Use the Microsoft Event Viewer to review the changes made to the installation. You can 
find the Event Viewer in  the Control Panel > Administrative Tools  folder.

Modify option

Use this option to add new programs or change program uses. This option is available 
when you reinstall a currently installed version of Accounting and Management Products 
on the server.

This utility proceeds through the traditional installation routine with the exception that you 
cannot change your registration name or client number.

To start the utility, begin the installation process by double-clicking Install.exe. In the 
Accounting Server - InstallShield Wizard window, select Modify.

Remove utility

Use the Remove utility to permanently remove Sage 300 Construction and Real Estate 
products from a server or workstation. For additional information, see "Removing 
Accounting and Management products entirely" (the next section)
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This utility removes application files and application registry folders which are created 
during the application installation process. It does not necessarily return the server or 
workstation to its original state. Files and registry values modified or created during the 
use of Accounting and Management products will still exist (for example, \HKEY_
CURRENT_USER\Software\Timberline).

Removing Accounting and Management products entirely

A complete removal of the Accounting and Management Products includes running the 
uninstall program first, then manually deleting the Program folder for Sage 300 
Construction and Real Estate, manually deleting the application data folder for Sage 300 
Construction and Real Estate, manually deleting the Current User registry keys for Sage 
300 Construction and Real Estate, and uninstalling any third-party prerequisite products. 
If you decide to reinstall after doing a complete removal of Accounting and Management 
Products, you must restore all Accounting and Management Products folders and files 
from a backup and then reinstall the Accounting and Management Products.

Summary of removal steps

 1.  Back up the Sage 300 Construction and Real Estate program folder and all 
company data. Confirm that the backup was successful before continuing.

 2.  Remove Sage 300 Construction and Real Estate using the Remove utility. To start 
the utility, open the Windows Add or Remove Programs feature, select Timberline 
Accounting Server or Timberline Accounting Client, and then click [Remove]. 

 3.  Use Windows Explorer to delete the Sage 300 Construction and Real Estate folder 
(typically installed at X:\Program Files\Timberline Office).

 4.  Use Windows Explorer to delete the Sage application data folder. This is typically 
installed at [Drive]:\Program Data\Sage. 

 5.  (Optional) Use the Microsoft Registry Editor to delete the registry key 
\HKEY_CURRENT_USER\Software\Timberline.

 6.  Use Windows Add or Remove Programs to remove Pervasive.SQL Server from the 
Sage 300 Construction and Real Estate Server.

 7.  Use Windows Add or Remove Programs to remove Pervasive.SQL Workgroup 
from Sage 300 Construction and Real Estate workstations.
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Chapter 5: Security

Security overview
If you have many people working in your office, you may not want each one to have 
access to all the features of the software. For instance, you may not want all staff 
members to be able to print checks or to print reports that include sensitive data.

You can use the security function in Sage 300 Construction and Real Estate to restrict 
access to various areas of the software. 

Sage 300 Construction and Real Estate security is set up through the Security 
Administration tool in Sage Desktop (by selecting Options > Security Administration).

User types

The Security Administration tool for Sage 300 Construction and Real Estate includes 
three types of users: security administrators, application administrators, and Sage 300 
Construction and Real Estate users. 

 l Security administrators set up and maintain accounts for users. For a complete list 
of tasks that a security administrator can perform, see "Setting up security      " on page 
57

 l Application administrators can restrict access to software features and data that 
each user has permission to access. They define roles and assign users to the roles. 
For a complete list of tasks that an application administrator can perform, see 
"Setting up security      " on page 57

 l Users have task permissions defined by the application administrator. These 
permissions can range from none to almost as extensive as an application 
administrator. Users can have the same level of file and record access as an 
application administrator. Users can have access to one or more companies.
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 l A role represents a group of users who have the same security requirements. A role 
has its own user name and its own task, record, file, and company permissions.

The use of roles often saves setup time, because the application administrator can 
assign permissions to new users simply by assigning them to an existing role. The 
use of roles can also clarify your company's security plan because the application 
administrator can create roles that correspond to the company's organizational 
structure. For example, the application administrator can create roles for Accounts 
Payable clerks, Payroll clerks, property managers, and project managers.

Types of security

 l Task security restricts access to menu items and certain tasks. For example, you 
can control who can set up vendors in Accounts Payable.

With task security, an application administrator can restrict access to menu items and 
certain tasks found within windows. For example, task security can control access to 
the Setup > Vendors menu item in Accounts Payable (AP.) Also, task security can 
control whether you can approve a change order in the Item Status field of the Enter 
Change Order Items - Scope of Change window in Job Cost.

In the following example of task security, an application administrator assigns task 
permissions based on the tasks that the employees need to perform.

Role
Permission to 
AP Settings?

Permission to 
Post Invoices?

Permission to 
AP Reports?

CONTROL (controller) Yes Yes Yes

APCLERK (AP clerk)   Yes Yes

PROJMGR (project 
manager)

    Yes

Example of task security setup                         
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Note: If employees are going to run reports with SQL data, they need to have read 
permissions to the relevant SQL tables. See the tables in SQL Data Access > 
Read Access in the Tasks tree.

 l File security blocks all access to a file and restricts ODBC access. For example, you 
can restrict access to sensitive payroll files.

File security allows application administrators to block all access to a file. This 
includes access through open database connectivity and through all related tasks, 
reports, and inquiries. This differs from task security, which allows application 
administrators to block tasks selectively and does not allow them to control ODBC 
access.

In the following example of file security, a company has two Payroll (PR) master files. 
One is for the executive staff and the other is for the field staff. In order to keep the 
executive payroll information private, the company creates a separate role for users 
that handle the executive PR master file.

Role Users
Access to Exec 
PR Master File?

Access to Field 
PR Master File?

EXECPR 
(executive payroll)

Controller and a 
senior payroll 
clerk

Yes, for all users 
assigned to this 
role

 

FIELDPR 
(field payroll)

Controller and all 
payroll clerks

 
Yes, for all users 
assigned to this 
role

Example of file security setup                         

In this example, the senior payroll clerk is a member of both the EXECPR and 
FIELDPR roles. A user can belong to more than one role.

 l Record security controls access to certain records so that reports and inquiries 
display only the records to which the user has security access. For example, you can 
restrict reporting and inquiries on jobs or bank accounts.
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 l Company security restricts access to which companies a user can see. Application 
administrators can grant a user access to specific companies. Security 
administrators and application administrators have access to all companies.

 l Application security prevents unauthorized users from accessing Sage 300 
Construction and Real Estate. When application administrators turn on application 
security, all users must enter a user name and password to access the software. 
They can restrict access to software features and data that each user has permission 
to access. Security Administration offers four types of application security: task, file, 
record, and company.

Application security also lets application administrators hide applications from users 
and roles. When an application administrator uses the Security Administration tool to 
deny a user or role access to all tasks in an application and sets secured menu items 
to not display, users cannot see the application in Sage Desktop.

Log settings

By default, logging is turned on. Security administrators can turn off Application, Security, 
or Setup logging.

The Audit Setup, Field Report, and System logs are required. You cannot turn them off.

The Posting Recap and Task Summary logs are for future use. No logs are created at this 
time.

Required 
log?

Log type Description

No Application
Logs the start and end of Accounting applications and 
tasks.

Yes Audit Setup
Logs changes when the audit setup activity is 
selected in an Accounting application.

Yes Field Report
Logs changes to finalized field reports in Project 
Management.

Types of logs                 
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Required 
log?

Log type Description

Yes Posting Recap
Logs recaps created while posting entries in 
Accounting. (Future)

No Security Logs events in the Security Administration tool.

No Setup Logs changes to setup information in Accounting.

Yes System Logs Accounting system events.

Yes Task Summary
Logs summaries created during an Accounting task. 
(Future)
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Applications with Security Administration

The following applications feature Security Administration:

 l Accounts Payable

 l Accounts Receivable

 l Address Book

 l Billing

 l Cash Management

 l Contacts

 l Equipment Cost

 l Financial Statements

 l General Ledger

 l Information Assistant

 l Inquiry Designer

 l Job Cost

 l Payroll

 l Project Management

 l Property Management

 l Remote Time

 l Report Designer

 

The following applications have limited Security Administration:

 l Purchasing and Inventory are affected by task security. Application administrators 
cannot set up Security Administration for these applications but you must type your 
user name and password if Security Administration is on. Purchasing and Inventory 
also offer their own form of task security. For more information, see Help in these 
applications.

 l Service Management uses task security. Application administrators can create 
users and roles and set up task security for Service Management just as you would in 
the bulleted list of applications above.

Record security
With record security, you can control access to four records:

 l Cash Management bank account

 l General Ledger prefix

 l Job Cost and Project Management job

 l Property Management property

In addition, you can select or clear the Give all users access to records with blank 
security IDs check box. Select the box if you want records with blank security IDs to be 
accessible to all users. Clear the box if you want only application administrators to access 
these records. For more information, see "Set up record security" on page 62.
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When record security is active, reports and inquiries display only the records to which the 
user has access. For more information, see "Effect of record security on reports" on page 
50 and "Effect of record security on inquiries" on page 53.

Record security also affects Job Cost, Contracts, and Project Management tasks. In 
these applications, you can type or select only jobs to which you have access. For more 
information, see "Effect of record security on tasks" on page 56.

Example—using record security

In the following example, a property manager, Accounts Payable (AP) clerk, and Property 
Management (PM) clerk work as a team on certain properties. Another project manager, 
AP clerk, and PM clerk work as a team on different properties.

With the following record security setup, these employees have access to only their 
team's properties.

Role Users
Access to TEAM1 

Properties?
Access to TEAM2 

Properties?

TEAM1

Proj Mgr 1

AP Clerk 1

JC Clerk 1

Yes, for all TEAM1 users 
assigned to this role

 

TEAM2

Proj Mgr 2

AP Clerk 2

JC Clerk 2

 
Yes, for all TEAM2 users 
assigned to this role

Example of record security setup>                 

Effect of record security on reports

When record security is active on a report, the report displays only the records that are 
accessible to the current user. Moreover, totals on the report adjust to reflect only the 
accessible records.

For example, in Job Cost, a Cost Entries by Job report (simplified for this example) 
would look like the following to an application administrator:
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Job Cost Code Category Amount

01-002 3-110 L (labor) 100.00

01-003 2-520 M (material) 350.00

   
Report 
Total

450.00

Example report view by application 
administrator                 

To a user with permissions to only job 01-002, the same report would look like the 
following:

Job Cost Code Category Amount

01-002 3-110 L (labor) 100.00

   
Report 
Total

100.00

Example report view by user with only access to 
job 01-002                 

 

Note: Some reports list information from several different records on the same line. If 
you lack access rights to the report’s driving record (the primary record upon which the 
report is based), the report skips the entire line. If you lack access rights to one of the 
non-driving records, the report skips only the information from that record.

Report record security settings

Each report has security settings that control whether record security can affect the 
report. If you own Report Designer, you can modify these settings (Report Designer 
>Design Security). If you do not own Report Designer, an application administrator can 
control record security on reports only by turning on or turning off record security. (For 
more information, see "Turn off record security" on page 68.)

51



User's Guide

Sage 300 Construction and Real Estate defines the security settings on stock reports 
based on whether (a) the report contains sensitive information or (b) the report's content 
should be tailored to the user. For example, Sage 300 Construction and Real Estate 
allows the bank record on the Cash Management Check Register report to be secured so 
that, if record security is on, you can generate reports that list only the entries for the 
banks to which the current user has access.

In some cases, for practical reasons, Sage 300 Construction and Real Estate does not 
allow record security to affect a report. For example, in Cash Management, you can type 
any bank in data entry tasks (bank account record security currently only affects reports 
and inquiries). Therefore, Sage 300 Construction and Real Estate does not secure the 
bank account record on the Cash Management Journal report.

Indicators that record security affects a report

Record security always affects a Crystal report, which has a “(CR)” in its name, unless the 
report uses a special formula to disable record security. To check for this formula, you 
must open the report in Crystal Decisions Crystal Reports. (You cannot use a Sage 300 
Construction and Real Estate application to check for this formula.) 

Note: If you create reports in Report Designer, then you can secure those reports with 
Security Administration. You must be an application administrator and own Report 
Designer to modify security settings on new report designs.

If you do not own Report Designer: the report's cover page indicates whether record 
security is on. You have the following options regarding cover pages:

 l If you want to print a cover page every time you print any report, select Tools > 
Options. On the Reports tab, select                Attach to report.

 l If you want to print a cover page only some of the time, you must choose to print a 
cover page at the time of printing. From an applications Tools menu, select the report 
and from the Print Selection window, click [Page Setup]. Then select Attach to 
report.

If you own Report Designer: in addition to the report cover page (see above), record 
security information can appear in three additional areas.
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 l A report's design information (Tools > Design Info) lists the report's record security 
settings.

 l A report's page heading (defined in File > Page Setup > Page Headings) indicates 
whether record security is on.

 l If you open a report created in Report Designer 7.x or earlier and the report contains 
secured records, you will receive an on-screen message that lists the secure records 
on that report. Once you save the report, you will no longer receive this message.

Effect of an upgrade on reports

When you upgrade from Sage 300 Construction and Real Estate Accounting products 7.x 
or earlier to Sage 300 Construction and Real Estate 8.0 or later, the following changes 
take place with reports.

Stock reports

New stock reports replace your existing stock reports. The new reports have settings that 
control whether record security can affect the reports. However, these settings take effect 
only if you activate record security.

Custom reports

If you open a custom report created in Report Designer 7.x or earlier, the software 
displays a message that lists the secure records on that report. Once you save the report, 
you no longer receive this message.

The software also modifies the report's security settings. It changes these settings to 
allow record security, if active, to affect all securable records on the report.

You must use Report Designer to change a report's settings. If you do not own Report 
Designer, the only way to control record security on a report is for an application 
administrator to turn on or turn off record security.

Effect of record security on inquiries

When record security for an inquiry is on, the inquiry displays only records that are 
accessible to the current user.
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For example, in Cash Management, a Bank List inquiry would look like the following to an 
application administrator:

Bank Account Description Account Number Register Balance

First First Bank  042134526 56,650.97

Liberty Liberty S&L 874613754 91,450.44

Example inquiry by application administrator                 

 

To a user with permissions to only First Bank, the same inquiry would look like the 
following:

Bank Account Description Account Number Register Balance

First First Bank  042134526 56,650.97

Example inquiry by user with only access to First Bank                 

 

Note: Some inquiries list information from several different records on the same line. If 
you lack access rights to the inquiry's driving record (the primary record upon which the 
inquiry is based), the inquiry skips the entire line. If you lack access rights to one of the 
non-driving records, the inquiry skips only the information from that record.

Inquiry record security settings

Each inquiry has record security settings that control whether record security can affect 
the inquiry. These settings take effect in the following scenarios:

 l New installations of Sage 300 Construction and Real Estate 8.0 or later.

 l Subsequent upgrades of a new 8.0 or later installation.

If you upgrade from Sage 300 Construction and Real Estate Accounting and 
Management products 7.x or earlier to Sage 300 Construction and Real Estate 8.0 or 
later, these settings do not take effect. Instead, record security automatically affects your 
inquiries if it is on. For more information, see "Effect of an upgrade on inquiries" (the next 
section).
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Sage 300 Construction and Real Estate selects inquiry record security settings based on 
whether the inquiry contains sensitive information or whether its information should be 
tailored to the user. For example, Sage 300 Construction and Real Estate allows the bank 
record on the Cash Management Bank Register inquiry to be secured so that, if record 
security is on, your inquiry displays entries for only the banks to which you have access.

If you own Inquiry Designer, you can modify inquiry security settings. For more 
information, see "Change design security on an inquiry" on page 72.

If you do not own Inquiry Designer, application administrators can control record security 
on inquiries 
only by turning on or turning off record security. For more information, see "Turn off 
record security" on page 68.

Indicators that record security affects an inquiry

A button with a lock on it appears in the upper right corner of the inquiry. If you click this 
button, a Record Security window appears that lists which records are secured on the 
inquiry.

Note: In this window, an application administrator can select or clear records to secure. 
However, the selections affect only the current user's session. Therefore, selections are 
inconsequential because an application administrator already has permission to view 
all records.

Effect of an upgrade on inquiries

If your Sage 300 Construction and Real Estate Accounting products installation started 
with 7.x or earlier, record security affects your stock and custom inquiries to the extent 
that it is on. (Installations that started with 8.0 or later are different; see the next section). 
For example, if record security is on for the Cash Management bank account record and 
the Job Cost and Project Management job records, these records are automatically 
secured on the inquiry. If record security is on for only the Cash Management bank 
account record, only this record is secured on the inquiry.

If you own Inquiry Designer, you can specify settings on each inquiry that control whether 
record security affects the inquiry.
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Difference between upgrades and new installations

New installations of Sage 300 Construction and Real Estate (and subsequent upgrades) 
use Sage 300 Construction and Real Estate’s predefined inquiry record security settings. 
These settings control whether record security can affect an inquiry. For example, if an 
inquiry’s settings do not allow Cash Management bank account record security, this 
record is not secured on the inquiry (even if record security is on). For an upgrade, record 
security automatically affects the bank account record because the inquiry does not use 
the predefined record security settings.

Effect of record security on tasks

Record security can restrict access to the job record in certain Job Cost (JC), Contracts 
(CN), and Project Management (PJ) tasks. When record security is turned on for jobs, 
you cannot view a job in a list or type a job unless you have security access for that job. 
For example, in the PJ Job Setup window (PJ > Setup > Jobs), when you click [Find] to 
list jobs that have been previously set up, you see only jobs to which you have access.

In addition, you can select or clear the Give all users access to records with blank 
security IDs check box. Select the box if you want records with blank security IDs to be 
accessible to all users. Clear the box if you want only application administrators to access 
these records. For more information, see "Set up record security" on page 62.

Job record security affects the following tasks:

Contracts

 l Edit > Link

 l Edit > Add/Edit JC CO link

 l Edit > JC CO Item Link Details

Job Cost

 l Setup > Jobs

 l Tasks > Enter Estimates

 l Tasks > Change Orders

 l Tasks > Commitments
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 l Tasks > Commitment Change Orders

 l Tasks > Enter Misc Worksheets

Project Management

 l All tasks that involve the job record (for example, job setup and document creation).

Setting up security      
This section contains the tasks that security administrators and application administrators 
need to perform to set up security. Some tasks can be performed by either administrator 
role. Other tasks must be performed by a specific administrator role. The best practice is 
for the security administrator to perform steps 1 through 8 and for the application 
administrator to perform steps 9 through 13. Steps 6, 12, and 13 are optional.

Whether you can perform this tack 
if you have this role:

Security 
Administrator

Application 
Administrator

"Turn on security" Yes No

"Add a security administrator" Yes No

"Add an application administrator" Yes No

"Log on" Yes No

"Restart Sage 300 Construction and Real 
Estate"

Yes No

"Turn off logging" (optional) Yes No

"Add roles" Yes No

"Add users" Yes No

"Add users to roles" Yes Yes

"Add tasks to roles" Limited Yes

"Grant users access to companies" No Yes

Tasks for security or application administrators                 
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Whether you can perform this tack 
if you have this role:

Security 
Administrator

Application 
Administrator

"Restrict access to files" (optional) No Yes

"Set up record security" (optional) No Yes

Turn on security

To prevent unauthorized users from accessing your software, we recommend that you 
turn on application security. When you turn on application security, all users must enter a 
user name and password to access the software. Application administrators can restrict 
access to software features and data that each user has permission to access.

Note: You must be a security administrator to turn on security.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Security Settings.

 3.  Select the Turn on application security check box.

 4.  Click [OK].

Add a security administrator

When you turn on security, you must add a security administrator. Security administrators 
set up and maintain accounts for users. For back-up purposes, we recommend adding at 
least two security administrators.

To add or change a security administrator later, go to Security Administration > User 
Setup. You must be a security administrator to add another security administrator.

Add an application administrator

When you turn on security, you must add an application administrator. Application 
administrators define roles and assign users to the roles. For back-up purposes, we 
recommend adding at least two application administrators.

To add or change an application administrator later, go to Security Administration > 
User Setup.
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Log on

 1.  From the Log On window, type your User name.

 2.  Type your Password.

 3.  Click [Log On].

Restart Sage 300 Construction and Real Estate

For the security settings to take effect, all users must restart Sage 300 Construction and 
Real Estate.

 1.  When the Restart message appears, click [OK].

 2.  Close Sage 300 Construction and Real Estate (File > Exit), and then reopen it.

 3.  Request all users to restart Sage 300 Construction and Real Estate.

Turn off logging

This task is optional.

Security administrators can only turn off Application, Security, or Setup logging. The 
Audit Setup, Field Report, and System logs are required; you cannot turn them off. The 
Posting Recap and Task Summary logs are for future use; no logs are created.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Log Settings.

 3.  In the On column, clear the types of logs that you want to turn off.

 4.  Click [OK].

Add roles

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Role Setup.

 3.  On the Roles pane, click [Add].

 4.  On the Role Details pane, type the Name of the role (for example, AP Clerk.)

 5.  (Optional) Type the Description for this role.
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 6.  (Optional) Select the tasks for this role. For more information, see "Add tasks to 
roles" on page 61.

 7.  (Optional) Select the users for this role. For more information, see "Add users to 
roles" on page 60.

 8.  Click [Save Changes].

Add users

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click User Setup.

 3.  On the Users pane, click [Add].

 4.  On the User Details pane, type the User name.

 5.  (Optional) Type the Full name and Windows user associated with the user name.

 6.  (Optional) On the Settings tab, select the User Account Settings and Password 
Settings.

 7.  Click the Roles tab, and then select or add roles for the user.

 8.  (Optional) Click the Companies tab, and then select the companies for the user. For 
more information, see "Grant users access to companies" on page 61.

Note: You must be an application administrator to grant a user access to 
companies. If you cannot perform this step, the application administrator must do 
it before the user can log on to Sage 300 Construction and Real Estate.

 9.  Click [Save Changes].

Add users to roles

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click User Setup.

 3.  On the Users pane, select the User Name.

 4.  Click the Roles tab, and then select roles for the user.

 5.  Click [Save Changes].

 6.  For the change to take effect, the users associated with this role must restart Sage 
300 Construction and Real Estate.
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Add tasks to roles

Application administrators can add all tasks to roles.

Security administrators can only add the following tasks to a role:

 l Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

 l Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup 
Activity)

 l View System Activity (Tasks > Common Tasks > Security > View System Activity)

 l Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit 
Setup Fields)

You cannot change the tasks for the application administrator and security administrator 
roles.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Role Setup.

 3.  On the Roles pane, select the role that you want to edit.

 4.  On the Roles Details pane, click the Tasks tab.

 5.  In the tasks tree, navigate to the tasks or sub-tasks that you want to add and select 
the tasks.

 6.  Click [Save Changes].

 7.  For the change to take effect, the users associated with this role must restart Sage 
300 Construction and Real Estate.

Grant users access to companies

You must be an application administrator to grant a user access to companies.

Security administrators and application administrators have access to all companies.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Company.

 3.  On the Companies pane, select the Company Name to which you want to add 
users.

 4.  On the Company Security Details pane, click [Add].
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 5.  In the Company Setup - Add Users window, select the users.

 6.  Click [OK].

 7.  Click [Save Changes].

 8.  For the change to take effect, the user associated with this company must restart 
Sage 300 Construction and Real Estate.

Restrict access to files

This task is optional.

Note: You must be an application administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Files. 

 3.  Select the Company for which you want to restrict access to files.

 4.  Select the Role that will have access to the corresponding File Name.

 5.  Click [OK].

 6.  After securing a file, make sure that users can still perform their required tasks.

 7.  For the file restriction to take effect, all users not assigned to the role must restart 
Sage 300 Construction and Real Estate.

Set up record security

This task is optional.

Note: You must be an application administrator to perform these tasks.

A. Setting up record security

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, select Records. The Record Security window 
opens.

 3.  On the Activation tab, select Activate record security.

 4.  Select or clear the Give all users access to records with blank security IDs check 
box. Select the box if you want records with blank security IDs to be accessible to all 
users. Clear the box if you want only application administrators to access these 
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records.

 5.  In the Securable record types box, select the records that you want to secure.

B. Assigning security IDs to records

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, select Records. The Record Security window 
opens.

 3.  Select the tab for the record to which you want to assign security IDs.

 4.  In the Security ID column, type the ID of a role. You can type only a single ID.

 5.  Click [OK].

Note: Record tabs in the Record Security window are accessible only if you have 
turned on record security for that record on the Activation tab.

Modifying security
This section contains the following topics:

 l "Change password settings" (the next section)         

 l "Delete a user" on page 66

 l "Delete a role" on page 66

 l "Copy a user" on page 66

 l "Copy a role" on page 67

 l "Turn off security" on page 67

 l "Remove file restrictions" on page 68

 l "Turn off record security" on page 68

 l "Turn on tasks" on page 69

 l "Turn off tasks" on page 69

 l "Add a role to a task" on page 69

 l "Remove a role from a task" on page 70

 l "Restrict access to files" on page 70

 l "Restrict access to additional files" on page 71
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 l "Modify record security permissions" on page 71

 l "Change design security on reports" on page 72

 l "Change design security on an inquiry" on page 72

 l "Review record security settings" on page 73

Change password settings

Note: You must be a security administrator to change the password settings.

When you turn on security, you must set up password strengths and requirements for all 
users. To change these settings later, go to Security Administration > Security Settings.

To change the password settings for a user name, go to Security Administration > User 
Setup > Settings.

For the password settings to take effect, all users must restart Sage 300 Construction and 
Real Estate.

Set strong passwords

To prevent unauthorized users from accessing your software, we recommend that you 
require strong passwords. Strong passwords must meet the following conditions for 
complexity:

 l Passwords must be at least eight characters long.

 l Passwords must contain at least three of the following four character groups:

 l English uppercase characters (A through Z)

 l English lowercase characters (a through z)

 l Numbers (0 through 9)

 l Special characters (~  ! @ # $ % ^ & * ( ) - + = { } [ ] | \ : ; < , > . ? /)

 l Passwords expire every 90 days.

 l You are warned 10 days before your password expires.

 l You cannot reuse your three previous passwords.

 l You must wait 10 days before changing your password.
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When you turn on security, the password settings default to these strong password 
conditions.

Change password strengths and requirements for all users

Note: You must be a security administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Security Settings.

 3.  If security is turned off, select the Turn on application security check box.

 4.  In the Password Settings area, move the slider to select the password strength.

 5.  If you choose Custom (top setting on the slider), set the requirements:

 a.  Click [Custom Password Settings]. 

 b.  In the Password Settings window, clear the check boxes that you do not 
want or change the requirements for the settings.

 c.  Click [OK] to save the custom password settings.

 6.  Click [OK] to save the security setting changes.

 7.  If you are strengthening the password requirements, the following message 
appears, “Existing passwords may not meet the new requirements. Do you want 
users to create new passwords the next time they log on?” Click [Yes]. 

 8.  For the password settings to take effect, all users must restart Sage 300 
Construction and Real Estate.

Change password settings for a user name

Note: You must be a security administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click User Setup.

 3.  On the Users pane, select the User Name for which you want to change the 
password settings.

 4.  On the User Details pane, click the Settings tab.

 5.  Select or clear the Password Settings options.

 6.  If you want to add or change the password for the user:
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 a.  Click [Set Password].

 b.  From the Set Password window, type the same password in the Password 
and Confirm password fields.

 c.  Click [OK].

Note: When you add or change the password, the User must change 
password at next log on option is automatically selected.

 7.  Click [Save Changes].

 8.  For the password settings to take effect, the user must restart Sage 300 
Construction and Real Estate.

Delete a user

Note: You must be a security administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click User Setup.

 3.  On the Users pane, select the User Name that you want to delete.

 4.  Click [Delete].

 5.  When you receive a confirmation message, click [Yes].

Delete a role

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Role Setup.

 3.  On the Roles pane, select the role that you want to delete.

 4.  Click [Delete].

 5.  When you receive the confirmation message, click [Yes].

Copy a user

Use the copy feature when you want a new user to have the same permissions as an 
existing user.

Note: You must be a security administrator and an application administrator to perform 
this task.
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 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click User Setup.

 3.  On the Users pane, select the User Name that you want to copy.

 4.  Click [Copy].

 5.  On the User Details pane, type the User name.

 6.  (Optional) Type the Full name and Windows user associated with the user name.

 7.  Click [Save Changes].

Copy a role

Use the copy feature when you want a new role to have the same tasks and users as an 
existing role.

Note: You must be an application administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Role Setup.

 3.  On the Roles pane, select the role that you want to copy.

 4.  Click [Copy].

 5.  On the Role Details pane, type the Name of the role (for example, AP Clerk.)

 6.  (Optional) Type the Description for this role.

 7.  Click [Save Changes].

Turn off security

Note: You must be a security administrator to turn off application security.

Important! To prevent unauthorized users from accessing your software, we 
recommend that you leave application security turned on.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Security Settings.

 3.  Clear the Turn on application security check box.

 4.  Click [OK].
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 5.  For the security settings to take effect, all users must restart Sage 300 Construction 
and Real Estate.

Remove file restrictions

Note: You must be an application administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Files. 

 3.  Select the Company for which you want to remove a file restriction.

 4.  In the Role column for the corresponding File Name, select (None.)

 5.  Click [OK].

 6.  For the file setting to take effect, all users must restart Sage 300 Construction and 
Real Estate.

Turn off record security

Note: You must be an application administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, select Records. The Record Security window 
opens.

 3.  Select the Activation tab.

 4.  If you want to turn off all record security, clear the Activate record security check 
box.

 5.  If you want to turn off record security for a particular record, clear the check box for 
that record.

 6.  Click [OK].

Notes:  

 l When you turn off record security, the Security ID field disappears from related 
record setup windows. However, Sage 300 Construction and Real Estate 
security saves your security ID assignments. If you reactivate record security, 
these settings take effect again.

 l In addition to record security settings in Security Administration, each Sage 300 
Construction and Real Estate report and inquiry has record security settings.
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Turn on tasks

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Tasks.

 3.  On the Tasks pane, navigate to the tasks or sub-tasks that you want to turn on.

 4.  On the Task Security Details pane, clear Turn off task.

 5.  Click [Save Changes].

 6.  For the task settings to take effect, all users must restart Sage 300 Construction and 
Real Estate.

Turn off tasks

Note: You cannot turn off tasks for the security administrator and application 
administrator roles.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Tasks.

 3.  On the Tasks pane, navigate to the tasks or sub-tasks that you want to turn off.

 4.  On the Task Security Details pane, select Turn off task.

 5.  If the Restart Sage 300 Construction and Real Estate message displays, click 
[OK].

 6.  Click [Save Changes].

Add a role to a task

Application administrators can add roles to all tasks.

Security administrators can only add roles to the following tasks:

 l Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

 l Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup 
Activity)

 l View System Activity (Tasks > Common Tasks > Security > View System Activity)

 l Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit 
Setup Fields)

To add a role to a task:
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 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Tasks.

 3.  On the Tasks pane, navigate to the task or sub-task to which you want to add a role.

 4.  On the Task Security Details pane, select the roles that you want to add.

 5.  Click [Save Changes].

Remove a role from a task

Application administrators can remove roles from all tasks.

Security administrators can only remove roles from the following tasks:

 l Log Viewer (Tasks > Common Tasks > Tools > Log Viewer)

 l Audit Setup Activity (Tasks > Common Tasks > Tools > Options > Audit Setup 
Activity)

 l View System Activity (Tasks > Common Tasks > Security > View System Activity)

 l Change Audit Setup Fields (Tasks > Common Tasks > Security > Change Audit 
Setup Fields)

To remove a role from a task:

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Tasks.

 3.  On the Tasks pane, navigate to the task or sub-task that you want to remove from a 
role.

 4.  On the Task Security Details pane, clear the roles.

 5.  Click [Save Changes].

Restrict access to files

Note: You must be an application administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Files.

 3.  Select the Company for which you want to restrict access to files.

 4.  Select the Role that will have access to the corresponding FileName.
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 5.  Click [OK].

 6.  After securing a file, make sure that users can still perform their required tasks. 

 7.  For the file restriction to take effect, all users not assigned to the role must restart 
Sage 300 Construction and Real Estate.

Restrict access to additional files

Application administrators will only see additional files if named files are selected for a 
securable file type (Sage 300 Construction and Real Estate > Common Tasks > File > 
Company Settings > File Locations > Ask Name.)

Note: You must be an application administrator to perform this task.

To restrict a file that is not in the File Security Setup grid:

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, click Files.

 3.  Select the Company for which you want to restrict access to files.

 4.  Click [Find Files].

 5.  From the File Security Setup - Find File window, select the File Type.

 6.  Click [OK].

 7.  Browse to the file location and select the File name that you want to restrict.

 8.  Click [Open]. The file is added to the grid.

 9.  Select the Role that will have access to the corresponding File Name.

 10.  Click [OK].

 11.  After securing a file, make sure that users can still perform their required tasks.

 12.  For the file restriction to take effect, all users not assigned to the role must restart 
Sage 300 Construction and Real Estate.

Modify record security permissions

Note: You must be an application administrator to perform this task.

To change the security ID in a Record Security window:
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 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, select Records. The Record Security window 
opens.

 3.  Select the tab for the record you want to change.

 4.  In the Security ID column, change the security ID.

 5.  Click [OK].

Note: Record tabs in the Record Security window are available only if you have turned 
on record security for that record.

To change the security ID in a Record Setup window:

Note: You must be an application administrator or have security access to the Change 
Security ID task. 

 1.  Open the record setup window of a securble record (Cash Management bank 
account, General Ledger prefix, Job Cost and Project Management job, and 
Property Management property.)

 2.  Click the Security ID field and change the ID.

Change design security on reports

Note: You must be an application administrator to modify report design security.

 1.  Start Report Designer.

 2.  Open the report design (File > Open Design.)

 3.  From the Tools menu, select Security > Design.

 4.  In the Design Record Security box, select or clear the check boxes.

 5.  Click [OK].

Note: The Design Record Security box lists all available records regardless of whether 
the report uses all the records. If record security is off, the check box for that record will 
be unavailable.

Change design security on an inquiry

Note: You must be an application administrator to modify the inquiry design security.
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 1.  Start Inquiry Designer.

 2.  From the Inquiry menu, select Inquiry Manager.

 3.  In the Applications window, select an application and click [OK].

 4.  In the Inquiry Manager window, select the inquiry; then click [Change].

 5.  In the Change Inquiry window, click [Record Security].

 6.  In the Record Security window, select or clear the check boxes.

 7.  Click [OK] in successive windows; then click [Close].

Note: The Record Security window lists all available securable records regardless of 
whether the inquiry uses all the records. If record security is not selected, the check box 
for that record will be unavailable.

Review record security settings

Note: You must be an application administrator to perform this task.

 1.  From the Sage Desktop, select Options > Security Administration.

 2.  On the Security Administration tab, select Records. The Record Security window 
opens.

 3.  Review the selections on the Activation tab. They control whether record security is 
on and how the software interprets blank security IDs.

 4.  Select one of the record tabs.

 5.  Review the users and roles in the Security ID column.

 6.  Repeat steps 4 and 5 for each record.

Note: Every report and inquiry has settings that control whether record security can 
affect the report or inquiry.

Troubleshooting security
This section contains information about the following issues:

 l "I cannot see a security ID in a Record Setup window"

 l "I cannot change a security ID in a Record Setup window"
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 l "I know a job was set up, but I cannot see it in the software" on page 74

 l "I forgot my password" on page 75

 l "My report or inquiry is missing information" on page 75

 l "Menu items and fields are unavailable" on page 75

 l "I cannot delete a user name" on page 76

 l "I cannot make an account unavailable" on page 76

 l "I cannot end account availability" on page 76

 l "I cannot remove a user name" on page 77

 l "I cannot turn on security" on page 77

 l "I cannot save changes" on page 77

I cannot see a security ID in a Record Setup window

The Security ID field appears in a record setup window only if record security is on for 
that record. For more information, see "Set up record security" on page 62.

I cannot change a security ID in a Record Setup window

During the setup of a new record, anyone can type a security ID. Once the record has 
been saved, only application administrators or users with permission to access the 
Change Security ID task can change the security ID.

I know a job was set up, but I cannot see it in the software

In most Sage 300 Construction and Real Estate applications, record security affects only 
reports and inquiries. In certain Contracts, Job Cost, and Project Management tasks, 
however, record security also affects whether you can type jobs or select jobs from lists. 
For more information, see "Effect of record security on tasks" on page 56.

Jobs may not appear for several reasons:

 l The job may have a status of closed; some lists do not display closed jobs.

 l The job may have been moved to a different file, such as a history file.

 l Record security may be active on the job and you do not have permission to access 
that job.
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I forgot my password

If you are an application administrator or user, request a new password from one of your 
company's security administrators.

If you are the only security administrator and you forgot your password, you must call 
Customer Support to restore access to your software. See "Technical assistance" on 
page 3.

Note: For back-up purposes, we recommend having at least two security 
administrators.

My report or inquiry is missing information

A report or inquiry can be missing information for several reasons. One explanation could 
be that you lack record security permissions. To investigate this possibility, see the 
following topics.

Reports

 l "Effect of an upgrade on reports" on page 53

 l "Indicators that record security affects a report" on page 52

 l "Report record security settings" on page 51

 l "Review record security settings" on page 73

Inquiries

 l "Effect of record security on inquiries" on page 53

 l "Indicators that record security affects an inquiry" on page 55

 l "Inquiry record security settings" on page 54

Menu items and fields are unavailable

Menu items and fields can be unavailable for two reasons. 

First, the task associated with the menu item or field requires a previous task that has not 
been performed. For example, the Edit > Paste menu is unavailable if you have not 
previously cut or copied anything. 
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Second, you lack task security permissions (for example, access to PM > Setup > 
Properties.)

I cannot delete a user name

Note: You must be a security administrator to delete a security administrator.

If security is on and only one user name is assigned to the Security Administrator role, 
you cannot delete the user name assigned to that role. 

To delete the user name, you must assign another user name to the Security 
Administrator role. For more information, see "Add a security administrator" on page 58.

For back-up purposes, we recommend adding at least two security administrators.

I cannot make an account unavailable

If security is on and only one available user name is assigned to the security 
administrator or application administrator role, you cannot make the account unavailable.

To make the account unavailable, you must assign another available user to that 
administrator role.

Note: You must be a security administrator to assign a user to an administrator role.

For back-up purposes, we recommend adding at least two security administrators and 
two application administrators. If necessary, you can assign two user accounts to both 
roles.

I cannot end account availability

If security is on and only one user name is assigned to the security administrator or 
application administrator role as of this date, you cannot end account availability.

To end account availability, you must assign another available user name to that 
administrator role.

Note: You must be a security administrator to assign a user to an administrator role.
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For back-up purposes, we recommend adding at least two security administrators and 
two application administrators. If necessary, you can assign two user accounts to both 
roles.

I cannot remove a user name

Note: You must be a security administrator to delete a security administrator.

If security is on and only one user name is assigned to the Security Administrator role, 
you cannot remove the user name assigned to that role. 

To remove the user name, you must assign another user name to the Security 
Administrator role. For more information, see "Add a security administrator" on page 58.

For back-up purposes, we recommend adding at least two security administrators.

I cannot turn on security

Note: You must be a security administrator to turn on application security.

If a user name is not assigned to the Security Administrator role, you cannot turn on 
application security.

To turn on security, you must assign a user name to the Security Administrator role. For 
more information, see "Add a security administrator" on page 58.

For back-up purposes, we recommend adding at least two security administrators.

For the security settings to take effect, all users must restart Sage 300 Construction and 
Real Estate.

I cannot save changes

Note: You must be a security administrator to remove users from the Security 
Administrator role.

If security is on, you cannot remove all users from the Security Administrator role.
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To remove all the existing users from the Security Administrator role, first you must 
assign another user name to that role. For more information, see "Add a security 
administrator" on page 58.

For back-up purposes, we recommend having at least two security administrators.

Security tips
This section contains the following tips:

 l "Be careful with print files"

 l "Create separate roles for task and record security"

 l "Consider limiting access to Crystal Decisions Crystal Reports" on page 79

 l "Specify how secured tasks appear" on page 79
 

Be careful with print files

If you print to a folder that is not secure, others may have access to your reports.

By default, Sage 300 Construction and Real Estate prints files to your data folder. If you 
run the software over a network, all users print to this location. Although you can change 
the default file location in File > Data Folder Settings > File Locations > Printouts, all 
network users will still print to whatever location you designate.

To print to a different folder, you must redirect the print job at the time of printing. From a 
Print Selection window, click [Printer Setup]. Then, click [Select File] and browse to the 
desired location.

Create separate roles for task and record security

Administrators may need to create certain roles for task security and other roles for 
record security. For example, a company has the following users:

 l Project Manager 1

 l Project Manager 2

 l Accounts Payable (AP) Clerk 1

 l AP Clerk 2
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Project Manager 1 and AP Clerk 1 always work together on jobs. Project Manager 2 and 
AP Clerk 2 always work together on a different set of jobs. In terms of record security, 
these two teams of users should be members of different roles because they need access 
to different jobs.

Project Managers 1 and 2 perform tasks such as approving change orders (COs.) AP 
Clerks 1 and 2 perform tasks such as entering invoices. In terms of task security, the 
project managers should be in one role and the AP clerks should be in a different role.

The overall security assignment for these users should look like the following:

Role Users Task Permissions Record Permissions

PROJMGR Proj managers Approve COs   

APCLERK AP clerks Enter invoices   

TEAM1 Proj Mgr 1 and AP Clerk 1   Team 1 jobs

TEAM2 Proj Mgr 2 and AP Clerk 2   Team 2 jobs

Example of task and record permissions for various roles                 

Consider limiting access to Crystal Decisions Crystal Reports

A user can use Crystal Decisions Crystal Reports to disable record security settings on 
Crystal reports. If you own Crystal Decisions Crystal Reports, guard against unwanted 
modification of reports by limiting who can use this software. You may want to allow only 
administrators of Sage 300 Construction and Real Estate security to use Crystal 
Decisions Crystal Reports.

Specify how secured tasks appear

Most securable tasks have an associated menu item or field. Application administrators 
can specify how these menu items and fields appear to a user who does not have access 
to them. You can specify whether the menu items and fields are hidden or whether they 
appear gray (which indicates that they are unavailable.)
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 1.  Select Tools > Options.

 2.  In the Options window, look in the Secured Menu Items box. Select Don't display 
or Display as disabled.

 3.  Click [OK].

Notes:  

 l You must be an application administrator to perform this task.

 l The  menu is subject to task security. You may not be able to see this menu item 
if the application administrator has selected Don't display in the Secured Menu 
Items box.

 l Application administrators need to specify this setting in only one application for 
the effect to be seen in all applications.

Glossary of security terms
Application Administrator

An application administrator has unrestricted access to all features in Sage 300 
Construction and Real Estate. They can set up task security and set up most aspects of 
record security in the Security Administration tool. For a complete list of tasks that an 
application administrator can perform, see "Setting up security      " on page 57.

Like other users, an application administrator has a user name and password. If security 
is on, application administrators must type this user name and password after they start 
an application. 

Only security administrators can create users.

Application Log

Logs the start and end of Accounting applications and tasks.

Application Security

Application administrators can prevent unauthorized users from accessing Sage 300 
Construction and Real Estate by turning on application security. When application 
administrators turn on application security, all users must enter a user name and 
password to access the software. They can restrict access to software features and data 
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that each user has permission to access. Security Administration offers four types of 
application security: task, file, record, and company.

Application security also lets application administrators hide applications from users and 
roles. When an application administrator uses the Security Administration tool to deny a 
user or role access to all tasks in an application and sets secured menu items to not 
display, users cannot see the application in  the Sage Desktop.

Audit Setup Log

Logs changes when the audit setup activity is selected in an Accounting application.

Company Security

Company security allows an application administrator to grant a user access to specific 
companies.

Security administrators and application administrators have access to all companies. 

Field Report Log

Logs changes to finalized field reports in Project Management.

File Security

File security allows application administrators to block all access to a file. This includes 
access through open database connectivity and through all related tasks, reports, and 
inquiries. This differs from task security, which allows application administrators to block 
tasks selectively and does not allow them to control ODBC access.

Open Database Connectivity (ODBC)

Open Database Connectivity (ODBC) allows a Sage 300 Construction and Real Estate 
database and a third-party program such as Microsoft Access to communicate. Once you 
set up an ODBC connection (which requires a special ODBC driver), you can send data 
between the two programs.

Posting Recap Log

Logs recaps created while posting entries in Accounting. (For future use. No logs are 
created at this time.)

Record Security
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With record security, you can control access to the Cash Management bank account, 
General Ledger prefix, Job Cost and Project Management job, and Property 
Management property records.

When record security is active, reports and inquiries display only the records to which the 
user has access.

Record security also affects Job Cost, Contracts, and Project Management tasks. In 
these applications, you can type or select only jobs to which you have access.

Roles

A role represents a group of users who have the same security requirements. A role has 
its own user account and its own task, record, file, and company permissions.

Security Administration

With Security Administration, application administrators can restrict access to tasks, files, 
records, and companies. For example, they can use task security to restrict who can set 
up vendors in Accounts Payable. With file security, they can restrict access to sensitive 
payroll files. With record security, they can produce reports that display only the jobs to 
which the user has security access. Finally, with company security, they can restrict 
access to which company information a user sees.

Security Administrator

Security administrators set up and maintain accounts for users. For a complete list of 
tasks that a security administrator can perform, see "Setting up security      " on page 57.

Security Log

Logs events in the Security Administration tool.

Setup Log

Logs changes to setup information in Accounting.

Strong Passwords

Strong passwords must meet the following conditions for complexity:
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 l Passwords must be at least eight characters long.

 l Passwords must contain at least three of the following four character groups:

 l English uppercase characters (A through Z)

 l English lowercase characters (a through z)

 l Numbers (0 through 9)

 l Special characters (~  ! @ # $ % ^ & * ( ) - + = { } [ ] | \ : ; < , > . ? /)

 l Passwords expire every 90 days.

 l You are warned 10 days before your password expires.

 l You cannot reuse your three previous passwords.

 l You must wait 10 days before changing your password.

System Log

Logs Accounting system events.

Task Security

With task security, an application administrator can restrict access to menu items and 
certain tasks found within windows.

Task Summary Log

Logs summaries created during an Accounting task. (For future use. No logs are created 
at this time.)

User

A user has restricted access to the Sage 300 Construction and Real Estate. A user can 
have security permissions that range from very restrictive to almost as complete as an 
application administrator.

All users have a user name and password. If Security Administration is on, you must type 
a user name and password immediately after you start an application.
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Chapter 6: Sage 300 Construction and 
Real Estate ODBC
This chapter presents an overview of Sage 300 Construction and Real Estate open 
database connectivity (ODBC). After you install ODBC, you should refer to the ODBC 
Help for detailed information about how to use the driver to access databases.

ODBC overview
ODBC is a standard interface that serves as a translator between different database file 
structures and different software. The ODBC driver lets applications collect data from 
databases in other applications. Applications that can access data via ODBC are 
commonly referred to as front-end applications and can include databases (for example, 
Microsoft® Access), word processors (for example, Microsoft Word), and spreadsheets 
(for example, Microsoft Excel). Applications such as Sage 300 Construction and Real 
Estate that make their data available through ODBC are referred to as back-end 
applications. Both the front-end and back-end applications must support the ODBC 
protocol for them to communicate with one another.

The Sage 300 Construction and Real Estate ODBC driver lets you read most Accounting 
and Management Product records as well as create and delete some selected records. 
You cannot delete individual fields, but you can replace many fields with new data. See 
the "About record topics" topic in ODBC Help for a list of records and fields that you can 
edit. To access the Help file, click the Start icon, select the Sage Administration program 
group, and select  ODBC Help.
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Note:  

You cannot use the Sage 300 Construction and Real Estate ODBC driver to 
access Purchasing, Inventory, or Service Management data. To access 
Purchasing, Inventory, or Service Management data through ODBC, use the 
Pervasive ODBC Engine Interface and Pervasive ODBC Client Interface drivers. 
For more information, see the Pervasive Help:

 1.  Click the Start icon, select the Actian PSQL 12 program group, and select  
PSQL Control Center & Documentation.

 2.  In the Documentation Library area, click User’s Guide > Using PSQL > 
Setting Up ODBC Database Access.

Important issues for ODBC users
This section contains important information. You should read it before you use the Sage 
300 Construction and Real Estate ODBC driver.

ODBC Support Policy

Sage 300 Construction and Real Estate ODBC interfaces with a variety of third-party 
products. Because other products are involved, Sage cannot guarantee that our 
Customer Support can resolve all ODBC-related problems. Any multiple-vendor software 
arrangement requires a significant level of technical expertise. Technical conflicts 
between databases from different vendors may require you to seek assistance from a 
vendor other than Sage.

Important! Currently, we only test Microsoft Office (Access, Word, and Excel) for 
compatibility with the Sage 300 Construction and Real Estate ODBC driver. We 
do not test for compatibility with any other products or programming languages, 
including Microsoft Visual Basic for Applications, which can be run from a macro 
within Microsoft Office. Although you may find success using another product, 
Customer Support can address only issues and problems that relate to the use of 
Microsoft Office (Access, Word, and Excel) to access data via the ODBC driver. 
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Support for Crystal Reports 2020

Crystal Reports 2020 is now available as a 64-bit application which requires the use of 
64-bit DSNs. Sage 300 Construction and Real Estate version 24.1 and later supports 
Crystal Reports 2020 with the inclusion of a 64-bit ODBC driver, administrator, and 
continued support for existing 32-bit User Defined Libraries (UDFs).

NOTE: If you use Crystal Reports 2016 or earlier, this change does not affect you.  
32-bit versions of Crystal Reports are still supported in Sage 300 Construction and 
Real Estate.

Related Knowledgebase articles:

Setting Up 64-bit DSNs for PO/IV for use with Crystal Reports 2020

Setting Up 64-bit DSNs for SM on Client machine for use with Crystal Reports 2020

Configuration Step doc for making Crystal Reports Portable

Important! The ODBC 64-bit driver is tested only with Crystal Reports 2020.

Data loss
ODBC processing leaves no audit trail of changes made, and its misuse can create 
untraceable data discrepancies. If Customer Support is unable to reproduce a data-
dependent problem using Sage 300 Construction and Real Estate software and data, it is 
assumed that the problem is specific to a data discrepancy introduced with ODBC.

Points to consider before you use ODBC
For fields like notes and memos, Sage 300 Construction and Real Estate software simply 
stores the values. Some fields have a data dependency (the value in one field can affect 
the value of another field). In other fields, the software requires the value to have a certain 
format or be within a specified range. When you make changes through a Sage 300 
Construction and Real Estate application, the software handles dependencies 
automatically. ODBC does not handle dependencies. It is up to you to be aware of these 
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issues and make any necessary edits. To be safe, you should always back up any 
database before you modify it through ODBC.

Consider the issues that follow before you write changes to a data file through ODBC:

 l Data Dependencies: the values in some fields change based on the value contained 
in another field.

 l Referential Integrity: some records which reside in one data file relate to records in 
another file.

An example of referential integrity in Accounting is the relationship between a job 
record and one of its subsidiary category records. Amounts that you enter through a 
miscellaneous worksheet into a category’s miscellaneous category amount field 
directly affect the total miscellaneous category amount field in the job record. If you 
modify one of those fields through ODBC and do not modify the other, the Job Cost 
Master file becomes out of balance.

 l Formatting: Sage 300 Construction and Real Estate applications expect the value 
stored in some fields to be formatted in a certain way. 

Proper use of ODBC requires a thorough understanding of these dependencies to 
make sure referential integrity is preserved.

Set up a data source
Before you can use the ODBC driver, you must first set up a link to a Sage 300 
Construction and Real Estate data source. The data source contains the data a user 
wants to access and its associated Database Management System. The data is pulled 
from a back-end application, for example, General Ledger. The data is then sent to a 
front-end application, such as Microsoft Excel. Each data source you set up has a data 
source name (DSN), which you provide. 

When you set up a data source, you specify a particular ODBC driver to be attached to 
the data source. These drivers are programs that access the information in the database 
and translate it into a format that the front-end application (Microsoft Excel, for example) 
can read. 
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You must set up a DSN for each Sage 300 Construction and Real Estate database. For 
example, your company might maintain one database for its construction business and 
another for its remodeling business. Because these databases are stored in separate 
folders, you must set up a DSN for each database folder.

For detailed instructions on how to set up a DSN, see "The data source for Crystal 
Reports" on page 91.

Use the ODBC driver
After you install ODBC and set up a data source, you can use the driver to access Sage 
300 Construction and Real Estate information from the database. Procedures to collect 
this data depend on the front-end application being used. ODBC Help provides detailed 
instructions for accessing and inserting Sage 300 Construction and Real Estate data into 
Microsoft Query, Excel, Access, and Word. Refer to the How To section on the Help 
Contents tab for links to the applicable topics.

Other software manufacturers’ ODBC-compliant products can access data through the 
Sage 300 Construction and Real Estate ODBC driver. Refer to those manufacturers’ 
ODBC documentation for instructions on using ODBC.
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Chapter 7: Crystal Reports

Introduction
If you already have technical experience using Crystal Reports®, this chapter will help you 
customize reports and invoices that you use in Sage 300 Construction and Real Estate 
applications. Please review the entire chapter before making changes to your reports.

If you do not have experience using Crystal Reports, contact your Sage certified 
consultant for help with creating custom reports that fit your business needs. You can 
also attend training sessions in Crystal Reports; visit 
http://www.sageu.com/Sage300CRE for more information.

Support for Crystal Reports 2020

Crystal Reports 2020 is now available as a 64-bit application which requires the use of 
64-bit DSNs. Sage 300 Construction and Real Estate version 24.1 and later supports 
Crystal Reports 2020 with the inclusion of a 64-bit ODBC driver, administrator, and 
continued support for existing 32-bit User Defined Libraries (UDFs).

NOTE: If you use Crystal Reports 2016 or earlier, this change does not affect you.  
32-bit versions of Crystal Reports are still supported in Sage 300 Construction and 
Real Estate.

Related Knowledgebase articles:

Setting Up 64-bit DSNs for PO/IV for use with Crystal Reports 2020

Setting Up 64-bit DSNs for SM on Client machine for use with Crystal Reports 2020

Configuration Step doc for making Crystal Reports Portable

Important! The ODBC 64-bit driver is tested only with Crystal Reports 2020.
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Using the SQL database

You can use the Sage SQL Replicator tool to take the Sage 300 Construction and Real 
Estate data stored in the Actian Pervasive database and replicate it into a SQL database.

You can switch the Crystal Reports on the menus and Desktop to use the SQL database. 
For information, see page 90.

Important! If employees are going to run reports with SQL data, they need to have 
read permissions to the relevant SQL tables (in SQL Data Access > Read 
Access in the Tasks tree). See "Chapter 5: Security" on page 44 for information 
about controlling permissions.

You can create custom reports to use this SQL database. See "Creating the SQL Server 
data source" on page 94.

Reports on the menus
Use Report Manager to add Crystal Reports designs to the Reports menu of your Sage 
300 Construction and Real Estate applications.

Currently, all Crystal report designs available on the Reports menu in Sage 300 
Construction and Real Estate use your data stored in the Actian Pervasive database with 
a data source name (DSN) of "Timberline Data Source" (as described on page 91) having 
the following options:

 l Standard descriptions for Table and Field Naming

 l Use maximum table segment size selected

 l Shorten field and table names cleared.

Using the SQL database

If you use the Sage SQL Replicator tool, you have the option to use data stored in the 
Actian Pervasive database or replicatated data in the SQL database.  Crystal Reports on 
the menus will still use the Pervasive database unless you change them. To use the SQL 
database for your Crystal Reports that are accessed from menus or Desktop, select the 
Use SQL check box. For more information, see the Using SQL data for reporting video.
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The Mobile Reports application enables selected employees to generate and view 
Crystal Reports  in the field using a mobile device or computer. See the Mobile Reports 
Introduction video for more information.

The data source for Crystal Reports
If you use the Sage SQL Replicator tool, you have the option to use data stored in the 
Actian Pervasive database or replicatated data in the SQL database. If you plan to use 
the SQL data for new custom reports, see "Creating the SQL Server data source" on 
page 94.

Configuring the Timberline data source

You must configure the Timberline Data Source before you customize reports and 
invoices.

Note: Beginning with Sage 300 Construction and Real Estate version 16.1, you must 
have a properly configured DSN to run "Custom Description" reports—even though 
these reports may have run without a properly configured DSN in 15.1 and earlier 
versions of Sage 300 Construction and Real Estate.

Because the Timberline Data Source is automatically created the first time you open 
Sage 300 Construction and Real Estate, open a Sage 300 Construction and Real Estate 
application on your computer if you have not opened one already.

To set up portability options for a report in the ODBC Setup window:

 1.  Click the Start icon, select  the Windows Administrative Tools program group, and 
select ODBC Data Sources (32-bit).

 2.  In the ODBC Data Source Administrator window, click the User DSN tab, select 
Timberline Data Source, and click [Configure].

 3.  In the Timberline Data ODBC Setup window for Database Type, verify that 
Accounting Data Folder is selected.

 4.  Click [Select Folder], select your construction data folder in the Select Company 
window, and click [OK].

 5.  Click [Options] to show the Data Source Options.
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 a.  In the Table and Field Naming list, select Standard descriptions, Custom 
descriptions, or Dictionary names. For more information, see "About table 
and field naming" (the next section).

Note: Crystal Report designs that come with Sage 300 Construction and 
Real Estate use Standard descriptions.

 b.  Select the Use maximum table segment size check box. For more 
information, see "About the maximum table segment size" on page 94.

 c.  If necessary, clear the Shorten field and table names check box.

Note: This option is available for earlier versions of ODBC, which 
truncated long field and table names.

 6.  Click [OK] to save your settings and close the Timberline Data ODBC Setup 
window.

 7.  Click [OK] to close the Data Source Administrator window.

About table and field naming

The Table and Field Naming selection determines how table and field names appear 
when you access data using this data source name (DSN). Three options are available:

Naming 
option

Description

Standard 
descriptions

(Recommended) Use this mode when you design a report for use in 
multiple databases. The default descriptions appear on the report 
design in Crystal Reports Designer. However, the operators’ custom 
descriptions appear when the report is generated in Sage 300 
Construction and Real Estate. If you select this option, you can use this 
report with all databases.

Custom 
descriptions

Use this mode when you design reports for a specific database. The 
custom descriptions for that database appear on the report design in 
Crystal Reports Designer. The custom descriptions also appear when 

Naming options
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Naming 
option

Description

the report is generated in Sage 300 Construction and Real Estate.  If 
you select this option, you can only use it with databases that have the 
same custom descriptions as the database used when creating the 
report. If the custom descriptions in that database change, the report 
may break.

Dictionary 
names

Use this mode only when modifying Billing invoice reports and reports 
that were designed in Crystal Reports with dictionary names for Sage 
300 Construction and Real Estate earlier than version 8.0.0. Dictionary 
names are internal table and field names that are less descriptive than 
the standard descriptions but provide the same functionality. If you 
select this option, you can use this report with all databases. 

 

The following table uses the Accounts Receivable customer field as an example to show 
how different Field Naming options affect how the field appears.

Naming 
option

Display table and field name Comments

Standard 
descriptions

ARM_MASTER_
CUSTOMER.Customer

No change regardless of custom 
descriptions for AR Customer. 
Standard descriptions are always 
the default descriptions.

Custom 
descriptions

MASTER_ARM_
CUSTOMER.Customer

If the custom description for AR 
Customer is “client,” the field 
appears as MASTER_ARM_
CLIENT.client

Dictionary 
names

MASTER_ARM_RECORD_
1.CUST

No change regardless of custom 
descriptions. Internal names 
always appear in dictionary 

Appearance of a field with each naming option
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Naming 
option

Display table and field name Comments

names.

 

About the maximum table segment size

To use reports in Sage 300 Construction and Real Estate that were designed using the 
Timberline Data Source, you must select the Use maximum table segments size check 
box when you design the reports so that tables remain intact regardless of size. If you 
clear the Use maximum table segment size check box and you access a table with more 
than 255 columns, the table is split into two tables.

For example, the Job Cost JC job record contains more than 255 columns. If you clear the 
Use maximum table segment size check box, the table splits into two tables (JCM_
Master_Job_1 and JCM_Master_Job_2). If you select the Use maximum table segment 
size check box, the table does not split (JCM_Master_Job).

Important! Some programs, including Microsoft® Access, do not support the use of 
maximum table segment size. Clear the check box when you use DSNs associated with 
those programs. You should set up a separate DSN for these programs.

About the maximum number of database objects

If you connect to a data source that contains a large number of objects (tables, views, 
stored procedures, etc.), you may need to change the display limit, which is usually set to 
8000 objects. For more information, see SAP knowledgebase article 1215994.

Creating the SQL Server data source

The Sage SQL Replicator tool, which takes the Sage 300 Construction and Real Estate 
data stored in the Actian Pervasive database and replicates it into a SQL database. You 
can create custom reports to use this SQL database.

To create a DSN for the SQL database:

 1.  Open the ODBC Data Source Administrator (64-bit) window.

 2.  On the User DSN tab, click [Add] to add a new User DSN.
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 3.  Select SQL Server Native Client 11.0.

 4.  Click [Finish].

 5.  Type a name for the DSN, such as Timberline SQL Data, and type a description.

 6.  For the SQL Server to connect to, select the SQL Server Instance that contains your 
replicated data, and then click [Next].

 7.  Select With Integrated Windows authentication, and then click [Next].

 8.  Select the Change the default database to check box, select the replicated 
database, and then click [Next].

 9.  Click [Finish].

 10.  Review the new ODBC data source setup and either click [Test Data Source] or 
click [OK].

 11.  Review the new entry in the User Data Sources table on the User DSN tab, and 
then click [OK].

Customizing Crystal Reports

Crystal Reports Designer

You should use Crystal Reports For Sage 2013 SP2 (version 13) to modify or create 
report designs for Accounting and Management Products. This software only runs on 
Windows 7 SP1, Windows Server 2008 R2, or higher operating systems (not Windows 
Vista).

Note:  

If you created custom Crystal Reports designs prior to Sage 300 Construction and 
Real Estate version 14.1, you will need to upgrade the designs before using them 
in Sage 300 Construction and Real Estate.  To upgrade designs created with 
version 9 or later, see "Upgrading custom reports using the Upgrade Crystal 
Reports tool" on page 140.

Creating and modifying custom reports

To add, modify, and create custom report designs that  use the Timberline Data Source:
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 1.  Open Crystal Reports.

 2.  Log on to a Timberline data source.

 a.  If you do not have the report open, select File > Log On or Off Server. If you 
have the report open, select Database > Log On or Off Server.

 b.  In the Data Explorer window, double-click Create New Connection. 

 c.  Double-click ODBC (RDO). 

 d.  Select Timberline Data Source and click [Next].

 e.  If necessary, type your User ID and Password for Sage 300 Construction 
and Real Estate.

 f.  Click [Finish].

 g.  Click [Close].

 3.  Open the report design you want to modify and proceed to step 4. If you want to 
create a new report design:

 a.  Select File > New.

 b.  Select the tables and fields that you want to use on the report and then 
design the report.

 4.  Set the location of the database. 

 a.  Select Database > Set Datasource Location.

 b.  Under Current Data Source, select the first data source.

 c.  Under Replace with, select Timberline Data Source. 

 d.  Click [Update].

 e.  Verify that all table locations in the Set Datasource Location window use 
the same data folder path. You know that all table locations point to the 
same path if only one group of tables appears under Current Data Source.

 f.  Click [Close].

 5.  Repeat step 4 for each table in the report.

 6.  Select Database > Verify Database.

 7.  When you see the “The database is up to date.” message, click  [OK]. Repeat step 4 
if the database is not up to date.
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 8.  Review the list of formulas, functions, and parameters from section 3. See "Crystal 
Reports integration" on page 97 to determine which to add or modify.

 9.  When you finish, save the report.

 10.  Use Reports Manager to add new reports to your Sage 300 Construction and Real 
Estate Reports menu.

Crystal Reports integration

Setting up printers

By default, the “No Printer” option (Crystal Reports: File > Page Setup) is selected for all 
Crystal report designs that ship with Sage 300 Construction and Real Estate. We 
recommend selecting this option for all Crystal reports you use to avoid potential printer 
error messages when using Sage 300 Construction and Real Estate applications with the 
Windows 7 operating system.

When printing a report in Crystal Reports, the data may print as cryptic symbols even 
though the report displays correctly in preview mode. This is because Crystal Reports 
requires Unicode functions to print. If your printer driver does not support Unicode, you 
must update your printer driver. To determine whether your printer driver supports 
Unicode, see the printer driver manufacturer's support web site. 

Note: In Crystal Reports, you must select Crystal Syntax for the Default Formula 
Language (File > Options > Formula Editor tab  > Default Formula Language).

Integration formulas

This section provides information about the following formulas that you can use in report 
designs.

 l tsAlternateSMFolder on page 98

 l tsApp on page 99

 l tsAskFile on page 99

 l tsDataFolder on page 100

 l tsDesignMode on page 101
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 l tsDesktopId on page 102

 l tsLetterhead on page 102

 l tsMargins on page 103

 l tsReportType on page 103

 l tsSQLDatabase on page 104

 l tsSQLServer on page 104

 l tsSubAskFile on page 104

Designs created in Crystal Reports use formulas to convey required report information to 
Sage 300 Construction and Real Estate. These formulas query the Sage 300 
Construction and Real Estate application for, or provide it with, required information that 
is not already in a database table field. For example, you may need to set the margins of 
the report when it prints. You use a formula to provide the margin information to the 
application. 

Caution! Name the formulas exactly as they are named in this document. Formulas 
may be case sensitive and may not work unless the formula name matches the 
corresponding formula written in Sage 300 Construction and Real Estate code. Also, 
do not add comments or additional expressions to the formulas.

Important! Do not type @ in front of formula fields. In Crystal Reports, “@” 
automatically appears in front of formula fields; for example, when you create a formula 
and type tsDesignMode, the formula appears as @tsDesignMode.

Note: Integration formulas need only to be included in the report design to function. You 
do not need to include these formulas on the report itself.

 

Formula: tsAlternateSMFolder

Description
This formula allows you to select whether you want a Service 
Management report to include current or historical information.

Syntax None. Leave the formula value blank.

tsAlternateSMFolder formula information
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Formula: tsAlternateSMFolder

Example @tsAlternateSMFolder=

 

Formula: tsApp

Description

Use this formula to specify the application abbreviation for the report. 
This formula is required on all Service Management primary reports and 
subreports. The formula is not required on any report that uses the 
ODBC driver to access Sage 300 Construction and Real Estate data.

Syntax “<Two-letter application abbreviation>”

Example @tsApp = “SM”

tsApp formula information

Formula: tsAskFile

Description

Use the tsAskFile formula to limit the file types the operator can choose 
when the report runs. This formula applies to the main report. It also 
applies to all subreports unless you use the tsSubAskFile formula on the 
subreports. This formula does not have file merging capabilities. If you 
use the formula example on a report design, the report will prompt the 
operator to choose between the New.glt file and the Current.glt file when 
the report runs. Without the formula on the report, the operator could 
choose whatever file codes are available.

For more information, see                      "Formula: tsSubAskFile" on page 104

Syntax

“[<file type>(<file code name>[,<file code name>]*)]”

<file type> = the abbreviation of the data file type; for example: BLI, GLT, 
APT, etc.

<file code name> = the file code name of the data file; for example: new, 
current, history, active, standard, etc.

Example @tsAskFile = “GLT(new,current)” or “GLT(new, current)JCT(current)”

tsAskFile formula information
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Note: You can also use one file code name in the tsAskFile function to force the report 
to use a specific file; for example, use @tsAskFile = “JCT(new)”.

Formula: tsDataFolder

Description

Use this formula to specify the company data folder to use for previewing 
the report in Crystal Reports Designer.

This formula is ignored when the report is generated in Sage 300 
Construction and Real Estate.
If using Pervasive data, it will be a data folder path from the Open 
Company window.
If using SQL data, it will be the SQL instance and current database in this 
format:
“SQL::SQLServerName\InstanceName:DatabaseName”

Example

@tsDataFolder = “C:\Timberline Office\YourCompanyDataFolder”

@tsDataFolder = “SQL::LSSVR20-
MP\SAGE300CRE:SQLDataFolder”

tsDataFolder formula information

Caution! If you place this formula on a primary report and you want to use it on a 
subreport, you must pass the formula to the subreport as a shared variable. Subreports 
do not automatically read the formula from the primary report. 

You can use the tsDataFolder formula with any of the following user-defined functions:

 l tsarContractOnlyDetail

 l tsarContractCustomerDetail

 l tsarCustomerDetailWithRetainage

 l tsarJobCustomerDetail

 l tsarJobOnlyDetail

 l tsControlData

 l tsCustomDescription

 l tsFieldSection
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 l tsFieldSectionDesc

 l tsglFiscalEntityInfo

 l tsHeaderData

 l tsItemDesc

 l tsLetterheadStyle

For more information on these functions, see "User-defined functions" on page 105.

Set the tsDataFolder formula to the same data path appearing in the Database box of the 
ODBC Setup window for the DSN if the report uses any of these user-defined functions:

 l tsControlData

 l tsHeaderData

 l tsCustomDescription

Formula: tsDesignMode

Description

This formula specifies the mode of the report design—and must match  
the Table and Field Naming setting of the DSN. 

When you run the report from Sage 300 Construction and Real Estate, 
the tsCrystal interface looks to the report design for the tsDesignMode 
formula. If the formula exists on the design, the system takes the value of 
the formula and sets the Table and Field Naming selection to match it. If 
the formula is not on the report, the Table and Field Naming selection is 
automatically set to Custom descriptions. If the report is written using a 
Pervasive data source and the Use SQL check box is selected when it is 
generated, this formula determines the correct schema to use from the 
SQL database.

Syntax
“<mode>”; mode can be “Dictionary” (dictionary names), "SDesc” 
(standard description), or "Custom" (custom description).

Example @tsDesignMode = “SDesc”

tsDesignMode formula information
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Note: Custom Billing invoice formats and subreports must include the tsDesignMode 
formula with a value of “Dictionary”. See "About table and field naming" on page 92 for 
more information.

Important! tsDesignMode must be included with every report design written with a 
Pervasive data source. If you want to prevent database switching, do not include the 
tsDesignMode formula.

Formula: tsDesktopId

Description

If you use security and you link a Desktop home page to an estimate, 
Sage 300 Construction and Real Estate will ask for your user name and 
password when you open the estimate. Use the tsDesktopId formula 
together with the TSEstimatingDKM function to suppress the request for 
user name and password when you open an estimate from a home page. 
See "Function: tsEstimatingDKM" on page 114 for more information on 
applying this function. 

Add the tsDesktopId function to the main report. Add the 
TSEstimatingDKM function to hyperlinks that link to estimates. 

Example @tsDesktopId = “”

tsDesktopId formula information

 

Formula: tsLetterhead

Description

Use this formula in conjunction with the tsLetterheadStyle function.

This formula dynamically places the letterhead image when the report 
runs. This formula is not required. This formula dynamically places the 
letterhead image only when the formula is set to “Y” and you have 
selected the Use this letterhead image below for my forms option in the 
Options window (Tools > Options > Letterhead tab > Use the 
letterhead image below for my forms). Sage 300 Construction and Real 
Estate will not dynamically place the letterhead image if any of the 

tsLetterhead formula information
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following conditions are true:

 l You set the formula to “N.” 

 l You select one of the other letterhead options in the Options window

 l You do not include the formula on the report.

For more information on the tsLetterheadStyle function, see "Function: 
tsLetterheadStyle" on page 119.

 

Formula: tsMargins

Description

Use the tsMargins formula to display the [Page Setup] button on the 
Print Selection window when you run the report from the Report menu 
in Sage 300 Construction and Real Estate. The tsMargins formula allows 
you to the set margins for the report.

Example @tsMargins =

tsMargins formula information

 

Formula: tsReportType

Description

Use this formula to force the report to use SQL as the data source. This 
is useful for process-based reports (that run after a task) or where  the 
Use SQL check box is not available. This formula should be on all 
reports written using a SQL data source.

Syntax SQL

Example @tsReportType = “SQL”

tsReportType formula information
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Formula: tsSQLDatabase

Description
Use this formula to show the SQL Database name when you run the 
report in Sage 300 Construction and Real Estate with the Use SQL 
check box selected. This is only an informational reporting field.

tsSQLDatabase formula information

 

Formula: tsSQLServer

Description
Use this formula to show the SQL instance name when you run the 
report in Sage 300 Construction and Real Estate with the Use SQL 
check box selected. This is only an informational reporting field.

tsSQLServer formula information

 

Formula: tsSubAskFile

Description

Use the tsSubAskFile formula on subreports only. Use this formula to 
limit the file types the operator can choose for the subreport when it runs.

To limit the file types the operator can choose for the main report, use the 
tsAskFile formula. See "Formula: tsAskFile" on page 99 for more 
information.

The tsSubAskFile formula applies to only the subreport on which you use 
it, not to other subreports. This formula does not have file merging 
capabilities. If you use the formula example on a report design, the report 
will prompt the operator to choose between the New.jct file and the 
Current.jct file when the report runs. Without the formula on the report, 
the operator could choose from the new, current, or history file.

Syntax

 “[<file type>(<file code name>[,<file code name>]*)];Prompt Text”

<file type> = the abbreviation of the data file type; for example: BLI, GLT, 
APT, etc.

tsSubAskFile formula information
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Formula: tsSubAskFile

<file code name> = the file code name of the data file; for example: new, 
current, history, active, standard, etc.

Prompt Text = Text to inform the person that runs the report. You can 
use the prompt text to indicate which subreport requires this selection.

Example
@tsSubAskFile = “JCT(new,current);Select a file for the Job Cost 
Transaction subreport”

Note: You can also use one file code name in the tsSubAskFile function to force the 
report to use a specific file: for example, use @tsSubAskFile = “JCT(new)”.

User-defined functions

You can use the Sage 300 Construction and Real Estate user-defined functions in 
conjunction with Crystal Reports formulas on all reports. These user-defined functions 
instruct the application how to transform the data retrieved by a formula. To select a user-
defined function, in the Formula Editor, click Functions > Additional Functions.

This section provides information about the following user-defined formulas:

 l pjLastJobUsed on page 106

 l rmCurrentPropertyID on page 106

 l rmSetupInfo on page 106

 l tsarContractCustomerDetail on page 107

 l tsarContractOnlyDetail on page 108

 l tsarCustomerDetailWithRetainage on page 109

 l tsarJobCustomerDetail on page 110

 l tsarJobOnlyDetail on page 111

 l tsControlData on page 112

 l tsCustomDescription on page 113

 l tsEstimatingDKM on page 114

 l tsFieldSection on page 114

 l tsFieldSectionDesc on page 115
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 l tsglFiscalEntityInfo on page 116

 l tsHeaderData on page 117

 l tsItemDesc on page 118

 l tsLetterheadStyle on page 119

 l tsOperator on page 120

 l tsRange on page 121

Function: pjLastJobUsed

Description

If you use this function on a field in the report design and if you selected 
the Use last job option in PJ Settings (Project Management: File > 
Company/Data Folder Settings > PJ Settings), the field retrieves the 
job number from of the last job used.

Syntax pjLastJobUsed

Example pjLastJobUsed()

pjLastJobUsed function information

 

Function: rmCurrentPropertyID

Description
Use to retrieve the current Residential Management (RM) property. The 
current property is the property currently open or the last property 
opened in the RM application.

Example rmCurrentPropertyID()

rmCurrentPropertyID function information

 

Function: rmSetupInfo

Description
Use to retrieve setting information based on the Residential 
Management property you specify. The design retrieves the setting for 

rmSetupInfo function information
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Function: rmSetupInfo

the property if it is specific to the property; otherwise, it retrieves the 
system setting.

Syntax

rmSetupInfo(property, setting)

Property: The Property ID
Setting: The system setting you want to retrieve

Example rmSetupInfo(rmCurrentPropertyID()”DefaultDepositCode”)

Function: tsarContractCustomerDetail

Description
Use this function to determine whether Accounts Receivable (AR) 
details should print for the specified contract and customer

Syntax

tsarContractCustomerDetail(Data Folder, AR Activity File, AR 
Transaction File, Contract, Customer, Aging As Of Date, Aging 
Basis, Include Retainage, Unpaid Only, Age Finance Charge)

Data Folder: The report design must use the tsDataFolder formula, 
which stores the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction 
(current.art) file.
Contract: The Contract ID.
Customer: The CustomerID.
Aging as of Date: The transaction cutoff date based on the Aging 
Basis date.
Include Retainage: True or False value. A True value takes retainage 
transactions into account. A False value bypasses retainage 
transactions.
Unpaid Only: True or False. A True value considers transactions at the 
invoice (status) level. A False value considers transactions at the 
Activity level.
Age Finance Charge: True or False value. A True value includes 

tsarContractCustomerDetail function information
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finance charges. A False value bypasses finance charges.

Example

(From report AR Statement of Account(CR).rpt)

tsarContractCustomerDetail({tsDataFolder},{@tsFileName(ARA)},
{@tsFileName(ART)},{ART_CURRENT_TRANSACTION.Contract},
{ART_CURRENT_TRANSACTION.Customer},{?Aging Date},
{?Aging Basis},{?Include Retainage?},{?Unpaid only?},{?Include 
Finance Charges?})

Function: tsarContractOnlyDetail

Description
Use this function to determine whether Accounts Receivable (AR) details 
should print for the specified contract.

Syntax

tsarContractOnlyDetail(Data Folder, AR Activity File, AR Transaction 
File, Contract, Aging As Of Date, Aging Basis, Include Retainage, 
Unpaid Only, Age Finance Charge)

Data Folder: The report design must use the tsDataFolder formula, 
which stores the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction 
(current.art) file.
Contract: The Contract ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis 
date.
Aging Basis: The date that the Aging as of Date uses to determine the 
cutoff date.
Include Retainage: True or False value. A True value takes retainage 
transactions into account. A False value bypasses retainage 
transactions.
Unpaid Only: True or False. A True value considers transactions at the 
invoice (status) level. A False value considers transactions at the Activity 

tsarContractOnlyDetail function information
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Function: tsarContractOnlyDetail

level.
Age Finance Charge: True or False value. A True value includes 
finance charges. A False value bypasses finance charges.

Example

(From report AR Statement of Account (CR).rpt)

tsarContractOnlyDetail({@tsDataFolder},{@tsFileName(ARA)},
{@tsFileName(ART)},{ART_CURRENT_TRANSACTION.Contract},
{?Aging Date},{?Aging Basis},{?Include Retainage?},{?Unpaid 
only?},{?Include Finance Charges?})

Function: tsarCustomerDetailWithRetainage

Description
Use this function to determine whether Accounts Receivable details 
should print for the specified customer.

Syntax

tsarCustomerDetailWithRetainage(Data Folder, AR Activity File, 
AR Transaction File, Customer, Aging As Of Date, Aging Basis, 
Include Retainage, Unpaid Only, Age Finance Charge)

Data Folder: The report design must use the tsDataFolder formula, 
which stores the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction 
(current.art) file.
Customer: The Customer ID.
Aging as of Date: The transaction cutoff date based on the Aging 
Basis date.
Aging Basis: The date that the Aging as of Date uses to determine 
the cutoff date.
Include Retainage: True or False value. A True value takes 
retainage transactions into account. A False value bypasses 
retainage transactions.
Unpaid Only: True or False. A True value considers transactions at 

tsarCustomerDetailWithRetainage function information
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the invoice (status) level. A False value considers transactions at 
the Activity level.
Age Finance Charge: True or False value. A True value includes 
finance charges. A False value bypasses finance charges. 

Example

(From report AR Statement of Account (CR).rpt)

tsarCustomerDetailWithRetainage({@tsDataFolder},
{@tsFileName(ARA)},{@tsFileName(ART)},{ART_CURRENT_
TRANSACTION.Customer},{?Aging Date},{?Aging Basis},
{?Include Retainage?},{?Unpaid only?},{?Include Finance 
Charges?})

Function: tsarJobCustomerDetail

Description
Use this function to determine whether Accounts Receivable details 
should print for the specified job and customer.

Syntax

tsarJobCustomerDetail(Data Folder, AR Activity File, AR Transaction 
File, Job, Customer, Aging As Of Date, Aging Basis, Include 
Retainage, Unpaid Only, Age Finance Charge)

Data Folder: The report design must use the tsDataFolder formula, 
which stores the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction 
(current.art) file.
Job: The Job ID.
Customer: The Customer ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis 
date.
Aging Basis: The date that the Aging as of Date uses to determine the 
cutoff date.
Include Retainage: True or False value. A True value takes retainage 

tsarJobCustomerDetail function information
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transactions into account. A False value bypasses retainage 
transactions.
Unpaid Only: True or False. A True value considers transactions at the 
invoice (status) level. A False value considers transactions at the Activity 
level.
Age Finance Charge: True or False value. A True value includes 
finance charges. A False value bypasses finance charges. 

Example

(From report AR Statement of Account (CR).rpt)

tsarJobCustomerDetail({@tsDataFolder},{@tsFileName(ARA)},
{@tsFileName(ART)},{ART_CURRENT_TRANSACTION.Job},{ART_
CURRENT_TRANSACTION.Customer},{?Aging Date},{?Aging 
Basis},{?Include Retainage?},{?Unpaid only?},{?Include Finance 
Charges?})

Function: tsarJobOnlyDetail

Description
Use this function to determine whether Accounts Receivable details 
should print for the specified job.

Syntax

tsarJobOnlyDetail(Data Folder, AR Activity File, AR Transaction File, 
Job, Aging As Of Date, Aging Basis, Include Retainage, Unpaid Only, 
Age Finance Charge)

Data Folder: The report design must use the tsDataFolder formula, 
which stores the folder path information.
AR Activity File: The full file path to the AR Activity (activity.ara) file.
AR Transaction File: The full file path to the current AR Transaction 
(current.art) file.
Job: The Job ID.
Aging as of Date: The transaction cutoff date based on the Aging Basis 
date.
Aging Basis: The date that the Aging as of Date uses to determine the 

tsarJobOnlyDetail function information
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cutoff date.
Include Retainage: True or False value. A True value takes retainage 
transactions into account. A False value bypasses retainage 
transactions.
Unpaid Only: True or False. A True value considers transactions at the 
invoice (status) level. A False value considers transactions at the Activity 
level.
Age Finance Charge: True or False value. A True value includes 
finance charges. A False value bypasses finance charges. 

Example

(From report AR Statement of Account (CR).rpt)

tsarJobOnlyDetail({@tsDataFolder},{@tsFileName(ARA)},
{@tsFileName(ART)},{ART_CURRENT_TRANSACTION.Job},
{?Aging Date},{?Aging Basis},{?Include Retainage?},{?Unpaid 
only?},{?Include Finance Charges?})

Function: tsControlData

Description
Use this function to retrieve information such as company name, 
address, and phone number from the Ts.ctl file.

Syntax

tsControlData(Data Folder Name, Field Name, Flags)

Data Folder Name: The report design must use the tsDataFolder 
formula, which stores the folder path information.
Field Name: You can type (case sensitive):
 l “Name”
 l “Address” or “Address 1” and “Address 2”
 l “City”
 l “State” 
 l “Zip”
 l “Phone”
 l “Fax"
 l “Email"
 l “Web Address"

tsControlData function information
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 l “Accounting Method”
 l “Assign Batch Name”

Flags: You can type
 l “P” to pluralize.
 l “A” for all capital letters.
 l “I” for initial capital letters.
 l “F” to capitalize the first letter only.
 l “L” for all lowercase.
 l “” to print as it is in the database.

Example
tsControlData(@tsDataFolder, “Name”, “A”) prints the company name 
in all capital letters.

Function: tsCustomDescription

Description This function retrieves custom descriptions from the ts.fld file.

Syntax

tsCustomDescription(Data Folder Name, Code, Flags)

Data Folder Name: The report design must use the tsDataFolder 
formula, which stores the folder path information.
Code: The custom description field code.
Flags: You can type:
 l “P” to pluralize.
 l “A” for all capital letters.
 l “I” for initial capital letters.
 l “F” to capitalize the first letter only.
 l “L” for all lowercase.
 l “” to print as it is in the database.

Example
tsCustomDescription(@tsDataFolder, 13, “A”) prints the JC Change 
Order custom description in all capital letters.

tsCustomDescription function information
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Note: All custom description codes are stored in the Ts.fld file. Custom descriptions are 
listed when you print an available fields report (TR:Tools > Available Fields) and you 
select the Include information for ODBC reporting? check box in the PrintAvailable 
Fields – Print Selection window.

The tsCustomDescription function was new on Accounting and Management Products 
8.0.0  and is used on new Crystal Reports designs. Earlier versions stored a function with 
a slightly different syntax called tsCustomDesc. The Billing invoice reports still use the 
older function. Both functions are stored in the u2lts.dll file on Accounting and 
Management Products 8.0.0 and later.

Function: tsEstimatingDKM

Description

If you use security and you link a report design used as a Sage 300 
Construction and Real Estate Desktop home page to an estimate, Sage 
300 Construction and Real Estate will ask for your user name and 
password when you open the estimate. Use the tsEstimatingDKM 
function to suppress the request for user name and password when you 
open an estimate from a home page in Desktop.

Syntax

tsEstimatingDKM({@tsDesktopID}, {Detail.PATH} & “\” & 
{Detail.FILENAME});

Detail.PATH and Detail.FILENAME are fields that store the estimate’s 
path and file name in the Estimating Explorer database.

tsEstimatingDKM function information

Note: You must add the tsDesktopId formula to the main report when you use the 
tsEstimatingDKM function in a hyperlink to an estimate.

Function: tsFieldSection

Description

Use this function to determine the value in a customer-specified field 
section. A field section is any portion of the GL Account, JC Job, or AR 
Customer that you define. For example, you can define up to 3 prefixes, 

tsFieldSection function information
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the base, and the suffix of a GL Account. Therefore, these are field 
sections. Using the tsFieldSection function, you can retrieve the prefix, 
base, or suffix field information from the GL Account.

Syntax

tsFieldSection(Data Folder Name, File Type, Field Name, Section, 
Value)

Data Folder Name: Type a path to the data folder or use the 
tsDataFolder formula, which stores the folder path information.
File Type: The type of file. For example, type “GLM” for the General 
Ledger account file or “JCM” for the Job Cost master file.
Field Name: The name of the field. For example, type “AACCT” for the 
General Ledger account field.
Section: Section 1, Section 2, or Section 3; Base; Suffix
Value: The ODBC field name on which to act. 

For example, GLT_CURRENT_TRANSACTION.Account for the 
Account number from the GLT current transaction file, GLM_MASTER_
ACCOUNT.Account for the Account number from the GLM Master 
account record, or JCM_MASTER_JOB.Job for the job number from the 
JCM Job record. 

Example
tsFieldSection(@tsDataFolder, “GLM”, “AACCT”, “Section 1”, GLM_
MASTER_ACCOUNT.Account) prints the information in section 1 of the 
GL Master Account field.

Function: tsFieldSectionDesc

Description

Use this function to determine the description in a customer-specified 
field section. A field section is any portion of the GL Account, JC Job, or 
AR Customer that you define. For example, you can define up to 3 
prefixes, the base, and the suffix of a GL Account. Therefore, these are 
field sections. Using the tsFieldSection function, you can retrieve the 
prefix, base, or suffix field description information from the GL Account.

tsFieldSectionDesc function information

115



Function: tsFieldSectionDesc

Syntax

tsFieldSectionDec(Data Folder Name, File Type, Field Name, 
Section, Flags)

Data Folder Name: Type a path to the data folder or use the 
tsDataFolder formula, which stores the folder path information.
File Type: The type of file. For example, type “GLM” for the General 
Ledger account file or “JCM” for the Job Cost master file.
Field Name: The name of the field. For example, type “AACCT” for the 
General Ledger account field.
Section: Section 1, Section 2, or Section 3; Base; Suffix
Flags: You can type:
 l “P” to pluralize.
 l “A” for all capital letters.
 l “I” for initial capital letters.
 l “F” to capitalize the first letter only.
 l “L” for all lowercase.
 l “” to print as it is in the database.

Example
tsFieldSectionDesc(@tsDataFolder, “GLM”, “AACCT”, “Section 1”, 
“A”) prints the section 1 description of the GL Master Account field in all 
caps.

Function: tsglFiscalEntityInfo

Description

Use this function to report on the Australian Business Number (ABN) for 
General Ledger or Accounts Payable accounts. For General Ledger 
accounts, you can report on the ABN for a General Ledger prefix or the 
entire account number. 

Syntax

tsglFiscalEntityInfo(Data Folder Name, Field Name, Prefix or 
Account, Account Section)

Data Folder Name: Type the path to the data folder or use the 
tsDataFolder formula, which stores folder path information.
Field Name: You must use “abn” as the field name.

tsglFiscalEntityInfo function information

116



User's Guide

Function: tsglFiscalEntityInfo

Prefix or Account: Type a valid prefix number or account number from 
the general ledger chart of accounts or type a valid accounts payable 
account number.
Account Section: Type the section of the account to use. You can type:
 l “account”
 l “prefix a”
 l “prefix b”
 l “prefix c”
 l “full prefix”

Example tsglFiscalEntityInfo(@tsDataFolder,”abn”,”10-1201”,”account”)

Function: tsHeaderData

Description
Use to determine the header information, such as header records in the 
BLM file.

Syntax

tsHeaderData(Data Folder Name, File Name, Header Number, Field 
Name, Flags)

Data Folder Name: The report design must use the tsDataFolder 
formula, which stores the folder path information.
Name: Use the actual file name; for example, Master.apm or 
Master.blm.
Header Number: Identifies the header record from which the field is 
retrieved.
Field Name: Use the internal field name; for example, SATXT or PABN.
Flags: You can type:
 l “P” to pluralize.
 l “A” for all capital letters.
 l “I” for initial capital letters.
 l “F” to capitalize only the first letter.
 l “L” for all lowercase.
 l “” to print as it is in the database.

Example tsHeaderData(@tsDataFolder, “Master.blm”, 2,”SATXT”, “PA”) 

tsHeaderData function information
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Function: tsHeaderData

retrieves the Auto Text field from the BL Settings Header, adds an “s” to 
the end, and prints in all capital letters.

Notes: Internal field names are listed when you print an available fields report (TR: 
Tools > Available Fields) and you select the Include information for ODBC 
reporting? check box in the Print Available Fields – Print Selection window.

To retrieve a date field, you must use the Crystal Reports ToDate function to convert 
the string value to a date. To retrieve a number, you must use the Crystal Reports 
ToNumber function to convert the string value to a number.

Function: tsItemDesc

Description
This function returns the description of a list field. Use this function to 
perform string comparisons on list fields that contain custom 
descriptions.

Syntax

tsItemDesc(Data Folder Name, File Type, Field Name, Item Name, 
Format)

Data Folder Name: Type a path to the data folder or use the 
tsDataFolder formula, which stores the folder path information.
File Type: The type of file. For example, type “ART” for the accounts 
receivable transaction file.
Field Name: The name of the custom list field. For example, type 
“TATYPE” for the accounts receivable Amount Type custom list.

Item Name: The short description of the custom list item. For example, 
type “PMT” for the cash receipt accounts receivable amount type.
Format:
 l “P” to pluralize.
 l “A” for all capital letters.
 l “I” for initial capital letters.
 l “F” to capitalize the first letter only.
 l “L” for all lowercase.

tsItemDesc function information
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Function: tsItemDesc

 l “” to print as it is in the database.

Example tsItemDesc(@tsDataFolder, “ART”, “TATYPE”,”Lab”,”A”) returns LAB

Note: When you use tsItemDesc for literal string comparisons, set the Format 
parameter to nothing (““) to return the description unchanged.

Function: tsLetterheadStyle

Description

This function retrieves your Sage 300 Construction and Real Estate 
letterhead settings (Tools > Options > Letterhead tab) and returns one 
of the following values:

 l “NONE”—No logo prints. The company name and address print in the 
header section.

 l “PREPRINTED”—No logo prints. Header is blank to accommodate 
letterhead stationery.

 l “CUSTOM”—Logo prints on the left. Company address prints on the 
right.

To accommodate the use of different database-specific Sage 300 
Construction and Real Estate letterhead settings, all report designs 
created in Crystal Reports and included in the software have separate 
header sections for all three letterhead options. The tsLetterheadStyle 
function is used as a suppress condition on a header section. The 
function determines which letterhead to use and suppresses the unused 
letterheads when the report prints.

tsLetterheadStyle function information
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Function: tsLetterheadStyle

Example

(Page Header—Suppress Condition)

Custom: tsLetterheadStyle({@tsDataFolder}) <> “CUSTOM”

Preprinted: tsLetterheadStyle({@tsDataFolder}) <> “PREPRINTED”

None: tsLetterheadStyle({@tsDataFolder}) <> “NONE”

Function: tsOperator

Description
Use to determine the identity or the description of the operator printing 
the report

Syntax

tsOperator(“Id”) or tsOperator(“Desc”)

Id: The identifier for the operator.

Desc: The description for the operator. For example, the name of the 
operator.

Example

tsOperator(“Id”) prints the Sage 300 Construction and Real Estate 
Security Id

tsOperator(“Desc”) prints the Sage 300 Construction and Real Estate 
Security operator description.

tsOperator function information
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Function: tsRange

Description

Use this function to add range values to custom Crystal Report designs 
that you use in Sage 300 Construction and Real Estate applications. You 
can select the range values from a database list.

To view the database list:

 1.  Select Report Designer: Tools > Available Fields.

 2.  Select the record that you want to use, and then click [OK]. For 
example, AP - Vendor.

 3.  On the Print Available Fields window, select Include information 
for ODBC reporting?, and then click [Start].

Tip: Use the report created in step 3 above to determine the values to 
use in the formulas.

Note: The tsRange parameter must be the last parameter on the report 
design.

Important! Do not use tsRange if the report will be run against the SQL 
database (instead of the Pervasive database).

Syntax

Formula 1: "File Abbreviation, Record Number, Internal Name, Standard 
Order Number, Internal Name 2"
Parameter: tsRange(Formula 1 Name)

 

Formula 2: ((UBound({?tsRange(Formula 1 Name)}) = 1) and 
({?tsRange(Formula 1 Name)}[1] = "")) or Database Field = {?tsRange
(Formula 1 Name)}
Database Field: {Table.Field} 
Expert: Formula 2 Name is True.
Formula Name: The name of the formula can be whatever you choose.
File Abbreviation: The three-letter abbreviation for the data file type.
Record Number: The number of the record in the file.

tsRange function information
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Function: tsRange

Internal Name: This is the key field. For example, VENDOR or JOB.
Standard Order Number: Optional. This is the alternative key. Use it for 
sorting the records.
Internal Name 2: Optional. This is the description field. For example, 
VNAME.
Database Field: The field in the database to which the parameter is 
attached.

Value options for the parameter should be set as follows:
Allow custom values: True
Allow multiple values: True
Allow discrete values: True
Allow range values: False (This is because you are using a Sage 300 
Construction and Real Estate range rather than a Crystal range.)

To create the function:

 1.  Name the formula and select the fields for the formula (Formula 
Workshop > Formula Editor).

 2.  Edit the value options for the parameter (Edit Parameter).

 3.  Attach the parameter to the database field (Select Expert).

Example

Formula 1 Name: VendorRangeSelection

Formula 1: “APM,9,VENDOR,1,VNAME”

Parameter: tsRange(VendorRangeSelection)

Formula 2 Name: SELECT - Vendor Range or NULL

Formula 2: ((UBound({?tsRange(VendorRangeSelection)}) = 1) and 
({?tsRange(VendorRangeSelection)}[1] =  "")) or APM_MASTER__
VENDOR. Vendor = {?tsRange(VendorRangeSelection)}

Expert:@SELECT - Vendor Range or NULL is True.

Provides a range in vendor number order with a description of vendor 
name.
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Special parameters in process reports

 Process reports are reports that print forms and are printed directly from application 
tasks. This section describes the procedure for defining the process reports to print using 
Crystal Reports. Although most applications print process reports, only the Job Cost (JC) 
and Project Management (PJ) applications use Crystal Reports currently to print process 
reports. 

Project Management uses the following process reports:

 l Change order forms

 l Change request forms

 l Commitment change order forms

 l Drawing logs

 l Meeting minutes

 l RFI forms

 l Submittal forms

 l Transmittal forms

Job Cost uses the following process reports:

 l Change order forms

 l Purchase order change order forms

 l Purchase order forms

 l Subcontract change order forms

 l Subcontract forms

Note: Do not type “?” in front of parameter fields. In Crystal Reports, “?” automatically 
appears in front of parameter fields. For example, when you create a parameter and 
type tsDocIndex, the parameter appears as:
?tsDocIndex
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Parameter: tsContactIndex

Description

Only transmittal forms require this additional parameter to retrieve the 
contact ID created by the process for the report.

 1.  In Crystal Reports, create the tsContactIndex string parameter.

 2.  Link the ?tsContactIndex parameter on the main report to the 
Contact ID on the subreport to print the To contact information.

tsContactIndex parameter information

 

Parameter: tsDocIndex

Description

Process reports require this parameter to retrieve the document ID 
created by the process for the report.

Use a tsDocIndex parameter when you want a document to print for only 
a specific document ID.

This parameter is stored in the u2lxx.dll files. These files are installed in 
different locations depending on the version of Crystal Reports that you 
use. If you use Timberline Registry Editor (TSRegEdit) to switch 
between different versions of Sage 300 Construction and Real Estate 
applications, always use the latest version of the  Registry Editor to 
ensure that u2lxx.dll files are in the proper location.

Create a parameter named tsDocIndex. Use Select Expert (Report > 
Select Expert) to set the document index field equal to ?tsDocIndex. 
For each report type, use the settings that follow:

RFIs:{PJD_DOCUMENT_RFI.RFI_INDEX} = {?tsDocIndex}

Submittals: {PJD_DOCUMENT_SUBMITTAL.SUBMITTAL_INDEX} = 
{?tsDocIndex}

Transmittals: {PJD_DOCUMENT_TRANSMITTAL.TRANSMITTAL_
INDEX} = {?tsDocIndex}

Purchase orders and subcontracts: {JCM_MASTER_
COMMITMENT.doc_ID} = {?tsDocIndex}

tsDocIndex parameter information
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Parameter: tsDocIndex

Change orders: {JCM_MASTER_CHANGE_ORDER.doc_ID} = 
{?tsDocIndex}

Purchase order COs and subcontract COs:{JCM_MASTER_
COMMITMENT_CO.doc_ID} = {?tsDocIndex}

Could not open data folder error

If you set the location on all tables and try to preview the report in Crystal, you still may 
receive an error message stating: Could not open data folder. Data folder does not 
exist, it is not a Timberline data folder, or the current operator does not have access.

This message refers to the path in the report’s tsDataFolder formula. The tsDataFolder 
formula must have a valid path to be previewed from Crystal.

To correct this error:

 1.  Click [OK] to this message. 

 2.  Close the Formula Workshop window.

 3.  Under Field Explorer, double-click Formula Fields and select tsDataFolder.

 4.  Right-click and select Edit.

 5.  Change the path to match your accounting data folder path.

Billing considerations
When upgrading, changing, or creating Billing invoice designs, you must:

 l Set the location and verify the database against a DSN called TS Billing Field 
Names.

 l Include the tsDesignMode formula in the designs.

Creating the TS Billing Field Names data source

 1.  Open the ODBC Data Source Administrator window.

 2.  On the User DSN tab, click [Add] to add a new User DSN.

 3.  Select Timberline Data as the data source.
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 4.  Click [Finish].

 5.  For the data source name, type TS Billing Field Names.

 6.  Click [Select Folder], select your construction data folder in the Select Company 
window, and click [OK].

 7.  Click [Options] to show the Data Source Options.

 a.  In the Table and Field Naming list, select Dictionary names.

 b.  Select the Use maximum table segment size check box.

 c.  If the report was created in a version before Accounting and Management 
Products 8.0.0, you may need to clear the Use maximum table segment 
size check box.

 d.  Clear the Shorten field and table names check box.

 8.  Click [OK] to save your settings and close the window.

 9.  Click [OK] to close the Data Source Administrator window.

tsDesignMode formula

The Billing invoice format invoice design and all subreports must contain the 
tsDesignMode formula. The value in this formula must be “Dictionary”.

Note: The invoice format designs provided with your Sage 300 Construction and Real 
Estate software already include this formula.

If you use a custom Crystal design for your Billing invoice task and the design does not 
contain the tsDesignMode formula, you will see the following error messages:

          “Print Engine error 7: unable to connect to database”
          “File report design is not a valid invoice design.” 

Purchasing and Inventory considerations

Database record changes

You may need to modify Purchasing and Inventory custom reports to reflect Sage 300 
Construction and Real Estate database changes. Refer to the Accounting and 
Management Release Notes to review database changes by application.
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Notes:  

 l When you open Purchasing, Sage 300 Construction and Real Estate creates 
the “Timberline Office Data PO” and “Timberline PO Data” data sources. When 
you open Inventory, Sage 300 Construction and Real Estate creates the” 
Timberline Office Data IV” and “Timberline IV Data” data sources. These data 
sources are not available until you open Purchasing or Inventory.

 l Purchasing and Inventory reports have a .crs extension. When you open one of 
these reports in Crystal Reports, make sure to select All files for Files of type. 
This ensures that files with the .crs extension appear in the Open window. 

Modifying custom reports

To modify  custom Purchasing and Inventory reports that were created in a previous 
version of Crystal Reports:

 1.  Open the report in the current version of Crystal Reports.

 2.  For Purchasing or Inventory tables:

 a.  Select Database > Set Datasource Location.

 b.  Under Replace with, double-click the Create New Connection folder.

 c.  Double-click the ODBC (RDO) folder.

 d.  In the ODBC (RDO) window, select Select Data Source. 

 e.  In the Data Source Name list, select Timberline PO Data or Timberline IV 
Data. (Select Timberline PO Data if you are using a PO report; select 
Timberline IV Data if you are using an IV report). 

 f.  Click [Finish].

 g.  For each table listed under Current Data Source, select the table, select 
the corresponding table in the Replace with area, and click [Update]. (If all 
the data sources are the same, you can do this at the data source level 
instead.)

 h.  Click [Close].

Note: You may have to manually map changed fields.

 3.  For Sage 300 Construction and Real Estate tables:
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 a.  Select Database > Set Datasource Location.

 b.  Under Replace with, double-click the Create New Connection folder.

 c.  Double-click the ODBC (RDO) folder.

 d.  Click Make New Connection if the Connection Information window does 
not appear.

 e.  In the ODBC (RDO) window, select Select Data Source.

 f.  In the Data Source Name list, select Timberline Office Data PO or 
Timberline Office Data IV. (Select Timberline Office Data PO if you are 
using a PO report; select Timberline Office Data IV if you are using an IV 
report). Click [Finish]. 

 g.  For each table listed under Current Data Source, select the table, select the 
corresponding table in the Replace with area, and click [Update]. (If all the 
data sources are the same, you can do this at the data source level instead.)

 h.  Click [Close].

Note: You may need to rename the report with a .crs extension after you save the 
report.

Formatted field formulas

Formatted fields are fields that you can format with sections separated by characters. You 
can create formulas that will print the following as formatted fields on reports:

 l Job

 l Job cost code

 l Equipment

 l Equipment cost code

 l GL account

Formula content for formatted fields contains only the field name.

Formula contents and field name Formula name

Job FMTJOB + at least one character

Formulas for formatting fields
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Formula contents and field name Formula name

Job Cost Code FMTJCC + at least one character

Equipment FMTEQU + at least one character

Equipment Cost Code FMTECC + at least one character

GL Account FMTGLA + at least one character

 

If you create a report that has several occurrences of the same fields from different 
records, you can create multiple formulas with different names; for example, if you create 
a report that uses the job and job cost code fields from both the PODetail and POHeader 
records, you could create the following formulas:

Field Record Formula name

Job PODetail FMTJOB1

Job POHeader FMTJOB2

Job Cost Code PODetail  FMTJCC1

Job Cost Code POHeader FMTJCC2

Example using the same fields from different records                 

 

Note: Formatting does not print from within Crystal Reports—but formatting does print 
when you print the report from the Reports menu in Purchasing or Inventory.

Ts.ctl formulas

To create formulas to include the general company information stored in the control 
(Ts.ctl) file:
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 1.  Name the new formula according to the following table.

Ts.ctl Field Name
Ts.ctl Formula 

Name

Company                          TSCOMPANY

Address                          TSADDRESS

Address 2                          TSADDRESS2

City                          TSCITY

State                          TSSTATE

Zip                          TSZIP

Phone                          TSPHONE

Folder                          TSFOLDER

Company field information                         

Caution! If your existing reports contain Purchasing or Inventory control file fields 
(such as Companyname, Address1, Address2, etc.), you must replace them with 
the formulas listed in this table.

 2.  In the Formula Editor window, leave the contents of the formula blank.

 3.  Save the formula.

Note: Return values for these formulas do not print from within Crystal Reports—but 
they do print when you print the report from the Reports menu in Purchasing or 
Inventory.

Parameter fields

When you print a report with parameter fields, the parameters determine which prompts 
appear in the print window. For example, if the parameter is a date field, the prompt uses 
the calendar control; if the parameter is a logic (true or false) field, the prompt uses a 
check box. For Purchasing and Inventory, name your parameters something specific if 
the design lets you see a list of available data for the parameter. 
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Preset parameter sets

All of the following parameter names allow use of drop-down selection lists to print.

 l STARTDATE

 l FIRSTITEM

 l FIRSTLOC

 l FIRSTCLASS

 l FIRSTJOB

 l FIRSTVENDOR

 l FIRSTPO

 l FIRSTRECEIPT

 l ENDDATE

 l LASTITEM

 l LASTLOC

 l LASTCLASS

 l LASTJOB

 l LASTVENDOR

 l LASTPO

 l LASTRECEIPT

Parameter names for selection lists                 

 

Parameter Purpose

PONUMBER
You want the report (for example, a purchase order form) to print for 
a single purchase order. Use also with the CONUMBER parameter 
as described below.

CONUMBER
You want the report (e.g., a purchase order change order form) to 
print for a single purchase order change order. 

Purchase order form and purchase order change order form parameters                 

 

Note: Lists for these parameters do not appear from within Crystal. They work, but you 
must type a value, not select a value from a list. They do print when you print the report 
from the Reports menu in Purchasing or Inventory.

Adding custom reports to the Purchasing or Inventory Reports menu

To add custom report designs to the Purchasing or Inventory Reports menu:

 1.  In Purchasing or Inventory, select Reports > Report Manager.

 2.  To add a new report, click [New]. To change a report, click [Change].
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 3.  Type the Report Name (the name that will appear on the report menu).

 4.  Select a Menu Group from the list, or type the name for a new menu group.

 5.  Click [List] to browse for the report. These must be Crystal Reports designs with a 
.crs extension.

 6.  Select the report, and then click  [Open].

 7.  Click [OK] to close the Add New Report window.

 8.  Click [Close] to close the Reports Manager window.

DSN error

If you install or upgrade Purchasing or Inventory on a computer that has the Windows 7 
operating system, you may need to elevate your permissions level before starting the 
program or Purchasing/Inventory may not be able to create the DSNs necessary to use 
Crystal Reports. If you encounter an error message when starting Purchasing or 
Inventory for the first time after installation, close the program, elevate your permissions 
level, and start Purchasing/Inventory again.

Service Management considerations

Database record changes

You may need to modify Service Management custom reports to reflect Sage 300 
Construction and Real Estate database changes.

Setting up or upgrading custom reports

To set up Crystal Reports in Service Management:

 l If the report is designed to switch between the current and history files, see "Option 
A" (the next section).

 l If the report is not designed to switch between current and history files, see "Option B 
" on page 134.
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Option A

 1.  Verify the Timberline Data Source is set up correctly. Subreports that pull 
information from the accounting database use the ODBC Timberline Data Source 
DSN.

 a.  Open the Data Source Administrator window.

 b.  On the User DSN tab, select Timberline Data Source and click 
[Configure].

 c.  Click [Select Folder], select your construction data folder, and click [OK].

 d.  Click [Options] to show the Data Source Options. 

 e.  In the Table and Field Naming list, select Standard descriptions.

 f.  Select the Use maximum table segment size check box.

 g.  Clear the Shorten field and table names check box.

 h.  Click [OK] twice.

Note: If you will print this custom report from within Crystal Reports, this 
DSN must use a valid Sage 300 Construction and Real Estate accounting 
data set.

 2.  Set the location to a valid data set. 

 a.  In Crystal Reports, open the custom report you are upgrading.

 b.  Select Database > Set Datasource Location.

 c.  Under Current Data Source, select the first data source.

 d.  Under Replace with, double-click Create New Connection.

 e.  Double-click Btrieve.

 f.  In the Open window, browse to the folder containing your Service 
Management data.

 g.  Select FILE.DDF and click [Open].

 h.  Select the data source that should replace the original.

 i.  Click [Update].
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 j.  Repeat steps b through i for all data sources listed under Current Data 
Source.

 k.  Verify all table locations in the Set Datasource Location window point to the 
same data folder path. All table locations point to the same path if only one 
group of tables appears under Current Data Source.

You must also set the location on all subreports. If a subreport retrieves 
Service Management data, follow the procedure in step 2. If a subreport 
retrieves data from the Timberline Data Source, follow the procedure in 
step 3 (which follows). The Current Data Source window lists subreport 
data sources in a separate group.

 3.  Select the data source for the subreport. 

 a.  Select Database > Set Datasource Location. 

 b.  Under Current Data Source, double-click Subreports and select the first 
data source.

 c.  Under Replace with, double-click Create New Connection.

 d.  Double-click ODBC (RDO).

 e.  Select Timberline Data Source.

 f.  Click [Finish].

 g.  If you have security enabled, type your Operator ID and Password.

 h.  Click [Close].

 4.  After you use Set Datasource Location, verify the path on each table of the report is 
correct. 

 5.  Select Database > Verify Database.

 6.  Select File > Save.

Option B 

 1.  Verify the Timberline Data Source is set up correctly. Subreports that pull 
information from the accounting database use the Timberline Data Source.
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 a.  Open the Data Source Administrator window.

 b.  On the User DSN tab, select Timberline Data Source and click 
[Configure].

 c.  Click [Select Folder], select your construction data folder, and click [OK].

 d.  Click [Options] to show the Data Source Options. 

 e.  In the Table and Field Naming list, select Standard descriptions.

 f.  Select the Use maximum table segment size check box.

 g.  Clear the Shorten field and table names check box.

 h.  Click [OK] twice.

 2.  Verify the Timberline SM Data DSN is set up correctly

 a.  Open the Data Source Administrator window.

 b.  If you are operating in a server/workstation environment, select the System 
DSN tab and verify there is a Timberline SM Data DSN.

Note: If Timberline SM Data does not appear in the list of data sources: 
1) Open Service Management at the server and preview any standard 
report. 
2) Open Service Management at each workstation and preview any 
standard report.

 c.  If you are operating on a standalone system, perform steps 2d - 2h to set up 
the Timberline SM Data DSN manually; otherwise, skip to step 3.

 d.  If you are on a standalone system, create the Timberline SM Data DSN 
manually by opening the ODBC Data Source Administrator window.

 e.  On the System DSN tab, click [Add].

 f.  Select the Pervasive ODBC Engine Interface driver.

 g.  In the Pervasive ODBC Engine DSN Setup window:

 l For Data Source Name, type Timberline SM Data

 l For Database Name, select the entry starting with the letters SM in its 
label (such as “SM1FE43AFDF79D459F”).
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Service Management creates two DSN GUIDs for each dataset. You may 
select any Service Management DSN GUID when creating the Timberline 
SM Data DSN manually. During run time, Service Management 
automatically points to the correct Service Management database.

 h.  Click [OK].

Note: If you will print this custom report from within Crystal Reports, this 
DSN must use a valid Sage 300 Construction and Real Estate accounting 
data set.

 3.  Set the location to a valid data set. 

 a.  From Crystal Reports, open the custom report you are upgrading.

 b.  Select Database > Set Datasource Location. 

 c.  Under Current Data Source, make note of any paths where *.ddf files exist 
(such as C:\Development\Testdata\Field.ddf).

 d.  Click [Close] to close the Set Datasource Location window without 
changing any locations.

 e.  Based on the information you determined in step 3b, use Windows Explorer 
to browse to the location referenced by the custom report. Confirm that 
these files exist:

 l Field.ddf

 l File.ddf

 l Index.ddf

 f.  If the files do exist there, copy the .ddf files from your Servmngt folder to the 
location you determined in step 3b. Typically, your Servmngt folder is 
located at X:\Program Files\Timberline Office\Accounting\Servmngt 
(where X represents the drive where your Sage 300 Construction and Real 
Estate programs are installed).

 4.  Verify the database.

 a.  Open the report design in the current version of Crystal Reports and select 
Database > Verify Database.
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 b.  You may receive several prompts at this point. Respond to these messages 
as instructed until the Map Fields window appears:

 l If you see “The Database file ‘[file name]’ has changed. Proceeding 
to fix up the report!”, click [OK].

 l If you see “The database is now up to date.”, click [OK].

 l If you see a message other than these (for example, “Remove table” 
messages), do not proceed. Close the design without saving your 
changes and then confirm that step 2 was done correctly.

 5.  Open the custom report design in the current version of Crystal Reports and update 
the data source:

 a.  Select Database > Set Datasource Location.

 b.  Under Replace with, double-click the Create New Connection folder.

 c.  Double-click the ODBC (RDO) folder.

 d.  In the ODBC (RDO) window, select Select Data Source.

 e.  In the Data Source Name list, select Timberline SM Data and then click 
[Finish].

 f.  For each item listed under Current Data Source, select the corresponding 
table in the Replace with area and click [Update].

 g.  Click [Close].

 6.  Verify the database.

 a.  Select Database > Verify Database.

 b.  Respond to the prompts as appropriate.

 7.  Save the custom report design.

You must also set the location on all subreports. If a subreport retrieves Service 
Management data, follow the procedure in steps 3-7. If a subreport retrieves data 
from Timberline Data Source, use the steps that follow. The Current Data Source 
window lists subreport data sources in a separate group.

 8.  Select the data source for the subreport.
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 a.  Select Database > Set Datasource Location.

 b.  Under Current Data Source, double-click Subreports and select the first 
data source. Many of the subreports retrieve information from the Timberline 
Data Source.

 c.  Under Replace with, double-click Create New Connection.

 d.  Double-click ODBC (RDO).

 e.  Select Timberline Data Source.

 f.  Click [Finish].

 g.  If you have security enabled, type your Operator ID and Password.

 h.  Click [Close].

 i.  After you use Set Datasource Location, verify that the path on each table of 
the report is correct.

 j.  Select Database > Verify Database.

 k.  Select File > Save.

DSN error

If you install or upgrade Service Management on a computer that has the Windows 7 
operating system, you may need to elevate your permissions level before starting the 
program or Service Management may not be able to create the DSNs necessary to use 
Crystal Reports. If you encounter an error message when starting Service Management 
for the first time after installation, close Service Management, elevate your permissions 
level, and start Service Management again.

Adding custom report designs to the  menu

To add a custom report design to the Service Management Reports menu:

 1.  Open Service Management.

 2.  Select Reports > Custom Reports Manager.

 3.  Click [New].

 4.  In the New Report window:
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 a.  For Name, type the name for the new report as you want it to appear in the 
menu.

 b.  For Path, click the browse button and select the path to the report.

 c.  (Optional) For Submenu, select a submenu or type the name of the 
submenu for the report.

 d.  To print the report automatically to a file, select the Print to file check box 
and type a File name.

 5.  Click [Finish]. 

 6.  Click [Done].

Notes:  

If you want custom invoice formats in Service Management 8.3.0 and later to be 
retrieved, add them to the appropriate location. These custom formats include 
Call Type, Service Location, AR Customer, and Service Management Settings.

You can store custom reports in a subdirectory for reports called Custom (file path 
X:\Program Data\Sage\Timberline Office\9.5\Accounting\Report\Service 
Management\Custom in Windows 2008 R2, or X:\Documents and Settings\All 
Users\Application Data\Sage\Timberline 
Office\9.5\Accounting\Report\Service Management\Custom in other supported 
operating systems). You must manually create this folder, but any reports you 
store there will be retrieved by Service Management before it retrieves the reports 
stored in the Service Management folder. This prevents custom reports from 
being overwritten during the upgrade process. This is most common for process-
oriented reports like work orders and agreements. You must use the same name 
as the original report.

tsAlternateSMFolder

You can select whether you want a Service Management report to include current or 
historical information by adding the tsAlternateSMFolder function to the report. You do 
not need to add a value to the formula. For more information on the tsAlternateSMFolder 
function, see "Formula: tsAlternateSMFolder" on page 98
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All Service Management reports designs and all subreports must contain the tsApp 
formula. The value in this formula must be “SM.” However, this formula is not required on 
any report that uses the ODBC driver to access Sage 300 Construction and Real Estate 
data. For more information on the tsApp formula, see "Formula: tsApp" on page 99.

Desktop considerations
You can display Crystal Reports in Sage Desktop. You will want to keep some concepts 
in mind when you create Crystal Reports designs for use as home pages.

To maximize the performance of Crystal Reports displayed in Sage Desktop:

 l If you use subreports, use on-demand subreports.

 l Do not use named files.

 l If a report takes a long time to process, you may not want to display it in Sage 
Desktop.

The following formulas do not function on Crystal Reports displayed in Sage Desktop:

 l tsAskFile

 l tsSubAskFile

 l tsLetterhead

Upgrading older custom report designs

Upgrading custom reports using the Upgrade Crystal Reports tool

If you upgraded from version 13.1 or earlier and have custom Crystal Reports designs, 
you must upgrade them before they can be used in Sage 300 Construction and Real 
Estate by running the Upgrade Crystal Reports Tool.

To access the tool, click the Start icon, select the Sage Administration program group, 
right-click Upgrade Crystal Reports, and then select Run as administrator.

For more information, click   (the help button) in the tool's window.
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