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Section 1
System Guidance

General

This document provides detailed information about system and environment considerations 
to ensure your network is ready to install Residential Management. You will also find what 
you need to prepare before you install. This document is specific to Residential 
Management requirements. For information about environment and installation 
considerations for Sage Timberline Office, refer to the Sage Timberline Office Technical 
System Reference, available on your Accounting and Management DVD at 
\Documents\TechnicalSystemReference.pdf. 

Develop a Plan to Back Up Files 

We strongly recommend that you use third-party software to back up all Sage Timberline 
Office and Residential Management data files to external media on a daily basis. 

Consider the following as you develop your backup plan: 

 Use third-party backup software for all backups.

 Verify that when a folder is included in a backup, the backup software also includes the 
subfolders. In other words, the backup software should support recursive backups.

 Schedule backup during off-peak hours, since all users must close Residential 
Management before you back up files. 
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 Always back up both the .mdf and .ldf Residential Management database files. 

 Review where you store the Residential Management data and back up all data, even if 
it is outside default folders.

 Store backup media in a secure location outside your building.

 Test backups by restoring them to test folders. These tests are important because backup 
media may have a limited life, backup devices may malfunction, and you may have 
incorrect software settings in your backup software. 

WARNING:  When you test a backup, keep the restored data separate from your production data. 

Creating a Backup of Residential Management data

We recommend two backup software packages that you can purchase to back up your 
Residential Management data nightly: 

 VERITAS® Backup Exec for Windows Servers

 Brightstor® ARCserve for Windows 

You can purchase an add-on module for either of these backup applications to back up SQL 
database files. The add-on module you purchase processes a batch file that stops the SQL 
server, allows the backup system to back up the specified files, and starts the SQL server. 
A low cost alternative to purchasing the add-on module is to write a batch file and allow 
the backup application to run the batch file prior to backing up the Residential Management 
database files. 

Follow the steps below to create text files with instructions for stopping and starting the 
SQL server: 

1 Create two text files using a text editor such as Notepad or WordPad. For example, you 
can name one file Stop.bat and name the other file Start.bat.

2 Add the following lines to the Stop.bat file:

Net stop mssql$sagerm 

net stop sqlserveragent

3 Add the following lines to the Start.bat file: 

Net start mssql$sagerm 

net start sqlserveragent 

4 Schedule your backup system to run the Stop.bat file, back up your Residential 
Management data files, and then run the Start.bat file.
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NOTE:  You can also manually enter the commands in steps 2 and 3 above at a command prompt (from 
the Windows Start menu, select Run and enter cmd).

Assign Full-Control User Rights to All Folders That Contain Sage 
Timberline Office Application Data Files and Sage Timberline Office 
Data Files

Assign full-control user rights to all folders that contain Pervasive program files, Sage 
Timberline Office program files, Sage Timberline Office data files, Residential 
Management program files, and Residential Management SQL database files. To use Sage 
Timberline Office and Residential Management, users must have full control of the 
following files and folders on the files server, terminal server, and workstations that have 
Sage Timberline Office and Residential Management installed.

WARNING:  Incorrectly modifying Microsoft Windows security may severely affect your system 
operations. Sage Software is not responsible for operation problems caused by incorrectly modifying your 
Microsoft Windows security settings. To set permissions on your network or Windows operating system, 
you must have advanced knowledge of your network. Contact your system administrator for assistance. 

 [Drive]:\Program Files\Timberline Office folder: This folder is located on the file 
server, terminal server, and workstations where you installed Sage Timberline Office. It 
is the default installation location for Sage Timberline Office. However, depending on 
your system configuration, your company may have renamed this folder or installed it to 
a different location. 

 [Drive]:\Documents and Settings\[username] folder (Windows XP, Windows Server 
2003, and earlier): This folder is located on the workstation or terminal server where 
you use Sage Timberline Office. Sage Timberline Office installs necessary files to this 
folder and requires that the user has full control of it. Typically, the user has full control 
of this folder by default.

 [Drive]:\Users\[User name] folder (Windows Vista, Windows 2008 Server, and 
Windows 7): This folder is located on the workstation or terminal server where you use 
Sage Timberline Office. Sage Timberline Office installs necessary files to this folder and 
requires that the user has full control of it. Typically, the user has full control of this folder 
by default.

 [Drive]:\Documents and Settings\All Users\Application Data\Sage\Timberline 
Office (Windows XP, Windows Server 2003, and earlier): This folder is located on the 
server and on any workstations or terminal server where you install Sage Timberline 
Office Accounting & Management programs. This folder must be shared on the server. 
Sage Timberline Office installs necessary files to this folder and requires that all users 
have read/write permissions to the folder and all of its subfolders. This folder may also 
be hidden. To view hidden folders, open Windows Explorer, select Tools > Folder 
Options, and select the View hidden files and folders check box on the View tab.
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 [Drive]:\ProgramData\Sage\Timberline Office (Windows Vista, Windows 2008 
Server, and Windows 7): This folder is located on the workstation or terminal server 
where you use Sage Timberline Office Accounting & Management programs. If you are 
using a workstation as a peer-to-peer server, the folder must also be shared. Sage 
Timberline Office installs necessary files to this folder and requires that all users have 
read/write permissions to this folder and all of its subfolders. This folder may be hidden 
by default. To view hidden folders, open Windows Explorer, select Tools > Folder 
Options, and select the View hidden files and folders check box on the View tab.

 Company data folder (Accounting): Typically, the data folder is located on the file 
server where you installed Accounting and Management Products.

 Database and estimates (Estimating): Typically, these files are located at both the file 
server and the workstation where you installed Estimating Products.

 Pervasive installation folder: By default, Pervasive installs to C:\Pvsw on the file 
server, terminal server, and workstations where you installed Sage Timberline Office.

 Windows system folder: Typically, the Windows system folder is located at 
C:\Windows or C:\Winnt on your workstation. If your system administrator does not 
want to give you full control of the local Windows system folder, ask for full control of 
just the Dbnames.cfg file and Pvsw.log file in the Windows system folder.

 [Drive:]\RM: This folder is located on the file server, terminal server, and workstations 
where you installed Residential Management. It is the default installation location for 
Residential Management. However, depending on your system configuration, your 
company may have renamed this folder or installed it to a different location.

NOTE:  Each Residential Management user must have at least power user rights on the network for access 
to the Sage Timberline Office directory, including all subfolders and all files, on the server where Terminal 
Services is installed and the file server.

Comply With Windows User Account Control (UAC) Requirements

The critical program files are being installed in the normal installation location (the 
Program Files folder by default), while data and all other files are being installed to a 
shared location. For Sage Timberline Office applications to work correctly, you must 
ensure you have read/write permissions to these files. For new installations of Sage 
Timberline Office Accounting & Management on Windows Vista, Windows 2008 Server, 
or Windows 7 operating systems, these data files are being installed in the 
[Drive]:\ProgramData\Sage\Timberline Office folder. For new installations on Windows 
XP or Windows Server 2003 and earlier operating systems, these files are being installed 
in the [Drive]:\Documents and Settings\All Users\Application Data\Sage\Timberline 
Office folder. 
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If you are upgrading Sage Timberline Office Accounting & Management applications, your 
data folders will not be moved automatically. You do not need to move your data; however, 
if you install Windows Vista, Windows 2008 Server, or Windows 7 and your data is not in 
a shared location, you need to share the data folders and assign read/write permissions, or 
you must move the folders to a shared location and assign read/write permissions. If you 
move your data files, ensure you update their locations using File Tools.

NOTE:  Some of these folders are hidden in their new location. To view them, open Windows Explorer, 
select Tools > Folder Options, and select the View hidden files and folders check box on the View 
tab.

In compliance with UAC requirements, you cannot save a file to a folder to which you do 
not have read/writer permissions assigned. If such an attempt is made, Windows security 
diverts your data to a copy of the data file or report and associates the copy with your user 
profile, thereby possibly compromising the integrity of your application. To prevent this, 
Sage Timberline Office applications present you with an error message if you try to save a 
file to such a location.
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Section 2
Frequently Asked Questions

Overview

These are some of the frequently asked questions concerning Residential Management. For 
more information on installing or upgrading Residential Management, refer to the 
Installation Guide, available on your Residential Management CD or DVD at 
\Documents\InstallationGuideResMgmt.pdf.

How do I move Accounting and Management Products from one 
server to another? 

For instructions, see “Moving Accounting and Management Products 9.2.0 or Later to a 
New Server” in the Sage Timberline Office Technical System Reference, available on your 
Accounting and Management DVD at \Documents\TechnicalSystemReference.pdf.
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What if no servers are listed in the Select Server window when I 
start Residential Management?

SQL Services are running on the local workstation

When you install Residential Management in a Local Area Network (LAN) environment, 
you must also install SQL Services (SQL Server 2005 or SQL Server 2005 Express) and 
Residential Management on the local workstations. To connect to the server’s SQL service, 
the service must not be running on the workstation.

Verify that SQL Services on the workstation are stopped:

1 On the workstation, select [Start] > All Programs > Microsoft SQL Server 2005 > 
Configuration Tools > SQL Server Service Manager. 

2 In the SQL Server Service Manager window, select SQL Server 2005 Services > SQL 
Server (SAGECRE).

3 Right-click SQL Server (SAGECRE) and select Stop.

4 Close the SQL Server Service Manager window.

A port is blocked by the firewall

By default, ports 1433 and 1434 are reserved for SQL Services. If either of these two ports 
is blocked, the SQL Services (SQL Server 2005 or SQL Server 2005 Express) on the 
workstation cannot communicate with SQL Services on the server. If you manually 
assigned different ports for SQL Services, verify that those ports are not blocked or being 
used by a different service.

Verify that the workstation is communicating with the server:

1 Ping the server from the workstation:

a From the Windows Start menu, select Run.

b In the Open box, type cmd. 

c Click [OK]. 

d At the command prompt, type ping and the name of the server you want to 
communicate with. Leave a space between the word ping and the computer name. 

e Press ENTER.

A successful ping returns a set of four reply packets with the IP address. An unsuccessful 
ping will return a note that the host is unknown, or will hang followed by a message that 
the connection timed out. 
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2 If the workstation is communicating successfully with the server, the server IP address is 
returned. For example, the IP address might be 172.72.242.50. 

3 If the test fails, the server is not configured correctly to allow workstations to 
communicate with it. Contact your systems administrator. 

For more information about how to use static and dynamic port allocation with SQL Server, 
refer to articles 823938, 287932, and 293107 in Microsoft's Knowledge Base. 

1 Open http://support.microsoft.com in your browser. 

2 Search for the article number.

3 Follow the instructions in Microsoft's Knowledge Base article. 

How do I troubleshoot problems that occur when I start Sage 
Timberline Office? 

Search the Knowledgebase at Sage Timberline Online. To access the Knowledgebase, open 
www.sagetimberlineonline.com. See “Online Help” on page 21 for instructions for 
registering and logging on. After you log on to Sage Timberline Online, type a question for 
a specific issue in the Knowledgebase Search box or click Solve for advanced search 
options.

How do I end a Terminal Services session that has stopped 
responding?

Use Terminal Services Manager on the server to end sessions

NOTES:  

 This solution includes information or procedures for a non-Sage Timberline Office 
product. Although we provide steps to solve the issue, we cannot guarantee them. Please 
refer to the documentation you received with the software or technical support for the 
product for detailed instructions. 

 Contact your system administrator if you are not comfortable following the steps below.

If your Terminal Services session stops responding, end the session as follows: 

1 On the server where Terminal Services is installed, click [Start] and then click Settings 
> Control Panel.

2 Select Administrative Tools.

3 Select Terminal Services Manager.

http://support.microsoft.com
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4 Right-click the operator whose session stopped responding, and select Disconnect. 

NOTE:  This is equivalent to ending a task using CTRL+ALT+DEL. 



11

Section 3
Prerequisite Software

Residential Management needs to have the following third-party components installed at 
the beginning of the Residential Management installation. 

Description of Third-Party Components

Microsoft SQL Server 2005 Express

Microsoft SQL Server 2005 Express provides access to Residential Management 
databases. This version is available on the Residential Management CD or DVD.
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Section 4
Compatibility Testing

The following tables list the software that Sage Timberline Office’s quality assurance 
department tests with Sage Timberline Office.

For more information about Sage Timberline Office requirements, see Get Started. It is 
located on your Accounting and Management DVD at \Documents\GetStarted.pdf.

Servers

We test Windows Server 2003 Standard Edition, Windows Server 2003 Enterprise Edition, 
and Windows Small Business Server 2003 with Sage Timberline Office. In this document, 
unless noted otherwise, the term “Windows Server 2003” refers to all three editions of this 
operating system.

Microsoft Windows Server 2003 R2 has been tested for compatibility with Residential 
Management and we are able to support its use.

Operating Systems Service Pack Other

Windows 2008 Server (with and 
without Terminal Services. For 
Standard, with Terminal Services 
and Citrix XP)

Service Pack 2
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In addition, we test Palm OS versions 3.x, 4.0, and 4.1 with Accounting and Management 
Products.

Workstations

We support workstation, stand-alone, and peer-to-peer operating systems.

Other Software

We test the following additional software with Sage Timberline Office.

Windows Server 2003 (with and 
without Terminal Services. For 
Standard, with Terminal Services 
and Citrix XP)

Service Pack 2

Peer to Peer 

Operating Systems Service Pack Other

Windows 7 Professional, Ultimate, 
and Enterprise

Windows Vista Business and 
Ultimate

Service Pack 2 Microsoft DirectX 9.0, 
Microsoft Windows Installer 
3.1

Windows XP Professional Service Pack 3 Microsoft DirectX 9.0, 
Microsoft Windows Installer 
3.1

Other Service Pack or Update

Crystal Reports® 11 for Sage As installed from a Sage 
Timberline Office DVDs

Internet Explorer 6.0 Service Pack 1

Microsoft .NET Framework 2.0 As installed from a Sage 
Timberline Office DVD

Microsoft Data Access Components (MDAC) 2.7 As installed from a Sage 
Timberline Office DVD

Microsoft Office 2002, and 2003 For Office 2003, Service Pack 2 

Symantec® Winfax 10.03 For Windows XP with Service 
Pack 2, 10.04 Update

Operating Systems Service Pack Other
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UniMessage Pro 1.0

SQL Server 2005 Express and SQL Server 2005 For SQL Server 2005, Service 
Pack 2

Other Service Pack or Update
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Section 5
Migrating Residential Management

Microsoft Installer and Residential Management 

Moving Residential Management to a New Server Location

WARNING:  Incorrectly moving Residential Management databases may severely damage your system. 
Sage Software is not responsible for damage to your data caused by incorrectly moving your Sage 
Timberline Office data folders or Residential Management databases. Before making changes to your Sage 
Timberline Office or Residential Management data, contact your system administrator for assistance and 
make a backup copy of all valued data. 

The default location for the Residential Management database is the SQL directory. For 
example, C:\MSSQL\Data. You can create a new data directory using Windows Explorer 
and use the Database Installer from your Residential Management CD or DVD to detach 
and reattach the database to your SQL server.

NOTE:  If you are moving the data to a different server, refer to the section “Moving Residential 
Management data to a New Host or Server” on page 19.

Follow these steps to move your Residential Management database to a different location 
on your server: 

1 Have all operators exit Residential Management. 



18

Migrating Residential Management

Section 5
2 Back up your database files. For example, if your database is called SunriseProp, make 
a backup of the SunriseProp.mdf and SunriseProp_log.ldf files. 

3 Use Windows Explorer to create a new data directory. For example, F:\RMData\Data (F:\ 
represents the drive on your server). 

4 Use the Database Installer to detach your database: 

a Insert your Residential Management CD or DVD in the CD-ROM drive (or DVD-
ROM drive, respectfully) of the server. 

b Click [Start] and select Run. 

c Click [Browse]. Browse to X:\RM Database (X:\ represents your CD-ROM or DVD-
ROM drive), select RMDatabase.exe, and click [Open]. 

d In the RM Data Installation window, type your Database Name in the box. For 
example, SunriseProp. 

e Click [Detach] to detach your database. 

f In the Database Installer window, click [OK] to detach the database. 

g In the Login Information window, in the Login field, type your SQL login ID and 
password, and click [Accept]. A password is required only if you set one up for this 
login ID. 

h After the detach is complete, click [OK]. Minimize the RM Data Installation 
window. 

5 Use Windows Explorer to cut and paste your SunriseProp.mdf and SunriseProp_log.ldf 
files from C:\MSSQL\Data to F:\RMData\Data (F:\ represents the drive on your server).

6 Maximize the RM Data Installation window to attach your database: 

a From the Data Drive list, select the F drive. 

b Type the new directory in the Data Directory box. For example, if your new directory 
is F:\RMData\Data, type \RMData. 

c Click [Attach].

d In the Database Installer window, click [OK]. 

e In the Login Information window in the Login field, type your SQL login ID and 
password and click [Accept]. 

f After the attach is complete, click [OK] and then click [Exit]. 

7 You should now be able to use Residential Management. 
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Moving Residential Management data to a New Host or Server

When you move Residential Management to a new server, you must move the Sage 
Timberline Office program folder and data folders. You will need the Accounting and 
Management Products DVD that you are using currently to install components, such as the 
Pervasive database engine, at the new server. Do not install a newer version of Accounting 
and Management Products until after you have moved and tested Sage Timberline Office 
at the new server. 

For information on how to move Accounting and Management products, refer to the Sage 
Timberline Office Technical System Reference, available on your Accounting and 
Management DVD at \Documents\TechnicalSystemReference.pdf. 

1 Verify that no operators are using Residential Management on the old server. 

2 On the new server: 

a Install the same version of Residential Management that is currently installed on the 
old server. 

b Insert the Residential Management CD or DVD, then click [Start] and select Run. 

c Click [Browse]. Browse to X:\RM Database (X:\ represents your CD-ROM or DVD-
ROM drive), select RMDatabase.exe, and click [Open]. 

d In the RM Data Installation window, click [Create] to create the RM Demo database 
as usual and prepare the database engine for your data from the old server. 

3 On the old server: 

a Click [Start] and select Settings > Control Panel > Administrative Tools > 
Services.

b Right-click MSSQL or MSSQLServer and select Stop.

c Using Windows Explorer, browse to your SQL data directory (for example, 
C:\MSSQL\Data) and copy the .mdf and .ldf files associated with your Residential 
Management database to the SQL data directory on the new server. For example, if 
your database is called SunriseProp, copy SunriseProp.mdf and SunriseProp_log.ldf 
to the new server.

d Close the Services window. 

4 On the new server: 

a Click [Start] and select Run. 

b Click [Browse]. Browse to X:\RM Database (X:\ represents your CD-ROM or DVD-
ROM drive), select RMDatabase.exe, and click [Open]. 
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c In the RM Data Installation window, type your Database Name in the box. For 
example, if your .mdf file is called SunriseProp.mdf, your database name is 
SunriseProp. 

d Click [Attach] to attach your database as usual. 

e Click [Exit] to close the RM Data Installation window. 

f You should now be able to start Residential Management. Select the SQL Server 
(usually (local)), and select your database. 

You may need to run ResetRegistry.vbs (located in your RM folder) to view the new 
server so that you can select it.

NOTE:  If you have any custom Residential Management reports, copy them from the old server to the 
same location on the new server. 
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Online Help

Each Sage Timberline Office module includes online help, which provides answers to

your questions about procedures as well as items in the windows.

To access the online help in the Sage Timberline Office software:

 In a window, click the Help button or icon, or press [F1] to display the help topic for that 
window.

 In the Desktop, select Help > Search for help on, and then choose the desired module.

To aid you in finding the information you need, the online help for each module includes 
the following panes:

 Contents pane containing links to the help topics

 Index pane containing keywords that link to help topics related to that keyword

 Search pane, where you can type text and click [Search] to locate that text in the help 
topics

For more information about using the online help, see the Sage Timberline Office

Desktop help (in the Desktop, select Help > Sage Timberline Office Desktop Help).
We would like your feedback about the online help so we can make improvements.
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Each help topic contains an area where you can indicate whether the topic was helpful and 
provide additional comments. To protect your privacy, all comments are anonymous.

Training

Sage University offers online and classroom training sessions to help you get the most out 
of your Sage Timberline Officesoftware. To access Sage University, from the Sage 
Timberline Office Desktop, select visit www.sageu.com. You can also get access to Sage 
University from the Sage Timberline Desktop from Help > Sage Timberline Office on the 
Web > Sage Software University.

Contact Customer Support

Depending on your Sage Service Plan, you may be able to take advantage of the following 
services:

Sage Customer Portal

You may log on to the Sage Customer Portal at https://customers.sagenorthamerica.com/irj/
portal/anonymous/login to access any of the following services:

 Knowledgebase: Find answers to your questions, access downloads, and subscribe to 
your favorite articles. This service is available online 24/7.

 Live Chat: Chat online with a customer support analyst - a great option for quick 
questions. Chat hours are the same as our telephone support hours.

 Online Support Request: Submit an online support ticket when you have a non-urgent 
question. One of our call center support analysts will assist you. Online support hours are 
the same as our customer support call center hours.

Sage Customer Support Call Center

Telephone Support: When you have a more urgent question or would prefer to speak to a 
customer support analyst directly, call us at 800-551-8307. Telephone support is available 
Monday through Friday from 6 a.m. to 5 p.m. Pacific time with the following exceptions:

 Every Thursday from 2 p.m. to 3 p.m. Pacific time (closed for customer support staff 
meetings)

 Standard United States holidays

 Quarterly company meetings
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Upgrading Your Service Plan

If your service plan does not provide online or telephone customer support and you would 
like to add or upgrade a service plan, please call 800-858-7098.
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