Contents

Chapter 1: Introduction
System Requirements ................................................................. 1–1
   Server Requirements .............................................................. 1–2
   Client Workstation Requirements ........................................ 1–2
Network Configuration ................................................................. 1–3
   Typical Network Configurations ............................................ 1–4
Where to Now? ........................................................................ 1–8

Chapter 2: Installing Sage ERP Accpac Programs
Before You Begin ........................................................................ 2–1
   Installation Considerations ................................................... 2–1
Using Sage ERP Accpac Sample Data ........................................ 2–4
Installing Sage ERP Accpac ........................................................ 2–5
   Installing the Programs .......................................................... 2–5
   Entering License Information ................................................ 2–7
When To Use Workstation Setup ................................................. 2–9
Running Sage Accpac Intelligence for the First Time .................. 2–10
Where To Now? ........................................................................ 2–10

Chapter 3: Database Setup
Overview of Database Setup ....................................................... 3–1
Creating System, Company, and Portal Databases ....................... 3–2
   Before You Begin ................................................................. 3–2
   Creating Pervasive PSQL Databases ....................................... 3–3
   Creating Microsoft SQL Server Databases .............................. 3–7
   Creating Oracle Server Databases .......................................... 3–13
Setting Up Company and System Databases ............................... 3–22
   Setting Up a System Database .............................................. 3–22
   Setting Up a Company Database .......................................... 3–27
Setting Global Security Options ................................................ 3–31
Where to Now? ........................................................................ 3–34
Chapter 4: Activating Sage ERP Accpac

Before You Begin ........................................................................................................ 4–1
Signing On to a New Company ................................................................................... 4–2
Creating the Company Profile
   Entering Company Information .............................................................................. 4–4
Activating Your Data .................................................................................................. 4–8
Change the Administrator’s Password
   Change the ADMIN Password ................................................................................. 4–11
Where To Now? ............................................................................................................. 4–13

Chapter 5: Configuring the Sage ERP Accpac Portal

Overview ...................................................................................................................... 5–1
Configuring Portal Security ........................................................................................ 5–2
Configuring the Portal Database
   Configuring a Microsoft SQL Server Express Database ........................................ 5–4
   Configuring English Windows to Display Chinese ............................................... 5–5
Starting the Sage ERP Accpac Portal ........................................................................ 5–7
Troubleshooting the Sage ERP Accpac Portal ............................................................ 5–7
   Components that Support the Sage ERP Accpac Portal ....................................... 5–7
   Configuring IIS 7 for Windows 7, Windows Vista, or Windows 2008 ...................... 5–8
   Configuring IIS 6 for Windows 2003 ..................................................................... 5–10
   Restarting IIS .......................................................................................................... 5–12
   Starting Sage ERP Accpac’s Tomcat ...................................................................... 5–12
   Sage Accpac Tomcat Doesn’t Start on a 64-Bit Machine ..................................... 5–12
   Sage Accpac Tomcat Doesn’t Start on a 32-Bit Machine ..................................... 5–12
   The Portal Doesn’t Open for Windows XP ............................................................. 5–12
   Shortcuts in the Portal Don’t Work ........................................................................ 5–12
   Unable to Start the Web Site .................................................................................. 5–13
   Unable to Export Queries or Snapshots ................................................................ 5–13
   Company List Failure Error ................................................................................... 5–14

Chapter 6: Performing Administrative Tasks

Add Users .................................................................................................................... 6–1
   Using Windows as the Authentication Method ..................................................... 6–3
Set Up Security Groups and Assign User Authorizations ...................................... 6–5
   Create Security Groups ......................................................................................... 6–5
   Authorizing Users .................................................................................................. 6–6
Create and Assign UI Profiles for Customized User Interface Forms .................... 6–7
Chapter 1
Introduction

Read all chapters in this guide before you install or set up a new installation of Sage ERP Accpac.

This guide provides the information you need to:

- Install Sage ERP Accpac
- Set up databases for use with Sage ERP Accpac
- Set Sage ERP Accpac security
- Set up Workstations to run Sage ERP Accpac
- Activate your data for new accounting programs
- Configure the Sage ERP Accpac portal
- Set up users and groups, and perform other administrative tasks
- Understand Sage ERP Accpac licensing
- Deploy Sage ERP Accpac over the web

The order of topics in this self-teaching guide matches the sequence of tasks you would typically perform to install and set up Sage ERP Accpac.

Integration with SageCRM

To find out how to integrate Sage ERP Accpac with SageCRM, see the SageCRM Integration Guide.

Important!

This guide contains troubleshooting tips and technical information on configuring supported operating systems and database engines for use with Sage ERP Accpac. However, this guide is not a replacement for a qualified network or database administrator.

System Requirements

Before you can install Sage ERP Accpac System Manager and any of the accounting applications, your hardware must be properly configured, and your operating system must be fully installed and operational.

For a complete list of hardware and operating system requirements for workstations and servers, check the Compatibility Guide in the Support
System Requirements

area of the Sage ERP Accpac Web site at:

Server Requirements

- **Database engines**
  - Sage ERP Accpac supports the following database servers:
    - Pervasive PSQL Server 10.3, or higher, for Microsoft Windows or Linux.
    - Choose Pervasive PSQL Server Engine if more than five users require a concurrent connection to Sage ERP Accpac data, and you have a dedicated server.
    - Choose Pervasive PSQL Workgroup Engine if you are working in a peer-to-peer network environment where there is no dedicated server and not more than 5 users require a concurrent connection to Sage ERP Accpac data.
  
  _Note:_ Version 6.0A does not support Pervasive PSQL 11.


    _Note:_ The Sage ERP Accpac Portal supports only Microsoft SQL Server (including Microsoft SQL Server Express) and Pervasive PSQL. However, the portal database can use a different database format than the company and system databases.

- **Pervasive PSQL Workgroup or Server?**

  In addition, the Sage ERP Accpac Portal requires Internet Information Services version 6 or 7 for the web server.

Client Workstation Requirements

- **Client workstations require:**
  - Workstation component of Microsoft SQL Server, Pervasive PSQL, or Oracle.
  - Microsoft Excel 2003 or 2007, for Excel-based financial reports.
  - Internet Explorer 7.0, or higher.
Network Configuration

You can configure Sage ERP Accpac in a number of ways. The best configuration for your company depends on the number of users who need to use Sage ERP Accpac programs and data concurrently, your chosen database engine, and your network setup.

Each network configuration contains the following components:

- **Server** — The computer that hosts the Sage ERP Accpac data, and optionally, Sage ERP Accpac programs.
  
  In a small workgroup, a workstation may act as a server, providing other workstations with access to Sage ERP Accpac data and programs.

- **Workstation** — A computer that connects to a server to access Sage ERP Accpac programs and/or data. A workstation may:
  - Run the Sage ERP Accpac desktop.
  - Connect to Sage ERP Accpac via an Internet browser.
  - Connect to another workstation or server using Remote Desktop Protocol (RDP).

- **Database Engine** — The software used to create, retrieve, update, and delete data from a database.
  
  Sage ERP Accpac works with the following database engines:
  - Pervasive. SQL.
  - Microsoft SQL Server.
  - Oracle Server.

  Refer to the *System Requirements* section for supported versions.

- **Sage ERP Accpac Program Files** — These include:
  - The Sage ERP Accpac System Manager.
  - Accounting applications, such as Accounts Receivable and Accounts Payable.

- **Sage ERP Accpac Shared Data** — This includes:
  - Site folder.
  - User folder.
  - Data.
− Company folder.
− License Files (*.lic).

• **Sage ERP Accpac Databases** — In Sage ERP Accpac, there are two types of databases:
  
  − The **System** database stores information on users, passwords, security groups, security settings, and currency for all the companies that are linked to it.
  
  − The **Company** database contains information that is shared by all the company’s accounting applications. This includes the company profile, fiscal calendar, optional field data, tax information for both sales and purchases, bank information, and all the accounting data for the company. Each company database must be linked to a system database.

• **Reporting Server** — The software that allows you to print reports from Sage ERP Accpac:
  
  − Crystal Reports runtime for the Sage ERP Accpac Desktop.
  
  − Sage ERP Accpac Web Reporting by Crystal, for Sage ERP Accpac deployed over the web.

---

**Note:** Sage ERP Accpac Web Reporting by Crystal is not supported on Windows Server 2008. The server on which you deploy Sage ERP Accpac over the web must use Windows 2003.

Also, if you are using Windows 7, you cannot print reports for web-deployed Sage ERP Accpac under Windows 7, although you can print them from the Sage ERP Accpac desktop.

---

**Typical Network Configurations**

This section describes the most common network configurations, including:

• Single computer.

• Windows peer-to-peer network.

• Client-server network.

• Sage ERP Accpac Web Server.

**Configuration 1: Single “Standalone” Computer**

Installing on a single computer is the simplest configuration. All components are installed on one computer.
Configuration 2: Windows Peer-to-Peer Network

A Windows peer-to-peer network allows the server and workstations to share resources. This type of network is good for small workgroups, consisting of two to five workstations networked together using Microsoft Windows Network. One of the workstations acts as a server, allowing other computers to access data stored on its hard drive.

If more than two users require concurrent access to Sage ERP Accpac data or programs, the workstation acting as the server should be dedicated. You may encounter performance issues if you run Sage ERP Accpac on the server at the same time as other users are accessing Sage ERP Accpac from their workstations.

Note: When using the Pervasive PSQL Workgroup Engine on a Windows peer-to-peer network, you can maximize performance by completing the tasks described in Appendix A, “Setting Up a Pervasive Workgroup Engine On a Peer-to-Peer Network.”

Configuration 3: Client-Server Network

In a client-server configuration, Sage ERP Accpac programs and databases are on one or more dedicated servers.

The optional Terminal Server may also reside on the same physical server. Workstations may access programs as well as data from the server(s), or may have Sage ERP Accpac programs installed locally for better performance.
Network Configuration

[Diagram showing network configuration with servers, workstations, and optional terminal server]

Note: On each workstation that will run Sage ERP Accpac programs locally, you must install System Manager and the accounting applications.

Configuration 4: Sage ERP Accpac Web Server

When you deploy Sage ERP Accpac on the web, all Sage ERP Accpac programs are installed on a web server, and data is typically stored on a separate server.

Workstations access Sage ERP Accpac programs and data through a supported Internet browser.

Recommendation

For better security and performance, do not store shared data on the web server.

This configuration can exist in combination with a client-server network configuration (Configuration 3). That is, some workstations may run the Sage ERP Accpac Desktop and access data and, optionally programs, from a server.

For more information about deploying Sage ERP Accpac on the web, see Chapter 8 in this guide.
Configuration 5: Sage ERP Accpac Integrated with SageCRM

Similar to Sage ERP Accpac, SageCRM can be installed locally, or on a server, or be deployed on the web.

In the illustration below, we’ve shown web deployment, with the Sage ERP Accpac web server and the SageCRM web server on separate computers.

**Note:** The Sage ERP Accpac and SageCRM web server can reside on the same computer. Typically, one database server stores both the SageCRM and Sage ERP Accpac data.

**Recommendation**

For better security and performance, do not store shared data on the web server.

For more information about integrating Sage ERP Accpac with SageCRM, see the *SageCRM Integration Guide*. 
Where to Now?

You are now ready to install Sage ERP Accpac.
Chapter 2
Installing Sage ERP Accpac Programs

This Chapter explains how to install System Manager, Sage ERP Accpac accounting programs, and Sage ERP Accpac Intelligence.

Before You Begin

Before proceeding, be sure you understand the different system configurations and their implications for installing Sage ERP Accpac:

• On a single workstation and on a network.
• Over different operating systems.
• For different database engines.

Use the information in Chapter 1, “Introduction,” to help you determine the configuration that best meets your company’s needs.

Also, make sure that the computer on which you are installing Sage ERP Accpac meets at least the minimum system requirements for the configuration you choose. For up-to-date information on system requirements, check the Support section of the Sage ERP Accpac Web site, at:


WARNING: If you are upgrading an existing system to the current version of Sage ERP Accpac, use the instructions in the Sage ERP Accpac Update Notice to prepare for and upgrade to the current version.

Installation Considerations

Read the following sections before you install Sage ERP Accpac.
Choosing Installation Folders in Windows Vista, Windows 7, and Windows 2008

If you are using Windows Vista or Windows 2008, installing Sage ERP Accpac to the default path (C:\Program Files\Sage\Sage ERP Accpac) could cause problems with security, because these operating systems do not allow more than one user to open Sage ERP Accpac.

To avoid these potential problems, change the Program and Shared Data directories to locations other than the default path. For example:

- For Programs, install to **C:\Sage ERP Accpac**.
- For Shared Data, install to **C:\AccpacData**.

Decide on suitable folders, and then during the installation of Sage ERP Accpac, be sure to change the default paths.

Considerations for Installing on a Windows Peer-to-Peer Network

The following are special considerations to be aware of before installing or upgrading Sage ERP Accpac on a Windows Peer-to-Peer network.


- If more than two users require concurrent access to Sage ERP Accpac data or programs, the workstation acting as the server should be dedicated. You may encounter performance issues if you run Sage ERP Accpac on the server at the same time as other users are accessing Sage ERP Accpac from their workstations.

- A maximum of five users is supported when running in a peer-to-peer environment.

- On the workstation that will be acting as the server, share the Sage ERP Accpac Program and Shared Data folders.
  - If the server is running Windows XP Professional Edition:
    - Share the designated data folder. All users that connect to this folder must have full control rights to the shared folder. Do not share the Sage ERP Accpac program folder directly.
    - On each workstation, use Universal Naming Convention (UNC) paths to connect to the shared folder. For example, \server\share. If you choose to map a drive letter to the shared folder on the server, then in the Map Network Drive window, select the Reconnect at Logon check box to create a persistent connection.
• If Simple File Sharing is used, when creating the share, select the Allow Network Users to Change My Files check box. To verify if Simple File Sharing is enabled, select Windows Start > My Computer. Then select Tools menu > Folder Options. Click the View tab and scroll to the bottom. Verify the Use Simple File Sharing (Recommended) check box is selected.

− If the server is running Windows Vista or Windows 7:

• During installation, change the Program and Shared Data folders to locations other than the default. For example, change the installation path to C:\Sage ERP Accpac from C:\Program Files\Sage\Sage ERP Accpac.

• Share the Program and Shared Data folders.

• On each workstation, use Universal Naming Convention (UNC) paths to connect to the shared folder. For example, \server\share. If you choose to map a drive letter to the shared folder on the server, then in the Map Network Drive window, select the Reconnect at Logon check box to create a persistent connection.

Considerations for 64-bit Windows Operating Systems

Sage ERP Accpac is a 32-bit program. When you create a data source for Sage ERP Accpac, you must use the 32-bit version of the ODBC Administrator.

In 64-bit versions of supported Windows operating systems, you can find the 32-bit ODBC Administrator in the following location:
C:\Windows\SysWOW64\odbcad32.exe.

Considerations for Installing the Sage ERP Accpac Portal

If you intend to install the Sage ERP Accpac Portal — a program that provides a browser-based and customizable interface for Sage ERP Accpac, with graphical presentations of key financial data — you must first:

• Ensure that Microsoft’s Internet Information Services (IIS) is installed on the server that will host the Sage ERP Accpac Portal.

If IIS is not installed, install it before you attempt to install the Sage ERP Accpac Portal.
Using Sage ERP Accpac Sample Data

When selecting Windows features for Windows 2003 and Windows 7, under World Wide Web Services’ Application Development Features, select the ASP, CGI, ISAPI Extensions, and ISAPI Filters options, as shown here:

If you plan to make the portal accessible from the internet:

- We recommend that you install Sage ERP Accpac on Windows Server 2003 or 2008.
- After installing the Sage ERP Accpac Portal, you need to configure it to make it secure. For more information, see “Configuring Portal Security” in Chapter 5, “Configuring the Sage ERP Accpac Portal.”

Using Sage ERP Accpac Sample Data

Sage ERP Accpac comes with two sample company databases that let users experiment and become familiar with Sage ERP Accpac features before they work with your company data.

The two databases are:

- **SAMINC.** A single-currency database for a US company named Sample Company Inc. It uses the US Payroll program.
- **SAMLTD.** A multicurrency database for a Canadian Company named Sample Company Ltd. It uses the Canadian Payroll program.

Both databases contain data for the following accounting modules:

- General Ledger
- Accounts Receivable
- Accounts Payable
- Inventory Control
- Order Entry
• Purchase Orders
• Payroll (US or Canadian)
• Project and Job Costing

You can choose to install sample data when you install Sage ERP Accpac.

**Installing Sage ERP Accpac**

You install Sage ERP Accpac System Manager, System Manager Components, and all Sage ERP Accpac accounting applications in one continuous process, consisting of two phases:

1. Installing the programs.
2. Entering license information.

**Installing the Programs**

1. Insert the Sage ERP Accpac installation DVD into your DVD drive.
   
   If the installation screen does not appear automatically, go to the DVD root directory (for example, d:\), and run LAUNCH.EXE.

2. On the installation screen, click View Pre-Installation Checklist. Print a copy of the checklist and follow all steps before you continue.

3. On the installation screen, click Sage ERP Accpac.

4. On the Sage ERP Accpac installation screen, click Sage ERP Accpac.

5. On the Welcome screen, click Next.

6. Click the option to accept the license agreement, and then click Next.

7. Select the geographical region where you are installing the software, and then click Next.

8. For the client information, enter your 7-digit or 10-digit client ID and the company name to use for registration, and then click Next.

9. For the optional information, enter a contact person, your dealer, and certified consultant, and then click Next.

10. If the next screen asks you to allow Sage to collect anonymous data, click Yes or No, as you prefer, and then click Next.

11. Select the edition of Sage ERP Accpac you require, and then click Next.

12. Specify the names and locations of your program and data folders, and then click Next.
Note: If you are using Windows Vista, Windows 2008, or Windows 7, be sure to install Sage ERP Accpac outside the default path (for example, C:\Sage\Sage ERP Accpac).

The Select Features screen appears, as follows:

13. On the Select Features screen, select the features and applications you want to install at this time.

Most of the applications require you to install others, and all of them require core System Manager files. The following list shows any additional requirements in parentheses for each application:

- Bank Services (requires Tax Services, G/L Subledger Services).
- Accounts Payable (requires Bank Services, Tax Services, G/L Subledger Services).
- Accounts Receivable (requires Bank Services, Tax Services, G/L Subledger Services).
- Canadian/US Payroll (requires G/L Subledger Services, Bank Services).
- Inventory Control (requires G/L Subledger Services).
- Order Entry (requires Accounts Receivable, Inventory Control, Tax Services).
- Purchase Orders (requires Accounts Payable, Inventory Control, Tax Services).
- Project and Job Costing (requires G/L Subledger Services, Accounts Payable, Accounts Receivable, Tax Services).
• Return Material Authorization (requires Accounts Receivable, Inventory Control, Order Entry).

• G/L Consolidations (requires General Ledger).

• Intercompany Transactions (requires General Ledger).

If you are installing Ops Inquiry or Uni Sales Analysis, note that there are different selections for Pervasive PSQL and for MS SQL Server. You can select only one database format.

14. After you select the programs and features you need, click Next.

15. On the next screen, in the Program Folder field, type the location on the Start menu where you want Sage ERP Accpac to appear, and then click Next.

16. Click Install.

Once installation has finished, the Sage ERP Accpac License Manager appears. Follow the instructions in the next section to enter license information.

**Entering License Information**

The following steps continue from the preceding section, "Installing the Programs."

The License Information tab is filled in with information you entered during installation:

![License Information](image)

**Note:** Do not change the company name unless you need to change the business entity to which the programs are registered.

If you change the company name, the licenses will appear Unauthorized, until you apply for and enter new activation codes.
To enter Sage ERP Accpac license information:

1. If you have activation codes for your Sage ERP Accpac programs, click the Licenses tab, then, for each Sage ERP Accpac program:
   a. Double-click in the Serial Number column, and then type the serial number.
   b. Double-click in the Activation Code column, and then type the activation code in that order.

   If you don’t yet have activation codes, you can use the 30-day temporary licenses created during installation, and record the permanent code later, as described in Chapter 7, “Licensing Sage ERP Accpac.”

2. If you installed Sage ERP Accpac Intelligence Analysis or Sage ERP Accpac Intelligence Connector, enter their activation codes on the Licenses tab.

   **Note:** The Report Manager, Report Viewer, Analysis, and Connector programs are not available with a 30-day license. You must have a permanent license to use them. (Sage ERP Accpac comes with one free Report Manager license.)

3. Click the Users tab.

   **Note:** The system allows you to register only one LanPak license. If a temporary LanPak license exists for this version, skip to step c, and then follow the remaining instructions to enter your permanent registration on the existing line.

   a. Right-click the grid, and then select Insert from the menu that appears. The new entry shows your current Sage ERP Accpac version and edition.
   b. In the new line, double-click the License Type column, and then select LanPak from the list.

      Do not select a database-specific entry!

   c. Double-click in the Count column, and then type the total number of users who require Sage Accpac access for this installation. (The count is the sum of existing users plus the new users for whom you’re adding LanPak licenses.)

      If you already have a permanent license for this version, the system asks you to confirm whether you want to overwrite the existing license. If you receive this message, click Yes.

      The system immediately deletes any existing LanPak licenses.
d. Double-click in the Serial Number column, and then type the LanPak serial number that Sage provided.

e. Double-click in the Activation Code column, and then type the activation code that Sage provided.

   If you don’t yet have an activation code, you can create a temporary license by leaving the activation code blank.

f. Press Tab, or click elsewhere on the grid, to leave the field.

   The system changes the Count to the purchased amount (if necessary) and enters Activated in the Activation Code field.

   IMPORTANT: You must record at least one LanPak license to use Sage ERP Accpac.

   For Sage ERP Accpac Intelligence, one Report Manager license for one user is free with Sage ERP Accpac. If you have additional licenses for Sage ERP Accpac Intelligence Report Manager and Sage ERP Accpac Intelligence Report Viewer, enter their activation codes in the Activation Code column.

4. Click Close.

5. Click Finish to close the Installation wizard.

---

**When To Use Workstation Setup**

The Workstation Setup utility is a component of the System Manager installation. It installs the components that a workstation requires to run System Manager and accounting modules on a server.

You must run Workstation Setup on each workstation that will run Sage ERP Accpac programs from a server, including programs opened through the Sage ERP Accpac Portal.

**Run Workstation Setup after:**

- You have set up shared folders to data and/or programs.
- You have created your system and company databases.

**Do not run Workstation Setup if:**

- The workstation will run Sage ERP Accpac programs locally.

   In this case, install Sage ERP Accpac System Manager and the accounting applications on the workstation as described in Chapter 2 of this guide.
• The workstation is a Web client, and will access Sage ERP Accpac programs and data through an Internet browser.

   In this case, deploy Sage ERP Accpac on the Web and follow the client setup instructions described in Chapter 7 of this guide.

• The workstation is using Remote Desktop Protocols (RDP) to remotely control another workstation or server.

   In this case, install Remote Desktop Client on your remote computer. Then, connect through a Terminal Server or directly to a workstation, or server, that is configured for remote access.

   **Note:** This guide does not include instructions for setting up terminal services or RDP. Talk to your network administrator about this option.

---

**Running Sage Accpac Intelligence for the First Time**

Sage Accpac Intelligence (SAI) is compatible with Microsoft SQL and Pervasive.PSQL.

If you are using Windows Vista, Windows 2008, or Window 7, you must log in as the Windows administrator the first time you run SAI version 6.0.

A user with Windows administrator privileges must register the ActiveX component, SageACCBI60.exe, that SAI requires. Open any form in the Sage Accpac Intelligence folder to register this component. Once it is registered, other types of users can open SAI forms.

---

**Where To Now?**

**New installation**

If you are installing Sage ERP Accpac for the first time, you need to create system and company databases using supported database software, and then set up the databases for use in Sage ERP Accpac. If you plan to use the Sage ERP Accpac Portal, you must also create a portal database.

For information on setting up databases for Sage ERP Accpac, see Chapter 3, “Database Setup.”

**Activating data**

Once you have set up company and system databases, you can activate your data for the current version, as described in Chapter 4, “Activating Sage ERP Accpac.”
Configuring the portal

If you installed the Sage ERP Accpac Portal, you need to configure the portal to connect it to the portal database.

For information about configuring the Sage ERP Accpac Portal, see Chapter 5, “Configuring the Sage ERP Accpac Portal.”

Grace period for temporary licenses

You can use temporary licenses for 30 days while you wait for your activation codes. However, you must enter activation codes before the grace period ends, or you will no longer have access to Sage ERP Accpac.

For instructions on updating your licenses, see Chapter 7, “Licensing Sage ERP Accpac.”

Upgrading an existing system

If you are upgrading an existing system, refer to the Sage ERP Accpac Update Notice for steps on activating your data and for important information about the conversion of your data, including additional steps you may need to take before and after activation.
Chapter 3
Database Setup

In this chapter, you'll learn how to create your Sage ERP Accpac system, company, and portal databases, and how to set global security options.

This chapter does not provide detailed instructions on how to install or configure database software. See your database or network administrator for detailed instructions and support.

For a list of database engines that are compatible with Sage ERP Accpac, see “Server Requirements” in Chapter 1.

To get the most recent list of supported database versions, check the Compatibility Guide in the Support area of the Sage ERP Accpac Web site at: http://www.sageaccpac.com/products/systemrequirements.

Overview of Database Setup

Before you can create a company in Sage ERP Accpac, you must create system and company databases using one of the following database programs:

- Pervasive PSQL

  Note: If you are running Pervasive PSQL Workgroup Engine on a peer-to-peer network, you should optimize your system as described in Appendix A, “Setting Up a Pervasive Workgroup Engine on a Peer-to-Peer Network.”

- Oracle

- Microsoft SQL Server

Portal database

If you plan to use the Sage ERP Accpac Portal, you must also create a portal database. Normally, you create the portal database on the same server as your company database.

You can create the portal database using Pervasive PSQL or Microsoft SQL Server.

After you have created the databases using your database software, use the Database Setup utility to set up the databases for Sage ERP Accpac.
Creating System, Company, and Portal Databases

In Sage ERP Accpac, there are three types of databases:

- **System Database.** Stores information on users, passwords, security groups, security settings, and currency for all the companies that are linked to it. You must create a system database before creating a company database.

- **Company Database.** Contains information that is shared by all the company’s accounting applications. This includes the company profile, fiscal calendar, optional field data, tax information for both sales and purchases, bank information, and all the accounting data for the company. Each company database must be linked to a system database. However, multiple companies can be linked to the same system database.

- **Portal Database.** The portal database stores files used exclusively by the Sage ERP Accpac Portal, including user preferences, snapshot configurations, and other files that determine how the Portal looks and functions.

  Note that the portal database is shared by all companies in a Sage ERP Accpac installation, and you can set up only one Sage ERP Accpac Portal.

**Database ID**

Sage ERP Accpac uses a Database ID to identify databases. Each ID is a unique code of uppercase characters, consisting of letters from A to Z, or numbers from 0 to 9, or any combination of letters and numbers.

**Note:** The ID for system and company databases cannot be more than six characters long. This restriction does not apply to portal database IDs.

For simplicity, we recommend that the Database ID, the database, the folder for the database, and the Data Source Name (DSN) be identical.

The instructions for creating system, company, and portal databases for Sage ERP Accpac are specific to the database software you use. In the sections that follow, read the instructions for the database software you use.

**Before You Begin**

Before you create your databases, create folders in Windows Explorer to contain your Sage ERP Accpac system, company, and portal databases.
In the Sage ERP Accpac\Data folder (or other installation location), create a 6-character subfolder for your system database, and then add another for your company database.

For example, you might have:

C:\Program Files\Sage\Sage ERP Accpac\DATA\GLDSYS (for your system database)

and

C:\Program Files\Sage\Sage ERP Accpac\DATA\GLDINC (for your company database)

Creating Pervasive PSQL Databases

Creating Databases in the Pervasive Control Center

1. On the server (or the workstation acting as a server), from the Window Start menu select All Programs > Pervasive > Pervasive PSQL Control Center.

The Pervasive PSQL Control Center appears, as follows:

2. In the Common Tasks section in the right panel, click New Database.
The New Database form appears, as follows:

3. Accept the Server name that is displayed (the name of the computer you are currently working on), and then click Next.

The following screen appears:

4. In the Database Name field, type the name of the folder you created for your database; for example, GLDSYS for your system database.

**Note:** The folder name and the database name must be identical.

5. In the Location field, type the path to the folder you created for the database.

6. In the DB Name Options section, select Bound and Create Dictionary Files.
Note: Do not select the option, Relational Integrity Enforced, because Sage ERP Accpac checks integrity.

7. Select the Create DSN option, and leave Normal as the Open Mode.

Note: The DSNs are used in Sage ERP Accpac Database Setup when you set up your system and company databases.

8. In the Metadata section, use the default selection.

9. Click Finish.

10. Repeat steps 2 to 8 for the company database.

In step 4, substitute the 6-character name of your company database (for example, GLDINC).

11. Repeat steps 2 to 8 for the portal database.

In step 4, substitute the name of your portal database. (We recommend PORTAL as the name of your portal database.)

12. Close the Pervasive PSQL Control Center.

Creating ODBC Connections on Client Workstations

On all client workstations, create ODBC connections to your system and company databases as follows:

1. Open the ODBC Data Source Administrator. On Windows’ Start menu, select Start > All Programs > Administrative Tools > ODBC Data Sources (ODBC).

![ODBC Data Source Administrator](image)

2. Select the System DSN tab, and then click Add.
The Create New Data Source form appears:

3. Select Pervasive ODBC Client Interface, and then click Finish.

The Pervasive ODBC Client DSN Setup form appears:

4. Enter the following information for the Data Source:
   a. In the Data Source Name field, type the 6-character name of the system database.
   b. Type an optional description.
   c. In the Address field, type the name of the database server.
   d. In the Transport Hint field, select Try TCPIP Only.

5. Click the Get DSN List button, and then select the DSN that you created for the server database.

6. Click the Test button to check your connection.

7. Click OK to create the connection.

8. Repeat steps 2 to 7 to create the DSN for the company database. In step 4a, type the 6-character name of the company database, and in step 5, select the DSN that you created for the company database.
Where to Now?

Now that you have created system and company databases in your database management system, you need to set them up for use with Sage ERP Accpac, as described in the section “Setting Up Company and System Databases,” later in this chapter.

If you set up a portal database, you need to configure it for use with the Sage ERP Accpac Portal, as described in Chapter 5, “Configuring the Sage ERP Accpac Portal.”

Creating Microsoft SQL Server Databases

Creating Databases in SQL Server Management Studio

1. On the server, On Windows’ Start menu, select Programs > Microsoft SQL Server 2005 (or 2008, depending on the version installed) > SQL Server Management Studio.

   The Connect to Server screen appears, as follows:

   ![Connect to Server Screen](image)

2. For Server type, select Database Engine.

3. Accept the Server name that is displayed (the name of the computer you are currently working on).

4. For Authentication, we recommend that you use SQL Server Authentication.

   Important! You must use SQL Server authentication for the portal database.

   Type in the database administrator’s Login name and Password.

5. Click Connect to open SQL Server Management Studio.

6. In the Object Explorer panel, expand the folder tree for the SQL Server, and then expand the Databases folder tree.

7. Right-click Databases, and then select New Database... from the menu.
Creating System, Company, and Portal Databases

The New Database window appears, as follows:

8. In the Database name field, type the 6-character name for the system database.
   a. In the Database files section:
      i. In the Initial Size column, specify the amount of disk space that SQL Server will initially reserve for the Sage ERP Accpac database. For new databases, use the default value.
      ii. In the Autogrowth column, you can select whether the container grows by a fixed percentage or by a fixed amount of disk. For new databases, use the default value.

9. In the left pane, click Options.
Creating System, Company, and Portal Databases

Installation and System Administrators Guide 3–9

a. For English-language support, use Latin1_general_bin or Latin1_general_ci as the collation method.

We recommend that you use a binary collation method, such as Latin1_general_bin.

b. For Recovery Model, select Full.

10. Click OK.

Extended Properties

Warning: If you are setting extended properties for your database, make sure you do not turn on the XACT_ABORT property. This feature is not supported by Sage ERP Accpac.

11. Repeat steps 7 to 10 to create your company database. In step 8, type the 6-character name for the company database.

12. Repeat steps 7 to 10 to create your portal database. In step 8, type the 6-character name for the portal database. (We recommend using PORTAL as the name of your portal database.)

Creating and Assigning Database Rights to a SQL Login ID

A SQL Login ID is required to log in to a Sage ERP Accpac company database. The ID is not revealed to users; Sage ERP Accpac uses this ID internally when it connects a user to the SQL Server.

Note: Only one SQL Login ID is needed for all Sage ERP Accpac databases and users.
1. In SQL Management Server Studio, in the left-side Object Explorer panel, expand the Security folder.

2. Right-click Logins and then click New Login... from the right-click menu.

   The New Login form appears, as follows:

   ![New Login Form](image)

3. In the Login name field, type a name for your new SQL Login ID.

4. Select SQL Server Authentication, and then type in a password, and confirm it.

5. Click OK to save your changes.

   In the Object Explorer, your new Login name appears within the Logins folder.

6. Assign database rights to the new SQL Login ID.

   a. In the Object Explorer, expand the Logins folder, and then double-click the new Login name you created.

      The Login Properties form appears.

   b. In the left pane, click Server Role, and in the right pane, select sysadmin.

   c. In the left pane, click User Mapping.

   d. In the Database column, select the system and company databases you created.

   e. Under Database role membership for, select db_owner.

   f. Click OK to save your changes.
Creating ODBC Connections on Client Workstations

If you are using a DSN to connect to your SQL databases on the server, on all client workstations, create an ODBC connection to your databases.

Important! If you do not create a Data Source (DSN) to connect to your databases, Sage ERP Accpac can connect to the SQL Server directly using the server name and default settings.

1. Open the ODBC Data Source Administrator.

   On Windows’ Start menu, select Settings > Control Panel > Administrative Tools > Data Sources (ODBC).

   Sage ERP Accpac is a 32-bit application. When you create a data source for Sage ERP Accpac, you must use the 32-bit version of the ODBC Administrator.

   In 64-bit versions of supported Windows operating systems, you can find the 32-bit ODBC Administrator in the following location: C:\Windows\SysWOW64\odbcad32.exe.

2. Select the System DSN tab, and then click Add.

   The Create New Data Source form appears:
3. Select SQL Native Client (for SQL Server 2005), or SQL Native Client 10 (for SQL Server 2008), and then click Finish.

The Create A New Data Source To SQL Server form appears:

4. Enter the following information for the Data Source:
   a. In the Name field, type the 6-character name of the system database.
   b. Type an optional description.
   c. Select the database server from the list.

   *Note:* When creating the DSN for a portal database, if you specify a named instance of SQL Server, be sure to append the database port number, or you may have trouble printing reports from the portal. For example, specify SERVER\INSTANCE,1433. (If you use a nonstandard port, specify that number instead of 1433.)

5. Click Next.

The following form appears:

6. Enter authentication information:
   a. Select SQL Server authentication.
b. Select Connect To SQL Server To Obtain Default Settings For The Additional Configuration Options.

c. In the Login ID field, type in the SQL Login ID and password that you created in the previous section.

7. Click Next.

The following form appears:

8. Select the option Change The Default Database To, and then select Database For This Connection. Leave the other fields at their default values.

9. Click Next, and then Finish to create the ODBC data source.

10. Click Test Data Source to test the connection to the database.

Where to Now?

Now that you have created system and company databases in your database management system, you need to set them up for use with Sage ERP Accpac, as described in the section “Setting Up Company and System Databases,” later in this chapter.

If you set up a portal database, you need to configure it for use with the Sage ERP Accpac Portal, as described in Chapter 5, “Configuring the Sage ERP Accpac Portal.”

Creating Oracle Server Databases

Because database joins must be within the same Oracle database, a single Oracle database must contain the system database and all company databases that use the system database.

Note: You cannot create a portal database in Oracle Server.
Creating System, Company, and Portal Databases

You use Oracle user names to identify the separate system and company database tables.

Creating a Single Database Using the Oracle Database Configuration Assistant

Use the Database Configuration Assistant to create a *single database* to hold all your accounting data.

1. On Windows’ Start menu, select All Programs > Oracle — Oracle_home name > Configuration and Migration Tools > Database Configuration Assistant.
   
   a. In Step 1, select Create a Database, then click Next.
   
   b. In Step 2, select the Transaction Processing template, and then click Next.
   
   c. In Step 3, type the same name for both the Global Database Name and the Oracle System Identifier (SID) – for example, ACCEPAC – and then click Next.
   
   d. In Step 4, select the options Configure The Database With Enterprise Manager and Use Database Control For Database Management, and then click Next.
   
   e. In Step 5, select the option to Use the Same Password for All Accounts, and then type in and confirm a password, and then click Next.
   
   f. In Step 6, select File System as the storage mechanism for database storage, and then click Next.
   
   g. In Step 7, browse to select the data folder, and then click Next.
   
   h. In Step 8, select Specify Flash Recovery Area as the database recovery option, and then browse to select a backup folder. Use the default Flash Recovery Area Size of 2048 MB, and then click Next.
   
   i. Click Next to skip Step 9.
   
   j. In Step 10, on the Memory tab, select Typical. Oracle will allocate memory as a percentage of total physical memory. Click Next.
   
   k. Click Next to skip Step 11.
   
   l. In Step 12, select Create Database.

2. Click Finish.

3. On the Confirmation form that appears, click OK.
4. When the database creation process is complete, click Exit to close the Database Configuration Assistant.

Create a Table Space in Oracle Enterprise Manager

1. On the server, open your Internet browser and log in to the Oracle Enterprise Manager Console.

2. Select the Administration tab.

   A page similar to the following one appears:

3. In the Storage section, click Tablespaces.

   A form similar to the following one appears:
4. On the Tablespace page, click Create.

   In the following example, SAMSYS is the system tablespace name.

5. On the General tab, type in the 6-character name of the system tablespace, and then click Add.

   The Add Datafile page appears:

6. Accept the default entries, and then click Continue to return to the Create Tablespace page.

7. Accept the default entries for all the fields on the Storage and Thresholds tabs, and then click OK to create the system tablespace.

8. Repeat steps 3 to 7 to create the company tablespace. In step 5, type in the 6-character name of the company tablespace.
9. On the top left, click the Database link to return to the main Enterprise Manager page.

**Setting Up Security to the Oracle Tablespaces**

1. You should be logged into the Oracle Enterprise Manager Console. On the Administration tab, in the Security section, click Users. The Users page appears:

2. On the Users page, click Create.

   A form similar to the following one appears:

3. Select the system tablespace, and then click Select.
Creating System, Company, and Portal Databases

The Create User page appears:

4. Select the Roles tab, and then click Modify.

The Modify Roles page appears:

5. Move CONNECT and RESOURCE to the Selected Roles box, and then click OK.

6. On the Create Users page, select the System Privileges tab, and then click Modify.
The Modify System Privileges page appears:

7. Move UNLIMITED TABLESPACE and SELECT ANY TABLE to the Selected System Privileges box, and then click OK.

8. Click OK to return to the Users page.

9. Repeat steps 1 to 8 to set security for the company tablespace.

Configuring the Listener on the Server

1. In Windows, from the Start menu, select All Programs > Oracle — Oracle_home name > Configuration and Migration Tools > Net Configuration Assistant.

2. On the Welcome screen, choose Listener Configuration, and then click Next.

3. Select Add, to add a listener, and then click Next.

4. Type in a name for the Listener; for example, Accpac, and then click Next.

5. Move TCP to the Select Protocols box, and then click Next.

6. Select the option to use the standard port number (1521), and then click Next.

7. Select No, and then Next to complete the configuration for this listener.
Installing the Oracle Client on Workstations

Before you install the Oracle Client
On the client workstation, disable Windows Firewall before you install the Oracle client.

If you have not installed the Oracle Client on workstations that will access Sage ERP Accpac databases, do so now.

When you are prompted to choose the Installation Type, select Runtime.

Specifying Local Net Service Name Configuration
On a network, workstations use a net service name to connect to an Oracle database.

On all workstations:
1. In Windows, from the Start menu, select All Programs > Oracle — Oracle_home name > Configuration and Migration Tools > Net Configuration Assistant.
2. Select Net Service Name Configuration.
3. Select Add, then Next.
4. Type in the Service Name of the Oracle database. This is the Global Database Name that you previously defined. In our example, we used ACCPAC.
5. Click Next.
6. For the network protocol, select TCP, and then click Next.
7. For Host name, type in the name of the server where the Oracle database is located. Use the standard port number of 1521.
8. Click Next.
9. Select the option to test the connection.
10. When the communication is successful, click Next.
11. Use the default Net Service Name. Oracle uses the name you entered in Step 4.
12. Click Next, and then Exit to close the Configuration Assistant.

Creating DSNs on Workstations for System and Company Databases
1. On the client, open the ODBC Administrator.
   On Windows’ Start menu, select All Programs > Administrative Tools > Data Sources (ODBC).
2. Click the System DSN tab, and then click Add.

   A form, similar to the following, appears:

   ![Create New Data Source form]

3. Select the Oracle — *Oracle_home name* driver, and then click Finish.

   The Driver Configuration form appears. An example follows:

   ![Oracle ODBC Driver Configuration form]

4. For the system tablespace, complete the Driver Configuration form as follows:

   a. In the Data Source Name field, type in the name of the system tablespace.

   b. In the Description field, type in an optional description.

   c. For the TNS Service Name, select the Service Name of the Oracle database. In our example, this is ACCPAC.
d. In the User ID field, type in the name of the system tablespace.

e. Leave all other options at their default setting.

f. Click Test Connection. When prompted, enter your password.

g. Click OK to save the DSN.

5. Repeat steps 2 to 4 to create the DSN for the company tablespace. In step 4, type the name of the company tablespace in the Data Source Name and User ID fields.

6. Click OK to close the ODBC Administrator.

Where to Now?

Now that you have created system and company databases in your database management system, you need to set them up for use with Sage ERP Accpac, as described in the next section “Setting Up Company and System Databases.”

If you set up a portal database, you need to configure it for use with the Sage ERP Accpac Portal, as described in Chapter 5, “Configuring the Sage ERP Accpac Portal.”

Setting Up Company and System Databases

Use the Sage ERP Accpac Database Setup utility to configure your system and company databases for use with Sage ERP Accpac. The Database Setup utility is installed with Sage ERP Accpac System Manager.

Important! Only the Sage ERP Accpac ADMIN user can use the Sage ERP Accpac Database Setup utility, which allows the ADMIN user to:

- Add, edit, and delete system and company databases.
- Configure the Sage ERP Accpac Portal.
- Turn on security for a system database.
- Select advanced security settings, such as password options, that apply to all users.

Setting Up a System Database

1. On the server, on Windows’ Start menu select All Programs > Sage ERP Accpac > Database Setup.
The Sign-on form appears:

2. Sign in using the administrator (ADMIN) password.

**Note:** The default password is “admin.”

After creating your databases and activating your applications, change the ADMIN password to prevent unauthorized use of Sage ERP Accpac. It is important that other users do not have access to the system administrator’s tasks.

The Database Setup form appears:

**Note:** What you see may be different, depending on whether sample data was installed, and whether other Sage ERP Accpac databases have already been created.

3. Click New, or press the Insert key.
The New Database form appears:

4. In the Database ID field, enter the name of the DSN you created for the system database.

   **Note:** The Database ID always defaults to uppercase, and cannot be changed after it is assigned.

5. Select the appropriate Database Format from the list.

6. For Database Category, select System.

7. Click OK.


   The fields that appear, and the next steps you follow, depend on the database format you selected in step 5.

   **To set up a Microsoft SQL Server system database:**

   a. In the Description field, type a description for the database, using up to 60 characters. The Database ID is displayed by default.
b. Click the Data Source option, and then select the data source name from the Data Source field, or specify the server name for the database in the Server field. (Only data sources you created on your workstation appear in the list.)

Note that the names of the data sources must be consistent on all workstations that use the same shared Data directories. Remember, also, to type the name with the same capitalization that you used to define it with the ODBC Administrator.

c. Enter the SQL Login ID that you created for all Sage ERP Accpac users.

Warning: Make sure you enter the SQL Login ID correctly because you will not be able to change it after you save the database profile.

d. Enter the Password for the Login ID you entered in the previous field.

When users sign on to Sage ERP Accpac, the System Manager verifies their Sage ERP Accpac passwords, then logs onto SQL Server using the Login ID and password specified here. Individual Sage ERP Accpac users do not need Login IDs for SQL Server.

e. Enter the name of the database you created as the Sage ERP Accpac system database. Make sure you use the same capitalization that you did when you defined it with the SQL Enterprise Manager.

f. If you intend to limit user access to accounting data, select the Enable Application Security option. (You can select this option only for system databases, not for company databases.)

With security on, all access to application windows is then controlled by Sage ERP Accpac’s own security system. With security off, Sage ERP Accpac still uses the SQL Server Login ID and Password to gain access to the database, but it doesn’t restrict access to Sage ERP Accpac users.

g. Click OK.
To set up a Pervasive PSQL system database:

a. The ID that appears in the Data Source field is identical to the database ID, and appears because it matches the datasource name (DSN) that you created for this system database in the Pervasive PSQL Control Center.

If you did not create a DSN for this database ID, the Data Source field is blank, and you cannot finish setting up this database.

b. Type a description (name) for the system database, up to 60 characters.

The default description is the Database ID that you entered previously.

The security model you selected in the Pervasive Control Center appears in the Security Model section. You cannot change these options during database setup.

However, if the Pervasive database uses either Mixed or Database security, you can edit the User Name and Password fields. (You cannot edit these fields if the database uses Classic security.)

c. If the Login ID and Password fields are available, type the user name and password in these fields.

d. To limit user access to accounting data, select the Enable Application Security option. (You can select this option only for system databases, not for company databases.)

e. Click OK.
To set up an Oracle system database:

a. Select the Oracle ODBC data source name from the list in the Data Source field, or type the server name in the TNS Service field.

You can use the same DSN for all Oracle systems and companies that are on the same server (provided you specified the user names accurately).

b. In the Login ID field, specify the system database user name, and then enter the password you created on the Oracle server.

c. Specify the Tablespace you created for the database.

Note: Although defining the Tablespace is optional, the Tablespace must already exist.

d. To limit user access to accounting data, select the Enable Application Security option. (You can select this option only for system databases, not for company databases.)

e. Click OK.

Setting Up a Company Database

1. If Database Setup is not already running, On Windows’ Start menu, select Programs > Sage ERP Accpac > Database Setup.

2. Sign in using the administrator (ADMIN) password.
Setting Up Company and System Databases

The Database Setup form appears:

![Database Setup Form]

**Note:** What you see may be different, depending on whether sample data was installed and whether other Sage ERP Accpac databases have already been created.

3. Click New, or press the Insert key.

The New Database form appears:

![New Database Form]

4. In the Database ID field, enter the name of the DSN you created for the company database.

**Note:** The Database ID always defaults to uppercase, and cannot be changed after it is assigned.

5. Select the appropriate Database Format from the list.

6. For Database Category, select Company.
Note: For company databases, the Database ID will appear in the title bar of windows that contain company data, such as Company Profile, Fiscal Calendar, and Optional Tables.

7. Select the system database ID you create earlier.

8. Click OK.


The fields that appear, and the next steps you follow, depend on the database format you selected in step 5.

To set up a Microsoft SQL Server company database:

a. In the Description field, type a description for the database, using up to 60 characters. The Database ID is displayed by default.

b. Click the Data Source option, and then select the data source name from the Data Source field, or specify the server name for the database in the Server field. (Only data sources you created on your workstation appear in the list.)

   Note that the names of the data sources must be consistent on all workstations that use the same shared Data directories. Remember, also, to type the name with the same capitalization that you used to define it with the ODBC Administrator.

   Warning: Make sure you enter the SQL Login ID correctly because you will not be able to change it after you save the database profile.

c. Enter the SQL Login ID that you created for all Sage ERP Accpac users.
d. Enter the Password for the Login ID you entered in the previous field.

e. Enter the name of the database you created as the Sage ERP Accpac company database. Make sure you use the same capitalization that you did when you defined it with the SQL Enterprise Manager.

f. Click OK.

**To set up a Pervasive PSQL company database:**

![Pervasive PSQL Database Profile]

a. The ID that appears in the Data Source field is identical to the database ID, and appears because it matches the datasource name (DSN) that you created for this company database in the Pervasive PSQL Control Center.

   If you did not create a DSN for this database ID, the Data Source field is blank, and you cannot finish setting up this database.

b. Type a description (name) for the company database, up to 60 characters.

   The default description is the Database ID that you entered previously.

   The security model you selected in the Pervasive Control Center appears in the Security Model section. You cannot change these options during database setup.

   However, if the Pervasive database uses either Mixed or Database security, you can edit the User Name and Password fields. (You cannot edit these fields if the database uses Classic security.)

c. If the Login ID and Password fields are available, type the user name and password in these fields.
d. Click OK.

To set up an Oracle Server company database:

a. Select the Oracle ODBC data source name from the list in the Data Source field, or type the server name in the TNS Service field.

   You can use the same DSN for all Oracle systems and companies that are on the same server (provided you specified the user names accurately).

b. In the Login ID field, specify the user name (Login ID) and password for each company you created on the server.

c. Specify the Tablespace you created for the database.

   **Note:** Although defining the Tablespace is optional, the Tablespace must already exist.

d. Click OK.

10. Click Exit to close Database Setup.

---

**Setting Global Security Options**

The Sage ERP Accpac System Administrator can set advanced global security options, such as the length of passwords and how often they should change. The options you set affect both company and system databases.
To set global security options:

1. If Database Setup is not already running, on Windows’ Start menu, select Programs > Sage ERP Accpac > Database Setup.

2. Sign in as ADMIN, and then click OK to open the Database Setup form. The Database Setup form lists the system and company databases that have been created.

3. Click the Security button.

   The Advanced Security Settings form appears:

4. Select the following options as needed.
Important!

Selections will apply to all Sage ERP Accpac databases listed on the Database Setup form.

Ensure that you turned on application security when you created your system database. If application security is not turned on, or is turned on and no password is required, the password settings on the Advanced Security Settings form have no effect.

Require complex passwords. Require users to create passwords that include both letters and numbers. If users enter a password without the complexity you specify, they receive the message, "Password change is required." When they click OK, the Change Password form opens.

Require passwords to change every [   ] days. Requires users to change their passwords after a specified number of days. Enter a value from 1 to 999.

Expired passwords

If a password expires, users will receive a message that it has expired, and the Change Password form will open.

Require minimum password length of [ ] characters. Requires users to create passwords of a set length. Enter a value between 4 and 64 characters. If users enter a shorter password, they will receive the message, "Password change is required." When they click OK, the Change Password form opens.

Lock out user after [ ] attempts. Enter the number of times a user can enter an invalid password before they are locked out of the system. When a user is locked out, they can wait for the lockout period to expire before attempting to log in again, or the System Administrator can clear the option, allowing the user to attempt to log in again.

Enable locked-out user after [ ] minutes. Enter the number of minutes between 1 and 30,000 in which a locked-out user can retry their password.

Use time server. Synchronize your workstation’s time with a specified server.

Note: If you restrict the hours a user can sign in to Sage ERP Accpac, it is important to use a time server to maintain this security.

5. Click OK to save your changes and return to the Database Setup form.

6. Click Exit to close Database Setup.
Where to Now?

You can now sign on to your new company, create the company profile, and activate your data for the current version.

For information about activating your data, see Chapter 4, “Activating Sage ERP Accpac.”
Chapter 4
Activating Sage ERP Accpac

Before you can use a new company or a new accounting application, you must prepare your database for use with Sage ERP Accpac. This process is called activation.

This chapter describes activation and gives instructions for:

- Signing on to a new company.
- Creating the company profile.
- Activating your data for new accounting programs.

If you are upgrading from an earlier version of Sage ERP Accpac, you should refer to the Sage ERP Accpac Update Notice, which provides specific instructions for installing programs and activating data for existing Sage Accpac systems. You may need to perform additional procedures in a certain sequence when upgrading from previous versions. Also, when you are upgrading, you don’t need to perform some of the steps that are required for new installations.

You must create system and company databases using your database software before you can set up the databases for use with Sage ERP Accpac. The instructions in this chapter assume that you have created a system database and a company database for the database engine you are using with Sage ERP Accpac. For information on setting up databases, see Chapter 3, “Database Setup.”

Before You Begin

When you start Sage ERP Accpac with a new company database, you will need to specify:

- The number of fiscal periods your company uses.

  Decide whether to use 12 or 13 periods in your fiscal year.
  
  If you use 13 periods, decide which quarter will contain four fiscal periods.

- Your company’s functional currency — that is, the currency in which your company keeps its books.
The functional currency applies to all Sage ERP Accpac applications for the company (such as Accounts Receivable, Accounts Payable, and Payroll).

If you use multicurrency accounting, you must also specify:

- A default exchange rate type (for example, monthly average rate or daily spot rate).

Determine the rate type your company uses most often to convert amounts entered in another currency to the functional currency

- Your reporting currency, if the euro is your functional currency, and you want to produce reports in both euro and your national currency.

**Note:** You must use the Desktop to activate all Sage ERP Accpac programs. You cannot use the Sage ERP Accpac Portal to activate programs.

### Signing On to a New Company

**New company**

When you sign on to a company, Sage ERP Accpac checks whether Administrative Services and Common Services for the company are activated.

- If this is the first time you are using a new system database, Sage ERP Accpac prompts you to activate Administrative Services. The activation process creates currency and security tables, installs standard currency codes and rate types, and places the Administrative Services icon on the Sage ERP Accpac desktop.

- The first time you open a new company, Sage ERP Accpac prompts you to activate Common Services. When you activate Common Services, the program creates tables to store company-wide information, displays the Company Profile, and places the Common Services icon on the Sage ERP Accpac desktop.

**To sign on to a new company**:

1. From the Windows Start menu, select All Programs > Sage ERP Accpac > Sage ERP Accpac. The Open Company form appears.
2. In the User ID field, type **ADMIN**. This is the ID for the system administrator, the only person authorized to set up a new company.

3. If you selected the option Enable Application Security when you set up the system database, enter the system administrator’s password.

4. From the Company list, select the name of the new company.

The list contains the names of all company databases you created for Sage ERP Accpac, as well as the names of sample companies, if you installed sample data.

5. In the Session Date field, type the date of your work session (or accept the default). This date will be the default Fiscal Year Starting Date when you activate Common Services for the company.

If the system database is being used for the first time, the following form appears:

7. Click Proceed to activate Administrative Services for the system database.

The program displays messages showing that data is being activated.

Once Administrative Services has been created and initialized, the program prompts you to enter the company’s fiscal year starting date and proceed to activate Common Services, as shown here:
8. Type the starting date of your company’s current fiscal year in the Fiscal Year Starting Date field, if it is different than the default date. Sage ERP Accpac creates this fiscal year in your company calendar.

9. Click Proceed to activate Common Services for the company database. Messages appear showing that tables are being created.

10. After Common Services has been created and initialized, the Common Services Activation form appears, as follows:

   ![Common Services Activation Form](image)

The options on the Common Services Activation form belong to your Company Profile. Follow the instructions in the next section to complete the company profile.

If you click Cancel, you return to the Open Company form. When you next start Sage ERP Accpac for this company, you are asked to activate Common Services.

11. When you are satisfied with the company profile information, click OK.

   Sage ERP Accpac places icons for Administrative Services and Common Services on the company desktop.

**Creating the Company Profile**

This section describes the company profile information you enter when you open a new company, such as the address and options for all the Sage ERP Accpac applications used by your company.
Entering Company Information

The Common Services Activation form includes the following tabs:

- **Address.** Displays the database ID and the name of the company you selected when you signed on. It includes fields for the address, telephone and fax numbers, and contact name.

- **Options.** Contains fields for company-wide settings, such as the number of fiscal periods in your fiscal year, and whether you use multicurrency accounting.

1. Fill in the fields on the Address tab, as follows:

   The address information you enter on this page also appears as the default in the Options form for each accounting application. You can change the contact, phone number, or fax number to identify a person or position in the company for whom you are creating a specific ledger system.

   **Doing Business As.** Type the company’s name, exactly as you want it to be on all reports, financial statements, customer statements, and invoices. You can use up to 60 characters, including letters, digits, symbols, and punctuation. The default entry is the description from Database Setup.

   **Legal Name.** Type the company’s legal name, if it is different from the business name.

   **Address.** Type the company’s address.

   **City.** Type the name of the city where the company is located.

   **State/Province.** Type the name of the state or province where the company is located.

   **Zip/Postal Code.** Type the company’s zip or postal code.

   **Country.** Type the name of the country where the company is located.

   **Contact.** Type the name of a general contact person or position in the company.

   **Format Phone Number.** Select this option if the company’s phone and fax numbers are 10 digits long and are formatted with standard parentheses and hyphens, for example (555) 982-9800. Don’t select the option if you use longer phone and fax numbers, or you need additional punctuation.

   **Telephone / Fax Number.** Type the company’s telephone and fax numbers.
Except for the database ID, you can change any of the entries on this tab at any time.

2. Fill in the fields on the Options tab, as follows:

**Number of Fiscal Periods.** In most cases, you select 12 periods if your fiscal year is divided into calendar months, and 13 if your fiscal year is divided into four-week periods.

**IMPORTANT:** If you change the number of fiscal periods, later, you will not be able to compare amounts between years that have different numbers of fiscal periods.

The number of fiscal periods you select determines the lengths of the default periods on the fiscal calendar. If your fiscal periods vary in length, or if you have a 12-period fiscal year, which does not start on the first day of the month, you need to edit the dates in the Fiscal Calendar form after you create the company profile.

**Quarter with 4 Periods.** If you use a 13-period ledger, select the quarter that contains four fiscal periods, rather than three. Note that you can change this quarter later, although if you do, your previously printed reports may not be consistent with data printed after the change.

**Locked Fiscal Period.** Select None, Warning, or Error from the list. If you select Error, subledgers and Bank Services prohibit transactions from being entered or posted to a period that is locked.

**Warning Date Range.** If you want to be warned when you enter a date for a transaction that is more than a specified number of days before or after the session date, type the number of days. If you want to be warned less often, type a large number (up to three characters).

**Inactive G/L Account.** Select None, Warning, or Error from the list. If you select Error, subledgers and Bank Services prohibit entries to a General Ledger account that has been flagged as Inactive.

**Non-existent G/L Account.** Select None, Warning, or Error from the list. If you select Error, subledgers and Bank Services prohibit entries to an account number that does not exist.
**Value Added Tax**

**Location Type and Location Code.** This information is used in countries, such as the United Kingdom, where a Value Added Tax (VAT) is calculated and reported. If your company reports VAT, type a six-character code for location type and up to 30 characters for the location code.

**Country Code and Branch.** You can type six-character codes for country and branch.

**Multicurrency.** Select this option if you will enter, retrieve, import, post, and report transactions in more than one currency.

*Note:* If you don’t select the multicurrency option during Common Services activation, you can select it later. However, once you select the multicurrency option and save the company profile you cannot change the option.

**Functional Currency.** Whether you use multicurrency or not, you must enter a functional currency.

To select from the list of supplied codes, click the Finder beside the Functional Currency field, then double-click the code for your currency.

If your company maintains its books in the currency of a participating country of the European Monetary Union (EMU), you must select EUR as your functional currency code.

If the code for your functional currency is not in the list, click the New icon beside the Finder, and then enter the international code for your currency.

*Note:* You cannot change the functional currency code after you save the company profile.

3. If you selected the Multicurrency option, fill in the following fields that appear on the Options tab:

**Default Rate Type.** If you use multicurrency accounting, you must select one of the rate types supplied with Sage ERP Accpac, or add a new one.

To view a list of defined rate types, click the Finder beside the Default Rate Type field, then double-click a rate type from the list.

**Gain/Loss Accounting Method.** When you select the Multicurrency option, you must also choose a currency translation method.

- **Realized and Unrealized Gain/Loss.** Exchange gains and losses resulting from fluctuating exchange rates are unrealized until transactions are settled. Outstanding balances in foreign currencies must be revalued at each balance sheet date at current rates. The
resulting gains and losses are considered temporary, so they are not included in net income. Unrealized gains and losses are reversed in the next period.

Or

- **Recognized Gain/Loss.** Exchange gains and losses are recognized when foreign currency monetary items are revalued or settled. These gains and losses are taken into income and appear on income statements for the current period.

**Euro option**

**Euro.** Select the Euro option if your functional currency is the euro, but your company wants to produce reports in the national currency of a member country of the EMU.

**Reporting currency**

**Reporting Currency.** If you selected the Euro option, you must enter a currency code in this field. Reports will print in both the reporting currency and the euro.

4. When you are satisfied with the company profile information, click OK.

Sage ERP Accpac places icons for Administrative Services and Common Services on the company desktop.

5. If you have not registered System Manager, the Unregistered Applications warning appears.

   a. Click OK to close the warning message.
      The Licenses form appears.

   b. Click the License Manager button, and then enter the required serial numbers and activation codes on the licenses tab of the License Manager form.

      If you don’t have activation codes for the unregistered programs, click OK, and use the temporary licenses for the 30-day grace period.

You can now activate your accounting applications, following the instructions in the next sections.

**Activating Your Data**

**To activate Sage ERP Accpac applications:**

1. In the Administrative Services folder, double-click the Data Activation icon.
2. When asked whether you are ready to proceed with activation, click Yes.

The following Data Activation form appears, listing applications that you can activate.

3. Select the check box beside each application for which you want to activate data.

The activation program automatically selects any applications that must be activated first, and then checks your data to ensure that it can activate them.

Most Sage ERP Accpac applications are interdependent. If you clear the selection for an application that others require, the activation program also clears the selection for the dependent applications. For example, if you clear the selection for Accounts Payable, but Purchase Orders and Project and Job Costing are selected, the program also
clears the selections for Purchase Orders and Project and Job Costing. (See “Step 1: Install Sage ERP Accpac Programs” for information about dependencies.)

**Note:** Sage ERP Accpac Options products are not part of the multi-application data activation. If you select Uni Sales Analysis, Ops Inquiry, or a number change program, you are prompted to activate that program immediately.

4. If the program displays a message saying that you cannot activate an application at this time:
   a. Close the Data Activation form.
   b. Correct the problems described in the error message.
   c. Reopen the Data Activation form, and continue the process.

5. When you have finished selecting applications and entering required information, click the Activate button.

The following form appears, showing the settings that will be used for any options that are required to activate a program:

![Data Activation Form](image)

**If you want to change any of the settings,** double-click in the Value column for the program, and enter the correct value.

**If you are unsure about a setting, and prefer not to activate the program at this time:**
   a. Click the Previous button.
   b. Clear the check box for the program on the previous screen.
   c. Click Next when you are ready to proceed.
6. To continue with the activation process, click Next.

The following form appears, showing you the status of the applications you selected for activation:

![Data Activation Form]

7. Click Activate.

Depending on the number of applications you are activating, the process can take several minutes. The program displays a progress bar indicating the stage of completion, and updates the status of each activated program on the Data Activation form.

8. When Activation has finished, click Close.

---

**Change the Administrator’s Password**

Sage ERP Accpac ships with a default password for the ADMIN user, allowing you to install and activate programs, and set up your databases.

Once you finish activating Sage ERP Accpac programs, we recommend that you change the password for the ADMIN user to prevent unauthorized access to your company data.

To restrict user access by password, you must first select the option to Enable Security for the system database, if you have not already done so.

1. On the Windows Start menu, select All Programs > Sage ERP Accpac > Database Setup.
2. In the Sign-On form that appears, type **ADMIN** for the password, and then click OK.

   The Database Setup form appears:
3. In the Database Setup form, select the system database, and then click Edit to display the Database Profile.

4. Select Enable Application Security, and then click OK.

5. Click Exit to close Database Setup.

**Change the ADMIN Password**

You can change the ADMIN password from the Open Company dialog box by entering the ADMIN user ID, then clicking the Change Password button. (The button is available only if your system database uses security.)

You can also change the password in the ADMIN user’s record, once you open the company:

1. From the Administrative Services folder, click the Users icon.
2. Type the new password in the Password field, and then type it again in the Verify field.

3. Click Save, and then click Close.

**Where To Now?**

You can now:

- Configure the Sage ERP Accpac Portal.
  
  For information on configuring the portal, see Chapter 5, “Configuring the Sage ERP Accpac Portal.”

- Add users and set up security groups.
  
  For information on adding users and setting up security groups, see Chapter 6, “Performing Administrative Tasks.”

- Set up accounting applications for your company.
  
  For guidance, refer to the help when setting up each application.
Chapter 5
Configuring the Sage ERP Accpac Portal

The Sage ERP Accpac Portal was designed to make Sage ERP Accpac easy to learn and to use.

It includes enhanced inquiry features, “snapshots” that present your General Ledger, Accounts Payable, and Accounts Receivable data graphically, and convenient shortcuts to the tasks and reports that you use most often. Individual users can customize all these features according to their own needs and preferences.

This chapter provides an overview of Sage ERP Accpac Portal installation and configuration. It also provides steps for:

- Configuring the Sage ERP Accpac Portal to establish a connection to the portal database.
- Adjusting certain settings configured during installation.
- Troubleshooting problems that might occur with the Portal.

Overview

Before you can use the Sage ERP Accpac Portal, you must:

1. Install the current version of Sage ERP Accpac, including the portal components. (The Portal option is selected as a default during Sage ERP Accpac program installation.)

   Chapter 2, “Installing Sage ERP Accpac Programs,” describes the installation process.

2. Run Workstation Setup on each workstation that will use the Sage ERP Accpac portal, if:

   - The workstation will run accounting modules or System Manager through the portal.

   And

   - Sage ERP Accpac is not fully installed on the workstation.

   (Workstation Setup installs components that a workstation requires to run Sage ERP Accpac on a server.)
3. Activate your company data for the Sage ERP Accpac programs you use.

4. Create a portal database using database software that is supported by the Portal. Normally, you create this database on the same server as your Sage ERP Accpac data.

The portal database stores files used by the Sage ERP Accpac Portal, including user preferences and passwords, snapshot configurations, and other files that determine how the Portal looks and functions.

Chapter 3, “Database Setup,” explains how to create a database using Pervasive PSQL and Microsoft SQL software.

If you create the portal database using SQL Server Express, you will need to configure a TCP/IP connection manually in that program. For more information, see, “Configuring a SQL Server Express Database for the Portal,” later in this chapter.

5. Configure the Sage ERP Accpac Portal, as described in this chapter.

**Configuring Portal Security**

This section outlines some security precautions you should take if you are setting up the portal to be accessible from the Internet.

**IMPORTANT**

This section is not a comprehensive discussion of security. Make sure you also consult any documentation you have regarding security for your specific system (in particular, the documentation for your version of IIS). However, as a minimum, you should take the following security precautions:

**IIS:**

- Configure the portal to use HTTPS:
  
  a. Purchase an SSL certificate from a reputable supplier.
  
  b. Turn on HTTPS by adding an HTTPS binding (in the binding you will specify your SSL certificate).
  
  c. Turn off HTTP by selecting the Require SSL option.

  **Note:** When you turn on HTTPS, all URLs for the portal are changed to begin with https instead of http. This invalidates any existing links to the portal.

- Disable Directory Browsing for all virtual directories.
- Remove any HTTP Response Headers.
• Make sure the /SDataServlet virtual directory is configured to return detailed errors.

**Note:** This setting is configured automatically during installation of Sage ERP Accpac, and the software will not work if it is changed.

**Other:**

• Secure Sage ERP Accpac databases.
• Secure shared folders.
• Run Windows Update.
• Turn off services you don’t need.
• Use a firewall.

If you have any concerns about security, contact your Sage business partner.

### Configuring the Portal Database

**You must create a portal database, first**

Before you can configure the portal for your Sage ERP Accpac installation, you must create a database for the Sage ERP Accpac portal using your database software. (See Chapter 3, “Database Setup,” for information on creating databases.)

Then, you must configure the Portal to establish a connection to the portal database.

**Note:** The portal database is shared by all companies in a Sage ERP Accpac installation, so you need to configure only one Sage ERP Accpac Portal.

#### To configure the Portal:

1. From Windows’ Start menu, select **All Programs** > **Sage ERP Accpac** > **Database Setup**.
2. On the Sign-On form that appears, enter the ADMIN password.
3. On the Database Setup form that appears, click the **Portal** button to open the Configure Portal form.
4. On the Configure Portal form, enter the following information:
   
   • **Database Format.** Select the database engine you used to create your portal database.
Configuring the Portal Database

- **Server Name.** The program automatically displays “localhost” to use the current machine. If you created your portal database on a different (remote) machine, enter the name of that machine, instead.

  Note: If multiple instances of Microsoft SQL Server are installed on the same machine, do not include the instance name. The program uses the unique server port number to determine the instance.

- **Server Port.** Enter the TCP/IP port number specified in your database software for your portal database.

  For Microsoft SQL Server, the default port number is 1433.

  For Pervasive PSQL, the default port number is 1583.

- **Database ID.** Enter the name specified for the portal database in your database software.

- **Login ID and Password.** Enter the ID and password specified for your database administrator in your database software. (They are not the credentials for the Sage ERP Accpac ADMIN User.)

  Note: For a Microsoft SQL Database, you must supply credentials for SQL authentication. The portal does not support Windows authentication.

5. Click OK, and then click Exit to close the Database Setup form.

6. If you are configuring the portal for Windows XP, restart the computer so that the changed environment variables take effect. (If you do not restart your computer, you will receive an error message when you try to open the portal.)

   For other operating systems, you can skip this step.

The program saves the portal configuration to a file named dbConnection.xml, located in the following folder under Program Files:

   Common Files\Sage\Sage ERP Accpac\Tomcat6\portal\swtServices.

   If you set up the portal database using SQL Server Express, follow the steps in the next section, “Using SQL Express for the Portal Database.”

**Configuring a Microsoft SQL Server Express Database**

The following instructions apply only to Microsoft SQL Server Express.
In SQL Server Express, the default TCP/IP connections settings are disabled. Because the portal requires a TCP/IP connection, you must set one up manually, as follows:

1. Launch the SQL Server Configuration Manager.
2. Under the SQL Server Network Configuration tree, click Protocols For SQLEXPRESS.
3. Enable the TCP/IP protocol. (The default setting is Disabled.)
4. Right-click the TCP/IP protocol, and then click Properties.
5. On the IP Addresses tab, in the IPAll Section:
   d. Clear the TCP Dynamic Ports field.
   e. Set the TCP Port to 1433.
6. Restart the SQL Server.

**Testing the TCP/IP Connection**

To test that TCP/IP works, from the command line, type:

telnet localhost 1433

The screen should clear, and you will be in a Telnet session with the SQL Server. If an error occurs, you have not set up the TCP/IP connection correctly.

**Configuring English Windows to Display Chinese**

If you work with Chinese language packs and the portal machine uses English Windows, you must configure Windows to display Chinese properly.

If the portal uses a Pervasive PSQL database

If the portal database is a Pervasive PSQL database, you must configure Windows to display Chinese properly before you open the Sage ERP Accpac Portal.

If the portal uses a Microsoft SQL or SQL Express database

If the portal database is a Microsoft SQL database, we recommend that you configure Windows before you open the Sage ERP Accpac Portal, although you can change this configuration at any time.

**Configuring English Windows Vista or English Windows 7**

To configure English Windows Vista or English Windows 7 to display Chinese:
1. On the machine where the Sage ERP Accpac Portal is installed, click **Start > Search Programs** And Files, and then type **intl.cpl**.

2. On the Regional And Language screen, select the **Formats** tab.

3. For the Format option, select **Chinese (Simplified, PRC)**, if it is not already selected, and then click **Apply**.

   Alternatively, you can select **Chinese (Traditional, Taiwan)** or **Chinese (Traditional, Hong Kong S.A.R.)** for Traditional Chinese.

4. Click the **Administrative** tab, and then:

   a. Click **Copy Settings**.

   b. For the Copy Your Current Settings To option, select **Welcome Screen And System Accounts**.

   c. Click **OK**.

   d. Click **Change system locale**.

   e. For the current system locale, select **Chinese (Simplified, PRC)**, if it is not already selected.

   f. Click **OK**.

5. When prompted to restart the machine, click **Restart now**.

**Configuring English Windows XP**

To configure English Windows XP to display Chinese:

1. On the machine where the Sage ERP Accpac Portal is installed, click **Start > Run**, and then type **intl.cpl**.

   The Regional And Language Options screen appears.

2. On the Regional Options tab, select **Chinese (PRC)**, if it is not already selected as the format, and then click **Apply**.

   Alternatively, you can select **Chinese (Taiwan)** or **Chinese (Hong Kong S.A.R.)** for Traditional Chinese.

3. Click the **Advanced** tab, and then:

   a. For the default user account option, select **Apply all settings to the current user account and to the default user profile**.

   b. When prompted, click **OK**.

   c. Select **Chinese (PRC)** as the language to match the language version of your non-Unicode programs, if it is not already selected.
d. Click **OK**.

e. When prompted, click **Yes**.

4. Restart the machine.

---

**Starting the Sage ERP Accpac Portal**

Once you have configured the Sage ERP Accpac Portal as described in this chapter, users can open the Sage ERP Accpac Portal from the Windows Start menu by clicking **All Programs > Sage Accpac > Portal**.

If you work with Chinese language packs, your Sage ERP Accpac Portal database is a Pervasive PSQL database, and the portal machine uses English Windows, remember to configure Windows to display Chinese properly before you open the Sage ERP Accpac Portal.

---

**Troubleshooting the Sage ERP Accpac Portal**

The Sage ERP Accpac installation program installs components that support the Sage ERP Accpac Portal, and it sets properties that the Portal requires in Internet Information Services (IIS). You shouldn’t have to change them.

The information and tips in this section are provided in case you have problems with IIS after installation.

---

**Components that Support the Sage ERP Accpac Portal**

The Sage ERP Accpac installation program saves several Portal components on the web server:

- **Portal components are saved to the WebUIs subfolder of the Sage Accpac program folder.** These files support the Portal interface, and include HTML, Javascript, CSS, and PNG files.

- The program installs the Java Runtime Environment, if it is not already installed.

- **Sage Accpac Tomcat 6 is saved to the Common Files\Sage\Sage Accpac\Tomcat6 subfolder in the Program Files folder.** The Tomcat program is installed as a private instance for Sage Accpac, only, and runs as a Windows service as Sage Accpac Tomcat 6. It can co-exist with other Tomcat instances on the same server.

- **Apache Tomcat Connector.**
This component is saved to the Jakarta subfolder under Common Files\Sage\Sage Accpac\Tomcat6.

Internet Information Services (IIS) Components

**IIS configuration**

The installation program creates an application pool for Sage Accpac in IIS, and sets up the following applications:

- **SageERPAccpac.** The directory is the WebUIs subfolder in the Sage Accpac program folder.

- **SDataServlet.** The directory is the Jakarta subfolder in the Common Files\Sage\Sage Accpac\Tomcat6 program folder.

How these applications are configured in IIS depends on the version of Windows you are using.

**Configuring IIS 7 for Windows 7, Windows Vista, or Windows 2008**

These instructions assume you need to create the Sage Accpac application pool and the SageERPAccpac and SDataServlet applications. If these components already exist in IIS, check to ensure that the configuration settings are correct.

1. From Windows Control Panel’s Administrative Tools, start Internet Information Services (IIS) Manager.

   a. In the Name field, enter **Sage Accpac App Pool**.
   b. Click **OK**.

3. Select Application Pools > Sage Accpac App Pool, and then on the Actions panel, under Edit Application Pool, click **Advanced Settings**.
   a. If you have a 64-bit operating system, set Enable 32-Bit Applications to **True**.
   b. Under Process Model, for the Identity, select **LocalSystem**, and then click **OK**.
   c. Click **OK** to close the Advanced Settings form.

4. In the Connections panel, select the current server, and then double-click the ISAPI & CGI Restrictions icon.
   a. Under Actions, click **Add**, and then on the form that appears:
i. For the ISAP Or CGI Path, enter:

   <Program Files>\Common Files\Sage\Sage Accpac\Tomcat6\Jakarta\isapi_redirect.dll

ii. For the Name, type Sage Accpac.

iii. Select the option Allow Extension Path To Execute.

iv. Click OK.

5. On the Connections panel, expand the server name and the Sites folder.

6. Select Default Web Site, and then click View Applications.

7. Click Add Application, and then on the form that appears:

   a. For the Alias, type SDataServlet.

   b. Set the application pool to Sage Accpac App Pool, and then click OK to return to the Add Application form.

   c. Set the physical path to the Apache Tomcat Connector, located at:

   <Program Files>\Common Files\Sage\Sage Accpac\Tomcat6\Jakarta.

   d. Click OK.

8. On the Connections panel, right-click Default Web Site, and then click Add Application. In the form that appears:

   a. For the Alias, type SageERPAccpac.

   b. Set the application pool to Sage Accpac App Pool, and then click OK to return to the Add Application form.

   c. Set the physical path to the webuis subfolder in your Sage Accpac program folder.

   d. Click OK.

9. On the Connections panel, select the Default Web Site, and then double-click the ISAPI Filters icon.

   a. On the Actions panel, click Add.

   b. For the filter name, type SageAccpacUrlRedirector.

   c. In the Executable field, select isapi_redirect.dll from the Common Files\Sage\Sage Accpac\Tomcat6\Jakarta folder.

   d. Click OK.
10. Restart IIS:
   a. On the Connections Panel, select the server.
   b. On the Actions panel, click Restart.

**Configuring IIS 6 for Windows 2003**

1. From Windows Control Panel’s Administrative Tools, start Internet Information Services (IIS).

   **Create the application pool**

2. On the left panel, under the local server, right-click Application Pools, and then select New > Application Pool.
   a. On the form that appears, type Sage Accpac App Pool for the Application Pool ID.
   b. Click OK.

   **Set properties**

3. Right-click Sage Accpac App Pool, and then select Properties.
   b. Under Application Pool Identity, select Predefined, and then select LocalSystem from the list.
   c. Click Apply.
      If a message appears asking you to confirm your choice, click Yes.

   **Add the SageERPAccpac application**

4. Under Web Sites, right-click Default Web Site, and then click New > Virtual Directory.
   a. In the Virtual Directory Creation Wizard, click Next.
   b. In the Alias field, type SageERPAccpac, and then click Next.
   c. In the Directory field, browse to the WebUIs subfolder in your Sage Accpac program folder, and then click Next.
   d. On the Access Permission screen, select Read and Run Scripts, if these options are not selected.
   e. Click Next, and then click Finish.

   **Set properties for SageERPAccpac**

5. Right-click the SageERPAccpac virtual directory, and then select Properties.
   a. Select the Virtual Directory tab.
   b. In the Application Pool field, select Sage Accpac App Pool.
6. Under Web Sites, right-click **Default Web Site**, and then click **New > Virtual Directory**.
   a. In the Virtual Directory Creation Wizard, click **Next**.
   b. In the Alias field, type **SDataServlet**, and then click **Next**.
   c. In the Directory field, enter the following path:
      
      ```
      Common Files/Sage/Sage Accpac/Tomcat6/Jakarta
      ```
   d. Click **Next**.
   e. On the Access Permission screen, select the **Read**, **Execute**, and **Run** options, if they are not selected.
   f. Click **Next**, and then click **Finish**.

7. Right-click the **SDataServlet** virtual directory, and then select **Properties**.
   a. Select the **Virtual Directory** tab.
   b. In the Application Pool field, select **Sage Accpac App Pool**.

8. Right-click **Web Service Extensions**, and then click **Add A New Web Service Extension**.
   a. On the form that appears, in the Extension Name field, enter **Sage Accpac**.
   b. Under Required Files, click **Add**, and then browse to:
      
      ```
      Common Files/Sage/Sage Accpac/Tomcat6/Jakarta/isapi_redirector.dll
      ```
   c. Select the option **Set Extension Status To Allow**.
   d. Click **OK**.

9. Right-click **Web Sites**, and then select **Properties**.
   a. On the **ISAPI Filters** tab, click **Add**.
   b. In the **Filter Name** field, type **Sage Accpac**.
   c. In the **Executable** field, browse to Common Files/Sage/Sage Accpac/Tomcat6/Jakarta/isapi_redirector.dll.
   d. Click **OK**.

10. To restart IIS, right-click the server name, and then select **All Tasks > Restart IIS**.
Restarting IIS

Clicking Stop and Start IIS in Administrative Tools’ Internet Information Services form does not restart IIS properly.

To restart IIS properly:

1. In Windows Control Panel, click Administrative Tools > Services.
2. Right-click your IIS Service (for example, IIS Admin), and then click Stop on the menu that appears.
3. Once the service has stopped, right-click, and then click Start.

Starting Sage ERP Accpac’s Tomcat

1. In Windows Control Panel, click Administrative Tools > Services.
2. Right-click the Sage Accpac Tomcat 6 service, and then click Start.

Note: The Startup type should be set to Automatic, so that Tomcat starts whenever the computer is restarted.

Sage Accpac Tomcat Doesn’t Start on a 64-Bit Machine

Note that you must have the 32-bit Java Runtime Environment installed. (The 64-bit version will not work.)

Sage Accpac Tomcat Doesn’t Start on a 32-Bit Machine

If Tomcat doesn’t start after upgrading the Java Runtime Environment, uninstall Java Runtime Environment, and reinstall the latest version.

The Portal Doesn’t Open for Windows XP

If you are running Windows XP, you will receive an error message when you try to start the portal if you did not restart your computer after configuring the portal.

You must restart your computer after configuring the portal for the changed environment variables to take effect.

Shortcuts in the Portal Don’t Work

The shortcuts to Sage ERP Accpac tasks require Sage ERP Accpac to be installed on local workstations.
You must run Workstation Setup on each machine that requires access to Sage ERP Accpac transaction-entry forms, setup records, and report forms.

**Unable to Start the Web Site**

If you receive the error, “The process cannot access the file because it is being used by another process” when trying to start the web site in IIS, it might be because another process is using port 80.

One process that might be using port 80 is Skype. If this is the case, you can re-configure Skype so that it will not use port 80 as its default, as follows:

1. In Skype, select **Tools > Options**.
2. On the left-hand panel, click **Advanced**.
3. Click Connection.
4. Clear the option **Use Port 80 And 443 As Alternatives For Incoming Connections**.
5. Click **Save**.

**Unable to Export Queries or Snapshots**

When exporting a query or a snapshot report, Internet Explorer may display a message saying it has blocked the portal from downloading files to your computer. If you click the message, as the message suggests, the portal will sign you out. If this situation occurs, you need to add the portal web server to your Local Intranet zone or Trusted Sites, as follows:

1. In Windows' Control Panel, open **Internet Properties**.
2. On the Security tab, select **Local Intranet** zone or the **Trusted Sites** zone, and then click the **Sites** button.
3. If you selected the Local Intranet zone, click the **Advanced** button on the next screen that appears.
4. In the **Add this Website to the Zone** field, type name of your portal server, and then click **Add**.
5. On the Security tab, click the **Custom Level** button.
6. Under Automatic Prompting For File Downloads, select **Enable**, and then click **OK**.
7. Click **OK** to close the Internet Properties form.
Company List Failure Error

When launching the Sage ERP Accpac portal, if the Sign In form appears, but you receive a Company List Failure error, check the following:

- Is the Java Runtime Environment installed on the machine?
- Is Java 1.6.0, or higher, installed?
- Has the isapi_redirect.properties file been updated correctly?
- Has the Jakarta virtual folder been created?
- Is the isapi dll set up correctly? Does it have execute and write permissions?
Chapter 6
Performing Administrative Tasks

The procedures in this chapter are relevant to all Sage ERP Accpac configurations.

Perform these procedures at any time after you have installed Sage ERP Accpac programs. Sign on as the ADMIN user at any server or workstation that runs Sage ERP Accpac.

This chapter describes how to:

- Create user records
- Set up optional security groups
- Assign user authorizations

Add Users

For each user, assign an ID and set up individual security options.

1. In the Administrative Services folder, double-click the Users icon.

2. In the User ID field, use up to eight characters to type a unique code to identify this user (letters from A to Z and digits from 0 to 9). The ID must start with a letter, not a number.

   New button If the ID field is not blank, click the New button to start a new record.

   When security is turned on for the system database, the User ID determines user’s access rights in Sage ERP Accpac.

3. In the User Name field, type a name for this user.

4. In the Account Type field, select User or Timecard.

   Note: If you select Timecard, you must create a security group for employees who only enter timecards, later.

5. Select the language in which to display and print this user’s messages, Help, reports, and forms.

6. In the Authentication Method field, select one of the following options that determines how this user will sign on to Sage ERP Accpac:
Sage ERP Accpac — allows the user to sign on using only their Sage ERP Accpac User ID.

Windows — allows the user to sign on using their Windows User ID.

Both — allows the user to sign on using either their Windows User ID or their Sage ERP Accpac User ID.

7. If you chose Windows or Both as the authentication method, enter a Windows Domain name and the Windows User Name for this user in the fields provided.

You can click the Browse button to select from a list of Windows users and domains.

If you selected Sage ERP Accpac as the authentication method, these fields are not available.

8. If you chose Sage ERP Accpac or Both as the authentication method, type a password in the Password field, and then type it again in the Verify field.

The password can use between 4 and 64 characters (letters from A to Z and digits from 0 to 9), but it must start with a letter.

When you type a password, Sage ERP Accpac displays asterisks. You must enter a password in each user record. However, if security is not turned on for the system database that the company uses, users are not asked for the password when they start Sage ERP Accpac.

Note: Users must use a password to open Sage ERP Accpac using their browsers.

9. Assign additional security to the password, selecting from the following options:

User Must Change Password At Next Logon — forces the user to change their password the next time they sign on to Sage ERP Accpac. This option is not available if you selected Windows as the authentication method.

User Cannot Change Password — prevents a user from changing their password. This option is not available if you selected Windows as the authentication method.

Password Never Expires — allows the same password to be used without requiring a change. This option is not available if you selected Windows as the authentication method.

Account Is Disabled — prevents a user from signing on to Sage ERP Accpac.
**Account Is Restricted** — restricts the user to signing on to Sage ERP Accpac only during the valid times that you specify.

**Account Is Locked Out** — locks out the user after they exceed the maximum number of attempts specified in the advanced security settings for the system database. The system assigns this status, and, depending on the security settings, can clear this status after a certain period. The ADMIN user can also clear this status.

This option is not available if you selected Windows as the authentication method.

10. If you selected the option to restrict the user’s account, in the Valid Times section, specify the days of the week and the hours that the user can sign on to Sage ERP Accpac.

11. Click Add to save each new user record.

**Using Windows as the Authentication Method**

If you select Windows as the authentication method for a user, the user must sign on to Sage ERP Accpac with a valid Windows user ID.

Normally, when a user signs on to Windows with their user name, domain, and password, the server uses this information to authenticate the user. If the user then signs on to Sage ERP Accpac with the same ID and domain, they do not need to provide a password.

**Note:** The administrator must first map the Windows password to the Sage ERP Accpac user ID. (See Windows’ documentation for instructions.)

The following fields are not available in the User record when you select Windows as the authentication method:

- Password and Verify
- User Must Change Password At Next Logon
- Password Never Expires
- User Cannot Change Password

If you are changing the authentication method for an existing user, any previously assigned passwords are cleared, and therefore no longer valid.
Signing On to Sage ERP Accpac with Windows Authentication

To allow Windows authentication, the Open Company dialog box includes:

- A Windows Authentication check box.
- A field for the Windows Domain name. (This field appears only if the particular user’s record specifies Windows authentication.)

If the Sage ERP Accpac authentication method is assigned to all users, the Open Company dialog box displays the Windows Authentication check box, but it is not available to any users, including the ADMIN user, from the Sage ERP Accpac desktop. (On the Sage ERP Accpac Web desktop, this option is always available.)

If the Windows or the Both authentication methods are assigned to any user, the Windows Authentication option is available, but not selected, for all users, as shown here:

When a user selects the Windows Authentication option, the Domain field appears, as follows:

By default, the Domain and User ID fields display the domain and user ID for the currently logged-in Windows user, if their Sage ERP Accpac User ID has been mapped to a Windows user account.

The Password field and the Change Password button are always disabled for Windows Authentication.
Signing On to Sage ERP Accpac if “Both” is the Authentication Method

The Both authentication setting allows a user to sign on to Sage ERP Accpac using either their Sage ERP Accpac ID and password or their Windows User ID.

Set Up Security Groups and Assign User Authorizations

If the Security option is selected for a system database, access to Sage ERP Accpac is restricted by password for all companies that share the system database.

If security is turned on, or if some users have a Timecard account, users require authorization to perform tasks in each Sage ERP Accpac program. You provide this authorization by assigning users to security groups.

When you create security groups, you specify the tasks that each group can perform. All companies using the same system database share security groups.

Create Security Groups

You create security groups, as follows:

1. In the Administrative Services folder, double-click the Security Groups icon.

2. Select an application from the Application list.

3. Enter a unique group ID and a description.

   The group ID can be up to eight characters (letters from A to Z and digits from 0 to 9).

4. Select the tasks the security group can perform.
Set Up Security Groups and Assign User Authorizations

- To select every task in the list, click Select All.
- To remove a task that has already been selected, click the check box to clear it.
- To remove all tasks, click the Remove All button.

5. Click Add.

6. Repeat these steps for each application.

Now, you can users to these security groups, as described in the next section.

Authorizing Users

You assign each user to one security group for each application. All users in the same group can perform the tasks defined for the group. The same user can be assigned to different groups within the same company.

To assign user authorizations:

1. In the Administrative Services folder, double-click the User Authorizations icon.

The User Authorizations dialog box appears:

2. Select the User ID.

   If a security group has been assigned to this user, it appears next to the Application name, in the Group ID column.

3. For each application to which you want to allow access for this user:
   a. Double-click the Group ID field to display a Finder button.
   b. Click the button to display security groups defined for the application.
   c. Select a security group from the list.
Create and Assign UI Profiles for Customized User Interface Forms

If your users do not need to use all fields in dialog boxes and forms, you can customize their user interfaces, hiding some fields.

To create a UI Profile ID:
1. Determine the fields a user will not need when using certain forms and dialog boxes.
2. Open Sage ERP Accpac as the ADMIN user.
3. Create your User IDs. (See previous sections for the steps.)
4. Open the form that you are customizing for a user. (In our following examples, we chose Currency Codes.)
5. Choose Customize from the File menu.

The Customize form for Currency Codes looks like this:

Field controls that can be hidden

The Customize screen displays a list of the controls that can be hidden for the dialog box or form that you started from (for our example, the Currency Codes dialog box). To hide some of these controls for users, you must either select an existing profile or create a new one. In the following steps, we explain how to create a new profile.

6. Click the New button beside the Working Profile field.
7. Enter a unique ID, using up to 20 characters, in the Profile ID field (for example, CURRCODE), and a description in the Profile Description field, then click Add, then click Close to return to the Customize form.

The Customize form will now look like this:

Because we have just created the first Working Profile, it is selected in the Working Profile field. We must now clear the controls that we do not want the user to see in the Currency Codes dialog box.

8. Click checkmarks beside the controls for the fields to hide. The checkmarks disappear, as shown next:
The field will be hidden when users assigned to the CURRCODE Working Profile open the Currency Codes dialog box.

9. Click Save, then click OK to return to the dialog box you customized. (In our example, we return to Currency Codes.)

10. Click Close in the dialog box.

After creating a UI Profile ID, you assign users to it. You can create as many Profiles as you need, and assign each user to a different Profile. You can assign more than one user to each Profile ID.

**To assign Users to Profile IDs:**

1. Double-click the Assign UI Profiles icon in the Administrative Services folder.

   If you have not assigned any UI Profiles to users, the Assign UI Profiles form has no entries in the grid, as shown below:

   ![Assign UI Profiles form](image1)

2. Click the Finder in the User ID column, highlight a User ID from the list, and click Select.

   ![Finder in User ID column](image2)

   The Assign UI Profile form reappears, with the selected User ID displayed in the User ID column.
3. Click the Finder in the Profile ID column to choose a Profile from the list.

Our sample Assign UI Profiles form now displays the following:

Each time you open the Assign UI Profiles screen, the grid displays all User IDs and Profile IDs previously assigned.

4. Click Close to return to the Sage ERP Accpac desktop.

The next time the selected user opens the form that has been restricted, the fields hidden in the Working Profile will not appear.

**Set Up Customization Directories**

If a user or group needs to print customized Sage ERP Accpac reports, you should set up customization directories to store the customized reports.

Note that:

- Only the ADMIN user can create customization directories.
- Crystal Reports is required to customize or create new reports.
Remove Sage ERP Accpac Programs

To remove all Sage ERP Accpac programs, use Windows’ Control Panel, as follows:

- **If you are using Windows XP**, open Add Or Remove Programs, select Sage Accpac X.xA (where X.xA refers to the version), and then click Remove. At the message asking whether to remove the program completely, click Yes.

- **If you are using Windows Vista or Windows 7**, from Programs And Features, open Uninstall Or Change A Program, and then double-click Sage Accpac X.xA.

To remove individual Sage Accpac programs, use Windows’ Control Panel, as follows:

- **If you are using Windows XP**, open Add Or Remove Programs, select Sage Accpac X.xA, and then click Change. Click Modify, and then use the Select Features screen to select the programs you want to install and clear the selections for programs you want to remove.

- **If you are using Windows Vista or Windows 7**, from Programs And Features, open Uninstall Or Change A Program. Click Sage Accpac X.xA, and then click Change. (Do not double-click Sage Accpac X.xA.) Click Modify, and then use the Select Features screen to select the programs you want to install and clear the selections for programs you want to remove.
Chapter 7
Licensing Sage ERP Accpac

This chapter describes Sage ERP Accpac licensing in general, and it explains how to:

- View or update license information for your Sage ERP Accpac installation.
- Enter activation codes for installed Sage ERP Accpac accounting programs.
- Enter activation codes for user LanPaks and for Sage ERP Accpac Intelligence Report Manager and Report Viewer.

Licensing Products and Users

Each Sage ERP Accpac product license allows a company to use a particular version of a Sage ERP Accpac program. You require a new license whenever you install a new Sage ERP Accpac program or upgrade to a new version.

During installation, the program creates temporary license files (with serial number “000000000000”) for Sage ERP Accpac programs. These temporary licenses let you use Sage ERP Accpac for 30 days, while you wait for activation codes from Sage.

Until you enter activation codes, whenever you sign on to your company database, Sage ERP Accpac reminds you to register the programs, as follows:

Once you receive valid serial numbers and activation codes, you enter them in the License Manager to make the licenses permanent.
You require a LanPak license to use Sage ERP Accpac. Installation does not generate temporary LanPak licenses, however.

LanPak is Sage ERP Accpac's user licensing system. Without a LanPak license, no one — including the ADMIN user — can sign on to a company.

Normally, you enter the activation code for your LanPak license as part of program installation. (When the installation program finishes, it displays the License Manager, where you enter the activation code for your LanPak on the Users tab.)

**Note:** You register a license for a particular company in combination with a product serial number. If your company changes its name (for example, after a merger), you need to update the licenses for all your Sage ERP Accpac products.

After you change the company name in the License Manager, the activation code will be marked Unauthorized. The license will remain valid, but you should apply for another activation code for the new company name.

The following sections describe LanPak licenses in more detail, and explain how to create a temporary LanPak license if you did not enter an activation code for a LanPak when you installed Sage ERP Accpac.

### LanPak Licenses

A LanPak license regulates how many users can work with a particular version of Sage ERP Accpac. The number of LanPak licenses you require depends on the number of workstations on which you install Sage ERP Accpac and the number of users who will access company databases on those workstations.

- To use Sage ERP Accpac on a single computer, you must register a 1-user LanPak. (With this type of LanPak, you cannot work with two Sage ERP Accpac databases at the same time.)

- To add Sage ERP Accpac users to a network, you register multi-user LanPaks. You can obtain LanPak licenses for any number of users on a network.

**Note:** To open Sage ERP Accpac through a browser, each user requires a LanPak for each company database they sign on to.

### Creating a Temporary LanPak License

Before you can begin using Sage ERP Accpac, you must register a LanPak license for a specific number of users.
If you have not registered a LanPak license, you see the following message when you run Sage ERP Accpac and try to open the company database:

![Warning message]

Click OK to close the message. The Licenses form appears, as follows:

![Licenses form]

You must add a temporary LanPak license for the number of users that require concurrent access to your company database.

**To add a temporary LanPak license:**

1. In the Licenses form, click License Manager.

2. Click the Users tab, and then click in the blank space to create a new line. (If there are existing lines, right-click in the blank space, and then click Insert.)

The Users tab should now appear as follows:

![Users tab]
3. In the new line:
   a. Click the License Type column, and then select LanPak from the list that appears. (Do not select a database-specific LanPak option.)
   b. Click the Count column, and then select the number of users that require concurrent access to Sage ERP Accpac from the list.

The columns in the following screen have been resized to show all the information:

![License Information Table]

4. Click Close, and then click OK.

You can now open the company.

**Requesting Activation Codes**

You need activation codes to use Sage ERP Accpac products, including upgrades. However, you can run Sage ERP Accpac for up to 30 days while you await your activation codes.

You can obtain activation codes from the Sage Customer or Partner Portal.

**If you are a Sage customer:**

1. Log in to your account at https://customers.sagenorthamerica.com/irj/portal/anonymous/login.
   
   If you don’t have an account, use the self-registration tool on the Customer Portal login page to create one.

2. On the Support menu, click Self Service.

3. Click the My Products tab.

4. Follow the instructions on the My Products tab to display and print the Details Sheet.
If you need assistance with the Customer Portal, e-mail Customer.Portal@sage.com, or call 1-877-828-6372.

**If you are a Sage partner:**

1. Log in to your account at https://partners.sagenorthamerica.com/irj/portal.
   
   If you don’t have an account, contact the portal administrator at your company, or contact Sage.

5. Click Customers > Details Sheet.

6. Click Show Advanced Search.

7. Enter an account ID, and then click Go.

8. On the Details Sheet, click the Products Details tab to view the customer’s activation codes.

If you need assistance with the Partner Portal, e-mail Partner.Portal@sage.com, or call 1-877-828-6372.

## Updating Your Sage ERP Accpac Licenses

You use the License Manager to:

- View license information for your Sage ERP Accpac programs, including the number of users authorized by the LanPak license.

- Enter serial numbers and activation codes for the Sage ERP Accpac programs and services that your company is using.

- When necessary, change the company name to which your Sage ERP Accpac software is registered (for instance, after a merger).

The License Manager form appears during program installation, letting you enter serial numbers and activation codes for any new Sage ERP Accpac programs and LanPaks that you are installing.

During installation, the program creates temporary license files (with serial number "000000000000") for Sage ERP Accpac Programs. If you have received valid serial numbers and activation codes, you enter them in the License Manager to make the licenses permanent.

You can also open the License Manager, later, if you need to add or change any licensing information. If you don’t enter LanPak information during installation, for example, the program prompts you to enter it in the License Manager form.
To update product licenses or LanPaks:

1. From the Help menu on the Sage ERP Accpac desktop, click Licenses.
2. On the Licenses form that appears, click the License Manager button.

- To edit the client ID, Licensed To (person or entity), dealer, and CC (certified consultant or business partner), click the License Information tab.

  If you need to change the company name to which your Sage ERP Accpac software is registered, you click the Change button, and then type the new name in the Company field. When you next open the License Manager form, the company field will be disabled, unless you click Change again.

**Note:** Activation codes are effective for serial numbers and company names used together. After you change the company name, the activation code will be marked Unauthorized. The license will remain valid, but you should apply for another activation code for the new company name.

- To enter activation codes for your Sage ERP Accpac products (for example, to update a temporary license with a permanent one), click the Licenses tab.

  You must enter the Serial Number and the Activation Code, in order, for each Sage ERP Accpac product you want to register:

  i. Click in the Serial Number column, and then type your serial number for the selected product.

  ii. Click in the Activation Code column, and then type the activation code for the product.

**Note:** You require permanent licenses for Sage ERP Accpac Intelligence Analysis and Connector. No temporary licenses are available for these programs.

- To enter activation codes for LanPak licenses, or to delete temporary licenses for databases that you do not use, click the Users tab.

  You must enter information for each LanPak user in this order:

  i. Click in the License Type column, and then select LanPak.

  ii. Click in the Count column, and then type the number of users that require concurrent access to Sage ERP Accpac from the list.
iii. Click in the Serial Number column, and then type your serial number for the selected product.

iv. Click in the Activation Code column, and then type the activation code for the product.

**Note:** You also use this tab to record activation codes for additional licenses for the Sage ERP Accpac Intelligence Report Manager and the Report Viewer in single-user increments. (One Sage ERP Accpac Intelligence Report Manager license — for one user — is free with Sage ERP Accpac.)

3. When you have finished entering information, click Close to return to the Licenses form.

4. Click OK to return to the desktop.

**Viewing License Information**

You can also view Sage ERP Accpac licenses using the Licenses form, as follows:

1. On the Sage ERP Accpac desktop, from the Help menu, click Licenses.

   - To see information for a single license, or select the product on the list, and then click the License Info button (or double-click the product name).

   - To see information for a LanPak, select it on the list, and then click the LanPak Users button.

   - To see information about any third-party products you are using that integrate with Sage ERP Accpac, click IAP Users.

   - To see details for all Sage ERP Accpac licenses and LanPaks, or to update licensing information, click the License Manager button.
Monitoring LanPak Activity

You can monitor your network use by clicking LanPak Users on the Sage ERP Accpac desktop Help menu.

This command lists all the users currently signed on to Sage ERP Accpac.

The Type displayed in the Users window will be Pervasive PSQL, Microsoft SQL Server, or Oracle, depending on the database you are running.
Chapter 8
Web Deployment of Sage ERP Accpac

Typically, you set up Web deployment on the same Windows server where the Sage ERP Accpac programs are installed.

However, because the only requirement is that Internet Information Services (IIS) is installed, you can set up Web deployment on a Sage ERP Accpac workstation or a server.

Before You Begin

Before you deploy Sage ERP Accpac on the Web:

1. Install Sage ERP Accpac as described in Chapters 1 through 4.

2. Create your system and company databases.

3. Check that you can connect to your data and run installed applications from the Sage ERP Accpac Desktop locally or from the server (depending on your network configuration).

Once you’ve confirmed that Sage ERP Accpac runs successfully as a desktop application, you can proceed with Web deployment.

Selecting Installation Options for Web Deployment

On the Web server you are using to deploy Sage ERP Accpac:

1. If Internet Information Services (IIS) is not already installed, install and configure it now.

   Use the instructions for your operating system provided in the section, “Installing Internet Information Services (IIS).”

2. Install Sage ERP Accpac with the following additional options:
   - Web-Deployment Files.
   - If you plan to use .NET Remoting for Web deployment, also select the option Sage ERP Accpac .NET Libraries.
3. Install Sage ERP Accpac Web Reporting by Crystal.

You must install this reporting server to allow users to print Sage ERP Accpac reports from their browser.

Sage ERP Accpac Web Reporting is not included on the installation DVD for Sage ERP Accpac.


Detailed instructions are included in the following sections.

**Installing Internet Information Services (IIS)**

The Web server on which you will deploy Sage ERP Accpac must have IIS installed.

If IIS is not already installed, ensure .NET Framework 2.0, or higher is installed, and then follow the directions for your operating system in the sections that follow.

**For Windows XP**

1. From the Windows Start menu, click Settings > Control Panel > Add or Remove programs.
2. Click Add/Remove Windows Components.
The Windows Components Wizard form appears, as follows:

3. Select Internet Information Services (IIS), and then click Next to install IIS. No further configuration is needed.

For Windows Vista and Windows 7

1. From the Windows Start menu, click Settings > Control Panel > All Programs And Features.

2. Click Turn Windows Features On Or Off.

   The Windows Features screen appears.

3. Expand the Internet Information Services folder, and then expand the Web Management Tools folder.

4. Expand the IIS 6 Management Compatibility folder, and then select Windows IIS Metabase And IIS 6 Configuration Compatibility.
5. Expand the World Wide Web Services folder, and then the Application Development Features folder. Select the following options:
   a. ASP
   b. ASP.NET

6. Click OK to install IIS.

**For Windows 2003 Server**

1. From the Windows Start menu, click Control Panel > Add/Remove All Programs > Add/Remove Windows Components.

   The Windows Components Wizard appears, as follows:

   ![Windows Components Wizard](image)

2. In the Windows Components Wizard, select the Application Server component.

3. Click the Details button to confirm that ASP.NET is selected, as shown:

   ![Details button](image)

4. Click OK, and then follow the instructions to install Application Server.

5. After Application Server is installed, open Internet Information Services (IIS) Manager.
Installing Internet Information Services (IIS)

From the Windows Start menu, click Settings > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager.

6. In IIS Manager, expand your machine name, and then select the Web Service Extensions folder, as shown:

![Web Service Extensions screenshot]

7. In the center panel, select Active Server Pages, and then change its status to Allowed.

8. Close the IIS Manager.

For Windows 2008 Server

1. From the Windows Start menu, click Settings > Control Panel > Administrative Tools > Server Manager.

   The Server Manager appears.

2. In the left pane, select Roles, and then in the center panel, click Add Roles.
The Add Roles Wizard appears.

3. In the left navigation pane, select Server Roles, and then select the roles Application Server and Web Server (IIS).

4. In the left navigation pane, select Application Server and then Role Services, and then select the role service COM+ Network Access.

5. In the left navigation pane, select Web Server (IIS), and then Role Services. Expand the Web Server folder tree, and then select:
   - Application Development > ASP.NET
   - Application Development > ASP
   - IIS 6 Management Compatibility > IIS 6 Metabase Compatibility

6. Click Next to install the selected options.
7. Close the Server Manager.

**For 64-bit versions of Windows**

For any supported 64-bit version of Microsoft Windows, you must enable 32-bit application support in Internet Information Services (IIS).

For detailed information on how to enable 32-bit support in IIS, see the following Microsoft article *Running 32-bit Applications on 64-bit Windows*:


---

**Configuring Web Deployment Options**

**On the Web server, run the Web Deployment Manager wizard to configure Web deployment options, as follows:**

1. From the Windows Start menu, click Programs > Sage ERP Accpac > Web Deployment Manager.

   If Sage ERP Accpac Web Reporting by Crystal is not installed, an error message appears. Click Yes to continue or No to quit.

   **Note:** Users cannot print Sage ERP Accpac reports from their browser unless the reporting server is installed.

2. If you are configuring Web Deployment over Windows 7, Windows Vista, or Windows 2008, and Windows' user access controls are set at the default level, you may receive a message saying that IIS or Sage ERP Accpac Web Reporting by Crystal is not installed, even though these programs are installed. If this occurs:
   a. Click Programs > Sage ERP Accpac.
   b. Right-click Web Deployment Manager, and then select Properties.
   c. Click the Compatibility tab, and then select Run As Administrator.
   d. Click OK.
The Sage ERP Accpac Web Deployment Wizard appears, as shown:

2. Read the information on the Welcome page, and then click Next.

Complete the steps on the following tabs:

**Step 1: Select Remoting Channel**

Choose how the Sage ERP Accpac server will communicate with browser clients.

You can select:

- **Microsoft .NET Framework Remoting (recommended)**

  Or

- **Distributed COM (DCOM) Remoting**
If you select this option, skip Steps 2 and 3.

The Sage ERP Accpac .NET Libraries provides a set of Microsoft .NET-based interfaces for System Manager.

Once installed, Web-deployed servers can make use of .NET Remoting to communicate with client machines through a predefined set of network ports. These ports can be easily configured to work with software and hardware firewalls.

DCOM is an older technology that allows COM-based components to access remote servers. DCOM works well on networks without firewalls, but requires extra configuration when communications between client and server machines pass through a firewall.

**Step 2: Configure .NET Remoting Parameters**

Specify the .NET Remoting parameters, as follows:

- **Port Range.** Specify the range of ports that .NET Remoting can use to communicate with clients. If you are not the network administrator, ask your network administrator to confirm whether the default range is in use. If other applications on the server are using ports within the default range, specify a different range.

- **Enhanced Security.** Provides an extra layer of data protection by requiring users to sign on to the Sage ERP Accpac server with a valid Windows username and password. This is in addition to the security you may have set for your Sage ERP Accpac databases, which require Sage ERP Accpac users to enter a user name and password on the Open Company screen.

A valid windows account is required—this could be a local user account or a domain account, if the server is part of a Windows domain.
• **Encrypt Network Data.** Encrypts all data transferred between the client and the server.

  **Recommendation** If you will deploy the server over the Internet, select this option to protect your data!

**Step 3: Configure .NET Desktop Parameters**

Select the maximum number of Web server objects you require. This will depend on the number of users who will access the Web Desktop, and the number of installed applications.

**Note:** One object is required for each user logged into the Web Desktop and for each user interface form that the user opens.

**Step 4: Configure Component Services**
On the server, the Sage ERP Accpac server components must be installed into Windows Component Services. The server components generate the Web pages that users see in their Web Desktop.

The server components run as a background process under an authorized Windows user account.

a. Type, or click Browse to select the username and password of a local or domain account user who has sufficient rights to run Sage ERP Accpac on the server.

b. Re-type the password to confirm.

**Step 5: Configure Internet Information Server**

Specify the server name and site directory that clients will access to view the Web Desktop.

a. Type the name of the Virtual directory in which your Sage ERP Accpac site will be stored.

   This name will form part of the URL that users enter in their browser’s address bar to access the Web Desktop.

b. Type the server's name in the Server name field.

   Web clients use this name to gain access to services and to download applications from the Sage ERP Accpac server.
   
   - If the server will be deployed on the Internet, enter the fully-qualified domain name of the server; for example, sageaccpac.yourcompany.com.
   
   - If you selected .NET Remoting in Step 4, you can enter the IP address of the server machine rather than the server name.
Changing Web Deployment Options

- If the server is deployed on an internal network, enter the server’s computer name or IP address.

c. Click Next.

Step 6 is not applicable. The Wizard will skip over this tab.

3. Click Next to install selected components and configure the remoting channel on the Sage ERP Accpac server.

4. Read the text on the Summary tab, and then click Next.

5. Read the text on the Done tab, and then click OK to quit the Wizard.

Changing Web Deployment Options

To change your Web deployment configuration:

1. Run the Sage ERP Accpac Web Deployment Wizard again.

The Sage ERP Accpac Web Deployment Configuration Manager form appears:

2. From the Configure menu, select Run Configuration Wizard.

The Sage ERP Accpac Web Deployment Wizard appears.

3. Refer to the setup instructions in the previous section, Installing Internet Information Services (IIS).
Running Sage ERP Accpac in Internet Explorer

Open Internet Explorer, and then enter the URL to the Sage ERP Accpac site on the Web server.

The URL has the form: http://<server name>/<virtual directory>; for example http://server1/ACCPAC/.

The first time you access a Sage ERP Accpac company database from your browser, you will be prompted to download Web Client Setup files. Click Sign On to start the download and sign on to your company database.
Appendix A
Setting Up a Pervasive Workgroup Engine On a Peer-to-Peer Network

This appendix explains how to optimize the Pervasive PSQL Workgroup Engine if you are using the Pervasive PSQL Workgroup Engine over a peer-to-peer network.

On a peer-to-peer network, one workstation should act as a dedicated server, allowing the other workstations efficient access to Sage ERP Accpac data and programs.

We recommend that you perform the following steps to maximize the performance of Sage ERP Accpac:

1. Install and configure the Workgroup Engine on all workstations.

2. Assign one workstation to be the **Gateway** computer. This is the computer that will store the Sage ERP Accpac databases.

   **Tip:** To maximize system performance, select the fastest computer in your peer-to-peer network to act as the Gateway.

3. Optimize the workgroup engine on the Gateway computer and on all client workstations.

**Optimizing the Workgroup Engine on the Gateway**

On the Gateway computer, configure the workgroup engine as follows:

1. Open the Pervasive Control Center.

2. Select Configure Microkernel Router, and then change the default settings as follows:

<table>
<thead>
<tr>
<th>In Section</th>
<th>Setting</th>
<th>Default Value</th>
<th>Recommended Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access</td>
<td>Use Remote Microkernel Engine</td>
<td>ON</td>
<td>OFF</td>
</tr>
<tr>
<td>Communication Protocols</td>
<td>Supported Protocols</td>
<td>TCP,SPX, NetBIOS</td>
<td>TCP/IP</td>
</tr>
</tbody>
</table>
3. Select Configure Local Engine, and then change the default settings as follows:

<table>
<thead>
<tr>
<th>In Section</th>
<th>Setting</th>
<th>Default Value</th>
<th>Recommended Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Communication Protocols</td>
<td>Supported Protocols</td>
<td>TCP/IP, SPXII</td>
<td>TCP/IP</td>
</tr>
<tr>
<td>Data Integrity</td>
<td>Transaction Logging</td>
<td>ON</td>
<td>OFF</td>
</tr>
<tr>
<td></td>
<td>Initiation Time Limit</td>
<td>10000</td>
<td>65535</td>
</tr>
</tbody>
</table>

**Optimizing the Workgroup Engine on Client Workstations**

On all Client workstations, configure the workgroup engine as follows:

1. Open the Pervasive Control Center.

2. Select Configure Microkernel Router, and change the default settings as follows:

<table>
<thead>
<tr>
<th>In Section</th>
<th>Setting</th>
<th>Default Value</th>
<th>Recommended Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access</td>
<td>Use Local Microkernel Engine</td>
<td>ON</td>
<td>OFF</td>
</tr>
<tr>
<td>Communication Protocols</td>
<td>Supported Protocols</td>
<td>TCP, SPX, NetBIOS</td>
<td>TCP/IP</td>
</tr>
</tbody>
</table>