
Sage HRMS

HR and Payroll Reports Catalog



This is a publication of Sage Software, Inc.

© 2020 The SageGroup plc or its licensors. All rights reserved. Sage, Sage logos, and Sage product
and service names mentioned herein are the trademarks of The SageGroup plc or its licensors. All
other trademarks are the property of their respective owners.

Last updated: June 18, 2020



Contents

Chapter 1: Introduction 1
Support and resources 1

Chapter 2: Employee reports 2
Code table reports 2

Compensation reports 4

EEO reports (U.S.) 7

Employee and organization reports 9

Employment equity reports (Canada) 10

Leave reports 11

OHS reports (Canada) 12

OSHA reports (U.S.) 13

Pay equity reports 14

Personal information reports 15

Benefit reports 16

Skill and education reports 18

Wellness reports 19

Chapter 3: TimeOff reports 20
Attendance reports 20

TimeOff code table reports 22

Chapter 4: Payroll Reports 23
Bank reports 23

Employee Payroll reports 25

General Ledger reports 26

Government reports 27

Sage Payroll Tax Forms and eFiling by Aatrix 29

iiiSage HRMS HR and Payroll Reports Catalog



Periodic processing reports 29

Setup Payroll reports 30

Transaction reports 31

Chapter 5: Training reports 33
Catalogs and code table reports 33

Class administration reports 34

Employee training reports 35

Training analysis reports 36

Chapter 6: System reports 38
Audit trail reports 38

Data Dictionary reports 39

Using functions in reports 39

Chapter 7: Using the standard reports 40
Generating reports 40

Selecting specific employees for a report 44

Defining custom criteria 45

Printing, previewing, or exporting a report 48

Chapter 8: Custom reporting with SAPCrystal Reports 51
Creating a custom report 51

Custom HR reports 55

Custom TimeOff reports 62

Custom Training reports 63

Chapter 9: Sage HRMSSecure Query 64
AdHoc Reporting Security 64

Using Secure Query 65

Creating a new query 66

Selecting fields 70

Grouping records 71

Sorting records 72

ivSage HRMS HR and Payroll Reports Catalog

Contents



Setting record filters 73

Viewing the data, running a query, and outputting the query results 77

vSage HRMS HR and Payroll Reports Catalog

Contents



Chapter 1: Introduction

This guide provides an overview of the reports available in Sage HRMS, Sage HRMSPayroll, Sage HRMS
Train, and custom and standard reports using SAPCrystal Reports.

Support and resources
Sage strives to provide you with the best help and support in the industry. If you have a question, we're
here to help!

l Online Help: Click or press F1 within in the product to open the online help for the window you are
viewing. From within the help, you can click the Contents tab (on the left side of the window) to
explore a variety of topics, click the Index tab to look for topics related to a particular keyword, or use
the search box (in the upper right corner of the window) by typing a particular word or phrase and

clicking to search for topics containing that text.

l Product Documents: Access this and other documents from the SageHRMS Product Documents
website.

l Sage City: Visit the online community at http://sagecity.na.sage.com/ for blogs, tips, and guidance
for your Sage programs.

l Sage Knowledgebase: Search the Sage Knowledgebase, which provides 24/7 access to support
articles as well as the latest software downloads and updates.

l Customer Support: For other support resources, visit the SageCity Customer Resources page,
select your country, and then select your product.

l Sage University: Learn pro tips for year-end processing in online or classroom courses. Visit
http://SageU.com and log on or create an account to register for training.

l Tax forms: Because all printed forms have variations, Sage HRMSPayroll only supports forms
printed by Sage Checks and Forms. Call Sage Checks and Forms at 800-617-3224 or order online
atwww.SageChecks.com.
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Chapter 2: Employee reports

Sage HRMS includes many HR and employee reports that are grouped into the following categories:

l "Code table reports" (page 2)

l "Compensation reports" (page 4)

l "EEO reports (U.S.)" (page 7)

l "Employee and organization reports" (page 9)

l "Employment equity reports (Canada)" (page 10)

l "Leave reports" (page 11)

l "OHS reports (Canada)" (page 12)

l "OSHA reports (U.S.)" (page 13)

l "Pay equity reports" (page 14)

l "Personal information reports" (page 15)

l "Benefit reports" (page 16)

l "Skill and education reports" (page 18)

l "Wellness reports" (page 19)

Code table reports
Use the following code table reports to review the codes in your code tables for employees for the
enterprise or an employer. You can print the reports before making a change to the code tables, and then
print them again after the change as a reference.

l Aboriginal Codes (Canada only)

l Attachment Codes

l Benefit Insurance Plans

l BenefitRate Tables

l Benefit Savings Plans

l Benefit Type Codes

l Census Metro Area Codes (Canada only)
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l Consent Types

l DependentRelationship Codes

l Direct/Indirect Codes

l Disability Codes (Canada only)

l EECategory Codes (Canada only)

l EEOccupationalGroupCodes (Canada only)

l EEO Classification Codes (U.S. only)

l EEO JobGroupCodes (U.S. only)

l EEO-4 Job FunctionCodes (U.S. only)

l Employee Note Author Codes

l Employee Note Type Codes

l Employee Type Codes

l Ethnic ID Codes

l Event Codes

l FMLA Event Reason Codes

l I-9 Form Codes (U.S. only)

l Industrial Sector Codes (Canada only)

l Job Classification Codes

l Job Codes

l Job Family Codes

l Job Status Codes

l Language Codes

l NOCOccupationGroupCodes (Canada only)

l OHSBody Part Codes (Canada only)

l OHS Injury Codes (Canada only)

l OHS Injury Location Codes (Canada only)

l OSHA Body Part Codes (U.S. only)

l OSHA Injury Codes (U.S. only)

l OSHA Injury Location Codes (U.S. only)

l Organization Codes

l Pay Equity JobGroupCodes
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l Rating Codes

l Reason Codes

l Salary Grades

l Shift Differential Codes

l Skill Codes

l State/Province Codes

l Step Rate Codes

l Union Codes

l User-Defined Codes

l Visible Minority Codes (Canada only)

Compensation reports
These reports track reviews, new hires, and terminations, as well as a variety of salary analyses and job
code statistics.

Note: Many compensation reports include the compa-ratio, which is the employee’s percent-of-midpoint
within a salary range. This is the formula for calculating compa-ratio:

Compa-ratio = Employee’s salary / Midpoint for Salary Grade * 100

Compa-ratio calculations do not print unless you enable Salary Grade Table Validation during
employer setup.

Report name Description

Ranked Salary List Displays the annual salaries of all your employees in descending order. The
report includes annual salaries, unit rate, employees, employee titles, and
organization level. You can include all, exempt, or nonexempt employees.

Reviews Due Displays performance and salary reviews by month. You can include
performance or salary reviews—and sort by organization level or supervisor. If
you select open reviews, the report includes reviews with a Next Review Date
that is earlier than the one specified; the program considers reviews open until
the Next Review Date is updated.
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Report name Description

ReviewForms for
Reviews Due

Displays employee job and salary history. It also provides a section of
requested changes for the reviewer to fill out and management to sign. The
options are identical to those for the Reviews Due report. When the form is
completed, it is intended for use in updating the employee information affected
by the review.

SalaryAnalysis by
Employee Name

Displays salaries categorized by individual employees, job title, all employees,
or your search criteria. The report includes pay rates, hours, annual salaries,
longevity, and compa-ratio.

SalaryAnalysis by
JobCode

Displays salaries by job code, individual employee, all employees, or your
search criteria. The report includes job titles, salary grades, pay rates, annual
salaries, and other data. It is sorted by exempt and nonexempt employees.

SalaryAnalysis by
Job Title

Displays salaries by job title, job code, individual employee, all employees, or
your search criteria. The report includes pay rates, hours, annual salaries,
longevity, compa-ratio, and other data.

SalaryAnalysis by
Organization

Displays employees’ salaries by organization level. The report includes the
employee’s pay rate, hours, annual salary, years of service, rating, and compa-
ratio. The report also displays the employees’ average annual salary, total
annual salary, and number of employees. The report includes the subtotals for
each organization level; the totals for the employer appear at the end the
report.

SalaryAnalysis by
Salary Grade

Displays salaries by salary grade, individual employee, all employees, or your
search criteria. The report includes job titles, salary grades, pay rates, annual
salaries, and other data. The report averages and totals the annual salaries for
each salary grade.

Salary AsOf Displays employees and their respective salaries at a given point in time. The
report includes the employee name, job title, unit pay rate, and annual salary as
of the selected date. The report also includes the total of the salaries displayed
and a calculated salary average. You can select individual employees, all
employees, or specify search criteria.

Salary Grade Range
Exceptions

Displays employees whose rate of pay is different (more or less) from their
assigned salary grade range. This report works only if Salary Grade Validation
is enabled during setup of Sage HRMS. Grouped by organization levels, the
report includes the employee, title, salary, normal salary grade range
(minimum and maximum), and the difference in dollar amount between the
salary grade range and what the employee is paid.
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Report name Description

Salary History Displays employee compensation history, including the employees, effective
dates, reasons for change, salary rates, and annual salaries.

Salary Increase
Analysis by Job
Code

Displays salary increases by job code, including previous versus current
salaries, effective dates, reasons for adjustments, and actual and percentage
amounts of increases.

Salary Increase
Analysis by
Organization

Displays employee salary increases by organization level. The report includes
previous versus current salaries, effective dates, reasons for adjustments, and
actual and percentage amounts of increases.

Salary Increase
Analysis by Reason

Displays employee salary increases by reason. The report includes previous
versus current salaries, effective dates, reasons for adjustments, and actual
and percentage amounts of increases.

Statistics by Job
Code

Groups statistical data into exempt and nonexempt employee categories. For
each job code, the report shows titles, number of employees in each category,
average unit rate, and average and total salaries.

Terminated
Employee Log

Displays terminated employees for a specified date range. The report searches
the Employee Status for all employees tagged as terminated. The report
provides dates of hire and termination, name, employee number, reason for
termination, title, organization levels, employee type, longevity, pay rate and
frequency, and annual salary. The report sorts the employees by termination
date, gives a headcount, and calculates average and total terminated salaries.

Turnover
Performance vs.
Longevity Matrix

Displays information about the turnover rate within your organization. The
report might indicate a problem if employees with a high performance rating
consistently leave your company, while poor performers have remained with
the company a long time. The report lists performance ratings vs. length of time
employed for terminated employees.

Turnover Statistics Displays turnover statistics and calculates service length by Adjusted Seniority
Date, Original Hire Date, or Last Hire Date. For each terminated employee, this
report includes termination type, termination date, employee name, title,
service length, salary grade, and termination reason.
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EEO reports (U.S.)
Use EEO reports to track the compliance of your company's hiring practices.

Report name Description

EEO JobGroupAge
Analysis

Displays the number of employees from specific age groups falling within each
EEO job group. In addition to assisting you with ADEA compliance, this report
helps you analyze your work force and plan for groups of employees who are
approaching retirement.

EEO JobGroup
Headcount

Displays the number and percentage of employees in each gender and ethnic
group who fall within specific EEO job groups.

EEO New-Hire
Headcount Detail

Displays new hire employees grouped by EEO classification.

EEO New-Hire
Headcount Summary

Displays the EEO classifications with the number of new hire employees in
each classification. The summary is broken down by gender and ethnic origin.

EEO Termination
Detail

Lists terminated employees grouped by EEO classification.

EEO Termination
Summary

Displays the EEO classifications with the number of terminated employees in
each classification. The summary is broken down by gender and ethnic origin.

EEO-1
Headcount Detail

Displays a list of employees grouped by EEO classification, which enables you
to reconcile the information generated in the EEO Headcount Summary report.

EEO-1 Headcount
Summary

Displays a table showing EEO classifications and the number of employees in
each classification. The table is broken down by gender and ethnic origin. Each
column is totaled.

EEO-4 Headcount
Detail

Displays employees grouped by EEO classification so you can reconcile the
information with the EEO Headcount Summary. This EEO-4 report consists of
multiple pages and is not intended to be submitted to the government as the
officialEEO-4 form.

EEO-4 Headcount
Summary

Displays EEO classifications with the annual salaries and employee counts in
each classification, including gender and ethnic origin. Each column is
totaled. This report is not intended to be submitted to the governmentas the
officialEEO-4 form.
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Report name Description

I-9 Citizenship
Verification

Lists employees with their I-9 citizenship status and renew dates.

Promotions Displays the EEO class codes, genders, and ethnic backgrounds of employees
promoted within a specific time period.

Veterans
Employment

Displays EEO classifications (job categories) with the number of employees
and new hires in each classification. The report is broken down by veteran
status.

Note: Sage HRMS adds the number of employees in EEO Class 1.1
(Executive/Senior Level Officials and Managers) with the number of
employees in EEO Class 1.2 (First/Mid Level Officials and Managers). The
total is displayed on the report as EEO Classification Code 1 (Officials and
Managers).

Vets 4212 Detail List Displays employee names and IDs by job category for each VETS-4212
category. The report includes newly hired veterans by category and total new
hires for the selected 12-month period. It displays the required report data for
the Information on Employees section of the VETS-4212 form.

Vets 4212 Form and
EFile

Displays the number of employees and new hires in each EEO classification
broken down by veteran status.

Note: Sage HRMS adds the number of employees in EEO Class 1 (Officials
and Managers) to the number of employees in EEO Class 1.1
(Executive/Senior Level Officials and Managers), and displays the total on
the report as EEO Classification Code 1.1 (Executive/Senior Level Officials
and Managers).

Vets 4212 Summary
List

Displays the number of employees by job category for each VETS-4212
category. The report includes newly hired veterans by category and total new
hires for the selected 12-month period. The report displays a summarized list of
the required report data for the Information on Employees section of the VETS-
4212 form.
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Employee and organization reports
Employee and organization reports include lists of anniversary dates, personnel events, organizational
structure, years of service, business telephone directory, recruiter activity, and union activity.

Report name Description

Anniversary List Lists hire dates and seniority rankings for individual employees, all employees,
or specified reporting criteria during one month or all months, as of the
specified effective date. You can base the anniversary date on the last hire
date, original hire date, or seniority date. You can sort by anniversary date,
employee name, anniversary date by organization level, or employee name by
organization level.

Event Report Lists employee events, including training, licenses, bonuses, professional
memberships, company cars, or anything defined in the Events code table. The
report includes the employee, title, organization level, event code, effective
date, event description, next due date, and comments. You can choose a
specific event or report all events, as well as specify a date range for next due
(renewal) dates.

NewHire Log Lists all employees hired during the specified date range. You can choose to
include or exclude rehires. You can sort by employee name or date hired.

Organizational
Report

Lists employees grouped by organizational levels and supervisors. Each group
includes the employee name, ID number, title, job code, seniority date, and
employee type (such as RFT or RPT). The employee count is subtotaled for
each organization level; the employee total appears at the end the report.

Recruiter Activity Displays recruiter activity during a specified time period. For each recruiter, the
report identifies new recruits, their current jobs, organization levels, and dates
of hire.

Service List Lists employees based on years of service The report includes their years of
service, seniority dates, employee names, titles, and organization levels. The
report includes the employee headcount and calculates the average length of
service.

Source-of-Hire
Activity

Displays the sources of new hires during the specified time period. The report
pinpoints new employees referred by personnel agencies, classifieds,
recruiters, and all other sources.

Step Rate Service Displays employees with their grade, step rate, service (month), job date, and
job title.
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Report name Description

Telephone Directory Provides a telephone directory of all employees and organization levels. You
can also build your own reporting criteria. You can select to display the full ten-
digit number, an extension number, or both numbers. You can also include
employees without phone numbers.

Note: This report uses the Nickname from the Demographics page as the
employee’s first name; if the nickname is blank, the report uses the First
Name; if the first name is blank, the report prints the Last Name but leaves
the Nickname/First Name column blank on the report.

Union Report Lists employees who belong to unions sorted alphabetical by name. The report
includes employee titles, longevity, and union sign-up dates. You can choose to
include or omit employee salaries.

Employment equity reports (Canada)
Use Employment Equity reports to track the compliance of a Canadian employer’s hiring practices.

These reports list employees based on the last activity that took place. For example, if you enter a date
range of 1/1/19 through 31/12/19 and during that time Donald Adams was hired, terminated, and then
rehired, the report would show Donald Adams as an active employee because the last activity was that he
was rehired.

Report name Description

EE 1 Audit: Summary Lists employees by designated CMA, employment status, industrial sector, and
province.

EE 2 Audit: Salary
Summary

Lists employees by industrial sector, province, salary, and gender.

EE 3 Audit:
OccupationalGroup

Lists employees by province, CMA, salary, employee name and ID, number of
active and inactive employees, and total number of employees by gender.

EE 4 Audit: Hired Displays information for new employees hired between a selected from and to
date.
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Report name Description

EE 5 Audit: Promoted Displays information for employees promoted between a selected from and to
date.

Note: Only employees whose change reason code is Promo are included in
the report. If you set up a code for promotions other than Promo, employees
with that code are not included on the report.

EE 6 Audit:
Terminated

Displays information for employees who were terminated between a selected
from and to date.

Leave reports
Sage HRMS includes reports to help you track and monitor employees’ leaves of absence.

Report name Description

Employees Currently
on FMLA

Displays all employees currently on FMLA leave. It includes the FMLA event as
well as the starting and ending dates. You can include selected employees,
selected organization levels, or a particular exempt status.

Employees Currently
on LOA

Displays all employees currently on leave. It includes the leave reason as well
as the starting and ending dates. You can include selected employees,
selected organization levels, or a particular exempt status.

FMLA Due to Return Displays all employees scheduled to return from FMLA leave. It includes the
FMLA event as well as the starting and ending dates. You can include selected
employees, selected organization levels, or selected exempt status.

LOA History Lists employees whose LOA start date is within a specified date range. The
report is grouped and sorted by employee name. It displays status, leave
reason, and the start and actual return dates.

Medical
Recertification

Lists employees due for medical recertification prior to returning from FMLA
leave. The report includes the FMLA event as well as the starting and
recertification dates. You can include selected employees, organization levels,
or a particular exempt status.
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OHS reports (Canada)
The information on Occupational Health and Safety (OHS) reports comes from the information provided on
the OHS page.

Report name Description

Accident Analysis by
Injury

Displays the number of work-related injuries or illnesses as well as the impact of
related medical costs and lost productivity on the organization due to these
incidents. Events are sorted by injury.

Accident Analysis by
Location

Displays the number of work-related injuries or illnesses as well as the impact of
related medical costs and lost productivity on the organization due to these
incidents. Events are sorted by location.

Accident Analysis by
Org Level

Displays the number of work-related injuries or illnesses as well as the impact of
related medical costs and lost productivity on the organization due to these
incidents. Events are sorted by organization level.

Accidents by Date Displays the number and nature of work-related injuries, illnesses, or first aid
administered by date within the specified time period. The report can include
individual employees, all employees, or your reporting criteria. You can include
or exclude information regarding unfiled accidents and closed accidents.

Accidents by
Employee

Displays the number and the nature of work-related injuries or illnesses within
the specified time period. It is sorted by employee. The report can include
individual employees, for all employees, or specify search criteria.

Accidents Not Filed Displays work-related injuries or illnesses not filed during the specified time
period. You can select individual employees, all employees, or specify search
criteria.

WSIB - Employers
Report Form 7

Creates the form for reporting a work-related accident or illness to the
Workplace Safely and Insurance Board.

Workers CompOpen
Claims

Displays the number of openWorkers' Compensation claims. The report
includes the number and nature of open cases, dates claims were filed and
closed, case numbers and claim IDs, and number of work days the employee
lost or experienced restricted duty.
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OSHA reports (U.S.)
The information in Occupational Safety and Health Act (OSHA) reports comes from the information
provided on theOSHA page.

Report name Description

Accident Analysis by
Injury

Displays the number of work-related injuries or illnesses as well as the impact of
related medical costs and lost productivity on the organization due to these
incidents. Events are sorted by injury.

Accident Analysis by
Location

Displays the number of work-related injuries or illnesses as well as the impact of
related medical costs and lost productivity on the organization due to these
incidents. Events are sorted by location.

Accident Analysis by
Org Level

Displays the number of work-related injuries or illnesses as well as the impact of
related medical costs and lost productivity on the organization due to these
incidents. Events are sorted by organization level.

Accidents Not Filed Displays work-related injuries or illnesses not filed during the specified time
period. You can select individual employees, all employees, or specify search
criteria.

Accidents by Date Displays the number and nature of work-related injuries, illnesses, or first aid
administered by date within the specified time period. You can select individual
employees, all employees, or specify search criteria. You can include or
exclude information regarding unfiled accidents and closed accidents.

Accidents by
Employee

Displays the number and the nature of work-related injuries or illnesses within
the specified time period. The report is sorted by employee. You can select
individual employees, all employees, or specify search criteria.

OSHA 101 Accident
Profile

Displays detailed information about employees' work-related accidents. The
report includes other information such as hospital details.

Note: This report is included for historical purposes only; it should not be
used for official reporting or filing.

OSHA 200 Log Displays a log and summary of occupational injuries and illness. The report
does not include a total.

Note: This report is included for historical purposes only; it should not be
used for official reporting or filing.
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Report name Description

OSHA 300 Incident
Log

Displays a log of the number of work-related illnesses and injuries sustained by
employees within a given time period.

OSHA 300A Incident
Summary

Displays the number of work-related illnesses and injuries sustained by
employees within a given time period. You can sort data according to incident
type and print either summary or detail versions of the report. Summary reports
contain those totals you must post by law. (Detail reports contain information to
help you reconcile totals in the summary reports.)

OSHA 301 Incident
Report

Displays work-related injuries and illnesses, including company and employee
home contact information, incident information, and other details.

Workers CompOpen
Claims

Displays the number of openWorkers' Compensation claims. The report
includes the number and nature of open cases, dates claims were filed and
closed, case numbers and claim IDs, and number of work days the employee
lost or experienced restricted duty.

Pay equity reports
The information on these reports comes from the information provided on the Pay Equity page. These
reports assist with the process of determining male-dominated and female-dominated jobs within an
organization.

Report name Description

Job Groups by
Gender

Lists employees by gender within a job and job group. This information assists
with pay equity purposes.

Jobs by Gender Lists employees by gender within a job. This information assists with the
determination of male-dominated and female-dominated jobs within an
organization.

14Sage HRMS HR and Payroll Reports Catalog



Personal information reports
Personal information includes lists of birthdays, addresses and telephone numbers, mailing labels,
headcounts, and detailed employee profiles.

Report name Description

Age List Lists employees sorted by age. The report includes employee birth dates, titles,
divisions, and departments.

Birthday List Lists employee birthdays. It can be sorted by date, name, by date for each
division and department, or by name for each division and department. It can
include any or all months. You can choose whether to include address
information.

Employee
Attachments

Lists the attachments for a selected group of employees. You can choose
whether to show employees who are missing required attachments.

Note: Running this report can return an error if either the total size of the
HREMPATT report file exceeds the memory handling ability of the SQL
server, or an attachment in the HREMPATT database is over 14.5
megabytes in size.

Employee Count Displays a count of all employees within an organization. You can choose to
count all the employees within your company, within a division, or within a
department.

Employee List Lists employee information by last name, first name, and middle initial. It also
includes employee IDs, titles, and organization levels.

Employee Notes Displays notes for the employees you specify. You can choose to print all notes
or only those of a particular type or by a particular author. You can sort by
employee name, note type, author, comment date, or follow-up date.

Employee Profile Displays the profile for an individual, all employees, or the criteria you specify.
You can customize the profile information by selecting the employee pages
from which the program pulls information.

HomeMailing Labels Prepares mailing labels showing employees’ names and addresses printed in
three-column label format (30 labels per page). You can sort these by
employee name, employee ID, or zip code and employee name.

Tip: If sheets of labels don’t move easily through your printer, try printing the
labels on regular paper, then use your copier to print them on labels.
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Report name Description

Work Phone List Lists employees' names and work telephone numbers. The report displays the
standard ten-digit phone number (including the area code), the extension
number, and the organization level for each employee.

Benefit reports
All benefits reports have a selection option for COBRA recipients. Most benefits reports prompt for the
effective date. In this way, benefits that have expired or have yet to begin are not included.

Report name Description

Beneficiary List Lists the dependents covered under each employee's benefit plans.

Benefit Coverage by
Employee

Lists personal and salary information for each employee, including the benefits,
effective and expiration dates, total monthly premium costs for the employee,
employee’s dependents, and the amount the employee pays for coverage. You
can choose to either include or exclude waived benefit plans, as well as to
include or exclude history.

Note: This report will only display Marital Status and Total Dependents
information if the effective date used to generate the report is the current
system date. If another effective date is used (  such as a past or future date),
this information will not appear on the report.

Benefit Enrollment by
Plan

Displays the totals benefits by plan. You can choose to either include or exclude
waived benefit plans, as well as to include or exclude history.

l For insurance plans, the report totals employee monthly premium,
dependent monthly premium, employee monthly contribution, and
monthly net cost.

l For savings plans, the report totals monthly projected employee
contribution and monthly employer match.

Note: You must enter an effective date for the report. Otherwise, if the date is
left blank, the report might not include all the appropriate enrollment
information.

Benefit Letter Prepares a letter showing the benefits set up for an employee.
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Report name Description

Benefit Premium
Totals by Plan

Displays a summary headcount of each benefit plan. The report includes the
plan, number of enrollees, coverage amount, employee monthly premium,
dependent monthly premium, employee monthly contribution, and monthly net
cost. You can choose whether to include insurance or savings plans in the
report as well as include or exclude history.

Census Report Displays information most insurance companies require when calculating the
cost of providing insurance. You can send this report directly to the insurance
company. The Dependents column on the report indicates the number of
insured as specified on the Dependents and Beneficiaries page. An insured
spouse counts as one dependent.

Certificate of
Coverage

Displays proof of previous health insurance coverage for the employee.

l If the Date of Certificate (entered on the Specific Criteria tab) is greater
than the date the employee’s coverage ended, the certificate will print the
employee’s name, the date the coverage began (item #10), and the date
the coverage ended (item #11).

l Otherwise, if coverage has not ended (as of the Date of Certificate), the
report will display an X in item #11.

COBRA Billing
Statement

Sage HRMS can track different types ofCOBRA at different rates. Sage HRMS
prompts you to select which COBRA codes (or all) you want to use for the
report.

Note: Knowing COBRA law and how to administer it is your responsibility.
We provide you with the tools to help manage COBRA but assume no
liability.COBRA laws change and are subject to interpretation. The penalty
for not following COBRA law is severe. If you are not well versed in COBRA
requirements, please seek professional counsel.

COBRAMailing
Labels

Prepares mailing labels for COBRA recipients in three-column label format (30
labels per page). You can choose the COBRA codes to have labels.

Tip: If sheets of labels don’t move easily through your printer, try printing the
labels on regular paper, then use your copier to print them on labels.

COBRA Notification
Letter

Prints a standard COBRA notification letter. You can select employees
terminated within a specific date range. You can also specify a markup factor.
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Report name Description

COBRA Recipient
Report

Lists people receiving COBRA benefits and how long they have received these
benefits. The report includes the recipient's name, division and department,
termination reason, date of termination, number of months the individual has
received COBRA, and the number of total dependents (including the insured).

Employee Benefit
Changes

Displays changes in employee benefits. You can choose whether to include or
exclude history.

InsuranceCoverage
Detail

Displays detailed information about each employee’s insurance benefit plans. It
includes the dependents covered under each plan, when their coverage was in
effect, and the individual coverage and premium amounts for each dependent
(when applicable). The report also contains insurance plan information that is
currently not available on any other standard report. You can choose to include
or exclude waived benefit plans, as well as to include or exclude history.

Skill and education reports
These reports help you track and record the skill sets and educational background of your employees.

Report name Description

Education Report Lists education information for all employees in the selected employer.

License/Certificate Lists all licensed and certified employees in the selected employer, including
the effective dates and due dates.

Membership List Lists all employee memberships, including the effective dates and due dates.

Previous Experience Displays each employee's previous work experience, including from and to
dates and previous salaries.

Skill Retrieval Displays employees who have specific skill sets. For each skill you choose, the
report includes each employee's title, organization level, and date of hire.

Skill and Education
List

Displays an alphabetized list of individual employees, all employees, or the
reporting criteria you specify. The report includes each employee’s skills, years
of experience in each skill, and a comment area that provides short details
about each skill. The report also includes the schools attended, attendance
duration, grade point averages, and scholastic degrees earned.

Skills Report Lists skills for all employees in the selected employer, including specialized
skills such as fluency in other languages.
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Wellness reports
The information on these reports comes from the information provided on the Wellness page.

Report name Description

Blood Donor List Lists each employee's department and division, blood type, RH factor, and last
donation date. The report also provides the employee’s telephone extension.
You can choose to include only employees with specific blood types or all
employees as of a specified date.

Drug Tests Due Displays the employee's name, date of the most recent drug test, its result, the
date of the next test, the number of years since the last test, and the
employee's telephone extension.

Emergency Contacts Lists employees and their emergency contacts.

Health Profile Displays an overall view of the employee's health, which may include allergies,
chronic conditions, wellness programs, blood type and eligibility for donation
date, height, and weight.

Physical ExamsDue Displays the date of the employee's last physical exam, the result of that
physical, the date of the next physical, the number of years since the last
physical, and the employee's telephone extension.
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Chapter 3: Time Off reports

Sage HRMSTime Off includes many attendance reports that are grouped into the following categories:

l "Attendance reports" (page 20)

l "TimeOff code table reports" (page 22)

Attendance reports
These reports provide information about employee absences, Time Off details, and attendance-related
benefits.

Report name Description

Absence Averages Displays statistics on the average number of absences per employee for each
absence reason. You can specify a date range as well as show averages for
only one or all absence reason codes. You can sort by organization level or
absence reason code.

Absence Log Displays the absence reason codes for each employee along with the date,
weekday, number of hours, and comments regarding each absence. You can
select one employee or a group of employees, include one or all absence
reason codes, and specify a date range. You can sort by Employee Name or ID.

Note: The Absence Log replaces the manual attendance card.

Absence
Percentages by
Department

Displays the percentage of absences for each absence reason for each
weekday sorted by department. The % of Reason column shows the
percentages for each reason within a department for all weekdays. The % of
Company column shows the percentage of absences for each reason within
the employer. You can specify a date range. This report helps you analyze the
reason for absences within given departments.

Absence
Percentages by
Reason

Displays the percentage of absences in each department for each absence
reason code for every day of the week. The % of Org column shows the
percentage of absences for each department and every day of the week. The
% of Company column shows the percentage of absences within the employer.
You can specify a date range for the report. This report helps you compare the
departmental absences.
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Report name Description

Absence Points Lists the employees who fall within a specified range of absence points from the
threshold value established for each attendance plan. The Over column shows
the number of absence points over the threshold value. You can specify
selected employees or employee groups, a date range, and the number of
points from the threshold value. The report helps you spot employees who
exceed your employer’s threshold values.

Employee Year-To-
Date Attendance
Detail

Displays a summary of attendance information for each plan, including
carryover hours, hours accrued, hours taken, and hours available. The report
also lists absences chronologically for each plan. (If an employee has zero
hours available for a plan, the plan does not appear on the report.) You can
select specific employees, employee groups, organization levels, a date range
for the absences, and whether to include absence comments.

Employee Year-To-
Date Attendance
Totals

Displays a summary of hours accrued, taken and available as of the current
accrual date. For each employee, the report lists the totals for every attendance
plan. You can include selected employees or employee groups, organization
levels, and employees of a specific exempt status.

Employees Currently
on FMLA

Displays leave statistics for employees assigned an FMLA event who have not
yet returned to work sorted by organization level. The report includes the leave
type, the FMLA event, the date leave started, and the scheduled return date.
You can include selected employees or employee groups, organization levels,
and employees with a specific exempt status.

FMLA Due to Return Lists the employees scheduled to return from FMLA leave. The report includes
the leave type, the FMLA event, the date leave started, and the scheduled
return date. You can include selected employees or employee groups,
organization levels, and employees with a specific exempt status.

Medical
Recertification

Lists the employees due for medical recertification before returning to work
from an FMLA event sorted by organization level. The report includes the leave
type, the FMLA event, the date leave started, and the recertification date. You
can include selected employees or employee groups, organization levels, and
employees with a specific exempt status.

Perfect Attendance Lists the employees who have perfect attendance within a specified date range.
You can select one or a group of employees, organization levels, employees
with a particular exempt status, and absence transactions within a specified
date range. Time Off calculates years of service for each employee as of the
Seniority Start Date on the employee’s HR Status page.
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Report name Description

Previous Year End
Totals

Displays the carryover hours, hours accrued, hours taken, and hours available
as of the previous plan year close date for each employee and each attendance
plan. It also totals the attendance information for all plans. You can include
selected employees or employee groups, organization levels, and employees
with a particular exempt status.

Ranked List by Hours
Absent

Displays the total number of absence hours taken for each absence reason for
each employee. The report groups the information by reason code and lists the
employees within each reason code. You can include selected employees or
employee groups, organization levels, and employees with a particular exempt
status.

TimeOff code table reports
Use the following code table reports to review the codes in your code tables for Time Off. You can print the
reports before making a change to the code tables, and then print them again after the change as a
reference.

l Absence Reason Codes

l FMLA Event Reason Codes
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Chapter 4: Payroll Reports

Sage HRMS includes many payroll reports that are grouped into the following categories:

l "Bank reports" (page 23)

l "Employee Payroll reports" (page 25)

l "General Ledger reports" (page 26)

l "Government reports" (page 27)

l "Periodic processing reports" (page 29)

l "Setup Payroll reports" (page 30)

l "Transaction reports" (page 31)

Bank reports
These reports provide information to assist you in managing your company's bank accounts, setup
options, and transactions, as well as in reconciling bank accounts.

Of the transaction reports, most use landscape orientation (for both previewing and printing)—only the
Reconciliation Status and Reconciliation Posting Journal reports use portrait orientation.

Report name Description

Bank Entries Posting
Journal

(Transaction report) Lists bank entries that were posted together. The report
provides an audit trail of transactions posted using bank services by posting
sequence.

Bank Reconciliation (Transaction report) Displays the result of the last posted bank reconciliation for
each bank included in the report. The report shows the difference between the
bank statement and your company records.

Banks (Setup report) Lists the banks set up for your company, including the G/L
account and other information about each bank. Generate the report after you
add, change, or delete banks.

Check Payment
Register

(Transaction report) Lists all payments made from a particular bank account for
a specified period of time.

Deposit Register (Transaction report) Lists all deposits to a particular bank account or a range of
banks over a specified period of time.
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Report name Description

Deposits Status (Transaction report) Lists all deposits (including transfers) that are currently in
transit for the bank account being reconciled.

Distribution Codes (Setup report) Lists the account distribution codes specified for bank
transactions. Generate the report after you add, change, or delete distribution
codes.

G/L Integration (Setup report) Lists the options you selected on the Bank G/L Integration page,
including when to create G/L batches (such as during posting), how to create
G/L transactions (such as by creating a new batch), and whether to consolidate
G/L batches.

G/L Transactions (Transaction report) Lists the general ledger transactions created from all
posted transactions. The report provides an audit trail for generated general
ledger transactions.

Options (Setup report) Lists the options you selected on the Bank Options page,
including the transfer adjustment account number, the next posting sequence
number, and the next transfer number. Generate the report after bank setup
and when you change bank options.

Reconciliation
Posting Journal

(Transaction report) Provides an audit trail of all transactions posted during
bank reconciliation. The report includes checks and deposits that cleared the
bank, as well as entries that Sage HRMSPayroll created to account for clearing
differences and bank errors.

Reconciliation Status (Transaction report) Lists the status and amounts of all transactions for a bank
account.

Transaction Listing (Transaction report) Lists all transactions recorded for one bank or a range of
banks.

Transfer Posting
Journal

(Transaction report) Provides an audit trail of all transactions posted during
bank transfers. The report includes payments and deposits transferred
between banks, transfer charges, and transfer charge adjustments, as well as
tax information (optional).

Withdrawals Status (Transaction report) Lists all outstanding checks and transfers from a bank or a
range of banks.
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Employee Payroll reports
These reports include information to assist you in managing payroll for your employees.

Report name Description

Assign Employee
Earn/Ded Audit

Lists the information entered in the Assign Employee Earnings/Deductions
window.

Assign Employee
Tax Audit

(U.S. employers) Lists the Employee ID, items, and values updated through the
Assign Taxes to Employeeswindow, including the tax name, withholding
method, amount/percent, and distribution code.

Employee
Information

Lists the information entered for the selected employees in the Employees
window.

Employee Selection Lists the information entered in the Employee Selection page for the specified
selection list codes. The report includes the employee number, employee
name, pay frequency, and status.

Employee
Supplemental Info

(U.S. employers) Lists the information you entered on the Employee
Supplemental Information window.

Transaction History Lists all transactions (in detail or summary form) for employees during the
selected period.

Transaction History
Audit

Lists the transaction history information entered for employees in Transaction
History. For each transaction, the report includes the employee name and
number associated with the transaction, date and time the transaction was last
edited, transaction date, description of the transaction, and amount.

Update
Employee Earn/Ded
Audit

Lists the information that entered in theUpdate Earnings/Deductionswindow.

Update TD1 Claim
Audit

(Canadian employers) Lists old TD1 claim amounts and the newTD1 claim
amounts for all employees, sorted by employee number.

Update Employee
Taxes Audit

(U.S. employers) Generate this report after you use the Update Tax for All
Employees function to save a record.
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General Ledger reports
These reports provide you with transaction listings and status information (such as batch listings, posting
journals, source journals, and the chart of accounts).

Report name Description

Account Structures Lists the account structure codes in the selected range, description for each
code, and the segments included in each account structure, in the order they
display.

Chart of Accounts Lists all or a range of General Ledger accounts according to the selection
criteria and the sort and format criteria you specify.

Account Groups Lists account group codes, sort codes, and descriptions.

Optional Fields Lists all the optional fields set up for your General Ledger, with a separate
section for the optional fields set up for accounts and the optional fields set up
for transaction details. For each optional field, the report shows the description,
default value, whether the optional field is required, and whether the optional
field is set for automatic insertion in new accounts.

Options Lists the options selected and information entered on the G/L Options window,
including the account-number segments defined for your ledger and the
descriptions associated with those segments, and posting preferences.

Segment Codes Lists all or a range of codes defined for each G/L segment. The report includes
the code descriptions as well as the numbers and descriptions of the retained
earnings accounts to which the segment codes are closed.

Source Codes Lists a range of source codes, along with the description entered in the Source
Codes window for each code.

Tip: Source codes add flexibility to your General Ledger, because you define
them. You can select and print lists of posted transaction details by source
codes, using the Source Journal report from the G/L Reports folder.

Source Journals Lists the details of posted transactions for the source codes that included in the
source-journal definition. You can specify the sort order.
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Government reports
These reports include information required to report payroll details to the government.

Sage Payroll Tax Forms and eFiling by Aatrix services are included with Sage HRMSPayroll for many of
the government reports. Sage Payroll Tax Forms and eFiling by Aatrix enables you to file tax forms
electronically from a Sage client workstation.

U.S. government reports

Report name Description

Federal Tax Filing When you select this report, a window opens so you can select the federal form
(such as form 940, 941, 943, 944, 945, 1095, 1-9, and W-4.

State Tax Filing When you select this report, a window opens so you can select a tax form
specific to your state. The tax forms are kept up to date by the Sage Payroll Tax
Forms and eFiling by Aatrix service. If you are prompted to update tax forms
after clicking the Display button, follow the prompts to update; otherwise the tax
forms may not include the latest state requirements.

W-2 Forms Use to save or print employee W-2 data to a paper report or e-file the W-2
forms using the Sage Payroll Tax Forms and eFiling by Aatrix service.

Canadian government reports

Report name Description

CRA Remittance
Info

Displays the remittance information required by Canada Revenue Agency (CRA)
for the selected check date range, and for employees selected by employee range
and/or selection list. The report shows earnings subject to tax, employee
withholding and employer contributions for EI and CPP, and employee withholding
for income tax, sorted by the account number (tax reporting ID) of the employment
insurance rate assigned to each employee.
You select one of the following for Report Type:

l Summary: prints only the totals for each EI tax reporting ID and report totals,
for the selected employees.

l Detail: provides the information in the date range for each employee, totals
for each EI tax reporting ID, and report totals.
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Report name Description

Ministère du
Revenu Info

Displays the remittance information required by Revenu Québec for the selected
check date range, and for employees selected by employee range and/or
selection list. The report shows earnings subject to tax, employee withholding and
employer contributions for EI and QPP, employer contributions for QHSF, and
employee withholding for federal and provincial income taxes, sorted by the
account number (tax reporting ID) of the employment insurance rate assigned to
each employee.
You select one of the following for Report Type:

l Summary: prints only the totals for each EI tax reporting ID and report totals,
for the selected employees.

l Detail: provides the information in the date range for each employee, totals
for each EI tax reporting ID, and report totals.

R1s Electronic
Filing

Generates a file with Relevé 1 information for the specified year that you can
submit to Revenu Québec.

Record of
Employment

Displays the information for an employee who stops working in insurable
employment. ThisRecord of Employment (ROE) report is used by Service
Canada to determine whether the person is eligible to receive EI benefits, what the
benefit amount will be, and for how long the benefits will be paid.
This report includes information from Payroll’s online RecordOf Employment
window, and the EI information maintained by Payroll. On the RecordOf
Employment window, enter the ROE information for the 53-week reporting format
if you plan to use the ROEWeb function; you can then generate an ROE file to
submit electronically (by Internet) to Service Canada’s ROEWeb application.

Relevé 1s Displays the Relevé 1s by year, formatted as required by Revenu Québec.
To review employees that may be out of balance based on expected CPP/QPP
and EI contributions, open the T4s selection from Government Reports and select
the Print CPP/QPP and EI Balancing Report option.

T4s When you select this report, you can select either:

l T4s, which you can print or save by year, formatted as required by the
Canada Revenue Agency (CRA).

l CPP/QPP and EI Balancing report, which is for your review; it lists employees
that may be out of balance based on expected CPP/QPP and EI
contributions.

Note: The payroll program supports many but not all "Other Information" boxes
on the T4 and T4A.

28Sage HRMS HR and Payroll Reports Catalog



Report name Description

T4s Electronic
Filing

Generates a file with T4 information (including the T4 Summary) for the specified
year that you can submit to the Canada Revenue Agency (CRA).

T4As Sage HRMSPayroll prints the information on the T4A for the selected year
required by Canada Revenue Agency (CRA). Follow the instructions in your tax
update package to install the tax update and print T4As.

Note: The payroll program supports printing "Other Information" on the T4A, but
only in a single box containing the total of all "Other Information" earnings for an
employee. To enter multiple "Other Information" earnings, clear the Print Total
Amount option on the T4As page before printing, and manually enter the
amounts on the T4A.

T4As Electronic
Filing

Generates a file with T4A information (including the T4A Summary) for the
specified year that you can submit to the Canada Revenue Agency (CRA).

Sage Payroll Tax Forms and eFiling by Aatrix
The Sage Payroll Tax Forms and eFiling by Aatrix feature is included with Sage HRMSPayroll.

Sage Payroll Tax Forms and eFiling by Aatrix enables you to file more than 250 state, provincial, and
federal withholding, unemployment, and new hire reports from the data produced by Sage HRMSPayroll.
You can print and mail the tax forms or eFile them. You can also email the forms to your employees using
the Sage Payroll Tax Forms and eFiling by Aatrix interface. To ensure legislative compliance, you are
prompted every quarter to download and install updated forms.

For a detailed overview, FAQs, and price structure of the Sage Payroll Tax Forms and eFiling by Aatrix
options, visit: http://partner.aatrix.com/sagehrms

Periodic processing reports
These reports provide transaction listings and status information for specific tasks in Sage HRMS (such as
batch listings, posting journals, source journals, and the chart of accounts).

Report name Description

Delete Inactive
Records Audit

Displays the information deleted using the Delete Inactive Records payroll task.

Duplicate SSN/SIN Lists social security numbers (SSNs) or social insurance numbers (SINs) that
are assigned to more than one employee, if applicable.
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Setup Payroll reports
These reports enable you to review the information you entered when setting up payroll features in Sage
HRMSPayroll.

Report name Description

Class Codes Lists the information entered for Class 1,Class 2,Class 3, andClass 4 on the
Class Codes page including the class codes and descriptions assigned to each
class.

Common Deduction
Limits

Lists details entered in theCommon Deduction Limitswindow, such as the
deduction, description, employee annual maximum, and employer annual
maximum.

Earnings and
Deductions

Lists the information set up for accruals, advances, benefits, deductions,
earnings, or expense reimbursements. The report must be generated for one
earning/deduction category at a time.

EFT Combine Lists the companies entered on the EFT Combine page.

EFT Options Generate this report after setting up your EFT (direct deposit) options or
whenever you want to verify the setup of the banks you use for direct deposit.
This report lists the information entered on the EFT Options page.

G/L Integration Generate this report to verify the information entered on theG/L Integration
page.

Optional Fields Generate this report after setting up optional fields or whenever you want to
verify the optional fields that were set up.

Options Lists the information entered on the Payroll Setup Optionswindow, including the
years of history to keep, pay periods per year, hours per pay frequencies for
each pay frequency, and integration options.

Overtime Schedules Lists the information entered for the selected overtime schedules on the
Overtime Schedules page.

Shift Differential
Schedules

Lists the information entered for the selected shift differential schedules on the
Shift Differential Schedules page, including shift differential rates for Shift 1,
Shift 2, Shift 3, and Shift 4.

30Sage HRMS HR and Payroll Reports Catalog



Report name Description

Update Local Taxes
Audit

(U.S. employers) Logs all changesmade to the Local/Other Tax Codeswindow.
The report includes the date and type of each change, if the tax setup is new or
wasmodified, and the new value of each change if applicable). After it is printed,
the audit report clears.

Work Classification
Codes

Generate this report after setting up or modifying work classification codes.

Workers'
Compensation
Codes

Lists the information entered for the workers' compensation groups and codes
on theWorkers' CompensationCodes page, including the workers'
compensation group, codes, descriptions, and rates (current and previous).

Transaction reports
These reports enable you to review a variety of payroll information such as employee earnings and hours
and electronic funds transfer (EFT or direct deposit) transactions.

Report name Description

Accruals Displays posted paychecks and entries made in transaction history. You can
choose to display the hours and amounts that have been accrued and paid—or
as an accrual carry-over log that displays the accrual amounts or hours that
were carried over to the start of a new accrual period.

Earnings and Hours Displays employee hours and totals as well as other information based on the
report options you select.

Earnings/Deductions
Summary

Displays earning/deduction codes and their descriptions, as well as other
information based on the report options you select.

Earns/Deds
Summary for T4A/R2

(Canadian employers) Lists employees who are assigned earnings and
deductions with T4A and/or R2 (Releve 2) Reporting settings. The report
summarizes amounts for each earning and deduction.

EFT Combine
History

Lists the EFT combine files created after using the Combine EFT File process.

EFT Direct Deposit Lists the details of the most recently generated EFT file. Generate this report
before you submit the file to your bank.

31Sage HRMS HR and Payroll Reports Catalog



Report name Description

EFT Transactions Displays the details of paychecks that were directly deposited. This report
includes information about each direct deposit transaction, such as the
employee’s number and name, bank account information, paycheck number,
and amount deposited.

Employee Timecards Lists employee timecards. Use this report to ensure the timecards are complete
and accurate before you calculate payroll.

Hours Analysis Displays the hours (regular, overtime, shift) that were paid for each earning on
an employee’s paycheck as well as the hours that were paid and accrued for
each accrual on the paycheck.

Payroll G/L
Transactions

Generate this report before using Create G/L Batch. This report includes only
G/L transactions created on request using Create G/L Batch; it does not include
G/L transactions created during payroll posting.

Payroll Processing
Exceptions

Lists error conditions that Sage HRMSPayroll encounters during processing.

Payroll Register Lists payroll information for calculated payroll, including the check date,
amounts of the checks, calculation sequence, posting sequence, employee
numbers, names, social security numbers/social insurance numbers, times
late, employee earnings/deductions and tax lists.

Pre-Check Payroll
Register

Generate this report to review the payroll register before generating checks.

Tax Calculation
Analysis

Generate this report to review tax information and totals by employee. The
information displayed depends on the report style you choose.

Timecards Generate this report to review employee timecard information. This report
includes employee numbers, names, timecard numbers, descriptions,
statuses, earning/deduction information entered for the pay period, tax
overrides for the pay period, total hours for regular and shift earnings, total
amounts for vacation, sick, and compensatory or banked time paid.

Workers'
Compensation

Generate this report to review workers' compensation information. The report
includes worker's compensation group, code, description, rate, employee total
pay, excess earnings, assessable earnings, worker's compensation code
totals, and company totals. The format depends on the report style you choose.

32Sage HRMS HR and Payroll Reports Catalog



Chapter 5: Training reports

Sage HRMSTrain includes many training reports that are grouped into the following categories:

l "Catalogs and code table reports" (page 33)

l "Class administration reports" (page 34)

l "Employee training reports" (page 35)

l "Training analysis reports" (page 36)

Catalogs and code table reports
Use the following code table reports to review the codes in your code tables for Sage HRMSTrain. You can
print the reports before making a change to the code tables, and then print them again after the change as
a reference.

l CertificationCodes

l Class Ratings

l CourseCatalog

l Course Types

l Enrollment Status Codes

l Instructor Catalog

l Instructor Ratings

l Job Codes

l Job Requirements

l Organization Codes

l Priority Codes

l State / Province Codes

l Training Locations

l Training Programs

l User-Defined Codes
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Class administration reports
These reports provide information so you can track classes and participants as well as generate class
enrollment and completion letters.

Report name Description

Class Completion
Letters

PrintsClass Completion Letters for all employees who completed the selected
class or group of classes.
Each letter prints on a separate page and can include the following letter
sections:
Enterprise Logo, Enterprise Name, Current Date, Employee Information,
Greeting, Introduction,Class Information, and Closing.
You can include or exclude any of these sections or change their content by
using the EditClass Correspondence task. You can choose to only include
employees with a particular enrollment status.

Class Enrollment
Letters

PrintsClass Enrollment Letters for all employees who enrolled in the selected
class or group of classes.
Each letter prints on a separate page and can include the following letter
sections:
Enterprise Logo, Enterprise Name, Current Date, Employee Information,
Greeting, Introduction,Class Information, and Closing.
You can include or exclude any of these sections or change their content by
using the EditClass Correspondence task. You can choose to only include
employees with a particular enrollment status.

Class Rosters Lists the employees on the class rosters of selected classes. The report is
sorted by class start date and class ID number. Within each class, the
employees are sorted by enrollment status and last name. You can choose to
only include employees with a specific enrollment status.

Class Schedules Lists the classes that are in progress or scheduled to begin during a specified
time period. You can also include classes that were completed or were
canceled. The report is sorted by class start date.

Mailing Labels Prints mailing labels for employees who enrolled in a selected class or group of
classes. You can choose to only include employees with a particular enrollment
status. The report is formatted for label sheets with 30 labels per page (three
columns of 10 labels each). If you print labels for more than one class, the
labels for each class begin on a new sheet.
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Report name Description

Overbooked Classes Lists the classes that have more employees enrolled than the class's maximum
capacity. The report is sorted by class start date.

Participants Training
History

Summarizes the courses already taken and courses scheduled for each
employee enrolled in a specific class. If you select more than one class, a
separate report is printed for each class. You can choose to only include
employees with a particular enrollment status. If an employee's status in a class
is Completed, their grade (if any) displays in the Grade column; otherwise, their
enrollment status displays.

Employee training reports
These reports provide information so you can track completed and required courses, training programs,
and certifications for all employees as well as training expenses and tuition reimbursements.

Report name Description

Employee
Certifications

Lists the certifications received or required for a selected group of employees.
The report is sorted by employee last name. Within each employee group, the
certifications are sorted by date required, with the earliest certifications listed
first.

Employee List Lists the employees by last name. You can also choose to include non-
employees. The report includes their titles and organization levels, if applicable.

Employee Required
Courses

Lists the courses that employees must complete over a specified time period.
For each employee, the classes are sorted by priority, with courses that are
most important and that must be completed soonest listed first. The report also
displays the date by which they must be completed.

Employee Training
Profile

Lists the courses an employee completed as well as courses that still need to
be taken. It is a combination of the Training History by Employee and Employee
Required Courses reports. If an employee’s status in a course is Completed,
their grade (if any) displays in the Grade column; otherwise, their enrollment
status displays.

Employee Training
Programs

Lists the training programs that employees completed over a specified period.
You can also include programs that are in progress—the report then shows
courses completed and courses still remaining within each program.
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Report name Description

Employees with a
Certification

Lists the employees who received or require a certification. The report is sorted
by certification group. Within each certification group, you can choose to sort by
employee name or by expiration date. You can include all certifications or only a
specific certification.

Training Expenses by
Employee

Lists the expenses associated with courses completed by an employee during
a specified period of time. You can also include courses that are scheduled but
not yet completed. If an employee’s status in a course is Completed, their grade
(if any) displays in the Grade column; otherwise, their enrollment status
displays.

Training History by
Employee

Lists the courses completed by an employee over a specified period of time.
You can also include courses that are scheduled but not yet completed. If an
employee’s status in a course is Completed, their grade (if any) displays in the
Grade column; otherwise, their enrollment status displays.

Training Schedules
by Employee

Lists the courses that are in progress or scheduled to begin over a specified
period of time. You can also include courses that are already completed.

Tuition
Reimbursements

Lists the tuition reimbursements an employee received or requested over a
specified period of time. The report is sorted by employee last name. Within
each employee listing, courses completed most recently are listed first. You can
select to include all courses, only those of a particular type, or only those with a
particular status. If an employee’s status in a course is Completed, their grade
(if any) displays in the Grade column; otherwise, their enrollment status
displays.

Training analysis reports
These reports provide information so you can track course fees and expenses, class attendance, class
utilization, and class ratings.

Report name Description

Class Attendance
Summary

Summarizes attendance totals for all classes offered over a period of time,
grouped by course code. The report also includes the percentage of people
that did not show up for class, the percentage that canceled, and the
percentage of available class space that was used.
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Report name Description

Class Financial
Summary

Summarizes financial information for all classes offered over a period of time.
Only classes with a status of Completed are included in the report. The report
compares budgeted costs with actual costs—and total fees with actual costs.
The Cost Per Student represents the additional cost per student (beyond fixed
costs) and is calculated by subtracting the Average Fixed Costs from the
Average Actual Costs and then dividing by the Average Attendance. The
Breakeven Fee is an estimate of the fee that should be charged to recover the
total class costs and is calculated by dividing the Average Fixed Costs by the
Average Attendance and then adding the Cost Per Student.

Expenses byCourse Displays the expenses for all courses taken over a period of time, grouped by
course code. You can choose to display just the total expenses for each course
code or to display the records for each course taken during the specified
period. You can select to include employees with a particular enrollment status.

Expenses by Job Title Displays the expenses for all courses taken over a period of time, grouped by
job title. You can choose to display just the total expenses for each job title or to
display the records for each course taken during the specified period. You can
select to include employees with a particular enrollment status.

Expenses byOrg
Level

Displays the expenses for all courses taken over a period of time, grouped by
organization level. You can choose to display just the total expenses for each
organization level or to display the records for each course taken during the
specified period. You can select to include employees with a particular
enrollment status.

Training Exception Lists employees that need to take a specific course or specific courses. The
report is sorted by course code. Within each course code, you can select to sort
employees by name or by priority, in which case employees to whom the
course is most important and who need to complete it the soonest are listed
first. You can also select to include employees who are already scheduled to
take the course. Use this report to determine which employees need training.

Training History by
Course

Lists employees that completed a specific course or are scheduled to complete
a course. You can also select to include a number of courses, in which case the
report is sorted by course code and all employees that have completed the
course are grouped together. You can select to include employees with a
particular enrollment status. If an employee’s status in a course is Completed,
their grade (if any) displays in the Grade column; otherwise, their enrollment
status displays. You can also select a specific date range.

37Sage HRMS HR and Payroll Reports Catalog



Chapter 6: System reports

System reports are provided to help you manage your Sage HRMS database, security, reporting, and the
entire system.

Audit trail reports
Sage HRMS provides an audit trail so you can track the changes data entry personnel made to the system
databases. For each user who makes changes to Sage HRMS data, the audit trail records the employee
number, the date and time, the type of change, and the new and old values of the affected data.

Note: The audit trail only tracks changes made to employees. It does not track changes to rules or setup
activities.

To access audit trail reports:

1. Select Reports > System >Audit Trail Reports.

2. In the report options window, you can select to include specific files, fields, users, or employees as
well as to specify a date range. You can also specify your own criteria to determine the content of the
report.

There are three audit trail reports.

Report name Description

Audit Trail by Date Lists audit trail records sorted by the date the changes were made.

Audit Trail by
File/Field

Lists audit trail records sorted by the files and fields that changed.

Audit Trail byUser Lists audit trail records sorted by the users who made the changes.
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Data Dictionary reports
The Data Dictionary is a collection of names and descriptions for the Sage HRMS system database
tables, where all of your company and employee information is stored. Use the Data Dictionary reports to
obtain the most recent version of the database structure in the software. After you have the database
tables and structure identified, you can use this information to build custom reports.

To run Data Dictionary reports:

1. Select Reports > System >Data Dictionary Reports.

2. In the Data Dictionary Reports window, select one of the following options:

l Files List to print a list of database files.

l Fields List to print a list of all the fields within each database file.

l Index Keys to print a list of the index keys.

3. Select the products you want to appear on the report by selecting the appropriate check boxes.

4. Click Preview to preview the report. Then, click the Close button to close the preview window.

5. Click Print to print the report.

6. Click the Close button to close the Data Dictionary Reports window.

Using functions in reports
Functions can be used to manipulate data in Sage HRMS reports. All field names beginning with an
underscore are functions. You can use them rather than the standard field names when creating custom
reports by simply selecting a field name beginning with an underscore.

For example, if you insert the field name _SEX, your report will display the field description of Male,
Female, or Unknown for an employee’s gender. If you insert the field name P_SEX, your report will display
the code M, F, or U instead. Some of the functions (field names beginning with an underscore) do more
than display a description rather than its code. The function _NAME1 displays the employee’s name as:
Last, First Middle.

Note:When you set up your organization levels, you provide a title for each level (such as Level1 =
Division) and then define the Organization Code tables (codes and descriptions) for each level. If you
want the description for an organization in a level (Accounting) to appear on your report rather than the
code (ACCTG), select the related field name that begins with an underscore (_LEVEL1).
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Chapter 7: Using the standard reports

Sage HRMS provides dozens of preformatted reports designed to meet virtually any reporting need. With
the standard reports, you can:

l Preview reports on your monitor.

l Print reports to your printer.

l Export reports to a file for use by other software applications.

Note: You can also create your own original reports using SAPCrystal Reports. Refer to the Crystal
Reports online Help for detailed instructions.

Generating reports
To generate a report:

1. Select Reports, then in the Employees, Canadian Employees, Time Off, Payroll, Canadian Payroll,
Training, or System section, select the report category.

2. The Report List tab of the Reports page lists the reports in the selected category. Highlight the report
you want to generate.

Sage HRMS displays the name of the report selected below the tab.

3. On the Standard Criteria and Specific Criteria tabs, define the criteria for the report.

For example, to sort the Employee Profile report by employee number rather than employee name,
you can choose Employee Number for Sort by on the Specific Criteria tab.

You can also use criteria to limit the data appearing on a report. If you do not limit the data, the report
includes all the data.

4. Click Print, Preview, or Export to print, preview, or export the report.

40Sage HRMS HR and Payroll Reports Catalog



Defining report criteria

When you select a report, Sage HRMS provides various criteria you can use to generate the report. The
information on the tabs of the Reports window enable you to tailor the output of your report. Using sorting
options and selection criteria, you can produce a variety of different reports to meet your specific needs.
You can:

l Use standard selection criteria, such as employer, organization levels, and exempt status.

l Enter your own criteria to select information to include in the report.

l Select specific employees to include in the report.

l Select report-specific options including the effective date or date range, a grouping by organization
level, a sort order by employee name or ID, or form alignment options.

l Save default report options for the next time you use the same report.

Note: After you generate a report by printing, previewing, or exporting it, Sage HRMS saves your
selection criteria. The next time you select that report, the saved selection criteria displays, but you can
always change it as needed for your new report.

Report List tab

Item Description

<report list> Highlight the name of the report that you want to generate.

Print Range Select either:

l All to print all pages of the report.

l Page and then enter the first and last page numbers of the range of
pages to print.

Restore Defaults Click to return to the last settings you saved.

Save Defaults Click to save the current report options for future use. The next time you choose
this report, these settings are already selected for you. This feature comes in
handy when you frequently generate a particular report.
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Standard Criteria tab

This tab lists general selection criteria that apply to all reports in a report group. Use the selection criteria to
determine which employees to include in the report. Not all of the following items are available for all
reports.

Item Description

Employer Choose one of the following:

l Enterprise to include all employees in all the employers you have set up in
Sage HRMS.

l An individual employer to include only the employees with that employer.

l Multiple to include the employees in more than one employer. Another
window opens so you can highlight each employer that you want to
include in the Available list, click Select > to move that employer to the
Selected list, and then click OK.

<organization levels> You can limit the report to employees who only belong to one group at a
particular organization.

Note: The number of organization levels (1-5) and names of the levels were
defined when the Enterprise was set up. The organization descriptions
included in the list for each level depend on two factors: the Employer
selection and how the organizations were set up. If you see duplicate entries
in the list, this means you set up different organization codes at the employer
level, but the descriptions you set up for the codes are the same. If you
change your employer selection, Sage HRMS clears all organization levels.
You can then reselect your organization levels

Changed Since (Certain reports) You can limit the report to include only employees whose
information changed since a specific date.

<course options> (Certain Training reports) Select from options such as the course type, class
description, certification, instructor, location, and date range.
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Item Description

Employee Select the Active, LOA (leave of absense), and/or Terminated check boxes to
include employees with those statuses in the report.
You can also click one of the following buttons to limit the employees included in
the report:

(the Employee Find button) to find a particular employee.

(the Multiple button) to select multiple employees.

(the Undo button) to remove the employee selections.

For more information, see "Selecting specific employees for a report" (page
44).

Individual Classes (Certain Training reports) Select the Open, In Progress, Completed, and/or
Canceled check boxes to include classes with those statuses in the report.
You can also click one of the following buttons to limit the classes included in the
report:

(the Class Find button) to find a particular class.

(the Multiple button) to select multiple classes.

(the Undo button) to remove the class selections.

Custom Criteria To generate reports using criteria other than what is already provided in Sage
HRMS's standard selection criteria, use the Custom Criteria function. Select
one of the following methods to use:

l Custom Criteria Table

l Custom Criteria Builder

l Visual FoxPro Expression Builder

For more information, see "Defining custom criteria" (page 45).

Exempt You can limit the report to include only employees with the Exempt or
Nonexempt overtime exempt status. If you leave this item blank, the report
includes both exempt and nonexempt employees.

Class Status (Certain Training reports) You can limit the report to classes with a status of
Open, In Progress, Completed, or Canceled.

Specific Criteria tab

This tab lists options for the specific report you selected. The options on this tab vary from report to report
within the report category you selected. Some examples of options are a date range, sort order, and
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effective date.

Selecting specific employees for a report
To further limit your report results, you can select specific employees within the employers you selected.
Using the buttons adjacent to Employee, specify which employees you want to select.

If you use Sage HRMSTrain, you can also use the buttons to specify which courses or classes you want to
include, depending on the type of training report you are running. For example, you can select classes for
Class Administration reports and courses for most Training Analysis reports.

Selecting one employee

1. Click (the Employee Find button).

2. In the Employee Find window, find and select the employee you want to include.

3. Click OK.

After you find the employee, Sage HRMS displays the selected employee's name, employee
number, and employer ID below Employee on the Standard Criteria tab.

Note:When you select one employee, Sage HRMS disables all other selection criteria. If you want to

cancel your employee selection, click (the Undo button) to re-enable all selection criteria.

Selecting multiple employees

1. Click (the Multiple button).

2. On the Select Employees page, the Available list includes all employees in the employers selected—
and displays each employee's name, number, and employer ID. If you already selected a single
employee, he/she automatically appears in the list of selected employees. Double-click to select an
employee name and move it to the Selected list. (Similarly, double-click an employee name in the
Selected list to move him/her back to the Available list.)

3. After selecting all employees to include in the report, click OK.

Note:When you select multiple employees, Sage HRMS disables all other selection criteria. To

cancel your multiple employee selection, click (the Undo button) to re-enable all selection

criteria.

Points to consider when selecting specific employees

When you are defining your report selection criteria by selecting employers, organization codes, and
specific employees, note that if you already selected the employer or organization codes and then attempt
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to select a specific employee, you might receive a message that there are no employees matching your
selection. This is because the employee you tried to select does not belong to the employer or the selected
organization codes.

If you want to run the report for a specific employee, select blank for all your organization codes and then
select the employee.

Selecting employees by employee status

Each employee you enter in Sage HRMS has an employee status.

When you generate a report, you can include employees who have an employee status of Active, LOA
(leave of absense), or Terminated by selecting the appropriate check boxes on the Standard Criteria tab.

When you run reports in Sage HRMSTrain, you can select employees who are Active, Terminated, on
LOA (leave of absense), and Non-Employees.

Defining custom criteria
Use the Custom Criteria function to generate reports using criteria other than what is already provided in
the Sage HRMS standard selection criteria.

Note:When you use any custom criteria, Sage HRMS disables all other selection criteria. To clear your
custom criteria selection, select the blank option from the Custom Criteria list on the Standard Criteria
tab.
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About the Custom Criteria Table

When you create expressions that define specific criteria for selecting employees, you can have Sage
HRMS store these expressions in the Criteria Code table. When you set up options for your reports, you
can choose a criteria code from (or add a new one to) the Criteria Code table. Sage HRMS then generates
the report according to the expression set up for the criteria code you selected.

Tip: If the expression you want to create is one you will be using more than once, add it to your Criteria
Code tables so it will be available for you to select any time you need it.

To select an existing criteria code

1. On the Standard Criteria tab, select Custom Criteria Table in the Custom Criteria list.

2. The Custom Criteria Table page opens and lists the criteria codes from your Criteria Code Table.
Highlight the code you want to use.

Note: If you did not define any criteria codes, only the Add NewCode selection appears in the
Criteria Table window.

3. Click OK.

The expression appears for Custom Criteria on the Standard Criteria tab.

To add a new criteria code

1. On the Standard Criteria tab, select Custom Criteria Table in the Custom Criteria list.

2. On the Custom CriteriaTable page , click Add NewCode and then click OK.

3. On the (New) Criteria Table page, enter a description for your criteria, and then click OK.

4. In the Expression Builder window, create the expression.

For example, to generate a report for only seasonal workers, select the P_SEASONAL field from
the Pe (Employee Personnel) database table and set it equal to (Y)es.

5. When you complete the expression, click OK.

The expression displays for Custom Criteria on the Standard Criteria tab.

In the example, Sage HRMS uses the expression to generate a report that only includes seasonal
employees.
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Using the Custom Criteria Builder

You can use the Sage HRMSCriteria Builder to build expressions for your selection criteria and save
them to your Criteria Code table.

Note:With the Criteria Builder, you can only create an expression with fields from the Employee
Personnel (HRPERSNL) database. If you need to build an expression with fields from a database other
than HRPERSNL, you must use the Visual FoxPro Expression Builder.

To create an expression with the Criteria Builder

1. On the Standard Criteria tab, select Custom Criteria Builder in the Custom Criteria list.

2. On the Criteria Builder page:

a. Make a selection in the Field list.

b. In the Relationship list, select a relationship expression.

c. For Value, type the value that you want to select for that field.

For example, if you want to limit the report to employees whose Job Title is Production
Manager, select Job Title for Field, select Equal To for Relationship, and type Production
Managers for Value.

3. If you need to define another criteria:

a. Click the And button. The first part of the expression appears in the window.

b. Repeat step 2.

For example, if you want to also limit the report to Production Managers who started their job
on or after 01/01/17, select Job Start Date for Field, select Greater Than or Equal To for
Relationship, and type 01/01/17 for Value.

Note: If you want to delete all the criteria you defined and start over, click Reset. If you want to
delete one criteria at a time (from the last to the first), click Undo.

4. When you finish defining the expression, click the Done button.

The page now shows the complete expression.

5. To save the expression to your Criteria Table:

a. Click the Save To Criteria Table button.

b. In the Criteria Table window, type a description for your new expression.

47Sage HRMS HR and Payroll Reports Catalog



c. Click OK.

6. To save and select the expression, click OK.

The expression displays for Custom Criteria on the Standard Criteria tab.

Using the Visual FoxPro Expression Builder

You can access the Visual FoxPro Expression Builder any time you need to create an expression for your
custom criteria.

1. On the Standard Criteria tab, select Visual FoxPro Expression Builder in the Custom Criteria list.

2. In the Expression Builder window, build your expression. For detailed instructions for using the
Expression Builder, see Using the Expression Builder.

3. When you finish defining the expression, click OK.

Your expression is then available from the Custom Criteria list on the Standard Criteria tab when you
generate reports within the selected report category.

Tip: If you only need to use fields from the Employee Personnel database (HRPERSNL) in your
expression, consider using the Criteria Builder instead. However, if you need to build an expression
with fields from any database other than HRPERSNL, you must use the Visual FoxPro Expression
Builder.

Printing, previewing, or exporting a report
After you specify the standard and specific selection criteria in the Report window, generate your report by
choosing:

l Preview to view it on the monitor

l Print to send it to your printer

l Export to export it to a file on the server

When you preview or print a report, the title of the report appears at the top of each page of the report. The
date and time the report was generated appear at the bottom of each page, along with a sequential page
number. Report totals and other control numbers also appear at the end of most reports.

Reports are formatted for standard 8.5-by-11-inch paper with a half-inch margin on all sides.
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Previewing a report

When you click Preview, a preview window opens on your monitor and displays the report. The top of the
preview window contains the page preview toolbar, which enables you to enlarge your view, scroll through
the report, and print the report. You can see each toolbar button name when you hover the cursor over the
button.

The following table describes the buttons on the page preview toolbar.

Button Action

Click the First Page button to display the first page of the report. This button is disabled if
you are previewing the first page of the report.

Click the Previous Page button to display the previous page of the report. This button is
disabled if you are previewing the first page of the report.

Click theGo To Page button to select a specific report page to display. Enter the page
number in theGo To Pagewindow and clickOK.

Click theNext Page button to display the next page of the report. This button is disabled if
you are previewing the last page of the report.

Click the Last Page button to display the last page of the report. This button is disabled if
you are previewing the last page of the report.

Use the Zoom control to choose six different magnifications.

Tip: You can also click your cursor anywhere in the preview window to zoom in or out on
a particular area of the report. When you zoom, your cursor changes to a magnifying
glass.

Click the Close Preview button to close the preview window and return to the Report
window.

Tip: You can also click in the report title bar to close the preview window.

Click the Print Report button to print the report.
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Printing a report

When you click Print in the Report window, the Print window opens. You then select the printer and options
such as a page range and number of copies.

If you have a PDF driver installed, you can create a PDF version of the report and then send it as an
email attachment.

Exporting a report to a file

You can export or save your report to a file so you can use it in a variety of different applications, such as
Microsoft Excel, or submit it electronically. To export the report to a file:

1. Click Export.

2. On the File Export Options page for File Type, select the file format to use from the list. Certain
reports, such as a Veterans Employment report, defaults to the Electronic Submission format.

3. For File Name, type one to eight characters for the file name. (The file extension automatically fills in
based on the File Type you selected.)

4. Click Export.

5. An information window appears showing the location of the exported file. Click OK.

Sage HRMS exports the file to the ..\Sage\SageHRMSServer\Data\Export directory on the server.
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Chapter 8: Custom reporting with SAP
Crystal Reports

SAPCrystal Reports is a desktop query and reporting application that offers powerful data analysis
capabilities. You can use SAPCrystal Reports to create your own unique customized reports or use
templates created by other Sage HRMS users and specialists. You can produce a variety of presentation-
quality reports with a minimum amount of effort. To create your own custom reports, see the SAPCrystal
Reports online Help for detailed instructions.

You can add new report groups containing any custom reports created in SAPCrystal Reports to the
ReportsMenu and order the items in these groups to suit your specific needs.

Sage HRMS is shipped with dozens of custom reports that were created with SAPCrystal Reports. Custom
reports are grouped into the following categories:

l "CustomHR reports" (page 55)

l "CustomTimeOff reports" (page 62)

l "CustomTraining reports" (page 63)

These custom reports can be used as they are or you can utilize SAPCrystal ReportsDesigner to modify
them to suit your employer's needs.

Note: Sage HRMSPayroll database tables and fields are available in Data Dictionary Reports and
using the Abra Data Access Driver. Contact Sage Professional Services or a certified channel partner for
help creating custom reports specific for payroll.

Creating a custom report
To walk you through the basic steps involved in creating a custom report using SAPCrystal Reports, we will
use an example. When you want to create more complex reports, see the SAPCrystal Reports online Help
for detailed instructions.

Note:We recommend creating a sub-report for each multi-record database you add to the same report.

The example report you will create will be an Employee Original Hire Date List report that retrieves the
following information: employee first name, employee last name, and original hire date.
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If you are creating a custom report for the first time, you must specify Abra HRMS Data Access as the data
source. See the in-product Help for detailed information about Abra HRMS Data Access.

To create a custom report

1. Select Connected Services > Sage HRMS Tools > Crystal Reports to launch SAPCrystal Reports.

2. In the Welcome to Crystal Reports window, select Blank Report and click OK.

3. In the Database Expert window:

a. Click the plus sign to expand Favorites.

b. Click the plus sign to expand Abra HRMS Data Access.

c. Scroll through the list until you find the tables you want to include in the report and click once
to highlight the tables.
For this example, highlight HRPERSNL.

d. Click Add to add a check mark to the tables you selected for the report.

4. When you finish selecting the tables you need for the report, click Close.

The report opens in Design mode with the Field Explorer window visible.

To add a report title

1. In the SAPCrystal Reports main menu, select Insert > Text Object.

2. The text object appears as a floating object. Drag it to the location on the report and click once to
anchor it in place.
For this example, drag it to the upper right hand corner of the PageHeader band line.

3. Double-click in the text object and type the report name.
For this example, type Employee Original Hire Date List.

4. Drag your cursor over the title to highlight the text.

5. In the main menu, select Format > Font.

6. In the Text Format window for Size, select 14 and click OK.

7. If you need to expand the text object to accommodate the larger text:

a. Move your cursor anywhere inside the text object and click once to highlight the text box and
display the crosshairs cursor.

b. Move the cursor to the right border of the text object until it changes to a left/right arrow.

c. Click and drag the cursor to resize the text object.
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To add column headings

1. In the SAPCrystal Reports main menu, select Insert > Text Object.

2. The text object appears as a floating object. Drag it to the location on the report and click once to
anchor it in place.
For this example, drag it to the lower left most position of the PageHeader band line for the first
column.

3. Double-click in the text object and type the report text.
For this example, type Employee Name.

4. Drag your cursor over the title to highlight the text.

5. In the main menu, select Format > Font.

6. In the Text Format window for Style, select Bold and click OK.

7. Repeat steps 1 through 6 to create additional column headings.
For this example, create a column heading for Original Hire Date, placing the column heading in
center of the PageHeader.

To add the data

1. In the SAPCrystal Reports main menu, select Insert > FieldObject.

2. In the Field Explorer window:

a. Click the plus sign to expand Database Fields and HRPERSNL.

b. Left-click and drag a field to the desired location on the report.
For this example, drag p_fname to the left most position of the Details band line, which will
insert the employee's first name on the report.

3. In the main menu, select Format > Font.

4. In the Text Format window for Size, select 8 and click OK.

5. Repeat steps 1 through 4 to add the other fields.
For this example, add the employee's last name using p_lname and date of birth using p_orighire.

To format the report

1. Place your cursor over the separation line between the PageHeader band line and the Details band
line. The cursor changes to an up and down arrow.

2. Click once and drag the separation line down about 1/8 inch.

3. In the main menu, select Insert > Line. The cursor changes to a pencil.

4. Place the cursor on the PageHeader band line under the Employee Name column heading.

5. Hold down the left mouse button and draw a line from the left side of the report to the right side of the
report.
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6. Right click on the line and select Format Line.

7. In the Format Editor window, change the width to the widest option and click OK.

8. Repeat steps 1 through 7 to add a line to the Page Footer.

9. In the main menu, select File > Save As and save the report.

10. In the main menu, select File > Print Preview to see the result.

To add a table

If the report contains data from two or more database files, the database files must be linked. You use a
field that is common to both databases to link the database files so records from one database match with
related records from the other database.

For example, you can add benefit plans descriptions from the Employee Benefit table (HBENE) and
employee benefit premiums from the Benefit Plan table (HBEPLAN) to the Employee report that uses the
Employee Personnel table (HRPERSNL). You link the databases so that each employee can be matched
up with their benefit descriptions (from the Benefit Plan table) and each benefit description (from the
Benefit Plan table) can be matched up with the employee benefit premium (from the Employee Benefit
table) .

1. In the SAPCrystal Reports main menu, selectDatabase > Add Database to Report.

2. In the Data Explorer window, select the tables for the report:

a. Click the plus sign to expand Favorites.

b. Click the plus sign to expand Abra HRMS Data Access.

c. Scroll through the list until you find the tables you want to include in the report and click once
on each table to highlight it.
For this example, highlight HBENE and HBEPLAN.

d. Click Add, which adds a check mark to the tables you are adding to the report.

e. When you finish selecting the tables for the report, click Close.

3. The Visual Linking Expert window shows all the tables currently in your report including any existing
links. To add a link:

a. Scroll through the primary database file, until you find the field to use as the link.
For this example, the field is p_empno in HRPERSNL.

b. Left-click and drag the field from the primary database file to the corresponding field in the
related database file. After the database files are linked, a link line is created from the field in
the primary database to the corresponding field in the related database.
For this example, drag p_empno in HRPERSNL to b_empno in HBENE.

c. Repeat steps 3a and 3b for all fields to be used to link the databases.
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For this example, drag b_benecode in HBENE to code in HBEPLAN.

d. When done, click OK.

4. Add the fields that you want from the linked tables:

a. In the main menu, select Insert > FieldObject.

b. In the Field Explorer window, click the plus sign to expand Database Fields and HBEPLAN.

c. Left-click and drag desc (the benefit plan descriptions) to the desired location on the report.

d. Repeat steps 4b and 4c to drag b_epremium in HBENE (the employees' benefit premiums)
to the desired location on the report.

Custom HR reports
Sage HRMS provides the following custom HR reports that were created using SAPCrystal Reports.

Report name Description

Age Listing Lists employees sorted by age. The report includes employee age, birth date,
employee name, job title, and organization levels.

Benefit Letter Displays an employee's annual costs and contributions for both savings and
insurance benefits. The report, in letter format, is designed to be printed on
company letterhead and given to the employee.

Benefits Enrollment Displays insurance benefits totals by employee. The report includes the
employee monthly premium, employee monthly contribution, and the
dependent monthly premium, along with the effective date of the plan.

Birthday List Lists birthdays by birth month. The report includes the employee birth date,
employee name, and employee address.

Blank HR This report is designed to be used as a template for creating HR reports. It is
linked to the employee master file and has the proper headers and footers.

Blood Donor List Lists each employee's department and division, blood type, RH factor, last
donation date, and the employee’s telephone extension.

Census Report Displays information an insurance company may require when calculating the
cost of providing insurance. The report includes detailed information for each
employee including birth date, social security number, gender, employee type,
occupation, annual salary, date of hire, marital status, and number of insured
dependents.
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Report name Description

Certificate of
Coverage

Provides proof of previous health insurance coverage for the employee,
including the date the coverage began and ended as well as any covered
dependents.
You specify the Date of Certificate, Administrator Name, andGroupHealth
Plan in the Enter Parameters Values window (accessed by selecting File
> Print Preview).
Before running this report, you must define the health plans to appear for
Group Health Plan:

1. In the SAPCrystal Reports main menu, select Insert > FieldObject.

2. In the Field Explorer window:

a. Click the plus sign to expand Parameter Fields.

b. Click once to highlightGroup_Health_Plan.

c. Click (the Edit button) in the toolbar.

3. In the Edit Parameter Fieldwindow, click the Set default values button.

4. In the SetDefault Values window:

a. Select hbeplan from the Browse table drop-down list.

b. Select code from the Browse field drop-down list.

c. In the Select or enter valuelist (which shows all available group
health plans), click once to highlight the plan you want to appear in
theGroupHealth Plan parameter field.

d. Click the > button to add the selected plan to the Default Values
list. (To remove a plan from the Default Values list, highlight it and
click the < button.)

e. If needed, use the Order arrow buttons to move a plan up or down
in the Default Values list.

f. Repeat steps 4c-4e to add any additional plans to the Default
Values list.

g. When you have finished, click OK.

5. In the Edit Parameter Fieldwindow, click OK.

6. From the menu, select File > Print Preview.

7. In the Enter Parameters Values window forGroupHealth Plan, select the
plans to use when running your report.
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Report name Description

Code Table Reports Lists the codes defined in your code tables, such as job codes, event codes,
and reason codes.

Dependent List Lists employees, their dependents, including the dependent relationship, birth
date, and social security number.

DependentUpdate
List

Lists employees and their dependents, including the dependent relationship,
birth date, and social security number. Use the update information section to
document changes to dependent information.

Drug Screen Listing Lists the employee's name, date of the most recent drug test, its result, the
number of years since the last test, and the date of the next test.

Emergency List Lists employees and their emergency contacts.

Employee Address
List

Displays employee demographic information, such as employee addresses
and phone numbers.

Employee Benefits
Summary

Lists employee insurance and savings benefits, including the associated costs.
The report includes all plans that do not have an expiration date or have not
expired (the expiration date is greater than the system date).

Employee Benefits
With Dependents

Lists employee insurance and savings benefits, including dependent benefit
information. The report includes all plans that do not have an expiration date or
have not expired (the expiration date is greater than the system date).

Employee Count Displays a count of all active and terminated employees.

Employee ID List Displays the employee name and ID, job title, division, and department for each
active employee.

Employee List Displays active employees, including the employee name and ID, job title,
original hire date, and annual salary. The report is sorted in ascending order by
employee number.

Employee List by
Name

Lists active employees sorted by employee name. The report includes the
employee name, employee number, job title, division, and department for each
active employee.

Employee Monthly
NewHire List

Lists new employees grouped by division and department. The report includes
the employee status, original hire date, and termination date.
You specify the Start Date in the Enter Parameters Values window (accessed
by selecting File > Print Preview).
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Report name Description

Employee Phone List Provides a telephone directory for your employees. The report includes the
employee name and ID, work telephone number, extension number, and
organization levels.

Employee Profile Displays detailed information for each employee, including demographic,
dependent, HR, and current job data.

EmployeesWith No
Benefits

Lists employees who do not have any insurance benefits.

Event Report Lists employee events, such as training, licenses, bonuses, professional
memberships, company cars, or anything defined in the Events code table. The
report includes the employee name, title, organization levels, event code,
effective date, event description, next due date, and comments associated with
each event.

Head Count By
Division

Displays employees by division in a graphical layout.

Insurance Benefit
Premium Summary

Lists employee insurance benefits and the associated costs. The report
includes all insurance plans that do not have an expiration date or have not
expired (the expiration date is greater than the system date).

Insurance Benefit
Premium Totals by
Plan

Displays the total premium for each plan as well as the number of employees
enrolled in the plan. The report includes all insurance plans that do not have an
expiration date or have not expired (the expiration date is greater than the
system date).

JobCode TableWith
Salary Grades

Lists the defined job codes and the associated salary grades.

Mail Labels Provides employees' names and addresses printed in a two-column label
format. You can adjust the information to print on the desired label stock.

Merit As Of Displays employees' merits received as of a certain date. The report includes
the employee name, effective date, reason for the merit, and salary.
You specify the merit As Of Date in the Enter Parameters Values window
(accessed by selecting File > Print Preview).
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Report name Description

NewHire Log Displays the new hires for a specific date range. The report includes the
employee's effective date, employee name, title, employee status, pay rate,
hours normally worked per pay period, and annual salary. The report provides
the total of the new hire salaries, the average of the salaries, and the new hire
count.
You specify the Beginning Hire Date and Ending Hire Date in the Enter
Parameters Values window (accessed by selecting File > Print Preview).

NewHire Reporting
Form

Displays the standard information most states require for new hire reporting,
include Employer FEIN, Employer Name, Employer Address, Employer
Contact, Employer Contact Phone, Employee Name, Employee Address,
Employee SSN, Employee DOB, Employee Hire Date, and New Hire Date
Range.
You can modify this report to comply with your state’s requirements. Contact
your state for details about submitting the New Hire Reporting Form.
You specify the Beginning Hire Date and Ending Hire Date in the Enter
Parameters Values window (accessed by selecting File > Print Preview).

OSHA 300 Illness
Detail

Displays information about employee illness cases as required byOSHA 300
report standards. The report includes the case number, date, and employee ID.
The report classifies totals byOSHA categories for Illness Types, Severity,
and Number of Days.
You specify the Start Date, End Date, and Case Types (including Recordable,
Nonrecordable, or All Cases) in the Enter Parameters Values window
(accessed by selecting File > Print Preview).

OSHA 300 Illness
Summary

Displays a count of employee illness cases as required byOSHA 300 report
standards. The report classifies totals byOSHA categories for Illness Types,
Severity, and Number of Days.
You specify the Start Date, End Date, and Case Types (including Recordable,
Nonrecordable, or All Cases) in the Enter Parameters Values window
(accessed by selecting File > Print Preview).

OSHA 300 Injury
Detail

Displays information about employee injury cases as required byOSHA 300
report standards. The report classifies totals byOSHA categories for Severity
and Number of Days.
You specify the Start Date, End Date, and Case Types (including Recordable,
Nonrecordable, or All Cases) in the Enter Parameters Values window
(accessed by selecting File > Print Preview).
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Report name Description

OSHA 300 Injury
Summary

Displays a count of employee injury cases as required byOSHA 300 report
standards. The report classifies totals byOSHA categories for Severity and
Number of Days.
You specify the Start Date, End Date, and Case Types (including Recordable,
Nonrecordable, or All Cases) in the Enter Parameters Values window
(accessed by selecting File > Print Preview).

OSHA 300 Log Detail Displays the number or work-related illnesses and injuries sustained by
employees within a given time period.
You specify the Start Date, End Date, and Case Types (including Recordable,
Nonrecordable, or All Cases) in the Enter Parameters Values window
(accessed by selecting File > Print Preview).

Physical ExamsDue Displays the date of the employee's last physical exam, the result of the exam,
the date of the next physical, the number of years since the last physical, and
the telephone extension.

Promotion List Displays an employee's old job title, new job title, and the effective date of the
new job.
You specify the Start Date and End Date in the Enter Parameters Values
window (accessed by selecting File > Print Preview).

SalaryAnalysis by
Division, Department
and Location

Lists employees' salaries by Division, Department, and Location. The report
includes years of service, performance rating, and comparatio.

SalaryAnalysis by
JobCode

Lists employees' salaries by Job Code. The report includes years of service,
performance rating, and comparatio.

SalaryAnalysis by
Name

Lists employees' salaries by employee name. The report includes years of
service, performance rating, and comparatio.

Salary Grade Lists each employee’s salary and pay grade including the minimum, maximum
and mid point of the salary grade.

Salary History Displays an employee's salary history. The report includes pay rates, increase
amounts, and percentages.

Salary ReviewForm Displays salary information, including salary history and percent of increase.
The report provides a form to submit job/salary changes.
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Report name Description

SavingsBenefit
CoverageBy
Employee

Lists employee savings benefits, including the associated contribution
amounts. The report includes all plans that do not have an expiration date or
have not expired (the expiration date is greater than the system date).

Scheduler Lists scheduled tasks, including the completion date and the person who
scheduled the task.

Skills Listing Lists each employee's skills, including years of experience in each skill and a
comment area that provides short details about each skill.

Spouse List Lists employees and their spouses.

Terminated
Employee Name List

Lists terminated employees, including employee name and ID, termination
date, and termination reason.

Transfer Log Lists employees who transferred within a specified date range.
You specify the Start Date and End Date in the Enter Parameters Values
window (accessed by selecting File > Print Preview).

Turnover Statistics Displays turnover statistics within a specified date range. The turnover statistics
are calculated based on the Service Length. The report includes the
termination type, date, terminated employee name and title, and service length.
The report displays the turnover rate and summary statistics for each
termination type.
You specify the Start Date, End Date, and Service Length (including Adjusted
Seniority, Original Hire, or Last Hire) in the Enter Parameters Values window
(accessed by selecting File > Print Preview).

Vets 100 Summary
List

Lists the number of employees by job category for each Vets 100 category. The
report includes newly hired veterans by category and total new hires for the
specified 12 month period.

Vets 100 Detail List Lists employee names and IDs by job category for each Vets 100 category. The
report includes newly hired veterans by category and total new hires for the
specified 12 month period.

Vets 100A Summary
List

Lists the number employees by job category for each Vets 100A category. The
report includes newly hired veterans by category and total new hires for the
specified 12 month period. The report displays a summarized list of the
required report data in the Information on Employees section of the VETS-
100A form.
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Report name Description

Vets 100A Detail List Lists employee names and IDs by job category for each Vets 100A category.
The report includes newly hired veterans by category and total new hires for the
specified 12 month period. The report displays a detailed list of the required
report data in the Information on Employees section of the VETS-100A form.

Custom TimeOff reports
Sage HRMS provides the following custom Time Off reports that were created using SAPCrystal Reports.

Report name Description

Absence Log Lists the absence reason codes the employee has on record, along with the
date, weekday, number of hours and comments regarding each absence. This
report includes parameters for the Beginning Hire Date and Ending Hire Date.

Note: From the menu, select File > Print Preview. In the Enter Parameters
Values window, enter the values to use for the report.

Absenteeism by
Reason

Displays absenteeism by absent reason in a graphical layout.

Attendance
Summary

Displays a summary of attendance information for each plan, including
carryover hours, hours accrued, year-end eligibility, and hours taken.

Attendance Totals by
Plan

Displays attendance totals for each active employee for each plan. The report
includes the employee name, employee number, the plan ID, carryover, hours
accrued, hours taken, and hours available as of the current accrual date.

Attendance YTD
Detail

Displays detailed attendance plan information for each employee, including
hours accrued, carryover, hours taken, hours available, and as of date. The
report also shows each absence date, day, hours absent, and the absence
reason.

Attendance YTD
Totals

Displays a summary of carryover hours, hours accrued, taken, and available as
of the current accrual date.
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Custom Training reports
Sage HRMS provides the following custom Training reports that were created using SAPCrystal Reports.

Report name Description

Courses Completed
By Employee

Lists courses completed by an employee. The report includes the course
description, instructor name, and length of the course in hours.

Expired Certifications Lists employees with expired certifications. The report includes the employee
name and ID, job title, date the certification was last received, and expiration
date.

Job Training History Lists courses completed by an employee during a specified period of time. The
report includes the employee name, job title, department, course name and
description, course completion date, and length of the course in hours.

Training Budget By
Department

Displays the expenses associated with courses completed by an employee.
The report is grouped by division and department. The report includes the
employee name and ID, job title, course code and description, the date by
which the course must be completed, and the cost of the course.

Training Exceptions
By Department

Lists employees that need to take a specific course or specific courses. The
report is grouped by division and department. The report includes the
employee name and ID, job title, the course description and priority, and the
date the training course is required.
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Chapter 9: Sage HRMS Secure Query

Secure Query is a query and reporting tool that enables you to request specific information from the
database tables in Sage HRMS. For example, if you need information about your employees'
demographics in a hurry to prepare for a meeting, Secure Query makes it easy to get the information you
need.

When you use Secure Query, you can select which fields to output, sort results in ascending or descending
order, build record filters, and group and summarize fields. When finished, you can choose to output the
query as a report, spreadsheet, text file, or database table. You can also create and save the queries to be
reused any time you need the information.

Secure Query reporting is available for the following features in Sage HRMS:

l Employees

l Time Off

l Training

AdHoc Reporting Security
Use Ad Hoc Reporting Security to restrict the database files and fields available to a security group who
uses Secure Query. Ad Hoc Reporting Security lets you assign an access level to each field contained in
your Sage HRMS databases.

Setting a group’s Ad Hoc Reporting Security Level works in conjunction with setting Ad Hoc Reporting
Security. When you set up group security, (by selecting Setup > System >Group Security link ), you
establish an access level that determines which fields in the Sage HRMS system databases are able to be
accessed by the security group’s users whenever they use Sage HRMSSecure Query.
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Using Secure Query
Sage HRMSSecure Query makes it easy to create custom queries to help you analyze and interpret
important information.

From the Query main page, you can:

l Select fields (page 70)

l Group records (page 71)

l Sort records (page 72)

l Set record filters (page 73)

l View data and run the query (page 77)

Before you begin

Before you begin working with queries using live data, we recommend you review Set Up Sample Queries
to guide you through the process of creating queries. Sample queries are provided in sample data for each
installed product. You might want to see how a sample query works before you create your own. Switch
from live data to sample data to practice with the sample queries before creating your own custom queries
with live data.

Note: Queries created in sample data cannot be copied or imported from sample data to live data.

Notes about Secure Query

l Only the author of a query or the Sage HRMSSystem Administrator can change the access type,
edit the query, or delete the query.

l View the data retrieved by your query at any time by clicking either the View Data button or the Run
Query button at the bottom of the page.
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Creating a new query
1. Select either Reports > Employees > Secure Query or Reports > Training > Secure Query.

2. In the Query List Manager window, click New.

3. In the Enter a Title for this NewQuery window for New Title, enter a title for the query. This query title
appears at the top of pages and prints on most reports.

4. Select an Access Type of either:

l Private for personal use only

l Public for all users who have access to Secure Query. Queries with a public access type can
be viewed and copied for modification by all users who have access to Secure Query.

5. Click OK.

6. In the Select Data To Use in Query window on the Choose Employee Information tab, select the
type of information to include in the query from the Master Table.

To define the fields in your query, you must know which Sage HRMS pages contain the fields you
need. The pages you will always use contain fields from the Master Table. The Employee Master
Table contains all the primary data for an employee in Sage HRMSHR, Time Off, or Training.

7. If you want all the fields from the Master Table available to choose from:

a. Click the Advanced button.

b. In the Advanced FieldOptions window, select Make all Employee Master Table fields
available for this query.

c. Click OK.

8. In the Select Data To Use in Query window, if you want to select additional optional information from
a second table:

a. Click the Choose Additional Information tab.

b. Select the appropriate type of additional information you want to include in the query.

c. Click OK.

d. In the Select Fields to Show in Query window, select the fields you want to include in the query
from the Fields to pick from list. Either double-click the fields or press the Shift and Ctrl keys
as you select the fields and click Select. The selected fields appear in the Fields to include in
query list on the right in the order you selected them; this is the order that the fields will display
in your query. (To remove a field from the Fields to include in query list, highlight it and click
Remove or double-click it.)
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Note: The available fields depend on the tables you selected in the Select Data To Use in
Query window.

e. If needed, change the order of the fields by moving your cursor over the button to the left of
the field until you see a two-headed arrow. Then press your left mouse button and drag the
field to the new position. When you release the mouse button, the field moves to the new
position and the other fields automatically reorder to accommodate the moved field.

f. After you select the appropriate fields, click OK. The Query main page opens.

From the Query main page, you can:

l Select fields (page 70)

l Group records (page 71)

l Sort records (page 72)

l Set record filters (page 73)

l View data and run the query (page 77)

To edit a query:

1. Select either Reports > Employees > Secure Query or Reports > Training > Secure Query.

2. In the list of queries in the Query List Manager window, select the one you want to edit and click
Open, which opens the Query main page so you can make your changes.

From the Query main page, you can:

l Select fields (page 70)

l Group records (page 71)

l Sort records (page 72)

l Set record filters (page 73)

l View data and run the query (page 77)
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To filter a query:

1. Select either Reports > Employees > Secure Query or Reports > Training > Secure Query.

2. The first time you click the Filter button in a query, the SetRecord Filter window opens. After you
add your first condition to a record filter, the Conditions List page opens.

From the Conditions List page, you can:

l Add a new condition to a record filter (page 73)

l Edit a condition (page 74)

l Switch a connector (page 75)

l Move a condition (page 75)

l Bracket two or more conditions (page 76)

l Delete a condition (page 76)

To copy a query:

1. Select either Reports > Employees > Secure Query or Reports > Training > Secure Query.

2. In the list of queries in the Query List Manager window, select the one you want to copy and click
Copy.

3. In the Enter a Title for this Copied Query window for To New Title, enter a new title for the query.
This query title appears at the top of pages and prints on most reports.

4. Select an Access Type of either:

l Private for personal use only

l Public for all users who have access to Secure Query

5. Click OK.
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To rename a query:

1. Select either Reports > Employees > Secure Query or Reports > Training > Secure Query.

2. In the list of queries in the Query List Manager window, select the one you want to rename and click
Rename.

3. In the Enter a New Title for this Query window for New Title, enter the new title for the query. This
query title appears at the top of pages and prints on most reports.

4. Select an Access Type of either:

l Private for personal use only

l Public for all users who have access to Secure Query

5. Click OK.

To delete a query:

1. Select either Reports > Employees > Secure Query or Reports > Training > Secure Query.

2. In the list of queries in the Query List Manager window, select the one you want to delete and click
Delete.

3. Click Yes to confirm the deletion. (Click No to cancel the deletion.)
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Selecting fields
Use the Select Fields tab to limit the results that are returned in your query to only those records that you
are interested in. The Select Fields tab lists previously saved fields for the selected query.

1. On the Select Fields tab, click the Select Fields button.

2. In the Select Fields to Show in Query window, select the fields you want to include in the query from
the Fields to pick from list. Either double-click the fields or press the Shift and Ctrl keys as you select
the fields and click Select. The selected fields appear in the Fields to include in query list on the right
in the order you selected them; this is the order that the fields will display in your query. (To remove a
field from the Fields to include in query list, highlight it and click Remove or double-click it.)

Note: The available fields depend on the tables you selected in the Select Data To Use in Query
window.

3. If needed, change the order of the fields by moving your cursor over the button to the left of the field
until you see a two-headed arrow. Then press your left mouse button and drag the field to the new
position. When you release the mouse button, the field moves to the new position and the other
fields automatically reorder to accommodate the moved field.

4. After you select the appropriate fields, click OK.

The Query main page opens.

To include additional data:

1. On the Select Fields tab, click Additional Data.

2. In the Select Data To Use in Query window on the Choose Employee Information tab, select the
type of information to include in the query from the Master Table.

To define the fields in your query, you must know which Sage HRMS pages contain the fields you
need. The pages you will always use contain fields from the Master Table. The Employee Master
Table contains all the primary data for an employee in Sage HRMSHR, Time Off, or Training.

3. If you want all the fields from the Master Table available to choose from:

a. Click the Advanced button.

b. In the Advanced FieldOptions window, select Make all Employee Master Table fields
available for this query.

c. Click OK.
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4. In the Select Data To Use in Query window, if you want to select additional optional information from
a second table:

a. Click the Choose Additional Information tab.

b. Select the appropriate type of additional information you want to include in the query.

Note: You cannot remove a table from the query after you have selected it.

c. Click OK.

Grouping records
Use theGroupRecords tab to specify how fields will be grouped and summarized in your query. Grouped
data is data that is divided into meaningful groups. For example, a group might consist of all employees
who have the same job title or are in the same department.

1. On theGroupRecords tab, select the fields you want the records grouped by from the drop-down
lists. The values in the drop-down lists depend on the fields selected in the Select Fields To Use in
Query window.

2. To add a count of the values within each group to the query, select Count the number of records in
the group.

3. To display all the data, select Detail records in the group. However, to display a summary of the
totals for each group, clear Detail records in the group. Summary information is most useful when
you only want to examine totals and do not need the detailed information.

4. By default, numeric fields are displayed in the Summarize the records for this numeric field. From
the list of fields, select the one you want to summarize and click once to highlight it.

5. Select one of the following summarizing options for the query:

l None

l Sum the records in this field—Adds the values within a group to provide a total.

l Average the records in this field—Finds the average of all values within a group.

l Find the smallest value in this field—Finds the minimum value within a group.

l Find the largest value in this field—Finds the maximum value within a group.
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Sorting records
The Sort Records tab lists previously saved sorts for the selected query. If you have not selected a sort
option for your query, only Sorted by current record order displays in the list, so the data is displayed in the
same order as it appears in your tables. 

Sorting means placing data in some kind of order to help you find and evaluate it. You define the field or
fields you want the sort to be based on and the sort direction.

l In single field sorting, all the records used in the query are sorted based on the values in a single
field. Sorting a query by employee last name is an example of a single field sort.

l In multiple field sorts, Secure Query first sorts the records based on the values in the first field. If two
or more records have the same field value in the first sort field, those records are then sorted based
on the value in the second sort field.

Sort Direction refers to the order in which the values are displayed when they are sorted.

l Ascending order means smallest to largest (1 to 9, A to Z).

l Descending order means largest to smallest (9 to 1, Z to A).

The fields you select for sorting automatically defaults to ascending order. "(DESC)" next to the field name
indicates that the values in the field are sorted in descending order.

1. On the Sort Records tab, click the Select Order button.

2. In the Select Sorting Order window, select the fields you want to use for sorting in the query from the
Fields to pick from list. Either double-click the fields or press the Shift and Ctrl keys as you select the
fields and click Select. The selected fields appear in the Fields to sort records by list (and their
corresponding sort order) on the right in the order you selected them; this is the order that the fields
will be sorted by in your query. (To remove a field from the Fields to sort records by list, highlight it
and click Remove or double-click it.)

3. If needed, change the order of the sort fields by moving your cursor over the button to the left of the
field until you see a two-headed arrow. Then press your left mouse button and drag the field to the
new position. When you release the mouse button, the field moves to the new position and the other
fields automatically reorder to accommodate the moved field.

4. Click the Sort Asc/Desc button to change the sort order.

5. Click OK.
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Setting record filters
Use the SetRecord Filter tab to limit the records included in a query. In some cases, you might want to
specify a particular value to limit the results. For example, you can include only active employees.

You can create a query that enables you to specify a different value each time it runs. The record filter acts
as placeholder for a value that is supplied when the query runs. For example, you can include only
employees hired during a certain date range.

The SetRecord Filter tab lists previously-saved conditions (a maximum of 10 conditions) for the selected
query in the order in which you added them. If the record filter contains conditions with set values, the
conditions display with their assigned values. If the record filter contains conditions that can have different
values at different times, the condition appears with {To be entered later}. SetRecord Filter fields do not
have to be placed in a query in order to be used as a condition in a record filter.

Select the Hide Duplicate Output Records check box if you do not want the query to display records that
are duplicated.

To add a new condition to a record filter

1. On the SetRecord Filter tab, select Hide Duplicate Output Recordsto prevent the query from
including duplicate records from the database.

2. Click SetRecord Filter.

3. Add a connector for the conditions::

a. In the SetRecord Filter window, click Add.

b. In the Select a Connector window, select one of the following connectors:

l And to require both this condition and the prior condition to be meet. This enables you to
specify that the values in a record filter must meet two (or more) conditions for the data
to be included in the query. This narrows the scope of the search and usually returns
less data.

l Or to require either this condition or the prior condition to be meet. This enables you to
specify several alternative values in a record filter. This expands the scope of the search
and can return more data.

4. In the SetRecord Filter window on the Pick a Field tab, select the field that contains the data you
want to filter or specify.

5. Click Next to move to the next applicable tab.
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6. If you have a true-false condition:

a. On the Pick True or False tab, select the type of operator that describes the operation or
action you want.

b. Click OK.

7. If you do not have a true-false condition:

a. On the Pick an Operator tab, select the type of operator that describes the operation or action
you want.

Note: The choices on this tab depends on the type of field selected on the Pick a Field tab
and the type of operator selected on the Pick an Operator tab.

b. If needed, click Next.

c. On the Enter a Value tab, enter or select the appropriate value for the condition.

d. If you want the filter to prompt you for the values when the query is run, select Ask later.

e. If you want the filter to compare data in this field with the content of another data field, select
Compare to Field.

f. Click OK.

8. On the Conditions List page if you have finished setting up the record filter, click Done. (If the Enter a
Value tab opens, click Cancel.)

To edit a condition in a record filter

1. On the SetRecord Filter tab, click the SetRecord Filter button. The Conditions List page opens and
lists previously saved conditions.

2. From the list, select the condition you want to edit.

3. Click Edit.

4. In the SetRecord Filter window on the Pick an Operator tab, select the type of operator that
describes the operation or action you want to take place.

5. Click Next to move to the Enter a Value tab (if the system does not automatically move you to that
tab).

6. On the Enter a Value tab:

a. Select the appropriate value.

Note: The choices on this tab depends on the type of field selected on the Pick a Field tab
and the type of operator selected on the Pick an Operator tab.
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b. If you want the filter to prompt you for the values when the query is run, select Ask later.

c. If you want the filter to compare data in this field with the content of another data field, select
Compare to Field.

d. Click OK.

7. On the Conditions List page if you have finished changing the record filter, click Done. (If the Enter a
Value tab opens, click Cancel.)

To switch a connector in a record filter

If a Record Filter includes more than one condition, the conditions are linked with one of the following
connectors:

l And to require both conditions and the prior condition to be meet (narrows the search)

l Or to require either this condition or the prior condition to be meet (broadens the search)

Use the Switch button to change the connector that links two conditions.

1. On the SetRecord Filter tab, click the SetRecord Filter button.

2. On the Conditions List page in the list of previously-saved conditions, click once to highlight the
condition that you want to change.

3. Click Switch.

4. When you finish changing the record filter, click Done. (If the Enter a Value tab opens, click Cancel.)

Tomove a condition in a record filter

1. On the SetRecord Filter tab, click the SetRecord Filter button.

2. The Conditions List page lists previously-saved conditions in the order in which you added them.
This is the order in which Sage HRMS evaluates the conditions in the record filter. From the list of
conditions, click once to highlight the one you want to move.

3. Click Move. A check mark indicates the condition you selected.

4. Go to the location where you want to move this condition and double click.

5. The condition moves to the new location. The other conditions automatically reorder to
accommodate the change.

6. If you have finished changing the record filter, click Done. (If the Enter a Value tab opens, click
Cancel.)
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To bracket two or more conditions in a record filter

Brackets around two or more conditions forces those conditions to be evaluated together. For example,
you might want to find employees hired during a certain date range that also have an employee status of
either A (active) or L (leave of absence).

1. On the SetRecord Filter tab, click the SetRecord Filter button.

2. The Conditions List page lists previously-saved conditions in the order in which you added them.
From the list of conditions, click once to highlight the one you want to change.

3. Click Bracket.

4. If you want to add parentheses:

a. In the Insert or Remove Parentheses window, click Insert. A check mark indicates the
condition you selected.

b. Select the condition that contains the matching ending parentheses and double click.

5. If you want to remove existing parentheses:

a. In the Insert or Remove Parentheses window, click Remove. A check mark indicates the
condition you select.

b. Select the condition that contains the matching ending parentheses and double click.

6. If you have finished changing the record filter, click Done. (If the Enter a Value tab opens, click
Cancel.)

To delete a condition in a record filter

1. On the SetRecord Filter tab, click the SetRecord Filter button.

2. The Conditions List page lists previously-saved conditions in the order in which you added them.
From the list of conditions, click once to highlight the one you want to delete.

3. Click Delete.

4. If you have finished changing the record filter, click Done. (If the Enter a Value tab opens, click
Cancel.)
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Viewing the data, running a query, and outputting the query
results
You can view the data retrieved by your query at any time by clicking either of the following buttons at the
bottom of the Output Results tab:

l View Data to view the data in a preview window on your monitor. The data is displayed in the same
order as it appears in your tables, with no grouping or sorting.

l Run Query to run the query and output the results as specified on the Output Results tab .

Before running the query, use the Output Results tab to specify the output of your query:

l A query report that you can preview, print, or save as a PDF file.

l An exported query file as an ASCII text file, for use in Microsoft Office applications, or as a data
table.

Generating a query report

You can output the query as a report that you can view or print. Reports are formatted for standard 8 1/2-
by-11-inch paper with a half-inch margin on all sides. Portrait orients the print vertically and displays a
maximum of 6 columns. Landscape orients the print horizontally and displays a maximum of 8 columns.
Each report has a query title that is at the top of each page of the report.

To generate a report:

1. On the Output Results tab, select either Report (Portrait Layout) or Report (Landscape Layout).

2. Click Run Query.

3. In the Report Setup window, select the Output Direction.

4. To preview the report, select Preview. You can use the Page Preview toolbar (explained in the next
section).

5. To print the report:

a. Select Print.

b. In the Print Options window, select the appropriate options (such as page range, number of
copies, and name of printer).

Tip: If you have a PDF driver installed, you can create a PDF version of the report and then
send it as an email attachment.

6. Click Start Report.
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7. If you send a report, it is generated as a PDF file attachment to an email message. You need to
specify the recipient (who needs to have Adobe Reader to view the report). The email subject will be
Sage HRMS Report.

8. Click Yes to view the file. If you do not have Adobe Reader installed, directions will be provided to
where you can download it from the web and install it. If Outlook is not installed, the file will be placed
in the export directory.

Page Preview toolbar

While previewing a report, you can use the page preview toolbar to enlarge the view, scroll the pages, and
print the report. The toolbar button name displays when you position your cursor over the button.

Button Name Description

First
Page

Displays the first page of the report. (This button is disabled if you are
previewing the first page of the report.)

Previous
Page

Displays the previous page of the report. (This button is disabled if you
are previewing the first page of the report.)

Go To
Page

Lets you select a specific report page to display.

Next
Page

Displays the next page of the report. (This button is disabled if you are
previewing the last page of the report.

Last
Page

Displays the last page of the report. (This button is disabled if you are
previewing the last page of the report.)

Zoom Lets you choose six different magnifications. You can also click your
cursor anywhere in the previewwindow to zoom in or out on a
particular area of the report. When you zoom, your cursor changes to
a magnifying glass.

Close
Preview

Closes the previewwindow and returns to the Reports window. You
can also click in the report title bar to close the previewwindow.

Print
Report

Prints the report.
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Exporting a query to a file

You can export or save your query to a file so you can use it in a variety of different applications, such as
Microsoft Excel.

To export the query:

1. On the Output Results tab, select the File Type. The extension for Filename automatically fills in
accordingly.

2. If you want, change the Filename, such as to add a date. The file name can have a maximum of 40
alpha and numeric characters (a-z, A-Z, and 0-9). Do not use any special characters (such as #, -,
@, or punctuation marks).

3. Click Run Query.

4. When the process is complete, a message displays the total number of records exported to your file,
the location of the file, and asks if you want to view file. Click Yes to view the file.

Sage HRMS exports the file to the \EXPORT directory in your Sage HRMS directory.
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